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FeatureWorks is a registered trademark of Geometric Ltd.
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Other brand or product names are trademarks or registered trademarks of their respective
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COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995),
consisting of “commercial computer software” and “commercial software documentation” as
such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government
(a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in
48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the department of Defense,
consistent with the policies set forth in 48 C.F.R. 227.7202-1 (JUN 1995) and 227.7202-4 (JUN
1995).
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Introduction
This guide describes new and changed SolidWorks® Enterprise PDM capabilities in the 2013
release.

Intended Audience

This guide is for experienced users of the SolidWorks Enterprise PDM software.
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1
SolidWorks Enterprise PDM

Available as a separately purchased product that can be used in SolidWorks® Standard,
SolidWorks Professional, or SolidWorks Premium.

This chapter includes the following topics:

• Administration Tool
• File Explorer and SolidWorks Add-in

Administration Tool

Delayed in State Notifications
You can create notifications that are triggered when a file has been in a state for more
than a specified length of time.

When you create a Delayed in State notification, you can also specify a resend value to
create repeated notifications.

You can create a Delayed in State notification from:

• The Workflow Editor in the Administration tool
• The Notification Editor when you are logged in to a vault in Windows® Explorer

Creating Delayed in State Notifications from the Workflow Editor
You can use the workflow editor in the Administration tool to create Delayed in State
notifications for folders.

1. In the Administration tool, expand Workflows and double-click a workflow to open
it in the workflow editor.

2. Click a state to open its State Properties dialog box.
3. On the Notifications tab, click Add Folder Notification.
4. In the Select Folder dialog box, select the folder for which you want to make the

notification and click OK.
5. In the Folder Notification dialog box:

a) For Type, select Delayed in State.
b) For Trigger after, specify the number of days the folder can remain in the state

before the notification is triggered.
c) For Resend every, specify a resend interval.

6. On the Recipients tab, click Add Recipients.
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7. In the Add recipients dialog box, select the users or groups to receive the notification
and click OK.

You can type a substring in the Filter field to hide recipients whose names do
not contain the substring.

8. Click OK to complete the notification and close the State Properties dialog box.

9. Click Save to save the change to the workflow.

When the notification is triggered, the recipients you specified receive a message in their
Inbox for each file in the folder that meets the delayed in state requirements. These
notifications contain links to the files.

Creating Delayed in State Notifications from Windows Explorer
You open the Notification Editor from Windows Explorer to create Delayed in State
notifications for files.

1. In Windows Explorer, log in to the vault.
2. Click Tools > Notify > My Notifications.
3. In the Notification Editor, click Add File Notification.
4. In the Browse for File(s) dialog box, navigate to the location of the files for which you

want to add the notification and click Open.
5. In the File Notification dialog box:

a) For Type, select Delayed in State.
b) On the Notification Properties tab, select a Workflow and State.
c) For Trigger after, specify the number of days the file can remain in the state

before the notification is triggered.
d) For Resend every, specify a resend interval.
e) Click OK.

6. In the Notification Editor, click OK.

When the notification is triggered, you receive a message in your Inbox with a link to the
document.

Parallel Workflow Transitions
When you create or edit a workflow transition, you can select Parallel as the transition
type. This requires multiple users to run the transition before a file is moved to a new
state.

You create parallel transitions in the Workflow editor of the Administration tool. When
you select Parallel as the transition type, a Role tab is added that lets you specify users
and groups who can approve the transition and the number of approvals that is necessary
to move a file to a new state.

If parallel transitions are in effect, when users right-click a file and select Change State,
the number of transitions already approved by other users and the total number required
to change the state of the file are shown.

In this example, Editing required is a parallel transition:
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where:

• 0 shows the number of users who have already approved the transition.
• 2 shows the number of approvals needed to complete the state change.

If the state change has not yet taken place because the required number of approvals
has not been reached, users who have already approved the transition can revoke their
approvals. When the user selects Change State, the Revoke option is available.

Creating a Parallel Transition

1. In the Administration tool, expand Workflows and double-click a workflow to open
it in the Workflow editor.

2. Click a transition to open its Transition Properties dialog box.
3. For Type, select Parallel.

A Roles tab is added to the dialog box.

4. On the Roles tab, click Add Role.

If roles have already been defined in the workflow, you can expand the Add
Role button to choose from a list of existing roles.

5. In the Add Role dialog box:
a) Type a Name for the role.
b) In the Required Users field, specify how many users in the role must run the

parallel transition before the file changes state.
c) Click Add Member.

6. In the Add Member dialog box:
a) Select the users or groups to add to the role.

You can type a substring in the Filter field to display only users or groups
whose names contain the substring.

b) Click OK.

7. Click OK again to close the Add Role dialog box.
8. On the Permissions tab:

a) In the Name column, select the users and groups you added to the roles you
created in steps 5 through 7.

b) In the left column, select Permit.
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9. Optionally, add a notification to the transition.
The notification can be used to inform users who need to approve the parallel
transition.
a) On the Notification tab, click Add Folder Notification.
b) Select the folder the notification applies to and click OK.
c) In the Folder Notification dialog box, on the Recipients tab, click Add Recipients.
d) In the Add recipients dialog box, select the users and groups to receive the

notification and click OK.
e) Optionally, if you want to let users who run the parallel transition choose notification

recipients, enable the Dynamic check box for the recipients.

10. Click OK to complete the transition and close the Transition Properties dialog box.
11. Click Save to save the change to the workflow.

Changing State Via a Parallel Transition
If a parallel transition has been created, multiple users must run the transition before
the file actually changes state.

This procedure describes how two users send a file back to editing by using a parallel
transition to change its state.

1. User A provides the first approval:
a) Log in to the vault.
b) Navigate to the file to be sent back to editing and select it.
c) Click Modify > Change State > Editing required.

The Editing required transition indicates the number of users who must run the
transition.

When the Do Transition dialog box appears, the Result column indicates that after
this transition is run, one more user must perform the transition before the state
of the file is changed.

d) Ensure that Change state is checked.
e) Enter a Comment.

The comment appears in the file's history and in a History column that is added
when the transition is run by other users.
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f) If dynamic notifications are enabled for the transition, enter a Notification
comment and select the users to notify.

g) Click OK.
The State column in the file list shows that the file did not change state.

2. After being notified by User A that approval is needed, User B provides the second
approval:
a) Log in to the vault.
b) Navigate to the file to be sent back to editing and select it.
c) Click Modify > Change State > Editing required.

The Editing required transition now indicates that one user has run the transition
and that two users must run the transition to change the state of the file.

When the Do Transition dialog box appears, there are no notes in the Results
column, since if User B approves the transition, the required number of approvals
has been reached.

At the bottom of the dialog box, the History field shows the comments made by
User A.

d) Ensure that Change state is checked.
e) Enter a Comment.
f) If dynamic notifications are enabled for the transition, enter a Notification

comment and select the users to notify.
g) Click OK.

The State column in the file list now shows that the file has changed state.

Recently Used List
The Recently Used list appears in the right pane of the SolidWorks Enterprise PDM
Administration tool. It provides quick access to the last ten administration features you
have used.
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The Recently Used list is retained when you close the Administration tool. When you
reopen the tool, you can see the history of the work you did in your previous session.

Click Clear to remove all of the items that are currently in the list.

The Card Editor also contains a Recently Used list showing the cards you have most
recently edited.

Workflow Editor Update
The Workflow Editor user interface has been updated to make it easier to navigate large
workflows.

The appearance and layout of workflow state and transition objects has been simplified.

Workflow Editor in Enterprise PDM 2012

Workflow Editor in Enterprise PDM 2013
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Zoom Controls

New controls on the toolbar make it easier to work in complex work flows. You can zoom
out to see the entire workflow graph or zoom in to modify specific sections.

Zooms to an area of the workflow that you select.Zoom to
Area

Zooms in and out when you hold down the left mouse button and drag
the mouse up or down. You can also zoom by using the mouse wheel.

Zoom
In\Out

Displays the entire workflow in the available space.Zoom to
Fit

Displays the workflow at its original (100%) size.Actual
Size

User Interface Simplification

The appearance of transition objects has been simplified. A combination of color and icons
make it easier to distinguish between transition types and identify transition settings.

Users run the transition to change file states.Normal transition

All files in the source state automatically pass
through the transition.

Automatic transition

A specified number of users must promote a file
through a transition before the file's state
changes.

Parallel transition
(new feature)

Normal transition with notifications set

Normal transition with authentication set
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State objects have also been simplified. Icons in the lower right corner are now used to
identify state object properties rather than to initiate changes. For example:

Initial state

Ignore permissions in previous states

New Properties Dialog Boxes

To open both state and transition properties dialog boxes, you click the objects in the
workflow map.

Tabs have been added to the dialog boxes to provide easier and more consistent access
to all settings.

Both the state and transition properties dialog boxes include:

• A Permissions tab, which replaces the permissions task pane from previous versions
of Enterprise PDM.

• A Notifications tab, which provides access to the Folder Notification dialog box of the
redesigned Notifications Editor.

• A Revision Numbers tab, which replaces the Increment Revision Command section
of the state properties dialog box and the Change revision counters option of the
transition properties dialog box.

Transition properties dialog boxes also include Conditions and Actions tabs.
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File Explorer and SolidWorks Add-in

Bill of Materials Tab Improvements
The toolbar area of the Bill of Materials tab in Windows Explorer has been updated. The
controls are easier to use and occupy less screen space. Bill of Materials functionality
remains the same.

BOM Toolbar Reorganization

Existing controls have been rearranged into four sections.

If you make the window too narrow for all the controls to be shown, as many sections of
the tab as necessary are compacted into flyout buttons. Clicking any of these buttons
displays the controls for that section.

BOM Comparison

The new Bill of Materials UI makes it easier to compare BOMs. Instead of displaying a

dialog box, when you click Compare , the sections of the BOM UI are reordered.
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The left section shows the BOM, version, and configuration that are the source of the
comparison. The middle section lets you choose the BOM, version, and configuration to
compare. In the commands section on the right, the Comparison button becomes a
Close comparison button.

Close SolidWorks Files on Check In
When you edit files and check them in from SolidWorks, you can select to have Enterprise
PDM close the files after the check in operation completes, rather than reload them.

This can improve performance since reloading the files can be time consuming.

To have files closed after you check them in from the SolidWorks Enterprise PDM add-in:

1. In the SolidWorks Enterprise PDM task pane, right-click the file, and click Check In.
2. In the Check in dialog box, in the toolbar, expand the Reload Files after Check In

command and click Close Files after Check In.
3. Complete your check in selections and click Check in.

The files are checked in and closed in SolidWorks.

Contains and Where Used Tab Improvements
The toolbar areas of the Contains and Where Used tabs in Windows Explorer have been
updated to make the controls easier to use and occupy less screen space.

Existing controls on both tabs have been rearranged into three sections.

• The source section lets you select the version and configuration of the file to view.
• The options section controls how the results are displayed.
• The commands section contains action buttons.

If you shrink the size of the window, the sections are compacted into flyout buttons.
Clicking any of these buttons displays the controls for that section.

The commands section buttons include three new buttons that are active when you select
a file from the list at the bottom of the tab.

Opens the file selected in the tree in the associated
application.

Open

Shows the property dialog box for the file selected in the
tree.

Properties

Opens a new Explorer window and browses to the file
selected in the tree.

Browse to
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Full Row Selection Highlighting in Windows Explorer
When a user selects a file in Windows Explorer or the Search Tool (including integrated
Search), the entire row is highlighted, making it easier to read the column data associated
with the file.

In previous releases, only the file name was highlighted.

Notification Editor Update
The Notification Editor user interface has been updated to make it easier to create and
modify notifications.

New File Notification and Folder Notification dialog boxes help you select notification types
and specify notification options.

Administrators creating notifications for workflow transitions also use the Folder
Notifications dialog box to add notifications to states and transitions.

Creating File Notifications in Windows Explorer
To create file notifications, you must work from Windows Explorer.

To create file notifications without opening the Notification Editor:

1. Select the files for which you want to create notifications.
2. Right-click and click Notify > Me when.

The File Notification dialog box appears.

3. For Type, select the type of notification to create.
The tab displays the controls that are appropriate to the notification type and an
informational message describing the notification's effect.
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4. Set the other controls and click OK.
The Notification Editor appears, listing a separate notification for each of the files you
selected.

5. Click OK.

Creating Folder Notifications from the Workflow Editor
Administrators can access the Folder Notification dialog box when they are editing workflow
state or transition properties in the administration tool.

To create a notification for a workflow transition:

1. In the Workflow Editor, click a transition to open its Properties dialog box.
2. On the Notifications tab, click Add Folder Notification.
3. In the Select Folder dialog box, select the folder for which to create the notification

and click OK.
The Folder Notification dialog box appears.

For transition notifications, the Type, Source state, Destination state, and State
change fields are read only. The transition you are editing dictates these properties.

For state notifications, you can edit these fields.

4. If appropriate, select one or both of the following to restrict who the notification is
sent to:

• Only to the file creator
• Only to the last state modifier

5. On the Recipients tab, click Add Recipients.
6. In the Add Recipients dialog box:

a) Select the users and groups to receive the notification.
If you select an entire group, the members of that group are automatically selected.

Type a string in the Filter field to display only users and groups whose names
include the string.

b) Click OK.

7. In the Folder Notification dialog box, to allow specific users who run this transition to
choose notification recipients, select the users and check the box under Dynamic
Selection.

The Dynamic Selection option is not available for folder notifications you create
from the State Properties dialog box.

8. Click OK twice.

9. Click Save to save the change to the workflow.

Viewing Your Notifications
In Windows Explorer, you can view the notifications you have created by opening the
Notification Editor. You can remove notifications you no longer use, edit existing
notifications, or add new folder and file notifications.

18
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1. Right-click a vault file and click Notify > My Notifications.
The Notification Editor appears.

indicates notifications you have created.

indicates notifications created by an administrator using the Workflow Editor.

2. To activate a notification, check its box under Activated.
3. To add a notification, click Add Folder Notification or Add File Notification.
4. To remove or edit a notification you have created, select it and click the appropriate

control.

You cannot remove or edit notifications created by an administrator. If you select
a notification identified with the icon, the Remove Notification control
remains inactive. The Edit Notification control changes to View Notification.
Use it to view notification details.

Quantity Specification for Manually Created File
References
When you create file references manually by using the Paste as Reference command,
you can specify a quantity for the referenced files, which is then displayed in the Bill of
Materials of the file.

If you check out the file, you can modify the quantity by using the Edit User Defined
File References command. Your change affects future versions of the file but not existing
versions.

To specify a quantity for a referenced file when you create the reference:

1. Right-click the file to be referenced and click Copy.
2. Check out the file to contain the reference, right-click it, and click Paste as Reference.
3. In the Create File References dialog box, specify a value in the Quantity column, and

click OK.
4. Check in the file with the reference.

When you view the file containing the reference in the Bill of Materials tab, the quantity
is displayed.

To modify the quantity of a referenced file:

1. Check out the file containing the reference.
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2. With the file selected, click the Contains tab.

3. Click Edit User Defined References .
4. In the Edit User-Defined References dialog box, modify the value in the Quantity

column, and click OK.

User Information Pop-up
When you mouse over a user name in the SolidWorks Enterprise PDM user interface, a
pop-up window appears. This window provides user details and links to help you
communicate with other users in your company.

You can display the user window by hovering over the user name in the Checked Out
By column in:

• Vault file lists in Windows Explorer, including the Contains and Where Used tabs
• The Enterprise PDM task pane in SolidWorks
• Dialog boxes such as Check in, Check out, and Get

In the History dialog box, you can display the user window by mousing over the User
column or User field for a selected event.

The user window that appears contains links to the Enterprise PDM email editor, as well
as Microsoft® Office Communicator or Microsoft Lync®, and Microsoft-enabled Voice over
IP (VoIP) if you have these products installed. Other details users add to their profiles,
such as an image, phone numbers, Web links, and presence statements, are also available.

Adding Information to the User Pop-up
If you have permission to administrate users, you can add information to user profiles
that will be displayed on the user pop-up window.

1. Open the Administration tool.
2. Expand Users and double-click the name of the user whose profile you want to modify.
3. In the right pane of the user's Properties dialog box:

a) To display phone numbers in the user window, complete the Phone and Cellphone
fields.

b) To add links to Web sites, type URLs in the Website Address fields.
You can add up to four web addresses.

The Tooltip field is completed automatically.

c) To add a note, type text in the Presence note field.

4. To add an image:

a) In the left pane, click Browse for Picture .
b) Navigate to the location of the image and click Open.

5. Click OK.

Viewing a User Pop-up Window
User pop-up windows are visible in Windows Explorer and SolidWorks views of an
Enterprise PDM vault.

To view user pop-ups in Windows Explorer:
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1. Navigate to an Enterprise PDM vault that has files checked out.
2. Mouse over a user name in the Checked Out By column.

A window appears that contains information about the user who checked out the file.

Depending on how much information has been added to the user's properties and
how your network is configured, the following information that is specific to the user
is provided on the card:

User's login name and full name

Date and time the user logged in

Number of files the user has checked out

Note from user

User's work phone number

User's cell phone number

Sends user email

Sends user a Microsoft Office Communicator or Microsoft Lync message

Initiates communication with a user using Microsoft-enabled Voice over
IP (VoIP)

Web sites included in user's properties

3. To pin the card so it remains displayed, click .
4. To close a pinned card, click .

Version Free Variables
You can update variables for a file without having to check the file out and increment the
version of the file when you check it back in.

This lets you update variables that change over time, such as cost, while the file itself
may not change.

Additionally, you can change the variable even if the file is in a state where you do not
have permission to check it out.
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A new version of a file is created if you update version free variables for a checked
out file or if a version free variable is modified by a workflow transition action.

To use a workflow transition to update version free variable data without versioning
the file, create a Dispatch script set to run after the transition to the destination
state.

Enabling Update of Version Free Variables
Administrators with permission to update variables and administrate users use the
Administration tool to enable users to update variables without creating new versions of
files.

1. To add the version free capability to a variable:
a) In the Administration tool, expand Variables and double-click the variable.
b) In the Edit Variable dialog box, click Version free.
c) Under Update versions, do one of the following:

• Select All Versions to make the variable update affect all versions and revisions
of the file.

• Select Latest Version to make the update affect only the latest version of the
file.

d) Click OK.

2. To give a user permission to update version free variables:
a) Expand Users and double-click the user.
b) In the user's Properties dialog box, click Folder Permissions.
c) On the Permissions per Folder tab, select a folder.

To assign the permission for the entire vault, select the vault.

d) Under Folder Permissions, click Edit version free variable data.
e) Click State Permissions.
f) Select a Workflow and Workflow state.
g) Under Permissions, click Edit version free variable data.
h) Click OK.

Updating Version Free Variables
Users with permissions to edit version free variable data can modify version free variable
data on a file's data card or by updating the file data cards for a folder.

1. To modify a version free variable for a data card:
a) Without checking it out, select a file and click the Data Card tab.

In the data card, fields that contain version free variables are editable. All other
fields are disabled.

b) Modify the editable variables and click .

2. To modify a version free variable for a folder and propagate the value to the files in
the folder:
a) Select the folder and click the Data Card tab.
b) On the Edit Values tab, modify the version free variable and click .
c) Click Modify > Update > Values in Files.
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d) In step 1 of the Updating File Data Cards wizard, click Version free variables
and click Next.

e) Complete steps 2 and 3.
f) In step 4, in the variable list, under Update, select the version free variable and

click Next.
g) Complete steps 5 and 6.
h) When the update is confirmed, click OK.

Windows Explorer Favorites Links
When you create a new local vault view, Enterprise PDM places a link to the vault view
in the Favorites list at the top of the Windows Explorer navigation pane.

This makes it easy to open the local vault view even if it is located in a subdirectory.
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