What's New in SolidWorks
Version 2010
What's New: Highlights of SolidWorks 2010........................................................................x
Legal Notices..................................................................................................................12

1 Administration..............................................................................................................15
   Installation Improvements..........................................................................................15
   SolidWorks Rx.............................................................................................................16
      Diagnostics for Graphics Card and Driver...............................................................16
      SolidWorks Rx Workflow.......................................................................................16
   Converting Files to SolidWorks 2010.........................................................................17

2 User Interface...............................................................................................................18
   Heads-Up View Toolbar Customization .....................................................................18
   Context Toolbars........................................................................................................18
   Instant3D Enhancements............................................................................................18
   Mouse Gesture Support.............................................................................................19
      Mouse Gestures.......................................................................................................19
   PropertyManager Improvements................................................................................23
   Graphics Area Controls Improvements ......................................................................23
   Larger Icons for Windows Vista................................................................................24
   Data Migration Tab in CommandManager....................................................................24
   Touch and Multi-Touch Support................................................................................24

3 Fundamentals..............................................................................................................26
   Documentation for SolidWorks...................................................................................26
      Web-based Documentation.......................................................................................26
      New Tutorials..........................................................................................................26
      30 Minute Lesson Renamed.....................................................................................27
      New Illustration Policy.............................................................................................27
   Display States for Parts.............................................................................................27
   Custom Properties.......................................................................................................28
   Reference Planes........................................................................................................28
      Creating Reference Planes......................................................................................28
      Modifying Reference Planes..................................................................................29
      Selecting Points to Create Planes..........................................................................29
   Viewing Decals in SolidWorks....................................................................................31
   Saving Multiple Documents.......................................................................................31
   Normal To Command.................................................................................................31

4 Application Programming Interface........................................................................33
5 3D ContentCentral..........................................................................................................................35
   Self-Service Catalog Publishing........................................................................................................35
   My 3D ContentCentral.......................................................................................................................35
   Request Content...............................................................................................................................36
   3D ContentCentral Community.........................................................................................................36

6 Assemblies........................................................................................................................................37
   Assembly Visualization ....................................................................................................................37
   Assembly Visualization Overview....................................................................................................37
   Activating the Assembly Visualization Tool....................................................................................37
   Visualizing the Assembly................................................................................................................38
   Changing the Sorting Property.........................................................................................................40
   Creating an Equation for Sorting....................................................................................................41
   Mirror Components .......................................................................................................................42
   Making Mirror Selections.................................................................................................................43
   Setting Orientation.........................................................................................................................43
   Creating Mirrored Configurations..................................................................................................44
   Editing a Mirror Component Feature.............................................................................................45
   Virtual Components .......................................................................................................................46
   Making External Components Virtual..........................................................................................46
   Naming Virtual Components............................................................................................................47
   Copying Virtual Components.........................................................................................................47
   Moving Virtual Components..........................................................................................................48
   Saving New In-Context Components..............................................................................................49
   Component Reference per Instance.................................................................................................50
   Display States..................................................................................................................................51
   SpeedPak..........................................................................................................................................52
   Mates................................................................................................................................................52
   Relocating Components..................................................................................................................52
   Replacing Components....................................................................................................................52
   Coordinate System Mates...............................................................................................................53

7 CircuitWorks..................................................................................................................................54
   User Interface..................................................................................................................................54
   Updating Assemblies.......................................................................................................................54
   Importing Non-CircuitWorks Assemblies from SolidWorks...........................................................54
   Selecting the Board Component and Orientation..........................................................................55
   Using Silhouette Edges to Determine Component Shape...............................................................55
   PADS Support................................................................................................................................55

8 Configurations..............................................................................................................................56
   Configuration Publisher ...................................................................................................................56
   Starting with Multiple Configurations............................................................................................57
   Starting with a Single Configuration.................................................................................................60
   Modify Configurations .....................................................................................................................65
3 Sketch Pictures .......................................................................................................................... 87
4 System Properties ....................................................................................................................... 87
5 Tangent Edges ............................................................................................................................. 87

13 eDrawings ................................................................................................................................. 90
 Integrated Publisher ........................................................................................................................ 90
 Print Preview ................................................................................................................................ 90
 Enhanced BOM Support ............................................................................................................... 91
 Apple Mac Printing Enhancements .............................................................................................. 92
 Display States Linked to Configurations ...................................................................................... 92
 Title Block Tables ......................................................................................................................... 93
 Decals .......................................................................................................................................... 94
 Sketch Pictures ............................................................................................................................. 94

14 Enterprise PDM ........................................................................................................................ 96
 Managing Tasks ............................................................................................................................. 96
 Setting Up Tasks ............................................................................................................................ 96
 Convert and Print Tasks ............................................................................................................... 97
 Executing Tasks ............................................................................................................................. 98
 Monitoring Tasks .......................................................................................................................... 98
 Task Add-ins ................................................................................................................................ 99
 Enterprise PDM and Toolbox Integration .................................................................................... 99
 Configuring Enterprise PDM and Toolbox ................................................................................ 99
 Using Toolbox with Enterprise PDM .......................................................................................... 100
 File Explorer and SolidWorks Add-in .......................................................................................... 101
 Naming Files with Serial Numbers Using Copy Tree ................................................................. 101
 Naming Drawings with Model Names Using Copy Tree ............................................................. 101
 Drawings with Multiple References Not Automatically Checked Out ........................................ 101
 File Preview Rebuild Warning ..................................................................................................... 101
 Warning when File Is Open in Another Application .................................................................... 101
 Changing Column Names and Order in the SolidWorks Add-in .................................................. 101
 Cold Storage Versions in Get Version Submenu ......................................................................... 102
 Item Management ......................................................................................................................... 102
 Generating Item IDs from File Attributes .................................................................................. 102
 Named BOMs for Items ............................................................................................................... 102
 Display Formats for Item BOMs ................................................................................................... 102
 Expanding and Collapsing Item Structure .................................................................................. 102
 Optional Parent Node Check Boxes ........................................................................................... 103
 API Support for Items .................................................................................................................. 103
 Administration Tool ....................................................................................................................... 103
 Add-in and File Format Support .................................................................................................. 103
 Extended Export and Import Functionality .................................................................................. 103
 Central Assignment of Permissions ............................................................................................ 104
 Serial Number Enhancements ................................................................................................... 105
 SMTP Mail Setup ........................................................................................................................ 105
## Contents

### 18 PhotoView 360

- PhotoWorks Decals in PhotoView 360
- Controlling Scenes
- Support for Background Images and Custom Environments
- Video Tutorials
- Saving Custom Views
- Camera Effects

### 19 Routing

- Manufacture-style Flattening
- Adding Components and Assembly Fittings to Routes
- 180-Degree Elbows or Bends for Piping
- Piping Drawings
- Access to Pipe, Tube, or Electrical Harness Coverings
- Multiple CPoint Enhancements
- P&ID Data Import and Modeling Process
- Reference Designators
- Pipe and Tube Route Export Enhancements
- Routing Library Enhancements

### 20 Sheet Metal

- Multibody Sheet Metal Parts
- Creating a Mirrored Sheet Metal Part
- Inserting a Part to Create a Multibody Sheet Metal Part
- Locating the Inserted Part
- Accessing Sheet Metal Bodies in Multibody Parts
- Merging Sheet Metal Bodies by Inserting Edge Flanges
- Splitting a Sheet Metal Part
- Preparing to Split the Part
- Inserting a Sheet Metal Part Using a Base Flange
- Editing Sheet Metal Bodies
- Closed Corner Improvements
- Hem Improvements
- Flat Pattern Improvements
- Exporting Sheet Metal Parts to DXF or DWG Files

### 21 Simulation

- SimulationXpress
  - New SimulationXpress Interface
  - Optimization in SimulationXpress
- NAFEMS Benchmarks
- Simulation Interface
  - Simulation Study Tree Enhancements
Contents

PropertyManager Enhancements.................................................................160
Simulation Studies......................................................................................161
General Enhancements..............................................................................161
Expanded Features for Simulation Advisor.................................................161
Simplified and Enhanced Fatigue Study (Professional)..............................161
Simplifying Assemblies for Nonlinear Studies (Premium).........................162
New Design Study.....................................................................................162
Offsets for Composites (Premium)..............................................................170
Beams........................................................................................................171
Connectors.................................................................................................173
Connectors Applied to Hole Series..........................................................173
Bolt Connectors........................................................................................173
Spring Connectors for Shells......................................................................173
Edge Weld Connectors (Professional)........................................................173
Bearing Connectors Between Parts.............................................................175
Bearing Loads for Circular Holes in Shells..................................................175
Mesh.........................................................................................................176
Mesh Enhancements..................................................................................176
Shell Definition by Selection of Faces.........................................................177
Contact.....................................................................................................177
Contact Set Enhancements........................................................................177
Component Contact..................................................................................178
Contact for Nonlinear Studies (Premium)...................................................178
Result Viewing..........................................................................................179
Handling Large Results Files (Premium).....................................................179
Plot Improvements....................................................................................179
Plot Stress During Time Steps in Motion....................................................179

22 Sketching............................................................................................181
Sketch Fillet Tool.......................................................................................181
Fit Spline Tool..........................................................................................181
Configurable Number of Instances in Sketch Entity Patterns.................181
Linking Sketch Text to File Properties.......................................................181
Convert Entities Sketch Tool....................................................................182
Equation-driven Curves..........................................................................182
Dimensions in 3D Sketches......................................................................182
Large Sketch Performance......................................................................182

23 SolidWorks Sustainability ....................................................................183
SolidWorks Sustainability Overview........................................................183
Designing for Sustainability......................................................................185
Selecting a Material..................................................................................186
Setting the Manufacturing and Use Options.............................................187
Comparing Similar Materials....................................................................187
Setting the Material................................................................................188
SolidWorks® 2010 includes many enhancements and improvements, most in direct response to customer requests. This release focuses on the following themes:

- User experience
- Reliability
- Performance

**Top Enhancements**

The top enhancements for SolidWorks 2010 provide improvements to existing products and innovative new functionality. Throughout this guide, look for the symbol in these areas:

<table>
<thead>
<tr>
<th>User Interface</th>
<th>Mouse Gesture Support on page 19</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fundamentals</td>
<td>Reference Planes on page 28</td>
</tr>
<tr>
<td>Assemblies</td>
<td>Assembly Visualization on page 37</td>
</tr>
<tr>
<td></td>
<td>Mirror Components on page 42</td>
</tr>
<tr>
<td></td>
<td>Virtual Components on page 46</td>
</tr>
<tr>
<td>Configurations</td>
<td>Configuration Publisher on page 56</td>
</tr>
<tr>
<td></td>
<td>Modify Configurations on page 65</td>
</tr>
<tr>
<td>Drawings and Detailing</td>
<td>Rapid Dimension on page 79</td>
</tr>
<tr>
<td></td>
<td>Dimension Palette on page 81</td>
</tr>
<tr>
<td></td>
<td>Drawing Views of Multibody Parts on page 85</td>
</tr>
<tr>
<td>Enterprise PDM</td>
<td>Enterprise PDM and Toolbox Integration on page 99</td>
</tr>
<tr>
<td></td>
<td>Managing Tasks on page 96</td>
</tr>
<tr>
<td>Motion Studies</td>
<td>Event-based Motion Analysis on page 110</td>
</tr>
<tr>
<td>Parts and Features</td>
<td>Move Face Features on page 120</td>
</tr>
<tr>
<td>Routing</td>
<td>Manufacture-style Flattening on page 133</td>
</tr>
<tr>
<td>Sheet Metal</td>
<td>Multibody Sheet Metal Parts on page 140</td>
</tr>
<tr>
<td>Simulation</td>
<td>New Design Study on page 162</td>
</tr>
<tr>
<td>Sustainability</td>
<td>SolidWorks Sustainability on page 183</td>
</tr>
</tbody>
</table>

**For More Information**

Use the following resources to learn about SolidWorks:

- **What's New in PDF and HTML**
  - This guide is available in PDF and HTML formats. Click: Help > What's New > PDF
Interactive What's New

In SolidWorks, click the 🤔 symbol to display the section of this manual that describes an enhancement. The symbol appears next to new menu items and the titles of new and changed Property Managers.

To enable Interactive What's New, click Help > What's New > Interactive.

Online Help

Contains complete coverage of our products, including details about the user interface, samples, and examples.

Release Notes

Provides information about late changes to our products.
Legal Notices

© 1995-2010, Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes S.A. company, 300 Baker Avenue, Concord, Mass. 01742 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of this license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the SolidWorks Corporation License and Subscription Service Agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of such warranties.


U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,184,044; 7,477,262; 7,502,027; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,694,238, and foreign patents, (e.g., EP 1,116,190 and JP 3,517,643). U.S. and foreign patents pending.

Trademarks and Other Notices for All SolidWorks Products

SolidWorks, 3D PartStream.NET, 3D ContentCentral, PDMWorks, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.


CircuitWorks, Feature Palette, FloXpress, PhotoWorks, TolAnalyst, and XchangeWorks are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of Geometric Ltd.

Other brand or product names are trademarks or registered trademarks of their respective holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

U.S. Government Restricted Rights. Use, duplication, or disclosure by the government is subject to restrictions as set forth in FAR 52.227-19 (Commercial Computer Software - Restricted Rights), DFARS 227.7202 (Commercial Computer Software and Commercial Computer Software Documentation), and in the license agreement, as applicable.

Contractor/Manufacturer:

Dassault Systèmes SolidWorks Corporation, 300 Baker Avenue, Concord, Massachusetts 01742 USA
Copyright Notices for SolidWorks Standard, Premium, and Professional Products

Portions of this software © 1990-2010 Siemens Product Lifecycle Management Software III (GB) Ltd.

Portions of this software © 1998-2010 Geometric Ltd.

Portions of this software © 1986-2010 mental images GmbH & Co. KG.

Portions of this software © 1996-2010 Microsoft Corporation. All rights reserved.

Portions of this software © 2000-2010 Tech Soft 3D.

Portions of this software © 1998-2010 3Dconnexion.

This software is based in part on the work of the Independent JPEG Group. All Rights Reserved.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software are copyrighted by and are the property of UGS Corp. © 2010.

Portions of this software © 2001 - 2010 Luxology, Inc. All Rights Reserved, Patents Pending.

Portions of this software © 2007 - 2010 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

Runtime: sha2

Copyright © 2000-2001, Aaron D. Gifford. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

1. Redistributions of source code must retain the above copyright notice, this list of conditions, and the following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and the following disclaimer in the documentation and/or other materials provided with the distribution.

3. Neither the name of the copyright holder nor the names of contributors may be used to endorse or promote products derived from this software without specific prior written permission.

This software is provided by the author and contributor(s) "as is" and any express or implied warranties, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose are disclaimer. In no event shall the author or contributor(s) be liable for any direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility of such damage.

For more copyright information, in SolidWorks see Help > About SolidWorks.

Other portions of SolidWorks 2010 are licensed from DS SolidWorks licensors.
Copyright Notices for SolidWorks Simulation

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2007 Computational Applications and System Integration, Inc. All rights reserved.

Portions of this product are distributed under license from DC Micro Development, Copyright © 1994-2005 DC Micro Development, Inc. All rights reserved.
This chapter includes the following topics:

- Installation Improvements
- SolidWorks Rx
- Converting Files to SolidWorks 2010

**Installation Improvements**

SolidWorks 2010 contains many improvements to SolidWorks Installation Manager and the installation process.

**Installation Manager**

The SolidWorks Installation Manager process has been redesigned to simplify the workflow and improve ease of use:

- The workflow is now displayed on the left, indicating the current step in the process.
- The default workflows are much shorter, typically one screen for the SolidWorks serial numbers followed by a summary screen in which you can initiate the installation, download files, or remove the installation.
- All optional settings are available from the summary screen (for example, product component selections, optional installation behavior, installation location, and Toolbox options). However, you are not required to click through multiple screens just to accept the default settings.

You can now start SolidWorks Installation Manager using the `setup.exe` file found at the root of the DVD or installation directory (in addition to the `sldim\sldim.exe` file).

**Error Messages and Log Files**

The Installation Manager error messages have been rewritten to allow easier diagnosis of installation problems.

The Installation Manager log files have been improved to help resellers and users read them more easily to resolve issues encountered during installation and update. The log files are located in the SolidWorks application data folder on the computer where you ran the installation:

- For Microsoft® Windows Vista®:
  
  `C:\Users\username\AppData\Roaming\SolidWorks\Installation Logs`

- For Windows® operating system versions prior to Windows Vista:
  
  `C:\Documents and Settings\username\Application Data\SolidWorks\Installation Logs`
**Installation File Sizes and Processing Time**

The installation and download process now supports patching for more individual product components. This patch support reduces file sizes and processing time when performing install, download, and uninstall actions, particularly for Service Pack releases.

**Downloading the Full Release File Set**

Using SolidWorks Installation Manager, you can now download the full file set for the release.

This file set includes all files included on the DVD for that release, not just the files required to update the computer on which you are running the installation. All users at your site can share this full download file set to install on any computer, without requiring any other local or downloaded files or a DVD.

**Service Pack Installation Changes**

Beginning in SolidWorks 2010, installing a new Service Pack release upgrades the latest version of the corresponding major release. Parallel Service Pack installations of the same major release on the same computer are not supported.

**SolidNetWork License Activation**

SolidNetWork License Manager now uses SolidWorks license activation technology, which allows a simple, wizard-based configuration process and eliminates the need for dongles.

**SolidWorks Rx**

**Diagnostics for Graphics Card and Driver**

You can now determine whether your graphics card is supported and your driver is up to date using the Diagnostics tab in SolidWorks Rx. If your driver is out of date, a new Download driver button allows you to download the latest SolidWorks certified driver.

If you encounter problems with downloading a library named GfxMbMash.dll from the Web site, a warning message is displayed. SolidWorks Rx cannot access the online graphics card database due to this error. This problem might be related to a proxy server or certain firewall restrictions.

**SolidWorks Rx Workflow**

The SolidWorks Rx Workflow is improved to create service requests based on the information you provide in the Rx file.

The following enhancements are made to improve the workflow for SolidWorks Rx:

- The Diagnostics tab is updated to include links to new graphics card diagnostics.
- A new Troubleshoot tab is added where you can view common solutions to the listed areas using the SolidWorks Knowledge Base.
- A new Check KB button is added to access the Knowledge Base in the Problem Capture Details dialog box.

On the Problem Capture tab, recreate the problem by clicking Begin Recording. To write an explanation of the problem, click Describe Problem. In the Problem Capture Details dialog box, type a summary of the problem. Click Check KB to check the Knowledge Base if similar issues have already been reported.
Converting Files to SolidWorks 2010

Opening a SolidWorks document from an earlier release can take extra time. After you open and save a file, subsequent opening time returns to normal.

You can use the SolidWorks Task Scheduler (SolidWorks Professional) to convert multiple files from an earlier version to the SolidWorks 2010 format. Click Windows Start, then All Programs > SolidWorks 2010 > SolidWorks Tools > SolidWorks Task Scheduler.

In the Task Scheduler:
- Click Convert Files and specify the files or folders to convert.
- For files in a SolidWorks Workgroup PDM vault, use Convert Workgroup PDM Files.

For files in a SolidWorks Enterprise PDM vault, use the utility provided with Enterprise PDM.

⚠️ After you convert files to SolidWorks 2010, you cannot open them in older SolidWorks versions.
This chapter includes the following topics:

- Heads-Up View Toolbar Customization
- Context Toolbars
- Instant3D Enhancements
- Mouse Gesture Support
- PropertyManager Improvements
- Graphics Area Controls Improvements
- Larger Icons for Windows Vista
- Data Migration Tab in CommandManager
- Touch and Multi-Touch Support

Heads-Up View Toolbar Customization

You can customize the Heads-Up View toolbar with different setups for modeling and drawing.

To customize the Heads-Up View toolbar, click Tools > Customize and select the Toolbars tab:

- Select or clear View (Heads-Up) to show or hide the toolbar.
- Select the Commands tab to add, remove, or reorder the toolbar buttons.

You can also show or hide the Heads-Up View toolbar by selecting or clearing View > Toolbars > View (Heads-Up).

Context Toolbars

Context toolbars appear when you right-click the following entities in drawings:

- Components
- Drawing views
- Edges
- Vertices

Instant3D Enhancements

In assemblies, when you click Move with Triad from the shortcut menu, rulers now appear with the triad so you can move components to a defined location.
You can use the triad to edit a Move Face feature (Translate or Rotate type) that was created with Instant3D triad. The triad appears when you select the feature in the graphics area.

Mouse Gesture Support

**Mouse Gestures**

You can use a mouse gesture as a shortcut to execute a command, similar to a keyboard shortcut. Once you learn command mappings, you can use mouse gestures to invoke mapped commands quickly.

To activate a mouse gesture, from the graphics area, right-drag in one of four directions: up, down, left or right.

When you right-drag, a guide appears, showing the command mappings for the gesture directions. The guide highlights the command you are about to select.

To cancel a mouse gesture, release the mouse within the mouse gesture guide.

Drawings Guide With Eight Gestures

Assemblies Guide with Four Gestures
You can customize up to eight gestures each, for drawings, assemblies, parts, and sketches.

To view or edit the current mouse gesture assignments, click **Tools > Customize**. From the Customize dialog box, select the Mouse Gestures tab.

To use mouse gestures with assemblies, right-drag in the graphics area away from components to avoid component rotation or press **Alt + right-drag**.

**Mouse Gestures for Sketches and Parts**

In this example, you create a simple part by creating a sketch, adding a dimension, and extruding it.

Actions you perform with mouse gestures include:

- Sketching a rectangle and a circle
- Saving the sketch
- Dimensioning the sketch
- Changing the view of the extruded part

To see the mouse gesture command mappings for sketches, drawings, parts, or assemblies, click **Tools > Customize**. From the **Mouse Gestures** tab, select **All Commands**, and **Show only commands with mouse gestures assigned**.

**Sketching the Part**

First you open a part and use a mouse gesture to invoke the rectangle sketch tool.

1. Click **File > New** and double-click **Part**.
2. Click **Sketch** (Sketch toolbar) and select the **Front Plane** to start the sketch.
3. To enable eight mouse gesture directions, click **Tools > Customize**, and from the Mouse Gestures tab, select **8 gestures** and click **OK**.
4. In the graphics area, right-click and drag straight down. The mouse gesture guide highlights the rectangle sketch tool icon. The rectangle sketch tool is mapped to the straight down mouse gesture.

Before selecting a highlighted command, with the cursor inside the guide, you can drag through another command to select it.

5. Drag through the highlighted rectangle sketch tool.
The Rectangle PropertyManager appears.

6. Click **Center Rectangle**. Your cursor is a sketch pencil, ready to draw a centered rectangle.
7. Left-click and drag to stretch a rectangle from the center of the graphics area.
8. Click again to complete the rectangle.

![Rectangle Sketch Tool](image)

**Invoking the Circle Sketch Tool**
Next you invoke the circle sketch tool with a mouse gesture.

The circle sketch tool is mapped to the straight right mouse gesture 🟦.

1. Right-click and drag to the right, through the highlighted circle sketch tool.

![Circle Sketch Tool](image)

The Circle PropertyManager appears.
2. Center a circle within the rectangle.
3. Click to set the radius and complete the circle.

**Invoking the Dimension Tool**
Next you invoke the dimension tool with a mouse gesture and save the sketch.

The dimension sketch tool is mapped to the straight up mouse gesture ⬆️. The save sketch tool is mapped to the right diagonal up mouse gesture 🟦.

1. Right-click and drag straight up through the highlighted dimension sketch tool.
2. Select the two upper corners of the rectangle and click to place the dimension.

3. Click ✓ to close the Modify dialog box.

4. Right-click and drag up in the right diagonal direction to save the sketch.

Extruding the Sketch and Viewing the Part

The back view command is mapped to the left diagonal down mouse gesture ➡️. Next, to complete the part, you extrude the sketch, using a mouse gesture to display the back view.

1. Click **Boss/Base** (Features toolbar). The Extrude PropertyManager appears.

2. For **Depth** ➡️, enter 0.40in and click ✓.
3. Right-click and drag down in the left diagonal direction to display the back view of the part.

PropertyManager Improvements

PropertyManager improvements include:

- Retaining settings, group box visibility, and values between uses of the same command across sessions
- Automatically transferring focus from one control to another to facilitate the workflow
- Using round numbers as default values

Graphics Area Controls Improvements

When you interact with PropertyManagers, graphics area controls, including the following are applied more consistently:

- Right-click OK pointers
• Right-click Advance pointers

💡 Right-click a graphics area Advance pointer to advance through PropertyManager selections when multiple selections are required.

Larger Icons for Windows Vista

When using Windows Vista, 256 x 256-pixel versions of the SolidWorks application and document icons are available, depending on your Windows icon display settings. Large icons appear in various interfaces in the operating system, including Windows File Explorer.

Data Migration Tab in CommandManager

The new Data Migration tab in the CommandManager contains tools to help you migrate solid or surface data.

By default, the tab is not displayed in the CommandManager. To turn on the Data Migration tab, right-click a CommandManager tab and click **Data Migration.**

Touch and Multi-Touch Support

If you install SolidWorks on a touch-enabled computer, you can use flick touch and multi-touch gestures in SolidWorks.

The back, forward, drag, and scroll flick actions are mapped to SolidWorks view rotations. Commands for all other flick actions, for example, Undo, invoke the same command in SolidWorks.

For example, flick back corresponds to the left arrow view rotation (15 degrees, by default).

📝 When you do a flick action, the default Windows command icon for the action is displayed, even though the commands are mapped to SolidWorks arrow key view rotations.

You can also apply multi-touch gestures for zoom, rotate, pan, roll, right-click, and zoom-to-fit operations.
To learn how to use touch and multi-touch gestures in touch-enabled computers, see the product documentation for your device.

For more information about the SolidWorks interpretation of touch and multi-touch gestures, see SolidWorks Help: Flick and Multi-Touch Actions.
This chapter includes the following topics:

- Documentation for SolidWorks
- Display States for Parts
- Custom Properties
- Reference Planes
- Viewing Decals in SolidWorks
- Saving Multiple Documents
- Normal To Command

Documentation for SolidWorks

Web-based Documentation

Documentation is now available on the Web for SolidWorks, SolidWorks Enterprise PDM, and eDrawings®.

By default, when you access help, the Web version of the documentation is displayed in a Web-based viewer. You can still choose to use local help files (.chm) if, for example, your Internet connection is slow or unavailable.

Benefits of Web-based help include:

- Improved search functionality, including improved relevancy ranking, spelling correction, short descriptions in search results views, and guided navigation to help you identify relevant topics.
- Improved topic navigation, including next and previous topic buttons and breadcrumb navigation.
- Ability to provide feedback directly to the documentation team on individual help topics.
- Up-to-date documentation without the need to download large compiled help (.chm) files.

Select or clear Help > Use SolidWorks Web Help to switch between the local and Web-based versions of the help.

New Tutorials

New tutorials are available:

- SolidWorks
  - DimXpert
  - Electrical Routing™
  - TolAnalyst™
  - SolidWorks API C#
• SolidWorks API Visual Basic
• SolidWorks API .NET
• SolidWorks Simulation®
  • Design Check for Assembly with Mixed Mesh
  • Design Check for Connectors

Click Help > SolidWorks Tutorials to access the SolidWorks and SolidWorks API tutorials.

Click Simulation > Help > Simulation Online Tutorial to access the SolidWorks Simulation tutorials.

**30 Minute Lesson Renamed**

*30 Minute Lesson* has been renamed *Introduction to SolidWorks* to better reflect its scope.

**New Illustration Policy**

In response to customer requests, our documentation now includes more images than in earlier releases. In the past, all images that contained text were localized, which limited the number and type of illustrations we could provide. In this release, we include English illustrations in localized documentation when translated text is not required for understanding the concept, for example, the location of an item or the general layout of the UI.

**Display States for Parts**

You can now specify display states for parts in the same way that you could specify them for assemblies in previous versions of SolidWorks. Display states allow you to toggle quickly between different visual representations of the part without changing configurations.

Part display states control the appearance, display mode, hide/show, and transparency of bodies, features, faces, and parts according to the following chart:

<table>
<thead>
<tr>
<th>Display Mode</th>
<th>Hide/Show</th>
<th>Transparency</th>
<th>Appearance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Body (solid and surface)</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Feature</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Features you can hide (including sketch, reference geometry, curves, parting lines, and routing points)</td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Face</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

If a part contains multiple display states, you can see them:

- When the display pane is:
  - Closed, by right-clicking » in the top right corner of the FeatureManager® design tree.
  - Open, by right-clicking in the display pane and mousing over **Activate Display State**.
• In the ConfigurationManager under **Display States**.
To add a display state, right-click in any blank area in the ConfigurationManager and click **Add Display State**.

💡 You can now select which of a part's display states to use in an assembly. See **Display States** on page 51.

**Custom Properties**

The Custom Properties tab of the Task Pane now supports lightweight components.
When you select a lightweight component of an assembly, you can view the component's custom properties in the Task Pane.

📝 You cannot save changes to lightweight components. If you edit a value, the software prompts you to resolve the component.

**Reference Planes ★**

Creating reference planes is now easier. You select geometry and apply constraints to the geometry to define reference planes. The new process lets you create more types of reference planes than were previously possible.

**Creating Reference Planes**

1. **Open** `install_dir\samples\whatsnew\RefGeom\Bracket.sldprt`.
2. Click **Plane** (Reference Geometry toolbar).
   The PropertyManager **Message** box prompts you to select references and constraints.
3. For **First Reference**, select the face shown.

![Reference Plane](image)

The software creates a plane that is offset from the selected face. The **Message** box indicates that the plane is fully defined. You can adjust the offset distance or select another type of reference to use to create the plane.

📝 The software creates the most likely plane based on the entities you select.

4. **Click ✓**.
Modifying Reference Planes

1. Right-click the plane you created and select Edit Feature.
2. In the PropertyManager, for First Reference, select the cylindrical face shown.

The software creates a plane tangent to the face. The plane type Tangent is selected.
3. Select the curved face shown.

The plane extends to become tangent to both faces.

The plane flips to become tangent with the opposite side of the cylindrical face.
5. Click.

Selecting Points to Create Planes

1. Click Shaded with Edges (View toolbar).
2. Click Plane (Reference Geometry toolbar).
3. For First Reference, select the vertex shown.
4. For Second Reference, select the vertex at the opposite end of the edge.

The software creates a plane coincident to both references.

5. For Third Reference, select an edge approximately as shown.

The plane turns red, indicating invalid selections. The Message box informs you that the current combination of references is not valid. The Rebuild Errors message instructs you to replace the selection with a point or plane.

6. Select the endpoint of the edge.
The software creates a valid plane that is coincident to the three selected references. The **Message** box reports that the plane is now fully defined.

7. Click ✓.

**Viewing Decals in SolidWorks**

A new menu item lets you see decals in SolidWorks without activating PhotoWorks™. To apply decals, you must first activate PhotoWorks, as in earlier releases.

To display or hide decals, click one of the following:

- **View > Decals**
- **Hide/Show Items** (Heads-up View toolbar), **View Decals**
- **View Decals** (View toolbar)

**Saving Multiple Documents**

The dialogs presented when saving or closing multiple documents have been consolidated into a single dialog box, **Save Modified Documents**.

When saving or closing an assembly or other document that includes modified documents, you can do the following from the **Save Modified Documents** dialog box:

- Save all modified documents
- Selectively save modified top-level documents
- Discard changes to all documents

Read-only documents and documents saved by other users during your session are indicated in the dialog box.

**Normal To Command**

You can use the **Normal To** command to orient a model normal to the nearest global XYZ coordinates.

To orient a model normal to the nearest global XYZ coordinates:
1. From an open model or 3D sketch, with nothing selected, press the spacebar.

2. From the **Orientation** dialog box, double-click **Normal To**.

   The model aligns with the rotated coordinate system.

   ![Model alignment](image)

   When you apply this method to a 2D Sketch, the model is aligned normal to the sketch.

   For more information on the Normal To command, see *SolidWorks Help: Orientation*. 
Major enhancements are new interfaces, methods, properties, and delegates. You can now:

- Access DimXpert features
- Include attributes in library features
- Access tangent lines associated with bend lines in drawings of sheet metal parts
- Get an array of mates for a component
- Create generic, right-click, and pop-up menus
- Specify alignment of axes when inserting a coordinate systems mate
- Find the corresponding faces, edges, and vertices in a folded and flattened sheet metal part
- Fire notifications:
  - For undo and redo operations in parts, assemblies, and drawings
  - When interactive users preselect entities in parts, assemblies, and drawings
  - After all SolidWorks graphics are drawn
- Compare two persistent reference IDs to determine if they point to the same SolidWorks data
- Create bubble ToolTips for PropertyManager page controls
- Add and modify graphics-area dimensions in circular and linear sketch patterns
- Get the names of all components in an assembly document before selectively opening the assembly document
- Get and set pick points for lofts
- Add and purge display states and fire notifications when a display states changes
- Create equations for 2D explicit, 2D parametric, and 3D curves
- Get or set a component reference
- Box-select entities
- Specify the distance from the section line of the section view
- Determine if a sketch is derived
- Insert a route line in an explode line or 3D sketch
- Rotate or copy 3D sketch entities about a vector or x, y, and z coordinates
- Add smart components and insert virtual components in assemblies
- Create a new assembly from preselected components
- Insert a title block table in a part or assembly
- Get sheet and configuration persistent reference IDs
- Create a loft body using specified parameters instead of using interactive user selections
- Create multiple types of macros (VBA, VB.NET, and C#) when recording a macro
- Delay solving of equations until all equations are added
- Customize the size of balloons
- Hide table columns
- Customize tags in hole tables
- Get the UV parameters of a curve
• Get a component in the context of the top assembly after getting the component in the context of a subassembly, and get a component in the context of a subassembly after getting the component in the context of the top assembly
• Access feature statistics

Click Help > API Help > SolidWorks API Help > SolidWorks APIs > Release Notes.
3D ContentCentral® is a free service for locating, configuring, downloading, and requesting 3D parts and assemblies, 2D blocks, library features, and macros. You can join this active community of more than a half million CAD users who share and download user-contributed and supplier-certified models and more.

Click 3D ContentCentral to learn more about this service. To register, click Register.

This chapter includes the following topics:

- Self-Service Catalog Publishing
- My 3D ContentCentral
- Request Content
- 3D ContentCentral Community

Self-Service Catalog Publishing

Supplier Services provides industrial component and OEM suppliers with the tools needed to publish CAD models of their products to the vast 3D ContentCentral community. Suppliers get access to their own secure content management system, browser-based file upload utility, and model preview and edit pages, which makes publishing supplier catalogs fast and easy. The Configuration Publisher tool in SolidWorks lets you create rules that define allowable configurations of a model before you upload the model to 3D ContentCentral.

Click Supplier Services on 3D ContentCentral to explore how to publish your models to the CAD community and to your own Web site. You can also generate reports about activity in your supplier catalog. Access to these subscription features is online and self service.

To register for a Supplier Services account, click Register Now. See Configuration Publisher on page 56 for more information on how to use the Configuration Publisher tool with 3D ContentCentral.

My 3D ContentCentral

You can personalize your own workspace on 3D ContentCentral. You can update your profile, add models to your portfolio, monitor your requests, favorites, or updates, and review your tags, comments, views, and downloads all on your own page.

Click My 3D ContentCentral on 3D ContentCentral to access your personal area.
Request Content

If you have a specific need, you can post a request and let the active members respond. You can take advantage of the vast user and supplier communities. Plus, you have the ability to request new suppliers.

Click Request Content on 3D ContentCentral to request specific parts, assemblies, or other content from the community.

3D ContentCentral Community

The 3D ContentCentral community is an active group of people who understand design and the advantages of sharing. You can invite colleagues or friends to be your contacts on 3D ContentCentral and stay current with each other’s activities in My Updates.

Click Updates on My 3D ContentCentral to add contacts and follow your contacts’ activities.
This chapter includes the following topics:

- Assembly Visualization
- Mirror Components
- Virtual Components
- Component Reference per Instance
- Display States
- SpeedPak
- Mates

Assembly Visualization

**Assembly Visualization Overview**

Assembly Visualization provides different ways to display and sort an assembly’s components in a list and in the graphics area.

You can list the components in these ways:

- Nested view, where subassemblies are indented
- Flat view, where subassembly structures are ignored (similar to a parts-only BOM)

You can sort the list by one property at a time. Basic calculated numerical data such as component mass, density, and volume are available in the tool. Additionally, you can create customized criteria which are dependent on several numerical values. If you defined noncalculated properties such as `Vendor` or `Status` in the component files, you can access those properties for modification and sorting. Properties from SolidWorks Sustainability are also available. (See SolidWorks Sustainability Overview on page 183.)

If you sort by `SW-Material`, you can edit component materials directly from the list.

You can save the list information in a separate file such as a Microsoft Excel® spreadsheet or a text file.

In the graphics area, the software applies colors to the components based on the value of the property you are sorting by. The colors help you to visualize the relative value of the property for each component.

**Activating the Assembly Visualization Tool**

To activate the Assembly Visualization tool:

1. Open
   
   `install_dir\samples\whatsnew\assemblies\visualize\food_processor.sldasm`
2. Click **Assembly Visualization** (Tools toolbar or Evaluate tab on the CommandManager).

The Assembly Visualization tab in the FeatureManager design tree panel contains a list of all components in the assembly, sorted initially by file name.

```
<table>
<thead>
<tr>
<th>File Name</th>
<th>Quantity</th>
<th>Mass</th>
</tr>
</thead>
<tbody>
<tr>
<td>base plate</td>
<td>1</td>
<td>83.39</td>
</tr>
<tr>
<td>drive shaft pin</td>
<td>1</td>
<td>0.13</td>
</tr>
<tr>
<td>drive shaft plate</td>
<td>1</td>
<td>1.95</td>
</tr>
<tr>
<td>drive shaft</td>
<td>1</td>
<td>8.77</td>
</tr>
<tr>
<td>gear caddy</td>
<td>1</td>
<td>222.48</td>
</tr>
<tr>
<td>middle gear plate</td>
<td>1</td>
<td>4.63</td>
</tr>
<tr>
<td>middle gear</td>
<td>1</td>
<td>52.16</td>
</tr>
<tr>
<td>rubber feet</td>
<td>5</td>
<td>0.01</td>
</tr>
<tr>
<td>shaft gear insert</td>
<td>1</td>
<td>0.44</td>
</tr>
<tr>
<td>shaft gear</td>
<td>1</td>
<td>127.37</td>
</tr>
<tr>
<td>shaft washer</td>
<td>2</td>
<td>0.42</td>
</tr>
</tbody>
</table>
```

You can click to change the appearance of the list.

- **Flat/Nested View**
  - Switches between:
    - Nested view, where subassemblies are indented
    - Flat view, where subassembly structures are ignored (similar to a parts-only BOM)

- **Show/Hide Value Bars**
  - Turns the value bars off and on. When the value bars are on, the longest bar is applied to the component with the highest value. The lengths of all the other bars are calculated as a percentage of the highest value.

Icons in the list indicate the following:

<table>
<thead>
<tr>
<th>Part</th>
<th>Subassembly</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Part" /> <img src="image" alt="Subassembly" /></td>
<td>A component with a single instance.</td>
<td></td>
</tr>
<tr>
<td><img src="image" alt="Part" /> <img src="image" alt="Subassembly" /></td>
<td>A component with multiple instances, all of which are shown.</td>
<td></td>
</tr>
</tbody>
</table>

For a complete list of possible icons, see *SolidWorks Help: Assembly Visualization Tab*.

**Visualizing the Assembly**

To visualize the assembly:

1. At the top of the last column, click **Mass** to sort the components by mass.
2. On the left side of the panel, click the vertical bar.

The vertical bar displays a spectrum of colors from red to blue. In the graphics area, the components change to the color that is beside their entry in the Assembly Visualization panel. The colors indicate the relative mass of the components. The heaviest components are shown in red, the lightest in blue, and the others in shades in between.

3. To add another color to the spectrum:
   a) Click in the blank area to the left of the vertical bar.

   b) In the Color dialog box, select (yellow) and click OK.
   A yellow slider is added to the spectrum. The parts change color in the graphics area.

💡 You can move the color sliders up and down to modify the spectrum. You can right-click a color slider and change its color or delete it. To return to the original two sliders, right-click any slider and click Reset all.
4. Under the column headers, drag the horizontal bar down and position it below \textit{gear-caddy}.

\begin{table}[h]
\centering
\begin{tabular}{lcc}
\hline
\textbf{Component} & \textbf{Quantity} & \textbf{Weight} \\
\hline
\textit{gear-caddy} & 1 & 222.450 \\
\hline
\textit{shaft gear} & 1 & 127.370 \\
\textit{middle case} & 1 & 124.450 \\
\hline
\end{tabular}
\end{table}

In the graphics area, the heaviest component, \textit{gear-caddy}, is hidden.

\begin{figure}[h]
\centering
\includegraphics[width=0.4\textwidth]{gear-caddy}
\end{figure}

5. At the bottom of the list, drag the horizontal bar up and position it above \textit{shaft gear insert}.

\begin{table}[h]
\centering
\begin{tabular}{lcc}
\hline
\textbf{Component} & \textbf{Quantity} & \textbf{Weight} \\
\hline
\textit{rubber feel} & 5 & 0.510 \\
\textit{shaft gear insert} & 1 & 0.440 \\
\textit{shaft washer} & 2 & 0.620 \\
\textit{drive shaft pin} & 1 & 0.130 \\
\hline
\end{tabular}
\end{table}

The three components that weigh the least are hidden. Note that the spectrum adjusts to the visible components, showing their relative values.

\begin{figure}[h]
\centering
\includegraphics[width=0.4\textwidth]{components}
\end{figure}

6. Return the bars to their original positions:
   a) Right-click the top bar and click \textbf{Roll to Top}.
   b) Right-click the bottom bar and click \textbf{Roll to End}.

**Changing the Sorting Property**

You can change the property used to sort components. You can select custom properties defined in the component files and create equations involving those properties.
To change the sorting property:

1. Click the arrow ➤ to the right of Mass.
   The flyout list contains some commonly used properties. You can also select from any other custom properties already defined in the components, as demonstrated in the following steps.
2. Click More.
3. In the dialog box, in Properties, select Cost.
   Cost appears in Column header.
4. Click OK.
   Cost appears at the top of the property column, and the components are sorted from highest to lowest cost. In the graphics area, the colors of the parts change accordingly.

Creating an Equation for Sorting

Some components are in the assembly multiple times. For example, there are five rubber feet on the bottom of the base plate. Component rubber feet appears at the bottom of the list because it costs the least.

Now create and sort by an equation that calculates the extended cost for each part.

1. Click the arrow ➤ to the right of Cost.
2. Click More.
3. In the dialog box:
   a) In Properties, select Cost.
   b) In Column header, type Extended Cost.
   c) Select Use Formula.
      Cost appears in the equation box.
d) In the equation box, type *.
e) In Properties, select Quantity.
The equation defines extended cost as cost multiplied by quantity.

4. Click OK.
   **Extended Cost** appears at the top of the property column and the components are sorted from highest to lowest extended cost. Component **rubber feet** moves up to the middle of the list. In the graphics area, the colors of the parts adjust accordingly.

5. Save the assembly.
   The custom column data is saved so it will appear the next time you access **Assembly Visualization** in this model.
   You can save the list information in a separate file.

6. In the header area of the list, right-click and click **Save as**.

7. In the Save As dialog box:
   a) For **Save in**, select **My Documents**.
   b) For **File name**, type **my_food_processor**.
   c) For **Save as type**, select **Text (*.txt)**.
   d) Click **Save**.
   The text file contains a list with the information from the Assembly Visualization panel.

8. At the top of the panel, click **Exit Visualization**.
   The panel closes and its tab disappears.

**Mirror Components**

Enhancements:

- A **MirrorComponent** feature is added to the FeatureManager design tree to maintain the position of mirrored components relative to seed components.
- You can create an opposite-hand version as a derived configuration of the component you are mirroring.
- The Mirror Components PropertyManager includes changes that simplify the workflow.
In this example, you mirror a two-component subassembly. You create opposite-hand versions of the subassembly and one component, and save them as derived configurations. You create a second instance of the other component.

**Making Mirror Selections**
First you select the mirror plane and the components to mirror.

1. Open `install_dir\samples\whatsnew\assemblies\mirror\vise.sldasm`.

2. Click **Mirror Components** (Assembly toolbar) or **Insert > Mirror Components**.
3. In the PropertyManager:
   a) For **Mirror plane**, in the flyout FeatureManager design tree, select **Right Plane**.
   b) For **Components to Mirror**, select the subassembly **jaw_and_support**.

4. Click **Next**. A preview of the mirrored components appears.

**Setting Orientation**
For each component, you specify whether to create an opposite-hand version or just a copy. For copies, you specify orientation.
In this example, you create an opposite-hand version of the subassembly jaw_and_support. For its components, you create an opposite-hand version of support and a copy of jaw.

1. Under Orient Components, expand jaw_and_support-1.

2. Click Create opposite hand version. The icon appears beside jaw_and_support-1 and each of its components to indicate that you are creating an opposite-hand version for each item. Because the jaw is symmetrical, you do not need to create an opposite-hand version. Instead, create a copy of the jaw and orient it as needed.


4. Click Create opposite hand version to clear the icon.

5. Click Reorient and to cycle through the four possible orientations and select the correct one.

Creating Mirrored Configurations
When you create an opposite-hand version of a component, you can create it in a new file or as a new derived configuration in the existing component file.

The subassembly and the support component appear under Opposite Hand Versions.

1. Select Create new derived configuration in existing files.

2. Click . If a message about mates appears, click OK.

MirrorComponent appears in the FeatureManager design tree.

3. Expand MirrorComponent, and then expand jaw_and_support.

4. Under jaw_and_support, right-click support and click Open Part.

5. In support.sldprt, on the ConfigurationManager tab, expand Default. MirrorDefault is the new opposite-hand configuration you created.
6. Close the part and click **No** when asked if you want to save changes.

**Editing a Mirror Component Feature**

You can edit a mirror component feature.

1. In the FeatureManager design tree, right-click **clamp** and click **Unsuppress**.
   A clamp appears on the model.

2. Right-click **MirrorComponent** and click **Edit Feature**.
3. In the PropertyManager, for **Components to Mirror**, select the clamp in the graphics area.

4. Click **Next**.
   Because the clamp is symmetrical, you do not need to create an opposite-hand version.

5. Under **Orient Components**, select **clamp-1**.

6. Click **Reorient** and if necessary to obtain the correct orientation.

7. Click ✓.
   Another instance of **clamp** is added to the assembly.
Virtual Components

Making External Components Virtual
You can make externally saved components virtual, which breaks the link to the external component file. Existing references are ignored and the component is renamed.
You can make components virtual while you insert them or after you insert them into the assembly.

1. Open `install_dir/samples/whatsnew/assemblies/virtual/conveyor.sldasm`. The assembly contains two components: a rail subassembly and a pin.

2. Click **Insert > Component > Existing Part/Assembly**.
3. In the Property Manager, under **Options**, select **Make Virtual**.
4. Under **Part/Assembly to Insert**, click **Browse**, open `rod_clevis.sldprt`, and click to place it in the graphics area.
The software warns you that making a component virtual breaks the link to the external file.

5. Click **OK**.
The part is added to the assembly as a virtual component named **[Copy of rod_clevis^conveyor]**.
Now make the pin a virtual component.

6. In either the FeatureManager design tree or the graphics area, right-click the pin and click **Make Virtual**.
The software warns you that making a component virtual breaks the link to the external file.

7. Click **OK**.
The name of the pin is changed to **[Copy of pin .75x3.0^conveyor]**.

**Naming Virtual Components**
The name of a virtual component now always includes its parent assembly's name.

The format of the default name for virtual components remains the same:

**[Partn^Assembly_name]**

However, now you can rename only the first name, **Partn**, and not the surname, **Assembly_name**, which ensures that the name of the virtual component is unique. When you move or copy a virtual component to another assembly, the surname changes to reflect that assembly's name.

1. In the FeatureManager design tree, right-click **[Copy of pin .75x3.0^conveyor]** and click **Rename Part**.
2. Type **pin_special** and press **Enter**.
The virtual component is renamed **[pin_special^conveyor]**.

**Copying Virtual Components**
You can copy virtual components between assemblies. The copy is not linked to the original virtual component. Existing references are not copied, and the copy is given a new name.

1. Open

   `install_dir/samples/whatsnew/assemblies/virtual/support_assembly_2.sldasm`
   
The assembly contains a virtual component named **[bumper^support_assembly_2]**.

2. Click **Window > Tile Horizontally** so that both **conveyor.sldasm** and **support_assembly_2.sldasm** are visible.

3. In the FeatureManager design tree of **support_assembly_2.sldasm**, select **[bumper^support_assembly_2]** and drag it to the graphics area of **conveyor.sldasm**.
The software warns you that copying a virtual component to another file breaks the link to the original file.

4. Click **OK**.
   The part is copied into `conveyor.sldasm` and is renamed **[Copy of bumper^conveyor]**.

---

**Moving Virtual Components**

You can move virtual components within the hierarchy of the FeatureManager design tree. Existing references are ignored and the component is renamed.

1. **Close** `support_assembly_2.sldasm` and **maximize the window for** `conveyor.sldasm`.
2. **In the graphics area, select the shaft and try to drag it.**
   You cannot move the shaft because it is a virtual component created in the context of the subassembly **RH_rail**. It is constrained by an **InPlace** mate and its sketch contains references to another component in the subassembly.

3. **In the FeatureManager design tree:**
   a) **Expand the subassembly **RH_rail**.**
   b) **Select [shaft^RH_rail]**, drag it down, and drop it when the pointer changes to **.**

   The software warns you that if you move a virtual component to another assembly, the component will be renamed and links to the original component will be broken.

4. **Click **OK**.**
   The Assembly Structure Editing dialog box appears. It informs you that the shaft’s **InPlace** mate will be deleted and its in-context sketch will go out of context.

5. **Click **Move**.**
   The component is renamed to **[Copy of shaft^conveyor]** to reflect that it is now a component of `conveyor.sldasm`.

6. **In the graphics area, select the shaft and drag it.**
The shaft moves because it is no longer constrained by its **Inplace** mate and in-context sketch.

---

**Saving New In-Context Components**

You can specify the default behavior for saving new in-context components as:

- External files (same as in SolidWorks 2007 and earlier)
- Virtual components (same as in SolidWorks 2008 and 2009)

A new option in System Options - Assemblies sets the default behavior:

- **Save new components to external files**: If selected, prompts you to name and save new in-context components to external files. If cleared, saves new in-context components in the assembly file as virtual components.

To save new in-context components in external files:

1. Open `install_dir/samples/whatsnew/assemblies/virtual/flanges.sldasm`.
2. Click **Tools > Options** and click **Assemblies**.
3. Select **Save new components to external files**.
4. Click **OK**.
5. Click **Insert > Component > New Part**.
   The Save As dialog box appears so you can save the new part to an external file.
6. In the dialog box, for **File name**, type `gasket1` and click **Save**.
   Now you select a face on which to position the new part.
7. Select the face of the three-bolt flange.

The new part, `gasket1`, appears in the FeatureManager design tree. Editing focus changes to the new part and a sketch opens on the selected face.

8. Use **Convert Entities** to create sketch entities that reference the edges of the flange, bolt holes, and center hole.
9. Close the sketch.
10. Extrude the sketch to a depth of 10 to create the part.

11. Click in the Confirmation Corner to return editing focus to the assembly.

After completing the above example, if you want to change the default behavior back to saving as virtual components, return to System Options - Assemblies and clear **Save new components to external files**.

Component Reference per Instance

In the Component Properties dialog box, you can assign a different value for **Component Reference** for each instance of a component in an assembly.

For example, you can use **Component Reference** to store the reference designators for an electrical harness or printed circuit board assembly. When different instances of the same component have different values for **Component Reference**, you can show the instances as separate line items in a BOM. In drawings, you can also link the value of a component reference to the text of a balloon.

In assemblies, right-click a component, click **Component Properties**, and set a value for **Component Reference**. The value appears in braces { } at the end of the component name string in the FeatureManager design tree.
In SolidWorks Routing, you can assign values automatically when importing a P&ID document.

In assemblies or drawings, when inserting a column in a BOM, select **COMPONENT REFERENCE** for **Column type**.

<table>
<thead>
<tr>
<th>ITEM NO</th>
<th>PART NUMBER</th>
<th>QTY</th>
<th>COMPONENT REFERENCE</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>10726-56</td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>10726-56</td>
<td>1</td>
<td>R12</td>
</tr>
<tr>
<td>3</td>
<td>10726-56</td>
<td>1</td>
<td>R13</td>
</tr>
<tr>
<td>4</td>
<td>10726-56</td>
<td>1</td>
<td>R15A</td>
</tr>
<tr>
<td>5</td>
<td>10726-56</td>
<td>1</td>
<td>R17</td>
</tr>
</tbody>
</table>

In drawings, when inserting balloons, select **Component Reference** for **Balloon text**.

To link balloons to component reference values, the drawing must contain a BOM with a **COMPONENT REFERENCE** column.

Display States

While editing an assembly, you can now specify which of a component's display states to use in the assembly.

By default, each instance of a component (part or subassembly) is shown in the display state that was current when the component was last saved. You can override the default for each instance of the component, without changing the instance's configuration. You can use different display states for each instance. The override is stored in the parent assembly's display state.

You can now assign display states to parts. See **Display States for Parts** on page 27.

To specify a different component display state, do one of the following:

- In the Display Pane, right-click a highlighted component and click **Component Display State > display_state_name**.
• In the Component Properties dialog box, under **Referenced Display State**, select from the list of display states currently available in the component.

**SpeedPak**

You can now create a SpeedPak configuration for an assembly even when the assembly contains subassemblies that have SpeedPak configurations active.

**Mates**

**Relocating Components**

**View Mates** now indicates which mates are in the path to ground, to help you understand which mates you need to modify to be able to relocate the component.

**View Mates** now appears in a separate window. A new icon, 🕵️, indicates mates that are in the path to ground. These positioning mates are shown first on the list. A horizontal bar separates the positioning mates from other mates.

**Replacing Components**

More guidance is provided to let you know which mate references need to be replaced.

In the Replace PropertyManager, you can now select a replacement component from a list of open files.

In the Mated Entities PropertyManager:
• A popup toolbar helps you to navigate through existing mates as you replace mate references.

From the popup toolbar, you can:
• Show the replacement part alone, show the replacement part with related parts, or show the entire assembly.
• Undo selections and operations.
• Delete mates.
• Skip mates.
• Toggle mate alignments.

• A view of the original component is displayed in a separate window. The missing mate entity is highlighted.

Coordinate System Mates
Mates involving coordinate systems have been enhanced.

**Coincident Mates**  You can create coincident mates between a coordinate system and an origin.

**Mate References**  For mate references, you can select coordinate systems and origins as reference entities and choose to align axes.

**SmartMates**  You can use SmartMates to create mates involving coordinate systems and origins. The pointer indicates a potential mate between two coordinate systems or between a coordinate system and an origin. When you drop a component to create a coordinate system SmartMate, you can select **Align axes** on the popup toolbar.
Available in SolidWorks Premium.

This chapter includes the following topics:

- User Interface
- Updating Assemblies
- Importing Non-CircuitWorks Assemblies from SolidWorks
- PADS Support

**User Interface**

The CircuitWorks user interface has been enhanced to better integrate with SolidWorks. For example, the CircuitWorks feature tree is now available in SolidWorks.

- To display the Annotate Components PropertyManager, which replaces the Annotate Components dialog box, click Annotate Components (CircuitWorks toolbar).
- To display the CircuitWorks feature tree, which replaces the Locate Components dialog box, click the CircuitWorks tab.
- To display the Properties dialog box, which replaces the Edit Component Information dialog box, right-click a feature in the CircuitWorks feature tree and click Properties.

Also, CircuitWorks now displays build progress in a pane at the bottom of the CircuitWorks window instead of in a separate window.

See CircuitWorks Help for details about these changes.

**Updating Assemblies**

CircuitWorks can now update an assembly that is open in SolidWorks when you make minor changes in CircuitWorks such as adding, deleting, or moving components. Previously, CircuitWorks rebuilt the entire assembly for any change.

To update an assembly, open the assembly in SolidWorks, make changes to the corresponding data file in CircuitWorks, and click Build Model.


**Importing Non-CircuitWorks Assemblies from SolidWorks**

Importing SolidWorks PCB assemblies that were not created in CircuitWorks has been improved.
Selecting the Board Component and Orientation
When exporting from SolidWorks, you can specify the assembly orientation by selecting the planar face that represents the top of the board component.

To import an assembly into CircuitWorks, do one of the following:

- From CircuitWorks, click Import Model (Tools toolbar).
- From SolidWorks, click Export to CircuitWorks (CircuitWorks toolbar).

If the assembly was not created by CircuitWorks, the Select Orientation dialog box appears. Select the top face of the board component and click Continue.


Using Silhouette Edges to Determine Component Shape
If appropriate sketches are not available, CircuitWorks can use silhouette edges to determine component shapes.

To control silhouette edge recognition, do one of the following:

- In CircuitWorks, click the CircuitWorks application menu and click Options.
- In SolidWorks, click CircuitWorks > CircuitWorks Options.

On the SolidWorks Export page of the CircuitWorks Options dialog box, select an option for If no correctly named sketches are found.


PADS Support
The CircuitWorks reader for Mentor Graphics® PADS ASCII (.asc) now imports files faster and supports plated holes.
This chapter includes the following topics:

- Configuration Publisher
- Modify Configurations

**Configuration Publisher**

The Create PropertyManager dialog box has been renamed to Configuration Publisher. In addition to its previous functionality, you can now use the dialog box to prepare models for uploading to 3D ContentCentral.

In the dialog box, you define the interface for specifying configurations. You upload models to 3D ContentCentral directly from the dialog box. On 3D ContentCentral, your end users select values to build the configuration they want. When they download your model, it contains only the configuration they specified.

You can now use rules to define the configurations of a model. Your model must contain a design table (single or multiple rows). As in previous releases of SolidWorks, you can define all the configurations in a multiple-row design table. Alternatively, now you can create a single-row design table that includes all the variables you need. Then, in the Configuration Publisher dialog box, you create rules to define the configurations. You assign values for the variables and define relationships between them.

In the Configuration Publisher dialog box, you drag controls (list boxes, number boxes, and check boxes) from the palette on the left into the pane in the center. You set attributes for each control in the pane on the right.

As in previous releases of SolidWorks, you can still build a PropertyManager that enables you to select a configuration when you place the model in an assembly. Other enhancements:

- You can configure custom properties.
- You can create PropertyManagers for assemblies.
Starting with Multiple Configurations

In this example, the model has multiple configurations which are defined in a design table.

The length, outside diameter, and hole diameter of the part vary among configurations. In some configurations, the hole is suppressed.

![Image of rod multiple configurations]

Accessing the Dialog Box

To create a PropertyManager:

1. Open `install_dir\samples\whatsnew\configurations\rod_multiple.sldprt`.
2. Save the part as `my_rod_multiple.sldprt` so you do not overwrite the example file.
3. At the top of the ConfigurationManager tab, right-click the part name and click `[Configuration Publisher]`. The Configuration Publisher dialog box appears and the design table opens in a separate window. Because the design table has multiple rows, a control appears in the palette for each parameter in the design table.

![Configuration Publisher dialog box]

Building the PropertyManager

Now create a PropertyManager for selecting the length, outside diameter, hole suppression state, and hole diameter.

1. Click the Edit tab in the center pane.
2. Drag **Rod-Diameter@Sketch1** from the palette to the center pane.  
   List1 appears in the center pane and its control attributes appear in the right pane.
3. In the right pane, under **Control Attributes**, double-click in **Name** and type **Outside Diameter**.
   Outside Diameter appears on the control in the center pane.
4. Drag **Rod-Length@Rod** from the palette and drop it below **Outside Diameter** in the Edit pane.
5. Under **Control Attributes**, double-click in **Name** and type **Length**.
   Now add the check box that controls the suppression state of the hole.
6. Drag **$STATE@Hole** from the palette and drop it below **Length** in the center pane.
7. In **Name**, type **Hole**.
8. Drag **Hole Diameter@Sketch2** from the palette and drop it below **Hole** in the center pane.
9. In **Name**, type **Hole Diameter**.
   Now make the **Hole Diameter** control available only when **Hole** is selected.
10. Under **Control Visibility**:
    a) In **Visibility Parent**, select **Hole**.
    b) For **Show**, set:
        - **Checked** to [✓]
        - **Unchecked** to [☐]
    The **Hole Diameter** control will be available only when **Hole** is selected.
11. Click **Apply**.
    The PropertyManager is saved. PropertyManager [:] appears in the ConfigurationManager.

**Previewing the SolidWorks PropertyManager**

You can preview the PropertyManager to see how it will appear in SolidWorks.

 pena In preview mode, there might be a delay as you select values.

1. In the center pane, click the SW Preview tab.
   The interface as it will appear in the SolidWorks PropertyManager is displayed.
2. In the PropertyManager preview:
   a) For **Outside Diameter**, select **10**.
   b) For **Length**, select **20**.
   c) Select **Hole**.
   d) For **Hole Diameter**, select **4.5**.
   Configuration changes to **Rod-10M-H45**.
3. Click **Update Model**.
   In the graphics area, the part changes to the selected configuration.
Previewing the 3D ContentCentral Interface

You can preview the interface to see how it will look in 3D ContentCentral.

In preview mode, there might be a delay as you select values.

1. Click the 3DCC Preview tab.
   The interface as it will appear in 3D ContentCentral is displayed.
2. In the 3D ContentCentral preview:
   a) For **Outside Diameter**, select **10**.
   b) For **Length**, select **10**.
   c) Clear **Hole**.
   The Hole Diameter control disappears, and Configuration changes to **Rod-10L-N**.
3. Click **Update Model**.
   In the graphics area, the part changes to the selected configuration.

   ![Diagram of a part with dimensions and labels]

   Do not upload the example model. When you have a real model to upload, click **Upload to 3D ContentCentral** to log in to your account and initiate the upload process.

4. Click the Edit tab.
5. Click **Close** and click **Yes** to save.
Before uploading a model, you must have a Supplier Services account registered on 3D ContentCentral. Supplier Services accounts are free.

- For more information about Supplier Services accounts, see Supplier Services on www.3dcontentcentral.com.
- To register for a Supplier Services account, see Register Now on www.3dcontentcentral.com.

**Starting with a Single Configuration**

In this example, the model has a single configuration which is defined in a design table. You create rules to define the configurations. You assign values for the variables and define relationships between them.

**Accessing the Dialog Box**

The Configuration Publisher process requires a design table. If your model does not contain a design table, the software asks if you want to autocreate it. The design table contains a single row of values for the parameters of the model.

To create a PropertyManager:

1. Open `install_dir\samples\whatsnew\configurations\rod_single.sldprt`
2. Save the part as `my_rod_single.sldprt` so you do not overwrite the example file.
3. At the top of the ConfigurationManager tab, right-click the part name and click Configuration Publisher.
   The Configuration Publisher dialog box appears and the design table opens in a separate window. Because the design table has only a single row, generic controls for List, Number, and Checkbox appear in the palette.
Building the PropertyManager

Now create a PropertyManager for selecting the length, outside diameter, hole suppression state, and hole diameter.

1. Click Edit in the center pane.
2. Drag a List control from the palette to the center pane.
   List1 appears in the center pane and its control attributes appear in the right pane.
3. In the right pane, under Control Attributes:
   a) Double-click in Name and type Outside Diameter.
   b) In Design Table Variable, select Rod-Diameter@Sketch1.
   c) In Type, select List.
   d) In List Values, type the following in the cells:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

   You can press Tab and Shift + Tab to move between cells.

Now define the range of values for rod length that correspond to each outside diameter. You also specify the increment between values in each range.

4. Drag a Number control from the palette and drop it below Outside Diameter in the center pane.
5. Under Control Attributes:
   a) Double-click in Name and type Length.
   b) In Design Table Variable, select Rod-Length@Rod.
   c) In Data Parent, select Outside Diameter.
      In Range Requirements, a table appears with rows for each value of Outside Diameter.
   d) In Range Requirements, type the following in the cells:
Now add a check box to control the suppression state of the holes. In this example, you want the check box to be available when Outside Diameter is set to 5, 10, or 13, but not when it is set to 7.

6. Drag a Checkbox control from the palette and drop it below Length in the center pane.

7. Under Control Attributes:
   a) In Name, type Hole.
   b) In Design Table Variable, select $State@Hole.
   c) In Data Parent, select None.

   In this example, you want the hole to be unavailable for all configurations with Outside Diameter set to 7. Because the check box is not needed, you can specify that it not be visible.

   A table with a column for each value of Outside Diameter appears.

9. Clear the check box for 7.

   The Hole check box will not be visible when Outside Diameter is set to 7.

Now define the values for the hole diameter.

10. Drag a List control from the palette and drop it below Hole in the center pane.

11. Under Control Attributes:
    a) In Name, type Hole Diameter.
    b) In Design Table Variable, select Hole-Diameter@Sketch2.
    c) In Type, select List.
    d) In Data Parent, select Outside Diameter.
    e) In List Values, type the following in the cells:

        | Minimum | Maximum | Increment |
        |---------|---------|-----------|
        | 5       | 10      | 10        |
        | 7       | 15      | 5         |
        | 10      | 20      | 15        |
        | 13      | 30      | 20        |

   Now make the Hole Diameter control available only when Hole is selected.

12. Under Control Visibility:
    a) In Visibility Parent, select Hole.
    b) For Show, set:
        • Checked to ☑
- Unchecked to □
  
  The **Hole Diameter** control will be available only when **Hole** is selected.

13. Click **Apply**.
  
  The PropertyManager is saved. **PropertyManager** appears in the ConfigurationManager.

**Previewing the SolidWorks PropertyManager**

You can preview the PropertyManager to see how it will appear in SolidWorks.

In preview mode, there might be a delay as you select values.

1. Click the SW Preview tab.
2. In the PropertyManager preview:
   a) For **Outside Diameter**, select **10**.
      
      The range of acceptable length values and increments, **20-80(by increments of 15)**, appears below the **Length** box.
   b) For **Length**, type **20**.
   c) Select **Hole**.
   d) For **Hole Diameter**, select **4.5**.
3. Click **Update Model**.
   
   In the graphics area, the part changes to the selected configuration.

**Previewing the 3D ContentCentral Interface**

You can preview the interface to see how it will look in 3D ContentCentral.

In preview mode, there might be a delay as you select values.

1. Click the 3DCC Preview tab.
2. In the 3D ContentCentral preview:
   a) For **Outside Diameter**, select **5**.
      
      The range of acceptable length values and increments, **10-50(by increments of 10)**, appears below the **Length** box.
b) For **Length**, type **20**.
c) Clear **Hole**.

3. Click **Update Model**.
   In the graphics area, the part changes to the selected configuration.

![Part configuration](image.png)

> Do not upload the example model.

4. Click the Edit tab.
5. Click **Close**.
6. Save the part, but do not close the file.

### Placing the Part in an Assembly

1. Open a new assembly.
2. In the Begin Assembly PropertyManager, select *my_rod_single* and click in the graphics area to place the part.
   The Configure Component PropertyManager opens.
3. Under **Parameters**:
   a) For **Outside Diameter**, select **13**.
   b) For **Length**, type **70**.
   c) Select **Hole**.
   d) For **Hole Diameter**, select **5.5**.

4. Click ✓.  
The specified configuration of the part appears in the assembly.
5. Save the assembly as rod.sldasm. In the Save Modified Documents dialog box, click **Save All**.
   In my_rod_single.sldprt, the configuration you specified in the assembly appears in the ConfigurationManager as **Default_New2**.

**Modify Configurations**

The Modify Configurations dialog box has been enhanced.

You can:
- Rename features and dimensions.
- Add and remove feature parameters from the table.
- Configure the material of parts.
- Create, edit, and delete configuration-specific custom properties.
- Unconfigure parameters.
- Save views of the table.
- Rearrange columns in the table.
- Edit and navigate the table similarly to how you would in Microsoft Excel. For more information about editing and navigating tables, see **Tables** on page 83.

**Configuring Material**

1. Open `install_dir\samples\whatsnew\configurations\flange_1.sldprt`. The part has three configurations.

2. In the FeatureManager design tree, right-click **Material** and click **Configure Material**.
   The Modify Configurations dialog box appears with a **Material** column.

3. Under **Material**, select a material for each configuration:
<table>
<thead>
<tr>
<th>Configuration</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.5</td>
<td>Brass</td>
</tr>
<tr>
<td>20</td>
<td>Copper</td>
</tr>
<tr>
<td>25</td>
<td>Plain Carbon Steel</td>
</tr>
</tbody>
</table>

4. Click **Apply**.
5. Click **<Enter Name>** and type **Material**.
6. Click **Save table view**.
   The table is saved in the **Tables** folder on the **ConfigurationManager** tab. The specified materials are applied to each configuration.

Do not close the dialog box yet.

![Images of configurations]

### Configuring Custom Properties

1. At the bottom of the Modify Configurations dialog box, click **Hide/Show Custom Properties**.
   The **Custom Properties** column appears, and contains a **New Property** column.
2. Right-click **New Property** and click **Rename**.
3. Type **Supplier** and press **Enter**.
4. Type values for each configuration:
<table>
<thead>
<tr>
<th>Configuration</th>
<th>Supplier</th>
</tr>
</thead>
<tbody>
<tr>
<td>12.5</td>
<td>ABC Co.</td>
</tr>
<tr>
<td>20</td>
<td>XYZ Co.</td>
</tr>
<tr>
<td>25</td>
<td>BCD Co.</td>
</tr>
</tbody>
</table>

Now configure some existing properties.
5. Click **✓** at the top of the **Custom Properties** column and select **Cost** and **LeadTime**.
   ![Light bulb icon] You can create additional new properties by selecting **New Property** from the list.
6. Click in a blank area of the dialog box.
   Columns appear for **Cost** and **LeadTime**.
7. Type values for each configuration:
8. Click **Save table view**.
9. Click **OK**.

**Editing a Table View**

In this example, you edit a saved table view and:
- Rename a sketch feature
- Add a sketch dimension
- Move a column
- Unconfigure a parameter

1. In the ConfigurationManager, expand **Tables**. The table you just created (**Material**) appears with two others that were saved previously.

2. Right-click **Base** and click **Show Table**. The table view opens in the Modify Configurations dialog box. It contains three dimensions from **Sketch1**.

3. In the dialog box, double-click **Sketch1**.

4. Type **Base Sketch** and press **Enter**. The sketch name changes to **Base Sketch** in the dialog box.

5. Click **Apply**. The sketch name updates in the FeatureManager design tree.

Now add another sketch dimension.

6. Beside **Base Sketch**, click the column header, select **J**, and click in a blank area. A column for **J** appears, and the dimension appears in the graphics area.
7. Under J:
   a) For 20, type 90 and press Enter.
   b) For 25, type 100.

8. Click Apply.

Now rearrange columns in the table.

9. Select the column heading J, drag the column and drop it to the left of column L.
   Now unconfigure a parameter.

10. Click column heading N.
    The dimension appears in the graphics area.

11. Right-click column heading N and click Unconfigure.
    The active configuration's value for N is applied to all configurations.

12. Click Save table view.

13. Click OK.
Available in SolidWorks Professional and SolidWorks Premium.

This chapter includes the following topics:

- Integration of Design Checker
- Validation Against ANSI/ISO/JIS Drafting Standards
- One-Button Push to Correct All Errors
- UI Enhancements
- Virtual Sharp Check
- Task Scheduler Option for Autocorrection
- Samples of Industry Vertical Custom Checks to 3D ContentCentral

Integration of Design Checker

The user interface for SolidWorks Design Checker has been fully integrated into toolbars and menus of the SolidWorks software. A Design Checker toolbar button is added to the Evaluate tab of the CommandManager.

When you select a related command, the add-in loads dynamically, provided you have installed it and are running SolidWorks Professional or SolidWorks Premium.

Click **Tools > Design Checker**. The Design Checker tab is added to the Task Pane.

Validation Against ANSI/ISO/JIS Drafting Standards

The following enhancements have been implemented:

- Drafting standards (ANSI, ISO, DIN, JIS, BSI, GOST and GB) are provided with a set of built-in drafting standard files. Validation using these files ensures that the SolidWorks document conforms to the corresponding drafting standard.

You can load any of the provided drafting standards in SolidWorks Design Checker to view its customized document settings.

The file location of the drafting standards is `install_dir\dsgnchk\Data`. You can set the location of Design Checker files in **Options > File Locations**.

- A new check box, **User defined**, in the Dimensioning Standard Check dialog box lets you specify a name for the user-defined drafting standard.
One-Button Push to Correct All Errors

A new tool, Auto Correct All, lets you correct all of the errors shown in Design Checker. The parameters that support checks are automatically corrected according to the selected *.swstd drafting standard file. Selective correction of failed entities is available with the Correct Selected option.

UI Enhancements

Enhancements for the Design Checker interface include:

- You can now specify your preferred correction values for parameters that support checks. When you select Auto Correct All, your preferred values override the default autocorrection values specified in the selected *.swstd file.

Create a parameter check in the Design Checker module, and specify the desired values under Preferred auto correction values.

- A new criticality factor box is added to the user interface. Select a criticality factor among Critical ☢️, High ☣️, Medium ☢️, or Low ☢️.

- A new tool, Recheck Document, allows you to revalidate your document without running a correction.

- The Update and Recheck button is removed.

- Only the list of failed checks is shown. The criticality factor icon is displayed next to each check definition.

Virtual Sharp Check

The Virtual Sharp check verifies that your document uses the correct style of virtual sharp. The active document passes the check when it satisfies the specified virtual sharp style criterion.

Activate Virtual Sharp 🗻 under Document Checks 🗻.
Task Scheduler Option for Autocorrection

A new task in SolidWorks Task Scheduler (SolidWorks Professional) allows Design Checker to automatically correct all errors. Design Checker can correct all failures for which it supports autocorrection. The corrected document is saved at the location of the original document for ease of comparison.

Click Design Checker on the SolidWorks Task Scheduler sidebar.

Samples of Industry Vertical Custom Checks to 3D ContentCentral

Design Checker provides samples of industry vertical custom checks which are added to 3D ContentCentral.
You can evaluate and optimize models by using a Design Study.

You can now run Design Studies in SolidWorks. Previously, the Design Study functionality was available only in SolidWorks Simulation as Design Scenarios and Optimization studies.

There are two main modes for running a Design Study:

**Evaluation**  
You specify discrete values for each variable and use sensors as constraints. The software runs the study using various combinations of the values and reports the output for each combination.

For example, for this multibody model of a water bottle, you specify values of 75mm, 100mm, and 150mm for the length (L); 30mm, 55mm, and 80mm for the height (H); and 10mm and 20mm for the radius (R). You specify a **Volume** sensor to monitor the volume of the water body. The Design Study results report the volume of the water for each combination of **L**, **R**, and **H**.

**Optimization**  
You specify values for each variable, either as discrete values or as a range. You use sensors as constraints and as goals. The software runs iterations of the values and reports the optimum combination of values to meet your specified goal.

For example, for the model above, you specify a range of 75mm to 150mm for the length (L); discrete values 30mm, 55mm, and 80mm for the height (H); and a range of 10mm to 20mm for the radius (R). For a constraint, you specify a **Volume** sensor to keep the volume of the water body between 299000mm^3 and 301000mm^3. For a goal, you use a **Mass** sensor and specify to minimize the mass of the bottle. The Design Study iterates on the values specified for **L**, **R**, **H**, and **Volume**, and reports the optimum combination to produce minimum mass.
Different sensors are available for use in Design Studies depending on your SolidWorks license and whether you are running an Evaluation study or an Optimization study.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Evaluation</td>
<td>Optimization</td>
<td>Evaluation</td>
<td>Optimization</td>
<td>Evaluation</td>
</tr>
<tr>
<td>Mass Properties</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Dimension</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Simulation Data</td>
<td></td>
<td></td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>

To create a study, click **Design Study** (Tools toolbar) or **Insert > Design Study > Add**. A Design Study tab appears at the bottom of the graphics area.

After running a study, select a scenario or iteration on the Results View tab. In the graphics area, the model updates with the values for that scenario or iteration.

For information about Design Studies in SolidWorks Simulation, see **New Design Study** on page 162.
This chapter includes the following topics:

- Sheet Metal Validation
- Managing Standard Hole Sizes
- Zoom to Selection

Sheet Metal Validation

DFMXpress now validates sheet metal parts. New rules validate hole diameter-to-thickness ratios, hole-to-edge distances, hole-to-hole spacing, and bend radii.

In the DFMXpress pane, click Settings. Under Manufacturing Process, select Sheet metal.

See DFMXpress Help: Sheet Metal Rules.

Managing Standard Hole Sizes

You can manage the list of standard hole sizes used by DFMXpress to validate parts.

In the DFMXpress pane, click Settings. Under Standard Hole Sizes, click Edit.


Zoom to Selection

You can easily view a failed instance by zooming the SolidWorks graphics area.

After running DFMXpress, right-click a failed instance and click Zoom to Selection.
This chapter includes the following topics:

- Annotation Attachments
- Balloons
- Bills of Materials
- Blocks
- Center Marks
- Cosmetic Threads
- Dimensions
- Notes
- Tables
- Title Block Tables in Parts and Assemblies
- Drawings

Annotation Attachments

It is now easier to attach annotations to one another. Supported annotations include geometric tolerance symbols, datum feature symbols, and surface finish symbols.

You can:

- Attach annotations to dimension extension lines
- Move annotations around dimension extension lines
- Use handles to detach annotations from dimension extension lines

Balloons

**Use Numbering from Specified BOMs**

When you insert balloons and stacked balloons into an assembly, you can set the balloons to follow the item numbering of a selected BOM in the assembly under Balloon text source in the Balloon PropertyManager. You can then import the balloons into a drawing.

*See SolidWorks Help: Balloon PropertyManager.*
**Parametric Quantities**
You can set a quantity value in the Balloon PropertyManager that updates parametrically. In previous versions you had to add text outside of the balloon, then group the text with the balloon. The text did not update parametrically.

![Balloon example](image)

**Custom Balloon Sizes**
You can set the balloon size to any value using either the Balloon PropertyManager or Tools > Options > Document Properties > Annotations > Balloons. Custom sizes are available in balloons, auto balloons, and stacked balloons.

**Component References**
You can display component references for balloons in the Balloon PropertyManager.
See also Component Reference per Instance on page 50.

**Bills of Materials**

**Assembly Options**
You can set options for specific assembly components directly from the BOM.
You can exclude items from BOMs by right-clicking a component in the assembly structure column and clicking **Exclude from BOM**.
You can also:
- Edit the display of child components
- Change how the part number is defined
- Control how the quantity is calculated
To access these options, right-click a component in the assembly structure column and click **Component Options**.

**Linked BOMs**
You can link drawing BOMs copied from a previously created assembly BOM using the Bill of Materials PropertyManager. You can edit the original assembly BOM or the copied drawing BOMs. Changes in one BOM update the other BOM. Formatting of linked BOMs is independent; only the data is linked. Formatting items include row height, column width, font size and color, and text direction.
You can unlink the drawing and assembly BOMs at any time, but you cannot reestablish the link. You need to create a new BOM to re-link the BOMs.
To link BOMs, in the Bill of Materials PropertyManager, under **BOM Options**, select **Copy existing table** and **Linked**.
Descriptions

In parts and assemblies, the Configuration Properties PropertyManager contains the option, **Use in bill of materials**. When you type text for the **Description** and select **Use in bill of materials**, the text is used as the description in the BOM. The text takes precedence over any configuration-specific or custom properties, but does not alter their values.

Highlighting

It is easier to visualize items that are represented in BOMs. Selecting an item in a BOM highlights it in the graphics area of an assembly or in a drawing view. Similarly, selecting a component in the graphics area, drawing view, or FeatureManager design tree highlights it in the BOM.

Highlighting is also supported in BOMs of eDrawings. See **Enhanced BOM Support** on page 91.

A thumbnail preview is available for each item in a BOM when you hover over its icon in the assembly structure column. If a component's preview does not appear when you hover over its icon, open and save the component, then hover over the icon again.

Moving BOMs to Different Sheets

You can move BOMs to different sheets by dragging them to:

- Sheet tabs
- Sheet icons in the FeatureManager design tree
- Different windows of the same drawing

Blocks

You can change the style and size of arrowheads on block leaders by right-clicking the handle on the arrowhead.

Center Marks

When you add a center mark to a hole that you have already dimensioned, a gap appears between the center mark and the dimension's extension line. Similarly, if you dimension a hole that already has a center mark, a gap appears.
Cosmetic Threads

You can define cosmetic threads using international standard sizes in the Cosmetic Thread PropertyManager. When you select the edge for the cosmetic thread, you can select a dimensioning standard and size. Thread callouts can also be created automatically. The callouts are populated with the appropriate text from the calloutformat.txt file.

Dimensions

**Rapid Dimension**

You can use the rapid dimension manipulator to place dimensions so they are evenly spaced and easier to read.

The rapid dimension manipulator appears when you insert dimensions in drawing views. Use the manipulator to place dimensions at evenly spaced intervals. For example, if you insert a dimension between two dimensions, the new dimension is spaced evenly between them.

To place dimensions quickly, use the:

- **Tab** key to switch to the different manipulator locations
- Spacebar to place the dimension in a suitable location outside of the model geometry

You can control the spacing used by rapid dimension in **Tools > Options > Document Properties > Dimensions** under **Offset distances**.

When the rapid dimension manipulator creates dimensions on a symmetric centerline, any dimensions that might overlap are staggered for drawings in the ANSI standard.
Using Rapid Dimension

To use rapid dimensioning:

1. Open `install_dir\samples\whatsnew\detailing\dimension.slddrw`.

2. Click **Smart Dimension** (Dimensions/Relations toolbar) or **Tools > Dimensions > Smart**.

3. Click the edge shown.

![Image of edge shown]

The rapid dimension manipulator appears as:

![Image of rapid dimension manipulator]

4. Click the lower portion of the rapid dimension manipulator.

![Image of dimension placed below selected edge]

The dimension is placed below the selected edge.

5. Click the two edges as shown, then click the lower portion of the rapid dimension manipulator.

![Image of dimension placed below selected edge]

6. Repeat step 5 for the two edges shown.

![Image of dimension placed below selected edge]

7. Click one of the circular edges.
The rapid dimension manipulator appears as:

8. Press **Tab** three times to switch dimension locations and press the spacebar to place the dimension.

The dimension appears in the lower right corner.

**Dimension Palette**

The dimension palette appears when you insert or select a dimension so you can easily change the dimension’s properties and formatting.

You can change the tolerance, precision, style, text, and other formatting options in the palette without going to the PropertyManager.

In the **Style** portion of the palette, you can select any of the formatting settings that you applied to other dimensions in the drawing, which saves you time when formatting dimensions.

If you select more than one dimension, the properties and formatting that you set in the palette apply to all of the dimensions.
**Ordinate Dimensions**

When you insert ordinate dimensions in parent views, the dimensions continue in detail views. The detail view uses the existing 0 point in the parent view. Conversely, when you insert ordinate dimensions in detail views and apply ordinate dimensions in parent views, the parent view uses the 0 point from the detail view.

**Fractional Dimensions**

You can turn off the double prime marks (") in fractional dimensions.

Click **Tools > Options > Document Properties > Dimensions** and set the options under *Fractional display*.

<table>
<thead>
<tr>
<th>Double prime marks on</th>
<th>Double prime marks off</th>
</tr>
</thead>
</table>

**Deleting Dimensions**

If you delete a dimension or remove text from a dimension, the software can automatically readjust the space among the remaining dimensions.

Click **Tools > Options > System Options > Drawings** and select *Adjust spacing when dimensions are deleted or text is removed*.

**Dimension Names**

The *Show Dimension Names* setting is now controlled and saved per document instead of for all documents as a system setting.

The *Show Dimension Names* setting is removed from the System Options - General dialog box. To show dimension names, click **View > Dimension Names** or, from the Heads-up View toolbar, click **Hide/Show Items > View Dimension Names**.

**Notes**

You can apply borders to portions of notes. When inserting or editing a note, select any portion of the note and select a border in the Note Property Manager.
Three new borders are also supported: square, circle in square, and inspection.

**Tables**

You can edit and navigate in tables as you do in Microsoft Excel. You can:

- Control vertical cell padding
- Navigate using the **Enter**, **Tab**, **Arrow**, **Shift + Enter**, **Shift + Tab**, **Shift + Arrow**, **Home**, **Ctrl + Home**, **End**, and **Ctrl + End** keys
- Select a cell, type data, and view the data immediately in the cell, overwriting existing data
- Press **F2** in a highlighted cell to activate the cell for editing and move the cursor to the end of the text in the cell
- Double-click a cell to move the cursor to the position where the cell was double-clicked
- Press **Alt + Enter** to add multiple lines of text in a cell
- Press **Delete** to erase all text from a cell without activating the cell for editing
- Press **Backspace** to erase all text from a cell and activate the cell for editing
- Select multiple rows or columns and change their heights or widths by dragging or using the formatting tools
- Lock row heights and column widths
- Copy cells from Microsoft Excel and paste them into SolidWorks tables

**Title Block Tables in Parts and Assemblies**

You can now generate a title block table in a part or assembly document as an aid for paperless manufacturing.

Tip: You cannot add title block tables to drawings. In drawings, use the title blocks that are part of the drawing sheet format.

You can base a title block table on a sample template supplied by SolidWorks or a template you create yourself. If you define custom properties for the part or assembly and use a template that references those properties, SolidWorks populates the table values from the custom properties automatically.

To add a title block table to a part or assembly, click **Insert > Tables > Title Block Table**.

In the Title Block Table PropertyManager, define the size and borders of the table or click **to browse to an existing table template with the file extension .sldtbt**.

After inserting the table, click the upper left corner to open the Title Block Table PropertyManager, which provides a scaling control that lets you resize the table proportionally.
See SolidWorks Help: Title Block Tables.

Drawings

**Aligned Section Views**
You can now dimension across aligned section views.

**Component Line Font**
The Component Line Font dialog box has been reorganized for ease of use.
To access the dialog box, right-click a drawing edge and click **Component Line Font**.

You can also access the **Line Color**, **Line Thickness**, and **Line Style** tools from the context menu.
**Configurations**

You can change drawing view configurations in drawing view Property Managers. Previously, you had to go to the Drawing View Properties dialog box.

**Drawing Templates**

Additional drawing templates are included for supported drawing standards.

**Drawing Views of Multibody Parts**

You can create Standard 3 Views and model views of multibody parts. For flat patterns of multibody sheet metal parts, you can use one body per view.

**Displaying Drawing Views of Multibody Parts**

1. Open `install_dir\samples\whatsnew\drawings\multibody.slddrw`
2. Select the drawing view.
3. In the PropertyManager, under **Reference Configuration**, click **Select Bodies**. `Multibody.sldprt` opens.
4. Select the two bodies shown and click ✅.

`Multibody.slddrw` opens and the drawing view shows the two selected bodies.
Hiding and Showing Edges

Toolbar Button

The Hide Edge and Show Edge buttons are merged into one button: Hide/Show Edges.

Edge Selection

You can use the following methods to select edges when using the Hide/Show Edges tool:

- Click individual edges.
- Box selection.
- Shift + Box selection to select edges fully enclosed in the box selection, including edges that were previously unselected.
- Alt + Box selection to clear edges fully enclosed in the box selection, excluding edges that were previously unselected.

Tangent Edges

New options in the Hide/Show Edges PropertyManager help you to hide and show different types of tangent edges.

See Display Options on page 87.

Opening Parts and Assemblies from Drawings

When you right-click a component in an assembly drawing, you can open the part or assembly. In previous versions, you could open the part only.

Section Views

Section Depth

You can now set the depth of section views in parts by specifying how far beyond the section view line you want to see. Previously, this functionality existed in assembly drawings only. This is available under Section Depth in the Section View PropertyManager.

Diameter Dimensions

When you insert diameter dimensions in section views, the diameter symbol appears in the dimension. The section cut must be through the center of the diameter.
Sketch Pictures
If you insert a sketch picture in a part or assembly, the picture appears in the associated drawing views.

System Properties
There are two new system properties for drawing documents: **SW-View Name** and **SW-View Scale**.
These properties are similar to the system properties **SW-Sheet Name** and **SW-Sheet Scale**.

Tangent Edges
Colors
You can set the color of tangent edges. The color applies to **Tangent Edges Use Font** only.

Click **Tools > Options > System Options > Colors**. In **Color scheme settings**, select **Drawings, Model Tangent Edges** and set the color.

Display Options
New options are available for filtering tangent edges in drawing views with hidden lines removed or hidden lines visible.

Click **Hide/Show Edges** (Line Format toolbar) to access these options (except for **Hide Ends**).
<table>
<thead>
<tr>
<th>Option</th>
<th>Before</th>
<th>After</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Hide Ends</strong></td>
<td>Hides the start and end segments of tangent edges.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Right-click a drawing view and click <strong>Tangent Edge &gt; Hide Ends</strong>.</td>
<td></td>
</tr>
<tr>
<td><strong>Hide Non-Planar Edges</strong></td>
<td>Hides tangent edges that border non-planar faces.</td>
<td></td>
</tr>
</tbody>
</table>

Drawings and Detailing
**Hide**  Hides tangent edges that:

**Blend Edges**

- Border on planar faces which are normal to the viewing direction
- Have second order continuity (C2) at the boundary of two faces

**Hide edges shorter than**  Hides tangent edges that are less than a specified length.
This chapter includes the following topics:

- Integrated Publisher
- Print Preview
- Enhanced BOM Support
- Apple Mac Printing Enhancements
- Display States Linked to Configurations
- Title Block Tables
- Decals
- Sketch Pictures

### Integrated Publisher

The ability to publish to eDrawings® is now fully integrated into SolidWorks toolbars and menus. You no longer need to load the eDrawings add-in manually.

To publish to eDrawings, click **File > Publish eDrawings File** (in the **Save** flyout toolbar).

As part of this integration, the eDrawings **Animate** button has been eliminated in the SolidWorks software. You can publish an eDrawings file and animate directly within eDrawings.

See *SolidWorks Help: SolidWorks eDrawings*.

### Print Preview

With eDrawing’s Print Preview, you can see your drawing or model exactly as it will be printed, eliminating wasted paper and time. You can also preview multiple sheets without having to exit Print Preview. Within the Print dialog box, you select a portion of the drawing to print. With the **Current screen image** option selected, you can pan and zoom to fine-tune your selection before printing.

Click **File > Print** and click **Show Preview** to fine-tune your selection. Close the preview by clicking **Hide Preview**.
Enhanced BOM Support

Bills of Materials (BOMs) for parts and assemblies have enhanced support in eDrawings. Select individual rows to highlight, hide, or show the corresponding components or to make them transparent. In earlier releases, you could view BOMs created in SolidWorks assemblies. Now, you can hide, show, and reposition them.

eDrawings displays BOMs in native SolidWorks documents, as well as in eDrawings files saved from SolidWorks. From SolidWorks, publish a part or assembly containing a BOM to eDrawings just as you publish any SolidWorks design to eDrawings, by clicking File > Publish eDrawings File (in the Save flyout toolbar).

In SolidWorks, you can explicitly save the design containing a BOM as an eDrawings file. In SolidWorks, click File > Save As and save to an eDrawings format, .eprt or .easm. Click Options and in the Export Options dialog box, select Save Table Features to eDrawings file.

eDrawings already supports BOMs in drawings, and this functionality is unchanged.
Apple Mac Printing Enhancements

Apple Mac® printing for eDrawings is enhanced. You can now print in color or grayscale rather than just black and white. You can print an entire sheet or what is currently displayed, and you can also set a scale factor.

Click File > Print to use the new print controls.

Display States Linked to Configurations

eDrawings now supports assigning display states to configurations as in SolidWorks. You can choose to link a display state to a configuration or to keep the display states independent from configurations.

From SolidWorks, create a configuration and publish the part or assembly containing the configuration by clicking File > Publish eDrawings File (in the Save flyout toolbar). In the Save Configurations to eDrawings file dialog box, select the configurations to be saved to the eDrawings file.

To link display states to configurations, in eDrawings, open the Configurations tab and select Link Display States to Configurations. Clear Link Display States to Configurations to toggle the display states so that they are independent from configurations.

Title Block Tables

Title block tables for parts and assemblies are visible in eDrawings. eDrawings displays title block tables in native SolidWorks documents, as well as in eDrawings files saved from the SolidWorks software. You can show, hide, and reposition title block tables.

From SolidWorks, create a title block table and publish the part or assembly containing the table by clicking **File > Publish eDrawings File** (in the Save flyout toolbar).

In eDrawings, in the component design tree, expand **Tables** and click the title block table to display the table's handle.

eDrawings supports title block tables in drawings, and this functionality is unchanged.

See **SolidWorks eDrawings Help: Title Block Tables**.
Decals

PhotoWorks decals applied to SolidWorks models are now visible in eDrawings. eDrawings displays decals in SolidWorks parts and assemblies, and also in eDrawings files saved from SolidWorks. The decal must be visible when the model is saved to an eDrawings file.

Apply a PhotoWorks decal in SolidWorks and publish the part, assembly, or drawing by clicking **File > Publish eDrawings File** (in the **Save** flyout toolbar). The model is displayed with the decal in eDrawings.

Sketch Pictures

Sketch pictures applied to SolidWorks drawing sheets and parts are now visible in eDrawings.

Add a sketch picture to a SolidWorks part, assembly, or drawing and publish by clicking **File > Publish eDrawings File** (in the **Save** flyout toolbar). The model or drawing is displayed with the sketch pictures shown in eDrawings.
Drawing view of a part with a part-level sketch picture and a sketch picture on the sheet format.

Model with sketch picture.
This chapter includes the following topics:

- Managing Tasks
- Enterprise PDM and Toolbox Integration
- File Explorer and SolidWorks Add-in
- Item Management
- Administration Tool
- API
- Installation
- Documentation

Managing Tasks

The new Tasks feature in the Administration tool makes it easy to perform tasks such as converting and printing SolidWorks documents.

The task framework lets administrators and users execute tasks on demand, based on a schedule, or triggered by a SolidWorks Enterprise PDM workflow. Administrators can configure tasks to run on a specific computer or distribute them to both client computers and dedicated servers. A SolidWorks Print or Convert task can be initiated on any computer that is running Enterprise PDM, as long as the computer where the task is executed has SolidWorks installed.

Administrators can define tasks to be interactive, letting users initiate the task and choose task options. Alternatively, they can set all options so that the task runs silently, without requiring user input.

Using the task API and templates provided in the Enterprise PDM software, programmers can also extend the functionality to support custom tasks.

Setting Up Tasks

You use the Administration tool to install and configure Enterprise PDM tasks.

To enable tasks:

- Include the Convert and Print task options when you create a new vault and specify the vault’s configuration details.
  
  See SolidWorks Enterprise PDM Administration Tool Help: Creating a Vault.

- Enable the execution of tasks on host computers.
  
  See SolidWorks Enterprise PDM Administration Tool Help: Permitting Task Execution.

- Configure the Convert and Print tasks.
These tasks, which are supported by the SolidWorks Task Add-in, are listed under Tasks in the Administration tool.

- Create new tasks using the Task wizard.
  
  If you use the Enterprise PDM API to program a task add-in, you add tasks supported by the add-in to the Tasks feature by creating new tasks.

- Include task execution in workflow transitions.
  
  For example, you can create a transition action that converts parts and drawings to .pdf files when an assembly is ready for review.

  See SolidWorks Enterprise PDM Administration Tool Help: Launching a Task Using a Workflow.

- Initiate and monitor tasks using the Task List dialog box.
  
  Use Add Task in the Task List dialog box to immediately launch a task.

  Use the Task List dialog box to monitor tasks and to view information about completed tasks.

**Convert and Print Tasks**

The Tasks feature in the Administration tool lets you configure task properties. The Convert and Print tasks are available if you select them when you create the vault.

💡 You can copy an existing task and modify it so that you have multiple task configurations. For example, you can create a silent configuration that does not require user input and a second user-initiated configuration that lets users modify task settings.

**Convert** tasks lets you convert SolidWorks files using the output formats and options supported by SolidWorks. For example, you can:

- Specify how converted files are named, for example, using the source file name and revision number.
- Save converted files to the vault or another destination such as a directory used by an Enterprise Resource Planning (ERP) application.
- Map variables from the source file data card to the output file data card to transfer attributes such as Description and Part Number.
- Convert a multisheet drawing to a multipage .pdf file.
- Convert only specifically named drawing sheets such as sheet metal flat patterns.

**Print** tasks are also performed on SolidWorks files. For example, you can:

- Print drawings to a print server, so that user computers are not tied up.
- Direct output to printers based on paper size requirements.
- Set permissions so that users can print files to a printer near them.
- Specify the following for source files with references:
  - Which references to print - none, drawings, parts, or assemblies
  - Which versions to print - the latest version or the version referenced the last time the source file was built

You can initiate either a Print or Convert task by adding it to a workflow transition. For example, you can:

- Print all drawings in an assembly when the assembly state changes to Reviewed.
• Convert all drawings in an assembly to .pdf format when the state changes to Released.

For instructions on configuring tasks, see *SolidWorks Enterprise PDM Administration Tool Help* topics:

• Configuring the Convert Task
• Configuring the Print Task

**Executing Tasks**
The task infrastructure provides multiple ways to initiate tasks.

As an administrator, you can:

• Trigger tasks using a workflow transition
  
  For example, you can automatically generate .pdf files when SolidWorks files reach a state such as Released. As part of task setup, you can specify options for the newly created files such as file names, properties, and destination folders.

• Use the Task List dialog box to execute an on-demand task

  On-demand task execution lets you initiate the printing of SolidWorks files from an Enterprise PDM client that does not have the SolidWorks software installed.

• Configure tasks so that they can be initiated by users

  With File Explorer, users with permissions to perform tasks can select files and use right-click menu options to convert or print them.

• Schedule task execution

  If you create custom tasks using the APIs, you can include the task scheduling infrastructure so that tasks can be performed when task hosts are available.

**Monitoring Tasks**
The primary tool for monitoring tasks is the Task List dialog box. You can also use notifications to inform users of the success or failure of tasks.

The Task List dialog box, which you display from the Tasks feature in the Administration tool, lets you identify tasks that are pending, monitor tasks that are running, and view information about completed tasks. You can also initiate tasks from this dialog box.

• The Pending tasks list shows the task queue, including tasks that are currently running and tasks that are scheduled or waiting to run. You can suspend and resume pending tasks, or cancel them completely.

  If you select a pending task or a task that is executing and click Details, you can see the task progress, who initiated the task, and the files on which the task is being executed.

• The Completed tasks list shows the status of completed tasks. If a task fails, you can view its details to see an error message and error code. These codes are also reported in error logs that are created for failed tasks.

  **Task List Options** let you specify the number of task records to retain in the Completed Tasks list.

You can set up notification messages to be sent to users and task initiators when a task succeeds or fails.
• If a conversion task succeeds, the notification contains links to the converted files, so that you open a file in the Enterprise PDM File viewer, view the file’s properties, and see the file’s history.
• If a task fails, the notification contains a link to the error log.

**Task Add-ins**
Tasks are defined by task executor add-ins. Enterprise PDM includes the task executor add-in SWTaskAddIn, which enables conversion and printing of SolidWorks files.

Programmers can use the Enterprise PDM API to create an add-in to execute tasks unique to their environment. After administrators install the add-in to the vault, they add the tasks it defines to the **Tasks** node by creating new tasks.

To create a task add-in, you need to program in Visual Basic® .Net, C#, or C++. See the description of the API in the *SolidWorks Enterprise PDM Programmer’s Reference Guide*.

A task add-in extends the capabilities of the task executor. For example, a task add-in could open files in Microsoft Word and save them to another format such as `.html`.

You can program the task add-in to:

• Send parameters and data to the task executor as part of the task instruction
• Execute any MS-DOS®/Windows command
• Start up any Windows program with an arbitrary number of parameters
• Give commands to any Windows program
• Access and send command to installed resources like printers and plotters

**Enterprise PDM and Toolbox Integration**

Enterprise PDM can now manage SolidWorks Toolbox part files and the Toolbox database entirely in an Enterprise PDM vault. Users point SolidWorks to the Toolbox vault folder and use Toolbox as before. Enterprise PDM automatically:

• Checks Toolbox parts out and in as needed so the latest versions are used
• Adds missing Toolbox parts to the vault
• Redirects assembly references to Toolbox parts in the vault
• Replicates the Toolbox files and database (if replication servers are configured)

Enterprise PDM still supports the SolidWorks pre-2010 Toolbox integration, where the master Toolbox library is outside the vault and Enterprise PDM creates copies in the vault as parts are used. If you have SolidWorks 2010, the new integration is recommended.

**Configuring Enterprise PDM and Toolbox**

An administrator must configure Enterprise PDM and Toolbox before users access Toolbox.

For details about this procedure, see *SolidWorks Enterprise PDM Administration Tool Help: Configuring Toolbox*.

To configure the 2010 Enterprise PDM and Toolbox integration:

1. Check the Toolbox root folder (*SolidWorks Data* by default) into the Enterprise PDM vault.
2. From the Enterprise PDM Administration tool, double-click **Toolbox** and set configuration options.
3. From SolidWorks, click **Tools > Options** > **Hole Wizard/Toolbox**:
   a) Set **Hole Wizard and Toolbox folder** to match the setting from the Enterprise PDM Administration tool.
   b) Click **Configure** to configure Toolbox using the Toolbox configuration tool.

4. Have all users set their SolidWorks **Hole Wizard and Toolbox folder** to the Toolbox vault folder.

**Using Toolbox with Enterprise PDM**
Enterprise PDM's management of Toolbox is mostly transparent to users, but there are some details to be aware of.

**Local Cache**
When you first insert a Toolbox component into an assembly, Enterprise PDM caches the latest version of the part file in your local vault view. As you continue to use Toolbox, Enterprise PDM manages your cache automatically.

To reduce disk space, you can clear the Enterprise PDM cache, which removes local files. Enterprise PDM caches files again when needed, which affects performance.

When you clear the cache from the vault root folder (from File Explorer, right-click the vault and select **Clear Local Cache**), the Clear Local Cache dialog box appears. You can remove cached Toolbox files by clearing **Do not remove Toolbox files**.

**Automatic Part Creation**
Toolbox detects when assemblies contain configurations that do not exist in the library and can automatically create missing sizes for you.

If Toolbox is configured to create part files for each new size, Enterprise PDM automatically creates a new file in the vault without first checking the local cache. If Toolbox is configured to add configurations to the master part file, Enterprise PDM checks the cache and retrieves the latest file if necessary. If the size does not already exist, Enterprise PDM creates a new version of the master part file containing the new configuration.

**Search Paths**
SolidWorks always searches for Toolbox parts in the Enterprise PDM vault first. You do not need to add the vault folder to your System Options - File Locations folder list.

**Permissions**
Depending on how your administrator has configured Toolbox integration, Enterprise PDM operations are performed using your Enterprise PDM permissions or the permissions of a designated user. These permissions determine what operations you can perform. Enterprise PDM displays a message if you do not have permission to perform an operation.

For example, if you have read access to Toolbox but no permission to check out files, you can use existing component sizes but not create new sizes.

**Working Offline**
You can work with Toolbox parts when you do not have access to the vault by caching the parts locally before going offline. In File Explorer, use **Get Latest** on the Toolbox vault folder. You cannot create new sizes when working offline.
File Explorer and SolidWorks Add-in

Naming Files with Serial Numbers Using Copy Tree
The Copy Tree command can now automatically name copied files using serial numbers. By default, the serial numbers set up for naming parts, assemblies, and drawings in the SolidWorks add-in options are used, but you can select any serial number.

Right-click a file and click Copy Tree. In the Copy Tree dialog box, do one of the following:
- Click Transform > Rename with Serial Number.
- Right-click a file in the file list and click Rename with Serial Number.

See SolidWorks Enterprise PDM File Explorer Help: Copying Files with References.

Naming Drawings with Model Names Using Copy Tree
The Copy Tree command can copy drawings using the same names as their associated assembly or part files.

Right-click a file and click Copy Tree. In the Copy Tree dialog box, select Name drawings after their models.

See SolidWorks Enterprise PDM File Explorer Help: Copying Files with References.

Drawings with Multiple References Not Automatically Checked Out
Enterprise PDM no longer automatically checks out or retrieves drawings referencing more than one file when you check out or retrieve a referenced part or assembly. This change addresses issues where drawings remained checked out after the referenced file was checked in.

File Preview Rebuild Warning
The Preview tab now displays a warning if a drawing or assembly needs to be rebuilt. This happens when referenced parts or subassemblies have been modified but the selected drawing or assembly has not been opened and resaved in SolidWorks.

Warning when File Is Open in Another Application
File Explorer now warns you if you check in, check out, or edit the data card of a file that is open in another application. Close the file in the other application and retry the Enterprise PDM operation.

By default, this condition blocks check-ins and check-outs. To make this condition nonblocking, from the Enterprise PDM Administration tool, expand Users or Groups and double-click a user or group. In the Properties dialog box, click Warnings. For Affected operation, select Check In or Check Out, clear The file is open in another application, and click OK.

💡 If the file is open in SolidWorks and the Enterprise PDM add-in is installed, you can perform operations from the add-in without closing the file.

Changing Column Names and Order in the SolidWorks Add-in
You can now rename and reorder the columns in the Enterprise PDM SolidWorks client.

To rename a column, in SolidWorks, click Enterprise PDM > Options. In the Enterprise PDM Options dialog box, on the View Setting tab, under Display Information, type a new Caption.
To reorder columns in the SolidWorks Enterprise PDM task pane, drag a column header (caption) to a new location. **File / Variable** must be the first column.

### Cold Storage Versions in Get Version Submenu

The **Get Version** command now lists cold storage versions in a submenu, which shortens the main list to only versions you can retrieve.

From File Explorer, right-click a file and click **Get Versions > Versions in Cold Storage**.
From the SolidWorks add-in, click **Get Versions > Versions in Cold Storage**.

**Versions in Cold Storage** is available only if at least one version is in cold storage.

---

**Item Management**

### Generating Item IDs from File Attributes

Enterprise PDM can now generate item IDs from file attributes. An administrator selects which data card variable to map to, such as part number. When generating an item from a file, Enterprise PDM defaults to an existing item if there is an item with the same ID, otherwise the item ID defaults to the mapped value. A user can choose to generate a different ID. If variable mapping is not enabled or if the variable has no value, Enterprise PDM uses the item serial number to generate the ID.

In the Administration tool, expand a vault and double-click **Items**. On the **Item ID** page, for **Item ID Variable**, select a variable or select **<Do not read the ID from a variable>**.

See *SolidWorks Enterprise PDM Administration Tool Help: Configuring Items*.

### Named BOMs for Items

Named bills of materials (BOMs) are now supported for items. You can create one or more BOM views and sort, filter, change position numbers, and compare BOMs.

In Item Explorer, on the Bill of Materials tab, click **Save BOM > Save as BOM**.
See *SolidWorks Enterprise PDM Item Explorer Help: Named BOMs*.

### Display Formats for Item BOMs

You can now control which items display in item BOMs.

In Item Explorer, on the Bill of Materials tab, click **BOM Display** and click one of the following:

- **Indented** displays all items in the BOM hierarchically.
- **Parts Only** displays only items without child items.
- **Top Level Only** displays only top-level items.

### Expanding and Collapsing Item Structure

You can now expand all items displayed in the Item Explorer main pane to display their content. You can expand one, two, three, or all levels of hierarchy, and collapse all levels of hierarchy.

In Item Explorer, click **Expand Levels** (toolbar) and click a command.
See SolidWorks Enterprise PDM Item Explorer Help: Expanding and Collapsing Items and Folders.

Optional Parent Node Check Boxes
When generating items from files with references, you can now choose whether to display bulk selection check boxes for parent nodes. Use these check boxes to make selections more efficiently, or turn them off to simplify the user interface. Previously, these bulk selection check boxes were always displayed.

In the Generate Item dialog box or Link Files to Item dialog box, right-click in the file list box and select or clear **Show Parent Node Check Boxes**.

See SolidWorks Enterprise PDM Item Explorer Help: Bulk Selecting References in Dialog Boxes.

API Support for Items
Enterprise PDM now provides an API for items.

See API Support for Items on page 105.

Administration Tool

Add-in and File Format Support
The SolidWorks add-in and file formats for Enterprise PDM 2010 have been updated to support SolidWorks 2010.

Extended Export and Import Functionality
The Administration tool export functionality has been expanded for Enterprise PDM 2010 to make it easier for you to move settings from one vault to another.

You can now export all configurable features to administrative export (.cex) files.

You can also export all settings in a vault to a single .cex file by right-clicking the vault name and clicking **Export**.

To import administrative export files, right-click the vault name, click **Import**, and navigate to the location of the .cex file.

Data Card Export and Import
You can export a data card created using the card editor to a .cex file and import the .cex file into another vault.

When you import a data card, all card dependencies, such as variables, serial numbers, and card lists, are also imported.

You can export data cards for:
- Files
- Folders
- Items
- Searches
- Templates

You can export all cards in the vault, all cards of a specific type, or individual cards.
Add-in Export and Import
You can export an API add-in to a .cex file and import the .cex file into another vault. You can export a single add-in or all the currently registered add-ins.

When you import an API add-in, all files included with the add-in are also imported.
To export all registered API add-ins in a vault, right-click Add-in and click Export.
To export an individual add-in, expand Add-in, right-click the add-in, and click Export.

Template Export and Import
You can export a template created using the template wizard to a .cex file and import the .cex file into another vault.

When you import a template, all template dependencies such as input forms, variables, and serial numbers are also imported.

ricane Group settings are included in export files for templates. User settings are not.

To export all templates in a vault, right-click Templates and click Export.
To export an individual template, expand Templates, right-click the template, and click Export.

Central Assignment of Permissions
The Properties dialog boxes for users and groups now provide a central place to assign all permissions, including permissions for search cards, bills of materials, and templates.

Access to the dialog boxes has not changed. For example, you still expand Groups and double-click a group to display its Properties dialog box. To make it easier to locate and display the permissions to set, the tabs used in previous releases have been replaced by a left pane list of controls that link to the permission pages.

The following graphic shows the new Group Properties dialog box controls, highlighting the Search Cards, Bills of Materials, Tasks, and Template links.
Serial Number Enhancements
You have more control over how Enterprise PDM handles serial numbers for added or renamed files. Previously, if you set up serial numbering, default values were generated for all configurations. You can now configure data cards to specify configurations for which default values will not be generated.

In the Card Editor, when adding most controls, select Default overwrites and type the names of the configurations from which to exclude default values.

Enterprise PDM also:
• Generates default values when you create new SolidWorks configurations
• Preserves card values when you rename a configuration

SMTP Mail Setup
You can now quickly verify your SMTP mail settings by performing an email test to validate them.

If there are errors in your settings, Enterprise PDM returns a detailed error message to help you find the problem.

With SMTP selected in the Message System dialog box, on the SMTP tab, click Test Settings. In the Test Settings dialog box, type the name of an email recipient and click OK to send the test message.

API
For information on using the Enterprise PDM API, see the SolidWorks Enterprise PDM Programmer’s Reference Guide. To access the guide, right-click Add-ins and click Programmer’s Reference Guide.

API Support for Items
Enterprise PDM now provides an API for items.

The API lets you create applications to perform custom tasks such as:
• Synchronizing items between Enterprise PDM and Enterprise Resource Planning (ERP), Materials Requirements Planning (MRP), and other external systems
• Importing items into Enterprise PDM
• Accessing information to generate reports
• Customizing item numbering

Specific API capabilities include:
• Reading, modifying, and creating items
• Generating items from files
• Reading, modifying, and creating item links to child items and files
• Reading and modifying item bills of materials (BOMs)
• Finding items and opening them in Item Explorer

API Methods for Users and Groups
The existing API methods for users and groups have been extended.

You can now use the API to:
• Copy permissions and settings from an existing user
• Assign folder permissions for users and groups
• Add users to and remove users from existing groups
• Delete existing users and groups
• Check folder permissions for users and groups

**Dispatch Set Card Variables Command**

The Dispatch module includes the new command Set card variables. This command sets file and folder data card variables to user-specified values. Administrators can select and configure the Set card variables command and add it to an action.

To access the Set card variables command:

1. Expand Add-ins, right-click Dispatch, and click Administer Actions.
2. In the Administer Actions dialog box, click Add.
3. In the Edit Action dialog box, click Add.
4. In the Select command dialog box, select Set card variables.

Use the Set Card Variables dialog box to:

- Configure the command to specify the target file or folder, data card variable, configurations, and variable value
- Specify the variable value as a static string or as a parameterized string constructed using Dispatch variables

**Installation**

**Predefined Data Set Configurations**

Enterprise PDM provides multiple predefined configurations that consist of data cards, workflows, templates, and bill of materials (BOM) column sets. To make it easier to begin using Enterprise PDM, when you create a vault, you can choose which configuration to import.

Configurations are defined using .cex files.

To select a configuration, right-click the server name in the Administration tool and click Create new vault. On the Configure vault screen, select one of the standard configurations shipped with Enterprise PDM:

<table>
<thead>
<tr>
<th>Configuration</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Empty</td>
<td>Creates a data folder with no files, which makes it easier to import or create objects such as data cards and workflows.</td>
</tr>
<tr>
<td>Default</td>
<td>Installs the data set from previous versions of Enterprise PDM.</td>
</tr>
<tr>
<td>SolidWorks Quick Start</td>
<td>Installs a simple data set with predefined groups and permissions, enabling companies installing Enterprise PDM for the first time to quickly use the software in a production environment.</td>
</tr>
</tbody>
</table>

If your company already has a customized data set based on an administrative export file, you can browse to it and import it.

**Documentation**

**Web-based Documentation**

Documentation for SolidWorks Enterprise PDM is now available on the Web.
By default, when you access help, the Web version of the documentation is displayed in a Web-based viewer. You can still choose to use local help files (.chm) if, for example, your Internet connection is slow or unavailable.

Benefits of Web-based help include:

- Improved search functionality, including improved relevancy ranking, spelling correction, short descriptions in search results views, and guided navigation to help you identify relevant topics.
- Improved topic navigation, including next and previous topic buttons and breadcrumb navigation.
- Ability to provide feedback directly to the documentation team on individual help topics.
- Up-to-date documentation without the need to download large compiled help (.chm) files.

Select or clear **Use SolidWorks Web Help** on all SolidWorks Enterprise PDM Help menus to switch between the local and Web-based versions of the help.

The *SolidWorks Enterprise PDM Programmer’s Reference Guide* is available as a locally installed .chm file only. To access it, in the Administration tool, right-click *Add-ins* and click *Programmer’s Reference Guide*. 
This chapter includes the following topics:

- DXF / DWG Output Property Manager
- Importing Rhino Files on 64-bit Computers
- Importing and Exporting Adobe Photoshop Files on 64-bit Computers
- Importing Autodesk Inventor Files
- Importing Adobe Illustrator Files
- Saving a TIF, JPG, or PSD File to a Custom Size

**DXF / DWG Output Property Manager**

The new DXF / DWG Output Property Manager lets you export any planar face or named view from a part file to one or more DXF or DWG files. A preview shows what you have selected so that you can remove entities. An expanded set of geometrical entities is available when you export a sheet metal flat pattern.

With a part open, open the PropertyManager by:

- Saving the part (File > Save As) to a .dxf or .dwg file type
- Selecting one or more planar faces, clicking File > Save As, and choosing a .dxf or .dwg file type
- Selecting one or more planar faces and clicking Export to DXF / DWG
- In the FeatureManager design tree for a sheet metal part, right-clicking Flat-Pattern and clicking Export to DXF / DWG

After you click Save, the PropertyManager appears.

For more information about this PropertyManager, see *SolidWorks Help: DXF / DWG Output Property Manager*.

**Importing Rhino Files on 64-bit Computers**

You can import Rhino files (in .3dm format) on 64-bit computers. In earlier releases, you could import Rhino files on 32-bit computers only. Restrictions are listed in SolidWorks Help.

See *SolidWorks Help: Rhino Files*.

**Importing and Exporting Adobe Photoshop Files on 64-bit Computers**

You can import and export Adobe® Photoshop® files (in .psd format) on 64-bit computers. In earlier releases, you could import Photoshop files on 32-bit computers only.

See *SolidWorks Help: Adobe Photoshop (*.psd) Files*. 
Importing Autodesk Inventor Files

When you import an Autodesk® Inventor® part or assembly file, you can choose to import the object as a single body or import it with its features. Importing by feature provides more detailed information about the original model.

Inventor must be installed on your computer to import features. You can import geometry with Inventor Viewer installed. When you import an Inventor file, you are prompted to select an import type.

Importing Adobe Illustrator Files

To import an Adobe® Illustrator® file into SolidWorks, version CS3 or later of Illustrator must be installed on your system.

Saving a TIF, JPG, or PSD File to a Custom Size

When you save a part or assembly in .tif, .jpg, or .psd format, you can save the image to a custom size by specifying dots per inch (DPI) or paper size.

In the Save As dialog box, select the file format from the Save as type list. In the Export Options dialog box, click Options to specify the print capture size.

For more information, see SolidWorks Help: TIFF, Photoshop, and JPEG Export Options.
Motion Studies

Available in SolidWorks Premium.

This chapter includes the following topics:

- Event-based Motion Analysis
- Rigid Groups
- Structural Simulation Analysis for Motion
- Force and Motor PropertyManager Enhancements
- Contact
- Setting the Exact Time for Key Points and the Time Bar

Event-based Motion Analysis

Event-based Motion Analysis
With SolidWorks Simulation® Professional added in, you can use Motion Analysis to calculate the motion of an assembly that incorporates event-based motion control.

Event-based motion requires a set of tasks. The tasks can be sequential or can overlap in time. Each task is defined by a triggering event and its associated task action. Task actions control or define motion during the task.

A task trigger is the event that drives the motion control action for a task. You can define task triggers based on time, previous tasks, or sensed values, such as component position.

You can create triggers from:

- Sensors:
  - Interference detection: Detects collisions.
  - Proximity: Detects motion of a body crossing a line.
  - Dimension: Detects the relative position of components from dimensions.

- Previous tasks in the event schedule
- Start and finish times for task actions

A task action defines or constrains the motion of one or more components in the assembly. You can define actions to suppress or activate mates, stop motion, or to change values for motors, forces, or torques.

You can define a task action to:

- Start, stop, or change the value of a constant speed motor, constant force, constant torque, or a servo motor
- Stop the motion
• Suppress a selected mate

To use event-based motion, you must:
  • Obtain a SolidWorks Simulation Professional license.
  • Add in SolidWorks Motion.
  • Select Motion Analysis for the motion study type.

Creating a Task

Create the required sensors, motors, torques, or forces before setting up the study.

To create an event-triggered motion task for a Motion Analysis study:

1. From a Motion Analysis motion study, if you are not already in an event-based view, click Event-based Motion View (MotionManager toolbar).
2. Click the next task row.
3. Enter the task description and specify the trigger and control action for the task.

Servo Motors for Event-based Motion Analysis

You can use servo motors to implement control actions for event-based motion analysis.

You can create the following types of linear or rotary servo motors:
  • Velocity
  • Acceleration
  • Displacement

When triggered, servo motors control the motion of a component. Specify the triggers and corresponding motor parameters in the Event-based Motion View.

To create a servo motor, click Motor (MotionManager toolbar), select Servo Motor for Motor Type, and specify the servo motor in the Motor PropertyManager.

New Proximity Motion Sensor

You can use proximity sensors to trigger actions in event-based motion analysis.

You can specify the location, direction, and range of a line that senses when a body in motion crosses it. For example, use proximity sensors to model laser position detectors.

To create a sensor, in the FeatureManager design tree, right-click the Sensors folder and click Add Sensor.

Event-based Motion Study

In this tutorial, you examine an event-based motion study of a welding robot.
Event-based motion requires a set of tasks. The tasks can be sequential or can overlap in time. Each task is defined by a triggering event and its associated task action. Task actions control or define motion during the task.

This motion study is set up for the following tasks:

- **Task 1**: Use a position sensor to stop the motion of a plate at a given location after .01 seconds.
- **Tasks 2-4**: Turn on three displacement servo motors. Each servo motor is set to move in one of the three spatial directions.
- **Task 5**: Activate the servo motors to move the robot to its welding X, Y, Z position.
- **Task 6**: Begin welding when the robot is in position.
- **Task 7**: Activate the servo motors to move the robot back to its original position.

You must have a SolidWorks Simulation Professional license and you must add in SolidWorks Motion to run this tutorial.

**Opening the Model**

First, you open the model and examine some components.

1. Open `install_dir\samples\whatsnew\motionstudies\weldingrobot\weldingrobot.sldasm`.
2. Select the Motion Study 1 tab.
   Notice there are four linear motors listed in the MotionManager and one sensor listed in the FeatureManager design tree.

**Viewing Motor and Sensor Parameters**

Next, you examine values for the motors and the sensor in this study.

1. Place your pointer over the MotionManager time slider to check the time and drag it all the way to the left.
This step places the assembly components in their initial positions and initializes the motor values.

2. Right-click LinearMotor4 in the MotionManager and click **Edit Feature** to view the motor parameters.
   Notice the constant velocity is set to 75 mm/s.

3. Right-click the sensor in the FeatureManager design tree and click **Edit Sensor**.
   Notice this is a proximity type sensor, sensing the position of an assembly component in motion. For this model, the position sensor is in place to indicate when the plate to weld has reached its required location.

4. Repeat Step 2 for the other motors in this study and observe that these are displacement servo motors.

**Viewing Trigger and Control Actions**

A task trigger is the event that drives the motion control action for a task. You can define task triggers based on time, previous tasks, or sensed values, such as component position.

A task action defines or constrains the motion of one or more components in the assembly. You can define actions to suppress or activate mates, stop motion, or to change values for motors, forces, or torques.

Next, you open the Trigger and Action dialog boxes to better understand the event-triggered motion setup.

1. In the **Trigger** column, double-click Sensor1, the trigger for Task1.
   The Trigger dialog box appears with Sensor1 selected.
   - You can specify triggers from sensors or tasks, or you can specify time-based triggers.
   - You can click **Add Sensor** to create a new sensor trigger.

2. Do not change the trigger selection and click **OK** to close the dialog box.

3. In the **Feature** column for Task1, double-click LinearMotor4.
   The Action dialog box appears, with LinearMotor4 selected.
   You can specify actions by activating or changing motors, torques, or forces, or by toggling mate suppression. You can also apply an action that stops the motion altogether.

4. Do not change the action selection and click **OK** to close the dialog box.

**Calculating the Motion**

Next, you calculate the event-triggered robot motion.

1. Click **Timeline View** (MotionManager toolbar) to see the motion events in a timeline.

2. Click **Calculate** (MotionManager toolbar).
   Event-based key points appear in the timeline as the events take place.
Hover over a key point to view information about the event for a given component.

3. Hover over the MotionManager timeline slider. The simulation takes 2.2566 seconds.

Changing the Linear Motor Speed
Next, you duplicate the study and change the linear motor speed.

1. Right-click the Motion Study 1 tab of the motion study and click Duplicate.
2. Select Motion Study 2, the duplicate study.
3. Right-click LinearMotor8 in the MotionManager and click Edit Feature.
4. Change the motor velocity to 35 mm/s and click ✓.
5. Click Calculate (MotionManager toolbar).
   Notice that changing the speed with which the plate moves into place does not affect the overall simulated motion. The welding task does not begin until the plate is properly placed.
6. Hover over the MotionManager timeline slider.
   The simulation takes 3.6776 seconds, due to the slower motor speed of Task1.

Changing the Servo Motor Profile
Next, you calculate the motion after changing the profile of the servo motor displacement.

1. Right-click the Motion Study 1 tab of the motion study and click Duplicate.
2. Select Motion Study 3, the duplicate study.
3. Adjust the column widths under **Actions** so that you can view the feature names and their profiles.

Notice that all of the motors have a linear profile.

The servo motor profile specifies the displacement path of the motor.

4. Select the **Harmonic** profile for LinearMotor9 in Task6.

5. Select the **Constant Acceleration** profile for LinearMotor11 in Task8.

6. Change the duration for tasks 8-11 to 0.5 seconds.

7. Click **Calculate** (MotionManager toolbar).

8. Hover over the MotionManager timeline slider.

   The simulation takes 2.4566 seconds.

9. Close the assembly and click **No** if you are prompted to save the document.

**Rigid Groups**

You can reduce the **Motion Analysis** simulation time by selecting components and grouping them into a rigid group.

Rigid groups of components behave like a single component in motion calculations:

- Motion between components in the group is ignored.
- Mates between components in the group are ignored.
- All group components contribute to the mass and moment of inertia of the rigid group.

To add a component or subassembly to a rigid group, right-click the component or subassembly in the MotionManager tree, and click **Add to New Rigid Group**.

If a rigid group contains one fixed component, the rigid group is considered fixed for motion calculations.

**Structural Simulation Analysis for Motion**

With SolidWorks Simulation added in, you can perform stress, factor of safety, or deformation analysis of components without setting up loads and boundary conditions. The required loads are obtained automatically from a calculated Motion Analysis study.

Click **Simulation Setup** (MotionManager toolbar) to select a part, stress analysis duration and start time, and the mesh for each result.
Click **Calculate Simulation Results** (MotionManager toolbar) to calculate stress analysis results after setting them up.

Click a simulation result flyout option (MotionManager toolbar) to display a plot of the results after successful calculation:

- **Stress Plot**
- **Deformation Plot**
- **Factor of Safety Plot**
- **No Plot**
- **Delete Simulation Results**

### Force and Motor PropertyManager Enhancements

The Force and Motor PropertyManagers are more consistent and easier to use:

- Force and Motor functions have preview graphs.
- You can specify motor location and direction from the same section of the Motor PropertyManager.
- You can specify a component for motion relative to the motor.
- You can specify a servo motor for event-based motion control.
- You can specify a phase shift for oscillating motors.
- You can use linear interpolation for interpolated motors or forces.
- The Force PropertyManager is now called the Force/Torque PropertyManager.

### Contact

**Contact PropertyManager Name Change**

The 3D Contact PropertyManager is now called the Contact PropertyManager.

**Contact Groups for Motion**

For Motion Analysis studies, when your assembly includes components that make contact during motion, you can create two groups of components to analyze component contact across the groups and ignore contact among components within the groups. A contact group is treated as a single component in contact force calculations.

Create contact groups to reduce computation time for motion of assemblies with contact considerations.

Define contact groups in the Contact PropertyManager.

To open the PropertyManager, click **Contact** (MotionManager toolbar).

**Curve-to-Curve Contact**

For Motion Analysis studies, when you can model component contact in your assembly with two curves that touch during motion, you can define curve-to-curve contact between
the two components. When the two components make intermittent contact during the motion analysis, curve-to-curve contact applies contact forces to the components, preventing them from moving through each other. You can also constrain the continual contact of two components with curve-to-curve contact.

1. Click **Contact** (MotionManager toolbar).
2. In the Contact PropertyManager, under **Contact Type**, click **Curves**.

When the curves are in continual contact throughout the motion, under **Selections**, select **Curves always touch**.

### Setting the Exact Time for Key Points and the Time Bar

You can specify the exact time for key points and the time bar in nanoseconds or other units.

To set exact key point time:

1. Right-click a key point and click **Edit Key Point Time**.
   - Select **Exact Time** to enter the exact key point time.
   - Select **Offset** to shift the current key point time by a value.
2. Drag the dial, click the spin buttons, or enter a value for the key point time or offset.
3. Click .
4. From the lower right corner of the MotionManager, click **Zoom to Fit** to rescale the timeline view if necessary.

To specify an exact time for the time bar, right-click the time bar, and click **Move Time Bar**.
This chapter includes the following topics:

- **Materials and Multibody Parts**
- **Features**

### Materials and Multibody Parts

You can assign different materials to individual bodies in a multibody part. The material assignments are used by mass properties, drawing section views, and SolidWorks Simulation.

In the FeatureManager design tree, in the **Solid Bodies** folder, right-click a body and click **Material**. To affect several bodies, select them before right-clicking.

For more information, see *SolidWorks Help: Materials and Multibody Parts*.

### Features

#### Hole Wizard

**Hole Wizard Creates 2D Sketches by Default**

When creating a Hole Wizard hole, you no longer have to preselect a planar face to create a 2D sketch. The Hole Wizard creates a 2D sketch unless you select a nonplanar face or explicitly request a 3D sketch.

Click **Hole Wizard** (Features toolbar) without preselecting a face. On the Positions tab of the Hole Wizard PropertyManager, click **3D Sketch** before clicking a planar surface to create a 3D sketch.

See *SolidWorks Help: Hole Wizard Overview*.

**Straight Pipe Threads Added for All Standards**

The Hole Wizard now includes straight pipe tapped holes for all standards. Previously, the Hole Wizard supported straight pipe tapped holes for the DIN standard only.

In the Hole Wizard PropertyManager, under **Hole Type**, click **Straight Tap** , select a **Standard**, and for **Type** select **Straight Pipe Tapped hole**.

#### Instant3D Enhancements

In assemblies, when you click **Move with Triad** from the shortcut menu, rulers now appear with the triad so you can move components to a defined location.
You can use the triad to edit a Move Face feature (Translate or Rotate type) that was created with Instant3D triad. The triad appears when you select the feature in the graphics area.

**Lip and Groove Enhancements**

The lip and groove feature now covers more geometry and is more robust for cases where there are tiny faces around the parting line.

You can now:

- Create a lip and groove feature when the interface between the lip and groove contains multiple faces, for example, for a mouse hole or a gap in the parting line.

- Allow for adjacent geometry, for example, where ribs join the sidewalls of the part. In the PropertyManager, select the new **Jump Gaps** option to allow ribs to adjoin lip and groove faces.
• The new **Copy** option in the Move Face PropertyManager uses Instant3D functionality to edit copied faces. You cannot create disjoint bodies using the **Copy** option.
• The Select Connected Faces pop-up toolbar now supports Move Face features.
• The shortcut menu now contains the **Move Face** command. **Move Face** is available when you are not in any command and right-click on a face.
• The new Direct Editing CommandManager tab contains tool buttons such as **Move Face**.

### Creating Move Face Features
Access to the Move Face tool has been enhanced. Several other enhancements support Move Face creation and editing.

#### Creating Translated Move Face Features
1. Open `install_dir\samples\whatsnew\I3D\MoveFace.sldprt`.
2. Right-click any CommandManager tab and click **Direct Editing** to activate this tab.
3. Do one of the following:
   • Right-click the face and click **Move Face**.
   • On the Direct Editing CommandManager tab, click **Move Face** and select the face.

   The triad appears. A graphical pop-up toolbar appears to help you select connected faces.
4. In the PropertyManager, under **Move Face**, select **Translate**.
5. Click the pop-up toolbar image shown to select all co-planar faces.
If the pop-up toolbar does not appear, clear the selected face and reselect it.

6. Drag the triad arm shown away from the face.

A ruler appears to help you drag a discrete distance. The selected faces are translated by that distance.

7. Click ✓.

Creating Rotated Move Face Features

1. Rotate the model and select the face shown.

2. Select Move Face (Direct Editing CommandManager tab).

3. Click Front (Standard Views toolbar).
4. Drag the blue-colored triad ring to rotate the face.

In the PropertyManager, **Rotate** is selected under **Move Face**. A protractor appears to help you rotate the face by a discrete angle. A preview of the rotated face appears.

5. Click ✅.

You can use the triad to edit a Move Face feature (Translate or Rotate type) that was created with Instant3D triad. The triad appears when you select the feature in the graphics area.
Pattern and Mirror Preview
Full preview is now available for pattern and mirror features.
The preview supports the **Up to Surface** end condition for patterns and mirrors.

Shape Feature
The shape feature is removed from the SolidWorks software.
Creating and editing the shape feature is not supported in SolidWorks 2010. Existing shape features are still supported unless you change their parent features. Use the freeform feature instead.

Split Lines Enhancements
You can now:
- Select multiple contours from the same sketch to split.
- Split curves on multiple bodies with one command.
- Pattern split line features that were created using projected curves.
- Create split lines using sketched text. This method is useful for creating items such as decals.

Wrap Feature Enhancement
You can now project a wrap feature onto multiple faces.
FeatureWorks

Available in SolidWorks Professional and SolidWorks Premium.

Menu and Toolbar Location
The user interface for FeatureWorks has been fully integrated into regular toolbars and menus of the SolidWorks software.

When you select a related command, the add-in loads dynamically if you have installed it and are running SolidWorks Professional or SolidWorks Premium.

To access FeatureWorks commands, open a part that contains imported features and do one of the following:

- Click Recognize Features or Options (Features toolbar).
- Click Recognize Features (Data Migration tab of the CommandManager).
- Click Insert > FeatureWorks and then click Recognize Features or Options.

Diagnostic Messages
Error messages that appear when a feature cannot be recognized have been enhanced.

During interactive recognition, if the software fails to recognize a feature, a detailed error message appears to explain the reason for the failure and to suggest possible solutions. The message also includes a link to a help topic.

The enhanced messages appear when the following features are not recognized:

- Chamfer
- Fillet
- Hole
- Boss Extrude
- Cut Extrude
- Boss Revolve
- Cut Revolve

Bosses and Cuts
Interactive Recognition of Bosses and Cuts
Interactive recognition of extrude features (bosses and cuts) has been enhanced.

In addition to recognizing similar features, FeatureWorks can now recognize dissimilar features if they have a face that is parallel to the selected face.

During interactive recognition of boss extrude features and cut extrude features, select Check parallel faces.
In this example, when you select one face, FeatureWorks recognizes four boss extrude features:

![Image of a gear with recognized extrude features]

**Automatic Recognition of Bosses and Cuts**
Automatic recognition of extrude features (bosses and cuts) has been enhanced to recognize more features.

If an imported body remains after automatic recognition is complete, the software automatically executes interactive recognition algorithms for extrude features.

**Direct Edit of Bosses and Cuts**
You can now use **Edit Feature** to recognize extrude features (bosses and cuts).

All types of extrude features (bosses and cuts) that are recognized by FeatureWorks are supported.

In the graphics area, right-click an unrecognized extrude feature on an imported body and click **Edit Feature**.

![Image of a gear with Edit Feature button]

**Child Features**

**Child Features of Recognized Features**
You can now use **Edit Feature** to recognize child features of features that have already been recognized.

In the graphics area, right-click an unrecognized child feature of a feature that has already been recognized and click **Edit Feature**.

**Child Features in Imported Bodies**
While using **Edit Feature** to recognize a face on an imported body, you can now recognize child features of the face.

In the FeatureWorks Options dialog box, on the Resize Tool page, for **Automatically recognize child features when using Edit Feature**, select **Prompt**, **Yes**, or **No**.

**Draft**
In interactive recognition mode, you can recognize all the fillets and drafts associated with a selected neutral face in one step.
Previously, you had to use one step to recognize the fillets and then more steps to recognize each of the different drafts.

In interactive recognition mode, select **Standard features**. For **Feature type**, select **Draft** and then **Recognize filleted**. When you select the neutral face, FeatureWorks recognizes all the fillets and drafts associated with that face in one step.

### Holes

**Intersecting Holes**
You can recognize intersecting holes.

In automatic recognition mode, select **Holes** under **Automatic Features**. FeatureWorks recognizes two separate hole features.

**Combining Holes**
You can combine holes on the same plane into a single feature.

Use automatic recognition mode to recognize the holes. Then in the Intermediate Stage PropertyManager, select the holes in **Recognized Features** and click **Combine Features**.

**Holes on Nonplanar Faces**
You can recognize holes on nonplanar faces.

Use automatic or interactive recognition modes, or, in the graphics area, right-click the face of an unrecognized hole feature and click **Edit Feature**.

### Reference Geometry, Sketches, and Surface Features

FeatureWorks recreates (but does not recognize) some reference geometry, sketches, and surface features.

Previously, you had to delete such features before proceeding with recognition of the part. Features supported for re-creation but not for recognition include:

- **Sketches**:
  - 2D Sketch
  - 3D Sketch
- **Features**:
• Delete Face
• Move Face
• Surface features:
  • Surface-Offset
• Reference Geometry features:
  • Plane
  • Axis

### Surfaces

#### Knit Surface Features

The Knit Surface PropertyManager has new options:

- Select **Merge entities** to merge faces that have the same underlying geometry type.

  Select **Gap Control** to control which gaps are knitted closed and which remain open. For more information see *SolidWorks Help: Knit Surface PropertyManager - Gap Control*.

![Knit Surface PropertyManager](image)

The **Minimal adjustment** option is removed from the Knit Surface PropertyManager for all new knit surface features.

#### Trim Surface Feature Enhancements

Copies of trimmed bodies are no longer stored when you create standard trim surface features, resulting in smaller file sizes and improved performance.

To create standard trim surface features:

1. Click **Insert > Surface > Trim**.
2. In the PropertyManager, under **Trim Type**, select **Standard**.
3. Select other trim surface options and click ✔.

#### Surface Extend Feature Enhancements

Tangent surfaces no longer fray when you extend them.
To extend surface features, click **Insert > Surface > Extend**.
Available in SolidWorks Professional and SolidWorks Premium.

This chapter includes the following topics:

- PhotoWorks Decals in PhotoView 360
- Controlling Scenes
- Support for Background Images and Custom Environments
- Video Tutorials
- Saving Custom Views
- Camera Effects

**PhotoWorks Decals in PhotoView 360**

In PhotoView 360, you can now see PhotoWorks decals that were applied in SolidWorks and that were visible when the part or assembly was saved.

As in earlier releases, you must use SolidWorks with PhotoWorks added in to edit, create, or delete a decal.

**Controlling Scenes**

You can orient the floor of a scene relative to a model. You can also display or hide the environment, the floor, or a background image.

On the Settings dialog box, make changes on the Environment Settings tab.
Support for Background Images and Custom Environments

You can now include 2D background images for display behind the model. You can also load High Dynamic Range Images (HDRI) to replace the current environment. Loading a custom HDRI image changes the background, reflections, and lighting of the rendering.

Click **Settings**. On the Environment Settings tab:

- Click **Load Background Image**.
- Click **Load Environment Image**.
- Select **Show Background** or **Show Environment** to show or hide either type of image. You can hide both, but you can show only one at a time.

The following image is rendered with the 3 Point Beige environment and a custom 2d background:

For more information about controlling backgrounds in PhotoView, see *PhotoView 360 Help: Settings Dialog Box - Environment Settings Tab*. 
Video Tutorials

New video tutorials are available for PhotoView 360.

The tutorials are available on the Gallery site. Click Help > Online Tutorials to get started.

Saving Custom Views

You can now save custom view orientations in PhotoView 360. Display a view that you saved earlier to ensure that the rendering has a specific orientation.

Right-click in the workspace, click Save Custom View, and name the view.

To restore a saved view, right-click in the workspace, click Recall Custom View, and select a view from the list.

Camera Effects

The camera now supports additional effects.

- You can switch between perspective and orthogonal views.
- Depth-of-field controls let you create renderings where part of the image is in focus and other parts are not in focus.
- You can add a bloom effect to the final render to create a glow for emissive appearances or areas of very bright environment reflections.

Click Settings. Make changes on the Output Settings tab in the Image Processing section and on the Camera Settings tab.

Example: Effect of Changing the Focal Length

![Focal length = 50 mm (default)](image1.png)  ![Focal length = 35 mm](image2.png)

For more information about camera settings, see PhotoView 360 Help: Settings Dialog Box - Output Settings Tab and Settings Dialog Box - Camera Settings Tab.
Example: Effect of Setting Bloom

Image without bloom

Image with bloom
Available in SolidWorks Premium.

This chapter includes the following topics:

- Manufacture-style Flattening
- Adding Components and Assembly Fittings to Routes
- 180-Degree Elbows or Bends for Piping
- Piping Drawings
- Access to Pipe, Tube, or Electrical Harness Coverings
- Multiple CPoint Enhancements
- P&ID Data Import and Modeling Process
- Reference Designators
- Pipe and Tube Route Export Enhancements
- Routing Library Enhancements

### Manufacture-style Flattening

**Manufacture-style Flattening**

A manufacture-style flattened route unfolds a route to scale and defines the boundary of a formboard in which to place the flattened route. You can use the manufacture-style flattened route when designing electrical cable routes for manufacturing.

Select **Manufacture** in the Flatten Route PropertyManager to create a manufacture-style flattened route.

To edit a manufacture-style flattened route, right-click the flattened route in the FeatureManager design tree and click **Edit Flattened Route**. You can edit:

- Segment curvature
- Segment angle
- Flattened route center

> You cannot apply manufacture-style flattening to ribbon cables.

**Scaled Drawing of an Electrical Route**

In this example, you open an electrical route and create a flattened drawing to scale.
Opening and Saving the Model
First you open the routing subassembly and save it with another name.

1. Open
   \texttt{install\_dir\samples\whatsnew\routing\manufactureflatten\5connector.sldasm}.

2. Click \texttt{File > Save As}, browse to a new directory on your computer, and rename the file to \texttt{my\_5connector.sldasm}.

Flattening the Route
Next you flatten the route subassembly.
1. Click **Routing > Electrical > Flatten Route**.
2. In the PropertyManager, select **Manufacture**.
3. Select the top right segment of the harness.

The selected segment is listed in the Flatten Route PropertyManager.

**Viewing the Drawing**
Next you check the drawing and decide whether to edit the flattened route.

1. In the PropertyManager, select **Drawing Options** and **Connector table**, and clear all other drawing options.
2. Click ✓.

Examine the drawing to decide whether to edit the flattened route. In the next procedure, you change the curvature of one of the cables.

3. Close the drawing and, when prompted, click **Save All** and **Save**.

**Editing the Flattened Route**
Next you edit the flattened route to change the curvature of a cable.

1. Right-click **ManufactureFlattenedRoute1** in the FeatureManager design tree and click **Edit Flattened Route**.
2. Select the curved spline as shown.
The spline is listed in the selection box under **Editing Tools** in the Edit Flattened Route PropertyManager.

3. Click **Adjust Curvature**.
4. Change the **Radius** to 20 mm, the **Bend Angle** to 10 degrees, and click **Apply**.

5. View the changes before clicking ✓.
6. Click **File > Save As** and save the flattened route assembly to a file name of your choice.
7. Close the flattened route assembly and in Save Modified Documents, click **Save All**.
Adding Components and Assembly Fittings to Routes

You can:

- Make fitting to fitting connections:
  - Drag flanges onto elbows, valves, and other fittings.
  - Drag elbows onto flanges, valves, and other fittings.
- Split a run of pipe by dragging a fitting or a pair of flanges into the pipe.
- Create branch lines in a pipe by dragging a tee into the pipe.
- Drag entire assemblies with appropriate references into a pipe. For example, you can drag an assembly consisting of a valve with four flanges into a pipe.
- Drag a flange, a gasket, and another flange into a route to insert a gasket between flanges.

180-Degree Elbows or Bends for Piping

You can use 180-degree elbows or create 180-degree bends in pipes.

Piping Drawings

Piping drawings of routes include fittings, pipes, dimensions, and a BOM in an isometric view. To create a piping drawing, click Pipe Drawing (Piping toolbar).

Access to Pipe, Tube, or Electrical Harness Coverings

You can access coverings for pipes, tubes, or electrical harnesses from the Covering Library. You can also create custom coverings with fixed diameters.

Click Coverings (Routing Tools toolbar) to access or add library coverings.

Multiple CPoint Enhancements

When you drag a routing component with multiple CPoints to create a route, you can select CPoints to include in the route from the Multiple CPoints dialog box, provided the component is set up for multiple CPoint selection.

You can also right-click a CPoint in the graphics area to add or remove it from a route.

From the Save Components to Library page of the Routing Component Wizard, you can control the treatment of multiple CPoints when creating or editing routing components. In the wizard, select Select CPoints to select which CPoints to route.
P&ID Data Import and Modeling Process

You can import a Piping and Instrumentation Diagram (P&ID) file created with an external system and use that file as a guide in building route assemblies.

To import route specifications from a P&ID file, click Piping and Instrumentation from the SolidWorks Task Pane, select the P&ID file, and click Import P&ID.

You must import the P&ID data file in .xml format. For an example, see Documents and Settings\All Users\Application Data\SolidWorks\SolidWorks Version\design library\routing\piping\pnid sample.xml. The path to the Application Data folder depends on your operating system. You must show hidden files to view this folder.

As a best practice, import schematics from a P&ID file to design a piping route:
• The piping design matches the connectivity and pipe sizes in the schematic.
• Design validation tools warn of any deviation from the schematic.

Reference Designators

You can use a component property called a Component Reference to store reference designators in an electrical harness. You can assign a different Component Reference value for each instance of a component. These references are added automatically when you import from a from-to list or a P&ID file.

You can:
• View component references in the FeatureManager design tree.
• Include component references in drawings and BOM tables.
• Select Highlight Search from the Task Pane to search for component references.

Pipe and Tube Route Export Enhancements

You can:
• Specify the file name and location for .pcf files.
• Export separate routes to different .pcf files.
• Select the assembly origin at the origin point for the .pcf file.
• Export routing components such as formed bends and penetrated pipes.

To access pipe and tube route data export options, right-click the route and select Export Pipe/Tube Data.

In addition, common component SKEY codes are supported to improve the routing of in-line fittings.

Routing Library Enhancements

New fittings, sample equipment parts, and valve components are in the Routing Library.
This chapter includes the following topics:

- Multibody Sheet Metal Parts
- Closed Corner Improvements
- Hem Improvements
- Flat Pattern Improvements
- Exporting Sheet Metal Parts to DXF or DWG Files

**Multibody Sheet Metal Parts**

SolidWorks multibody part functionality has been extended to sheet metal to allow you to create complex sheet metal designs. Multibody sheet metal parts can consist of multiple sheet metal bodies or a combination of sheet metal and other bodies such as weldment bodies.

To create a multibody sheet metal part:

- Create new bodies in an existing sheet metal part using **Base Flange**, **Convert to Sheet Metal**, **Insert Bends**, and **Lofted-Bend** commands.
- Split a single sheet metal part into multiple bodies.
- Insert one or more sheet metal, weldment, or other bodies into an existing sheet metal part.
- Duplicate a sheet metal body in a part by creating a linear or circular pattern, mirroring the body, or using the **Move/Copy Body** command.

**Cut Lists**

In the FeatureManager design tree, the main tree lists each body and its features in the order in which you add them. In addition, a cut list contains a separate representation for each body, with a flat pattern specific to the body.
Multibody sheet metal cut lists offer the same features as weldment cut lists, including the ability to automatically organize and update sheet metal bodies, and view sheet metal properties. You can use the body-related properties in bills of materials and drawings.

**Merging Sheet Metal Bodies**

You can merge sheet metal bodies of the same thickness by:

- Using the **Up to Edge and Merge** option when inserting an edge flange between two bodies with parallel linear edges.
- Using the **Merge result** option when adding a base flange that overlaps the profiles of multiple bodies with coplanar faces.

**Creating a Mirrored Sheet Metal Part**

The **Mirror Part** command now supports sheet metal parts. When you mirror a sheet metal part, a new part is created. You can copy the features of the original part to the mirrored part by breaking the link to the original part. The copied sheet metal features are added to the FeatureManager design tree of the new part.

To create a mirrored sheet metal part:

1. Open `install_dir\samples\whatsnew\Sheetmetal\corner.sldprt`.

![Image of a mirrored sheet metal part]

2. Select the **Front Plane** and click **Insert > Mirror Part**.

3. In the Insert Part PropertyManager:
   a) Under **Link**, click **Break link to original part**. The source part is visible in the graphics area.
b) Click ✓.
   The part appears in the graphics area mirrored around the plane.

c) Click ✓ to close the Locate Part PropertyManager.

4. Save the part as corner_mirrored.sldprt.

5. In the FeatureManager design tree, expand corner_Mirrored Features1.
The features of the original part are displayed and are fully editable.

   ✍ You can also access the features by expanding Cut list(1) ➢ Body-Move/Copy1.

6. Keep this part open for use in the next section.

**Inserting a Part to Create a Multibody Sheet Metal Part**

The Insert Part command now lets you create a multibody sheet metal part by inserting a sheet metal body into another sheet metal part.

When you insert a body and break the links to the source part, the resulting sheet metal body has its own sheet metal definition. You can:

- Edit the features of the body
- Give each body its own material definition and custom properties
- Isolate and flatten a selected body
- Display bodies individually in drawings

To create a multibody part by inserting a part:

1. In the Heads Up View toolbar, click View Orientation ➢ Front ➢
2. Click **Insert > Part**, select `corner.sldprt`, and click **Open**.

3. In the PropertyManager, under **Locate Part**, select **Launch move dialog**.

4. Under **Link**, select **Break link to original part**.

5. In the graphics area, move the translucent image of `corner.prt` until it aligns with `corner_mirrored.prt`.

6. Click to place the part in the graphics area and open the Locate Part PropertyManager.

**Locating the Inserted Part**

To locate the inserted part:

1. In the Heads Up View toolbar, click **View Orientation** > **Right**.
   The parts are aligned back to back.

2. To separate the parts, if the Locate Part PropertyManager opens to **Mate Settings**, click **Translate/Rotate**.
   
   ⌨️ If the PropertyManager opens to **Translate**, skip to step 3.

3. Expand **Translate**.
   You do not have to select anything in the model.

4. For **Delta Z**, type **4.00in**.
   The image of the inserted part moves four inches to the left.
5. Click ✓.

6. In the Heads Up View toolbar, click View Orientation ➔ > Isometric.

7. Save the part as corner_multipart.sldprt.

**Accessing Sheet Metal Bodies in Multibody Parts**

You can access the bodies of a multibody sheet metal part in the main FeatureManager design tree or in a cut list added to the top of the tree.

1. In the FeatureManager design tree, expand corner_Mirrored Features1 to view the features of the mirrored body, which was the original body in the part.
2. Near the top of the tree, expand the cut list [Image 1]. The cut list shows two bodies:

Body-Move/Copy1

and Body-Move/Copy2

3. Expand Body-Move/Copy1. The features listed are the same as the features under corner Mirrored Features1.

4. Right-click Body-Move/Copy1 and click Flatten [Image 2].

Body-Move/Copy1 flattens and the second body is hidden.
5. Right-click **Body-Move/Copy1** again and click **Exit Flatten** to restore the body to its folded state.

You can also click **Exit Flatten** in the Confirmation Corner.

Both bodies are visible.

6. Right-click **Body-Move/Copy2** and click **Isolate**. Only **Body-Move/Copy2** is visible.

7. In the Isolate dialog box, click **Visibility of Removed Bodies** and select **Transparent**. **Body-Move/Copy1** appears in a transparent state.

8. Click **again and click Hidden. Body-Move/Copy1** is hidden.

9. Click **Exit Isolate**. Both bodies are completely visible.

**Merging Sheet Metal Bodies by Inserting Edge Flanges**

The new **Up to Edge and Merge** option in the Edge Flange Property Manager connects two parallel edges in a multibody part. The edges must be the same thickness, part of the sheet metal part base, and must belong to different bodies. The option is available if you select a single edge under **Flange Parameters**.

The **Up to Edge and Merge** option calculates the angle between the edges automatically. You can unlock the angle to override the calculation to extend or shorten the connecting flange.

To merge the sheet metal bodies in **corner_multipart.sldprt**:

1. Click **Edge Flange** (Sheet Metal toolbar).
2. In the Edge-Flange Property Manager, under **Flange Parameters**, for **Edge**, select the outside front edge of **corner Features1**.
3. Under **Flange Length**, from the **Length End Condition** list, select **Up to Edge and Merge**.

4. For the reference edge, select the outside front edge of **corner_mirrored Features1**.

💡 You must select corresponding edges (for example, the outer edges) on both bodies for Flatten to work. To make selection easier, move over an edge and press G to magnify the area.

5. Under **Flange Position**, click **Bend Outside**.

6. Click ✔️.
   The edge flange merges the two bodies.

In the FeatureManager design tree **Cut List**, there is now only one body, **Edge-Flange6**.

7. Right-click **Edge-Flange6** and click **Flatten**.
   The merged part flattens.
8. In the Confirmation Corner, click Exit Flatten to restore the body to its folded state.

**Splitting a Sheet Metal Part**
You can now split a sheet metal part to create a multibody part. You can separately edit and flatten the bodies that are created.

You can split sheet metal parts using extruded/revolved cuts, split line, and other features that can cut a body into pieces. This example describes the use of the Split feature.

**Preparing to Split the Part**
Create the sketch to use to split the part.

To create the sketch:

1. Open `install_dir\samples\whatsnew\Sheetmetal\casing_base_part.sldprt`.

2. Click Sketch (Sketch toolbar).
3. Select the front plane.
4. Click Line > Line (Sketch toolbar).
5. In the Insert Line PropertyManager, for Orientation, select Vertical.
6. Sketch a vertical line through the midpoints of the face.
   Extend it beyond the model face.
7. Exit the sketch.

**Splitting the Part**

To split the sheet metal part:

1. Click **Insert > Features > Split**.
2. In the PropertyManager, under **Trim Tools**, select the sketch.
3. Click **Cut Part**.

4. Under **Resulting Bodies**, double-click the first body.
5. In the Save As dialog box, for **File name**, type *casing_left.sldprt* and click **Save**. The name appears in the PropertyManager and in the **Body 1** callout.

6. Repeat steps 4 and 5 to assign **Body 2** the name *casing_right.sldprt*. 
7. Click ✓.
The part now contains two sheet metal parts.

8. In the FeatureManager design tree, expand Cut list (2).
   The software names bodies in the cut list according to the last feature added to
   the body. In this case, the last feature added is the split feature. As you add
   features, the cut list names change.


10. Right-click Split1[2] and click Exit Flatten to restore the body to its folded state.
    Both bodies are visible.

**Inserting a Sheet Metal Part Using a Base Flange**
You can use the commands that create sheet metal parts to create new bodies in an
existing sheet metal part.

These include:
This procedure illustrates the use of the Base Flange/Tab command to insert a tab without merging it with another body in the part.

2. In the PropertyManager:
   a) For First Reference, select the face of the flange.
   b) Select Coincident.
   c) Click .
3. In the Heads Up View toolbar, click View Orientation > Front.
4. Extend the plane to the right.
5. Click Base Flange/Tab (Sheet Metal toolbar). A sketch opens on the plane.
6. Click Corner Rectangle (Sketch toolbar) and draw a rectangle extending from the lower corner of the flange to the right.
7. Exit the sketch.
8. In the Base Flange PropertyManager, under **Sheet Metal Parameters**, clear **Merge result**.

9. Click ✓.
   The **Base-Flange1** feature appears at the bottom of the FeatureManager design tree and in the cut list.

**Editing Sheet Metal Bodies**
In a multibody sheet metal part, you can edit a feature of an individual body by selecting the feature in the FeatureManager design tree or from the body's folder in the cut list. All the editing options are available for both selection methods.

1. Click **Edge Flange** (Sheet Metal toolbar).
2. In the PropertyManager:
   a) Under **Flange Parameters**, for **Edge**, select the right edge of the base flange.

   ![Flange Parameters Selection](image)

   b) Under **Flange Length**, set the **Length End Condition** to **Blind** and the **Length** to **35.00**.

   ![Flange Length Settings](image)

   c) Under **Flange Position**, click **Material Outside**.

   ![Flange Position Setting](image)

   d) Click ✓.

3. To edit the flange feature from the cut list, expand the cut list and expand the **Edge-Flange4** body.

4. Right-click the **Edge-Flange4** feature and click **Edit Sketch**.

5. In the graphics area, click the intersection point of the top of the edge flange and **Tab1**.
6. In the PropertyManager:
   a) Under Parameters, set the X Coordinate to 55.
   b) Click .
      The edge flange is resized.

7. Click the intersection point of the bottom of the edge flange and Tab1.
8. In the PropertyManager:
   a) Under Parameters, set the X Coordinate to 10.
   b) Click .

9. Click Exit Sketch .

Closed Corner Improvements

You can now use the existing Closed Corner command with a greater variety of sheet metal parts.

You can use the Closed Corner command to add material between sheet metal features:
• When there is a cut across flanges

• With large radius bends

• When the part is created using **Insert Bends** or **Convert to Sheet Metal**

• With faces that are part of a larger corner

The new **Automatic propagation** option controls automatic recognition of matching faces. It is enabled by default.

![Pencil icon]
If you delete a face from one of the face set selection boxes, the option turns off to let you make manual selections.

**Hem Improvements**

Improved sheet metal hem functionality lets you design more complex sheet metal parts. When you add a hem to a sheet metal part edge, you can now edit the hem profile to control the length. You can build the hem according to design requirements, even when it is not applied to the whole edge. You can also add hems to selected nonlinear edges.
You can:

1. Add hems to edges on different levels.
2. Change the size of the hem feature.

**Flat Pattern Improvements**

Graphical highlighting of self-intersecting flat patterns makes it easier to recognize areas that need improvement for manufacturing.

You can also turn off the **Normal cut** option. This minimizes the weldment gap for manufacturing of rolled sheet metal parts with cut extrudes and produces a flat pattern with different outlines for the inner and outer faces of the cut.

**Exporting Sheet Metal Parts to DXF or DWG Files**

The new DXF/DWG Output PropertyManager exports sheet metal bodies to `.dxf` or `.dwg` files. You can also export entities such as bend lines, sketches, and forming tools. A preview shows your selections and lets you remove unwanted entities such as holes or cutouts.
1. With a sheet metal part open, open the PropertyManager by doing one of the following:
   - Saving the part (File > Save As) to a .dxf or .dwg file type.
   - Right-clicking the Flat-Pattern feature and clicking Export to DXF/DWG.

2. Click Save.
   The PropertyManager appears.

3. Select the bodies and entities to export and click ✔.
   The DXF/DWG Cleanup preview window appears.

4. To remove entities, select them and click Remove Entities.

5. Cancel the preview and return to the PropertyManager if you want to make changes.
Simulation

Available in SolidWorks Premium.

The following enhancements are available in SolidWorks Simulation. Enhancements marked with (Professional) are available in SolidWorks Simulation Professional and SolidWorks Simulation Premium. Enhancements marked with (Premium) are available in SolidWorks Simulation Premium.

This chapter includes the following topics:

- SimulationXpress
- NAFEMS Benchmarks
- Simulation Interface
- Simulation Studies
- Connectors
- Mesh
- Contact
- Result Viewing

SimulationXpress

New SimulationXpress Interface

SolidWorks SimulationXpress is redesigned to reduce screen clutter, provide better guidance to new users, and allow experienced users to create simulations more quickly. The new wizard uses elements of the full Simulation Professional and Premium interface to make the transition to Simulation easier.

Click SimulationXpress Analysis Wizard or Tools > SimulationXpress and follow the prompts. The wizard interacts with Simulation interface components, such as the Simulation study tree and Property Managers, to guide you through the simulation workflow.
Optimization in SimulationXpress

After running a simulation on a body and reporting the results, SimulationXpress allows you to perform optimization.

SimulationXpress uses the New Design Study on page 162 interface with certain restrictions, so you can quickly learn to use the new design study feature. You can minimize the mass by varying one model dimension. You can define one constraint, which can be the factor of safety, maximum von Mises stress, or maximum resultant displacement.

NAFEMS Benchmarks

New National Agency for Finite Element Methods and Standards (NAFEMS) benchmarks are added for Static, Thermal, Nonlinear, Frequency, and Linear Dynamic studies.

To access the benchmarks, in the Help menu, click SolidWorks Simulation > Validation > NAFEMS Benchmarks.

Simulation Interface

Simulation Study Tree Enhancements

- Simulation study tree feature names are now more descriptive and provide more information, such as the force values and bolt types.
• When you move the cursor over a feature in the tree or its symbols in the graphics area, Simulation displays details of the feature.

• Fixture icons in the tree now indicate the type of fixture.

• You can now organize fixtures, loads, and connectors into folders.
Right-click **Connections, Fixtures, or External Loads** in the Simulation study tree and select **Create New Folder**. Drag corresponding connections, fixtures, or external loads to the folder, or right-click the folder name and select an item to create in the folder.

- In the Connectors PropertyManager, while the pushpin is active 📋, the software groups connectors that you create into a separate folder.

**PropertyManager Enhancements**

- You can now select an entity in two different selection areas of a PropertyManager. For example, when applying a force to a group of faces, you can select one of these faces as a reference geometry.

- You can select multiple features, such as connectors, to edit common input. Select several connectors of the same type, right-click, and select **Edit Definition**. Edit the properties. When you click ✅, the properties are applied in all of the selected connectors.
Simulation Studies

General Enhancements

Enhanced Auto-Recover Capability
SolidWorks backup and recover settings now apply to Simulation. You have the option
to back up and recover file information after meshing and running a study.

1. Click Options (Standard toolbar) or Tools > Options.
2. On the System Options tab, click Backup/Recover and select Save auto-recover
info after meshing and after running a simulation study.

Mesh and Solver Window Improvements
The Mesh Progress and Solver Status windows now include memory usage information.
A new, minimized Simulation study tooltip allows you to track the solver status without
having to show a separate solver window.

The Mesh Progress window shows memory usage, elapsed time, the number of components
that failed to mesh, and progress.

The redesigned Solver Status window now shows memory usage, elapsed time, solver
information, and progress, in addition to information shown in previous versions.

Move the pointer over the Simulation study tab of a running study to see the status of
the study.

Expanded Features for Simulation Advisor
The Simulation Advisor is enhanced with a new interface that interacts with the Simulation
PropertyManagers to help new users create, define, solve, and view the results of Static
studies.

Simplified and Enhanced Fatigue Study (Professional)
Fatigue study enhancements include:
• S-N material curves are now defined in the fatigue study, not in the associated studies.
  You can view other material properties in a fatigue study.
• You can now use stress results at a particular solution step from nonlinear and linear
dynamic studies.
• When creating a fatigue study, you choose constant or variable amplitude. The Change
  Event Type command is removed.
• Body icons appear in the fatigue study tree to allow you to define S-N fatigue curves.
• Damage is shown as a percentage instead of as a fraction in Damage plots.
**Fatigue Check Plot (Professional)**

The Fatigue Check plot alerts you if certain regions of your model are likely to fail due to repeated loading and unloading over infinite time. You can assess in advance the safety of your model due to fatigue, without running a fatigue study, based on results from static studies.

After you run a static study, right-click Results and select Define Fatigue Check Plot.

![Fatigue Check Plot](image)

The plot is based on a single constant-amplitude fatigue event with a fully-reversible or zero-based loading. The Fatigue Check plot shows the model in two colors:

- Blue regions indicate that the stress levels are so low that fatigue should not be a concern with the specified loading.
- Red regions indicate that the specified loading will consume a percentage of the part's life. It is recommended to run a fatigue study to assess in detail the safety of your model's design.

 pena The Fatigue Check plot is not available for composite shells or beams.

For more information about how the Fatigue Check plot is calculated, see Simulation Help: Fatigue - Check Plot.

**Simplifying Assemblies for Nonlinear Studies (Premium)**

You can simplify assemblies and multibody parts in nonlinear studies by treating selected bodies as rigid, fixing them in space, or excluding them from the analysis. These options can save you computational time when analyzing large assemblies.

In a nonlinear study tree, right-click the body and select one of the available options: Exclude from Analysis, Make Rigid, or Fix.

**New Design Study**

You can now create the Design Study to evaluate or optimize models. The new Design Study interface consolidates the earlier interfaces for optimization studies and design scenarios. You can plot the updated bodies and the calculated results for different iterations or scenarios by clicking their columns on the Results View tab.

To create a study, click Design Study (Tools toolbar) or Insert > Design Study > Add. A Design Study tab appears at the bottom of the graphics area.
You can also right-click a study tab and select **Create New Design Study**.

![Design Study Tab](image)

You can use the Design Study in SolidWorks for models without Simulation results. For example, you can minimize the mass of an assembly with density and model dimensions as the variables, and volume as the constraint.

Different sensors are available for use in Design Studies depending on your SolidWorks license and whether you are running an Evaluation study or an Optimization study.

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Evaluation</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Optimization</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Mass Properties</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Dimension</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Simulation Data</td>
<td></td>
<td></td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>

**Optimization Design Study**

To perform an optimization, on the Design Study tab, select the **Optimization** check box. If you choose to define **Variables** as a **Range** or define **Goals**, the program automatically selects the **Optimization** checkbox. In most cases, use the Variable View tab to set up the parameters for the Optimization Design Study.

![Variable View Tab](image)

Use the Table View tab to manually define certain scenarios with all discrete variables, run them, and find the optimal one among the defined scenarios.

- **Variables**: You select from a list of predefined parameters or define a new parameter by selecting **Add Parameter**. You can use all Simulation parameters and driving global variables. Define the variables as **Range**, **Discrete Values**, or **Range with Step**.
You can define a combination of discrete and continuous variables. If you define only discrete variables, the program finds the optimal scenario only from the predefined scenarios.

- **Constraints**: You select from a list of predefined sensors or define a new sensor. When using Simulation results, select the Simulation study associated with the sensor. The Design Study runs the selected Simulation studies, and tracks the sensor values for all iterations.

**Goals**: You use sensors to define the goals. You can also define exact goals, for example, a tip deflection of 1mm with cantilever length as the variable.

**Evaluation Design Study**
The module lets you evaluate certain scenarios and view their results without performing an optimization. Use the Variable View tab to allow the program to automatically define the scenarios based on all possible combinations of defined discrete variables. Use the Table View tab only to specify each scenario manually or clear certain scenarios if required before running the study.

Define the following items to set up the Evaluation Design Study:

- **Variables**: Select from a list of setup parameters or define a new parameter by selecting **Add Parameter**. Define the variables as **Discrete Values** or **Range with Step**.

  - If you select **Range**, the program uses the Optimization Design Study.

- **Constraints**: You can select from a list of predefined sensors or define a new sensor.

**Viewing the Results of the Design Study**
Click the Results View tab to see the results.

Scenarios are highlighted in different colors. Selecting a scenario on the Results View tab updates the model in the graphics window.
### Design Study Outcomes

The tables summarize the expected results for different combinations of variables and study quality.

### Optimization Design Study

<table>
<thead>
<tr>
<th>Variable Type</th>
<th>Study Quality</th>
<th>High Quality</th>
<th>Fast Results</th>
</tr>
</thead>
<tbody>
<tr>
<td>Continuous (Range)</td>
<td><strong>Operation</strong></td>
<td>Finds the optimal solution using many iterations and displays the initial scenario, the optimal scenario and all iterations.</td>
<td>Finds the optimal solution using few steps and displays the initial and optimal scenarios.</td>
</tr>
<tr>
<td></td>
<td><strong>Results</strong></td>
<td>You display the plots and updated bodies for all iterations in the Results View tab. You plot local trend graphs for variables.</td>
<td>You display the plots and updated bodies only for the optimal and initial scenarios. You plot local trend graphs for variables.</td>
</tr>
</tbody>
</table>

---

**Scenario Color**

- **Green**
  - Indicate the best or optimal scenario
  - (available only for optimization mode)

- **Red**
  - Indicates violation of one or more constraints by the scenario

- **Background color**
  - Indicates current scenario and all scenarios that are not optimal or faulty

- **Gray text with background color**
  - Indicates failure to rebuild the scenario or interpolate the results for the scenario when using a low quality study with discrete variables

You can plot simulation results on the model and display graphs depending on the combination of variables and the quality of the design study.
<table>
<thead>
<tr>
<th>Discrete Values and Range with step</th>
<th>Operation</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Calculates initial and optimal scenarios accurately, and interpolates the results for the remaining scenarios.</strong> It finds the optimal solution among the defined scenarios.</td>
<td><strong>Fully calculates the results for each scenario. It finds the optimal solution among the defined scenarios.</strong> If you use continuous variables, the program fully calculates the results for all iterations.</td>
<td><strong>You display the plots and updated bodies for all scenarios. You plot design history graphs for variables.</strong></td>
</tr>
<tr>
<td><strong>Results</strong></td>
<td>You display the plots and updated bodies for initial and optimal scenarios, and only updated bodies for the remaining scenarios. You plot design history graphs and local trend graphs for variables.</td>
<td><strong>You display the plots and updated bodies for initial and optimal scenarios. You display the plots and local trend graphs for variables.</strong> Local trend graph plots include interpolated results.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Combination of continuous and discrete</th>
<th>Operation</th>
<th>Results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Operates on a continuous space even for discrete variables while finding the optimal solution. Resolves back to the discrete space while reporting the optimal solution. Finds the optimal solution using many iterations and displays the initial scenario, the optimal scenario and all iterations.</strong></td>
<td><strong>Operates on a continuous space even for discrete variables while finding the optimal solution. Resolves back to the discrete space while reporting the optimal solution. Finds the optimal solution using few steps and displays the initial and optimal scenarios.</strong></td>
<td><strong>You display the plots and updated bodies for all iterations. You plot local trend graphs for variables.</strong> You display the plots and updated bodies only for the optimal and initial scenarios. You plot local trend graphs for variables.</td>
</tr>
</tbody>
</table>

**Evaluation Design Study**
<table>
<thead>
<tr>
<th>Variable Type</th>
<th>Study Quality</th>
<th>Fast Results</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Discrete</strong></td>
<td><strong>Operation</strong></td>
<td>Fully calculates the results for each scenario.</td>
</tr>
<tr>
<td>(Discrete Values and Range with step)</td>
<td><strong>Results</strong></td>
<td>You display the plots and updated bodies for all scenarios. You plot design history graphs for variables.</td>
</tr>
</tbody>
</table>

A gray column indicates interpolated results. To fully calculate an interpolated result, right-click its column heading and select **Run**.

Do not use continuous variables with an Evaluation Design Study, because discrete scenarios cannot be defined with a range of variable values.

**Design Study of a Knob**

You explore the new Design Study interface by solving this example. You perform an optimization of a knob to minimize its mass by defining the variables, constraints, and goals. Minimizing the mass saves the cost of the part by reducing material while meeting your validation constraints.

To see the model, open `install_dir\samples\whatsnew\Optimization\knob.sldprt`.

At each iteration of this example, the Design Study runs the Simulation study to determine the factor of safety. Click the **Ready_Torsion** study tab to review the Simulation study. The study subjects the knob to torsional loading. It applies a torque to the handle and does not allow the yellow faces to twist.
**Defining the Variables**

You can select Simulation parameters and driving global variables for **Variables**. In this example you vary different model dimensions within a certain range to optimize the mass of the knob.

To open the part and define the variables for the design study:

1. On the Optimize study tab, click Options ☰.
2. In the PropertyManager, under **Design Study Quality**, select **High quality (slower)** and click ✓.
   
The program finds the optimal solution using many steps without compromising the accuracy of the solution. See *SolidWorks Simulation Help: Design Study Outcomes*.
3. On the Variable View tab, in **Variables**, select **Rib_Thickness**.
   
The parameter represents the thickness of the three ribs defined by the **Rib4** feature. Ribs increase resistance to torsional loading, but also increase the mass of the knob.
4. For **Rib_Thickness**, select **Range**. For Min, type 1mm and for Max, type 3mm.
5. In **Variables**, select **Cut_Depth**.
   
The parameter represents the depth of the cut defined by the **Extrude3** feature. You can save mass by increasing the depth of the cut.
6. For **Cut_Depth**, select **Range**. For Min, type 1mm and for Max, type 10mm.
7. In **Variables**, select **Cyl_Ht**.
   
The parameter represents the height of the cylinder defined by the **Boss-Extrude1** feature.
8. For **Cyl_Ht**, select **Range**. For Min, type 11mm and for Max, type 15mm.

---

**Defining the Constraints and Goals**

Use sensors to define constraints and goals for the design study. You can also use driven global variables for the constraints.

1. On the Variable View tab, in **Constraints**, select **FOS**.
   
The variable uses the tracked value from the factor of safety (**FOS**) sensor in the FeatureManager design tree.
2. For **FOS**, select **Ready_Torsion**.
The design study updates the sensor value at each iteration by running the Ready_Torsion study.

3. For condition, select \textbf{is greater than} and for \textbf{Min}, type 2.
   You require the optimal knob design to carry at least two times its operational load.

4. In \textbf{Goals}, select \textbf{Mass1} from the list of sensors.

5. For \textbf{Mass1}, select \textbf{Minimize}.
   You want to reduce the mass of the knob as much as possible, without violating the constraint on the FOS.

Running the Optimization Design Study

1. Click \textbf{Run}.
   The program selects the variables using a Design of Experiments method, invokes the Simulation study at each iteration, and finds the optimal solution. See \textit{SolidWorks Simulation Help: Properties for the Optimization Design Study} for a description of the method.

2. Review \textbf{Iteration1}.
   
   \textbf{Iterations} that do not satisfy the constraints are highlighted in red. Here, FOS < 2.

   \begin{tabular}{|c|c|c|c|}
   \hline
   Rgb_Thickness & Range & Min & 1mm & Max: 3mm \\
   \hline
   Cut_Depth & Range & Min: 1mm & Max: 10mm & \\
   \hline
   Cyl_Lift & Range & Min: 11mm & Max: 15mm & \\
   \hline
   \end{tabular}

   \begin{tabular}{|c|c|c|c|c|c|}
   \hline
   Constraints & FOS & Ready_Torsion & is greater than & Min & 2 \\
   \hline
   \end{tabular}

   \begin{tabular}{|c|c|c|}
   \hline
   Goals & Mass1 & Minimize & \checkmark \\
   \hline
   \end{tabular}

3. Click the \textbf{Optimal} column highlighted in green.
   The study updates the body to correspond to the optimal variables in the graphics window.
4. Review the **Optimal** column.

<table>
<thead>
<tr>
<th>Column</th>
<th>Optimal</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ribs Thickness</td>
<td>1.11471 8mm</td>
</tr>
<tr>
<td>Out Depth</td>
<td>8.946573mm</td>
</tr>
<tr>
<td>Cyl Ht</td>
<td>11.072571mm</td>
</tr>
<tr>
<td>POS</td>
<td>200787</td>
</tr>
<tr>
<td>Mass 1</td>
<td>33.8779g</td>
</tr>
</tbody>
</table>

The initial mass of the knob was 49.8646g. The optimal mass of the knob is now 33.8779g, a reduction of 32%.

**Offsets for Composites (Premium)**

You can now control the position of a composite laminate or stack relative to its surface. Previously, while creating a model, you had to account for clearance between surfaces with different shell thicknesses, as the program always located the surface at the mid-plane of the laminate. The **Shell Definition** PropertyManager for composites now has these options:

- **Middle Surface** Positions the middle of the stack on the surface body (as in the previous release).
- **Top Surface** Positions the top of the stack on the surface body.
- **Bottom Surface** Positions the bottom of the stack on the surface body.
- **Specify Ratio** Positions the portion of the stack defined by an offset value that is a fraction of total thickness measured from the mid-surface to the reference surface. The figure shows the meaning of the negative and positive offset values.

For example, consider a hollow stepped shaft made of two different composite stacks.
Create two surfaces using the inner radius of the shaft and select the **Bottom Surface** option. This eliminates the necessity to redefine the geometry every time you change the number of layers or thickness of the laminates.

**Beams**

**Support for Beams in Nonlinear Studies (Premium)**
You can now define beams in nonlinear studies (static and dynamic) and combine them with solids and shells. Simulation supports all post-processing features and plots for beams, similar to Static studies.

**Improved Neutral Axis Detection**
Previously, the identification of neutral axes for short structural members (those with a length-to-width ratio < 3) was not always accurate. A new feature called **Define Beam Neutral Axis** lets you override the neutral axis of beams selected by the program.

To modify the direction of a beam's neutral axis, right-click the beam definition, and select **Define Beam Neutral Axis**.

Select an edge from the beam body parallel to the desired direction of the neutral axis.

**Editing Torsional Rigidity and Shear Factor for Beams**
You can now input the torsional constant and shear factor of beams that are used in calculating the torsional and shear stresses, respectively.

In the Apply/Edit Beam PropertyManager, under **Section Properties**, set the appropriate options. The torsional constant, distance for max shear stress, and shear factor depend on the shape and dimensions of the beam's cross section.

To list beam shear forces, right-click **Results** and select **Define Beam Diagrams**.

Select the shear force and its direction in **Component**.

For more information on beam properties, see *Simulation Help: Apply/Edit Beam*. 
**Beam Stiffeners for Curved Surfaces**
You can now bond beams (straight or curved) that act as stiffeners to curved surfaces of shells or sheet metal bodies.

The software automatically bonds beams to curved surfaces that have touching geometries or are situated within reasonable clearance. The program uses beam element sizes compatible with the surface mesh sizes.

The feature is available for static, frequency, and buckling studies.

**Improved Bonded Contact for Beam Stiffeners**
The accuracy of the bonded contact between faces of solids or shells and beams that act as stiffeners has been improved.

**Beam Information in Reports**
You can include beam information in reports and save beam results to an eDrawings file.

To include beam information in a report:
1. Click **Simulation > Report**.
2. In the dialog box under **Report format settings**:
   - In **Included sections**, select **Beams**.
   - Select or clear **Include beam forces** and **Include beam stresses**.
   - Select **Joints** or **Entire Length**.

To save beam results to an eDrawings file:
1. In **Results**, double-click the plot to display it.
2. In **Results**, right-click the plot and select **Save As**.
3. In **Save as type**, select **eDrawings Files (*.analysis.eprt)**.

To save all beam result plots to eDrawings files, right-click **Results** and select **Save All Plots as eDrawings**.
Connectors

Connectors Applied to Hole Series

The following enhancements are available:

• The software automatically groups connectors based on a hole series in a separate folder. Editing any one bolt in the group applies to all bolts in the series.

Create a bolt for one hole in a hole series. A dialog box opens to let you propagate the bolt to all the holes in the series. Click Yes to propagate bolts to all holes. A new folder containing the set of bolts appears in Connections.

• You can dissolve the bolt series and break the link to allow editing each feature on its own. You can restore the bolt series after you dissolve it.

To dissolve a bolt series, right-click the folder containing the series and select Dissolve Bolt Series. To restore the series, right-click the same folder and select Reestablish Bolt Series.

Bolt Connectors

Simulation selects Alloy steel from the SolidWorks Material library as bolt material by default.

Spring Connectors for Shells

You can now define a spring connector with entities (faces or edges) belonging to surfaces and sheet metal bodies. The spring connector enhancement is available for static, frequency, and buckling studies.

The figure shows a spring connection between cylindrical faces of the solid and surface bodies.

<table>
<thead>
<tr>
<th>Model (surfaces are at the ends and solid along the entire length of the cylinder)</th>
<th>Zoomed-in cross section</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Model" /></td>
<td><img src="image" alt="Zoomed-in cross section" /></td>
</tr>
</tbody>
</table>

Edge Weld Connectors (Professional)

Simulation now supports edge weld connectors between two faces. This easy-to-use connector estimates the appropriate size of a weld needed to attach two metal components. The program calculates the size of a weld at each node location along the welding edge.
Right-click **Connections** and select **Edge Weld**. Four weld types are available:

- **Fillet, Double-Sided**
- **Fillet, Single-Sided**
- **Groove, Double-Sided**
- **Groove, Single-Sided**

Set the properties of the weld connector:

- **Face for Set 1** A face of a shell or sheet metal body.
- **Face for Set 2** A face of a shell, sheet metal, or solid body.
- **Intersecting Edges** An edge that belongs to the terminated part where the welding seam is applied. The software automatically selects the welding edge for touching faces of terminated and mating parts. Otherwise, you select it manually.
- **Electrode** Material for the electrode with predefined weld strength. To specify a user-defined weld strength, select **Custom Steel** or **Custom Aluminum**.
- **Estimated weld size** Checks the adequacy of the weld connectors when viewing results.

### Viewing Results for Edge Weld Connectors

After you run a Simulation study, you can assess the adequacy of the weld connectors in bonding the selected parts. If the estimated weld size is larger than the calculated maximum weld size, the weld edge is shown in green (safe). Otherwise, the weld edge is shown in red (unsafe). The weld check plot is only available for static studies.

Right-click **Results** and select **Define Weld Check Plot**.

For more information about the check plot of edge weld connectors, see *Simulation Help: Connector - Weld Check Plot*.

You can also view weld results along the weld seam such as: weld size, weld throat size, normal force, shear-weld axis force, shear-surface normal force, and bending moment.

Right-click **Results** and select **List Weld Results**.
To graph weld size and weld throat values along the weld seam, click **Plot** (Edge-weld results PropertyManager).

![Graph showing weld size and throat values along the weld seam.]

**Bearing Connectors Between Parts**

You can now define a bearing connector between split cylindrical faces of a shaft and cylindrical or spherical faces of a housing. You can select the housing faces in the Connectors PropertyManager.

The exploded view shows the cylindrical face of a shaft connected to a spherical face of the housing.

![Exploded view showing bearing connector between shaft and housing.]

Create split faces on the shaft representing the contact areas before defining a bearing connector.

To define a bearing between the shaft and the ground, right-click **Fixtures** in the Simulation study tree and select **Bearing Support**.

**Bearing Loads for Circular Holes in Shells**

You can now define bearing forces on the following entities:
- Circular shell edges
- Cylindrical shell faces

The bearing force acts normal to the selected edges or faces and has the following distributions:
• Sinusoidal
• Parabolic

For the case shown below, the load is transferred only to the right side of the shell. Note that the applied load has a vertical component.

Mesh

Mesh Enhancements
• The curvature-based mesher supports compatible meshing between touching solid faces.
• The curvature-based mesher can check for interference between bodies before meshing. If interferences are detected, meshing stops and you can access the Interference Detection Property Manager to view the interfering parts. Make sure to resolve all interferences before you mesh again.

Interference detection is only available when you define bonded contact with compatible mesh.

• The curvature-based mesher can now mesh models with small features that previously failed to mesh.
• The mesh at the common boundary between shells and beams that acts as a stiffener is now compatible.
• The mesher’s memory usage is improved. As a result, you can generate a larger mesh with smaller element sizes than in earlier versions. The table shows a comparison of memory management for an h-adaptive analysis between the current and previous releases on a Windows XP machine with a 32-bit operating system and 3 gigabytes (GB) of physical memory.

<table>
<thead>
<tr>
<th>Release</th>
<th>Successful number of loops run</th>
<th>Degrees of freedom ($x 10^6$)</th>
<th>Solver time (in sec)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current</td>
<td>5</td>
<td>2.963</td>
<td>433</td>
</tr>
<tr>
<td>Previous</td>
<td>4*</td>
<td>1.855</td>
<td>288**</td>
</tr>
</tbody>
</table>

* Mesher aborts with insufficient memory.
** Time is shown for 4 loops.

**Shell Definition by Selection of Faces**
You can select faces of solid, sheet metal, and surface bodies to define them as shells.

- The original bodies are excluded from analysis.

Right-click on a solid, surface, or sheet metal body in the Simulation study tree and select **Define Shell by Selected Faces**.

You can:
- Mesh thin solid bodies as shells. When many thin solid bodies are in an assembly, you can save analysis time by defining them as shells. Shells are suitable for thin solid bodies, as they are two-dimensional elements.
- Create multiple shell definitions for a surface or sheet metal body. You can assign different shell thicknesses and material properties to faces that belong to the same body. You can group the faces with common properties into separate subfolders in the study tree.

The figure shows three different shell definitions created from a single surface body.

---

**Contact**

The contact workflow has changed. These changes help you intuitively set up the proper contact conditions for your model and ensure that forces are correctly transferred between components and bodies.

**Contact Set Enhancements**

- You can select contact sets (manually or automatically) and fully define their types, such as **No penetration** or **Bonded**, in a single user interface.

  Right-click **Connections** and select **Contact Set**. Under **Contact**, set the option for a manual or automatic selection.

- You can use the automatic detection tool to find contact sets for touching faces or non-touching faces within a defined clearance. You can select components, bodies, or top-level assemblies to let the program automatically find contact sets between the selected components.

- Use the new option **Find contacts with the rest of the assembly** to select a single component or body and let the program find the contact sets for touching faces of neighboring components.
Select **Automatically find contact sets** to activate this option.

- In the Simulation study tree, error icons 🚫 next to contact set definitions indicate conflicting contact sets. Move the pointer over a conflicting contact set to see the message.

New contact sets override previously defined contact sets. Resolve any conflicting contacts before running the simulation.

**Component Contact**

The **Component Contact** tool defines contact types for selected components, bodies, and top-level assemblies.

Right-click **Connections** 🔗 and select **Component Contact**. Under **Contact Type**, select the desired contact behavior.

**Component Contact** features include:

- For the **No Penetration** contact, components or bodies you select in the Component Contact PropertyManager do not penetrate each other during simulation, regardless of their initial contact condition. By default, bodies do not penetrate themselves if the deformation during simulation is sufficient to cause self-intersection.

  - The **No Penetration** component contact option is not available for nonlinear studies. Use contact set definitions to apply **No Penetration** contact between selected bodies.

- To apply a global contact behavior, select the entire assembly and set **Contact Type** to **Bonded (No clearance)**.

- The **No Contact** option overrides existing component contacts. To apply **No Contact** to components or a top-level assembly, you need to previously define a contact type.

**Contact for Nonlinear Studies (Premium)**

Enhancements include:

- The **No-penetration** and **Bonded** mortar contact options are now available for nonlinear studies. Mortar contact definitions provide continuous and more accurate stress results in regions of contacting surfaces with incompatible meshes.

- You can apply **No-penetration** contact to both sides of a shell.

- You can drag contact definitions from static studies to nonlinear studies and vice versa. Make sure that these contact definitions are available to both study types.
Result Viewing

Handling Large Results Files (Premium)
The time to load and view result plots for the first time from a linear dynamic or nonlinear dynamic study has been reduced considerably.

Plot Improvements

- You can use ksi units in stress plots.
- The units available for displacement plots match the units provided in the SolidWorks application. The units are am, nm, micron, mm, cm, m, micron, mil, in, and ft.
- You do not need to display a plot to modify the Edit Definition, Chart Options, and Settings PropertyManagers.
- Plots with floating or general values for **Number Format** now support a 1000 comma separator (,).

In the Chart Options PropertyManager, under **Position/Format**, in **Number Format**, select **floating** or **general**, and select **Use 1000 Separator (,)**.

- You can now control the width of beam plots for better visibility.

Plot Stress During Time Steps in Motion

You can compute stress, factor of safety, and deformation results on selected parts as you perform a Motion Analysis study. You can compute the finite element results at the specified time step, or the entire time range. Stress, displacement, and factor of safety results at the chosen time steps or ranges are displayed on the parts during the motion simulation.
In the Motion Analysis study, after finite element setup and analysis, click **Display Stress** and select from the list of options.

The figure shows the stress plot on a four-bar linkage mechanism at a time step during the motion simulation.
This chapter includes the following topics:

- Sketch Fillet Tool
- Fit Spline Tool
- Configurable Number of Instances in Sketch Entity Patterns
- Linking Sketch Text to File Properties
- Convert Entities Sketch Tool
- Equation-driven Curves
- Dimensions in 3D Sketches
- Large Sketch Performance

### Sketch Fillet Tool

The Sketch Fillet Tool contains numerous enhancements, including a preview mode, entity selection before and after starting the tool, and an enhanced PropertyManager.

- The fillet preview shows virtual intersections between entities, extending the entities in the preview if necessary to show fillets that are possible for the selected entities.
- You can specify multiple fillets in a single Sketch Fillet operation. Fillets are not created until you click OK in the PropertyManager.
- While previewing fillets, you can drag fillets to adjust the radius.
- You can set the fillet radius in the PropertyManager before or after selecting the entities.

### Fit Spline Tool

In the Fit Spline tool, you can now preview the spline and its inflection points, maximum curvature, and curvature comb.

In the Fit Spline PropertyManager, you can use a horizontal slider to adjust the Tolerance value. Adjusting the tolerance dynamically updates spline previews.

### Configurable Number of Instances in Sketch Entity Patterns

You can now use the Number of Instances parameter for sketch entity patterns to create configurations (for example, in design tables). This parameter can be displayed and used to change the pattern directly.

### Linking Sketch Text to File Properties

You can link sketch text to file properties using those properties to display sketch text values in the sketch and to create configurations in design tables.
In the Sketch Text PropertyManager, click **Link to Property** and then select the property in the Link to Property dialog box.

After you link the sketch text to the property, the property reference appears under **Text** in the Sketch Text PropertyManager.

If the file properties or their values are not yet specified, you can click **File Properties** in the Link to Property dialog box to specify values for existing file properties such as **Author**, **Title**, and **Subject**, or to create custom and configuration-specific properties and values.

**Convert Entities Sketch Tool**

The Convert Entities Sketch Tool has been improved to become more consistent with other sketch tools.

- There is now a Convert Entities PropertyManager.
- You are no longer required to preselect the correct entity types before starting. You can select entities after opening the PropertyManager.
- You can select multiple entities for conversion.
- You can select a face and a number of edges on the internal boundaries of that face, which are transformed into a loop and then converted into sketch entities.
- In the PropertyManager, you can specify **Select Chain**, which enables you to convert contiguous sketch entities.

**Equation-driven Curves**

You can now create parametric (in addition to explicit) equation-driven curves in both 2D and 3D sketches.

You now can drag equation-driven curves.

**Dimensions in 3D Sketches**

You can now use Smart Dimensioning to create point-to-point and Along X/Y/Z dimensions in 3D sketches and configure those dimensions.

**Large Sketch Performance**

Selecting a large number of sketch entities to create blocks is now much faster. Copy and Paste is also faster.
This chapter includes the following topics:

- SolidWorks Sustainability Overview
- Designing for Sustainability

**SolidWorks Sustainability Overview**

SolidWorks Sustainability evaluates the environmental impact of a design throughout the life cycle of a product. You can compare results from different designs to ensure a sustainable solution for the product and the environment.

Two products are available:

- **SolidWorks Sustainability Xpress**
  Handles part documents (solid bodies only) and is included in the core software.

- **SolidWorks Sustainability**
  Handles parts (solid bodies only) and assemblies. Available as a separate product. Other functionality includes configuration support, expanded reporting, and expanded environmental impact options.

To begin working with Sustainability Xpress, click one of the following:

- **Sustainability Xpress** (Tools toolbar or Evaluate CommandManager tab)
- **Tools > Sustainability Xpress**

The application opens in the Task Pane.

**Dashboard and Reports**

SolidWorks Sustainability provides real-time feedback on environmental impact factors. Results appear in the Environmental Impact Dashboard, which updates dynamically with any changes.
You can generate customizable reports to share the results.

**Life Cycle Assessment**

By integrating Life Cycle Assessment (LCA) into the design process, you can see how decisions about material, manufacturing, and location (where parts are manufactured and where they are used) influence a design’s environmental impact. You specify various parameters that SolidWorks Sustainability uses to perform a comprehensive evaluation of all the steps in a design’s life.

LCA includes:

- Ore extraction from the earth
- Material processing
- Part manufacturing
- Assembly
- Product usage by the end consumer
- End of Life (EOL) – Landfill, recycling, and incineration
- All the transportation that occurs between and within each of these steps.
**Environmental Impact Factors**

SolidWorks Sustainability assesses all the life cycle steps based on your material, manufacturing, and location input. SolidWorks Sustainability distills the results into environmental impact factors, which it measures and totals.

- **Carbon Emissions**
  Carbon dioxide and equivalents, such as carbon monoxide and methane, that are released into the atmosphere, resulting in global warming.

- **Energy Consumed**
  All forms of energy consumed over the entire life cycle of the product.

- **Air Acidification**
  Air pollution primarily due to the burning of fossil fuels, eventually leading to acid rain.

- **Water Eutrophication**
  Contamination by fertilizers that travel through rivers to coastal waters, resulting in algal blooms and the eventual killing of all sea life in certain coastal regions.

**Designing for Sustainability**

This example demonstrates using SustainabilityXpress to perform an environmental impact analysis of a part.

You analyze a common part used in computers - the drive sled that holds drives in the computer case.
Sustainability measures these areas of environmental impact:

**Carbon Footprint**  A measure of carbon dioxide and equivalents, such as carbon monoxide and methane, that are released into the atmosphere primarily by burning fossil fuels.

**Energy Consumption**  All forms of nonrenewable energy consumed over the entire life cycle of the product.

**Air Acidification**  Acidic emissions, such as sulfur dioxide and nitrous oxides, which eventually lead to acid rain.

**Water Eutrophication**  Contamination of water ecosystems by waste water and fertilizers, resulting in algae blooms and the eventual death of plant and animal life.

The software measures the environmental impact based on these parameters:

- Material used
- Manufacturing process and region
- Transportation and use region
- End of life

Follow these steps to analyze parts:

**Selecting a Material**

You start by activating the application and selecting a material.

1. Open `install_dir\Samples\WhatsNew\Sustainability\Drive Sled.sldprt`.

2. Do one of the following:
   - Click **SustainabilityXpress** (Tools toolbar or Evaluate CommandManager tab)
   - Click **Tools > SustainabilityXpress**
The application opens in the Task Pane.

3. Under **Material**:
   a) In **Class**, select **Plastics**.
   b) In **Name**, select **PC High Viscosity**.

   The software displays the part's weight. The **Environmental Impact** dashboard at the bottom of the Task Pane provides real-time feedback about the environmental impact of your design.

### Setting the Manufacturing and Use Options
Select the manufacturing process and the regions where the part is manufactured and used.

1. Under **Manufacturing**, in **Process**, select **Injection Molded**.
2. For **Region**, select **North America** on the map.

![](image1)

- On each Sustainability map, **Japan** has its own region.

![](image2)

3. Under **Transportation and Use**, for **Use Region**, select **North America**.

![](image3)

- Data is not available for all regions. Regions that contain data are highlighted when you hover over them.

### Comparing Similar Materials
Now you set the baseline material and compare it with other materials, to try to minimize the environmental impact, using the **Environmental Impact** dashboard.

1. Click **Set Baseline** at the bottom of the Task Pane.
The **Baseline** bar for each environmental impact adjusts to show the values for the selected material, **PC High Viscosity**.

Next you try to find a similar material that is a better environmental choice.

2. **Under Material**, click **Find Similar**.
   The dialog box displays the current material with values for multiple parameters.

3. **Set these values**:

<table>
<thead>
<tr>
<th>Property</th>
<th>Condition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Density</td>
<td>~ (Approximately)</td>
</tr>
<tr>
<td>Tensile Strength</td>
<td>&gt; (Greater than)</td>
</tr>
</tbody>
</table>

4. Click **Find Similar** next to the list in the dialog box.
   A list of similar materials appears. You select materials from this list to compare them to the original material. The **Environmental Impact** dashboard at the bottom of the dialog box gives you intermediate feedback on your selections.

   ✍ To filter the list, select the checkbox ✓ next to the materials to list and click **Show selected only**.

5. **Under the Materials column**, select **Acrylic (Medium-high impact)**.
   In the dialog box's **Environmental Impact** dashboard, a green bar for **Selected** appears above the black bar for **Original** for all four impact areas. The pie charts are updated.

   The bar's green color and shorter length indicate that the selected material, **Acrylic (Medium-high impact)**, is a better environmental choice than the original material, **PC High Viscosity**.

6. **Now select Nylon 101** from the list to see how it compares to the original material. The bars and pie charts are updated. The visual cues indicate that this material is an even better choice than **Acrylic (Medium-high impact)**. You decide to accept this material.

   ✍ You can modify the **Manufacturing Process** using the menu next to the pie charts.

7. **Click Accept**.
   The dialog box closes. In the Task Pane, under **Material**, **Plastics Nylon 101** is the current material. The pie charts in the **Environmental Impact** dashboard are updated.

**Setting the Material**
Now you set **Plastics Nylon 101** as your material in the model and review the results in the **Environmental Impact** dashboard.

1. **In the Task Pane, under Material**, click **Set Material**.
Nylon 101 becomes the active Material in the FeatureManager design tree. The model updates in the graphics area.

2. Hover over the pieces of the pie charts. The pie chart colors represent the parameters used to measure the environmental impact.

The size of the pieces represent the percentage contributed by the parameters to the total environmental impact.

3. Click and at the bottom of the Task Pane to scroll through detailed reports of the selected material's environmental impact on carbon, energy, air, and water.

Creating a Report
You can create a report that provides details about the environmental impact of your design, including comparisons between the final material and the baseline material.

1. Click Generate Report at the bottom of the Task Pane. The report opens as a separate document.

2. Scroll through the document and note the detailed information about each type of environmental impact. Links after each section bring you to the SolidWorks Sustainability web site where you find more information about this product.

3. Save the report.

4. Save the model and click to close the Sustainability Task Pane. The software saves the results with the model.
SolidWorks Utilities

Available in SolidWorks Professional and SolidWorks Premium.

This chapter includes the following topics:

- **Compare BOM Utility**
- **Simplify Utility**
- **Usability Improvements**

**Compare BOM Utility**

The new **Compare BOM** utility compares Bill Of Material (BOM) tables from two SolidWorks assembly or drawing documents.

The results list missing columns and rows, extra columns and rows, and failed rows.

To access this utility, click **Tools > Compare > BOM**. You can also select **Bill of Materials** under **Items to compare** from any Compare Task Pane.

For more information about the **Compare BOM** utility, see *SolidWorks Help: Viewing Compare Results*.

**Simplify Utility**

When you unsuppress a feature, the new **Unsuppress child features** option lets you unsuppress its child features.

**Usability Improvements**

The user interface for SolidWorks Utilities is now fully integrated into regular toolbars and menus of the SolidWorks software. The user interface has also been remodeled to improve usability.

When you select a related command, the add-in loads dynamically if you have installed it and are running SolidWorks Professional or SolidWorks Premium.

- All Compare utilities are combined into one Task Pane: Compare Documents, Compare Features, Compare Geometry, and Compare Bill of Materials.
- Find/Modify/Suppress Features are combined into one Task Pane.
- You can more easily recompare results because you no longer need to switch between input and result panes.
- The user interface resizes better when you resize the Task Pane.
- Window tiling has been improved when you display results.
- The look and feel of the **Results** list is more consistent with the SolidWorks FeatureManager design tree.

To access utilities, click a utility from the Tools toolbar or **Tools** menu.
Available in SolidWorks Professional and SolidWorks Premium.

This chapter includes the following topics:

- Toolbox and Enterprise PDM Integration
- Australian Standard
- Toolbox Custom Properties

**Toolbox and Enterprise PDM Integration**

Enterprise PDM can now fully manage SolidWorks Toolbox.

For details, see Enterprise PDM and Toolbox Integration on page 99.

**Australian Standard**

Toolbox now includes the Australian standard. Additionally, each size of the structural members from the Australian standard is published as a weldment profile, which you can download from SolidWorks Content in the Design Library task pane.

From the SolidWorks menu, click Toolbox > Configure. From the Toolbox configuration tool, click **1. Select your hardware** and select AS.

**Toolbox Custom Properties**

Toolbox provides more control over custom properties.

**Custom Property Visibility in the PropertyManager**

You can now control whether a custom property appears in the component PropertyManager in SolidWorks. Previously, custom properties always appeared in the PropertyManager.

From the SolidWorks menu, click Toolbox > Configure. From the Toolbox configuration tool, click **2. Customize your hardware**. Under Custom Properties, click Add new Custom Property 📚 or select a custom property and click Modify Custom Property 🛠️. In the Custom Property Definition dialog box, select or clear Show in PropertyManager.

**Single Part Number per Component Size**

For components with editable length properties, you can now specify a single part number for a component size regardless of length. Previously, you had to specify a part number for each length.
From the SolidWorks menu, click **Toolbox > Configure**. From the Toolbox configuration tool, click **2. Customize your hardware**. Select a component that has an editable length property, such as structural steel. Select or clear **Use single Part Number per size, regardless of length**.

**Configuration-specific Properties in the Configurations Table**

Configuration-specific text properties now appear in the table of configurations. You can type values directly in the table or export the table to Microsoft Excel. Previously, you could only enter values from the SolidWorks PropertyManager.

From the SolidWorks menu, click **Toolbox > Configure**. From the Toolbox configuration tool, click **2. Customize your hardware**. Under **Custom Properties**, click **Add new Custom Property**. In the Custom Property Definition dialog box, define a Textbox custom property, select **Add as configuration specific property**, and click **OK**. Under **Custom Properties**, select the new custom property. The property appears as a column in the configuration table and you can type values.

**Custom Property Creation**

You can now create custom properties that are not configuration-specific in Toolbox. In prior releases, you had to create custom properties manually by opening the Toolbox file in SolidWorks.

From the SolidWorks menu, click **Toolbox > Configure**. From the Toolbox configuration tool, click **2. Customize your hardware**. Under **Custom Properties**, click **Add new Custom Property**. In the Custom Property Definition dialog box, define a Textbox or List custom property, clear **Add as configuration specific property**, and click **OK**. Apply this custom property to a folder or individual component.

To see custom properties in SolidWorks, open the part and click **File > Properties**. Custom properties appear on the Custom tab of the Summary Information dialog box.

*Custom properties are added when a new configuration is created (or a copied part is generated).*
This chapter includes the following topics:

- DimXpert

**DimXpert**

**New Feature Recognition**
The following features are now recognized by DimXpert tools.

**Intersect Circles**
An intersect circle is a circle derived at the intersection of a cone and plane. To show the reference circle created by DimXpert, click **View > Curves**.

**Patterns of Boss Features**
DimXpert supports dimensioning and tolerancing of patterns of boss features.
Patterns of Cone Features
Patterns of cones are supported as long as the included angle is the same.

Patterns of Width Features
Use the Pattern Feature tool to recognize width features.
Auto Dimension Scheme

Polar Plus and Minus Dimension Schemes

You can use Auto Dimension Scheme to apply polar plus and minus dimension schemes. Use the polar dimension scheme to apply DimXpert patterns with axial features to define a bolt circle. In the Auto Dimension Scheme PropertyManager, set the Minimum number of holes to recognize as a pattern.

Dimension Layout

When you use Auto Dimension Scheme, the layout of dimensions has been improved to account for the sketch direction.

The example below is the same part, but each sketch is extruded along a different axis:

<table>
<thead>
<tr>
<th>X-axis</th>
<th>Y-axis</th>
<th>Z-axis</th>
</tr>
</thead>
</table>

Location Dimensions

You can apply location dimensions between pairs of axes and lines that are skew (non-intersecting and non-parallel).

Supported feature types include cylinders, simple holes, counterbore holes, countersink holes, cones, slots, and intersect lines.
This chapter includes the following topics:

- Cut List Items
- Drawing Views of Weldments
- Materials in Cut Lists
- Property Tab Builder

Cut List Items

The Cut-List Properties dialog box is enhanced for ease of use and efficiency:

- Select a **Cut-List-Item** in the dialog box, and the entities in the folder are highlighted in the graphics area.
- Modify a **Value / Text Expression**, and the **Evaluated Value** updates.
- The dialog box contains three tabs to manage, edit, and view all **Cut-List-Item** properties:

  - **Cut List Summary** Manages a cut list, letting you navigate to any of the **Cut-List-Item** folders. In previous versions, you could edit only one **Cut-List-Item** at a time. You can now manage all **Cut-List-Items** from one dialog box.

  - **Properties Summary** Shows the unique **Cut-List-Item** properties in a weldment part. Click each property to display the property's value for every item in the cut list. If a **Cut-List-Item** does not have a unique property assigned, it appears as **<Not Specified>**.

  - **Cut List Table** Shows a preview of how the cut list will look in a drawing.

To display the Cut-List Properties dialog box, right-click the cut list folder and select **Properties**.

Drawing Views of Weldments

You can link a drawing view to a cut list table to control the information displayed in balloons, even if the view references a different configuration than the cut list. In the Drawing View Properties dialog box, under **Balloons**, you can select any of the cut list tables associated with the model.

See *SolidWorks Help: Drawing View Properties.*

Materials in Cut Lists

Weldment cut lists recognize materials when determining whether bodies are identical.
When you create a weldment part, the cut list includes **Material** as a property that links to the material applied to the body.

If two bodies are geometrically identical but have different materials applied to them, they are placed in separate folders in the cut list. When you apply a material to a body, the cut list automatically updates by placing the body in the appropriate folder.

*See SolidWorks Help: Weldment Cut Lists.*

**Property Tab Builder**

You can use Property Tab Builder to create custom properties tabs for Weldment cut list items.
This chapter includes the following topics:

- Support for Virtual Components in SolidWorks Explorer
- Support for the /3GB Switch

Support for Virtual Components in SolidWorks Explorer

The SolidWorks Explorer Rename Document and Replace Document dialog boxes can display virtual components and update their reference paths. Because including virtual components degrades performance, you can choose to include virtual components during rename and replace operations.

You cannot manage virtual components in a Workgroup PDM vault. The check-in operation is disabled for virtual components.

In SolidWorks Explorer, on the File Explorer tab in the left pane, select a document and click SolidWorks Rename or SolidWorks Replace on the Mini Toolbar. In the Rename Documents or Replace Documents dialog box, select Include virtual components.

You can also display virtual components in the Where Used tab. Click Options (SolidWorks Explorer toolbar). On the References/Where Used tab, under Look for, select Virtual components.


Support for the /3GB Switch

Workgroup PDM now supports the Microsoft Windows /3GB switch. Consider using this switch for large vaults.

For details about the /3GB switch, visit the Microsoft website:
http://www.microsoft.com/whdc/system/platform/server/PAE/PAEmem.mspx