What's New
SOLIDWORKS 2011

Image courtesy of ABCO Automation, Inc.
Contents

What’s New: Highlights of SolidWorks 2011.................................................................................................................ix
Legal Notices........................................................................................................................................................................11

1 User Interface........................................................................................................................................................................13
  SolidWorks Search......................................................................................................................................................................13
  Save As and File Properties Buttons on Standard Toolbar ................................................................................................13
  PropertyManager Icons...............................................................................................................................................................13
  Error Reporting............................................................................................................................................................................14

2 SolidWorks Fundamentals..................................................................................................................................................15
  Application Programming Interface................................................................................................................................................15
  Pack and Go..................................................................................................................................................................................16
  Documentation............................................................................................................................................................................16
    New Tutorials............................................................................................................................................................................16
    Toolbox Administration Overview.............................................................................................................................................16

3 3D ContentCentral...............................................................................................................................................................17
  Defeature Tool..............................................................................................................................................................................17
  Configuration Publisher...............................................................................................................................................................17
  3D ContentCentral for Suppliers................................................................................................................................................17

4 Administration.......................................................................................................................................................................19
  Converting Files to SolidWorks 2011...........................................................................................................................................19
  Installation Improvements...........................................................................................................................................................19
  SolidWorks Rx.............................................................................................................................................................................21
    Diagnostics................................................................................................................................................................................21
    Usability and Workflow Improvements..................................................................................................................................21
    Hardware Benchmarks...............................................................................................................................................................22
    Graphics Card Health Checker..................................................................................................................................................22

5 Assemblies............................................................................................................................................................................23
  Assembly Features.........................................................................................................................................................................23
    Fillets and Chamfers.................................................................................................................................................................23
    Weld Beads ..................................................................................................................................................................................23
  Assembly Visualization.................................................................................................................................................................24
  Defeature for Assemblies ............................................................................................................................................................25
    Defeature - Step 1: Components...................................................................................................................................................25
    Defeature - Step 2: Motion.............................................................................................................................................................26
    Defeature - Step 3: To Keep.........................................................................................................................................................26
    Defeature - Step 4: To Remove...................................................................................................................................................27
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defeature - Feature Removal Complete .........................................................</td>
</tr>
<tr>
<td>Equations ........................................................................................................</td>
</tr>
<tr>
<td>Interference Detection ...................................................................................</td>
</tr>
<tr>
<td>Ignore Hidden Bodies ......................................................................................</td>
</tr>
<tr>
<td>Quality and Performance ...............................................................................</td>
</tr>
<tr>
<td>Mates .............................................................................................................</td>
</tr>
<tr>
<td>Replace Mate Entities ....................................................................................</td>
</tr>
<tr>
<td>Mates in Motion ............................................................................................</td>
</tr>
<tr>
<td>Rebuild Report .............................................................................................</td>
</tr>
<tr>
<td>SpeedPak .......................................................................................................</td>
</tr>
<tr>
<td>6 CircuitWorks ...............................................................................................</td>
</tr>
<tr>
<td>User-Defined Coordinates for Component Orientation ......................................</td>
</tr>
<tr>
<td>Interface Improvements ..................................................................................</td>
</tr>
<tr>
<td>Workflow Improvements ..................................................................................</td>
</tr>
<tr>
<td>Comparing Boards ...........................................................................................</td>
</tr>
<tr>
<td>Export to PADS PowerPCB Format ...................................................................</td>
</tr>
<tr>
<td>7 Configurations .............................................................................................</td>
</tr>
<tr>
<td>Configuration Publisher ..................................................................................</td>
</tr>
<tr>
<td>3D ContentCentral .........................................................................................</td>
</tr>
<tr>
<td>Parent/Child Relationships ............................................................................</td>
</tr>
<tr>
<td>Modify Configurations ....................................................................................</td>
</tr>
<tr>
<td>Parameters .....................................................................................................</td>
</tr>
<tr>
<td>SpeedPak .......................................................................................................</td>
</tr>
<tr>
<td>8 Design Checker ............................................................................................</td>
</tr>
<tr>
<td>Design Checker Standards from SolidWorks Files ............................................</td>
</tr>
<tr>
<td>File Location Check .......................................................................................</td>
</tr>
<tr>
<td>Dimension Precision Check ............................................................................</td>
</tr>
<tr>
<td>Feature Positioning Check .............................................................................</td>
</tr>
<tr>
<td>Standard Template Check ..............................................................................</td>
</tr>
<tr>
<td>Design Checker Report ...................................................................................</td>
</tr>
<tr>
<td>Summary Report for Task Scheduler ...............................................................</td>
</tr>
<tr>
<td>Design Checker Task in Enterprise PDM ..........................................................</td>
</tr>
<tr>
<td>9 DFMXpress ....................................................................................................</td>
</tr>
<tr>
<td>Injection Molding ...........................................................................................</td>
</tr>
<tr>
<td>Running an Injection Molding Check ..............................................................</td>
</tr>
<tr>
<td>10 Drawings and Detailing ..............................................................................</td>
</tr>
<tr>
<td>Alignment Options for Dimension Palette ......................................................</td>
</tr>
<tr>
<td>Auto Arrange Dimensions .............................................................................</td>
</tr>
<tr>
<td>Using Auto Arrange Dimensions .................................................................</td>
</tr>
<tr>
<td>Adjusting Spacing ..........................................................................................</td>
</tr>
<tr>
<td>Bounding Box for Sheet Metal ........................................................................</td>
</tr>
</tbody>
</table>
Contents

Cut List Properties in Drawings.................................................................52
Center Marks in Assembly Drawings..................................................52
Cosmetic Threads..................................................................................53
Display Scale in Orthogonal Views....................................................54
Drawing Sheet Format..........................................................................54
Dual Dimensions for Chamfers............................................................54
Hide Bodies in Drawing View..............................................................55
  Hiding a Body..................................................................................55
  Showing a Body..............................................................................55
Hole Tables..........................................................................................55
  Tags............................................................................................55
Dual Unit Support................................................................................56
Merge and Unmerge Cells in Tables..................................................56
Notes..................................................................................................57
  Fit Text in Notes............................................................................57
  Pattern Notes...............................................................................57
Show Dimension Units.........................................................................58
Show Model Colors in Drawings.......................................................58
GB Drafting Standard..........................................................................59
ANSI Drafting Standard.....................................................................59
  Datum Feature Symbols...............................................................59
  Geometric Tolerance Symbols....................................................60
3D Drawing Views..............................................................................61

11 DriveWorksXpress........................................................................62
  Task Pane Interface.......................................................................62

12 eDrawings......................................................................................63
  Display Enhancements..................................................................63
  File Synchronization....................................................................63
  Triad Manipulation.......................................................................63
  Filtering by Component Name.....................................................63
  Native 64-Bit Support..................................................................64

13 Enterprise PDM............................................................................65
  File Explorer and SolidWorks Add-in.............................................65
    Enterprise PDM Menus...............................................................65
    Expanded Search Capability.....................................................67
    Expanded File Open Capabilities.............................................67
    Updating Broken File References...........................................68
    Saving eDrawings Markup Files..............................................68
    Restoring Files from Cold Storage..........................................69
    Creating Submenus..................................................................69
  Administration Tool.....................................................................70
  Collecting Support Information..................................................70
Contents

18 Mold Design.................................................................96
     Manual Mode for Creating Parting Surfaces..................96

19 Motion Studies............................................................98
     Function Builder for Force and Motor Functions............98
     User Interface Changes.............................................99
     Reflected Load Inertia and Reflected Load Mass.............99
     Reference Components for Linear Couplers..................99
     Motion Along a Path..................................................100

20 Parts and Features.......................................................101
     Parts...........................................................................101
     Defeature for Parts....................................................101
     Equations.....................................................................101
     Global Variables.......................................................106
     Features.......................................................................107
     Helix...........................................................................107
     Revolve.......................................................................108
     Scale...........................................................................109
     Surfaces.......................................................................109
     Surface Extrudes From a 2D or 3D Face.........................109
     Capping an Extruded Surface.......................................115
     FeatureWorks..............................................................115
     Bosses and Cuts Recognition.......................................115
     Automatic Recognition of Draft Features........................118
     Combining Like Features During Automatic Feature Recognition..................118

21 Routing.........................................................................120
     Routing Library Manager............................................120
     Route Along Existing Geometry...................................121
     Weld Gaps....................................................................121
     Autosize.......................................................................122
     Moving and Rotating a Fitting......................................122
     P&ID Import.................................................................123
     P&ID Report.................................................................123
     Routing Options in Isolate............................................123

22 Sheet Metal....................................................................125
     Bend Calculation Tables...............................................125
Contents

Convert to Sheet Metal.................................................................125
Flat Patterns..................................................................................127
K-Factor in Configurations............................................................127
Mapping Bend Directions When Exporting to DXF/DWG Files........128
Mirroring Edge Flanges and Miter Flanges.................................128
Sheet Metal Properties.................................................................128
Patterns of Edge Flanges and Tab Features.................................129
New Simulation Studies...............................................................130
  New 2D Simplification Study (Professional)..............................130
  New Response Spectrum Analysis Study (Premium)..................139
Interface......................................................................................144
  Organization of Bodies.............................................................144
  Filtering the Simulation Study Tree..........................................144
  Display Enhancements for Simulation Studies..........................146
  Display of Simulation Symbols...............................................146
  Expressions in Input Fields......................................................146
Shells.........................................................................................146
  Offsets for Shells...................................................................146
  Ply Orientation in Composites (Premium).................................147
  Composite Stack Information (Premium).................................148
Beams.........................................................................................149
  Non-uniform and Partial Loading of Beams..............................149
  Tapered Beams......................................................................150
Connectors..................................................................................151
  European Standard for Edge Welds (Professional)....................151
Contact.......................................................................................152
  Automatic Option for Simplified Bonding...............................152
Mesh.........................................................................................152
  Mesh Enhancements...............................................................152
Nonlinear Studies......................................................................152
  Improved Accuracy for Nonlinear fixtures (Premium)...............152
Results.......................................................................................152
  Nonlinear Plots (Premium)......................................................152
  Heat Power and Heat Energy..................................................153
  Interaction with List Result Tables.........................................153
  Probe Callout Enhancements..................................................153
  Sensors for Transient Studies................................................155
  Study Reports.........................................................................155
New Simulation Studies...............................................................130
  New 2D Simplification Study (Professional)..............................130
  New Response Spectrum Analysis Study (Premium)..................139
Interface......................................................................................144
  Organization of Bodies.............................................................144
  Filtering the Simulation Study Tree..........................................144
  Display Enhancements for Simulation Studies..........................146
  Display of Simulation Symbols...............................................146
  Expressions in Input Fields......................................................146
Shells.........................................................................................146
  Offsets for Shells...................................................................146
  Ply Orientation in Composites (Premium).................................147
  Composite Stack Information (Premium).................................148
Beams.........................................................................................149
  Non-uniform and Partial Loading of Beams..............................149
  Tapered Beams......................................................................150
Connectors..................................................................................151
  European Standard for Edge Welds (Professional)....................151
Contact.......................................................................................152
  Automatic Option for Simplified Bonding...............................152
Mesh.........................................................................................152
  Mesh Enhancements...............................................................152
Nonlinear Studies......................................................................152
  Improved Accuracy for Nonlinear fixtures (Premium)...............152
Results.......................................................................................152
  Nonlinear Plots (Premium)......................................................152
  Heat Power and Heat Energy..................................................153
  Interaction with List Result Tables.........................................153
  Probe Callout Enhancements..................................................153
  Sensors for Transient Studies................................................155
  Study Reports.........................................................................155
24 Sketching..............................................................................158
  Grid System..........................................................................158
25 Sustainability.......................................................................160
SolidWorks® 2011 includes many enhancements and improvements, most in direct response to customer requests. This release focuses on the following themes:

- Design faster and more efficiently
- Improved collaboration and visualization
- Enhanced support for manufacturing

**Top Enhancements**

The top enhancements for SolidWorks 2011 provide improvements to existing products and innovative new functionality. Throughout this guide, look for the symbol in these areas:

**Assemblies**
- Fillets and Chamfers on page 23
- Weld Bead Display on page 165
- Defeature for Assemblies on page 25

**Drawings and Detailing**
- Alignment Options for Dimension Palette on page 43
- Auto Arrange Dimensions on page 49
- Dual Unit Support on page 56
- Weld Support in Drawings on page 169

**Enterprise PDM**
- Enterprise PDM Menus on page 65

**Model Display**
- DisplayManager on page 86
- PhotoView 360 on page 90

**Parts and Features**
- Defeature for Parts on page 101
- Sharing Equations Among Models on page 101
- Suppression States of Features and Components on page 103
For More Information

Use the following resources to learn about SolidWorks:

**What's New in PDF and HTML**
This guide is available in PDF and HTML formats. Click:
- **Help > What's New > PDF**
- **Help > What's New > HTML**

**Interactive What's New**
In SolidWorks, click the symbol to display the section of this manual that describes an enhancement. The symbol appears next to new menu items and the titles of new and changed PropertyManagers.

To enable Interactive What’s New, click **Help > What's New > Interactive**.

**What's New Examples**
What's New Examples are updated at every major release to provide examples of how to use most top enhancements in the release.

To open What's New Examples click **Help > What's New > What's New Examples**.

**Online Help**
Contains complete coverage of our products, including details about the user interface, samples, and examples.

**Release Notes**
Provides information about late changes to our products.
© 1995-2010, Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes S.A. company, 300 Baker Avenue, Concord, Mass. 01742 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of the license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the license agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of any terms, including warranties, in the license agreement.

**Patent Notices**

SolidWorks® 3D mechanical CAD software is protected by U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; and foreign patents, (e.g., EP 1,116,190 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

**Trademarks and Product Names for SolidWorks Products and Services**

SolidWorks, 3D PartStream.NET, 3D ContentCentral, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.

CircuitWorks, Feature Palette, FloXpress, PhotoWorks, TolAnalyst, and XchangeWorks are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of Geometric Ltd.


Other brand or product names are trademarks or registered trademarks of their respective holders.

**COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY**

U.S. Government Restricted Rights. Use, duplication, or disclosure by the government is subject to restrictions as set forth in FAR 52.227-19 (Commercial Computer Software - Restricted Rights), DFARS 227.7202 (Commercial Computer Software and Commercial Computer Software Documentation), and in the license agreement, as applicable.

Contractor/Manufacturer:
Copyright Notices for SolidWorks Standard, Premium, Professional, and Education Products

Portions of this software © 1986-2010 Siemens Product Lifecycle Management Software Inc. All rights reserved.

Portions of this software © 1986-2010 Siemens Industry Software Limited. All rights reserved.

Portions of this software © 1998-2010 Geometric Ltd.

Portions of this software © 1996-2010 Microsoft Corporation. All rights reserved.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001 - 2010 Luxology, Inc. All rights reserved, Patents Pending.

Portions of this software © 2007 - 2010 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more copyright information, in SolidWorks see Help > About SolidWorks.

Copyright Notices for SolidWorks Simulation Products

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2007 Computational Applications and System Integration, Inc. All rights reserved.

Copyright Notices for Enterprise PDM Product

Outside In® Viewer Technology, © Copyright 1992-2010, Oracle
© Copyright 1995-2010, Oracle. All rights reserved.

Portions of this software © 1996-2010 Microsoft Corporation. All rights reserved.

Copyright Notices for eDrawings Products

Portions of this software © 2000-2010 Tech Soft 3D.

Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.

Portions of this software © 1998-2001 3Dconnexion.

Portions of this software © 1998-2010 Open Design Alliance. All rights reserved.

Portions of this software © 1995-2009 Spatial Corporation.

This software is based in part on the work of the Independent JPEG Group.
User Interface

This chapter includes the following topics:

- **SolidWorks Search**
- **Save As and File Properties Buttons on Standard Toolbar**
- **PropertyManager Icons**
- **Error Reporting**

**SolidWorks Search**

New search modes have been added to SolidWorks® Search. In addition to searching for files and models, you can search SolidWorks Help, the Knowledge Base, or the community forums.

On the Menu Bar, in the SolidWorks **Search** box, select the location to search and type the text to search for.

*See SolidWorks Help: Search.*

**Save As and File Properties Buttons on Standard Toolbar**

The Standard toolbar now has two new buttons, Save As and File Properties. Use **Tools > Customize > Commands** to add the buttons to a toolbar or the CommandManager.

*See SolidWorks Help: Customize Tool Buttons.*

**PropertyManager Icons**

Icons for labels and buttons in PropertyManagers and dialog boxes are updated for greater consistency with toolbar and FeatureManager design tree icons.
Error Reporting

The SolidWorks Error Report dialog box now allows SolidWorks® to gather more information about why the software stopped responding.

The dialog box lets you do the following:

- Send a failure report to SolidWorks.
- Include a short description of your actions when the application stopped responding.
- Indicate whether this is a new problem or is similar to a previous problem. This information helps SolidWorks Engineering identify stability trends.
- Preview the contents of the report to send to SolidWorks.
- View the SolidWorks data privacy policy. The reports are confidential, subject to this policy.

To send reports to SolidWorks for every failure, select Enable performance feedback in Tools > Options > General.
This chapter includes the following topics:

- Application Programming Interface
- Pack and Go
- Documentation

Application Programming Interface

Major enhancements are new interfaces, methods, properties, and delegates.

You can now:

- Display .NET controls in the SolidWorks user interface
- Access Pack and Go
- Get data objects containing curve, spline, and surface parameter properties
- Manage line styles in drawings
- Get the contents of folders in the FeatureManager design tree
- Create flyout groups in the CommandManager
- Convert draft quality drawing views to high quality
- Access a ray-trace rendering engine, such as PhotoView 360, and its options
- Determine whether the current sketch is a boundary box
- Get the direction of a bend line
- Get the boundary-box sketch display data of a flat-pattern drawing view
- Add and delete material from specific display states in the active configuration of a model
- Add a standard SolidWorks or custom button to the Task Pane
- Get the name of the active PropertyManager page
- Get custom and stock render references for a model
- Get whether a command or PropertyManager page is active
- Add a line to a C# or VB.NET macro and to the SolidWorks journal file
- Send notification:
  - Before a command or PropertyManager page executes or opens
  - When a BOM or general table is inserted in an assembly, drawing, or part document
  - After an entity is selected in a part, assembly, or drawing document
- Use Design Checker to:
  - Build checks from existing SolidWorks documents, templates, and drawing standards
  - Check against an existing file
  - Get summary results and save its report in Microsoft Word format

Click Help > API Help > SolidWorks API Help > SolidWorks APIs > Release Notes.
Pack and Go

New options on the Pack and Go dialog box let you save system-provided and custom decals, appearances, and scenes associated with the model.

The options are:

- Include default decals, appearances and scenes
- Include custom decals, appearances and scenes

💡 As an alternative to Pack and Go, go to Tools > Options > Document Properties > Model Display and select Store Appearance, Decal and Scene data in model file.

Documentation

New Tutorials

SolidWorks® 2011 includes the following tutorials: Assembly Visualization, Event-based Motion Studies, Mouse Gestures, and SustainabilityXpress.

To access these tutorials:

1. Click Help > SolidWorks Tutorials.
2. Click one of the following:
   - All SolidWorks Tutorials (Set 1)
   - All SolidWorks Tutorials (Set 2)
3. Select a new tutorial from the list.

Toolbox Administration Overview

SolidWorks Help contains new Toolbox administration information.

See SolidWorks Help: Toolbox Administration Overview.
This chapter includes the following topics:

- **Defeature Tool**
- **Configuration Publisher**
- **3D ContentCentral for Suppliers**

### Defeature Tool

Use the SolidWorks® **Defeature** tool to remove details from a part or assembly and save the results to a new file in which the details are replaced by dumb solids (that is, solids without feature definition or history). You can then share the new file without revealing all the design details of the model. For more information, see **Defeature for Parts** on page 101.

### Configuration Publisher

**Multiple Parent/Child Control**

The Configuration Publisher offers more flexibility when defining data parents for controls. You can define parents explicitly, and multiple parents are allowed. You no longer automatically inherit grandparents (that is, the parents of controls which you have specified as parents). See **Parent/Child Relationships** on page 37.

**Model Tests**

You can test the health of models before uploading them to 3D ContentCentral®. A sample of possible configurations is tested. Results are reported in a log file that lists the configurations that were tested and whether they rebuilt successfully. See **Model Tests** on page 37.

### 3D ContentCentral for Suppliers

**Supplier Services** introduces new self-service publishing capabilities for industrial component suppliers.

**Part Numbers**

Suppliers can use the Configuration Publisher to generate part numbers for a configurable model, and users can search for models by part number on 3D ContentCentral. See **Part Numbers** on page 36.
Model Health
Suppliers can test configurable models for Model Health in SolidWorks before uploading them to 3D ContentCentral. See Model Tests on page 37.

Defeature Tool
Suppliers can enable the rules they have defined in SolidWorks to remove details from configurable models prior to download. See Defeature for Parts on page 101.
This chapter includes the following topics:

- **Converting Files to SolidWorks 2011**
- **Installation Improvements**
- **SolidWorks Rx**

### Converting Files to SolidWorks 2011

Opening a SolidWorks® document from an earlier release can take extra time. After you open and save a file, subsequent opening time returns to normal.

You can use the SolidWorks Task Scheduler (SolidWorks Professional) to convert multiple files from an earlier version to the SolidWorks 2011 format. Click **Windows Start > All Programs > SolidWorks 2011 > SolidWorks Tools > SolidWorks Task Scheduler**.

In the Task Scheduler:
- Click **Convert Files** and specify the files or folders to convert.
- For files in a SolidWorks Workgroup PDM vault, use **Convert Workgroup PDM Files**.

For files in a SolidWorks Enterprise PDM vault, use the utility provided with Enterprise PDM.

⚠️ After you convert files to SolidWorks 2011, you cannot open them in older versions of SolidWorks.

### Installation Improvements

SolidWorks Installation Manager and the installation process have significant improvements.

#### License Activation

SolidWorks License Activation is enhanced.
- You can activate and transfer licenses for multiple serial numbers in a single step.
- You can transfer a license from a computer even if SolidWorks is no longer installed on that computer. You can download and run SolidWorks Activation Wizard from the SolidWorks customer portal to transfer the license.

#### SolidNetWork License Manager

SolidNetWork License Manager is enhanced.
- The display of borrowed licenses is improved.
- The list of product licenses available to borrow now shows only what has been purchased and is available on the SolidNetWork License Manager.
- Borrowing a SolidWorks package license now automatically borrows the pre-requisite SolidWorks Standard license.
- You can update SolidNetWork License Manager to a new version using SolidWorks Installation Manager, rather than removing the previous version and then installing the new one.

### Installation Manager

SolidWorks Installation Manager is enhanced.

- You can specify which languages to include in the SolidWorks product installation, rather than installing all languages. English is always installed, even if you do not specify it during installation.

> The **Languages** specification in the **Product Summary** applies only to the SolidWorks product installation. It does not apply to other product installations such as SolidWorks eDrawings®, SolidWorks Workgroup PDM, and SolidWorks Explorer, which install all languages.

- The Workgroup PDM and SolidNetWork License Manager installations are more integrated into the SolidWorks Installation Manager workflow.
- You can create 32-bit and 64-bit administrative images on both 32-bit and 64-bit operating systems. For example, you can:
  - Create a 32-bit image on a 64-bit operating system
  - Create a 64-bit image on a 32-bit operating system
  - Create 32-bit and 64-bit images on the same operating system

### Administrative Image Option Editor

The interface and workflow for SolidWorks Administrative Image Option Editor are enhanced.

- The Option Editor opens automatically after SolidWorks Installation Manager creates the administrative image.
- You can manage both 32-bit and 64-bit administrative images using the same Option Editor on either a 32-bit or a 64-bit operating system.
- You can perform all administrative image configuration steps using SolidWorks Administrative Image Option Editor (some of which were handled previously in SolidWorks Installation Manager).
- In SolidWorks Administrative Image Option Editor, you can specify whether automatic updating is enabled for one or more machines or groups. You also can specify when the update occurs for specific machines or group of machines. This allows you to manage automatic updates (for example, avoiding the overload of a particular server because all the updates take place simultaneously).

### Background Downloader

You can use SolidWorks Background Downloader to download installation files in the background. You are notified when downloading is complete and the files are ready for installation. You can choose to install now, delay the installation, or delete the download.
SolidWorks Rx

Diagnostics
The improved page design and content on the Diagnostics tab helps you locate and download the correct graphics driver at http://www.solidworks.com/sw/support/videocardtesting.html.

Status shown in the Diagnostics tab for different system and graphics card combinations on your machine:

<table>
<thead>
<tr>
<th>Machine</th>
<th>Status</th>
<th>Fields Displayed</th>
</tr>
</thead>
<tbody>
<tr>
<td>System</td>
<td>Certified</td>
<td>All system and graphics card related fields</td>
</tr>
<tr>
<td>Graphics Card</td>
<td>Certified only for previous version of SolidWorks</td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>Not certified</td>
<td>Graphics card related information</td>
</tr>
<tr>
<td>Graphics Card</td>
<td>Certified only for previous version of SolidWorks</td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>Certified</td>
<td>All system and graphics card related fields</td>
</tr>
<tr>
<td>Graphics Card</td>
<td>Out-of-date</td>
<td></td>
</tr>
<tr>
<td>System</td>
<td>Certified</td>
<td>All system and graphics card related fields</td>
</tr>
<tr>
<td>Graphics Card</td>
<td>Current</td>
<td></td>
</tr>
</tbody>
</table>

If you have no internet connection, the status shows the error icon ✗.

Usability and Workflow Improvements
The Problem Capture tab helps you describe the problem, record the video, and package the SolidWorks files.

1. On the Problem Capture tab, click **Describe Problem**.
2. In the Problem Capture Details dialog box, describe the problem and click **OK**
   This dialog box has been shortened to improve usability.
3. Click **Record Video**.
   A new SolidWorks session starts. This button replaces the Re-create the problem dialog box.
4. In the Capturing Problem dialog box, click **Start Recording**.
The floating dialog box stays on top of your SolidWorks session.

5. Record the problem and click **Finish Recording**.
6. When prompted to shut down the SolidWorks session, click **OK**.
7. Click **Add Files** to add parts, drawings, or assembly files, then click **Package files Now**.
   A zipped folder is created. You can rename the folder, save it on your hard disk, and send it to the Technical Support team.

**Hardware Benchmarks**
The Addins tab now has a link to [www.solidworks.com/benchmarks](http://www.solidworks.com/benchmarks) for you to find details about running SolidWorks and computer-related benchmarks. You can determine whether your system is qualified to run SolidWorks effectively.

To run the SolidWorks performance benchmark, on the Addins tab, click **Start the SolidWorks Performance Benchmark**.

**Graphics Card Health Checker**

Improvements:

- A one-click application that profiles your system and graphics card, and populates the information on the web page for you to identify the correct graphics card.
  
  You need .NET 2.0 or later installed on your machine to view this button on the web page.

- An updated results chart with color-coded keys that improves readability.
Assemblies

This chapter includes the following topics:

- **Assembly Features**
- **Assembly Visualization**
- **Defeature for Assemblies**
- **Equations**
- **Interference Detection**
- **Mates**
- **Rebuild Report**
- **SpeedPak**

**Assembly Features**

Enhancements include the ability to add fillets, chamfers, and weld beads to assemblies.

**Fillets and Chamfers**

In assemblies, you can create fillets and chamfers, which are useful for weld preparation. As with other assembly features, you can propagate these features to the parts they affect.

For a step-by-step example of adding chamfers in an assembly, see **Fillets and Chamfers** on page 166.

**Weld Beads**

You can add simplified weld beads to assemblies. Simplified weld beads provide a lightweight, simple representation of weld beads.
In previous versions of SolidWorks®, you added weld beads as components of the assembly. This method is no longer supported. However, you can still edit existing weld bead components.

For more information about simplified weld beads, see Weld Beads on page 164.

For a step-by-step example of adding a weld bead to an assembly, see Weld Beads on page 165.

Assembly Visualization

Enhancements support complex sorting scenarios and provide additional display and save options.

Sorting and Column Options

You can build more complex sorting scenarios by doing the following:

- Adding multiple columns
- Adding multiple parameters to the sorting hierarchy
- Rearranging column position to change the order in which the parameters are sorted

Right-click a column header and select the following:

- **Add Column.** Adds a column to the Assembly Visualization list. You can then change which property is listed in the new column.
- **Delete Current.** Deletes the column you right-clicked. The minimum number of columns is three. The **File Name** and **Quantity** columns cannot be deleted.
- **Add to Sort Hierarchy.** Enables you to sort by the values in that column. A sorting widget appears under the column title. To remove a column from the sort hierarchy, right-click it and click **Remove from Sort Hierarchy.** When multiple columns have sorting widgets, the hierarchy of the sort is from left to right. Drag a column header to move a column left or right to move it up or down in the sorting hierarchy.

💡 You can adjust the width of a column to fit the column contents by double-clicking the column separator.

Save and Display Options

With enhanced save and display capabilities, you can:

- Export the Assembly Visualization list in top-level only, parts only, or indented format when saving the list to a separate file. Right-click any column header and click **Save as.** Then in the Save As dialog box, select **Top-level only, Parts only,** or **Indented.**
- Save the Assembly Visualization view as a display state. Click the arrow to the right of the column headers and click **Add Display State.**
• Apply the same color to components that have identical values (for example, when components are sorted by a discrete property such as Vendor or Status). Right-click a color slider and click Group Identical. The software adds sliders as needed to apply a distinct color for each discrete value.

• Set the length of the value bars to be calculated as a percentage of the value for the highest-value component or as a percentage of the value for the entire assembly. Click the arrow to the right of the column headers, click Value Bars, and then click Component Driven or Assembly Driven.

**Defeature for Assemblies**

With the Defeature tool, you can remove details from a part or assembly and save the results to a new file in which the details are replaced by dumb solids (that is, solids without feature definition or history). You can then share the new file without revealing all the design details of the model.

Before

After

Click Defeature (Tools toolbar) or Tools > Defeature to access the Defeature PropertyManager, which provides tools for manual and automatic selection of details to keep and remove.

The PropertyManager has multiple pages.

**Defeature - Step 1: Components**

You can specify components to remove from the model.

In this example, you use the Defeature tool to remove all internal components and features, and some external features, from an oil pump assembly. You retain the mounting holes.

1. Open  \( \text{install_dir}\backslash\text{samples}\backslash\text{whatsnew}\backslash\text{assemblies}\backslash\text{oil\_pump.sldasm} \).

2. Click Tools > Defeature.
The Defeature PropertyManager opens to **Step1: Components**. First, examine a section view of the assembly.

3. In the PropertyManager, under **Section View**, click **Plane1**. You can see internal details and components.

   ![Image](image1.png)

   Change **Offset Distance** to view different sections of the assembly.

4. Click **Plane1** to clear the section view.
5. Under **Remove**, select **Internal components**.
6. Click **Next**.

**Defeature - Step 2: Motion**

If you want to allow motion in an assembly, you can remove details from groups of components and allow motion between the groups.

For this example, skip this step.

Click **Next**.

**Defeature - Step 3: To Keep**

You can specify features that you want to retain, such as mounting holes, that might otherwise be removed by the **Defeature** tool.

1. For **Features to Keep**:
   a) In the graphics area, select the three mounting holes on the cover.

   ![Image](image2.png)

   b) Rotate the assembly and select the three mounting holes on the housing.
2. Click **Next**.
   The screen splits and a preview of the model appears. Features on the housing are removed to close up the assembly. The mounting holes you selected are retained.

💡 When you rotate the assembly, the preview also rotates.

---

**Defeature - Step 4: To Remove**

You can specify to remove features that were not automatically removed.

1. In the flyout FeatureManager design tree, expand **Cover** and select **Rib Cut**.
   In the PropertyManager, **Rib Cut** and its dependent features appear in **Items to Remove**. In the graphics area, the cut feature is highlighted.

2. Click **Next**.
   The preview shows that the cut feature is removed.
Defeature - Feature Removal Complete
You can save the less-detailed model in a separate part file or publish it to 3D ContentCentral. The settings you select in the PropertyManager are saved in the original model.

1. Under **Results**, select **Save the model as a separate file**.
2. Click ✓.
3. In the Save As dialog box:
   a) For **File name**, type **oil pump - details removed**.
   b) For **Save as type**, select **Part(*.sldprt)**.
   c) Click **Save**.

The assembly is saved as a part. The part has only one feature, **Imported1**，and has no references to the original assembly.

In the assembly, **Defeature** appears near the top of the FeatureManager design tree.

💡 You can right-click **Defeature**, click **Edit Feature**, change the settings, and save another version of the assembly, with different details removed.

4. In the part window, click **Section View** (Heads-Up toolbar) or **View > Display > Section View**.
   The part has no internal details.
Equations

Equation functionality is enhanced.
- You can use equations to control the suppression state of assembly components.
- You can share equations and global variables among models.
- You can configure global variables.

See *Equations* on page 101.

Interference Detection

*Interference Detection* has been enhanced.

**Ignore Hidden Bodies**
You can ignore interferences with hidden bodies.

For example, suppose that in a multibody part, you create a body for construction purposes and then hide it. In an assembly, you can choose to not show interferences between the hidden body and other components.

Click *Interference Detection* (Assembly toolbar) or *Tools > Interference Detection*. In the PropertyManager, under *Options*, select *Ignore hidden bodies*.

**Quality and Performance**
The quality and performance of *Interference Detection* have been improved. Because of the changes, the software might find interferences that were previously missed, resulting in changes in the number of interferences reported.

Mates

**Replace Mate Entities**
Replace Mate Entities is enhanced.
- The Missing Entities popup toolbar is now available while you replace any mate entities, not just while you replace a component that includes mate entities.
• While replacing multiple mate entities, you can postpone the solving of the mates. Select **Defer update** so that all mates are solved together when you exit the PropertyManager, instead of solving individually each time you select a replacement entity.

Select a mate, a component, or a Mates folder and click **Replace Mate Entities** (Assembly toolbar).

**Mates in Motion**
To support more accurate motion simulations, certain mates are now solved relative to other components rather than relative to the assembly origin.

The reference components for gear mates, rack and pinion mates, and screw mates are detected automatically. For linear/linear coupler mates, you specify the appropriate reference components in the Mate PropertyManager.

The reference component information is used in SolidWorks Motion simulations.

**Rebuild Report**
AssemblyXpert now provides a report of the rebuild time for the total assembly.

You must rebuild the assembly during the current session of SolidWorks before generating the report.

1. Click **AssemblyXpert** (Assembly toolbar) or Tools > **AssemblyXpert**.
2. In the AssemblyXpert dialog box, in the information-only row about the rebuild report, click **Show these Parts**.

**SpeedPak**
New commands make it easier to switch between SpeedPak and parent configurations of subassemblies. Also, sketches now appear in SpeedPak configurations.

**Switching All Subassemblies to SpeedPak**
Do one of the following:

• When opening an assembly, click **Open** (Standard toolbar) or File > **Open**. In the Open dialog box, select **Use SpeedPak**.
• In an assembly that is already open, in the FeatureManager design tree, right-click the top-level assembly and click **Use SpeedPak**.

If a subassembly's active configuration has a SpeedPak configuration, then the SpeedPak configuration is used.

**Switching Selected Subassemblies to SpeedPak**
In the FeatureManager design tree, right-click one or more subassemblies and click **Use SpeedPak**.

If the selected subassembly's active configuration has a SpeedPak configuration, then the SpeedPak configuration is used.
Switching from SpeedPak to Parent Configurations

In the FeatureManager design tree, right-click the top-level assembly or one or more selected subassemblies and click **Set SpeedPak to Parent**.

The subassemblies switch from the SpeedPak configuration to the SpeedPak’s parent configuration.

Sketches in SpeedPak Configurations

Unabsorbed sketches are included in SpeedPak configurations. You can suppress unneeded sketches to avoid having them affect performance of the SpeedPak configuration. As in any assembly, you suppress and unsuppress sketches by right-clicking them in the FeatureManager design tree and selecting **Suppress** ⌚ or **Unsuppress** ⌚.
Available in SolidWorks® Premium.

This chapter includes the following topics:

- User-Defined Coordinates for Component Orientation
- Interface Improvements
- Workflow Improvements
- Comparing Boards
- Export to PADS PowerPCB Format

User-Defined Coordinates for Component Orientation

You can add a SolidWorks® user-defined coordinate system to a component that is not modeled with the SolidWorks origin. You might obtain such components from a manufacturer website or from other CAD systems.

CircuitWorks™ assigns the user-defined coordinate system as the ECAD origin when you export the assembly into CircuitWorks.

If you insert components without a user-defined coordinate system into a CircuitWorks assembly, CircuitWorks assigns SolidWorks origin as the ECAD origin.

To add your own coordinates to a component, see SolidWorks Help: Coordinate System. When you name the user-defined coordinate system CWX before inserting the component in the CircuitWorks Library, CircuitWorks assigns the user-defined coordinate system as the ECAD origin and correctly positions the components when you insert them into a circuit board assembly.

CircuitWorks interprets the positive Z-direction of a user-defined coordinate system as perpendicular to a circuit board assembly. The XY plane represents the board surface, and the X- and Y- directions control the angle at which the component is inserted into the assembly.

To assign a name other than CWX to the user-defined coordinate system representing the ECAD origin, click CircuitWorks > CircuitWorks Options, select SolidWorks Export, and modify the Import and export components relative to this coordinate system option.
**Example: LED Orientation With and Without Coordinates Defined**

The coordinates of an externally manufactured LED set the Z-direction parallel to the base of the LED.

You add the LED to the CircuitWorks Library without defining a coordinate system named CWX. When you insert the LED components into the board assembly after building it in CircuitWorks, the LEDs are horizontal.

Before adding the component to the CircuitWorks Library, add a coordinate system named CWX to the LED component in SolidWorks.
The LEDs are properly oriented when you insert them into the board assembly.

**Interface Improvements**

The CircuitWorks library is enhanced.

Improvements to menus, options, and the library display include:

- Commands to import and export library data are grouped more logically on the **Tools** menu.
- The **Add Parts from Folder** function has been renamed **Add Multiple Components** and moved to the **File** menu. The **Add Multiple Components** wizard assists you in adding SolidWorks models to the CircuitWorks library.
  
  For more information, see *SolidWorks Help: Adding Multiple Components to the Library*.

- The option **Check component library data for errors** highlights any missing SolidWorks components in the component tree (rather than simply removing them as in previous releases). You can then remove or repair them.
- Components managed through SolidWorks Workgroup PDM or SolidWorks Enterprise PDM are marked with this icon 🐬.

**Workflow Improvements**

New options improve the CircuitWorks workflow.

- You can now save library data to a database for backup or data migration.
  
  To save library data to a database:
  
  1. Click **Tools > Export Data > To Database**.
  2. Select a database file name and location and click **Save**.

- CircuitWorks offers to overwrite zero-height components in the library if it later encounters the same component with a defined height. You can set the **Overwrite any existing 2D models in the Library with 3D model** option to apply this action automatically.

- When you set the **Add components to the library when exporting from SolidWorks** option, CircuitWorks adds records to the library for any new component it encounters when exporting a SolidWorks assembly to CircuitWorks.
Comparing Boards

You can use the **Compare** command to identify differences between boards (their shape, for example). In previous releases, only the components on the board were compared. When differences are identified, you can choose whether to replace the board or selected components in the SolidWorks assembly.

Open two boards in CircuitWorks and click **Tools > Compare**.

Export to PADS PowerPCB Format

You can export Circuitworks data to the PADS PowerPCB 2007 (*.asc) format.

In CircuitWorks, click **File > Save As** and select **PowerPCB 2007 File (*.asc)**.
This chapter includes the following topics:

- Configuration Publisher
- Modify Configurations
- Parameters
- SpeedPak

Configuration Publisher

**3D ContentCentral**

The Configuration Publisher has new capabilities for 3D ContentCentral suppliers.

**Part Numbers**

A part number can be displayed with your model on 3D ContentCentral. Your customers can search for the model by part number.

To include a part number with the model:

1. In the design table of the model, create a column with the header $PARTNUMBER.
2. Under $PARTNUMBER:
   - For single-row design tables, use Microsoft Excel functions such as CONCATENATE to make the value of the cell reflect the model's part number based on values in other columns.
   - For multiple-row design tables, enter a part number for each configuration by typing or using Microsoft Excel functions.
3. In the Configuration Publisher, add controls, rules, and values. On the 3DCC Preview tab, **Supplier part number** displays the part number of the selected configuration. As you change selections, the part number updates to reflect the current selections.
4. Click **Upload to 3D ContentCentral** and click **Yes** to save the model. The software generates a list of part numbers and stores it within the model in a format that is accessible to the 3D ContentCentral software.
   - For single-configuration models, a part number is generated for each possible configuration, based on the rules and values you defined in the Configuration Publisher.
   - For multiple-configuration models, the list contains the part numbers you entered for each configuration in the design table.

On 3D ContentCentral:
• On the Configure & Download page, the part number appears at the bottom of the Configure area and updates as you change selections.
• You can search for the model by part number or partial part number.

Model Tests
You can test the health of models before uploading them to 3D ContentCentral.

A sample of possible configurations is tested. Results are reported in a log file that lists the configurations that were tested and whether they rebuilt successfully.

To test a model before uploading it:
1. In the Configuration Publisher, on the 3DCC Preview tab, click Test.
2. In the Configuration Tester dialog box, specify the sample size and where to store the log file, and click Begin Test.

The dialog box reports the percentage of the samples that succeeded. You can view the log file for more details.

Parent/Child Relationships
The Configuration Publisher offers more flexibility when defining data parents for controls.

You can define parents explicitly, and multiple parents are allowed. You no longer automatically inherit grandparents (that is, the parents of controls which you have specified as parents).

💡 You must have at least two controls already defined. Then you can add multiple data parents to the third or later controls.

In the Configuration Publisher, under Data, one Parent field is initially visible. To add others, click Add Parent.

Modify Configurations
The Modify Configurations dialog box has been enhanced.
• The All Parameters option has been moved from the table view drop-down list to a separate button.
• Linked dimensions are grouped in a column labeled Linked Dimension instead of appearing in columns for individual features. Each linked dimension appears in the list only once, even if it is used in several features.

Right-click an item and select Configure dimension, Configure feature, Configure component, or Configure Material.

Parameters
You can configure parameters in the following areas.
• Scale features (See Scale on page 109.)
• Global variables (See Global Variables on page 106.)
• Cosmetic threads (See Cosmetic Threads on page 53.)
SpeedPak

New commands make it easier to switch between SpeedPak and parent configurations of subassemblies. Also, sketches now appear in SpeedPak configurations.

For more information, see SpeedPak on page 30.
Available in SolidWorks® Professional and SolidWorks Premium.

This chapter includes the following topics:

- **Design Checker Standards from SolidWorks Files**
- **File Location Check**
- **Dimension Precision Check**
- **Feature Positioning Check**
- **Standard Template Check**
- **Design Checker Report**
- **Summary Report for Task Scheduler**
- **Design Checker Task in Enterprise PDM**

### Design Checker Standards from SolidWorks Files

Design Checker now supports the creation of standard files (*.swstd) from the following file formats, in addition to the *.dwg file format:

- Part (*.sldprt, *.prt)
- Assembly (*.asm, *.sldasm)
- Drawing (*.drw, *.slddrw)
- Template (*.prtdot, *.asmdot, *.drwdot)
- Drafting Standard (*.sldstd)

Click **Tools > Design Checker > Check Against Existing File** to specify a file for the creation of the standard file. The program creates the standard file based on your selection, validates the active document, and displays results in the Task Pane.

### File Location Check

You can use the **File Location** check to verify that your document templates are located in the correct file path. The current document is checked against the settings in **Tools > Options > System Options > File Locations**.

Click **File Location** under **Document Checks** to add to the **Build Checks**.

The check also contains three new options for auto-correction:

- **Add missing paths.** During autocorrection, Design Checker adds the file paths in the preferred values list to the list of actual values at the system level.
- **Remove extra paths.** During autocorrection, Design Checker removes the file paths that are not present in the preferred values list from the list of actual values at the system level.
• **Check for order.** Design Checker checks for the file path order in the actual and preferred lists.

**Dimension Precision Check**

The **Dimension Precision** check now includes the expected precision for dimensions, angles, and tolerances. You set the level of precision by selecting the number of digits after the decimal point or by setting the value. The current document is checked against the settings in **Tools > Options > Document Properties > Dimensions**.

The check also contains two new options for auto-correction:

• **Modify all length dimension & tolerance precisions in document**
• **Modify all angle dimension & tolerance precisions in document**

Click **Dimension Precision** under **Dimension Checks** to add to the **Build Checks**.

**Feature Positioning Check**

The **Feature Positioning** check verifies that the active document has no 2D or 3D sketches positioned with references to fillet or chamfer edges.

Click **Feature Positioning** under **Feature Checks** to add to the **Build Checks**.

**Standard Template Check**

The **Sheet Format** check is renamed to **Standard Template** check. This check verifies the sheet size properties of the drawing and the type of projection used for the views' layout.

Click **Standard Template** under **Drawing Document Checks** to add to the **Build Checks**.

**Design Checker Report**

The Design Checker report is now formatted for better readability. You can also save the report as a Microsoft Word document. The report includes information for autocorrected entities when a Design Checker task is executed from the SolidWorks Task Scheduler or SolidWorks Enterprise PDM.

The new format summarizes the failure instances according to criticality level and lists the autocorrected parameters with their initial and corrected values.

**Summary Report for Task Scheduler**

Design Checker creates a summary report when run on multiple files through SolidWorks Task Scheduler.

You can access the summary report under the **Status** of the Design Checker task. To view the detailed Design Checker report for a file, in the Task Scheduler summary report, select the report file path.
Design Checker Task in Enterprise PDM

You can use the new Design Checker task inside the Administration Tool of Enterprise PDM to validate selected SolidWorks documents in the vault using standards files (.swstd) created in Design Checker.

See Design Checker Validation on page 71.
This chapter includes the following topics:

- **Injection Molding**
- **Running an Injection Molding Check**

### Injection Molding

DFMXpress supports injection molded parts. You set the **Minimum wall thickness** and **Maximum wall thickness** parameters that DFMXpress uses to validate manufacturability.

### Running an Injection Molding Check

1. With a part open, click **Tools > DFMXpress**.
2. Click **Settings**.
3. Under **Manufacturing Process**, select **Injection Molding**.
4. Under **Rule Parameters**, set **Minimum wall thickness** and **Maximum wall thickness**.
5. Click **Run**.

The **Manufacturing Process: Injection Molding** report displays a list of rules passed and rules failed.
This chapter includes the following topics:

- **Alignment Options for Dimension Palette**
- **Auto Arrange Dimensions**
- **Bounding Box for Sheet Metal**
- **Cut List Properties in Drawings**
- **Center Marks in Assembly Drawings**
- **Cosmetic Threads**
- **Display Scale in Orthogonal Views**
- **Drawing Sheet Format**
- **Dual Dimensions for Chamfers**
- **Hide Bodies in Drawing View**
- **Hole Tables**
- **Merge and Unmerge Cells in Tables**
- **Notes**
- **Show Dimension Units**
- **Show Model Colors in Drawings**
- **GB Drafting Standard**
- **ANSI Drafting Standard**
- **3D Drawing Views**

### Alignment Options for Dimension Palette

Alignment tools are available on the dimension palette when you select more than one dimension.

To display the dimension palette, select dimensions and move the pointer over the **Dimension Palette** rollover button.
The following alignment tools are on the dimension palette.

These tools are also available on the Align toolbar.

**Auto Arrange Dimensions**

Automatically arranges selected dimensions. See **Auto Arrange Dimensions** on page 49.
Space Evenly Linear/Radial

Equally spaces all dimensions, linearly or radially, between the closest and furthest selected dimensions from the part.

Linear

![Linear Diagram]

Before

After

Radial

![Radial Diagram]

Before

After
**Align Collinear**

Aligns dimensions horizontally, vertically, or radially.

**Align Stagger**

Staggers linear dimensions.
Top Justify Dimension Text

Top justifies linear dimension text.

Before

After

Bottom Justify Dimension Text

Bottom justifies linear dimension text.

Before

After
**Left Justify Dimension Text**

Left justifies linear dimension text.

![Before and After Diagrams]

**Right Justify Dimension Text**

Right justifies linear dimension text.

![Before and After Diagrams]

You can adjust the spacing between dimensions using the thumbwheel in the dimension palette or by manually dragging the dimensions.
• The thumbwheel appears in the dimension palette only when spacing options are available.
• The **Dimension Spacing Value** is the scaling factor for the spacing. For example, 2 increases the spacing by a factor of 2, or doubles it.

**Auto Arrange Dimensions**

The **Auto Arrange Dimensions** tool positions dimensions quickly and easily.

When you use **Auto Arrange Dimensions**, the selected dimensions are placed as follows:

- Spaced from smallest to largest
- Aligned and centered, if possible
- Spaced with the offset distances defined in Document Properties - Dimensions
- Adjusted to avoid overlapping
- Staggered, if necessary

**Using Auto Arrange Dimensions**

To use **Auto Arrange Dimensions**:

1. Open `install_dir\samples\whatsnew\drawings\Auto_arrange.SLDDRW`.
2. Box select all of the dimensions.
3. Move the pointer over the **Dimension Palette** rollover button to display the dimension palette.
4. Click **Auto Arrange Dimensions**.
5. Click in the graphics area off of the dimension palette. The dimensions are automatically arranged.
Adjusting Spacing

To adjust the horizontal spacing in the dimensions at the top of the drawing:

1. Select the horizontal dimensions at the top of the drawing and display the dimension palette.

2. Move the thumbwheel to the right and left to adjust the **Dimension Spacing Value**.

Bounding Box for Sheet Metal

You can display a bounding box that fits a flat pattern for sheet metal parts and bodies, with or without grain direction.
To display the bounding box:
1. Right-click a drawing view and click **Properties**.
2. In the Drawing View Properties dialog box, select **Display bounding box**.

To set grain direction:
1. In the part, edit the Flat Pattern feature.
2. Click in **Grain Direction**.
3. Select an edge or sketch line to define the grain direction.

4. Click ✓.
Cut List Properties in Drawings

You can insert the cut list properties as an annotation when you insert a flat pattern view of a sheet metal part in a drawing.

To insert the cut list properties:

1. In the graphics area, right-click the flat pattern view and click **Annotations > Cut List Properties**.
2. Click to place the list in the graphics area.

Center Marks in Assembly Drawings

You can insert center marks automatically in assembly drawings.

To insert center marks on holes, fillets, or slots automatically in assembly drawing views:

1. In an assembly drawing document, click **Options** (Standard toolbar) or **Tools > Options**.
2. On the Document Properties tab, click **Detailing**.
3. Under **Auto insert on view creation**, select from:
   - Center marks - holes - assembly
   - Center marks - fillets - assembly
   - Center marks - slots - assembly
Cosmetic Threads

You can configure callouts for cosmetic threads. |

💡 Cosmetic thread callouts are editable, and therefore configurable, only when **Standard** is set to **None** in the Cosmetic Thread PropertyManager.

Use one of the following methods:

**PropertyManager** Under **Thread Callout**, click **Configurations** and specify the configurations to which the callout applies.

**Design Table** The column header for controlling the callout of a cosmetic thread uses this syntax:

\$THREAD_CALLOUT@cosmetic_thread_feature_name

Example:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Design Table for: 560726</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>P001</td>
<td>3/4-14 NPT</td>
</tr>
<tr>
<td>4</td>
<td>P002</td>
<td>1/2-14 NPT</td>
</tr>
</tbody>
</table>

[Diagram of cosmetic thread callouts and threaded components]
Display Scale in Orthogonal Views

You can display the scale of an orthogonal view if the scale is different than the default drawing scale. Previously, you could only display the scale of a detail, section, or auxiliary view in a drawing.

To display the scale of an orthogonal view:

1. In a drawing, click Options (Standard toolbar) or Tools > Options.
3. Select Show label if view scale differs from sheet scale.
4. Click OK.

Scale Not Displayed

Scale Displayed

Drawing Sheet Format

The default location for storing drawing sheet formats is now at:

- **Windows XP**
  
  C:Documents and Settings\All Users\Application Data\SolidWorks\version\lang\language\sheetformat

- **Windows 7**
  
  C:ProgramData\SolidWorks\version\lang\language\sheetformat

- **Windows Vista**
  
  C:ProgramData\SolidWorks\version\lang\language\sheetformat

To change the default location, click Tools > Options > System Options > File Locations. In Show folder for, select Sheet Formats.

Dual Dimensions for Chamfers

You can display dual units in chamfer dimensions. For example, you can display the chamfer dimensions in inches and centimeters.

To display dual dimensions for all chamfers in a drawing, click Tools > Options > Document Properties > Dimensions > Chamfer. Under Dual dimensions, select Dual dimensions display. To display units, select Show units for dual display.
To display dual dimensions for a particular chamfer, select the chamfer dimension and then in the Dimension PropertyManager, select **Dual Dimension**.

**Hide Bodies in Drawing View**

In addition to hiding components in a drawing view, you can now hide a body in a drawing view.

**Hiding a Body**

To hide a body:

- In the drawing view, right-click the body and click **Show/Hide**, then **Hide Body**.

**Showing a Body**

To show a body:

1. In the FeatureManager design tree or graphics area, right-click the drawing view and click **Properties**.
2. In the Drawing View Properties dialog box on the Hide/Show Bodies tab, select the body to view and press **Delete**.
3. Click **OK**.

**Hole Tables**

**Tags**

You can renumber the tags when you add or delete holes from a hole table.

**Renumbering All Tags**

To renumber all tags:

- Right-click the hole table in the graphics area or in the FeatureManager design tree and select **Renumber All Tags**.

**Renumbering a Series**

To renumber a series:

- Right-click any row in the series and select **Renumber Series**.

In this example, hole A3 is removed and the corresponding A series is renumbered.
Dual Unit Support

You can display dual units in hole tables. For example, you can display the size of a hole in millimeters and inches.

To display dual dimensions in hole tables, click Tools > Options > Document Properties > Tables > Hole. Under Dual dimensions, select Dual dimensions display. To display units, select Show units for dual display.

You can also right-click a hole table and click Show dual dimensions. When dual dimensions are displayed, you can right-click the hole table and click Show units for dual dimensions.

Merge and Unmerge Cells in Tables

You can merge and unmerge cells in a table using tools from the Table pop-up toolbar.

To merge cells:
1. Select the cells.
2. Click Merge Cells (Table pop-up toolbar).

To unmerge cells:
1. Select the cell.
2. Click Unmerge a Cell (Table pop-up toolbar).
Notes

**Fit Text in Notes**

The Fit Text tool is available in the PropertyManager and pop-up toolbar when you create notes. Previously, it was available only when you edited notes.

**Pattern Notes**

You can display notes in linear or circular patterns in drawings.

First create a note, then create the linear or circular pattern of the note.

1. In a drawing, click **Note** (Annotation toolbar) or **Insert > Annotations > Note**.
2. In the PropertyManager, set the options for the note and place it in the drawing.

3. To create a circular note pattern, click **Circular Note Pattern** (Annotations toolbar), or click **Insert > Annotations > Circular Note Pattern**.
4. In the PropertyManager, set the options.

5. To edit the notes, double-click each note and enter the text.
Show Dimension Units

You can show dimension units in drawings.

1. In a drawing, click **Options** ![Options icon] (Standard toolbar) or **Tools > Options**.
2. On the Document Properties tab, click **Dimensions** and select **Show units of dimensions**.
3. Click **OK**.

Show Model Colors in Drawings

You can view the model colors of a part or assembly in a drawing in HLR/HLV. Any assigned layer overrides this setting.

To show model colors, click **Tools > Options > Document Properties > Detailing**. Select **Use model color for HLR/HLV in drawings**.
GB Drafting Standard

Additional requirements of the GB drafting standard are supported.

In **Tools > Options > Document Properties > Dimensions:**
- Arrow length increased from 3.3mm to 4.08mm.
- Arrows changed from hollow to solid.
- Extension line:
  - **Gap** changed from 1mm to 0mm.
  - **Beyond dimension line** changed from 1mm to 2mm.

In **Tools > Options > Document Properties > Dimensions > Chamfer**, a new **Text position** option, **Horizontal Text, along the model line extension**, puts the chamfer dimension in line with the model edge.

![Chamfered corner](image)

ANSI Drafting Standard

The **SolidWorks®** software supports some of the requirements of ASME Y14.5-2009.

**Datum Feature Symbols**

**Leaders**
You can use leaders for datum feature symbols that you apply to planar surfaces.

Click **Datum Feature** (Annotation toolbar) or **Insert > Annotations > Datum Feature Symbol**. In the PropertyManager, under **Leader**, click **Leader** or **No Leader**.

**Attachment to Linear Dimensions**
You can attach datum feature symbols to linear dimensions.

Click **Datum Feature** (Annotation toolbar) or **Insert > Annotations > Datum Feature Symbol**. In the PropertyManager, set the options, then select a linear dimension to which you want to attach the symbol. The datum is placed in the center of the dimension.
If you attach the symbol to a dimension that is centered between its extension lines, the symbol is placed as shown.

Geometric Tolerance Symbols

Leaders
All Over Leader is available as a new leader type.

Click Geometric Tolerance (Annotation toolbar) or Insert > Annotations > Geometric Tolerance. In the PropertyManager, under Leader, click All Over Leader
Material Conditions
The following material conditions are available.

Diameter and Square
You can use the Diameter \( \text{\textbullet}\) and Square \( \text{\textsquare}\) symbols when applying a Flatness \( \text{\textperp}\) tolerance.

Unequally Disposed Profile
You can use the Unequally Disposed Profile \( \text{\textparallel}\) symbol in geometric tolerance symbols.

Click Geometric Tolerance (Annotation toolbar) or Insert > Annotations > Geometric Tolerance. In the Properties dialog box, set the options.

Symbols
The following symbols are available in the symbol library.

Independency \( \text{\textbullet}\)

Continuous Feature \( \text{\textsquare}\)

Click Geometric Tolerance (Annotation toolbar) or Insert > Annotations > Geometric Tolerance. In the PropertyManager, under Text, click More. In the Symbols dialog box, in Symbol library, select Modifying Symbols, then select a symbol.

3D Drawing Views
You can use the 3D Drawing View \( \text{\textsquare}\) tool to save a 3D drawing view or to select pre-defined view orientations.

Click 3D Drawing View (View toolbar) or View > Modify > 3D Drawing View and access the options in the pop-up toolbar.

The OK \( \text{\checkmark}\) button has changed in functionality. When you rotate the model or set a different view orientation from View Orientation \( \text{\textsquare}\), then click OK \( \text{\checkmark}\), the orientation is kept. If you click Exit \( \text{x}\), you exit 3D Drawing View mode and the model returns to its original orientation.

You can save the view orientation to use it in other views. Click Save the view \( \text{\textsquare}\), type a View name, and click OK.
This chapter includes the following topics:

- **Task Pane Interface**

Task Pane Interface

DriveWorksXpress is now available from the SolidWorks® Task Pane. You can move easily between designing models in SolidWorks and automating their production in DriveWorksXpress.
This chapter includes the following topics:

- Display Enhancements
- File Synchronization
- Triad Manipulation
- Filtering by Component Name
- Native 64-Bit Support

Display Enhancements

The performance of display and printing in SolidWorks® eDrawings® is significantly improved for some documents.

eDrawings now displays DWG files more accurately. Gradient hatches are supported, and the handling of overlapping entities more closely matches the display order used in AutoCAD.

File Synchronization

eDrawings can now detect when the graphics data for a component may not be in sync with a later version modified and saved within a SolidWorks assembly.

When you open a potentially outdated component, a watermark displays a warning and suggests that you rebuild the part in SolidWorks.

To control the display of the watermark during the session, click View > Show Warning Watermark.

Triad Manipulation

You can manipulate components of an assembly with greater control and precision.

You can use the triad tool to constrain component movement to a coordinate axis or plane and to rotate components about a coordinate axis. You can also enter values to specify position, translation, or rotation.

Click Tools > Move Component and select Use triad or enter values.

Filtering by Component Name

You can filter the assembly tree to show component names that contain text you specify. This feature was previously available only in eDrawings for Mac®.
In the Component tree, type your search text in Enter text to filter list.

Native 64-Bit Support

SolidWorks eDrawings software can now run as a native 64-bit application on a 64-bit Microsoft® Windows® operating system, which permits larger documents to be opened.
This chapter includes the following topics:

- **File Explorer and SolidWorks Add-in**
- **Administration Tool**
- **API**
- **Installation**

**File Explorer and SolidWorks Add-in**

**Enterprise PDM Menus**

New menus for the SolidWorks® Enterprise PDM client make the commands that you use most frequently easier to find.

All commands are grouped into four Enterprise PDM menus at the top of the file view pane.

The new menus reduce the length of the shortcut menu. However, the most frequently used commands are still available by right-clicking.

The commands available depend on your selection.

Click **Actions** to access actions you can perform such as checking files in or out.
Click **Modify** to access commands that let you make modifications, such as changing a file's state.

Click **Display** to control how vault information is displayed in the file view pane. The **Options** submenu lets you choose display options such as **Set focus to active configuration** and **Show bitmap for SolidWorks files**. **Display** also lets you view a selected document's history, open it in the SolidWorks Enterprise PDM File Viewer, or view its properties.

Click **Tools** to access tools such as **EPDM Searches**, **Copy Tree**, the Notification Editor, the **Report Generator**, or the EPDM Administration tool.
To access the File Explorer online help, click **Get help** on the Windows Explorer toolbar or select **Help > SolidWorks Enterprise PDM Help** on the Windows Explorer menu bar.

On Windows 7 systems, Windows Explorer menus are suppressed by default. To display them, click **Organize > Layout** and select **Menu bar**.

**Expanded Search Capability**

You can use new options on the History tab of the Complete Search card to search the vault based on text in file/item names and configuration/sheet names.

Administrators must use the Card Editor to add the new options to search cards created before SolidWorks Enterprise PDM 2011.

To access the new search options:

1. Expand (menu bar) and click **Complete Search**.
2. On the History tab, select **Look in file/item names** or **Look in configuration/sheet names**.
3. In the **Text to find in history** field, type the text to search for.
4. Click **Start Search** (Search dialog box toolbar).
   
   Files matching the search appear in the middle pane of the Search dialog box.

**Expanded File Open Capabilities**

In the SolidWorks Open dialog box, you can preview files by selecting them on the Contains or Where Used tabs. In SolidWorks and other applications, double-clicking a file on the Contains or Where Used tabs opens the file in the application.

To use the Contains tab to preview and open files:

1. In SolidWorks, click **Open** (Standard toolbar) or **File > Open**.
2. In the Open dialog box, navigate to a folder in an Enterprise PDM vault.
3. Select a file that references other files (for example, an assembly) and click the Contains tab.
The referenced files are listed.
4. Double-click the referenced file to open it in SolidWorks.

**Updating Broken File References**

You can use the **Update References** command to repair broken file references.

- You can repoint references to existing files in the vault.
- If the referenced files are outside the vault, you can locate them, update the references, and add the files to the vault.
- You can replace existing references.

Warning messages appear when you try to check files with broken references into the vault.

To update the references, cancel the check in and complete the following procedure:

1. Select a file with broken references.
2. Click **Tools > Update References**.
   
   The Update References dialog box opens, listing all references and identifying those that are missing.

3. If a warning indicates that a file cannot be found, click **Find Files** (Update References toolbar).
4. In the Find Files wizard, select the folder to search, specify how the search should be performed, and click **Next**.

   Files that meet your search criteria are listed.

5. If the **Found in** column indicates that there are multiple matches, expand the list and select the file to use.
6. To update a reference, in the **Update** column, check the box and click **Finish**.
7. Click **OK** in the Update References message box.
8. Click **Update** to save the reference paths that are shown in the **Found In** column to the parent file.

Menu options in the Update References dialog box let you:

- Save the file list as a CSV file
- Open the file list in Excel
- Change the view of columns
- Replace a selected reference
- Add a file to the vault if it is found outside the vault

See *SolidWorks Enterprise PDM File Explorer Help: Updating File References* for more information.

**Saving eDrawings Markup Files**

SolidWorks eDrawings markup files saved from the Save Markup dialog box are automatically added to the vault.

To save markup files to the vault automatically, in eDrawings, click **File > Save Markup**.

To see the added file type in the Administration tool:

1. Click **Tools > EPDM Administration** to open the Administration tool.
2. Expand **Users**, right-click your user name, and click **Settings**.
On the Adding Files tab of the Settings dialog box, markup has been added to the list of files that are always saved to the vault.

**Restoring Files from Cold Storage**

You can retrieve files from cold storage for any archive server to which you have access if your administrator has granted you permission.

You may want to retrieve files from cold storage if a design's functional specification has changed or if you need to access an older archived design change.

You can only select one file at a time to restore. However, if a selected file such as an assembly contains references, both the parent file and the referenced files can be retrieved in one restore operation.

You can only restore files that were removed from the vault by moving archive files to a folder outside the archive. If your administrator set up cold storage to delete archive files, you cannot restore them.

To restore a single file from cold storage:

1. Select a file and click **Actions > Get Version**.
2. In the submenu, expand **Versions in Cold Storage** and select the cold stored version to use.
3. In the Get from Cold Storage dialog box, click **Restore**.

   The file is restored to the folder containing the non-cold stored versions.

   The restored file's history contains a comment that the file was restored from cold storage, including the restoration date and the name of the user performing the restore.

See *SolidWorks Enterprise PDM File Explorer Help: Restoring Files from Cold Storage*.

**Creating Submenus**

The Enterprise PDM API now supports submenus.

You can use submenu support to organize items you create in File Explorer, such as Search Favorites.

To create a submenu for your favorite searches:

1. Click **Search** (Enterprise PDM menu bar).
2. In the SolidWorks Enterprise PDM Search dialog box, select the search type to use.
3. Add search criteria to define the search.
4. Click **Add to Favorites** (Search dialog box toolbar).
5. In the Add to Favorites dialog box, for **Favorite name**, type `submenu_name\favorite_name`, select users who can see the favorite, and click **OK**.

When you view the Search menus, the new favorite will be listed in the submenu:
Administration Tool

Collecting Support Information
You can run the Collect Support Information wizard to collect information about a vault. The wizard creates a single package that you can send to technical support.

You must be logged in as the Admin user to run the wizard.

The Collect Support Information wizard lets you:

• Specify logs and settings to collect.
  Options include archive server, Enterprise PDM client, and local event logs, registry and environment information, database statistics, version numbers of all installed Enterprise PDM .exe and .dll files, and all installed add-in packages.

• Select folders and files to include in the support package.
  The .zip file created by the wizard maintains the archive server folder structure if you include archives.

• Create a backup of the SQL database.
  The backup is not added to the package. You must provide the backup manually to technical support.

• Include special instructions or problem descriptions.
  This input is saved as AdditionalInformation.txt in the package.

• Specify the location where the support information package is saved.

See SolidWorks Enterprise PDM Administration Tool Help: Vaults > Collecting Support Information.

Group Import from Active Directory
If you have defined the Archive server login type as Windows login, you can now import groups, group memberships, and email addresses from Microsoft Windows Active Directory®.

Importing groups from Active Directory lets you quickly set up the Enterprise PDM environment to be the same as the environment throughout your organization.

You can import Active Directory groups:

• When you add or edit a group
• When you add a new user
New users are added to Enterprise PDM groups with the names they have in the Active Directory groups.


**3DVIA Composer File Format Support**

SolidWorks Enterprise PDM now recognizes the 3DVIA Composer file formats `.smg` and `.smgxml`.

Users can preview embedded 3DVIA Composer files if the 3DVIA Composer Player is installed. As with other previews, you can use the 3DVIA Composer Player tools to manipulate the model.

![Image of 3DVIA Composer]

The 3DVIA Composer data card, which is installed when you create a vault using the Default setup, lets users view file information.

The 3DVIA Composer Player is available as a free download from [http://www.solidworks.com/sw/support/downloads.htm](http://www.solidworks.com/sw/support/downloads.htm), on the 3DVIA Composer tab.

**Design Checker Validation**

You can use the new Design Checker task to validate selected SolidWorks documents in the vault using standards (.swstd) files created in the SolidWorks Design Checker add-in.

SolidWorks Design Checker verifies design elements such as dimensioning standards, fonts, materials, and sketches to ensure that SolidWorks documents meet pre-defined design criteria. By using auto-correct, you can modify the documents you check to meet the design standards.

You configure the Design Checker task in the Administration tool to specify the computer the task is run on, who has permissions to run the task, and notifications. You can also set up design checks to be performed during workflow transitions by specifying that the Design Checker task is performed as a transition action.

You can initiate the Design Checker task:
For selected files in File Explorer
- From the **Add Task** button of the Task List dialog box in the Administration tool
- By changing a file's workflow state

When the task runs, you complete the Design Checker card to specify the standards file to use, whether to auto-correct failed checks, and where to store reports and logs.

- Reports list the criteria used to evaluate the document and show failed checks.
- Log files list the selections made when the task is run and the results of task execution, such as success or failure checking files out and in.

After a design check, the Design Checker status appear on the document's data card.

**Configuring the Design Checker Task**
You configure the Design Checker task from the **Tasks** node of the Administration tool.

1. Expand **Tasks** and double-click **Design Checker**.
   - On the Add-in screen, the Design Checker card is selected as the input card.
2. Select the user whose permissions are used when the task is run.
3. In the left pane, click **Execution Method** and select how the task is initiated and the computer on which the task is run.
4. Click **Menu Command** and specify whether and how the command appears to users in File Explorer.
5. Click **Permissions** and select users and groups that are allowed to initiate the task.
6. Click **Success Notification** and **Error Notification** to create notification messages and select users and groups to be notified.

**Running the Design Checker Task**
You can run the Design Checker task in File Explorer or from the Administration tool.

To initiate the task in File Explorer:
1. Select the files to check.
2. Click **Actions** > **Tasks** > **Design Checker**.

To initiate the task in the Administration tool:
1. Click **Tasks** > **Task List**.
2. In the Task List dialog box, click **Add Task**.
3. In the Add Task dialog box, select **Design Checker**.
4. Use the Select Files and Folders for Design Checker dialog box to select the files to check, then click **OK**.

In both File Explorer and the Administration tool, when the task runs, the Design Checker template card displays to let you specify:
- The **.swstd** file to use.
  - The standards file must be checked in to the vault.
- Whether to auto correct failed checks.
- Where reports and logs generated by the Design Checker task are saved.

**Aliases in Card Lists**
A new **Text with Alias** card list data type lets you add aliases when you create card lists to display variable values in data cards. Aliases let you truncate values for display and
use in input formulas. If you have existing lists of associated variable values and aliases in spreadsheets or other documents, you can copy and paste them to easily create card lists with aliases.

To create an alias list:

1. Right-click **Lists (for cards)** and click **Add New**.
2. In the dialog box, type the **List name** and select **Text with Alias** as the **Data type**.
3. In the **Data** list, for **Displayed Value**, type the value.
4. For **Alias**, type the alias to use for the displayed value when the list is used.

To use existing lists of paired display values and aliases from spreadsheets, CSV files, or Word tables:

1. Open the source document and copy the values.
2. In the card list, right-click under **Displayed Value** or **Alias** and click **Paste**.

To use an alias list in a data card:

1. Open the card in the Card Editor.
2. Add one of the following controls:
   - **Listbox**
   - **Droplist**
   - **Combobox**
   - **Combolist**
3. Under **Items**, select **Special value**.
4. Select the alias list to use.

See *SolidWorks Enterprise PDM Administration Help: Using Aliases in Card Lists*.

**Arithmetic and String Functions in Input Formulas**

You can now add arithmetic and string functions to input formulas for data card edit boxes. The arithmetic and string functions are available as input formula selection choices that are organized on a flyout menu. For easier access, variables have been reorganized on a second flyout menu.

To add arithmetic and string functions to an input formula:

1. Open or create a data card in the Card Editor.
2. Add an **Edit** control.
3. Under **Input formula**, to the right of the field, click **Variables**.
4. Select **Variables** to display a list of variables that you can use in the formula.

For easier access, the variables list is now divided into alphabetically-arranged sublists.

Select the variable to add.
5. Select **Functions** to display a list of arithmetic and string functions to use.

<table>
<thead>
<tr>
<th>Add Numbers</th>
<th>Subtract Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiply Numbers</td>
<td>Divide Numbers</td>
</tr>
<tr>
<td>Left Substring</td>
<td>Right Substring</td>
</tr>
<tr>
<td>Middle Substring</td>
<td>String X from List</td>
</tr>
<tr>
<td>String Length</td>
<td>Find Substring</td>
</tr>
<tr>
<td>Reversed Find Substring</td>
<td></td>
</tr>
<tr>
<td>Reverse String</td>
<td>Today's Date</td>
</tr>
</tbody>
</table>

Select the function to add.

6. Save the modified card.

*See SolidWorks Enterprise PDM Administration Help: Input Formula Functions.*

**Exported Workflow Links**

When you export workflows as `.cex` files and then import them into a vault, Enterprise PDM maintains any links between workflows.

> Workflow links are only maintained in `.cex` files when you export a workflow from SolidWorks Enterprise PDM 2011 or higher.

To see this functionality:

1. In an Enterprise PDM archive, create vaults A and B.
2. In vault A, create two workflows.
3. Right-click in the first workflow, and select **New Workflow Link**.
4. Select the second workflow as the workflow to link to.
5. Save the workflows.
6. Export both workflows to a `.cex` file.
7. Import the `.cex` file into vault B.
8. View the workflows in the Workflow editor.

The workflow link is maintained.

**Associating Drawing Types with File Types**

You can improve performance by modifying file type properties to specify the types of drawings that are checked for references when you check specific files out or in. The reference check determines if a drawing is a sub-parent of the file you are checking out or in.

This example describes how to specify the drawing types to check for references to `.sldprt` files:

1. Expand **File Types**.
2. Double-click `sldprt`. 
3. In the File Type Properties dialog box, under **This file can have drawing nodes with the following extensions**, specify the file types to be checked for references.

   The file type `slddrw` is listed by default.

   To add the file type `drw`, type a comma (, ) and type `drw`, so that the field reads `slddrw,drw`.

   Do not include periods (`.`)

4. Click **OK**.

When you check a `.sldprt` file out or in, Enterprise PDM looks for references to the file in all files of type `slddrw` and `drw`.

In the Check Out or Check In dialog box, drawings that are sub-parents to the `.sldprt` file appear in blue above the `.sldprt` file so you can choose to check them out or in.

This functionality replaces two options on the File Type Properties dialog box in previous versions of Enterprise PDM:

- Do not show "sub-parents" for this file type
- Show this file type as a "sub-parent" (drawing)

**API**

For information on using the Enterprise PDM API, see the *SolidWorks Enterprise PDM Programmer's Reference Guide*. To access the guide, right-click **Add-ins** and click **Programmer’s Reference Guide**.

**Adding Commands to Submenus**

You can now structure add-in commands so that they appear in submenus.

You can structure cascading menus by adding backslashes to menu strings.

You do not need to do this programmatically.

For example, when you configure a task, you can make the task command appear to users in a **Tasks** submenu by writing the menu command with a backslash.

In the task’s Properties wizard, on the Menu Command screen, for **Menu command**, type `Tasks\command_name`. In File Explorer, users see:

![Tasks Menu](image)

**Using an Add-in to Define Item Explorer Menu Commands**

You can define menu commands to be used in Item Explorer.

You can add commands to:

- Shortcut menus for files, items, and folders
- The Item Explorer Tools menu
• The Item Explorer toolbar

**Updating the BOM Quantity Using the API**
You can now update the BOM quantity using the API without having a pre-defined BOM view.

**Installation**

**SQL-DMO Drivers**
It is no longer necessary to install SQL-DMO drivers when deploying Enterprise PDM clients using an administrative installation image. Enterprise PDM components now communicate with SQL Server 2008 or SQL Server 2005 using ODBC.
Two new modules, Electronic Cooling and HVAC Design, enhance Flow Simulation by helping you quickly solve specific industry problems.

These modules are available in the Flow Simulation CommandManager or on the Flow Simulation menu.


This chapter includes the following topics:

- Electronic Cooling Module
- HVAC Design

**Electronic Cooling Module**

The electronic cooling module provides accurate thermal analysis of printed circuit boards (PCBs) and enclosure designs based on more realistic modeling of individual components and PCBs.

These factors improve the accuracy of the thermal modeling:

- The engineering database now contains more materials and components, and a PCB generator, for the precise thermal modeling of a multilayer PCB.
- The module accounts for the effects of Joule heating.
- You can choose to represent geometry as a two-resistor model.

**HVAC Design**

The HVAC module evaluates the impact of air quality and temperature on products or people. For example, the module can analyze a vehicle's air conditioning unit, a server room's cooling system, or a building's ability to clear smoke. The inclusion of building materials and the calculation of materials that are semitransparent to radiation, such as glass, make the thermal simulation of buildings and most enclosures easier and more accurate.
This chapter includes the following topics:

- Exporting .IFC Files
- DXF DWG Import Wizard
- Exporting Sheet Metal Parts to DXF or DWG Files

Exporting .IFC Files

You can export SolidWorks® models to the Industry Foundation Classes .ifc files format.

To export SolidWorks models as .ifc files:

1. Click File > Save As.
2. For Save as type, select IFC 2x3.
3. Navigate to the correct folder and enter a file name.
4. Click Options, select the OmniClass™ and units, and click OK.
5. Click Save.

For more information, see SolidWorks Help: .IFC Files.

DXF DWG Import Wizard

Importing Layers from .DWG or .DXF Files

When importing a .dwg or .dxf file as a 2D sketch for a part, you can create a new sketch for each layer in the file.

1. Open a .dwg file with layers.
2. In the DXF/DWG Import wizard, select Import to a new part as and 2D sketch.
3. Click Next.
4. Select Import each layer to a new sketch.
5. Select other options and click Next or Finish.

Defining the Sketch Origin and Orientation on .DWG or .DXF Import

When importing a .dwg or .dxf file as a 2D sketch for a part, you can define the model origin and orientation.

1. Open a .dwg file.
2. In the DXF/DWG Import wizard, select Import to a new part as and 2D sketch.
3. Click Next.
4. Select part document options and click Next.
5. Click **Define Sketch Origin** and click a point in the sketch preview to define the origin.

6. Adjust the origin values and click **Apply**.

7. To change the model orientation about the origin, select **Rotate about the origin** and enter the angle of rotation.

8. Select other options and click **Finish**.

**Filtering Sketch Entities on .DWG or .DXF Import**

When importing a .dwg or .dxf file as a 2D sketch for a part, you can filter out unnecessary entities.

1. Open a .dwg file.

2. In the DXF/DWG Import wizard, select **Import to a new part as** and **2D sketch**.

3. Click **Next**.

4. Select part document options and click **Next**.

5. In the preview, select entities to remove and click **Remove Entities**.

   To undo this action, click **Undo Remove Entities**.

6. Select other options and click **Finish**.

**Repairing Sketches After .DWG or .DXF Import**

When importing a .dwg or .dxf file as a 2D sketch for a part, you can launch the SolidWorks Repair Sketch tool from the DXF/DWG Import Wizard to fix gap or overlap errors after import.

1. Open a .dwg file.

2. In the DXF/DWG Import wizard, select **Import to a new part as** and **2D sketch**.

3. Click **Next**.

4. Select part document options and click **Next**.

5. Select **Run Repair Sketch**.

6. Select other options and click **Finish**.

**Exporting Sheet Metal Parts to DXF or DWG Files**

**Exporting a Bounding Box**

When exporting a sheet metal part as a .dxf or .dwg file, you can export the bounding box and assign the bounding box to a specific layer.

To assign the bounding box sketch to a layer:

1. Click **File > Save As**.

2. For file type, select .dxf or .dwg.

3. Click **Options**.

4. In the DXF/ DWG Output PropertyManager, under **Entities to Export**, select **Bounding box**.

5. Select other options and click **✓**.

6. In the SolidWorks to DXF/DWG Mapping dialog box:
Exporting Bend Line Directions
You can map bend line directions to specific layers when you export sheet metal models as .dxf or .dwg files. For example, in sheet metal parts with up and down bend directions, you can map the different bend line directions to separate layers when you export the part.

To export and map bend line directions for a sheet metal part:

1. Click **File > Save As**.
2. For file type, select `.dxf` or `.dwg`.
3. Click **Options**.
4. Under **Custom Map SolidWorks to DXF/DWG**, select **Enable**.
5. Set other export options and click **OK**.
6. In the DXF/ DWG Output PropertyManager, under **Entities to Export**, select **Bend lines**.
7. Select other options and click **✓**.
8. In the SolidWorks to DXF/DWG Mapping dialog box:
   - Assign layers to entities.
   - Map other properties.
   - Click **OK**.
Large Scale Design helps you use the tools that the SolidWorks® software offers for creating equipment, facilities, and plants.

This chapter includes the following topics:

- **Walk-through**
- **Exporting .IFC Files**
- **Grid System**

### Walk-through

You can use the **Walk-through** function to explore or create a video of the 3D geometry of plants or other systems. You “see” the geometry of the system as you maneuver through it. You can save what you see and play it back for further study.

To activate the function, click **View > Lights and Cameras > Add Walk Through**.

Define motion constraints and other parameters, such as the camera height, in the PropertyManager, and click **Capture Motion** to open the control panel. Define your starting point, click **Record**, and use the controls to maneuver through the system.

You can also use the arrow keys and the mouse to maneuver through the system. You may eventually find that a combination of mouse and keyboard controls allows you to maneuver through the system most efficiently.

To use the mouse, left-click to manipulate the view.

The keyboard controls are:
<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrows</td>
<td>Move forward or back, turn left or right.</td>
</tr>
<tr>
<td>Shift + arrows</td>
<td>Move up, down, left, or right.</td>
</tr>
<tr>
<td>Control + arrows</td>
<td>Turn up or down.</td>
</tr>
<tr>
<td>Alt + arrows</td>
<td>Look up, down, left, or right. Press the Alt and arrow keys simultaneously.</td>
</tr>
<tr>
<td>Home</td>
<td>Reset “view” direction.</td>
</tr>
<tr>
<td>Z, Shift + Z</td>
<td>Zoom out or in.</td>
</tr>
<tr>
<td>+, -</td>
<td>Increase or decrease speed.</td>
</tr>
<tr>
<td>1 - 9</td>
<td>Set speed.</td>
</tr>
<tr>
<td>Scroll Lock</td>
<td>Lock to constraint.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Next constraint.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Previous constraint.</td>
</tr>
<tr>
<td>R</td>
<td>Record.</td>
</tr>
<tr>
<td>Space</td>
<td>Pause.</td>
</tr>
<tr>
<td>Esc</td>
<td>Cancel.</td>
</tr>
<tr>
<td>M</td>
<td>Toggle map view.</td>
</tr>
</tbody>
</table>

### Exporting .IFC Files

You can export SolidWorks® models to the Industry Foundation Classes .ifc files format.

To export SolidWorks models as .ifc files:

1. Click **File > Save As**.
2. For **Save as type**, select **IFC 2x3**.
3. Navigate to the correct folder and enter a file name.
4. Click **Options**, select the OmniClass™ and units, and click **OK**.
5. Click **Save**.

For more information, see *SolidWorks Help: IFC Files*.

**Grid System**

You can use the **Grid System** tool to lay out a grid system for large structures. The grid system is useful when creating welded structures. The grid system is also helpful when you work with multiple users who use different third-party applications to make grids. Multiple users can use the grid system and work from the same baseline.

You can create a grid to help specify the location of key elements in structures. When you use the **Grid System** tool, you create a sketch to represent the grid. You can then specify the number of floors for the structure and the distance between each floor. The sketch is replicated for every floor in the structure. Balloons are attached to the grid items to help with orientation.

[Grid system sketch]

[Grid system with weldments applied]

Click **Grid System** (Features toolbar) or **Insert > Reference Geometry > Grid System**.

See *SolidWorks® Help: Creating a Grid System*.

The graphics area can appear cluttered when the grid system creates a lot of geometry or if you create multiple grid systems. To reduce clutter, you can hide the geometry.

Display options are available to help you visualize the grid structure and to ensure correct grid inferencing.
To access the display options, in the FeatureManager design tree, right-click Grid System and click View Grid Components. In the View Grid Components dialog box, select an item and click a display option, such as Normal To ↓.
This chapter includes the following topics:

- DisplayManager
- Appearances
- Lights
- Scenes
- Decals
- PhotoView 360
- Working with Appearances and Rendering a Model

DisplayManager

The SolidWorks® DisplayManager is the central location for managing appearances, decals, scenes, cameras, lights, and Walk Through. Use the DisplayManager to view, edit, and delete display items applied to the current model.

On the Manager Pane, click the DisplayManager tab. See SolidWorks Help: DisplayManager.

Appearances

All appearance functionality, including controls previously available only in PhotoView or PhotoWorks™, is now available in SolidWorks Standard. The DisplayManager lists the appearances applied to the currently active model. You can also save custom appearances in SolidWorks Standard.

On the DisplayManager tab, click View Appearances.
Lights

The DisplayManager is the central location for managing all aspects of lighting, including lighting controls that are available only when PhotoView is added in. The DisplayManager lists the lights applied to the currently active model. Controls for shadows and fog now provide a stronger integration with PhotoView. Light intensity is controlled with wattages. Lighting controls are separate for SolidWorks and PhotoView 360.

**SolidWorks**  
By default, point, spot, and directional lights are on in SolidWorks. Scene lighting is not possible in RealView, so you often need to illuminate models manually.

**PhotoView**  
By default, lighting is off in PhotoView. With lights off, you can use the realistic lighting provided by scenes, which is usually sufficient for rendering. You typically need additional lighting in PhotoView to illuminate occluded spaces in the model.

The icons for specific lights in this image from the Scene, Lights, and Cameras pane of the DisplayManager have the following meanings:

- **Directional**  
  - On in SolidWorks
  - Off in PhotoView

- **Spot**
  - Off in SolidWorks
  - Off in PhotoView

- **Point**
  - Off in SolidWorks
  - On in PhotoView

On the DisplayManager tab, click **View Scenes, Lights, and Cameras**.

See *SolidWorks Help: Lights*. 
Scenes

Scene functionality is enhanced to allow full control of the scene that is visible behind the model. The DisplayManager lists the background and environment applied to the currently active model. The new Edit Scene PropertyManager, available from the View Scene pane in the DisplayManager, lets you size the floor, control the background or environment, and save custom scenes.

On the DisplayManager tab, click View Scenes, Lights, and Cameras.

Scenes are simplified and now consist of the following:

- A spherical environment based on a preset scene or image you select is mapped around the model.
- A 2D background that can be a single color, a gradient of color, or an image you select. Although partially obscured by the background, elements of the environment are reflected in the model. You can also turn off the background and show the spherical environment instead.
- A 2D floor on which you can see shadows and reflections. You can change the distance of the model from the floor.

The Insert Picture functionality is removed. Background images in legacy models are discarded and are not displayed. You can use the Edit Scene PropertyManager to add a background image to the scene.

To save a custom scene, click Save Scene on the Advanced tab of the Edit Scene PropertyManager.

Office Space scene
Rooftop scene

Warm Kitchen scene

See *SolidWorks Help: Scenes*.

**Decals**

Decals are now part of *SolidWorks Standard*. Use the DisplayManager to view and manage decals applied to the current model.

On the DisplayManager tab, click **View Decals**.

See *SolidWorks Help: Decals*. 
PhotoView 360

PhotoView 360 is now the standard photorealistic rendering solution for SolidWorks. PhotoWorks is no longer supported. Rendering capabilities are the same as in previous releases. The underlying technology has been updated to enhance the user experience and the final results.

Available in SolidWorks® Professional and SolidWorks Premium.

Add in PhotoView 360 and select actions from the PhotoView 360 menu or from the Render Tools tab of the CommandManager.

See SolidWorks Help: Rendering with PhotoView 360.

PhotoView Integrated Preview
You can preview a rendering of the current model within the SolidWorks graphics area.
To start the preview, with PhotoView added in, click PhotoView 360 > Integrated Preview.

PhotoView Preview Window
The PhotoView Preview window lets you anticipate how changes to a SolidWorks model affect the final rendering of the model.
With PhotoView 360 added in, click PhotoView 360 > Preview Window.

See SolidWorks Help: PhotoView Previewing Renders.
Motion
Animations are rendered using PhotoView.
Right-click the Motion Study tab and click Create New Motion Study.

PhotoView Support on 64-bit Computers
Native support for the PhotoView 360 application on 64-bit platforms lets PhotoView use all available system memory.

Working with Appearances and Rendering a Model
In this example, you use the DisplayManager, change appearances on a model, and add a decal. If you have installed SolidWorks Professional or Premium, you make further adjustments to lighting and scenes before completing a final render.

Learning About the DisplayManager
To start working with the model:

1. Open install_dir\samples\whatsnew\display\tractor_in_box.SLDASM.

2. In the Manager Pane, click the DisplayManager tab.

   ![DisplayManager Tab]

   The DisplayManager catalogs the appearances, decals, and scenes, lights, and cameras applied to the model.

3. Under the DisplayManager tab, click View Appearances.
4. In Sort order, select Hierarchy.
5. Expand Face.
   The black appearance is applied to faces of the box. Expand the black appearance to see where it is applied.

Adding and Editing an Appearance
In this section, you add an appearance to a part in the model and edit the appearance.

1. Open the box part in its own window. In the graphics area, right-click the black box and click Open Part (Context toolbar).
Why do you open the part in its own window?
- You want to change the appearance of the inside of the box only. By default, in assemblies, appearances are applied to components, overriding part appearances. You edit the part to gain more control over where to apply the appearance.
- In a subsequent step, you apply a decal. We recommend applying decals to parts, not to assemblies.

2. In the Task Pane, on the Appearances, Scenes, and Decals tab, click **Appearances > Plastic > Textured**.
3. In the bottom pane, **Alt + double-click PW-MT11010** to apply it to the entire part and to open the Appearance PropertyManager.

4. In the PropertyManager, edit the appearance:
   a) On the Color/Image tab, under **Color**, change the color to medium grey.
      ![Color Palette](image)
   b) Click **Advanced**.
   c) On the Illumination tab, set **Specular Amount** to 0.10 to create a matte appearance that reflects almost no light.
   d) Click **✓**.
5. Review your work:
a) On the Appearances pane of the DisplayManager, in **Sort order**, select **Hierarchy**.
b) Expand **Parts/Assemblies** and **Face**.

The entire part has the **PW-MT11010** appearance. Because the faces are highest in the hierarchy, their appearance, **black**, overrides the appearance at the part level.

---

**Adding a Decal**

In this section, you add a decal to the part. In SolidWorks 2011, you can add decals without loading any add-in applications.

1. Zoom in to the small rectangular panel inside the front of the box, where you will place the decal.

2. In the Task Pane, on the Appearances, Scenes, and Decals tab, click **Decals**.
3. Drag the **logo** decal to the rectangle.

4. In the Decals PropertyManager, on the Mapping tab:
   a) Select **Fit height to selection**.

   The decal adjusts to fit the rectangle.

   b) Click ✔️.
Changing Another Appearance on the Model

Return to the assembly and apply an appearance to the tractor.

1. Click Window > Tractor_in_box.SLDASM. If you are prompted to rebuild the model, click Yes.
2. Zoom in to the tractor.
3. Change the appearance of the rear exhaust pipe:
   a) In the Task Pane, on the Appearances, Scenes, and Decals tab, click Appearances > Metal > Chrome.
   b) Drag burnished chrome to the rightmost stack.
   c) On the popup toolbar, click Assembly.
4. Press F to fit the entire assembly in the graphics area.

If you have installed SolidWorks Professional or SolidWorks Premium, then PhotoView 360 is available and you can continue to the next steps.

Preparing to Render: Working with Lighting and Scenes

So far, you have performed all steps in the SolidWorks software without adding in PhotoView 360. In preparation for rendering, add in PhotoView and use the Preview window to anticipate the effect of further changes.

1. On the Office Products tab of the CommandManager, click PhotoView 360 to add in PhotoView.
2. Click PhotoView 360 > Preview Window. Arrange or resize the Preview window so that you can see the graphics area.
   While it is open, the Preview window remains on top of the SolidWorks window.
  💡 Instead of opening a new window, you can also preview renders directly in the SolidWorks graphics area. Click PhotoView 360 > Integrated Preview.
3. The light inside the box is too dim. Adjust the lighting:
   a) In the DisplayManager, click View Scenes, Lights, and Cameras.
   b) Expand Lights. Right-click Point2 and click On in PhotoView.
      By default, lights are off in PhotoView because scene lighting is usually sufficient to illuminate the model.
      The PhotoView icon next to Point2 is enabled to indicate that the point light is on in PhotoView. The Preview window updates. The image in the graphics area does not change because your action does not affect SolidWorks.
   c) Right-click Point2 and select Edit Point Light to increase the brightness of the light.
   d) On the Basic tab, select Keep light when scene changes.
e) On the PhotoView tab, under **PhotoView controls**, set **Brightness** to 0.15.

f) Click ✔.

💡 If you are not satisfied with the lighting provided by a scene, you can either adjust the lights in the current scene or try a new scene. Changing the scene removes all directional, point, and spot lights unless you select **Keep light when scene changes** in the PropertyManager for each light.

4. Change the scene to affect lighting and highlights.
   a) In the Task Pane, on the **Appearances, Scenes, and Decals** tab, click **Scenes > Basic Scenes**.
   b) From the bottom pane, drag **Backdrop - Studio Room** into the graphics area. The Preview window updates.

**Performing a Final Render**
You are now ready to perform the final render.

1. Click **PhotoView 360 > Final Render**.
   The Render Frame dialog box opens and rendering begins.

2. Click **Save Image**.
3. Browse to the directory, type a file name, and select the type of image to save.
4. Click **Save**.
This chapter includes the following topics:

- **Manual Mode for Creating Parting Surfaces**

**Manual Mode for Creating Parting Surfaces**

You can create parting surfaces using **Manual Mode**, which lets you modify surface direction. **Manual Mode** lets you override the defined parting surface direction and manually create a portion of the surface.

Select **Manual Mode** in the Parting Surface PropertyManager to display handles that you can manipulate to adjust the parting surface. To further modify the surface, right-click an inner vertex and select **Start fill surface region** or **End fill surface region**.

The first image below shows an irregular parting surface. In the second image the surface has been fixed.
This chapter includes the following topics:

- Function Builder for Force and Motor Functions
- User Interface Changes
- Reflected Load Inertia and Reflected Load Mass
- Reference Components for Linear Couplers
- Motion Along a Path

Function Builder for Force and Motor Functions

You can use the Function Builder to define motor or force profiles from an imported data set. You can also use the Function Builder to define a motor or force profile from a mathematical expression or from interpolated functions along connected segments. For motor profiles, you can specify time, cycle angle, or any result as the independent variable.

To open the Function Builder from a motion study, click Motor 🎥 (MotionManager toolbar) and in the PropertyManager, for Motor Type, click one of the following:
• **Segments.** Defines profile from piecewise continuous functions of time or cycle angle.
• **Data Points.** Defines profile from an interpolated data set as a function of time, cycle angle, or motion study results.
• **Expression.** Defines profile as mathematical expression of time, cycle angle, or motion study results.

You can also access the Function Builder from the Force PropertyManager.

Some Function Builder options are not available for **Animation** or **Basic Motion** study types.

For more information, see *SolidWorks® Help: Motor and Force Profiles*.

### User Interface Changes

The Force and Motor PropertyManagers have minor user interface changes for interpolated profiles or profiles defined from expressions.

- The **Interpolated** force or motor type is now the **Data Points** type.
- The user interface options for the **Interpolated** and **Expression** force or motor types are no longer available in the PropertyManager.
- Selecting **Data Points** or **Expression** now launches the Function Builder.
- To modify an existing **Data Points** or **Expression** motor or force type, select the motor or force type and click **Edit**.

For more information, see *SolidWorks Help: Motor and Force Profiles*.

### Reflected Load Inertia and Reflected Load Mass

For **Motion Analysis** studies, you can compute and plot the reflected load mass for linear motors and the reflected load inertia for rotary motors.

To create reflected load inertia results:

1. From a **Motion Analysis** study, click **Results and Plots**.
2. For **Category**, select **Other Quantities**.
3. For **Subcategory**, select **Reflected Load Inertia**
4. For the first selection component, select a constant speed rotary motor from the MotionManager tree.
5. Select **Plot Results** options and click **✓**.

### Reference Components for Linear Couplers

You can select reference components for components mated for linearly coupled motion. When required, select reference components when you specify linear/linear coupler mates in the Mates PropertyManager.
For more information, see SolidWorks Help: Motion for Components Mated with Linear Couplers.

**Motion Along a Path**

For Motion Analysis studies, you can define a path mate motor to specify displacement, velocity, or acceleration values as a body moves along a path.

To define a path mate motor:

1. From a Motion Analysis study, click **Motor**.
2. For **Path Mate**, under Mates in the FeatureManager design tree, select a path mate.
3. Select the motor profile.
   
  💡 To define the motor profile from a function or from data, click **Expression**, **Data Points**, or **Segments**.

4. Select options and click ✔️.
   
  💡 To reverse the motor direction, for Mates/Direction, click **Reverse Direction**.
Parts and Features

This chapter includes the following topics:

- Parts
- Features
- Surfaces
- FeatureWorks

Parts

**Defeature for Parts**

With the **Defeature** tool, you can remove details from a part or assembly and save the results to a new file in which the details are replaced by dumb solids (that is, solids without feature definition or history). You can then share the new file without revealing all the design details of the model.

Click **Defeature** (Tools toolbar) or **Tools > Defeature** to access the Defeature PropertyManager, which provides tools for manual and automatic selection of details to keep and remove.

![Before](image1.png)  ![After](image2.png)

For a step-by-step example, see **Defeature for Assemblies** on page 25.

Equations

**Sharing Equations Among Models**

You can share equations and global variables among models.

You export selected equations and variables from a model to an external text (.txt) file. Alternatively, you can build the text file manually using an application such as Notepad. Then you import information from the text file into other models. You can choose to link
models to the text file, so that changes you make in the text file update the equations and variables in the models.

**Exporting Equations**
In this example, you export equations from a part to a text file.

1. Open `install_dir\samples\whatsnew\parts\frontplate_01.sldprt`.

2. Click **Tools > Equations**.
The Equations dialog box lists five equations.

3. Click **Export**.
All the equations are listed in the Equations Export dialog box. Under **Active**, all the equations are selected for export. **Link to file** is selected as well.

4. Click **Save**.
5. In the Save As dialog box, for **File name**, type `my_equations`.
6. Click **Save**.
The equations are saved in a text file. The text file is available to import into other parts and assemblies. Because **Link to file** was selected, changes you make in the text file are propagated to the model.

   In the Equations dialog box:
   - Under **Active**, the icon ![indicating linked equations](image) indicates equations that are linked to the external file.
   - At the bottom of the dialog box, **Linked File** displays the path to the external file.

7. Click **OK**.
8. Save the part. If prompted to rebuild, click **Yes**.

**Importing Equations**
Now import the equations from the text file to another part.

1. Open `install_dir\samples\whatsnew\parts\backplate_01.sldprt`.

2. Click **Tools > Equations**.
3. In the Equations dialog box, click **Import**.
4. In the Open dialog box:
   a) Select `my_equations.txt`.
   b) Select **Link to file**.
   c) Click **Open**.

   Five equations are imported into the model.
In the Equations dialog box:

- Under **Active**, the icon indicates equations that are linked to the external file.
- At the bottom of the dialog box, **Linked File** displays the path to the external file.

5. Click **OK**.

6. Click **Rebuild** (Standard toolbar).
   The equations are applied to the model.

7. Save the part.

**Suppression States of Features and Components**
You can use equations to control the suppression state of part features and assembly components.
In the Add Equation dialog box, you use the Visual Basic `IIf` function to specify when to suppress or unsuppress a feature or component.

💡 The syntax of the Visual Basic `IIf` function is:

\[
iif(\text{expression}, \text{truepart}, \text{falsepart})
\]

where:
- **expression** is the expression you want to evaluate
- **truepart** is the value to use if **expression** is true
- **falsepart** is the value to use if **expression** is false

**Defining a Feature Suppression Equation**
In this example, you suppress a hole in a plate when the length of the plate is less than 40 mm.

The hole you want to suppress is part of a linear pattern, so you define an equation to suppress or unsuppress the linear pattern feature depending on the part length.

To suppress the feature:

1. Open **frontplate_01.sldprt** from the previous example.

2. In the FeatureManager design tree, right-click **Equations** and click **Add Equation**.
   The Equations and Add Equations dialog boxes open.

3. In the FeatureManager design tree, click the linear pattern feature **LPattern1**.
"LPattern1" appears in the Add Equations dialog box.

If Instant 3D is active, you need to click-pause-click LPattern1. The first click selects the linear pattern. The second click adds it to the Add Equations dialog box.

4. In the dialog box, complete the equation:
   "LPattern1" = iif ("overall length"<40, "suppressed", "unsuppressed")

  💡 You can type the entire equation or use the following tips to enter various pieces:
   - To insert global variable "overall length", expand Equations in the FeatureManager design tree and click "overall length"=100.
   - To insert "suppressed" and "unsuppressed", click the suppress and unsuppress buttons in the dialog box.

5. Click OK.
   The new equation is added to the Equations dialog box.

6. Click OK.

Testing the Feature Suppression Equation
Now decrease the length of the part to 35 mm, which triggers the suppression of the linear pattern feature.

The length of the part (length@outline) is controlled by the global variable "overall length", which is defined in the linked external file.

To trigger the suppression state equation:
1. Open my_equations.txt.
2. For "overall length", change 100 to 35.
3. Save the text file.
4. Click Rebuild (Standard toolbar).
   The external equations file is checked for changes and the length of the part is updated from 100 to 35. Because the length is now less than 40 mm, LPattern1 is suppressed, which eliminates the second hole.

5. Edit my_equations.txt again, and change "overall length" back to 100.
6. Save and close the text file.
7. Click Rebuild (Standard toolbar).
   The external equations file is checked for changes and the length of the part is updated from 35 to 100. Because the length is now greater than 40 mm, LPattern1 is unsuppressed.
8. Save the part.

**Exporting the Feature Suppression Equation**
Now add the new equation to the external text file.

1. In the FeatureManager design tree, right-click **Equations** and click **Edit Equation**.
2. In the dialog box, click **Export**.
   The new equation appears at the bottom of the list.
3. Click **Save**.
4. In the Save As dialog box, select my_equations.txt and click **Save**. When asked to replace the existing file, click **Yes**.
5. Click **OK**.
6. Open my_equations.txt.
   The feature suppression equation appears in the text file.

**Defining a Component Suppression Equation**
Now use an equation to suppress a component in an assembly.

1. Open `install_dir\samples\whatsnew\parts\plate_assembly_111.sldasm`. If prompted to rebuild, click **Yes**.

   First, import `my_equations.txt` so that you can use the global variable "overall length" in the component suppression equation.

2. Click **Tools > Equations**.
3. In the Equations dialog box, click **Import**.
4. In the Open dialog box:
   a) Select `my_equations.txt`.
   b) Select **Link to file**.
   c) Click **Open**.
   Because the assembly does not contain all the same dimensions as the parts, warnings about invalid equations appear.
5. Click **OK** to dismiss each warning.
Two equations are imported into the model, including global variable "overall length".

6. Click OK to close the Equations dialog box.

Now add an equation to suppress the second instance of the pin when overall length is less than 40 mm.

7. In the FeatureManager design tree, right-click **Equations** and click **Add Equation**.

8. In the FeatureManager design tree, click **pin<2>**. "pin<2>" appears in the Add Equation dialog box.

9. In the dialog box, complete the equation:

   "pin<2>" = iif ( "overall length"<40, "suppressed" , "unsuppressed" )

   - You can type the entire equation or use the following tips to enter various pieces:
     - To insert global variable "overall length", expand **Equations** in the FeatureManager design tree and click "overall length"=100.
     - To insert "suppressed" and "unsuppressed", click the **suppress** and **unsuppress** buttons in the dialog box.

10. Click OK.

    The new equation is added to the Equations dialog box.

11. Click OK.

12. Save the assembly. In the Save Modified Documents dialog box, click **Save All**. If prompted to rebuild, click **Yes**.

**Testing the Component Suppression Equation**

Now decrease the overall length to 35 mm, which triggers the suppression of the linear pattern feature in the two parts and the suppression of the second instance of the pin in the assembly.

1. In **my_equations.txt**, for "overall length", change 100 to 35.

2. Save the text file.

3. In the assembly, click **Rebuild** (Standard toolbar).

   The length of the plates changes to 35 mm and the linear pattern is suppressed. In the assembly, the second instance of the pin is suppressed.

**Global Variables**

You can configure global variables.

In a design table, the column header for controlling the value of a global variable uses this syntax:
In the table body cells, type the value for the global variable. If you leave a cell blank, it inherits the value from the configuration that was active when you opened the design table.

Example:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Design Table for: pump</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>small</td>
<td>250</td>
</tr>
<tr>
<td>4</td>
<td>large</td>
<td>600</td>
</tr>
</tbody>
</table>

**Features**

**Helix**

The PropertyManager and callouts are enhanced. Methods of defining a **Variable pitch** helix have been expanded.

**PropertyManager and Callouts**

The PropertyManager and callouts display more information.

- Callouts for **Constant pitch** cases are now displayed in the graphics area, similar to those that already appear for **Variable pitch** cases.
- The callouts show all parameters, including those that are for information only (shown in gray).
- In the PropertyManager, for **Variable pitch**, the table now shows all parameters, including those that are inactive or for information only (shown in gray).

<table>
<thead>
<tr>
<th></th>
<th>H (mm)</th>
<th>Rev</th>
<th>P (mm)</th>
<th>Dia (mm)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>50</td>
<td>0</td>
<td>5</td>
<td>20</td>
</tr>
<tr>
<td>2</td>
<td>150</td>
<td>20</td>
<td>5</td>
<td>20</td>
</tr>
<tr>
<td>3</td>
<td>200</td>
<td>25</td>
<td>5</td>
<td>20</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Variable Pitch Helix**

You can define a **Variable pitch** helix by specifying **Height and Revolution**.
Previously, only **Pitch and Revolution** and **Height and Pitch** were available for **Variable pitch**, and you could use **Height and Revolution** only when defining a **Constant pitch** helix.

In a part, select a sketch that contains a circle. Click **Insert > Curve > Helix/Spiral**. In the PropertyManager, under **Defined By**, select **Height and Revolution**. Under **Parameters**, select **Variable pitch**. Enter values for **H** and **Rev** in the table.

---

### Revolve

More end conditions are available when creating a revolve feature.

New end conditions include:

- **Up To Vertex**
- **Up To Surface**
- **Offset From Surface**

You can specify separate end conditions for each direction (clockwise and counter-clockwise from the sketch plane).

The new end conditions are available when you click the following:

- **Revolved Boss/Base** (Features toolbar) or **Insert > Boss/Base > Revolve**
- **Revolved Cut** (Features toolbar) or **Insert > Cut > Revolve**
- **Revolved Surface** (Surfaces toolbar) or **Insert > Surface > Revolve**

In the PropertyManager, under **Direction1**, in **Revolve Type**, select an end condition. Select **Direction2** to specify an end condition for the second direction.

Example: For this revolved boss, the end condition is **Up To Surface** for **Direction1** and **Direction2**.
Scale
You can configure the X, Y, and Z scale factors.

Use one of the following methods:

PropertyManager Under Configurations, specify the configurations to which the scale factors apply.

Design Table The column headers for controlling the X, Y, and Z factors of a scale feature use this syntax:

$X\_AXIS@scale\_feature\_name
$Y\_AXIS@scale\_feature\_name
$Z\_AXIS@scale\_feature\_name

Example:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Design Table for: bracket</td>
<td>$X_AXIS@scale1</td>
<td>$Y_AXIS@scale1</td>
<td>$Z_AXIS@scale1</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>$X_AXIS@scale2</td>
<td>$Y_AXIS@scale2</td>
<td>$Z_AXIS@scale2</td>
</tr>
<tr>
<td>3</td>
<td>plastic</td>
<td>1.5</td>
<td>1.7</td>
<td>1.3</td>
</tr>
<tr>
<td>4</td>
<td>metal</td>
<td>1.07</td>
<td>1.07</td>
<td>1.12</td>
</tr>
</tbody>
</table>

💡 For uniform scaling, only $X\_AXIS@scale\_feature\_name needs to be defined.

Surfaces

Surface Extrudes From a 2D or 3D Face
You can create extruded surfaces from models that include 2D or 3D faces and knit the extruded surfaces to surrounding features.
Click **Insert > Surface > Extrude**.

1. Select a face:
   - To extrude from a 3D face, select a 3D face.
   - To extrude from a 2D face, press `Alt` + select the planar face.

2. Select the end condition.

3. For 3D faces, select a plane, edge, 2D face, or sketch line to define the direction of extrusion.

   ![Select a plane to define an extrude direction normal to the plane.](image)

4. To remove the faces defining the extrude from the model after extruding, click **Delete original faces**.

5. To create a single body from the extrude when faces are deleted, select **Knit result**.

6. Set other options and click **✓**.

**Surface Extrudes from Faces**

You can create extruded surfaces from models that include 2D or 3D faces and knit the extruded surfaces to surrounding features.

In this example, you examine a part that has two surface extrudes. Both extrudes are created from three contiguous faces: one planar face and two 3D faces.
Opening the Model
First, you open the model and examine some components.

1. Open 
   `install_dir\samples\whatsnew\surfaces\multiface-surf-extrude_example.SLDPRT`.

2. Notice the surface extrude features in the FeatureManager design tree.
   The two extrusions into and out of the central portion of the model were created by selecting three faces, deleting the original faces, and capping one end of the extrusion.
Viewing the Surface Extrude Options
Next, you examine the options used to specify the surface extrude for the model.

1. Click Surface-Extrude2 and click Edit Feature.

2. To view one of the 3D faces used to create the surface extrude, select Face<1> under Faces to Extrude in the PropertyManager.

3. To view the other faces used to create the surface extrude, select each of them under Faces to Extrude in the PropertyManager.
A 3D face defines each end portion of the extrude.

A planar face defines the middle portion of the extrude.

4. To display the plane defining the direction of extrusion, click **Front Plane** in the PropertyManager. Notice the extrude direction is normal to the front plane.

5. Note the selected options:
   - **Cap end**. Seals the **Direction 1** end of the extrude with a translated copy of the selected 3D face.
   - **Delete original faces** 🗑️. Deletes the faces selected under **Faces to Extrude** 🚧. The 3D faces are removed from the model.
   - **Knit result** 🧵. Knits the resulting extrude to the surface boundary where the original face is deleted.

6. Close the PropertyManager.
To examine the other surface extrude created from 3D faces, rotate the model and repeat Steps 1 - 6 for **Surface-Extrude3**.

Viewing the Original Surface Before the Extrude
Next, you suppress a surface extrude to view the surface before the extrude.

1. Click **Surface-Extrude2** and select **Suppress**.

    The three faces were created by splitting the surfaces with a Split Line feature.

2. Press `Ctrl` + select the three faces in the middle to view the original surface used to create this model.

3. Close the model without saving it.
Capping an Extruded Surface
You can cap an extruded surface at one end or at both ends.

Click Insert > Surface > Extrude. To seal an end of the extrude, under Direction 1 in the PropertyManager, select Cap end.

You can seal the other end of the extrude by selecting Cap end under Direction 2. When you cap both ends of an extrude to define an enclosed volume, a solid is created automatically.

Set other options and click ✓.

FeatureWorks

Available in SolidWorks® Professional and SolidWorks Premium.

Bosses and Cuts Recognition
Feature recognition is enhanced and new feature types are recognized.

Interactive Recognition of Boss and Cut Sweeps
FeatureWorks® recognizes boss sweep and cut sweep features during interactive recognition when two faces are selected.

Boss Sweep

1. Open install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-BossSweep.x_t.
2. First recognize the upper boss sweep. During interactive recognition of boss sweep features, select End Face1 and End Face 2/Support Face.

3. Then, recognize the lower boss sweep. Select End Face1 and End Face 2/Support Face.
In the FeatureWorks PropertyManager under Interactive Features, the Boss-Sweep feature type replaces Base-Sweep. Boss-Sweep recognizes both base and boss sweeps.

**Cut Sweep**

1. Open `install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-CutSweep.x_t`.
2. Use interactive recognition and under Feature type, select Cut-Sweep.
3. Select End face and then select End Face 1.

4. Select End Face 2. If necessary, rotate the model.

**Interactive Recognition of Cut Revolve Features**

FeatureWorks recognizes cut revolve features of the type known as "pencil sharpening cuts" during interactive recognition.

1. Open `install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-Pencil.x_t`.
2. During interactive recognition of cut revolve features, select the face of the cut revolved feature.
Do not select the top planar face. Verify that Chain revolved faces is cleared.

Interactive and Automatic Recognition of Bosses and Cuts From Non-Planar Faces
FeatureWorks recognizes extrude features (bosses and cuts) that are created from non-planar faces in both interactive and automatic recognition modes.

1. Open 
   `install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-NonPlanar_1.x_t`
2. Use automatic recognition and under Automatic Features, select Extrudes.
   Previously, FeatureWorks could recognize only the highlighted boss extrude.

FeatureWorks now recognizes the original boss extrude as well as the four boss extrudes created from the non-planar face.

The extrudes must be exact offsets from the supporting face.

1. Open 
   `install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-NonPlanar_2.x_t`
2. Use automatic recognition and under Automatic Features, click Check all filters

FeatureWorks recognizes one base revolve, ten cut extrudes, nine holes, two chamfers, and 42 fillets. FeatureWorks finds two circular patterns. FeatureWorks maps all of the features automatically.
Automatic Recognition of Draft Features

FeatureWorks recognize draft features during automatic recognition. Drafts were previously recognized only in interactive mode.

1. Open `install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-Draft.x_t`
2. In automatic recognition mode, select Standard features. Under Automatic Features, select Drafts and Fillets/Chamfers only.

FeatureWorks maps all of the features automatically.

Combining Like Features During Automatic Feature Recognition

Automatic feature recognition can now combine fillets, chamfers, or holes of the same geometry into a single feature. For example, seven fillets with the same radius are recognized as one feature. This reduces the number of features in the FeatureManager design tree and lets you group features together for better readability and smaller file size.

1. Open `install_dir\samples\whatsnew\FeatureWorks\FeatureWorks-CombineFeatures.x_t`
Previously, FeatureWorks recognized 36 chamfers in this example. Now, one chamfer feature appears in the FeatureManager design tree.

To turn off the combine features functionality, click FeatureWorks Options (Features toolbar) or Insert > FeatureWorks > Options. On the Advanced Controls tab, under Automatic Recognition, select or clear Combine Fillets, Combine Chamfers, or Combine Holes.
Routing

Available in SolidWorks® Premium.

This chapter includes the following topics:

- Routing Library Manager
- Route Along Existing Geometry
- Weld Gaps
- Autosize
- Moving and Rotating a Fitting
- P&ID Import
- P&ID Report
- Routing Options in Isolate

Routing Library Manager

The Routing Library Manager is a new interface that can be run without launching the SolidWorks® application. It provides access to several existing and new functions.

To open the Routing Library Manager, click Routing > Routing Tools > Routing Library Manager. Click on a tab to open a wizard or tool. Tabs are available for the following functions:

- Wizards for creating routing components, and cable/wire, covering, and electrical component libraries
- The Routing File Locations tab for defining library paths
- The Administration Tool for managing a database and filtering parts
- The Tag Schema Manager for defining the syntax and format of tags in imported schematics

The Routing Library Manager provides the following new functionality:

- The Routing Component Wizard lets you configure additional types of components such as o-lets and elbows, pipes, and equipment. To use the wizard, create the geometry of the part and click the Routing Component Wizard tab.
• You can use the Tag Schema Manager to define the syntax and format of tags in imported schematics, which allows SolidWorks to interpret the data in P&ID documents. You can define the number of fields in each tag, the name of each field, and the number of characters in each field. You can also define the delimiter character.

• The Administration Tool lets you manage the database that is used to select SolidWorks parts when you create a design from an imported P&ID. You can add part information from the Routing Component Library to the database. You can also define or change property values and add new properties for parts in the database. When you use a P&ID to create a design, this database is searched for parts that correspond to information available in the schematic and a filtered list appears. You can select a part from this list.

**Route Along Existing Geometry**

You can create a route at a defined distance from a surface, using a pipe segment or a planar surface or face as a reference. The distance is calculated from the outer surface of the pipe, unless the centerline is specified.

There are two ways to define the distance:

• Use the **Smart Dimension** tool to define the offset distance.
• Select the route segment you want to offset and then **Ctrl** + select the reference object. Select **Route Along** in the PropertyManager and then type the distance in the Modify dialog box.

![Route Along Existing Geometry](image)

**Weld Gaps**

You can add weld gaps to routes between pipes and fittings, using global or joint-specific offset values.

You can define weld gaps when you start a route or at any point after you have started it.
• To define when you start a route, select **Use weld gaps** in the Route Properties PropertyManager and type an offset value in the text box that appears. This value applies to all weld gaps in the route.
• To define after you have created a route, or to edit one or more values, right-click a segment and select **Weld Gap**. Type a new value for an individual weld gap in the weld gap label, or make global changes in the Weld Gap Settings PropertyManager. You can also click **Weld Gap** in the Piping toolbar and select a segment.

See *SolidWorks Help: Weld Gaps*

### Autosize

When you place a part, it now resizes automatically to match the target equipment or fitting.

Autosizing also works when editing a pipe. If you drag a fitting onto a pipe, the fitting size adjusts to match the diameter of the pipe.

The size is obtained from the face that the mate reference mates to. If the size does not match any available component size, +/- 5%, then an attempt is made to obtain the size from a CPoint.

After you place the part you are prompted to select a part configuration. If a matching size is not located then you are prompted to select a size and configuration.

### Moving and Rotating a Fitting

You can use the triad control to rotate or move parts inserted into a route.

To display the triad every time you place a part, click **Tools > Options > Routing** and select the option **Use triad to position and orient components**.

You can also right-click a part and select **Move fitting with triad**.

Click and rotate one of the triad's circles to rotate the part about its axis. Click and drag one of the arrows to move the part.

Guidelines appear after a part is moved. You can use the **Auto Route** command to convert the guidelines into a route when you have finished positioning the part. You can also right-click a guideline and select **Convert Guidelines**.
See SolidWorks Help: Positioning Parts with the Triad

P&ID Import
You can insert inline components into a pipe route after creating it from imported P&ID data, such as from a Solution Partner. SolidWorks identifies required components such as tees and reducers that are not defined in the document and lets you select them from a list.
Routing guidelines display without having to first place tees, inline fittings such as valves, and reducers. You can convert these guidelines to routes as required.

P&ID Report
You can generate reports that shows missing components or incomplete connections in a 3D model created from imported P&ID data.
To generate the report, click Report in the Piping and Instrumentation pane. The P&ID Validation Report dialog box displays.
Click Text to see a printable report. Click Tree to see the piping system tree. Symbols and tooltips in the tree identify connections that are missing or have not been successfully created.

Routing Options in Isolate
You now have routing-specific actions available in the Isolate command.
Right-click the piping assembly in the FeatureManager® and select Isolate.
Make your selection in the Isolate dialog box. As an example, if you select Route only then the route will be isolated. If you select Route and direct references then the route and any object it is connected to will be isolated. Other options are:
- Route and secondary references
- Route bounding box
- Route segments bounding box
In the image below, the Isolate command is used to isolate a route.
This chapter includes the following topics:

- **Bend Calculation Tables**
- **Convert to Sheet Metal**
- **Flat Patterns**
- **K-Factor in Configurations**
- **Mapping Bend Directions When Exporting to DXF/DWG Files**
- **Mirroring Edge Flanges and Miter Flanges**
- **Sheet Metal Properties**
- **Patterns of Edge Flanges and Tab Features**

### Bend Calculation Tables

You can calculate the developed length of sheet metal parts using bend calculation tables. In previous releases, you calculated the developed length with K-Factor, bend table, gauge table, bend allowance, and bend deduction methods. With bend calculation tables, you can define different angular ranges, assign equations to those ranges, and calculate the developed length of the part.

Click any sheet metal tool where you can select a calculation method for the developed length. In the PropertyManager, under **Bend Allowance**, in **Bend Allowance Type**, select **Bend Calculation** and set the options.

*See SolidWorks® Help: Bend Calculation Tables.*

### Convert to Sheet Metal

The **Convert to Sheet Metal** tool is enhanced.

**Gauge Tables**

You can use gauge tables with the **Convert to Sheet Metal** tool. The sheet metal parameters (material thickness, bend radius, and bend calculation method) use the values stored in the gauge table unless you override them.

Click **Convert to Sheet Metal** (Sheet Metal toolbar) or **Insert > Sheet Metal > Convert To Sheet Metal**. In the PropertyManager, under **Sheet Metal Gauges**, select **Use gauge table** and select a gauge table. You can specify the file locations for gauge tables in **Tools > Options > System Options > File Locations**. In **Show folders for**, select **Sheet Metal Gauge Table**.
**Rip Types**

You can define parameters for rip edges and rip sketches created with the **Convert to Sheet Metal** tool. Available rip types are open butt, overlap, and underlap. You can also control individual rip settings by clicking a rip callout in the graphics area. Additionally, you can set the **Default overlap ratio for all rips** and show or hide callouts in the graphics area.

Click **Convert to Sheet Metal** (Sheet Metal toolbar) or **Insert > Sheet Metal > Convert To Sheet Metal**. In the PropertyManager, under **Corner Defaults**, select a rip type and set the options.

*See SolidWorks Help: Converting a Solid Part to a Sheet Metal Part.*

**Keep or Consume Solid Bodies**

When using the **Convert to Sheet Metal** tool, you can keep the solid body to use with multiple **Convert to Sheet Metal** features or specify that the entire body be consumed by the tool.

Machine with a sheet metal enclosure.

Use **Convert to Sheet Metal** to create the first sheet metal body. **Keep body** is selected. You want to keep the solid body to derive another sheet metal body from the same solid body.
Use **Convert to Sheet Metal** to create the second sheet metal body. **Keep body** is cleared so the solid body is consumed.

Click **Convert to Sheet Metal** (Sheet Metal toolbar) or **Insert > Sheet Metal > Convert To Sheet Metal**. In the PropertyManager, under **Sheet Metal Parameters**, select or clear **Keep body**.

### Bend Allowance

You can select the bend allowance method for the developed length calculation of the part. In previous releases, you completed the **Convert to Sheet Metal** command and then changed the bend allowance in a separate step.

Click **Convert to Sheet Metal** (Sheet Metal toolbar) or **Insert > Sheet Metal > Convert To Sheet Metal**. In the PropertyManager, under **Custom Bend Allowance**, select a bend allowance.

### Callouts

You can show or hide callouts for **Bend Edges**, **Rip Edges found**, and **Rip Sketches**.

Click **Convert to Sheet Metal** (Sheet Metal toolbar) or **Insert > Sheet Metal > Convert To Sheet Metal**. In the PropertyManager, select or clear **Show callouts**.

### Flat Patterns

Improvements to flattening sheet metal parts make flattening succeed for complex shapes which previously failed. These improvements also provide better flattened geometry for certain corner treatments, lofted bends, and in some cases where cuts intersect bend regions.

You can update existing flat patterns created prior to SolidWorks 2011 to use the improved method.

In the FeatureManager design tree, right-click **Flat-Pattern** and click **Edit Feature**. In the Flat-Pattern PropertyManager, under **Parameters**, select **Recreate flat-pattern**.

### K-Factor in Configurations

When you use K-Factor as the bend allowance type in sheet metal parts, you can specify different values for the K-Factor in different configurations.
In the FeatureManager design tree, right-click Sheet-Metal1 and click Configure feature. In the dialog box, in Sheet-Metal1, select the variable that corresponds to K-Factor. Set the K-Factor values for each configuration.

**Mapping Bend Directions When Exporting to DXF/DWG Files**

You can map bend line directions to specific layers when you export sheet metal models as .dxf or .dwg files. For example, in sheet metal parts with up and down bend directions, you can map the different bend line directions to separate layers when you export the part.

See Exporting Bend Line Directions on page 81.

**Mirroring Edge Flanges and Miter Flanges**

You can mirror edge flanges that consist of several flanges attached to different edges. You can also mirror modified miter flanges where the flanges are shortened so the geometry does not overlap.

![Part with multiple edge flanges](image1)

![Mirrored edge flanges](image2)

**Sheet Metal Properties**

New properties specific to sheet metal parts are calculated and displayed in the Cut-List Properties dialog box.

Some of the properties that are calculated are based on the bounding box, the smallest rectangle in which the flat pattern can fit. You can set a grain direction to determine the smallest rectangle that aligns with the grain direction to fit the flat pattern. The bounding box is represented by a sketch when you flatten the sheet metal part and is located in the FeatureManager design tree under Flat-Pattern.

When exporting a sheet metal part as a .dxf or .dwg file, you can export the bounding box and assign the bounding box to a specific layer.

See Exporting Sheet Metal Parts to DXF or DWG Files on page 80.

The following properties are calculated in sheet metal parts:
<table>
<thead>
<tr>
<th><strong>Bounding Box Length</strong></th>
<th>Longest side of the bounding box</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bounding Box Width</strong></td>
<td>Shortest side of the bounding box</td>
</tr>
<tr>
<td><strong>Bounding Box Area</strong></td>
<td>Bounding box length x Bounding box width</td>
</tr>
<tr>
<td><strong>Bounding Box Area-Blank</strong></td>
<td>Area of the flat pattern excluding the through cut-outs</td>
</tr>
<tr>
<td><strong>Cutting Length-Outer</strong></td>
<td>Outer perimeter of the flat pattern (blank), which is used for calculating the machine’s cutting time</td>
</tr>
<tr>
<td><strong>Cutting Length-Inner</strong></td>
<td>Sum of the perimeters of internal loops or cut-outs</td>
</tr>
<tr>
<td><strong>Cut Outs</strong></td>
<td>Closed cut outs (through holes) on the flat pattern, which are used for calculating the machine’s idle time</td>
</tr>
<tr>
<td><strong>Bends</strong></td>
<td>Number of bends in the part</td>
</tr>
</tbody>
</table>

To view these properties, in the FeatureManager design tree, expand **Cut list**. Right-click a **Cut-List-Item** and click **Properties**. The properties are updated whenever you update the cut list or flatten the part.

See *SolidWorks Help: Sheet Metal Properties* and *Setting the Grain Direction for Bounding Boxes*.

**Patterns of Edge Flanges and Tab Features**

You can pattern edge flanges and tab features that have additional sheet metal features attached.

The patterns are supported for the same sheet metal body only. Multibody is not supported. Pattern tools include linear, circular, curve driven, sketch driven, and table driven patterns.

![Patterned Sheet Metal]

You cannot pattern tab features with attached jogs or sketched bends.
Available in SolidWorks® Premium.

Enhancements marked with (Professional) are available in SolidWorks Simulation Professional and SolidWorks Simulation Premium. Enhancements marked with (Premium) are available only in SolidWorks Simulation Premium.

This chapter includes the following topics:

- New Simulation Studies
- Interface
- Shells
- Beams
- Connectors
- Contact
- Mesh
- Nonlinear Studies
- Results

New Simulation Studies

New 2D Simplification Study (Professional) ★

You can simplify certain 3D models by simulating them in 2D. 2D simplification is available for static, nonlinear, pressure vessel design, and thermal studies. You can save analysis time by using the 2D simplification option for applicable models. 2D models require fewer mesh elements and simpler contact conditions compared to their 3D counterparts.

To create a 2D simplification study:

1. Click New Study (Simulation CommandManager).
2. Under Type, select Static, Nonlinear, or Thermal study.
3. Under Options, select Use 2D Simplification and click ✓.
4. In the 2D Simplification PropertyManager, set options and click ✓.

Types of 2D Simplification

You can select from four types of 2D simplification options based on the geometry, material properties, fixtures, loads, and contact conditions.
**Plane stress**
Simulates thin geometries with no forces acting normal to the section plane. For the plane stress assumption, no stresses develop normal to the section plane. This option is available for static and nonlinear studies.

This example shows a bracket under distributed load.

Other examples include thin plates under pressure, turning a wrench while tightening a bolt, and snap fit of plastic clips.

**Plane strain**
Simulates thick geometries that extend a long distance on either side of the section plane with no forces acting normal to the section plane. For the plane strain assumption, no strains develop normal to the section plane. Plane strain problems are less common than plane stress problems. This option is not available for thermal studies.

This example shows a dam under water pressure.

Other examples include a tunnel under pressure and sheet rolling.

**Extruded**
Simulates geometries with constant thermal loads along the extrusion direction. This option is available only for thermal studies.

The figure shows an example of a long block held at a uniform temperature and suddenly exposed to a convection environment.
**Axisymmetric** Simulates geometries, material properties, loads, and fixtures that are symmetric about an axis. This example shows a nonlinear contact analysis of an o-ring.

<table>
<thead>
<tr>
<th>3D geometry</th>
<th>Modeled section</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Diagram" /></td>
<td><img src="image2.png" alt="Diagram" /></td>
</tr>
</tbody>
</table>

Other examples include vessels under external or internal pressure and many problems encountered in turbine construction.

**2D Section**
You create 2D sections from 3D geometries, or use planar surfaces and 2D closed sketches on the section plane to define the bodies required for analysis. You use the 2D Simplification PropertyManager to create the section.

**Sectioning Solids** You can create bodies in 2D by splitting solids using a section plane. For the plane stress example of a disk shown below, use the top plane to extract the 2D model from the 3D geometry.
For the axisymmetric example of a bolt-nut connection, select any plane that sections the solid and the axis of revolution.

The head of the bolt and the helical pattern of the threads are not modeled (helical threads are not axisymmetric).

Using planar surfaces

You can create planar surface bodies or 2D closed sketches on the section plane to create 2D sections.

The example shows a three-point bend test on a plate under plane strain with the surface bodies created on the section plane.
Running the Study and Viewing Results

Setting up a 2D study is similar to setting up a 3D study. Notes on 2D simplification studies:

- For plane stress or plane strain assumptions, you cannot apply loads and fixtures in a direction normal to the section plane. For the axisymmetric assumption, you cannot apply them along the circumferential direction.
- You need to apply fixtures, loads, and contact conditions on edges rather than faces.
- For axisymmetric models, the applied loads are given in total values (not per radian). For plane stress and plane strain models, the applied loads are based on a thickness unit you specify.

Viewing Results

You can view the results of a 2D simplification analysis in 2D or 3D. For plane stress or plane strain assumptions, the results are the same for all cross sections parallel to the section plane. The results are reported per the thickness unit you specify.
For the axisymmetric assumption, the results are the same for all cross sections about the axis of revolution. Results are reported in total values (not per radian).

<table>
<thead>
<tr>
<th>2D Results Plot</th>
<th>3D Results Plot (rotated 200°)</th>
</tr>
</thead>
</table>

---

2D Simplification Analysis of a Bolt-Nut Connection
You perform an axisymmetric analysis on a bolt-and-nut assembly to plot the stress results on the threads. By performing a 2D simplification analysis, you save time because 2D models require fewer mesh elements and simpler contact conditions compared to 3D models.

To see the model, open install_dir\samples\whatsnew\2dsimplification\bolt_nut.sldasm.

The bolt head and the clamped members are not modeled. To apply 2D simplification, the threads are modeled as separate rings of material and not as a continuous helix (this is a simplification, as helical threads are not axisymmetric). To model the tightening of the joint or sliding of the bolt, you still need to use a 3D model.

Creating the 2D Simplification Study
You define a 2D simplification study from the 3D model and perform a nonlinear static study.
1. Click the down arrow on Study Advisor (Simulation CommandManager) and select New Study.
2. In the PropertyManager, under Name, type bolted connection.
3. Under Type, click Nonlinear.
4. Under Options, select Use 2D Simplification.
5. Click ✓.
6. In the 2D Simplification PropertyManager, under Type, select Axi-symmetric.
7. For Section plane, select Plane1 from the FeatureManager design tree.
8. For Axis of symmetry, select Axis1 from the FeatureManager design tree. This is the axis about which the geometry, loads, and fixtures are symmetric.

Applying Material Properties and Contact Sets
You define the material properties and contact sets.

1. In the Simulation study tree, right-click the bolted connection study folder and select Properties.
2. In the Nonlinear-Static dialog box, under Geometry nonlinearity options, select Large strain option. You select the Large strain option to model plasticity in the bolted connection.
3. Under Solver, select Direct Sparse and click OK.
4. Right-click Parts and select Apply Material to All.
5. In the Material dialog box, for Model Type, select Plasticity- von Mises.
6. Click Apply and Close.
   The elastic-plastic material properties of Alloy Steel are assigned to the bolt and the nut.
7. Right-click Connections and select Contact Set. In the PropertyManager, do the following:
   a) For Faces, Edges, Vertices for Set 1, select the 2D body of the bolt.
b) For **Faces for Set 2**，select the 2D body of the nut.

c) Under **Advanced**，select **Surface to surface**.

8. Click ✓. 
   No penetration contact without friction is applied between the touching thread regions of the bolt and the nut.

**Running the Analysis**
You apply load to the top edge of the bolt shank and prevent the nut from moving vertically. You then run the **bolted connection** study.

1. Right-click **Fixtures**  and select **Roller/Slider**.
2. In the PropertyManager, for **Straight Edges for Fixture**，select the edge of the bolt and the top edge of the nut as shown. Click ✓.
3. Right-click **External Loads** and select **Force**. 
4. In the PropertyManager, define the load:
   a) Under **Force/Torque**, for **Faces and Shell Edges for Normal Force**, select the edge shown by arrows in the figure.
   
   ![Diagram](image1)

   b) Select **Selected direction**.
   c) For **Face, Edge, Plane, Axis for Direction**, from the FeatureManager design tree, select **Plane1**.

   ![Diagram](image2)
   d) For **Unit**, select **English (IPS)**.

   ![Diagram](image3)
   e) Under **Force**, select **Along Plane Dir 2** and type 3000.

   ![Diagram](image4)

   This is the total force acting on the circular face of the bolt shank.

   ![Diagram](image5)

   f) Click ✓.

5. Click **Run** (Simulation CommandManager).

**Viewing the Results**
You can view the results of a 2D analysis in 2D or 3D. For an axisymmetric analysis, the results are the same for any cross section about the axis of revolution.
1. In the Simulation study tree, open the Results folder.
2. Double-click Stress (-von Mises-) to display the plot.

By default, you view the results in 2D.

3. Right-click Stress (-von Mises-) and select Show as 3D plot.

By default, the 2D section revolves by 330°. You can change the angle in the Stress Plot PropertyManager under Advanced Options.

The result shows plastic deformation on the model. Among the contacting threads, the first engaged thread shows a high stress value. The values are lower for the subsequent threads.

**New Response Spectrum Analysis Study (Premium)**

The new Response Spectrum Analysis study estimates the peak values of your model's response based on a design spectrum specified as a base excitation.

In a response spectrum analysis, the results of a modal analysis are used in terms of a known spectrum to calculate displacements and stresses in the model. For each mode, a response is read from a design spectrum based on the modal frequency and a given damping ratio. All modal responses are then combined to provide an estimate of the maximum response of the structure.
Relative displacement response spectrum for a particular damping ratio $\xi_1$.

$$SD_n = \max|y_n(t)| \quad (n = 1, \ldots, 4)$$

equals the maximum absolute value of the relative displacement time history response for each SDOF oscillator.

You can use a response spectrum analysis rather than a time history analysis to estimate the response of structures to random or time-dependent loading environments such as earthquakes, wind loads, ocean wave loads, jet engine thrust or rocket motor vibrations.

**Mode Combination Techniques**

The mode combination options for evaluating the maximum response are:

- **Absolute Sum**: Assumes that the maximum modal responses occur at the same time for all modes. It is the most conservative among the modal combination methods.

- **Square Root Sum of Squares (SRSS)**: Estimates the peak response by the square root of the sum of the maximum modal responses squared.

- **Complete Quadratic Combination (CQC)**: This method is based on random vibration theories. It takes into account the cross-correlation factors between two modes and the modal damping ratios.

- **Naval Research Laboratory (NRL)**: Takes the absolute value of the response for the mode that exhibits the largest response and adds it to the SRSS response of the remaining modes.

**Creating a Response Spectrum Analysis Study**

1. Click **Simulation > Study**.
   a) Under **Type**, select **Linear Dynamic**.
   b) Under **Options**, select **Response Spectrum Analysis**.
2. Define the frequency and response spectrum options of the study. In the Simulation study tree, right-click the study icon and click **Properties**. Select the modal combination method to estimate the maximum response.

3. Define material for each body.
   Beams and composite shells are not supported in a response spectrum study.

4. Under **Connections**, define contact sets and any connectors.
   Bonded contact, spring and edge welds connector are supported.

5. To define fixtures, right-click **Fixtures** and select from the options.

6. Right-click **External Loads** and select **Uniform Base Excitation** or **Selected Base Excitation**. This defines the base excitation (uniform or selected) in terms of a given displacement, velocity, or acceleration response spectrum.
   In a response spectrum analysis study, you can apply multiple response spectra definitions for uniform or selected base excitations. In case of multiple response spectra definitions, the total response is calculated by the square root of the sum of the squares of the individual responses.

7. Right-click **Result Options** and select **Edit/Define**.

8. Mesh the model and run the study.

9. Right-click **Results** and select the desired options.
   You can view the model's maximum response values (stresses, displacements, velocities, accelerations) based on the modal combination technique you selected in Step 2.
   For more information on Response Spectrum Analysis studies, see *Simulation Help: Response Spectrum Analysis*.

**Response Spectrum Analysis of a Circuit Board**
You perform a response spectrum analysis on a circuit board assembly. You use the design response spectra for horizontal components of ground motion recommended by the Applied Technology Council (ATC-3-06, Tentative Provisions, 1984). You apply the design response spectrum in one horizontal direction and view the results. Select the Naval Research Laboratory mode combination method to evaluate the model's expected maximum response.

To see the model, open
*install_dir\samples\whatsnew\response_spectrum\circuit_board.sldasm*.
The assembly document includes a frequency study with material, fixture and mesh definitions. You copy the frequency study to the new response spectrum study.

Creating the Response Spectrum Analysis Study
You create a response spectrum analysis study from the existing frequency study and set the study’s properties.

1. In the Simulation study tree, right-click the frequency study icon, and select Copy to New Dynamic Study.
2. Under Study Name, type Response Spectrum.
3. Under Linear dynamic study type, select Response Spectrum Analysis.
4. Click OK.

The program creates the new Response Spectrum study. All material, fixture, contact and mesh definitions from the Frequency study are copied to the new Response Spectrum study.

Setting the Study’s Properties
You select the mode combination method (Naval Research Laboratory) to evaluate the estimated maximum response.

1. Click the response spectrum study tab.
2. Right-click the response spectrum study icon and select Properties.
3. On the Response Spectrum Options tab, select Naval Research Laboratory.
4. Click OK.

The response spectrum analysis is based on the model’s first 30 frequencies for the calculation of the maximum response. To modify the number of frequencies, right-click the response spectrum study icon, and select Properties. Set the desired value for Number of frequencies.

Applying Base Excitation
You apply a horizontal base excitation in the global X direction defined in terms of an acceleration design response spectrum. The design spectrum is recommended by the Applied Technology Council (ATC-3-06, Tentative Provisions, 1984).

1. Right-click External Loads, and select Uniform Base Excitation.
2. In the PropertyManager, under Type, select Acceleration.
3. Under Acceleration:
a) For **Unit** \( \frac{m}{s^2} \), select \( g \).

b) Click **Along Plane Dir 1** \( \frac{m}{s^2} \), and type \( 1 \).

This excitation is applied to all locations restrained in the global X direction.

4. Under **Variation with Frequency**:
   a) Click **Curve**.
   b) Click **Edit**.

5. In the **Frequency curve** PropertyManager:
   a) Click **Get curve** to load the predefined acceleration response spectrum curve.
   b) In the **Function Curves** PropertyManager, load the curve library `install_dir\Simulation\CWLang\English\response spectra curves.cwcur`.
   c) Expand **Frequency curve** and select **ATC-3-06-Acceleration (g)**.
   d) For **Units**, select **Hz**.
   e) Click **OK** twice.

6. Click ✔.

**Running the Analysis and Viewing Results**
After you run the analysis, you can view response plots for the maximum acceleration, velocity, displacement, and stress quantities.

1. Click **Run** (Simulation CommandManager).
2. In the Simulation study tree, right-click **Results** and select **Define Displacement Plot**.
   A plot of the maximum resultant displacement appears.
3. Plot the resultant acceleration plot.
Note that the maximum displacement and acceleration values occur at different locations of the circuit board.

You can use a different modal combination method (SRSS, Absolute Sum, or CQC) and compare the results.

Interface

Organization of Bodies
Enhancements to the Simulation study tree let you apply simulation features more easily.

- You can organize bodies into folders in the Simulation study tree.
- Cut lists for beams and sheet metal bodies appear in the Simulation study tree.

To create sub-folders, right-click a folder in the Simulation study tree and select **Create New Folder**. You can then drag entities into the new folder.

All options under the parent folder are available for a newly created sub-folder, for example:

- You can assign the same material properties to the bodies in a sub-folder under the **Parts** folder.

- You can drag existing pressure loads to a sub-folder under the **External Loads** folder.

Filtering the Simulation Study Tree
You can use the new Simulation-specific filter tool to filter the Simulation study tree.

Type text to filter by in the filter tool at the top of the Simulation study tree.
• Filter by text-based names such as Pressure-3 or properties such as shell thickness or fixed geometry.

• Recently used searches are stored for usage in other documents.
• Use **Filter Graphics View** to show only filtered items in the graphics area.

**Display Enhancements for Simulation Studies**
Enhancements to the display of parts and assemblies include:

- A body that is excluded from an analysis is hidden in the Simulation study.
- When you change a body's material in a Simulation study, the material's appearance updates to the new material when viewing the Simulation study.

**Display of Simulation Symbols**
While editing a Simulation study, you can toggle the display of all Simulation-related symbols, such as loads, fixtures, and connectors. To toggle the display of Simulation symbols, click **View > Simulation Symbols** or click **Hide/Show Items** (Heads-Up View toolbar), and select **View Simulation Symbols**.

**Expressions in Input Fields**
You can now type expressions in fields that allow numerical inputs.

Examples:

- To use a component of a resultant force of 50N oriented at a 30° angle to the selected direction, you can type `50*cos(pi/6)` for **Force** in the Force/Torque PropertyManager.
- To reduce the parametric value of density of 7800 kg/m^3 by one-third, you can type `7800/3` for **User defined value** in the Add Parameters dialog box.

For a list of allowed expressions, see **SolidWorks Help: List of Operators and Functions**.

**Shells**

**Offsets for Shells**
You can align the mesh to the top, middle, or bottom faces of the shell. To align the mesh to a reference surface, you can type an offset value.

The Shell Definition PropertyManager has the following options:
### Middle surface
Aligns the mesh with the middle surface of the shell.

### Top surface
Aligns the mesh with the top surface of the shell.

### Bottom surface
Aligns the mesh with the bottom surface of the shell.

### Specify ratio
Aligns the mesh to a reference surface defined by an offset value that is a fraction of the total thickness. The figure shows the meaning of the positive and negative offset values.

For example, to model adjacent shells with differing thicknesses such that their bottom faces coincide, you can create the two surfaces using the **Bottom surface** option.

#### Ply Orientation in Composites (Premium)
The options for ply angles of a composite are enhanced.

To access the options, in the Shell Definition PropertyManager, under **Type**, select **Composite**. Under **Composite Options**, you can do the following:

- Select a row in the **Composite shell plies** table.

A striped texture on the composite surface body highlights the ply angle of the selected ply. The figure shows the texture for a 45° ply angle. The white arrow shows the ply direction.
- Select **Ply angles relative to ply 1**.

Ply angles are defined relative to its first ply. The first ply angle is always absolute. For example, if ply angle 1 is 45° and the absolute value of ply angle 2 is 60°, then the relative value of ply angle 2 with respect to ply angle 1 is 15°.

- Use the **Planar Mapping** option to define a common zero degree ply angle reference for a group of planar shell faces or if you encounter problems with the default **Surface Mapping** option.

**Inappropriate Ply Orientation**
The figure shows a face created using the surface fill operation. The surface mapping technique that uses the UV coordinates shows curved stripes on the shell. You can use the planar mapping technique by selecting the XY plane and projecting the desired ply orientation.

<table>
<thead>
<tr>
<th>Surface mapping</th>
<th>Planar mapping using XY plane</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
</tbody>
</table>

**Inconsistent Orientation across Faces**
The figure shows consistent ply orientation across multiple faces with the planar mapping option. The surface mapping creates inconsistent orientation for a 45° ply angle across the faces.

<table>
<thead>
<tr>
<th>Planar mapping using XZ plane</th>
<th>Surface mapping</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image3.png" alt="Image" /></td>
<td><img src="image4.png" alt="Image" /></td>
</tr>
</tbody>
</table>

**Composite Stack Information (Premium)**
When defining a composite shell, you can now save the stack data in .csv or .txt formats. You can then reload the stack information for future use.
As a best practice, you should edit the stack information in the Shell Definition PropertyManager. Editing the file in an external editor is not recommended.

To save or load the composite stack information:

1. In the Shell Definition PropertyManager, under **Type** select **Composite** and set the different **Composite Options**.
2. Click **Save stack to file**.
3. Click **Load stack from file** to load a saved composite stack file.

### Beams

**Non-uniform and Partial Loading of Beams**

You can now define non-uniform loads or loads that are defined on a part of the beam. You can specify table driven force values at different locations of the beam, or you can select from predefined load distributions such as triangular, parabolic, or elliptical.

In the Force/Torque PropertyManager, select **Nonuniform Distribution**.

Select one of the following options:

- **Total Load Distribution**: Distributes the total force or moment you specify along the length of the beam. No loads are applied at the ends of the beam. The shape of the distribution can be parabolic, triangular, or elliptical.

- **Centered Load Distribution**: Applies the force or moment you specify at the center of the beam. Loads decrease on either side of the center according to the selected distribution, and are defined per unit length. No loads are applied at the ends of the beam.

- **Table Driven Load Distribution**: Applies the force values at specific locations along the length of the beam. You specify the locations either as percentages or distances from one end of the beam. You can select between linear and cubic interpolation schemes for intermediate locations not specified in the table.

  You can save the table as a `.txt` or `.csv` file for future use.
Tapered Beams

You can now treat tapered geometries as beams with varying cross-sectional sizes along their length. Tapered geometries should have the same cross-sectional profile along their length to be treated as beams.

In the Simulation study tree, right-click a solid body and select Treat as Beam. A tapered beam icon appears in the study tree, if the solid body has a taper along its length.

The figure shows a tapered I-section beam with cross sectional size that decreases linearly along the direction shown. The tapered beam is represented by a straight line (neutral axis) connecting the two end joints. The lower image shows the mesh, where the beam is divided into a number of tapered beam elements represented by cylinders. Each element consists of two nodes having cross-sectional areas of the same shape but different sizes. The mesh and the results give you a visual indication of the taper along the beam length.

<table>
<thead>
<tr>
<th>Percentage</th>
<th>Force(N)</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>10</td>
</tr>
<tr>
<td>3</td>
<td>20</td>
</tr>
<tr>
<td>4</td>
<td>30</td>
</tr>
</tbody>
</table>

If a solid body does not qualify as a tapered beam, a warning recommends that you do not treat the body as a tapered beam. To qualify as a tapered beam, the solid body should maintain its cross-sectional profile along its axis, but with varying sizes.

This example shows a body with a twist along its length that does not strictly qualify as a tapered beam.
Connectors

**European Standard for Edge Welds (Professional)**

You can now use the European standard EN1993-1-8:2002- Eurocode 3 for edge weld calculations.

To use the European standard:

1. Right-click **Connections** and select **Edge Weld**.
2. In the PropertyManager, under **Weld Sizing**, select **European Standard**.

Set the properties of the weld connector:

- **Material of weaker joined part**: Select the material of the attached metal component with the lesser tensile strength value. You can also select **Custom** to define the tensile strength value of the weld.

- **Ultimate Tensile Strength**: Type the value of the tensile strength for the custom weld material. For other selections, the value is populated automatically.

- **Correlation Factor**: Type the correlation factor used to determine whether the resistance of the weld is sufficient.

  For correlation factors of different material grades, see EN1993-1-8:200 - Eurocode 3 Standard, Table 4.1.

- **Partial Safety Factor**: Type the partial safety factor used to determine whether the resistance of the weld is sufficient.

  For correlation factors of different types of joints, see EN1993-1-8:200 - Eurocode 3 Standard, Table 2.1.

- **Estimated weld size**: Type the value of the weld size. Edge weld calculations determine whether this size provides adequate resistance to the applied loads.
Contact

**Automatic Option for Simplified Bonding**
The solver now selects the surface-based or node-based bonding contact based on certain performance criteria. If the default surface-to-surface bonding slows down the solution considerably, the solver switches to node-to-surface bonding automatically. The new option for automatic bonding contact is available for Static, Frequency, Buckling, and Linear Dynamic Studies.

Right-click the Simulation study's icon and select **Properties**. Under **Incompatible bonding options**, select **Automatic**.

Mesh

**Mesh Enhancements**
- Solid and shell meshing performance has been improved because SolidWorks Simulation now takes advantage of your computer's multi-processors for meshing surfaces.
- The default mesher is now the curvature-based mesher.
- The curvature-based mesher supports the option **Remesh failed parts with incompatible mesh**.
- Mesh diagnostics is incorporated in the Mesh Advisor, which guides you to resolve meshing issues like meshing failed bodies.
- You can control the mesh size of beams. Specify the total number of elements or the element size.

In the Mesh Control PropertyManager, under **Mesh Parameters**, select **Number of elements** or **Element Size**.

Nonlinear Studies

**Improved Accuracy for Nonlinear fixtures (Premium)**
An exact method rather than an approximate penalty method is used to apply fixtures in nonlinear studies. The new method avoids numerical convergence difficulties encountered by the penalty method and improves accuracy and speed for most nonlinear studies.

The performance improvement is more prominent (up to 20% gain in analysis time) for nonlinear studies with many restraint definitions and higher mesh densities.

Results

**Nonlinear Plots (Premium)**
You can plot elemental principal strains for nonlinear studies.

In the Strain Plot PropertyManager, select **First**, **Second**, or **Third Principal Strain** in **Component**.
**Heat Power and Heat Energy**

You can more easily and accurately find out the heat power generated or dissipated through selected entities for steady-state and transient thermal studies.

Right-click **Results** and select **List Heat Power/Energy**. Heat energy is available for transient thermal studies only and for a specified time interval.

**Interaction with List Result Tables**

When you highlight a row in the Pin/Bolt/Bearing or List Beam Forces dialog box, the corresponding connector or beam is highlighted in the graphics area and Simulation study tree.

**Probe Callout Enhancements**

Probe callouts contain more information and can be relocated in the graphics area.

- You can move probe results to different locations in the graphics area.
• You can customize the callouts to display annotations such as ID numbers (node numbers), coordinates, and results-specific information like von Mises stress or temperature. In the Probe Result PropertyManager, under Annotations, select or clear the results-specific annotations. In this example of a thermal study, Show Value is selected and Show Node/Element Number and Show X, Y, Z Location are cleared.
• When probing an envelope plot for a transient study, the solution step is listed.

![Envelope plot with values and settings.

Sensors for Transient Studies
You can now define sensors to track the results of nonlinear, drop test, linear dynamics, and transient thermal studies. You can define these sensors to track values across all steps, at a specific plot step, or at a specific mode.

In the Sensor PropertyManager, for Sensor Type, select Simulation Data. Under Properties, for Step Criterion, select one of the following:

**Across All Steps**  Tracks the Simulation data value across all steps for the entire model or for the selected entities and reports a single value. For example, if you select Model Max for Criterion, the sensor reports the maximum value in the model across all steps.

**At Specific Plot Step**  Tracks the Simulation data value at the specified plot step based on the plot number you specify. You can control the number of plot steps and the step interval using the Result Options folder in the Simulation study tree.

**At Specific Mode Shape**  This option is available only for the frequency and buckling sensors. Specifies the mode number at which the sensor tracks the result.

Study Reports

Report Styles and Sections
• Different report styles are available and the included sections are customized to the study type.

To select specific sections for a report type, click Simulation > Options. On the Default Options tab, click Report and select a report style from Report formats. After selecting a report format, select or clear Report sections.

• Reports are available for all study types.

Image Capture Enhancements
You can include annotations for fixtures and loads when capturing the image for a report.
• After creating a report, in the Simulation study tree, right-click **Report** and select **Include Image**. Set the parameters. To display the annotations, select **Annotations** and select or clear features under **Feature Name**. You can move the callouts to different positions. Click ✔ to add the image to the **Images** folder.

![Image of a chair showing pressure annotations]

• To add the image to a report, add the image to the report's folder, right-click the report in the **Report** folder, and select **Publish**.

**Graphs for Material Properties**

Related graphs are included along with material properties. In this example, the Curve Data graph is included with the material properties.
SimulationXpress Study Reports

SimulationXpress study reports are generated as Microsoft Word documents.
This chapter includes the following topics:

- **Grid System**

**Grid System**

You can use the **Grid System** tool to lay out a grid system for large structures. The grid system is useful when creating welded structures. The grid system is also helpful when you work with multiple users who use different third-party applications to make grids. Multiple users can use the grid system and work from the same baseline.

You can create a grid to help specify the location of key elements in structures. When you use the **Grid System** tool, you create a sketch to represent the grid. You can then specify the number of floors for the structure and the distance between each floor. The sketch is replicated for every floor in the structure. Balloons are attached to the grid items to help with orientation.

Click **Grid System** (Features toolbar) or **Insert > Reference Geometry > Grid System**.
See SolidWorks® Help: Creating a Grid System.

The graphics area can appear cluttered when the grid system creates a lot of geometry or if you create multiple grid systems. To reduce clutter, you can hide the geometry. Display options are available to help you visualize the grid structure and to ensure correct grid inferencing.

To access the display options, in the FeatureManager design tree, right-click Grid System and click View Grid Components. In the View Grid Components dialog box, select an item and click a display option, such as Normal To. 
This chapter includes the following topics:

- **New Supported Regions**
- **Sustainability Link for Custom Material**

### New Supported Regions

SolidWorks® Sustainability and SustainabilityXpress support these additional regions: **South America, Australia, and India**. You can specify the regions as **Manufacturing** or **Transportation and Use** regions.

### Sustainability Link for Custom Material

You can perform a sustainability analysis using custom materials. This is done by linking your custom material to a material with similar characteristics in the default SolidWorks Materials database. The analysis is then performed using the Sustainability characteristics of the SolidWorks material.

To link your custom material to a similar material:

1. In the Material dialog box, in a custom materials library, select your custom material.
2. In the Properties tab, in **Material properties**, click Select.
3. In the Match Sustainability Information dialog box, select the material that is most similar to your custom material.

> Only materials with a link to the Sustainability database are listed.

4. Click OK.
5. Click Apply and Close.
SolidWorks Utilities

Available in SolidWorks® Professional and SolidWorks Premium.

This chapter includes the following topics:

- **Symmetry Check Utility**
- **Find/Modify/Suppress Feature Selection**

**Symmetry Check Utility**

You can use the Symmetry Check Utility to check component symmetry about a selected plane, and to identify symmetric and asymmetric components in an assembly.

To run a part or assembly symmetry check with respect to a plane, select the plane in the FeatureManager design tree and click **Symmetry Check** (Tools toolbar).
By default, after running a symmetry check on an assembly, components that are symmetric with respect to the selected plane appear blue and asymmetric components are pink.

For more information, see SolidWorks® Help: Symmetry Check Utility.

Find/Modify/Suppress Feature Selection

You can select a part feature to match when using the Find/Modify/Suppress utility. To find, modify, or suppress part features based on properties of a selected feature, select the feature and click Find/Modify Features (Tools toolbar).

For more information, see SolidWorks Help: Find/Modify/Suppress Feature Selection.
Available in SolidWorks® Professional and SolidWorks Premium.

This chapter includes the following topics:

- Opening Models with Referenced Toolbox Components
- Gears in the GB Standard

Opening Models with Referenced Toolbox Components

When you open an assembly, SolidWorks® automatically finds references to Toolbox components in your Toolbox folder, even if the assembly is created from a separate Toolbox installation, for example, from outside your company. You can set this behavior, which is applied to all new SolidWorks installations by default, from a Hole Wizard/Toolbox system option.

To set SolidWorks to search the Toolbox folder for referenced Toolbox components:

1. Click Options (Standard toolbar).
2. Click Hole Wizard/Toolbox.
3. Select Make this folder the default search location for Toolbox components.

If you clear the system option, SolidWorks does not automatically find Toolbox component references in the Toolbox folder.

Gears in the GB Standard

Toolbox administrators can include GB standards gears in Toolbox.

To include GB standard gears in Toolbox:

1. From the Windows Start menu, click All Programs > SolidWorks version > SolidWorks Tools > Toolbox Settings.
2. From the Select Hardware page, click GB, Power Transmission, and Gears.
3. Select the required GB gears and clear the unnecessary ones.
This chapter includes the following topics:

- Cut Lists
- Weld Beads
- Weld Support in Drawings

## Cut Lists

### Cut List Icons

New icons appear in the FeatureManager design tree under Cut list. The icons are based on the type of body in the model:

- Sheet Metal
- Weldment or structural members
- Other bodies

### Reordering and Excluding Cut List Items

You can reorder Cut-List-Item folders. Because the order of the Cut-List-Item folders drives the cut list entries, you can apply a customized order to the cut list. The reordering propagates to the cut lists in the part and drawing. You can also exclude Cut-List-Item folders from cut lists.

To reorder the Cut-List-Item folders:

- Drag and drop folders in the FeatureManager design tree.
- Use the Cut-List Properties dialog box to drag and drop folders on the Cut List Summary or Cut List Table tabs.

To exclude Cut-List-Item folders from cut lists:

- Right-click a folder in the FeatureManager design tree and click Exclude from cut list.
- Use the Cut-List Properties dialog box to select Exclude from cut list on the Cut List Summary and Cut List Table tabs.

See SolidWorks Help: Excluding Folders from Cut Lists.

You should finish modeling the part before modifying the cut list items. You may lose changes to the cut list if you change the geometry after modifying the cut list.

## Weld Beads

You can add simplified weld beads to weldment parts and assemblies, and multibody parts.
Benefits of simplified weld beads:
- Uniform implementation in parts and assemblies
- Compatibility with all types of geometry, including bodies with gaps
- Lightweight, simplified weld bead display
- Inclusion of weld bead properties in drawings using weld tables
- Smart Weld selection tool for face selection of weld bead paths
- Association of weld bead symbols with the weld beads
- Handles that assist in defining weld paths (lengths)
- Inclusion in the Weld Folder in the FeatureManager design tree

Additionally, you can set properties for Weld Sub Folders, including:
- Weld material
- Weld process
- Weld mass per unit length
- Welding cost per unit mass
- Welding time per unit length
- Number of weld passes

Click Weld Bead (Weldments toolbar) or Insert > Weldments > Weld Bead. In an assembly, click Insert > Assembly Feature > Weld Bead.

Weld Bead Display
Weld beads are displayed as graphical representations in models. The weld beads are lightweight and do not affect performance.

Weld Beads in Assemblies
Weld Beads
You can add simplified weld beads to assemblies.
In previous versions of SolidWorks®, you added weld beads as components of the assembly. This method is no longer supported. However, you can still edit existing weld bead components.

Fillets and Chamfers
In assemblies, you can create fillets and chamfers, which are useful for weld preparation. As with other assembly features, you can propagate these features to the parts they affect.

Example: Adding Chamfers and Weld Beads to an Assembly
In this example, you add chamfers to two plates to prepare them for welding. Then you add a simplified weld bead.

1. Open \install_dir\samples\whatsnew\assemblies\plate_assembly.sldasm.

2. Click Assembly Features (Assembly tab on the CommandManager) and click Chamfer, or click Insert > Assembly Feature > Chamfer.

3. In the PropertyManager, under Chamfer Parameters, for Edges and Faces or Vertex, do the following to select the edge of plate01:

   a) Right-click the top edge between the two plates and click Select Other.
b) In the dialog box, select Edge@[plate01<1>].
A preview of the chamfer appears.

4. Under **Chamfer Parameters:**
   a) Select **Angle distance**.
   b) Set **Distance** to 5.
   c) Set **Angle** to 45.

💡 Under **Feature Scope**, you can select **Propagate feature to parts** if you want to add the chamfer to the plate’s part file.

5. Click ✅.
The chamfer appears.

**Adding a Chamfer to a Second Component**
Now add a chamfer to the other plate.

1. Select the edge of the plate.
2. Click **Assembly Features** (Assembly tab on the CommandManager) and click **Chamfer**.
   A preview of the chamfer appears.

3. In the PropertyManager, click ✓. The chamfer appears in the second plate.

**Adding a Weld Bead**
Now add a weld bead to the assembly.

1. Do one of the following:
   - Click **Weld Bead** (Weldments toolbar).
   - Click **Assembly Features** (Assembly tab on the CommandManager) and click **Weld Bead**.
   - Click **Insert > Assembly Feature > Weld Bead**.

2. In the PropertyManager, under **Settings**:
   a) For **Weld selection**, select the faces of the two chamfers in the graphics area.
b) Set **Bead size** to 15.

3. Click ✓. The weld bead appears in the graphics area.

In the FeatureManager design tree, **Weld Folder** appears. Weld bead features that have identical properties are stored together in subfolders. **Weld Bead1** is the weld you just created.

**Weld Support in Drawings**

**Weld Symbols**
- In drawings, you can insert bi-directional weld symbols that are attached to weld paths. Click **Insert > Model Items** and under **Annotations**, click **Weld Symbols**.
- You can insert weld symbols, caterpillars, and end treatments for weld beads in specific views. Click **Insert > Model Items** and under **Source/Destination**, click **Selected feature** for **Source**. Under **Annotations**, click **Weld Symbols**, **Caterpillar**, or **End Treatment**. Move the pointer to highlight a weld path and click to place the annotation. You can also select weld bead features from the FeatureManager design tree while in the **Model Items** command.

**Weld Tables**
You can insert weld tables in a drawing that summarize the weld bead data.

By default, weld tables include:
- Weld size
- Symbol
- Weld length
- Weld material
• Quantity

You can add other weld bead custom properties to the table such as weld cost and weld time, and save it as a template for future use.

In a drawing view, click **Weld Table**(Table toolbar) or **Insert > Tables > Weld Table**. In the PropertyManager, set the options and click ✓.

<table>
<thead>
<tr>
<th>ITEM NO.</th>
<th>WELD SIZE</th>
<th>SYMBOL</th>
<th>WELD LENGTH</th>
<th>WELD MATERIAL</th>
<th>QTY.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>3</td>
<td>▼</td>
<td>50</td>
<td>CARBON STEEL</td>
<td>2</td>
</tr>
<tr>
<td>2</td>
<td>3</td>
<td>▼</td>
<td>40</td>
<td>CARBON STEEL</td>
<td>2</td>
</tr>
<tr>
<td>3</td>
<td>4</td>
<td>▼</td>
<td>20</td>
<td>CARBON STEEL</td>
<td>2</td>
</tr>
<tr>
<td>4</td>
<td>4</td>
<td>▽</td>
<td>12.5</td>
<td>CARBON STEEL</td>
<td>2</td>
</tr>
<tr>
<td>5</td>
<td>2</td>
<td>▼</td>
<td>15</td>
<td>CARBON STEEL</td>
<td>1</td>
</tr>
</tbody>
</table>