What's New
SOLIDWORKS 2013

Image courtesy of Martin Aircraft Company

DS DASSAULT SYSTEMES
Legal Notices..........................................................................................................................10

1 Welcome to SolidWorks 2013...............................................................................................13
   Highlights ..................................................................................................................................13
   Top Enhancements ....................................................................................................................13
   For More Information ...............................................................................................................15

2 User Interface .........................................................................................................................16
   Customizing Shortcut Bars ........................................................................................................16
   Easier Access to Troubleshooting and Administrative Tools .....................................................16
   FeatureManager Design Tree ....................................................................................................17
      FeatureManager Design Tree Favorites ..................................................................................17
      FeatureManager Design Tree Views ......................................................................................18
   Subfolders in the FeatureManager Design Tree ........................................................................19
   Scrolling Through CommandManager Tabs ..............................................................................19

3 SolidWorks Fundamentals ....................................................................................................20
   Application Programming Interface ........................................................................................20
   Controlling the Save Reminder ..............................................................................................21
   Documentation ......................................................................................................................21
      Help Navigation ..................................................................................................................21
      Motion Studies Tutorials ....................................................................................................21
      SolidWorks Tutorials User Interface ....................................................................................22
   Equations ..................................................................................................................................22
      Direct Input of Equations .....................................................................................................22
      Enhanced Support for Units of Measurement ....................................................................25
   Manipulating Views ................................................................................................................26
      Orientation Dialog Box .......................................................................................................26
      Updating Standard Views Without Using the Orientation Dialog Box ....................................29
      View Rotation ......................................................................................................................29
      View Selector .....................................................................................................................30
   Measure Tool ..........................................................................................................................31
      Measuring in Point to Point Mode .......................................................................................32
      Measuring the Distance Between Two Circles ....................................................................33
   Opening Files - Quick Filter Buttons ......................................................................................34
   Opening Top-Level Assemblies ..............................................................................................34
Contents

Previous Release Interoperability ................................................................. 34
Searching SolidWorks Options ......................................................................... 36
Selecting a SolidWorks Version When Opening a File ................................. 36
SolidWorks Sounds ......................................................................................... 36
Adding Sounds to Events in SolidWorks ....................................................... 37
SolidWorks Startup .......................................................................................... 37
Transferring Custom Properties When Inserting Configured Parts ................ 37

4 Administration ............................................................................................. 38
Converting Files to SolidWorks 2013 .......................................................... 38
Interoperability Between SolidWorks 2012 SP5 and SolidWorks 2013 ...... 38
Save and Restore User Settings ..................................................................... 38
SolidWorks CAD Admin Dashboard ................................................................. 39
The CAD Admin Dashboard Basic Workflow .................................................. 39

5 Installation .................................................................................................... 42
Push Install and Uninstall Method Using the Option Editor ......................... 42

6 Assemblies .................................................................................................... 43
Assembly Visualization ..................................................................................... 43
Additional Properties Available ...................................................................... 43
Colors for Group Identical .............................................................................. 44
Component Image Quality .............................................................................. 44
Excluding Hidden Components ....................................................................... 44
Import and Export of Settings ......................................................................... 44
Breaking All External References at Once ....................................................... 45
Deleting Components from Subassemblies .................................................... 45
Derived Components ....................................................................................... 45
Envelopes ........................................................................................................ 45
Creating an Envelope from a Component ....................................................... 46
Creating an Envelope While Inserting a Component ...................................... 47
Changing Envelope Appearance ..................................................................... 48
Hiding and Showing Envelopes ...................................................................... 49
Changing Envelopes into Regular Components ............................................ 50
Other Changes for Envelopes ......................................................................... 51
Multiple Exploded Views per Configuration ................................................... 51
Adding Multiple Exploded Views ................................................................. 51
Copying Exploded Views ................................................................................ 53
Inserting Components ..................................................................................... 54
Improved Depth When Inserting Components .............................................. 54
Inserting Multiple Components ...................................................................... 54
Interference Detection ..................................................................................... 57
Excluding Components ................................................................................... 57
Volume Features ...............................................................................................................................91
  Calculating the Cost of a Volume Feature ........................................................................................92

10 Drawings and Detailing ..................................................................................................................93
  Balloons .............................................................................................................................................93
    Auto Balloon Functionality Works on Existing Balloons ...............................................................93
    Auto Balloon Improvements .........................................................................................................97
    Balloon Text Field Options ..........................................................................................................97
  Dimensions ........................................................................................................................................98
    Add Dimensions to Baseline Dimensions ....................................................................................98
    Imported Tolerance and Precision Dimensions Parametric with Model ........................................99
    Improved Arrows on Radius Dimensions ....................................................................................100
    Improved Control of Extension and Dimension Lines ................................................................101
    Insert Dimensions with Tolerances ..............................................................................................103
    Radius and Diameter ISO Leader Dimensions ..........................................................................104
    Radius, Diameter, Chamfer, and Hole Callout Bent Leader Improvements ..............................105
  Reference Center of Mass in Drawings .........................................................................................106
  Drawing Views .................................................................................................................................107
    Convert Drawing View to Sketch ..............................................................................................107
    Multiple Exploded Views ............................................................................................................109
    New Edge Types for Flat Pattern Views ....................................................................................109
    New Section Tool User Interface ..............................................................................................110
    Save Drawing View as DXF or DWG File ....................................................................................124
    SpeedPak Drawing Support ........................................................................................................124
  Layers ..............................................................................................................................................124
    Center Marks and Centerlines Assigned to Layers ...................................................................124
    Improved Access to Layer Function ..........................................................................................125
  Other Annotations ............................................................................................................................126
    Display Note Behind Sheet ........................................................................................................126
    Dowel Pin Symbol Support .......................................................................................................127
    GTOL Allows Notation Below the Feature Control Frame ..........................................................127
    JIS Weld Symbol Improvements ..............................................................................................128
    Linking Cut List Properties to Annotations ...............................................................................129
    Padding Annotation Option ........................................................................................................131
    Revision Cloud ............................................................................................................................132
    Sheet Metal Bend Note Improvements ......................................................................................135
    SolidWorks eDrawings Markups Visible in SolidWorks .............................................................135
    Use Mouse Wheel to Zoom While Editing Text Field ................................................................135
    View Label Custom Names ..........................................................................................................136
  Tables ..............................................................................................................................................136
    Improved Cell Padding in SolidWorks Tables ............................................................................136
    Improved Sizing of Table Columns ............................................................................................136
## eDrawings

- eDrawings and eDrawings Pro for iPad ........................................ 138
- Exploded Views ........................................................................ 139
- Saving and Sending Files in eDrawings 64-bit Installations .... 139
- Stereographic Viewing ............................................................. 139
- Version Support for Mac and PowerPC ................................. 139

## SolidWorks Enterprise PDM

- Administration Tool .............................................................. 140
- Delayed in State Notifications ............................................. 140
- Parallel Workflow Transitions ............................................. 141
- Recently Used List ............................................................... 145
- Workflow Editor Update ...................................................... 145
- Bill of Materials Tab Improvements ................................... 148
- Close SolidWorks Files on Check In .................................... 149
- Contains and Where Used Tab Improvements .................... 149
- Full Row Selection Highlighting in Windows Explorer ....... 150
- Notification Editor Update .................................................. 150
- Quantity Specification for Manually Created File References 153
- User Information Pop-up ...................................................... 153
- Version Free Variables ....................................................... 155
- Windows Explorer Favorites Links ..................................... 156

## SolidWorks Flow Simulation

- Compare Configuration Mode ................................................ 158
- Erosion Plot .......................................................................... 159
- Evenly Spaced Surface Streamline Algorithm ..................... 159
- Improved Feature Tree ......................................................... 160
- Improved Geometry Handling ............................................ 160
- Low Temperature Condensation ......................................... 161
- Parametric Study Mode ...................................................... 162
- Improved eDrawings Plots .................................................. 162

## Import/Export

- Import Performance Enhancements ...................................... 163

## Model Display

- Appearances ......................................................................... 164
- Adding Appearances .......................................................... 164
- Copying and Pasting Appearances ...................................... 165
- New and Enhanced Appearances ....................................... 165
Rounding Sharp Edges in an Appearance ................................................................. 166
Scaling Textural Appearances, Surface Finishes, and Decals ................................. 166
PhotoView 360 .............................................................................................................. 166
  Final Render Window ............................................................................................... 168
  PhotoView 360 Options .......................................................................................... 169
  Using Modo Appearances in SolidWorks .............................................................. 169

16 Motion Studies ......................................................................................................... 170
  Motion Studies Tutorials ......................................................................................... 170

17 Parts and Features ................................................................................................. 171
  Edge Selection Toolbar Available for Fillets .......................................................... 172
  Enhanced Support for Mounting Bosses .............................................................. 172
  Creating the Mounting Boss .................................................................................. 173
  Enhanced Support for Thin Extrudes ..................................................................... 176
  Selecting Multiple Contours for Thin Extrudes ..................................................... 176
  Enhancement for Inserting Cosmetic Threads ...................................................... 178
  Enhancements to Part Reviewer ............................................................................. 178
  Highlighting Related Bodies or Surfaces in Multibody Parts ................................. 178
  Inserting Dowel Holes with the Hole Wizard ....................................................... 178
  Linking a Defeature Model to Original ................................................................. 179
  Mass Properties in Parts ....................................................................................... 179
  Custom Inertia Properties in Parts ........................................................................ 179
  Mass Properties Dialog Box .................................................................................. 179
  Point at the Center of Mass .................................................................................. 179
  Modifying Geometry with the Intersect Tool ....................................................... 180
  Creating Geometry from Solids, Surfaces, or Planes ........................................... 181
  Multibody Library Features .................................................................................. 185
  Selecting End Conditions for Extruded Features ................................................ 185
  Show Hidden Bodies ............................................................................................. 186
  Smarter Configuration Switching ........................................................................... 186
  Transferring Custom Properties ........................................................................... 186
  Varying Dimension Patterns ................................................................................ 186
  Varying the Spacing and Dimensions of All Instances ........................................ 186
  Modifying Dimensions of One Instance .............................................................. 187
  Restoring Instances to Their Original State ....................................................... 188
  Weldments ............................................................................................................. 188
  Bounding Boxes .................................................................................................... 188
  Creating Bounding Boxes .................................................................................... 190

18 SolidWorks Plastics .............................................................................................. 191
  Plastics Part and Injection Mold Design Optimization ......................................... 191
19 Routing

Auto Route Tool Supports Routing Along Existing Geometry ......................................................... 192
Creating Drawings for Flexible Tubing Routes ..................................................................................... 192
Enhanced Pipe Penetration .................................................................................................................... 193
Enhanced Support for Exporting Pipe and Tube Data ............................................................................ 193
Improvements for Flattened Routes ....................................................................................................... 193
Improvements for Ribbon Cable Routes ................................................................................................ 193
Adding Slopes for Pipe Routes .............................................................................................................. 194
Adding a Slope ....................................................................................................................................... 195
Support for Tubing in P&ID Files .......................................................................................................... 195
Validation Check for Routing Component Wizard ................................................................................. 195

20 Sheet Metal ..................................................................................................................................... 196

Bend Notes ........................................................................................................................................... 196
Forming Tools ...................................................................................................................................... 197
Multibody Parts .................................................................................................................................... 198

21 SolidWorks Simulation...................................................................................................................... 200

Beams .................................................................................................................................................. 200
Contact .............................................................................................................................................. 201
  Automatic Contact Set Detection ........................................................................................................ 201
  Detecting Interfering Faces ............................................................................................................... 202
  Shell Edges to Beam Bonding .......................................................................................................... 202
Incremental Meshing .............................................................................................................................. 203
Interface .............................................................................................................................................. 203
  Error Messages ................................................................................................................................. 204
Materials in Design Studies .................................................................................................................. 204
  Design Evaluation of a Knob based on Material ............................................................................... 205
Results .................................................................................................................................................. 207
  Factor of Safety for Selected Bodies .................................................................................................. 207
  Plots on Selected Entities .................................................................................................................. 208
  Shell Results .................................................................................................................................... 209
  Storing Results ................................................................................................................................. 209
Sensors ................................................................................................................................................. 210
  Defining a Transient Sensor .............................................................................................................. 210
Submodeling ........................................................................................................................................ 210
  Submodeling Principles ................................................................................................................... 211
  Submodeling Study for a Pressure Vessel ......................................................................................... 211

22 Sketching ....................................................................................................................................... 215

Conic Curves ....................................................................................................................................... 215
Dimensions .......................................................................................................................................... 218
© 1995-2013, Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes S.A. company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of the license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the license agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices
SolidWorks® 3D mechanical CAD software is protected by U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademarks and Product Names for SolidWorks Products and Services
SolidWorks, 3D PartStream.NET, 3D ContentCentral, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.

CircuitWorks, FloXpress, PhotoWorks, Tol Analyst, and XchangeWorks are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of Geometric Ltd.


Other brand or product names are trademarks or registered trademarks of their respective holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY
The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of “commercial computer software” and “commercial software documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government (a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in 48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the department of Defense,

In the event that you receive a request from any agency of the U.S. government to provide Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope of the request and DS SolidWorks will have five (5) business days to, in its sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

**Copyright Notices for SolidWorks Standard, Premium, Professional, and Education Products**

Portions of this software © 1986-2012 Siemens Product Lifecycle Management Software Inc. All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:


Portions of this software © 1998-2012 Geometric Ltd.

Portions of this software © 1996-2012 Microsoft Corporation. All rights reserved.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2012 Luxology, LLC. All rights reserved, patents pending.

Portions of this software © 2007-2011 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SolidWorks.

**Copyright Notices for SolidWorks Simulation Products**

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2010 Computational Applications and System Integration, Inc. All rights reserved.

**Copyright Notices for SolidWorks Enterprise PDM Product**

Outside In ® Viewer Technology, © 1992-2012 Oracle

© 2011, Microsoft Corporation. All rights reserved.

**Copyright Notices for eDrawings Products**

Portions of this software © 2000-2012 Tech Soft 3D.
Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.
Portions of this software © 1998-2001 3Dconnexion.
Portions of this software © 1998-2012 Open Design Alliance. All rights reserved.
Portions of this software © 1995-2010 Spatial Corporation.
The eDrawings® for Windows® software is based in part on the work of the Independent JPEG Group.
Welcome to SolidWorks 2013

This chapter includes the following topics:

- **Highlights**
- **Top Enhancements**
- **For More Information**

**Highlights**

SolidWorks® 2013 includes many enhancements and improvements, most in direct response to customer requests. This release focuses on the following themes:

- **More powerful design capabilities**: You can model and verify complex geometries faster and with more control. New tools help you create cost effective designs that meet your objectives.

![Image of a guitar](image_url) Image courtesy of Fender® Musical Instruments Corporation

- **More effective collaboration**: There is an expanded range of collaboration for design and product development with new tools for release interoperability, manufacturing cost estimation, and technical communication.

- **Increased performance and productivity**: Take advantage of processing power to create and simulate models and monitor SolidWorks functionality and performance.

**Top Enhancements**

The top enhancements for SolidWorks 2013 provide improvements to existing products and innovative new functionality.

Throughout this guide, look for the symbol in these areas:
<table>
<thead>
<tr>
<th><strong>SolidWorks Fundamentals</strong></th>
<th><strong>Measure Tool</strong> on page 31</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Orientation Dialog Box</strong> on page 26</td>
</tr>
<tr>
<td></td>
<td><strong>View Selector</strong> on page 30</td>
</tr>
<tr>
<td><strong>Administration</strong></td>
<td><strong>SolidWorks CAD Admin Dashboard</strong> on page 39</td>
</tr>
<tr>
<td><strong>Installation</strong></td>
<td><strong>Previous Release Interoperability</strong> on page 34</td>
</tr>
<tr>
<td><strong>Assemblies</strong></td>
<td><strong>Envelopes</strong> on page 45</td>
</tr>
<tr>
<td></td>
<td><strong>Multiple Exploded Views per Configuration</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Inserting Multiple Components</strong> on page 54</td>
</tr>
<tr>
<td><strong>CircuitWorks</strong></td>
<td><strong>Importing and Exporting ECAD File Features</strong> on page 65</td>
</tr>
<tr>
<td><strong>Configurations</strong></td>
<td><strong>Disabling the SpeedPak Graphics Circle</strong> on page 78</td>
</tr>
<tr>
<td></td>
<td><strong>Speedpak Creation from Parent Assembly</strong></td>
</tr>
<tr>
<td><strong>SolidWorks Costing</strong></td>
<td><strong>Turned Parts</strong></td>
</tr>
<tr>
<td><strong>Drawings and Detailing</strong></td>
<td><strong>Convert Drawing View to Sketch</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Imported Tolerance and Precision Dimensions Parametric with Model</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Revision Cloud</strong></td>
</tr>
<tr>
<td></td>
<td><strong>New Section Tool User Interface</strong></td>
</tr>
<tr>
<td><strong>SolidWorks Enterprise PDM</strong></td>
<td><strong>Delayed in State Notifications</strong> on page 140</td>
</tr>
<tr>
<td></td>
<td><strong>Notification Editor Update</strong> on page 150</td>
</tr>
<tr>
<td></td>
<td><strong>Parallel Workflow Transitions</strong> on page 151</td>
</tr>
<tr>
<td></td>
<td><strong>User Information Pop-up</strong> on page 153</td>
</tr>
<tr>
<td></td>
<td><strong>Version Free Variables</strong> on page 155</td>
</tr>
<tr>
<td></td>
<td><strong>Workflow Editor Update</strong> on page 145</td>
</tr>
<tr>
<td><strong>Parts and Features</strong></td>
<td><strong>3D Bounding Boxes</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Enhanced Support for Mounting Bosses</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Enhanced Support for Thin Extrudes</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Modifying Geometry With the Intersect Tool</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Varying Dimension Patterns</strong> on page 186</td>
</tr>
</tbody>
</table>
Routing

Adding Slopes for Pipe Routes on page 194

Improvements for Ribbon Cable Routes

Simulation

Incremental Meshing on page 203

Submodeling on page 210

Sketching

Conic Curves on page 215

Sustainability

TRACI Impact Assessment Methodology on page 225

All features are available in SolidWorks Standard, SolidWorks Professional, and SolidWorks Premium unless otherwise noted.

For More Information

Use the following resources to learn about SolidWorks:

What's New in PDF and HTML

This guide is available in PDF and HTML formats. Click:

- Help > What's New > PDF
- Help > What's New > HTML

Interactive What's New

In SolidWorks, click the symbol to display the section of this manual that describes an enhancement. The symbol appears next to new menu items and the titles of new and changed PropertyManagers.

To enable Interactive What's New, click Help > What's New > Interactive.

What's New Examples

What's New Examples are updated at every major release to provide examples of how to use most enhancements in the release.

To open What's New Examples click Help > What's New > What's New Examples.

Online Help

Contains complete coverage of our products, including details about the user interface, samples, and examples.

Release Notes

Provides information about late changes to our products.
This chapter includes the following topics:

- Customizing Shortcut Bars
- Easier Access to Troubleshooting and Administrative Tools
- FeatureManager Design Tree
- Scrolling Through CommandManager Tabs

Customizing Shortcut Bars

The ability to customize shortcut bars has been improved.

Shortcut bars appear when you press the S key in an open part, assembly, drawing, or sketch.

To customize a shortcut bar:

1. Click Tools > Customize or right-click the shortcut bar and click Customize.
2. In the Customize dialog box, on the Shortcut Bars tab, click one of the following:
   - Part
   - Assembly
   - Drawing
   - Sketch
   The shortcut bar appears.
3. For Toolbar, select a command group and drag the desired buttons onto the shortcut bar.

   To remove buttons from the shortcut bars, drag the button onto the graphics area until a red X appears.

Easier Access to Troubleshooting and Administrative Tools

Troubleshooting and administrative tools are available in the SolidWorks Resources tab of the Task Pane under SolidWorks Tools.

SolidWorks Tools contains the following tools:
**Property Tab Builder**

Opens the Property Tab Builder, a utility that you can use to create a customized interface for entering properties into SolidWorks files. The tabs you create appear in the Custom Properties tab of the Task Pane.

**SolidWorks Rx**

Analyzes your system, suggests possible solutions, and captures data that can help technical support personnel diagnose problems.

**Performance Benchmark Test**

Analyzes your system performance, compares it to other users, and allows you to share your score.

**Compare My Score**

Reports the results of your SolidWorks Performance Test in comparison to other users. This tool is available only for subscription customers.

**Copy Settings Wizard**

The Copy Settings Wizard saves, restores, and propagates system settings to users, computers, or profiles. You can also run the Copy Settings Wizard from the Tools menu. See Save and Restore User Settings on page 38.

---

**FeatureManager Design Tree**

**FeatureManager Design Tree Favorites**

You can add commonly used features, sketches, and reference geometry to the Favorites folder in the FeatureManager design tree.

With the Favorites folder, you can easily access items in a part or assembly with a very long feature tree. You can also use the Favorites folder to highlight features for other team members to look at during collaboration.

To add an item to the Favorites folder, right-click the item and click Add to Favorites.
You can choose whether to hide or show the Favorites folder in **Tools > Options > FeatureManager**.

To remove a feature from the Favorites folder, right-click the feature and click **Remove from Favorites**.

**If you right-click an item in the Favorites folder and click Delete, the item is permanently deleted from the part or assembly.**

Any changes you make to an item in the **Favorites** folder are also made wherever the item appears in the tree. For example, if you rename an item in Favorites, all other instances of that item in the FeatureManager design tree appear with the new name.

**FeatureManager Design Tree Views**

In part documents, you can set the FeatureManager design tree to show features in the order they were created, instead of hierarchically.

Right-click in the FeatureManager design tree and click **Tree Display > Show Flat Tree View**. In Flat Tree View, curves, 2D sketches, and 3D sketches are not absorbed into the features that reference them. Instead, they are shown in the order of creation.

**Flat Tree View is only available for parts.**

All regular FeatureManager design tree functionality is available in Flat Tree View, with the exception of user-created folders. You can reorder features in Flat Tree View, changing design intent.

Not all items are unabsorbed in Flat Tree View. The following features continue to absorb items in Flat Tree View:

- Simple hole
- Hole Wizard hole
- Mounting boss
- Lip/Groove
- Snap hook groove
- Vent
- Snap hook
- Sheet metal feature
- Library feature
- Weldment structural member
- Sketch block

In the following example, the same part is shown in Normal View and Flat Tree View.
Flat Tree View: Items are shown in the order of creation, with the exception of the Hole Wizard holes, which still absorb the sketches.

Normal View: Items are displayed hierarchically, with sketches absorbed into features.

**Subfolders in the FeatureManager Design Tree**

In parts and assemblies, you can create subfolders in the FeatureManager design tree. You can use multiple layers of folders to organize long FeatureManager design trees.

To create a subfolder, select one or more items within a folder, right-click, and click **Add to New Folder**. You can drag additional items into the subfolder from any level in the tree.

As in previous releases, the software prevents actions that violate parent-child relationships.

To expand or collapse a folder and all its subfolders, right-click and click **Expand All** or **Collapse All**. To retain a subfolder’s expanded or collapsed state when you expand or collapse its parent folder, right-click the parent folder and click **Expand Item** or **Collapse Item**.

Any command that can be applied to folders can be applied to subfolders. When you apply a command to a folder, it is applied to that folder’s subfolders as well. For example, when you suppress a folder, all items in the folder are suppressed, including its subfolders and the items they contain.

**Scrolling Through CommandManager Tabs**

Use **Ctrl+Page Up** and **Ctrl+Page Down** to scroll through the CommandManager tabs.

As in previous releases, you can change the shortcut keys by clicking **Tools > Customize** and clicking the Keyboard tab.
3
SolidWorks Fundamentals

This chapter includes the following topics:

- Application Programming Interface
- Controlling the Save Reminder
- Documentation
- Equations
- Manipulating Views
- Measure Tool
- Opening Files - Quick Filter Buttons
- Previous Release Interoperability
- Searching SolidWorks Options
- Selecting a SolidWorks Version When Opening a File
- SolidWorks Sounds
- SolidWorks Startup
- Transferring Custom Properties When Inserting Configured Parts

Application Programming Interface

SolidWorks 2013 includes the following functionality:

- Microsoft® Visual Basic® for Applications (VBA) programming language, one of the programming languages available to record, edit, and run macros in SolidWorks, has been upgraded to support both 32-bit and 64-bit data types.
- SolidWorks primary interop assemblies created with Microsoft .NET Framework:
  - Version 2.0 are in install_dir\api\redist\CLR2. This is the version of primary interop assemblies to use with SolidWorks VSTA (VB.NET and C#) macros.
  - Version 4.0 are in install_dir\api\redist.
- Both SolidWorks Costing and SolidWorks Sustainability include APIs.

Other major enhancements include the ability to:

- Insert cosmetic weld beads and access their feature data and folders.
- Get the direction vectors of connection points.
- Get or set whether to display a ruler when the drag arrow manipulator moves.
- Get or set whether to allow the unidirectional drag arrow manipulator to change direction when dragged past length = 0.
- Create a forming tool feature with a point of insertion.
- Add display dimensions to a macro feature.
- Get or set whether to apply the appearance of material.
- Insert revision cloud annotations into drawings.
• Create a conic curve in the active sketch.
• Get the direction of a bend in sheet metal.
• Get or set the background processing option and handle background processing events for drawings.
• Handle drawing sheet activation events.
• Hide Undo operations.
• Specify the type of numbering and whether to show the detailed cut list in indented BOM tables.
• Get or set the state of the flyout FeatureManager design tree.
• Make a component virtual by saving it in an assembly.
• Vary individual instances of linear and circular feature patterns.
• Get the unique name of a section view.
• Get or set the transparency level of unmodified components in assemblies opened in Large Design Review mode.
• Create a SpeedPak configuration that includes all faces and a specified threshold of parts or bodies for the active configuration.
• Copy appearances to the clipboard and apply them to faces, features, bodies, components, and parts.
• Merge bend tags in drawings of sheet metal parts.
• Get or set the text format of bend notes in the drawing views of sheet metal parts.
• Place the selected note, located on the sheet format, behind the drawing sheet.
• Insert a note that contains all of the cut list item properties of a sheet metal part.


Controlling the Save Reminder

You can control how long the save notification is displayed.

Click Tools > Options > System Options > Backup/Recover and under Save notification, enter a value for Automatically dismiss after n seconds.

Documentation

Help Navigation

Help content has more consistent presentation and styling.

Links to Related Topics are now more accessible. They appear on the right side of the page and remain in place and visible as you scroll the Help content.

Motion Studies Tutorials

There are two new Motion Studies tutorials: Motion Analysis Redundancies and Motion Along a Path.

To access a tutorial:

1. Click Help > SolidWorks Tutorials.
2. Click All SolidWorks Tutorials and select a tutorial from the list.
**SolidWorks Tutorials User Interface**

The access page for SolidWorks tutorials has been redesigned for improved user experience.

The layout and groupings of tutorials have been reorganized. All tutorials, including SolidWorks Simulation tutorials, are available from one interface. Links for navigating through the tutorials are always visible at the bottom of the page.

To open SolidWorks tutorials, click **Help > SolidWorks Tutorials**.

---

**Equations**

**Direct Input of Equations**

For many features, you can enter and modify equations directly in PropertyManager fields that allow numerical inputs. You can create equations with global variables, functions, and file properties without accessing the Equations, Global Variables and Dimensions dialog box.

The following table lists where this capability is available:

<table>
<thead>
<tr>
<th>Part Features</th>
<th>Assembly Features</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extruded Boss/Base</td>
<td>Extruded Cut</td>
</tr>
<tr>
<td>Extruded Cut</td>
<td>Revolved Cut</td>
</tr>
<tr>
<td>Simple Hole</td>
<td>Fillet</td>
</tr>
<tr>
<td>Part Features</td>
<td>Assembly Features</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------</td>
</tr>
<tr>
<td>Revolved Boss/Base</td>
<td>Chamfer</td>
</tr>
<tr>
<td>Revolved Cut</td>
<td>Hole</td>
</tr>
<tr>
<td>Fillet</td>
<td>Linear Pattern</td>
</tr>
<tr>
<td>Chamfer</td>
<td>Circular Pattern</td>
</tr>
<tr>
<td>Scale</td>
<td></td>
</tr>
<tr>
<td>Shell</td>
<td></td>
</tr>
<tr>
<td>Rib</td>
<td></td>
</tr>
<tr>
<td>Draft</td>
<td></td>
</tr>
<tr>
<td>Base Flange</td>
<td></td>
</tr>
<tr>
<td>Edge Flange</td>
<td></td>
</tr>
<tr>
<td>Linear Pattern</td>
<td></td>
</tr>
<tr>
<td>Circular Pattern</td>
<td></td>
</tr>
<tr>
<td>Curve Driven Pattern</td>
<td></td>
</tr>
<tr>
<td>Extruded Surface</td>
<td></td>
</tr>
<tr>
<td>Revolved Surface</td>
<td></td>
</tr>
<tr>
<td>Fillet Surface</td>
<td></td>
</tr>
</tbody>
</table>

For example, in the PropertyManager for the Extruded Boss/Base feature, you can enter equations in:

- **Depth** fields for **Direction 1** and **Direction 2**
- **Draft** fields for **Direction 1** and **Direction 2**
- **Thickness** fields for a **Thin Feature** with two direction types
- **Offset Distance** field

To create an equation in a numeric input field, start by entering = (equal sign). A drop-down list displays options for global variables, functions, and file properties.

Numeric input fields that contain equations can display either the equation itself or its evaluated value. You can toggle between the equation and the value by clicking the Equations or Global Variable button that appears at the beginning of the field.

You cannot change an evaluated value when it is displayed in the input field, but you can toggle to the equation and then edit or delete the equation.
Equations that you create or edit in the PropertyManager, Equations dialog box, or Modify dialog box are reflected in all that areas.

**Increment Values with Spin Arrows**
You can quickly increment or decrement values in equations using the spin arrows that appear at the end of a numeric input field.

For example, use the following keys or key combinations:

- Click the **Up** or **Down** arrow to change the value by 10. For example, if the value is 10.00mm, click the **Up** arrow to increase it to 20.00mm.
- Press **Alt+Up** or **Alt+Down** arrow to change the value by 1. If the value is 10.00mm, **Alt+Up** increases the value to 11.00mm.
- Press **Ctrl+Up** or **Ctrl+Down** arrow to change the value by a 100. If the value is 10.00mm, **Ctrl+Up** increases the value to 110.00mm.

The units of the **Spin Box Increments** may vary depending on the settings specified in **System Options**.

**Using Equations in the Chamfer PropertyManager**
You can bevel the edges of a model using equations.

1. **Open** `install_dir\samples\whatsnew\fundamentals\simple_frontplate.sldprt`.
2. In the FeatureManager design tree, right-click the **Equations** folder, and select **Manage Equations**.
   
   The Equations dialog box lists two global variables and three equations.
3. Click **OK** to close the Equations dialog box.
4. Click **Chamfer** (Features toolbar), or **Insert > Features > Chamfer**.
5. In the PropertyManager, under **Chamfer Parameters**, do the following:
   
   a) In the graphics area, select the four edges of the front face for **Edges and Faces** or **Vertex**.
   
   b) Create a new global variable in **Distance** by typing `=chamfer` and click **OK** in the input field.
c) Type to change the value from 10mm to 6mm.
d) Type \( \text{Angle} \) : Select \textbf{Functions} > \textbf{sin()} \) from the flyout menu. Then type \( \text{sin}(90) \times 10 \) and click \( \checkmark \) in the input field.

The field displays an \textbf{Equations} button \( \sum \). Click \( \sum \) to toggle the display between the equation and the value.

6. Click \( \checkmark \).

The global variable "chamfer" and the angle equation are listed in the Equations dialog box.

To remove either a global variable or equation from the PropertyManager, click in the input field and press \textbf{Delete}.

**Enhanced Support for Units of Measurement**

You can specify the units of measurement for global variables, and for the values and equations that define the global variables. You can define the units in the Equations and Modify dialog boxes for dimensions, and in PropertyManagers that support equations.

Assigning units of measure in equations ensures that you do not need to edit the equations if you change the unit of measure property of a document. It also allows you to create equations that mix values with different units of measurement.

For example, you can create a global variable \textit{Length} and define it by the equation: \( =100\text{in} + 3\text{mm} + 5\text{cm} \). The equation includes values with three different units of measurement. If the unit of measurement of the document is inches, then \textit{Length} evaluates to 102.087in. If you change the unit of measurement of the document to millimeters, then \textit{Length} automatically evaluates to the value of 2593mm. You do not need to edit the equation, or be concerned that the size of the part will change.

In the Equation and Modify dialog boxes, type-ahead lists help you assign a valid unit of measurement to each value in an equation.
Manipulating Views

**Orientation Dialog Box**

You can create custom views and save them to SolidWorks, allowing you to reuse saved views in different documents.

You also access snapshots in the custom view list. The Orientation dialog box now shares the same set of buttons for standard views as the Heads-up View toolbar.

The Orientation dialog box also provides access to the View Selector.

Axonometric Views are displayed in a drop-down list. Click to select isometric, trimetric, or dimetric.

To activate the Orientation dialog box, press the spacebar or click View Orientation (Heads-up View toolbar) and click More Options.

**Using the Orientation Dialog Box and the View Selector**

In this example, you use the Orientation dialog box and the View Selector to manipulate views, update standard views, and save a custom view to SolidWorks.

First, you use the Orientation dialog box and the View Selector:

1. Open install_dir\samples\whatsnew\fundamentals\RobotArm.sldprt.
2. Press the spacebar or click View > Modify > Orientation.
   
   The Orientation dialog box appears.

3. Click View Selector.
   
   The View Selector is activated. As you hover over the buttons in the Orientation dialog box, the corresponding faces dynamically highlight in the View Selector.

4. Select the back view in the View Selector or click Back in the Orientation dialog box.

   The Orientation dialog box closes and the model rotates to the back view.
5. Press **Ctrl + spacebar** to activate the View Selector. Select one of the diagonal views.

### Updating Standard Views

You can use the Orientation dialog box to update standard views.

1. Press the spacebar. Click ![Deactivate View Selector](image) to deactivate the View Selector.

   When the View Selector is active, it automatically launches when you open the Orientation dialog box.

2. Click ![Pin Orientation Dialog Box](image) to pin the Orientation dialog box.

3. Click **Top**.
   
   The model rotates to the top view.

4. Click **Update Standard Views**.

   The software prompts you to select the standard view you want to assign the current view to.
5. Click **Front**.
6. Click **Yes** in the warning dialog box.
   The standard views update, with the current view set as the front view.

**Saving a Custom View to SolidWorks**

You can create a custom view and save it so it is accessible other documents.

1. Rotate the model as shown.

![Image of a model]

2. Click **New View**.
3. In the dialog box, name the view **Foreshortened** and click **OK**.
   Your view appears in the Orientation dialog box. You can now toggle between any of the standard views and the custom view you created.
4. Mouse over **Foreshortened** in the Orientation dialog box. Options to save or delete the view appear. Click **Save to SolidWorks**.
   The 📀 image appears next to **Foreshortened**, indicating that it is available in other SolidWorks documents.
5. Open the document `install_dir\samples\whatsnew\fundamentals\RobotLeg.sldprt`

![Image of a model]

6. In the Orientation dialog box, click **Saved Views** and click **Foreshortened**.
   **Foreshortened** is added to the Orientation dialog box and the model rotates to the saved view.

If you click only the checkbox, and not the view name, **Foreshortened** is added to the list of saved views, but the model does not rotate to the view.
Updating Standard Views Without Using the Orientation Dialog Box

You can update standard views without opening the Orientation dialog box.

To update standard views:

1. Right-click in the graphics area and click **Set Current View As**. Select the desired view from the menu.
2. Click **Yes** in the warning dialog box.
   
The scene floor automatically updates to be aligned with the bottom view plane, updating floor reflections and shadows.

By default, the scene floor is aligned with the bottom view plane. To align the scene floor differently, right-click the scene in the DisplayManager and click **Edit Scene**. Under **Floor**, make a selection in **Align floor with**.

View Rotation

You can lock the vertical axis in relation to the front view during view rotation. This prevents the model from tipping and tilting about the horizon plane and creates the impression that the model is on a floor.

Right-click in the graphics area and click **Rotate about scene floor**.

The vertical axis locks in relationship to the front view. If your model's front view does not match the vertical axis you want to rotate around, you can change the front view. See **Updating Standard Views Without Using the Orientation Dialog Box** on page 29.

For example, this image shows the front view of the toy tractor.

The vertical axis of rotation locks around the Y axis and the floor is parallel to the X axis. In the following image, the dotted red arrow indicates the locked axis of rotation:
The Y axis is the vertical axis by default. However, if you update standard views, the vertical axis might change.

**View Selector**

You can use the View Selector to see and select model views in context.

Press **Ctrl + Spacebar** or click **View Selector** in the Orientation dialog box.

The View Selector helps you see what right, left, front, back, top, and isometric views of your model will look like when selected.

The View Selector also allows you to select additional standard and isometric views. For example, in the image below, the bottom isometric view is highlighted.

When selected, the model rotates to the bottom isometric view:
For a What's New Example that uses the View Selector, see Using the Orientation Dialog Box and the View Selector on page 26.

Measure Tool

Improvements have been made to the Measure Tool functionality and user interface.

Point-to-Point Mode

You can measure the distance between two points on your model. This mode supports snapping to model faces and edges, as well as midpoints, quadrant points, and intersections.

Arc/Circle Measurements

You can create measurements with custom arc conditions. For example, you can measure the distance from the center of one arc or circle to the outer edge of another. Use drop-down menus on the Measure callouts in the graphics area to toggle between center, maximum, minimum, and custom distances.

Last Used Settings

The Measure tool retains settings from the last time it was used.

History

Click History to see measurements made during the current session of SolidWorks.

User Interface

The icon has been replaced with to indicate the option to create a sensor from the current measurement.

XYZ Relative To does not appear when there is only one coordinate system.
Measuring in Point to Point Mode

You can use Point-to-Point mode to compare the distance between two faces at different places on the model.

1. Open `install_dir\samples\whatsnew\fundamentals\clip.sldprt`.

2. Click **Measure** (Tools toolbar) or **Tools > Measure**.

3. In the Measure dialog box, click **Point-to-Point**.

4. Select a point near the center of one of the flat faces of the grip, and then a point near the center of the other flat face, rotating the model if necessary.
   The measurement appears in the graphics area and in the Measure dialog box.

5. Click in the graphics area to clear the current measurement.

6. Select the midpoint of the top edge of the flat face of the grip, and then the midpoint of the opposite edge.

   When you hover over an edge, the midpoint appears, allowing you to select it, like in a sketch.

   The measurement appears in the graphics area and in the Measure dialog box.
7. Click in the graphics area to clear the current measurement.
8. Click **Point-to-Point** to exit Point-to-Point mode.

### Measuring the Distance Between Two Circles

You can measure the distance between two circles using Maximum, Minimum, and Custom Distances.

1. With the Measure dialog box still open, rotate the model so you can see the bottom face.
2. Click the edges of the two holes.
   The measurement appears in the graphics area and in the Measure dialog box.

3. Click the down arrow on the measure callout in the graphics area to toggle between Center, Maximum, and Minimum Distance.
4. To set a custom arc condition, click **Arc/Circle** in the Measure tool and click **Custom Distance**. Set the following values:
   a) Under **First Arc Condition**, select **Minimum Distance**.
   b) Under **Second Arc Condition**, select **Center Distance**.
5. Click **Measurement History** to view all the measurements made during this session of SolidWorks.
6. Close the Measure tool.
Opening Files - Quick Filter Buttons

Quick Filter buttons in the Open dialog box allow quicker access to commonly-used SolidWorks file types.

Click Quick Filter buttons in any combination to see the desired file type. For example, click **Filter Parts** to see only parts. To see parts and assemblies, click **Filter Parts** and then **Filter Assemblies**.

Opening Top-Level Assemblies

If you have a folder containing assemblies and subassemblies, you can use a quick filter button to see only top-level assemblies.

Click **Filter Top-Level Assemblies** to see only top-level assemblies. If you have a very large number of files in the folder, this may take a while.

Previous Release Interoperability

You can open SolidWorks 2013 parts and assemblies using SolidWorks 2012 Service Pack 5.

From SolidWorks 2012 on, you can open a future version file in Service Pack 5 of the previous release. For example, in SolidWorks 2013 Service Pack 5 you will be able to open SolidWorks 2014 files. Interoperability is only supported between consecutive releases. For example, you cannot open a SolidWorks 2014 file in SolidWorks 2012 Service Pack 5.

Future version files appear in read-only mode when opened in the previous release. However, once you upgrade to the next version of SolidWorks, all the FeatureManager design tree data is available.

SolidWorks 2013 files have reduced functionality in SolidWorks 2012 Service Pack 5. SolidWorks 2013 files will not have most FeatureManager design tree data when opened in SolidWorks 2012 Service Pack 5. Any actions that require FeatureManager design tree data cannot be performed with a SolidWorks 2013 document open in SolidWorks 2012 Service Pack 5.

The following table summarizes what you can and cannot do in SolidWorks 2012 Service Pack 5:
### Parts and Assemblies: Assemblies: Drawings:

<table>
<thead>
<tr>
<th>With a SolidWorks 2013 part or assembly open in SolidWorks 2012 you can:</th>
<th>You can work with SolidWorks 2013 parts and subassemblies in a SolidWorks 2012 assembly. In a SolidWorks 2012 assembly, you can:</th>
<th>You can create drawings of SolidWorks 2013 parts and assemblies in SolidWorks 2012 with some limitations. You cannot:</th>
</tr>
</thead>
<tbody>
<tr>
<td>• View configurations.</td>
<td>• Mate the SolidWorks 2013 component or subassembly to SolidWorks 2012 or SolidWorks 2013 components.</td>
<td>• Insert model items.</td>
</tr>
<tr>
<td>• Use the Measure tool.</td>
<td>• Add a Bill of Materials that includes SolidWorks 2012 and SolidWorks 2013 components.</td>
<td>• Access FeatureManager design tree data such as weldment cut lists and weld beads.</td>
</tr>
<tr>
<td>• View Mass Properties and Custom Properties.</td>
<td>• Suppress and unsuppress SolidWorks 2013 components.</td>
<td></td>
</tr>
<tr>
<td>• View Materials</td>
<td>• Create a drawing of the SolidWorks 2012 assembly that includes both SolidWorks 2012 and SolidWorks 2013 components.</td>
<td>You cannot open 2013 drawings in SolidWorks 2012 Service Pack 5</td>
</tr>
<tr>
<td>You cannot edit SolidWorks 2013 parts or assemblies in SolidWorks 2012.</td>
<td>• Use interference detection when mating SolidWorks 2013 and SolidWorks 2012 parts.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Mirror and pattern components from SolidWorks 2013.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• See and reference default planes and origins of the SolidWorks 2013 part or subassembly.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>You cannot edit mates or components in the SolidWorks 2013 subassembly.</td>
<td></td>
</tr>
</tbody>
</table>

In SolidWorks 2013, you must rebuild and save data for each configuration that you want to be available in SolidWorks 2012 Service Pack 5. See Managing Configuration Data on page 75.
Searching SolidWorks Options

You can search for options and settings within **Tools > Options**.

In the Options dialog box, enter a term in the **Search** box and select a result. You can search for both System and Document Options.

As you type in the Search string, search results dynamically appear. Click a search result to be taken to the appropriate Options page. Search results are highlighted in the Options dialog box, unless they appear in a drop-down menu.

Your search may not be visible on the Options page due to the type of model you have open or the current settings.

Selecting a SolidWorks Version When Opening a File

If you use Windows® Explorer to open a SolidWorks file, and you have multiple versions of SolidWorks installed on your computer, a dialog box prompts you to select which version to use to open the file.

The Multiple Versions dialog box displays up to the three most recent versions of SolidWorks that are installed on your computer. For example, if SolidWorks versions 2009 to 2013 are installed, you can choose to open the file with version 2011, 2012 or 2013.

If you want to use the selected version to open all of your SolidWorks files, you can suppress the dialog box by selecting **Do not show this again**.

You can reset files with the version of SolidWorks that last saved them from **Tools > System Options > File Explorer** and clicking **Restore file Associations**. For example, you might use this if you had SolidWorks 2012 SPO4 and the SolidWorks 2013 beta on your machine, and then uninstalled the SolidWorks 2013 beta.

To restore file associations, you must launch SolidWorks with **Run as administrator** privileges. These steps may vary per operating system. For information on how to **Run as administrator**, consult the Microsoft Knowledge Base.

SolidWorks Sounds

You can add sounds to SolidWorks program events using the Windows Sounds dialog box.

You can add sounds to the following SolidWorks events:

- Animation Complete
- Collision Detected
- Design Study Scenario Complete
- Interference Detected
- Mesh Completed Successfully
- Mesh Failure
- Open File Complete
- Rebuild Complete
- Rebuild Error
- Render Complete
- Sensor Alert
Adding Sounds to Events in SolidWorks

To assign sounds to events in SolidWorks:

1. Click **Tools > Options > System Options > General** and select **Enable sounds for SolidWorks events**.
2. Click **Configure Sounds**.
   The Windows Sound dialog box opens.
3. Scroll to the bottom of the **Program Events** box. Under **SolidWorks** select the event you want to add a sound to.
4. Select a sound from the **Sounds** drop-down list.
5. Click **OK**.

SolidWorks Startup

You can cancel the startup of SolidWorks if you launch it accidentally. Messages on the splash screen inform you of the startup progress.

**SolidWorks Fast Start**

To launch more quickly, SolidWorks begins loading components in the background when you start your computer.

To turn off SolidWorks Fast Start, from Windows click **Start > Startup**. Right-click **SolidWorks Fast Start** and click **Delete**.

See **SolidWorks Help: SolidWorks Fast Start**.

Transferring Custom Properties When Inserting Configured Parts

Improvements have been made to transferring of custom properties when you insert a configured part into another part.

See **Transferring Custom Properties**.
This chapter includes the following topics:

- Converting Files to SolidWorks 2013
- Interoperability Between SolidWorks 2012 SP5 and SolidWorks 2013
- Save and Restore User Settings
- SolidWorks CAD Admin Dashboard

Converting Files to SolidWorks 2013

Opening a SolidWorks document from an earlier release might take extra time. After you open and save a file, subsequent opening time returns to normal.

You can use SolidWorks Task Scheduler to convert multiple files from an earlier version to the SolidWorks 2013 format. Click Windows Start, then All Programs > SolidWorks 2013 > SolidWorks Tools > SolidWorks Task Scheduler.

In the Task Scheduler:

- Click Convert Files and specify the files or folders to convert.
- For files in a SolidWorks Workgroup PDM vault, use Convert Workgroup PDM Files.

For files in a SolidWorks Enterprise PDM vault, use the utility provided with Enterprise PDM.

After you convert files to SolidWorks 2013, you cannot open them in older SolidWorks versions, with the exception of SolidWorks 2012 Service Pack 5. See Previous Release Interoperability on page 34 for more information.

Interoperability Between SolidWorks 2012 SP5 and SolidWorks 2013

If you have SolidWorks 2012 Service Pack 5, you can open parts and assemblies created with SolidWorks 2013.

However, the files open in read-only mode, and not all FeatureManager design tree data is available. See Previous Release Interoperability on page 34 for more information.

Save and Restore User Settings

You can save and restore your keyboard shortcuts, customized menus and toolbars, and system options from the Tools menu. Selecting Tools > Save/Restore Settings runs
the Copy Settings Wizard in a special mode which allows the SolidWorks software to remain up and running, while you save or restore your current user settings.

**SolidWorks CAD Admin Dashboard**

With the CAD Admin Dashboard, you can monitor the performance, hardware status, and changes to SolidWorks System Options settings for each SolidWorks user at your company. You can access the dashboard through the SolidWorks Customer Portal, provided you have a SolidWorks subscription contract.

**To access the SolidWorks CAD Admin Dashboard:**

- Link to the SolidWorks Customer Portal, select your language, and login.

Some update to the CAD Admin Dashboard might not be reflected in this documentation.

**The CAD Admin Dashboard Basic Workflow**

In this example, you step through a basic workflow for overseeing SolidWorks software usage in your network.
**Accessing the CAD Admin Dashboard**
As a subscription customer, you can access the CAD Admin Dashboard from the SolidWorks Customer Portal.

**To access the CAD Admin Dashboard:**
1. Open the [SolidWorks Customer Portal](#) in a browser, select your language, and login.
2. Under Quick Links, click CAD Admin Dashboard.
3. After reading the agreement, click I agree.

   If you do not agree to the terms, you cannot access the CAD Admin Dashboard.

**System Options Assessments**
You can assess your network computers against a baseline of selected SolidWorks system options.

You can set a baseline for the following SolidWorks system options for your network:
- Performance
- Assemblies
- External References
- Default Templates
- File Locations
- Hole Wizard
- Dismissed Messages

The system options for any account on your network are tested against those of the baseline account you select.

**Assigning the System Options Baseline**
The CAD Admin Dashboard compares system options of SolidWorks software users in your network to those of a baseline machine.

**To set the baseline machine for system options in the CAD Admin Dashboard:**
1. Select a row for the target machine account from the main CAD Admin Dashboard.
2. At the right end of the account row, click Set System Options Baseline to this Account.

   The baseline is defined by the system options that are in effect on the selected account machine at the time that you select the account.

**Assessing Machine Details**
You can view information about the computers running SolidWorks in your network from the Machine Details column of the CAD Admin Dashboard.

To view detailed information about an account in your network, select the account under the Machine Details column. If the machine details indicate problems, you can improve system performance by updating graphics drivers or adding more memory or hard disk space according to the reported details.
To view computer information for SolidWorks users in your network from the CAD Admin Dashboard:

1. Scroll through the overview of computer information for your accounts in the **Machine Details** column.
   
   You can view the following types of information:

   - **Driver unsupported**
     
     Indicates an unsupported graphics card driver. You can select the account to view more graphics driver details.

   - **Low memory**
     
     Indicates the account machine is low on memory. You can select the account to view the available hard disk space in the **Free HDD** column and the available RAM in the **RAM** column.

2. When you select an account, you can view more machine details.
   a) Select the account row.
   b) In the **Details** section below, select the Machine Details tab.

   You can view details for the account machine, such as CPU, free HDD, and graphics card information.

3. When the information is available, double-click the account row  in the **History** column of the machine account details.

   The Hardware and Software History dialog box displays the version of the SolidWorks software that is installed or graphics card updates when available.

For a list of supported drivers, see [http://www.solidworks.com/sw/support/videocardtesting.html](http://www.solidworks.com/sw/support/videocardtesting.html).
This chapter includes the following topics:

- **Push Install and Uninstall Method Using the Option Editor**

**Push Install and Uninstall Method Using the Option Editor**

The Administrative Image Option Editor provides a push method for deploying the SolidWorks software remotely on Windows Vista® and Windows 7 clients for users who do not have administrative privileges.

A new **Deploy Automatically** page allows administrators to select systems for installing, updating or uninstalling the SolidWorks software. Operations can be scheduled for a specific time. Custom uninstalls can also be performed. The status of each requested deployment is recorded and listed as **Pending**, **Succeeded** or **Failed**.

The installation tasks are pushed to the target machines and carried out by the Microsoft Task Scheduler on each system, without requiring any actions by users.

To use this method, the computer serving the administrative image and the target client machines must be members of the same Microsoft Active Directory domain.
This chapter includes the following topics:

- Assembly Visualization
- Breaking All External References at Once
- Deleting Components from Subassemblies
- Derived Components
- Envelopes
- Multiple Exploded Views per Configuration
- Inserting Components
- Interference Detection
- Large Assemblies
- Mass Properties in Assemblies
- Mates in Mirrored Subassemblies
- Replacing Components
- Selecting Subassemblies in the Graphics Area
- Snapshots
- Swept Cut Assembly Features

Assembly Visualization

Additional Properties Available

Additional predefined properties are available for selection. New view modes are available for grouping and ungrouping components in the list.

You can select the following component properties from the drop-down list in the Custom Column dialog box.

- Converted to current version
- Excluded from BOM (instance-specific)
- External references
- Flexible subassemblies (instance-specific)
- Fully mated (instance-specific)

A new view mode has been added:

Grouped/Ungrouped View

**Grouped View**

Groups multiple instances of a component into a single line item in the list. **Grouped View** is useful when listing values for properties that are identical for every instance of the component.
**Ungrouped View**  Lists each instance of a component individually. **Ungrouped View** is useful when listing values for instance-specific properties, such as **Fully mated**, which might be different for different instances of the component.

By default, instance-specific properties are displayed in **Ungrouped View**, and properties that are not instance-specific are displayed in **Grouped View**. Previously, instance-specific properties were not available, and all properties were displayed in what is now called **Grouped View**.

**Colors for Group Identical**

To make the display more consistent and predictable, six colors are predefined for use with the **Group Identical** command.

If more than six colors are required, a random color assignment is made for the additional colors. Also, when you turn the colors off and then on again, the colors are retained. Previously, new random colors were assigned.

To change the predefined colors, click **Tools > Options > System Options > Colors**. Under **Color scheme settings**, select **Assembly Visualization number** and click **Edit**.

**Component Image Quality**

You can check for components whose image quality might be slowing down graphics performance of very large assemblies.

The property **Graphics-Triangles** indicates the number of tessellation triangles used to display a component. For a given component, as you increase the image quality setting, the triangle count increases and performance slows down. If graphics performance is slow in a very large assembly, you can sort components by **Graphics-Triangles**. Then consider hiding components with high triangle counts.

**Excluding Hidden Components**

When you save a list of components to an external file, you can specify to exclude hidden components from the list.

In Assembly Visualization, click the arrow ▶ to the right of the column headers and click **Save as**. In the Save As dialog box, select **Exclude hidden components**.

**Import and Export of Settings**

You can import and export assembly visualization settings, enabling you to transfer your setup from one assembly to another.

In Assembly Visualization, click the arrow ▶ to the right of the column headers and click **Save Style** to export the current settings, or **Load Style** to import saved settings. Settings are saved in an Excel® spreadsheet.

Supported settings include:
- Number of columns
- Selected properties in columns
- Sort order
- Colors
• Value bars
• Part mode or assembly mode
• Units

Breaking All External References at Once

You can lock or break all external references in an entire assembly hierarchy (or in a selected subassembly within the hierarchy) at the same time. Previously, you had to find and address each component individually.

Optionally, you can select to replace broken sketch relations with fixed relations when you break the references.

Right-click a top-level assembly or one subassembly at a time and click **List External References**.

Deleting Components from Subassemblies

In an assembly, when you select a component that belongs to a subassembly and perform a **Delete**, only the selected component is deleted.

Previously, the entire subassembly hierarchy to which the component belongs was deleted.

Derived Components

You can include items such as custom properties, sketches, and model dimensions from the seed component when mirroring components or creating derived components.

For example, when you mirror a component and create an opposite-hand version, a new page in the PropertyManager lets you select items to copy from the seed component to the opposite hand version. You can select any of the following:

• **Solid bodies**
• **Surface bodies**
• **Axes**
• **Planes**
• **Cosmetic Threads**
• **Absorbed sketches**
• **Unabsorbed sketches**
• **Custom properties**
• **Coordinate systems**
• **Model dimensions**
• **Hole wizard data**

Envelopes

You can now make envelopes from subassemblies. Workflow improvements include designating components as envelopes as you insert them into assemblies, and changing
components to or from envelopes at any time. New options let you adjust envelope visibility and load envelopes as lightweight or read-only.

**Creating an Envelope from a Component**

You can change components to or from envelopes at any time. You can make an envelope from any component within the hierarchy of the assembly.

1. Open `install_dir\samples\whatsnew\assemblies\printer\printer_bottom.sldasm`.
   
   The component `case_bottom` is already an envelope, as indicated by 🗑️ in the FeatureManager design tree and the component's transparent blue color in the graphics area.

![Diagram of a component](image)

Now make `jack_12` an envelope. `jack_12` is a component of subassembly `board_A2`.

2. Right-click `jack_12` in the graphics area or FeatureManager design tree and click **Component Properties 🗑️**.

3. In the lower right corner of the dialog box, select **Envelope**. **Exclude from bill of materials** also becomes selected, because envelopes are never included in the bill of materials.

4. Click **OK**.
   
   In the graphics area, the component becomes a transparent blue color. In the FeatureManager design tree, 🗑️ beside `jack_12` indicates that the component is an envelope.
Creating an Envelope While Inserting a Component

You can make envelopes from subassemblies. You can designate components as envelopes as you insert them into assemblies.

1. Click **Insert Components** (Assembly toolbar) or **Insert > Component > Existing Part/Assembly**.
2. In the PropertyManager, under **Options**, select **Envelope**.
3. Under **Part/Assembly to Insert**, click **Browse**.
4. In the **Open** dialog box, browse to `install_dir\samples\whatsnew\assemblies\printer\connector_andBracket.sldasm` and click **Open**.
5. Click to place the subassembly in the graphics area approximately as shown.

Now mate the envelope to the case. Coordinate systems have already been added to the models to facilitate mating.

6. Click **View > Coordinate Systems**.
7. Click **Mate** (Assembly toolbar) or **Insert > Mate**.
8. In the PropertyManager:
   a) For **Entities to mate** ✴, select the two coordinate systems in the graphics area.

   ![Diagram showing coordinate systems]

   b) Under **Standard Mates**, select **Coincident** and **Align axes**.

c) Click ✅ twice.
   The subassembly envelope is mated to the case.

9. Click **View > Coordinate Systems** to hide the coordinate systems.

**Changing Envelope Appearance**

In System Options, you can adjust the color and transparency of envelopes.

1. Click **Options (Standard toolbar)** or **Tools > Options**.
2. On the System Options tab, click **Colors**.
3. In **Color scheme settings**, select **Envelope Components**.
4. Click **Edit** and select a new color, such as ✉️, and click **OK**.
5. Near the bottom of the dialog box, for **Envelopes**, select **Opaque**.
6. Click **OK**.
7. All the envelopes change color and become opaque in the graphics area.

8. To restore the default settings, repeat steps 1 through 6, except:
   - For color, select \( \text{Red} = 128, \text{Green} = 255, \text{Blue} = 255 \).
   - For Envelopes, select Semi Transparent.

Hiding and Showing Envelopes

You can hide and show all envelopes at once.

1. In the FeatureManager design tree, right-click the assembly name at the top of the tree and click Hide All Envelopes.
   All envelopes in the assembly are hidden.

2. To show the envelopes, right-click the assembly name again, and click Show All Envelopes.
   All the envelopes are shown.
You can right-click any subassembly in the tree and click **Hide All Envelopes** or **Show All Envelopes** to hide or show all envelopes within the subassembly.

### Changing Envelopes into Regular Components

You can change envelope components into regular components.

1. Right-click `case_bottom` in the graphics area or FeatureManager design tree and click **Component Properties**.

2. In the lower right corner of the dialog box, clear **Envelope**. **Exclude from bill of materials** also becomes cleared.

3. Click **OK**.

   The component is no longer an envelope. In the FeatureManager design tree, 📦 is replaced by 📦 to indicate that the component is a regular component of the assembly. In the graphics area, the component is no longer transparent blue.
Other Changes for Envelopes

- The prefix Envelope is no longer used in the names of envelope components.
- The menu item Insert > Envelope is no longer available.
- Envelopes are no longer listed in the ConfigurationManager.
- Envelopes are no longer shown when using Show with Dependents.
- If you copy, mirror, or pattern an envelope, the resulting new component is also an envelope.

Advanced Selection Tools for Envelopes

The advanced selection tools that use envelopes to select, show, or hide other components are available from the FeatureManager design tree and the graphics area. Previously they were available by right-clicking an envelope in the ConfigurationManager.

The advanced selection tools are available only for envelopes made from parts, and only in the top-level assembly. They are not available for envelopes made from subassemblies, and are not available for envelopes within subassemblies.

To select, show, or hide using envelopes:

1. Right-click an envelope.
2. Click Envelope, and click one of the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Using Envelope</td>
<td>Lets you select components for editing operations, based on their positions relative to an envelope component.</td>
</tr>
<tr>
<td>Show/Hide using Envelope</td>
<td>Lets you specify selection criteria to hide or show assembly components, based on their positions relative to an envelope component.</td>
</tr>
</tbody>
</table>

Multiple Exploded Views per Configuration

In assemblies and multibody parts, you can create multiple exploded views for each configuration. You can use keyboard shortcuts to copy and paste exploded views.

Adding Multiple Exploded Views

You can add more than one exploded view to a configuration.

1. Open \install_dir\samples\whatsnew\assemblies\castor\castor_901.sldasm.
2. In the ConfigurationManager, expand `cfg_1` to see that it already has one exploded view. Now add another exploded view to `cfg_1`.

3. Click **Insert > Exploded View** or right-click `cfg_1` and click **New Exploded View**.

4. In the graphics area or flyout FeatureManager design tree, select the following components:
   - `wheel_105<1>`
   - `axle_support_102<1>`
   - `bushing_103<1>`

   In the PropertyManager, the components appear in **Component(s) of the explode step**. A triad appears in the graphics area.

5. In the PropertyManager, under **Options**, select **Auto-space components after drag** to automatically space the group of components along the axis after you drag and drop them.

6. In the graphics area, drag the red arm of the triad and release it approximately as shown:

   The wheel, axle support, and bushing are automatically spaced as shown:
7. Click ✓.

In the ConfigurationManager, ExplView2 appears under cfg_1.

8. Double-click ExplView2 to collapse it.

Copying Exploded Views
You can copy exploded views from one configuration and paste them into others.

1. Under cfg_1, Ctrl + select the two exploded views.
2. Press Ctrl + C.
3. Single-click cfg_2 to select it without activating it.
4. Press Ctrl + V.

The configuration icon changes from to to indicate that the configuration now has exploded views.

5. Double-click cfg_2 to activate it, and click to expand it.

Copies of the two exploded views are listed.

Each exploded view in the assembly must have a unique name.

6. Double-click Copy of ExplView2.

The exploded view expands.
Inserting Components

**Improved Depth When Inserting Components**

When you insert components, they are now placed at a more reasonable depth relative to nearby components or geometry. Previously, components sometimes looked close in the view plane but were actually at very different depths, which resulted in components flying out of view when you rotated the assembly.

**Inserting Multiple Components**

In the Insert Components PropertyManager, you can select multiple components at a time and then insert each one in succession without returning to the PropertyManager. Also, if you double-click the assembly origin, all the selected components are inserted at once, each with respect to the origin.

**Inserting Multiple Components at the Origin**

You can insert multiple components at a time at the origin of an assembly.

1. Open a new assembly.

2. If the origin is not visible in the graphics area, click View > Origins to display it.

3. In the PropertyManager, under Part/Assembly to Insert, click Browse, and browse to install_dir\samples\whatsnew\assemblies\mill.

4. In the dialog box, Ctrl + select these parts:
   - knee_2013.sldprt
   - saddle_2013.sldprt

   Both items appear in File name.

5. Click Open.

   In the PropertyManager, both parts are selected in Open documents. In the graphics area, a preview of knee_2013 is attached to the pointer.

   If a preview does not appear, click Graphics preview under Options in the PropertyManager.
6. Double-click on the assembly origin.
   The PropertyManager closes. Both parts are inserted at the assembly origin. The
   origin of each part is coincident with the assembly origin, and the planes of each part
   are aligned with the planes of the assembly. In the FeatureManager design tree, (f)
   beside each part indicates that both parts are fixed.

7. Click **View > Origins** to turn off the origin.

**Inserting Components in Succession**

You can select several components and click in succession to place them in different
locations in the assembly.

1. Click **Insert Components** (Assembly toolbar) or **Insert > Component >
   Existing Part/Assembly**.
2. In the PropertyManager, under **Part/Assembly to Insert**, click **Browse**.
3. In the dialog box, **Ctrl** + select these parts:
   - bracket_2013.sldprt
   - head_2013.sldprt
   - scale_2013.sldprt
   - table_2013.sldprt
4. Click **Open**.
   In the PropertyManager, all four parts are selected in **Open documents**. In the
   graphics area, a preview of **bracket_2013** is attached to the pointer.

5. Click to place the bracket approximately as shown.

   In the PropertyManager, the bracket disappears from the list. In the graphics area,
   a preview of **head_2013** is attached to the pointer.
6. Click in succession to place the head, the scale, and the table approximately as shown.

The PropertyManager closes. Each component is inserted where you clicked to place it.

**Inserting Multiple Instances of Multiple Components**

You can insert multiple instances of several components without closing the PropertyManager.

1. Click **Insert Components** (Assembly toolbar) or **Insert > Component > Existing Part/Assembly**.
2. In the PropertyManager, under **Part/Assembly to Insert**, click **Browse**.
3. In the dialog box, **Ctrl** + select these parts:
   - clamp_2013.sldprt
   - pillar_2013.sldprt
   - pin_2013.sldprt
4. Click **Open**.
   In the PropertyManager, all three parts are selected in **Open documents**. In the graphics area, a preview of clamp_2013 is attached to the pointer.

5. At the top of the PropertyManager, click 👇 to pin the PropertyManager, so that it remains open after you place the first instances of the parts.
6. Double-click approximately as shown.

An instance of each of the three parts is placed where you double-clicked.

7. Unpin the PropertyManager, so that it closes after you place the next instances of the parts.
8. Double-click approximately as shown.

Another instance of each of the three parts is placed where you double-clicked. The PropertyManager closes.

**Interference Detection**

You can exclude selected components in Interference Detection. You can filter components with matching cosmetic threads from Interference Detection results and place them in a separate folder.

**Excluding Components**

**Excluding Hidden Components**
You can exclude interferences involving hidden components.

1. Click **Interference Detection** (Assembly toolbar) or **Tools > Interference Detection**.
2. In the PropertyManager, under **Options**, select **Ignore hidden bodies/components**. When you click **Calculate**, interferences involving components that are hidden, including those hidden by the **Isolate** command, are ignored.
As in previous releases when the option was named **Ignore hidden bodies**, interferences between a multibody part’s hidden bodies and other components are also ignored.

**Excluding Selected Components**

You can exclude selected components from Interference Detection results. Optionally, you can specify to remember components to exclude from session to session.

1. Click **Interference Detection** (Assembly toolbar) or **Tools > Interference Detection**.
2. In the PropertyManager, select **Excluded Components**.
3. In the graphics area or flyout FeatureManager design tree, select components to exclude.
4. Select options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide excluded components from view</td>
<td>Hides the selected components until you close the PropertyManager.</td>
</tr>
<tr>
<td>Remember excluded components</td>
<td>Saves the list of components, so that they are automatically selected the next time you open the PropertyManager.</td>
</tr>
</tbody>
</table>

**Filtering Cosmetic Threads**

You can filter components with matching cosmetic threads from Interference Detection results and place them in a separate folder. Interferences due to mismatched threads, misaligned threads, or other interfering geometry are still listed as interferences.

Click **Interference Detection** (Assembly toolbar) or **Tools > Interference Detection**. In the PropertyManager, under **Options**, select **Create matching cosmetic threads folder**.

When you click **Calculate**, interferences due to properly matched cosmetic threads are filtered out of the main results and listed in the **Matching cosmetic threads** folder.

Interferences not moved to the folder are due to other problems and those interferences need to be investigated.

**Example 1: Matching Cosmetic Threads**

In this assembly, the cosmetic threads of the shaft and the hole are identical (for example, M10 x 1.5 hole and M10 x 1.5 shaft). Therefore, the interference is ignored (moved to the **Matching cosmetic threads** folder).
**Example 2: Mismatched Thread Specification**

If the parts in Example 1 have threads with mismatched pitch (for example, M10 x 1.5 hole and M10 x 1.25 shaft), they are flagged as interfering.

**Example 3: Misaligned Threaded Components**

If the threaded components are misaligned, they are flagged as interfering, even if the cosmetic threads are properly matched.

**Example 4: Other Interfering Geometry**

In this example, the cosmetic threads have matching thread specifications, but the hole is threaded for its full length through the plate, and the shaft is threaded for only part of the length of the bolt. They are flagged as interfering.

Separate components:

Assembled:
Large Assemblies

Large Design Review
New options and commands give you more control over updates in Large Design Review.

Updates While Opening an Assembly
A new system option lets you control whether or not components are checked for out-of-date graphics data and updated when you open an assembly in Large Design Review mode.

Previously, components were always checked and updated. Now, the default behavior is to not check and update. To return to the old behavior, click **Tools > Options > System Options > Assemblies** and select **Automatic check and update all components**.

Updates After Opening an Assembly
Existing command **LDR Update** has been renamed to **Update Connected Components**. Two new commands let you update the entire assembly or selected components.

- Right-click the assembly name at the top of the FeatureManager design tree and click one of the following:

  | **Update Connected Components** | (Previously named **LDR Update**) Updates the graphics data of all dependent components that become out of date due to changes to their parent components. |
  | **Update Model Graphics** | Updates the graphics data of the entire model. |

- Right-click a component and click:

  | **Update Component Graphics** | Updates the graphics data of the selected component. |

Managing Configuration Data
For part and assembly models containing configurations, new options help you to manage the size of files and the time needed to save them. You can specify and identify which
configurations to always keep up to date. You can purge cached configuration data every
time you save the model.

In SolidWorks 2013, you must rebuild and save data for each configuration that you
want to be available in SolidWorks 2012 Service Pack 5. See Previous Release
Interoperability on page 34.

See Managing Configuration Data on page 75.

Skipping Rebuild After Editing Components

A new system option lets you skip the rebuilding of large assemblies after editing a
component in a separate window.

As in previous releases, when you switch back to the assembly window after editing a
component in a separate window, a message asks if you want to rebuild the assembly.
If you have selected the new option and the assembly is in Large Assembly Mode, then
the message no longer appears, the assembly is not rebuilt, and a yellow warning triangle
appears on Rebuild (Standard toolbar) to indicate that the assembly is out of date.

To set the option, click Tools > Options > System Options > Assemblies. Under
Large Assembly Mode, select Do not rebuild when switching to assembly window.

As in previous releases, in the rebuild message, you can select to not be asked again
and click Yes to rebuild. Subsequently, whenever you switch back to an assembly, it
rebuilds automatically without asking, regardless of the assembly size. Now, with the
new option selected, this automatic rebuild is skipped for assemblies in Large Assembly
Mode.

SpeedPak Configurations

You can create and update SpeedPak configurations of subassemblies from within the
parent assembly. You can disable the SpeedPak graphics circle.

See SpeedPak on page 78.

Mass Properties in Assemblies

Center of Mass Point in Assemblies

You can add a Center of Mass (COM) point to an assembly.

The position of the COM point updates when the model's center of mass changes. For
example, the position of the COM point updates as you add, modify, delete, or suppress
components or add or delete assembly features. The COM point can be useful when you
are designing assemblies requiring balanced mass (for example, to avoid excessive
vibration).

You can mate to the COM points of an assembly's components in distance, coincident,
and concentric mates. You cannot mate to the COM point of the assembly itself.
Click **Center of Mass** (Reference Geometry toolbar) or **Insert > Reference Geometry > Center of Mass**.

In the graphics area, ![Center of Mass](image) appears at the center of mass of the model. In the FeatureManager design tree, **Center of Mass** appears just below **Origin**.

If you add COM points in component files, the points appear in the parent assembly:

![Subassembly](image)

![Part](image)

For example, in this assembly, ![Center of Mass](image) indicates the center of mass of the assembly, and ![Center of Mass](image) indicates the centers of mass of three component parts:

![Assembly](image)

For more information about COM points, see **Point at the Center of Mass** on page 179 and **Reference Center of Mass in Drawings** on page 106.

**Custom Inertia Properties in Assemblies**

You can override moments of inertia properties for an assembly or its components.

Adding custom inertia properties to a component can help you visualize the component's effect on the overall inertia and mass of the structure. For example, if you have simplified models of purchased components, you can manually add accurate moment of inertia information to these components so that the entire mass of the assembly is correctly represented.

1. In the FeatureManager design tree, select the top-level assembly or a component.
2. Click **Mass Properties** (Tools toolbar) or **Tools > Mass Properties**.
3. In the Mass Properties dialog box, click **Override Mass Properties**.
4. In the Override Mass Properties dialog box, select **Override moments of inertia** and then select options and enter values.

**Mates in Mirrored Subassemblies**

When you create an opposite-hand version while mirroring a subassembly, all the standard mates in the subassembly are mirrored as well. Previously, standard mates within the subassembly that mated to the default planes or origin of the subassembly were not created.

**Replacing Components**

When using **Replace Component**, you can replace a component with another that has the same name and type but comes from a different folder.

**Selecting Subassemblies in the Graphics Area**

When you select a subassembly by right-clicking in the graphics area and choosing **Select Subassembly**, the context toolbar for the subassembly appears automatically. Previously, you had to do an additional left-click for the context toolbar to appear.

Additionally, the context toolbar now contains **Open Assembly** 📂, which, when clicked, opens the selected subassembly.

**Snapshots**

**Snapshots in Resolved Assemblies**

Snapshots are available in fully resolved assemblies and lightweight assemblies.

Previously, snapshots were available only in Large Design Review mode. Snapshots in resolved and lightweight assemblies work the same way as in Large Design Review mode, with capabilities such as recording the view orientation of the assembly, recording hide/show state of components, and adding comments. You can view snapshots in Large Design Review, resolved, and lightweight modes, regardless of which mode they were created in.

If you view a snapshot in resolved or lightweight mode, the View Snapshots pop-up toolbar appears. Click **Exit Snapshot** on the pop-up toolbar to return to the display state that was active before you viewed the snapshot.

**Snapshots in Walk-throughs**

You can take snapshots in walk-throughs.

When you take a snapshot from within an active walk-through, the camera angle is recorded in addition to the view orientation of the assembly and hide/show state of components. When you activate a snapshot that was created inside a walk-through, the walk-through opens automatically.
Swept Cut Assembly Features

You can create profile swept cut features in assemblies. As with other assembly features, you can propagate swept cut features to the parts they affect.

You cannot create solid swept cut features in assemblies.

When creating a Swept Cut as an assembly feature:

- For Profile, the sketch you select must be in the top level of the assembly.
- For Path and Guide Curves, you can select the following:
  - Sketches or curves in the top level of the assembly.
  - Edges of components at any level of the assembly.

You can create patterns of swept cut assembly features. Linear, circular, table driven, and sketch driven patterns are supported.

Click Assembly Features (Assembly tab on the CommandManager) and click Swept Cut, or click Insert > Assembly Feature > Cut > Sweep.
Chapter 7
CircuitWorks

Available in SolidWorks Premium.

This chapter includes the following topics:

- **Importing and Exporting ECAD File Features**

**Importing and Exporting ECAD File Features**

You can import layers, traces, holes of any shape, filled areas, vias, and pads from ECAD® files into the CircuitWorks™ software. You can also build these features into a SolidWorks assembly from CircuitWorks.

Not all ECAD file types support all of these features, and you cannot export traces, filled areas, vias, or pads back into CircuitWorks from SolidWorks.

**Exploring Layers, Traces, Filled Areas, and Vias**

In this example, you explore some of the new CircuitWorks features for ECAD models with layers, traces, filled areas, and vias.

You perform the following tasks:

- Explore the PADS® model layers, traces, pads, vias, and filled areas.
- View layer properties.
- Examine the board thickness.
- Change via properties and filter vias.
- Build the model in SolidWorks.
- Export the model back to CircuitWorks.
- Explore conductive layer modeling options.

**Opening and Exploring the PADS File in CircuitWorks**

First, open the PADS ECAD file in the CircuitWorks software and explore layers, traces, vias, pads, and filled areas.

You must add in CircuitWorks to follow this example.
1. From SolidWorks, click **CircuitWorks > Open ECAD File** and browse to 
`install_dir\CircuitWorksFull\Examples\Pads\preview.asc`. 

2. In the CircuitWorks tree, expand **Filled Areas** and select the second filled area **HP83515280**. 
The selected filled area is displayed in the preview window. 

3. In the CircuitWorks tree, select **Pads**. 
The pads are displayed on the ECAD file preview. 
You can also view individual pads you select in the tree. 

4. In the CircuitWorks tree, select **Traces**. 
The traces are displayed on the ECAD file preview. You can also select individual traces in the tree.
5. Click the Preview tab, select **Bottom View** (Preview toolbar), and in the CircuitWorks tree, select **Traces** again.

6. Click **Top View** (Preview toolbar) and click the Tools tab.
7. In the CircuitWorks tree, select **Vias**.

The vias are displayed on the ECAD file preview.

**Viewing Layer Properties**
Next, you view the thickness and types of layers.

You can view properties of any entity in the CircuitWorks tree by right-clicking the entity and clicking **Properties**.

1. In the CircuitWorks tree, expand **Layers**.
   The listed layers are distinguished by their dielectric or conductor property.

   The layers of the circuit board are stacked, back-to-back, starting with the first layer at the bottom of the board. The distance from the first layer to the last layer determines the board thickness. The layers can have different heights.

2. Right-click a conductor layer and click **Properties**.
   Properties including the following are displayed:

   **Start Height**  Specifies the height of the bottom of the layer relative to the bottom of the board.

   **End Height**  Specifies the height of the top of the layer relative to the bottom of the board.

   The end height of one layer is the same as the start height of the next layer.

   **Thickness**  Specifies the thickness of the layer.
3. Select other layers and view the properties.
4. In the CircuitWorks tree, click **Board Outlines**.
   
   Board Properties appears. The board thickness, **0.7870** mm, is the sum of the layer thicknesses.

**Editing Via Properties and Filtering Vias**

Next, you view and edit the position and diameter of a via, filter a via, and build the model in SolidWorks.

1. In the CircuitWorks tree, expand and select **Vias**.
   
   There are 37 vias on the board. There are three vias through the **U2** component of the board.

2. Right-click the first **STANDARDVIA_EXAMPLE** via and click **Properties**.
   
   The Via Properties pane appears.

3. For **Via Diameter**, enter **1.0** click ✔.

4. Repeat steps 2 and 3 for the other two **STANDARDVIA_EXAMPLE** vias.
5. On the Filter command menu of the Tools tab, click **Vias**.
   The Via Filters pane appears.

6. Select **Larger than**, and enter **0.99**.
   The three vias with a via diameter of 1.0 mm are filtered out. The filtered vias appear suppressed in the CircuitWorks tree.

**Building the Model in SolidWorks**

Next, you build the model in the SolidWorks application and see how the features are exported.

Close any models you have open in the SolidWorks application before you proceed.

1. In CircuitWorks, click **SolidWorks > Build Model** (Tools tab) and click **Build** in the CircuitWorks dialog box.
When the SolidWorks model appears, the traces, layers, vias, pads, holes, and filled areas are included in the SolidWorks FeatureManager design tree.

2. In the FeatureManager design tree, expand the `<previewpcb>` component and examine ECAD file features such as conductive and dielectric layers, holes, keep-outs, and vias in the SolidWorks model.
   a) Rotate the model.
   b) Select the third conductive layer in the rotated model.
c) Select the first dielectric layer.

d) Select **PTH**, the plated holes.
e) Select the vias.

f) Zoom in on the location of the filtered vias, which do not appear in the model.

3. In the SolidWorks application, save the model as My_previewpcb.sldasm.

4. In the SolidWorks application, click **CircuitWorks > Export to CircuitWorks**.

   The exported ECAD model does not include vias, filled areas, or pads, since CircuitWorks does not export these features.

5. In the SolidWorks application, close the model.

**Building Only Top and Bottom Conductive Layers**

You can set up CircuitWorks to model only the top and bottom conductive layers in SolidWorks to save build time.

To model only the top and bottom conductive layers when building in SolidWorks:

1. In SolidWorks, click **CircuitWorks > CircuitWorks Options**.
2. In the dialog box, click **SolidWorks Import**, and for **Conductive layer modeling**, select **Only top and bottom layers (faster)**.
3. Click **OK**.
Building the PADS File Again
Next, build the PADS file to see that only the top and bottom layers appear in the tree.

1. In CircuitWorks, select `previewpcb.asc`, the original PADS ECAD file.
2. In CircuitWorks, click ** SolidWorks > Build Model (Tools tab)** and, in the dialog box, click **Build**.
3. Click **Yes** when prompted to overwrite the model component.
4. In the FeatureManager design tree, expand the `previewpcb<1>` component.
   Only the two outer conductive layers are listed.
5. Close the SolidWorks model without saving it.
6. Close the CircuitWorks model without saving it.
This chapter includes the following topics:

- **Design Tables**
- **Managing Configuration Data**
- **SpeedPak**
- **Transferring Custom Properties When Inserting Configured Parts**

## Design Tables

### Configuring Materials in a Design Table

A design table parameter is available for configuring materials. The column header uses this syntax:

<table>
<thead>
<tr>
<th>For a part:</th>
<th>$LIBRARY: MATERIAL@part_name</th>
</tr>
</thead>
<tbody>
<tr>
<td>For a body in a multibody part:</td>
<td>$LIBRARY: MATERIAL@body_name@part_name</td>
</tr>
</tbody>
</table>

\$LIBRARY is the library name found in the top level of the tree in the Material dialog box. Examples: **SolidWorks Materials, SolidWorks DIN Materials, Custom Materials**.

MATERIAL is the name of the material as defined in the Material dialog box. Examples: **Plain Carbon Steel, AISI 304, 1060 Alloy**.

**To enter a material, do one of the following:**

- Manually type the information.
- Click in a cell and select from a drop-down list of material Favorites.

If a cell is left blank, it inherits the current material at the time the configuration is created.

Example:
Data Validation in Design Tables

Data validation has been incorporated into design tables. For certain parameters, when you select a cell in the design table, you can choose a value from a drop-down list of valid selections.

If you type an invalid value, an error message appears and tells you to enter a valid value (which you can select from the drop-down list).

Examples:

For suppression state of features ($STATE@feature_name), the values on the drop-down list are:

- SUPPRESSED
- UNSUPPRESSED
- S
- U

For fixed or floating position ($FIXED@component_name) the values on the drop-down list are:

- YES
- NO
- Y
- N

Simplified Selection for Display States and Configurations

In a design table, to access the drop-down list of existing display states or component configurations, click in a table body cell for parameters $DISPLAYSTATE or $CONFIGURATION@component<instance>. Previously, you had to right-click.

Managing Configuration Data

For part and assembly models containing configurations, new options help you to manage the size of files and the time needed to save them. You can specify and identify which
configurations to always keep up to date. You can purge cached configuration data every time you save the model.

As in previous releases:

If a configuration has never been activated (such as one defined in a design table), only essential defining data about the configuration is carried in the model. When you activate a configuration for the first time, the full definition of the configuration’s model data is generated. This full data set is updated and saved every time you save the document. By default, once the full data set is generated, it remains available every time you open the model. Having this full data set readily available for a configuration can save a significant amount of time when switching to that configuration from another. However, for each configuration that you activate, the file size of the model increases, as does the time required to rebuild and save the file.

New in this release:

- In the ConfigurationManager:
  - A checkmark ✔️ indicates a configuration for which a full up-to-date data set exists.
  - A dash – indicates a configuration for which a full data set is out of date or does not exist.

- You can flag one or more configurations with the Rebuild/Save mark 🔖 to generate full data sets for them without having to activate each configuration individually. This capability can be useful when you want data generated for many configurations at once. These full data sets are rebuilt and saved every time you save the document.

- You can purge the full data sets for specific configurations or all configurations (except the active one), either manually or automatically, to reduce the file size and the save time. Only the essential defining data remains.

In SolidWorks 2013, a full data set must exist for each configuration that you want to be available in SolidWorks 2012 Service Pack 5. See Previous Release Interoperability on page 34.

### Generating Configuration Data

To generate full data sets for one or more configurations without activating each configuration individually, do one of the following:

- In the ConfigurationManager, right-click one or more configurations and click Add Rebuild/Save Mark.

- At the top of the ConfigurationManager or FeatureManager design tree, right-click the model name, click Rebuild/Save Mark, and click one of the following:

<table>
<thead>
<tr>
<th>Add Mark for This Configuration</th>
<th>Marks the active configuration to have its full data set generated the next time you save the document. Subsequently, the data is rebuilt and saved every time you save the document.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Mark for All Configurations</td>
<td>Marks all configurations to have full data sets generated the next time you save the document. Subsequently, the data is rebuilt and saved every time you save the document.</td>
</tr>
</tbody>
</table>
**Add Mark for Specified Configurations**  
Opens the Rebuild and Save Settings dialog box, where you select configurations to mark to have full data sets generated the next time you save the document. Subsequently, the data is rebuilt and saved every time you save the document.

Also, removes the Rebuild/Save mark 📘 from all other configurations, and changes their icons to ✔️ or ⋯ (depending on the current state of their configuration data).

**Remove Mark and Purge Data for All Configurations**  
Removes the Rebuild/Save mark 📘 from all configurations including the active configuration, and purges the data for all configurations except the active one.

The following icons appear beside the configurations in the ConfigurationManager:

<table>
<thead>
<tr>
<th>Active Configuration</th>
<th>Inactive Configurations</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✔️</td>
<td>✔️</td>
<td>Indicates a configuration for which a full up-to-date data set exists.</td>
</tr>
<tr>
<td>📘</td>
<td>📘</td>
<td><strong>Rebuild/Save Mark.</strong> Indicates a configuration that will have its full data set generated the next time you save the document. Subsequently, the data is rebuilt and saved every time you save the document. To unmark a configuration, right-click it and select <strong>Remove Rebuild/Save Mark.</strong> Its icon changes to ✔️ or ⋯ (depending on the current state of its configuration data).</td>
</tr>
<tr>
<td>⋯</td>
<td>⋯</td>
<td>Indicates a configuration for which a full data set is out of date or does not exist.</td>
</tr>
</tbody>
</table>
Purging Configuration Data

To reduce the size of files and the time needed to save them, you can purge the cached configuration data of inactive configurations.

To manually purge the data:

- At the top of the ConfigurationManager or FeatureManager design tree, right-click the model name, click Rebuild/Save Mark, and click Remove Mark and Purge Data for All Configurations.

To automatically purge the data every time you save the document:

- Click Tools > Options > System Options > Performance and select Purge cached configuration data.

Every time you save the document:

- If the purge option is selected:
  - Data is purged for all inactive configurations flagged ✔️ or ‍️.
  - Data is saved only for the active configuration (✔️ or ‍️) and inactive configurations marked ‍️.

- If the purge option is not selected:
  - Data is rebuilt and saved for all configurations flagged ✔️, ✔️, ‍️, or ‍️.
  - Data is purged for all configurations flagged ‍️.

SpeedPak

You can create and update SpeedPak configurations of subassemblies from within the parent assembly. You can disable the SpeedPak graphics circle.

Disabling the SpeedPak Graphics Circle ✗

You can disable the SpeedPak graphics circle so that the geometry in the region surrounding the pointer remains visible even if it is not selectable.

When the graphics circle is on, only selectable geometry is visible in the region surrounding the pointer.

When the graphics circle is off, all geometry in the region surrounding the pointer remains visible. If the pointer is over a SpeedPak entity that is not selectable, the pointer changes to 📐.

To enable or disable the SpeedPak graphics circle, do one of the following:

- Click Tools > Options > Display/Selection and select or clear Display SpeedPak graphics circle.
- Press Alt + S.

For an example of disabling the SpeedPak graphics circle, see the example under SpeedPak Creation from Parent Assembly on page 79.
**SpeedPak Creation from Parent Assembly**

You can create SpeedPak configurations for subassemblies from within a parent assembly. You can choose to include only graphics, or include mated faces, edges, and points as resolved geometry.

In an assembly, select one or more subassemblies. Right-click and click **SpeedPak Options**, and then click one of the following:

<table>
<thead>
<tr>
<th><strong>Create Mated SpeedPak</strong></th>
<th>Includes mated faces, edges, and points as resolved geometry, which allows you to create other mates to those entities. Entities included as resolved geometry include entities of the subassembly that mate to other components in the open parent assembly or to the open parent assembly itself.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Create Graphics SpeedPak</strong></td>
<td>Lets you see graphics for the subassembly but does not include any resolved geometry, which yields more performance improvement.</td>
</tr>
</tbody>
</table>

A SpeedPak configuration is created for the active configuration of the subassembly. If the subassembly is a top-level subassembly, then the SpeedPak configuration becomes the active configuration used by the parent assembly.

Improvements in assembly performance are most noticeable in very large and complex assemblies. Because the assembly used in the following example is small and simple, performance improvements are not noticeable.

**Creating a Graphics-Only SpeedPak**

You can create a graphics-only SpeedPak for a subassembly directly from the parent assembly.

1. Open `install_dir\samples\whatsnew\configurations\overender.sldasm`.

79
2. In the FeatureManager design tree, right-click subassembly lifter and click SpeedPak Options > Create Graphic SpeedPak.
   A SpeedPak configuration is created for the active configuration of lifter. In the FeatureManager design tree, the icon indicates that the SpeedPak configuration is being used in the assembly.

3. Right-click lifter and click Isolate.
   In the graphics area, all components except lifter are hidden.

4. Move the pointer over the subassembly.
   Note that nothing is visible in the region around the pointer, indicating that there are no selectable entities.

5. On the Isolate popup toolbar, click Exit Isolate.
Creating a Mated SpeedPak
You can create a SpeedPak that includes mated faces, edges, and points as resolved geometry directly from the parent assembly.

1. In the FeatureManager design tree, right-click subassembly slider and click SpeedPak Options > Create Mated SpeedPak.
   A SpeedPak configuration is created for the active configuration of slider. In the FeatureManager design tree, the icon indicates that the SpeedPak configuration is being used in the assembly.

2. Right-click slider and click Isolate.
   In the graphics area, all components except slider are hidden.

3. Move the pointer over the subassembly.
   Note that several entities are visible in the region around the pointer. These entities are mated to other components in the parent assembly or to the parent assembly itself, and are selectable for creating other mates.

Disabling the SpeedPak Graphics Circle
You can disable the SpeedPak graphics circle so that the geometry in the region surrounding the pointer remains visible even if it is not selectable.

1. Press **Alt + S**.
   Now when you move the pointer over a SpeedPak entity that is not selectable, the pointer changes to ☐, but the entity remains visible.

2. Press **Alt + S** again.
   The SpeedPak graphics circle returns. In the region around the pointer, entities that are not selectable are not visible.

You can also click **Tools > Options > System Options > Display/Selection** and select or clear **Display SpeedPak graphics circle** to turn the graphics circle on or off.

**SpeedPak PropertyManager**
In the SpeedPak PropertyManager, under **Enable Quick Include**, the **Faces to Include** slider has been removed.

The **Faces to Include** slider is no longer needed because of improvements in performance relative to previous releases for creating, editing, and opening SpeedPaks that include many bodies.
Updating Subassembly SpeedPaks from Parent Assembly

You can update SpeedPak subassemblies from within the parent assembly. You can select one or more SpeedPak subassemblies and update them by right-clicking and selecting **Update SpeedPak**.

You can update all SpeedPak subassemblies by clicking **Update SpeedPak** (Assemblies toolbar), or right-clicking the top-level assembly in the FeatureManager design tree and clicking **Update All SpeedPaks**.

Updating SpeedPak subassemblies might take a significant amount of time depending on the number and complexity of out-of-date SpeedPaks in the parent assembly.

Transferring Custom Properties When Inserting Configured Parts

Improvements have been made to transferring of custom properties when you insert a configured part into another part.

See **Transferring Custom Properties**.
Available in SolidWorks Professional and SolidWorks Premium.

This chapter includes the following topics:

- **Converting Simple Drilled Holes to Milled Pockets**
- **Multibody Parts**
- **Turned Parts**
- **User Interface**
- **Volume Features**

### Converting Simple Drilled Holes to Milled Pockets

You can convert simple holes to circular milled pockets, and you can revert the circular pockets back to holes. When you switch circular milled pockets to drilled holes, you must define a drill diameter in the machining template that matches the hole diameter, or that is at most 10 percent smaller than the circular pocket diameter.

You cannot convert holes that require tapping or counterbored holes.

For simple drilled holes, in the CostingManager, right-click the feature, and click **Change to Mill**. This converts the drilling operation to a milling operation. You can also drag the simple hole feature to the **Mill Operations** folder.

For circular milled pockets that are converted from drilled holes, in the CostingManager, right-click the feature, and click **Change to Drill**. This converts the milling operation to a drilling operation. You can also drag the circular milled pocket feature to the **Hole Operations** folder.

### Multibody Parts

With SolidWorks Costing®, you can calculate how much it costs to manufacture multibody parts.

When you apply Costing to multibody parts, you can select a main template that controls Costing operations at the part level. The main template references two other templates, one for sheet metal bodies, and one for machined bodies. The software automatically recognizes sheet metal bodies. For machined or custom bodies, you can specify the type of body in the Costing Task Pane.

The Costing tool does not compute the cost of custom bodies. You enter the cost of a custom body in the Costing Task Pane.
You can also switch from the multibody Costing environment to a single-body environment to improve performance.

You must assign a custom cost to weldment bodies in a multibody part.

**Examining the Costing Templates for Multibody Parts**

When a multibody part includes sheet metal and machined bodies, the Costing tool references separate templates for each type of body. In this procedure, you view the templates for a multibody part in the Costing Template Editor.

1. Open `install_dir\samples\whatsnew\costing\multibody.sldprt`.
   A multibody part appears. The part includes machined, sheet metal, and turned bodies.

2. Click **Costing** (Tools toolbar) or **Tools > Costing**.

3. In the Costing Task Pane:
   a) Under **Costing Templates**, in **Main template**, select `multibodytemplate_default(metric)`.
      The main template defines operations at the part level.
      When you select the main default metric template, the default metric templates for sheet metal and machined bodies are assigned to the main template in the Costing Template Editor. The message area of the Costing Task Pane appears green, indicating you can start the cost estimation.
   b) Click **Launch Template Editor**.
      On the General node of the Costing Template Editor, you can view the **Sheet Metal Template** and **Machining Template** that are associated with the main template.

4. Next to **Sheet Metal Template**, click **View**.
   A Sheet Metal tab appears, displaying the costing data associated with sheet metal parts.

   You can repeat this step for the machining template.

5. Close the Costing Template Editor.
   Keep this part and the Costing Task Pane open for the next procedure.
Evaluating the Cost of a Multibody Part

In this procedure, you run Costing to determine the cost of manufacturing a multibody part.

1. In the Costing Task Pane, examine the Body List.
   There are four bodies in the list. You can view these bodies in the FeatureManager design tree. The type of body determines the costing template that is referenced in the cost estimation. Costing automatically recognizes sheet metal bodies. You must assign the type of body for the other types of bodies in the part.

2. Select the body type for each body on the part:
   a) In the Costing Task Pane, under Body List, select Cut-Extrude4.
      The selected body is highlighted in the graphics area.

   For Type of body, Sheet Metal is automatically selected. The body materials are also assigned.

   b) In the Costing Task Pane, under Body List, select CBORE for M6 Hex Head Bolt2, and for Type of body, select Machined.
      The materials are already assigned.

   c) In the Costing Task Pane, under Body List, select Chamfer2, and for Type of body, select Machined.
      The materials are already assigned.

   d) Enter the cost of the Actual Cost Body directly:
      1. In the Costing Task Pane, under Body List, select Actual Cost Body.
      2. For Type of body, select Custom, and for Custom Cost, type 10.
      The Costing tool does not compute the cost of a custom body. Consequently, you enter the cost of the body, but not the materials.

After you assign the type of body to each body in the part, the green message area indicates you can start the cost estimation.

To exclude the cost of one or more bodies before computing the cost, select the bodies and click Exclude.

3. Click Begin Cost Estimation.
   The CostingManager displays the bodies with their types and materials in their appropriate folders. If you exclude a body from the costing computation, it appears in the No Cost Assigned folder. Excluded bodies are hidden in graphics area. The
**Setup** folder has the setup costs for the part level, not the body level. The **Custom Operations** folder is at the part level.

The setup cost is derived from the setup time you specify in the template.

4. In the CostingManager, expand **Sheet Metal Bodies**.
   The sheet metal part, **Cut-Extrude4** is listed. When you expand **Cut-Extrude4**, you can see the estimated cost of the body, and the template applied to the cost estimation.

5. Keep this part and the Costing Task Pane open for the next procedure.

### Evaluating the Cost of One Body in a Multibody Part

When applying Costing to multibody parts, you can perform a cost estimate on one body, rather than the entire part.

1. In the CostingManager, double-click the **Chamfer2** body.

All other bodies are hidden, and the CostingManager and the Task Pane display only the chamfer body costing information.

2. In the CostingManager, click **Back to Multibody Environment**.
   The multibody part appears in the graphics area and all bodies appear in the CostingManager.

3. Close the part:
   a) Close the Costing Task Pane.
   b) Click **File > Save As**.
   c) In the Save As dialog box, click **Save without Costing data** and click **Save**.

### Turned Parts

With SolidWorks Costing, you can calculate how much it costs to manufacture turned parts.

### Evaluating the Cost of a Turned Part

Cylindrical parts require turning for manufacture. In this procedure, you run Costing to determine the cost of manufacturing a turned part.

1. Open `install_dir\samples\whatsnew\costing\turned.sldprt`.
A cylindrical part appears.

2. Click **Costing** (Tools toolbar) or **Tools > Costing**.
3. In the Costing Task Pane:
   a) Under **Machining Template**, select `machiningtemplate_default(englishstandard)`.
   b) Under **Material**, for **Class** select **Steel**, and for **Name** select **Plain Carbon Steel**.
4. Under **Stock Body**, in **Type**, select **Cylinder**.
5. Under **Estimated Cost Per Part**, click **Click to Update**.

The Costing tool estimates the manufacturing cost using the material information in the part.

The Costing Task Pane displays the **Estimated Cost Per Part**.

The CostingManager in the FeatureManager design tree displays the recognized operations required to manufacture the part.

<table>
<thead>
<tr>
<th>Operation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Setup</strong></td>
<td>There are four setup operations for this part. Two of the operations are required for all turned parts. When manufacturing a turned part, one end of the part is in the chuck, while the other end is machined. The portion of the part inside the chuck is not machinable until the part is flipped.</td>
</tr>
<tr>
<td><strong>Setup Operation 1</strong></td>
<td>Contains the setup operation to manufacture <strong>Slot 1</strong>.</td>
</tr>
<tr>
<td><strong>Setup Operation 2</strong></td>
<td>Contains the setup operation to manufacture <strong>Hole 1</strong>.</td>
</tr>
<tr>
<td>Operation</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Setup Operation 3</strong></td>
<td>Contains the setup operations needed to manufacture the part:</td>
</tr>
<tr>
<td>OD Groove 1</td>
<td>Outer diameter groove. Material is removed from the outside faces. The ratio of the length (L) of the material to remove to the depth (D) of the material to remove is L:D or L/D.</td>
</tr>
<tr>
<td>ID Groove 1</td>
<td>Inner diameter groove. Material is removed from the outside faces. The ratio of the length (L) of the material to remove to the depth (D) of the material to remove is L:D or L/D.</td>
</tr>
<tr>
<td>OD Turn 2</td>
<td>Outer diameter turn. Material is removed from outside faces for one side of the part.</td>
</tr>
<tr>
<td><strong>Setup Operation 4</strong></td>
<td>Contains additional setup operations required to manufacture the part:</td>
</tr>
<tr>
<td>ID Turn 1</td>
<td>Inner diameter turn. Material is removed from outside faces.</td>
</tr>
<tr>
<td>OD Turn 1</td>
<td>Outer diameter turn. Material is removed from outside faces for the other side of the part.</td>
</tr>
<tr>
<td><strong>Mill Operations</strong></td>
<td></td>
</tr>
<tr>
<td>Slot 1</td>
<td>Material is removed from the face.</td>
</tr>
<tr>
<td>Operation</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-------------------------------------------</td>
</tr>
<tr>
<td>Turn Operations</td>
<td></td>
</tr>
<tr>
<td>ID Groove 1</td>
<td></td>
</tr>
<tr>
<td>OD Groove 1</td>
<td></td>
</tr>
<tr>
<td>OD Turn 1</td>
<td></td>
</tr>
<tr>
<td>ID Turn 1</td>
<td></td>
</tr>
<tr>
<td>OD Turn 2</td>
<td></td>
</tr>
<tr>
<td>Hole Operations</td>
<td></td>
</tr>
<tr>
<td>Hole 1</td>
<td>Material is drilled from the face and then tapped.</td>
</tr>
</tbody>
</table>

6. Close the part:
   a) Close the Costing Task Pane.
   b) Click **File > Save As**.
   c) In the Save As dialog box, click **Save without Costing data** and click **Save**.

**User Interface**

**Costing Toolbar Button and Menu Command**

You can run the Costing tool for sheet metal or machined parts with the same command. You are no longer required to choose between the sheet metal or machining Costing tools.

Click **Costing** (Tools toolbar) or **Tools > Costing**.

**CostingManager**

You can drag and drop items into other valid locations in the CostingManager. For example, you can drag a hole pattern to the **No Cost Assigned** folder. You can also drag and drop operations between **Setup** folders.

You can also multiselect (**Ctrl + select** or **Shift + select**) items in the CostingManager to apply a common option to the selected items. For example, you can multiselect two setup operations and apply the same cost override value to them.

You can dissolve library features on sheet metal bodies. If you need to manufacture a library feature with a laser or water jet machine, you can dissolve the library feature so the Costing tool can calculate the cost based on the length to be cut, not on a per-stroke basis. In the FeatureManager design tree, right-click the library feature and click **Dissolve Library Feature**. The library feature is converted to cut paths for the Costing tool to evaluate.
You can move items between various Setup folders. This is helpful if you have machines that can make parts with fewer setups. For example, when you start Costing for a machined part, the Costing tool might create two setup operations because there are machining features on two side faces of the part. However, you may have a machine that can manufacture both features without changing the setup. Therefore, you can move the features from Setup Operation 2 to Setup Operation 1 to reduce the cost by eliminating Setup Operation 2.

You can use the keyboard to navigate the CostingManager.

When you right-click a folder in the CostingManager, you can Expand All or Collapse All.

**Costing Templates**

On the Machine node of the Costing Template Editor for a machining template, you can specify drill, mill, and turn machine types.

On the General node of the Costing Template Editor for a machining template, you can set values that contribute to the cost calculation, including the Setup time, the amount of time it takes to set up turning for the part.

**Volume Features**

When you apply the Costing tool to a part that is machined from a block or cylinder stock type, the software calculates the difference between the stock material and the actual part, excluding machined features such as holes and pocket features. This difference creates volume features, which contribute to the cost of the part as a result of the required milling operations.

Volume features account for the cost of tooling a part from a block or cylinder. The cost of the machined part includes the following:

- The cost of the stock body
- The cost of tooling a volume of material from the stock body

The volume of material removed from the stock body to produce the part defines the volume features.
The Costing tool computes the contribution of the volume features to the total cost of machining the part.

After estimating the cost, the Volume features appear in the Costing Manager in the Mill Operations folder. You can change the tool used to create a volume feature to adjust the cost. You can right-click a Volume feature and change the tool to modify the cost calculation. You might also have a volume feature appear in the No Cost Assigned folder.

**Calculating the Cost of a Volume Feature**

In this example, you calculate the cost of a volume feature.

1. Open `install_dir\samples\whatsnew\costing\volume.sldprt`.

2. Click Costing (Tools toolbar) or Tools > Costing.

3. In the Costing Task Pane, under Machining Template, select `machiningtemplate_default(metric)`.

4. For Class, select Steel, and for Name, select Plain Carbon Steel. The Costing tool estimates the manufacturing cost.

5. In the Costing Manager, expand Mill Operations.

6. Expand the Volume 1 feature.

7. Right-click Flat End Mill and select Flat End Mill (Mill) > 15.00 mm. The tool change increases the cost of the volume feature and the part cost estimate is updated in the Costing Task Pane.

8. Close the part:
   a) Close the Costing Task Pane.
   b) Click File > Save As.
   c) In the Save As dialog box, click Save without Costing data and click Save.
10
Drawings and Detailing

This chapter includes the following topics:

- Balloons
- Dimensions
- Drawing Views
- Layers
- Other Annotations
- Tables

Balloons

**Auto Balloon Functionality Works on Existing Balloons**

You can use auto balloon functions in drawing views with existing balloons. A BOM is still required, but the existing balloons do not need to be created with auto balloon.

**Updating Balloons Created with the Auto Balloon Annotation**

To update existing balloons with Auto Balloon:

1. In a drawing view that contains a BOM and balloons that have Item Number as their balloon text, click Insert > Annotations > Auto Balloon. This example shows the inserted auto balloons.
2. In the Auto Balloon PropertyManager, in **Edit Balloons**:
   a) Select **Replace balloons** to delete all balloons that have **Item Number** as their balloon text and insert the balloons as specified by the Auto Balloon PropertyManager.
   b) Select **Resequence existing balloons** to modify the ordering of the existing balloons.

3. If you select **Replace balloons**, you can specify any of the auto balloon parameters. In this example, in **Balloon Settings**, **Style** is **none** and **Balloon text** is **File Name**.

4. If you select **Resequence existing balloons**, you can only modify the parameters in **Item Numbers**, including **Start at** and **Increment**, and you can specify to **Follow assembly order** or **Order sequentially**. In this example, **Start at** is **1** and **Increment** is **1**, and **Order sequentially** is selected.
5. Click □.

To order balloons sequentially, you must have a bill of materials in the drawing.

**Sequentially Reordering Balloons Created with the Balloon Annotation**

To sequentially reorder balloons that were created with the balloon annotation:

1. In a drawing view that contains balloons created with balloon, click **Insert > Annotations > Auto Balloon**. This example contains 4 balloons with **Item Numbers** and 2 balloons with **Part Number (BOM)**.

2. In the Auto Balloon PropertyManager, in **Edit Balloons**:
• Select **Replace balloons** to delete all balloons that have **Item Number** as their balloon text and insert the balloons as specified by the Auto Balloon PropertyManager.

• Select **Resequence existing balloons** to modify the ordering of the existing balloons.

3. If you select **Replace balloons**, you can specify any of the auto balloon parameters. In this example, in **Balloon Settings**, **Style** is **Square** and **Balloon text** is **Quantity**. Balloons with **Item Number** are removed, balloons with other **Balloon text** remain, and all auto balloons are inserted.

4. If you select **Resequence existing balloons**, you can only modify the parameters in **Item Numbers**, including **Start at** and **Increment**, and you can specify to **Follow assembly order** or **Order sequentially**. In this example, **Start at** is **1** and **Increment** is **1**.

5. Click ✓.

**To order balloons sequentially, you must have a bill of materials in the drawing.**
Auto Balloon Improvements

Auto balloon improvements provide better arrow and balloon placement requiring less editing afterward.

Improvements in auto balloon placement include:

- For multiple instances of the same part, balloons point to the closest instance.
- When **Edges** is selected in **Balloon Layouts** of the Auto Balloon PropertyManager:
  - Arrows no longer point to vertices.
  - Arrows no longer point to far side edges of a model unless there is no other solution.
- When **Faces** is selected in **Balloon Layouts** of the Auto Balloon PropertyManager:
  - Attachment points no longer appear on the most foreshortened surfaces.
  - Attachment points no longer appear near model edges, if possible.
  - Attachment points no longer appear on portions of a surface that are hidden by geometry, if possible.

Balloon Text Field Options

Two new options, **Part Number (BOM)** and **File Name**, are now available in the **Balloon text** field when creating or editing balloons.

Inserting Balloons with Part Numbers

To insert balloons with part numbers from the bill of materials:

1. In a drawing, click **Insert > Annotations > Balloon**.
   The Balloon PropertyManager appears.
2. In **Balloon Settings**, click **Balloon text** and click **Part Number (BOM)**.
3. Set the options.
4. Click in the graphics area to place the balloon.
5. Continue adding balloons and click ✓ when done.

To insert balloons with the file name, follow the same procedure and click **File Name** instead of **Part Number (BOM)** under **Balloon text**.
Dimensions

Add Dimensions to Baseline Dimensions
You can add new dimensions to baseline dimensions. You can auto arrange baseline dimensions using **Auto Arrange Dimensions** in the dimension palette.

Adding Dimensions to Existing Baseline Dimensions
To add new dimensions to an existing set of baseline dimensions:
1. Right-click on one of the existing baseline dimensions and click **Add To Baseline**.

   The cursor changes to and the **Baseline** tool activates.
2. Click new elements in the drawing view to add to the baseline dimensions.
   As you add new elements to the baseline, the set of baseline dimensions reorders to accommodate the additional dimensions.

   To specify spacing in baseline dimensions, use **Tools > Options**. On the Document Properties tab, click **Dimensions** and in **Offset distances**, set the spacing.

Auto Arranging Baseline Dimensions
To auto arrange baseline dimensions:
1. Select the baseline dimensions.
2. When the dimension palette rollover button appears, move the pointer over the button to view the dimension palette.
3. On the dimension palette, click **Auto Arrange Dimensions**.
Imported Tolerance and Precision Dimensions Parametric with Model

You can make imported dimension settings for precision of dimensions and tolerance values parametric with the model.

A change in precision in either the model or the drawing changes the precision in both places.

Linking Tolerance and Unit Precision with the Model

To link tolerance and unit precision in imported dimensions in a drawing with the model:

1. In the drawing, select the dimension.
2. In the Dimension PropertyManager, under Tolerance/Precision, select Link precisions with model.
3. Click ☑.

When you first select Link precisions with model in the PropertyManager, the precision in the model is used. Any future edits to the tolerance or unit precision in either the model or drawing change the precision in both locations.

Setting a Default to Link Tolerance and Unit Precision with Model

To link tolerance and unit precision with the model by default:

1. Click Tools > Options.
3. In Primary precision, select Link precisions with model to link the primary unit and tolerance precision.
4. In Dual precision, select Link precisions with model to link the secondary unit and tolerance precision.
5. Click OK.
**Improved Arrows on Radius Dimensions**

A new option is available that sets smart arrows direction to automatically coincide with the location of the dimension text.

<table>
<thead>
<tr>
<th>Previous Releases</th>
<th>SolidWorks 2013</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Previous Release" /></td>
<td><img src="image2.png" alt="SolidWorks 2013" /></td>
</tr>
</tbody>
</table>

- If the dimension text is outside the detailed arc, the arrow displays outside the arc and points to the center of the arc.
- If the dimension text is inside the detailed arc, the arrow displays inside the arc and points away from the center of the arc.

When possible, the arrow tip attaches to the arc. Extension arcs only appear if the arrow tip cannot be attached to the arc.

**Attaching Smart Arrows to Arcs**

To attach smart arrows to an arc and point away from the dimension text:

1. Click **Tools > Options**.
2. On the Document Properties tab, expand **Dimensions** and click **Radius**.
3. In **Arrow placement**, select **Smart arrows attach to arcs and point away from dimension**.
4. Click **OK**.
**Improved Control of Extension and Dimension Lines**

In linear and radial dimensions, you can separately break dimension and extension lines around other dimensional elements.

---

**Break Lines Not Selected**

---

**Break Lines Selected for Both Options**

---

In linear and radial dimensions, you can control which elements of a dimension break around other dimensional elements. On the Leaders tab of the respective PropertyManager, under **Break Lines**:

- Select **Break extension lines** to break extension lines around dimension lines and other extension lines.
- Select **Break dimension line** to break the dimension line around other dimension lines and other extension lines.

---

In **Tools > Options > Document Properties > Dimensions**, the **Break only around dimension arrows** option still limits breaks to be around dimension arrows only when you select either of the above options.
<table>
<thead>
<tr>
<th>Break Extension Lines Only</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Extension Lines" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Break Both Extension Lines and Dimension Lines</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image2" alt="Both Extension Lines and Dimension Lines" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Break Dimension Lines Only</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image3" alt="Dimension Lines Only" /></td>
</tr>
</tbody>
</table>
**Insert Dimensions with Tolerances**

When inserting model items, you can specifically import dimensions with tolerances from the model.

You can now insert only those dimensions with tolerances into a drawing.

- **All Dimensions:**

- **Only Toleranced Dimensions:**
Inserting Dimensions with Tolerances

To insert only dimensions with tolerances:

1. In a drawing, click Insert > Model Items.
2. In the Model Items PropertyManager, under Dimensions, clear Marked for drawing, and click Toleranced dimensions.
3. Set the options.
4. Click ✓.

Radius and Diameter ISO Leader Dimensions

Radius and diameter leader dimensions in all ISO and other international standards attach to the geometric dimensioning and tolerancing feature control frame instead of the dimension text.

Bent leaders align with the center of the feature control frame on the side of the arrow, including composite and multiple frame symbols.
Previously, bent leaders attached to the dimension text. For legacy purposes, existing dimensions remain as they were originally placed.

To update the dimensions to the new style:

1. Click **Tools > Options**.
2. On the Document Properties tab, click **Dimensions**.
3. Select **Apply updated rules**.
4. Click **OK**.

Once you apply the updated rules, **Apply updated rules** is no longer selectable and all existing dimensions on the drawing will adjust to the ISO-compliant display behavior.

**Radius, Diameter, Chamfer, and Hole Callout Bent Leader Improvements**

The shoulders of bent leader dimensions for radius, diameter, chamfer, and hole callout display in a consistent manner, aligning with the appropriate line of dimension text. Bends extend to meet the end of a line of text when the leader is on the side opposite to the callout justification.

**Bent Leader Dimensions and Alignment**

The shoulders of bent leaders for radius, diameter, chamfer, and hole callout display consistently, aligning with the appropriate line of dimension text.

- Left- and right-sided leaders set to **Top Justify** center to the top line of text in the dimension.
- Left- and right-sided leaders set to **Bottom Justify** center to the bottom line of text in the dimension.
- Left-sided leaders attached to **Left Justify** dimension text maintain a consistent gap between the shoulder and text.

To vertically align the bent leader shoulder to the appropriate line of text, click **Options > Document Properties > Dimensions**, and select **Apply updated rules**.
If you do not select this option, vertical alignment of the bent leader shoulders display as unchanged.

**Bent Leader Shoulders**

A new default option lets the shoulders of bent leader dimensions meet the end of the dimension text line. Previously, when an arrow was on the opposite side of the justification (left or right), the shoulder stopped at the closest point to the bend. This option extends the shoulder to meet the line of aligned text (top or bottom).

To set the default option, click **Options > Document Properties > Dimensions**, and in **Bent leaders** select **Extend to text**.

**Reference Center of Mass in Drawings**

Center of mass is a selectable entity in drawings, and you can reference it to create dimensions.

In a drawing, you can create reference dimensions between center of mass points and geometric entities, such as points and edges.

**Inserting a Center of Mass in a Drawing**

The part or assembly must include a center of mass.
To insert a center of mass:

1. In a drawing, click **Insert > Model Items**.
2. In the Model Items PropertyManager, under **Reference Geometry**, click **Center of Mass**.
3. Click ✔.

You can create dimensions between the center of mass points and geometric entities using any of the dimensioning methods.

To view the center of mass in a drawing, click **View > Center of mass**.

### Drawing Views

**Convert Drawing View to Sketch**

From the shortcut menu, you can convert a drawing view to sketch entities or a block of sketch entities.

In a drawing view, right-click and click **Convert View to Sketch**. In the Convert View to Sketch PropertyManager, you can:

- **Replace view with sketch**: Replaces the drawing view with equivalent 2D sketch entities.

Original drawing view

Equivalent 2D sketch entities
Replace view with block

Replaces the drawing view with equivalent 2D sketch entities that are grouped in a block.

Original drawing view

Block with equivalent 2D sketch entities
Insert as block

Creates a separate block comprised of equivalent 2D sketch entities that you can place anywhere in the drawing.

In this example, the block on the right is added to the drawing view, rather than replacing the drawing view on the left.

Multiple Exploded Views

Drawings can have more than one exploded view per configuration.

If an assembly or multibody part contains more than one exploded view, you can now include those exploded views in the drawing using a new drop-down selection within drawing view properties.

Including Multiple Exploded Views in a Drawing

To include more than one exploded view in a drawing:

1. Create the drawing of an assembly or multibody part that contains multiple exploded views.
2. In a drawing view, right-click and click Properties.
3. In Configuration information, select Show in exploded state.
4. Select an exploded view from the drop-down list.
5. Click OK.
6. Select a different drawing view, right-click and click Properties.
7. In Configuration information, select Show in exploded state.
8. Select a different exploded view from the drop-down list.
9. Click OK.

New Edge Types for Flat Pattern Views

In flat pattern drawing views, you can specify two new types of edges – Bend up, flat pattern and Bend down, flat pattern. Bend up, flat pattern uses the default of thin solid line and Bend down, flat pattern uses the default of thin dashed line.

New flat patterns use these new edge types.
To access or change the edge types, click **Tools > Options**. On the Document Properties tab, click **Line Font** and under **Type of edge**, click **Bend Up, Flat Pattern** or **Bend Down, Flat Pattern**.

## New Section Tool User Interface

Use the improved section view sketch mode in conjunction with the new section tool user interface to create both section views and aligned section views.

The new interface allows you to create section views, aligned section views, and half section views on a drawing. The single interface supports both ASME and ISO-based standards.

While in **Edit Sketch** mode for section views created in SolidWorks 2013, lines that are marked **For Construction** in a PropertyManager are considered jogs, and are ignored in the placed section view. This makes it easier to create section views in compliance with ASME, ISO, and other standards.

Section views created in SolidWorks 2012 and earlier versions maintain their previous look. If you need to create these ignored construction lines from section views created in previous versions of SolidWorks, you must recreate them in SolidWorks 2013. This ensures that drawings are not automatically changed without user intent.

### Inserting a Section or Half Section View

To insert a section or half section view, in a drawing, click **Section View** (Drawing toolbar) or **Insert > Drawing View > Section**.

In the Section View PropertyManager, click **Section** or **Half Section**.

**Section**

- Select the cutting line:

  - Vertical
  - Horizontal
You can use Tab to switch between Cutting Lines in Section or Half Section.

• After you select and place the cutting line in the drawing view, the Section View popup displays.

Use the Section View popup to add offsets to the section view.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Function</th>
<th>Additional Steps</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="1" alt="2" /></td>
<td><strong>Add Arc Offset</strong></td>
<td>Select first point of arc on cutting line, then select second point of arc.</td>
</tr>
<tr>
<td><img src="1" alt="2" /></td>
<td><strong>Add Single Offset</strong></td>
<td>Select first point of offset on cutting line, then select second point of offset.</td>
</tr>
<tr>
<td><img src="1" alt="2" /></td>
<td><strong>Add Notch Offset</strong></td>
<td>Select first point of notch on cutting line, select second point on cutting line for width of notch, then select third point for depth of notch.</td>
</tr>
<tr>
<td><img src="2" alt="3" /></td>
<td><strong>Step Back</strong></td>
<td></td>
</tr>
<tr>
<td><img src="2" alt="1" /></td>
<td><strong>OK (Add the view)</strong></td>
<td></td>
</tr>
<tr>
<td><img src="2" alt="1" /></td>
<td><strong>Cancel (Cancel the view)</strong></td>
<td></td>
</tr>
</tbody>
</table>

If you select Auto-start section view in the Section View PropertyManager, the Section View popup does not appear, allowing you to immediately preview and place the section view in the drawing.

• You can add multiple offsets to a section view. Notch offset may be applied to any cutting line segment. Single offset and Arc offset may only be applied to one of the two outer cutting line segments.

• The cutting line inferences to the drawing's geometry.

**Half Section**
• Select the type of half section:

<table>
<thead>
<tr>
<th>Topside Right</th>
<th>Topside Left</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bottomside Right</td>
<td>Bottomside Left</td>
</tr>
<tr>
<td>Leftside Down</td>
<td>Rightside Down</td>
</tr>
<tr>
<td>Leftside Up</td>
<td>Rightside Up</td>
</tr>
</tbody>
</table>

• The vertex inferences to the drawing’s geometry.

**Inserting a Vertical Section View**

**To insert a vertical section view:**

1. Open `install_dir\samples\whatsnew\drawings\sectionview1.slddrw`.
2. Click **Section View** (Drawing toolbar) or **Insert > Drawing View > Section**.
3. In the Section View PropertyManager, click **Section**.
4. In **Cutting Line**, select **Auto-start section view** if not already selected.
5. Click **Vertical** and move the cutting line to the location as shown and click.
If the Section View dialog box appears, click **OK**.

6. Drag the preview to the right and click to place the section view.

---

**Inserting an Auxiliary Section View**

**To insert an auxiliary section view:**

1. Open `install_dir\samples\whatsnew\drawings\sectionview2.slddrw`.
2. Click **Section View** (Drawing toolbar) or **Insert > Drawing View > Section**.
3. In the Section View Property Manager, click **Section**.
4. In **Cutting Line**, select **Auto-start section view** if not already selected.
5. Click **Auxiliary** and move the cutting line and pointer to the location as shown and click.
6. Move the pointer to the location as shown and click to set the angle of the cutting line.
If the Section View dialog box appears, click OK.

7. Drag the preview to the left and click to place the section view.

Inserting a Section View with an Arc Offset

To insert a section view with an arc offset:

1. Open install_dir\samples\whatsnew\drawings\sectionview3.slddrw.
2. Click Section View (Drawing toolbar) or Insert > Drawing View > Section.
3. In the Section View PropertyManager, click Section.
4. In Cutting Line, clear Auto-start section view. This eliminates the automatic insertion of the section view and lets you add additional offsets to the view.
5. Click Horizontal and move the cutting line to the location as shown and click to place the line.
The Section View popup appears.

6. Click \[ \frac{1}{2} \] to add an arc offset.

7. Move the pointer \( \approx \) to the location as shown and click to select the first point of the arc.

This point must be on the cutting line.

8. Move the pointer to the location as shown and click to select the second point of the arc.
9. Click to close the Section View popup.
10. Drag the preview to the location as shown and click to place the section view.

**Inserting a Section View with a Single Offset**

To insert a section view with a single offset:

1. Open *install_dir\samples\whatsnew\drawings\sectionview4.slddrw*.
2. Click **Section View** (Drawing toolbar) or **Insert > Drawing View > Section**.
3. In the Section View Property Manager, click **Section**.
4. In **Cutting Line**, clear **Auto-start section view**. This eliminates the automatic insertion of the section view and lets you add additional offsets to the view.

5. Click **Vertical** and move the cutting line to the location as shown and click to place the line.

The Section View popup appears.

6. Click **** to add a single offset.

7. Move the pointer to the location as shown and click to select the first point of the offset.
8. Move the pointer to the location as shown and click to select the second point of the offset.

9. Click to close the Section View popup.
10. Drag the preview to the location as shown and click to place the section view.

**Inserting a Section View with a Notched Offset**

To insert a section view with a notched offset:

1. Open `install_dir\samples\whatsnew\drawings\sectionview4.slddrw`.
2. Click **Section View** (Drawing toolbar) or **Insert > Drawing View > Section**.
3. In the Section View PropertyManager, click **Section**.
4. In **Cutting Line**, clear **Auto-start section view**. This eliminates the automatic insertion of the section view and lets you add additional offsets to the view.
5. Click **Horizontal** and move the cutting line to the location as shown and click to place the line.

The Section View popup appears.

6. Click **** to add a notched offset.

7. Move the pointer to the location as shown and click to select the first point of the notch.

This point must be on the cutting line.

8. Move the pointer to the location as shown and click to select the width of the notch.
This point must be on the cutting line.

9. Move the pointer to the location as shown and click to select the depth of the notch. The Section View popup appears.

At this point, you could add additional offsets to the view.

10. Click ✔ to close the Section View popup.
11. Drag the preview to the location as shown and click to place the section view.
Inserting a Half Section View

To create a half section view:

1. Open `install_dir\samples\whatsnew\drawings\sectionview3.slddrw`.
2. Click `Section View` (Drawing toolbar) or `Insert > Drawing View > Section`.
3. In the Section View PropertyManager, click `Half Section`.
4. In `Half Section`, click `Topside Right`.
5. Move the pointer to the location as shown and click to place it.
6. Drag the preview to the right and click to place the section view.
Inserting an Aligned Section View

To create an aligned section view:

1. Open `install_dir\samples\whatsnew\drawings\sectionview2.slddrw`.
2. Click **Section View** (Drawing toolbar) or **Insert > Drawing View > Section**.
3. In the Section View PropertyManager, click **Section**.
4. In **Cutting Line**, select **Auto-start section view** if not already selected.
5. Click **Aligned** and move the vertex of the cutting line to the location as shown and click.

6. Move the initial side of the first cutting line to the location as shown and click.
7. Move the initial side of the second cutting line to the location as shown and click.

If the Section View dialog box appears, click **OK**.

8. Drag the preview to the right and click to place the section view.
Save Drawing View as DXF or DWG File

You can save a drawing view as a DXF™ or DWG™ file directly from the Drawing View PropertyManager.

DWG is the native file format for Autodesk's AutoCAD® software and is a trademark of Autodesk, Inc.

Saving a Drawing View from the PropertyManager

To save a drawing view as a .dxf or .dwg file from the Drawing View PropertyManager:

1. Select a drawing view.
2. In the Drawing View PropertyManager, expand Save View as.
3. Drag the manipulator to set the origin in the file.
4. Click Save View As DXF/DWG.
5. In the Save As dialog box:
   a) Enter a file name.
   b) Select Dxf or Dwg as file type.
   c) Enter a description and set options.
   d) Select or clear Export only model geometry.
      This option ignores other sketch annotations that are associated with the selected view.
   e) Click Save.

SpeedPak Drawing Support

SpeedPak drawings support section views. You can dimension and annotate them (included bodies only).

Layers

Center Marks and Centerlines Assigned to Layers

You can assign default layers to center marks and centerlines on drawings when using the Per Standard option as the drawing layer.

Click Tools > Options. On the Document Properties tab, click Centerlines/Center Marks.

- Use Centerline layer to set the layer for elements created with the centerline tool.
- Use Center mark layer to set the layer for elements created with the center mark tool, including linear and circular extensions between center marks.
**Improved Access to Layer Function**

You can access the layer assignment function from toolbars and the CommandManager. You can also assign a shortcut to the *Change layer* function.

You can add layer functionality to toolbars (including the shortcut toolbar), the CommandManager, and keyboard shortcuts. In addition, you can access layers by right-clicking in a drawing.

**Changing the Layer of a Document**

**To change the layer of a document:**

1. Right-click in the drawing, but not on a drawing element.
2. In the shortcut menu, click *Change Layer*.
3. When the dialog box appears, move the pointer over the dialog box to activate it.
4. In the dialog box, click the arrow and click a layer.

**Changing the Layer of a Drawing Element**

**To change the layer of a drawing element:**

1. Right-click the drawing element, such as an annotation.
2. In the shortcut menu, click *Change Layer*.
3. When the dialog box appears, move the pointer over the dialog box to activate it.
4. In the dialog box, click the arrow and click a layer.

If you select more than one drawing element, you can change their layer at one time.
Other Annotations

**Display Note Behind Sheet**

Annotation notes on the sheet format can be set to always display under the drawing sheet objects, allowing you to place annotations on the sheet format that can act as watermarks.

This option displays the annotation note on the sheet format behind drawing objects.
Sending Annotation Note to Back

To display an annotation note behind the drawing sheet:

On the drawing sheet format, right-click an existing note and click **Display Note Behind Sheet**.

Dowel Pin Symbol Support

There is a new document option for the automatic creation of all dowel pin symbols on view creation. Additionally, you can automatically insert all dowel pin symbols in a drawing view after view creation.

Automatically Inserting Dowel Pin Symbols

To automatically insert dowel symbols after view creation:

1. In a drawing, click **Dowel Pin Symbol** (Annotation toolbar) or right-click and click **Annotations > Dowel Pin Symbol**.
2. In the Dowel Pin Symbol PropertyManager, under **Auto Insert**, select **For all dowel holes**.
3. Set the options.
4. Select one or more drawings views.
5. Click ✔ to insert the dowel pin symbols.

Setting Document Properties for Dowel Pin Symbols

To set the document properties to automatically create all dowel pin symbols on view creation:

1. In a drawing, click **Tools > Options**.
2. On the Document Properties tab, click **Detailing**.
3. Under **Auto insert on view creation**, select:
   - Dowel symbols -part
   - Dowel symbols -assembly
4. Click **OK**.

GTOL Allows Notation Below the Feature Control Frame

In geometric tolerancing, you can add text such as ALL OVER or BOUNDARY below the feature control frame without using the PropertyManager.

When you insert a geometric tolerance symbol, in the Properties dialog box, you can enter text in **Below frame** to insert text below the feature control frame.
Inserting Text Below the Feature Control Frame

To insert text:
1. In a drawing, click Insert > Annotations > Geometric Tolerance.
2. In the Properties dialog box:
   a) Set the parameters.
   b) In Below frame, enter the text to appear below the feature control frame.
3. Click OK.

JIS Weld Symbol Improvements

Improvements in JIS weld symbols are available for creating weld symbols in compliance with the JIS Z 3021 standard.

New Weld Symbols

The following new weld symbols are available:

<table>
<thead>
<tr>
<th>Single-Flange</th>
<th>JIS Spot (flat electrode)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flare V</td>
<td>Cladding (2009)</td>
</tr>
<tr>
<td>Flare Bevel</td>
<td>Cladding (2010)</td>
</tr>
</tbody>
</table>

Single V Butt has been updated to match the JIS standard with a 90 degree angle between the two lines.

Finishing Method

Finishing method is now available in the JIS Weld Symbol tab of the Properties dialog box with the following options:
•None
•C - Chipping
•G - Grinding
•M - Machining
•F - Unspecified

Other JIS Weld Symbol Improvements

Size of Symbol Text
•Weld symbols are appropriately sized for the 13-point font.
•On the JIS Weld Symbol tab of the Properties dialog box, if you select Inside, Root Opening now appears within the weld symbol at a more appropriate size.
•All other text displays at locations and sizes that are appropriate for the weld symbol size and JIS standards.

Groove Angle Position

Groove Angle position is now displayed just outside the weld symbol when Inside is selected or Root Opening is not specified.

JIS Weld Symbol Library
The JIS Weld Symbol library is now the default when you create new weld symbols.

JIS and ANSI Symbols
Contour and Finishing method symbol elements that are the same in ANSI and JIS now map appropriately when you switch the drawing standard between ANSI and JIS.

Linking Cut List Properties to Annotations
You can link cut list properties to annotations including notes, balloons, BOM table columns, and sheet metal flat pattern views.

Linking a Cut List Property to a Balloon
To link a cut list property to a balloon:
1. In a drawing with cut list properties, click Insert > Annotations > Balloon.
2. Attach the balloon to a face or edge.
3. In the Balloon PropertyManager, under Balloon Settings, in Balloon text, select Cut List Properties.
4. Click the down arrow and select one of the cut list properties.
5. Drag the note to a location.
6. In the Balloon PropertyManager, click ✓.
Linking a Cut List Property to a BOM Table Column

To link a cut list property to a BOM table column:

1. In the BOM table, select the column.
2. In the popup toolbar, click **Column Property**.
3. In **Column type**, select **CUT LIST PROPERTIES**.
4. In **Property name**, select a cut list property to link to the column.
5. Click outside the BOM table.

Linking a Cut List Property to a Note

To link a cut list property to a note:

1. In a drawing with cut list properties, click **Insert > Annotations > Note**.
2. Attach the note to a face or edge of a body.
3. In the Note PropertyManager, under **Text Format**, click **Link to Property**.
4. In the Link to Property dialog box:
   a) Select **Component to which the annotation is attached**.
   b) Select **Cut list properties**.
   c) Click the down arrow and select a cut list property.
   d) Click **OK**.
5. Drag the note to a location.
6. In the Note PropertyManager, click ✔️.
Editing Cut List Properties for Sheet Metal Flat Pattern View

To edit cut list properties for a flat pattern view:

1. To insert the cut list properties for a flat pattern view:
   a) In a flat pattern view, right-click and click **Annotations > Cut List Properties**.
   b) Drag the Cut List Properties list and click to place it.
2. Double-click an annotation to select it.
3. Modify the text.
4. Click outside the edit box to exit edit mode.

Padding Annotation Option

Padding is a new tight-fit border option for annotation notes and balloons where you can specify a distance to offset the border from the selected text or annotation note.

Using padding, you can specify the distance between the border and the selected text or annotation note. This example shows a note with:

- Tight fit and no padding
- Tight fit and 0.5 inches of padding
User Defined is still an available option for setting a static border size. For example, if you want a set of notes to always be in 1" boxes, you can set the value in Document Properties as Box for Border Style, Custom Size for Border Size, and 1 inch for User Defined. Then, when you add Note annotations, they default to 1" fixed-sized boxes. If you change the Border Size to Tight Fit, you can adjust the space between the text and the border with Padding.

Add Padding to a Note

To add padding to a note:

1. Select a note with a border.
2. In the Note PropertyManager, under Border, select Tight Fit for Size.
3. In Padding, enter a padding value.
4. Click ✓.

Revision Cloud

Revision cloud is a new annotation type that lets you create cloud-like shapes in a drawing. Use revision clouds to call attention to geometry changes. You can insert revision clouds in drawing views or on the drawing sheet.

Revision Cloud Shapes

<table>
<thead>
<tr>
<th>Shape</th>
<th>Icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangle</td>
<td>![Rectangle Icon]</td>
</tr>
</tbody>
</table>
Inserting a Rectangular Revision Cloud

To insert a rectangular revision cloud:

1. Open `install_dir\samples\whatsnew\drawings\sectionview3.slddrw`.

2. In the drawing view, click Revision Cloud (Annotation toolbar) or click Insert > Annotations > Revision Cloud.

   The pointer changes to 🎨.

3. In the Revision Cloud PropertyManager, under Cloud Shape, select Rectangle 📊.

4. In the drawing view:
   a) Click to set the first point of the revision cloud.
   b) Drag and click to set the end point of the revision cloud.

5. Click ✅.

You can resize a rectangular revision cloud by selecting the cloud and dragging a corner handle to resize it.

You can resize rectangular and elliptical clouds. You can reshape irregular polygon clouds. You cannot resize or reshape freehand clouds. You can use the Sketch Rotate tool to rotate any cloud type.
Inserting a Freehand Revision Cloud

To insert a freehand revision cloud:

1. If not already opened, open *install_dir\samples\whatsnew\drawings\sectionview3.slddrw*.

2. In the drawing view, click Revision Cloud (Annotation toolbar) or click Insert > Annotations > Revision Cloud.

3. In the Revision Cloud Property Manager, under Cloud Shape, select Freehand.

4. In the drawing view:
   a) Click to set the first point of the revision cloud.
   b) Drag a freehand shape and click to set the end point of the revision cloud.

   If you click away from the first point, the tool automatically closes the cloud.

5. Click .

Attaching a Note to a Revision Cloud

To add a note to the rectangular revision cloud:

1. In the drawing view, click Note (Annotation toolbar) or click Insert > Annotations > Note.

2. In the Note Property Manager, under Leader, select No Leader.

3. In drawing view:
   a) Click to place the note.
   b) Type a note.
   c) In the Note Property Manager, click .

4. Drag the note to the revision cloud.
5. Select the note and the revision cloud.
6. Click Tools > Align > Group > Group.

The note and revision cloud are grouped and can be moved together to a new location.

**Setting Revision Cloud Options**

To set revision cloud options:
1. Click Tools > Options.
3. Set the options.
4. Click OK.

**Sheet Metal Bend Note Improvements**

You have more control of bend notes including displaying complementary and supplementary angles or both, merging notes for collinear bends into one note, customizations, and changing the precision of flat pattern bend notes.

For more information, see Bend Notes on page 196.

**SolidWorks eDrawings Markups Visible in SolidWorks**

Markups on drawings in SolidWorks eDrawings® are visible in SolidWorks.

When a drawing contains markups that were created in SolidWorks eDrawings, the markups appear in the SolidWorks drawing and eDrawings Markups appears in the SolidWorks FeatureManager design tree. Individual comments appear under eDrawings Markups so that you can view or zoom to them.

**Use Mouse Wheel to Zoom While Editing Text Field**

You can use the mouse wheel to zoom in and out when editing annotation text fields on a drawing.

In a drawing, double-click a note, balloon, or section or detail view letter or label and spin the mouse wheel to zoom in or out of the text.
View Label Custom Names
You can create your own names for view labels within Document Properties. View labels are no longer limited to SECTION, VIEW, AUXILIARY, or DETAIL.

Creating a Custom View Label
To create a custom view label:

1. In a drawing, click Options (Standard toolbar) or Tools > Options.
3. Under Label options, clear Per standard.
4. In Name and Scale, type your view labels.
5. Click OK.

When you create an auxiliary view, your custom labels appear in the drawing.

To create custom view labels for the other view types, click Detail, Section, or Orthographic under View Labels, and follow the same procedure.

Tables

Improved Cell Padding in SolidWorks Tables
The default minimum vertical cell padding is 1mm in all SolidWorks table templates. You can still change the vertical cell padding using the table toolbars and selecting or typing a value for Vertical Cell Padding.

To set default values for vertical and horizontal cell padding for any new table, click Tools > Options. On the Document Properties tab, click Tables. In Cell paddings, specify values for Horizontal padding and Vertical padding.

Improved Sizing of Table Columns
There are additional spreadsheet-like options for quickly resizing columns to fit text. Double-clicking the right-side border of a cell now:
• Expands the column so that the longest line of text of any cell in that column is on a single line.
• Changes the cell height to accommodate the newly formatted text.
eDrawings® Professional is available in SolidWorks Professional and SolidWorks Premium.

This chapter includes the following topics:

- eDrawings and eDrawings Pro for iPad
- Exploded Views
- Saving and Sending Files in eDrawings 64-bit Installations
- Stereographic Viewing
- Version Support for Mac and PowerPC

eDrawings and eDrawings Pro for iPad

eDrawings and eDrawings Pro are available for the iPad®. You can download them on the App Store™.

You can perform the following with eDrawings for iPad:

- Pan, zoom, and rotate 2D and 3D models.
- Animate and explode 3D models.
- View and animate SolidWorks or AutoCAD® drawings.

In addition to all of the features in the original eDrawings for iPad, eDrawings Pro lets you measure, add markup, and insert cross sections in models. For more details, visit the App Store:

- eDrawings for iPad
- eDrawings Pro for iPad
Exploded Views

eDrawings supports multiple exploded views per configuration. See Multiple Exploded Views per Configuration on page 51.

Saving and Sending Files in eDrawings 64-bit Installations

You can save and send files in eDrawings 64-bit installations. When you use Save As or Send As to create .exe or .zip files from eDrawings x64, a message in the dialog box notifies you that the file will run on 64-bit systems only. If you use Save As or Send As and you also have the eDrawings 32-bit version installed, you can set Save as type to eDrawings 32-bit Executable Files (*.exe) or eDrawings 32-bit Zip Files (*.zip).

If you use Send As and you also have the eDrawings 32-bit version installed, the Send As dialog box contains options to send 32-bit .exe and .zip files.

Stereographic Viewing

eDrawings supports stereographic viewing of models.

Before opening an eDrawings file, on the Markup tab, click Options, or click Tools > Options. On the General tab, under Performance, select 3D Stereo Viewing (enable before opening a file in eDrawings).

To use stereographic viewing, you must have a supported monitor, graphics card, and 3D glasses.

Stereographic viewing is available in eDrawings only, not in the SolidWorks software.

Version Support for Mac and PowerPC

eDrawings is supported on Mac OS® X 10.7. It is no longer supported on Mac OS X 10.4, Mac OS X 10.5, or PowerPC™.
SolidWorks Enterprise PDM

Available as a separately purchased product that can be used in SolidWorks® Standard, SolidWorks Professional, or SolidWorks Premium.

This chapter includes the following topics:

- **Administration Tool**
- **File Explorer and SolidWorks Add-in**

**Administration Tool**

**Delayed in State Notifications**

You can create notifications that are triggered when a file has been in a state for more than a specified length of time.

When you create a Delayed in State notification, you can also specify a resend value to create repeated notifications.

You can create a Delayed in State notification from:

- The Workflow Editor in the Administration tool
- The Notification Editor when you are logged in to a vault in Windows® Explorer

**Creating Delayed in State Notifications from the Workflow Editor**

You can use the workflow editor in the Administration tool to create Delayed in State notifications for folders.

1. In the Administration tool, expand **Workflows** and double-click a workflow to open it in the workflow editor.
2. Click a state to open its State Properties dialog box.
3. On the Notifications tab, click **Add Folder Notification**.
4. In the Select Folder dialog box, select the folder for which you want to make the notification and click **OK**.
5. In the Folder Notification dialog box:
   a) For **Type**, select **Delayed in State**.
   b) For **Trigger after**, specify the number of days the folder can remain in the state before the notification is triggered.
   c) For **Resend every**, specify a resend interval.
6. On the Recipients tab, click **Add Recipients**.
7. In the Add recipients dialog box, select the users or groups to receive the notification and click **OK**.

You can type a substring in the **Filter** field to hide recipients whose names do not contain the substring.

8. Click **OK** to complete the notification and close the State Properties dialog box.

9. Click **Save** to save the change to the workflow.

When the notification is triggered, the recipients you specified receive a message in their Inbox for each file in the folder that meets the delayed in state requirements. These notifications contain links to the files.

### Creating Delayed in State Notifications from Windows Explorer

You open the Notification Editor from Windows Explorer to create Delayed in State notifications for files.

1. In Windows Explorer, log in to the vault.
2. Click **Tools > Notify > My Notifications**.
3. In the Notification Editor, click **Add File Notification**.
4. In the Browse for File(s) dialog box, navigate to the location of the files for which you want to add the notification and click **Open**.
5. In the File Notification dialog box:
   a) For **Type**, select **Delayed in State**.
   b) On the Notification Properties tab, select a **Workflow** and **State**.
   c) For **Trigger after**, specify the number of days the file can remain in the state before the notification is triggered.
   d) For **Resend every**, specify a resend interval.
   e) Click **OK**.
6. In the Notification Editor, click **OK**.

When the notification is triggered, you receive a message in your Inbox with a link to the document.

### Parallel Workflow Transitions

When you create or edit a workflow transition, you can select **Parallel** as the transition type. This requires multiple users to run the transition before a file is moved to a new state.

You create parallel transitions in the Workflow editor of the Administration tool. When you select **Parallel** as the transition type, a Role tab is added that lets you specify users and groups who can approve the transition and the number of approvals that is necessary to move a file to a new state.

If parallel transitions are in effect, when users right-click a file and select **Change State**, the number of transitions already approved by other users and the total number required to change the state of the file are shown.

In this example, **Editing required** is a parallel transition:
where:

- 0 shows the number of users who have already approved the transition.
- 2 shows the number of approvals needed to complete the state change.

If the state change has not yet taken place because the required number of approvals has not been reached, users who have already approved the transition can revoke their approvals. When the user selects Change State, the Revoke option is available.

Creating a Parallel Transition

1. In the Administration tool, expand Workflows and double-click a workflow to open it in the Workflow editor.
2. Click a transition to open its Transition Properties dialog box.
3. For Type, select Parallel.
   A Roles tab is added to the dialog box.
4. On the Roles tab, click Add Role.
   ![](image)

   If roles have already been defined in the workflow, you can expand the Add Role button to choose from a list of existing roles.

5. In the Add Role dialog box:
   a) Type a Name for the role.
   b) In the Required Users field, specify how many users in the role must run the parallel transition before the file changes state.
   c) Click Add Member.
6. In the Add Member dialog box:
   a) Select the users or groups to add to the role.

   You can type a substring in the Filter field to display only users or groups whose names contain the substring.

   b) Click OK.
7. Click OK again to close the Add Role dialog box.
8. On the Permissions tab:
   a) In the Name column, select the users and groups you added to the roles you created in steps 5 through 7.
   b) In the left column, select Permit.
9. Optionally, add a notification to the transition.
   The notification can be used to inform users who need to approve the parallel transition.
   a) On the Notification tab, click Add Folder Notification.
   b) Select the folder the notification applies to and click OK.
   c) In the Folder Notification dialog box, on the Recipients tab, click Add Recipients.
   d) In the Add recipients dialog box, select the users and groups to receive the notification and click OK.
   e) Optionally, if you want to let users who run the parallel transition choose notification recipients, enable the Dynamic check box for the recipients.

10. Click OK to complete the transition and close the Transition Properties dialog box.
11. Click Save to save the change to the workflow.

**Changing State Via a Parallel Transition**

If a parallel transition has been created, multiple users must run the transition before the file actually changes state.

This procedure describes how two users send a file back to editing by using a parallel transition to change its state.

1. User A provides the first approval:
   a) Log in to the vault.
   b) Navigate to the file to be sent back to editing and select it.
   c) Click Modify > Change State > Editing required.
   The Editing required transition indicates the number of users who must run the transition.

   When the Do Transition dialog box appears, the Result column indicates that after this transition is run, one more user must perform the transition before the state of the file is changed.

   d) Ensure that Change state is checked.
   e) Enter a Comment.
   The comment appears in the file’s history and in a History column that is added when the transition is run by other users.
f) If dynamic notifications are enabled for the transition, enter a **Notification comment** and select the users to notify.

g) Click **OK**.

The **State** column in the file list shows that the file did not change state.

2. After being notified by User A that approval is needed, User B provides the second approval:

a) Log in to the vault.

b) Navigate to the file to be sent back to editing and select it.

c) Click **Modify > Change State > Editing required**.

The **Editing required** transition now indicates that one user has run the transition and that two users must run the transition to change the state of the file.

When the Do Transition dialog box appears, there are no notes in the **Results** column, since if User B approves the transition, the required number of approvals has been reached.

At the bottom of the dialog box, the **History** field shows the comments made by User A.

d) Ensure that **Change state** is checked.

e) Enter a **Comment**.

f) If dynamic notifications are enabled for the transition, enter a **Notification comment** and select the users to notify.

g) Click **OK**.

The **State** column in the file list now shows that the file has changed state.
Recently Used List

The Recently Used list appears in the right pane of the SolidWorks Enterprise PDM Administration tool. It provides quick access to the last ten administration features you have used.

The Recently Used list is retained when you close the Administration tool. When you reopen the tool, you can see the history of the work you did in your previous session.

Click Clear to remove all of the items that are currently in the list.

The Card Editor also contains a Recently Used list showing the cards you have most recently edited.

Workflow Editor Update

The Workflow Editor user interface has been updated to make it easier to navigate large workflows.

The appearance and layout of workflow state and transition objects has been simplified.

Workflow Editor in Enterprise PDM 2012

Workflow Editor in Enterprise PDM 2013
### Zoom Controls

New controls on the toolbar make it easier to work in complex work flows. You can zoom out to see the entire workflow graph or zoom in to modify specific sections.

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Zoom to Area</strong></td>
<td>Zooms to an area of the workflow that you select.</td>
</tr>
<tr>
<td><strong>Zoom In\Out</strong></td>
<td>Zooms in and out when you hold down the left mouse button and drag the mouse up or down. You can also zoom by using the mouse wheel.</td>
</tr>
<tr>
<td><strong>Zoom to Fit</strong></td>
<td>Displays the entire workflow in the available space.</td>
</tr>
<tr>
<td><strong>Actual Size</strong></td>
<td>Displays the workflow at its original (100%) size.</td>
</tr>
</tbody>
</table>

### User Interface Simplification

The appearance of transition objects has been simplified. A combination of color and icons make it easier to distinguish between transition types and identify transition settings.

<table>
<thead>
<tr>
<th>Transition Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal transition</td>
<td>Users run the transition to change file states.</td>
</tr>
<tr>
<td>Automatic transition</td>
<td>All files in the source state automatically pass through the transition.</td>
</tr>
<tr>
<td>Parallel transition (new feature)</td>
<td>A specified number of users must promote a file through a transition before the file's state changes.</td>
</tr>
<tr>
<td>Normal transition with notifications set</td>
<td></td>
</tr>
</tbody>
</table>
Normal transition with authentication set

State objects have also been simplified. Icons in the lower right corner are now used to identify state object properties rather than to initiate changes. For example:

- [Image](image1.png)
- [Image](image2.png)

**New Properties Dialog Boxes**

To open both state and transition properties dialog boxes, you click the objects in the workflow map.

![New Properties Dialog Boxes](image3.png)

Tabs have been added to the dialog boxes to provide easier and more consistent access to all settings.

Both the state and transition properties dialog boxes include:
• A Permissions tab, which replaces the permissions task pane from previous versions of Enterprise PDM.
• A Notifications tab, which provides access to the Folder Notification dialog box of the redesigned Notifications Editor.
• A Revision Numbers tab, which replaces the Increment Revision Command section of the state properties dialog box and the Change revision counters option of the transition properties dialog box.

Transition properties dialog boxes also include Conditions and Actions tabs.

File Explorer and SolidWorks Add-in

Bill of Materials Tab Improvements
The toolbar area of the Bill of Materials tab in Windows Explorer has been updated. The controls are easier to use and occupy less screen space. Bill of Materials functionality remains the same.

BOM Toolbar Reorganization
Existing controls have been rearranged into four sections.

If you make the window too narrow for all the controls to be shown, as many sections of the tab as necessary are compacted into flyout buttons. Clicking any of these buttons displays the controls for that section.

BOM Comparison
The new Bill of Materials UI makes it easier to compare BOMs. Instead of displaying a dialog box, when you click Compare, the sections of the BOM UI are reordered.
The left section shows the BOM, version, and configuration that are the source of the comparison. The middle section lets you choose the BOM, version, and configuration to compare. In the commands section on the right, the Comparison button becomes a Close comparison button.

Close SolidWorks Files on Check In

When you edit files and check them in from SolidWorks, you can select to have Enterprise PDM close the files after the check in operation completes, rather than reload them. This can improve performance since reloading the files can be time consuming.

To have files closed after you check them in from the SolidWorks Enterprise PDM add-in:

1. In the SolidWorks Enterprise PDM task pane, right-click the file, and click Check In.
2. In the Check in dialog box, in the toolbar, expand the Reload Files after Check In command and click Close Files after Check In.
3. Complete your check in selections and click Check in.

The files are checked in and closed in SolidWorks.

Contains and Where Used Tab Improvements

The toolbar areas of the Contains and Where Used tabs in Windows Explorer have been updated to make the controls easier to use and occupy less screen space.

Existing controls on both tabs have been rearranged into three sections.

- The source section lets you select the version and configuration of the file to view.
- The options section controls how the results are displayed.
- The commands section contains action buttons.

If you shrink the size of the window, the sections are compacted into flyout buttons. Clicking any of these buttons displays the controls for that section.

The commands section buttons include three new buttons that are active when you select a file from the list at the bottom of the tab.
<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Open</strong></td>
<td>Opens the file selected in the tree in the associated application.</td>
</tr>
<tr>
<td><strong>Properties</strong></td>
<td>Shows the property dialog box for the file selected in the tree.</td>
</tr>
<tr>
<td><strong>Browse to</strong></td>
<td>Opens a new Explorer window and browses to the file selected in the tree.</td>
</tr>
</tbody>
</table>

**Full Row Selection Highlighting in Windows Explorer**

When a user selects a file in Windows Explorer or the Search Tool (including integrated Search), the entire row is highlighted, making it easier to read the column data associated with the file.

In previous releases, only the file name was highlighted.

**Notification Editor Update**

The Notification Editor user interface has been updated to make it easier to create and modify notifications.

New File Notification and Folder Notification dialog boxes help you select notification types and specify notification options.

Administrators creating notifications for workflow transitions also use the Folder Notifications dialog box to add notifications to states and transitions.

**Creating File Notifications in Windows Explorer**

To create file notifications, you must work from Windows Explorer.

To create file notifications without opening the Notification Editor:

1. Select the files for which you want to create notifications.
2. Right-click and click **Notify > Me when**. The File Notification dialog box appears.
3. For **Type**, select the type of notification to create.  
   The tab displays the controls that are appropriate to the notification type and an informational message describing the notification's effect.

4. Set the other controls and click **OK**.  
   The Notification Editor appears, listing a separate notification for each of the files you selected.

5. Click **OK**.

**Creating Folder Notifications from the Workflow Editor**

Administrators can access the Folder Notification dialog box when they are editing workflow state or transition properties in the administration tool.

To create a notification for a workflow transition:

1. In the Workflow Editor, click a transition to open its Properties dialog box.
2. On the Notifications tab, click **Add Folder Notification**.
3. In the Select Folder dialog box, select the folder for which to create the notification and click **OK**.  
   The Folder Notification dialog box appears.

   For transition notifications, the **Type**, **Source state**, **Destination state**, and **State change** fields are read only. The transition you are editing dictates these properties.

   For state notifications, you can edit these fields.

4. If appropriate, select one or both of the following to restrict who the notification is sent to:
   - **Only to the file creator**
   - **Only to the last state modifier**

5. On the Recipients tab, click **Add Recipients**.
6. In the Add Recipients dialog box:
   a) Select the users and groups to receive the notification.
      If you select an entire group, the members of that group are automatically selected.
      Type a string in the Filter field to display only users and groups whose names include the string.

   b) Click OK.

7. In the Folder Notification dialog box, to allow specific users who run this transition to choose notification recipients, select the users and check the box under Dynamic Selection.

   The Dynamic Selection option is not available for folder notifications you create from the State Properties dialog box.

8. Click OK twice.
9. Click Save to save the change to the workflow.

**Viewing Your Notifications**

In Windows Explorer, you can view the notifications you have created by opening the Notification Editor. You can remove notifications you no longer use, edit existing notifications, or add new folder and file notifications.

1. Right-click a vault file and click Notify > My Notifications.
   The Notification Editor appears.

2. To activate a notification, check its box under Activated.
3. To add a notification, click Add Folder Notification or Add File Notification.
4. To remove or edit a notification you have created, select it and click the appropriate control.

   You cannot remove or edit notifications created by an administrator. If you select a notification identified with the icon, the Remove Notification control remains inactive. The Edit Notification control changes to View Notification. Use it to view notification details.
Quantity Specification for Manually Created File References

When you create file references manually by using the Paste as Reference command, you can specify a quantity for the referenced files, which is then displayed in the Bill of Materials of the file.

If you check out the file, you can modify the quantity by using the Edit User Defined File References command. Your change affects future versions of the file but not existing versions.

To specify a quantity for a referenced file when you create the reference:

1. Right-click the file to be referenced and click Copy.
2. Check out the file to contain the reference, right-click it, and click Paste as Reference.
3. In the Create File References dialog box, specify a value in the Quantity column, and click OK.
4. Check in the file with the reference.

When you view the file containing the reference in the Bill of Materials tab, the quantity is displayed.

To modify the quantity of a referenced file:

1. Check out the file containing the reference.
2. With the file selected, click the Contains tab.
3. Click Edit User Defined References.
4. In the Edit User-Defined References dialog box, modify the value in the Quantity column, and click OK.

User Information Pop-up

When you mouse over a user name in the SolidWorks Enterprise PDM user interface, a pop-up window appears. This window provides user details and links to help you communicate with other users in your company.

You can display the user window by hovering over the user name in the Checked Out By column in:

- Vault file lists in Windows Explorer, including the Contains and Where Used tabs
- The Enterprise PDM task pane in SolidWorks
- Dialog boxes such as Check in, Check out, and Get

In the History dialog box, you can display the user window by mousing over the User column or User field for a selected event.

The user window that appears contains links to the Enterprise PDM email editor, as well as Microsoft® Office Communicator or Microsoft Lync®, and Microsoft-enabled Voice over IP (VoIP) if you have these products installed. Other details users add to their profiles, such as an image, phone numbers, Web links, and presence statements, are also available.
Adding Information to the User Pop-up

If you have permission to administrate users, you can add information to user profiles that will be displayed on the user pop-up window.

1. Open the Administration tool.
2. Expand Users and double-click the name of the user whose profile you want to modify.
3. In the right pane of the user’s Properties dialog box:
   a) To display phone numbers in the user window, complete the Phone and Cellphone fields.
   b) To add links to Web sites, type URLs in the Website Address fields.
      You can add up to four web addresses.
      The Tooltip field is completed automatically.
   c) To add a note, type text in the Presence note field.
4. To add an image:
   a) In the left pane, click Browse for Picture.
   b) Navigate to the location of the image and click Open.
5. Click OK.

Viewing a User Pop-up Window

User pop-up windows are visible in Windows Explorer and SolidWorks views of an Enterprise PDM vault.

To view user pop-ups in Windows Explorer:

1. Navigate to an Enterprise PDM vault that has files checked out.
2. Mouse over a username in the Checked Out By column.
   A window appears that contains information about the user who checked out the file.

Depending on how much information has been added to the user's properties and how your network is configured, the following information that is specific to the user is provided on the card:

<table>
<thead>
<tr>
<th>User’s login name and full name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Date and time the user logged in</td>
</tr>
<tr>
<td>Number of files the user has checked out</td>
</tr>
<tr>
<td>Note from user</td>
</tr>
<tr>
<td>User’s work phone number</td>
</tr>
</tbody>
</table>
3. To pin the card so it remains displayed, click ![pin](..).
4. To close a pinned card, click ![close](..).

**Version Free Variables**

You can update variables for a file without having to check the file out and increment the version of the file when you check it back in.

This lets you update variables that change over time, such as cost, while the file itself may not change.

Additionally, you can change the variable even if the file is in a state where you do not have permission to check it out.

A new version of a file is created if you update version free variables for a checked out file or if a version free variable is modified by a workflow transition action.

To use a workflow transition to update version free variable data without versioning the file, create a Dispatch script set to run after the transition to the destination state.

**Enabling Update of Version Free Variables**

Administrators with permission to update variables and administrate users use the Administration tool to enable users to update variables without creating new versions of files.

1. To add the version free capability to a variable:
   a) In the Administration tool, expand **Variables** and double-click the variable.
   b) In the Edit Variable dialog box, click **Version free**.
   c) Under **Update versions**, do one of the following:
      - Select **All Versions** to make the variable update affect all versions and revisions of the file.
      - Select **Latest Version** to make the update affect only the latest version of the file.
   d) Click **OK**.

2. To give a user permission to update version free variables:
   a) Expand **Users** and double-click the user.
   b) In the user's Properties dialog box, click **Folder Permissions**.
c) On the Permissions per Folder tab, select a folder.
   To assign the permission for the entire vault, select the vault.

d) Under **Folder Permissions**, click **Edit version free variable data**.

e) Click **State Permissions**.

f) Select a **Workflow** and **Workflow state**.

g) Under **Permissions**, click **Edit version free variable data**.

h) Click **OK**.

**Updating Version Free Variables**
Users with permissions to edit version free variable data can modify version free variable data on a file's data card or by updating the file data cards for a folder.

1. To modify a version free variable for a data card:
   a) Without checking it out, select a file and click the Data Card tab.
      In the data card, fields that contain version free variables are editable. All other fields are disabled.

   b) Modify the editable variables and click **OK**.

2. To modify a version free variable for a folder and propagate the value to the files in the folder:
   a) Select the folder and click the Data Card tab.

   b) On the Edit Values tab, modify the version free variable and click **OK**.

   c) Click **Modify > Update > Values in Files**.

   d) In step 1 of the Updating File Data Cards wizard, click **Version free variables** and click **Next**.

   e) Complete steps 2 and 3.

   f) In step 4, in the variable list, under **Update**, select the version free variable and click **Next**.

   g) Complete steps 5 and 6.

   h) When the update is confirmed, click **OK**.

**Windows Explorer Favorites Links**
When you create a new local vault view, Enterprise PDM places a link to the vault view in the **Favorites** list at the top of the Windows Explorer navigation pane.
This makes it easy to open the local vault view even if it is located in a subdirectory.
SolidWorks Flow Simulation is available as a separately purchased product that can be used with SolidWorks Standard, SolidWorks Professional, or SolidWorks Premium.

This chapter includes the following topics:

- **Compare Configuration Mode**
- **Erosion Plot**
- **Evenly Spaced Surface Streamline Algorithm**
- **Improved Feature Tree**
- **Improved Geometry Handling**
- **Low Temperature Condensation**
- **Parametric Study Mode**
- **Improved eDrawings Plots**

**Compare Configuration Mode**

The **Compare Configuration Mode** tool makes it easy to compare the setup and results of Fluid Flow analyses. You can leverage these results to efficiently improve your designs.

With the **Compare Configuration Mode** tool (available from the Compare tab) you can compare:

- Input data from different projects
- Results of various projects coming from different configurations. A widget is used to display data from different configurations in 3D view mode.

Numerical and graphical comparison is available.
Erosion Plot

When you use the **Particle Study** feature, the **Erosion Plot** lets you visualize the distribution of the erosion accumulation rate on a surface. This is particularly useful for two-phase flow aspects in particle-wall interactions.

In addition to integral parameters for erosion and accretion of particles, SolidWorks Flow Simulation 2013 introduces local parameters of erosion and accretion, which allows for detailed quantitative and qualitative evaluations of two-phase flows, particularly in particle-wall interaction studies.

![Erosion Plot Image](image)

Evenly Spaced Surface Streamline Algorithm

The **Evenly Spaced Surface Streamline** algorithm uses a novel GPU-based technology to render evenly spaced surface streamlines in interactive real-time mode. This offers an optimal distribution of streamlines over a given surface.

The new algorithm offers a better visualization of results, as the streamline distribution is updated in real time as you manipulate the model, even when you zoom in on local areas.

The streamlines are calculated over an arbitrary vector field specified as a parameter (velocity, heat flux, and so on).

You can display streamlines in addition to flow trajectories and vector plots.

You graphics card driver must support OpenGL® 3.3. Update your driver, if necessary.

![Streamline Algorithm Image](image)
Improved Feature Tree

SolidWorks Flow Simulation 2013 has improved the visibility of geometrical and flow configurations.

Flow configurations appear on the Flow Simulation Analysis tree under their associated SolidWorks configurations. The ☰ icon appears next to each flow configuration.

Improved Geometry Handling

A new set of tools offers you more flexibility in handling complex geometries for fluid model creation or boundary condition definitions. The new functionalities save you time in preparing the model geometry for the fluid flow analysis.

No Fluid mode

Improves the handling of complex/large models to save set up time when defining the fluid flow simulation. Activate this mode to define the boundary conditions, even if the fluid model is not defined.
**Leakage Browser** Available in the *Create Lids* feature. Helps you locate holes or displacement gaps in the model by visualizing the route from an internal face to an external face of the component.

**Split component into faces** Applies the defined surface boundary condition to all faces of the selected component.

**Replicate a condition to the same component instances** Copies a flow condition (heat source, material, engineering goal, and so on) that is applied to one part to its other instances in the assembly.

**Check Geometry** The *Check Geometry* option is redesigned inside the PropertyManager to keep it visible.

**Results Resolution** Governs the solution accuracy through mesh settings and conditions for finishing the calculation. For local mesh settings, the maximum level is set at nine instead of seven for a finer mesh and an even more rigorous resolution of the simulation.

**Mesh Settings** When defining a mesh control, the limitation of 1000 basic cells in each direction is removed. You can define a finer mesh for complex or large models.

### Low Temperature Condensation

The ability to model condensation is extended to low temperatures below -70 °C. This allows you to simulate steam or humidity in extreme conditions.

For example, in a case of steam gas passing through a pipe system, the low temperature condensation capability helps you visualize where condensation will be a concern based on the pipe temperature.
Parametric Study Mode

The **Parametric Study Mode** enables designers to run multiple fluid flow tests automatically and then investigate the results to determine the best design. This mode makes it more intuitive for you to evaluate design scenarios.

To create a parametric study, click the **Parametric Study** toolbar or right-click at a boundary condition and select **Parametric Study**.

Designers tackle a vast number of problems using the new parametric study. With a new easy-to-use interface you can:

- Set an input variable as boundary condition (input data), a model dimension or mate, and a Design Table parameter.
- Set output parameters as the study goals.
- Display a compare goals report that you can export into Excel.

Improved eDrawings Plots

Result plots from Flow Simulation saved as eDrawings files are improved to show the plot legend.
This chapter includes the following topics:

- Import Performance Enhancements

Import Performance Enhancements

The SolidWorks software no longer temporarily saves part files to your computer when you import IGES files, or Pro/Engineer® or Creo™ assemblies.

When you import Pro/Engineer or Creo assemblies, SolidWorks parts are saved to your computer if you select the **Use feature import for all parts** import option.
This chapter includes the following topics:

- **Appearances**
- **PhotoView 360**

**Appearances**

**Adding Appearances**

The Appearance Target palette appears when you add a new appearance to a model so you can add the appearance at the face, feature, body, part, or component level. You can now pin the palette, which allows you to add or paste appearances quickly.

If you pin the Appearance Target palette, the workflow changes slightly. With the Appearance Target palette pinned, click the level you want to add the appearance to before you add or paste the appearance.

Click **Appearance filter** to change all instances of a certain appearance to another. For example, in the following image, the green high gloss plastic appearance is applied to each of the legs:

To change all instances of green high gloss plastic to blue high gloss plastic, drag **blue high gloss plastic** from the Appearances, Scenes, and Decals tab of the Task Pane onto any instance of green high gloss plastic in the graphics area. When the Appearance Target palette appears, click **Appearance filter**.
Copying and Pasting Appearances

You can copy an appearance from one entity and paste it onto another. Pasted appearances retain all the customizations made in the Edit Appearance PropertyManager.

To copy and paste an appearance:

1. Do one of the following:
   - Select the appearance in the DisplayManager or on the model and click Ctrl + Shift + C or PhotoView 360 > Copy Appearance.
   - Select the appearance on the model and click Copy Appearance in the context menu.
   - Right-click the appearance in the DisplayManager and click Copy Appearance in the context menu.

2. Click the face, feature, body, or part you want to add the appearance to and do one of the following:
   - Click PhotoView 360 > Paste Appearance.
   - In the context menu, click Paste Appearance.
   - Press Ctrl + Shift + V.

The Appearance Target palette appears.

3. On the Appearance Target palette, click Face, Feature, Body, Part, or Appearance Filter to paste the appearance at the desired level. As you hover over the palette buttons, a preview appears in the graphics area.

You can copy and paste multiple appearances more easily with the Appearance Target palette pinned. If you pin the Appearance Target, select the level you want to add the appearance to before pasting the appearance.

New and Enhanced Appearances

There are many new appearances in SolidWorks 2013, including liquids, plastics, and organic materials such as waxes and translucent marbles. In addition, brushed metals now show directionally-dependent (anisotropic) reflections to create a more realistic appearance.
It is recommended that you experiment with the new materials in a number of different contexts to get the best results. Factors like lighting, reflections, and the thickness of the model affect the appearance.

### Rounding Sharp Edges in an Appearance

You can set an appearance to round sharp model edges when you render with PhotoView 360.

Rounding sharp edges in an appearance does not affect model geometry. To use the **Round Sharp Edges** option, right-click the appearance in the Display Manager and click **Edit Appearance**. In the Property Manager, on the Illumination tab, select **Round Sharp Edges** and set a value for the radius.

The following image shows a wheel with the yellow high gloss plastic appearance applied.

The following image shows the same wheel and appearance, with the **Round Sharp Edges** option enabled and the radius set to 3mm.

### Scaling Textural Appearances, Surface Finishes, and Decals

You can now use a default scale for textural appearances, surface finishes, and decals. Previously, the software automatically scaled textures, surface finishes, and decals to the model size. To use a default scale instead of scaling appearances to the model size, click **Tools > Options > Document Properties > Model Display** and clear **Automatically scale textures, surface finishes, and decals to the model size**.
The default scale of SolidWorks textures, surface finishes, and decals mimics the real-life scale.

For example, in the following image, the textured appearance is scaled to the model size, creating a different texture scale on each body it is applied to:

However, in the following image, the same appearance uses a default scale:

Creating a Custom Appearance With a Default Scale

To create a custom appearance with a default scale:

1. Open a model with a textural appearance or apply a textural appearance to a model.
2. Click **Tools > Options > Document Properties > Model Display**.
3. Clear **Automatically scale textures, surface finishes, and decals to model size** and click **OK**.
4. In the DisplayManager, click **View Appearances**.
5. Right-click the appearance you want to set a default scale for and click **Edit Appearance**.
   - The Appearances PropertyManager opens.
6. Click **Advanced**.
7. On the Mapping tab, under **Size/Orientation**, define the height, width, and rotation if applicable.
8. On the **Color/Image** tab, under **Appearance**, click **Save Appearance**.
9. In the Save dialog box, name the file and click **Save**.
10. Click ✔️.
PhotoView 360

**Final Render Window**

The Final Render window has been enhanced to allow for greater manipulation of the final rendered image.

You can adjust aspects such as color saturation, brightness, and bloom in the Final Render window. Using the compare functionality, you can perform a side-by-side or magnifying glass comparison between two renderings.

The Final Render window contains three tabs:

- Image Processing
- Compare and Options
- Statistics

**Image Processing**

PhotoView 360 creates high dynamic range images. These high-quality images include extreme lights and darks, which allow for a greater degree of manipulation and editing. On the image processing tab, you can monitor intensity, saturation, and color channels. You can also make adjustments to input white, gray, and black levels as well as bloom, tone mapping, saturation, and gamma. Use the Colorization option to add a color tint to your image. All adjustments are non-destructive, meaning that you can always go back to your original image.

**Compare and Options**

On the Compare and Options tab, you can compare two images using the following three methods:

- **Wipe**
  
  The two images are overlaid and the top image is wiped away, revealing the other image.

- **Spotlight**
  
  The two images are overlaid and the cursor turns into a spotlight, which reveals the bottom image.

- **Side by Side**
  
  Displays the two full images side-by-side or vertically.

**Statistics**

The Statistics panel provides statistical information related to rendering the scene. Included in this information is the following:

- The elapsed time and approximate remaining time for in-progress renders.
- The total rendering time, memory usage, and number of polygons for finished renders.

See SolidWorks Help: Final Render Window.
PhotoView 360 Options

Network Rendering
To accelerate render times, SolidWorks Subscription Services customers can share the effort of rendering in PhotoView 360 across multiple computers.

Using PhotoView 360 Net Render Client, you can initiate final renders on the Coordinator machine, which uses the processing power of the Client machines.

To perform network rendering, you must first install the PhotoView 360 Net Render Client on the Client machines. You do not need to install SolidWorks on the Client machines.

Once the PhotoView 360 Net Render Client is installed, users can specify when their machines are available for network rendering. PhotoView 360 Net Render Client must be running on the Client machines to perform network rendering.

On the Coordinator machine, to turn on network rendering, click PhotoView 360 > Options and select Network Rendering.

Reflections and Refractions
You can use PhotoView Options to set the number of reflections and refractions that appear in the PhotoView 360 Final Render Window.

For example, when two reflective objects face each other, you can set the number of reflections that multiply and appear to recede into the distance.

Additionally, if light passes through multiple transparent surfaces, you can set the number of refractions so that objects behind the transparent surfaces are visible. One reflection (or refraction) is required for each successive face that the light reflects off of or refracts through.

Setting the Number of Reflections and Refractions
To set a specific number of reflections and refractions:
1. Click PhotoView 360 > Options.
2. In the PropertyManager, under Render Quality, select Custom render settings.
3. Set the number of reflections and refractions.

Increasing the number of reflections and refractions increases rendering time.

Using Modo Appearances in SolidWorks
Modo® users can use Luxology® appearance files in SolidWorks. After you apply the Luxology appearance, you save it as a custom appearance.

SolidWorks Subscription Customers can now access the Luxology website through the Customer Portal.

When using Luxology appearances, you have limited editing capability. The full effect of the appearance may only be visible when rendering with PhotoView 360, and not in RealView and SolidWorks OpenGL graphics.
Motion Studies

Available in SolidWorks Premium.

This chapter includes the following topics:

- **Motion Studies Tutorials**

Motion Studies Tutorials

There are two new Motion Studies tutorials: Motion Analysis Redundancies and Motion Along a Path.

To access a tutorial:

1. Click Help > SolidWorks Tutorials.
2. Click All SolidWorks Tutorials and select a tutorial from the list.
This chapter includes the following topics:

- **Edge Selection Toolbar Available for Fillets**
- **Enhanced Support for Mounting Bosses**
- **Enhanced Support for Thin Extrudes**
- **Enhancement for Inserting Cosmetic Threads**
- **Enhancements to Part Reviewer**
- **Highlighting Related Bodies or Surfaces in Multibody Parts**
- **Inserting Dowel Holes with the Hole Wizard**
- **Linking a Defeature Model to Original**
- **Mass Properties in Parts**
- **Modifying Geometry with the Intersect Tool**
- **Multibody Library Features**
- **Selecting End Conditions for Extruded Features**
- **Show Hidden Bodies**
- **Smarter Configuration Switching**
- **Transferring Custom Properties**
- **Varying Dimension Patterns**
- **Weldments**
Edge Selection Toolbar Available for Fillets

When manually adding or editing constant and variable radius fillets, a pop-up toolbar is available to help you select multiple edges or fillets. The same toolbar is used with FilletXpert.

Enhanced Support for Mounting Bosses

More options are available for creating mounting bosses.

You can create hardware mounting bosses that accept fasteners to join two plastic parts. Hardware mounting bosses have head-side and thread-side properties, and can include a lead or step to assist mating with another boss.

You can specify nine parameters for a hardware boss, not only the boss height and diameter, but also height and diameter of the boss step, the draft angle of the boss, the diameter of the hole, the diameter and the depth of the inside counter bore, and the draft angle of the inside hole.

You can specify a clearance or gap to the plane where two bosses mate. You can also specify a direction vector for a mounting boss when it is created on a planar surface.

Bosses also support a new fin profile for more cost effective designs. You can specify the number of fins, their length, width and height, the draft angle, the distance between the fin chamfer and the edge of the fin, and the angle of the fin chamfer.

To create a hardware boss, click Insert > Fastening Feature > Mounting Boss and under Boss Type, click Hardware Boss.
Creating the Mounting Boss

This example consists of two tasks: adding the head and thread portions of a hardware boss to a model.

Adding the Head Portion

For this task, you select a face to position the head portion of the boss. The Boss Type, Hardware Boss of type Head, and four fins are the defaults.

1. Open the model install_dir\samples\whatsnew\parts\mount_boss.sldprt.
2. Click Insert > Fastening Feature > Mounting Boss.
   The Mounting Boss PropertyManager appears.
3. In the graphics area, select the base of Shell 2.

The head portion of the hardware boss automatically appears on the face. Four fins are equally spaced on the boss.
4. Under **Boss**, click **Select mating face** and select the face around the edge of the shell where the two bosses will meet.

5. Rotate the model to compare the boss height. Under **Boss**, you can **Set the clearance for the boss height** and adjust the measurement by using the spin arrows.

6. Click ✓.

**Mounting Boss1** appears in the FeatureManager design tree.

**Adding the Thread Portion**
Now you add the thread portion of the boss and align it with the head portion.

1. In the graphics area, rotate the model to the other side.
2. Click **Insert > Fastening Feature > Mounting Boss**.
   The Mounting Boss PropertyManager appears.
3. Under **Position**, select the following in the graphics area:
   
   a) For **Face**, select the base of **Shell 1**.

   ![Shell 1](image)

   b) For **Direction**, select the face around the edge of **Shell 1**.

   ![Face](image)

   c) For **Circular edge**, select the edge on the bottom face of **Mounting Boss1**.

   ![Circular edge](image)

   These settings help align the thread with the head portion.

4. Under **Boss Type**, select **Thread**.

5. Under **Boss**, click **Select mating face** and select the face around the edge of the shell again.
6. Rotate the model to compare the boss height. Under **Boss**, you can **Set the clearance for the boss height** and adjust the measurement by using the spin arrows.

7. Click ✓. Mounting **Boss2** appears in the FeatureManager design tree. You can rotate the model to review the alignment of the bosses.

---

**Enhanced Support for Thin Extrudes ✨**

The Extrude features support multiple open contours for thin extrudes. You can create a thin extrude by selecting from a series of open or closed profiles within a sketch.

This enhancement includes:

- Support for this new behavior in boss and cut extrudes.
- Instant 3D capability to edit extrudes that have multiple open contours.
- Full preview capability for extrudes with multiple open contours.

**Selecting Multiple Contours for Thin Extrudes**

In this example, you select the sketch contours to create thin features on a model.

1. Open `install_dir\samples\whatsnew\parts\thin_extrude.sldprt`.
2. Click **Extruded Boss/Base** (Features toolbar).
3. In the flyout FeatureManager design tree, select **Sketch9**. **Sketch9** appears in **Selected Contours** of the PropertyManager.
4. Under **Thin Feature**, type 1.00mm for **Thickness**.

5. In the PropertyManager, click **Selected Contours**.
6. In the graphics area, select each of the six sketch lines within the ring.

   The sketch lines are listed in **Selected Contours**.

7. Pull the handle to 30mm in the graphics area to adjust the depth of the sketch plane.

8. Click ✅.
   The fins are added to the model.
Enhancement for Inserting Cosmetic Threads

With the Start from a face/plane option, you must select a face or plane, and specify the thread depth. This applies to new cosmetic threads and to legacy cosmetic threads that you edit.

Previously, when inserting cosmetic threads, the start dimension was inferred from the selected edge.

Enhancements to Part Reviewer

To use Part Reviewer, click Tools > Part Reviewer. You no longer need to enable Part Reviewer as an add-in.

Enhancements for Part Reviewer include the ability to:

• Display all sketch and relation information. When a feature has more than one sketch, you can step through each sketch.
• Display construction sketches. It previously skipped sketch-only features.
• Show only features with comments.
• Edit feature names and comments directly in the task pane.
• Hide features within a part.

Highlighting Related Bodies or Surfaces in Multibody Parts

In multibody parts, if you select a body or surface in the graphics area, the corresponding item is highlighted in the Cut-List-Item folder, the Solid Bodies or Surface Bodies folder, and the feature name in the FeatureManager design tree. The highlighting helps you identify which body or surface was selected, especially if you are working with large weldments and cut lists.

Although the body or surface is highlighted in the folders, it is not selected.

Inserting Dowel Holes with the Hole Wizard

You can insert standard dowel holes using the Hole Wizard. Dowel holes are used to align components in assemblies. You can choose from standard diameters, or assign custom diameters appropriate to your industry.

To insert the dowel hole:

1. Click Hole Wizard (Features toolbar).
2. In the Type tab of the PropertyManager:
   a) Under Hole Type, click Hole.
   b) In Type, select Dowels.
   c) Set the remaining options as needed.
3. Click .
Linking a Defeature Model to Original

You can link a defeature model to the original model. With this option, changes made to the original are automatically reflected in the defeature model.

To link a defeature model to the original model, in the Results area of the Defeature PropertyManager, select **Save the model as a separate file** and click **Link to Original**.

Mass Properties in Parts

**Custom Inertia Properties in Parts**

You can override moments of inertia properties for parts.

Adding custom inertia properties to a part can help you visualize the part's effect on the overall inertia and mass of assemblies in which it is used. For example, if you have simplified models of purchased components, you can manually add accurate moment of inertia information to these components so that the entire mass of the assembly is correctly represented.

**Mass Properties Dialog Box**

The Mass Properties dialog box has been enhanced to improve workflow and clarify options.

Some of the changes include:

- The **Assigned mass properties** option has been replaced by the **Override Mass Properties** button. When you click **Override Mass Properties**, the new Override Mass Properties dialog box appears. As in previous releases, you can override values for mass and center of mass. Now you can also override moments of inertia.
- For assemblies, if one or more components has mass properties that have been overridden, the components are listed at the bottom of the Mass Properties dialog box.
- **Output coordinate system** has been changed to **Report coordinate values relative to**. The contents of the drop-down list remain the same.
- The **Print** and **Copy** buttons have been moved to the bottom of the dialog box, and a **Help** button has been added.
- **Show output coordinate system in corner of window** has been moved to the Mass/Section Property Options dialog box. Click **Options** in the Mass Properties dialog box.

**Point at the Center of Mass**

You can add a **Center of Mass** (COM) point to parts, assemblies, and drawings.

You add a COM by clicking **Center of Mass** (Reference Geometry toolbar) or **Insert > Reference Geometry > Center of Mass**.

In the graphics area, the **Center of Mass** appears at the center of mass of the model. In the FeatureManager design tree, **Center of Mass** appears just below **Origin**.

The position of the COM point updates when the model’s center of mass changes. For example, the position of the COM point updates as you add, move, and delete features in a part.
The COM point can be suppressed and unsuppressed for configurations.

You can measure distances and add reference dimensions between the COM point and entities such as vertices, edges, and faces.

You cannot create driving dimensions from the COM point. However, you can create a Center of Mass Reference Point (COMRP), and use that point to define driving dimensions. A COMRP is a reference point created at the current center of mass of the part. It remains at the coordinates where you create it even if the COM point moves due to changes in the geometry of the part.

To create a COM reference point:

- Right-click the Center of Mass in the FeatureManager design tree and click Center of Mass Reference Point.

See also Center of Mass Point in Assemblies on page 61 and Reference Center of Mass in Drawings on page 106.

Modifying Geometry with the Intersect Tool

You can intersect solids, surfaces, and planes to modify existing geometry, or to create new geometry with the Intersect tool.

For example, you can add open surface geometry to a solid, remove material from a model, or you can create geometry from an enclosed cavity. You can also merge solids that you define with the Intersect tool, or cap some surfaces to define closed volumes.

<table>
<thead>
<tr>
<th>Open surface and a solid body</th>
<th>Two halves of a mold</th>
</tr>
</thead>
<tbody>
<tr>
<td>The open surface defines details that you can add to the body with the Intersect tool.</td>
<td>The empty cavity enclosed by the two mold bodies defines a body you can create with the Intersect tool.</td>
</tr>
</tbody>
</table>
To create geometry from solids, surfaces, or planes in a part:

1. Click **Intersect** (Features toolbar) or **Insert > Features > Intersect**.
2. Select solids, surfaces, or planes.
3. Click **Intersect**.
4. Select the regions to exclude and click ✓.

**Creating Geometry from Solids, Surfaces, or Planes**

In these examples, you intersect a surface body with a solid body to add detail to the solid body, and you create a solid body from a mold by filling in the cavity and removing the mold bodies.
Adding Surface Details to a Body

In this example, you form the intersection of a surface body with a flat solid body to provide detail to the solid body. First, you open the model and examine the surface detail to add to the solid body.

1. Open `install_dir\samples\whatsnew\surfaces\intake_cover.sldprt`. This model has two entities to intersect: a surface body and a solid body.

![Image of model]

The separate surface and solid bodies in this part are coincident, but also intersect, since the surface is not flat.

2. In the FeatureManager design tree, click Solid Bodies(1), and click Hide to view the surface body.

3. In the FeatureManager design tree, click Solid Bodies(1), and click Show.

Intersecting the Bodies and Removing Regions

Next, you apply the Intersect command to intersect the surface and solid bodies, removing the regions you do not require for your design.

1. In the FeatureManager design tree, select the bodies to intersect:
   a) Expand the Surface Bodies folder and select the surface body Surface-Revolve1.
   b) Expand the Solid Bodies folder and select the solid body CircPattern1.

2. Click Intersect (Features toolbar) or Insert > Features > Intersect. Surface-Revolve1 and CircPattern1 are selected in the PropertyManager.
3. In the PropertyManager, click **Intersect**.

![Image of intersecting regions](image)

The features you can remove appear in the **Regions to Exclude** list.

4. Select **Region 1**, **Region 3**, and **Region 5**.

The regions you select are not included as added geometry. By removing regions 3 and 5, you exclude the center hole from the resulting body. By removing region 1, you exclude the inner ring of material while creating the outer groove.

![Image of selected regions](image)

5. In the PropertyManager, under **Options**, select **Consume surfaces**, to remove the surface body from the FeatureManager design tree when you click ✓.

6. Click ✓.

![Image of solid body](image)

7. Save the part as **my_intake_cover.sldprt**.

### Creating a Solid Body from the Cavity in a Mold

Next, you open a mold, and with the Intersect tool, and create three regions from the top and bottom bodies: the top, the bottom, and the cavity. Then you remove the mold top and bottom regions to create a solid body from the filled cavity.

1. Open *install_dir*\samples\whatsnew\surfaces\Mold_to_part.sldprt.

   The part consists of the two solid bodies of a mold.
2. In the FeatureManager design tree, click **Move-Copy/Body1**, and click **Suppress** to close the mold.

To apply the Intersect tool to create a solid from a cavity, the cavity must be enclosed by the selected bodies. The mold bodies enclose the cavity when you close the mold.

3. Expand **Solid Bodies(2)** (FeatureManager design tree), and select **Split1[1]** and **CirPattern1**.

4. In the PropertyManager, click **Intersect**.

The features you can remove appear in the **Regions to Exclude** list.
5. Select **Region 1** and **Region 3**.
   By removing regions 1 and 3, you exclude the mold bodies and retain the cavity.

![Mold cavity model](image)

6. Click ✓.

![Solid model](image)

The result is a solid model of the mold cavity.

7. Save the part as `my_Mold_to_part.sldprt`.

**Multibody Library Features**

You can create library features from multibody parts.

Previously, you could not create library features from multibody parts.

**Selecting End Conditions for Extruded Features**

You can right-click anywhere on an extruded feature and change the end condition from a shortcut menu. You can click in empty space, on geometry, or on the handle.

The shortcut menu provides all the options for **Direction 1** and **Direction 2**, and is available for the following features:

- Extruded Boss/Base
- Revolved Boss/Base
- Extruded Cut
- Revolved Cut
- Extruded Surface
- Revolved Surface
- Sheet Metal Base Flange

Previously, you could only enable **Direction 2** from the PropertyManager. Also, if both directions were enabled, you had to right-click the appropriate handle to set that direction’s end condition.
Show Hidden Bodies

You can toggle the display of hidden and shown bodies for multibody parts. This command is the same as the **Show Hidden Components** command for assemblies.

Smarter Configuration Switching

Showing a new configuration in a part is now faster if the configuration is in memory. A configuration is only in memory if it has been shown in the current session or saved using the new Manage Configurations functionality.

For more information, see **Managing Configuration Data** on page 75.

Transferring Custom Properties

Improvements have been made to transferring of custom properties when you insert a configured part into another part.

- When you insert a configured part into a parent part, the configuration-specific properties are now correctly transferred.
- When you insert a single-body configured part into a weldment part, the custom and configuration-specific properties are propagated into the weldment part as cut list properties.

Varying Dimension Patterns

The **Instance to Vary** option in the Linear and Circular Pattern Property Managers allows you to vary the dimensions and locations of instances in a feature pattern.

You can vary the dimensions of a series of instances, so that each instance is larger or smaller than the previous one. You can also change the dimensions of a single instance in a pattern and change the position of that instance relative to the seed feature of the pattern.

For linear patterns, you can change the spacing between the columns and rows in the pattern. For circular patterns, you can arrange the instances to become closer together or farther apart.

Varying the Spacing and Dimensions of All Instances

The seed feature in this pattern is a cut extrude with a fillet. In this task, you use the **Instances to Vary** options to vary the spacing and dimensions of all instances in the pattern.

1. Open the model `install_dir\samples\whatsnew\parts\simple_plate.sldprt`.

   ![Image](image)

2. In the FeatureManager design tree, select **Lpattern** and right-click **Edit Feature**. The LinearPattern PropertyManager appears.

3. In the PropertyManager, click **Instances to Vary**.
4. In the graphics area, click the **height** (8) and **width** (6) dimensions of the seed feature.

![Image](187x733)

The **Instances to Vary** box populates a table with the dimensions and values.

5. Under **Direction 1 Increments**:
   a) Set **Spacing** to 5mm.
   b) For the **Height** dimension, set **Increment** to 10mm.

6. Click ✓.

The spacing between all the instances increase by 5mm.

Each instance increases in height by 10mm over the preceding instance. For example, since the height of the seed instance is 8mm, the height of succeeding instances increase to 18mm, 28mm, 38mm and 48mm.

![Image](187x733)

**Modifying Dimensions of One Instance**

You can change the dimensions and position of one instance in a pattern.

1. In the FeatureManager design tree, select **Lpattern** and right-click **Edit Feature**.
2. On the last instance in the row, do the following:
   a) Hover the pointer over the instance marker.
   b) Left-click and select **Modify Instance**.

A callout appears in the graphics area and lists the instance in array format (5,1).

If you select **Skip Instance**, the instance is removed from the pattern.

3. In the **Instance (5,1)** callout, override the **Width** dimension by entering 12mm.

![Image](187x733)
To adjust the dimension and spacing values, hover over the instance marker, right-click and select **Edit Modified Instance**.

4. Click ✅.

The modified instance doubles in width.

Restoring Instances to Their Original State

You can restore a modified instance to its original state by using the **Modified Instance** box in the Property Manager.

1. In the FeatureManager design tree, select *Lpattern* and right-click **Edit Feature**.
2. In the **Modified Instances** box, right-click the instance *(5,1)* and select **Delete**.

You can remove all modifications by right-clicking the **Modified Instance** box, and selecting **Clear Selections**.

3. Click ✅.

Weldments

**Bounding Boxes**

You can create a bounding box for any cut list item in a cut list, independent of the type of solid or sheet metal bodies in the cut list item.

The bounding box is represented by a 3D sketch and is based, by default, on the X-Y plane. Taking into consideration the bounding box's orientation, the bounding box is the smallest box in which the body fits.

Benefits of bounding boxes:
• The overall dimensions of the bounding box appear in the Cut-List Properties dialog box so you can use them in a bill of materials, cut list, or other annotations.
• With a bounding box, you can determine the length, width, and height of the stock needed for the body, which helps you to know how much space is required for packaging the product.
• With weldments, you no longer have to find the stock size for plates manually.

Bounding Box Orientation
The orientation of a bounding box is based on one of the following:
• The X-Y plane (default)
• A preselected plane or planar face
Exceptions to these orientations are for weldment gussets and end caps:
• For gussets, the orientation plane for the bounding box is parallel to the gusset faces.
• For end caps, the orientation plane for the bounding box is parallel to the planar faces that they cap.
• For a linear structural member, the orientation plane for the bounding box is perpendicular to the sketch line defining the member.

When you create bounding boxes for different cut list items, they can be oriented differently due to individual exceptions.

When you update a cut list, the existing orientation is used. When you edit a cut list or cut list item, the existing orientation is used unless you select a plane.

Working with Bounding Boxes

To create a bounding box:
1. In the FeatureManager design tree, update the Cut list.
2. Right-click the Cut list or a Cut-List-Item and click Create Bounding Box.

To edit a bounding box:
• Right-click a Cut list or Cut-List-Item that already has a bounding box and click Edit Bounding Box to change the orientation plane or face in the PropertyManager.

To delete a bounding box:
• Right-click a Cut list or Cut-List-Item and click Delete Bounding Box.

You cannot edit the actual 3D sketch.
Creating Bounding Boxes

To create a bounding box:

1. Open install_dir\samples\whatsnew\parts\weldment.sldprt.

2. In the FeatureManager design tree:
   a) Right-click Cut list(41) and click Create Bounding Box. Bounding boxes are created for each cut list item in the model, but they are hidden in the graphics area.
   b) Expand Cut list(41).
   c) Under Cut-List-Item8, click Bounding-Box_Cut-List-Item8 and click Show.
   d) Click Bounding-Box_Cut-List-Item8 again. The bounding box appears around the flange.
   e) Right-click Cut-List-Item12 and click Properties. The Cut-List Properties dialog box displays the 3D-Bounding Box Thickness, 3D-Bounding Box Width, 3D-Bounding Box Length, and 3D-Bounding Box Volume. If you create a drawing, these values appear in the bill of materials.
   f) Click OK.
SolidWorks Plastics Professional and SolidWorks Plastics Premium are available as separately purchased products that can be used in SolidWorks Standard, SolidWorks Professional, or SolidWorks Premium.

This chapter includes the following topics:

- **Plastics Part and Injection Mold Design Optimization**

**Plastics Part and Injection Mold Design Optimization**

When designing plastic parts, you can optimize for wall thickness and molded part quality with SolidWorks Plastics Professional. You can analyze injection mold runner systems and optimize the mold size and layout with SolidWorks Plastics Premium, reducing or eliminating the need for rework.

Routing

Available in SolidWorks Premium.

This chapter includes the following topics:

- **Auto Route Tool Supports Routing Along Existing Geometry**
- **Creating Drawings for Flexible Tubing Routes**
- **Enhanced Pipe Penetration**
- **Enhanced Support for Exporting Pipe and Tube Data**
- **Improvements for Flattened Routes**
- **Improvements for Ribbon Cable Routes**
- **Adding Slopes for Pipe Routes**
- **Support for Tubing in P&ID Files**
- **Validation Check for Routing Component Wizard**

**Auto Route Tool Supports Routing Along Existing Geometry**

The **Auto Route** tool includes an option to create a route based on existing geometry.

To route along geometry, specify a start point, one or more planar faces, and an endpoint in the **Auto Route** PropertyManager. Routing automatically creates a route from the start point to the end point that runs parallel to the faces.

You can specify the distance between the route and each planar face. This makes it easy to create a route that maintains a specific distance from walls and other planar surfaces.

You can also specify if the route should include a covering for dimensions, and if it should use a centerline dimension.

**Creating Drawings for Flexible Tubing Routes**

You can create a drawing of a flexible tube assembly in the same manner as you create a pipe drawing. Tube drawings can include fittings, tubes, dimensions, and a BOM in an isometric view. You can also create drawings of tube routes that contain spools.

To create a tube drawing, click **Tube Drawing** (Flexible Tubing toolbar) or **Routing > Flexible Tubing > Tube Drawing**.
Enhanced Pipe Penetration

The workflow for penetrating pipes has improved.

When you add a pipe penetration, Routing creates a cut extrude feature and sets **Offset From Surface** instead of **Up To Surface** as the **End Condition**. The outside surface of the pipe is selected and the offset is the pipe thickness.

You can delete a penetration by right-clicking **Remove Penetration**. This removes the penetration permanently.

If you delete a penetrating pipe from the FeatureManager design tree, the point of penetration is maintained in the Route feature. When you exit the route, the penetration automatically updates.

You can also replace a pipe penetration with a fitting by dragging and dropping a fitting at the penetration point. This adds a split point in the route segment to align the fitting with the route segment.

Enhanced Support for Exporting Pipe and Tube Data

You can export more types of routing components to a .pcf file and import them into ISOGEN® applications, such as coverings, supports, and fittings center point data.

To export data, in the FeatureManager design tree, right-click a route assembly and select **Export pipe/tube data**.

Improvements for Flattened Routes

Enhancements to electrical flattened routes give flattened harness drawings a cleaner and more complete appearance.

Improvements have been made in annotations and the detailing of wires in flattened drawings. These include clearer layouts of flattened harnesses, no overlaps, placement of connectors, fan-out creation for multipin connectors, support for splices, and improvements in the way disconnected routes are handled in flattened harnesses.

In drawings, connector tables are attached to the drawing view ,and connectors are highlighted when connector tables are selected.

Enhancements to editing flattened routes make it easier for you to manipulate fan-out segments. For annotation-style and manufacturing-style flattened routes, the Edit Flattened PropertyManager includes an option that lets you specify an angle to position an entire fan-out segment relative to the base segment. You can also specify the spacing between the individual fan-out segments. These options help remove overlaps between connectors, and fit designs within the confines of a form board for manufacturing-style flattened routes.

Improvements for Ribbon Cable Routes

Enhancements to ribbon cables make it easier for you to create route paths. All **Sketch Tools** are available when you create and edit ribbon cable routes, like other routing functionality.

To use the **Sketch Tools**, open the ribbon cable assembly and right-click in the graphics area. You can add or delete segments, and add or delete dimensions.
Also, handles are added to the route path so that you can control the twist and bend on the ribbon cables.

Previously, Sketch Tools were not enabled when you modified ribbon cable routes, and only limited use of these tools was available with Auto Route.

Adding Slopes for Pipe Routes

Routing provides full support for adding slopes to segments of solid pipe routes. You define a slope by specifying the gravity plane, the start point, the direction of the slope, and the slope value. The slope becomes a property of the route segment.

If one end of the pipe route is fixed, then vertical segments of the route are shortened or lengthened to accommodate the sloped pipe segment. If the other end of the pipe
route is not fixed, then the entire pipe route, including the fittings, are adjusted to move up or down.

**Adding a Slope**

To add a slope to a pipe route:

1. Open a routing assembly and click Piping > Edit Route (Routing toolbar).
2. Right-click the sketch entity at the location where you want to add the slope and select Add Slope.
   The Pipe Slope PropertyManager appears.
3. Select the Gravity Plane. The pipe segment must be on that plane.
4. Select a Start Point. The start point must be a fixed point that the pipe segment can use to rotate and create the slope.
5. In the PropertyManager, enter the rotation angle of the Slope, expressed as a ratio.
6. Click .
   The slope is added to the pipe segment.

You can edit the slope by selecting the route segment and right-clicking Edit Slope. To remove the slope, right-click the segment and select Remove Slope. You can also annotate slopes in drawings and BOMs.

**Support for Tubing in P&ID Files**

You can import data for tubing systems from a Piping and Instrumentation Diagram (P&ID) file. The import of tubing systems is the same as the import of piping systems. You can also combine piping and tubing connections in the same file.

**Validation Check for Routing Component Wizard**

The Routing Component Wizard in the Routing Library Manager can validate design tables. The Design Table Check dialog box validates custom design table entries and displays feedback.
This chapter includes the following topics:

- **Bend Notes**
- **Forming Tools**
- **Multibody Parts**

**Bend Notes**

You have more control over the text and display for bend notes in drawings.

This option is only available in the flat pattern view of a sheet metal part.

In the Drawing View PropertyManager, you can:

- Show or hide bend notes
- Set the bend direction, bend radius, bend order, and bend allowance
- Edit the text, including removing the R for the bend radius parameter
- Display complementary and supplementary bend angles

In a drawing with a flat pattern view of a sheet metal part, select the drawing view. Set options in the Drawing View PropertyManager under **Bend Notes**.

You can also:
• Control the precision of bend notes per drawing view. Click **Options** (Standard toolbar) or **Tools > Options**. On the Document Properties tab, expand **Tables** and click **Bend**. Set options for **Precision**.

• Merge and unmerge collinear bend notes.

  To merge the bend notes into a single note, multi-select the notes, right-click, and select **Merge Bend Notes**.

  To unmerge, right-click the merged note and click **Unmerge Bend Notes**.

• Use the new options for bend notes as columns in bend tables. In a bend table, double-click a column heading and select a column such as **COMPLEMENTARY ANGLE**, **BEND ORDER**, or **BEND ALLOWANCE**.

### Forming Tools

#### Dimensions for Rotation Angles

If you set a rotation angle for a forming tool in the PropertyManager, you can edit the angle in the PropertyManager or when editing the profile sketch. The angle is located with respect to the X axis of the profile sketch.

#### Insertion Points

You can set an insertion point for forming tools. The insertion point helps you determine the precise location of the forming tool on the target part.

In a part, click **Forming Tool** (Sheet Metal toolbar) or **Insert > Sheet Metal > Forming Tool**. In the PropertyManager, set options on the Type tab, then select the Insertion Point tab. Use dimensions and relations tools to define the insertion point.
Multibody Parts

FeatureManager Design Tree Structure

The FeatureManager design tree structure for multibody sheet metal parts has changed. In SolidWorks 2013, there are two separate parent folders (Sheet-Metal and Flat-Pattern) that contain the sheet metal bodies and their associated flat patterns.

If you create a new sheet metal body from an existing sheet metal body, only one Sheet-Metal feature appears in the parent sheet metal folder in the FeatureManager design tree. For example, if you pattern a sheet metal body so there are three sheet metal bodies instead of one, only one sheet metal feature node corresponding to the three resulting bodies controls the sheet metal parameters of the bodies.

If you attach two existing bodies to create one sheet metal body, two Sheet-Metal features appear in the parent sheet metal folder in the FeatureManager design tree. Even though there is only one body, the second body retains its own sheet metal parameters.

The sheet metal feature that corresponds to the first body controls the first body geometry as well as any new feature geometry added to the combined body.

The sheet metal feature that corresponds to the second body is indented under the sheet metal feature that corresponds to the first body.
It controls only the second body geometry (thickness and bend radius).

**Gauge Tables**

Only one gauge table is allowed per multibody sheet metal part. The gauge table is determined by the first sheet metal body that you create in the part.

To control the gauge table settings, in the FeatureManager design tree, right-click the *Sheet-Metal* parent folder and click *Edit Feature*. In the PropertyManager, under *Sheet Metal Gauges*, set options.

Each body in the part can use different gauges from the table.

**Options**

When you display sheet metal properties by selecting *Tools > Options > Document Properties > Sheet Metal*, the option *Create multiple flat patterns whenever a feature creates multiple sheetmetal bodies*, applies to parts created prior to SolidWorks 2013. In SolidWorks 2013, each body in a multibody sheet metal part has its own flat pattern.

**Parent Sheet Metal Parameters**

All bodies in multibody sheet metal parts inherit the bend radius and thickness values from the sheet metal parent folder. You can override the inherited values. Bend allowance and auto relief values are not affected.

The values in the sheet metal parent folder are determined by the first sheet metal body you create in the part.

In the FeatureManager design tree, right-click the *Sheet-Metal(n)* feature below the parent folder and click *Edit Feature*.

In the PropertyManager, under *Bend Parameters*, select or clear *Override default parameters*. 
SolidWorks Simulation Professional and SolidWorks Simulation Premium are available as separately purchased products that can be used in SolidWorks Standard, SolidWorks Professional, or SolidWorks Premium. SolidWorks Premium contains simulation capabilities for linear static analysis and motion analysis.

This chapter includes the following topics:

- **Beams**
- **Contact**
- **Incremental Meshing**
- **Interface**
- **Materials in Design Studies**
- **Results**
- **Sensors**
- **Submodeling**

**Beams**

You can list the reaction forces and reaction moments at beam joints that have fixed translations or rotations.

In the Result Force Property Manager, under **Selection**, select the beam joint to list the reaction forces.
Contact

Improvements in contact definitions include the removal of the limit on the number of contact sets in static, nonlinear, and drop test studies, improved detection of contact pairs between surface splines and touching faces, detection of interfering faces, and the bonding of shell edges to beams.

**Automatic Contact Set Detection**

The automatic detection tool for contact sets is improved to detect surface splines touching planar or cylindrical faces.

The option **Find shell edge - solid/shell face pairs** (automatic detection tool for contact sets) is enhanced to detect contact sets between solid and shell bodies that intersect at spline surfaces.
Detecting Interfering Faces
The Find Contact Sets dialog box lists the interfering pairs of shell and solid faces making it easier to detect them.

1. In the Contact Sets PropertyManager, under Contact, select Automatically find contact sets.
2. Under Options, select Find shell edge - solid/shell face pairs.
3. Under Components, select the bodies for which you want to detect the contact sets.
4. Click Find contact sets.
   If interference is detected, the interfering pairs are listed under Interfering Faces. Select an interfering set to highlight the interfering faces in the graphics area.

Shell Edges to Beam Bonding
The bonding of shell edges that belong to surface or sheet metal bodies to beams, commonly used to simulate gusset plates connecting beams, is supported through manual contact set definitions.

This functionality is available for linear static, frequency, buckling, and linear dynamic studies.

To create a shell edge to beam bonded contact, in the Contact Sets PropertyManager, under Type, select Bonded. For Set 1, click Beams and select the beam from the graphics area. For Faces, Edges for Set 2, select the shell edge.
Incremental Meshing

Incremental meshing gives you more flexibility in refining meshes of individual components inside a large assembly. By remeshing only the selected solid or shell bodies instead of the entire assembly, you save computation time.

Incremental meshing allows you to mesh components individually without having to mesh the whole assembly. If you meshed some (but not all) bodies of an assembly before you run the study, only the bodies with no mesh will be meshed.

When meshing fails for certain components, you can remesh only the failed components. The existing mesh for the rest of components remains intact.

For bodies that have no mesh, right-click the selected bodies, and select Create Mesh. Apply the mesh settings in the Mesh Control PropertyManager. Bodies that failed to mesh are flagged with a red mesh icon in the study tree.

For bodies with mesh, right-click the selected bodies and select Remesh. The new mesh control settings override the existing mesh.

Incremental meshing is not available for beams and 2D simplification studies.

Interface

Enhancements in the user interface include:

- Folder customization in the Connections folder.
  To better organize features in the Connections folder, there is a Connectors folder. The Connectors folder is similar to the Contact Sets and Component Contacts folders.

- Improved use of the Tab key and shortcut menus.
  - You can use the Tab key to move between entries in PropertyManagers. Shift + Tab works in a similar way, but in reverse order.
  - In PropertyManagers with multiple selection boxes, when you right-click in the graphics area to make a selection, the Advance pointer appears so that you can advance through the PropertyManager selections directly from the graphics area.
• More flexibility in treating bodies as solids or beams.

If you select a group of beams or solid bodies in the Simulation study tree, you can select:

• **Treat selected bodies as beams**
• **Treat selected bodies as solids**

• Linked error messages to geometry

**Error Messages**

By linking the solver error messages to the geometry, you can more easily resolve any errors in the Simulation study setup. The error messages are listed in a What’s Wrong dialog box next to the study feature where the error was detected.

When the solver identifies an error with a feature, it marks the feature in the study tree with a warning icon and adds a solver message.

For errors while formulating the mesh, the solver highlights the mesh element or node in the graphics area.

---

**Materials in Design Studies**

You can use the material of a part or body component in a Design Study using the new Design Study Materials parameter. This functionality allows you to evaluate a wide range of design choices or optimize a current design by defining a parameter that sets bodies to use different materials as a design study variable. This functionality is available in SolidWorks Professional and above for setting Simulation results as goals in the design studies.

**To define a material as a variable in a Design study:**

1. Create a Design study.
2. Click **Insert > Design Study > Parameters** or click the Design study tab and under **Variables**, select **Add Parameter**.
3. In the **Parameters** dialog box, under **Name**, type a name for the parameter.
4. Under **Category**, select **Material**.
5. Under **References**, select the bodies for which the material is set as a variable in a design study.
   Rows highlighted in green contain bodies assigned to the material parameter.

6. Click **Apply** and **OK**.
   An asterisk appears under **Linked** to show that the selected bodies are linked to the material parameter.

7. Switch to the **Table View** tab to define the design scenarios.
8. For each scenario, click the **Select Material** cell on the material parameter row.
9. Select a material from the SolidWorks or custom materials library and click **Apply**.
   The selected material is applied to the bodies linked to the material parameter.

A body can be assigned only one material for a given scenario. In case the parameters are defined such that a body has two material assignments, only the first material assignment is applied for each scenario.

The material of composite shell bodies cannot be set as variable in design studies.

### Design Evaluation of a Knob based on Material

You run three design scenarios of a knob part by varying its material definition for each scenario.

You create a design variable based on the knob's material definition. You assign a different material definition for each design scenario.

To open the model, go to `install_dir\samples\whatsnew\DesignStudies\knob.sldprt`.

Review the **Ready Study** features:
- Applies a torque to the handle.
- Prevents the inner cylindrical face from twisting.
- Prevents the knob from moving along the axial direction.

Review the **Design Study** features:
- Defines model dimensions as parameters: **Cut_Diameter**, **Cyl_Ht**, and **Cut_Depth**.
- Sets two constraints: a) FOS greater than 2.0 and b) monitoring of mass.
- Sets design scenarios with given values for the three design variables.
**Defining Material as a Design Variable**
You define a material parameter and you add it as a variable in the design study.

1. Open the **Design Study**.
2. On the **Table View** tab, expand **Variables**, and select **Add Parameter**. In the **Parameters** dialog box:
   a) Under **Name**, type a name for the parameter, for example *mat*.
   b) Under **Category**, select **Material**.
   The knob’s single body is listed under **References** with a check box.
   c) Click **Apply**.
      An asterisk under **Linked** shows that the body’s material definition is now linked to the material parameter.
   d) Click **OK**.

**Selecting Materials for Design Scenarios**
You assign three different materials for the design scenarios of the knob.

1. On the **Table View** tab, under **Scenario 1**, click **Select Material**.
2. From the SolidWorks Materials library, under **Plastics** select **Acrylic (Medium-high impact)**.
3. Click **Apply**.
4. Under **Scenario 2**, click **Select Material**. Under **Other Non-metals**, select **C (Graphite)**.
5. Click **Apply**.
6. For **Scenario 3**, under **Other Non-metals**, apply **Ceramic Porcelain**.
7. Close the **Material** dialog.
Running the Design Scenarios

1. Click Run. The program invokes the Ready static study at each iteration, and reports the values for each iteration.

2. Switch to the Results View.

3. Select Scenario 1 which is highlighted in red because the minimum FOS is less than 2.

The Acrylic material is not a good material choice for this particular model. You can also use materials as design variables in an Optimization design study.

Results

Improvements in viewing results include the option to display plots and factor of safety for selected entities, more realistic representation of results on shell bodies, and options for selecting which results to store.

Factor of Safety for Selected Bodies

After you run a static study, you can view factor of safety plots on selected bodies only. In the Factor of Safety PropertyManager, click Selected Bodies. Select one or multiple bodies to view plots of factor of safety distribution, or regions below the factor of safety. Results are shown only for the selected bodies.
Plots on Selected Entities

A new option for viewing results lets you display results (stress, displacement, and strain) on selected entities only.

In a Stress Plot, Displacement Plot, or Strain Plot PropertyManager, under Advanced Options, select *Show plot only on selected entities*. You can select faces or bodies to view results.
**Shell Results**

You can display the mesh and results of shells using a 3D representation of shell bodies. There is a new option to display the thickness of shells in result plots (stress, displacement, and strain) and when viewing the mesh.

To view the results on a 3D representation of shell bodies, in a Stress Plot, Displacement Plot, or Strain Plot PropertyManager, under Advanced Options, select **Render shell thickness in 3D (slower)**.

The shell thickness displayed in the plots is the value defined in the Shell Definition PropertyManager. The orientation of thickness is displayed with relation to the mid-surface of the shell, as defined by the offset value (Shell Definition PropertyManager).

For stress plots, results for the top and bottom shell faces are shown. Results are linearly interpolated across the shell thickness. When probing stress plots, both the top and bottom shell values are displayed.

**Storing Results**

You can control the amount of results data stored in the simulation results file, reducing the file size and improving the loading speed, especially for transient analysis.

Enhancements in storing results include:

- Having the option not to store the stress and strain results in the result file (*.CWR) for static studies.
  
  In the Result Options PropertyManager, clear **Stresses and strains** under **Quantities to save into file**. Only displacement and body force results are calculated and stored in the results file.

  The default option for the solver is to calculate and store all the results.

- Having the option to save results only for selected solution steps for thermal transient studies.
  
  In the Result Options PropertyManager, select **For specified solutions steps**. Set the first and last solution step, and step increment for the desired solution step set.

  You can still save results for all solution steps for vertices and reference points stored in sensors, under **Locations for Graphs**.
Sensors

A new sensor tracks results from transient studies (nonlinear, dynamic, drop test, and transient thermal). After you run a transient study, you can graph the stored sensor values versus the range of time or frequency solution steps.

This functionality is available in SolidWorks Simulation Professional and above.

Defining a Transient Sensor

With a transient sensor, you can track simulation results for the whole model or selected model entities across all solution steps of a transient study. After your run the study, you can list and create graph plots of the data stored by the transient sensor.

1. Create a transient study (nonlinear, dynamic, transient thermal, or drop test)
2. In the FeatureManager design tree, right-click Sensors and select Add Sensor.
3. In the PropertyManager:
   a) Under Sensor Type, select Simulation Data.
   b) Under Data Quantity, select the result quantity to track with the sensor.
   c) Under Properties, select a Criterion. Select Transient for Step Criterion.
   d) Click .
      A new sensor icon is created under Sensors.

To list the data stored in a transient sensor, right-click the sensor icon under Sensors and select List.

To view 2D graphs of the results stored in transient sensors, right-click the sensor icon under Sensors and select Graph.

Submodeling

For studies with a large number of bodies, the new submodeling feature allows you to improve the results at critical areas without having to rerun the analysis for the whole model. Refining the mesh for a selected portion of the model and rerunning the analysis only for the submodel saves computation time.

This functionality is available in SolidWorks Simulation Professional and above.

After you run your problem with a relatively coarse mesh, you may define a group of bodies in a submodel where stresses may not have been calculated accurately due to sharp corners, or geometric and load non-uniformities.

The mesh of the bodies inside the submodel is refined, and you can rerun the problem to improve results for the submodel only, without recalculating results for the rest of the model.

A submodeling study is derived from an eligible parent study. The parent study should meet these conditions to be eligible for a submodeling study:
The study type must be Static or Nonlinear static with more than one body and not be a submodeling study itself. The parent study cannot be a 2D Simplification Study.

The selected bodies that compose the submodel may not have **No penetration** contact with unselected bodies that result in contact pressure across the cut boundary.

The selected bodies that compose the submodel may not share connectors with unselected bodies.

![Unsuitable parent model for submodeling. All bodies are connected with bolts.](image)

**Submodeling Principles**

Submodeling is based on the St. Venant’s principle which states that the stresses reasonably distant from an applied load on a boundary are not significantly altered if this load is changed to a statically equivalent load. The distribution of stress and strain is altered only near the regions of load application.

You may cut a portion of the model and run analysis only for the selected portion provided that displacements are properly prescribed at the boundaries of the cut. If displacements at the boundaries of the cut are calculated accurately at the first run, then these displacements may be considered as boundary conditions for the submodel run.

The cut boundary of the submodel cannot cut through a bonded contact defined by either beam-to-beam joints or shell edge-to-shell edge joints.

The boundaries of the submodel must be adequately far from stress concentration areas.

**Submodeling Study for a Pressure Vessel**

You create a submodeling study based on the static analysis of a pressure vessel. The submodeling study contains only the supporting frame of the pressure vessel model. Then
you refine the solid mesh of the supporting frame and rerun the analysis to improve the accuracy of the results.

To open the model, go to `install_dir\samples\whatsnew\Submodeling\pressure_vessel.sldprt`.

Review the Ready Pressure study features:

- Applies a pressure of 100 psi on the inner faces of the tank.
- Defines a distributed mass of 700 lbs (for liquefied gas) inside the tank.
- Applies a gravity load.
- Applies four mesh controls.

**Creating the Submodeling Study**

You create a submodeling study that contains only the bodies of the supporting frame.

1. Run the Ready-Pressure study with the default mesh settings.
2. After the analysis completes, right-click Ready-Pressure and click Create Submodeling study.
3. From the list of bodies to include in the submodel, select the four supporting legs and four plates for a total of eight bodies.

4. Click \( \checkmark \).
   Study **Submodel-1** is created. The displacement field from the parent study is transferred to the submodel at the cut boundary.

**Meshing the Submodel and Running the Study**
You refine the mesh of the solid bodies to improve the accuracy of the results for the submodel.

You apply a fine solid mesh to the submodel using the curvature-based meshing scheme which automatically creates more elements in higher-curvature areas.
1. In the **Submodel-1** study, right-click **Mesh** and click **Create Mesh**.
2. Under **Mesh Density**, move the slider to **Fine**.
3. Under **Mesh Parameters**, select **Curvature based mesh**.
4. Under **Options**, select **Run (solve) the analysis**.
5. Click ✔.

**Viewing Results for the Submodel**

After running the submodeling study, you can plot results for the submodel only. In the submodeling study, open the von Mises stress plot of the submodel.

To compare results between the submodel and the parent study, activate the **Ready-Pressure** study and plot the desired result quantity.
This chapter includes the following topics:

- **Conic Curves**
- **Dimensions**

### Conic Curves

The **Conic** tool lets you sketch conic curves driven by endpoints and Rho value. Depending on the Rho value, the curve can be elliptical, parabolic, or hyperbolic.

In previous versions of the SolidWorks software, you could sketch ellipses and parabolas. However, you could not sketch ellipses or parabolas by their endpoints, so it was difficult to make them tangent to existing geometry.

Conic curves can reference existing sketch or model geometry, or they can be standalone entities. You can dimension the curve with a driving dimension, and the resulting dimension displays the Rho value. The conic entity also includes a value for the radius of curvature.
To create conic curves:

1. Open `install_dir\samples\whatsnew\sketching\conic.sldprt`. The model contains a sketched arc and spline.

2. Click **Conic** (Sketch toolbar) or **Tools > Sketch Entities > Conic**. The pointer changes to .

3. In the graphics area, click the first endpoint for the conic curve as shown.

4. Drag the pointer to the right so it is tangent with the arc.

Because the endpoint is attached to the existing arc sketch, a yellow inferencing line is displayed tangent to the sketch.
5. Click the second endpoint as shown.

6. Drag the pointer upwards.

A yellow inferencing line is displayed tangent to the spline sketch.

7. Drag the pointer out to the intersection of the two yellow inferencing lines.

You can snap to the intersection of both inference lines to choose the top vertex of the conic curve.

8. Click at the intersection of both inferencing lines to set the top vertex of the conic curve.

By selecting the intersection of both inferencing lines, you ensure that the conic curve is tangent at both endpoints.
9. Drag the pointer to the left until the Rho value is 0.75.

As you move the pointer, the conic curve's Rho value changes.

10. Click to set the Rho value to 0.75.

Reference points are displayed for the curve's shoulder and top vertex. Tangent relations are created between the curve and the original sketches.

Dimensions

You can automatically add dimensions to sketch entities if you type a dimension value while sketching the entity in the graphics area. Previously, you had to choose to add dimensions before sketching an entity.

Click **Tools > Options > System Options > Sketch**. Select **Enable on screen numeric input on entity creation** and **Create dimension only when value is entered** and click **OK**.

Slots are not supported.

**To add dimensions to sketch entities:**

1. Click **Options** (Standard toolbar) or **Tools > Options**.
2. On the System Options tab, click **Sketch**.
3. Select **Enable on screen numeric input on entity creation** and **Create dimension only when value is entered** and click **OK**.
4. Open a new sketch and click a sketch entity, such as **Corner Rectangle**.
5. Left-drag while sketching the rectangle. Do not release the mouse button.

Releasing the mouse button exits the input mode.
6. Type a value for the height dimension and press Enter.

7. Type a value for the width dimension and press Enter.

8. Release the mouse button.

The rectangle is dimensioned.
23
Sustainability

Available as a separately purchased product that can be used in SolidWorks Standard, SolidWorks Professional, or SolidWorks Premium.

This chapter includes the following topics:

- Environmental Impact of Painted Parts
- Exporting Settings for a SolidWorks Sustainability Study
- Financial Impact of Material Choices
- Improved Calculation Consistency
- TRACI Impact Assessment Methodology
- Selecting Units in the Find Similar Dialog Box

Environmental Impact of Painted Parts

When a part is painted, the surface area of the part is used to determine the amount of paint and the environmental impact of painting the part.

Using the Paint Options drop-down list in the Manufacturing section of the Sustainability task pane, you can indicate that a part has:

- No Paint
- Water-based Paint
- Solvent-based Paint

The change is immediately visible when you add or change the paint setting. For most parts, adding paint results in a relatively small change in the environmental impact.
Exporting Settings for a SolidWorks Sustainability Study

You can expand the Life Cycle Assessment (LCA) analysis of your products by saving the settings for a SolidWorks Sustainability study to the GaBi® Life Cycle Assessment Software (produced by PE INTERNATIONAL).

To save the settings:

1. At the bottom of the Environmental Impact section of the Sustainability task pane, click Save As.
2. In the Sustainability Output dialog box, for File type, select GaBi input file.
   The File name and Save file to fields default to the name and location of the part or assembly for which you are doing the Sustainability study.
3. Optionally, change the File name and save location.
   Do not add an extension to the file name. The software uses the correct extension (.xml) to save the file.
4. Click OK.

You can also use the Sustainability Output dialog box to:

- Generate Sustainability reports.
- Export the settings and results for a SolidWorks Sustainability study to a spreadsheet so that you can share this information without sharing the model.

Financial Impact of Material Choices

You can estimate the relative financial impact of your material choices based on the financial impact per unit mass associated with each material.

The material financial impact is the mass of the parts in the model multiplied by the financial impact property for each part material.

The SolidWorks materials database includes default financial impact values. When you select materials from the database, the financial impact of your choices is shown in the Environmental Impact section of the Sustainability task pane.

In the Find Similar Material dialog box, you can use the financial impact value as a search category to locate materials that meet your physical and environmental requirements with a lower cost impact.

If you use custom materials, you can add the Financial Impact property to assign values to the financial impacts of the materials.

Material financial impact in Sustainability is not related to SolidWorks Costing.
Viewing Financial Impact

To view the material financial impact of a single part:

1. Open a part and click **Tools > Sustainability**.
2. In the **Material** section of the Sustainability task pane, select the **Class** and **Name** of a material.
3. Click **Set Material**.
4. Expand the **Environmental Impact** dashboard.
   The material financial impact is shown near the bottom of the dashboard.

   ![Material Financial Impact](Image)

   If this is the first time you have selected a material for the part, there is no previous financial impact to compare to. Only the current financial impact can be shown.

5. In the **Material** section, choose a different material for the part and click **Set Material**.
   Since there are values to compare, SolidWorks Sustainability shows the percentage decrease or increase in cost.

   ![Material Financial Impact](Image)

6. To see the actual costs, mouse over the bars that show the financial impact change.
Using Find Similar to Reduce Costs

You can use the Find Similar dialog box to compare the financial impact of materials. Use this method to find materials with lower cost while assuring that other requirements such as elasticity or tensile strength are still met.

To find materials with lower financial impact:

1. In the graphics area, select the part whose cost you want to reduce.
2. In the Material section of the Sustainability task pane, click Find Similar.
3. In the Find Similar Material dialog box, set the required conditions and values for other material properties.
4. For Financial Impact, select < (less than).
5. On the right side of the Find Similar Material dialog box, click Find Similar.
   A list of results appears in the upper half of the dialog box.
6. In the results list, click the Material Financial Impact column head to sort the materials by financial impact.
7. In the sorted list, click on a material that has a lower cost and still meets your other material requirements.
   The Environmental Impact section updates to show the comparison of the environmental and financial impacts of your original choice and your new selection.
8. Repeat step 7 until you have identified an appropriate substitute for the original material.
9. Click Accept.
   The Find Similar Material dialog box closes and the selected material replaces the original in the Material section in the Sustainability task pane.
   When you calculate the study's results, the cost difference is factored in to the total financial impact.

Assigning Financial Impact to a Custom Material

If you use a custom material that is not defined in the SolidWorks database, you can add financial impact to the material's properties. You can also customize a SolidWorks material if you know that your cost for the material is different from the default cost.

To add a financial impact property to an existing custom material:

1. In the FeatureManager, expand the component for which you want to calculate financial impact.
2. Right-click ⌨️ and click Edit Material.
3. In the Material dialog box, expand Custom Materials and select the material whose financial impact you want to specify.
4. In the right pane, on the Custom tab, click Add.
5. For Property Name, type Financial Impact.

   Although the property is not case sensitive, you must use the words "Financial Impact."

6. For Value, type a positive number representing the cost of the material.
   Examples: 35, 63.67

   Letters, symbols, and punctuation marks other than "," or ",," are invalid. The
   Materials editor does not report an error, but the financial impact is not read into
   SolidWorks Sustainability and a tooltip in the Material Financial Impact section of
   the task pane reports that there is no financial impact data for the material.

7. For Units, type currency/measure.
   The default Units value for materials defined in the database is USD/kg, standing
   for United States dollars per kilograms.

8. Click Apply, and then click Close.

   When you assign the material to a part, the value is used to calculate the material financial
   impact.

### Improved Calculation Consistency

Improved algorithms and a more robust and flexible Life Cycle Inventory model make
sustainability calculations even more accurate.

### TRACI Impact Assessment Methodology

You can display SolidWorks Sustainability results that are determined using the Tool for
the Reduction and Assessment of Chemical and Other Environmental Impacts (TRACI)
impact assessment methodology.

Two impact assessment methodologies are available:

- **CML**
  
  This methodology was developed by the Center for Environmental Sciences (CML or
  Centre for Milieukunde, Leiden) at the University of Leiden, The Netherlands.

  CML is based on European regional conditions. For LCA studies outside of North America,
  the CML methodology is the most commonly-used set of environmental indicators used
  for Life Cycle Assessment (LCA).

- **TRACI**

  This methodology was developed by the United States Environmental Protection Agency.

  TRACI is based on regional conditions of the United States and can be used to accurately
  model North American LCA studies.

A drop-down list at the bottom of the **Environmental Impact** section of the Sustainability
task pane indicates whether TRACI or CML should be used to calculate results. Use this
control to change the impact assessment methodology.
# Units in the TRACI Methodology

TRACI uses different values for air acidification and water eutrophication compared to the CML methodology used in SolidWorks Sustainability.

<table>
<thead>
<tr>
<th>Damage Category</th>
<th>Unit</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Air Acidification</td>
<td>mol H+ e</td>
<td>The equivalent molar concentration of the hydrogen ion. Also referred to as the pH of a solution or the measure of the acidity or basicity of the solution.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>mol</strong> Refers to Moles, which are the SI units of amount of substance, equal to the quantity containing as many elementary units as there are atoms in 0.012 kg of carbon-12.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>H+</strong> Refers to ions of hydrogen</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>e</strong> An indicator for equivalence. Although many substances contribute to the acidity of the air, the amount of each acidifying substance in the air is scaled by an equivalence factor so that a single value can be reported.</td>
</tr>
</tbody>
</table>
### Using TRACI to Assess Sustainability

**To use the TRACI methodology to evaluate a study:**

1. Complete your inputs for Material, Manufacturing, Use, Transportation, and End of Life.
2. Expand the Environmental Impact dashboard and click Air. Note the current values.
3. At the bottom of the Sustainability task pane, expand the drop-down list box next to the Home button and select TRACI. The results are recalculated. The values are different because CML and TRACI use different units of measure.
4. Click Save As.
5. In the Sustainability Output dialog box, ensure that Report is selected for File type and click OK.

   The report cannot be generated if other Microsoft Word documents are open.

   The Sustainability report opens in Microsoft Word.

   The Environmental Impact section of the report states that it was calculated using TRACI impact assessment methodology. Values in this section of the report and the Component Environmental Impact section are given in TRACI units of measure.

<table>
<thead>
<tr>
<th>Damage Category</th>
<th>Unit</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Water Eutrophication</td>
<td>kg N e</td>
<td>The equivalent amount of nitrogen dissolved in water measured in kilograms. Water eutrophication occurs through the addition of artificial or natural substances, such as nitrates and phosphates, through fertilizers or sewage. Using an equivalence factor, TRACI summates these substances to provide a measure for water eutrophication using nitrogen equivalence.</td>
</tr>
</tbody>
</table>
Selecting Units in the Find Similar Dialog Box

You can change the units that are displayed for material properties in the Find Similar dialog box.

The options available are the same as those that are available when you edit a material using the SolidWorks Materials editor.

1. In the Material section of the Sustainability task pane, click Find Similar.
2. In the Find Similar Material dialog box, on the right side of the Environmental Impact section, expand the Units drop-down list to select from the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SI -N/m^2 (Pa)</td>
<td></td>
</tr>
<tr>
<td>English (IPS)</td>
<td>Inch, pound, second</td>
</tr>
<tr>
<td>Metric (MKS)</td>
<td>Meter, kilogram, second</td>
</tr>
<tr>
<td>SI -N/mn^2 (MPa)</td>
<td></td>
</tr>
</tbody>
</table>

The changes appear in the dialog box headers and in the materials list that appears when you initiate the search for similar materials.
This chapter includes the following topics:

- Limiting Export to Files in the Current Revision Scheme
- Vault Service Management

Limiting Export to Files in the Current Revision Scheme

When you export Workgroup PDM documents, the Export tool provides an option to export only documents that are in the current revision scheme. This makes it easier to migrate the vault to other PDM products.

When you select the **Export only document in current revision scheme** option, files that are not in the current revision scheme are skipped.

The Export tool displays a list of files whose revisions do not match the current scheme, including the project, date, revision number, and file size. If there are files with out-of-date revision schemes that you still want to export, you can select them to be included in the export.

Vault Service Management

You can manage the Workgroup PDM vault service without having to open the Microsoft Management console.

If the vault service is stopped when you log in to the VaultAdmin tool, a **Start Service** button appears in the SolidWorks Workgroup PDM 2013 VaultAdmin - Login dialog box. Click this button to start the service.

If you do not start the service, you can only access the Vault Management tab of the VaultAdmin tool when it opens.

The Vault Management tab contains controls that let you:

- Start or stop the vault service
- Specify a new vault directory
- Set validation on or off
- Rebuild the vault
- View vault memory usage and the vault log size and age