## Contents

Legal Notices...............................................................................................................11

1 Welcome to SOLIDWORKS 2015.................................................................14
   Highlights ............................................................................................................14
   Top Enhancements ...............................................................................................14
   For More Information ..........................................................................................16

2 User Interface ................................................................................................18
   Configurations Toolbar .......................................................................................18
   Customizing Context-Sensitive Toolbars .........................................................19
   Grouping Features in Favorites Folders ............................................................21
   Magnifying Glass Access ...................................................................................22
   Modify Dimensions ..............................................................................................22
   Saving and Restoring Settings ...........................................................................23
       Saving and Restoring Mouse Gestures .........................................................23
   Selection Enhancements .......................................................................................24
       Selection Context Toolbar ..............................................................................24
       Selection of Small Entities ...........................................................................25
       Selection Sets .................................................................................................25
   Setting Multiple Dimensions to Driven ...........................................................26
   Shortcut Menu Enhancements ............................................................................27
   SOLIDWORKS Add-ins CommandManager .....................................................27
   Status Bar Display of Cylinder Diameter .......................................................28
   Switching from Models to Drawings ...............................................................28
   Tools Menu Modifications .................................................................................28
   Visualization Tool for References .................................................................29

3 SOLIDWORKS Fundamentals......................................................................31
   2D Emulator ........................................................................................................31
   32-bit Operating Systems ....................................................................................31
   Add-in Load Times .............................................................................................31
   Application Programming Interface ...............................................................31
   Equation Performance .........................................................................................32
   Identify File Version ..........................................................................................33
   Using Intersection Zones in Section Views .......................................................33
   Open Model in Position .....................................................................................37
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pack and Go Adds Flow Simulation Files</td>
<td>37</td>
</tr>
<tr>
<td>Surface Curvature Combs</td>
<td>37</td>
</tr>
<tr>
<td>Viewing Surface Curvature Combs</td>
<td>37</td>
</tr>
<tr>
<td>Using Dynamic Surface Curvature Combs</td>
<td>38</td>
</tr>
<tr>
<td>Using the PropertyManager to View Curvature Combs</td>
<td>40</td>
</tr>
<tr>
<td>Task Pane Improvements</td>
<td>41</td>
</tr>
<tr>
<td>View Selector Preview</td>
<td>41</td>
</tr>
<tr>
<td><strong>4 Installation</strong></td>
<td>43</td>
</tr>
<tr>
<td>CircuitWorks Added to SOLIDWORKS Professional</td>
<td>43</td>
</tr>
<tr>
<td>Licensing Change for Enterprise PDM</td>
<td>43</td>
</tr>
<tr>
<td>SOLIDWORKS Inspection</td>
<td>43</td>
</tr>
<tr>
<td>SOLIDWORKS Sustainability Added to SOLIDWORKS Premium</td>
<td>43</td>
</tr>
<tr>
<td>Support for Multiple DVDs</td>
<td>44</td>
</tr>
<tr>
<td><strong>5 Assemblies</strong></td>
<td>45</td>
</tr>
<tr>
<td>Chain Pattern</td>
<td>45</td>
</tr>
<tr>
<td>Creating a Distance Linkage Chain Pattern</td>
<td>46</td>
</tr>
<tr>
<td>Creating a Connected Linkage Chain Pattern</td>
<td>47</td>
</tr>
<tr>
<td>Confirm Delete Dialog Box</td>
<td>49</td>
</tr>
<tr>
<td>Selectively Deleting Items in an Assembly</td>
<td>50</td>
</tr>
<tr>
<td>Deleting Subassemblies and Components of Subassemblies</td>
<td>50</td>
</tr>
<tr>
<td>Editing Limit Mate Values in the Graphics Area</td>
<td>50</td>
</tr>
<tr>
<td>Enhanced Performance when Hiding and Showing Components</td>
<td>51</td>
</tr>
<tr>
<td>Equations in Assemblies</td>
<td>51</td>
</tr>
<tr>
<td>Selecting by View</td>
<td>52</td>
</tr>
<tr>
<td>Exploded Views</td>
<td>52</td>
</tr>
<tr>
<td>Radial Explode</td>
<td>52</td>
</tr>
<tr>
<td>Intelligent Auto-Space in Chain-Step Exploded Views</td>
<td>53</td>
</tr>
<tr>
<td>Forming and Dissolving Subassemblies</td>
<td>54</td>
</tr>
<tr>
<td>Interference Detection</td>
<td>54</td>
</tr>
<tr>
<td>Isolate Components</td>
<td>55</td>
</tr>
<tr>
<td>Mates</td>
<td>55</td>
</tr>
<tr>
<td>Angle Mates</td>
<td>55</td>
</tr>
<tr>
<td>Copy with Mates</td>
<td>56</td>
</tr>
<tr>
<td>Globally Replace Failed Mate References</td>
<td>56</td>
</tr>
<tr>
<td>Mates in Configurations</td>
<td>57</td>
</tr>
<tr>
<td>Profile Center Mate</td>
<td>57</td>
</tr>
<tr>
<td>Symmetry Mates</td>
<td>59</td>
</tr>
<tr>
<td>Width Mates</td>
<td>59</td>
</tr>
<tr>
<td>Move Face in Assemblies</td>
<td>61</td>
</tr>
<tr>
<td>Open Summary Report Created When Opening Assemblies</td>
<td>61</td>
</tr>
</tbody>
</table>
Contents

Costing Template Improvements ........................................................................................................ 78
Custom Stock Bodies in Machined Parts ............................................................................................ 79

10 Drawings and Detailing .................................................................................................................. 80
Drawing Zones ................................................................................................................................. 80
  Defining Drawing Sheet Zones ....................................................................................................... 80
  Adding Zones to Annotations ......................................................................................................... 80
  Location Labels for Views ............................................................................................................. 81
  Revision Symbols Update Zone Information in Revision Tables .................................................. 83
Center Marks ..................................................................................................................................... 83
  Adding to a Center Mark Set ......................................................................................................... 83
  Reattaching Dangling Center Marks ............................................................................................ 84
Connection Lines .............................................................................................................................. 84
Centerlines ........................................................................................................................................ 84
Dimensions ........................................................................................................................................ 84
  Decimal Rounding ........................................................................................................................ 84
  Enhanced Angle Dimension Capabilities ..................................................................................... 86
  Hide Zero Value Angle Dimension Units .................................................................................... 88
  Symmetrical Angular Dimension .................................................................................................. 88
Drawing Views .................................................................................................................................... 89
  Slice Section View for Surface Bodies ........................................................................................ 89
  Zoom to Sheet .............................................................................................................................. 89
Layers ................................................................................................................................................ 90
  Layers Dialog Box ........................................................................................................................ 90
  Omit Layers from Print ................................................................................................................ 90
Model Detailing .................................................................................................................................. 91
  Hide or Show Annotations in Assemblies ................................................................................... 91
  Quickly Apply Annotation Views ................................................................................................. 91
  Reference Dimensions ................................................................................................................ 92
Notes and Balloons ........................................................................................................................... 94
  Feedback for Balloon Asterisks .................................................................................................. 94
Paragraph Properties ....................................................................................................................... 95
Spline Leader ...................................................................................................................................... 96
Spotface Symbol ................................................................................................................................ 97
Tables ................................................................................................................................................ 97
  Horizontal Auto Split .................................................................................................................. 97
  Item Numbers in a BOM Table ..................................................................................................... 97
  Revision Symbols ......................................................................................................................... 98
  Revision Tables ........................................................................................................................... 98
Sorting in a BOM ............................................................................................................................... 98
Table Editing Improvements ........................................................................................................... 98
Table Response Time ....................................................................................................................... 99
### Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Other</td>
<td>99</td>
</tr>
<tr>
<td>New Sheet Formats</td>
<td>99</td>
</tr>
<tr>
<td>Performance Options</td>
<td>99</td>
</tr>
<tr>
<td><strong>11 eDrawings</strong></td>
<td>100</td>
</tr>
<tr>
<td>3D Views</td>
<td>100</td>
</tr>
<tr>
<td>Annotation Views</td>
<td>100</td>
</tr>
<tr>
<td>Mass Properties</td>
<td>101</td>
</tr>
<tr>
<td>eDrawings Support for SOLIDWORKS Plastics Result Plots</td>
<td>102</td>
</tr>
<tr>
<td>Named Views</td>
<td>102</td>
</tr>
<tr>
<td>Query Highlighting</td>
<td>102</td>
</tr>
<tr>
<td>Updated User Interface</td>
<td>102</td>
</tr>
<tr>
<td><strong>12 SOLIDWORKS Electrical</strong></td>
<td>104</td>
</tr>
<tr>
<td>Advanced Environmental Archives</td>
<td>104</td>
</tr>
<tr>
<td>Dynamic Connector Tool</td>
<td>104</td>
</tr>
<tr>
<td>Enhanced Formula Manager</td>
<td>105</td>
</tr>
<tr>
<td>Importing and Exporting Data from Microsoft Excel</td>
<td>105</td>
</tr>
<tr>
<td>Inline Routing Diagnostics</td>
<td>105</td>
</tr>
<tr>
<td>Managing User Rights</td>
<td>106</td>
</tr>
<tr>
<td>Multipart Association to Symbol</td>
<td>106</td>
</tr>
<tr>
<td>Populate Spreadsheet with BOM Data</td>
<td>106</td>
</tr>
<tr>
<td>Set Component Status to Permanent or Non-permanent</td>
<td>106</td>
</tr>
<tr>
<td>Support for the 2013 Version of DXF/DWG files</td>
<td>106</td>
</tr>
<tr>
<td>User Interface - Additional Enhancements</td>
<td>107</td>
</tr>
<tr>
<td>Varied Line Width in Schematic</td>
<td>107</td>
</tr>
<tr>
<td>XML Export</td>
<td>107</td>
</tr>
<tr>
<td><strong>13 SOLIDWORKS Enterprise PDM</strong></td>
<td>108</td>
</tr>
<tr>
<td>Copy Tree Enhancements</td>
<td>108</td>
</tr>
<tr>
<td>Copy Tree Filter Display Control</td>
<td>110</td>
</tr>
<tr>
<td>Duplicate File Name Warnings</td>
<td>111</td>
</tr>
<tr>
<td>Microsoft® Office Add-in</td>
<td>112</td>
</tr>
<tr>
<td>Move Tree</td>
<td>113</td>
</tr>
<tr>
<td>Move Tree Filter Display Control</td>
<td>115</td>
</tr>
<tr>
<td>Moving a File Structure to Multiple Folders</td>
<td>116</td>
</tr>
<tr>
<td>Parallel Approval Data Mapping</td>
<td>116</td>
</tr>
<tr>
<td>Predefined Transition Action Comments</td>
<td>117</td>
</tr>
<tr>
<td>Rollback Enhancements</td>
<td>117</td>
</tr>
<tr>
<td>Separate Move and Delete Permissions</td>
<td>120</td>
</tr>
<tr>
<td>SolidNetWork License Manager</td>
<td>121</td>
</tr>
<tr>
<td>User Interface Changes</td>
<td>122</td>
</tr>
<tr>
<td>Quick Info Icons for File Lists</td>
<td>122</td>
</tr>
</tbody>
</table>
22 Sheet Metal ................................................................. 194
  Lofted Bends ............................................................... 194
  Mirrored Parts and Components ............................... 196
  Sheet Metal Gussets .................................................... 197
  Sketched Bends ........................................................... 197

23 SOLIDWORKS Simulation ............................................ 198
  Contact ....................................................................... 198
    Edge-to-Edge Bonding for Shells ............................... 198
    Self-contact Detection ............................................. 199
  Fatigue ....................................................................... 199
    Defining Fatigue based on Harmonic Results .............. 200
    Creating a Fatigue Study Based on Random Vibration Results ........................................................................... 201
  Frequency Analysis Graphs ......................................... 202
  Loads ......................................................................... 202
    Load Case Manager for Static Studies ......................... 202
    Prescribed Displacement as Force ............................. 203
    Cylindrical and Spherical Coordinates for Nonuniform Force and Pressure .................................................. 203
  Materials ...................................................................... 204
  Mesh .......................................................................... 204
  Nonlinear .................................................................... 205
    Intermediate Results in Nonlinear Analysis ............... 205
    Cyclic Symmetry for Nonlinear Studies .................... 206
  Performance .................................................................. 207
    Running Specified Studies ........................................ 208
  Shells ......................................................................... 208
    Shell Manager ......................................................... 208
    Flipping Shell Faces ................................................ 210
  Simulation Results for the Colorblind ......................... 210

24 Sketching .................................................................... 211
  Adding Centerlines to Rectangles ............................... 211
  Blocks Retain Sketch Relations .................................... 212
  Continuity Relations for Tangency and Equal Curvature ................................................................. 212
  Converting Spline Types ............................................. 213
  Equidistant Points and Segments .............................. 213
  Horizontal and Vertical Sketch Relations ................... 214
  Midpoint Line ............................................................. 215
Legal Notices

© 1995-2015, Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes SE company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of the license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the license agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SOLIDWORKS® 3D mechanical CAD software is protected by U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; 8,581,902; 8,817,028; 8,910,078; 9,129,083; 9,153,072; and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademark and Product Names for SOLIDWORKS Products and Services

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360, and TolAnalyst are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of Geometric Ltd.


Other brand or product names are trademarks or registered trademarks of their respective holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of “commercial computer software” and “commercial software documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government (a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in
48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the Department of Defense, consistent with the policies set forth in 48 C.F.R. 227.7202-1 (JUN 1995) and 227.7202-4 (JUN 1995).

In the event that you receive a request from any agency of the U.S. Government to provide Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope of the request and DS SolidWorks will have five (5) business days to, in its sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SOLIDWORKS Standard, Premium, Professional, and Education Products

Portions of this software © 1986-2015 Siemens Product Lifecycle Management Software Inc. All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:


Portions of this software © 1998-2015 Geometric Ltd.
Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.
Portions of this software © 2001-2015 Luxology, LLC. All rights reserved, patents pending.
Portions of this software © 2007-2015 DriveWorks Ltd.
Copyright 1984-2010 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SOLIDWORKS.

Copyright Notices for SOLIDWORKS Simulation Products

Portions of this software © 2008 Solverossoft Corporation.
PCGLSS © 1992-2013 Computational Applications and System Integration, Inc. All rights reserved.

Copyright Notices for SOLIDWORKS Enterprise PDM Product

Outside In® Viewer Technology, © 1992-2012 Oracle
© 2011, Microsoft Corporation. All rights reserved.

Copyright Notices for eDrawings Products

Portions of this software © 2000-2014 Tech Soft 3D.
Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.
Portions of this software © 1998-2001 3Dconnexion.
Portions of this software © 1998-2014 Open Design Alliance. All rights reserved.
Portions of this software © 1995-2012 Spatial Corporation.
The eDrawings® for Windows® software is based in part on the work of the Independent JPEG Group.
Welcome to SOLIDWORKS 2015

This chapter includes the following topics:

- **Highlights**
- **Top Enhancements**
- **For More Information**

### Highlights

SOLIDWORKS® 2015 includes many enhancements and improvements, most in direct response to customer requests. This release focuses on the following themes:

- **Improve everyday productivity**: Improved engineering and design performance to make your job faster and easier.
- **Optimize your work process**: Share information seamlessly and globally with minimal effort.
- **Reduce production and operations costs**: Bring design and operations closer together.
- **Expand the markets you serve**: New applications let you expand the markets you serve.

### Top Enhancements

The top enhancements for SOLIDWORKS 2015 provide improvements to existing products and innovative new functionality.

Throughout this guide, look for the symbol in these areas:
<table>
<thead>
<tr>
<th>Section</th>
<th>Page References</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>User Interface</strong></td>
<td></td>
</tr>
<tr>
<td>Customizing Context-Sensitive Toolbars</td>
<td>on page 19</td>
</tr>
<tr>
<td>Selection Sets</td>
<td>on page 25</td>
</tr>
<tr>
<td>Visualization Tool for References</td>
<td>on page 29</td>
</tr>
<tr>
<td><strong>SOLIDWORKS Fundamentals</strong></td>
<td></td>
</tr>
<tr>
<td>Surface Curvature Combs</td>
<td>on page 37</td>
</tr>
<tr>
<td><strong>Assemblies</strong></td>
<td></td>
</tr>
<tr>
<td>Chain Pattern</td>
<td>on page 45</td>
</tr>
<tr>
<td>Profile Center Mate</td>
<td>on page 57</td>
</tr>
<tr>
<td>Radial Explode</td>
<td>on page 52</td>
</tr>
<tr>
<td>Using Intersection Zones in Section Views</td>
<td>on page 33</td>
</tr>
<tr>
<td>Width Mates</td>
<td>on page 59</td>
</tr>
<tr>
<td><strong>CircuitWorks</strong></td>
<td></td>
</tr>
<tr>
<td>Selecting Entities in the CircuitWorks Preview</td>
<td>on page 67</td>
</tr>
<tr>
<td><strong>SOLIDWORKS Costing</strong></td>
<td></td>
</tr>
<tr>
<td>Costing for 3D Printing</td>
<td>on page 74</td>
</tr>
<tr>
<td>Costing for Casting</td>
<td>on page 75</td>
</tr>
<tr>
<td>Costing for Plastic</td>
<td>on page 75</td>
</tr>
<tr>
<td>Costing for Weldments</td>
<td>on page 75</td>
</tr>
<tr>
<td><strong>Drawings and Detailing</strong></td>
<td></td>
</tr>
<tr>
<td>Drawing Zones</td>
<td>on page 80</td>
</tr>
<tr>
<td>Enhanced Angle Dimension Capabilities</td>
<td>on page 86</td>
</tr>
<tr>
<td>Paragraph Properties</td>
<td>on page 95</td>
</tr>
<tr>
<td>Spline Leader</td>
<td>on page 96</td>
</tr>
<tr>
<td><strong>SOLIDWORKS Electrical</strong></td>
<td></td>
</tr>
<tr>
<td>Dynamic Connector Tool</td>
<td>on page 104</td>
</tr>
<tr>
<td>Managing User Rights</td>
<td>on page 106</td>
</tr>
<tr>
<td><strong>SOLIDWORKS Enterprise PDM</strong></td>
<td></td>
</tr>
<tr>
<td>Copy Tree Enhancements</td>
<td>on page 108</td>
</tr>
<tr>
<td>Duplicate File Name Warnings</td>
<td></td>
</tr>
<tr>
<td>Move Tree</td>
<td>on page 113</td>
</tr>
<tr>
<td>Parallel Approval Data Mapping</td>
<td>on page 116</td>
</tr>
<tr>
<td>Predefined Transition Action Comments</td>
<td>on page 117</td>
</tr>
<tr>
<td>Rollback Enhancements</td>
<td>on page 119</td>
</tr>
<tr>
<td>Separate Move and Delete Permissions</td>
<td>on page 120</td>
</tr>
<tr>
<td>Version Number Column in Windows Explorer</td>
<td>on page 124</td>
</tr>
<tr>
<td>Visibility of Private State Files</td>
<td>on page 126</td>
</tr>
</tbody>
</table>
Welcome to SOLIDWORKS 2015

Import/Export

- **3D Printing** on page 134

Parts and Features

- **Controlling Linear Patterns with Reference Geometry** on page 165
- **Flattening Surfaces** on page 158
- **Move Face** on page 160
- **Variable Patterns** on page 172

Plastics

- **eDrawings Support for SOLIDWORKS Plastics Result Plots** on page 102
- **Nominal Wall Thickness Advisor** on page 184
- **Symmetry Analysis** on page 185

Routing

- **Reusing Electrical Route Assemblies** on page 190
- **Support for Square and Rectangular Sections** on page 193

Sheet Metal

- **Lofted Bends** on page 194

SOLIDWORKS Simulation

- **Cyclic Symmetry for Nonlinear Studies** on page 206
- **Cylindrical and Spherical Coordinates for Nonuniform Force and Pressure** on page 203
- **Fatigue** on page 199
- **Intermediate Results in Nonlinear Analysis** on page 205
- **Load Case Manager for Static Studies** on page 202
- **Running Specified Studies** on page 208
- **Shell Manager** on page 208

Sketching

- **Midpoint Line** on page 215

SOLIDWORKS Toolbox

- **Customized Configuration Names** on page 221

Weldments

- **Gusset Enhancements** on page 227
- **Internal End Caps** on page 229

---

All features are available in SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium unless otherwise noted.

For More Information

Use the following resources to learn about SOLIDWORKS:
What's New in PDF and HTML

This guide is available in PDF and HTML formats. Click:
• Help > What's New > PDF
• Help > What's New > HTML

Interactive What's New

In SOLIDWORKS, click the symbol to display the section of this manual that describes an enhancement. The symbol appears next to new menu items and the titles of new and changed PropertyManagers.

To enable Interactive What's New, click Help > What's New > Interactive.

What's New Examples

What's New Examples are updated at every major release to provide examples of how to use most top enhancements in the release.

To open What's New Examples click Help > What's New > What's New Examples.

Online Help

Contains complete coverage of our products, including details about the user interface, samples, and examples.

Release Notes

Provides information about late changes to our products, including changes to the What's New book, online help, and other documentation.
User Interface

This chapter includes the following topics:

- Configurations Toolbar
- Customizing Context-Sensitive Toolbars
- Grouping Features in Favorites Folders
- Magnifying Glass Access
- Modify Dimensions
- Saving and Restoring Settings
- Selection Enhancements
- Setting Multiple Dimensions to Driven
- Shortcut Menu Enhancements
- SOLIDWORKS Add-ins CommandManager
- Status Bar Display of Cylinder Diameter
- Switching from Models to Drawings
- Tools Menu Modifications
- Visualization Tool for References

Configurations Toolbar

With the Configurations toolbar, you can switch configurations without changing tabs in the FeatureManager® design tree or using the Specify Configurations dialog box.

The Configurations toolbar provides a drop-down list of the model's configurations.
To display the toolbar, click **Tools > Customize**. On the Toolbars tab of the Customize dialog box, select **Configurations**.

As with other toolbars, you can detach the Configurations toolbar and place it anywhere in the graphics area or on a second monitor.

**Customizing Context-Sensitive Toolbars**

To make it easier to access commands you use frequently, you can add toolbar buttons to the context toolbars that appear when you select features in the graphics area or FeatureManager design tree.

**To customize context-sensitive toolbars:**

1. Select a feature in the graphics area or FeatureManager design tree.
2. Right-click the context toolbar that appears and click **Customize**.

The Customize dialog box opens to the Commands tab.

Below the **Buttons** area on the right side of the dialog box, a box appears with the default context toolbar buttons shown as unavailable. You cannot remove or reorder the default buttons.

The label of the box indicates whether you displayed the context toolbar from the FeatureManager design tree or the graphics area.
3. Select a command category.

4. Under **Buttons**, drag a toolbar button to the toolbar. The software places the button after the default buttons.

5. Drag additional buttons to the toolbar.

   The I pointer lets you control the button placement.

   If you add more than eight buttons, the added buttons automatically wrap to the next line.

6. To remove a toolbar button you have added, drag it off the context-sensitive toolbar.

7. Click **OK**.

8. To access the newly added buttons, click a feature in the location – graphics area or FeatureManager design tree – where you initiated the customization.
Grouping Features in Favorites Folders

To provide easy access to features such as cuts, holes, and chamfers, you can group them in a subfolder in the Favorites folder.

You move process-specific features to the Favorites folder and then group them by adding them to a new Favorites subfolder and giving the subfolder a custom name.

For example, to allow for proper weld dimensions and the strongest possible weld penetration, you can specify a weld gap in the Trim/Extend features that you add to a weldment part. You can group these features in a Trim/Extend subfolder for quick visual access, to create configurations, and to check your design.

You can also group components by putting them in a subfolder of the Favorites folder in the assembly.

To group features in Favorites folders:

1. In the FeatureManager design tree, right-click the part and click Hide/Show Tree Items.
2. In the dialog box, under Hide/show tree items, set Favorites to Show and click OK.
3. Select features to group, right-click and click Add to Favorites.
4. Expand Favorites.
5. Select the features again, right-click and click Add to New Favorite Folder.
6. Rename the new folder to identify the features it contains.

To remove a feature from the subfolder or to remove the entire subfolder, right-click and click Remove from Favorites.

To reorder subfolders in the Favorites folder, select the subfolder and drag it towards its new location. The pointer changes to indicating the new location of the subfolder.

To remove a feature from the subfolder or to remove the entire subfolder, right-click and click Remove from Favorites.
Magnifying Glass Access

The **Tools** menu and the **Select** flyout menu on the Standard toolbar include the **Magnified Selection** tool, which displays the magnifying glass tool.

The tool is also available on the context toolbar that appears when you right-click an empty space in the graphics area.

The magnifying glass, which you can also display using the **G** shortcut key, gives a magnified view of a section of a model so you can inspect the model and make selections without changing the overall view.

You can add the **Magnified Selection** tool to other toolbars, such as the Heads-Up View toolbar, by clicking **Tools > Customize**. On the Commands tab, in **Categories**, select **Standard** and drag the tool button to the toolbar where you want to add it.

![Select flyout menu](image1.png)  ![Select context toolbar](image2.png)

The magnifying glass is disabled if **Use software OpenGL** is selected in **Tools > Options > Performance**. **Use software OpenGL** is selected by default if you access the SOLIDWORKS software remotely.

Modify Dimensions

When you modify a dimension, the type-ahead drop-down list no longer displays numerical values you have previously used.

Since previously used numerical values are often inappropriate, they no longer appear. Values such as global variables, dimensions, and features that start with an alphabetic character are still included as suggested values because they provide quick access to global variables.
Saving and Restoring Settings

You can use the **Save/Restore Settings** command to invoke the Copy Settings Wizard from within SOLIDWORKS when files are open.

Previously **Save/Restore Settings** was only available when all files were closed.

To invoke the Copy Settings Wizard to save or restore settings, do one of the following:

- Click **Tools > Save/Restore Settings**.
- Click the **Options** flyout tool button (Standard toolbar) and click **Save/Restore Settings**.
- On the SOLIDWORKS Resources tab of the Task Pane, under **SOLIDWORKS Tools**, click **Copy Settings Wizard** 🎨.

In the SOLIDWORKS Copy Settings Wizard, select **Save Settings** or **Restore Settings**.

**Saving and Restoring Mouse Gestures**

The Copy Settings Wizard lets you save and restore mouse gestures independently of system options.

Previously, mouse gestures were only saved and restored when you selected to save or restore system settings.

**To save mouse gestures:**

1. Click **Tools > Save/Restore Settings**.
2. In the SOLIDWORKS Copy Settings Wizard, select **Save Settings** and click **Next**.
3. On the Save Settings to File screen, select the location and name for the settings file.
4. Click **Mouse Gestures** and click **Finish**.

**To restore mouse gestures:**

1. Click **Tools > Save/Restore Settings**.
2. In the SOLIDWORKS Copy Settings Wizard, select **Restore Settings** and click **Next**.
3. On the Restore Settings from File screen, select the settings file to restore.
4. Click **Mouse Gestures** and click **Next**.
5. Click **Finish**.

### Selection Enhancements

**Selection Context Toolbar**

When you right-click an empty space in the graphics area of a part or assembly, a selection context toolbar above the shortcut menu provides easy access to the most commonly used selection tools.

The toolbar includes the **Previous Selection** tool, which restores the last set of entities you selected in the current editing session. For example, if you used **Ctrl** to select a series of entities and accidentally clear the selection, clicking **Previous Selection** will restore it.

The options available are:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Box Selection" /></td>
<td>Lets you select entities in parts, assemblies, and drawings by dragging a selection box with the pointer.</td>
</tr>
<tr>
<td><img src="image" alt="Lasso Selection" /></td>
<td>Lets you select entities by drawing a lasso around the entities.</td>
</tr>
<tr>
<td><img src="image" alt="Selection Filters" /></td>
<td>Displays a list of selection filter commands.</td>
</tr>
<tr>
<td><img src="image" alt="Previous Selection" /></td>
<td>Re-selects the last entities you selected. Only available if you made a selection during this editing session.</td>
</tr>
<tr>
<td><img src="image" alt="Select Other" /></td>
<td>Displays the Select Other dialog box.</td>
</tr>
<tr>
<td><img src="image" alt="Select" /></td>
<td>Displays a list of selection commands.</td>
</tr>
<tr>
<td><img src="image" alt="Magnified Selection" /></td>
<td>Displays the magnifying glass, which gives you a magnified view of a section of a model.</td>
</tr>
</tbody>
</table>
**Selection of Small Entities**

New selection paradigms make it easier to select small entities without having to zoom or use selection filters.

When you make repeated small mouse movements as you try to select an edge or face, the software switches to a more precise selection method. When your mouse movements become large again, the software returns to the selection method used in previous SOLIDWORKS versions.

To prevent the new selection method from being used, click **Tools > Options > Display/Selection** and clear **Enhance small face selection precision**.

**Selection Sets**

You can select multiple entities in a model or drawing and save the selections as a selection set that you can return to at any time.

When you create a selection set, it is saved in the **Selection Sets** folder in the FeatureManager design tree.

Automatic display of the **Selection Sets** folder is enabled in **Tools > Options > System Options > FeatureManager** under **Hide/show tree items**.

**Creating Selection Sets**

Your options for saving a selection set depend on whether you are working in a part or an assembly.

In a part, **Save Selection** is available at the top of the context-sensitive shortcut menu, and under **Features**.

In an assembly, **Save Selection** is also available under **Components**.

Where you choose **Save Selection** determines the display of the saved selections in the FeatureManager design tree:
To create selection sets:

1. Select items in the model.
2. Right-click and click **Save Selection**.

   The **Selection Sets** folder appears in the FeatureManager design tree, containing the selection set.

   By default, the selection set is named in the following format:

   \[
   \text{Selection-Set}n(nn)
   \]

   where:

   - \(n\) indicates the order of creation. This number increments as you add new selection sets.
   - \(nn\) indicates the number of items in the selection set.

Removing Selections and Selection Sets

You can remove individual selections from selection sets or remove an entire selection set from the **Selection Sets** folder.

To remove selections from selection sets:

1. In the FeatureManager design tree, expand **Selection Sets** and the selection set you want to modify.
2. Right-click the selection to remove and click **Remove from Selection Set**.

To remove selection sets from the **Selection Sets** folder:

1. Expand **Selection Sets**.
2. Right-click the selection set and click **Remove Selection Set**.

Setting Multiple Dimensions to Driven

When you select multiple dimensions, the **Driven** option on the shortcut menu lets you set the dimensions to driven.

In previous versions of SOLIDWORKS, you could only set multiple dimensions to driven using the Other tab in the Dimension PropertyManager.
Shortcut Menu Enhancements

Simplified shortcut menus are displayed when you right-click in a sketch. This reduces the menu complexity while still providing access to all choices that were previously available.

When you edit sketches and sketch entities:

• Flyout menus have been added to the shortcut menu.

• Less frequently used commands have been moved to the long form of the shortcut menus, which displays when you click at the bottom of the menu.

You can customize the menus to return these commands to the shorter form of the menu.

SOLIDWORKS Add-ins CommandManager

In SOLIDWORKS 2015, the SOLIDWORKS Add-ins CommandManager replaces the Office Products CommandManager from previous SOLIDWORKS versions.

The following products from the Office Products CommandManager are available on the SOLIDWORKS Add-ins CommandManager:

• CircuitWorks
• PhotoView 360
• ScanTo3D
• SOLIDWORKS Motion
• SOLIDWORKS Routing
• SOLIDWORKS Simulation
• SOLIDWORKS Toolbox
• TolAnalyst

In addition, the SOLIDWORKS Add-ins CommandManager includes:
• SOLIDWORKS Flow Simulation
• SOLIDWORKS Plastics
• SOLIDWORKS Inspection (new in SOLIDWORKS 2015)

Status Bar Display of Cylinder Diameter

To quickly see the diameter of a cylinder, select it and view the diameter in the status bar.

Switching from Models to Drawings

You can quickly switch from a part or assembly to an associated drawing using the **Open Drawing** command on shortcut menus and context toolbars.

When there is more than one open and unsaved drawing for a model, a dialog box lets you display the Open Documents browser to select the drawing to activate.

Tools Menu Modifications

The **Tools** menu now contains some add-in menus. It also groups Xpress products and SOLIDWORKS applications for easier access.

Add-ins

Some add-ins that were accessed from the main menu in previous versions of SOLIDWORKS are now accessed from the **Tools** menu.

The following add-ins are affected:

• CircuitWorks
• Routing
• SOLIDWORKS Plastics
• Toolbox
Third-party add-ins accessed from the main menu in previous versions of SOLIDWORKS are also now accessed from the **Tools** menu. Any new third-party add-in that attempts to create a menu on the main menu will now appear on the **Tools** menu.

### Xpress Products

Products moved to the **Tools > Xpress Products** menu include:

- DriveWorksXpress
- SimulationXpress
- FloXpress
- SustainabilityXpress
- DFMXpress

### SOLIDWORKS Applications

Products moved to the **Tools > SOLIDWORKS Applications** menu include:

- SOLIDWORKS Explorer
- Part Reviewer
- Costing
- Sustainability

### Visualization Tool for References

To quickly view feature dependencies, you can display graphical relationships between items in the FeatureManager design tree.

Dynamic reference visualization lets you view the parent relationships between items in the FeatureManager design tree. When you hover over a feature with references in the FeatureManager design tree, arrows display showing the relationships.

If a reference cannot be shown because a feature is not expanded, the arrow points to the feature that contains the reference and the actual reference appears in a text box to the right of the arrow.
Dynamic reference visualization is enabled by default.
To turn it off, in the FeatureManager design tree, right-click the first item (part or assembly) and clear Dynamic Reference Visualization on the context toolbar in the shortcut menu.
This chapter includes the following topics:

- **2D Emulator**
- **32-bit Operating Systems**
- **Add-in Load Times**
- **Application Programming Interface**
- **Equation Performance**
- **Identify File Version**
- **Using Intersection Zones in Section Views**
- **Open Model in Position**
- **Pack and Go Adds Flow Simulation Files**
- **Surface Curvature Combs**
- **Task Pane Improvements**
- **View Selector Preview**

**2D Emulator**

The SOLIDWORKS software no longer supports the 2D Emulator add-in.

**32-bit Operating Systems**

The SOLIDWORKS software no longer supports 32-bit operating systems, with the exception of the Enterprise PDM Editor Contributor and Viewer clients.

**Add-in Load Times**

The Add-Ins dialog box displays the amount of time it took to load add-ins the last time you started up the SOLIDWORKS software.

This information is helpful in deciding whether you want to load specific add-ins at start-up.

Click **Tools > Add-Ins** to see the **Last Load Time** for each add-in.

**Application Programming Interface**

See **SOLIDWORKS 2015 API Help Release Notes** for late-breaking updates.

SOLIDWORKS 2015 includes the ability to:

- Access the ISafeArrayUtility interface.
- Access scenes.
• Insert a table-driven pattern feature.
• Get or set pattern elements.
• Specify offsets when inserting a linear-pattern feature.
• Get or set sunlight advanced properties, get the length of the day for the current sunlight, and update sunlight.
• Get or set the components and transforms for interferences.
• Specify more document printing options.
• Get or set how to replace components when keeping missing items in BOM features.
• Get or set the display states in which a specified appearance is applied, get the appearances applied in specified display states, and get whether a model, component, face, body, or feature has an appearance.
• Create and access local curve- and sketch-driven patterns.
• Get type of body folder cut list.
• Specify more options when mirroring components in an assembly.
• Add a width mate to an assembly.
• Specify whether to print a specified layer when printing a drawing document.
• Get a feature's folder.
• Move a feature to another location in the FeatureManager design tree of a part or assembly.
• Specify whether to unlock configurations when moving the freeze bar.
• Get or set whether to display rebuild indicators on parts that have out-of-date frozen features.
• Get all of the bodies that result from splitting a part.
• Modify a split-body feature by changing its split bodies.
• Specify more options when editing a mate in an assembly.
• Get or set whether to scale draft edges when printing drawings in high quality.
• Specify the type of decimal rounding in display dimensions.
• Support for intersect features.
• Support for extracting Scanto3D information.
• Specify whether to keep or delete bodies in a multibody part.
• Access 3D Views in parts and assemblies.
• Get the position of a menu item in the SOLIDWORKS menu bar.
• Divide a sketch segment into equally spaced sketch segments or points.
• Get the display dimension object for a specified pattern property or a sketch relation.
• Get the sketch segments that define the path of a structural member body.
• Specify more properties when creating a weldment gusset.
• Specify more properties when creating a structural member end cap.
• Access asymmetric fillets.
• Specify more properties when creating cosmetic threads.
• Modify variable-pitch helix features.

Equation Performance

Equation solving performance is improved, especially in cases where the equations in the set depend upon one another.

See **Equations in Assemblies** on page 51.
Identify File Version

You can identify the SOLIDWORKS version that files were last saved in from within the software, SOLIDWORKS Explorer, Enterprise PDM and Windows® Explorer.

You can access the file version from SOLIDWORKS Explorer, Enterprise PDM file properties, and from File > Properties in an open SOLIDWORKS document. The version is also visible in the Details pane in Windows Explorer when you select a SOLIDWORKS document.

Using Intersection Zones in Section Views

You can create section views in a model by cutting away multiple areas of the model. These multiple areas are defined by “intersection zones.”

When you select section planes or faces, the bounding box of your selections is the intersection zone. You can use the intersection zones to create a section view of multiple areas of a model.

To use intersection zones in section views:

1. Open install_dir\samples\whatsnew\assemblies\intersection_zones\gearbox.sldasm.
2. Click Section View (View toolbar) or View > Display > Section View.
3. In the PropertyManager, under Section Method, select Zonal.
4. Under Section 1:
   a) Click Front Plane.
   b) For Offset Distance, enter 0.
   c) Select Show section cap and Graphics-only section.
5. Under Section 2:
   a) Click Top Plane.
   b) For Offset Distance, enter 0.
6. Under Section 3:
   a) Click Right Plane.
   b) For Offset Distance, enter 0.
7. Under Section Method, click in Intersection Zones. Shaded intersection zones display in the graphics area.
8. In the graphics area, select the lower left and upper right intersection zones shown.
9. Click ✓.
10. Change the view orientation to **Front (Ctrl + 1)**.

11. Zoom to the area shown and notice the single point contact along the centerline of the shaft.

12. Press **F**, or click **Zoom to Fit**.

---

**SOLIDWORKS Fundamentals**
13. In the open graphics area, right-click and click **Section View Properties**.
14. In the PropertyManager, clear **Graphics-only section**.

15. Click ✓.
16. In the task dialog box, select **Automatically resolve the issue and create the section view**.
17. Change the view orientation to **Front** (Ctrl + 1).
18. Zoom to the area shown and notice the single point contact no longer exists along the centerline of the shaft.

19. The section planes that created the section view have been shifted slightly to remove the single point contact that caused a zero-thickness geometry error.
Open Model in Position

When you open a part or subassembly from an assembly or drawing document, you can open the model in the same view position and orientation as seen in the assembly or drawing view.

Do one of the following:

- In a drawing, to open a model in position, right-click the part or subassembly in the FeatureManager design tree or the graphics area and select **Open Assembly In Position** or **Open Part In Position** from the context toolbar.
- In an assembly, left-click or right-click the part or subassembly in the FeatureManager design tree or the graphics area and select **Open Assembly In Position** or **Open Part In Position** from the context toolbar.

Pack and Go Adds Flow Simulation Files

You can include files from SOLIDWORKS Flow Simulation in Pack and Go.

This option lets you include more simulation file types when you select files for Pack and Go.

Surface Curvature Combs

You can display curvature combs on model surfaces to analyze how adjacent surfaces join and transition.

The **Surface Curvature Combs** tool evaluates curvature quality and smoothness. It displays U and V mapping lines in a graphical display across face boundaries. The tool looks for curvature constraints and extends curvature combs across adjacent faces. The length of each spine on the comb is proportional to the amount of curvature at the point. The spines are perpendicular to the surface.

Click **View > Display > Surface Curvature Combs** or in the Fill Surface, Sweep, Loft, and Boundary Surface Property Managers.

Viewing Surface Curvature Combs

The **Surface Curvature Combs** tool shows curvature combs at various locations on the surface of the model.

**To view surface curvature combs:**

1. Open `install_dir\samples\whatsnew\parts\scanner.sldprt`.
2. Roll the model back to **Controls-Split Line**.
3. Select the face shown.
4. Click **View > Display > Surface Curvature Combs**.
The combs indicate a smooth continuous curvature across adjacent faces.

5. Click ✅.
The curvature combs are displayed on the surface for use in further editing.

To stop displaying curvature combs, click **View > Display > Surface Curvature Combs**.

**Using Dynamic Surface Curvature Combs**

Now use the pointer to place curvature values at more specific locations in the model.

1. Click **View > Display > Surface Curvature Combs**.
2. In the PropertyManager, under **Options**, select **Dynamic**.
3. Drag the pointer along the face.
   Curvature values appear.
4. Click approximately in the areas shown.

The curvature combs display until you close the PropertyManager.
5. Click ✓.

**Using the PropertyManager to View Curvature Combs**

In addition to the *Surface Curvature Combs* tool, you can use PropertyManagers to view curvature combs.

1. Roll the model forward to **ControlsCornerFill-Surface-Fill3**.
2. Select the face shown and click **Edit Feature**.
3. In the PropertyManager, under **Curvature Display**, select **Curvature combs** and **Direction 1**. Clear **Direction 2**.

4. Set the **Scale** to **40**.
   
   The combs indicate a smooth continuous curvature across adjacent faces.

---

**Task Pane Improvements**

**Back and Forward Buttons**

You can use the **Back** and **Forward** buttons in the Design Library tab and the Appearances, Scenes, and Decals tab of the Task Pane to navigate in folders.

**Activate Toolbox Settings**

You can display and activate the Toolbox - Customize Hardware dialog box directly from the Design Library tab in the Task Pane. In the Design Library tab in the Task Pane, click **Configure Toolbox**.

**View Selector Preview**

When you use the View Selector to modify a model’s orientation, it appears with the current model orientation, rather than changing the model orientation. This makes it easier to change to the desired view orientation. In addition, you can see a preview by moving the pointer over a View Selector plane.

To launch the View Selector, press the **Ctrl + Spacebar** or click **View Selector** in the **View Orientation** flyout menu on the Heads-up View toolbar.

As you move the pointer over different planes, the preview window updates. If a view is a standard view, the view name appears in the upper left corner of the preview window.
Planes that are obscured because they are in the back of the model are exploded away from the center of the View Selector to make them easier to select without rotating the model.

The following image shows the right pane selected and the bottom, left, and back panes exploded.

If you rotate the view using the middle mouse button, the positions of the planes update dynamically so you can still select obscured planes.
4

Installation

This chapter includes the following topics:

- **CircuitWorks Added to SOLIDWORKS Professional**
- **Licensing Change for Enterprise PDM**
- **SOLIDWORKS Inspection**
- **SOLIDWORKS Sustainability Added to SOLIDWORKS Premium**
- **Support for Multiple DVDs**

**CircuitWorks Added to SOLIDWORKS Professional**

CircuitWorks is now part of the SOLIDWORKS Professional product suite. If you are a SOLIDWORKS Professional customer, you can use the full set of CircuitWorks tools starting with SOLIDWORKS 2015.

**Licensing Change for Enterprise PDM**

Enterprise PDM now uses SolidNetWork License Manager for licensing. See *SOLIDWORKS Enterprise PDM* and *SOLIDWORKS Installation and Administration Guide*.

**SOLIDWORKS Inspection**

You can install SOLIDWORKS Inspection from the Installation Manager. You can also add SOLIDWORKS Inspection to an administrative image. See *SOLIDWORKS Installation and Administration Guide*.

**SOLIDWORKS Sustainability Added to SOLIDWORKS Premium**

SOLIDWORKS Sustainability is now part of the SOLIDWORKS Premium product suite. If you are a SOLIDWORKS Premium customer, you can use the full set of Sustainability tools starting with SOLIDWORKS 2015. You do not have to do any additional installation to use the product. See *SOLIDWORKS Help: Sustainability Products*.
Support for Multiple DVDs

SOLIDWORKS 2015 product offerings have expanded to 2 DVDs to support the 64-bit installation.

When you initiate the installation, you begin installing with Disc 1 of 2. If needed, the Installation Manager prompts you to insert the second disc.

If you used both DVDs to install, you will also use the DVDs to modify or repair.
Assemblies

This chapter includes the following topics:

- Chain Pattern
- Confirm Delete Dialog Box
- Deleting Subassemblies and Components of Subassemblies
- Editing Limit Mate Values in the Graphics Area
- Enhanced Performance when Hiding and Showing Components
- Equations in Assemblies
- Selecting by View
- Exploded Views
- Forming and Dissolving Subassemblies
- Interference Detection
- Isolate Components
- Mates
- Move Face in Assemblies
- Open Summary Report Created When Opening Assemblies
- Temporarily Fix Components to Limit Dynamic Motion
- Rotating Inserted Components in Assemblies
- Saving Component Instances as New Files
- SpeedPak Quick Include Can Exclude Internal Components
- Treehouse

Chain Pattern

You can pattern components along an open or closed loop path to simulate roller chains, energy chains, and power transmission components.

You can create three types of chain patterns:
Creating a Distance Linkage Chain Pattern

To create a distance linkage chain pattern:

1. Open `install_dir\samples\whatsnew\assemblies\chain_pattern\Distance Linkage.sldasm`.

2. Click Insert > Component Pattern > Chain Pattern or click Chain Component Pattern (Assembly toolbar).

3. In the PropertyManager, for Pitch Method, click Distance Linkage.

4. Under Chain Path, click SelectionManager.

5. In the SelectionManager, click Select Closed Loop and in the graphics area select the closed profile sketch.

6. For Number of Instances, type 10.

7. Under Chain Group 1, for Component to Pattern, select Mount Base <1> in the graphics area or the flyout FeatureManager design tree.

8. For Path Link 1, select the face shown.
9. For **Path Link 2** 🔄, select the face shown.

10. For **Path Alignment Plane**, in the flyout FeatureManager design tree, in **Mount Base <1>**, select the right plane.
11. Under **Chain Group 1**, click **Equal Spacing**.
12. Click ✓.

**Creating a Connected Linkage Chain Pattern**

To create a connected linkage chain pattern:
1. Open `install_dir\samples\whatsnew\assemblies\chain_pattern\Connected Linkage.sldasm`.

2. Click **Insert** > **Component Pattern** > **Chain Pattern** or click **Chain Component Pattern** (Assembly toolbar). Note that the two components do not have any mates and you can move them freely around the graphics area.

3. In the PropertyManager, for **Pitch Method**, click **Connected Linkage**.

4. Under **Chain Path**, for **Path**, in the flyout FeatureManager design tree, in the main assembly, select **Chain Path**.

5. Under **Chain Group 1**, in **Component to Pattern**, select **Chain Outer Link 06B1<1>** in the graphics area or the flyout FeatureManager design tree.

6. In the PropertyManager, for **Path Link 1**, select the face shown.

7. For **Path Link 2**, select the face shown.

8. For **Path Alignment Plane**, in the flyout FeatureManager design tree, in **Chain Outer Link 06B1<1>**, select **Mid-plane**.

9. In the PropertyManager, select **Chain Group 2**.

10. Under **Chain Group 2**, for **Component to Pattern**, in the graphics area or the flyout FeatureManager design tree, select **Chain Inner Link 06B1<1>**.

11. For **Path Link 1**, select the face shown.
12. For **Path Link 2** 🔄, select the face shown.

13. For **Path Alignment Plane**, in the flyout FeatureManager design tree, in **Chain Inner Link 06B1<1>** 🛠️ select **Mid-plane** ⛩.

14. Under **Chain Path**, select **Fill Path**.

   The software calculates the correct number of instances to fill the chain path.

15. Click ✓.

16. Drag one of the links to see the chain move.

**Confirm Delete Dialog Box**

In an assembly, you can prevent items from being automatically deleted when their parent features are deleted.

When you delete a parent feature or component that has child or absorbed features, you can select which features in the assembly to delete. Use the Confirm Delete dialog box to selectively delete child and absorbed features. The features that you retain might
display warnings or error messages in the FeatureManager design tree. You must manually resolve any errors.

**Selectively Deleting Items in an Assembly**

**To selectively delete child or absorbed features:**

1. In an assembly, in the FeatureManager design tree, right-click a parent feature or a component that has child or absorbed features, and click **Delete**.
2. In the Confirm Delete dialog box, click **Advanced**.
3. Select or clear child or absorbed features.
4. Click **Yes** to delete the selected features.

If warning or error messages display in the FeatureManager design tree, you must resolve them manually.

**Deleting Subassemblies and Components of Subassemblies**

When you delete a component from a subassembly, you can delete the component only, or the entire subassembly.

**To delete a component from a subassembly:**

1. In an assembly with a subassembly, in the FeatureManager design tree, select a subassembly component and press **Delete**.
2. In the dialog box, select whether to **Delete the subassembly**, or **Delete only the selected components**.
3. In the Confirm Delete dialog box, verify the component and dependent items to delete and click **Yes**.

**Editing Limit Mate Values in the Graphics Area**

You can view and edit the **Min** and **Max** values in the Modify Dimensions dialog boxes for Distance and Angle Mates.

This improves common machine design workflows.
Enhanced Performance when Hiding and Showing Components

Performance is improved for hiding and showing components in large assemblies when you select a large number of components or have a large number of components already hidden.

Equations in Assemblies

Performance is improved when creating equation references between assembly components.

The equation syntax for references between assembly components is simpler and more consistent. This syntax loads automatically when you select dimensions, features, and global variables in the FeatureManager design tree, the graphics area, File Properties, and the Equations dialog box.

Existing equations that do not follow this syntax are marked as errors because they create inconsistent results. You need to edit these equations to correct the syntax.

In the following example, A1 is a subassembly of A2 containing the parts P1 and P2:

```
A2
  A1
    P1
    P2
```

GV1 and GV2 are global variables in the documents. Use the following syntax:

<table>
<thead>
<tr>
<th>Edit Target</th>
<th>Reference to</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td>A2</td>
<td>A2</td>
<td>“GV1” = “GV2”</td>
</tr>
<tr>
<td>A2</td>
<td>A1</td>
<td>“GV1” = “GV2@A1&lt;1&gt;.Assembly”</td>
</tr>
<tr>
<td>A2</td>
<td>P1</td>
<td>“GV1” = “GV2@P1&lt;1&gt;.Part@A1&lt;1&gt;.Assembly”</td>
</tr>
<tr>
<td>A1</td>
<td>A2</td>
<td>“GV1” = “GV2@A2.Assembly”</td>
</tr>
<tr>
<td>A1</td>
<td>A1</td>
<td>“GV1” = “GV2”</td>
</tr>
<tr>
<td>A1</td>
<td>P1</td>
<td>“GV1” = “GV2@P1&lt;1&gt;.Part”</td>
</tr>
<tr>
<td>P1</td>
<td>A2</td>
<td>“GV1” = “GV2@A2.Assembly”</td>
</tr>
<tr>
<td>P1</td>
<td>A1</td>
<td>“GV1” = “GV2@A1&lt;1&gt;.Assembly”</td>
</tr>
<tr>
<td>P1</td>
<td>P1</td>
<td>“GV1” = “GV2”</td>
</tr>
<tr>
<td>P1</td>
<td>P2</td>
<td>“GV1” = “GV2@P2&lt;1&gt;.Part@A1&lt;1&gt;.Assembly”</td>
</tr>
</tbody>
</table>
Selecting by View

You can select all the assembly components that are visible from a standard or current view.

You can select up to three views in the Select by Views dialog box.

To select components by view:

1. Click the down arrow next to Select and click Select by Views.
2. In the Select Components by View dialog box, select one or more views. Components that are visible from the selected views are selected.

Exploded Views

Radial Explode

You can explode components aligned radially/cylindrically about an axis in one step.

You can also explode radially by diverging along an axis.

To radially explode components about an axis:

1. In an assembly document, click Exploded View (Assembly toolbar) or Insert > Exploded View.
2. In the Explode PropertyManager, under Explode Step Type, click Radial step.
3. In **Settings**, select the components to explode.
4. In the graphics area, drag the handle and release.

5. Click ✔.

**Intelligent Auto-Space in Chain-Step Exploded Views**

When you auto-space components in a chain-step exploded view, you can drag all the components simultaneously.

Components that are on the same plane remain parallel during the explode.

The model includes sets of components that are on the same horizontal plane.

During the vertical explode with auto-spacing, the components remain parallel.
**To create a linear exploded view with auto-spaced components:**

1. With an assembly open, select the components that you want to explode in the graphics area or FeatureManager design tree and click **Exploded View**.
2. In the PropertyManager, select **Auto-space components on drag**.
3. Use the handle in the graphics area to move all the components. When you release the handle, additional handles become available to move individual components or component groups.
4. Optionally, use the **Adjust the spacing between chain components** slider in the PropertyManager to readjust the distance between components.

**Forming and Dissolving Subassemblies**

You can form or dissolve a subassembly that contains suppressed components from the FeatureManager design tree or the graphics area.

When a subassembly dissolves, the components remain at the same position in the FeatureManager design tree, with folders and subfolders preserved.

You can also:
- Select and dissolve multiple subassemblies.
- Undo the dissolve action.
- Form a new subassembly by right-clicking a folder in the FeatureManager design tree and clicking **Form New Subassembly**.

**Interference Detection**

You can ignore all interference volumes less than a selected value. You can also sort the list of results.

**To ignore interferences less than a selected value:**

1. In an assembly document, click **Tools > Interference Detection**.
2. In the PropertyManager, in **Selected Components**, click **Calculate**. The **Results** list populates.
3. Optionally, in the **Results** list, right-click a value and click **Sort Largest to Smallest** or **Sort Smallest to Largest**.
4. In the **Results** list, right-click a value and click **Ignore all smaller than**.
5. Click ✅.
Isolate Components

You can isolate components while editing the components within the context of an assembly. This also applies to multibody components and subassemblies.

To isolate components that you are editing within the context of an assembly:

1. In an assembly, right-click a component and click Edit Part or Edit Assembly.
2. Right-click the component and click Isolate.
   All other components are hidden.

You can isolate components that share a mate by right-clicking the mate in the FeatureManager design tree and clicking Isolate.

Mates

Angle Mates

You can add a reference direction to help prevent angle mates from flipping unexpectedly. This makes the mate definition more robust and predictable.

To define an angle mate and place the dimension:

1. Open install_dir\samples\whatsnew\assemblies\angle_mate\angle_case1.sldasm.
2. Click Mate (Assembly toolbar) or Insert > Mate.
3. In the Mate PropertyManager, under Standard Mates, click Angle.
4. In Mate Selections, select the edges shown for Entities to Mate.
5. Under Mate Selections, do one of the following:
   • In Reference Entity, select the axis shown.
6. Use the dimension selector to determine the angle orientation to drive the dimension value.

See SOLIDWORKS Help: Reference Entity for Angle Mates.

**Copy with Mates**

Improvements have been made to the Copy With Mates PropertyManager:
- Copy With Mates now supports width and symmetry mates.
- For a cleaner workflow, the PropertyManager is divided into two pages. Users select the component on the first page, and on the second page select which mates to copy.
- You can repeat all mates when creating a copy of a component.

**Globally Replace Failed Mate References**

You can simultaneously replace all missing mate references in failed mates. When you repair a mate with a missing reference, a dialog prompts you to repair other mates with the same missing reference.
Mates in Configurations

If you edit a distance or angle mate, you can select which configurations to apply the mate to directly from the Mate PropertyManager.

Profile Center Mate

Mate to Center automatically center-aligns common component types such as rectangular and circular profiles to each other and fully defines the components.

1. Open `install_dir\samples\whatsnew\assemblies\profile_center_mate\profile_center.sldasm`.
2. Click Mate (Assembly toolbar) or Insert > Mate.
3. In the PropertyManager, under Advanced Mates, click Profile Center.
4. For Entities to Mate, select the faces shown.

The components align.

5. In Mate alignment, click Anti-Aligned.
6. To rotate the component, in **Orientation**, click **Clockwise**.

7. Click ✔️. The PropertyManager remains open.

8. Under **Advanced Mates**, click **Profile Center**.
9. For **Entities to Mate**, select the faces shown.
The components align.

10. In **Offset Distance**, type 2.5 and select **Flip dimension**.

11. In the PropertyManager, select **Lock Rotation** to prevent the components from rotating.

12. Click ✓.

13. Click ✓ again to close the PropertyManager.

See **SOLIDWORKS Help: Profile Center Mate**.

**Symmetry Mates**

The workflow has changed for symmetry mates.

You select the symmetry plane first, and then the assembly references.

To create a symmetry mate, you can pre-select the symmetry plane and then click **Mate** (Assembly toolbar) or **Insert > Mate**.

**Width Mates**

You can select geometry to drive the limits of width mates, eliminating the need for numerical input.

When you create a width mate, you can select the following options to define the limits of the mate:
**Centred**
Centers a tab within the width of a groove. This is the same functionality as in previous releases.

**Free**
Lets the components move freely within the limits of the selected faces or planes with respect to the components.

**Dimension**
Sets a distance or angle dimension from one selection set to the closest opposing selection set of faces or planes.

**Percent**
Sets the distance or angle based on a percentage value dimension from one set of the selection set to the center of the other selection set.

To set these options, click **Mate** (Assembly toolbar) or **Insert > Mate**. In the PropertyManager, under **Advanced Mates**, click **Width** and set the options. See SOLIDWORKS Help: *Width Mates*.

### Creating a Free Width Mate

**To use the width mate options:**

1. Open `install_dir\samples\whatsnew\assemblies\linear_rail\Linear Rail and Bearing.sldasm`.
2. Click **Mate** (Assembly Toolbar) or **Insert > Mate**.
3. In the PropertyManager, in **Advanced Mates**, click **Width**.
4. For **Width Selections**, select the two parallel planar faces of the **Block** component.

5. For **Tab Selections**, select the two parallel planar faces of the **Rail** component.

6. In **Advanced Mates**, for **Constraint**, select **Free**.
7. Click ✓.
8. Click ✓ again to close the PropertyManager.
9. In the graphics area, drag the Block component to see that it is constrained by the faces of the Rail part.

Creating a Percent Width Mate

To create a percent width mate:

1. In the FeatureManager design tree, expand Mates, click Width1 and click Edit Feature.
2. In the PropertyManager, in Advanced Mates, for Constraint, select Percent.
3. In Percentage Distance from the End, type 70. The Rail component slides to 70% of the distance between the two tabs.
4. Click ✓.
5. Click ✓ again to close the PropertyManager.

Move Face in Assemblies

You can use the Move Face option to move a component face up to the surface of another component.

While editing a part in the context of an assembly, click Insert > Face > Move. With the Up to Surface end condition, you can move the face up to the surface of another component.

Open Summary Report Created When Opening Assemblies

You can use these options when opening assemblies and assembly drawings.

Optional Timer on Open Dialog Boxes

You can use the configurable timeout mechanism on some common dialog boxes to automatically dismiss them. This is useful if you open a large assembly that takes considerable time to open, and you need to perform other tasks while the SOLIDWORKS software opens the files. The timeout mechanism lets the tasks continue without you clicking OK in the dialog boxes.
To activate the optional timer:

1. Click **Tools > Options > System Options > Messages/Errors/Warnings**.
2. Select **Dismiss reference/update dialog boxes when opening assemblies after: n seconds.**
   
   You can change the number of seconds.
3. Click **OK**.

This option adds the timeout feature to these dialog boxes:
- Rebuild this document
- Missing Toolbox configuration (with or without auto-create option)
- Open External Referenced Documents
- Unable to locate file
- File has a non-matching internal ID
- Resolve components in lightweight drawings if units differ
- Update drawings sheets if out of date

**Open Summary Report**

When you open assemblies and assembly drawings, an Open Summary report collects dismissed warning and error messages. Viewing the Open Summary report can help you diagnose problems in an assembly. The report only applies to assemblies or assembly drawings that you open from disk.

The Open Summary report contains:
- Warning and error messages that you dismissed by clicking **Don’t show again**, that timed out, or that were only informational.
- Components that could not be opened, along with the path and the reason they could not load.

**To view the Open Summary report:**

1. Click **AssemblyXpert** (Assembly toolbar) or **Tools > AssemblyXpert**.
2. In the AssemblyXpert dialog box, in **Open Summary**, click **Show these Parts**.
   
   You can view, print, or copy the report or save the list to a file.
3. Click **Return to AssemblyXpert**.

**Temporarily Fix Components to Limit Dynamic Motion**

You can temporarily fix or group components or subassemblies to test motion or design setup directly from the top-level assembly.

In an assembly, click **Move Component** or **Rotate Component** (Assembly toolbar) or **Tools > Component > Move** or **Tools > Component > Rotate**. In the PropertyManager, select **Temporary Fix/Group**, and set options.
Rotating Inserted Components in Assemblies

When you insert a component into an assembly using the Insert Component Property Manager, you can change its orientation.

Choose one of the following to change the orientation of a component when you insert it into an assembly.

**Context Menu**

Before you place the component, right-click to view the context menu.

In the context menu, click:

<table>
<thead>
<tr>
<th></th>
<th>Rotate X 90 Deg</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Rotate Y 90 Deg</td>
</tr>
<tr>
<td></td>
<td>Rotate Z 90 Deg</td>
</tr>
</tbody>
</table>

**Rotate Context Toolbar**

1. In the Insert Component Property Manager, under **Options**, select **Show Rotate context toolbar**.
2. Enter the number of degrees for the rotation.
3. Click \( \times \), \( \y \), or \( \z \).
4. Click to place the component.

You can drag the Rotate context toolbar to the desired location in the graphics area. The toolbar appears in your selected location for future inserted components.

**Tab Key**

Press **Tab** to rotate 90° or **Shift+Tab** to rotate -90° in the most recently selected direction.
Saving Component Instances as New Files

You can save one or more component instances as a new file from within an assembly. The assembly points to the new file for those instances only; other unselected component instances in the assembly still point to the original file.

**To save one or more component instances as a new file:**

1. In an assembly, in the graphics area or FeatureManager design tree, right-click a component or Ctrl + select multiple components and click **Make Independent**.
2. In the dialog box, click **OK** when asked to save the component with a new name.
3. In the Save As dialog box, type a name and click **Save**.

The new component is referenced in the assembly for each instance you selected.

You can save component instances as new files for virtual and envelope components. You cannot save instances of patterned components as new files.

SpeedPak Quick Include Can Exclude Internal Components

SpeedPak can automatically exclude internal components when using the Quick Include slider.

In addition, you can specify standard model views with the Quick Include slider to facilitate layout views for large assembly models. The new view selection options can speed up the creation, opening, and saving of SpeedPak files.

**To exclude internal components:**

1. In an assembly document, click **ConfigurationManager**.
2. In the ConfigurationManager, right-click an existing configuration and click **Add SpeedPak**.
3. In the SpeedPak PropertyManager, under **Quick Include**, select **Exterior Bodies Only**.

**To specify standard model views with Quick Include:**

1. In an assembly document, click **ConfigurationManager**.
2. In the ConfigurationManager, right-click an existing configuration and click **Add SpeedPak**.
3. In the SpeedPak PropertyManager, under **Quick Include**, select **Select Views** and select one or more view directions.

Treehouse

With Treehouse, you can set up your file structure in a graphical user interface before you start building the models in SOLIDWORKS.

To run Treehouse, in Windows, click **Start > SOLIDWORKS 2015 > SOLIDWORKS Tools > SOLIDWORKS Treehouse 2015**.

To create a file structure, drag templates onto the workspace. Double-click a node to edit the File Properties. After you create the file structure, you can export it to SOLIDWORKS.

You can also drag existing documents into Treehouse from Windows Explorer to edit.
This chapter includes the following topics:

- **Dashboard Enhancements**
- **Export Dashboard to Microsoft Excel Files**

### Dashboard Enhancements

New features to the CAD Admin Dashboard include:

- A **Serial Number** column
  
  This column helps you to keep better track of machines that are using a specific serial number.

- A **Date Updated** column
  
  This column helps you to identify machines that have stopped sending data because they have been retired, or identify a setting change that has stopped sending feedback data to the dashboard.

### Export Dashboard to Microsoft Excel Files

You can download data from the CAD Admin Dashboard to generate customized spreadsheets.

To export the dashboard data to an `.xls` file, click **Export** in the Dashboard toolbar, at the bottom of the screen.

You can also download session details for specific users to share with Value Added Resellers (VARs). To export session details, click **Export** in the Session Details tab.
CircuitWorks

Available in SOLIDWORKS Professional.

This chapter includes the following topics:

- CircuitWorks Added to SOLIDWORKS Professional
- Panel Exit Message and SOLIDWORKS Build Progress Indicator
- Selecting Entities in the CircuitWorks Preview
- Support for ProStep Features
- Update of Existing CircuitWorks Boards

CircuitWorks Added to SOLIDWORKS Professional

CircuitWorks is now part of the SOLIDWORKS Professional product suite.

If you are a SOLIDWORKS Professional customer, you can use the full set of CircuitWorks tools starting with SOLIDWORKS 2015.

Panel Exit Message and SOLIDWORKS Build Progress Indicator

When you exit a CircuitWorks® panel, a message gives you a chance to save changes. A graphical indicator in the Windows task bar shows build progress when you build an ECAD part in the SOLIDWORKS software.

If you modify a parameter in the CircuitWorks Component Properties or File Properties panels and do not save changes, a message prompts you to save or cancel changes when you exit the panel. The software also prompts you to save changes when you select another object in the graphics area.

CircuitWorks provides progress information when you load an ECAD part and build it in SOLIDWORKS. The SolidWorks icon in the Windows task bar is gradually filled with green as the build progresses.

Selecting Entities in the CircuitWorks Preview

You can select entities directly in a CircuitWorks preview.

Selecting an entity in the preview:
• Highlights the item in the CircuitWorks tree.
• Updates the display of the object’s properties if they are visible.

**To use the preview selection options, do one of the following:**

• Select an object by clicking it in the preview.
  The object is highlighted in the tree.
  If the Component Instance Properties panel is open, the panel updates to show the details of the selected object.

• Select multiple objects by doing one of the following:
  • Press **Ctrl** while selecting.
  • Drag a selection box around the objects.

When you select a preview object, additional controls appear on the preview shortcut menu:

<table>
<thead>
<tr>
<th><strong>Zoom to Selection</strong></th>
<th>Zooms the preview to the selected object.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select Other</strong></td>
<td>The pointer changes to 🦶 and lets you toggle between objects of a similar type that overlap each other.</td>
</tr>
<tr>
<td><strong>Filter In</strong></td>
<td>Restores the selected object if it has been filtered out.</td>
</tr>
<tr>
<td><strong>Filter Out</strong></td>
<td>Filters out the selected object. The object is shown as unavailable in the tree view and preview image.</td>
</tr>
<tr>
<td><strong>Properties</strong></td>
<td>Displays the selected object’s Component Instance Properties panel.</td>
</tr>
<tr>
<td><strong>Build Model</strong></td>
<td>Builds the SOLIDWORKS part model for the component that contains the selected objects.</td>
</tr>
</tbody>
</table>

**Build Model** is unavailable from the shortcut menu if the selected component has multiple instances and only one is selected.

**Support for ProStep Features**

ProStep EDMD is an ECAD-MCAD format supported by CircuitWorks.

CircuitWorks supports the following ProStep features:

• When you use **Build Model** to build a ProStep EDMD file for SOLIDWORKS, CircuitWorks identifies individual holes by storing each hole’s unique ID in the SOLIDWORKS software.
When you move holes in SOLIDWORKS, the stored IDs are used to accurately report the move in the ECAD file.

- You can right-click a change in the CircuitWorks Changes tree and select **Show Report** to display the EDMD Report dialog box.

This dialog box shows the history of the change. It includes a table that lists:

- The baseline.
- Individual changes made to the file, who made the changes, and when the changes were made.
- Change notes included in replies sent to CircuitWorks from ECAD.

- A new **EDMD Info** section of the Revision Properties panel displays details about a selected change and the ECAD response to the change.

- Added file types in the Save As dialog box let you manually save ProStep *idx* and *idz* baseline files to ProStep 1.2, 2, and 3.

## Update of Existing CircuitWorks Boards

CircuitWorks evaluates changes you make to boards and determines whether to create a new PCB (Printed Circuit Board) or update the existing PCB.

CircuitWorks updates the existing board if you change the following features:

- **Board outlines**
  
  If you change the shape of the board outline or the number of cut-outs, CircuitWorks replaces the sketch elements within the board_outline sketch. Any mates that reference the top or bottom board faces remain unaffected.

- **Plated holes**
  
  If you change the number of plated holes within a PTH sketch, CircuitWorks replaces the sketch elements. If the board did not have any plated holes, CircuitWorks creates a new PTH plated hole feature. If the board had holes but the new data has none, CircuitWorks removes the PTH feature from the model.

- **Non-plated holes**
  
  If you change the number of non-plated holes within an NPTH sketch, CircuitWorks replaces the sketch elements. If the board did not have any non-plated holes, CircuitWorks creates a new NPTH feature. If the board had holes but the new data has none, CircuitWorks removes the NPTH feature from the model.

- **Keep-in, Keep-out, and Outlines**
  
  If you modify keep-in/keep-out areas, CircuitWorks removes the old keep-in/keep-out features from the board model and recreates them with the new parameters.

When you change traces, vias, or other copper features, a message lets you choose to have CircuitWorks rebuild the SOLIDWORKS part representing the board by creating a new part file with a new part name, or overwrite the existing model instead.
This chapter includes the following topics:

- **SOLIDWORKS Composer**
- **SOLIDWORKS Composer Player**
- **SOLIDWORKS Composer Sync**

**SOLIDWORKS Composer**

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents for product communication and technical illustrations.

These products are available:

- **SOLIDWORKS Composer**
- **SOLIDWORKS Composer Check**
- **SOLIDWORKS Composer Path Planning**
- **SOLIDWORKS Composer Player**
- **SOLIDWORKS Composer Player Pro**
- **SOLIDWORKS Composer Sync**
- **SOLIDWORKS Composer Enterprise Sync**

**Import Enhancements**

SOLIDWORKS Composer and SOLIDWORKS Composer Sync can import these formats:

- ACIS R23
- Pro/E® Creo 2.0
- SOLIDWORKS 2015

**Password Management**

A new **Confirm password** field has been added for improved safety when securing a document with a password.

This is available in the **Security** page of the Document Properties or Default Document Properties dialog box.
Polyline Borders

For SOLIDWORKS Composer and SOLIDWORKS Composer Player, you can define a back border for polylines.

You can control the color, width, opacity, and type properties of back-line borders in polylines, similar to front-line borders. This improvement creates a WYSIWYG display between interactive 3D and technical illustrations.

Properties Enhancements

A number of properties, which previously did not support the multi-selection of actors, are now displayed and editable in the Properties pane when several actors are selected.

These properties are:

- **Color**
  - For an assembly (root).

- **Area and Volume**
  - For actors.

- **Background Gradient, Background Dynamic Gradient, Publication Aspect, Publication Non Client Color**
  - For viewport.

These properties are now available from the Styles workshop. You can manage them through style profile like other properties.

Render Mode

You can now define the render mode as a document property, or as a default document property, of the viewport.

You set this definition in the Viewport page of the Document Properties or Default Document Properties dialog box.

You must first create an environment variable, `DS_3DVC_OVERRIDE_RENDER_MODE`, and set its value to 1.

Previously, you could only set the render mode from the Render tab in the ribbon.

Searching for Actors

In the Search pane, you can now search for actors by their **Type** or **Net GUID**.

- **Type**
  - (For example, measurements, labels, and geometry). Use the **Class name** property with string operators.

- **Net GUID (or GUID)**
  - Use the **Net GUID** property with string operators and regular expressions.
User Assistance
User assistance is now provided in HTML format via a browser-based portal.
The new browser-based portal offers a single entry point to user assistance for the entire SOLIDWORKS Composer line.
User guides have undergone a major revamp. In particular, step-by-step information has been separated from reference information.

Viewport Zoom Factor
For SOLIDWORKS Composer and SOLIDWORKS Composer Player, you can specify the zoom factor of the viewport in the viewport properties using the Camera FOV or Camera Height properties.
You can control the camera height of the viewport navigator so you can work with the same scale in different views.

Windows 8 Support
The Windows 8 operating system is now supported with all Composer products.
You can use the Windows 8 gestures functionality on your desktop and tablet devices.

SOLIDWORKS Composer Player

User Interface
SOLIDWORKS Composer Player retains its user interface layout when you close and reopen the software.
Composer Player retains all layout customizations made by you or administrators.
SOLIDWORKS Composer Sync

Log File in HTML Format

The log file, which was previously available in XML format only, is now also available in HTML.

This ensures that the log file can be read by Internet Explorer® 9 and later. By default, the log file is displayed in HTML. You can change this setting in the Logging page.
New Methods for Costing

You can use SOLIDWORKS Costing to cost plastics, castings, 3D printed parts, and weldments.

To choose the manufacturing method:

1. In the Costing Task Pane, under Method, select the manufacturing method:
   - Machining
   - Casting
   - Plastic
   - 3D Printing

Costing for 3D Printing

SOLIDWORKS Costing supports 3D Printing.

To cost 3D Printing, the SOLIDWORKS Costing software:

- Analyzes the volume of the part for material cost.
- Estimates the time required to lay down 3D printing material and cooling wait time between layers.

You must add any additional cost for support material.

SOLIDWORKS Costing determines:

- Cost of material
- Cost of manufacturing
Costing for Casting

SOLIDWORKS Costing supports casting.

To cost castings, the SOLIDWORKS Costing software:
• Analyzes the volume of the part for material cost.
• Determines the time required to complete a cycle, including heating, injecting, cooling, and ejecting the part.

Due to cost variance, you provide the cost of tooling (or the mold) directly.

SOLIDWORKS Costing determines:
• Cost of material
• Cost of manufacturing
• Cost of mold (based on user input)

Costing for Plastic

SOLIDWORKS Costing supports plastics.

To cost plastics, the SOLIDWORKS Costing software:
• Analyzes the volume of the part for material cost.
• Determines the time required to complete a cycle, including heating, injecting, cooling, and ejecting the part.

Due to cost variance, you provide the cost of tooling (or the mold) directly.

There are two runner systems available:
• Hot runner mold
• Cold runner mold

Presets are defined in the template for each type of runner system.

SOLIDWORKS Costing determines:
• Cost of material
• Cost of manufacturing
• Cost of mold (based on user input)

Costing for Weldments

You can use SOLIDWORKS Costing to cost multibody weldments or single-body structural members.

With Costing, you can:
- Open a multibody weldment or a single-body structural member. If the body contains a Structural Member in the FeatureManager design tree, the Costing software will automatically cost the structural member as an extruded part.
- Cost either per length or per stock length.
- Multibody templates support weld beads and fillet beads cost information. The cost for fillet beads is applied to all fillet beads. The cost for weld beads is automatically chosen based on weld bead information.

Access to Costing Defaults

You can set default values for your specific needs and prepopulate the task pane, which will streamline the costing process and improve the efficiency of getting your results.

The Costing Options dialog box is enhanced. It contains two tabs:

<table>
<thead>
<tr>
<th>Defaults</th>
<th>Define values for the Costing task pane.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template Overrides</td>
<td>Define or override system-level costing options. These are the previous costing options.</td>
</tr>
</tbody>
</table>

To open the Costing Options dialog box, in the Costing Task Pane, click **Costing Options** (upper left corner).

**Costing Defaults**

Use the costing default values to populate the Costing Task Pane.

To access the costing defaults, in the Costing Options dialog box, click the Defaults tab.

**Manufacturing Method**

<table>
<thead>
<tr>
<th>General body</th>
<th>Select one of the following: Machining Plastics Casting 3D Printing</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General body</strong> is anything that is not sheet metal or a structural member.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Sheet metal</th>
<th>Select one of the following: SheetMetal Machined Plate</th>
</tr>
</thead>
<tbody>
<tr>
<td>Machined Plate is now included as a manufacturing method for sheet metal.</td>
<td></td>
</tr>
</tbody>
</table>
Select one of the following:

- Structural Member
- Machining
- Plastics
- Casting
- 3D Printing

**Template**

You can choose machining or sheet metal templates to be chosen by default for machined parts, sheet metal templates for sheet metal parts, and multi body templates for multi body parts.

**Body Types for Multibody Parts**

When using Costing for multibody parts, you set the manufacturing method to any of the supported methods.

**To set the manufacturing method:**

1. In a multibody part, click **Costing** (Tools toolbar) or **Tools > SOLIDWORKS Applications > Costing**.
2. In **Body List**, select a body.
3. In the Costing Task Pane, under **Type of Body**, select **General**.
4. Under **Method**, select an option:
   - Machining
   - Casting
   - Plastic
   - 3D Printing

In a previously costed multibody part, in the CostingManager, if you right-click a body in **General Bodies** and click **Change Body Settings**, you can choose a different method from this selection in the Costing Task Pane.
Costing Sensors

You can use costing sensors to track material, manufacturing, and total part cost, and set an alert if cost exceeds a value.

To create a costing sensor:

1. In the FeatureManager design tree, right-click the Sensors folder and click Add Sensor.
2. In Sensor Type, select Costing Data.
3. In Data Quantity, select one:
   - Total Cost
   - Material Cost
   - Manufacturing Cost
4. To set an alert that notifies you when cost value deviates from your set limit:
   a) Select Alert.
   b) Specify an operator and one or two numeric values.
      Operators include:
      - is greater than
      - is less than
      - is exactly
      - is not greater than
      - is not less than
      - is not exactly
      - is between
      - is not between
5. Click ✓.

The sensor and its current value appear in the Sensors folder in the FeatureManager design tree. The sensor value updates when the costing data is updated.

Costing Template Improvements

The costing templates have been expanded and contain additional information, and they are easier to update.

Enhancements include:
- All machines are moved to the Machine tab.
- Materials are updated to support the new cutting, plastics, castings, structural members, and 3D printing operations.
- Manufacturing methods are updated to support the new cutting, plastics, castings, and 3D printing operations.
- Multibody templates support weld beads and fillet beads cost information. The cost for fillet beads is applied to all fillet beads; the cost for weld beads is automatically chosen based on weld bead information.
- You can add end cut operation information to the machining templates.
• In sheet metal, you can set Punching/Stroke Method as the default.
• You can select different units for custom operations.

Custom Stock Bodies in Machined Parts

When using Costing for machined parts, you can select a custom stock body, either a configuration of the current part or an imported stock body. With custom stock bodies, you can calculate the cost of imported geometry, for example, machined castings.

To use a custom stock body:

1. In a standard or weldment part, click Costing (Tools toolbar) or Tools > SOLIDWORKS Applications > Costing.
2. In the Costing Task Pane, under Method, select Machining.
3. Under Stock Body:
   a) In Type, select Custom.
   b) For Choose Stock Body, select an option:
      - Configuration Lets you select a part configuration.
      - Reference Part Lets you browse to a part to use for Costing.
   c) For Cost Information, select an option:
      - Saved Costing Data Displays the cost if the part or configuration has already been calculated and saved in Costing.
      - Volume Displays the stock volume. Uses the material cost from the template and uses the volume of the imported stock for the stock material cost calculation.
      - Custom Cost Lets you enter a value for the stock material cost.
This chapter includes the following topics:

- Drawing Zones
- Center Marks
- Centerlines
- Dimensions
- Drawing Views
- Layers
- Model Detailing
- Notes and Balloons
- Tables
- Other

### Drawing Zones

You can define drawing sheet zones on a sheet format for the purpose of providing locations where drawing views and annotations reside on the drawing.

#### Defining Drawing Sheet Zones

To define drawing sheet zones in the sheet format:

1. In a drawing, do one of the following:
   - Click **Edit > Sheet Format**.
   - Right-click any blank area on the drawing sheet and click **Edit Sheet Format**.
   - Right-click the sheet icon in the FeatureManager design tree and select **Edit Sheet Format**.

2. Right-click the sheet format icon in the FeatureManager design tree, any blank area of the drawing sheet, or the sheet tab at the bottom of the drawing window, and select **Properties**.

3. In the **Sheet Properties** dialog box, click the Zone Parameters tab.
4. Set the options.
5. Click **OK**.

To show or hide drawing zone lines, click **View > Zone Lines**.
Adding Zones to Annotations

You can use annotation notes and balloons to identify which drawing zone they are in. As you move an annotation in the graphics area, the drawing zone updates to the current zone.

To add zone information to an annotation note or balloon:

1. Create an annotation note or balloon and place it on the drawing sheet. If you create a balloon, the **Balloon text** must be set to **Text**.
2. In the annotation note or balloon, double-clicking the text to edit it.
3. In the text field, move the insertion point to the location where you want to insert the zone in the text.
4. In the Note Property Manager, under **Text Format**, click **Add Zone**.
5. In the Add Zone dialog box, select one:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zone</td>
<td>Inserts column and row</td>
</tr>
<tr>
<td>Zone Column</td>
<td>Inserts only column</td>
</tr>
<tr>
<td>Zone Row</td>
<td>Inserts only row</td>
</tr>
<tr>
<td>Drawing View</td>
<td>Inserts selected drawing view row and column</td>
</tr>
</tbody>
</table>

6. Click **OK**.
7. In the Note Property Manager, click **✓**.

Location Labels for Views

You can place location labels on detail, section, and auxiliary drawings views to provide the sheet and zone location for the parent view. Additionally, you can place location labels
on detail circles, section cutting lines, and auxiliary view arrows to provide the location of the corresponding child view.

In this section view example, Sheet 1 shows the parent view and Sheet 2 shows the child view. The zone is determined by the centroid of the view. The location label on the parent view shows where the child view is located, Sheet 2 - Zone C1. The location label on the child view shows where the parent is located, Sheet 1 - Zone B1.

**Setting Options for Location Labels**

To set document properties for Location Labels:

1. Click **Options** (Standard toolbar) or **Tools > Options**.
2. On the Document Properties tab, click **Annotations > Location Label**.
3. Set the properties.
4. Click **OK**.

**Using Location Labels**

**Adding a Location Label to a Child View**

To add a location label to a child view in a section, detail, or auxiliary view:

1. In a drawing, create the view.
   
   You can move the child view to a sheet that is different than the parent view.

2. Click **Insert > Annotations > Location Label**.
3. In the Location Label PropertyManager, set the options.
4. Click the child view.

5. Click ✓.

Adding a Location Label to a Parent View

To add a location label to a section cutting line, detail circle, or view arrow in a parent view:

1. In a drawing, create a section, detail, or auxiliary view.

   You can move the child view to a sheet that is different than the parent view.

2. Click Insert > Annotations > Location Label.
3. In the Location Label PropertyManager, set the options.
4. In the parent view, click on the section cutting line, detail circle, or view arrow.

5. Click ✓.

Revision Symbols Update Zone Information in Revision Tables

When you place or move a revision symbol on a drawing, the revision symbol's zone updates in the revision table.

When you move a revision symbol from one zone to another and the Zone column is displayed in the revision table, the zone updates in the revision table.

Center Marks

You can create center mark sets and add additional center marks to the set. You can reattach dangling center marks to geometry. You can automatically insert connection lines to hole patterns with center marks.

Adding to a Center Mark Set

In a center mark set, you can add additional center marks.

To create a center mark set in a drawing, you manually insert a linear or circular center mark. Then, in the Center Mark PropertyManager, and under Manual Insert Options, select Linear Center Mark or Circular Center Mark.

To add center marks to an existing center mark set:

1. Right-click a center mark in the center mark set, and click Add to Center Mark Set.
2. Select circular edges, slot edges, or arcs whose center marks you want to add to the center mark set.

3. Click ✓.

   If Connection lines is selected in the Center Mark PropertyManager, connection lines are automatically added where possible for the new center marks.
Reattaching Dangling Center Marks
You can reattach dangling center marks to valid geometry such as holes, fillets, and slots that do not already have center marks.

To reattach a dangling center mark:
1. Right-click the dangling center mark and click Reattach.
2. In the same drawing view, select the hole edge, fillet, or slot whose center mark you want to reattach to the center mark set.
   The center mark reattaches to the new selection and the connection lines update.

Connection Lines
You can apply connection lines automatically when you add center marks to a drawing view at the time of creation. In a drawing, click Tools > Options > Document Properties > Detailing, and under Auto insert on view creation, select Connection lines to hole patterns with center marks. The option is selected by default.

The automatic addition of connection lines supports sketch patterns of holes from a single hole wizard feature.

Centerlines

Centerline enhancements include:
• You can attach annotation leaders to centerlines.
• You can select a relation between a centerline and a sketch entity in the PropertyManager.
• You can find intersections of virtual sharps using centerlines.

Dimensions

Decimal Rounding
You have more control over decimal rounding methods in dimensions.

Rounding Options
The following options are available in Tools > Options > Document Properties > Units:

Round half away from zero Rounding method where 5 rounds the previous digit up. For example, 46.15 at one decimal place becomes 46.2.

Round half towards zero Rounding method where 5 keeps the previous digit unchanged. For example, 46.15 at one decimal place becomes 46.1.
**Round half to even**  
Rounding method where 5 is the removed digit. When the previous digit is even, the digit remains unchanged. For example, 46.25 at one decimal place becomes 46.2. When the previous digit is odd, the digit is rounded up to the next even number. This method is also referred to as Statistician’s Rounding. For example, 46.15 at one decimal place becomes 46.2.

**Truncate without rounding**  
Method that removes digits without rounding. For example, 46.19 at one decimal place becomes 46.1.

**Only apply rounding method to dimensions**  
(Parts and Assemblies only). When selected, this option applies the rounding rule to dimensions and their tolerances, including dimensions whose values are derived from equations. When cleared, this option applies the rounding rule to any numeric display where rounding occurs, including dialog boxes, such as Mass Properties.

Additionally, in any dimension PropertyManager that has an Other tab, you can select **Use document method** or select a rounding method described above to apply to the dimension.

**Tolerance Rounding**

For the secondary units of dual dimensions, you can set the limits of the secondary unit’s tolerance range to fit within the tolerance range of the primary unit by using inward rounding so that the dual dimension does not conflict with the primary dimension.

Click **Tools > Options > Document Properties > Dimensions**. In the Dimensions node and in any of the nodes under Dimensions, click **Tolerance**. In the Dimension Tolerance dialog box, under Dual dimension tolerance, select **Inward rounding of secondary unit tolerance extents**. When selected, if the high end of the secondary unit’s tolerance rounds to a number that is larger than the displayed rounded number of the primary unit’s tolerance high end, the secondary unit’s high end is rounded down. If the low end of the secondary unit’s tolerance rounds to a number that is smaller than the displayed rounded number of the primary unit’s tolerance low end, the secondary unit’s low end is rounded up.

![Inward rounding of secondary unit tolerance extents](image)

Additionally, in any dimension PropertyManager, on the Value tab, you can select **Inward rounding** to control individual dimensions.
Enhanced Angle Dimension Capabilities

There are several new angle dimension features available in drawings.

Angle Dimension Using an Imaginary Line

You can use the Smart Dimension tool to create an angle dimension between a line and an imaginary horizontal or vertical line. For example,

1. Start the Smart Dimension tool.
2. In a drawing view, select an edge.

![Image](411x706 to 423x718)

3. Select a collinear vertex.

![Image](111x315 to 213x428)

4. When the crosshair appears, select one of its segments.

![Image](97x688 to 97x661)

5. A preview of the angle dimension between the edge and segment appears. Click to place the dimension.

![Image](111x163 to 215x273)
Flip an Angle Dimension to its Vertically Opposite Angle

To flip an angle dimension to its vertically opposite angle, right-click the angle dimension and click **Display Options > Vertically Opposite Angle**.

<table>
<thead>
<tr>
<th>Angle dimension</th>
<th>Vertically opposite angle</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Angle dimension" /></td>
<td><img src="image2.png" alt="Vertically opposite angle" /></td>
</tr>
</tbody>
</table>

Flip an Angle Dimension to its Explementary Angle

To flip an angle dimension $X^\circ$ to its explementary angle $360^\circ - x^\circ$, right-click the angle dimension and click **Display Options > Explementary Angle**.

<table>
<thead>
<tr>
<th>Angle dimension</th>
<th>Explementary angle dimension</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image3.png" alt="Angle dimension" /></td>
<td><img src="image4.png" alt="Explementary angle dimension" /></td>
</tr>
</tbody>
</table>

Create a 180° Angle Dimension

You can create a 180° angle dimension between two distinct collinear lines using the **Smart Dimension** tool.
**Hide Zero Value Angle Dimension Units**

In angle dimensions set to deg/min or deg/min/sec, you can hide units that have a value of zero.

Click **Tools > Options > Document Properties > Dimensions > Angle**. Select or clear **Remove units with 0 value for deg/min and deg/min/sec**.

| 73°37" | 73°0'37"
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Selected</td>
<td>Cleared</td>
</tr>
</tbody>
</table>

**Symmetrical Angular Dimension**

You can create multiple half and full symmetric angular dimensions without selecting the centerline each time.

This type of dimensioning is helpful when you create sketches for revolved geometry that require several angular dimensions or the display of a full angular dimension.

Multiple half angle and single full angle dimensions
To create a symmetrical angular dimension:

1. In a sketch with a centerline and lines or points, click **Smart Dimension** (Dimensions/Relations toolbar) or **Tools > Dimensions > Smart**.
2. Select the centerline and a non-parallel line.
3. To create a half angle dimension, move the pointer to the desired location. To create a full angle dimension, press and hold the **Shift** key.

   The pointer changes to indicate that you can place multiple angular dimensions using the centerline.

**Drawing Views**

**Slice Section View for Surface Bodies**

In a drawing of a surface body, you can show the portion of a surface body that intersects the section view cutting plane.

In the Section View Property Manager, under **Section View**, the **Display only cut faces** option has been renamed to **Slice section**. In addition to sectioning solid bodies, you can use **Slice section** to show the portion of a surface body that intersects the section view cutting plane.

**Zoom to Sheet**

The **Zoom to Sheet** tool zooms a drawing sheet to its maximum size within a window. **Zoom to Sheet** zooms to maximize the drawing sheet within the current viewport. If interface elements such as the Heads-Up View toolbar or the Task Pane are present, it zooms to fit the sheet to the window with no portion appearing under those interface elements.

For example, if you have a drawing view with geometry within the sheet, but a bounding box that extends beyond the sheet, **Zoom to Sheet** focuses on the sheet only and zooms the sheet to fit the window. In contrast, **Zoom to Fit** zooms to include the bounding box.
To use Zoom to Sheet:

Click **Zoom to Sheet** (View toolbar) or **View > Modify > Zoom to Sheet**.

**Layers**

**Layers Dialog Box**

You can resize the Layers dialog box, and the size persists across sessions.

**Omit Layers from Print**

When you print drawings with multiple layers, you can specify layers to omit from printing. If you omit layers from printing, the layers are still visible on the screen.

**To omit layers from printing:**

1. Click **Layer Properties** (Layer or Line Format toolbar).
2. In the dialog box, in the Print column, click the icon to set the layer to print or not print.
Model Detailing

**Hide or Show Annotations in Assemblies**

In assemblies, you can show or hide annotations that pertain to the part or subassemblies separately from the display of annotations at the assembly level.

On the **View** menu, new items include:

- **Top Level Annotations**
  - Controls annotation display at the assembly level.

- **Component Annotations**
  - Controls annotation display for the parts and subassemblies within the assembly document.

The **View All Annotations** menu item is no longer available in assemblies.

**Quickly Apply Annotation Views**

You can apply annotation views to dimensions and other annotations directly from the graphics area.

You can assign and reassign the annotation view of any dimension or annotation within parts and assemblies with an onscreen dialog in the graphics area.

To assign an annotation view when creating an annotation, press `~` (back quote, on Tilde ~ key) after selecting the geometry or before placing the annotation.

To reassign an annotation view, right-click the annotation and click **Select Annotation View** or press `~` (back quote).

Keys may vary for language-specific keyboards. For example, if you are using a Japanese keyboard, press the @ key, instead of `~` (back quote, on Tilde ~ key).

---

**Notes Area** selected
Reference Dimensions

You can use reference dimensions to create diameter and radius dimensions on cylinders and radii features such as holes and fillets.

Additionally, the silhouette edges of cylinders, radii, and conical features are supported when an Annotation View other than Notes Area or Undefined is active. These silhouette edges are also supported when the feature is orthographic to the view orientation.
Adding a Reference Dimension to a Model
This example adds an angle dimension to a chamfer at the end of a cylinder.

In the modeling environment, if the model view orientation is normal to an annotation or standard view, you can use the Smart Dimension tool to select silhouettes of the surfaces when their profiles are perpendicular to the view orientation.

To add a reference dimension to a model:

1. With the model view orientation normal to the annotation view, click Smart Dimension (Dimensions/Relations toolbar) or Tools > Dimensions > Smart.
2. In the Dimension Property Manager, select Reference dimension.
3. In the graphics area, select the silhouette edge of the chamfer. Notice the cursor changes from \ to \ when you hover over the silhouette edge.
4. Select the silhouette edge of the cylinder.

5. Click to place the dimension.

Notes and Balloons

**Feedback for Balloon Asterisks**

Feedback is provided when you hover over an asterisk in a balloon that is generated by SOLIDWORKS.

In a drawing view, when you hover over an asterisk in a balloon whose leader is attached to a component that is associated with a BOM, SOLIDWORKS provides feedback that explains why the asterisk is shown.
Paragraph Properties

There is improved formatting control over general notes in your drawings and tables. The Bullet and Numbering dialog box is renamed the Paragraph Properties dialog box.

To access Paragraph Properties:

- From a note, click Paragraph Properties (Formatting pop-up toolbar).
- From a table, double-click a table cell and click Paragraph Properties (table cell editing toolbar).

Improvements include:

- **First Line Indent** and **Indent** fields are restored to previous behavior.
- Numbering can ascend from either the top or bottom of the list.
- The Note PropertyManager contains a **Wordwrap** option.
- **Paragraph spacing** and **Line spacing** are available. This example shows the effects of changing **Paragraph spacing** and **Line spacing** on a Note.

<table>
<thead>
<tr>
<th>Initial note</th>
<th>Increased line spacing for selected text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notes:</td>
<td><strong>Line Spacing</strong> is available when <strong>Wordwrap</strong> is selected.</td>
</tr>
<tr>
<td>• Have Jim review cell</td>
<td></td>
</tr>
<tr>
<td>• Verify tests by 1/24/15</td>
<td></td>
</tr>
<tr>
<td>Reminder to check in with Sam for final update.</td>
<td></td>
</tr>
</tbody>
</table>
Increased paragraph spacing for selected text. The new **Paragraph Spacing** value is added to the initial **Paragraph Spacing** value.

---

**Spline Leader**

You can use a spline leader in notes and balloons.

**To use a spline leader in a note:**

1. In the Note Property Manager, under **Leader**, select **Spline Leader**.
2. Set the options and place the note. For example:

   ![Spline Leader Example](image)

3. To modify the spline leader, select the note and drag the control vertex points. For example:
Spotface Symbol

The spotface symbol is no longer font dependent.

ASME Y14.5 drawings use the spotface symbol to represent shallow counterbores to clean up surfaces to a specified diameter around holes. The new symbol draws the S and F as lines and arcs that are consistently sized to match the ASME standard, regardless of font or font size. The redesigned symbol replaces the old symbol within SOLIDWORKS by an update to the `GTOL.SYM` file.

Table

Horizontal Auto Split

You can save horizontal auto split settings in the table template.

In the Horizontal Auto Split dialog box, under Apply, select Continuously and click Apply. When you save the table as a template, new tables created from the template preserve the horizontal auto split settings.

Item Numbers in a BOM Table

There are several enhancements to BOM tables when used with assemblies.

Do Not Change Item Numbers Respects Replace Component

If you select Do not change item numbers in the BOM PropertyManager and you change the file name (for example, using Save As or Replace Component) within the referenced assembly, the BOM table retains the BOM item number of the original component being replaced.
New Settings for Replaced Components

You can define how to handle replaced components in BOM table. In the BOM PropertyManager, in the Keep Missing Item section, Replaced components defines how to handle replaced components when you select Keep Missing Item, regardless of the Do not change item numbers setting.

Revision Symbols

You can set an option to invoke the Revision Symbol tool any time you insert a row in a revision table.

In Tools > Options > System Options > Drawings, select Enable symbol when adding new revision. When selected, any time you insert a row in a revision table, the Revision Symbol tool opens so you can insert revision symbols in the drawing. When cleared, the Description column in the new row is activated so you can insert text.

Revision Tables

You can quickly insert rows into revision tables.

To insert a row, at the bottom left corner of an activated revision table, click .

Sorting in a BOM

You can sort items in a BOM literally or numerically.

In a BOM, right-click an item and select Sort. Under Method, select:

- Literal Applies a left-to-right alphanumeric sort to each digit within every field in the column to be sorted.
- Numeric Applies a numeric sort between numbers based on the magnitude of the number. When letters are included, alphanumeric sorting is applied as a secondary sorting method.

Table Editing Improvements

When you edit tables, performance and usability has been improved by displaying the table editing toolbar in one place, regardless of which table cells you select to edit.

In the past, when you changed cells during an editing session, the table toolbars were realigned to be left-justified with the cell you were editing. This meant that the table toolbars were repeatedly redrawn.

Now, the location of the table editing toolbar remains the same as long as you continue to edit the table. By default, the software places the table editing toolbar above the upper left corner of the table. While you can drag a toolbar to reposition it, the toolbar will remain in position as long as you continue to edit the table.

The toolbar always appears fully on the screen:

- If the table is positioned to the far right of the screen, the toolbar aligns with the right edge of the first fully visible row of cells.
- If the table is positioned beyond the left edge of the screen, the toolbar aligns with the left edge of the first fully visible row of cells.
In addition, when you double-click to display the table cell toolbar, a **Paragraph Properties** button has been added at the right end of the toolbar. This button opens the Paragraph Properties dialog box, which you can use to format the cell contents. For more information, see **Paragraph Properties** on page 95.

**Table Response Time**

There is improved responsiveness when you edit the content of individual cells in a table.

**Other**

**New Sheet Formats**

The following sheet formats are available:

- F Size (ANSI)
- A0 (BSI)
- A0 (GB)

**Performance Options**

There is a new location where you can access performance options specific to drawings. The following options are available in **Tools > Options > System Options > Drawings > Performance**:

- Show contents while dragging drawing view
- Allow auto-update when opening drawings
- Save tessellated data for drawings with shaded and draft quality views

These options were previously located in **Tools > Options > System Options > Drawings**.
eDrawings® Professional is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

This chapter includes the following topics:

- **3D Views**
- **Annotation Views**
- **Mass Properties**
- **eDrawings Support for SOLIDWORKS Plastics Result Plots**
- **Named Views**
- **Query Highlighting**
- **Updated User Interface**

### 3D Views

eDrawings supports 3D Views.

This functionality is available in eDrawings Professional only.

In eDrawings, click **3D Views** and select a view.

### Annotation Views

eDrawings supports annotation views.

This functionality is available in eDrawings Professional only.
In eDrawings, click **Annotations** and select a view on the Annotation Views pane. If you select the dot, it shows the annotation view. If you select the name, it activates and orients the annotation view. In this example, the **Front** annotation view is activated and oriented.

**Mass Properties**

When you open an eDrawings file, you can view the file's mass properties.

Click **Properties**.
eDrawings Support for SOLIDWORKS Plastics Result Plots

You can export Plastics Simulation results from SOLIDWORKS Plastics as eDrawings files. eDrawings allows you to share your results between stakeholders (without having to install SOLIDWORKS or SOLIDWORKS Plastics), add annotations and notes to your plots, and archive your results.

You cannot export vector plot results such as Weld Line, Air Traps, and Velocity Vector at End of Fill plots to eDrawings.

Named Views

When you create a named view for a model in the SOLIDWORKS software, you can access the named views when you open the model in eDrawings.

Click View Orientation and click a named view.

Query Highlighting

In part documents, when you select an annotation or DimXpert dimension that is related to geometry, the geometry highlights so it is easier to see what the annotation refers to.

Updated User Interface

The eDrawings user interface has been redesigned. Tools are located around the border of the eDrawings window.

These enhancements help to streamline your overall workflow.
This chapter includes the following topics:

- Advanced Environmental Archives
- Dynamic Connector Tool
- Enhanced Formula Manager
- Importing and Exporting Data from Microsoft Excel
- Inline Routing Diagnostics
- Managing User Rights
- Multipart Association to Symbol
- Populate Spreadsheet with BOM Data
- Set Component Status to Permanent or Non-permanent
- Support for the 2013 Version of DXF/DWG files
- User Interface - Additional Enhancements
- Varied Line Width in Schematic
- XML Export

Advanced Environmental Archives

Advanced environmental archive capabilities can help you archive user environments and associated projects.

You can set automatic reminders to back up SOLIDWORKS Electrical data and define specific date ranges for inclusion in any archive to manage process times. You can select options for:

- Custom
- All objects
- Objects modified by user
- Objects modified by user since a specific date

You can also set a reminder to create an archive on a regular schedule.

Dynamic Connector Tool

SOLIDWORKS Electrical 2015 includes a new interface for connectors that simplifies the creation, design and use of electrical connectors.

From the Insert Connector command, you can apply multiple connector types in the schema design.

This command includes options for:
• Inserting connectors dynamically
• Simplified pin swapping
• Displaying a visual circuit type indicator
• Allowing mixed circuit types
• Segmenting across schematic pages
• Creating individual schematic elements
• Creating dynamic symbols
• Used pin allocation

Another configuration option allows you to create multiple connector style templates.

Enhanced Formula Manager

The Formula Manager has been updated to simplify the creation of complex formulas. The interface has been designed to facilitate reuse of suggested and favorite formulas. It also includes syntax checking.

Over 40 additional variables are available across all formula types.

A new formula option also makes it easier for you to build and locate required marking systems, such as concatenating wire or data that specify color, gauge, size standard (AWG, mm², MCM), voltage, and frequency.

Importing and Exporting Data from Microsoft Excel

You can export project data to .xsls files for editing. You can also import data to update existing document sets, or to create and populate new project component lists.

This feature is available in the Import/Export menu.

To use this feature, you must define Excel templates under Project > Configurations > Excel export/import.

This functionality does not allow you to migrate data from one project to another project.

Inline Routing Diagnostics

The Show Errors option provides inline diagnostic support for routing. It helps you to identify issues such as duplicate components, missing CPPoints, and missing parameters and paths.

When you select Show Errors at the end of a dialog box, it displays a list of warnings and errors. You can click on an item in the graphics area, and any problems associated with that item will be displayed. If you have a problem with a path, double click the error to highlight a potential path.
Managing User Rights

SOLIDWORKS Electrical provides a new interface to set up and administer users and user groups. The tool allows you to assign user roles with different levels of authorization to manage libraries and project data.

Administrators can assign roles to users and user groups that define the tasks they can perform in the software. The following user roles are available:

- Administrator
- Library Manager
- Project Manager
- Project Editor
- Project Contributor

Previously, SOLIDWORKS Electrical only supported two basic levels of user roles.

Multipart Association to Symbol

This feature allows you to associate several schematic symbols with a single manufactured component.

After you place the primary component on the schematic you can select alternative symbols, with each symbol associated with a different circuit.

Populate Spreadsheet with BOM Data

You can export the entire contents of a SOLIDWORKS Electrical component tree to an .xls file from a BOM.

This data includes parent/child relations, book and location.

To export the BOM, click **Project > Reports > Export to Excel**.

Set Component Status to Permanent or Non-permanent

When inserting a symbol, you can define the component as permanent or non-permanent. Permanent components remain in the design tree.

In the previous version of the software, if a symbol was removed from the schematic design, the component was removed as well.

Support for the 2013 Version of DXF/DWG files

You can save a drawing as a DXF or DWG file. SOLIDWORKS Electrical supports the 2013 version of these file formats.

User Interface - Additional Enhancements

New features include major improvements to the SOLIDWORKS Electrical interface:
• The commands for the **Drawing** menu have been reorganized to two tabs. You can use the **Draw** tab to create and dimension drawings and the **Modify** tab to edit drawings.

• A new **Filter** tab in the **Manager** makes it easier to filter properties and content for symbols, 2D footprints, title blocks, and macros. When you filter a field, it will be highlighted in yellow for easy detection. You can click **Remove filters** at the top of the tab to reset filters to their default status.

• You can display properties for elements such as symbols, 2D footprints, title blocks, macros, cables and manufacturer parts.

• You can display cross references in table format by selecting **Project > Configurations > Cross References**. This interface makes it easier to read symbols.

• You can manage marks from the **Mark** tab under **Project Configuration**.

• You can display the line style and color of cable cores in the project configuration with a new **Cable Cores style** option.

• The **Macros Manager** includes a checkbox that can prevent the dialog box from closing when opening a macro.

• If you try to archive an open project that is in use by another user, a message will display telling you that it cannot be archived.

**Varied Line Width in Schematic**

You can display different line widths in the schematic based on wire type.

![Varied Line Width in Schematic](image)

**XML Export**

In the **Report manager**, you can export project data in .xml format.
This chapter includes the following topics:

- Copy Tree Enhancements
- Duplicate File Name Warnings
- Microsoft Office Add-in
- Move Tree
- Parallel Approval Data Mapping
- Predefined Transition Action Comments
- Rollback Enhancements
- Separate Move and Delete Permissions
- SolidNetWork License Manager
- User Interface Changes
- Version Number Column in Windows Explorer
- Visibility of Private State Files
- Web2 Client

Copy Tree Enhancements

The Copy Tree dialog box has been redesigned and enhanced to improve usability and make it easier to work with large data sets.

Administrators can also set user and group properties to exclude users and groups from copying files from selected folders. This prevents standard part libraries and other common components from being copied mistakenly.
In the Copy Tree dialog box:

1. **Default Destination** displays the current folder location of the selected file. You can type a new path or browse to specify the destination path.

   You can also select the **Default Destination** from the drop-down list. The list contains previously selected destination paths.

2. The **Settings** group is a collapsible interface that includes:
   - The **Version to Use** – **Latest** or **Referenced**.
   - The **Copy Type** – **Files** or **Compressed Archive**.
   - Copy **Options**, including **Include Simulation** that copies SOLIDWORKS Simulation results associated with the copied files.

3. **Filter Display** lets you enter text to refine the list of files displayed in the list. There is also a column selection drop-down that limits filtering to a specific column, for example, **File name**, or for **All Columns**. For more information, see **Copy Tree Filter Display Control**.

4. The revised table structure includes new columns and behaviors:
   - The **Type** column displays a thumbnail preview of SOLIDWORKS files when you hover over the file type icon.

109
• Currently selected rows are highlighted in blue.
• Rows you have edited are highlighted in yellow, with the modified text shown in blue and bold.
• Text you specify in Filter Display is highlighted in pink.
• When you hover over a file’s Destination Folder Path, the button displays the Browse For Folder dialog box to choose a new destination for the copied file.
• You can edit the Target File Name and Destination Folder Path in the list to change the name and destination of a copied file. The editable cells are outlined in blue for easy identification.

5. The bottom of the dialog box shows the number and type of files you have selected for copying.
6. The Transform Operations grouping shows all transform options at the top level of the dialog box.

See SOLIDWORKS Enterprise PDM File Explorer Help for details.

Copy Tree Filter Display Control

The Filter Display helps you locate files faster in the Copy Tree dialog box.

You can use Filter Display to search columns based on a text string you enter and display only rows that match the search criteria.

In the search field, enter the string to search for. By default, the filter is applied to All Columns. You can expand the All Columns list and select a specific column to apply the filter to. The software searches for the text that you enter, displays rows that contain the text, and highlights the text for easy identification.

For example, enter the text PRT and select File name as the column from the list. Filter Display searches for PRT in the File name column and displays rows that contain filenames that include PRT. The search string is not case-sensitive.

Filter Display provides the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Invert filter</td>
<td>You can invert the filter by clicking or by entering the ! character as a prefix to the text in the search field. Files that do not include the entered text are displayed.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Filter</strong></td>
<td>Filters the file list based on one or more of the following:</td>
</tr>
<tr>
<td></td>
<td>• File Type</td>
</tr>
<tr>
<td></td>
<td>• Assemblies                                                                  • Parts</td>
</tr>
<tr>
<td></td>
<td>• Drawings                                                                  • Others</td>
</tr>
<tr>
<td></td>
<td>• Selected For Copy                                                            • Yes, Selected</td>
</tr>
<tr>
<td></td>
<td>• No, Not Selected                                                                • Path/Name Changed</td>
</tr>
<tr>
<td></td>
<td>• Yes, Changed                                                            • No, Not Changed</td>
</tr>
<tr>
<td></td>
<td>When you apply the filter, the 📄 icon appears. Click 📄 to clear the filter.</td>
</tr>
<tr>
<td><strong>All Columns</strong></td>
<td>Filters the file list based on the text you enter and the column you select. You can select one of the following columns:</td>
</tr>
<tr>
<td></td>
<td>• File name</td>
</tr>
<tr>
<td></td>
<td>• Warnings                                                                     • Version</td>
</tr>
<tr>
<td></td>
<td>• Checked out by                                                               • Checked out in</td>
</tr>
<tr>
<td></td>
<td>• Found in                                                                     • Destination Folder Path</td>
</tr>
<tr>
<td></td>
<td>• Target File Name                                                              • State</td>
</tr>
<tr>
<td></td>
<td>This filter supports all custom columns that appear in the file list.</td>
</tr>
<tr>
<td><strong>Clear All</strong></td>
<td>Removes all filters. This appears when you enter text or select an option in <strong>Filter</strong>.</td>
</tr>
</tbody>
</table>

**Duplicate File Name Warnings 📄**

SOLIDWORKS Enterprise PDM warns users when they try to add files to the vault that have the same names as existing vault files. In previous releases, the software warned users when they attempted to check in the files.

A dialog box states which files have duplicate names. You can launch the dialog box from the:
• Duplicate file warning when adding files to the vault
• System tray when saving a file from an application
• Duplicate file warning when checking the files in to the vault

To display the warning, an administrator must select **Do not allow duplicate file names in this vault**. This option is available in the Administration tool in the Duplicate File Name Check dialog box for **File Types**.

When users attempt to add duplicate files, the dialog box displays the following information:

• Names of duplicate files that cannot be added
• Location where the user is trying to add files
• Locations of the existing files in the vault
• Names of users who have existing files checked out

When users click the hyperlink in the **Current Location** column, Windows Explorer view opens that lets users rename the file they are adding. There is also an option to export this list in **.csv** format. The functionality applies to all supported file types, including private state files.

**Microsoft® Office Add-in**

The Microsoft Office Add-in adds an Enterprise PDM ribbon to Microsoft Word, Excel®, and PowerPoint®. From the ribbon, users can perform vault operations and display information about the file open in the Microsoft Office application.

![Microsoft Office Add-in Ribbon](image)

Users do not need additional licenses to use the Microsoft Office Add-in. However, users must have a Contributor, CAD Editor, or PSL license to check files out and in.

You can install Microsoft Office Add-in when you install SOLIDWORKS Enterprise PDM. When you install the Add-in, the **Enterprise PDM** ribbon appears with the other Office ribbons.

The Microsoft Office Add-in lets users:

• Check out, check in, and undo check out.
• Get the latest or previous file versions.
• Display and edit Data Card information.
• Change State.
• Access the Search Tool.
• Select in Windows Explorer.
• View file status information:
  • Local Version
  • Local Revision
  • Checked Out and Workflow information

Benefits of the Add-in include:
• Easier check out and check in of Microsoft Office files.

Previously, users had to check out the file in Windows Explorer, edit it in a Microsoft Office application, and check it in to the vault via the Windows Explorer interface. Now, users can perform these actions in the Microsoft Office application.

• The ability to save in-session changes to a file that is checked in.

Previously, when users edited a checked in file, the in-session changes were lost during the check out and file caching. Now, users have a choice to apply these edits during check out.

• The ability to access older versions of files.

• The ability to change workflow state.

Move Tree

The Move Tree lets you move partial or entire file and folder structures, including related drawings, to another folder or to multiple folders.

To open the Move Tree dialog box, select the file and click **Tools > Move Tree.**

In the Move Tree dialog box:

1. **Default Destination** displays the current folder location of the selected file. You can type a new path or browse to specify the destination path.

2. The **Settings** group is a collapsible interface that includes:
• **Include simulation**: Moves SOLIDWORKS Simulation results associated to the selected files.
• **Preserve relative paths**: Keeps the paths of references relative to the moved parent file, creating a folder structure as needed. When you clear **Preserve relative paths**, the folder hierarchy is flattened and all referenced files move to the same destination folder as the parent.
• **Include drawings**: Shows any related drawing files in the file list so you can include them when moving the reference tree.
• **Regenerate serial number in cards**: When serial numbers are used in data cards, this assigns the next sequential number. For **Rename with serial number** transformations, the same serial numbers used to name the files are used in data cards.

3. **Filter Display** lets you enter text to refine the list of files displayed in the list. Additionally, there is a column selection drop-down that limits the filtering to a specific column, for example, **File name**, or for **All Columns**. For more information, see **Move Tree Filter Display Control**.

4. The revised table structure includes new columns and behaviors:
   • The **Type** column displays a thumbnail preview of SOLIDWORKS files when you hover over the file type icon.
   • Currently selected rows are highlighted in blue.
   • Rows you have edited are highlighted in yellow, with the modified text shown in blue and bold.
   • Text you specify in **Filter Display** is highlighted in pink.
   • When you hover over a file’s **Destination Folder Path**, the button displays the Browse For Folder dialog box to choose a new destination for the moved file.
   • You can edit the **Target File Name** and **Destination Folder Path** in the list to change the name and destination of a moved file. The editable cells are outlined in blue for easy identification.

5. The bottom of the dialog box shows the number and type of files you have selected for moving.

6. The **Transform Operations** grouping shows all transform options at the top level of the dialog box.

The transform operations let you rename target files before you move them.
• **Add Prefix**: Adds the prefix you type to the target file names.
• **Add Suffix**: Adds the suffix you type to the target file names.
• **Rename with serial number**: Replaces target file names with serial numbers.
• **Replace**: Replaces strings in target file names.

Click **Reset All** to revert to the original names.

The permissions required to move a file or folder are:
• **Read file contents**: For the source and destination folders
• **Move Folder**: For the folder(s) to be moved
• **Add or Rename Folder**: For the destination folder
• **Move File**: For files to be moved

See *SOLIDWORKS Enterprise PDM File Explorer Help* for details.

### Move Tree Filter Display Control

The Filter Display helps you locate files faster in the Move Tree dialog box.

You can use **Filter Display** to search columns based on a text string you enter and display only rows that match the search criteria.

In the search field, enter the string to search for. By default, the filter is applied to **All Columns**. You can expand the **All Columns** list and select a specific column to apply the filter to. The software searches for the text that you enter, displays rows that contain the text, and highlights the text for easy identification.

For example, enter the text **PRT** and select **File name** as the column from the list. **Filter Display** searches for **PRT** in the **File name** column and displays rows that contain filenames that include **PRT**. The search string is not case-sensitive.

**Filter Display** provides the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Invert filter</strong></td>
<td>You can invert the filter by clicking △ or by entering the ! character as a prefix to the text in the search field. Files that do not include the entered text are displayed.</td>
</tr>
<tr>
<td><strong>Filter</strong></td>
<td>Filters the file list based on one or more of the following:</td>
</tr>
<tr>
<td></td>
<td>• <strong>File Type</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Assemblies</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Parts</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Drawings</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Others</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Selected For Move</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Yes, Selected</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>No, Not Selected</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Path/Name Changed</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Yes, Changed</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>No, Not Changed</strong></td>
</tr>
</tbody>
</table>

When you apply filter, the △ icon appears. Click △ to clear the filter.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>All Columns</strong></td>
<td>Filters the file list based on the text you enter and the column you select. You can select one of the following columns:</td>
</tr>
<tr>
<td></td>
<td>• File name</td>
</tr>
<tr>
<td></td>
<td>• Warnings</td>
</tr>
<tr>
<td></td>
<td>• Version</td>
</tr>
<tr>
<td></td>
<td>• Checked out by</td>
</tr>
<tr>
<td></td>
<td>• Checked out in</td>
</tr>
<tr>
<td></td>
<td>• Found in</td>
</tr>
<tr>
<td></td>
<td>• Destination Folder Path</td>
</tr>
<tr>
<td></td>
<td>• Target File Name</td>
</tr>
<tr>
<td></td>
<td>• State</td>
</tr>
<tr>
<td><strong>Clear All</strong></td>
<td>Removes all filters. This appears when you enter text or select an option in <strong>Filter</strong>.</td>
</tr>
<tr>
<td></td>
<td>This filter supports all custom columns that appear in the file list.</td>
</tr>
</tbody>
</table>

### Moving a File Structure to Multiple Folders

Users can move a file structure to multiple folders using the Move Tree functionality.

**To move a file structure to multiple folders:**

1. Select the parent file and click **Tools > Move Tree**.
2. In the Move Tree dialog box, in **Default Destination** click **Browse** to navigate to the primary destination folder.
3. To specify other folder locations for specific files:
   a) Select the file.
   b) In the **Destination Folder Path** column, click $\rightarrow$ and navigate to the destination folder.
4. Set the remaining options.
5. In the file list, under **Move**, select the references to move.
6. Click **Move**.

### Parallel Approval Data Mapping

An administrator can configure SOLIDWORKS Enterprise PDM to capture user and system data for each user who participates in a parallel approval process.

The software captures data each time a member of a role completes a transition. It writes the data to the data card and any mapped properties when the required number of users have given their approval. In previous versions, it was only possible to capture data for the last required approver who transitioned a file.
An enhanced Set Variable transition action dialog box lets administrators select users from various roles to capture data from. There is also an override that lets you capture data from a specific user irrespective of users who actually transitioned the file.

**To set parallel approval data mapping:**

1. In the Administration tool, expand **Workflows** and select a workflow.
2. Select a transition.
3. In the Properties dialog box, for **Type**, select **Parallel**.
4. On the Actions tab, click **Add Action**.
5. In the dialog box, for **Type**, select **Set Variable**.
6. Select the **Variable** and enter the **Value**.
7. Expand **Mapped Approvers** and select approvers.

8. Click **OK** twice.
9. Save the workflow.

If you select **Override Approver Value**, radio buttons replace check boxes, and you can select only one user.

See **SOLIDWORKS Enterprise PDM File Explorer Help** and **Administration Tool Help** for details.

**Predefined Transition Action Comments**

To provide better information to users about file versions, administrators can add predefined transition comments for automatic transitions and transition actions that set variables or increment revisions.

Users can see these comments in file histories and Get Version lists.

**To add predefined transition action comments:**

1. In the Administration tool, expand **Workflows** and select a workflow.
2. Select a transition.
3. In the transition Properties dialog box of the transition you selected, select a **Type**.
4. On the Actions tab, click **Add Action**.
5. In the Transition Action dialog box, select an action **Type**:
   - **Comment.** Enter a comment for **Transition Comment**.
     
     This action type is only available for the **Automatic** transition.
   
   - **Inc. Revision.** Enter a comment for **Revision Comment**.
   - **Set Variable.** Enter a comment for **Version Comment**.

   **Version Comment** is shared for all set variable actions on a transition.

6. Click **OK** twice.
7. Save the workflow.

If you create an **Automatic** transition with a comment and change the transition to Parallel or Normal, a warning message appears. Click **OK** to delete the transition action comment and change the transition type or click **Cancel** undo the change.

The following History dialog box shows the transition action comments. The first three comments are for increment revision, transition action, and set variable respectively.
Rollback Enhancements

Rolling back a file now resets the revision counter to match the revision label. Previously, the counter was not changed resulting in out-of-sequence revisions. You can also add comments that appear in the file's history when performing a rollback operation.

The rollback operation permanently deletes versions, revisions, and transitions created after the selected event in the file's history.

To add rollback comments:

1. In the Windows Explorer file view, right-click a file and click **History**.
2. Select the event to roll back to.
3. Click **Rollback**.
4. In the dialog box, enter a comment and click **Continue Rollback**.
   
   You can see the comment in the History dialog box.
5. Click **Close**.

**Separate Move and Delete Permissions**

To provide more granular administrative control of user permissions, Enterprise PDM provides separate Move and Delete permissions for files and folders.

To move files, an administrator must enable the **Add or Rename File** permission for the destination folder.

**To set move and delete permissions:**

1. In the Administration tool, expand **Users** or **Groups**.
2. Double-click a user or group.
3. In the dialog box, click **Folder Permissions**.
4. On the Permissions per Folder tab, select a folder for which you want to grant permissions.
5. Select the appropriate permission for what the user needs to do:
   - **Delete File**
   - **Move File**
   - **Delete Folder**
   - **Move Folder**

   In previous releases, only **Delete File** and **Delete Folder** permissions were available.

6. Use the State Permissions page to let users move and delete files while changing state.

   There are no move or delete folder permissions for State Permissions.
SolidNetWork License Manager

SOLIDWORKS Enterprise PDM 2015 now uses the SolidNetWork License (SNL) Manager to manage licenses. In previous versions, licensing was controlled inside the SQL database.

Licensing with the SNL Manager provides control and visibility to license usage and lets you use the same SNL Manager to manage Enterprise PDM license as other SOLIDWORKS products. Administrators can check the SNL Manager to see available licenses and allow or restrict user access to the vault. Administrators can reserve or refuse certain license types using the FlexNet options file. For information on using the options file, see http://www.solidworks.com/sw/support/Administration_guides/ServicePacks.html.

To run SOLIDWORKS Enterprise PDM 2015, install SNL Manager 2015 is included with the SOLIDWORKS Enterprise PDM installation media. Activate your licenses using your assigned 24-digit SOLIDWORKS Enterprise PDM serial number. Serial numbers were generated when you originally purchased SOLIDWORKS Enterprise PDM. You can obtain registered serial numbers from the My Products section on the SOLIDWORKS Customer Portal. If you do not know your SOLIDWORKS Enterprise PDM serial number or if it is 16-digit, contact your SOLIDWORKS Value Added Reseller (VAR) to obtain the 24-digit serial number.

Activating SOLIDWORKS Enterprise PDM licenses is similar to activating a SOLIDWORKS SNL license. You cannot combine SOLIDWORKS Enterprise PDM network installation with SOLIDWORKS network installations, although you can manage both Enterprise PDM and SOLIDWORKS on the same SNL Manager. If you do not have a SOLIDWORKS network installation, there is no network installation fee for SOLIDWORKS Enterprise PDM. However, if you later purchase any other SOLIDWORKS network products, you must pay the normal network installation fee.

For more information on activating and setting up the SolidNetWork License Manager, refer to SOLIDWORKS Customer Portal or SOLIDWORKS Enterprise PDM Administration Tool Help.
User Interface Changes

Many of the common user interfaces and system icons have been enhanced to provide a better user experience.

Quick Info Icons for File Lists

Enterprise PDM provides a new set of quick info icons in the SOLIDWORKS add-in and file lists.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Version tab, Windows Explorer, and Search Results File Lists</th>
<th>SOLIDWORKS Enterprise PDM Add-in</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>![Icon]</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>![Icon]</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>![Icon]</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>![Icon]</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>![Icon]</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>![Icon]</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>

- **Icon meaning**
  - References a file that is not the latest version. This icon appears next to the parent file and the referenced child file if the "As built" (last checked in) version of the parent does not reference the latest version of the child.
  - The local file version is older than the latest vault version.
  - The local file version is newer than the latest vault version. This icon appears when you modify a file and save it locally but do not check it in.
  - The local file version is not in the vault or is a private state file. This icon appears in the SOLIDWORKS Enterprise PDM Add-in for files either in the user’s cache or located outside the vault.
  - The local file version is the same as the latest vault version.
  - The local file version is modified in SOLIDWORKS but not yet saved. This icon appears when a user modifies a file or when SOLIDWORKS has done a rebuild or an update.
  - The file is checked in by another user during the current SOLIDWORKS session. This icon appears with the older version icon when another user checks in a file that was opened as read-only before you check it in.
Table Formats

Tables and controls have been reformatted for ease of use.

These improvements apply to the Bill of Materials, Contains, and Where Used tabs and many dialog boxes.

The revised table structure includes the following:

- A **Type** column displays a thumbnail preview of SOLIDWORKS files when you hover over the file type icon.

- A **Warnings** column that displays only warnings replaces the **Result** column.
- Rows are highlighted in light blue when you hover over them.
- Selected rows are highlighted in blue.

Editing of column text is more visible on the Bill of Materials tab and in the Copy Tree, Move Tree, Generate Item, and Create File References dialog boxes.

- Editable cells are outlined in blue.
- Rows you have edited are highlighted in yellow, with the modified text shown in blue and bold.

Additional changes to the Bill of Materials tab include:

- The column that displays a thumbnail preview of SOLIDWORKS files shows a new header, **Type**.
- If you sort on a column, the column is highlighted in green.
- A quantity you have edited appears in blue and bold instead of in green.
- When you save a change to the quantity, an orange bar appears to the left of the updated text.
- Full cell highlighting that was used in previous releases for BOM compare is replaced by highlighting on the edge of the cell.
- Orange bars appear to the left of edited cells when you compare BOMs.
- A green bar appears to the left of each cell when you add a new row and compare.
- A red bar appears to the left of each cell when you delete a row and compare.

Below shows user interface changes in a named BOM. The row that is currently being edited is highlighted in yellow. Orange bars indicate text that has been edited and saved.
Version Number Column in Windows Explorer

To improve cache management and awareness, you can view version information in the Windows Explorer and Search tool file lists.

Administrators can add the **Version Number** column using the Customizable Column dialog box in the Administration tool. The column displays the local version and the latest vaulted version numerically.

Users can sort files in the list by clicking the **Version Number** column. Files are sorted in the following order:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>The local file is the same as the latest vault version.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>The local file is not in the vault or is a private state file.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>The local file is newer than the latest vault version.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>The local file is older than the latest vault version.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>The file is not cached.</td>
</tr>
</tbody>
</table>

This column is blank for folders in the vault and displays the ![Icon] icon for folders that are not in the vault.

**Adding a Version Number Column to File Lists**

Administrators can either create a new column set or edit an existing column set to add the **Version Number** column. The column appears when users enable the detail view in Windows Explorer.

**To add a Version Number column to file lists:**

1. In the Administration tool, right-click **Columns** and click **New Column Set**.
2. In the dialog box, enter the **Column set name**.
3. For **Type**, select **File List**.
4. Click **New Column**.
5. For **Variable**, select `<Version Number>`.
   * **Version Number** appears in the **Columns** list.
6. Under **Users**, select users who can view the new column.
7. Click **OK**.

**Adding a Version Number Column to Search Results**

**To add a Version Number column to search results:**

1. In the Administration tool, expand **Cards** and **Search Cards**.
2. Double-click **Complete Search**.
3. In the dialog box, under **Card Properties**, for **Result column set**, select `<New Column Set>`.
4. In the dialog box, enter the **Column set name**.
5. Under **Columns**, click **New Column**.
6. To add a **Version Number** column, for **Variable**, select `<Version Number>`.
7. To add other columns such as **Name** and **Checked Out By**, for each column, repeat steps 5 and 6.

8. To modify the column order, select the column and click ![Move Up](#) or ![Move Down](#). The column order is shown in the **Preview**.
9. Click **OK**.
10. In the **Card Editor**, under **Card Properties**, for **Result column set**, select the column set name that you entered in step 4.
11. Ensure that **Users who may use the form** is selected.
12. Save the Search Card.

**Quick Info Icons on the Version Tab**

Icons on the Version tab let you see a file’s status at a glance. These icons appear whether the **Version Number** column is enabled or not.

When you select a file, the same quick information icons that are used in the **Version Number** column show the file’s status.

The ![Document](#) icon appears when you:
- Do not select a file
- Select a folder
- Select multiple files

Additionally, if you select a file that does not have the latest local version, a warning message appears.
Visibility of Private State Files

To make it easier to coordinate file names and project work, administrators can give users and groups permission to see files that are in the private state. These are files that other users have added to the vault, but have not yet checked in.

In earlier releases, only administrators could see these files. Making private state files visible to selected users helps to prevent problems like duplicate designs and redundant part numbers. The details of the file appear in italics in the Windows Explorer file view and search results. Users cannot perform any actions on private state files.

For a file in the private state:

- In file view or search results:
  - The **Checked Out By** column displays the file owner
  - The **Version Number** column displays which represents a file that is not in the vault

<table>
<thead>
<tr>
<th>Name</th>
<th>Checked Out By</th>
<th>Size</th>
<th>Version Number</th>
<th>File Type</th>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>abc.txt</td>
<td>Admin</td>
<td>0 bytes</td>
<td>1/1</td>
<td>Text Document</td>
<td>&lt;Private State&gt;</td>
</tr>
<tr>
<td>Test Dustin</td>
<td>Admin</td>
<td>0 bytes</td>
<td>1/1</td>
<td>Text Document</td>
<td>&lt;Private State&gt;</td>
</tr>
</tbody>
</table>

- The Data card, Bill of Materials, Contains, and Where Used tabs display the message, **This information is not available because the file has never been checked in.**

- The Version tab displays:

Local version: 1
Latest version: 2
Latest revision: No revision
Local state: Under editing
Category: Workflow Default Workflow
Replicated to: All Servers

You do not have the latest version of this file on your local hard disk.
Permitting Users to See Private State Files

Administrators can allow users to see files that are in the private state by granting Folder Permissions.

This permission is not available for State Permissions because the file is not in any workflow.

1. In the Administration tool, expand Users or Groups.
2. Double-click a user or group.
3. In the dialog box, click Folder Permissions.
4. On the Permissions per Folder tab, select a folder for which you want to grant permissions.
5. Select May see files before initial check in (Private State).
6. Click OK.

Web2 Client

Web2 client is a Web client that lets users connect to an Enterprise PDM vault from most devices with an Internet browser. Web2 client is beneficial for external and internal users who are not connected to their office network or have an unsupported operating system.

Access to Web2 is included with SOLIDWORKS Enterprise PDM using either a Web or a Viewer license. The Web license comes with each CAD Editor, Contributor, or PSL license. Web2 client works with browsers such as Microsoft Internet Explorer, Google® Chrome™, Mozilla® Firefox®, and Apple® Safari®. Using the Web2 client with Internet Explorer lets users dynamically view SOLIDWORKS files using the eDrawings ActiveX® plug-in.

The eDrawings ActiveX plug-in requires eDrawings to be installed on users' machines.

Web2 client lets users connect to an Enterprise PDM vault from a mobile digital device such as an iPhone® to browse folders, view file information and thumbnails, search, and change file states.
Some advantages of Web2 client over the existing Web Client:

- Viewing capabilities for many file types such as PDF, Word, Excel, and PowerPoint
- Browser independence
- No client installation requirements
- Transition action support such as setting revision variables

Other capabilities include:

- Quick searching and viewing of vault data.
- A mobile version for small hand held devices like smartphones.
- The ability to preview multiple file types.
- eDrawings previews of SOLIDWORKS files when accessed with Internet Explorer.
- Thumbnail previews of SOLIDWORKS files when accessed with other browsers or via the mobile version.
- The ability to open SOLIDWORKS files with the eDrawings application for iPhone, iPad®, and Android.
- Contains and Where Used information.
- State change capabilities.
- Editing capabilities.

Web2 is not included with the SOLIDWORKS Enterprise PDM 2015 installation media. For more information on Web2, contact your SOLIDWORKS Value Added Reseller (VAR).
Available as a separately purchased product that can be used with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

This chapter includes the following topics:

- **Advanced Solver Control**
- **Compare Improvements**
- **Pack and Go Support**
- **Rotating Mesh**
- **Time-dependent Analysis**
- **Usability Improvements**

### Advanced Solver Control

You can specify advanced parameters governing the flow simulation calculation.

With the advanced solver:

- New global goals for mass, energy, and momentum balance help you control the convergence of the task. To access the new goals, click **Insert > Global Goals**.
- To minimize the results file size, you can select which parameters to save. To select parameters, go to the Saving tab in the Calculation Control Options dialog box.

### Compare Improvements

With the **Compare** tool, you can compare the results of various projects coming from configurations within the same model.

You can:

- Compare XY plots.
- Display tabular data results as a bar chart.
Pack and Go Support

When using Pack and Go, SOLIDWORKS Flow Simulation results are included in the folder or zip file that you create.

Click File > Pack and Go. In the Pack and Go dialog box, select Include simulation results and click Save.

Rotating Mesh

You can simulate Fluid Driving motion with enhanced rotating regions.

The “sliding mesh” mode simulates rotating equipment where fluid flow entering the rotor is highly non symmetric with regard to the axis of rotation.

Since angular velocity can be dependent on time, you can simulate motion at a specified angle.
To use the rotating mesh mode:

1. In the General Settings dialog box, under Analysis, select Rotation.
2. Select Local Region (Sliding Mesh).

Time-dependent Analysis

SOLIDWORKS Flow Simulation solves the time-dependent form of the Navier-Stokes equations.

Improvements for unsteady (transient or time-dependent) problems include:

- Faster transient analysis calculation
- The ability to stop the calculation when a goal reaches a specified value
- The ability to save time averaged results

Usability Improvements

Usability improvements include:

- **Ability to specify BCs based on discrete values.** You can set an integral boundary condition and heat flux by importing a table of discrete values which are further interpolated on the selected geometry reference. You can use a table from an experiment or another simulation.
- **Equation Editor.** You can add gravity (G) and PI into the Equation goal formula.
- **Batch Run Projects.** In the Batch Run dialog box, projects appear in the same order as in the project tree.
- **Porous media data.** A set of commercially available filter data is included in the Engineering database.
- **CFD preparation while solving.** You can pre- and post-process other Fluid Flow projects while another is calculated.
- **Multi-edit improvement.** You can use multi-edit to change Solid Materials.
- **Radiant heat flux intensity as a function of wavelength property output.** For wavelength dependent analysis (DO radiation model), you can display radiant flux separately for each bend.
- **Leak tracking.** The connection between components in the **Leak Tracking** tool is displayed as a two color band to help identify the gap location.

- **Component Explorer.**
  - The **Component Explorer** lets you quickly observe the material settings defined in the analysis by component. Click **Tools > Component Explorer**.
  - You can adjust material priority for overlapping components.

- **Search material.** You can perform a quick material search by name in the Material step of the General Settings dialog box.
This chapter includes the following topics:

- **3D Printing**
- **Exporting a SOLIDWORKS Model for Use with AEC Software**
- **NX Files**
- **Viewpoint Translator**

### 3D Printing

With Microsoft Windows 8.1, you can print directly to a 3D printer from the SOLIDWORKS software.

After you set the print options in the 3D Print PropertyManager, Windows 8.1 handles all communication with the 3D printer. A preview of the print bed and the model's location within the print bed lets you modify settings before committing to a 3D print job.

To access the 3D print dialog box and specify print options, click **File > Print3D**.

The print dialog box that is available depends on your installed 3D print driver.

You can also export part and assembly files to Additive Manufacturing File Format (AMF), an XML-based format designed to support additive manufacturing processes like 3D printing. In addition to the model geometry, an AMF file can contain information about the color and materials of objects for 3D printing.

**To export a file to AMF format:**

1. Click **File > Save as**.
2. In the dialog box, for **Save as type**, select **Additive Manufacturing File Format (*.amf)**.
3. To specify export options, click **Options**.

### Exporting a SOLIDWORKS Model for Use with AEC Software

The Export to AEC Wizard helps you prepare a SOLIDWORKS model so you can import it into AEC software.

The wizard guides you to specify the model host plane (floor based, ceiling/roof based, or wall based) and the level of de-featuring to apply. You can preview your choices in the graphics area before saving the properly oriented, simplified file in .sat format. The resulting file uses the reference coordinates you provide in the wizard.
1. Open the model to export.

2. Click Export to AEC (Tools toolbar) or Tools > Export to AEC.

3. In the PropertyManager, under Define Host:
   a) Select the type of host component: Floor Based Component, Ceiling/Roof Based Component, or Wall Based Component.
   b) Use the flyout FeatureManager design tree to select the host reference plane.
   c) Optionally, select Flip Normal to reverse the default axis orientation.
      By default, the output coordinate system for a:
      • Floor or ceiling/roof based component is defined with +Z normal to the floor plane.
      • Wall based component is defined with +Y normal to the wall reference plane.
   d) On the model, select a reference point.

4. Click .

5. On the Specify Export Detail page, under Set Target Model Details, select one of the following and click Generate Preview to open a second graphics window with a preview of the amount of detail that will be exported:
   • High
      The model is exported as is, without removing any details.
      The preview shows the model in the orientation expected for AEC products.
- **Medium**

All internal components are removed and internal cross section geometry is removed and made solid. Fillets and chamfers with less than one inch radii are removed and holes under two inches in diameter are suppressed.

- **Low**

All internal components are removed and internal cross section geometry is removed and made solid. Fillets and chamfers with less than two inch radii are removed. Holes under three inches in diameter and extrudes less than three inches in total depth are suppressed.
Custom

Generate Preview is unavailable. Click 🔄 to start the defeature process.

See SOLIDWORKS Help: Defeature Tool.

6. Click 🔄.
7. Click Save As .SAT.
8. Specify the file name and save location and click Save.

NX Files

The SOLIDWORKS software supports import of NX® 8 and NX 8.5 files.

Viewpoint Translator

The Viewpoint® translator add-in is no longer in the software because it does not have a 64-bit module.
16
SOLIDWORKS Inspection

This chapter includes the following topics:

- SOLIDWORKS Inspection Add-In
- SOLIDWORKS Inspection Standalone

SOLIDWORKS Inspection Add-In

**Export to SOLIDWORKS Inspection Project**

You can export a SOLIDWORKS Inspection project to the standalone application to continue inspection work.

Designers or quality inspectors can generate ballooned drawings and inspection reports in the SOLIDWORKS software using the SOLIDWORKS Inspection add-in. Then, quality inspectors can open the inspection project (*.ixprj) in the standalone application where they can enter measurements and import coordinate measuring machine (CMM) results.

**Project Templates**

You can create project templates in the SOLIDWORKS Inspection add-in to save project properties and speed up the creation of inspection documents.

When starting a new inspection project, you are prompted to select a template. SOLIDWORKS Inspection includes several templates, or you can add other project templates. By default, templates are located in `C:\ProgramData\SOLIDWORKS\SOLIDWORKS Inspection Addin\Templates`.

After you create an inspection project, you can save all of the settings in a new template using **Create New Template**.

Project templates include:

- Auto balloons
- Extraction settings
- Characteristic information, such as classification and sorting
- Vendor list
- Balloons shape & appearance
- Default tolerances

**Usability Improvements**

SOLIDWORKS Inspection add-in improvements include:
• Buttons with similar functionality are grouped for increased clarity in the CommandManager, PropertyManager, and menu.
• You can create a ballooned PDF of a drawing directly from the add-in using Export to PDF. It is not necessary to use Save As.
• Basic dimensions appear framed on the drawing, and reference dimension values are enclosed within parentheses.

SOLIDWORKS Inspection Standalone

Encrypted PDF Support
You can open encrypted PDFs in SOLIDWORKS Inspection. When you add an encrypted PDF to the inspection project, you are prompted to enter the password.

Rescaling Drawings
You can rescale drawings if they were not properly scaled.
Incorrectly scaled PDFs are often the results of scanned documents. Improperly scaled drawings often have balloons that are either too small or too large. Use the Drawing tab in Project Options to add or remove drawings and rescale them.

If SOLIDWORKS Inspection detects that a drawing is improperly scaled, it is listed with a warning icon in Project Options and you are prompted with a warning message that allows you to change the scaling and fix the project.

Usability Improvements
SOLIDWORKS Inspection standalone improvements include:
• You can extract notes from a searchable text PDF document using Optical Character Recognition (OCR) or Searchable Text. To toggle between OCR and Searchable Text, right-click in the drawing, and click Toggle OCR.
• You can edit fields directly in the bill of materials instead of using the characteristic properties.
• Basic dimensions appear framed on the drawing, and reference dimension values are enclosed within parentheses.
• You can reuse a number from the retired numbers list by right-clicking the number in the characteristic table and clicking Reuse Characteristic Number.
• If you change a default tolerance, the software automatically updates the characteristics.
• In Measurements Input, you can rename column headers, for example, Part Number Inspected, Sample Name, Date, and Time.
SOLIDWORKS MBD (Model Based Definition) lets you create models without the need for drawings giving you an integrated manufacturing solution for the SOLIDWORKS software.

SOLIDWORKS MBD helps companies define, organize, and publish 3D product and manufacturing information (PMI), including 3D model data in industry standard file formats.

- SOLIDWORKS MBD offers 3D PMI definition capabilities using DimXpert and reference dimensions.
- You can use SOLIDWORKS technologies such as annotation views, dynamic viewing of annotation planes and 3D views to organize 3D PMI in a structured, easy-to-locate fashion.
- Besides the native SOLIDWORKS file formats, SOLIDWORKS MBD creates output files such as 3D PDF and eDrawings.

SOLIDWORKS MBD guides the manufacturing process directly in 3D:

- By avoiding the unnecessary and costly revision of 2D drawings, SOLIDWORKS MBD streamlines production, cuts cycle time, and improves communication with the supply chain.
- By using intuitive 3D interaction and rich metadata properties that reduce manufacturing errors.
- By providing help to meet industry standards such as MIL-STD-31000 Rev A and ASME 14.41, which gives a competitive advantage in winning contracts.

The SOLIDWORKS MBD add-in:

- Operates within the SOLIDWORKS environment with its own CommandManager.

- Supports all native SOLIDWORKS 3D part and assembly data, such as configurations, constraints, and PMI.

This chapter includes the following topics:
3D Views for Model Based Definition

To support MBD, you can create 3D views of parts and assemblies that contain the model settings needed for review and manufacturing. The output you create lets users navigate back to those settings as they evaluate the design. Similar to 2D drawing views, except these views are in 3D.

Use the tools on the SOLIDWORKS MBD CommandManager to set up a model with selected configurations, including exploded and model break views, annotations, display states, zoom level, view orientation, and section views. You then capture those settings so that you and other users can return to them using the 3D Views tab.

To access the 3D Views tab, click the 3D Views tab at the bottom of the SOLIDWORKS window:

A resizable pane appears at the bottom of the screen. It includes 3D View controls that let you:

- Capture 3D views
- Update the previews that represent the views when the model changes
- Publish 3D views to 3D PDFs and eDrawings files

**Capture 3D View** opens the Capture 3D View PropertyManager, where you specify the 3D view name, and the configuration, display state, and annotation view to capture.

**Capture 3D View** also captures information about the file, including exploded and model break views, zoom level, view orientation, section views, and the current settings from **Hide/Show Items** in the Heads-Up View toolbar.

When you capture a 3D view, the view name and a preview are added to the 3D Views tab. To see the details of a view, hover over its preview. To switch views, double-click a view. The view is outlined and the display in the graphics area changes to the selected view.
When you make changes to models such as modifying a dimension, click **Update Previews** to update the preview images/thumbnails.

On the left side of the 3D Views tab, publish buttons let you output your model and 3D views in a neutral file format:

<table>
<thead>
<tr>
<th><strong>Publish to 3D PDF</strong></th>
<th>Creates a shareable 3DPDF model file with 3D PMI integrated. These model files are based on templates that you can edit using the SOLIDWORKS 3DPDF Template Editor.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Publish eDrawings File</strong></td>
<td>Publishes the file in SOLIDWORKS eDrawings.</td>
</tr>
</tbody>
</table>

To make more space in the graphics area, click on the top right of the 3D Views tab. The 3D Views tab collapses, leaving thumbnails that represent the 3D views. When you hover over a thumbnail, the same details appear, including a larger preview image.

**Dynamic Annotation Views**

Available in SOLIDWORKS MBD. You can control how annotations are displayed when you rotate models.

When you activate **Dynamic Annotation Views**, you see only the annotation views that are relevant to the current model orientation. As you rotate the model, annotation views that are not normal to the model orientation fade away, while annotations appear as they approach normal.
Annotation views are automatically set as the active view when they are displayed using **Dynamic Annotation Views**.

To activate **Dynamic Annotation Views**, do one of the following:

- Click **Dynamic Annotation Views** (SOLIDWORKS MBD CommandManager).
- In the FeatureManager design tree, right-click **Annotations** and click **Dynamic Annotation Views**.

The annotation types you see when you select **Dynamic Annotation Views** depend on the annotation types you select on the **Annotations** shortcut menu or Annotation Properties dialog box. Available options are:

- **Show Feature Dimensions**
- **Show Reference Dimensions**
- **Show DimXpert Annotations**
- **Show Reference Annotations**. Displays annotations that are not dimensions, including reference dimensions, balloons, surface finish symbols, weld symbols, geometric tolerance symbols, datum feature symbols, and datum targets.

**Show All Views in Dynamic View Mode.** Shows all annotation views regardless of their show/hide state in the **Annotations** folder of the FeatureManager design tree. When cleared, only annotation views that are not hidden are shown.

**Model Break Views ✗**

Available in SOLIDWORKS MBD.
You can add breaks to models using the **Model Break View** tool. Model break views are saved as configurations.

Model break views, also known as broken views or interrupted views, are helpful when you need to shorten model components, especially for technical documentation and marketing purposes.

**Creating Model Break Views in Parts**

To create model break views in parts:

1. Open `install_dir\samples\whatsnew\parts\model break views\brace strip.sldprt`.
2. Click **Insert > Model Break View**.
3. In the graphics area, use the handles to move the red and green planes approximately as shown.

4. In the PropertyManager, under **Model Break Steps**, click **Apply**. A break appears where you placed the break lines.

5. In the PropertyManager, under **Model Break Steps**, click **Add Step**.
6. In the graphics area, use the handles to move the red and green planes approximately as shown.
7. In the PropertyManager:
   a) Click the Styles tab.
   b) Under Style, click Zig Zag Break.
   c) Click .

A new derived configuration, Model Break View1, with two break steps, is added under the Default configuration.

Creating Model Break Views in Assemblies

To create model break views in assemblies:

1. Open install_dir\samples\whatsnew\parts\model break views\flow body.sldasm.
2. Click Insert > Model Break View.
3. In the graphics area, use the handles to move the red and green planes approximately as shown.
4. In the PropertyManager:
   a) Click the Styles tab.

   b) Under Style, click Pipe Break.

   c) For Method, click Individual Breaks.

   d) Under Properties:
     • Set Gap to 100.
     • Move the Shape Intensity control about half way between the center and High.
     • Set Angle to 15°.

   e) Click ✓.

Although the break is applied, the dimension, 2215, remains the same.
Customizing a Template

Available in SOLIDWORKS MBD.
You can customize a template by including features such as a background, text blocks, and images.

**To customize a template:**

1. Click **3D PDF Template Editor** 📝 (SOLIDWORKS MBD toolbar).
2. In the SOLIDWORKS 3D PDF Template Editor, set the template options.
3. Click **Save**.

To use a custom 3D PDF template, add the file location to the **3D PDF Themes** folders. Click **Tools > Options > System Options > File Locations**. In **Show folder for**, select **3D PDF Themes**. Click **Add**, browse to the custom 3D PDF templates, and click **OK**.

### 3D PDF Template Editor Options

<table>
<thead>
<tr>
<th>Icon</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📜</td>
<td>New</td>
<td>Creates a new template.</td>
</tr>
<tr>
<td>📝</td>
<td>Open</td>
<td>Opens a saved template.</td>
</tr>
<tr>
<td>📜</td>
<td>Save</td>
<td>Saves the template to the same name and location.</td>
</tr>
<tr>
<td>📜</td>
<td>Save As</td>
<td>Saves the template to a new name and location.</td>
</tr>
<tr>
<td>🗑️</td>
<td>Delete Theme</td>
<td>Deletes the template.</td>
</tr>
<tr>
<td>🔍</td>
<td>Undo</td>
<td>Reverses the last action.</td>
</tr>
<tr>
<td>📝</td>
<td>Snap</td>
<td>Snaps the selected entity to other template entities.</td>
</tr>
<tr>
<td>📜</td>
<td>Fit to Window</td>
<td>Zooms the page to fit in the entire window.</td>
</tr>
<tr>
<td>📜</td>
<td>Change Background</td>
<td>Sets a background image for the template.</td>
</tr>
<tr>
<td>📜</td>
<td>Page Setup</td>
<td>Sets the template size and orientation.</td>
</tr>
</tbody>
</table>
| **Insert Image** | Inserts an image on the template. The image can be moved and resized in the template editor. Set options:
|                  | • **Change Image** to select a different image.
|                  | • **Reset to Original Size**  to restore the image size.
|                  | • **Lock Aspect Ratio**  to maintain the ratio of width to height.
|                  | • **Delete** to remove the image. |

| **Insert BOM Table** | Inserts a BOM placeholder in an assembly document. When you publish to 3D PDF, the BOM from the assembly appears in the BOM placeholder. |
Insert Text

Inserts a text placeholder. Set options:

- **Template text field.** Places a text box on the template. Specify text when creating the template to display on every document.

- **Text field.** Places a text box on the template. You can specify text when publishing the 3D PDF in the SOLIDWORKS software. Set the font family, size, color, and type text in the text box.

- **Custom property field.** Places a text box on the template. You can choose a custom property value to display when publishing the 3D PDF in the SOLIDWORKS software.

- **PDF form field.** Places a text box with a text fill-in area on the template. You can enter text in the published 3D PDF document.
Publishing a Model to 3D PDF

To publish a model to 3D PDF:

1. Click **Publish to 3D PDF** (SOLIDWORKS MBD toolbar).
2. In the PropertyManager, in:
   a) **Template**, select a template or click **Manage 3D PDF Templates** to create or edit a template.
   b) **Views to Include**, select the views. Views include orthographic views, axonometric views, the current model view, name views, and 3D views.
   c) **Output Details**:
      - In **File name**, enter a file name or browse to a location to save the 3D PDF file.
      - To include custom text, click **Text fields**. In the Custom Text dialog box, in each line, enter the text to display on the page when publishing the 3D PDF, then click **Close**.
      - To include custom properties, click **Custom property fields**. In the Custom Property Text dialog box, select a custom property value to display when publishing the 3D PDF, then click **Close**.
      - To display the PDF file after saving, select **View PDF after saving**.
3. Click ✔️.

The PDF file is saved in the location specified in **File name**.
This chapter includes the following topics:

- **Hiding New Components in Display States**
- **Isolate**
- **Lighting for PhotoView 360 and SOLIDWORKS**
- **Link Display States to Configurations Option**
- **Manipulating Decals**
- **PhotoView 360 Render Region**
- **Previewing Hidden Bodies or Components**

### Hiding New Components in Display States

You can set the properties of specific display states so that new components that are inactive are hidden in those display states.

**To hide new components in display states:**

1. On the ConfigurationManager tab, right-click a display state and click **Properties**.
2. In the PropertyManager, select **Hide new components when inactive**.
3. For **Apply to**, select one of the following:
   - **This display state**
     New components are hidden in the current display state.
   - **All display states**
     New components are hidden in all display states.
   - **Specify display states**
     Select the display states where new components will be hidden.
4. Click ![Apply](apply_icon.png).

### Isolate

When you use the **Isolate** tool to isolate a body in a part, you can save the display characteristics of the body to a new display state.

In a part, right-click a body and click **Isolate**. In the dialog box, click **Save as Display State** ![Save button](save_icon.png).
Lighting for PhotoView 360 and SOLIDWORKS

The controls you use to adjust lighting in the SOLIDWORKS software and PhotoView 360™ have been redesigned to clarify the differences between lighting methods. Screen messages, dynamic help, and previews explain the effects of your lighting choices.

When you activate the PhotoView 360 add-in, the Scene, Lights, and Cameras tool in the DisplayManager provides access to PhotoView 360 and SOLIDWORKS lighting controls.

This makes the lighting defaults clear:

- For PhotoView 360, the default is to use scene illumination and have directional, point, and spot lights off.
- For SOLIDWORKS, the default is to have ambient, directional, point, and spot lights on.

If PhotoView 360 is not active, the Scene, Lights, and Cameras tab shows only a Lights folder, which contains the SOLIDWORKS lights.

Link Display States to Configurations Option

The option Link display states to configurations has been moved.

In previous versions of SOLIDWORKS, the option Link display states to configurations was located at the bottom of the ConfigurationManager tree, below the configuration's Display States.

In SOLIDWORKS 2015 and later, to change display state linking:

- Right-click the configuration's display state and click Properties.
- In the Display State Properties PropertyManager, under Advanced Options, select or clear Link display states to configurations.
Manipulating Decals

The onscreen decal handles you use to map a decal to a model have been improved to make it easier to map decals to complex surfaces.

For all decal mapping types, a rotation handle appears as a ring with its center at the center of the decal. When you drag the rotation handle, the software displays an on-screen protractor that shows the decal angle and lets you change the angle.

For label-mapped decals, the decal handles follows the decal faces.

To access the handles to control the location of decals, do one of the following:

- In the Task Pane, on the Appearances, Scenes, and Decals tab, expand Decals and drag a decal into the graphics area.
- In the DisplayManager, click View Decals. Click Open Decal Library to open the Decals folder in the Task Pane. Drag a decal into the graphics area. If the model already has decals, right-click a decal and click Edit Decal.

PhotoView 360 Render Region

In PhotoView 360, you can define a region of the SOLIDWORKS graphics area for rendering. Using this render region, you can limit the rendering in the integrated preview, the preview window, or the final rendering to the area of the render region. This lets you rapidly preview or create a final rendering of a subset of the scene so you can assess the impact
of changes to the rendering settings, lighting, and appearances of this section of the model.

The render region provides an accelerator that lets you render a subsection of the current scene without having to zoom in or out or change the window size. For example, if you define a render region, when you edit the properties of an appearance applied to the section of the model within the render region, the preview updates more quickly than it would if you previewed the entire scene.

To access the render region functionality, click **Render Region**:

- In the Render Tools CommandManager
- On the **PhotoView 360** menu
- On the Render Tools toolbar

If the preview window is displayed and you activate a render region, when you change the appearance, the area inside the render region is updated while the area outside the render region remains as it was previously rendered.

### Previewing Hidden Bodies or Components

You can display a temporary preview of one or more hidden bodies or components from the FeatureManager design tree.

In the graphics area, the body or component appears as transparent, using the color for **Selected Item 1** in **Tools > Options > System Options > Colors**.

To display a preview, in the FeatureManager design tree, do one of the following:

- To preview a single hidden body or component, select the body or component.
- To preview multiple hidden bodies or components, press **Shift** or **Ctrl** and select the bodies or components.
- To remove the preview, click in the graphics area to deselect the component.
This chapter includes the following topics:

- **Asymmetric Fillets**
- **Creating Planes Normal to View Orientation**
- **Delete/Keep Body**
- **Flattening Surfaces**
- **Holes**
- **Move Face**
- **Patterns**
- **Splitting Surfaces**
- **Using Open Profiles for Cut Features**

### Asymmetric Fillets

You can use the **Fillet** tool to create asymmetrical fillets for parts, assemblies, and surfaces.

You can apply asymmetric shapes to constant size, variable size, and face fillets.

1. Open `install_dir\samples\whatsnew\parts\remote.sldprt`.
2. Select the edge shown.

3. Click **Fillet** (Features toolbar) or **Insert > Features > Fillet/Round**.

4. In the Property Manager, under **Fillet Type**, click **Constant Size Fillet**.
5. Under **Items To Fillet**, select **Full preview**.
6. Under **Fillet Parameters**:
   a) Select **Asymmetric** in the drop-down list.
   b) Set **Distance 1** to 5.
   c) Set **Distance 2** to 10.
   d) Click **Reverse Direction**.
   e) In **Profile**, select **Conic Rho**.
   f) Set **Conic Rho** to 0.65.

g) Click ✔.
   The asymmetric fillet is added.

**Creating Planes Normal to View Orientation**

You can create a reference plane parallel to the screen by setting an offset from a reference vertex.

1. Open `install_dir\samples\whatsnew\parts\shoe.sldprt`.
2. Click **Plane** (Reference Geometry toolbar) or **Insert > Reference Geometry > Plane**.
3. In the graphics area, select the vertex shown for **First Reference**.
4. In the PropertyManager, under **First Reference**:
   a) Click **Parallel to screen**.
   b) Set **Distance** to 0.

5. Click .

6. Rotate the model to see the plane created normal to the screen.

7. In the FeatureManager design tree, right-click **Plane1** and click **Edit Feature**.

8. In the PropertyManager, under **First Reference**, click **Update Plane** to reorient the plane parallel to the screen.

9. Click .
Delete/Keep Body

Delete Body is now called Delete/Keep Body. In multibody parts, you can delete or keep bodies for ease of selection.

The Delete/Keep Body tool makes it easier to select bodies for different configurations.

To delete or keep bodies:

1. In a multibody part, click Delete/Keep Body (Features toolbar) or Insert > Features > Delete/Keep Body.
2. In the PropertyManager, under Type, select whether to Delete Bodies or Keep Bodies.
3. In the graphics area, select the bodies to delete or keep.
4. Click ✓.

Flattening Surfaces

Available in SOLIDWORKS Premium.

You can flatten single- or multi-faced surfaces. You cannot flatten surfaces that have holes or other internal geometry.

To flatten a surface:

1. Open install_dir\samples\whatsnew\parts\surface.sldprt.

2. Click Flatten (Surfaces toolbar) or Insert > Surface > Flatten.
3. In the graphics area:
   a) Select the surface for Face/Surface to Flatten.
   b) Select the vertex shown for Vertex or Edge to Flatten From.
4. Click ✓.

5. In the graphics area, right-click the flattened surface, and click Deformation Plot.

A deformation plot appears in the graphics area showing where the surface is compressed or stretched.

6. To display only the flattened surface, in the FeatureManager design tree, right-click Boundary-Surface3 and click Hide.

See SOLIDWORKS Help: Flatten Surface.
Holes

**Database Migration**

SWBrowser.mdb has been migrated to a new format to improve performance and stability for future upgrades.

The contents and location of the SWBrowser.mdb file are unchanged. The file is not editable.

**Support for PEM® Hole Wizard Standard**

You can create and place Hole Wizard PEM® fastener holes for use with Toolbox PEM® fasteners.

Additional options are available in the Hole Wizard to support the PEM® fastener holes.

**Move Face**

The Move Face tool is easier to use, includes additional options in the PropertyManager, and allows for multibody selection for translate operations.

The following end conditions are available:

- Blind
- Up to Vertex
- Up to Surface
- Offset from Surface
- Up to Body

When editing a part in an assembly, you can move a component face up to the surface of another component. See Move Face in Assemblies on page 61.

**Graphics Area Enhancements**

The Move Face tool has been improved for ease of use.

In the graphics area, you can:

- Type a numerical value in the callout.
- See an arrow that indicates the direction the face will move.
- See better placement of the triad based on selections you make. The triad is placed at the centroid of your selections.

Click Move Face (Features toolbar) or Insert > Face > Move.

**Moving a Face Up to a Surface**

Additional end conditions are available in the Move Face PropertyManager, including Up To Surface.
To move a face up to a surface:
1. Open install_dir\samples\whatsnew\parts\block.sldprt.
2. Click Move Face (Features toolbar) or Insert > Face > Move.
3. In the graphics area, select the face shown for Face(s) to move.
4. In the PropertyManager, under Parameters, in End Condition, select Up To Surface.
5. Select the face shown for To Entity.
6. Click .
The face moves to the selected surface.
7. Close the part without saving.

**Offsetting a Face from a Surface**

Now offset the face from a surface.

1. Open `install_dir\samples\whatsnew\parts\block.sldprt`.
2. Click *Move Face* (Features toolbar) or *Insert > Face > Move*.
3. In the graphics area, select the face shown for *Face(s) to move*.

4. In the PropertyManager, under *Parameters*, in *End Condition*, select *Offset From Surface*.
5. Select the same face as in Step 3 for *Surface/Face/Plane*.
6. Select the face shown for *Face/Plane*.
7. For **Distance**, type `10`.

8. Click ✔. The face is offset from the selected surface.

---

**Using Multibody Selections**

You can select multiple bodies to move faces.

1. Open `install_dir\samples\whatsnew\parts\grater.sldprt`.

2. Click **Move Face** (Features toolbar) or **Insert > Face > Move**.

3. Box select (drag from left to right) the area shown.
The triad is placed at the centroid of your selections.

4. In the graphics area, drag the triad arm to the left approximately as shown.

5. In the callout, type 20 and press Enter.

6. Click ✓. The selected faces move.
Patterns

Controlling Linear Patterns with Reference Geometry

You can control linear patterns using reference geometry, such as vertices, edges, faces, or planes, to indicate how far you want to generate the pattern, and to designate the number of instances and spacing between instances.

To control linear patterns with reference geometry:

1. Open `install_dir\samples\whatsnew\parts\slotted_channel.sldprt`.

2. Click **Linear Pattern** (Features toolbar) or Insert > Pattern/Mirror > Linear Pattern.

3. In the graphics area, select **CSK SLOT for M4 SFHCS1** for **Features to Pattern**.

4. In the PropertyManager, under **Direction 1**:
   a) For **Pattern Direction**, select the edge shown.

   b) Select **Up to reference**.
      With this option you can set the offset distance of the patterned feature/body from the selected reference.
c) For Reference Geometry, select the face shown.

d) Set Offset distance to 0.
e) Set Spacing to 25.

5. Click ✓.

Changing Features/Faces to Bodies in Patterns
When you edit an existing pattern, you can change the seed feature to or from features, faces, or bodies. This eliminates the need to delete a pattern and recreate it.

To change a feature or face to a body in a pattern:

1. Open install_dir\samples\whatsnew\parts\pattern.sldprt.
2. In the FeatureManager design tree, select **Loft1** and click **Edit Feature**.

3. In the Loft PropertyManager, under **Options**, clear **Merge result** and click ✔. In the FeatureManager design tree, **Fill Pattern1** appears with an error icon because the pattern fails.

4. In the FeatureManager design tree, select **Fill Pattern1** and click **Edit Feature**.

5. In the Fill Pattern PropertyManager:
   a) Under **Features and Faces**, in **Features to Pattern**, right-click and click **Clear Selections**.
   b) Under **Bodies**, for **Solid/Surface Bodies to Pattern**, select **Loft1** in the graphics area.
   c) Click ✔.
      The pattern is successful by substituting the body for the feature as the seed.
**Fill Pattern Instance Count**

You can get an instance count for the number of instances in a fill pattern for use in annotations and equations.

The software calculates the number of instances in a fill pattern and displays that number in the graphics area when pattern dimensions are displayed. You can use the instance count in a custom property and link it for annotations and equations. The number is not editable or configurable.

The instance count is helpful for calculating open and closed volumes, conveying information to machinists, or determining a quantity based on a desired aesthetic.

**Displaying a Pattern Instance Count**

To display a fill pattern instance count:

1. Open `install_dir\samples\whatsnew\parts\fill_pattern.sldprt`.
2. In the FeatureManager design tree, expand **Multi-feature Seed Fill Pattern**, right-click **Fill Pattern1** and click **Edit Feature**.

   In the PropertyManager, under **Pattern Layout**, the **Instance Count** is 11. Even though the seed feature creates five extruded cuts per feature, there are 10 instances (plus the seed feature) in total.

3. Click ✓.
4. In the FeatureManager design tree, click **Fill Pattern1**.
   The number of pattern instances appears in the graphics area.

   If Instant3D is off, double-click **Fill Pattern1** in the FeatureManager design tree to see the instance count in the graphics area.

5. Right-click **Multi-feature Seed Fill Pattern** and click **Suppress**.

**Creating an Over-Run Fill Pattern**

1. In the FeatureManager design tree, right-click **Over-run Fill Pattern** and click **Unsuppress**.
2. In the FeatureManager design tree, under **Over-run Fill Pattern**, select **Cut-Extrude3**.
3. Click **Insert > Pattern/Mirror > Fill Pattern** or **Fill Pattern** (Features toolbar).
4. In the PropertyManager, for **Fill Boundary**, select the top face of the plate.

5. For **Pattern Layout**, select **Perforation**.
6. For **Instance Spacing**, type **12.5**.
7. For **Stagger Angle**, type **60**.
8. If not automatically selected, for **Pattern Direction**, select the edge shown.

   In the PropertyManager, under **Pattern Layout**, the **Instance Count** is 147. This is the total amount of cuts in the fill pattern.

10. In the PropertyManager, click **Validate Count**.

    The **Instance Count** changes to 94 because only 94 cuts intersect the model.

11. Click **✓**.

12. In the FeatureManager design tree, click **Fill Pattern2**.

    The number 94 appears in the graphics area.

13. Right-click **Over-run Fill Pattern** and click **Suppress**.

### Creating an Instance-Consuming Fill Pattern

1. Right-click **Instance-consuming Fill Pattern** and click **Unsuppress**.

2. In the FeatureManager design tree, under **Instance-consuming Fill Pattern**, select **Cut-Extrude4** and click **Insert > Pattern/Mirror > Fill Pattern** or **Fill Pattern** (Features toolbar).
3. In the PropertyManager, for Fill Boundary, in the flyout FeatureManager design tree, select Sketch7.

4. For Pattern Layout, select Perforation.

5. For Instance Spacing, type 4.

6. For Stagger Angle, type 60.

7. For Margins, type 0.

8. For Pattern Direction, select the edge shown.

In the PropertyManager, under Pattern Layout, the Instance Count is 467.

9. Click ✓.
10. In the FeatureManager design tree, click Fill Pattern3.
   The instance count automatically validates and the value 70 appears in the graphics area because only 70 partial circular edges result on the finished geometry.

11. In the FeatureManager design tree, click Fill Pattern3 and click Edit Feature.
   In the PropertyManager, the Instance Count has changed to 70.

12. Click ✅.

**Variable Patterns**

You can pattern features across both planar and non-planar surfaces and vary the dimensions and references for each pattern instance. There are no restrictions on how many dimensions you can vary.

The software maintains the design intent of the patterned features. For example, an extrusion made normal to surface will be normal to that surface for each pattern instance.

With variable patterns, you use a table to store the dimensions and their values. In the table, you can:

- Copy and paste data from a spreadsheet or tab-separated source into the pattern table and vice versa.
- Use equations to vary pattern dimensions. The equations are solved when written and are not available for editing or reference.

<table>
<thead>
<tr>
<th>Functions Available for Pattern Table Equations</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ Add</td>
</tr>
<tr>
<td>- Subtract</td>
</tr>
<tr>
<td>/ Divide</td>
</tr>
<tr>
<td>* Multiply</td>
</tr>
<tr>
<td>Function</td>
</tr>
<tr>
<td>------------</td>
</tr>
<tr>
<td>ABS(X)</td>
</tr>
<tr>
<td>COS(X)</td>
</tr>
<tr>
<td>EXP(X)</td>
</tr>
<tr>
<td>INT(X)</td>
</tr>
<tr>
<td>LOG(X)</td>
</tr>
<tr>
<td>PI</td>
</tr>
<tr>
<td>SIN(X)</td>
</tr>
<tr>
<td>SQRT(X)</td>
</tr>
<tr>
<td>TAN(X)</td>
</tr>
</tbody>
</table>

To create a variable pattern, you need the following:

- At least one feature to pattern
- A planar or non-planar surface
- At least one controlling dimension for each feature

Even if you do not want to vary a patterned feature, you still must choose a controlling dimension for that feature.

You can use reference geometry and sketches to control the physical geometry of the pattern. Click **Reference Geometry to Drive Seeds** and make selections in the graphics area.

To pattern a feature across a non-planar surface, the feature should contain at least one reference to that surface.

You can create variable patterns for the following features:

- Extrude/Cut Extrude
- Revolve/Cut Revolve
- Sweep/Cut Sweep
- Loft/Cut Loft
- Fillet
- Chamfer
- Dome
- Draft
Creating a Variable Pattern

To create a variable pattern:

1. Open \texttt{install\_dir\samples\whatsnew\parts\bottle.sldprt}.

2. In the FeatureManager design tree, expand \texttt{Revolve2}, click \texttt{Sketch2} and click \texttt{Edit Sketch}.

3. Note that the sketch includes two points that are coincident to the edge of the bottle.

4. Click \texttt{Exit Sketch}.

5. Click \texttt{Insert > Pattern/Mirror > Variable Pattern} or click \texttt{Variable Pattern} (Features toolbar).

6. For \texttt{Features to Pattern}, in the graphics area or the flyout FeatureManager design tree, select \texttt{Revolve2} and \texttt{Fillet1}.

Creating the Pattern Table

To create the pattern table:

1. In the PropertyManager, click \texttt{Create Pattern Table}.
2. With the pattern table open, in the graphics area, select the dimension shown.
3. Orient the model to the Right view to select the two Fillet1 dimensions.

4. In the pattern table, for **Number of instances to add**, type 4 and press **Enter**. The pattern table now contains the following values:

<p>| | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
<td>D</td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td>Sketch2</td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td>Instances to Skip</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>D3</td>
<td>D1</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>25.00mm</td>
<td>5.00mm</td>
</tr>
<tr>
<td>7</td>
<td></td>
<td>1</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td>25.00mm</td>
<td>5.00mm</td>
</tr>
<tr>
<td>9</td>
<td></td>
<td>2</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td>25.00mm</td>
<td>5.00mm</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td>25.00mm</td>
<td>5.00mm</td>
</tr>
<tr>
<td>13</td>
<td></td>
<td>4</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td>25.00mm</td>
<td>5.00mm</td>
</tr>
</tbody>
</table>

If the columns do not appear as shown, you can highlight a column to drag it to a new location. However, you cannot violate parent/child or sibling relationships in the table.

5. Click in cell C4 and type 37.5 to change the value for the first pattern instance.

6. Select cells C3 and C4. A small white circle appears in the lower right corner of the selection.
7. Pause the pointer over the white circle until the pointer changes to +. Drag down to expand the selection to the rest of the column. The pattern propagates to the other cells in the column, adding 12.5 successively to each dimension instance.

8. Click **Update Preview** to see where the new pattern instances will appear on the model.

### Adding Instances to the Pattern Table

**To add more instances to the pattern table:**

1. In **Number of instances to add**, type 3 and press **Enter**. Three new instances appear in the table with the dimensions of the seed feature.

2. In cells C8 and C9, type the values 110 and 125, respectively.

3. Select cells C8 and C9 and drag the small white circle down to expand the selection to C10. The software adds 15 to C9 to calculate the C10 value, continuing the pattern.

4. In cell D8, type 10. Select the cell and drag the small white circle to expand the selection to D9 and D10. The D8 value is repeated in D9 and D10.

5. Repeat Step 4 for Column E.

The table now contains the following values:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Instance</td>
<td>Instances to Skip</td>
<td>Sketch2</td>
<td>Fillet1</td>
<td>Fillet1</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td>D3</td>
<td>D1</td>
<td>D3</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td></td>
<td>25.00mm</td>
<td>5.00mm</td>
<td>5.00mm</td>
</tr>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
<td>D</td>
<td>E</td>
<td></td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>-----</td>
<td>-----</td>
<td>-----</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td></td>
<td>37.50mm</td>
<td>5.00mm</td>
<td>5.00mm</td>
</tr>
<tr>
<td>5</td>
<td>2</td>
<td></td>
<td>50.00mm</td>
<td>5.00mm</td>
<td>5.00mm</td>
</tr>
<tr>
<td>6</td>
<td>3</td>
<td></td>
<td>62.50mm</td>
<td>5.00mm</td>
<td>5.00mm</td>
</tr>
<tr>
<td>7</td>
<td>4</td>
<td></td>
<td>75.00mm</td>
<td>5.00mm</td>
<td>5.00mm</td>
</tr>
<tr>
<td>8</td>
<td>5</td>
<td></td>
<td>110.00mm</td>
<td>10.00mm</td>
<td>10.00mm</td>
</tr>
<tr>
<td>9</td>
<td>6</td>
<td></td>
<td>125.00mm</td>
<td>10.00mm</td>
<td>10.00mm</td>
</tr>
<tr>
<td>10</td>
<td>7</td>
<td></td>
<td>140.00mm</td>
<td>10.00mm</td>
<td>10.00mm</td>
</tr>
</tbody>
</table>

6. Click **OK**.

7. In the PropertyManager, click ✔. The variable pattern appears in the graphics area.

**Suppressing Pattern Instances**

**To suppress a pattern instance:**

1. In the FeatureManager design tree, expand **VarPattern1**.
2. Click **VarInstance3** and click **Suppress**. The instance disappears from the graphics area.
3. In the FeatureManager design tree, click VarPattern1 and click Edit Feature.
4. In the PropertyManager, click Edit Pattern Table.
   In the pattern table, for Instance 3, Instances to Skip is selected.
5. For Instance 3, clear Instances to Skip and click OK.
6. In the PropertyManager, click ✓.
7. In the FeatureManager design tree, VarInstance3 is no longer suppressed.

Splitting Surfaces

You can split surfaces with the Split tool. You can also split a combination of surfaces and solid bodies.

To split a surface:
1. Open install_dir\samples\whatsnew\parts\split.sldprt.
2. Click Split (Mold Tools toolbar) or Insert > Features > Split.
3. In the graphics area, select Surface-Extrude1 for Trimming Surfaces.
4. In the PropertyManager, under Target Bodies, click Selected bodies.
5. For **Solids or Surfaces to Split** ![image](image), in the FeatureManager design tree, in the **Surface Bodies** ![image](image) folder, select **Surface-Knit1** ![image](image).

6. In the PropertyManager:
   a) Under **Target Bodies**, click **Cut Bodies**.
   b) Under **Resulting Bodies**, select the checkboxes in rows 1 and 2.
   c) Click ![image](image).

7. In the FeatureManager design tree, right-click **Surface-Extrude1** ![image](image) and click **Hide** ![image](image).

8. Rotate the model to see that the selected bodies are split by the surface. The mounting bosses (**Boss-Extrude1** ![image](image)) were not split.
Using Open Profiles for Cut Features

You can use an open profile to cut a model if the profile completely intersects the model. You can use an open profile for Blind or Through all cuts.

To create a cut using an open profile:

1. Open `install_dir\samples\whatsnew\parts\cut.sldprt`.
2. In the FeatureManager design tree, select Sketch2. The sketch intersects the model on both sides.

3. Click Extruded Cut (Features toolbar) or Insert > Cut > Extrude.
4. In the PropertyManager, under Direction 1, set Depth to 23.
5. Click ✓.
SOLIDWORKS Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS Plastics Premium are available as separately purchased products that can be used with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

This chapter includes the following topics:

- eDrawings Support for SOLIDWORKS Plastics Result Plots
- Mesh Improvements
- Nominal Wall Thickness Advisor
- Symmetry Analysis
- Venting Analysis

**eDrawings Support for SOLIDWORKS Plastics Result Plots**

You can export Plastics Simulation results from SOLIDWORKS Plastics as eDrawings files. eDrawings allows you to share your results between stakeholders (without having to install SOLIDWORKS or SOLIDWORKS Plastics), add annotations and notes to your plots, and archive your results.

You cannot export vector plot results such as Weld Line, Air Traps, and Velocity Vector at End of Fill plots to eDrawings.

**Mesh Improvements**

With the addition of mesh options for tetrahedral and hexahedral mesh, the mesh quality is improved.

Mesh improvements include:

- New tetrahedral mesh settings to control the mesh generated for volume channel in the runner. Click **Advanced (Runner)** in the Tetrahedral Mesh PropertyManager. Under **Runner** (Advanced Setting), enter values for **Ring Count**, **Ring Cut Count**, and **Length Ratio**.
**Volume channel runner with advanced settings**

**Volume channel runner without advanced settings**

- Option to set the **Minimum number of elements through thickness** (set the boundary layer elements) in the Tetrahedral Mesh Property Manager. More mesh elements are added across the thickness for thin parts of the geometry like ribs and bosses to improve the results.

**Mesh without minimum number of elements through thickness**

**Mesh with minimum number of elements through thickness**
• For hexahedral mesh, a new mesh algorithm called **Marching** replaces the **Regressive** mesh algorithm.

• For hexahedral mesh, a new mesh algorithm called **Non orthogonal Voxel** is added. The new mesher automatically adds more elements in areas that need more than one layer of mesh.

### Mesh generated by the Voxel algorithm

### Mesh generated by the Non orthogonal Voxel algorithm

---

**Nominal Wall Thickness Advisor**

The Nominal Wall Thickness Advisor queries the geometry and determines the overall nominal wall thickness in the model and the percentage deviation of thickness from this nominal value.

The primary design rule for injection-molded plastic parts is the maintenance of a uniform wall thickness. A uniform wall thickness leads to uniform filling patterns, pressure distributions, cooling times, shear stress, and volumetric shrinkage. Parts with uniform wall thicknesses have optimized cycle times and are less likely to warp or deform out of shape.

To access the Nominal Wall Thickness Advisor, right-click **Nominal Wall Thickness**, and select **Open Adviser**.

A thickness distribution plot of the part shows the percentage deviation from the nominal wall thickness.
Symmetry Analysis

With the support of symmetry analysis, you can save simulation time by analyzing a part of a model instead of the full model. The model has to be symmetric about a plane or two planes of symmetry, or an axis (for circular symmetry).

**To set a symmetrical runner:**

1. Create a Solid Mesh (Guide).
2. Select Runner and Cooling System Design.
3. In the Tetrahedral Mesh Property Manager, select Set Symmetrical Runner.

Symmetry analysis is supported for these cases:

- A single runner edge stream: one-half symmetry (T-Type), one-quarter symmetry (X-Type), circular symmetry
- Multiple runner edge streams, where the second and third runner edge streams are changing directions with respect to the first runner edge stream: one-half symmetry (S-Type), one-half symmetry (T-Type), one-quarter symmetry (H-Type), one-quarter symmetry (X-Type)

### Symmetry Types for Single Runner Edge Stream

![Symmetry Types for Single Runner Edge Stream](image)
### Symmetry Types for Multiple Runner Edge Streams

<table>
<thead>
<tr>
<th>Original cavity</th>
<th>One-half symmetry (T-Type)</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Original cavity" /></td>
<td><img src="image2" alt="One-half symmetry (T-Type)" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>One-quarter symmetry (X-Type)</th>
<th>Circular symmetry (five cavities)</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image3" alt="One-quarter symmetry (X-Type)" /></td>
<td><img src="image4" alt="Circular symmetry (five cavities)" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Original cavity</th>
<th>One-half symmetry (S-Type)</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image5" alt="Original cavity" /></td>
<td><img src="image6" alt="One-half symmetry (S-Type)" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>One-half symmetry (T-Type)</th>
<th>One-half symmetry (T-Type)</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image7" alt="One-half symmetry (T-Type)" /></td>
<td><img src="image8" alt="One-half symmetry (T-Type)" /></td>
</tr>
</tbody>
</table>
Symmetry analysis is available for SOLIDWORKS Plastics Professional and SOLIDWORKS Plastics Premium.

**Venting Analysis**

Available in SOLIDWORKS Plastics Professional and SOLIDWORKS Plastics Premium. With venting analysis, you can specify various venting locations which are incorporated in the injection-molded plastic part. You can avoid potential defects of the plastics parts due to burning because of improper vent locations or specifications.

To run Venting Analysis, in the Fill Settings PropertyManager, select **Venting Analysis**. Run **FLOW** Analysis and click **Venting Pressure**.
At the locations of the mold where high venting pressures are observed, you can specify air vents:

1. Under **Boundary Conditions**, right-click **Air Vents** and select **Open Settings**.
2. In the graphics area, select the locations on the mold to specify air vents, and click **Apply**.

Run **Flow** Analysis again, and select **Venting Pressure** to view the new pressure distribution.
Assign Color for Electrical Cables

You can assign a specific color for cables when editing wires or in a Cable Wire Library. The color is reflected on the cable in the cable part.

To define a color when editing wires, in the Edit Wires PropertyManager, click *More Properties*. In the Edit Attributes dialog box, double click a color under the *SWColor* column and select a color from the Color dialog box.

To define colors in an existing Cable Wire Library, click **Tools > Routing Tools > Routing Library Manager** and select **Cable Wire Library Wizard**.

Assigning Connector Accessories

You can assign connector accessories such as terminals, seals, plugs, and miscellaneous accessories, to a specific connector or to all the connectors in a route. You can further customize the parameters of a connector accessory for an individual pin.

You can define connector accessories in the Component Library of the Routing Library Manager, the From-To List wizard, and the Edit Connector PropertyManager.

You can assign either a terminal or a plug for a connector, but not both a terminal and a plug. However, you can select a seal for a terminal and a seal for a plug.

Data about connector accessories display in connector tables and circuit summaries for flattened routes, BOMs and drawings.

To define a connector accessory, right-click the route assembly in the FeatureManager design tree and click **Edit Connectors** (Electrical toolbar) or click **Tools > Routing > Electrical > Edit Connectors**.
Determine Cut Lengths for Twisted Pairs

You can identify two or more wires to braid into a twisted pair and calculate its cut length.

To define twisted pairs, click Edit Wires or Tools > Routing > Electrical > Edit Wires.

In the Edit Wires PropertyManager, select the wires that will form a pair and in Wire From-To List, click Twisted Pair.

The wires must be of the same type and diameter.

The Twisted Pair Parameters dialog box displays and lists the selected wires. In the Twists per unit length field, set the number of turns per unit length that the wires require and click OK. SOLIDWORKS then calculates and displays the route and cut lengths of the braided wire based on the route segment.

For BOMs, an existing column for length has been renamed to Routed Length and a new column for Manufactured Length has been added. This column lists the required cut length for the twisted wires.

This functionality is limited to annotations and not available in 3D route geometry.

Reusing Electrical Route Assemblies

You can reuse an existing harness in the same assembly or in other assemblies. The reused route uses the same wire definitions and connectors as the original route, but you can edit the reused route path as if it were unique.

To reuse an electrical route assembly, right-click an electrical assembly and select Reuse Route or Tools > Routing > Electrical > Reuse Route.

The Reuse Route command allows you to browse for an existing harness assembly. The reused harness inherits properties from the parent harness, including custom properties and part number from configuration properties. If the part number is blank in the parent, then the reused harness takes on the assembly name from the parent assembly. The lengths of each route segment is assigned to each route segment of the reused harness and the fixed length parameter is applied. All configurations, if more than one exists, are also applied to the reused route.

If a reused route is in the same assembly as the original route, they are grouped together in the BOM as if they are two instances of the same assembly.
Edits made in the route path do not propagate from the reused route to the parent harness. The reused route is a copy. To preserve the design intent and keep the reused route from deviating from the parent, several features are disabled. For example, you cannot add splices, connectors or assembly features to a reused route, but you can route through clips and flatten the reused route to generate drawings.

A reused route is identified by a unique icon in the FeatureManager design tree. If you need to edit the route design from the parent by adding new connectors or by changing wires, you can remove the link between the reused route and the parent.

To remove the link, right-click the reused route assembly and select **Delink Harness**. All routing features are restored, the icon is removed, and the reused route is not grouped with its parent in a BOM.

## Setting Fixed Length to Route Segments

You can dimension a route segment or multiple segments to a fixed length.

**To set a fixed length:***

1. Right-click the route in the FeatureManager design tree and click **Edit Route**.

2. In the graphics area, right-click a route segment and click **Fixed Length**.

   You can also access this command by clicking **Tools > Routing > Routing Tools > Fixed Length**.

3. Add more route segments to the Fixed Length PropertyManager by selecting them in the graphics area.

   You can only select sketch segments that are adjacent and continuous.

4. Under **Dimension Display**, select one of the following options:
   - **Dimension Length**
   - **Dimension of Each Segment**
   - **Dimension Both**

   To reposition a dimension callout, drag it in the graphics area.

5. Click **✓**.

After you set a fixed length, you can perform the following tasks:

- Edit a fixed length by right-clicking the route segment and clicking **Edit Length**.
- Show or hide dimension callouts by clicking **Tools > Routing > Routing Tools > Show Fixed Length Dimensions**.
- Remove a fixed length by right-clicking the route segment and clicking **Fixed Length**.
Support for Assembly Fittings in Piping and Tubing Database

You can add assembly fittings to the Piping and Tubing database.

Support for Manifold Fittings with Unaligned Connection and Route Points

You can add manifold fittings to a route. These fittings have several connection points but their axes do not align at a common point where you can add a route point.

The following example displays a fitting with multiple connection points (CPoints) and route points (RPoints).

You can snap, drag and drop manifold fittings in the middle of a route segment. Press Tab to align and place fittings with different pairs of aligned CPoints and RPoints.

The following examples show the alignment and placement of fittings:

In this subassembly, RPoint 1 is used for alignment. CPoint1 and CPoint2 are aligned to the main route segment.

In this example, RPoint2 is used for alignment but CPoint5 and CPoint6 are aligned to the main route segment.
Support for Square and Rectangular Sections

Routing has added support for route types that require square and rectangular sections. This enhancement allows you to create routing assemblies for:

- HVAC rigid air conditioning ducts and other user defined mechanical styles of ducting.
- Cable trays and electrical ducting/trunking for rectangular section open or closed top ducting.

Many components for these route types are available in the Design Library. You can drag and drop components and fittings from the HVAC, Round Ducting, Electrical Cable Tray and Electrical Ducting folders under Routing. You can also add components for these types to the Routing Library Manager.

Property Managers including Connection Point, Route Properties, and Edit Route contain additional options for these route types. For example in the Connection Point Property Manager, additional subroute types under Electrical include Cable Tray.

In the Connection Point and Route Properties Property Managers, you can also define a User Defined route type to create air conditioning, other mechanical styles of ducting and space planning type route subassemblies. When you apply a User Defined route type, you must specify that the cross section is Rectangular or Circular, and set parameters according to this type. You then sketch the path between components, add other routing fittings, or sketch lines using 3D sketch tools. For this route type, you can create rectangular and circular routes in the same routing assembly.

These route types are also fully supported in BOMs and drawings.
Lofted Bends

You can create bent lofted bends from sketches on non-parallel planes. Previously, the planes had to be parallel.

To create bent lofted bends:

1. Open `install_dir\samples\whatsnew\sheetmetal\bent_lofted_bends.sldprt`.
2. Click Lofted Bends (Sheet Metal toolbar) or Insert > Sheet Metal > Lofted Bends.
3. In the graphics area, select the entities shown.
4. Click ✓.
Bent lofted bends form a realistic transition between the non-parallel profiles.
Mirrored Parts and Components

When you mirror a sheet metal part or component, you can include the sheet metal information in the mirrored model. This is helpful when you create drawings with flat patterns.

To include sheet metal information in a mirrored part:

1. Open `install_dir\samples\whatsnew\sheetmetal\mirror_part.sldprt`.
2. Select the face shown.

3. Click **Insert > Mirror Part**.
4. In the PropertyManager, under **Transfer**, select:
   a) **Sheet metal information**. Transfers the sheet metal and flat pattern information from the original part to the mirrored part, such as fixed face, grain direction, bend lines, and bounding box.
   b) **Unlocked properties**. Lets you edit the sheet metal definition in the mirrored part, which will update the cut list properties. This applies only to new feature properties, not the imported mirrored body.

5. Click 🔄.

The part is mirrored and retains the sheet metal information from the original part.
Sheet Metal Gussets

You can choose how to display sheet metal gussets in the flattened state.

In flattened sheet metal parts, you display gussets as profiles, center marks, or both.

Click **Tools > Options > Document Properties > Sheet Metal** and select from the following options:

| Show sheet metal gusset profiles when flattened | Show sheet metal gusset centers when flattened |

Sketched Bends

A preview appears when you set parameters in the Sketched Bend PropertyManager.
Contact enhancements include the addition of edge-to-edge incompatible bonding and self-contact detection for nonlinear analysis.

**Edge-to-Edge Bonding for Shells**

You can create bonded contact between non-touching edges of shell bodies. When the software extracts the mid-surfaces of sheet metals (or solid parts that are treated as shells) to create shell bodies, a gap can be formed between the edges of adjacent shell bodies. You can create a bonded contact set definition between the non-touching shell edges. The bonding formulation is incompatible; the nodes of the shell edges participating in the bonded contact are not merged.

In the Contact Sets PropertyManager, select the first set of shell edges for **Set1** and the second set of shell edges for **Set2**.

You can also select a face that corresponds to the thickness of the shell.

In a contact visualization plot, the shell edges that are part of the bonded contact definition are shown in red.
With the support of edge-to-edge incompatible bonding for shells, you can create cut boundaries for sub-modeling studies at the locations where shell edges are bonded.

**Self-contact Detection**

A new option allows the detection of self-contact for faces of a body or part that have regions that can come into contact with each other during the simulation. The self-contact option is available for nonlinear studies and static studies running with the large displacement option.

Available for SOLIDWORKS Simulation Premium.

In the Contact Sets PropertyManager, select **Self-contact**.

Select the faces that can come into contact with each other while deforming during the simulation. For example, if you select Face 1 and Face 2 for Set1, the program assigns these pairs as the source and target entity for the detection of interference: Face 1 - Face 1, Face 2 - Face 2, and Face 1 - Face 2.

A no penetration contact is applied to a face that comes into contact with itself during deformation.

- Self-contact detection is not automatic. You need to select option Self-contact.
- Detection of self-contact is not available for 2D Planar Simplification nonlinear analysis.

**Fatigue**

You can predict the damage and remaining life of a part that is exposed to repeated cyclic loading at a given operating frequency or to a random vibration environment.

Available for SOLIDWORKS Simulation Premium.

You can perform fatigue analysis based on frequency domain events that use the results from linear dynamic harmonic and linear dynamic random vibration studies.
The output of fatigue studies based on frequency domain events include remaining life and damage plots. For random vibration-based fatigue studies, a Time to Failure plot is included as well.

**Fatigue based on Harmonic Results**

A fatigue study that is based on stress results as a function of frequency from a linear dynamic harmonic study, predicts the remaining life and damage of a part under periodic (or sinusoidal) vibration of a given number of cycles at a certain operating frequency.

The calculation of the cumulative damage ratio is based on the Linear Damage rule or Miner's rule:

\[ E[D] = \sum_{i} \frac{n_i}{N_i} \]

where \( E[D] \) is the expected damage ratio, \( n_i \) is the number of cycles the part is subjected at a certain operating frequency and alternating stress \( S_f \) and \( N_i \) is the number of cycles required to cause failure at stress level \( S_f \) given by the material's S-N curve.

**Fatigue based on Random Vibration Results**

To estimate the fatigue life when the stress or strain histories obtained from the structure or component are random in nature (and therefore best described using statistical parameters like probability density functions, upward zero crossings, and number of peaks per second), these frequency domain computational methods are available:

- Narrow Band
- Steinberg
- Wirsching

The assumption of a frequency-based fatigue life prediction is that the response parameters (stress and strain) of the model being analyzed are random, stationary, and Gaussian in nature.

Unlike other fatigue studies, the material S-N curve is defined using Basquin's equation:

\[ N = \frac{B}{(S_e)^m} \]

where \( N \) = allowable number of cycles to failure; \( B \) = curve-specific constant (the intercept of the S axis); \( S_e \) = stress range of cyclic load; \( m \) = slope of the linear S-N curve.

This equation shows that under constant amplitude cyclic loading a linear relationship exists between cycles to failure \( N \) and applied stress range \( S_e \) when plotted on a log-log scale.

**Defining Fatigue based on Harmonic Results**

To define a fatigue event based on results from a linear dynamic harmonic study:

1. Set up and run a linear dynamic harmonic study.
2. Create a fatigue study. In the Study PropertyManager, under **Options** select **Harmonic-fatigue of sinusoidal loading**.
3. In the fatigue study tree, right-click **Loading (Harmonic)** and select **Add Event**.
4. In the Add Event (Harmonic) Property Manager:
   a) Under **Study**, select the harmonic study to associate the fatigue event.
   b) Under **Plot Step**, select the frequency (or plot step) of the sinusoidal fatigue loading.
   c) Under **Scale and Cycles**, enter the number of **Cycles** for this event and the **Scale Factor** that applies to the stress results from the selected harmonic study.
   d) Click ✓.

5. Right-click the top study icon and click **Define Function Curves** to associate an S-N curve to the material.

6. After you run the fatigue study, you can view plot results for **Life** (number of cycles that causes fatigue failure), **Damage** (percentage of the life of structure consumed by the fatigue event), and **Load Factor** of safety against fatigue failure.

You can create multiple fatigue events that are based on the same linear dynamic harmonic study. The software assumes that the events occur sequentially one after the other without any interaction. The von Mises stress is used to calculate the equivalent alternating stress for extracting the number of cycles from the S-N curve.

### Creating a Fatigue Study Based on Random Vibration Results

You can create a fatigue study that is based on stress results (in the form of Power Spectral Density function) from a dynamic - random vibration study.

To define a fatigue event based on results from a linear dynamic random vibration study:

1. Set up and run a linear dynamic random vibration study.
2. Create a fatigue study. In the Study Property Manager, under **Options** select **Random vibration - fatigue of random vibration**.
3. In the fatigue study tree, right-click **Loading (Random Vibration)** and select **Add Event**.
4. In the Add Event (Random Vibration) Property Manager:
   a) Under **Study**, select the random vibration study to associate the fatigue event.
   b) Under **Duration**, select the time duration (in units seconds, minutes, hours, or days) of the random loading input applied to the model.
   c) Click ✓.
5. Right-click the top study icon and click **Apply/Edit Fatigue Data** to associate an S-N curve to the material.

You can enter the two S-N Basquin curve constants (B) and (m), or click **Estimate Basquin constants from S-N curve** and enter multiple data points that capture the stress range (stress variation from the maximum cyclic stress to the minimum cyclic stress) versus the cycles to failure.
6. In the Fatigue - Random Vibration dialog box, select the computational method for estimating the vibration fatigue damage: Narrow Band, Steinberg, or Wirsching. The Narrow Band method gives usually the most conservative results. It is recommended to run the fatigue study with all three methods and compare the results for the fatigue damage estimates.

7. After you run the study, you can view plot results for **Life** (Time to fatigue failure), and **Damage** (percentage or ratio of the life consumed by the random vibration loading). A damage factor of 1 and above indicates that the part has failed for the given time duration of the random loading.

**Frequency Analysis Graphs**

Three new graphs are added to the results from frequency and linear dynamic studies: frequency versus mode number, frequency versus effective mass participation factor, and frequency versus cumulative mass participation factor.

Available for SOLIDWORKS Simulation Professional and SOLIDWORKS Simulation Premium.

Run a frequency or linear dynamic study. Right-click **Results** and select **Define Frequency Response Graph**. You can select to plot graphs of:

- Frequency versus mode number
- Frequency versus effective mass participation for each X, Y, and Z direction.
- Frequency versus cumulative effective mass participation for each X, Y, and Z direction.

Plotting the frequency versus the mass participation factors helps you identify if the number of modes considered during the vibration analysis are sufficient to capture the actual dynamic response of the system.

**Loads**

Enhancements to load definitions include a new load case manager interface within a static study, support for cylindrical and spherical coordinates for nonuniform distribution of a force, torque, or pressure, and easier access to prescribed displacement definitions.

**Load Case Manager for Static Studies**

A new load case manager interface within a Static study allows you to define (secondary) load combinations from (primary) load definitions quickly and evaluate the effects of the various load combinations on your model.

Available for SOLIDWORKS Simulation Professional and SOLIDWORKS Simulation Premium.

Right-click the top icon of a Simulation static study tree and select **Load Case Manager**. Use the **Load Case Manager** to define:

- **Primary Load Cases** that link to the loads, fixtures, and connectors of the static study. You can suppress features or add new features (loads or fixtures) for each primary load case. For example, each primary load case can correspond to a "Dead", "Live", "Wind", or "Earthquake" loads.
- **Load Case Combinations** are linear combinations of the primary load cases. You enter the equation that describes the primary load combination through an equation editor, for example: 1.4 * "Dead" + 1.6 * "Live" + 0.5 * "Wind".
- **Simulation data sensors** to track results for the primary loads and secondary load case combinations.
After you set up the load case combinations, click Run. Switch to the Results View tab to view Simulation sensor results.

Result plots are saved under Load Case Results in the Simulation static study tree.

The Load Case Manager does not support H-Adaptive and P-Adaptive meshing methods.

**Prescribed Displacement as Force**

The External Loads folder now has an option to apply prescribed displacements.

Right-click External Loads and click Prescribed Displacement. For the selected geometric entity, apply the desired displacement distance or angle of rotation (for cylindrical or spherical faces).

**Cylindrical and Spherical Coordinates for Nonuniform Force and Pressure**

The user interface for defining the nonuniform distribution of a force, torque, or pressure supports cylindrical and spherical coordinates.

In the Force/Torque PropertyManager under Nonuniform Distribution, select Cylindrical Coordinate System, or Spherical Coordinate System.

Click Edit Equation to enter the formula which describes the spatial variation of the force applied to the selected entities. You can use a list of basic mathematical functions from the drop-down menu. For example:
Equation for nonuniform force distribution based on cylindrical coordinates \((r, t, z)\):

\[
F (r, t, z) = 5 \times "r" + \sin ("t") + 2 \times "z"
\]

Equation for nonuniform force distribution based on spherical coordinates \((r, t, p)\):

\[
F (r, t, p) = "r" + 3 \times \sin ("t") + 2 \times \cos ("p")
\]

In the equation interface, enter the coordinates inside quotation marks: "r", "t", "p", and "z".

Materials

You can create a folder with your favorite materials and apply a favorite material from the list to multibody parts and assemblies.

Right-click the part icon to apply a material and click **Apply Favorite Material**. Select a material from the list of favorite materials.

From the materials favorites list, you can quickly apply a material without displaying the Material dialog box.

To manage the material favorites list, right-click **Material** in the FeatureManager design tree of a part and select **Manage Favorites**.

Mesh

When meshing fails, you have better visualization tools to display these parts which failed to mesh.

For parts which failed to mesh, you can launch the **Mesh Failure Diagnostic** tool, to render these parts in shaded display mode in the graphics area. Meshed parts are rendered in wireframe display mode.

Click **Show bodies which failed to mesh**.

Click **Show mesh for all bodies** to view the meshed bodies only.

You can double-click a body listed in the **Mesh Failure Diagnostics** pane to zoom-in the body in the graphics area.
Nonlinear

Enhancements for nonlinear studies include viewing intermediate results as the solution progresses and the availability of cyclic symmetry.

**Intermediate Results in Nonlinear Analysis**

You can visualize intermediate results during a nonlinear solution. By getting visual feedback of the results as the solution progresses, you can make decisions to either stop the simulation and make adjustments to the input, or let the solver proceed with the current settings.

Available for SOLIDWORKS Simulation Premium.

To view intermediate result plots while running a nonlinear study, in Default Options > Results, select *Show intermediate result plots up to the current iteration (while running the nonlinear study)*.

When the first iteration step completes, the results for the active plot are shown on the graphics area. As the solution progresses to the next iteration step, the active plot gets dynamically updated. If you have not activated a result plot, the first plot under Results is dynamically updated in the graphics area.
To toggle the visibility between plots, under **Results** right-click the active plot, and click **Show** or **Hide**.

For a new Simulation study, first you need to define the default result plots in **Default Options > Plot > Nonlinear Study Results**.

**Cyclic Symmetry for Nonlinear Studies**

Cyclic symmetry is supported for nonlinear studies.

Available for SOLIDWORKS Simulation Premium.

In the Fixture PropertyManager under **Advanced**, select **Cyclic symmetry**.

The cyclic symmetry constraint is appropriate for simulations of models where the geometry, restraints, and loading conditions are repeated in a cyclical pattern with reference to a central axis.

After you run the nonlinear analysis, you can display results on the full model. In the PropertyManager of the desired result quantity, under **Advanced Options**, select **Display symmetric results**.

Displacement results shown for a part with applied cyclic symmetry constraints. Displacement results shown for the entire model with active option **Display symmetric results**.
For circular symmetry, the angle between the selected faces must be evenly divisible into 360. The axis of symmetry must lie at the intersection of the two selected planes where you apply the cyclic symmetry.

To set up your model for applying cyclic symmetry restraints, you create a cut (or an assembly cut feature) to produce a section of the model that can be repeated in a cyclical pattern about a central axis of revolution. A valid cut section produces a complete part, when it is repeated with an equal spacing circular pattern feature, and there are no gaps or interferences between the sections. You cannot apply a cyclic symmetry restraint to an invalid section.

**Performance**

Performance improvements include reduced solution time for Simulation studies with certain features, solver improvements (Direct Sparse and FFEPlus for static and nonlinear studies, availability of a new solver (Intel equation solver) for large problems), and the option to run selected Simulation studies.

Performance enhancements include:

- A new solver powered by Intel is available for static, thermal, frequency, linear dynamic, and nonlinear studies. In the study properties dialog box, under Solver select **Intel Direct Sparse**. By leveraging enhanced memory-allocation algorithms and multi-core processing capability, the **Intel Direct Sparse** solver improves solution speeds for simulation problems that are solved in-core.

- For studies with multiple sheet metal bodies that are converted to shell bodies, the processing time between meshing and solver launch has been improved significantly. This improvement leads to an overall reduction of solution time by approximately 5x to 9x.

- The overall processing time for detecting bonding and no-penetration contacts has been decreased.

- Improved performance for the FFEPlus solver by introducing new element types for the formulation of connectors, bonding, and no penetration contact.

- Obtaining and displaying progress feedback when using the Large Problem Direct Sparse solver.

- Solution accuracy is improved for linear static studies that have soft springs applied to shells and the large displacement option active.
Running Specified Studies

You can select which Simulation studies to run from the list of all Simulation studies defined in a part or assembly document. The selected Simulation studies are run automatically in a batch mode.

To specify which Simulation studies to run:

1. Click the down arrow on Run (Simulation CommandManager) and select Run Specified Studies.
2. Under Run, select the Simulation studies to run.
   The Mesh Status and Results Status columns indicate which studies have current or out-of-date mesh and result data.
3. Click OK.
   All selected studies are run in a batch mode. A progress information window shows the solver status for the current study being run.

   If you select to run a study which is dependent on a parent study (such as a design, fatigue, sub-modeling, or pressure vessel study) the program will also run the parent study, if the mesh or the results of the parent study are out-of-date.

Shells

Enhancements for shells include a new Shell Manager user interface which allows you to define, edit, and organize multiple shell definitions more efficiently, and the ability to preview a shell's orientation before creating the mesh.

Shell Manager

Available for SOLIDWORKS Premium.
The Shell Manager improves the workflow for defining, editing and organizing multiple shell definitions of your part or assembly document. It allows for a better visualization and verification of shell properties according to type, thickness, orientation, or material.

To access the Shell Manager, click Simulation > Shells > Shell Manager.

With the Shell Manager, you can:
• Create shell definitions from surface bodies or faces of solid bodies.
• Assign shell properties: type (thick or thin), orientation (top or bottom face), thickness, and material.
• Sort shells by type, thickness, or material, and apply temporary color to shells with the same thickness or material for better visualization.
• Group shells with similar properties (type, thickness, units, and material) and propagate changes to all shells within a group.

You cannot define composite shells with the Shell Manager.

The Shell Manager provides these options:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Faces</strong> and <strong>Surface</strong></td>
<td>Select faces of solid bodies or surface geometries to define them as shells.</td>
</tr>
<tr>
<td><strong>Bodies</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Shell Category</strong></td>
<td>Assigns thin or thick shell formulation.</td>
</tr>
<tr>
<td><strong>Shell offset</strong></td>
<td>Controls the position of the shell mesh. You can preview the shell thickness and the orientation of the top and bottom shell faces.</td>
</tr>
<tr>
<td></td>
<td>You can position the mesh on the middle, top, or bottom surface of the shell body, or on a reference surface specified at a fraction of the total thickness. The shell mesh is created at the selected surface.</td>
</tr>
<tr>
<td><strong>Shell Material</strong></td>
<td>Applies the shell material. Shells with assigned material have the icon 🌿.</td>
</tr>
<tr>
<td><strong>Thickness and Unit</strong></td>
<td>Specifies the shell thickness and units.</td>
</tr>
<tr>
<td><strong>Flip</strong></td>
<td>Flips the top and bottom face of the shell. The bottom face of the shell is rendered in orange and the top face of the shell, in green.</td>
</tr>
<tr>
<td><strong>Manage Groups</strong></td>
<td>Creates a shell group object. All shells assigned to a group have the same formulation (thick or thin), material, and thickness.</td>
</tr>
<tr>
<td></td>
<td>If you change any properties of a shell group, the changes propagate to all shells within the group.</td>
</tr>
<tr>
<td><strong>Color by: Thickness or Material</strong></td>
<td>Renders shells with a unique color according to thickness or material. Click <strong>Show legend</strong> to view the color distribution.</td>
</tr>
<tr>
<td><strong>Preview Offset Selected or All (Slower)</strong></td>
<td>Renders the thickness of the shells with the top and bottom shell faces.</td>
</tr>
</tbody>
</table>
Rendering of shell bodies according to their thickness (model is provided by Grantec Engineering Consultants, Inc.)

Flipping Shell Faces
You can flip the shell top and bottom faces and preview their locations with respect to the shell midsurface before creating the mesh.

In the Shell Definition PropertyManager, select **Flip shell top and bottom**.
Select **Full preview** to render the top and bottom faces of the shells.
Top faces are shown in green. The color of the bottom faces is set in **Simulation Options > General > Mesh colors > Shell bottom face color**.

The flip state (top / bottom) of the shell faces is retained during meshing.

Simulation Results for the Colorblind
A new color scale option for rendering simulation results is available to help users with color vision deficiencies in viewing result plots.

In the Default Options dialog box, select **Plot > Color Chart > Color options > Optimized for Colorblindness**.

The color scale is optimized for red-green colorblind users when viewing result plots to better assist these users with the task of interpreting simulation results.

To apply the new color scale to an active result plot, select **Chart Options > Color Options > Optimized for Colorblindness**.
This chapter includes the following topics:

- **Adding Centerlines to Rectangles**
- **Blocks Retain Sketch Relations**
- **Continuity Relations for Tangency and Equal Curvature**
- **Converting Spline Types**
- **Equidistant Points and Segments**
- **Horizontal and Vertical Sketch Relations**
- **Midpoint Line**
- **Relations for Shared Sketch Endpoints**
- **Replace Sketch Entities with Contours**
- **Select Chain for Construction Geometry**
- **Specifying Construction Lines and Centerlines**
- **Splines on Surfaces**

### Adding Centerlines to Rectangles

You can add centerlines when sketching a rectangle.

Click **Rectangle** (Sketch toolbar). In the PropertyManager, under **Options**, select **Add construction lines** and select either **From Corner** or **From Midpoint**.

<table>
<thead>
<tr>
<th>From Corner construction centerlines</th>
<th>From Midpoint construction centerlines</th>
</tr>
</thead>
<tbody>
<tr>
<td>![From Corner construction centerlines]</td>
<td>![From Midpoint construction centerlines]</td>
</tr>
</tbody>
</table>
Blocks Retain Sketch Relations

When you edit blocks that are linked to external files, the sketch relations between the blocks are maintained as long as the geometry used to define the sketch relations remain identical.

Continuity Relations for Tangency and Equal Curvature

You can add continuity relations for tangency and equal curvature to certain sketch entities as soon as you finish sketching them on existing geometry.

You add the continuity relations when you select a shared endpoint between two entities using the Constraint pop-up toolbar. The toolbar appears when the following sketch entities terminate on:

- A line and an arc
- A style spline and a spline
- Model edges
- Conic, parabola and partial ellipse entities

To apply continuity relations:

1. Open a new sketch. Use the 3 Point Arc tool to sketch an arc.

2. Click Spline (Sketch toolbar) or Tools > Sketch Entities > Spline. Sketch a spline at some distance away from the arc.
3. Snap the spline to the arc's endpoint and double click to terminate the spline.

The Constraint pop-up toolbar displays.

4. Click **Tangent** or **Equal Curvature** from the pop-up toolbar.

Converting Spline Types

You can convert splines to style splines and vice versa. This is helpful when you want to sketch a spline by its through points, but then convert it to a style spline.

To convert a spline, right-click a spline and click **Convert to Style Spline** or **Convert to Spline**.

Equidistant Points and Segments

You can create equidistant points or segments in sketch entities.

**To create equidistant points and segments:**

1. In an active sketch, select a sketch segment.
2. Click Tools > Sketch Tools > Segment.
3. In the PropertyManager:
   a) Set the Number of Instances.
   
   b) Select Sketch points or Sketch segments.
   c) Click.

Horizontal and Vertical Sketch Relations

When you edit lines that are nearly horizontal or vertical, commands on the Sketch Relations context toolbar are highlighted to make it easier for you to align the lines. The software evaluates your actions and selectively highlights either the Make Horizontal or Make Vertical command buttons.

For example, if the line you are editing is close to horizontal, the Make Horizontal icon is outlined, calling your attention to the command to make it easier to align the line horizontally.
If the line is close to vertical, the **Make Vertical** icon is outlined.

**Midpoint Line**

You can create a line that is symmetrical from the midpoint of the line.

Click **Midpoint Line** (Sketch toolbar) or **Tools > Sketch Entities > Midpoint Line**.

**Relations for Shared Sketch Endpoints**

You can select an endpoint shared by two sketch entities to display the same context sensitive toolbar as if you selected each of the entities one-by-one or by lasso or box select.

By selecting one shared endpoint, it is easier to add relations to the sketch entities because the context toolbar contains all possible relations.
Replace Sketch Entities with Contours

With the **Replace Entity** tool, you can replace sketch entities with regular contours instead of only construction geometry.

1. Open `install_dir\samples\whatsnew\parts\replace_entity.sldprt`.
2. Click **Replace Entity** (Sketch toolbar) or **Tools > Sketch Tools > Replace Entity**.
3. In the PropertyManager, click 🔶.
4. In the graphics area, select the line shown for **Replace this entity**.
5. In the graphics area, select the arc shown for **With this one**.
6. In the PropertyManager, select **Make contour** and click ✅.
   The entities are replaced, but the line becomes construction geometry and the arc becomes a regular contour.
7. In the graphics area, select the line shown for Replace this entity.

8. In the graphics area, select the arc shown for With this one.

9. In the PropertyManager, clear Make contour and click ✅. The entities are replaced and become construction geometry.
Select Chain for Construction Geometry

The Select Chain command has been enhanced to allow you to select construction entities.

Specifying Construction Lines and Centerlines

You can convert line segments in a rectangle to construction lines. You can also add centerlines when sketching a rectangle.

In the PropertyManager, you can convert solid line segments to construction lines by selecting For Construction in the PropertyManager.

To add centerlines in a rectangle, select Add construction lines and select either From Corners or From Midpoints in the PropertyManager.

<table>
<thead>
<tr>
<th>From Corner centerlines</th>
<th>From Midpoint centerlines</th>
</tr>
</thead>
</table>

Splines on Surfaces

The Spline on Surface tool works across multiple faces and is more robust for parametric updates. The curve is now more precise and sticks to the actual surface.

Splines on surfaces can:

- Span multiple faces regardless of continuity.
- Update if model geometry is updated (unless the splines are constrained).

You can move the points on the spline to different faces by dragging the points, but not by dragging the curve itself. You can also use handles and apply constraints to edit the curve.
To create a spline on a surface that spans multiple faces:

1. Open `install_dir\samples\whatsnew\parts\spline.sldprt`.

2. Click **Spline on Surface** (Sketch toolbar) or **Tools > Sketch Entities > Spline on Surface**.

3. Sketch a spline starting from the top edge of the surface approximately as shown.

   ![Image of a spline on a surface]

   The spline spans multiple faces with an **On Surface** relation.

4. In the FeatureManager design tree, expand **Surface-Extrude1** and edit **Sketch1**.

5. Drag a spline endpoint to change the shape of the surface. This example shows that the lower endpoint was moved.

6. Exit the sketch.
   The spline on the surface updates to the model geometry.
This chapter includes the following topics:

- Customized Configuration Names
- Tab Stops in Toolbox Settings

### Customized Configuration Names

You can customize configuration names in toolbox components.

- You can display the custom information in the Configuration Name and Designation columns.
- You can display the custom information in the FeatureManager design tree and the BOM.
- You can export the configuration table data to Excel, edit the data, and then import the data back into Toolbox using the existing Toolbox Settings Import/Export menu.
- You cannot use these characters in configuration names due to Microsoft and SOLIDWORKS restrictions: \ / : * ? “ < > | @
- Customized configuration names are added to the configuration list of the Toolbox component when the new configuration is used in an assembly.

#### Customizing Configuration Names

**To customize configuration names:**

1. From Windows, click Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools > Toolbox Settings.
2. Click 2 - Customize your hardware.
3. Select a toolbox component.
4. Select Allow custom configuration name. The Configuration Names are editable.

#### Customizing Designations

**To customize designations:**

1. From Windows, click Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools > Toolbox Settings.
2. Click 2 - Customize your hardware.
3. Select a toolbox component that allows customized designations.

Designation applies only to the AS, DIN, GB, ISO, IS, and KS standards.

4. Select **Allow custom designation**.
   The **Designations** are editable.

**Displaying Custom Configuration Names**

To display custom configuration names or other properties in the FeatureManager design tree or Bill of Materials:

1. From Windows, click **Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools > Toolbox Settings**.
2. Click **3 - User Settings**.
3. Under **Display Options**, do any of the following:
   a) To change the component name in the FeatureManager design tree, in **Show as Component Name in FeatureManager**, select from:
      - Filename
      - Configuration Name
      - Description
      - Designation
      - Part Number
      - Toolbox Custom Properties
   b) To change the part number in the Bill of Materials, in **Show as Part Number in Bill of Materials**, select from:
      - Filename
      - Configuration Name
      - Description
      - Designation
      - Part Number
      - Toolbox Custom Properties
   c) To change the description in the Bill of Materials, in **Show as Description in Bill of Materials**, select from:
      - Filename
      - Configuration Name
      - Description
      - Designation
      - Part Number
      - Toolbox Custom Properties

To update existing assemblies and BOMs, in the FeatureManager design tree, right-click a Toolbox component and click **Edit Toolbox component**. The FeatureManager design tree and Bill of Material update after selecting the new configuration and exiting the Configure Component PropertyManager.

If a component does not have a value associated with the selected property, the default properties display:
When you upgrade to SOLIDWORKS 2015, designation settings from installations prior to SOLIDWORKS 2015 are applied.

### Tab Stops in Toolbox Settings

In Toolbox forms such as the Add New Size dialog box, you can press **Tab** to move forward from cell to cell, and **Shift+Tab** to move backwards.
This chapter includes the following topics:

- **Automatic Update of Cut Lists**
- **Corner Treatment Dialog Box**
- **Creating Assemblies from Multibody Parts or Cut Lists**
- **Cut List Folder Names Inherited from DESCRIPTION Property**
- **Disabling Automatic Creation of Derived Weldment Configurations**
- **Gusset Enhancements**
- **Internal End Caps**
- **QUANTITY and TOTAL LENGTH Properties**
- **Structural Member Visual Grouping**
- **Weld Beads on Single and Multibody Parts**
- **Weldment Options**

### Automatic Update of Cut Lists

When you make geometry changes or edits to weldments, you can automatically update cut lists by right-clicking the cut list and clicking **Update Automatically**.

Use this option when you add new features, such as extruded plates or 3D bounding boxes, edit existing features, or rebuild the model. This updates the model's custom properties and internal supporting data, preventing custom property errors.

To turn off **Update Automatically**, click **Options** (Standard toolbar). On the Document Properties tab, click **Weldments** and select **Automatically update cut lists**.

You can set other weldment options from the Weldments page, including **Create Cut Lists Automatically**, which previously appeared on the Cut list shortcut menu as **Automatic**. This automatically groups similar bodies together in one cut list folder.

### Corner Treatment Dialog Box

The Corner Treatment dialog box has been redesigned so you can more directly control how structural members are trimmed when three or more line segments intersect.

With the newly designed dialog box, it is easier to design weldment frame structures and control the order in which members are trimmed.

In the updated Corner Treatment dialog box:

- The design lets you continue to pan, zoom, and rotate while the dialog box is open.
- A list box provides consistent access to all groups without requiring you to switch pages.
Groups are listed in the same order each time you open the dialog box. The trim order is displayed with each group.

- Corner weld gaps are no longer restricted to one inch or less. You can enter any weld gap.

Creating Assemblies from Multibody Parts or Cut Lists

You can use **Save Bodies** to recognize similar bodies or a multibody cut list, such as weldments, and create an assembly with the appropriate bodies and instance counts.

Bodies must have identical material properties to be instanced in this way.

**To save a part as an assembly and create instance counts from similar bodies:**

1. Click **Insert > Features > Save Bodies**.
2. In the Save Bodies PropertyManager, under **Create Assembly**, select **Derive resulting parts from similar bodies or cut list**.

Cut List Folder Names Inherited from DESCRIPTION Property

You can have the software automatically name cut list folders in a weldment part using the value of the cut list DESCRIPTION property.

Cut list folders with meaningful names provide more information when you check the weldment structure and allow for better communication when you share documents. You can manually rename the folders, or you can automate cut list folder naming.

To set automatic cut list folder names based on the DESCRIPTION property, click **Options** (Standard toolbar) or **Tools > Options**. On the Document Properties tab, click **Weldments** and select **Rename cut list folders with Description property value**.
For weldments created with earlier versions of the SOLIDWORKS software, to generate folder names from the DESCRIPTION property, set the **Rename cut list folders with Description property value** option. Then right-click the cut list and click **Update**.

**Cut list folders with default names**

**Cut list folders renamed using the DESCRIPTION property**

---

**Disabling Automatic Creation of Derived Weldment Configurations**

You can disable the automatic creation of derived configurations if you do not use these configurations.

Previously, the software automatically created derived configurations when you selected **Weldments** or created a structural member. This is still the default behavior. However, many users do not want derived configurations and choose to delete them.

**To disable the automatic creation of derived weldment configurations and configuration description strings:**

1. In a new part, before inserting a weldment, click **Options** (Standard toolbar) or **Tools > Options**.
2. On the Document Properties tab, click **Weldments**.
3. Do one of the following:
   - To disable automatic creation of derived weldment configurations and configuration description strings, clear **Create derived configuration**.
     
     **Assign configuration Description strings** is cleared.
   - To disable only the assignment of configuration description strings, clear **Assign configuration Description strings**.
4. Click **OK**.
Gusset Enhancements

The Gusset PropertyManager includes additional geometric selection conditions for creating gussets.

You can create gussets between:
- Disjointed planar surface bodies separated by a structural member, body radius, or gap
- Rectangular/planar surface bodies and cylindrical/round surface bodies
- Cylindrical to cylindrical (tube to tube) faces

To access these features, click Gusset (Weldments toolbar) or Insert > Weldments > Gusset.

For cylindrical to cylindrical gussets, in the Gusset PropertyManager, you can use planes, sketch lines, and linear edges to define a vector direction. You can also flip the vector direction to the opposite side of the cylinder.

If you provide valid inputs for the selected geometry, a preview of the gusset appears in the graphics area.
Creating a Cylinder-to-Cylinder Gusset

You can add gussets to provide center-to-center reinforcement of cylinders.

To create a cylinder-to-cylinder gusset:

1. Click **Gusset** (Weldments toolbar) or **Insert > Weldments > Gusset**.
2. In the Property Manager, for **Supporting Faces**, select the faces of the cylinders between which you want to add the gusset.
   In this example, the horizontal face is selected first.
   A preview of the gusset appears in the graphics area with arrows showing the gusset direction.

3. Under **Profile**, select a triangular or polygonal gusset profile and specify the profile distances.

4. Optionally, click to create a chamfer to allow room to create a weld bead under the gusset.

5. Select where to apply the gusset thickness and set a value for the thickness.

6. Optionally, reverse the gusset direction by clicking the handle in the preview when the pointer shows **Reverse Direction**.

By default, the profile locates at the midpoint.
Internal End Caps

You can add internal end caps to structural members.

To access the End Cap PropertyManager, click **End Cap** (Weldments toolbar) or **Insert > Weldments > End Cap**.

The **Internal** end cap option in the PropertyManager lets you create the internal end cap. To apply fillets or chamfers to all end caps, under **Corner Treatment**, select **Fillet** or **Chamfer**.

You can offset an end cap from the inside face of a structural member by specifying a decimal **Offset value** in addition to the existing **Thickness ratio**.

You can set **Outward** and **Inward** end caps to be larger than the structural member's outside dimension for base plate or mounting pad applications. You can set the **Thickness ratio** to be larger than 1 for these applications.

### Adding an Internal End Cap

**To add an internal end cap:**

1. Open `install_dir\samples\whatsnew\weldments\inset_with_angled_end_face.sldprt`.

2. Click **End Cap** (Weldments toolbar) or **Insert > Weldments > End Cap**.

3. In the End Cap PropertyManager, under **Parameters**, for **Face**, select the slanted face of the structural member.
   
The preview shows the end cap.
4. Click **Front** (View toolbar) to have a better view of how the end cap controls affect the end cap.

5. For **Thickness direction**, select **Internal**.
6. For **Thickness**, type 0.25in and for **Inset Distance**, type 0.33in.
7. Under **Offset**, select **Offset Value** and type 0.0125in.
8. Select **Corner Treatment**.
9. Select **Fillet** and type 0.125 for **Fillet Radius**.

10. Click ✓.

**QUANTITY and TOTAL LENGTH Properties**

For weldments you create using SOLIDWORKS 2015 or later, the SOLIDWORKS software automatically generates two new properties, **QUANTITY** and **TOTAL LENGTH**.

To view these properties for a cut list folder, right-click the folder in the FeatureManager design tree and click **Properties**. The properties are shown on the **Cut List Summary** and **Properties Summary** tabs.

- **QUANTITY** reflects the quantity in each cut list folder.

  The **QUANTITY** property is unique to the part file that it is created in. It is not propagated when a body is inserted into another part file.

- **TOTAL LENGTH** sums up the lengths of all cut list members that have the same standard, type, material, and size.

  The SOLIDWORKS software traverses all structural member cut list folders to calculate the total length.

  The **TOTAL LENGTH** property uses the same units and precision as the current document property settings. It updates when you edit or change a weldment feature, or rebuild the weldment part.

The software automatically calculates the total length and quantity of cut list items for weldments you create using SOLIDWORKS 2015 or later. For weldments created with
earlier versions of SOLIDWORKS, to generate these values, right-click the cut list and click **Update** or click **Ctrl + Q** to update the cut list.

You can add the values of the **QUANTITY** and **TOTAL LENGTH** properties to Bills of Materials and drawing annotations, as well as accessing the values directly in the Cut-List Properties dialog box.

### Structural Member Visual Grouping

To make it easier to create and edit structural members with multiple groups, when you select a group it highlights in the preview.

When you create structural members, you may use more than one group of selection sets of sketch entities to form the members. To provide visual feedback and let you know which sketch entities belong to a specific group, in the preview, the SOLIDWORKS software shows the group you select in a different color.

To enhance working in the graphics area, when you pause the pointer over a group member, a tooltip identifies the group.

### Weld Beads on Single and Multibody Parts

You can now create and document weld beads on single and multibody parts.

The **Weld Bead** feature now enables you to create and document weld information in geometric cases such as:

- Single body welds
- Welds running between more than two components

You can choose between two weld settings:

- **Weld Geometry**
  
  You define the geometric entities to be welded and the SOLIDWORKS software calculates the weld path.

- **Weld Path**
  
  You select one or more edges or sketches from the same body or a different body to define the weld path.

In addition, you can hold rebuilds to improve performance, especially in large assemblies.
Creating a Single Body Weld Bead

You can create a weld bead on a single body using **Weld Geometry**.

**To create a weld bead on a rolled sheet metal part:**

1. Open `install_dir\samples\whatsnew\weldments\RolledSheetmetal.sldprt`.

![Image of a rolled sheet metal part]

2. Click **Weld Bead** (Weldments toolbar) or **Insert > Weldments > Weld Bead**.

3. Click **Zoom to Area** (Heads-Up View toolbar) and zoom to the bottom of the slit as shown.

![Image showing zoomed area]

4. In the Weld Bead Property Manager, under **Settings**, select **Weld Geometry**.

5. In **Weld From**, select the face of Chamfer1.

![Image showing welded area]
6. In **Weld To**, and select the edge of BaseBend1.

If you select a face for **Weld From**, you must select an edge for **Weld To**.

A preview of the weld between the selected face and edge displays.

7. For **Bead Size**, type 4mm.

8. Click ✔️.

**Creating a Weld Bead on a Multibody Part**

**To create a weld bead on a multibody part:**

1. **Open** `install_dir\samples\whatsnew\weldments\Multi Body Weld Test.sldprt`.

2. **Click** [Weld Bead](#) (Weldments toolbar) or **Insert > Weldments > Weld Bead**.

3. In the Weld Bead Property Manager, under **Settings**, select **Weld Geometry**.

4. In **Weld From**, select the face of Gusset1.
5. In **Weld To**, select Face2 and Face3 of StructuralMember1.

A preview of the weld between the selected faces displays.

6. For **Bead Size**, type 6mm.

7. Click ✔️.

**Weldment Options**

There is a Weldments page on the Document Properties tab of the Options dialog box. On a per document basis, this page lets you set the following weldment behaviors:

<table>
<thead>
<tr>
<th>Option</th>
<th>Default Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Automatically create cut lists</strong></td>
<td>On Off</td>
<td>Enables the Create Cut Lists Automatically setting on the cut list shortcut menu. This setting automatically groups similar bodies together within one cut list folder.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Option</th>
<th>Default Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Automatically create cut lists</strong></td>
<td>On Off</td>
<td>Enables the Create Cut Lists Automatically setting on the cut list shortcut menu. This setting automatically groups similar bodies together within one cut list folder.</td>
</tr>
<tr>
<td>Option</td>
<td>Default Setting</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Automatically update cut lists</td>
<td>On</td>
<td>Enables the <strong>Update Automatically</strong> setting on the cut list shortcut menu.</td>
</tr>
<tr>
<td></td>
<td>Off</td>
<td>This setting updates the model's custom properties and internal supporting data when you make geometry changes or edits to weldments.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>This setting is on by default for all new parts you create in SOLIDWORKS 2015. You can turn it off manually to avoid performance issues with large weldments.</td>
</tr>
<tr>
<td>Create derived configurations</td>
<td>On</td>
<td>Creates the derived configuration <strong>Default[As Welded]</strong> when you create a structural member in a part.</td>
</tr>
<tr>
<td>Assign configuration Description strings</td>
<td>On</td>
<td>Only available when <strong>Create derived configurations</strong> is enabled.</td>
</tr>
<tr>
<td></td>
<td>Off</td>
<td>Adds the <strong>As Welded</strong> and <strong>As Machined</strong> configuration descriptions when you insert a weldment feature into a new part.</td>
</tr>
<tr>
<td>Rename cut list folders with Description</td>
<td>On</td>
<td>Enables the option to rename cut list folders with the Description property value.</td>
</tr>
<tr>
<td>Description property value</td>
<td>Off</td>
<td>The behavior of this option is as follows:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• When you create new parts in SOLIDWORKS 2015 using blank templates, the option is enabled.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• When you create new parts in SOLIDWORKS 2015 with existing/saved templates that were created using SOLIDWORKS 2015, the option is read from the templates you use.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• When you create new parts with existing/saved templates that were created in versions before SOLIDWORKS 2015, the option is disabled.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• For files created with a version of SOLIDWORKS that is older than 2015, the option is disabled. You must manually enable it for these files.</td>
</tr>
</tbody>
</table>
These options, except **Assign configuration Description strings**, are new for SOLIDWORKS 2015. They are enabled by default.

- To enable the new options for a SOLIDWORKS file created before 2015, open the file, check the options, and save the file.
- To disable any of the options for a new SOLIDWORKS 2015 file, open the file, clear the option, and save the file.

You can also set the option behavior for future parts by opening the SOLIDWORKS 2015 part template, checking or clearing the options, and saving the template.