WHAT'S NEW
SOLIDWORKS 2016
## Contents

**Legal Notices** ................................................................................................................................. 11

1 Welcome to SOLIDWORKS 2016 ........................................................................................................... 14
   Top Enhancements ................................................................................................................................. 15
   For More Information .......................................................................................................................... 17

2 User Interface ................................................................................................................................... 18
   User Interface Redesign ....................................................................................................................... 18
   Improved User Interface Scaling for High-Resolution Screens .......................................................... 19
   New Icon Style with Color Options ..................................................................................................... 20
   Icons in the FeatureManager Design Tree .......................................................................................... 21
   Redesigned Triad ................................................................................................................................. 21
   Analysis Preparation CommandManager ............................................................................................ 23
   Changing Background ......................................................................................................................... 24
   Expandable PropertyManager Input Boxes .......................................................................................... 25
   FeatureManager Design Tree Filter Performance ............................................................................... 26
   Hiding and Showing Primary Planes .................................................................................................... 26
   Keyboard Input in PropertyManagers ................................................................................................... 27
   Menu Consolidation ............................................................................................................................ 27
   Moving the Confirmation Corner Options to the Pointer ...................................................................... 28
   Persistent Context Toolbar When Sketching ....................................................................................... 29
   Selection Breadcrumbs ......................................................................................................................... 29
   Toolbar and CommandManager Docking Behavior ............................................................................. 32
      Freezing the Current Layout of Docked Toolbars ............................................................................ 33
   Undo Location on Mate Context Toolbar ............................................................................................ 33
   Visualization Tool for References ...................................................................................................... 33

3 SOLIDWORKS Fundamentals ............................................................................................................. 35
   3D ContentCentral ................................................................................................................................. 35
   3D Printing Enhancements - Preview .................................................................................................... 36
      Displaying Striation Lines .................................................................................................................. 36
      Identifying Faces that Require Supports ......................................................................................... 38
   3D Printing Enhancements - Settings .................................................................................................. 39
      Changing the Model Scale ............................................................................................................... 39
      Reorienting the Model to Fit the Print Volume ................................................................................. 40
   Active Content Warnings .................................................................................................................... 42
<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>42</td>
</tr>
<tr>
<td>43</td>
</tr>
<tr>
<td>44</td>
</tr>
<tr>
<td>44</td>
</tr>
<tr>
<td>46</td>
</tr>
<tr>
<td>47</td>
</tr>
<tr>
<td>47</td>
</tr>
<tr>
<td>48</td>
</tr>
<tr>
<td>50</td>
</tr>
<tr>
<td>51</td>
</tr>
<tr>
<td>51</td>
</tr>
<tr>
<td>51</td>
</tr>
<tr>
<td>52</td>
</tr>
<tr>
<td>53</td>
</tr>
<tr>
<td>54</td>
</tr>
<tr>
<td>54</td>
</tr>
<tr>
<td>54</td>
</tr>
<tr>
<td>54</td>
</tr>
<tr>
<td>55</td>
</tr>
<tr>
<td>55</td>
</tr>
<tr>
<td>56</td>
</tr>
<tr>
<td>56</td>
</tr>
<tr>
<td>56</td>
</tr>
<tr>
<td>57</td>
</tr>
<tr>
<td>57</td>
</tr>
<tr>
<td>58</td>
</tr>
<tr>
<td>58</td>
</tr>
<tr>
<td>58</td>
</tr>
<tr>
<td>59</td>
</tr>
<tr>
<td>60</td>
</tr>
<tr>
<td>60</td>
</tr>
<tr>
<td>62</td>
</tr>
<tr>
<td>64</td>
</tr>
<tr>
<td>70</td>
</tr>
<tr>
<td>71</td>
</tr>
<tr>
<td>72</td>
</tr>
<tr>
<td>73</td>
</tr>
<tr>
<td>73</td>
</tr>
<tr>
<td>73</td>
</tr>
</tbody>
</table>

### 4 Installation and Administration

- Deleting Accounts from the CAD Admin Dashboard View
- Deploying Installs by IP Addresses
- Installing SOLIDWORKS PDM
- Managing Access to SOLIDWORKS Versions
- Products Included with SOLIDWORKS
- SOLIDWORKS Rx
  - Graphics Card Validation
  - Record Extended Logging Data
  - Simulation Test
- Troubleshooting Resources for Installation
- Upgrade Assistant

### 5 Assemblies

- Choosing a Configuration While Adding a Component
- Component Selection Enhancements
  - Selecting Components by Size
  - Selecting Identical Components
- Copying Multiple Components
- Mates
  - Cam Mate Selection Enhancement
  - Component Preview Window
  - Copy with Mates Enhancement
  - Globally Replacing Failed Mate References
  - Making Components Transparent for Mating
  - Mate Controller
  - Quick Mates Improvements
- Mirroring Assembly Features
- Pattern Driven Component Pattern Improvements
- Performance Evaluation (Formerly AssemblyXpert)
- Purging Unused Features
Contents

- Remove All Appearances ................................................................. 74
- Renaming Components in the FeatureManager Design Tree .................. 74
- Replacing Subassemblies with Multibody Parts .................................. 76
- Subassemblies .................................................................................... 76
  - Form/Disolve Subassembly Improvements .......................................... 76
  - Improved Reordering of Subassemblies .............................................. 76
  - Mirroring and Patterning Flexible Subassemblies .................................. 77
  - Opening Subassemblies ...................................................................... 78
  - Virtual Subassemblies ........................................................................ 79
- Temporarily Fix Components with a Separate Tool .................................. 79
- Toggling the Visibility of Components .................................................. 79
- Treehouse Improvements ..................................................................... 80
  - Displaying and Editing Configuration Specific Properties .................. 80
  - Treehouse Options ............................................................................ 80
  - Creating New Files from Existing Ones ............................................ 81

6 CircuitWorks .................................................................................. 82
- Building SOLIDWORKS Models from ECAD Files in Batch Mode ........ 82
- Component Library Improvements ..................................................... 83
- Creating Copper Traces as Decals ....................................................... 83
- Filtering Components When Opening ECAD Files .............................. 85
- Locating CircuitWorks Components ................................................... 86
- Saving and Loading CircuitWorks Options ......................................... 86
- Specifying Component Heights .......................................................... 87

7 DimXpert ....................................................................................... 88
- Basic Dimensions .............................................................................. 88
- Datums ............................................................................................... 89
- Datum Reference Frames ................................................................. 90
- DimXpert in Assemblies ..................................................................... 91
- DimXpert Updates ............................................................................ 91
- Face Edge Selection ........................................................................... 92
- Horizontal and Vertical Reference and DimXpert Dimensions .......... 93
- Silhouette Edge Selection ................................................................... 94

8 SOLIDWORKS Composer ............................................................... 96
- SOLIDWORKS Composer ................................................................ 96
  - Accurate Naming of Tree Items Imported from 3DXML ..................... 96
  - Construction Geometries Imported as Stay on Top ......................... 96
  - Import of Parasolid Files .................................................................. 97
  - Import of Unigraphics Files .............................................................. 97
  - New Features in Composer Application Programming Interface ....... 97
  - New Timeline Tracks ....................................................................... 97
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flag Notes .................................................................</td>
</tr>
<tr>
<td>Link to Property ..........................................................</td>
</tr>
<tr>
<td>Paragraph Numbering .......................................................</td>
</tr>
<tr>
<td>Rearranging Stacked Balloons ............................................</td>
</tr>
<tr>
<td>Set all Custom Property Values to the Same as a Sheet ............</td>
</tr>
<tr>
<td>Sheet Metal Information in Drawings ....................................</td>
</tr>
<tr>
<td>Performance ........................................................................</td>
</tr>
<tr>
<td>Full Scene Anti-Aliasing Improvements ...................................</td>
</tr>
<tr>
<td>Performance Evaluation .....................................................</td>
</tr>
<tr>
<td>Sheets ................................................................................</td>
</tr>
<tr>
<td>Automatic Border .............................................................</td>
</tr>
<tr>
<td>Edit Sheet Format ............................................................</td>
</tr>
<tr>
<td>Sheet Scale ..........................................................................</td>
</tr>
<tr>
<td>Title Blocks .........................................................................</td>
</tr>
<tr>
<td>11 eDrawings .......................................................................</td>
</tr>
<tr>
<td>3D Views and Annotation Views ...........................................</td>
</tr>
<tr>
<td>Component Descriptions ....................................................</td>
</tr>
<tr>
<td>Exploded Views ....................................................................</td>
</tr>
<tr>
<td>Exploded Views Slider .......................................................</td>
</tr>
<tr>
<td>Radial Explodes ...................................................................</td>
</tr>
<tr>
<td>Intersection Zones in Section Views .....................................</td>
</tr>
<tr>
<td>Model Break Views ............................................................</td>
</tr>
<tr>
<td>Performance ........................................................................</td>
</tr>
<tr>
<td>Rotating Models ...............................................................</td>
</tr>
<tr>
<td>Undo and Redo .....................................................................</td>
</tr>
<tr>
<td>Units of Measure ..............................................................</td>
</tr>
<tr>
<td>User Interface Enhancements ...............................................</td>
</tr>
<tr>
<td>Weld Beads .........................................................................</td>
</tr>
<tr>
<td>12 SOLIDWORKS Electrical ..................................................</td>
</tr>
<tr>
<td>Annotate Documents with eDrawings ......................................</td>
</tr>
<tr>
<td>Formula Manager Enhancements ..........................................</td>
</tr>
<tr>
<td>Integration with CircuitWorks Lite .......................................</td>
</tr>
<tr>
<td>Limiting User Rights on Project Data ....................................</td>
</tr>
<tr>
<td>Paste Special Wizard Improvements ......................................</td>
</tr>
<tr>
<td>Project Snapshot ...............................................................</td>
</tr>
<tr>
<td>Properties Side Panels ......................................................</td>
</tr>
<tr>
<td>Report Filters .....................................................................</td>
</tr>
<tr>
<td>Additional Enhancements for SOLIDWORKS Electrical ............</td>
</tr>
<tr>
<td>13 SOLIDWORKS Flow Simulation .........................................</td>
</tr>
<tr>
<td>Mesh Settings ......................................................................</td>
</tr>
</tbody>
</table>
Mirror Results for Symmetrical Models ................................................................................................. 133
Transient Analysis ...................................................................................................................................... 134
Sunlight Properties Import .......................................................................................................................... 134

14 Import/Export ....................................................................................................................................... 135
Exporting Material Properties to IFC 2x3 Files ....................................................................................... 135
Exporting to the IFC 4.0 Format .................................................................................................................. 135
Import of Visual Properties ......................................................................................................................... 136
Importing PTC Creo 3.0 Files ...................................................................................................................... 136
Importing STL Models ............................................................................................................................... 136

15 SOLIDWORKS Inspection .................................................................................................................... 137
Exporting Inspection Reports to Net-Inspect and QualityXpert ................................................................. 137
Horizontal and Vertical Report Formats .................................................................................................... 137
Standalone SOLIDWORKS Inspection Enhancements ............................................................................. 138
Deleting Multiple Measurement Results .................................................................................................... 138
Optical Character Recognition Editor ....................................................................................................... 138
Optical Character Recognition for Custom Properties ............................................................................... 139
Specifying Export Results ......................................................................................................................... 139

16 SOLIDWORKS MBD ............................................................................................................................ 140
3D PDF Improvements ............................................................................................................................... 140
3D PDF Template Editor ............................................................................................................................. 141
Generic Tables ........................................................................................................................................... 141
Multiple BOMs .......................................................................................................................................... 141
Multiple Viewports .................................................................................................................................... 141
Adding PDF Sheets ..................................................................................................................................... 142
Removing PDF Sheets ............................................................................................................................... 142
3D Views Tab Visibility ............................................................................................................................... 142

17 Model Display ....................................................................................................................................... 143
Callout Improvements ............................................................................................................................... 143
Cartoon Rendering in RealView .................................................................................................................. 145
Changing Cartoon Settings with PhotoView 360 ...................................................................................... 146
Changing Cartoon Settings Using Model Display Options ......................................................................... 147
PhotoView 360 Rendering Improvements .................................................................................................. 148
Access to Perspective Views for Renderings ............................................................................................... 148
Adding Motion Blur to Animations .............................................................................................................. 148
Including Annotations and Dimensions in Final Renderings .................................................................... 148
PhotoView 360 Lighting Control Through Proof Sheets ............................................................................ 149
Parallel Tessellation When Regenerating Assembly Graphics .................................................................... 151
Preserving Appearances with Derived Parts ............................................................................................. 151
Section View Offset Options ..................................................................................................................... 152
18 Parts and Features........................................................................................................154
  Create ANSI Inch Holes with FeatureWorks and Direct Editing........................................154
  Curvature Continuous Edge Fillets .....................................................................................154
  Dynamic Preview for Intersect and Trim Surface Tools .......................................................156
    Removing Regions with Intersect Tool ..............................................................................157
  Maintain Hole Wizard Settings When Changing Type .........................................................159
  Options for Modifying Geometry with the Intersect Tool ..................................................159
  Patterns....................................................................................................................................160
    More Inputs for Linear Patterns .........................................................................................160
    No Limit on Number of Instances .....................................................................................160
    Pattern Table Enhancements for Variable Patterns ..........................................................161
  Reference Geometry .............................................................................................................162
    Planes Parallel to Screen ....................................................................................................162
    Reusing Absorbed Reference Curves .................................................................................162
  Surfaces...................................................................................................................................163
    Converting a Surface into a Solid .......................................................................................163
    Flatten Surface Enhancements .........................................................................................163
  Sweep......................................................................................................................................166
    Sweep Redesign ................................................................................................................166
  Thread .....................................................................................................................................170
    Setting Thread Profiles Location .....................................................................................170
    Creating a Cut Thread ........................................................................................................170
  Toggling the Visibility of Bodies ...........................................................................................172

19 SOLIDWORKS PDM........................................................................................................173
  Installation Changes for SOLIDWORKS PDM .....................................................................173
    Installing Using the SOLIDWORKS Installation Manager .............................................174
    Installing Using the SOLIDWORKS PDM InstallShield Wizard .........................................175
  Modifying Custom Properties of PDFs Using PDF Plug-in (For SOLIDWORKS PDM
  Professional only) .................................................................................................................175
    Mapping Custom Properties to PDF Cards .........................................................................176
  Reference Handling for Moved or Renamed Files ...............................................................176
  Rename a File in SOLIDWORKS FeatureManager Design Tree ........................................177
    Warning Icons and Background Colors in the SOLIDWORKS PDM Task Pane ...............178
  SOLIDWORKS PDM Standard .............................................................................................178
  Sorting Columns in Tables ....................................................................................................182
    Sorting Order in Columns ..................................................................................................182
    Table Control Settings and Sorting Behavior ....................................................................183
  Synchronizing a Revision Variable to a Revision Number ................................................183
  Set Revision Enhancements .................................................................................................184
  Using Windows Search for Content Search ........................................................................185
## 20 SOLIDWORKS Plastics

- Runner Domain .............................................................................................................. 187
- Solver Performance ........................................................................................................... 187
- Report Template ............................................................................................................... 188
- User Interface .................................................................................................................. 188

## 21 Routing

- CommandManager and Menu Updates for Rectangular Ducting ........................................ 189
- Using Auto Route for Rectangular Section Routing ........................................................... 190
- Flex Cables ....................................................................................................................... 190
  - Creating Flex Cable Routes ............................................................................................. 190
- General Quality Enhancements .......................................................................................... 193
- Support for Elbows and Pipes in the Pack and Go Route Assembly ..................................... 194
- Route Wires through Electrical Ducts and Cable Tray ....................................................... 195
  - Creating a Route for Connectors through Cable Tray .................................................... 195
- Coverings for Rectangular Section Routes and Ducts ....................................................... 197

## 22 Sheet Metal

- Cuts in Swept Flanges ........................................................................................................ 198
- Edge Flanges ..................................................................................................................... 199
- Using Flattened Mass ....................................................................................................... 200

## 23 SOLIDWORKS Simulation

- Blended Curvature-based Mesher ...................................................................................... 201
- Automatic Bonding for Shells ............................................................................................. 202
- Bolts and Pins on the Same Part ....................................................................................... 203
- Controlling Values and Display of Maxima and Minima on Contour Plots ......................... 204
- Detecting Underconstrained Bodies .................................................................................. 206
- Display Results for Remote Mass and Remote Load ......................................................... 206
- Equation-driven Results .................................................................................................... 207
- Improved Solver Error Messages ..................................................................................... 207
- Releasing Prescribed Displacements ............................................................................... 207
- Report Publish Options .................................................................................................... 208
- Sectioning the Mesh .......................................................................................................... 209

## 24 Sketching

- Cap Ends for Offset Entities .............................................................................................. 210
  - Construction Geometry for Offset Entities .................................................................... 211
- Converting Entities with Internal Loops .......................................................................... 212
- Equal Curve Length Parametric Relations ...................................................................... 212
- Instant2D for Changing Sketch Dimensions .................................................................... 213
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preselection of Entities for Smart Dimensioning</td>
<td>214</td>
</tr>
<tr>
<td>Reversing Sketch Offsets</td>
<td>214</td>
</tr>
<tr>
<td>Segment Tool</td>
<td>214</td>
</tr>
<tr>
<td>Arc and Circle Segments</td>
<td>214</td>
</tr>
<tr>
<td>Equidistant Relations</td>
<td>215</td>
</tr>
<tr>
<td>Editing Sketch Points</td>
<td>215</td>
</tr>
<tr>
<td>Deleting Sketch Points</td>
<td>215</td>
</tr>
<tr>
<td>Selecting Midpoints with Dynamic Highlighting</td>
<td>216</td>
</tr>
<tr>
<td>Show or Hide Sketch Dimensions</td>
<td>217</td>
</tr>
<tr>
<td>Style Spline Support for B-Splines</td>
<td>217</td>
</tr>
<tr>
<td>Unmerging Sketch Endpoints with Detach Segment on Drag</td>
<td>218</td>
</tr>
<tr>
<td>Improvement in Large Sketch Performance</td>
<td>219</td>
</tr>
<tr>
<td>25 SOLIDWORKS Toolbox</td>
<td>220</td>
</tr>
<tr>
<td>Editing Multiple Configurations of a Toolbox Component</td>
<td>220</td>
</tr>
<tr>
<td>Replacing Toolbox Components</td>
<td>221</td>
</tr>
<tr>
<td>Toolbox Add-in Name Changes</td>
<td>222</td>
</tr>
<tr>
<td>Toolbox Data Import and Export</td>
<td>222</td>
</tr>
<tr>
<td>Toolbox Favorites</td>
<td>222</td>
</tr>
<tr>
<td>26 SOLIDWORKS Utilities</td>
<td>224</td>
</tr>
<tr>
<td>Compare Geometry Enhancements</td>
<td>224</td>
</tr>
<tr>
<td>Running Compare Geometry</td>
<td>224</td>
</tr>
<tr>
<td>Merging Volumes with the Intersect Tool</td>
<td>226</td>
</tr>
<tr>
<td>27 Weldments</td>
<td>228</td>
</tr>
<tr>
<td>Modifying End Cap Positions Using Reference Dimensions</td>
<td>228</td>
</tr>
<tr>
<td>Structural Member Feature Names</td>
<td>229</td>
</tr>
<tr>
<td>Structural Member Size Lists</td>
<td>230</td>
</tr>
<tr>
<td>Total Length for Derived Parts</td>
<td>230</td>
</tr>
<tr>
<td>Transferring Material Properties from Library Profiles</td>
<td>231</td>
</tr>
</tbody>
</table>
Legal Notices

© 1995-2016, Dassault Systemes SolidWorks Corporation, a Dassault Systèmes SE company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systemes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of the license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the license agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SOLIDWORKS® 3D mechanical CAD and/or Simulation software is protected by U.S. Patents 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; 8,581,902; 8,817,028, 8,910,078; 9,129,083; 9,153,072 and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademarks and Product Names for SOLIDWORKS Products and Services

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360, and TolAnalyst are trademarks of DS SolidWorks. FeatureWorks is a registered trademark of Geometric Ltd.


Other brand or product names are trademarks or registered trademarks of their respective holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of “commercial computer software” and “commercial software documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government (a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in
48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the Department of Defense, consistent with the policies set forth in 48 C.F.R. 227.7202-1 (JUN 1995) and 227.7202-4 (JUN 1995)

In the event that you receive a request from any agency of the U.S. Government to provide Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope of the request and DS SolidWorks will have five (5) business days to, in its sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SOLIDWORKS Standard, Premium, Professional, and Education Products

Portions of this software © 1986-2015 Siemens Product Lifecycle Management Software Inc. All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:


Portions of this software © 1998-2015 Geometric Ltd.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2015 Luxology, LLC. All rights reserved, patents pending.

Portions of this software © 2007-2015 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SOLIDWORKS.

Copyright Notices for SOLIDWORKS Simulation Products

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2014 Computational Applications and System Integration, Inc. All rights reserved.

Copyright Notices for SOLIDWORKS Standard Product

© 2011, Microsoft Corporation. All rights reserved.

Copyright Notices for SOLIDWORKS PDM Professional Product

Outside In® Viewer Technology, © 1992-2012 Oracle
© 2011, Microsoft Corporation. All rights reserved.
Copyright Notices for eDrawings Products

Portions of this software © 2000-2014 Tech Soft 3D.
Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.
Portions of this software © 1998-2001 3Dconnexion.
Portions of this software © 1998-2014 Open Design Alliance. All rights reserved.
Portions of this software © 1995-2012 Spatial Corporation.
The eDrawings® for Windows® software is based in part on the work of the Independent JPEG Group.
Welcome to SOLIDWORKS 2016

SOLIDWORKS® 2016 delivers many enhancements and improvements, most created in direct response to customer requests. This release focuses on helping you get your work done faster and easier than ever before:

- **Focus on your design, not the software**: Work smarter and get the CAD system out of your way.
- **Solve complex problems faster and easier**: Access innovative tools to solve complex problems.
- **Streamline your parallel design processes**: Use integrated mechatronic design processes, concurrent design on one platform, streamlined electrical and mechanical design, and collaborate across multiple disciplines from design to manufacturing.
- **Fast-track your designs to manufacturing**: Create better outputs for manufacturing, streamline the process, and shorten the product development cycle.

This chapter includes the following topics:

- **Top Enhancements**
- **For More Information**
Top Enhancements

The top enhancements for SOLIDWORKS 2016 provide improvements to existing products and innovative new functionality.

Throughout this guide, look for the symbol in these areas:

**User Interface**
- **User Interface Redesign** on page 18
- **Improved User Interface Scaling for High-Resolution Screens** on page 19
- **New Icon Style with Color Options** on page 20
- **Redesigned Triad** on page 21
- **Selection Breadcrumbs** on page 29

**SOLIDWORKS Fundamentals**
- **Expandable PropertyManager Input Boxes** on page 25

**Assemblies**
- **Component Preview Window** on page 58
- **Copying Multiple Components** on page 57
- **Globally Replacing Failed Mate References** on page 60
- **Mate Controller** on page 64
- **Mirroring Assembly Features** on page 71
- **Renaming Components in the FeatureManager Design Tree** on page 74
- **Replacing Subassemblies with Multibody Parts** on page 76

**SOLIDWORKS Costing**
- **Costing Assemblies Report** on page 101
- **Rules-based Costing** on page 105

**Drawings and Detailing**
- **Automatic Border** on page 120
- **Flag Notes** on page 115
- **Foreshortening of Linear Dimensions** on page 108
- **Model Break Views Within Drawings** on page 110
- **Part and Assembly Watermarks** on page 114
- **Rearranging Stacked Balloons** on page 118

**eDrawings**
- **Rotating Models** on page 128
- **Units of Measure** on page 128

**SOLIDWORKS Electrical**
- **Annotate Documents with eDrawings** on page 130
- **Integration with CircuitWorks Lite** on page 130
- **Properties Side Panels** on page 131
<table>
<thead>
<tr>
<th>Category</th>
<th>New Feature</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLIDWORKS PDM</td>
<td>Modifying Custom Properties of PDFs Using PDF Plug-in</td>
<td>175</td>
</tr>
<tr>
<td></td>
<td>(For SOLIDWORKS PDM Professional only)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SOLIDWORKS PDM Standard</td>
<td>178</td>
</tr>
<tr>
<td></td>
<td>Synchronizing a Revision Variable to a Revision Number</td>
<td>183</td>
</tr>
<tr>
<td>Import/Export</td>
<td>Exporting to the IFC 4.0 Format</td>
<td>135</td>
</tr>
<tr>
<td></td>
<td>Importing PTC Creo 3.0 Files</td>
<td>136</td>
</tr>
<tr>
<td>Model Display</td>
<td>Callout Improvements</td>
<td>143</td>
</tr>
<tr>
<td>Parts and Features</td>
<td>Creating Rods and Tubes with a Circular Profile</td>
<td>168</td>
</tr>
<tr>
<td></td>
<td>Creating a Bidirectional Sweep</td>
<td>166</td>
</tr>
<tr>
<td></td>
<td>Curvature Continuous Edge Fillets</td>
<td>154</td>
</tr>
<tr>
<td></td>
<td>Thread</td>
<td>170</td>
</tr>
<tr>
<td></td>
<td>Dynamic Preview for Intersect and Trim Surface Tools</td>
<td>156</td>
</tr>
<tr>
<td></td>
<td>Flatten Surface Enhancements</td>
<td>163</td>
</tr>
<tr>
<td>Sheet Metal</td>
<td>Cuts in Swept Flanges</td>
<td>198</td>
</tr>
<tr>
<td></td>
<td>Edge Flanges</td>
<td>199</td>
</tr>
<tr>
<td></td>
<td>Using Flattened Mass</td>
<td>200</td>
</tr>
<tr>
<td>SOLIDWORKS Simulation</td>
<td>Blended Curvature-based Mesher</td>
<td>201</td>
</tr>
<tr>
<td></td>
<td>Detecting Underconstrained Bodies</td>
<td>206</td>
</tr>
<tr>
<td></td>
<td>Equation-driven Results</td>
<td>207</td>
</tr>
<tr>
<td></td>
<td>Improved Solver Error Messages</td>
<td>207</td>
</tr>
<tr>
<td></td>
<td>Sectioning the Mesh</td>
<td>209</td>
</tr>
<tr>
<td>Sketching</td>
<td>Equal Curve Length Parametric Relations</td>
<td>212</td>
</tr>
<tr>
<td></td>
<td>Selecting Midpoints with Dynamic Highlighting</td>
<td>216</td>
</tr>
<tr>
<td></td>
<td>Style Spline Support for B-Splines</td>
<td>217</td>
</tr>
<tr>
<td>SOLIDWORKS Toolbox</td>
<td>Editing Multiple Configurations of a Toolbox Component</td>
<td>220</td>
</tr>
<tr>
<td></td>
<td>Replacing Toolbox Components</td>
<td>221</td>
</tr>
</tbody>
</table>
Weldments

- Transferring Material Properties from Library Profiles on page 231

All features are available in SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium unless otherwise noted.

For More Information

Use the following resources to learn about SOLIDWORKS:

**What's New in PDF and HTML**

This guide is available in PDF and HTML formats. Click:

- Help > What's New > PDF
- Help > What's New > HTML

**Interactive What's New**

In SOLIDWORKS, click the symbol to display the section of this manual that describes an enhancement. The symbol appears next to new menu items and the titles of new and changed PropertyManagers.

To enable Interactive What's New, click Help > What's New > Interactive.

**What's New Examples**

What's New Examples are updated at every major release to provide examples of how to use most top enhancements in the release.

To open What's New Examples click Help > What's New > What's New Examples.

**Online Help**

Contains complete coverage of our products, including details about the user interface, samples, and examples.

**Release Notes**

Provides information about late changes to our products, including changes to the What's New book, online help, and other documentation.
User Interface

This chapter includes the following topics:

- User Interface Redesign
- Improved User Interface Scaling for High-Resolution Screens
- New Icon Style with Color Options
- Icons in the FeatureManager Design Tree
- Redesigned Triad
- Analysis Preparation CommandManager
- Changing Background
- Expandable PropertyManager Input Boxes
- FeatureManager Design Tree Filter Performance
- Hiding and Showing Primary Planes
- Keyboard Input in PropertyManagers
- Menu Consolidation
- Moving the Confirmation Corner Options to the Pointer
- Persistent Context Toolbar When Sketching
- Selection Breadcrumbs
- Toolbar and CommandManager Docking Behavior
- Undo Location on Mate Context Toolbar
- Visualization Tool for References

User Interface Redesign

The SOLIDWORKS 2016 user interface is redesigned to provide better support for high-resolution, high-pixel density displays.

Icons and buttons are more crisp and readable, and they scale properly when used with high-resolution displays. Two icon color schemes are available, one with a limited palette of blue and gray, and the other with colors similar to the previous icon set for the most frequently used icons.

Visual clutter is reduced in the user interface, and a new triad design improves visual clarity and ease of use.
Improved User Interface Scaling for High-Resolution Screens

Icons and buttons scale so that their appearance does not degrade or become blurry when they are displayed on high-resolution and high-pixel density displays.

All aspects of the user interface respond to the Microsoft Windows® display scaling setting. In dialog boxes, PropertyManagers, and the FeatureManager design tree, the SOLIDWORKS software uses the display scaling setting to display icons and buttons at an appropriate size. Icons that are associated with text are scaled to a size appropriate for the text.

In addition, for toolbars, you can display Small, Medium, or Large buttons by doing one of the following:

- Click the Options fly-out button (Standard toolbar), click Button Size and select a button size.
- Click Tools > Customize and on the Toolbar tab, select an Icon size:
New Icon Style with Color Options

SOLIDWORKS 2016 provides a new icon style that improves readability and recognition. The icon style includes crisper lines, removes non-essential details, and emphasizes primary elements. The icons scale without loss of clarity on high-resolution and high-density displays.

Most icons are similar to previous icons, and their location on the CommandManager and toolbars has not changed.

SOLIDWORKS 2016 (Default icons)

The new icons are available in two color schemes. The Default icons use a blue and gray color scheme to provide a cool, crisp look, and to avoid distracting attention from the main design area. The visual styling uses dark gray outlining to define the icon shape and blue to emphasize the primary action or feature.

The Classic icons use colors similar to the icons from earlier versions of SOLIDWORKS.

<table>
<thead>
<tr>
<th>Action/Feature</th>
<th>Default icon</th>
<th>Classic icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundary Cut</td>
<td>![Boundary Cut Icon]</td>
<td>![Boundary Cut Icon]</td>
</tr>
<tr>
<td>Extruded Boss/Base</td>
<td>![Extruded Boss/Base Icon]</td>
<td>![Extruded Boss/Base Icon]</td>
</tr>
<tr>
<td>Offset Surface</td>
<td>![Offset Surface Icon]</td>
<td>![Offset Surface Icon]</td>
</tr>
</tbody>
</table>

To select which icon colors to use:
1. Click **Options** (Standard toolbar) and click **Colors**.
2. For **Icon colors**, select **Default** or **Classic**.
3. Click **OK**.

**Icons in the FeatureManager Design Tree**

In the FeatureManager design tree, the icons for bodies, parts, and folders are blue instead of gray.

Hidden components have their own wireframe-like icons, instead of being indicated by a slash over the icon used for the regular (non-hidden) version.

**Redesigned Triad**

The triad is redesigned to make it easier to control model orientation in 3D, using selection handles and angle rotation.

On screen manipulators like the triad manipulator, section view triad, and Instant3D arrows have been redesigned for better visibility and enlarged to be easier to manipulate.

<table>
<thead>
<tr>
<th>2015</th>
<th>2016</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Move triad" /></td>
<td><img src="image" alt="Move triad" /></td>
</tr>
<tr>
<td><img src="image" alt="Instant3D arrows" /></td>
<td><img src="image" alt="Instant3D arrows" /></td>
</tr>
</tbody>
</table>
In the redesigned triad, the controls are orange. When you hover near them, they turn blue to show they are active.

- Rings

The ring that contains the X and Y arrows is shown as a full circle. Use it to rotate the selected plane:
Rings that are perpendicular to the selected plane are single quadrants. Use them to rotate the model around the axis (in this case Z) that is normal to the selected plane:

In the section view triad, 180° rings let you rotate the selected plane or a reference plane:

- Selection handles
  The handles are more visible and easier to drag in the graphics area. Coordinates (X, Y, Z) are shown for each handle. Use them to move the model in the selected direction:

Analysis Preparation CommandManager

When the active document is a SOLIDWORKS part, an Analysis Preparation tab is added to the CommandManager when you add in SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, or SOLIDWORKS Plastics.

The Analysis Preparation tab is prepopulated with tools that you use frequently with the add-in you select. You can customize the tab by adding additional tools.

To display the Analysis Preparation tab, click **Tools > Add-ins** and select **SOLIDWORKS Simulation**, **SOLIDWORKS Flow Simulation**, or **SOLIDWORKS Plastics**.
The Analysis Preparation CommandManager is not available for Assemblies.

Changing Background

You can control the brightness of the background of the SOLIDWORKS user interface. The background setting affects the user interface surrounding the graphics area but does not change the graphics area.
To change the background:

1. Click Options.
2. Select System Options > Colors.
3. For Background, select one of the following:
   - Light (default)
   - Medium Light
   - Medium
   - Dark

The screen text color adjusts automatically for visibility on the new background.

Optionally, you can choose a specific color for the text in the FeatureManager design tree or the Flyout FeatureManager design tree by selecting and editing FeatureManager Design Tree Text or Flyout FeatureManager Design Tree Text under Color scheme settings.

4. Click OK.

Expandable PropertyManager Input Boxes

When a PropertyManager contains an input box that lists selections, the list expands to show all selections. You can also drag the bottom of the list to control its size.

Previously, input boxes showed only three lines. When there were many selections, you had to scroll to locate a specific selection.

Now, if you create a fillet feature and need to select many edges, as you make selections, the list expands.

Drag the handle or the bottom edge of the list to lengthen or shorten it.

To return the list to its full size, right-click and click Autosize or double-click the handle or the bottom edge of the list.
If you are adding selections using a PropertyManager that provides two list boxes, you can resize a list without losing focus on the active list. For example, if you are adding selections to one list and it is growing large, you can shrink an inactive list to provide more room and still continue to add selections to the first list without having to refocus on it.

**FeatureManager Design Tree Filter Performance**

When you use the FeatureManager design tree filter, the software waits for you to finish typing before it starts to search. This improves the search behavior for large trees such as assemblies that contain thousands of components.

The improvement applies to the response when you enter characters to increase the specificity of the filter, and if you delete characters to reduce filtering.

When the software begins the search, a progress bar appears, informing you that you can cancel the search by pressing **Esc**.

**Hiding and Showing Primary Planes**

You can toggle the visibility of the primary (Front, Top, Right) planes in the graphics area. Primary planes are displayed when you start the first sketch in a model. After you select the plane for the sketch, the planes are hidden unless you select a plane in the FeatureManager design tree.

**To show all three planes in the graphics area:**

1. Activate **View Planes** by doing one of the following:
   - Click **View > Hide/Show > Planes**.
   - In the Heads-up View toolbar, click **Hide/Show Items > View Planes**.

2. Click **View > Hide/Show > Primary Planes**.
Using the Customize dialog box, you can add **Hide / Show Primary Planes** to the CommandManager, a toolbar, or a keyboard shortcut.

**Keyboard Input in PropertyManagers**

The SOLIDWORKS software now provides better support for keyboard input in PropertyManagers.

You can:
- Access every control in a PropertyManager by pressing **Tab** to move from control to control.
- Use keyboard shortcuts to expand and collapse group boxes, turn checkboxes on and off, and select radio buttons.

For example, you can use the spacebar to toggle check boxes and invoke command buttons.

You can use arrow keys to move between sets of radio buttons and choose a radio button.

**Menu Consolidation**

New submenus are in the **File**, **View**, and **Tools** menus so the menus fit more easily on a monitor display.

The following changes have been made:
- **File** menu
  - When you have a part, assembly, or drawing open, **Open Recent** is available. This submenu lists up to 16 of the most recently used documents.
  - If no document is open, the list of most recently used documents continues to appear at the top level of the **File** menu.
- **View** menu
  - The **Hide/Show** submenu contains tools that toggle the visibility of features such as planes, axes, annotations, sketches, and sketch relations.
  - The **User Interface** submenu contains tools that toggle the visibility of major items in the user interface, such as the FeatureManager design tree, Task Pane, toolbars (including the CommandManager), and the status bar.
- **Tools** menu
  - The structure of the top level **Tools** menu is rearranged. The selection menu items are at the top, followed by sketch-oriented menu items.
  - A subset of tools is on an **Evaluate** submenu. The tools that are included depend on whether the active document is a part, assembly, or drawing.
Moving the Confirmation Corner Options to the Pointer

You can confirm changes you make in sketches and tools more easily by using the D keyboard shortcut to move the OK and Cancel buttons to the pointer location in the graphics area.

When you open a PropertyManager, the OK ✔ and Cancel ✗ options are located in the upper left corner of the PropertyManager and in the Confirmation Corner, while your pointer may be in the middle of the graphics area where you are manipulating the model.

To move the Confirmation Corner options to the pointer:

1. Open a tool.
2. Use a manipulator to modify a feature.
3. Click in the graphics area and then press D.
   
   The buttons from the Confirmation Corner move to the pointer position, making it easier to complete the action.

To move the buttons back to the Confirmation Corner, press D again.

If a PropertyManager or sketch is not open, you can also press D to display selection breadcrumbs at the pointer location. See Selection Breadcrumbs on page 29.
**D** is assigned as the keyboard shortcut to move the Confirmation Corner buttons or selection breadcrumbs to the pointer unless you have assigned **D** as a shortcut for another SOLIDWORKS action.

**To assign a different key to move the controls:**

1. Click **Tools > Customize**.
2. In the Customize dialog box, on the Keyboard tab, in the **Search for** field, type **Move Selection Breadcrumbs, Confirmation Corner**.
3. In the **Shortcut(s)** column for the tool, type an unused key or key combination.
4. Click **OK**.

**Persistent Context Toolbar When Sketching**

When you add relations to selected entities in a sketch, you can make multiple selections from the sketch context toolbar without having to redisplay the toolbar.

If you right-click with one or more sketch entities selected, the toolbar that displays stays visible to allow you to add multiple relations. For example, if you have two lines selected, you can you can add vertical and parallel relations to the lines and make them equal without having to make changes in the PropertyManager or redisplay the toolbar.

If you move the pointer away from the context toolbar, it fades out.

If you apply a toolbar option other than a relation - for example, **Construction Geometry** or **Smart Dimension** - the context toolbar closes.

**Selection Breadcrumbs**

Selection breadcrumbs are a context-based view of the current selection. They show related elements up and down the hierarchical tree, from the selected entity through the top level assembly or part.

Breadcrumbs let you select something in the graphics area and refine that selection through the context-based representation of the item. For example, in an assembly, when you select a face, you can see all of the mates of the component that face belongs to. Prior to SOLIDWORKS 2016, to view the mates you either had to right-click the component or find the component in the FeatureManager design tree and open the mates folder.

Breadcrumbs provide access to the entire hierarchical chain of entities from the item you selected up through the top level document. In addition, breadcrumbs provide access to common selections that are adjacent to the entities in the breadcrumb, such as the underlying sketch of a feature, or the mates of a component.
These capabilities let you hide the FeatureManager design tree yet still make selections for which you would typically use the FeatureManager design tree.

Breadcrumbs are available for parts and assemblies. Breadcrumbs are enabled by default and appear in the upper left corner of the graphics area when you select:

- An entity in the graphics area
- A node in the FeatureManager design tree

Breadcrumbs do not appear when a PropertyManager is displayed, when you select an annotation or dimension in the graphics area, or if you multi-select entities.

Breadcrumbs provide the same access to tools that you have from the FeatureManager design tree.
<table>
<thead>
<tr>
<th><strong>To remove the breadcrumbs:</strong></th>
<th>Click an open area of the graphics area or press Esc.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>To turn off breadcrumbs:</strong></td>
<td>Click Tools &gt; Options &gt; System Options &gt; Display/Selection and clear Show breadcrumbs on selection.</td>
</tr>
<tr>
<td><strong>To display a toolbar that contains tools that relate to a selection:</strong></td>
<td>Click an item in the breadcrumbs.</td>
</tr>
<tr>
<td><strong>To display the context toolbar and a shortcut menu:</strong></td>
<td>Right-click the item.</td>
</tr>
<tr>
<td><strong>To display a context toolbar and shortcut menu for a component’s mate in an assembly:</strong></td>
<td>Right-click the mate breadcrumb. Access to mate details makes it easier to interrogate and understand the mates related to specific elements of a design. When you select a mate, its name appears in a tooltip and the mate is highlighted in the graphics area. This provides the same information that is available when you right-click a component in the FeatureManager design tree and click View Mates to open the View Mates window.</td>
</tr>
</tbody>
</table>

Hover over a breadcrumb.
To see a tooltip and highlight the corresponding feature in the graphics area:

Moving Selection Breadcrumbs to Pointer

To move breadcrumbs to the pointer location, press D.

When you edit a sketch or are in a PropertyManager, after changing a value, click in the graphics area and then press D to move the Confirmation Corner options to the pointer.

D is assigned as the keyboard shortcut to move the Confirmation Corner buttons or selection breadcrumbs to the pointer unless you have assigned D as a shortcut for another SOLIDWORKS action.

To assign a different key to move the controls:

1. Click Tools > Customize.
2. In the Customize dialog box, on the Keyboard tab, in the Search for field, type Move Selection Breadcrumbs, Confirmation Corner.
3. In the Shortcut(s) column for the tool, type an unused key or key combination.
4. Click OK.

Toolbar and CommandManager Docking Behavior

The docking behavior of toolbars and the CommandManager has changed to eliminate inadvertent docking and undocking.

The move zone for toolbars and the CommandManager is now more specific so you are less likely to undock accidentally.

The move zone is the area of the toolbar or CommandManager where the move pointer becomes active.

Prior to SOLIDWORKS 2016, if you clicked anywhere on the toolbar that did not have a button, the move pointer allowed you to undock the toolbar.

With SOLIDWORKS 2016, the move zone is limited to the handle. If you click anywhere else on the toolbar, a message tells you to drag the toolbar by the handle to undock it.
Freezing the Current Layout of Docked Toolbars

An option in the Customize dialog box lets you freeze the current status (docked or undocked) of toolbars and the CommandManager so you do not accidentally move them.

To freeze the current layout of docked toolbars:

1. Click Tools > Customize or right-click in the window border and click Customize.
2. On the Toolbars tab, select Lock CommandManager and toolbars.
   - If the CommandManager and toolbars are docked when you select the option, you cannot undock them.
   - If they are undocked when you select the option, you cannot dock them.
3. Click OK.

Undo Location on Mate Context Toolbar

When you edit mates, the Undo button is always added to the right of the mate context toolbar. This keeps the OK button in the same relative position on the toolbar and makes it less likely that you will accidentally undo a change you meant to save.

Visualization Tool for References

In the FeatureManager design tree, when you hover over a feature, the software displays graphical arrows that communicate the complex relationships between items.

This is called dynamic reference visualization.

Blue arrows show parent relationships. Purple arrows show child relationships. If a reference cannot be shown because a feature is not expanded, the arrow points to the feature that contains the reference and the actual reference appears in a text box to the right of the arrow.
Parent and child relationship arrows are disabled by default. You can toggle one or both sets of arrows on or off.

The setting you choose becomes the default setting for all documents.

**To turn on dynamic reference visualization in parts:**
1. Right-click the first item in the FeatureManager design tree.
2. On the context toolbar, click the following:
   - Click **Dynamic Reference Visualization (Parent)** to turn on parent reference arrows.
   - Click **Dynamic Reference Visualization (Child)** to turn on child reference arrows.

**To turn on dynamic reference visualization in assemblies:**
1. Right-click the top assembly feature, a component, or a subassembly.
2. Click **Dynamic Reference Visualization (Parent)** or **Dynamic Reference Visualization (Child)**.
   
   If you turn dynamic reference visualization on or off at any level, the change affects the entire assembly.

You can customize other toolbars by adding the **Dynamic Reference Visualization (Parent)** and **Dynamic Reference Visualization (Child)** buttons. For example, you can add them to the Heads-up View toolbar so they are always visible and you do not have to right-click to access them. You can also create keyboard shortcuts to make it easier to turn the tools on and off.
This chapter includes the following topics:

- 3D ContentCentral
- 3D Printing Enhancements - Preview
- 3D Printing Enhancements - Settings
- Active Content Warnings
- Application Programming Interface
- Improved SOLIDWORKS Error Report Dialog Box
- Property Tab Builder Conditional Lists
- Quick Tip Removal
- Replacing Equation References for Deleted Features
- Saved Dialog Box Modifications
- Searching MySolidWorks
- Task Scheduler Print Enhancements

3D ContentCentral

3D ContentCentral is updated for the user and supplier communities. 3D ContentCentral contains millions of 2D and 3D models from users and suppliers that can accelerate the design process and save you time and development costs.

User improvements include:

- Updated Web site that makes it easier to browse and find content
- New eDrawings Viewer that uses WebGL technology in Google Chrome™, Internet Explorer® 11, and Mozilla Firefox®, and has improved capabilities for rotation, section views, shading, and component explosion
- New search technology that enhances the user experience
Paid supplier improvements include:

- Expanded storage limits
- Marketing tools such as usage reports to research and gather usage statistics for your models
- 3D preview and download of models on your company’s Web site
- Verified supplier status highlights your supplier catalog in the community providing improved visibility over free suppliers and individual contributors

3D Printing Enhancements - Preview

Use the Preview tab to run preview analyses to evaluate the current print job.

You can identify faces that require support and show striation lines to see where details may be lost while printing.

You must change your printer settings to address any issues you uncover by previewing the model.

Displaying Striation Lines

To determine whether the print resolution is sufficiently fine to produce the desired output, you can display striation lines on the model.

Striation lines appear only when the Print3D PropertyManager is open.

If you have RealView on, you can view striation lines as a bump map.

To display striation lines:

1. Click File > Print3D.
2. On the PropertyManager Settings tab, select a model face to align to the print bed.
3. On the Preview tab, under Build Analysis, click Show striation lines.
   Striation lines appear on the model as a texture.
The default layer height is 0.3mm, which corresponds to a coarse printer resolution with a relatively fast printer speed.

4. Optionally, change the layer height in the Set striation size field.
5. To display the striation lines as a bump map:
   a) Clear Show faces that require supports.
   b) Select Show as bump map.

Bump maps can reveal where detail will be lost in the printed model.

6. Click ✓.
Identifying Faces that Require Supports

The Preview tab of the Print3D PropertyManager lets you run a preview analysis to identify faces that require supports during 3D printing.

Printers have different rules for face angles that require supports. Often, if the angle of a face extends more than 45° relative to the print bed, the face must be supported using support geometry during 3D printing.

To identify faces that require supports:

1. Click File > Print3D.
2. On the PropertyManager Preview tab, under Build Analysis, select Show faces that require supports.
3. Set the angle from vertical to define the support threshold.
   This is the angle above which you should add supports to prevent the model from collapsing while it is printing.
4. To define the color of the faces that need or do not need support:
   a) For Support face color, click Edit Color.
      Select the color to use and click OK.
   b) For Supports not required, click Edit Color.
      Select the color to use and click OK.

The colors you select are reflected in the model.
5. Click **Show as transparent** to make the geometry that does not need support transparent so that you can more easily see the areas that need support.

6. Click ✔.

**3D Printing Enhancements - Settings**

The Print3D PropertyManager Settings tab includes the ability to change the model scale and to reorient the model to fit the print volume.

**Changing the Model Scale**

You can specify a scale factor to control the printed size of a model.

To change the model scale:

1. Click **File > Print3D**.
2. In the Print3D PropertyManager, on the Settings tab, select a model face to act as the bottom plane of the model.
   Under **Scale**, the default scale is set to 1, which is the size of the model in the software.
3. Hover over the scale factor input box.
   The software calculates the maximum recommended scale factor and informs you of this limit.

   *If you change the orientation of the face that is aligned with the print bed, the maximum recommended scale factor is recalculated.*

4. Set the scale by doing one of the following:
   a) Type a value for the scale factor.
      The new value is saved as a document property. When you print the model again, the saved value is used unless you change it.
   b) Click **Scale to Fit** to apply the maximum scale factor.
   c) Click **Orient to Fit** and **Scale to Fit**.
      The software orients the model and scales it so that you get the largest possible printed model.
5. Click ✓.

**Reorienting the Model to Fit the Print Volume**

If you select **Orient to Fit** when you specify a model's print bed location, the software automatically reorients the model so that the highest volume of the printed model fits within the print volume.

**To reorient the model to fit the print volume:**

1. Click **File > Print3D**.
2. In the Print3D PropertyManager, on the Settings tab, expand **Print Bed Location**.
3. Select the face to act as the bottom plane of the model.

4. Click **Orient to Fit**.

The software translates the model parallel to the print bed or rotates the model about its axis normal to the print bed to fit the entire model, at its current scale, within the print volume.

If **Orient to Fit** does not fit the entire model within the print volume, the model geometry outside the print volume is highlighted in red. In this case, you can specify a scale parameter or select both **Scale to Fit** and **Orient to Fit**, so the software can fit the model into the print volume.

5. Click ✓.
Active Content Warnings

When you open a part, the SOLIDWORKS software can detect embedded VBA code such as equations and macros and display a warning so that you can decide whether to execute the embedded code.

In previous versions of SOLIDWORKS, equations that contained a predefined set of mathematical functions and operators could be evaluated using a built-in VC++ function. These equations are assumed to be safe and to not require authorization.

Other code, such as embedded VBA code (also known as active content), could potentially be less secure. SOLIDWORKS lets you choose whether to:

- Display a warning so that you can authorize the execution of the code.
- Run the code automatically when you open or rebuild a model that contains it.

A **Warn about active content** setting on the Messages/Errors/Warnings page of the System Options dialog box is selected by default. If the software finds an active content equation or macro when you open or rebuild a model:

- The What's Wrong dialog box appears, identifying the feature containing the equation or macro.

  An **Enable Active Content** button lets you enable the equation or macro that triggered the message.

- A warning icon appears on the document name at the top of the FeatureManager design tree and on the parent feature whose child issued the warning.

  Selecting active content removes these icons.

If you clear the **Warn about active content** setting, the software treats all active content as safe and runs it without displaying a warning message.

Application Programming Interface

See **SOLIDWORKS 2016 API Help Release Notes** for late-breaking updates.

SOLIDWORKS 2016 includes the ability to:

- For SOLIDWORKS MBD:
  - Publish to 3D PDF.
  - Create a general table annotation for 3D PDF.
  - Support for exporting decals and textures to 3D PDF.
  - Get corresponding sketch contours, sketch segments, and annotations for a specific instance of a component in the context of an assembly.
  - Get or set the properties of paragraphs in note annotations.
  - Get or set cross break feature data in sheet metal parts.
  - Get or set indent feature data.
  - Get or set boundary feature data.
  - Get or set chain pattern feature data.
  - Insert a structural weldment feature using a configuration in a custom weldment profile.
  - Get or set the name of the configuration in a custom weldment profile for a structural member.
  - Get or set hole callout variables.
• Get or set gaps between center marks and extension lines, add center marks to a
  center mark set, get whether center marks are detached, get whether entities have
detached center marks in a center mark set, reattach center marks to a center mark
set, and get the coordinates of center marks.
• Get or set options for ray-trace rendering engines, including the option to include
annotations and dimensions visible in the model in the final render.
• Make the child components of a component virtual when the component is made virtual.
• Get the name of the drawing zone for the specified x and y coordinates on the drawing
sheet.
• Reload the sheet format from the original sheet format template.
• Support for these leader styles: **Attach Leader Bottom**, **Attach Leader Center**,  
  **Attach Leader Nearest**, and **Attach Leader Top**.
• Set geometric tolerance values and datum references in gtol symbol frames.
• Get or set whether to display hole sizes in hole tables using ANSI inch letters and drill
numbers.
• Get or set the message to display in the What's Wrong dialog box when a non-embedded
macro feature fails to rebuild due to missing files.
• Get the actual mass properties of selected components in a model.
• Get or set the **Same as sheet specified in Document Properties** check box in the
Sheet Properties dialog box.
• Specify whether to convert the inner loops of the selected faces to sketch entities on
a sketch plane.
• Get the name of a sketch segment.
• Get or set curvature continuous for a variable radius fillet feature.
• Fire an event when an assembly component is about to be renamed.

Improved SOLIDWORKS Error Report Dialog Box

If the SOLIDWORKS software crashes, an improved SOLIDWORKS Error Report dialog
box gives you more options for notifying Dassault Systèmes SolidWorks Corporation of
the problem and recovering your work when you restart.

From the dialog box, you can:
• Preview the error report.
• Choose whether to send a crash report to DS SolidWorks.

  When a crash occurs, a report is sent to DS SolidWorks by default. By clearing **Send
a crash report to SOLIDWORKS**, you can turn off this behavior.

  If you send a crash report, you can add details of your actions before and when the
.crash occurred.
• Indicate whether you have experienced a previous crash in the same context.
• Run the SOLIDWORKS RX diagnostic tool.
• Connect to SOLIDWORKS 3D CAD Support.
• Restart SOLIDWORKS.

  If recovery data is available, SOLIDWORKS attempts to recover your work.
• View the SOLIDWORKS Privacy Policy.

To close the dialog box, click **Done**.
Property Tab Builder Conditional Lists

Property Tab Builder supports the use of conditional lists. This feature lets you define and administer lists once, and eliminate errors by automating the population of dependent properties.

For example, you can create a parent list of different materials and a second set of lists of finishes, where the availability of a finish is dependent on the selection of a material. Users select a material, then select a finish from the options that are available for their material.

You can implement conditional lists by:

• Specifying a set of radio buttons, a check box, or another list as a parent to a list control.
• Creating a group list, where the first list is automatically created as the parent.

Creating a List Group Control

You can use the Property Tab Builder to create List Group controls for conditional lists.

Before creating a list group control, create a Microsoft Excel spreadsheet that defines the properties that are available from a template that contains the list group.

Arrange the choices in columns.

For example, you could define two levels:

• Materials
• Finishes

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Materials</td>
<td>Finishes</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Steel</td>
<td>Sand-blasted</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Steel</td>
<td>Polished</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Steel</td>
<td>Satinated</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Plastic</td>
<td>Rough</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Plastic</td>
<td>Semi-smooth</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Plastic</td>
<td>Smooth</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
To create a list group control:

1. From the Windows Start menu, click All Programs > SOLIDWORKS version > SOLIDWORKS Tools > Property Tab Builder.

2. To define the type of template you are creating, in the right column under Control Attributes:
   a) Optionally, type a message for template users.
   b) Select the template type (Part, Assembly, Drawing, or Weldment).

3. To add a list group, drag the List Group control from the left column to the Custom Properties column.
   The control contains three lists. The first is the parent to the second list.
   When a user selects an item from the parent, it determines the selections that are available in the successive lists.

   The second control is the parent to the third list, and so on.

4. Add or delete lists depending on the number of dependencies you need.

5. To specify the spreadsheet to use with the list group controls:
   a) Click the list group header. Under Control Attributes, type a Caption for the list group.
   b) Under Custom Property Attributes, select whether the list group is Expanded or Collapsed when users view the template.
   c) For Path, specify the path to the spreadsheet or use the browse button to search for the file.
   d) For Range, specify the sheet and cells that define the lists in the list group.
      For example, to use the values in cells A1 through A8 and B1 through B8 on Sheet1, type Sheet1(A1:B8).

6. To specify the values available for the parent list group:
   a) Under Custom Properties, click the first List.
   b) Under Control Attributes, type a Caption.
   c) Under Custom Property Attributes, for Name select the name of the custom property that template users will specify.
   d) For Column, select the column of the spreadsheet whose values should be used.
   e) For Configurations, select Show on Custom Tab or Show on Configurations Tab.

7. Repeat step 6 for each additional list you want to configure.

8. To save the template:
   a) Click Save.
   b) In the Save SolidWorks Properties template dialog box, for File name, type a name.
   c) For Save in, navigate to the location defined for Custom Property Files on the File Locations page of the System Options dialog box.
   d) Click Save.

9. Close the Property Tab Builder dialog box.
Specifying a Parent for a Conditional List

You can specify one or more parents for a list control. The parent can be a set of radio buttons, a check box, or another list control.

This procedure describes how to conditionalize a list control by assigning materials to a set of three radio buttons and then, in the list control, specifying the finishes that are available for each material.

To specify a parent for a conditional list:

1. From the Windows Start menu, click All Programs > SOLIDWORKS version > SOLIDWORKS Tools > Property Tab Builder.
2. From the left column, drag a Radio button control into the GroupBox control in the Custom Properties column.
3. For the radio button control:
   a) In the right pane, under Control Attributes, type the Caption Materials.
   b) Under Custom Property Attributes, select a Name for the custom property the user is creating in the SOLIDWORKS software.
   c) For Quantity, specify the number of radio buttons for the control.
      You must have at least two radio buttons.
   d) Under Label, enter text for the label on each button.
   e) Select whether the property will be written to the Custom tab or the Configurations tab of the Summary Information dialog box.
4. Drag a List box control below the Radio button control.
5. For the list box control:
   a) Type the Caption Finishes.
   b) For Parent, click and select the radio button control.
   c) Under Custom Property Attributes, select the property Name.
   d) For Type, select List.
      The labels you assigned to the radio buttons are listed beside Values.
   e) Under the value that is derived from the first radio button, type a finish associated with the material.
   f) Press Enter to create another row and type another finish.
   g) Repeat step 5f to specify all available finishes for the material.
   h) Repeat steps 5e through 5g for each of the radio button values.
6. To save the template:
   a) Click Save.
   b) In the Save SolidWorks Properties template dialog box, for File name, type a name.
   c) For Save in, navigate to the location defined for Custom Property Files on the File Locations page of the System Options dialog box.
   d) Click Save.
7. Close the Property Tab Builder dialog box.
Quick Tip Removal

Quick Tip help functionality has been removed from the SOLIDWORKS software.

To learn the software, you can use the following learning resources:

- Over 100 hours of online training lessons in MySolidWorks, at http://my.solidworks.com/mylearning.

Replacing Equation References for Deleted Features

If you delete a feature that is referenced by equations, you might have errors in your equations. These errors occur when the equations for a deleted feature contain driving dimensions. You can repair the equations by replacing the dangling portion of the equations with other dimensions or variables in the Equations dialog box.

To use the Replace Reference tool:

1. Do one of the following:
   - Click Equations (Tools toolbar).
   - Click Tools > Equations.
   - In the FeatureManager design tree, right-click Equations and click Manage Equations.

2. Select the Equation View.

3. Under the Value/Equation, in the dangling portion of the equation column, right-click Replace Reference.

   The dangling portion displays in red.

4. In the Replace Dimension/Variable dialog box, type a global variable or dimension string to repair the dangling portion of the equation, or select it from the graphics area.

5. Select one of the following to apply the replacement text and click OK:
   - This Instance
   - All instances in this configuration
   - All instances in all configurations

Saved Dialog Box Modifications

If you modify the Summary Information or Cut-List Properties dialog boxes by resizing them or changing column widths, the software saves your changes with the active document.

You can resize these dialog boxes and column widths to make information visible that would otherwise be truncated. As you continue to work with a document, having these changes saved means you do not need to repeat the modifications if you reopen the dialog boxes.
Changes you make are specific to the active document and do not affect other documents. You can resize the width of both dialog boxes. In addition, you can resize the following column widths:

<table>
<thead>
<tr>
<th>Summary Information dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active document</td>
</tr>
<tr>
<td>Assembly</td>
</tr>
<tr>
<td>Part</td>
</tr>
<tr>
<td>Drawing</td>
</tr>
<tr>
<td>Tabs you can resize</td>
</tr>
<tr>
<td>Custom</td>
</tr>
<tr>
<td>Configuration Specific</td>
</tr>
<tr>
<td>Column widths changes you make to the Custom tab are reflected on the Configuration Specific tab and vice versa.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cut-List Properties dialog box</th>
</tr>
</thead>
<tbody>
<tr>
<td>Active document</td>
</tr>
<tr>
<td>Weldment</td>
</tr>
<tr>
<td>Tabs you can resize</td>
</tr>
<tr>
<td>Cut List Summary</td>
</tr>
<tr>
<td>Properties Summary</td>
</tr>
<tr>
<td>Cut List Table</td>
</tr>
<tr>
<td>Column widths changes you make to the Cut List Summary tab are reflected on the Properties Summary tab and vice versa.</td>
</tr>
</tbody>
</table>

The software saves only the last changes you make in the dialog box. For example, if you change column widths on the Cut List Summary tab and then change them on the Properties Summary tab, the modified column widths from the Properties Summary tab are saved.

The modifications are saved if you close the dialog box by clicking **OK**. They are not saved if you close the dialog box by clicking **Cancel**.

**Searching MySolidWorks**

An enhanced search capability provides filtered access to content within the MySolidWorks Web site and lets you search within multiple categories at once.

When you open the SOLIDWORKS software and expand the search menu in the upper right corner, you see options for:
<table>
<thead>
<tr>
<th><strong>SOLIDWORKS Help</strong></th>
<th>Searches the SOLIDWORKS Web Help window. The option to search SOLIDWORKS help is only available if you select <strong>Use SOLIDWORKS Web help</strong>.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Commands</strong></td>
<td>Searches valid SOLIDWORKS commands for the current document.</td>
</tr>
<tr>
<td><strong>Files and Models</strong></td>
<td>Searches your computer for files and models.</td>
</tr>
<tr>
<td><strong>MySolidWorks</strong></td>
<td>Searches the MySolidWorks Web site.</td>
</tr>
</tbody>
</table>

To see the search filters that are available for the MySolidWorks site, expand **MySolidWorks**.

<table>
<thead>
<tr>
<th><strong>Knowledge Base</strong></th>
<th>Searches the SOLIDWORKS Knowledge Base, which includes:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• Solutions</td>
</tr>
<tr>
<td></td>
<td>• Software Performance Requests (SPRs)</td>
</tr>
<tr>
<td></td>
<td>• SOLIDWORKS Web sites</td>
</tr>
<tr>
<td>Access to the Knowledge Base requires SOLIDWORKS Subscription Service and a Customer Portal login.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Community Forum</strong></th>
<th>Searches the SOLIDWORKS Community Forum.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Blogs</strong></td>
<td>Searches SOLIDWORKS blog posts.</td>
</tr>
<tr>
<td><strong>CAD Models</strong></td>
<td>Searches models in 3D ContentCentral.</td>
</tr>
<tr>
<td><strong>Training</strong></td>
<td>Searches MySolidWorks online training sessions.</td>
</tr>
<tr>
<td><strong>YouTube</strong></td>
<td>Searches SOLIDWORKS YouTube videos.</td>
</tr>
<tr>
<td><strong>Twitter</strong></td>
<td>Searches the SOLIDWORKS Twitter feed.</td>
</tr>
<tr>
<td><strong>Manufacturers</strong></td>
<td>Searches SOLIDWORKS manufacturers.</td>
</tr>
</tbody>
</table>

With the exception of **Manufacturers**, all options are selected by default. By selecting fewer filters, you can narrow your search before navigating to the MySolidWorks Web site.

You can specify the search types for places to search every time you initiate a MySolidWorks search. You can also search just one location without changing your regular search.
To search selected types within the MySolidWorks Web site:

1. In the expanded list, select only the types to search. Clear all other types.
2. Type a search term.
3. Click ⭕ or press Enter.

   The MySolidWorks Web site opens in a browser with the search types you selected listed.

To search a single MySolidWorks search type:

1. In the expanded list, select the label (not the check box) of the search type to use.
2. Type a search term.
3. Click ⭕ or press Enter.

   The MySolidWorks Web site opens to the selected search type.

Task Scheduler Print Enhancements

When you schedule batch printing of files with Task Scheduler, you can choose from many of the same settings that are available when you print directly from the SOLIDWORKS software. You can also choose to use a document’s saved printer settings for each print task.

- **Page Setup dialog box:**
  
  Provides all settings with the exception of the Preview button and preview functionality.

- **Print dialog box:**
  
  Provides all settings with the exception of:
  
  - Preview button
  - Current sheet and Current screen image
  - Print to file
  - Line thickness
  - Margins
  - Collate (available through Page Setup)

When you select printer-specific settings in the Print dialog box, the same settings are used for all files in the print job.

Instead of specifying settings for all documents in the task, you can use the print settings that are saved in the documents. To use saved settings, select **Use document printer settings**. Documents that do not have saved settings use the settings that you specify in the Task Scheduler Print dialog box.

To save printer settings with a document:

1. In SOLIDWORKS, create the document.
2. Click File > Print.
3. Select settings in the Print dialog box and click OK.
4. After printing, save the document.
This chapter includes the following topics:

- Deleting Accounts from the CAD Admin Dashboard View
- Deploying Installs by IP Addresses
- Installing SOLIDWORKS PDM
- Managing Access to SOLIDWORKS Versions
- Products Included with SOLIDWORKS
- SOLIDWORKS Rx
- Troubleshooting Resources for Installation
- Upgrade Assistant

Deleting Accounts from the CAD Admin Dashboard View

You can delete accounts from the CAD Admin Dashboard View.

You may decide that you do not need an account to be listed anymore because the computer has been retired, or because the account is shown multiple times and some of the duplicates have not been updated for a long time.

When you delete an account from the view, it cannot be restored. A useful strategy is to sort the account view by the Date Updated date. Accounts which have not updated recently may be good candidates to delete.

To delete accounts in the CAD Admin Dashboard View:

1. In the main dashboard, select the accounts to delete in the Account Selection column located to the left of the Status column.
2. In the toolbar located below the main dashboard, click Delete Accounts.
3. Click Yes to confirm the deletion or No to cancel.

Deploying Installs by IP Addresses

The Administrative Image Option Editor allows administrators to deploy installation options to machines based on IP addresses or IP address ranges. This feature eliminates the need to list the names of all of the machines targeted for installation.

Installing SOLIDWORKS PDM

SOLIDWORKS PDM is available from the SOLIDWORKS Installation Manager.

SOLIDWORKS PDM is a document management product based on the same client/server architecture as SOLIDWORKS Enterprise PDM.
SOLIDWORKS PDM is available in two types:

- Standard
- Professional

SOLIDWORKS PDM uses a Microsoft SQL Server database to manage file vaults. If you install PDM Standard, SOLIDWORKS installation provides a free version of Microsoft SQL Server Express. If you install PDM Professional, you must obtain a full version of SQL Server.

You can also use the Administrative Image Option Editor to create and deploy images of PDM clients.

Managing Access to SOLIDWORKS Versions

You can restrict users from using specific versions of SOLIDWORKS in a SolidNetWork environment. This capability allows you to manage the versions of SOLIDWORKS used by different individuals, projects, and business units.

**To manage access to SOLIDWORKS versions using a FLEXnet options file:**

1. In the SolidNetwork License Manager installation directory, create a text file:
   \SolidNetwork_License_Manager_install_dir\Licenses\sw_d.opt

2. To manage access to a specific SOLIDWORKS version in the license file, add the following syntax next to SOLIDWORKS:

   ```
   :SWVERSION=xx
   where xx is the version of the SOLIDWORKS product you want to manage
   ```

3. To manage multiple versions of SOLIDWORKS, add a line for each version you want to manage.

Not all FLEXnet options are supported. The supported options for version filters are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>INCLUDE</strong></td>
<td>Only allow the user or group the ability to start the specific version. All other users will not be allowed to start that version.</td>
</tr>
<tr>
<td><strong>INCLUDE_BORROW</strong></td>
<td>Only allow the user or group the ability to borrow the specific version. All other users will not be allowed to borrow that version.</td>
</tr>
<tr>
<td><strong>EXCLUDE</strong></td>
<td>Prohibit the listed user or group from starting the specific version of SOLIDWORKS. EXCLUDE supersedes INCLUDE.</td>
</tr>
<tr>
<td><strong>EXCLUDE_BORROW</strong></td>
<td>Prohibit the listed user or group from borrowing the specific version of SOLIDWORKS. EXCLUDE supersedes INCLUDE.</td>
</tr>
</tbody>
</table>
For more information about FLEXnet, see the FLEXnet Publisher License Administration Guide in the SolidNetwork License Manager installation directory (\Docs\flexuser\licensingenduserguide.pdf).

Products Included with SOLIDWORKS

The following products are now available in SOLIDWORKS Standard:

- SOLIDWORKS Utilities
- FeatureWorks

The following products are now available in SOLIDWORKS Professional:

- ScanTo3D
- TolAnalyst

SOLIDWORKS PDM Standard is also included, but it is not licensed by SOLIDWORKS.
SOLIDWORKS Premium also includes Assembly Costing.

SOLIDWORKS Rx

Graphics Card Validation
When you install or upgrade the SOLIDWORKS software, a Check Your System message prompts you to run SOLIDWORKS RX to validate your graphics card before you use the software.

If you change your graphics card or driver and it does not meet the requirements for running SOLIDWORKS, another message informs you that the card is out of date and provides a link to download the recommended driver.

The Check Your System message appears every tenth time you start SOLIDWORKS. Clicking the message opens SOLIDWORKS RX to the Diagnostics tab. You can also manually run SOLIDWORKS RX by clicking SOLIDWORKS Resource Monitor in the Windows notification area and then clicking the message that appears.

To suppress these notifications, right-click SOLIDWORKS Resource Monitor and click Turn Off Notifications.

The shortcut menu also lets you:
• Display Help for the SOLIDWORKS Resource Monitor
• Run System Diagnostics
• Clear Turn Off Notifications to restore notifications
• Update Graphics Drivers (if your current driver does not support SOLIDWORKS)

Record Extended Logging Data
You can use SOLIDWORKS Rx to capture performance profiling data to help Technical Support diagnose the causes of problems faster.

The Capture Problem dialog box provides a Record Extended Logging Data option. When selected, SOLIDWORKS Rx logs disk and CPU activity, and sends that data with other information to SOLIDWORKS Technical Support.

The default setting of the Capture Problem dialog box is not to capture performance profiling information. This information is only logged if you select Record Extended Logging Data.

Simulation Test
SOLIDWORKS RX Benchmark includes SOLIDWORKS Simulation. SOLIDWORKS Premium or SOLIDWORKS Simulation must be installed and licensed to run this benchmark.

See SOLIDWORKS Help: SOLIDWORKS Rx.
Troubleshooting Resources for Installation

When a product installation is unsuccessful, the SOLIDWORKS Installation Manager provides a link to troubleshooting solutions documented in the Customer Portal, Help, and Knowledge Base.

The Installation Manager also provides links to resume installing other products, and to zip up a directory with log files to share with SOLIDWORKS Technical Support.

Upgrade Assistant

If you are planning to migrate to a new version of SOLIDWORKS, you can use the Upgrade Assistant to test that your parts, assemblies and drawings will migrate correctly. The Upgrade Assistant works with files created by SOLIDWORKS 2013 and later.

You begin by selecting a subset of your parts, assemblies and drawings to perform the comparison test. The Upgrade Assistant opens each file using both your installed production version of SOLIDWORKS and the installed SW version you are planning to migrate to. It runs a series of tests comparing each file, and generates a comparison report including performance changes, rebuild errors, drawing pixel changes (color and position), and stability problems. If no critical errors are found, you can be confident that your data will migrate successfully to the target version. If critical errors are found, send a copy of the comparison report to your reseller for further assistance.

To access the Upgrade Assistant, open SOLIDWORKS Task Scheduler from the Windows Start menu, and click All Programs > SOLIDWORKS <version> > SOLIDWORKS Tools > SOLIDWORKS Task Scheduler. Then on the sidebar, click Upgrade Assistant.
5

Assemblies

This chapter includes the following topics:

- Choosing a Configuration While Adding a Component
- Component Selection Enhancements
- Copying Multiple Components
- Mates
- Mirroring Assembly Features
- Pattern Driven Component Pattern Improvements
- Performance Evaluation (Formerly AssemblyXpert)
- Purging Unused Features
- Remove All Appearances
- Renaming Components in the FeatureManager Design Tree
- Replacing Subassemblies with Multibody Parts
- Subassemblies
- Temporarily Fix Components with a Separate Tool
- Toggling the Visibility of Components
- Treehouse Improvements

Choosing a Configuration While Adding a Component

When you use the Insert Components/Begin Assembly PropertyManager to add a component to an assembly, you can select a configuration from a list.

Component Selection Enhancements

Enhancements to facilitate component selection include the new Select Identical Components tool, improvements to Select Components by Size, and improved performance when using Assembly Visualization to select a large number of components.

Selecting Components by Size

The Select By Size tool is improved. You can dynamically preview the selections. Also, a count of selected components appears in the dialog box.

Click Tools > Component Selection > Select By Size.

The following new options are available in the dialog box:

| Dynamic selection | Highlights selected components as you change Percent of assembly size. |

56
Selecting Identical Components

You can select all components that are identical to the selected component.

1. Click Tools > Component Selection > Select Identical Components.
2. In the PropertyManager, select or clear Match configuration names.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selected</td>
<td>All instances of the component with the same configuration are selected.</td>
</tr>
<tr>
<td>Cleared</td>
<td>All instances of the component, regardless of configuration, are selected.</td>
</tr>
</tbody>
</table>

3. Select a component.

Copying Multiple Components

You can copy several components at a time and retain the mates between them.

In the assembly in this example, the screw and two washers are mated together, but are three separate components (not a subassembly). You want to create another instance of each of them and retain the mates between them.
To copy multiple components:

1. In the FeatureManager design tree, **Ctrl** + select or **Shift** + select the components to copy.

2. **Ctrl** + drag the selected components and drop them in the graphics area. New instances of the components are created. Mates that exist between the selected components are retained between the new instances.

Mates

Cam Mate Selection Enhancement

When you select one face of a cam, all other faces that form the extruded profile of the cam are automatically selected.

Previously, you had to select each face individually, or right-click one face and click **Select Tangency**.

Component Preview Window

To facilitate the selection of items to mate, you can preview a component in its own separate preview viewport.

Use **Component Preview Window** to open a preview viewport for the selected component. In the preview viewport, you can zoom and rotate the view of the component.

Click one of the following:

- **Component Preview Window** (context toolbar).
- **Component Preview Window** (Assembly toolbar).
- **Tools > Component > Preview Window**.

To close the **Component Preview Window**, click **Exit Preview**.
Previewing a Mate Component in a Separate Window

In this example, you add a concentric mate between a rivet and the pivot hole in a scissors blade. You use the Component Preview Window to make it easier to select the small cylindrical face of the hole.

To preview a mate component:

1. Open \install_dir\samples\whatsnew\assemblies\component_preview\scissors.sldasm.

2. Select blade<1>.

3. On the context toolbar, click Component Preview Window. The Component Preview Window opens and displays the selected component.

4. In the Component Preview Window:
   a) Zoom and rotate the view.
   b) Select the cylindrical wall of the hole.
5. In the main window, **Ctrl** + select the barrel of the rivet.

6. Click **Concentric** (Quick Mates context toolbar). The mate is complete.

7. Click **Exit Preview**.

**Copy with Mates Enhancement**

*Copy with Mates* supports *Profile Center* mates.

**Globally Replacing Failed Mate References**

If a mate reference is missing from a component that is used in many places in an assembly, you can replace the missing reference for all instances at the same time.

When you replace the mate reference for one of the many affected mates, a dialog box offers the option to replace it in all other mates with the same missing reference.

**To globally replace failed mate references:**

1. Open `install_dir\samples\whatsnew\assemblies\global_replace\blocks_knobs_903.sldasm`. The assembly contains two instances of `knob_002`.

The same cylindrical surface on each knob is used in a concentric mate to a block.
2. Select a knob and click **Open Part**.

3. At the bottom of the FeatureManager design tree, select the suppressed feature **Resolve2** and click **Unsuppress**.
   A revolved spline feature replaces the cylindrical surface used in the concentric mates in the assembly.

4. Click **Save** (Standard toolbar) or **File > Save**.
5. Change back to the assembly window.
   If prompted to rebuild the assembly, click **Yes**.
   The What's Wrong dialog box informs you that two mates, **Concentric1** and **Concentric2**, are missing a mate entity. The mates are flagged in the FeatureManager design tree.
6. In the dialog box, click **Close**.
7. In the FeatureManager design tree, expand **Mates**.
8. Select **Concentric1** and click **Replace Mate Entities**.
9. In the PropertyManager:
   a) Under **Mate Entities**, select **Face of knob_002-1**.

   b) For **Replacement Mate Entity** 🔄, in the graphics area, select the cylindrical feature of the knob as shown.

   c) In the PropertyManager, click ✔.

10. In the dialog box, click **Yes, replace all other missing mate references**.
    The missing mate reference is replaced in both mates and the error flags disappear from the FeatureManager design tree.

---

**Making Components Transparent for Mating**

You can set an option in the Mate PropertyManager so that the first component you select from becomes transparent. Then selecting from the second component is easier, especially if the second component is behind the first.

The option is supported for all mate types except those that might have more than one selection from the first component (width, symmetry, linear coupler, cam, and hinge).

In this example, you want to mate the hole in the clamp with the cylinder of the pin.
In the assembly window, the pin is behind the clamp.

To make components transparent for mating:

1. Open \install_dir\samples\whatsnew\assemblies\make_transparent\clamp_pin_assembly.sldasm.
2. Click Mate (Assembly toolbar) or Insert > Mate.
3. In the PropertyManager, under Options, select Make first selection transparent.
4. Select the hole in the clamp.

The clamp becomes transparent.

5. Select the cylinder of the pin.

A preview of the concentric mate appears.
6. Accept the concentric mate.

**Mate Controller**

Mate Controller lets you manipulate specific mates that control degrees of freedom for a design. You can save and recall saved positions and mate values. You can create animations based on the saved positions.

In Mate Controller, you can show and save the positions of assembly components at various mate values and degrees of freedom without using configurations for each position. You can create simple animations between those positions and save the animations to .avi files. Mate Controller is integrated with Motion Studies, so you can use Animation to create animations based on the positions you define in Mate Controller.

Supported mate types include:

- Angle
- Distance
- LimitAngle
- LimitDistance
- Slot (Distance Along Slot, Percent Along Slot)
- Width (Dimension, Percent)

Click **Mate Controller** (Assembly toolbar) or Insert > Mate Controller.
Adding Positions in Mate Controller

You can specify sets of mate values to define various component positions.

To add positions in Mate Controller:

1. Open `install_dir\samples\whatsnew\assemblies\mate_controller\mate_controller.sldasm`.
2. Click **Mate Controller** (Assembly toolbar) or **Insert > Mate Controller**.
3. In the PropertyManager, under **Mates**, click **Collect All Supported Mates**.

Three mates appear in the list.

If you want to work with only a few of the supported mates in an assembly, do one of the following:
- Before opening Mate Controller, preselect the mates.
- After opening Mate Controller, select mates from the flyout FeatureManager design tree.

Under **Mates Positions**, the current values for the mates are shown. These values specify **Position 1**.

<table>
<thead>
<tr>
<th>Mate</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distance1</td>
<td>0.00mm</td>
</tr>
<tr>
<td>Angle1</td>
<td>0.00deg</td>
</tr>
<tr>
<td>LimitAngle1</td>
<td>90.00deg</td>
</tr>
</tbody>
</table>

4. Enter the mate values for the next position (**Position 2**):

<table>
<thead>
<tr>
<th>Mate</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distance1</td>
<td>30.00mm</td>
</tr>
</tbody>
</table>
In the graphics area, as you change the mate values, the components move to the new positions.

<table>
<thead>
<tr>
<th>Mate</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Angle1</td>
<td>0.00deg</td>
</tr>
<tr>
<td>LimitAngle1</td>
<td>90.00deg</td>
</tr>
</tbody>
</table>

5. Under **Mate Positions**, click **Add Position**.
6. In the Name Position dialog box, enter **Position 2** and click **OK**.
   **Position 2** is created from the mate values you entered.
7. Enter the mate values for the next position (**Position 3**):

<table>
<thead>
<tr>
<th>Mate</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distance1</td>
<td>150.00mm</td>
</tr>
<tr>
<td>Angle1</td>
<td>90.00deg</td>
</tr>
<tr>
<td>LimitAngle1</td>
<td>10.00deg</td>
</tr>
</tbody>
</table>
8. Click **Add Position**.
9. In the dialog box, enter **Position 3** and click **OK**.

**Position 3** is created.

**Dragging to Positions in Mate Controller**

You can drag components into position in Mate Controller.

By default, the components are locked into the positions defined by the numerical values for the mates in the Mate Controller PropertyManager. You can unlock one or more mates so you can drag components in the graphics area.

**To unlock and drag components:**

1. In the PropertyManager, to the right of the numerical input box for **LimitAngle1**, click **Make This Mate Driven**.
2. In the graphics area, drag a face of the small yellow block back and forth.

   You can drag the components through the full range of values for **LimitAngle1**. As you drag the components:
   - In the PropertyManager, the value for **LimitAngle1** changes.
   - In the graphics area, arrows indicate the degrees of freedom allowed by **LimitAngle1**.
3. Drag the block to the right until it reaches the limit of the mate. In the Property Manager, the value for LimitAngle1 is \textbf{0.00deg}.

Viewing Animations in Mate Controller
You can view an animation of the components in Mate Controller.

\textbf{To view an animation:}

1. In the Property Manager, under \textbf{Animation}, click \textbf{Calculate Animation}. In the graphics area, the components move through the positions you created.

2. Click \checkmark. A \textbf{Mate Controller} feature appears in the Feature Manager design tree.

3. In the Feature Manager design tree, select \textbf{Mate Controller}.

4. In the list above the context toolbar, select \textbf{Position 1} and then click \checkmark. The components return to \textbf{Position 1}.
**Editing a Position in Mate Controller**

You can change a saved mate position.

In this example, suppose you want to increase the vertical distance that the components move between **Position 1** and **Position 2**.

**To edit a position:**

1. In the FeatureManager design tree, select **Mate Controller** and click **Edit Feature**.

2. In the PropertyManager, under **Mates Positions**, select **Position 2** from the list. The components move to **Position 2**.

3. Change the value of **Distance1** to **60**. A preview of the new vertical position of the components appears in the graphics area.

4. Click **Update Position**. The change is applied to **Position 2**.

5. Click ✅. The change is saved.
Creating Animations for Mate Controller

In Motion Studies, you can use Animation to create animations based on the positions you define in Mate Controller. You can create **Key Point** animations and **Motor** animations.

**To create animations from Mate Controller positions:**

1. In the lower left region of the graphics area, select the Motion Study 1 tab.
2. For **Type of Study**, select **Animation**.
3. Click **Animation Wizard** (MotionManager toolbar).
4. In the dialog box:
   a) Select **Mate Controller**.
   b) Click **Next**.
   c) For **Import Type**, select **Key Points**.
   d) Click **Next**.
   e) Leave the default values for **Duration** and **Start Time**, and click **Finish**.
5. Scroll to the bottom of the MotionManager tree and expand **Mates**.
   The timeline is populated with changebars and key points based on the data from Mate Controller.
6. Click **Calculate** (MotionManager toolbar).
   The animation plays in the graphics area. You can use the changebars, key points, and other Animation tools to adjust the animation.
   You can also use Animation to create **Motor** animations.
7. Right-click the Motion Study 1 tab and click **Create New Motion Study**.
8. Repeat steps 3 and 4, except in step 4c, for **Import Type**, select **Motors**.
9. After you click **Finish**, scroll to the top of the MotionManager tree.
   A motor appears in the tree for each of the mates for which you specified values in Mate Controller. The timeline is populated with changebars and key points for each motor.
10. Click **Calculate** (MotionManager toolbar).
    The animation plays in the graphics area. You can use the changebars, key points, and other Animation tools to adjust the animation.

Quick Mates Improvements

The Quick Mates context toolbar now includes more mate types. Also, you can now preselect reference geometry (such as planes, axes, and points) in the FeatureManager design tree.

For model geometry (such as faces, edges, and vertices), you still need to preselect in the graphics area.

The following mate types are now available on the Quick Mates context toolbar:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Mate Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>🌋</td>
<td>Cam</td>
</tr>
</tbody>
</table>
To activate the Quick Mates functionality, click **Tools > Customize**. On the Toolbars tab, under **Context toolbar settings**, select **Show quick mates**.

## Mirroring Assembly Features

You can mirror assembly features.

### To mirror assembly features:

1. Open `install_dir\samples\whatsnew\assemblies\mirror\assembly_feature.sldasm`.

2. Click **Assembly Features** (Assembly tab on the CommandManager) and click **Mirror**，or click **Insert > Assembly Feature > Mirror**.
3. In the PropertyManager:
   a) For **Mirror Face/Plane**, select the **Front Plane** of the assembly.
   
   You can make selections in the flyout FeatureManager design tree.

   ![Diagram](image1)

   b) For **Features to Mirror**, select **Hole1**.

   ![Diagram](image2)

4. Click ✓.
Pattern Driven Component Pattern Improvements

When you create a pattern-driven component pattern, the instances skipped in the parent pattern are now listed in the Pattern Driven PropertyManager.

Performance Evaluation (Formerly AssemblyXpert)

AssemblyXpert is renamed to Performance Evaluation. The user interface is consistent with the new Performance Evaluation tool for drawings.

Click **Performance Evaluation** (Assembly toolbar) or **Tools > Evaluate > Performance Evaluation**.

Purging Unused Features

In parts and assemblies, you can selectively delete features and components that are suppressed in all configurations of the model. You can also selectively delete unused reference geometry and sketches that have no child references in the model.

**To purge unused features:**

1. In a part or assembly, at the top of the FeatureManager design tree or the ConfigurationManager, right-click the file name and click **Purge Unused Features**.
2. In the dialog box:
   a) In **Suppressed in all configurations**, select items to delete.
   b) In **Unused sketches and reference geometry**, select items to delete.

Reference geometry and sketches listed as unused in this model might be used by other models. Do not delete the listed items unless you are sure they are not required by another model.

3. Click **OK**.
   The Confirm Delete dialog box appears.
4. Click **Yes**.
   The selected items are deleted from the model.

You can click **Undo** (Standard toolbar) to reverse the deletions.
Remove All Appearances

You can remove all appearances from all models inside an assembly or subassembly.

To remove all appearances:
1. In the FeatureManager design tree, right-click the assembly containing appearances to remove and click **Appearances**.
2. Click **Remove all appearances from components in assembly-name**.

Renaming Components in the FeatureManager Design Tree

You can change component file names directly from the FeatureManager design tree. You can update references to the renamed files in unopened documents at the same time.

Before you begin:
To enable renaming, click **Tools > Options > System Options > FeatureManager > Allow component files to be renamed from FeatureManager tree**.

To change a component file name:
1. In an assembly, in the FeatureManager design tree, do one of the following for the component whose file name you want to change:
   - Click-pause-click the component.
   - Right-click the component and select **Rename Assembly** or **Rename Part**.
   - Select the component and press **F2**.
2. Type a new name and press **Enter**.
3. In the dialog box, select **Temporarily rename document** and, if prompted to rebuild, click **Yes**.
   
   The file name of the component changes in the SOLIDWORKS software, but is not yet changed in the Windows file system. Any currently open documents that reference the renamed file are updated in the SOLIDWORKS software to reference the new file name.
4. Save the assembly.
   The Rename Documents dialog box opens. It warns you of the following:
   - Files that have been temporarily renamed in the SOLIDWORKS software will now be renamed permanently in the Windows file system.
   - Other currently open documents that reference the files being renamed will be updated in the Windows file system.
   - References will be broken in currently closed documents that reference the renamed files unless you select **Update where used references** and specify which documents to update.

5. (Optional.) To avoid broken references in documents that are not currently open:
   a) Select **Update where used references**.
      The dialog box expands.
   b) Specify folders in which to search for documents to update.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File locations</strong></td>
<td>Lists the folders to search. Click <strong>Add Folder</strong> to browse for folders to add to the search. To remove a folder from the list, select it and click <strong>Remove</strong>.</td>
</tr>
<tr>
<td><strong>Include file locations - Referenced Document folders</strong></td>
<td>Specifies to search the folders listed under <strong>Referenced Documents</strong> in Tools &gt; Options &gt; File Locations.</td>
</tr>
</tbody>
</table>

   c) Click **Search**.
      Results are listed under **Update where used references**. By default, all items are selected.
   d) Clear items that you do not want to update.

<table>
<thead>
<tr>
<th>State</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✓</td>
<td>Selected</td>
</tr>
<tr>
<td></td>
<td>Items update to reference the new file name.</td>
</tr>
<tr>
<td>□</td>
<td>Cleared</td>
</tr>
<tr>
<td></td>
<td>Items continue to reference the old file name.</td>
</tr>
</tbody>
</table>

6. Click **OK**.
   The component file is permanently renamed.
Replacing Subassemblies with Multibody Parts

When you save an assembly as a multibody part, more internal data is saved. The additional data allows mates from the assembly to be retained in the multibody part. This is useful when you use the multibody part as a simplified representation of the assembly in a higher level layout assembly and then later need to make changes.

When you make changes to the subassembly and again save it as a multibody part, you can replace the old multibody part with the new one, without having to recreate the mates.

Only the active configuration of the assembly is saved in the multibody part. Configuration-specific properties from the active configuration, plus all custom properties, are saved in the multibody part, so you can use them in the BOM and annotations.

Subassemblies

Form/Dissolve Subassembly Improvements

The ability to form and dissolve subassemblies is enhanced to support patterned and mirrored components.

Improved Reordering of Subassemblies

When you reorder components in the FeatureManager design tree, the pointer changes to indicate whether the component will move into or below a subassembly.

Previously, if you reordered a component in the FeatureManager design tree, you had to press Alt to ensure the component did not move into a subassembly. The pointer changes make it easier to ascertain where the component will move when you drag it.

- Moves a component below a subassembly. While dragging a component, hover over or to the left of the subassembly icon.

- Moves a component into a subassembly. While dragging a component, hover over the name of the subassembly.
Mirroring and Patterning Flexible Subassemblies

When you mirror or pattern a flexible subassembly, you can synchronize the movement of the components of the mirrored or patterned instances with the components of the seed flexible subassembly.

Synchronizing Patterned Flexible Subassemblies

When you pattern a flexible subassembly, you can synchronize the movement of the components of the patterned instances with the components of the seed flexible subassembly.

To synchronize a patterned flexible subassembly:

1. In an assembly, click one of the following:
   - Linear Component Pattern (Assembly toolbar)
   - Circular Component Pattern (Assembly toolbar)
   
2. In the Property Manager:
   a) Set options to define the pattern.
   b) For Components to Pattern, select a flexible subassembly.
   c) Select Synchronize flexible subassemblies.
   d) Click .

   When you move components in the seed flexible subassembly, components in the patterned instances also move, and vice versa.

Synchronizing Mirrored Flexible Subassemblies

When you mirror a flexible subassembly, you can synchronize the movement of the components of the mirrored version with the components of the seed subassembly.

To synchronize a mirrored flexible subassembly:

1. In an assembly, click Mirror Components (Assembly toolbar) or Insert > Mirror Components.

2. On the Step 1: Selections page of the Property Manager:
   a) For Mirror plane, select a plane or planar face to mirror about.
   b) For Components to Mirror, select a flexible subassembly.
   c) Click .

3. On the Step 2: Set Orientation page of the Property Manager:
   a) Under Orient Components, select the flexible subassembly.
   b) Click Create opposite hand version .

   The icon appears beside the component to indicate that you are creating an opposite-hand version.
c) Select **Synchronize flexible subassemblies**.

A lock overlay 🗝️ indicates that the opposite-hand version is synchronized with the seed flexible subassembly.

d) Click **Next**.

4. On the **Step 3: Opposite Hand** page of the PropertyManager:
   a) Select a format for saving all listed components.
   b) Specify a naming convention for the new file or configuration.
   c) Click **Next**.

5. On the **Step 4: Import Features** page of the PropertyManager:
   a) Under **Transfer**, select any combination of items from the seed subassembly to include in the opposite-hand version.
   b) Click 🔄.

The PropertyManager closes and an opposite-hand version of the flexible subassembly is created. When you move components in the seed flexible subassembly, components in the opposite-hand version also move, and vice versa.

### Opening Subassemblies

You can open a subassembly from the graphics area by clicking one of its components and selecting the subassembly from the **Open Part** drop-down list on the context toolbar.

**To open a subassembly:**

1. In the graphics area, select a component of the subassembly.

2. On the context toolbar, click the drop-down arrow on **Open Part**.

   The part and the subassembly that contains the part are listed. If the part is in a nested subassembly, the list displays the hierarchy.

3. Move the pointer over the list to highlight the various subassemblies and click the one to open.

   ![Subassembly opening](https://example.com/subassembly_opening)

   The selected subassembly opens in a separate window.

   To open the selected part, rather than a subassembly, click the folder icon:
**Virtual Subassemblies**

When you make a subassembly virtual, you can make all of its child components virtual at the same time. Conversely, when you save a virtual subassembly to an external file, you can save all of its child components to external files at the same time.

When you make a subassembly virtual or save a virtual subassembly to an external file, the option to include its child components is available in the dialog box.

**Temporarily Fix Components with a Separate Tool**

A separate tool is now available to temporarily fix and group components.

Previously, the functionality was available as an option in the Move Components or Rotate Components PropertyManagers.

Click **Temporary Fix/Group** (Assembly toolbar).

You can also right-click anywhere in the graphics area, or right-click a component in the FeatureManager design tree or graphics area and click **Temporary Fix/Group**.

**Toggling the Visibility of Components**

A new keyboard shortcut lets you temporarily view all hidden components and select ones you want to show.

To show one or more components, move the pointer to the graphics area and press and hold **Ctrl + Shift + Tab**. All hidden components are temporarily displayed as transparent. Click a hidden component to change it to shown.
Treehouse Improvements

Treehouse improvements include the display of configuration-specific properties, an option to keep exported files open in the SOLIDWORKS software, and the creation of new files from existing ones.

Displaying and Editing Configuration Specific Properties

You can display and edit configuration-specific properties of existing SOLIDWORKS files that you add to a Treehouse hierarchy.

To edit configuration-specific properties:

1. Double-click the node of an existing SOLIDWORKS file.
2. In the Properties dialog box, on the Configuration Specific tab, select a configuration. Configuration-specific properties for the selected configuration are displayed.
3. Edit the values of the configuration-specific properties.
4. Click OK.
   The property changes are saved in Treehouse.
5. When you have completed your hierarchy, click Export to SOLIDWORKS Documents.
6. In the dialog box, browse to a folder in which to store new files and click OK.
   The existing file remains in its original folder. You are prompted to optionally create a backup copy of the existing file before it is overwritten with your changes.
7. Click one of the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>Creates a backup copy of the original existing file in a folder that you specify.</td>
</tr>
<tr>
<td>No</td>
<td>Does not create a backup copy.</td>
</tr>
</tbody>
</table>

The property changes are saved in the existing SOLIDWORKS file in its original folder.

Treehouse Options

Changes to Treehouse options include one new option and several renamed options.

Opening New Documents After Export

You can set an option that automatically opens new SOLIDWORKS files that are created during export from Treehouse.

To automatically open new files:

1. Click Treehouse Options.
2. Under Export Option, select Open created documents after export.
3. Click **OK**.
4. In Treehouse, create an assembly structure of new and existing files.

5. Click **Export to SOLIDWORKS Documents**.
   The software creates new files and opens them in SOLIDWORKS. Existing files are not opened.

### Renamed Options
Some viewing options have been renamed.

Click **Treehouse Options**.

Under **Viewing Options**, the following options are renamed:

<table>
<thead>
<tr>
<th>New Name</th>
<th>Previous Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group documents under parent reference</td>
<td>Group documents without references</td>
</tr>
<tr>
<td>Display active configuration name</td>
<td>Show active configuration name</td>
</tr>
<tr>
<td>Display Quick Help tooltips</td>
<td>Show Quick Help tooltips</td>
</tr>
</tbody>
</table>

### Creating New Files from Existing Ones
When you export a hierarchy from Treehouse, you can save existing SOLIDWORKS documents as new copies.

When saving an existing document as a new copy, you must work from the top down. For example, if you have an existing assembly document in the hierarchy and you want to save a component of that assembly as a new document, you must first save the assembly as a new document.

**To save an existing document as a new document:**

1. In the hierarchy, right-click an existing document and click **Save as New Document**.
2. In the Save As New Document dialog box, enter a new name and properties for the new document.
3. Click **OK**.
   The node background becomes green to indicate that the node will be saved as a new document when you export the hierarchy to SOLIDWORKS documents.
CircuitWorks

Available in SOLIDWORKS Professional and SOLIDWORKS Premium.

This chapter includes the following topics:

- Building SOLIDWORKS Models from ECAD Files in Batch Mode
- Component Library Improvements
- Creating Copper Traces as Decals
- Filtering Components When Opening ECAD Files
- Locating CircuitWorks Components
- Saving and Loading CircuitWorks Options
- Specifying Component Heights

Building SOLIDWORKS Models from ECAD Files in Batch Mode

You can schedule a task in SOLIDWORKS Task Scheduler to build multiple ECAD files as SOLIDWORKS solid models.

The ability to build solid models from ECAD files in batch mode saves you time by letting you schedule the task to run when the system is not in use.

This option is available only on client machines with CircuitWorks licenses.

To build SOLIDWORKS models from ECAD files in batch mode:

1. In Windows, click Start > SOLIDWORKS version > SOLIDWORKS Tools > SOLIDWORKS Task Scheduler.
2. Click Build ECAD Files on the sidebar or Tasks > Build ECAD Files.
3. In the Build ECAD Files dialog box:
   a) Under Task files or folders, use the Add File and Add Folder buttons to select the files or folders to build.
   b) Under Task schedule, set the Running mode to specify how often the task runs and set the Start time and Start date.
   c) Click Finish.

The task is stored in a macro and runs at the scheduled time. The task stores the completed SOLIDWORKS models in \ProgramData\SOLIDWORKS\CircuitWorks\AssemblyModels. You can modify this location from the Models page of the CircuitWorks Options dialog box.

When the task is complete, a .txt file reports the results of the build task for your review. When you close the report, this file is saved in \ProgramData\SOLIDWORKS\CircuitWorks.
Component Library Improvements

To make it easier to find components, you can add properties to selected components and use those properties to add columns to the CircuitWorks Component Library dialog box. Each added column includes a filter that you can use to limit the components that appear in the dialog box.

**To add a custom property:**

1. In the CircuitWorks Component Library dialog box, in the left pane, select a component.
2. Click **Add Property**.
3. In the New Custom Property dialog box, type a **Property name** and **Property value**.
4. Select optional settings:
   - **Apply to all components**. Applies the property value to all components that are visible in the library.
   - **Add new column in table**. Creates a column in the left pane that is labeled with the property name and property value.

**To add a column:**

1. In the CircuitWorks Component Library dialog box, click **Add Column**.
2. In the Mapping Column to Property dialog box, in **Available properties**, select a property.
   - The list includes custom properties you have added to components and original properties.
   - The new column labeled with the property name appears in the left pane.
3. To hide or rename an added column, right-click the column header and click **Hide Column** or **Change Column Name**.

**To filter on a column property:**

1. In the column heading, click **Apply Filter**.
   - A field with a list control appears above the column. A red x appears next to the control.
2. In the list, select a property.
   - The component list is redisplayed, showing only components that have the selected property.
   - The property you selected remains in a field above the column heading.

Creating Copper Traces as Decals

To increase performance, when you use **Build Model** to create PCB models from PADS or EDMD files, CircuitWorks can represent the copper traces as images instead of physical geometry in the board file.

You can save the images as bitmap files in the CircuitWorks Trace Decals folder or internally to the board file.

Using preview geometry, CircuitWorks quickly creates decal images that represent the traces on the various layers of the PCB.
Decals do not use a vectored display format. Depending on the density of traces, the quality of the decal display may vary from one board to another. The most accurate way to display traces is still to build them as geometry.

**To create copper traces as decals:**

1. Open an ECAD file with tracings.  
   This example uses *Install_dir\CircuitWorksFull\Examples\PAVES\preview.asc*.

2. Click the CircuitWorks application menu and click **Options**.

3. Set the following:
   a) On the SOLIDWORKS Import page, under **Conductive layer modeling**, select one of the following:
      - **Complete**. Creates copper traces on all model layers.
      - **Only top and bottom layers (faster)**. Creates copper traces on the top and bottom layers.
   b) On the Models page, under **Save the models CircuitWorks creates to these folders**, select a **Decals** folder.  
      The default folder location is: 
      C:\ProgramData\SOLIDWORKS\CircuitWorks\Decals\  
   c) Click **OK**.

4. Click **Build Model** (SOLIDWORKS section of the Tools tab).
5. In the CircuitWorks dialog box:
   a) Select **Use trace decals instead of geometry**.
      When selected, copper traces are saved as bitmap files in the **Decals** folder you specified previously.
   b) Optionally, select **Store decal in model file**.
      When selected, copper traces are incorporated directly in the model file. They are not saved as preview bitmaps.
   c) Click **Build**.
      CircuitWorks creates the board in the SOLIDWORKS software.

6. To see previews of the copper traces, on the DisplayManager tab, click **View Decals**, then hover over the preview.

![Decals preview](image)

**Filtering Components When Opening ECAD Files**

You can create filters to suppress components or annotations and have the software apply the filters when you load ECAD boards.

When an ECAD file contains many components, it can take a long time to open in CircuitWorks. If you know there are components you do not need to see, you can create filters to identify the components to suppress. You store these filters in the `CircuitWorks\Filters` folder. When you turn on a setting in the CircuitWorks Options dialog box, the software applies the filters to the ECAD file when it loads.

After the ECAD file opens, the filtered components are not visible in the graphics area, but they appear in the FeatureManager design tree as inaccessible components.
Locating CircuitWorks Components

You can locate CircuitWorks components using the search fields at the top of the CircuitWorks feature tree and in the CircuitWorks Component Library dialog box. You can also search using the Find in Tree and Find in Component Library dialog boxes.

To locate components in the CircuitWorks feature tree:

- Type a portion of a component name in the Search field at the top of the feature tree. CircuitWorks filters the component list to show only items that match the portion of the component name you type.
- In the feature tree, right-click and click Find in Tree, or press Ctrl + F to open the Find in tree dialog box.
  
  As you type in the Find field, a search-ahead capability displays a list of components whose names contain the characters you type.
  
  Click a component to select it in the feature tree and in the graphics area.

To locate components in the CircuitWorks Component Library:

- Type part of a component name in the search field above the preview image. The component list shows only the components that match the text.
- In the component list, right-click and click Find, or press Ctrl + F to open the Find in Component Library dialog box.
  
  As you type in the Find field, a search-ahead capability displays a list of components whose names contain the characters you type.
  
  Click a component to display it in the preview window and list its properties.

Saving and Loading CircuitWorks Options

To transfer your CircuitWorks options to another computer or to share them with another user, you can save them to an .xml file.

You access the settings by loading the saved settings file.

Saving CircuitWorks Options

To save CircuitWorks options:

1. In the CircuitWorks Options dialog box, modify options as needed.
2. Expand Settings and click Save Settings.
3. In the Save CircuitWorks options file dialog box:
   a) Specify the location to save the options.
      If you share the settings with another user, make sure the network location where you save them is accessible to that user.
   b) Use the default file name ecadopt.xml or type a file name.

   The extension must be .xml.

   c) Click OK.
Loading CircuitWorks Options

To load CircuitWorks options:

1. In the CircuitWorks Options dialog box, expand Settings and click Load Settings.
2. In the Load CircuitWorks options file dialog box, navigate to the location containing saved options files.
3. Select an options file and click Open.

Options files must be .xml files.

The settings in the CircuitWorks Options dialog box update to match those in the saved options file.

Specifying Component Heights

You can provide the height for each component instance when you design a circuit board.

The height information for a component from an ECAD file appears in the Component Instance Properties panel. For each component instance, you can modify the component height and associate the modified instance with a specific SOLIDWORKS configuration.

The software saves the height modification in the ECAD file. When you build a SOLIDWORKS assembly from the data in CircuitWorks, the software assigns the height to the SOLIDWORKS configuration you specified.

To specify component heights:

1. In CircuitWorks, open an ECAD file.
2. In the CircuitWorks feature tree, right-click a component instance and click Properties.
3. In the Component Instance Properties panel, type the value for Height (mm).

The value for SOLIDWORKS Configuration is NA if you have not exported the ECAD file to SOLIDWORKS.

4. Repeat steps 1 and 2 for each component instance.
5. Click Build Model (SOLIDWORKS section of the Tools tab).
6. In SOLIDWORKS, on the CircuitWorks CommandManager, click Export to CircuitWorks.
7. In the CircuitWorks feature tree, in the file you exported from SOLIDWORKS, right-click one of the component instances to which you assigned a height.
   In the Component Instance Properties panel, SOLIDWORKS Configuration shows the configuration associated with the component instance.
This chapter includes the following topics:

- Basic Dimensions
- Datums
- Datum Reference Frames
- DimXpert in Assemblies
- DimXpert Updates
- Face Edge Selection
- Horizontal and Vertical Reference and DimXpert Dimensions
- Silhouette Edge Selection

**Basic Dimensions**

You can create basic dimensions manually.

![Basic Dimension Example](image)

**To create basic dimensions:**

1. In a part, click **Smart Dimension** (Dimensions/Relations toolbar) or **Tools > Dimensions > Smart**.
2. In the Dimension PropertyManager, under **Dimension**, click **DimXpert basic location dimension**.
3. Select entities in the graphics area.
4. Place the dimension.
5. In the DimXpert PropertyManager, set options.
6. Click ✓.
Datums

Datums on a Radius or Hole
When you add a DimXpert datum to a radius or hole, the “R” no longer appears. This correction also applies to existing datums from documents saved in previous releases that are opened in SOLIDWORKS 2016.

Horizontal Datums and Feature Control Frames
DimXpert datums and feature control frames display horizontal to orthographic views of the model.

Hole Callouts Placement
DimXpert hole callouts are placed on the top face for blind, counterbore, and countersink holes.
**Width Datums**

Datums that represent the width between two faces have the following display options:

- Change the annotation view
- Change the annotation plane using drag handles
- Move the dimension lines of linear dimensions to the inside or outside
- Change a diameter dimension to linear display

**Datum Reference Frames**

When you create a geometry tolerance (also known as a feature control frame), a datum control frame is automatically created in compliance with the ASME 14.41 model based definition standard.
DimXpert in Assemblies

Available in SOLIDWORKS MBD.
You can use DimXpert in assemblies.

To use DimXpert in assemblies:
1. Open an assembly.
2. Click Tools > Options > Document Properties, and set DimXpert options, such as Geometric Tolerance.
3. Insert dimensions and geometric tolerances manually or automatically.
4. Save the assembly.

DimXpert dimensions created in parts and subassemblies will not appear in the open assembly. Only DimXpert annotations created in the open assembly will appear in the open assembly.

DimXpert Updates

Document Properties
- In part documents, DimXpert Document Properties appear under Drafting Standard. You can save and restore them with a drafting standard file, filename.sldstd. These settings are ignored in assembly and drawing documents.
- To set DimXpert options, click Tools > Options > Document Properties > DimXpert.
**Tolerance Defaults**

The default tolerance settings for DimXpert Document Properties are based on the document's drafting standard. When you select the **ANSI** (ASME) standard, the defaults are based on common machined parts used in industry practice. When you select the **ISO**, **DIN, JIS, BSI, GOST**, or **GB** standards, the defaults are based on ISO 2768-1 “f” designation and the 0.5 to 3mm size range, as applicable.

**Face Edge Selection**

Using DimXpert, you can select face edges to create size and location dimensions. Previously, you needed to select a face to create size or location dimensions. Now, you can select either faces or edges. For example, clicking any of the highlighted circles or curves in the models below selects the adjacent cylinders.
Horizontal and Vertical Reference and DimXpert Dimensions

In the modeling environment, you can set horizontal and vertical linear dimensions during dimension creation.

You can move the pointer to set horizontal and vertical linear dimensions during dimension creation within the modeling environment. This is similar to creating horizontal and vertical dimensions in drawings and sketches.
Silhouette Edge Selection

Using DimXpert, you can select silhouette edges to create dimensions.

Previously, you had to select a face to create size or location dimensions. Now, you can select silhouette edges. In the following examples, each pointer shows a selected silhouette edge and dimension.
Dimension placed
This chapter includes the following topics:

- **SOLIDWORKS Composer**
- **SOLIDWORKS Composer Sync**
- **SOLIDWORKS Composer Player**

**SOLIDWORKS Composer**

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents for product communication and technical illustrations.

These products are available:

- SOLIDWORKS Composer
- SOLIDWORKS Composer Check
- SOLIDWORKS Composer Path Planning
- SOLIDWORKS Composer Player
- SOLIDWORKS Composer Player Pro
- SOLIDWORKS Composer Sync
- SOLIDWORKS Composer Enterprise Sync

**Accurate Naming of Tree Items Imported from 3DXML**

When importing 3DXML files, 3D shapes that are aggregated directly under the root node of the product reference, are now imported with the name of the 3D shape reference, and the name of the 3D shape instance.

In order for this feature to work, you have to select the **Import instance names** option in the **Input** page of the Document Properties or Default Document Properties dialog box.

**Construction Geometries Imported as Stay on Top**

Previously, the advanced document property **IOImportCurvesStayOnTop** enabled you to import curves, wires, and wireframes as staying on top. This property has been
enhanced to simultaneously allow the import of construction geometries (construction lines, construction circles and construction threads) as staying on top.

**Import of Parasolid Files**

It is no longer possible to import Parasolid files into Composer.

Parasolid files have the following extensions: *x_t, *x_b, *xmt_txt, *xmt_bin.

**Import of Unigraphics Files**

It is no longer possible to import Unigraphics (UG) files into Composer.

UG files have the following extension: *.prt. This extension should not be confused with the *.prt extension of Pro/ENGINEER files, which can still be imported.

**New Features in Composer Application Programming Interface**

The Composer Application Programming Interface (API) has been enhanced with a number of features.

For more information, see the Composer Programming Guide: click Help > Programming Guide.

**New Timeline Tracks**

The timeline has been revamped with additional tracks to offer an array of new functionality for your 3D animations.

The existing Camera and Digger tracks remain unchanged. However, the track for actor keys has been split into the following:

- **Location** track: displays the keys indicating an actor's location.
- **Properties** track: expands into sub-tracks (such as Opacity, Materials and Events) displaying property-related keys.
- **Viewport** track: displays all the viewport property keys.

**Points Imported as Stay on Top**

A new advanced document property, IOImportPointsStayOnTop, lets you specify that points and construction points are imported as staying on top.

**Restore Active View Visibility**

A new visibility command is now available in the Home ribbon to let you restore the visibility of all actors of the active view.

Use it when you have made changes in the view (such as moving or adding actors, changing actors' visibility) and then want to restore the visibility of all actors to the last updated state. Other properties such as color, opacity, position, etc. will not be restored.
Thick Border for Active View
The active view is now surrounded by a thick border in the Views pane.
This enables you to differentiate between the active view and selected views (which are highlighted and surrounded by a thinner border).

SOLIDWORKS Composer Sync

Accurate Naming of Tree Items Imported from 3DXML
When importing 3DXML files, 3D shapes that are aggregated directly under the root node of the product reference, are now imported with the name of the 3D shape reference, and the name of the 3D shape instance.
In order for this feature to work, you have to select the Import instance names option in the Input page of the Document Properties or Default Document Properties dialog box.

Construction Geometries Imported as Stay on Top
Previously, the advanced document property IOImportCurvesStayOnTop enabled you to import curves, wires, and wireframes as staying on top. This property has been enhanced to simultaneously allow the import of construction geometries (construction lines, construction circles and construction threads) as staying on top.

Import of Parasolid Files
It is no longer possible to import Parasolid files into Composer.
Parasolid files have the following extensions: *.x_t, *.x_b, *.xmt_txt, *.xmt_bin.

Import of Unigraphics Files
It is no longer possible to import Unigraphics (UG) files into Composer.
UG files have the following extension: *.prt. This extension should not be confused with the *.prt extension of Pro/ENGINEER files, which can still be imported.
**Points Imported as Stay on Top**
A new advanced document property, `IOImportPointsStayOnTop`, lets you specify that points and construction points are imported as staying on top.

**SOLIDWORKS Composer Player**

**Restore Active View Visibility**
A new visibility command is now available in the **Home** ribbon to let you restore the visibility of all actors of the active view.

Use it when you have made changes in the view (such as moving or adding actors, changing actors' visibility) and then want to restore the visibility of all actors to the last updated state. Other properties such as color, opacity, position, etc. will not be restored.

**Thick Border for Active View**
The active view is now surrounded by a thick border in the Views pane.
This enables you to differentiate between the active view and selected views (which are highlighted and surrounded by a thinner border).
SOLIDWORKS Costing is available in SOLIDWORKS Professional and SOLIDWORKS Premium. Costing for assemblies is only available in SOLIDWORKS Premium.

This chapter includes the following topics:

- Assembly Costing Rollup
- Costing Templates
- Costing Performance Improvements
- Rules-based Costing

Assembly Costing Rollup

You can use Costing for assemblies. You can calculate the total cost of the assembly by calculating the cost of all parts and adding them together with all hardware and other purchased component costs. You can also recognize welding operations and add custom operations such as painting to the top-level assembly.

Costing for assemblies is available only in SOLIDWORKS Premium.

You can select how Costing assigns a cost to each part by selecting the type of cost estimation.

Types of cost estimation:

- **To be calculated**: Cost is calculated if the part does not have a cost assigned. Cost will be recalculated if you manually choose this option for a part with a saved or purchased cost.
- **Saved Cost**: Cost that has been saved to the part if the part has been costed.
- **Purchased Cost**: Cost that is assigned automatically if you have set a custom property or cost in the template. You can manually override this cost and it is saved at the assembly level.
- **Toolbox Parts**: You can include or exclude all Toolbox components if needed. To save time, Toolbox parts are not run through Costing. You can add costs to them manually or define them in the template, or through custom properties.

The Costing Task Pane for assemblies includes:
• **Costs to be calculated**: Parts with no cost data saved to them and no purchased costs associated with them. Parts that appear here by default are not costed.

• **Cost Defined**: Parts already costed, defined in the template, or manually assigned purchased costs. The parts that appear by default have already been costed, have a custom cost in the template, or are a manually added purchased cost. Costing is not run on these parts.

• **Purchased Parts**: Parts with purchased costs defined in the chosen template or a template set to a custom property with a defined purchased cost.

The multibody Costing template for assemblies includes:

The Purchased Parts tab.

• You can enter the name of one or more custom properties under **Purchased Cost Custom Property** and it automatically uses the value of these properties for the purchased cost of the part.

• You can define the **Component Name**, **Configuration Name**, and **Cost (USD/Part)**.

The costs defined under **Purchased Cost Custom Property** take precedence over values defined in **Part Cost**.

The CostingManager displays the parts with their types and materials in their appropriate folders. The CostingManager for assemblies includes:

• **Setup**: Has the setup costs for custom operations at the top-level assembly.

• **Calculated Parts**: Contains:
  • Method and stock type, if applicable.
  • Template
  • Stock material

• **Purchased Parts**: Displays parts that have a cost defined in the template or custom properties.

• **Toolbox Parts**: Displays purchased toolbox components specifically.

• **Welding**: Displays the welding operations of the top-level assembly.

• **Custom Operations**: Displays the custom operations of the top-level assembly.

• **No Cost Assigned**: Displays bodies excluded from the Costing calculation and bodies without assigned costs.

**Costing Assemblies Report**

You can customize the assemblies Costing report template to present the results of the cost analysis. You can generate assembly Costing reports in Microsoft Word and Microsoft Excel formats.

**Evaluating the Cost of an Assembly**

To evaluate the cost of an assembly:

1. In an assembly, click **Tools > SOLIDWORKS Applications > Costing**.

2. In the Costing Task Pane, under **Costing Templates**, in **Main template**, select a template.

3. Under **Part List**, select the parts for:
• Costs to be calculated
• Cost Defined

See Assembly Costing Rollup.

To change the category of a part, use **Type of cost estimation**. You can manually define costs under **Type of Cost Estimation** for purchased parts to override pre-defined costs.

4. To set or change a predefined cost, select the part in **Cost defined** and type the cost.
5. Select parts under **Toolbox Parts** and set one of the following:
   • **Exclude**. Excludes the selected bodies from cost calculations.
   • **Include**. Includes the selected bodies for cost calculations.
6. Click **Begin Cost Estimation**.

**Costing Templates**

**Importing and Exporting in Costing Templates**

You can use **Import** and **Export** tools for **Weld Bead**, **Fillet Bead**, and **Purchased Cost** in a multibody template, as well as for all materials in the machining and sheet metal templates.

You can use **Import** to extract information relating to materials from a Microsoft Excel template into a blank or partially populated Costing template. You can use **Export** to transfer the information from a material tab to a Microsoft Excel spreadsheet.

The Update command is replaced by **Import**. When you use **Import**, new lines of materials and changed costs of previous lines of material are updated. New imported rows in the sheet are blue and updated fields are green.

**To access Import and Export in machining templates:**

1. In a machined part, click **Costing** (Tools toolbar or the Evaluate tab on the CommandManager).
2. In the Costing Task Pane, under **Costing Template**, click **Launch Template Editor**.
3. In the Costing Template Editor, under **Material**, click **Machining**.
4. Click **Import** or **Export**.

You can also access **Import** and **Export** for 3D printing, weldments, and casting.

**To access Import and Export in sheet metal templates:**

1. In a sheet metal part, click **Costing** (Tools toolbar or the Evaluate tab on the CommandManager).
2. In the Costing Task Pane, under **Costing Template**, click **Launch Template Editor**.
3. In the Costing Template Editor, click **Thickness**.
4. Click **Import** or **Export**.

   Before you can import additional instances of a material in the **Thickness** tab, you must add the material in the **Material** tab.

**To Import and Export in multibody templates:**

1. In a multibody part, click **Costing** (Tools toolbar or the Evaluate tab on the CommandManager).
2. In the Costing Task Pane, under **Costing Template**, click **Launch Template Editor**.
3. In the Costing Template Editor, under **Main**, select one of the following:
   - **Weld Bead**
   - **Fillet Bead**
   - **Purchased Cost**

**Bounding Box Nesting**

To estimate material usage and costs of nested sheet metal parts, you can:

- Choose the sheet size
- Estimate the number of parts that can fit on a sheet
- Determine the number of sheets necessary

You can also preview the nested parts with or without offsets along the X and Y dimensions. Previously, you had to select materials that were estimated per pound.

Types of offsets include:

- **Bounding Box offset**: You can apply offsets to all sides on the exterior of the bounding boxes in a sheet.
- **Sheet Border offset**: You can define the sheet border offset for the X axis to the bottom and the Y axis to the left of the sheet.

**Estimating Sheet Metal Part Costs with the Sheet Size Option**

To estimate sheet metal part costs with the Sheet Size option:

1. In a sheet metal part, click **Costing** (Tools toolbar) or **Tools > SOLIDWORKS Applications > Costing**.
2. In the Costing Task Pane, under **Blank Size**, select **Sheet Size**.
   The most appropriate sheet size is automatically selected.
3. In the Task Pane, under **Blank Size**, define value for **Bounding Box Offset**.
4. Under **Bounding Box Nesting**, enter X and Y values for **Sheet Border Offset**.

   The image created in the **Bounding Box Nest Preview** is part of the final report.
5. Click **Begin Cost Estimation**. Under **Bounding Box Nesting**, the **Percent Scrap**, **Total Number of parts per sheet**, and **Total number of sheets for Lot Size** are displayed.

6. Click **Show Bounding Box Nesting**. The **Bounding Box Nest Preview** is displayed as a drawing of the nested elements.

The red dotted line is the sheet metal offset and the black dotted line is the bounding box offset.

### Selecting Stock Sheet Sizes in Sheet Metal Costing

You can modify the sheet metal stock sheet sizes in a template. Previously, you could only add the **Per Weight** stock type. You can select between **Material Weight** and **Sheet Size** stock types in the Task Pane.

The Costing Template Editor contains four new columns on the **Thickness** tab:

<table>
<thead>
<tr>
<th>Entity</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stock Type</td>
<td>Per Weight or Per Sheet options</td>
</tr>
<tr>
<td>X Dimension / Y Dimension</td>
<td>Defines values for Per Sheet Stock Type option</td>
</tr>
</tbody>
</table>

The **X Dimension** and **Y Dimension** are only available when **Stock Type** is **Per Sheet**.

You cannot create multiple entries with the same set of values in the **Thickness** column or the X Dimension and Y Dimension column. The unit type is automatically updated depending on the stock type selected.

### Costing Performance Improvements

Costing performance is improved.

- When you hover over **Cut Paths** in the CostingManager, the cut paths in the graphics area are highlighted on the sheet metal flattened state. When you right-click **Cut Paths** and click **Map Cut Paths on folded state**, you can toggle it on or off by clicking it. The cut paths are highlighted in a flat pattern rather than the folded state unless you mapped them.
Mapping may cause slower performance on parts with more complex geometry.

- The performance is enhanced for volume on machined parts. When a rebuild occurs and there are many volume features, Costing takes less time to re-cost the part.
- You can collapse the Costing Task Pane to increase the space for Task Pane items. You can also edit sheet metal values by using tabbing and reverse tabbing.
- When you cost a part, Costing does not run immediately so that you can make changes to the method and other settings before running the analysis. When you are ready, you can click **Begin Cost Estimation** and the costs are automatically updated. Previously, you had to wait for Costing to process the part before changing the method and other calculations.

### Rules-based Costing

You can customize machining templates to more accurately reflect the manufacturing process for creating parts. The machining templates include customizable rules for handling special geometry cases such as large holes or stock body selection.

The List of Rules under the Rules tab includes:

- **IF**:
  - **CONVERT large drilled holes to milled circular pockets IF the hole diameter is a certain size**: Mills certain holes that are larger than a specific diameter rather than drill them.
  - **ADD material to the machining stock body IF machining is selected**: Sets an amount of additional stock to always add to the machining stock body.
  - **ADD material to the cylinder stock body IF machining method is selected**: Sets an amount of additional stock to add to the cylinder stock body.
  - **Select a larger plate thickness for plate stock body IF machining method is selected**: Sets a larger plate thickness to use for the plate stock body.

- **IF/THEN**
  - **IF a material is chosen, THEN add a custom operation**: Adds a custom operation like painting or inspection whenever you choose a specific material.
  - **IF a material is chosen, THEN add a markup/discount to the total material/cost**: Adds a markup or discount to the total cost or cost of material whenever you choose a specific material.
  - **IF no appropriate drill tool is available, THEN use a different tool**: Lets you choose a tool for drilling operations if a tool is not available in the template.
• **IF no appropriate mill tool is available for roughing, THEN use a different tool**: Lets you choose a tool for milling operations if a tool is not available in the template.

• **IF no appropriate mill tool is available for finishing or semi-finishing, THEN use a different tool**: Lets you choose a tool for finishing and semi-finishing operations if a tool is not available in the template.

### Setting Up Rules-based Costing

**To set up rules-based Costing:**

1. Open a machined part and click **Tools > SOLIDWORKS Applications > Costing**.

2. Under **Method**, select **Machining**.

3. In the Costing Task Pane, under **Costing Templates**, click **Launch Template Editor**.

4. In the Costing Template Editor, click **Rules**.

5. Under **Name**, type a Rule name and under **Category** select **IF/THEN**.

6. Under **Structure**, select **IF a material is chosen, THEN add a custom operation**.

7. Under **Definition**, click **<Select a material>**.

8. In the Rule Input dialog box, under **Select a Material**, set options for **Select Class** and **Select Material**.

9. Click **OK**.

10. Under **Definition**, click **<Select a custom operation>**.

11. In the Rule Input dialog box, set an option for **Select a custom operation**.

12. Click **Save As** and enter a name.

   The template is saved in the defined location.

---

You can only copy and paste material-based rules with their defined parameters to another row. You can define the remaining rules only once.
10
Detailing and Drawings

This chapter includes the following topics:

- Dimensions
- Drawing Views
- Model Detailing
- Notes and Balloons
- Performance
- Sheets

Dimensions

Chamfer Callouts and Dual Dimensions

In chamfer callouts with dual dimensions, the defaults for new documents have changed. Also, bent leaders attached to chamfer callouts with dual dimensions follow the same rules as hole callouts and respect justification settings of the dimension text.

In Tools > Options > Document Properties > Dimensions > Chamfer, the default for:

- **Dual Dimension** position is **Right** for all new drawings.
- **Text** vertical alignment is **Bottom** for all new drawings.

Dimensioning Improvements

The selection behavior when you add a dimension to a sketch has improved.

If you select an endpoint or sketch point and then accidentally click in the graphics area, the first selected point is retained so you can try again to select a second entity.

If you select an invalid entity to complete a dimension, such as a spline, ellipse, or parabola, instead of an error dialog box, a tooltip warns that a dimension cannot be created from the currently selected items. Move the pointer to dismiss the message. Again, your first selection is retained so you can select a second entity.
Foreshortening of Linear Dimensions

You can foreshorten (or clip) linear dimensions in any type of drawing view.

To foreshorten linear dimensions:
1. Right-click the side of the dimension to foreshorten and click Display Options > Foreshorten.

To set a document-level default for the foreshortened style, with a drawing open, click Tools > Options > Document Properties > Dimensions > Linear and under Foreshortened, select a style.

Hole Callouts and Dual Dimensions

In hole callouts with tolerances on the diameter, dual dimension nominal, maximum, and minimum values are grouped together within one bracket set instead of separated between each of the callout elements.

Bent leaders attached to hole callouts with dual dimensions follow the same rules as other hole callouts and respect justification settings of the dimension text.
Smart Dimensioning for Simple Thread Callouts

The Smart Dimension tool creates a simple thread callout when you select the cosmetic thread of a threaded hole.

Drawing Views

Center Mark Scaling

You can turn off the view scale that is applied to center marks.
To turn off the view scale that is applied to center marks, in **Tools > Options > Document Properties > Centerlines/Center Marks**, clear **Scale by view scale**. When selected, center marks are scaled based on the drawing view scale. When cleared, center marks are scaled based on the drawing sheet scale.

### Hatch Patterns

New DIN ISO 128-50 crosshatch types are available in the **Area Hatch/Fill** tool.

The new hatch patterns are:

- Alloyed steel
- Carbon steel
- Cast iron
- Elastomers and rubbers
- Heavy metals
- Light alloys
- Metals
- Plastics
- Solids
- Thermoplastics
- Thermoset plastics

### Model Break Views Within Drawings

Use the **Model Break View** tool to create configuration-based 3D break views (also known as interrupted views) of a model for individual drawing views.

You can create break views in a model of isometric orientation with traditional break shapes, including accurate depiction of pipe breaks. This allows angled parts and isometric drawing views to break correctly.
To show a model break view within a drawing:

1. Select the drawing view of a model that contains a model break view.
2. Do one of the following:
   - In the **Drawing View** PropertyManager, under **Reference Configuration**, select **Show in exploded or model break state**.
   - Right-click the drawing view and click **Properties**. In the dialog box, in **Configuration information**, select **Show in exploded or model break state**, and click **OK**.

**Section Views**

**Standard without connector** is a cutting line display for section views that complies with the ISO 128 standard.

**Standard Display** and **Alternative Display** are renamed to **Standard with connector** and **Alternative without connector**, respectively. This example shows the **Standard**
**without connector** cutting line. This option has thick lines at the ends of the cutting line and at any change in direction within the cutting line.

**To set the cutting line style:**

1. In a drawing, click **Options > Document Properties > Views > Section**.
2. In **Line style**, select one:

<table>
<thead>
<tr>
<th>Standard with connector</th>
<th>Displays a continuous section line in the source view.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Standard with connector" /></td>
<td><img src="image" alt="Standard with connector" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Alternative without connector</th>
<th>Displays a split section line in the source view.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Alternative without connector" /></td>
<td><img src="image" alt="Alternative without connector" /></td>
</tr>
</tbody>
</table>
3. Set options.
4. Click **OK**.

**View Letters on Section Views**

The placement of section view letters for **Standard with connector** and **Standard without connector** cutting line displays has changed. View letters on section view cutting lines are always placed to the outside of the arrows instead of at the top of each arrow.

---

**View Arrow Letters**

When you create a view letter attached to a view arrow, such as an auxiliary view or projected view, you can move the view letter. This is similar to moving the view letter in a section view.

To move a view arrow letter, select the arrow and drag the letter. For example:
Model Detailing

**Part and Assembly Watermarks**

You can set notes in the **Notes Area** annotation view to behave as watermarks in models. You can display the watermarks under the model geometry or on top of the model geometry, with specified transparency.

When you set a note to **Watermark**, you can only select it if **Notes Area** is the active annotation view.

**To create a watermark in a part or assembly:**

1. In the FeatureManager design tree, expand **Annotations**.
2. Right-click **Notes Area** and click **Activate**.
3. Click **Insert > Annotation > Note**.
4. Create the note for the watermark.
5. Right-click the note and click **Watermark**.
6. In the PropertyManager, under **Watermark**:
   a) Under **Ordering**, select whether the watermark displays **Behind geometry** or **On top of geometry**.
b) Optionally, adjust the **Transparency**.

7. Click ✓.

### Reference Geometry

The names and labels for points, axes, and coordinate systems now respect the settings **Always display text at the same size** and **Text scale**.

**To set fonts for names and labels for points, axes, and coordinate systems:**

1. With a model open, click **Tools > Options > Document Properties > Detailing**.
2. Under **Point, Axis, and Coordinate System**, set options:

   - **Hide names**: Hides reference geometry names for points, axes, and coordinate systems.
   - **Name font**: Sets the font for the names of points, axes, and coordinate systems.
   - **Label font**: Sets the font for the labels of coordinate system arrows.

3. Click **OK**.

### Notes and Balloons

#### Flag Notes

Flag notes are a method of cross-referencing one area or feature on a drawing to a list of notes, often called general notes.

You can create flag notes in general notes and parametrically link these paragraphs with flag note balloons that you can place throughout a drawing.
Creating Flag Notes

To create flag notes:

1. In a drawing, click **Insert > Annotations > Note**.
2. Click to place the note in the drawing.
3. On the Formatting toolbar, click **Number**.
4. Type the numbered items.
5. Click the item number to flag.
6. In the Property Manager, under **Border**:
   a) Select **Add to Flag Note Bank**.
   b) Select options.
   As you select and add other numbered items, they are added to the Flag Note Bank.
7. Click ✔.

Creating Flag Note Balloons

There must be at least one flag note in the Flag Note Bank.

To create flag note balloons:

1. In a drawing, click **Insert > Annotations > Balloon**.
2. In the Property Manager, select **Flag Note Bank**.
3. In **Flag Note Bank**, select a flag note.
4. In the drawing, click to place the flag note balloon. To include a leader with the flag note balloon, click the geometry first.
5. Click ✔.

Adding Flag Note Balloons to Notes

To add flag note balloons to notes:

1. Double-click a note to edit it.
2. In the note, position the pointer where you want to insert the flag note balloon.
3. In the Note Property Manager, under **Text Format**, select **Flag Note Bank**.
4. In the Flag Note Bank dialog box, select the flag to insert.
5. Click **OK** to close the dialog box.
6. Click ✔ to close the Property Manager.
Adding Flag Notes to a Balloon Stack

To add flag notes to a balloon stack:
1. Right-click a balloon stack and click Add Flag Note to Stack.
2. In the Flag Note Bank, select a flag note.
3. Click OK.

Link to Property
You can link annotations to custom properties in subassemblies.

In the Link to Property dialog box, you can select a custom property from any model in the drawing without preselection or leader attachment.

To link an annotation to the custom property of a subassembly:
1. In a drawing view of an assembly that contains a subassembly, create a note with a leader that is attached to a subassembly component.
2. While creating the note, in the Note PropertyManager, under Text Format, select Link to Property.
3. In the Link to Property dialog box, under Use custom properties from, select Model found here.
4. In the list, click Selected component or other drawing view.
5. In the drawing view, right-click the component and click Select Other.
6. Select the subassembly.
7. In Property name, select the custom property.
8. In the Link to Property dialog box, click OK.
9. Click ✓ to close the PropertyManager.
Paragraph Numbering

In notes with numbered paragraphs, you can remove the period after the paragraph number when the note has a border.

To remove the period after the paragraph number:

1. In a note with a numbered paragraph and a border, double-click the note.
2. In the Formatting toolbar, click **Paragraph Properties**.
3. In the Paragraph Properties dialog box, select **Do not show period with borders**.
4. Click **OK** to close the dialog box.
5. Click ✔ to close the PropertyManager.

Rearranging Stacked Balloons

You can rearrange balloons within a stack or move balloons between stacks.

In this example, the “4” balloon is moved between the two “3” balloons.

To rearrange stacked balloons:

1. **Shift +** click a balloon within the stack.
2. With the balloon selected, move the pointer within the stack to see a preview of the new position within the stack.
3. When the balloon is in the correct position, release the mouse button.

Sorting Stacked Balloons

To sort stacked balloons numerically:

Right-click in the stacked balloons and click **Sort Stack**.
Set all Custom Property Values to the Same as a Sheet

You can use the same $PRPSHEET custom property values across all drawing sheets by selecting one specified sheet.

To set all custom property values to the same as a sheet:

1. Click Tools > Options > Document Properties > Drawing Sheets.
2. Under Multi-sheet custom properties source, select Use custom property values from this sheet on all sheets and select the sheet number to use.

Sheet Metal Information in Drawings

Sheet metal components that are mirrored or derived retrieve their sheet metal information from the parent component. This information is available in drawings.

The SOLIDWORKS software supports the flat pattern view for mirrored or derived parts, as well as functions such as bend notes (bend table, bend direction, and bend angle) and bend line representation.

Performance

Full Scene Anti-Aliasing Improvements

Improvements for FSAA (Full Scene Anti-Aliasing) for drawings provide faster performance. In addition, better quality results from the extended FSAA modes.

Drawing performance has improved because the software now caches textures rather than the full geometry of the view.

Performance Evaluation

AssemblyXpert is renamed to Performance Evaluation and is available for drawings.

To run Performance Evaluation in a drawing:

- Click Performance Evaluation (Tools toolbar) or Tools > Evaluate > Performance Evaluation.

Like Performance Evaluation in assemblies (previously called AssemblyXpert), Performance Evaluation in drawings examines a drawing for performance issues, and lists rebuild times for drawing elements such as drawing views, sketch entities, and referenced files. Use this report to determine which elements take longer to load and rebuild.
Sheets

**Automatic Border**

The **Automatic Border** tool lets you control every aspect of a sheet format’s border, including zone layout and border size.

Using the **Automatic Border** tool, borders and zones automatically update to match changes in the Zone Parameters tab of the Sheet Properties dialog box without having to manually edit the sheet format. You can also include Margin Mask areas where formatting elements such as labels and dividers are not shown. This is helpful when you want to mask an area on a sheet for notes.

**To use the Automatic Border tool:**

1. In a drawing, click **Edit Sheet Format** (Sheet Format toolbar).
2. Click **Automatic Border** (Sheet Format toolbar).
3. Set options:
   - On the first page of the Automatic Border PropertyManager, select items to delete from the sheet’s format. For example, you can delete existing format entities before creating a new smart border.
   
   When you use the **Automatic Border** tool, the borders and zone dividers automatically align and update with existing zones.

   • On the second page, define the margins, borders, and zones.
   • On the third page, define Margin Mask areas for zone labels and dividers that provide a convenient location for notes. In this example, the margin masked area includes the upper right zone labels.

4. Click ✔.
Creating a Zone Layout

This example uses the B (ANSI) Landscape sheet format. First, you remove the existing zone labels and zone dividers. Then, you add new zone information to create four rows and six columns.

To create a zone layout:

1. Create a new drawing and select B (ANSI) Landscape as the sheet format/size.
2. Click Edit Sheet Format (Sheet Format toolbar).
3. Click Automatic Border (Sheet Format toolbar).
4. To remove the existing zone labels and dividers, on the first page of the PropertyManager, select the zone letters and zone dividers on the sheet to delete. As you select the letters and dividers, the notes and lines appear in Delete List.

These entities will not be deleted from the sheet until you click ✓.

5. Click ✓.
7. Under Zone Formatting:
   a) Select Show zone dividers.
   b) Set Length of Zone Divider to 0.25 in.
   c) Set Length of Outer Center Zone Divider to 0.25 in.
   d) Set Length of Inner Center Zone Divider to 0.25 in.
   e) Under Zone labels, select Show columns and Show rows.

8. Click ✓.
10. In the graphics area, you can resize the mask and drag it over view labels and zone dividers to mask them out.
11. Click ✓.
12. Click Edit > Sheet, or right-click any blank area on the drawing sheet, or the sheet icon in the FeatureManager design tree, and click Edit Sheet.

After you create borders and zone dividers with the Automatic Border tool, any changes you make to the zones using the tool or Sheet Properties > Zone Parameters will automatically update.

Document Properties - Borders

You can set drawing document properties for sheet borders and zone formatting.

With a drawing open, click Tools > Options > Document Properties > Borders.
Detailing and Drawings

Overall drafting standard

| Overall drafting standard | Uses settings from the Drafting Standard page. |

Margins

| Line Style | Sets the style. |
| Line Thickness | Sets the thickness or select **Custom size** and enter a thickness. |
| Double-Line Border | Displays the border using two lines. |

Zone Formatting

| Show Zone Dividers | Displays zone dividers. |
| Line Style | Sets the style. |
| Line Thickness | Sets the thickness or select **Custom size** and enter a thickness. |

Zone Divider

| | Sets the length for the zone divider. |
Center Zone Divider

Sets the length for the outer center zone divider. In this example, the outer center zone divider is shown in the blue box.

Sets the length for the inner center zone divider. In this example, the inner center zone divider is shown in the red box.

Zone Labels

Show columns Displays column labels.

Show rows Displays row labels.

Layer

Sets the layer.

You must first create layers for the drawing before you can select them for document properties.

Edit Sheet Format

You can edit your sheet format from the CommandManager tab or Sheet Format toolbar.

- Right-click a blank area and click Edit Sheet Format.

Sheet Scale

You can change the sheet scale from the status bar.

To change the sheet scale of a drawing, in the status bar click Sheet Scale and click a scale. You can also access the Sheet Properties dialog box from the menu.
Title Blocks

You can define or edit a title block from the CommandManager tab or Sheet Format toolbar.

To define or edit a title block:

1. Do one of the following:
   - On the Sheet Format toolbar, click Edit Sheet Format, then click Title Block Fields.
   - On the Sheet Format CommandManager, click Edit Sheet Format, then click Title Block Fields.
   - In the FeatureManager design tree of a drawing, right-click Sheet Format and click Edit Sheet Format. Then right-click Sheet Format and click Title Block Fields.

2. In the Title Block Table PropertyManager, set options.

3. Click ✓.
eDrawings® Professional is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

This chapter includes the following topics:

- 3D Views and Annotation Views
- Component Descriptions
- Exploded Views
- Intersection Zones in Section Views
- Model Break Views
- Performance
- Rotating Models
- Undo and Redo
- Units of Measure
- User Interface Enhancements
- Weld Beads

3D Views and Annotation Views

eDrawings supports 3D Views and annotation views for assemblies. Previously, only parts were supported.

Component Descriptions

If you saved component descriptions for models in the SOLIDWORKS software, the eDrawings Components pane includes the descriptions. This helps you see information about the components in an assembly.

When you save the model in SOLIDWORKS using either the component name, component description, or both, eDrawings uses the same settings.

To show component descriptions, click **Components**.

To hide component descriptions, click **Options**. In the dialog box, on the General tab, clear **Show Component Descriptions**.
Exploded Views

Enhancements to exploded views include a slider for controlling the extent of explodes and radial explodes.

Exploded Views Slider

When you use the Explode tool in eDrawings, it is easier to control the extent of the exploded view with a slider that you can drag.

With an assembly open in eDrawings, click Explode. Use the slider to control how much to explode the view.

Radial Explodes

You can explode components aligned radially or cylindrically about an axis.

In the SOLIDWORKS software, save a radial exploded step in a model. When you open the file in eDrawings and click Explode, the exploded view appears.

Radial explodes are available for eDrawings assemblies (.easm) only.

Intersection Zones in Section Views

When you save section views with intersection zones in the SOLIDWORKS software, you can see the views in eDrawings.

Click View Orientation (Heads-up View toolbar) and click a section view.
Model Break Views

When you create model break views in the SOLIDWORKS software, you can view them in eDrawings .eprt files. This supports the model based definition workflow.

Model break views support:
- Query highlighting
- 3D Views
- Annotation views
- Multiple configurations

Click MBV.

Performance

Performance is improved for large parts and assemblies in eDrawings.

Click Options. In the dialog box on the General tab, under Performance, select Graphics boost and Fastest speed for a better overall frame rate.
Rotating Models

When you rotate a model, the rotation is influenced by the zoom level in the model. When the model is zoomed in, the rotation is about the closest entity on the model from the pointer. When the model is zoomed out, the rotation is about the center of the model.

Previously, the model always rotated about the center of the scene. Now the rotation behaves more like that in the SOLIDWORKS software.

Undo and Redo

You can undo and redo changes that you make in the current eDrawings session.

This functionality is available for tools such as Pan, Zoom, Rotate, View Orientation, Explode, Markup, hiding and showing components, and changing configurations.

To undo a change, click File > Undo or CTRL + Z.

To redo a change that was undone, click File > Redo or CTRL + Y.

This functionality is not available for Move Component.

Units of Measure

When you open a SOLIDWORKS file in eDrawings, the units remain the same in eDrawings.

Previously, millimeters was the default unit of measure regardless of the units used in the file when it was saved in the SOLIDWORKS software.

User Interface Enhancements

User interface updates have been implemented to streamline your overall workflow.

Enhancements include:

- Tabs at the top of the eDrawings window so you can move among documents.

- The Upgrade to Professional tool (Tools toolbar) brings you to a web page to upgrade to eDrawings Professional.
Weld Beads

eDrawings supports weld beads. When you open a model in eDrawings that has weld beads, the weld beads and callouts are displayed in the graphics area.
This chapter includes the following topics:

- Annotate Documents with eDrawings
- Formula Manager Enhancements
- Integration with CircuitWorks Lite
- Limiting User Rights on Project Data
- Paste Special Wizard Improvements
- Project Snapshot
- Properties Side Panels
- Report Filters
- Additional Enhancements for SOLIDWORKS Electrical

Annotate Documents with eDrawings

You can annotate SOLIDWORKS Electrical documents, drawings, and schematics using eDrawings.

Formula Manager Enhancements

Enhancements for the Formula Manager include:

- Long names in the interface, for example, COMPONENT_MARK_ROOT instead of COM_ROOT.
- A tab displays a tree of available functions and operators. You can select a function or operator and add it to the formula with one click. The functions and operators include mathematical, data and string functions, and unitary, logic, relational, and arithmetic operators.
- A Test button displays next to each formula. When you click Test, the Formula tester dialog box lets you test the formula and see the result.
- When you create a formula, you can save it as a predefined formula.

Integration with CircuitWorks Lite

You can use CircuitWorks Lite to automatically create a SOLIDWORKS component from an EDA (eCAD) file describing a printed circuit board (PCB). You can then insert that component into the SOLIDWORKS software.

The PCB can be a manufactured PCB or one that you design. You can use it for a specific project, or import it into a PCB catalog for use in multiple projects. You can also route wires and cables to the component representing the PCB, but first you have to define the connection points on the component.
CircuitWorks Lite supports the import of IDF files only.

To add a PCB component to a project, select **Components > New PCB**.

**Limiting User Rights on Project Data**

Users with a role of project manager or higher can limit the right to edit project information to specific groups.

Users who are restricted from editing a book cannot edit properties of that book or any of its files or folders, and cannot open its files. However, they can preview files from the book, edit wire cabling and manage origin-destination arrows from files in the book, and modify components.

To set access restrictions, select the book and click **Configure access rights**.

**Paste Special Wizard Improvements**

When you copy and paste an element, you can associate it with an existing mark, create a new mark for the entity, and rename the element.

This enhancement applies to books, folders, files, locations, functions, components, cables, harnesses, wire styles, cable styles, wires, and equipotential lines.

Previously, the Paste Special Wizard allowed you to choose only one action for each type of element. For example, you could keep the existing mark for all cables, but you could not keep existing marks for some cables and create new marks for others.

**Project Snapshot**

You can create snapshots of a project, and restore the snapshots later if necessary. Snapshots are saved as `.tewzip` archive files in a Snapshots folder.

SOLIDWORKS Electrical prompts you to save a snapshot when you close a revision. You can save a snapshot at any time using a command on the ribbon bar or in the component/document tree. You can also specify that snapshots should be taken automatically at fixed intervals.

You also have the option to include project dependencies in the snapshot, or to leave them out to make the archive file smaller.

**Properties Side Panels**

New side panels display on the right side of the interface to help you find information faster and take actions with fewer clicks.

The panels show properties of objects such as items on document and component trees, and graphic entities and symbols in the graphics area. Properties are listed in a grid format.

Depending on the type of entity, one or more tabs provide access to different properties. For example, the property panel for a line (wire) includes tabs for wire style, cable, equipotential lines, and graphical properties. Tabs for multiple object types display when you select two or more objects.
The panels display on the right side of the interface by default, but you can move them and save the modified panel layout.

You can access the panels from the SOLIDWORKS Electrical CommandManager.

Report Filters

You can create multiple filters for a report. This enhancement lets you use the same report, with the appropriate filter, for different scenarios. You no longer need to make multiple copies of the report and maintain them separately.

A Filters tab in the report configuration editor lets you create and edit filters. You can create filters with multiple conditions about the value of fields, using logical operators (<, <=, >, >=, =, />, LIKE) and Boolean AND/OR conditions, for example: WHERE ((Field1 > Value1) AND (Field2 > Value2)) OR Field3 = Value3.

After you create a filter, you can add it to a report in the Report Manager.

Additional Enhancements for SOLIDWORKS Electrical

• A new interface helps manage title block attributes. Its features are similar to those used to manage symbol attributes.
• A new tab in the PDM link configuration makes it easy to manage reports.
• You can manage translations in any number of languages, not just the three languages specified in project properties.
• In 3D module Routing, you can define the origin and destination of cable routes for cabinets by the cable location.
Available as a separately purchased product that can be used with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

This chapter includes the following topics:

- **Mesh Settings**
- **Mirror Results for Symmetrical Models**
- **Transient Analysis**
- **Sunlight Properties Import**

### Mesh Settings

Improvements in mesh settings include uniform mesh, control planes, and quality plots.

- **Uniform mesh.** For better convergence you may need to create a uniform mesh around a body. The equidistant refinement ensures a uniform mesh around a body with minimum effort.
- **Gaps.** You can automatically fill gaps of a specified size with the solid at the meshing stage.
- **User interface.** The Mesh Settings PropertyManager is updated with a new interface.
- **Control planes.** There is improved specification of control planes.
- **Previews.** A preview mesh is available.
- **Quality plots.** Mesh quality plots show where the mesh is too coarse, where geometry is poorly resolved, and so on.

### Mirror Results for Symmetrical Models

For models using a symmetry plane, you can display graphical results on a full model. In **Cut plots and Surface Plots**, select **Mirror results**.
Transient Analysis

Improvements in transient analysis include nested iterations, time-averaged results, and results data.

- Nested iterations. Transient analysis is more robust when using a large time step with the nested iterations algorithm. By using a large time step (in cases where you do not want to capture tiny transient details) you can speed up the transient calculation.
- Time-averaged results. With transient tasks, sometimes you need to observe the flow field averaged on time rather than on a set of fields at the exact time moment. You can save time-averaged results for a specified parameter on the Solving tab of the Calculation Options dialog box.
- Results data. Transient results data can be smaller when you save specific parameters rather than all of the parameters.

Currently, nested iterations do not support:

- Rotation (sliding, circumferential averaging)
- Condensation, humidity, steam, real gases
- Cavitation
- High mach number

Sunlight Properties Import

You can link sunlight study properties from the SOLIDWORKS software to a solar radiation project.

In the General Settings dialog box, under Solar radiation, select SOLIDWORKS Sunlight to link the solar radiation boundary condition to the Sunlight settings.
This chapter includes the following topics:

- Exporting Material Properties to IFC 2x3 Files
- Exporting to the IFC 4.0 Format
- Import of Visual Properties
- Importing PTC Creo 3.0 Files
- Importing STL Models

Exporting Material Properties to IFC 2x3 Files

You can export material properties such as mass, area, and volume that are assigned to SOLIDWORKS models to IFC 2x3 files.

These properties are stored with the exported file and are available when you open the file using an IFC-capable viewer.

Exporting to the IFC 4.0 Format

To make it easier to share design data with Building Information Modeling (BIM) systems, the SOLIDWORKS software supports exporting to the IFC 4.0 format.

You can map the following data from a SOLIDWORKS file to an IFC 4.0 file:

- Geometrical data
- Material and mass properties
- Tessellated geometry
- Face and body colors

Export to the IFC 4.0 format is supported for:

- Parts
- Top-level assemblies
- Multibody parts
- Weldment parts

To export to the IFC 4.0 format:

1. Click **File > Save As**.
2. In the Save As dialog box:
   a) For **Save as type**, select **IFC 4 (*.ifc)**.
   b) Click **Options**.
3. In the Export Options dialog box:
   a) Select whether to output the IFC 4.0 file as OmniClass or UniClass2, and expand the items to select the specific class to use.
   b) Select Units.
   c) Under IFC4 Export, select one of the following:
      • BREP
      • BREP and Tessellation
      • Tessellation
   d) Click OK.

4. Select the file name and location, enter an optional description, and click OK.

Import of Visual Properties

The SOLIDWORKS software analyzes incoming colors and combines them when assigning them to a new SOLIDWORKS part or assembly. This reduces the number of visual properties created when you import files with appearances and saves time loading the imported models.

The results of the analysis are:

• When an imported file contains the same color definitions for every face on a body, the software creates a single body appearance.
• When the file contains the same color definitions for every body in a part, the software creates a single part appearance.
• When an imported assembly contains the same color definitions for every component in the assembly, the software creates a single assembly appearance.

Colors that are defined on features in the imported file are kept in the final model.

Importing PTC Creo 3.0 Files

You can open PTC Creo® 3.0 files in the SOLIDWORKS software.

Parts and assemblies are supported, including all legacy behavior of the Pro/ENGINEER® file import.

Importing STL Models

You can import .STL files with up to 500,000 facets (~ 24 MB for binary format .STL files and ~ 138 MB for ASCII format .STL files).

This increase in size is approximately:

• Twenty-five times larger than what was previously allowed for solid .STL files.
• Five times larger than what was previously allowed for surface .STL files.

For surface and solid .STL file imports, you are warned that conversion may take a long time and you are given an opportunity to cancel the import.

However, import performance has increased significantly. For example, the import time for a solid .STL file with 20,000 triangles is now as much as three times faster than it was with SOLIDWORKS 2015.

For surface .STL files, a stringent check gives more meaningful results.
This chapter includes the following topics:

- **Exporting Inspection Reports to Net-Inspect and QualityXpert**
- **Horizontal and Vertical Report Formats**
- **Standalone SOLIDWORKS Inspection Enhancements**

### Exporting Inspection Reports to Net-Inspect and QualityXpert

You can export inspection reports directly to the online quality systems Net-Inspect and QualityXpert to analyze process capability or track your supply chain.

To export an inspection report:

1. Balloon your drawing.
2. Click one of the following:
   - Export to Net-Inspect
   - Export to QualityXpert
3. In the dialog box, enter your credentials and click **OK**.
   - The inspection report is uploaded and a FAI number is generated.

### Horizontal and Vertical Report Formats

You can create inspection reports that are formatted vertically or horizontally without having to change the report format in Microsoft Excel.

In the horizontal report format, characteristics are listed in a column, and the properties of each characteristic (for example results, or inspection methods) are listed horizontally by row.

**To select the report format:**

1. Click SOLIDWORKS Inspection and select **Template Editor**.
2. In the dialog box, select a template and click **Open**.
3. In the SOLIDWORKS Inspection Template Editor dialog box, select one of the following:
   - Vertical Based Template
   - Horizontal Based Template
4. Complete other template editor selections, and click **Finished**.
Standalone SOLIDWORKS Inspection Enhancements

These features are available for standalone SOLIDWORKS Inspection.

Deleting Multiple Measurement Results
You can delete multiple measurement results at once instead of individually.

To delete multiple measurement results:
1. In the Measurements Input window, select multiple columns using the Ctrl and Shift keys.
2. Right-click the column header.
3. Click Delete.

Optical Character Recognition Editor
To make better use of optical character recognition, the Optical Character Recognition (OCR) Editor lets you create custom OCR dictionaries that quickly and accurately interpret the fonts and symbols you use. The OCR Editor lets you achieve better results and save time when you create inspection reports and drawings with balloons.

The OCR engine uses dictionaries to extract and interpret information from PDF or TIFF files. While the OCR performs relatively well with good quality drawings created by the majority of CAD software, the accuracy can drop significantly if the resolution is low, the font is not recognized, or the document has been scanned.

The OCR Editor lets you create from scratch and modify OCR dictionaries. You can open a PDF or TIFF document, manually select characters, and specify the correct value. When you finish defining characters, you can save the results as a new OCR dictionary. You can use this dictionary for your projects or share it with other members of your organization.

Creating a Custom OCR Dictionary
For best results, when you define characters, capture three to five iterations of the same character.

To create a custom OCR Dictionary:
1. Launch the SOLIDWORKS Inspection - OCR Editor by doing one of the following:
   - In the SOLIDWORKS Inspection main menu, click OCR Editor.
   - With a project open in SOLIDWORKS Inspection, on the Home tab, click Options. In the Options dialog box, on the Imaging/OCR page, click OCR Editor.
2. Click Add Drawing (Drawing toolbar).
3. In the Open dialog box, select a drawing file in .pdf, .tif, or .tiff format and click Open.
   The document you select opens in a viewing area.
4. Use the scroll bars and View tools to navigate to the characters to define.
5. Do one of the following:
   - Click Extract (General toolbar) to select one or more characters and define them manually.
Under **Extraction**, type the **Value** to use for the selected characters. You can use alphanumeric characters or symbols.

- Click **Auto Extract** to select one or more characters and have the software attempt to recognize them.

The value and coordinates of the selected characters are listed in the table below the viewing area.

If a value is incorrect, you can select it in the table and modify it manually.

**Optical Character Recognition for Custom Properties**

In the Project Properties dialog box, you can use optical character recognition to capture information for custom properties directly from documents.

Under **Custom Properties**, for each property, click **OCR** to initiate optical character recognition the same way as you do for non-custom properties such as **Part Name**, **Part Number**, or **Part Rev**.

**Specifying Export Results**

When you create a SOLIDWORKS Inspection report for a project with a large number of results, you can specify the results to export on the Measurements tab in the Export to Excel dialog box.

Choose from the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>All</strong></td>
<td>Exports all results to the report.</td>
</tr>
</tbody>
</table>
| **Results** | Exports the results you specify to the report. Enter result numbers and measurement result ranges, separated by commas. For example:  
- 1–10 exports the first 10 results.  
- 1–10,15,18 exports the first 10 results plus results 15 and 18. |
| **Last n** | Exports the last n results, where n is a number you specify. For example, if you type 10, the last 10 results are exported. |
SOLIDWORKS MBD is available as a separately purchased product that you can use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

This chapter includes the following topics:

- **3D PDF Improvements**
- **3D PDF Template Editor**
- **3D Views Tab Visibility**

### 3D PDF Improvements

Publishing to 3D PDF is enhanced:

- You can use the display styles **Shaded with Edges** and **Hidden Lines Removed**.
- You can export non-rotated decals and textures to 3D PDF, but you cannot have decals and textures on the same face.
- You can include projected views in the 3D PDF.
- You can include an independent viewport in the 3D PDF if the template contains one.

1. In the 3D PDF Template Editor, click **Independent Viewport** and place it in the template.
2. In the Publish to 3D PDF PropertyManager, select a view from **Independent Viewport**.

- You can include multiple BOMs in the 3D PDF, and you can select which columns to include in the BOM.

1. In the 3D PDF Template Editor, click **BOM Table** and place it in the template.
2. On page 2 of the Publish to 3D PDF PropertyManager, under **Output BOM Table**, select a BOM and columns to output.

Select **Exclude from annotation view** to hide the BOM from the primary viewport in the 3D PDF.
3D PDF Template Editor

**Generic Tables**

In the 3D PDF Template Editor, you can add generic tables to a template from existing SOLIDWORKS table templates.

**To add generic tables:**

1. In an open template in the 3D PDF Template Editor, click **Generic Table**.
2. In the Open dialog box, select a table and click **Open**.
   
   You can position and resize the table.

**Multiple BOMs**

In the 3D PDF Template Editor, you can add more than one BOM to a template. If there is more than one BOM, you can assign the table to a BOM in the original document or to follow the assembly order.

**To add multiple BOMs:**

1. In an open template in the 3D PDF Template Editor, click **BOM Table**.
   
   You can position and resize the table.
2. Repeat step 1 to add additional BOM tables.

**Multiple Viewports**

In the 3D PDF Template Editor, you can add more than one viewport to a template. You can project viewports from the primary viewport or the viewports can be independent and are assigned from the 3D PDF Publisher.

**To add more than one viewport to a 3D PDF template:**

In an open template in the 3D PDF Template Editor, click one of the following:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Independent Viewport</strong></td>
<td>Independent viewports do not depend on the original viewport or the 3D View Palette. Users control the viewport in the final PDF by right-clicking and selecting from the context menu or using mouse-controlled zooming and orientation.</td>
</tr>
</tbody>
</table>
### Adding PDF Sheets

In the 3D PDF Template Editor, you can add more than one PDF sheet to a template.

**To add more than one PDF sheet to a template:**

1. In an open template in the 3D PDF Template Editor, at the bottom of the window in the Tab area, click the **Plus** tab.

### Removing PDF Sheets

In the 3D PDF Template Editor, you can remove PDF sheets from a template.

**To remove PDF sheets from a template:**

1. In an open template in the 3D PDF Template Editor, at the bottom of the window in the Tab area, click **Remove Tab** in a tab.
2. In the Remove Tab dialog box, click **Yes**.

### 3D Views Tab Visibility

The 3D Views tab is visible to all users.

Previously, only MBD users could access the 3D Views tab. All users can now access the 3D Views tab when a model includes 3D views, and can activate any of the views. You must have an MBD license to capture, edit, or publish 3D Views.
Model Display

This chapter includes the following topics:

- **Callout Improvements**
- **Cartoon Rendering in RealView**
- **PhotoView 360 Rendering Improvements**
- **Parallel Tessellation When Regenerating Assembly Graphics**
- **Preserving Appearances with Derived Parts**
- **Section View Offset Options**

**Callout Improvements**

Improvements in callout placement and new callout features make callouts easier to use.

In previous versions of the SOLIDWORKS software, overlapping callouts in complex situations made reading and interacting with individual callouts difficult.

SOLIDWORKS 2016 places callouts with a minimum of overlap of leaders and callouts, making it easier to understand and manipulate complex input schemes.
When there are more than five visible callouts in the graphics area, a pushpin control appears with each callout to let you fix the position of the callout.

<table>
<thead>
<tr>
<th>Pushpin disabled</th>
<th>Pushpin enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Body 1, 2: discard</td>
<td>Body 1, 2: discard</td>
</tr>
</tbody>
</table>

When you zoom, rotate, or move the model, the callout is repositioned. When you zoom, rotate, or move the model, the callout remains in the same location in the graphics area. Other callouts move with the model.
When a callout for a feature such as an asymmetric fillet contains multiple values, a control below the callout lets you expand it to see all values or collapse it to see the primary value:

<table>
<thead>
<tr>
<th>Callout collapsed</th>
<th>Callout expanded</th>
</tr>
</thead>
</table>

**Cartoon Rendering in RealView**

You can turn on cartoon rendering in OpenGL and RealView to provide a cartoon-like effect on edges and faces.

Cartoon rendering lets you add a non-photorealistic cartoon-like effect to your RealView models.

**To turn on cartoon rendering in RealView:**

1. Turn on RealView by doing one of the following:
   - Click **View > Display > RealView**.
   - In the Heads-up View toolbar, expand **View Settings** and click **RealView**.
2. Turn on cartoon rendering by doing one of the following:
   - Click **View > Display > Cartoon**.
   - In the Heads-up View toolbar, expand **View Settings** and click **Cartoon**.

The behavior of the **Cartoon** option depends on whether PhotoView 360 is enabled.
Changing Cartoon Settings with PhotoView 360

If you have PhotoView 360 added in when you select Cartoon, the behavior of the Cartoon tool is linked to the Contour/Cartoon Rendering settings in the PhotoView 360 PropertyManager.

When you select Cartoon, a screen message tells you that turning on Cartoon will enable the Cartoon rendering option in PhotoView 360.

To change cartoon settings with PhotoView 360:

1. With a model open, click Tools > Add-In and add in PhotoView 360.
2. Click PhotoView 360 > Options.
3. Expand Cartoon/Contour Rendering.
   
   Cartoon/Contour Rendering is already selected because you selected Cartoon.

4. Optionally, specify a line thickness and edit the line color.
5. Select one of the following:

   ![Render only with cartoon edges](image1)

   ![Render with cartoon shading](image2)
Changing Cartoon Settings Using Model Display Options

If PhotoView 360 is not added in, you can control cartooning behavior by changing the Document settings in the Options dialog box that control color and line thickness in the model display.

**To change cartoon settings using model display options:**

1. In the Heads-up View toolbar, expand **View Settings** and click **RealView** and **Cartoon**.
2. Click **Tools > Options > Document Properties > Model Display**.
3. To change the color of cartoon edges, under **Model/feature colors**, select **Cartoon edges** and click **Edit**.
4. For cartoon edge thickness, type or select a value between one and six pixels.
5. Click **OK**.

The image shows the result of selecting blue as the cartoon edge color and two as the thickness.
PhotoView 360 Rendering Improvements

Access to Perspective Views for Renderings
When you prepare to do a final rendering without a perspective view or a camera with perspective enabled, a dialog box prompts you to add a camera or turn on perspective view.

More realistic renderings are produced with perspective view turned on or with a camera with perspective enabled. Earlier versions of the SOLIDWORKS software detected the absence of perspective settings and displayed a recommendation to switch views or enable a camera with perspective. With SOLIDWORKS 2016, this message is replaced with a task dialog box that lets you:

- **Add a Camera**
  Cancels the current rendering and opens the **Camera PropertyManager** to let you add a camera.
  To continue rendering using the camera, click **Preview Window**, **Integrated Preview**, or **Final Render**.

- **Turn on Perspective View**
  Turns on perspective view and lets you continue with the rendering.

- **Continue without Camera or Perspective**
  Continues the current rendering without turning on perspective or adding a camera.

Adding Motion Blur to Animations
When you save an animation, you can use motion blur to simulate the dynamic blurring effect of a static image of a moving object.

Because objects must be moving to create the blurring effect, this final rendering effect is coupled with the SOLIDWORKS MotionManager. You can add motion blur to an animation or extract a single frame that shows the motion blur from a motion study.

Including Annotations and Dimensions in Final Renderings
You can include dimensions and annotations in a final PhotoView 360 rendering if they are currently visible in a part or assembly.

In relation to the image in the SOLIDWORKS graphics area, the final rendered dimensions and annotations:

- Are proportionally the same.
- Are in the same relative position.
- Show the same text, symbols, and leaders.

**To include annotations and dimensions in final renderings:**

1. Do one of the following:
   - Click **PhotoView 360 > Schedule Render**.
In the Schedule Render dialog box, select **Render visible annotations and dimensions**.

To create an additional .png file that contains just the annotations and dimensions, select **Save annotations to a separate image**.

- Click **PhotoView 360 > Final Render**.

A dialog box appears with options for including dimensions and annotations.

Select **Include Dimensions and or Annotations in the final rendering** to bypass the Final Render dialog box and immediately save the preview image using the Saving Image dialog box.

Select **Render without Dimensions and or Annotations** to open the Final Render dialog box to make detailed adjustments to your render before saving the image. The dimensions and annotations visible in the graphics area are not rendered.

If you choose to render dimensions and annotations, the Rendering Annotations progress bar reports that model information is being transferred to PhotoView 360.

2. When the rendering is complete, click **OK**.

The rendered image includes the dimensions and annotations.

---

**PhotoView 360 Lighting Control Through Proof Sheets**

PhotoView 360 proof sheets let you select lighting settings by viewing the effects of a range of settings in a series of proof sheets. Each image represents a different setting for your primary PhotoView 360 lighting.

Rendering brightness, background brightness, and scene reflectivity are controlled by the PhotoView 360 Scene Illumination Proof Sheet, a dialog box that lets you quickly see a wide range of variations of these parameters.

The proof sheet lets you experiment with primary PhotoView 360 lighting variations. You cannot use proof sheets to change the settings of physical lights (point, spot, or directional lights) that are on in PhotoView 360.
To open a PhotoView 360 Scene Illumination Proof Sheet:

Do one of the following:

- Click PhotoView 360 > Proof Sheet.
- On the DisplayManager tab, click View Scene, Lights, and Cameras, then right-click PhotoView 360 Lights and click Scene Illumination Proof Sheet.
- On the Render Tools CommandManager or Render Tools toolbar, click Scene Illumination Proof Sheet.

The proof sheet contains sets of thumbnail renderings. On the left, the thumbnails show the results of decreases in rendering brightness, background brightness, and scene reflectivity. On the right, they show increases in these values. By default, three columns of thumbnails appear on each side. A Number of columns control lets you increase or decrease the number of columns.

In the center, you can toggle between two larger thumbnails, one showing the original illumination and the other your selected illumination combination.

When you hover over a thumbnail, a tooltip shows the radiance for the setting.

By default, the radiance increases by 0.2 W/srm^2 as you move from left to right.

You can control the amount of increase by moving the Increment slider from Fine toward Coarse.
Below the illumination thumbnails, if you select **Change the Position of Lights and Shadows (slower)**, two sets of environment rotation thumbnails let you spin the environment around the center of the scene floor. Use these controls if you need to move the lighting or reflections from the environment image to another location as seen in the PhotoView 360 rendering.

Changes to environment rotation cannot happen in real time. As a result, enabling environment rotation disables editing of the illumination properties. It is recommended that you work on one set of properties at a time – the three illumination properties or the environment rotation – and not jump back and forth between them.

**Parallel Tessellation When Regenerating Assembly Graphics**

The SOLIDWORKS software uses multicore CPU technology to reduce the time it takes to regenerate the graphics display of large assemblies.

Instead of processing components individually, all of the bodies of every component that need to be retessellated are gathered together, allowing parallel tessellation of longer lists of bodies.

Some examples of places where this processing method improves performance are:

- Opening files when out of date components must be updated
- Regenerating assembly features when multiple components are affected
- Creating sectioned bodies
- Patterning multiple components

For best performance, click **Tools > Options > Document Properties > Image Quality**. Under **Shaded and draft quality HLR/HLV resolution**, select **Apply to all reference part documents**.

Only components with the same image quality can be processed together.

**Preserving Appearances with Derived Parts**

If you split a part, you can preserve the appearances that are applied to the bodies that are created when you save the bodies or when you insert the bodies into new parts.

You can also preserve the appearance of a part that you insert into another part.

If a body you save or insert has an appearance at the body level, the software translates the appearance as a body-level appearance in the newly created file. If the original body has an appearance at the face or feature level, the software translates the appearance as a face-level appearance.

The saved or inserted parts are derived parts. If you change an appearance in the original part, the change is propagated to the derived part.

You cannot preserve the appearances of parts when you mirror components to create new opposite-hand version files.
To preserve an appearance when you save a body:
1. In a part, create a sketch to be used to split the part into bodies.
2. Click Split (Features toolbar) or Insert > Features > Split.
3. In the PropertyManager, under Trim Tools, select the sketch and click Cut Part.
4. Under Resulting Bodies, do one of the following:
   - Click Auto-assign Names to have the software name all the bodies automatically.
   - Select the bodies to save under and double-click each body to assign a name.
5. Click Propagate visual properties.
   The newly created bodies will have the same appearances as the base part.
   If you do not select the option, the newly created bodies do not have any appearances.
6. Set options in the PropertyManager and click ✓.

To preserve an appearance when you insert a body into a part:
1. In a split part, expand the Solid Bodies folder.
2. Right-click the part to insert and click Insert into New Part.
3. In the PropertyManager, under Transfer, click Browse (...) to browse the location for the new part, type a File name, and click Save.
4. Click Propagate visual properties.
5. Click ✓.

To preserve the appearance of a part when you insert it into another part:
1. With a part open, click Insert > Part.
2. In the Open dialog box, locate the part to insert and click Open.
3. In the PropertyManager, under Visual Properties, click Propagate from original part.
4. Click in the graphics area to position the inserted part.

Section View Offset Options
When you create a section view in a part or assembly, the view offset can be perpendicular to the reference plane or perpendicular to the currently selected plane.

In the Section View PropertyManager, under Section Options, you can switch the Offset Method between Reference Plane and Selected Plane.

All values you input for the offset distance are calculated based on your selection. The direction of the translation arrow in the graphics area is updated accordingly:
- When you select Reference Plane, values are calculated normal to the currently-oriented section plane.
- When you select Selected Plane, values are calculated normal to the plane you select in Section 1 in the PropertyManager.

By default, when you open the Section View PropertyManager, Reference Plane is selected. The view offset, as shown by the triad arrow, is perpendicular to the plane selected in Section 1; in this case, the front plane:
If you rotate the section plane and leave Reference Plane selected, the view offset remains perpendicular to the plane:

If you change the Offset Method to Selected Plane, the view offset is calculated perpendicular to the selected plane, in this case, the front pane:
This chapter includes the following topics:

- **Create ANSI Inch Holes with FeatureWorks and Direct Editing**
- **Curvature Continuous Edge Fillets**
- **Dynamic Preview for Intersect and Trim Surface Tools**
- **Maintain Hole Wizard Settings When Changing Type**
- **Options for Modifying Geometry with the Intersect Tool**
- **Patterns**
- **Reference Geometry**
- **Surfaces**
- **Sweep**
- **Thread**
- **Toggling the Visibility of Bodies**

Create ANSI Inch Holes with FeatureWorks and Direct Editing

When you import a part and run FeatureWorks or Direct Editing, and set measurement units to ANSI inch, all holes are created in ANSI inch.

In previous releases, FeatureWorks automatically converted holes to metric units when you selected the **Recognize holes as wizard holes** option in the **Advanced Controls** page. Direct Editing also automatically created holes in metric units even if the template was set to ANSI inch.

Curvature Continuous Edge Fillets

You can define the edges of constant and variable fillets as curvature continuous. This option creates a smoother curvature between adjacent surfaces.

Previously, this option was only available for face fillets.
1. Open `install_dir\samples\whatsnew\parts\c2edgefillet.sldprt.
2. Select the edge shown.
3. Click `Fillet` (Features toolbar) or `Insert > Features > Fillet/Round`.
4. In the PropertyManager, under `Fillet Type`, click `Constant Size Fillet`.
5. Under `Items To Fillet`, select `Tangent Propagation` and `Full preview`. 
6. Under **Fillet Parameters**:
   a) Select **Symmetric** in the drop-down list.
   b) Set **Radius** to 40 mm.
   c) In **Profile**, select **Curvature Continuous**.

![Fillet Parameters Diagram]

7. Click ✔.

![Dynamic Preview for Intersect and Trim Surface Tools]

**Dynamic Preview for Intersect and Trim Surface Tools**

The **Intersect** and **Trim Surface** tools provide a set of preview options that make it easier to navigate and remove regions in a model.

The **Preview options** in the PropertyManagers let you select regions and exclude them in the graphics area. The preview dynamically updates as you work through the model to access the regions you need. As a result, there is less clutter in the graphics area and no overlapping regions.

If you need to revert to a region that is excluded, you can add the region back to the model by clicking **Invert Preview**.

Previously, you could only select regions from the PropertyManagers which made it difficult to identify the regions you wanted to remove.
For the **Intersect** tool 🔄, click **Insert > Features > Intersect**. For the **Trim** tool 🎨, click **Insert > Surface**. Then in the Trim PropertyManager, under **Trim Type**, select **Mutual Trim**.

### Removing Regions with Intersect Tool
This example walks you through the preview options for the **Intersect** tool.

**To remove regions with the Intersect tool:**

1. Open `install_dir\samples\whatsnew\parts\junction_box.sldprt`.

2. Click **Intersect** 🔄 (Features toolbar) or **Insert > Features > Intersect**.

3. In the PropertyManager, do the following:
   a) From the flyout FeatureManager design tree, select **Shell 1, Extrude-Thin1** and **Extrude-Thin2** for **Solids, Surfaces, or Planes to Intersect**.
   b) Click **Create Both** and click **Intersect**.
   The software populates the **Regions List**.

4. Under **Preview Options**, click **Show included and excluded regions**.

5. In the graphics area, select an inner pipe.

The highlighted pipe is removed from the preview. The region corresponding to the pipe is also selected in the **Region List**.
6. In **Region List**, select **Region 14** and **Region 15**.
   The pipes highlight in the preview.

7. In the graphics area, select all the pipes inside the shell until they disappear in the preview.

![Image](image1.png)

8. In the Property Manager, under **Preview Options**, click **Show excluded regions**.

![Image](image2.png)

9. Click **Show both included and excluded regions**.

![Image](image3.png)

10. Click **Invert Selection**.

![Image](image4.png)

11. Click ✔.
Maintain Hole Wizard Settings When Changing Type

Hole Wizard settings are retained when you edit a Hole Wizard feature and change a hole or slot type. You can also maintain holes that have had custom sizing applied or reset new hole types to the default values.

Click Hole Wizard (Features toolbar) or Insert > Features > Hole Wizard.

Options for Modifying Geometry with the Intersect Tool

The Intersect PropertyManager includes three options that make it easier to create and modify geometry.

The options are:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create intersecting regions</td>
<td>Displays the selections, and creates and displays regions that intersect each other.</td>
</tr>
<tr>
<td>Create internal regions</td>
<td>Creates and displays internal regions from enclosed (hollow) volumes within the intersection of the selections.</td>
</tr>
<tr>
<td>Create both</td>
<td>Displays the selections, and creates and displays intersecting regions, and the internal (hollow) regions.</td>
</tr>
</tbody>
</table>

In previous releases, defining a part that included only the internal regions required removing all of the intersecting regions one at a time. The new Create internal regions option simplifies this task and allows you to measure properties, such as the internal volume, more easily.

To measure internal volume:

1. Open install_dir\samples\whatsnew\parts\pot.sldprt.

2. In the FeatureManager design tree, select Shell1 and Plane6.

3. Click Intersect (Features toolbar) or Insert > Features > Intersect.
4. In the PropertyManager, click Create internal regions and click Intersect.

5. Click ✓.

Two solid bodies are added to the FeatureManager design tree. Intersect[1] is the newly created region. Intersect[2] is the original model.

6. In the FeatureManager design tree, select Intersect[1]. Then in the CommandManager, on the Evaluate tab, click Mass Properties.


Patterns

More Inputs for Linear Patterns

You can specify more inputs to define the vector for Direction 1 and Direction 2 in part and assembly feature linear patterns.

In the Linear Pattern PropertyManager, you can use planar faces and surfaces, conical faces and surfaces, circular edges, and reference planes as inputs for Direction 1 and Direction 2.

Previously, you could only define a linear edge, sketch line, axis, or linear dimension as input.

Click Linear Pattern (Features toolbar) or Insert > Pattern/Mirror > Linear Pattern.

No Limit on Number of Instances

There is no upper limit on the number of instances in a pattern. You can enter any number of instances.

When you create a pattern with a large number of instances, a dialog box prompts you to confirm or revise the number. Patterns with a large number of instances tend to impact performance.

This feature applies to all patterns in parts, features, and assemblies.
Pattern Table Enhancements for Variable Patterns

To access the pattern table:

1. Click Variable Pattern (Feature toolbar) or Insert > Pattern/Mirror > Variable Pattern.
2. In the PropertyManager, click Create Pattern Table for new parts or Edit Pattern Table for existing parts.

Importing Data from Microsoft Excel

You can import data into variable patterns from Microsoft Excel .xls, .xlsx, and .xlsm file types. Microsoft Excel overwrites any existing data.

If the Microsoft Excel file contains driving dimensions, you no longer have to select the driving dimensions from the graphics area.

With the pattern table open, click Import from Excel.

You can also import data from a specific sheet in the Excel file. With the pattern table open, click Import from Excel and select the Excel file to import. Then click the Sheet: drop-down list, and select the sheet.

Exporting Data to Microsoft Excel

You can export data from variable patterns into Excel *.xls, *xlsx, and *.xlsm file types.

With the pattern table open, click Export from Excel.

Interface Improvements for Equation-driven Instances

Instance dimensions controlled by an equation are read-only in the pattern table for variable patterns because you cannot modify original equations by changing values in a pattern table.

Icons indicate which cells contain values that are equation-driven, link-driven, or linked equation-driven. Tooltips display the equations.

If you delete rows of data that include values that are controlled by an equation, or if you copy or cut and paste those rows, a message warns that you might need to fix missing references in the equation. If you try to paste data into cells whose values are controlled by an equation, a message informs you that those values are read-only.

Support for Zero and Negative Values

You can enter zero and negative values for many types of dimensions in the Pattern Table dialog box and from the graphics area. Zeroes and negative values are accepted for dimensions that allow them when editing the feature or dimension.

Entering a negative dimension for a feature dimension, such as a blind depth or revolve angle, causes the instance to reverse direction. The effect is equivalent to using Reverse button in the feature’s PropertyManager.
Reference Geometry

The names and labels for points, axes, and coordinate systems now respect the settings *Always display text at the same size* and *Text scale*.

**To set fonts for names and labels for points, axes, and coordinate systems:**

1. With a model open, click **Tools > Options > Document Properties > Detailing**.
2. Under **Point, Axis, and Coordinate System**, set options:
   - **Hide names**: Hides reference geometry names for points, axes, and coordinate systems.
   - **Name font**: Sets the font for the names of points, axes, and coordinate systems.
   - **Label font**: Sets the font for the labels of coordinate system arrows.
3. Click **OK**.

**Planes Parallel to Screen**

You can create a reference plane that is parallel to the screen without using the Plane PropertyManager.

Right-click a face in the graphics area and click **Create a Plane Parallel to Screen**. The software adds an **On Plane** or **On Surface** 3D sketch point where you right-clicked and positions a reference plane parallel to the screen at that point.

The sketch point may move if the surface moves. To ensure that the sketch point does not move, set its position relative to other geometry.

In the previous release, you could only create a plane parallel to the screen at a reference vertex.

**Reusing Absorbed Reference Curves**

You can select and reuse all reference curves in a model. Previously, you could only use absorbed reference curves in the feature for which they were created.

Projected curves, composite curves, curves through XYZ points, curves through reference points, helixes, and spirals cannot be absorbed by a feature. They appear in the FeatureManager design tree where they can be referenced by any feature.

When you open a file created with a previous version of the software that contains absorbed curve features, the position of those features are changed in the FeatureManager design tree so that they can be referenced by other features in the FeatureManager design tree.
Converting a Surface into a Solid

You can convert boundary surface and trim surface features into solid features using a **Create Solid** option, provided the surface features can create a closed volume from the inputs.

The **Create Solid** option was formerly called the **Try to form solid** option. In previous releases, you had to knit the surface manually before you could convert the surface into a solid.

To convert a boundary surface into a solid, click **Insert > Surface > Boundary Surface**, and in **Options and Preview**, click **Create solid**.

To convert a trim-surface feature into a solid, click **Insert > Surface > Trim Surface** and in **Surface Split Options**, click **Create solid**.

Flatten Surface Enhancements

The **Flatten** tool provides more control and more variations of surfaces that can be flattened. You can flatten any face, surface, or set of faces with internal geometries such as holes or extruded cuts.

You can select curves and sketches on the surface to flatten. You can also select curves, sketches, and edges on the surface to be relief cuts or split lines. When you select these entities in the graphics area or the FeatureManager design tree, they display in the Flatten PropertyManager.

**To flatten a surface:**

1. In an open part, click **Flatten** (Surfaces toolbar) or **Insert > Surface > Flatten**. The Flatten PropertyManager displays.
2. Select faces in the graphics area or from the FeatureManager design tree.
3. Then select a vertex. A preview of the flatten surface appears.
4. In the Property Manager, click **Relief Cuts**.

You can select curves or sketches as cuts to relieve stress in the flattened surface. In this example, the sketch entities are perpendicular to the edge.

You can also choose to include relief cuts or not.
5. You can transpose additional sketch entities, curves or lines to a flattened surface. However, you cannot modify the sketch in a flattened surface feature. To use the entities in other sketches, use the **Convert Entities** tool.

6. To add a deformation plot, right-click the flattened surface in the graphics area and select **Deformation Plot**.
Sweep

Sweep Redesign
The workflow and interface for all sweep features has improved.
Controls, group boxes, and options have been rearranged and updated to accommodate enhancements which include the ability to create bidirectional sweeps and to choose between two types of profiles, Sketch Profile and Circular Profile.

Sketch Profile is similar to existing functionality where you create a sweep by moving a 2D sketch profile along a 2D or 3D sketch path, but it provides more options. Circular Profile lets you create a sweep directly on a model without having to work in a sketch.

These changes impact the PropertyManagers for the features. You can access these PropertyManagers from:

- Swept Boss/Base (Features toolbar) or Insert > Boss/Base > Sweep
- Swept Cut (Features toolbar) or Insert > Cut > Sweep
- Swept Surface (Surfaces toolbar) or Insert > Surface > Sweep

Creating a Bidirectional Sweep
You can create sweeps for a mid-path profile in either direction or the entire path using Bidirectional.

You can also control the twist value of the path independently for each direction of the sweep and apply the twist value over the entire length. However, you cannot use guide curves or set the start and end tangency for a bidirectional sweep.

The bidirectional option is available for swept boss/base, swept cut (except for swept cuts using the solid sweep option), and swept surface parts. It is also available for swept cut assemblies.

To create a bidirectional sweep:

1. Open install_dir\samples\whatsnew\parts\notebook.sldprt

2. Click Insert > Boss/Base > Sweep.
3. In the PropertyManager, under **Profile and Path**, click **Sketch Profile** and do the following:
   a) In the flyout FeatureManager design tree, select **Sketch8** for **Profile** and select **Helix/Spiral1** for **Path**.
   b) Click **Direction 1** and **Direction 2** to toggle the direction of the sweep.
   c) Click **Bidirectional**.
      The sweep runs in both directions.

4. Under **Options**, do the following:
   a) For **Profile orientation**, click **Follow Path**.
   b) For **Profile twist**, click **None**.

   You can specify the twist for each end of the sweep independently and apply the twist angle for the entire path.
Show preview and Merge result are selected by default.

5. Click ✓.

Creating Rods and Tubes with a Circular Profile

You can use the Circular Profile option to create a solid rod or hollow tube along a sketch line, edge, or curve directly on a model without having to sketch. This sweep is available for Swept Boss/Base, Swept Cut, and Swept Surface features.

To create a circular profile sweep:

1. Open install_dir\samples\whatsnew\parts\sweep_part_1.sldprt.

2. Click Insert > Cut > Sweep to cut a tube into the part.

3. In the PropertyManager, under Profile and Path, click Circular Profile.
4. In the graphics area, select a curved edge for **Path**. Then set the **Diameter** to **50.00mm**.

   In the PropertyManager, under **Options**, **Show preview** and **Align with end faces** are selected by default.

   ![Path](image)

5. Click ✓.

   The **Cut-Sweep** feature appears in the FeatureManager design tree.

6. Click **Insert > Boss/Base > Sweep** to add the solid rod.
7. In the PropertyManager, under **Profile and Path**, click **Circular Profile**.
8. In the graphics area, select the bottom edge of the part for **Path**.
9. In the PropertyManager set **20.00 mm** for **Diameter**.

   **Show preview** and **Merge result** are selected by default.

10. Click ✓.

   ![Sweep](image)

   The **Sweep** feature appears in the FeatureManager design tree.
Thread

You can create helical threads on cylindrical faces using profile sketches. You can store custom thread profiles as library features.

Using Thread, you can define the start thread location, specify an offset, set end conditions, specify the type, size, diameter, pitch and rotation angle, and choose options such as right-hand or left-hand thread.

Setting Thread Profiles Location

Before starting a custom thread, add the location of the thread profiles in System Options.

1. Click Options or Tools > Options > System Options > File Locations.

   The default directory is C:\ProgramData\SolidWorks\SOLIDWORKS YYYY\Thread Profiles.

2. Under Show Folders for, select Thread Profiles.
3. Set the file location and click OK.

Creating a Cut Thread

1. Open install_dir\samples\whatsnew\parts\custom_thread.sldprt.

2. Click Insert > Features > Thread.
3. In the graphics area, select the top edge of the cylinder.
4. In the PropertyManager, under **Specification**:
   a) In **Type**, select **metric die**.
   b) Set **Size** to **M6x1.0**.

   The color of the preview varies depending on **Color Scheme Settings** in System Options, under **Temporary Graphics, Remove Material** and **Add Material**.

5. Under **Thread Location**:
   a) Click **Offset**.
   b) Click **Reverse Direction**.
   c) Set **Offset Distance** to **1.00mm**.

6. Under **End Condition**, click **Maintain Thread Length**.
   The thread profile updates from 10 to 11 millimeters in length.

7. Click ✔.
Toggling the Visibility of Bodies

You can toggle the visibility of solid and surface bodies by moving the pointer over the body in the graphics area and clicking **Tab** to hide or **Shift + Tab** to show.

In addition, you can show one or more hidden bodies by moving the pointer to the graphics area, and pressing and holding **Ctrl + Shift + Tab**. Hidden bodies will temporarily display as transparent and can be changed to show by clicking them.

To assign other keyboard shortcuts to these actions, click **Tools > Customize**.
SOLIDWORKS PDM Standard is a new product based on SOLIDWORKS Enterprise PDM. It is included with SOLIDWORKS Professional and SOLIDWORKS Premium.

SOLIDWORKS PDM Professional is the name of the product previously called SOLIDWORKS Enterprise PDM. It is available as a separately purchased product.

This chapter includes the following topics:

- Installation Changes for SOLIDWORKS PDM
- Modifying Custom Properties of PDFs Using PDF Plug-in (For SOLIDWORKS PDM Professional only)
- Reference Handling for Moved or Renamed Files
- Rename a File in SOLIDWORKS FeatureManager Design Tree
- Resize Thumbnail Previews of SOLIDWORKS Files in Tables
- SOLIDWORKS PDM Standard
- Sorting Columns in Tables
- Synchronizing a Revision Variable to a Revision Number
- Using Windows Search for Content Search

Installation Changes for SOLIDWORKS PDM

You can install SOLIDWORKS PDM Standard or SOLIDWORKS PDM Professional using:

- SOLIDWORKS Installation Manager (SLDIM)
- SOLIDWORKS PDM InstallShield Wizard

Recommendation: Use SLDIM to install SOLIDWORKS PDM Standard or SOLIDWORKS PDM Professional.

You must install the SolidNetWork License Manager separately.

The installations of the SOLIDWORKS PDM clients and the SOLIDWORKS PDM servers are separate.

You can select a product type based on the license available. The following add-ins specific to the product type are available.
### Client | Product types and add-ins
--- | ---
SOLIDWORKS PDM Standard | SOLIDWORKS PDM CAD Editor
• SOLIDWORKS
• DraftSight
SOLIDWORKS PDM Contributor
• DraftSight
SOLIDWORKS PDM Viewer: No add-in

SOLIDWORKS PDM Professional | SOLIDWORKS PDM CAD Editor
• Microsoft Office Integration
• SOLIDWORKS
• DraftSight
• Autodesk Inventor
• AutoCAD
SOLIDWORKS PDM Contributor
• Microsoft Office Integration
• DraftSight
SOLIDWORKS PDM Viewer
• Microsoft Office Integration

---

**Installing Using the SOLIDWORKS Installation Manager**

If you install using the SOLIDWORKS Installation Manager, the following options are available:

- **Individual** install
  
  **SOLIDWORKS PDM Standard** is preselected on the Product Selection page.

  For SOLIDWORKS PDM Standard, you must install SQL Express before installing the SOLIDWORKS PDM database server. You can either install SQL Express or point to your existing SQL Express database.

  If you have a license for SOLIDWORKS PDM Professional you can install **Item Explorer**.

- **Administrative image**
  
  If your organization uses the SOLIDWORKS Administrative Image Option Editor, you can create and deploy the administrative image for SOLIDWORKS PDM simultaneously with other SOLIDWORKS products.

- **Server products**
  
  For SOLIDWORKS PDM Professional, run the installation with **Server products** selected to install the SolidNetWork License Manager, the archive server, and the database server, if these are on the same machine, or run the installation separately on two different machines to install these servers.
Installing Using the SOLIDWORKS PDM InstallShield Wizard

After you install and configure the SolidNetWork License Manager using the SOLIDWORKS Installation Manager, you can install SOLIDWORKS PDM using the SOLIDWORKS PDM InstallShield Wizard in these ways:

- SOLIDWORKS PDM Standard client or SOLIDWORKS PDM Professional client
  
  For new installations, SOLIDWORKS PDM Standard is preselected. You can change it to SOLIDWORKS PDM Professional.

  Based on the license available and the product type you select, different add-ins are available.

  If you select SOLIDWORKS PDM Professional, the Customize option appears. This option lets you install Item Explorer.

- SOLIDWORKS PDM Standard server or SOLIDWORKS PDM Professional server

  For SOLIDWORKS PDM Standard server, on the Server Installation page, the following options are available:
  
  - Archive Server
  - Database Server

  For new installations, these options are preselected. For upgrades, the previous selections are retained.

  For SOLIDWORKS PDM Professional server, on the Server Installation page, the following options are available:
  
  - Archive Server
  - Database Server
  - Web Server
  - Web2

  For new installations, no option is preselected. For upgrades, the previous selections are retained.

Modifying Custom Properties of PDFs Using PDF Plug-in

(For SOLIDWORKS PDM Professional only)

SOLIDWORKS PDM Professional lets users read or write custom properties of PDFs using the PDF plug-in.

The PDF plug-in also maps any user-defined custom properties that are written in the Custom tab of a PDF. Previously, there was no read or write support of PDF custom properties for SOLIDWORKS PDM variables.

An administrator can map a variable to a supported Block name and Attribute name for a PDF. When a user adds a PDF to a vault and updates custom properties in the PDF, the updated custom properties appear on the PDF file data card. Similarly, when a user updates variable values on the PDF file data card, the mapped property values are updated in the PDF.
**Property Mappings**

<table>
<thead>
<tr>
<th>Block name</th>
<th>Attribute name</th>
</tr>
</thead>
<tbody>
<tr>
<td>CustomProperty</td>
<td>TITLE</td>
</tr>
<tr>
<td>CustomProperty</td>
<td>AUTHOR</td>
</tr>
<tr>
<td>CustomProperty</td>
<td>SUBJECT</td>
</tr>
<tr>
<td>CustomProperty</td>
<td>KEYWORDS</td>
</tr>
<tr>
<td>CustomProperty</td>
<td>PART NUMBER</td>
</tr>
<tr>
<td>CustomProperty</td>
<td>DESCRIPTION</td>
</tr>
</tbody>
</table>

The attribute, **FILE**, that represents the filename is read-only. The value is only read from the PDF.

**Mapping Custom Properties to PDF Cards**

This example describes how to map the variable Title to the custom property TITLE.

**To map custom properties to PDF cards:**

1. In the Administration tool, right-click **Variables** and click **New Variable**.
2. In the dialog box, create a variable named **Title**.
3. Click **New Attribute**.
4. Under **Selected attribute**:
   a) For **Block name**, select **CustomProperty**.
   b) For **Attribute name**, type **TITLE**.
   c) Type the file extension that contains the property.
      For example: pdf.
5. Click **OK**.
6. In the Card Editor, open the **PDF Card**.
7. Add an edit box and for **Variable name** select the new **Title** variable.
8. Save the card and close the Card Editor.

When a user adds a PDF to the SOLIDWORKS PDM vault, the PDF file data card shows the **Title** variable. User can read/write the custom property Title to the PDF file data card.

**Reference Handling for Moved or Renamed Files**

When you have files in the local cache that contain references, the SOLIDWORKS PDM add-in warns you if another user moves or renames the references.

Previously, if you opened a cached parent file with a referenced component that was moved or renamed by another user, the SOLIDWORKS software would open the cached file without a warning.
Now, you receive the warning:

- When you have a SOLIDWORKS file open in read-only mode and another user moves or renames references.

In the Task Pane, the SOLIDWORKS PDM add-in adds a question mark next to the names of the modified files and the add-in displays a warning message.

Do the following:
1. In the Task Pane, click the link to see details of the moved or renamed files.
2. Close and re-open the files.

The SOLIDWORKS software repoints the references to the latest file location and displays a message that files have been renamed or moved and that the references have been updated.

- When another user has moved or renamed references for a SOLIDWORKS file that is in your local cache and you open the cached parent file.

The SOLIDWORKS software automatically updates the references and displays a message that files have been renamed or moved, and that the references have been updated.

## Rename a File in SOLIDWORKS FeatureManager Design Tree

You can rename a file in the SOLIDWORKS FeatureManager design tree.

Before a user can rename a file:
- The user must load the SOLIDWORKS PDM add-in.
- The administrator must set Add or rename file permission for State Permissions and Folder Permissions.
- The user must check out the component and its referencing assembly on the same machine.

A warning message appears if any of the above conditions is not met.

In the SOLIDWORKS FeatureManager design tree, if you try to rename a component with the same name as an existing file, the duplicate filename warning appears.

This warning appears only if the administrator selects Do not allow duplicate file names in this vault in the Administration tool.

## Resize Thumbnail Previews of SOLIDWORKS Files in Tables

You can resize thumbnail previews of SOLIDWORKS files using Change Thumbnail Preview Size.

SOLIDWORKS PDM lets you select the size of thumbnail previews as Small, Medium, or Large. By default, Medium is selected. When you select the size in one table, SOLIDWORKS PDM sets the same size in applicable tables and on tabs.
To resize the thumbnail previews:

1. Right-click in the file list.
2. Click **Change Thumbnail Preview Size** and select the size to use.

The thumbnail previews for non-SOLIDWORKS files may not be clear when you select **Medium** or **Large**.

**Warning Icons and Background Colors in the SOLIDWORKS PDM Task Pane**

You can turn off individual warning icons and background colors that appear in the SOLIDWORKS PDM Task Pane.

**To turn off the warning icons and background colors in the SOLIDWORKS PDM Task Pane:**

1. In the SOLIDWORKS software, click **SOLIDWORKS PDM > Options > View Setting**.
2. Under **Status**, clear the check boxes for the warning icons and its background colors to suppress.

**SOLIDWORKS PDM Standard**

SOLIDWORKS PDM Standard is a document management product based on the same architecture as SOLIDWORKS Enterprise PDM.

You can upgrade from SOLIDWORKS PDM Standard to SOLIDWORKS PDM Professional without migrating files or data because SOLIDWORKS PDM Standard is based on the same architecture as SOLIDWORKS PDM Professional. However, you cannot downgrade a SOLIDWORKS PDM Professional vault to a SOLIDWORKS PDM Standard vault.

One license of SOLIDWORKS PDM Standard CAD Editor is included with each license of SOLIDWORKS 2016 Professional and SOLIDWORKS 2016 Premium. Licenses for non-CAD users are available as separately purchased products.

SOLIDWORKS PDM Standard uses the SolidNetwork License Manager and requires a serial number. Serial numbers for Beta testing are available to all eligible SOLIDWORKS 2016 customers. Contact your SOLIDWORKS Value Added Reseller (VAR) to obtain serial numbers.

This table shows the functionalities of each license:

<table>
<thead>
<tr>
<th>Functionality</th>
<th>SOLIDWORKS PDM Standard CAD Editor</th>
<th>SOLIDWORKS PDM Standard Contributor</th>
<th>SOLIDWORKS PDM Standard Viewer</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLIDWORKS add-in</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add and edit SOLIDWORKS files</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Integrated preview for SOLIDWORKS files</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>
This table shows differences between SOLIDWORKS PDM Standard and SOLIDWORKS PDM Professional:

<table>
<thead>
<tr>
<th>Functionality</th>
<th>SOLIDWORKS PDM Standard</th>
<th>SOLIDWORKS PDM Professional</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLIDWORKS add-in</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>eDrawings Professional</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>DraftSight add-in</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Microsoft Office add-in</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>AutoCAD add-in</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Inventor add-in</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>CAD Editor client</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Contributor client</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Functionality</td>
<td>SOLIDWORKS PDM Standard</td>
<td>SOLIDWORKS PDM Professional</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>Viewer client</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Multiple workflows</td>
<td>Limited to 1</td>
<td>✓</td>
</tr>
<tr>
<td>Workflow States</td>
<td>Limited to 10</td>
<td>✓</td>
</tr>
<tr>
<td>Parallel Approvals</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Offline mode</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Transition actions</td>
<td>✓ (Limited)</td>
<td>✓</td>
</tr>
<tr>
<td>eDrawings preview</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Multi-document preview</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>External Viewer Integration</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Templates</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Serial Numbers</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Content search (indexing)</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Integrated search tool</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Dedicated search tool</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Search favorites</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Active directory and LDAP login</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Notifications - PDM inbox (database)</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td>Notifications - email (SMTP)</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Functionality</td>
<td>SOLIDWORKS PDM Standard</td>
<td>SOLIDWORKS PDM Professional</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>--------------------------</td>
<td>----------------------------</td>
</tr>
<tr>
<td>SQL Server Express support</td>
<td>✓</td>
<td></td>
</tr>
<tr>
<td>SQL Standard support</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Automated tasks</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Automated data import/export</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>API</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Custom add-in support</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Dispatch</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Item support</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Web client</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Multi-site replication</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Report generator</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Revision schemes</td>
<td>Limited to 2</td>
<td>✓</td>
</tr>
<tr>
<td>File categories</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Version labels</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Named Bill of Materials</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Paste shared links</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Menu and toolbar customization</td>
<td></td>
<td>✓</td>
</tr>
<tr>
<td>Version free variables</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>
### Sorting Columns in Tables

You can sort the default and custom columns in tables in ascending, descending, or default order by clicking column headers. Column sorting is useful within large datasets. Column sorting is available in all dialog boxes and on all tabs.

If you sort a column in ascending or descending order, the column is highlighted in green and an arrowhead appears.

#### Sorting Order in Columns

You can sort the default and custom columns in tables in ascending, descending, or default order by clicking column headers.

Sorting sequence for ascending order:

<table>
<thead>
<tr>
<th>Column heading</th>
<th>Sorting sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td></td>
</tr>
<tr>
<td>Assemblies</td>
<td></td>
</tr>
<tr>
<td>Drawings</td>
<td></td>
</tr>
<tr>
<td>Parts</td>
<td></td>
</tr>
<tr>
<td>Other (alphabetical by file type)</td>
<td></td>
</tr>
<tr>
<td><strong>File Name</strong></td>
<td>Alphanumeric</td>
</tr>
<tr>
<td><strong>Warnings</strong></td>
<td>Alphabetical</td>
</tr>
<tr>
<td><strong>Copy or Move</strong></td>
<td>Turned off</td>
</tr>
<tr>
<td>Turned on</td>
<td></td>
</tr>
<tr>
<td><strong>Version</strong></td>
<td>Cached value</td>
</tr>
<tr>
<td>If the cached values are equal, the software uses the vault values.</td>
<td></td>
</tr>
<tr>
<td><strong>Checked Out By</strong></td>
<td>Alphabetical</td>
</tr>
<tr>
<td><strong>Checked Out In</strong></td>
<td>Alphabetical</td>
</tr>
</tbody>
</table>
### Table Control Settings and Sorting Behavior

When you sort a column in a table, SOLIDWORKS PDM removes the file structure hierarchy. Sorting turns off **Show Tree Lines** and **Show Reference Selection Control**.

Previously, **Open File List** or **Save File List** gave results for the entire list. Now, SOLIDWORKS PDM considers filters you have applied and column sorting and lets you display all files or only the visible files.

**Open File List** includes options to open the list of files in Microsoft Excel:

- Open All
- Open Visible

Similarly, **Save File List** includes options to export the list of all files or only the visible files:

- Export All
- Export Visible

### Synchronizing a Revision Variable to a Revision Number

Administrators can map a revision variable in the workflow to synchronize it with a revision number.

Previously, to set a revision number, users had to perform an increment revision.
Now, using **Set Revision** you can synchronize a revision number to a revision value stored in a card variable, for any files including those that were previously managed outside of SOLIDWORKS PDM.

**To synchronize a revision variable to a revision number:**

1. In the Administration tool, expand **Workflows** and select a workflow.
2. Select a state.
3. On the Revision Numbers tab, set a revision number to associate with this state.
4. For **Increment by**, enter the number (typically 1) to use when the **Set Revision** command is invoked.
5. Select a revision variable in **Revision Variable**.

   - This variable must exist on the data cards of files that will have the revision synchronized.
   - The variable should be linked to the custom property holding the legacy revision value.
   - The revision number must match the revision value found in the variable for the revision to become synchronized.

6. Click **OK**.
7. Click **File > Save** to save the workflow.

To verify synchronizing the revision number, manually set the revision number on a file in SOLIDWORKS PDM Explorer View. For details, see *SOLIDWORKS PDM File Explorer Help*.

**Set Revision Enhancements**

In the File Explorer, the Increment Revision dialog box has been renamed to Set Revision and redesigned to improve usability.

To display this dialog box, select a file and click **Modify > Set Revision**.

In the dialog box:

<table>
<thead>
<tr>
<th><strong>Set Revision</strong></th>
<th>Lets users select a file to set its current revision to the value that they select in the <strong>New Revision</strong> column.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Current Revision</strong></td>
<td>Displays the current revision of a file.</td>
</tr>
<tr>
<td><strong>New Revision</strong></td>
<td>By default, displays the next revision of a file. You can select a new revision for the file based on the revision scheme set on the state. When users select a revision from the list, the row is highlighted in yellow, with the modified text shown in blue and bold. The revision displayed on the <strong>Data Card Variable</strong> is flagged with <strong>On Card</strong>.</td>
</tr>
<tr>
<td><strong>Data Card Variable</strong></td>
<td>Displays the value of the revision variable that is written on the data card.</td>
</tr>
</tbody>
</table>
Using Windows Search for Content Search

SOLIDWORKS PDM uses the Windows Search service to perform content searches.

Previously, SOLIDWORKS PDM content search used the Microsoft Indexing Service. Because Microsoft does not support the Indexing Service for Windows 8 or Windows Server 2012 operating systems, SOLIDWORKS PDM uses the Windows Search service to support content search.

Administrators can choose an indexing method, Indexing Service, or Windows Search. Administrators of upgraded systems can still use the Indexing Service, while administrators of new systems that have not been previously indexed should use Windows Search.

To use the Windows Search for Content Search:

- The administrator must configure the Windows Search service and index a file vault archive folder.
- The file vault archive folder that is being indexed must be:
  - On the same machine as the configured Windows Search service.
  - Accessible to the Windows Search service to build a system index.
- If the file vault archive folder is on a different machine than an SQL server:
  - The administrator must share the file vault archive folder.
  - The logged in user running the SQL server service must have full permission to the shared folder.

When the Windows Search service builds the system index, the administrator can set up SOLIDWORKS PDM to use the system index.

Setting Up Windows Search

Configuring the SOLIDWORKS PDM Professional Content Search to use Windows Search requires installing the Windows Search Service, adding the archive folder path to the indexing settings, and indexing the file vault archives.

To set up Windows Search:

1. In the Administration tool, log into the file vault to be indexed as SOLIDWORKS PDM user with Can update index settings permissions.
2. Right-click Indexing and click Open.
3. In the Indexing Settings dialog box, select Index File Vault Archives.
5. Under Archive Locations, double-click the archive path to configure index locations.
6. In the Edit File Vault Archive Folder Path dialog box, type a path to a file vault archive folder from the SQL server.

- If the Archive server is on a different machine than the SQL server, enter a UNC path to the archive folder share.
- The archive folders must be accessible on locally attached storage or SAN storage on the archive server machine.

7. Click **OK** twice.

For details, see *SOLIDWORKS PDM Installation Guide: Installing Windows Search Service*. 
SOLIDWORKS Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS Plastics Premium are available as separately purchased products that can be used with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

This chapter includes the following topics:

- **Runner Domain**
- **Solver Performance**
- **Report Template**
- **User Interface**

### Runner Domain

In addition to the cavity, mold, and insert domains, a new category for a runner domain is available. You can assign a runner domain to the solid CAD components which are part of a runner system.

You can assign a runner domain to a part you mesh with solid elements.

In the Solid-Mesh Manual PropertyManager, when you set the domain type, select **Runner**.

![Runner Domain Image]

### Solver Performance

The Flow and Warp analysis solvers are improved. A new solver, which is based on the CICSAM (compressive interface capturing scheme for arbitrary meshes) method for flow front tracking, is the default Flow solver for plastic injection molding analysis.

Solver performance enhancements include:

- A new option for a Flow solver for flow front tracking. In the Fill Settings PropertyManager, click **Options**. Select **CICSAM** for **Volume of Fluid Algorithm**.
- A quadratic mesh option is added for the Warp solver.
In the Warp Settings PropertyManager, click **Options**. In the Modify Calculating Parameters of WARP dialog box, select **High quality mesh (Quadratic)** for more accurate warp analysis results.

- Option to control the solver CPU number. In **Settings and Help** (Plastics CommandManager), set the **Solver CPU Number** from 1 to the maximum available core processors on your computer.

**Report Template**

The report template is enhanced for improved readability.

The report template includes these sections:

- Introduction
- Model Information
- Material Properties
- Process Parameters
- Flow, Pack, Cool, and Warp Results
- X-Y Plots
- Conclusion

You can publish the report in Microsoft Word format. You can select one of the available MS Word document templates, or create a custom template (*.dot, *.dotx).

1. Right-click **Summary and Report**. Select **MS Word**, and click **Generate**.
2. In the Report Generator dialog box, on the Template tab, select a MS Word template to apply: **Classic**, **Light**, or a custom template.

**User Interface**

An updated user interface conforms to the SOLIDWORKS software user interface for improved usability.

The CommandManager is updated to contain the most commonly used commands for SOLIDWORKS Plastics.
Routing

Available in SOLIDWORKS Premium.

This chapter includes the following topics:

- CommandManager and Menu Updates for Rectangular Ducting
- Using Auto Route for Rectangular Section Routing
- Flex Cables
- General Quality Enhancements
- Support for Elbows and Pipes in the Pack and Go Route Assembly
- Route Wires through Electrical Ducts and Cable Tray
- Coverings for Rectangular Section Routes and Ducts

CommandManager and Menu Updates for Rectangular Ducting

When you work with user defined route types for rectangular and circular cross sections, and ducting, you can access functionality from the User Defined tab in the CommandManager or from Tools > Routing > User Defined.

From the tab or menu, you can access frequently used commands, such as:

- Start by Drag/Drop
- Start at Point
- Add Fitting
- Add Point
- Edit Route
- Route Properties

Shortcut menus have also been implemented for user defined route types. Right-click a route assembly, connector, fitting, or sketch entity to display a list of actions.
Using Auto Route for Rectangular Section Routing

You can use the **Auto Route** tool for creating **Rectangular** section routing for **Cable Trays**, **Electrical Ducting**, **HVAC**, and others using rectangular routes. **Auto Route** is available only for orthogonal routes and not flexible routes in rectangular section routing.

You can create routes by selecting one of the following in the **Auto Route** **PropertyManager**:

- **Auto Route**
- **Edit** (drag)
- **Manual sketch**

You can perform the following in **Auto Route** mode:

- Select **Alternate paths** in the Auto Route PropertyManager to view valid alternate orthogonal routes.
- **Edit** (drag) to modify the routes.
- **Manual sketch** to sketch a route manually.

Flex Cables

You can route single strip flex cables between two connectors as part of electrical routes from **Tools > Routing > Electrical > Start at Point** and selecting **Flex Cable** as the subroute type. You can also drag and drop a flex cable component into a route assembly.

In the Connection Point PropertyManager, you can set the cable thickness, cable width, alignment direction, and stub length.

The **Flex Cable** support is built on the existing **Ribbon Cable** functionality. The From-To List functionality is not available for flex cables.

Creating Flex Cable Routes

To create flex cable routes:

1. Insert the first flex cable connector into the assembly.
   The following occurs:
   - A 3D sketch opens in a new route subassembly.
   - The new route subassembly is created, and appears in the FeatureManager design tree as **[Flex cablen-assembly_name]**.
   - A stub of flex cable appears, extending from the connector you just placed.
2. Insert the second flex cable connector.

All sketch tools are available when you create and edit flex cable routes. To use the sketch tools, open the flex cable assembly and right-click in the graphics area. You can add or delete segments, and add or delete dimensions.

3. Define the path of the flex cable with **Auto Route**:
   a) In the Auto Route PropertyManager, under **Routing Mode**, select **Auto Route**.
   b) Select the point at the end of the route stub on the first connector.
   c) Select the point at the end of the route stub on the second connector.

   The software creates a route between the two connectors.
4. To modify the twists in the cable, under **Auto Route**, select **Edit** (drag), and then drag the construction lines on the spline.

When Auto Route is disabled, you can modify the twists in the cable by clicking on the triad manipulators available on the route path at the base of the construction line. You can extend the route using Z axis and add twist by rotating the ring in the triad manipulator.

5. You can optionally do one of the following:
   - Add flat bends in the routes by inserting a line at an angle, in the same plane.
   - Set the cable thickness, cable width, alignment direction, and stub length in the Connection Point PropertyManager.

6. Click ✓.
   The 3D sketch closes. The following appear in the FeatureManager design tree of the route subassembly:
   - **Components** folder. Contains the connector parts you placed in the route.
   - **Route Parts** folder. Contains the cable that was created as a virtual component when you exited the sketch.
   - **Route** feature. Contains the 3D sketch that defines the path of the cable.
To edit an existing route, right-click it and click **Edit Route**.

**General Quality Enhancements**

**Flattening**

- When you modify the position of a flattened length annotation with the **Drawings** tool, make changes in the 3D route, and return to the flattened length annotation, the position remains the same as the user-defined position. Previously, when the position of the flattened length annotation was manually modified and changes were made in the 3D route, the annotations would move back to the previously defined position.

- When you modify the position of a **Connector Table** with the **Drawings** tool in an assembly, make changes in the 3D route, and return to the **Connector Table**, the position remains the same as the user-defined position. Previously, when the position of the **Connector Table** was manually modified and changes were made in the 3D route, the **Connector Table** would move back to the previously defined position.
Piping

- With the Change Route Diameter tool, you can change the route of the diameter for the routes which are created on the fly.
- You can view the Pipe Length in notes and custom properties of a piping route. You can view the Pipe Length in the Bill of Materials in a drawing.
- You can design spools faster by selecting only one part of an assembly to be part of the spool and not the whole assembly.
- In the Angle command of the Pipe Slope PropertyManager, you can provide angular dimensions as inputs for slope values.

Mates Tool

You can reposition connectors or fittings in an assembly by using the Mates tool. The alignment sketch relations associated with stubs of connectors and fittings are removed to avoid overdefined or unsolvable sketch conditions. The sketch constraints are added back to the sketch, wherever necessary.

Support for Elbows and Pipes in the Pack and Go Route Assembly

Pipe and elbow components are included in Pack and Go without having to use SOLIDWORKS add-ins or SOLIDWORKS Explorer.

The route segment pipe and elbow component templates are included in Pack and Go even if the Routing add-in is not enabled.

You can use Pack and Go through Windows File Explorer or SOLIDWORKS Explorer.
Route Wires through Electrical Ducts and Cable Tray

You can route wires, cables and harness through Cable Tray and Electrical Duct.

Creating a Route for Connectors through Cable Tray

To create routes for connectors through a cable tray:

1. Click **New > Assembly** and click **Save**.
2. To start route, insert the following into the main assembly by clicking **Insert Component** (Assembly toolbar) or by dragging them from the Design Library, the File Explorer, an open part window, or Windows Explorer:
   a) Cable tray fittings to create cable tray assembly.
   b) Electrical connectors at openings of the cable tray.

3. Set options in the Route Properties PropertyManager, then click **✓**.
   The new route subassembly appears in the FeatureManager design tree as **[CableTray <n>-<assembly_name>]**.

   If the order of the steps is reversed in step 2 above, the name of the new route subassembly is **[Harness <n>-<assembly_name>]**.
4. Sketch the path between components on each side and the **CPoint** of the **Cable Tray** using any combination of the following methods:
   - Use **Auto Route** to generate splines.

   ![Sketch diagram]

   - Sketch lines \( \backslash \), splines \( \backslash \) and fillets \( \backslash \) using 3D sketch tools.

   Electrical Routes are generated from the connector’s endpoint and the cable tray’s **CPoint**.

   To make the connection points visible, click **View Routing Points** (View toolbar) or **View > Routing Points**.

5. Drag additional connectors and routing hardware into the route subassembly as needed.

   As each connector is added to the route, a short stub is added to the sketch (from the connector’s **CPoint**).

6. To assign electrical attributes to the route segments:
   a) Click **Tools > Routing > Electrical > Edit Wires**.
   b) Specify the wires and cables to use.
   c) To specify the route path, do one of the following:
      - Select the route segments between connectors on both sides of the **Cable Tray**.
      - In **Wire From-To List**, click **Select Path**.

      The route path between connectors is automatically identified.

   d) Click ✅.

7. Exit the sketch.

   You can use the same procedure to create routes for connectors with **HVAC** ducts.
Coverings for Rectangular Section Routes and Ducts

You can create coverings for rectangular cross section route types including HVAC round ducting and electrical ducting.

From **Tools > Routing > Routing Tools > Covering** you can:

- Select the covering material from the covering library.
- Create a custom covering.
- Set parameters like thickness and covering name.
- Add multiple layers of covering.
This chapter includes the following topics:

- **Cuts in Swept Flanges**
- **Edge Flanges**
- **Using Flattened Mass**

**Cuts in Swept Flanges**

If you use a swept flange with cuts in the bend area, the cuts are mapped correctly to flatten geometry.

Model with swept flange

<table>
<thead>
<tr>
<th>Flattened in SOLIDWORKS 2016</th>
<th>Flattened in SOLIDWORKS 2015</th>
</tr>
</thead>
</table>
Edge Flanges

You can create edge flanges that are longer than the edge to which they are attached.

**To create an edge flange that is longer than its adjoining edge:**

1. Open `install_dir\samples\whatsnew\sheetmetal\bracket.sldprt`.
2. Click **Edge Flange** (Sheet Metal toolbar) or **Insert > Sheet Metal > Edge Flange**.
3. Select the edge shown.

4. In the PropertyManager, under:
   a) **Flange Length**, set to **Length** to 40.
   b) **Flange Parameters**, click **Edit Flange Profile**.

5. In the graphics area, drag each vertical sketch segment so they extend beyond the adjoining sheet metal edge approximately as shown.

6. In the Profile Sketch dialog box, click **Finish**. The edge flange is added to the part.
Using Flattened Mass

For sheet metal parts, you can choose Flattened-Mass in the Cut-List Properties and Summary Information dialog boxes. Flattened mass is calculated based on the model's flat pattern.

In previous releases, only Mass was available, which corresponded to the folded mass.

**To use flattened mass:**

1. Open `install_dir\samples\whatsnew\sheetmetal\enclosure.sldprt`.
2. Click **File > Properties**.
3. In the dialog box, select the Custom tab.
4. In row 1 of the table, set the following:
   a) **Property Name**: Weight
   b) **Type**: Text.
   c) **Value / Text Expression**: Mass.
      The **Evaluated Value** is 2071.551.
   The **Evaluated Value** changes to 2071.599.
6. Click **OK**.
SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional and SOLIDWORKS Simulation Premium are available as separately purchased products that can be used with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

This chapter includes the following topics:

- Blended Curvature-based Mesher
- Automatic Bonding for Shells
- Bolts and Pins on the Same Part
- Controlling Values and Display of Maxima and Minima on Contour Plots
- Detecting Underconstrained Bodies
- Display Results for Remote Mass and Remote Load
- Equation-driven Results
- Improved Solver Error Messages
- Releasing Prescribed Displacements
- Report Publish Options
- Sectioning the Mesh

Blended Curvature-based Mesher

An alternate curvature-based mesher is available. The new mesher uses improved algorithms that provide a high-quality surface mesh.

In the Mesh PropertyManager, select **Blended curvature-based mesh**.

With the blended curvature-based mesher, you can attempt to mesh models that failed to mesh with the standard or curvature-based mesher.

For the global mesh settings, the same options you specify for the curvature-based mesher are available for the blended curvature-based mesher: **maximum element size**, **minimum element size**, **minimum number of elements in a circle**, and **element size growth ratio**.

For local mesh control settings (Mesh Control PropertyManager), you specify: **maximum element size**, **minimum element size**, and **minimum number of elements in a circle**.

The local mesh control settings for the **maximum element size** and **minimum element size** should be within the range of values you specify for the global mesh settings.

The blended curvature-based mesh is not supported for h-adaptive and p-adaptive options for static studies.
Automatic Bonding for Shells

The Global component contact algorithm is enhanced to detect non-touching edges of shells within a maximum gap distance.

The improved functionality of detecting all pairs of shell edges-to-shell edges and shell edges-to-shell faces within a certain gap distance eliminates the manual definition of bonded contact sets, especially for models with many shells.

In the Component Contact PropertyManager, select Bonded for Contact Type, and select Include shell edge - solid/shell face and pairs (Slower).

The program creates automatically edge-to-edge bonded contact sets for pairs of shell edges within a certain gap distance set in Maximum Clearance. The valid pairs of edges belonging to shell or sheet metal bodies are:

- A pair of straight, parallel, and non-interfering shell edges (or almost parallel within one degree of tolerance).
- A pair of circular edges that have the same radius and are concentric and non-interfering.
- A pair of shell edge (straight or arc) to a shell face (planar or cylindrical).

Mid-surface shells from sheet metal plates with a gap due to welding. Bonded contact is detected for the pair of parallel shell edges within the specified distance.

Bonded contact is detected for the pair of circular concentric shell edges within the specified distance.
Bolts and Pins on the Same Part

Bolt and pin connectors can start and end on the same body.

When defining a pin or bolt connector, you can select geometric entities that define the start and end of the connector from the same body. For example, circular edges of the bolt head and bolt nut, or cylindrical faces for a pin belong to the same body.

These bolt connectors can start and end on the same part:

- Standard or counterbore with nut
- Countersink with nut
- Standard or counterbore screw
- Countersink screw
### Controlling Values and Display of Maxima and Minima on Contour Plots

You can control independently the maximum and minimum values of Simulation results in contour plots (automatic or defined status). You can pick a color that is different from the default color range to display results that fall outside the customized limits you define. The Chart Options PropertyManager has new options that customize the maximum and minimum limits on result plots independently, and control the color contours of results.

<table>
<thead>
<tr>
<th>Description</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Automatically defined maximum value</strong></td>
<td>Picks the maximum limit on the contour plot as calculated by the software. Clear this option to set a customized maximum value for the contour plot.</td>
</tr>
<tr>
<td><strong>Specify color for values above maximum value</strong></td>
<td>Applies the selected color (set in 📊) to regions of the model with result values above the maximum value set in Max 📊. For improved visibility of the contour plot, you can pick a color outside the default color range of the chart plot. If you do not specify a color for Specify color for values above maximum value, a grey color is applied by default.</td>
</tr>
<tr>
<td><strong>Automatically defined minimum value</strong></td>
<td>Picks the minimum limit on the contour plot as calculated by the software. Clear this option to set a customized minimum value for the contour plot.</td>
</tr>
<tr>
<td><strong>Specify color for values below minimum value</strong></td>
<td>Applies the selected color (set in 📊) to regions of the model with result values below the minimum value set in Min 📈.</td>
</tr>
</tbody>
</table>
Displacement plot shown with automatically defined maximum and minimum values.

Displacement plot shown with minimum value set to 2.0 mm in Min. Regions of the model with displacement results below 2 mm are shown in grey color selected in .
Detecting Underconstrained Bodies

You can analyze the contacts and boundary conditions of bodies to verify that bodies are sufficiently constrained. You can view animations of the model based on the active degrees of freedom, and identify bodies that are under constrained before you run a simulation.

To detect unconstrained bodies:
In a static study, open the Contact Visualization Plot PropertyManager, and click the Underconstrained bodies tab.

The enhanced algorithm detects the active degrees of freedom (DOF) for each body, and helps you visualize the parts in a model that exhibit translational or rotational rigid body modes.

Click Calculate to detect bodies that are not sufficiently constrained, and exhibit translational or rotational rigid body modes. The analysis tool applies a coarse mesh and runs the static study (using the Direct Sparse Solver) with all defined loads, contacts, and boundary conditions.

If the analysis tool detects bodies that can translate or rotate freely exhibiting rigid body modes, it lists these bodies and the directional active degrees of freedom (translations and rotations) under Underconstrained bodies.

Select one of the listed degrees of freedom (for example, Translation 1 or Rotation 1) to view an animated translation of the under constrained body. A green arrow in the graphics area points to the direction of free movement.

If no rigid bodies are detected, the solver issues a message that the model is fully constrained.

The Underconstrained bodies tool does not detect any instability issues for models containing no penetration contacts, or bolt connectors. Bodies with bolt connectors and no penetration contacts can be sufficiently constrained for a successful simulation, but they are shown in the list of underconstrained bodies.

Display Results for Remote Mass and Remote Load

For linear dynamic studies, you can plot response graphs at the center of gravity of a body that is treated as a remote mass, or at a point where you apply a remote load or remote mass.

Run a linear dynamic study (time history, harmonic, or random vibration) where you treat a body as a remote mass, or you define a remote load or remote mass as an external load.

In the Response Graph PropertyManager, click At remote locations. The list includes these bodies that are treated as remote masses, and nodes where you apply a remote load or remote mass.

You can plot response graphs of acceleration, velocity, or displacement components as a function of frequency (harmonic and random vibration studies), or as a function of time (modal time history studies). You can plot a maximum of six response graphs on the same plot.

The program displays the results at the center of gravity of a body that is treated as a remote mass.
Equation-driven Results

You can create new Simulation result plots that are defined with equations using standard mathematical functions of existing result variables.

To create an equation-driven result plot, right-click Results and click Results Equations.

In the Edit Equation dialog box, enter the equation that drives the new result plot. The drop-down menu lists available mathematical functions and result variables you can enter in the equation field.

<table>
<thead>
<tr>
<th>Node Values</th>
<th>Combines result components based on nodal values.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element Values</td>
<td>Combines result components based on element values.</td>
</tr>
<tr>
<td>Functions</td>
<td>Lists the acceptable mathematical functions to include in the equation.</td>
</tr>
<tr>
<td>Stresses, Strains, Displacements</td>
<td>Filters acceptable result components to include in the equation.</td>
</tr>
</tbody>
</table>

Enter a legend for the plot and the applicable units in Legend title text.

The Results Equation Plot is available for static, linear dynamic, thermal, drop test, submodeling, and pressure vessel studies. You can only combine result variables from the active study.

Improved Solver Error Messages

Error messages issued by the solver are improved with a hyperlink that directs you to the right solution article in the SOLIDWORKS Knowledge base.

For the most common error messages encountered when running a Simulation study, a hyperlink connects you to the appropriate solution stored in the SOLIDWORKS Knowledge base to help you troubleshoot the errors issued by the solver.

You need to have access to the SOLIDWORKS Customer Portal to access the SOLIDWORKS Knowledge base.

Releasing Prescribed Displacements

You can activate and deactivate prescribed displacements at selected time steps in nonlinear studies.

Available with a SOLIDWORKS Simulation Premium license.
To release a prescribed displacement at a specific time step in a nonlinear study:

1. Apply a prescribed displacement to selected geometric entities (faces, edges, or vertices).
2. In the Fixture PropertyManager, under **Variation with Time**, click Curve.
3. For the time steps you want to remove the prescribed displacement, in the Time curve dialog box, click the down arrow in the Y column cell and select Off.

For example, type these curve data values to turn off the prescribed displacement for the time steps between the 0.3 seconds to 0.6 seconds range.

<table>
<thead>
<tr>
<th>Points</th>
<th>X</th>
<th>Y</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>0</td>
<td>3</td>
</tr>
<tr>
<td>2</td>
<td>0.3</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>0.4</td>
<td>Off</td>
</tr>
<tr>
<td>4</td>
<td>0.6</td>
<td>2</td>
</tr>
<tr>
<td>5</td>
<td>0.8</td>
<td>3</td>
</tr>
<tr>
<td>6</td>
<td>1</td>
<td>5</td>
</tr>
</tbody>
</table>

Report Publish Options

You can select the paper size to print a Simulation report.

For **Paper size** (Report Options dialog box), select an option to print a Simulation study report:

- **Letter (8.5” x 11”)**
  - Prints the report on a Letter (8.5 in. x 11 in.) paper size.

- **A4 (8.27” X 11.69”)**
  - Prints the report on a standard A4 (297 mm x 210 mm) paper size.
Sectioning the Mesh

The mesh sectioning tool lets you section the mesh and view internal mesh elements in Simulation studies.

You can check the quality of the internal mesh and make adjustments to mesh settings before running the study. You can also view the edges of the mesh elements that are clipped by a section plane when sectioning result plots.

You can create a mesh sectioning plot from a mesh quality plot or a results plot. You can check the quality of internal volume filling elements before you run the study.

After you create the mesh, and before you run the study, right-click a mesh quality plot and click **Mesh Sectioning**.

To view a mesh sectioning plot superimposed on a result plot, right-click an active result plot and click **Mesh Sectioning**.

In the Mesh Section PropertyManager, select a reference plane or cylinder for the orientation of the mesh section plane. You can dynamically position the mesh section plane in the graphics area. The distance dynamically updates as you move the pointer along the reference axis.

To view the edges of the elements that are clipped by the section plane select **Show mesh edge**.

Mesh sectioning of a mesh aspect ratio plot
This chapter includes the following topics:

- **Cap Ends for Offset Entities**
- **Converting Entities with Internal Loops**
- **Equal Curve Length Parametric Relations**
- **Instant2D for Changing Sketch Dimensions**
- **Preselection of Entities for Smart Dimensioning**
- **Reversing Sketch Offsets**
- **Segment Tool**
- **Selecting Midpoints with Dynamic Highlighting**
- **Show or Hide Sketch Dimensions**
- **Style Spline Support for B-Splines**
- **Unmerging Sketch Endpoints with Detach Segment on Drag**
- **Improvement in Large Sketch Performance**

**Cap Ends for Offset Entities**

You can create cap ends while using the **Offset Entities** tool to offset open loop, one-directional sketch entities in 2D sketches, for arc and line **Cap end** types.

Previously you could only use cap ends on bi-directional offsets.

To access cap ends and **Offset geometry**, select a sketch entity and click **Tools > Sketch Tools > Offset Entities**. 

Preview of capped offset entities
Complete capped offset entities

**Construction Geometry for Offset Entities**

You can create offset geometry as construction geometry while using the **Offset Entities** tool.

Previously, you could only convert the base geometry to construction geometry.

To access **Base geometry** and **Offset geometry** construction geometry options, select a sketch entity and click **Tools > Sketch Tools > Offset Entities**.

**Construction Geometry option for Offset geometry**

**Construction Geometry for Base geometry and Offset geometry**
Converting Entities with Internal Loops

You can convert an entity's internal loops or entities of a model face automatically with the Select all inner loops option of the Convert Entities tool.

Previously, you had to select the internal loops of an entity one by one with the Convert Entities tool.

Equal Curve Length Parametric Relations

You can apply equal curve length relations between any two entities such as a line, spline, arc, or circle, depending on the type of entity.

You can still use the equal $=\,$ relation to make the lengths of line segments equal. You can use the equal curve length $\equiv\,$ relation for adding relations between a circle and an arc, two circles, or two arcs. You can also use the equal curve length relation for adding relations between a line and a circle, a circle and a spline, and a spline and a line.

When you use these relations:

- You can create relationship pairs for each set of relations that adhere to all existing logic for creation, display, and deletion.
- Two or more homogenous entities can have the relations applied to them at the same time.
- You can apply the equal curve length relation to a projected curve and another entity, except for another projected curve.
- The equal curve length relation is applicable within a 2D or 3D sketch.
- Relations are hidden in the graphics area when you clear View > Hide/Show > Sketch Relations.
- You can create a fixed spline when you select a spline and any other sketch entity.

You can access these relations from the Sketch Relations context toolbar, the Add Relations PropertyManager.
Instant2D for Changing Sketch Dimensions

You can use **Instant2D** to dynamically manipulate sketch dimensions in sketch mode. You can click a dimension and quickly edit its values without clicking **Rebuild** to reset the geometry.

With the enhanced **Instant2D**, you can:

- View the dimension handles or **Instant2D Rulers** while selecting dimensions in sketch mode.
- Edit dimensions for any dimension type in the dimension input value box by clicking a dimension value.

**Instant2D** in sketch mode is available for 2D and 3D sketches.
Preselection of Entities for Smart Dimensioning

You can preselect sketch entities, then use the **Smart Dimension** tool to add dimensions to the entities.

Previously, you had to click **Smart Dimension** prior to selecting entities.

Reversing Sketch Offsets

You can reverse the direction of offset sketch entities with the **Reverse Direction** functionality.

Previously, you had to delete or recreate sketches to change the direction of the entities.

To reverse sketch offsets:

1. In the Dimension Property Manager, under **Primary Value**, click ▼.
2. Double-click the offset dimension of a sketch entity. In the Modify dialog box, do one of the following:
   - Click ▼.
   - Insert a minus sign before the existing dimension value.
3. Right-click the offset dimension and click **Reverse Direction**.

Segment Tool

**Arc and Circle Segments**

You can use the **Segment** tool to create equal length segments in arcs and circles.

In an open sketch of an arc or circle, click **Segment** (Sketch toolbar) or **Tools > Sketch Tools > Segment**. In the Property Manager, under **Segment Parameters**, select **Sketch segments**.

When you use the **Sketch segments** option on arcs or circles, an **Equal Length** relation is applied to the sketch segments.
**Equidistant Relations**

When you use the **Segment** tool in lines, arcs, or circles, an equidistant relation is applied to the sketch points.

The equidistant relation creates space between the sketch points on the line, arc, or circle. If you drag or resize the line, arc, or circle, the sketch points automatically adjust to remain equidistant along the segment.

Deleting any of the equidistant relations in a sketch point group deletes the entire relations group. After deleting an equidistant relation, the sketch points remain in their previous locations with a coincident relation to the entity onto which they were placed.

**Editing Sketch Points**

You can change the number of sketch points you created with the **Segment** tool. Previously, you had to delete the points and use the **Segment** tool again.

**To edit sketch points:**

1. Open a sketch on which you previously used the **Segment** tool.

   ![Sketch](image)

   You must have created the sketch in SOLIDWORKS 2016 or later.

2. Right-click an **Equidistant** relation icon and click **Edit Segment Points**.

3. In the PropertyManager, edit the **Number of Instances** and click ✓. The sketch updates with the specified segments.

**Deleting Sketch Points**

If you delete a sketch point created with the **Segment** tool, the remaining points update to maintain equal spacing along the sketch entity.

**To delete sketch points:**

1. Open a sketch on which you previously used the **Segment** tool to create sketch points.

   ![Sketch](image)

   You must have created the sketch in SOLIDWORKS 2016 or later.

2. Delete a sketch point. The spacing for the remaining sketch points adjusts so the points remain equidistant to each other along the sketch entity.
Selecting Midpoints with Dynamic Highlighting

You can dynamically highlight and select midpoints on sketch entities and model edges to add relations. You can also dynamically highlight and select midpoints of sketch entities while dimensioning in sketches.

Previously, you could only select midpoints of model edges while dimensioning using Select Midpoint from the shortcut menu. However, on selection of a second midpoint on another entity, the first entity was cleared.

To select midpoints with dynamic highlighting:

1. Hover over a midpoint on a sketch entity or model edge. The entity and its midpoint are highlighted.
2. Select the midpoint.

Selecting midpoints with dynamic highlighting is only available for lines, arcs, and model edges in sketch mode.
Show or Hide Sketch Dimensions

You can show or hide 2D and 3D sketch dimensions with the **View Sketch Dimensions** functionality.

Previously, only 3D sketch dimensions were hidden when you turned off **View Sketch Dimensions**.

Click **View > View Sketch Dimensions** or click **View Sketch Dimensions** in **Hide/Show Items** (Heads Up View toolbar).

**View Sketch Dimensions** is available only for parts and assemblies.

Style Spline Support for B-Splines

You can create B-Splines of 3°, 5°, or 7° with the **Style Spline** tool. You can adjust the smoothness of the curve by manipulating the degree of the curve.

Previously, you could only create a Bezier curve with the **Spline** tool. When converting a spline into a **Style Spline**, many unusable points were created, making it difficult to work with.

You can have one-to-one conversion from a Spline to a **Style Spline** since the resulting **Style Spline** will now be a degree 3 B-Spline.

Click **Tools > Sketch Entities > Style Spline**. In the Insert Style Spline Property Manager, select from options **B-Spline Degree 3**, **B-Spline Degree 5** and, **B-Spline Degree 7**.
The minimum points required to create 3º, 5º, and 7º B-Splines are 4, 6, and 8 respectively.

**Unmerging Sketch Endpoints with Detach Segment on Drag**

You can unmerge sketch entity endpoints with **Detach Segment on Drag**.

Previously, with **Detach Segment on Drag**, you could drag any sketch entity and detach it from other entities, but you could not detach an entity at just one endpoint.

**To unmerge sketch endpoints with Detach Segment on Drag:**

1. Open any sketch with segments or closed spline endpoints.
2. Right-click the entity to detach and click **Detach Segment on Drag**. The endpoints change to a different color when you select the entity with merged points.
3. Drag the endpoint to the desired location.
4. Right-click the entity and clear **Detach Segment on Drag**.
Improvement in Large Sketch Performance

The performance of large sketches is improved for the following sketch options on the shortcut menu:

- Drag
- Scroll
- Zoom
- Pan
- Suppress
This chapter includes the following topics:

- Editing Multiple Configurations of a Toolbox Component
- Replacing Toolbox Components
- Toolbox Add-in Name Changes
- Toolbox Data Import and Export
- Toolbox Favorites

**Editing Multiple Configurations of a Toolbox Component**

When a model contains multiple configurations of the same Toolbox component, you can edit them simultaneously. You can initiate the edits from the FeatureManager design tree or from the graphics area.

**To modify the length of multiple configurations from the graphics area:**

1. In the graphics area, select the configurations to modify.

   ![Unselected configurations](image)

   ![Selected configurations](image)

   Unselected configurations

   Selected configurations.

   The arrow indicates that the last selected configuration will control the change.

2. On the last component you select, drag the arrow to the new length for the components.

   The length of all the selected components adjusts to match the size of the modified component.
To edit multiple configurations of a Toolbox component from the Configure Component PropertyManager:

1. In the FeatureManager design tree, Shift + select the configurations to modify.
2. Right-click and click Edit Toolbox component.

   If you do not select configurations of the same component, Edit Toolbox Component does not appear on the shortcut menu.

   In the PropertyManager, under Properties, the values listed are those of the last item you select.
3. Modify component properties.

   The changes you make in the PropertyManager are reflected in the graphics area for all selected configurations of the component.
4. Click ✓.

Replacing Toolbox Components

You can replace multiple instances of a Toolbox component with another Toolbox component by editing the components.

The components you replace must be configurations of the same parent component. For example, you can replace different lengths and sizes of the same socket head cap screw, but you cannot replace a nut and a bolt in the same operation.

To replace Toolbox components:

1. In the FeatureManager design tree, select the components to replace.
2. Right-click and click Edit Toolbox Component.
3. In the PropertyManager, under Replace Component, click Change Fastener Type.
4. In the dialog box, select the replacement component and click OK.

   The graphics area shows the updated preview geometry, manipulation arrows, and configuration flags for the components you replace.

   If one of the components is a seed for one or more component patterns, the components contained in those patterns are replaced.

   All applicable mates are updated with new references from the replacement components. If the software cannot automatically recreate any mates, the Mated Entities PropertyManager opens to let you edit and fix the mates.
Toolbox Add-in Name Changes

The names of the SOLIDWORKS Toolbox add-ins have changed in SOLIDWORKS 2016.

<table>
<thead>
<tr>
<th>2016 Add-in Name</th>
<th>Previous Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLIDWORKS Toolbox</td>
<td>SOLIDWORKS Toolbox</td>
<td>Loads the Toolbox configuration tool and the Toolbox Design Library Task Pane, where you can access Toolbox components.</td>
</tr>
<tr>
<td>Library</td>
<td>Browser</td>
<td></td>
</tr>
<tr>
<td>SOLIDWORKS Toolbox</td>
<td>SOLIDWORKS Toolbox</td>
<td>Loads the Beam Calculator, the Bearing Calculator, and the tools for creating cams, grooves, and structural steel.</td>
</tr>
<tr>
<td>Utilities</td>
<td>Library</td>
<td></td>
</tr>
</tbody>
</table>

Toolbox Data Import and Export

You can import and export Toolbox data tables using the .xlsx file format.

When you click Toolbox > Export Data, in the Save As dialog box you can choose either of these formats:

- Excel Workbook (*.xlsx)
- Excel 97-2003 Workbook (*.xls)

When you click Toolbox > Import Data, the Microsoft Excel file type includes the .xls and .xlsx file formats.

Toolbox Favorites

The Toolbox Favorites folder is a local folder where you can store shortcuts to frequently used Toolbox components.

In the SOLIDWORKS software, the Favorites 🗄 folder appears under Toolbox in the Design Library Task Pane. The content you add to the folder is stored as Windows shortcut files on your local computer.

The Toolbox Favorites folder is visible by default. To hide the folder, click Tools > Options > System Options > Hole Wizard/Toolbox and clear Display Toolbox Favorites. This does not remove your favorites - it just hides them on the Design Library Task Pane.

You can add content directly to the Favorites folder or create subfolders to organize the content. You then drag components from a Toolbox standard folder in the lower part of the Task Pane to the Favorites folder or subfolder.

You should not share favorites with other users.
To save and use Toolbox favorites:

1. In the Task Pane, on the Design Library tab, expand Toolbox.
2. Select the Favorites folder and click Create New Folder.
3. Type a name for the subfolder.

If you use standard Toolbox folder names such as Bearings or Bolts and Screws, the software displays the names with the appropriate icons. Otherwise a generic folder icon represents the folder.

The new folder appears under the Favorites folder and is created on your local computer in C:\Users\username\AppData\Roaming\SOLIDWORKS\SOLIDWORKS\release\Toolbox\Favorites.

4. Using the Toolbox library of components, expand the standard, category, and type of component to save as a favorite.
5. Select the component and drag it to the subfolder.
Each favorite you save appears as a shortcut in the Favorites subfolder and in the Favorites directory on your local computer.

If a Toolbox component is moved, deleted, or disabled, a warning flag appears on the shortcut.

Hover over the favorite to display a tooltip that describes the problem.

6. To use a favorite, select it in the Favorites subfolder and drag it to the graphics area, just as you would a component in one of the other Toolbox folders.
This chapter includes the following topics:

- **Compare Geometry Enhancements**

### Compare Geometry Enhancements

Enhancements in the **Compare Geometry** utility make it easier to identify the volumes that have been added and removed in a model.

When you run **Compare Geometry**, select **Keep bodies on close** to save the comparison volume bodies directly in the reference model, in the modified model, or in both. The volume bodies are listed in the model's FeatureManager design tree and appear under the **Compare Volume** folder, in the **Common Volume, Material Added** and **Material Removed** subfolders.

You can then use the **Intersect** tool to merge any combination of the added and removed materials into the reference or modified model.

When you use the **Intersect** tool to add materials, they will be fixed (static) bodies. Linked dimensions and references will not be carried over to the merged bodies.

Previously, the **Compare Geometry** utility generated a separate **Volume Comparison** file that included both bodies added and bodies removed, but made it difficult to distinguish between them.

### Running Compare Geometry

**To compare two versions of a model and save the comparison data in a model:**

1. Open `install_dir\samples\whatsnew\utilities\apple.sldprt` and `peach.sldprt`. 
2. Click **Tools > Compare > Geometry**.

3. In the Compare Task Pane select:
   b) For **Modified document**, select `peach.sldprt`.

4. Under **Items to compare**, select **Geometry** and click **Run Comparison**.
   The two part files are tiled.

5. Under **Volume comparison**, click **Common Volume, Material removed** and **Material Added**.

---

apple.sldprt

peach.sldprt
6. Select **Keep bodies on close** and click **Add to apple.sldprt** to keep differences with the reference document.
7. Click **Close** to exit the Task Pane.
   The comparison data is saved in apple.sldprt.

8. In the graphics area, expand the window for apple.sldprt. Then in the FeatureManager design tree, expand the **Compare Volume** folder and each subfolder. You can click each material entity to highlight the bodies added to and removed from the part.

### Merging Volumes with the Intersect Tool

To merge materials in the **Compare Volume** folder into apple.sldprt:

1. From the FeatureManager design tree, select the following:
   - **Cut-Extrude3**
   - **Material Added1**
   - **Material Added2**
   - **Material Removed1**

2. Click **Insert > Features > Intersect**.
3. Click **Create both** and click **Intersect**.
4. Under **Regions to Exclude**, click **Region 3**.
5. Then click **Merge Results** and ✔.
27
Weldments

This chapter includes the following topics:

- **Modifying End Cap Positions Using Reference Dimensions**
- **Structural Member Feature Names**
- **Structural Member Size Lists**
- **Total Length for Derived Parts**
- **Transferring Material Properties from Library Profiles**

**Modifying End Cap Positions Using Reference Dimensions**

When you create weldment end caps, the software adds reference dimensions to mark the inset distance in linear and curved structural members. You can modify these dimensions for parts, assemblies, and drawings without opening the end cap feature.

The inset dimensions are added automatically for the first end cap of the end cap feature. If you place the end cap on a straight member, the software assigns a linear dimension. If you place it on a curved member, the dimension assigned is an arc length.

**To modify end cap positions using reference dimensions:**

1. In a weldment part with end caps, click **Instant3D** (Features toolbar).
2. Select the end cap feature.
   - Reference dimensions appear on the first end cap in the feature.
3. Click the dimension and type a new dimension.

The end cap moves to the new location.

If you did not turn on Instant3D, click **Rebuild** (Standard toolbar) to complete the move.

**Structural Member Feature Names**

When you create structural member features, the software automatically names them based on the type and size of the structural members you insert.

The naming convention is **Type Size**(n), where n is the suffix that indicates the number of identical instances of the feature.

For example, if you insert four rectangular tubes with the size 3 x 2 x 0.25, the structural member that defines them is named **rectangular tube 3 x 2 x 0.25(4)**.

When you hover over a structural member feature in the graphics area, the tooltip uses the same naming convention:
This naming convention applies to weldments created in SOLIDWORKS 2016 and later.

**Structural Member Size Lists**

The structural member size list is sorted alphanumerically from the smallest size to the largest to make it easier to work with a library that contains a large number of standard size components.

In addition, the two sizes you have most recently used appear at the top of the menu so you can locate them easily.

**Total Length for Derived Parts**

When you view cut list properties for derived parts, the total length of the derived parts is included.

To access the **Total Length** property, right-click a cut list folder in a derived part and click **Properties**.

Total length is available when you create a derived part by:

- Inserting selected structural members of a weldment part into a new part.
- Copying cut list properties to new parts using **Split** or **Save Bodies**.
- Selecting **Cut list properties** when mirroring a weldment part.

The software also calculates the total length of derived parts in assemblies when you add derived parts using:

- **File > Derived component part**
- **Insert > Mirror Components**
Transferring Material Properties from Library Profiles

You can transfer the material properties of a library profile when you use it as a structural member.

You can also transfer the material properties of library profiles that have configuration-specific materials.

**Transfer Material from Profile** is available and selected by default for new structural member features. Between SOLIDWORKS sessions, the software retains the choice you made to transfer or not transfer materials.

If you choose to transfer the library profile material and no material was previously assigned to the document, the transferred material is assigned as the global document material, as well as the material for the specific cut list items where it applies.

**To transfer the material properties from library profiles:**

1. Create a sketch.

2. Click **Structural Member** (Weldments toolbar) or **Insert > Weldments > Structural Member**.

3. In the PropertyManager, select the **Standard, Type, and Size** for the profile.

4. In the graphics area, select sketch segments to define the path for the structural members.
   
   If the library profile you specified in step 3 has a material assigned, **Transfer Material from Profile** is available and selected.

5. If **Transfer Material from Profile** is available:
   
   - Leave it selected to transfer the material to the part.
   - Clear it to prevent the material from being transferred.

6. Click **✓**.
   
   In the FeatureManager design tree:

   - The **Material** node shows the transferred material.
   - When you expanded the newly-added cut list items, they are assigned the transferred material.