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INTRODUCTION 
 

The purpose of this document is to teach new users the 

fundamentals of SOLIDWORKS Electrical and assist in the 

creation of new projects using SOLIDWORKS Electrical. 

 

                                                          What is SOLIDWORKS Electrical? 
 

SOLIDWORKS Electrical is an add-on program which allows you 

to design and create documentation for your electrical 

schematics which can then be routed in SolidWorks3D CAD. This 

allows for added intelligence and design intent in the creation 

of new systems and assemblies.  

 

Learning Resources 

Online Help and Support 

 

You can learn more about SOLIDWORKS Electrical from our 

YouTube Page and from our Facebook Page. You can also visit 

the SOLIDWORKS Electrical Website. If you have any question 

you can leave a post on our SOLIDWORKS Teacher Blog. You can 

also use the SolidWorks FIRST Tutorials

http://www.youtube.com/user/solidworks
https://www.facebook.com/SolidWorksEducation
http://www.solidworks.com/sw/products/electrical-design/solidworks-electrical.htm
http://blogs.solidworks.com/teacher/
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                                                          Setting Up SOLIDWORKS Electrical 
 

To get SOLIDWORKS Electrical for your team, you first need to 

apply to SolidWorks for sponsorship. Once you apply, 

SolidWorks will let you have access to the following programs: 

 SOLIDWORKS 3D CAD (SOLIDWORKS) 

 SOLIDWORKS Electrical 

 SOLIDWORKS Simulation 

 SOLIDWORKS Composer 

 

How do you Apply for SolidWorks Sponsorship? 

 

To apply for SolidWorks Sponsorship: 

1. Click the link to the SolidWorks FIRST Robotics Website. 

2. Click the SOLIDWORKS SPONSORSHIP link and fill out 

the survey. 

3. Once you’ve completed the survey, you will have to 

wait between 3 to 5 business days in order for 

SolidWorks to approve you or not. 

4. Once APPROVED SolidWorks will send you codes and 

instruction on how to get your SolidWorks products by 

the email you provided. 

 

  

http://www.solidworks.com/sw/education/robot-student-design-contest.htm
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                                                Enabling SOLIDWORKS Electrical in SOLIDWORKS 
 

                                                                       SOLIDWORKS Electrical has two parts to it: 

 SOLIDWORKS Electrical 2D, which is a standalone 

program. 

 SOLIWORKS Electrical 3D, which is an add-in in 

SOLIDWORKS. 

To enable SOLIDWORKS Electrical 3D in SOLIDWORKS: 

1. Run SOLIDWORKS. 

2. Click Tools > Add Ins. 

3. Check the ACTIVE ADD-INS check box next to 

SOLIDWORKS Electrical to active SOLIDWORKS 

Electrical in SOLIDWORKS. 

4. Click OK to exit the menu and save your changes. 

 

 

 

NOTE: You can set SOLIDWORKS Electrical to automatically run 

once SOLIDWORKS 3D CAD runs by checking the START UP check 

box next to SOLIDWORKS ELECTRICAL. 
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SOLIDWORKS ELECTRICAL DESIGN 

CYCLE 
 

                                                          Overview 
 

In SOLIDWORKS Electrical consists of seven main design steps, 

assuming you have already acquired your components and 

created 3D models for them: 

1. Creating a Library 

2. Creating Manufactures Parts 

3. Creating Symbols 

4. Line Diagram 

5. Schematics Diagram 

6. 3D Representation 

7. Wire Harness 

By going through these steps SOLIDWORKS Electrical will help 

you bring your electrical design ideas to life. 
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Using 2015 FIRST Robotics Electrical Environment   
 

Importing the Environment  
 

Designing a robot using SOLIDWORKS Electrical requires the 

proper libraries and settings. This information is contained within 

the FIRST Robotics 2015 SOLIDWORKS Electrical Environment.  

To Import the environment, open SOLIDWORKS Electrical and 

select Unarchive  Environment from the Archiving  tab under the 

file menu.  

When prompted, select “FIRST Robotics 2015 SOLIDWORKS 

Electrical Environment.twezip” 

Continue through the menu and click okay at each prompt until the 

finish option appears. Click finish and the environment has been 

fully imported.  
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UNDERSTANDING THE 

WORKFLOW 
 

                                                          Single Line Diagram 
 

Single line diagrams provide an excellent project overview 

along with a quick means to create basic cable connections. 

Symbols are first placed that represent each major electrical 

component. These components can be associated to a 

manufacturer’s part at any time. Cables are then drawn to 

visually connect components and optionally connect circuits. 
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                                                          Schematics 
 

Schematics are built for power and control circuits using 

symbols tied to components. Single or multiple wires can be 

drawn between symbols and wires are numbered and trimmed 

automatically. Origin and destination arrows are created easily 

to ensure multi-page schematics are wired correctly. 

SOLIDWORKS Electrical also prevents origin – destination 

arrows from connecting to the wrong wire type to avoid 

connecting ground to power. Additional schematic tools 

automate the placement and organization of terminals, PLCs 

and black box components. 
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                                                         Component Tree 
 

As symbols are added, a Component tree is built dynamically. 

Locations can be defined for the project so that components 

can be identified with them. This helps with documentation as 

well as organization. The component tree can be used in 

schematics and 3D to insert their corresponding symbols and 3D 

models. 

SOLIDWORKS Electrical 3D can be used to assemble 

components along with their mechanical counterparts to create 

complete 3D models. Finally, wires and cables are routed 

automatically along guide lines to layout route locations as well 

as calculate lengths. 

The symbol and manufacturer part libraries can be tailored to 

your needs by removing or importing symbols and parts. Parts 

can be added individually as they are used and are shared with 

all Electrical users through SQL database. 
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                                                         The User Interface 
The SOLIDWORKS Electrical user interface is divided up into four 

main sections. 

The Side Panel provides access to project documents as well as 

components, macros and symbols. It also includes a command 

tab and options when a command is active. 

The Ribbon, or Command Manager menu, contains input 

commands sorted into multiple groupings (tabs). 

The Graphics Zone is limited to drawing access and editing. 

The Status Bar shows the cursor position and allows you to 

toggle modes like SNAP on and off. 
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PROJECTS 
 

What are Projects? 
A Project is the collection of the many different types of files 

used to create the reports, data and other files that together 

fully defines the system.  

A Project contains one or more document books and each book 

can contain multiple folders to manage the different files 

related to that book. 

Project Elements 
Some important elements of projects to know about when 

using SOLIDWORKS Electrical are: 

 Project: is the name assigned to the entire project 

including all the books and drawing files. 

 Book: contains all the documentation that is used to 

create the project including folders, drawings and 

associated documents. Each project can contain one or 

more books. 

 Folders: contain data within the Book, and can be used 

to categorize data, for greater manageability. 

 Drawings: contain different information types that go 

to make up the complete project data set, drawings can 

contain, schemes, lists, 2D cabinet layouts... 

 Cover Page: contains a title block in which user can set 

attributes to display information such as the project 

name and description, contents of a book. The drawing 

tools may be used to add an image. 

 Scheme: Scheme drawings contain circuit information 

related to the function of the electrical project. 

 Line diagram: shows a simplified overview of project 

components interconnects and cables used to form 

these connections. 

 Mixed schema: drawing allows users to mix the data 

style of scheme and line diagram type drawings to 

produce data rich hybrid designs. 

 Drawing lists: contain a variety of project reports 

generated as drawings. 
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 Terminal drawings: are automatically created from data 

applied to terminals in the project drawing set and 

through the Terminals editor. 

 2D Cabinet Layouts: are general arrangement layouts 

that can be created within SolidWorks Electrical 

Schematic to aid in the positioning of components 

within a machine, cabinet, installation... 

 SolidWorks Cabinet Layouts: allows for the 

development of project data in a 3D environment. 

 

Creating a New Project 
To create a New Project: 

1. Start SOLIDWORKS Electrical 2D. 

2. Click Project Manager  > New Project . 

3. Select the standard you want to use using the 

dropdown menu (e.g. ANSI). Click OK to confirm your 

selection. 

4. Click the English (or the language you want to use) and 

click OK. 

5. Type in your project information. Give your project a 

name and a description by filling out the Name and 

Description (English) sections.  

6. Click OK when done and a new project will be created. 

 

NOTE: Creating a new project automatically creates multiple 

files of several different types. Additional drawings and 

other files can be added manually. The structure of a new 

project is based on a template. You only need to create an 

initial project structure and configure its settings once. It can 

then be saved as a template to keep all projects consistent 

and to speed up initial design. 
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Creating a new Library 
 

To create a new Library: 

1. Run the SOLIDWORKS Electrical 2D standalone 

program. 

2. The Project Manager will automatically open every time 

you launch SOLIDWORKS Electrical 2D. Close the Project 

Manager. 

3. Click the Library Tab > Libraries Manager. 

4. In the Libraries Manager click New to create a new 

library. 

5. The Library Property Manager should open. Give your 

library a name and description. For this guide we will 

call the library Custom. 

6. Click OK to save you data and create a new library. 
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Creating a New 

Manufacturer Part 
To create a new manufacturer part that does not yet exist in the 

catalog: 

1. Click the Library Tab > Manufacturer parts manager. 

2. Click Add part  in the Manufacturer parts manager 

window. 

3. Fill in the following sections with information about 

your component: 

 Part: For the part number. 

 Manufacturer: For the name of the 

manufacturer  

 Class: What type of component you have 

(Connector, Relay, Transformer…)  

 Library: Which library your component will be 

in. 

 Type: This should be set as BASE. 

 Description (English): The name of the part (e.g. 

4 Pin Connector) 

4. Click the Add button to start adding circuits to your 

component.  

 

 

Circuits are what give your component life. It defines how many 

pins or terminals your component has and what each of those 

pins or terminals do. 

There are four fields related to circuits: 

 Number: This is the number of circuits you have. As you 

add more circuits the number increases starting from 

zero. 

 Type: This is the type of circuit you have. They range 

from a variety of type ranging from Ground, Power 

supply, Terminals, etc.… 

 Terminal Number: This is the number or terminals in 

the circuit which share the same type. You can either 

give it a name such as GND for or if you have multiple 



14 
 

terminals of the same type, you number them starting 

from one with commas after each number (e.g. 1, 2, 3, 

4…). 

 Group: This helps you to give more information about 

the terminal. It is not necessary to be filled out but will 

help you document your project. 

 

5. Fill out the information for your circuits and add more 

circuits as needed. Click OK to save your work. 
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SINGLE LINE DIAGRAMS 

 

What are Single Line 

Diagrams? 
A Line Diagram, or Single Line Diagram, is a simplified 

representation of the cabling that will be used in the project. It 

shows the original concept of the project, optionally with 

drawing graphics, rather than the final result. The single line 

diagram is a useful tool for managing components and their 

relationships, functionality and connectivity. Cables can be 

defined between components within the line diagram.  

In a line diagram you use symbolic representation of your 

components which most often are images of the component 

being used. SOLIDWORKS Electrical comes with an extensive 

library of line diagram symbols which you can use. You can also 

make your own symbols for components to use in the line 

diagram. 

 

Creating a Single Line 

Diagram Symbol 
 

Creating the Symbol 

 

To create a Line Diagram Symbol: 

1. Click the Library Tab > Symbols Manager. 

2. Once the Symbols Manger opens, click New to create a 

new symbol. 

 

 

 

 

 



16 
 

 

 

Once you create a new symbol, the symbol properties window 

will open. This is where you can enter all the data about your 

component. The data entered has a direct impact on how the 

symbol will be used and how it will interact with other symbols. 

Some of the main fields available are: 

 Symbol name: The name of the symbols DWG file. 

 Description: This will be displayed when viewing the 

symbols through the Thumbnail Mode, if left blank the 

Symbol name will be shown. 

 Manufacturer/Part: A manufacturer and part that will 

be automatically applied to the symbol on insertion. 

 Library: The library the symbol will be associated to can 

be filtered at a project level to limit different symbol 

standards availability in project drawings. 

 Symbol type: Defines that command that will allow 

access to the symbol, Multi wire symbols are available 

when using the Insert Symbol command from the 

Schematic tab, for example. 

 Classification: Allows association of the symbol to 

specific classification, manufacturers parts also have 

classification, matching symbol and part classification 

assists in part assignment in scheme drawings. 

 Unit system: Metric or Imperial, sets the symbols 

drawing unit system, this can affect symbol size during 

insertion of a mm symbol into a scheme drawing in 

inches. 

 

3. Fill in the information associated with the component 

you want to use. Make sure to select line diagram 

symbols for the Symbol type and Custom (the library 

you created earlier) for the Library. 

4. Click OK so save the data and create a new symbol. The 

symbol should now appear in the Symbol Manager 

under the Custom library. 
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NOTE: You can search for any library by going to the 

Filters tab in the Symbols manager and selecting your 

library under the Library drop box. Make sure that the 

‘In the class:’ box is unchecked when doing this. 

 

Drafting the Symbol 

 

Now that you have created the symbol you now need to create 

a visual representation so you know what component the 

symbol is representing. 

To Draft your symbol: 

1. Double click your symbol in the Symbols Manager to 

open the drawing window. 

When you are in the drawing window, a new tab called Drawing 

will appear. This tab will house most of the tools you will need 

to make your draft. 

2. Click the Drawing tab to bring up the drawing tools. 

NOTE: Normally a line diagram symbol draft consists of an 

image of the component you are using in real life which is inside 

a box. The box is needed so that program knows the boundaries 

of the draft.  

3. Click on the GRID button to show the grid. 

4. Click the SNAP button to turn snap on. 

NOTE: The GRID and SNAP tools will make it easier to create 

your drafts.  
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TIP: You can right click on either the GRID or SNAP button to 

adjust the grid, grid spacing and snap distance. 

5. Click Insert Image and browse for the image you are 

going to use. Select the image click Open to confirm 

your selection. The image you select must be in bitmap 

form. The Insert image window should appear. Click OK 

in insert your image. 

NOTE: The bitmap image should be a 16 color bitmap. 

6. To adjust the size and location of the image, click on 

one of the corners of the image. Five blue squares will 

appear on the image, four are for resizing the image 

and one for moving the image. 

7. Draw a rectangle around your image making sure that 

your image is within the boundary. To do this click the 

Rectangle too. The first click is where the upper left 

corner will be and the second click will be where the 

bottom right corner will be. 

 

Next you need to properly label your draft. To do this we have 

to add an attribute. Attributes label your draft with specific 

information such as: 

 Location of component 

 Manufacture’s part number 
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 Manufacture 

 

8. Add an attribute by clicking Edit symbol > Attributes 

insertion. 

9. Check the check box new to the #TAG attribute in the 

Identification folder. Click OK to confirm your selection. 

10. Click a location where your want the attribute to 

appear. 

NOTE: The location doesn’t have to be inside the rectangle that 

you drew earlier. 

 

 

Creating a Single Line Diagram 

Inserting a Symbol 

 

To insert a symbol into your Single Line Diagram: 

1. Open 03 – Wiring line diagram from the project 

drawing list. 

2. Click the Line diagram tab > Insert Symbol. 

3. The Side Panel will change to a Symbol insertion menu. 

To pick a symbol to insert click the Other symbol… 

button which will bring up the Symbol selector. 

NOTE: The Symbol selector is where you can find any symbol 

that SOLIDWORKS Electrical has in its database or any symbols 

you add to the database to use in your single line diagrams. 

 

4. Click the Filters tab in the Symbols selector. Make sure 

that In the class is unchecked. 

5. Select your library from the Library list to bring up all 

your components in your library, click the component 

you want to insert. 

6. Click Select. 

7. Place your component symbol where you want it on the 

sheet. 
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8. After placing a symbol, the Symbol properties 

dialog will be displayed. 

9. Leave the default location and root mark. 

10. Select the Manufacturer part and circuits tab. 

11. Click Search. 

12. In the Filters tab select your library from the Library 

list. 

13. Click Search or enable Automatic refresh 

14. Double-click the component that corresponds to 

your symbol. 

15. Click Select to associate the manufacturer part data 

to the symbol. 

16. Click OK. 
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Sketching Wires 

 

Since we are using the Single Line Diagram as a representation 

of our wire connections, we can sketch simple lines to illustrate 

the connections. 

The two sketch tools you will mostly need the most to draw 

your wire representations are: 

 Line Tool . 

 Arc Tool  . 

 

Sketching a Line 

 

To sketch a Line: 

1. From the Drawing tab, click the Line tool. 
2. Click where you would like the line to start. 
3. Move your mouse and click where you would like the 

line to end.  
4. You can keep clicking to continue the line. Once you are 

finished creating your line click the Esc key to stop 

drawing lines. 

 

 

  



22 
 

Sketching an Arc 

 

To sketch an Arc: 

1. From the Drawing tab, click the Arc tool. 

2. Click where you would like the arc to start. 

3. Move your mouse and click where you would like the 

midpoint of the arc to be. 

4. Click a third time where you would like the end point of the 

arc to be.  
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SCHEMATICS 

 

What are Schematics? 
A Schematic diagram is used to show the electrical components 

and their electrical connections. Schematics may appear in one 

or more of the drawings of the book. 

Like Single Line Diagrams, SOLIDWORKS Electrical comes with an 

extensive library of schematic symbols which you can use and 

you can also make your own symbols to use. 

 

Creating a Schematics 

Symbol 
 

Creating the Symbol 

 

To create a Schematic Symbol: 

1. Click the Library Tab > Symbols Manager. 

2. Once the Symbols Manger opens, click New to create a 

new symbol. The Symbol properties window will open. 

NOTE: See page 15 to view a description of the different 

data properties for the symbols. 

NOTE: For this section we will be creating a simple 2 Pin 

Female Connector. 

 

3. Fill in the information associated with the component 

you want to use. Make sure to select Multiwire 

symbols for the Symbol type and Custom (the library 

you created earlier) for the Library.  

4. Click <No reference> under the Part field. 

5. The Manufacturer part selection window will appear. 

Make sure In the class is unchecked. Select Custom for 

Library. Click Search. 
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6. Double-click the component (the 2 Pin Female 

Connector) you are creating the Symbol for.  

7. Click OK to create the symbol.  

Drafting a Symbols 

 

To Draft your symbol: 

1. Double click your symbol in the Symbols Manager to 

open the drawing window. 

2. Click on the GRID button to show the grid. 

3. Click the SNAP button to turn snap on. 

4. Set your SNAP and GRID to 1.00 mm spacing. 

 

TIP: You can right click on either the GRID or SNAP 

button to adjust the grid, grid spacing and snap 

distance. 

 

5. Click the Drawing tab to bring up the drawing tools. 

Click the Rectangle tool. 

6. Draw a 12 mm X  9 mm rectangle. 

7. Click New circuit under the Edit Symbol tab to add 

terminals to your connector. 

8. The New circuit window will open. Enter 2 for the 

Number. Select Aux. female pin for Circuit type. Make 

sure that you have Disconnectable selected for 

Information transmission. 

9. Click OK. 

Since we are making a 2 Pin Connector that means we will 

have two different circuits attached to the connector. Each 

circuit will have two nodes to connect the two ends through 

the connector.  

10. Right Click Circuit: 0 – Aux. female pin in the Side 

Panel, New connection point > Incoming/Outgoing. 

11. Click a location in the upper left corner of the rectangle 

so that the bigger black circle is outside the rectangle 

while the smaller white circle is inside the rectangle. 

 

TIP: You can right-click to rotate the node. 
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12. Right Click Circuit: 0 – Aux. female pin in the Side 

Panel, New connection point > Incoming/Outgoing. 

13. Click a location in the lower left corner of the rectangle 

so that the bigger black circle is outside the rectangle 

while the smaller white circle is inside the rectangle. 

Now when you use the symbol in your schematic anything 

attached to these two nodes will be connected to each 

other. 

14. Repeat steps 10-13 but making connections for Circuit: 

1 – Aux. female pin. 

15. Click Attributes insertion in the Edit symbol tab. 

16. Check the boxes next to #TAG and #REF_DES_2 in the 

Identification folder. Click OK. 

17. Click a location next to your symbol. 

18. Save and close your symbol. 

 

Creating a Schematic 

Diagram 
 

Inserting a Symbol 

 

To insert a symbol into your Schematic: 

1. Open 04 – Electrical scheme from the project drawing 

list. 

2. Click the Schematic tab > Insert Symbol. 

3. The Side Panel will change to a Symbol insertion menu. 

To pick a symbol to insert click the Other symbol… 

button which will bring up the Symbol selector. 

4. Click the Filters tab in the Symbols selector. Make sure 

that In the class is unchecked. 

5. Select your library (Custom)  from the Library list to 

bring up all your components in your library, click the 

component you want to insert (2 Pin Female 

Connector). 

6. Click Select. 

7. Place your component symbol where you want it on the 

sheet. 
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8. After placing a symbol, the Symbol properties dialog 

will be displayed. 

9. Leave the default location and root mark. 

10. Select the Manufacturer part and circuits tab. 

11. Click Search. 

12. In the Filters tab select your library from the Library 

list. 

13. Click Search or enable Automatic refresh 

14. Double-click the component that corresponds to your 

symbol. 

15. Click Select to associate the manufacturer part data to 

the symbol. 

16. Click OK. 
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Inserting a Wire 

 

Now that you have placed your components in your schematic, 

it’s time to add wire connection between your components. To 

add wires: 

1. Click Draw single wire type in the Schematic tab. 

2. The Side Panel should show the Electrical wire 

manager. Click the … Browse button. 

3. The Wire style selector will open. Here you can select 

what type of wire you would like to use. Click the 

Command wire and then click Select. 

4. Click on a node of a component to start your wire. You 

can click to add bends to the wire. Click on a second 

node to end your wire and create a connection. 

5. When you are done drawing wires, press the Esc key on 

your keyboard to stop using the wire tool. 

  

Note: The wire connection will 

automatically end when a positive 

connection is made 
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Adding Wire Numbers  

SolidWorks Electrical can be configured to a variety of 

wire numbering conventions. These can include sheet, 

row and column numbers, static text, origin and 

destination component information among other data. 

These options are selected via the Wire Style Manager.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 
Note: You can hide and show wire 

numbers on any wire line by right-

clicking and toggling Show/hide wire 

marks. 
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Assigning Cables and Harnesses  

As you learned earlier cables are used in single line diagrams to 

connect various components to one another. These cables have the 

additional ability to connect circuits aside from simply creating visual 

connections. Harnesses are groupings of wires and or cables which 

are routed together to create simplified designs.  

Once components are connected, a purchasable cable with 

predefined cores can be associated to the connection from the 

existing part library. As components are assigned on each end of the 

cable the connectivity between the components and the cable will be 

created as a cabling detail  

To assign a cable: 

1. Right click the cable 

2. Select Detailed Cabling  to open the Detailed Cabling dialog 

3. Select the wires with “?” assigned in the origin column 

4. Drag the selected wires to the terminal column for the 

desired component  

5. Close the dialog  

6. From the File tab, click Save to ensure changes are saved to 

the project  
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SolidWorks Electrical 3D 

Inserting 3D Components:  

As soon as an electrical assembly is created in SolidWorks, the 

Electrical Component Tree displays in the Property Manager pane on 

the left. Components that already have 3D models will display those 

parts under the component mark.  

 

Opening a part in SolidWorks: 

1. From the SolidWorks Electrical Menu, select the Projects 

Manger. 

2. Select the project highlighted in red and select open 

3. Expand the feature tree on the left and double click the 3D 

model icon. 
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Routing Cables: 

After inserting components into your SOLIDWORKS assembly, the 

associated cable and wire routes can be created. SOLIDWORKS Electrical 

provides an Electrical Component Wizard to walk through the required setup of 

parts to include wire and cable points and mate references to help you use your 

own parts or downloaded components. 

1. Select the Route Cables command from the SolidWorks 

Electrical 3D Command Manager tab 

2. Select SolidWorks Route as the route type  

3. Select Use Splines 

4. Select All Components 

5. Set Routing parameters  

6. Click the check mark  
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Generating Reports 

SolidWorks Electrical maintains a database of information about components, 

wires, cables and assemblies within a project. A variety of reports are available 

to share and organize this data. Drawings with this data can be easily shared and 

edited.  

To generate a report: 

1. Select the Project Tab in the SolidWorks Electrical Application 

2. Click Reports to open the Reports Manager  

3. Click the reports to review the data  

4. To generate drawings, click Generate Drawings 

5. Select each report listed and click OK 

6. Click Close  


