1 SolidWorks Enterprise PDM Installation Guide...............................................................10

2 Installation Overview......................................................................................................11

   Required Installation Components..................................................................................11
   Optional Installation Components....................................................................................12
   Enterprise PDM Deployment Scenarios.............................................................................12
   System Requirements.......................................................................................................14
   Installation Summary.......................................................................................................14
   Installation Assistance.....................................................................................................15

3 Installing and Configuring SQL Server........................................................................16

   SQL Server 2012 Support................................................................................................16
   Installing SQL Server 2008............................................................................................17
       Before Installing SQL Server 2008............................................................................17
       Performing the SQL Server 2008 Installation.............................................................17
       After Installing SQL Server 2008.............................................................................21
       Verifying That SQL Server 2008 Was Installed Correctly............................................21
   Upgrading to SQL Server 2008......................................................................................21
       Before Upgrading to SQL Server 2008....................................................................22
       Performing the Upgrade to SQL Server 2008..............................................................22
       After Upgrading to SQL Server 2008.......................................................................23
   Installing SQL Server 2005..........................................................................................24
       Before Installing SQL Server 2005...........................................................................24
       Performing the SQL Server 2005 Installation.............................................................24
       After Installing SQL Server 2005.............................................................................27
       Verifying That SQL Server 2005 Was Installed Correctly..........................................27
   Upgrading to SQL Server 2005......................................................................................27
       Before Upgrading to SQL Server 2005....................................................................27
       Performing the Upgrade to SQL Server 2005..............................................................28
       After Upgrading to SQL Server 2005.......................................................................30
   Installing the SQL Server 2005 Service Pack.................................................................30
       Determining the Currently Installed Version of SQL Server 2005..............................30
       Obtaining the SQL Server 2005 Service Pack.............................................................31
       Preparing To Install the SQL Server 2005 Service Pack.............................................31
       Installing the SQL Server 2005 Service Pack............................................................31
SQL Server Troubleshooting.............................................................................................................32
  Clients cannot work in the file vault..............................................................................................32
  Enterprise PDM administrative features fail.................................................................................33
  Enterprise PDM cannot connect to the server.............................................................................33
Changing the SQL Server Login Account Used by Enterprise PDM.........................................................34
  Creating a New SQL Login Account............................................................................................34
  Using the New SQL Login with the Enterprise PDM Archive.......................................................34
  Giving an SQL User db_owner Access to Existing Enterprise PDM File Vault Databases................35
  Insufficient SQL Permissions.......................................................................................................36

4 Installing SolidWorks Enterprise PDM.......................................................................................37
  Initiating Enterprise PDM Installations..........................................................................................37
  Installing SolidWorks Enterprise PDM Database Server.................................................................39
    Before Installing the Database Server..........................................................................................40
    Performing the Database Server Installation.............................................................................40
  Installing SolidWorks Enterprise PDM Archive Server..................................................................41
    Before Installing the Archive Server..........................................................................................42
    Performing the Archive Server Installation.............................................................................43
    Opening Ports for Client/Server Communication.......................................................................47
    Running the Archive Server on Windows Vista........................................................................48
    Adding Archive Servers in a WAN Environment........................................................................49
  Installing SolidWorks Enterprise PDM Web Server.......................................................................50
  Installing SolidWorks Enterprise PDM Client..................................................................................50
    Before Installing Clients.............................................................................................................50
    Installing Clients Using the Installation Wizard..........................................................................52
    Enabling Logging to Troubleshoot Installation..........................................................................52
    Creating an Enterprise PDM Client Administrative Image...........................................................53
    Deploying Clients Using Windows Active Directory....................................................................54
    Enabling Logging When Deploying Enterprise PDM....................................................................56
    Scripting a Silent Installation of Enterprise PDM..........................................................................57

5 Creating and Distributing File Vault Views..................................................................................59
  Creating the File Vault.......................................................................................................................59
  Creating a File Vault View Using the View Setup Wizard.................................................................59
    Enabling Broadcast with Windows Firewalls...............................................................................61
    Using a Shared File Vault View with Multiple User Profiles..........................................................62
    Using Enterprise PDM on a Terminal Server...............................................................................63
  Creating a File Vault View Setup File.............................................................................................64
  Scripting File Vault View Setup.......................................................................................................64
  Distributing an Enterprise PDM File Vault View Using Microsoft Windows Active Directory...........65
    Finding the Enterprise PDM Vault ID............................................................................................67
    Receiving a Distributed File Vault View.......................................................................................67
Contents

Distributing File Vault Views in a WAN Environment ............................................................... 67
Manually Configuring the Archive Server That Is Announced to Enterprise PDM Clients .... 68
Specifying SolidWorks Enterprise PDM Settings Group Policy Manually ......................... 68
SolidWorks Enterprise PDM Settings Policy Options ......................................................... 69

6 Configuring Content Search .......................................................................................... 72
Content Search Overview ................................................................................................. 72
Recommended Computer Configuration .............................................................................. 72
Configuring the Index Service on the SQL Server System ................................................. 73
  Verifying Microsoft Indexing Service Installation ............................................................ 73
  Monitoring and Tuning the Microsoft Indexing Service .................................................. 74
  Indexing Enterprise PDM File Vault Archives ................................................................. 74
Configuring the Index Service on a Non-SQL Server System ............................................ 75
  Updating the File Vault Database with the Index Server Name ...................................... 75
  Changing the Database Server Login Account ............................................................... 75
  Changing the SQL Server Login Account ...................................................................... 76
Adding Index Server Filters .............................................................................................. 77
  Compressed Archives (gzip) Filter .................................................................................. 77
  Microsoft Index Filters .................................................................................................. 77
Managing File Vault Index Catalogs .................................................................................. 78
Removing a File Vault Index .............................................................................................. 78

7 Backing Up and Restoring File Vaults ....................................................................... 79
Backing Up the File Vault Database .................................................................................. 79
Backing Up the Enterprise PDM Master Database ............................................................ 80
Backing Up the Archive Server Settings ........................................................................... 80
Backing Up the Archive Files ............................................................................................ 81
Scheduling Database Backups Using a Maintenance Plan .................................................. 81
  Starting the SQL Server Agent ....................................................................................... 81
  Setting Up a Maintenance Plan for Database Backup .................................................... 82
Restoring a File Vault ........................................................................................................ 84
  Restoring the SQL Server File Vault Databases ............................................................ 84
  Verifying the ConisioMasterDb Restore ....................................................................... 84
  Restoring the Archive Server and File Vault Archives ................................................... 85

8 Upgrading Enterprise PDM ......................................................................................... 86
About Enterprise PDM Upgrade ....................................................................................... 86
Upgrading from Versions Older than Conisio 6.2 ............................................................ 86
Upgrading the Enterprise PDM Web Server ..................................................................... 86
Client Licenses .................................................................................................................. 86
Visual Basic 6 Add-ins ..................................................................................................... 87
Before Upgrading ............................................................................................................. 87
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuring the Moved Archive Server</td>
<td>130</td>
</tr>
<tr>
<td>Updating Client Registry Keys</td>
<td>131</td>
</tr>
<tr>
<td>Updating Replication Settings</td>
<td>131</td>
</tr>
<tr>
<td>Verifying the Server Move</td>
<td>132</td>
</tr>
</tbody>
</table>
Legal Notices

© 1995-2013, Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes S.A. company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of the license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the license agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SolidWorks® 3D mechanical CAD software is protected by U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940, 8,305,376, and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

Other U.S. and foreign patents pending.

Trademarks and Product Names for SolidWorks Products and Services

SolidWorks, 3D PartStream.NET, 3D ContentCentral, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.

CircuitWorks, FloXpress, PhotoWorks, TolAnalyst, and XchangeWorks are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of Geometric Ltd.


Other brand or product names are trademarks or registered trademarks of their respective holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of “commercial computer software” and “commercial software documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government (a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in 48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the department of Defense,

In the event that you receive a request from any agency of the U.S. government to provide Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope of the request and DS SolidWorks will have five (5) business days to, in its sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SolidWorks Standard, Premium, Professional, and Education Products

Portions of this software © 1986-2012 Siemens Product Lifecycle Management Software Inc. All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:

Portions of this software © 1998-2012 Geometric Ltd.
Portions of this software © 1996-2012 Microsoft Corporation. All rights reserved.
Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.
Portions of this software © 2001-2012 Luxology, LLC. All rights reserved, patents pending.
Portions of this software © 2007-2011 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SolidWorks.

Copyright Notices for SolidWorks Simulation Products

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2010 Computational Applications and System Integration, Inc. All rights reserved.

Copyright Notices for SolidWorks Enterprise PDM Product

Outside In® Viewer Technology, © 1992-2012 Oracle
© 2011, Microsoft Corporation. All rights reserved.

Copyright Notices for eDrawings Products

Portions of this software © 2000-2012 Tech Soft 3D.
Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.
Portions of this software © 1998-2001 3Dconnexion.
Portions of this software © 1998-2012 Open Design Alliance. All rights reserved.
Portions of this software © 1995-2010 Spatial Corporation.
The eDrawings® for Windows® software is based in part on the work of the Independent JPEG Group.
## Installation Overview

Required and optional installation components, deployment scenarios, and installation summary.

### Installing and Configuring SQL Server


### Installing SolidWorks Enterprise PDM

The installation of Enterprise PDM database, archive, and Web servers, and Enterprise PDM clients. Client installation includes creating and deploying admin images, and scripting silent installations.

### Creating and Distributing File Vault Views

Creating file vault views using the View Setup wizard. Includes using shared views, scripting file vault view setup, and distributing file vault views.

### Configuring Content Search

Configuration of the Enterprise PDM Index Service. Includes indexing file vault archives, updating the index server name, changing login accounts, and adding index server filters.

### Upgrading Enterprise PDM

Upgrade of the database, archive, and Web servers, the file vault database and archives, and Enterprise PDM clients.

### Backing Up and Restoring File Vaults

Backing up the file vault database and Enterprise PDM Master database, including archive server settings. Includes scheduling database backups and restoring file vaults.

### Additional Configuration

Managing the SQL transaction log size, configuring Enterprise PDM communication with IP addresses only, and moving server components to another system.
Installation Overview

This chapter includes the following topics:

- **Required Installation Components**
- **Optional Installation Components**
- **Enterprise PDM Deployment Scenarios**
- **System Requirements**
- **Installation Summary**
- **Installation Assistance**

### Required Installation Components

To use Enterprise PDM, these components must be installed and configured.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft SQL Server</td>
<td>The Enterprise PDM file vault database must be hosted on Microsoft SQL Server 2008 (SP0 or higher) or Microsoft SQL Server 2005 (SP02 or higher). The SQL Server software is not included on the SolidWorks Enterprise PDM DVD and must be installed separately.</td>
</tr>
<tr>
<td>Enterprise PDM database server</td>
<td>The database server periodically polls Enterprise PDM databases for updates such as notifications, local view refresh, replication schedule updates, and index server changes. It also manages data import and export rules.</td>
</tr>
<tr>
<td>Enterprise PDM archive server</td>
<td>The archive server hosts the physical files stored in a Enterprise PDM file vault, and manages users and their credentials.</td>
</tr>
</tbody>
</table>
Each computer accessing the Enterprise PDM file vault must have one of the following clients installed:

**Enterprise PDM**
- Supports working with all file types, including enhanced management and previewing of CAD formats such as SolidWorks. CAD add-ins allow users to access Enterprise PDM from within the CAD application.

**Enterprise PDM Contributor**
- Supports working with all file types, including CAD files. However, the CAD add-ins are not supported on this client type.

**Enterprise PDM Viewer**
- Allows read-only access to file vaults; user cannot add or modify (check out, check in, update values) files or use CAD add-ins.

### Optional Installation Components

The following installation components are optional:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enterprise PDM Web server</td>
<td>The Web server provides access to a file vault from the Internet or an intranet.</td>
</tr>
<tr>
<td>Enterprise PDM index server</td>
<td>The Enterprise PDM index server provides for full content search in many file types stored in a Enterprise PDM file vault.</td>
</tr>
</tbody>
</table>

### Enterprise PDM Deployment Scenarios

The deployment of Enterprise PDM components depends on the size and type of organization where Enterprise PDM is used.

**Medium Office Network**

A server running Microsoft SQL Server hosts the archive server and database server. Windows workstations installed with the Enterprise PDM client attach to the server.
Large Office Network

One server running SQL Server hosts the file vault databases and the database server. Another server hosts the archive server. Workstations installed with the Enterprise PDM client attach to the servers. A Web server allows access over the Internet using Enterprise PDM Web clients.

WAN Connected Offices

One main server running SQL Server hosts the central database server. A second server hosts the archive server. Each WAN office has a server hosting a local archive server with a replicated file vault archive.

Workstations installed with the Enterprise PDM client attach to their local archive server and to the central database server.
System Requirements

Enterprise PDM system requirements are available on the SolidWorks Web site.

Installation Summary

Although components can be installed in any order, the recommended sequence for a LAN installation is described.

To install Enterprise PDM components:

1. Install SQL Server on the system that will host the Enterprise PDM file vault database, unless you have an existing SQL Server running.
   For details, see Installing and Configuring SQL Server on page 16.

2. Install the database server component on the system running the SQL Server.
   For details, see Installing SolidWorks Enterprise PDM Database Server on page 39.

3. Install the archive server on the system running the SQL Server or on a separate system.
   For details, see Installing SolidWorks Enterprise PDM Archive Server on page 41.
4. Install the Enterprise PDM client on all workstations that will work in the file vault. For details, see Installing SolidWorks Enterprise PDM Client on page 50.

5. Create a new file vault using the Enterprise PDM administration tool on a system where the Enterprise PDM client is installed. For details, see Creating the File Vault on page 59.

6. Optionally, set up the Enterprise PDM index server for content search support. For details, see Configuring Content Search on page 72.

7. Attach the remaining clients to the archive server and create local file vault views using the View Setup wizard. For details, see Creating a File Vault View Using the View Setup Wizard on page 59.

Installation Assistance

First level technical support for SolidWorks products is provided by your reseller. For help contacting your reseller:

- Call 1-800-693-9000 from the USA or Canada.
- Call 1-978-371-5011 from other locations.
- Send e-mail to customercenter@solidworks.com.
SolidWorks Enterprise PDM uses a Microsoft SQL-based database to store information about files and activities in a file vault. File vaults require SQL Server 2012, SQL Server 2008 (SP0 or higher) or SQL Server 2005 (SP2 or higher).

It is recommended that you use SQL Server 2008 to host the file vault database.

A Microsoft SQL Server 2008 DVD is included with the SolidWorks Enterprise PDM media kit. If you install from a downloaded kit, you must obtain Microsoft SQL Server software separately; it is not included in the download.

If you already have the required version of SQL Server installed, continue to **Installing SolidWorks Enterprise PDM** on page 37.

If you are uncertain of which SQL Server version is installed, see Microsoft Knowledge Base article 321185 to identify version and edition:

http://support.microsoft.com/default.aspx/kb/321185/en-us

This chapter includes the following topics:

- **SQL Server 2012 Support**
- **Installing SQL Server 2008**
- **Upgrading to SQL Server 2008**
- **Installing SQL Server 2005**
- **Upgrading to SQL Server 2005**
- **Installing the SQL Server 2005 Service Pack**
- **SQL Server Troubleshooting**
- **Changing the SQL Server Login Account Used by Enterprise PDM**

**SQL Server 2012 Support**

SolidWorks Enterprise PDM 2013 SP02 and later supports the use of Microsoft SQL Server 2012.

For those customers who have obtained SQL Server 2012 through other channels, SolidWorks now supports its use with SolidWorks Enterprise PDM 2013 SP02 and later.

SolidWorks will distribute SQL Server 2012 in a future release of SolidWorks Enterprise PDM.
Installing SQL Server 2008

The SQL Server 2008 installer provides help, including considerations for running on Windows Vista or later. The SQL Server 2008 Books Online (SQL Server 2012 Documentation Components) provide hardware and software requirements and detailed installation instructions.


This section describes how to install the initial release of SQL Server 2008. If you are installing SQL Server 2008 R2, use these instructions. For details, see http://msdn.microsoft.com/en-us/library/ms130214.aspx.

Before Installing SQL Server 2008

For local installations, you must run Setup as an administrator. If you install SQL Server 2008 from a remote share, you must use a domain account that has read and execute permissions on the remote share.

If Enterprise PDM is installed on the system, use Uninstall a program to uninstall the Microsoft SQL Server 2005 Backward Compatibility package before starting the SQL Server 2008 installation.

Microsoft .Net framework version 3.5 SP01 and Windows Installer 4.5 are required. If they are not installed, the Installation Wizard installs them before starting the SQL Server 2008 installation. These installations may require you to restart your computer.


Performing the SQL Server 2008 Installation

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2008 installation media. From the root folder, double-click setup.exe and use the default selections unless otherwise instructed.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server Installation Center/Planning</td>
<td>In the left pane, click Installation.</td>
</tr>
<tr>
<td>SQL Server Installation Center/Installation</td>
<td>Click New SQL Server stand-alone installation or add features to an existing installation.</td>
</tr>
<tr>
<td>Screen</td>
<td>Action</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Setup Support Rules            | The installer checks for problems that will prevent the installation of the SQL Server support files:  
  • If no problems are reported, click **OK**.  
  • If problems are reported:  
    1. Click **Show details** to list the components that failed or prompted warnings.  
    2. Click **Cancel** to stop the installation and fix the problems. |
| Product Key                    | 1. Select **Enter the product key** and type your license key.  
  2. Click **Next**.                                                    |
| License Terms                  | 1. Read and accept the license agreement.  
  2. Click **Next**.                                                    |
| Setup Support Rules            | Click **Install**.                                                      |
| Setup Support Rules            | The installer performs an additional check:  
  • If no problems are reported, click **Next**.  
  • If problems are reported:  
    1. Click **Show details** to list the components that failed or prompted warnings.  
    2. Click **Cancel** to stop the installation and fix the problems. |
| Feature Selection              | 1. Under **Instance Features**, select **Database Engine Services**.  
  2. Under **Shared Features**, select:  
    • **Client Tools Connectivity**  
    • **Integration Services**  
    • **Client Tools Backward Compatibility**  
    • **SQL Server Books Online**  
    In SQL Server 2012, the name of this option is **Documentation Components**.  
    • **Management Tools - Basic**  
    • **Management Tools - Complete**  
  3. Click **Next**.                                                     |
<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
</table>
| Instance Configuration | If this is a new installation:  
1. Select **Default instance**.  
2. Click **Next**.  
If SQL Server is already installed on the system and you opted not to upgrade:  
1. Select **Named Instance**.  
2. Enter a unique instance name for this installation: \computername\instancename.  
3. Click **Next**. |
| Disk Space Requirements | If disk space requirements are met, click **Next**.  
If disk space requirements are not met:  
1. Note the space required.  
2. Click **Cancel**.  
3. Add the required space.  
4. Run the installation again. |
| Server Configuration/Service Account tab | **SQL Server Agent and SQL Server Database Engine:**  
- **Account Name**: NT AUTHORITY\SYSTEM  
- **Startup Type**: Automatic  
**SQL Server Integration Services 10.0:**  
- **Account Name**: NT AUTHORITY\SYSTEM  
- **Startup Type**: Automatic  
**SQL Server Browser:**  
- **Account Name**: NT AUTHORITY\LOCAL SERVICE  
- **Startup Type**: Automatic |
| Server Configuration/Collation tab | 1. For **Database Engine**, click **Customize**.  
2. In the dialog box, select **Windows Collation designator and sort order**, and the **Collation designator** that matches your locale. Keep the other selections.  
You cannot use Enterprise PDM on a server using binary settings.  
3. Click **Next**. |
<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
</table>
| Database Engine Configuration/Account Provisioning tab | 1. Select **Mixed Mode (SQL Server Authentication and Windows Authentication)**. Enterprise PDM uses SQL Server authentication for database communication.  
2. Type a strong password for the system administrator account (**sa**). Do not leave the password blank. For password rules, click **Help**.  
Retype the password to confirm it.  
*Remember the password for use when setting up Enterprise PDM file vault databases.*  
3. Under **Specify SQL Server administrators**, click **Add**.  
4. In the Select Users, Computers, or Groups dialog box, enter the name of the local administrator of the system or the Administrators group.  
5. Click **Next**. |
| Database Engine Configuration/Data Directories tab | (Optional) To change the default folder where databases created by Enterprise PDM are stored, change the location for **User database directory** and **User database log directory**. |
| Error and Usage Reporting | Click **Next**. |
| Installation Rules | The installer checks for problems that will prevent the installation of SQL Server 2008.  
- If no problems are reported, click **Next**.  
- If problems are reported:  
  1. Click **Show details** to list the components that failed or prompted warnings.  
  2. Click **Cancel** to stop the installation and fix the problems. |
| Ready to Install | Click **Install**. |
| Installation Progress | Installation may take a long time.  
If you get an error regarding the SQL Server Backwards-Compatibility Files, cancel the installation. Use **Uninstall a program** to uninstall the Microsoft SQL Server 2005 Backward Compatibility package. Then restart the SQL Server 2008 installation.  
When the progress bar shows **Setup process complete**, click **Next**. |
<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Complete</td>
<td>Click <strong>Close</strong>. If you receive a message that computer restart is required, click <strong>OK</strong>. If a restart does not begin automatically, manually restart your computer.</td>
</tr>
</tbody>
</table>

**After Installing SQL Server 2008**

To use secure SQL communication over the network and have a certificate server, you can enable SSL encryption.

See the following Microsoft articles:

- http://support.microsoft.com/kb/316818/en-us

**Verifying That SQL Server 2008 Was Installed Correctly**

1. From the Windows **Start** menu, click **All Programs > Microsoft SQL Server 2008 > Configuration Tools > SQL Server Configuration Manager**.
2. Click **SQL Server 2008 Services** and see whether **SQL Server (MSSQLSERVER)** is running.
3. If it is not, start the service by right-clicking **SQL Server (MSSQLSERVER)** and selecting **Start**.

**Upgrading to SQL Server 2008**

Follow these instructions to upgrade an existing SQL Server 2000 or SQL 2005 instance to SQL Server 2008 or SQL Server 2008 R2.

If upgrading to SQL Server 2008, see the SQL Server 2008 books online for detailed instructions:


If upgrading to SQL Server 2008 R2, see

If you are uncertain of which SQL Server version is installed, refer to Microsoft Knowledge Base article 321185 to identify version and edition:


All file vault databases are automatically upgraded to SQL Server 2008 format when the server instance is upgraded.
Performing the Upgrade to SQL Server 2008

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2008 installation media, and from the root folder, double-click setup.exe.
   
   Use the default selections unless otherwise instructed.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server Installation Center/Planning page</td>
<td>In the left pane, click <strong>Installation</strong>.</td>
</tr>
<tr>
<td>SQL Server Installation Center/Installation page</td>
<td>Click <strong>Upgrade from SQL Server 2000 or SQL Server 2005</strong>.</td>
</tr>
<tr>
<td>Setup Support Rules</td>
<td>The installer checks for problems that will prevent the installation of the SQL Server support files:</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>1. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>2. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
<tr>
<td>Product Key</td>
<td>1. Select <strong>Enter the product key</strong> and type your license key.</td>
</tr>
<tr>
<td></td>
<td>2. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>License Terms</td>
<td>1. Read and accept the license agreement.</td>
</tr>
<tr>
<td></td>
<td>2. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Setup Support Files</td>
<td>Click <strong>Install</strong>.</td>
</tr>
<tr>
<td>Setup Support Rules</td>
<td>The installer performs an additional check.</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>1. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>2. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
<tr>
<td>Select Instance</td>
<td>Select the SQL Server instance to upgrade.</td>
</tr>
<tr>
<td></td>
<td><strong>MSSQLSERVER</strong> is the default.</td>
</tr>
<tr>
<td>Screen</td>
<td>Action</td>
</tr>
<tr>
<td>------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Select Features</td>
<td>Lists the installed SQL features that will be upgraded.</td>
</tr>
<tr>
<td></td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Instance Configuration</td>
<td>Lists the named instance that will be upgraded.</td>
</tr>
<tr>
<td></td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Disk Space Requirements</td>
<td>If disk space requirements are met, click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>If disk space requirements are not met:</td>
</tr>
<tr>
<td></td>
<td>1. Note the space required.</td>
</tr>
<tr>
<td></td>
<td>2. Click <strong>Cancel</strong>.</td>
</tr>
<tr>
<td></td>
<td>3. Add the required space.</td>
</tr>
<tr>
<td></td>
<td>4. Run the installation again.</td>
</tr>
<tr>
<td>Server Configuration</td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Full-text Upgrade</td>
<td>Select <strong>Import</strong> and click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Error and Usage Reporting</td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Upgrade Rules</td>
<td>The installer checks for problems that will prevent the upgrade to SQL Server 2008.</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>1. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>2. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
<tr>
<td>Ready to Upgrade</td>
<td>Click <strong>Upgrade</strong>.</td>
</tr>
<tr>
<td>Upgrade Progress</td>
<td>When the upgrade finishes for all components, click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Complete</td>
<td>Click <strong>Close</strong>.</td>
</tr>
<tr>
<td>SQL Server Installation Center</td>
<td>Click X in the upper right corner to close.</td>
</tr>
</tbody>
</table>

**After Upgrading to SQL Server 2008**

- Verify the upgrade.
Installing SQL Server 2005

The installer provides help. See the SQL Server books online for detailed installation instructions.

Click here to view the SQL Server books online.

Before Installing SQL Server 2005

Use Uninstall a program to see if the Microsoft SQL Server 2005 Backward Compatibility package is installed. If it is, remove the package before starting the SQL Server 2005 installation.

Performing the SQL Server 2005 Installation

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2005 CD, and use the default selections unless otherwise instructed.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>Under Install, select Server components, tools, books online, and samples.</td>
</tr>
<tr>
<td>End User License Agreement</td>
<td>1. Read and accept the license agreement.</td>
</tr>
<tr>
<td></td>
<td>2. Click Next.</td>
</tr>
<tr>
<td>Installing Prerequisites</td>
<td>• If required components are listed, click Install.</td>
</tr>
<tr>
<td></td>
<td>• If there are no prerequisites, click Next.</td>
</tr>
<tr>
<td>Welcome to the Microsoft SQL Server Installation Wizard</td>
<td>Click Next. The installation wizard scans the system to ensure the requirements are met.</td>
</tr>
<tr>
<td>System Configuration Check</td>
<td>View and correct any warnings.</td>
</tr>
<tr>
<td></td>
<td>If there are no warnings, click Next.</td>
</tr>
<tr>
<td>Registration Information</td>
<td>Type your name and company information and click Next.</td>
</tr>
</tbody>
</table>
### Components to Install

1. Select:
   - **SQL Server Database Services**
   - **Workstation components, Books Online and development tools**

   Click **Advanced** to use custom options, for example, to remove the development tools, or specify an installation location other than C:\Program Files\Microsoft SQL Server.

2. Click **Next**.

### Instance Name

If this is a new installation, select **Default instance** and click **Next**.

If SQL Server is already installed on the system and you opted not to upgrade:

1. Select **Named Instance**.
2. Enter a unique instance name for this installation:
   
   computername\instancename.

3. Click **Next**.

### Service Account

1. Select **Use the built-in System account, Local system**.

2. Under **Start services at the end of setup**, select **SQL Server Agent** and **SQL Browser**.

   **SQL Server** is selected by default.

3. Click **Next**.
<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Authentication Mode</td>
<td>1. Select <strong>Mixed Mode (Windows Authentication and SQL Server Authentication)</strong>. Enterprise PDM uses SQL Server authentication for database communication.</td>
</tr>
<tr>
<td></td>
<td>2. Type a strong password for the system administrator account (<strong>sa</strong>). Do not leave the password blank. For password rules, click <strong>Help</strong>.</td>
</tr>
<tr>
<td></td>
<td>Remember the password for use when setting up Enterprise PDM file vault databases.</td>
</tr>
<tr>
<td></td>
<td>3. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Collation Settings</td>
<td>1. Under <strong>Collation Settings for service: SQL</strong>, select <strong>Collation designator and sort order</strong>, and the collation that matches your locale.</td>
</tr>
<tr>
<td></td>
<td>Keep the other selections.</td>
</tr>
<tr>
<td></td>
<td>You cannot use Enterprise PDM on a server using binary settings.</td>
</tr>
<tr>
<td></td>
<td>2. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Error and Usage Report Settings</td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Ready to Install</td>
<td>Click <strong>Install</strong>.</td>
</tr>
<tr>
<td>Setup Progress</td>
<td>When setup finishes for all components, click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>If you get an error regarding the SQL Server Backwards-Compatibility Files:</td>
</tr>
<tr>
<td></td>
<td>1. Cancel the installation.</td>
</tr>
<tr>
<td></td>
<td>2. Use <strong>Uninstall a program</strong> to uninstall the Microsoft SQL Server 2005 Backward Compatibility package.</td>
</tr>
<tr>
<td></td>
<td>3. Restart the SQL Server 2005 installation.</td>
</tr>
<tr>
<td>Completing Microsoft SQL Server 2005 Setup</td>
<td>Click <strong>Finish</strong>.</td>
</tr>
</tbody>
</table>
**After Installing SQL Server 2005**

Apply SQL 2005 Service Pack 2 (SP2) or higher. For details, see *Installing the SQL Server 2005 Service Pack* on page 30.

To use secure SQL communication over the network and have a certificate server, you can enable SSL encryption. See the following Microsoft articles:

- [http://support.microsoft.com/kb/316818/en-us](http://support.microsoft.com/kb/316818/en-us)

**Verifying That SQL Server 2005 Was Installed Correctly**

1. From the Windows **Start** menu, click **All Programs** > Microsoft SQL Server 2005 > **Configuration Tools** > **SQL Server Configuration Manager**.
2. Click **SQL Server 2005 Services** and see whether **SQL Server (MSSQLSERVER)** is running.
3. If it is not, start the service by right-clicking **SQL Server (MSSQLSERVER)** and selecting **Start**.

**Upgrading to SQL Server 2005**

Follow these instructions to upgrade an existing SQL Server 7 or SQL Server 2000 instance to SQL Server 2005.

See the SQL Server books online for detailed instructions:

Click here to view the SQL Server books online.

If you are uncertain of which SQL Server version is installed, refer to Microsoft Knowledge Base article 321185 to identify version and edition:


All file vault databases are automatically upgraded to SQL Server 2005 format when the server instance is upgraded.

**Before Upgrading to SQL Server 2005**

Perform these configuration steps before upgrading to SQL Server 2005.

- Make a full SQL backup of all existing SQL databases.

  You cannot downgrade a database that has been upgraded to SQL Server 2005 or SQL Server 2008, or restore a SQL 2005 or SQL 2008 database backup in an older SQL Server version (i.e., SQL Server 2000). However, you can restore a SQL/MSDE 2000 database backup directly into SQL Server 2005.

- Ensure that you upgrade the correct instance of SQL Server.

  It is possible to run SQL Server 2005 parallel to SQL Server 2000 or 7. However, it is recommended to upgrade, not to create an instance.
• If Enterprise PDM is already installed on the system, use Uninstall a program to uninstall the Microsoft SQL Server 2005 Backward Compatibility package.
• Obtain the user name and password of an SQL account with administrative access to the instance you are upgrading.

Performing the Upgrade to SQL Server 2005

Follow this process for upgrading to SQL Server 2005.

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2005 CD, and use the default selections unless otherwise instructed.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start</td>
<td>Under Install, click Server components, tools, books online, and samples.</td>
</tr>
<tr>
<td>End User License Agreement</td>
<td>1. Read and accept the license agreement. 2. Click Next.</td>
</tr>
<tr>
<td>Installing Prerequisites</td>
<td>If any required components are listed. click Install. If there are no required components, click Next.</td>
</tr>
<tr>
<td>Welcome to the Microsoft SQL Server Installation Wizard</td>
<td>Click Next. The installation wizard scans the system to ensure the requirements are met.</td>
</tr>
<tr>
<td>System Configuration Check</td>
<td>View and correct any warnings before continuing. If there are no warnings, click Next.</td>
</tr>
<tr>
<td>Registration Information</td>
<td>Type your name and company information and click Next.</td>
</tr>
</tbody>
</table>
| Components to Install | 1. Select:  
  - SQL Server Database Services  
  - Workstation components, Books Online and development tools  
    Click Advanced to use custom options, for example, to remove the development tools, or specify an installation location other than C:\Program Files\Microsoft SQL Server.  
  2. Click Next. |
### Screen | Action
--- | ---
**Instance Name** | 1. Select the instance to upgrade, typically the Default instance.
To upgrade a Named instance, select an existing instance. If you enter a new instance name, SQL Server 2005 is installed in addition to the older server and does not replace or upgrade it. Refer to SQL Server books online for detailed instructions on upgrading instances.

Click **Installed Instances** to see a list of existing instances on the server that can be upgraded on the system. In the Installed Instances dialog box, select the instance to upgrade and click **OK**.

2. Click **Next**.

**Existing Components** | Select all SQL components that can be upgraded and click **Next**.

**Upgrade Logon Information** | 1. Select **SQL Server Authentication Mode**.
2. Type the username and password of an SQL account with system administrative access to the instance being upgraded (typically the sa user account).
3. Click **Next**.

**Service Account** | 1. Select **Use the built-in System account, Local system**.
2. Under **Start services at the end of setup**, select **SQL Browser**.
3. Click **Next**.

**Error and Usage Report Settings** | Click **Next**.

**Ready to Install** | Click **Install**.

**Setup Progress** | When setup finishes for all components, click **Next**.

**Completing Microsoft SQL Server 2005 Setup** | Click **Finish**.
After Upgrading to SQL Server 2005

After you upgrade to SQL Server 2005, there are a few additional validation and configuration steps.

Some of these procedures, such as troubleshooting, are the same for SQL Server 2005 as they are for SQL Server 2008.

- Verify the upgrade.
  For details, see Verifying That SQL Server 2005 Was Installed Correctly on page 27.
- Apply SQL 2005 Service Pack 2 (SP2) or higher.
  For details, see Installing the SQL Server 2005 Service Pack on page 30.
- Troubleshoot problems.
  For details, see SQL Server Troubleshooting on page 32.

Installing the SQL Server 2005 Service Pack

Enterprise PDM requires at least Service Pack 2 (SP2) installed on the SQL Server 2005 instance hosting the file vault databases.

Follow these instructions to apply the latest SQL Server 2005 service pack.

For more information, see the service pack installation documentation on the download site.

Determining the Currently Installed Version of SQL Server 2005

Using SQL Server Management Studio, you can determine which version of SQL Server 2005 is installed.

1. From the Windows Start menu, click All Programs > Microsoft SQL Server 2005 > SQL Server Management Studio.
2. Log in as a system administrator.
3. Right-click the server and select Properties.
4. In the left pane, click General.
5. In the right pane, locate the version number and use this table to determine the service pack.

<table>
<thead>
<tr>
<th>Version Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>9.00.1399.06</td>
<td>SQL Server 2005</td>
</tr>
<tr>
<td>9.00.2047.00</td>
<td>SQL Server 2005 Service Pack 1 (SP1)</td>
</tr>
<tr>
<td>9.00.3042.00</td>
<td>SQL Server 2005 Service Pack 2 (SP2)</td>
</tr>
</tbody>
</table>

6. If Service Pack 2 is not installed, download and install it.
Obtaining the SQL Server 2005 Service Pack

Follow this process to download SQL Server 2005 Service Pack 2 from Microsoft.

2. Under How to obtain, click To obtain SQL Server 2005 SP2.
3. Select the appropriate package for the server platform (32-bit or 64-bit edition) and language of SQL Server 2005 you are using. The “x86” package is for the 32-bit edition.
4. Download the service pack files to the SQL Server.

Preparing To Install the SQL Server 2005 Service Pack

Before installing a SQL Server 2005 Service Pack, perform these procedures.

1. Make a full SQL backup of any existing SQL user databases (for example, the file vault database.)
2. From the Windows Start menu, click Control Panel > Administrative Tools.
3. In the Administrative Tools dialog box, click Services.
4. In the Services dialog box, stop all applications and services that connect to the instances of SQL Server being upgraded.
   These include:
   • SQL Server Management Studio
   • Enterprise PDM database server
   • Enterprise PDM archive server

   Do NOT stop these SQL services:
   • SQL Server (MSSQLSERVER)
   • SQL Server Agent (MSSQLSERVER)

Installing the SQL Server 2005 Service Pack

To install a SQL Server 2005 Service Pack, follow this procedure.

1. Run the self-extracting service package file.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>Click Next.</td>
</tr>
<tr>
<td>License Terms</td>
<td>Read and accept the license agreement and click Next.</td>
</tr>
<tr>
<td>Feature Selection</td>
<td>Verify that all features are selected and click Next.</td>
</tr>
<tr>
<td>Authentication</td>
<td>Select Apply selection to all instances and click Next.</td>
</tr>
<tr>
<td>Error and Usage Reporting</td>
<td>Select reporting options and click Next.</td>
</tr>
<tr>
<td>Settings</td>
<td></td>
</tr>
</tbody>
</table>
**Screen** | **Action**
---|---
Running Processes | End any running processes and click **Next**.
Ready to Install | Click **Install**.
Setup Progress | When setup finishes for all components, click **Next**.
Completing Microsoft SQL Server 2005 SP2 Setup | Click **Next**.

**Additional Information**
- If you are not running Windows Vista or later, clear Launch the provisioning tool for Windows Vista after SP2 installation completes and click Finish to close the Setup wizard.
- If you are running Windows Vista or later, in the SQL Server User Provisioning on Vista dialog box, under Available privileges, select the administrative privileges needed and move them to the Privileges that will be granted list.

2. If a reboot was not required, you may have to start the SQL Server service:
   a) From the Windows **Start** menu, click All Programs > Microsoft SQL Server 2005 > Configuration Tools > SQL Server Configuration Manager.
   b) Select SQL Server 2005 Services.
   c) If **SQL Server (MSSQLSERVER)** is not running, right-click it and click **Start**.

3. Start any other services that you stopped before the service pack was applied, including the database server and archive server.

### SQL Server Troubleshooting

**Clients cannot work in the file vault**

**Cause**
The SQL password has expired or the account has been locked out.

**Solution**
Unlock the account by logging in using Windows Authentication.

**To unlock the SQL Server Account**

1. From the Windows **Start** menu, click All Programs > Microsoft SQL Server 2008 > SQL Server Management Studio.
2. In the Connect to Server dialog box:
   a) For **Authentication**, select **Windows Authentication**.
   b) Click **Connect**.
3. In the left pane, expand **Security** and select **Logins**.
4. Right-click the SQL login that is defined for use in the archive server (typically the \textit{sa} account) and select **Properties**.
5. In the Login Properties dialog box, in the left pane, click **Status**.
6. Under **Status**, for **SQL Server authentication**, clear **Login is locked out**.
7. Exit SQL Server Management Studio.

**Enterprise PDM administrative features fail**

<table>
<thead>
<tr>
<th>Cause</th>
<th>Remote connections are not allowed.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solution</td>
<td>Enable the SQL Server remote access option.</td>
</tr>
</tbody>
</table>

**To enable the SQL server remote access option**

1. From the Windows **Start** menu, click **All Programs > Microsoft SQL Server 2008 > SQL Server Management Studio**.
2. Log in as system administrator.
3. Right-click the server and select **Properties**.
4. In the Server Properties dialog box, click **Connections**.
5. In the right pane, under **Remote server connections**, verify that **Allow remote connections to this server** is selected, and click **OK**.

**Enterprise PDM cannot connect to the server**

<table>
<thead>
<tr>
<th>Cause</th>
<th>TCP/IP is not enabled, or the TCP port is wrong.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Solution</td>
<td>Activate the TCP/IP protocol for client connections and ensure that TCP port 1433 is open.</td>
</tr>
</tbody>
</table>

**To activate the SQL Server TCP/IP protocol:**

1. From the Windows **Start** menu, click **All Programs > Microsoft SQL Server 2008 > Configuration Tools > SQL Server Configuration Manager**.
2. Log in as system administrator.
3. In the left pane, expand **SQL Server 2008 Network Configuration**, and click **Protocols for MSSQLSERVER**.
4. In the right pane, verify that TCP/IP is enabled.
5. Right-click **TCP/IP** and select **Properties**.
6. On the IP Addresses tab, ensure that TCP is using port 1433.
7. Exit the SQL Server Configuration Manager.
Changing the SQL Server Login Account Used by Enterprise PDM

The archive and/or database server services must be able to reach any Enterprise PDM databases they manage using an SQL login that has at least db_owner access to the databases. Normally when SQL Server is installed, a system administrator login (sa) is created that has full access to all databases on the SQL Server.

Use this system administrator, or create a new user with db_owner access to the Enterprise PDM databases.

If you plan to create new file vault databases using a db_owner SQL login, create this SQL login first.

To create a new file vault database, you must log in as a SQL system administrator. If you use a db_owner SQL login, you are prompted for the system administrator (sa) login during vault creation.

Creating a New SQL Login Account

1. On the SQL Server that should host the new Enterprise PDM databases, from the Windows Start menu, click All Programs > Microsoft SQL Server 2005 > SQL Server Management Studio.
2. Log in as a system administrator.
3. In the left pane, expand Security.
4. Right-click Logins and select New Login.
5. In the Login - New dialog box, select General:
   a) Type a Login name for the new SQL user.
   b) Select SQL Server Authentication and enter a password.
   c) Clear Enforce password policy.
   d) Click OK.
6. Close the management studio.

This login does not need any additional permissions to be used by Enterprise PDM.

Using the New SQL Login with the Enterprise PDM Archive

1. On the system running the Enterprise PDM archive server, from the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Archive Server Configuration.
2. In the SolidWorks Enterprise PDM Archive Server dialog box, select Tools > Default settings.
3. In the Settings dialog box, under SQL login, click Change.
4. In the Change SQL User Login dialog box, enter the SQL user login and password of the new SQL user.

From now on, new file vault databases that are created are assigned db_owner access for this user.

5. On the system running the Enterprise PDM database server, from the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Database Server Configuration.

6. In the SolidWorks Enterprise PDM Database Server dialog box, enter the new SQL user login and password, and click OK.

7. Restart the SolidWorks Enterprise PDM Database Server service.

**Giving an SQL User db_owner Access to Existing Enterprise PDM File Vault Databases**

1. On the SQL Server that hosts the new Enterprise PDM databases, from the Windows Start menu, click All Programs > Microsoft SQL Server 2005 > SQL Server Management Studio.

2. Log in as a system administrator.

3. In the left pane, expand Security and click Logins.

4. Right-click the SQL user and select Properties.

5. In the Login Properties dialog box:
   a) In the left pane, select User Mapping.
   b) In the right pane, under Users mapped to this login, select Map for all Enterprise PDM databases (file vault databases and ConisioMasterDb.)
   c) For each database, under Database role membership, select db_owner.
   d) Click OK.

6. Right-click the server and select New Query.

7. In the right pane, enter the following query statement on the new db_owner user and click Execute.

   GRANT VIEW SERVER STATE TO [SQL_USER_NAME]

8. Exit Microsoft SQL Server Management Studio.

9. On the system running the Enterprise PDM archive server, from the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Archive Server Configuration.

10. In the SolidWorks Enterprise PDM Archive Server dialog box, select Tools > Default settings.

11. In the Settings dialog box, under SQL login, click Change.

12. In the Change SQL User Login dialog box, enter the SQL user login and password of the new SQL user and click OK.

13. On the system running the Enterprise PDM database server, from the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Database Server Configuration.

14. In the SolidWorks Enterprise PDM Database Server dialog box, enter the new SQL user login and password and click OK.

15. Restart the SolidWorks Enterprise PDM Database Server service.
Insufficient SQL Permissions

If you do not assign the SQL user sufficient SQL permissions, you cannot log in to any file vault views.

Warning messages are displayed if the SQL user does not have at least db_owner access:

- To the ConisioMasterDb database
  
  For example:

  ```
  Could not log in to the database "filevault on Server servername".
  ```

- To the file vault database
  
  For example:

  ```
  Could not access the item in the database.
  ```
Installing SolidWorks Enterprise PDM

The SolidWorks Enterprise PDM media contains the server and client components. You can install each component separately, or select multiple components to install in a single operation.

For example, to install the database server and archive server on the same computer, you can select both options on the Server Installation screen.

When you install multiple components, the screens appropriate to those components are displayed. For simplicity, the procedures in this chapter describe the component installations separately.

This chapter includes the following topics:

- Initiating Enterprise PDM Installations
- Installing SolidWorks Enterprise PDM Database Server
- Installing SolidWorks Enterprise PDM Archive Server
- Installing SolidWorks Enterprise PDM Web Server
- Installing SolidWorks Enterprise PDM Client

Initiating Enterprise PDM Installations

You perform the same initial steps to begin all Enterprise PDM installations. The following components must be installed to install SolidWorks Enterprise PDM:

- Windows Installer 3.1
- MSXML 6.0
- .Net Framework 4.0

Adobe Acrobat must be installed if you want to view documentation provided on the SolidWorks Enterprise PDM DVD.

To initiate the Enterprise PDM installation:

1. Insert the SolidWorks Enterprise PDM DVD.
   If the SolidWorks Enterprise PDM Setup screen is not displayed, navigate to Autorun.exe on the install disk and double-click.
You can also start the installation wizard manually by running `\setup\setup.exe` from the CD; however, this bypasses the initial installation screen.

2. On the SolidWorks Enterprise PDM Setup screen, to change the setup screen language and the language that is installed, place your cursor over the language icon 🇧🇷 and select a language.

3. At the bottom of the screen, you can:
   - Click the first two links to view summary installation instructions.
   - Click **Administration Guides** to view installation and administration documentation.

4. To begin the installation, click **Install**.
   The installation wizard checks whether the required software components, Windows Installer 3.1, MSXML 6.0, and .Net Framework 4.0, are installed on the system.

5. If a required component is missing, a dialog box listing the missing components is displayed.
   Click **OK** to install the components.

When done, the installation wizard continues. Initiate the installation using these instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>License Agreement</td>
<td>Accept the license agreement and click <strong>Next</strong>.</td>
</tr>
</tbody>
</table>
| Customer Information    | 1. Enter **User Name** and **Organization**.  
|                         | 2. Select the **Default language**.          
|                         | 3. Click **Next**.                          |
| Destination Folder      | To accept the default installation location, click **Next**.  
|                         | To specify a different installation location:  
|                         | 1. Click **Change**.                         
|                         | 2. Browse to the new location.               
|                         | 3. Click **OK**.                            
|                         | 4. Click **Next**.                          |
• To install one or more Enterprise PDM servers, select **Server Installation**.

For details, see:

- **Installing SolidWorks Enterprise PDM Database Server** on page 39
- **Installing SolidWorks Enterprise PDM Archive Server** on page 41
- **Installing SolidWorks Enterprise PDM Web Server** on page 50

• To install the Enterprise PDM client, select **Client Installation**.

For details, see **Installing SolidWorks Enterprise PDM Client** on page 50.

• To choose the features to be installed (including Item Explore and the GZ filter for indexing compressed archives), select **Custom**.

---

### Installing SolidWorks Enterprise PDM Database Server

The database server periodically polls Enterprise PDM databases for updates such as notifications, local view refresh, replication schedule updates, and index server changes.

It must be installed for:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Automatic notifications</strong></td>
<td>Workflow and other automatic notifications, such as change state, check out, check in, add, and deadline</td>
</tr>
<tr>
<td><strong>View updates</strong></td>
<td>Automatic updates (refresh) of listings in file vault views and add-ins</td>
</tr>
<tr>
<td><strong>Card list updates</strong></td>
<td>Periodic updates of card lists that use SQL queries for their content</td>
</tr>
<tr>
<td><strong>Cold store scheduling</strong></td>
<td>Updates of archive servers with changes made to cold store schedules</td>
</tr>
<tr>
<td><strong>Replication scheduling</strong></td>
<td>Updates of archive servers with changes made to replication schedules</td>
</tr>
<tr>
<td><strong>Index server administration</strong></td>
<td>Administration of the indexing service for content searches</td>
</tr>
<tr>
<td><strong>Data import/export</strong></td>
<td>Execution of data import and export rules at predefined intervals</td>
</tr>
</tbody>
</table>
It is recommended that you install the database server on the same system as Microsoft SQL Server. You can install it on another system, but some network overhead may occur.

**Before Installing the Database Server**

- Ensure that the database server has access to the archive server over TCP port 3030 and to the SQL Server over TCP port 1433.
- Obtain the following information:
  - SQL Server name
  - Name and password of an SQL user account with read/write access

If you do not know the name of a user with read and write access, you can use the SQL sa account that has these permissions. You can also create a login for this purpose. For details, see [Changing the SQL Server Login Account Used by Enterprise PDM](#) on page 34.

**Performing the Database Server Installation**

1. Login locally or remotely as a user with local administrative rights on the system where you are installing the database server.
2. Begin the installation, as described in [Initiating Enterprise PDM Installations](#) on page 37.
3. Complete the installation using these instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Setup Type</strong></td>
<td>Select <strong>Server Installation</strong> and click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td><strong>To install multiple components on the same system, such as client and server components, or install additional components, select <strong>Custom</strong>.</strong></td>
</tr>
<tr>
<td><strong>Server Installation</strong></td>
<td>Select <strong>Database Server</strong> and click <strong>Next</strong>.</td>
</tr>
</tbody>
</table>
### SolidWorks Enterprise PDM Database Server SQL Login

1. Specify the name of the SQL server to host the file vault databases, by doing one of the following:
   - Type the name of the SQL server.
   - Click **Browse** to select from the list of available SQL server instances on the network and click **OK**.
     - If SQL server is installed on the system where you are installing the database server, type or select **(local)**.

2. In the **Login name** field, type the name of an SQL user on the server who has read and write access (i.e., db_owner permission) to all Enterprise PDM databases hosted on the SQL server (the file vault databases and **ConisioMasterDb**.)

3. In the **Password** field, enter the SQL user's password.

4. Click **Next**.
   - The login information is verified. If it is incorrect, a warning is displayed.

### Ready to Install the Program

Click **Install**.

### InstallShield Wizard Completed

Click **Finish**.

---

### Installing SolidWorks Enterprise PDM Archive Server

The archive server hosts the physical files (drawings, documents, etc.) stored in a Enterprise PDM file vault and manages Enterprise PDM users and their credentials.

All clients using Enterprise PDM must connect to one or more archive servers hosting one or more file vault archives.

The archive server runs as a service on the system account of the computer where it is installed, sending and receiving files between the clients and the file vault archive. It also stores passwords and user login information. Only one archive server installation is required per computer, hosting one or more file vault archives.

In a replicated environment, multiple archive servers can be set up to host replicated copies of the same file vault archive. See the *SolidWorks Enterprise PDM Replication Guide*, located in the `\Support\Guides\` directory of the SolidWorks Enterprise PDM DVD.
To prevent problems attaching to the archive server, the server name should be 15 characters or less.

## Before Installing the Archive Server

Set up the users, accounts, and permissions required to complete the archive server installation.

### Root folder access

The system account must have full access rights to create folders and files under the folder to be designated as the archive server root folder. The root folder can also be on a network share that allows the archive server service to both read and write files.

You can change the archive server service log-on account to users other than the system account in the service properties.

### SQL user account

The SQL user that communicates with Enterprise PDM file vault databases must have at least db_owner permissions to any existing file vault databases on the SQL Server.

You can use the sa account that was created when the SQL Server was installed.

For more information about SQL logins, see [Changing the SQL Server Login Account Used by Enterprise PDM](#) on page 34.

### User and group accounts

If you want to assign user and group access rights to the archive server during the installation, create the users and groups before you begin.

To use domain users in Enterprise PDM, create a domain group on the domain controller and add domain users that should be able to log into SolidWorks Enterprise PDM.

- During installation, add the domain group using the Find User or Group dialog; the users will appear in the Enterprise PDM administration tool.
- After installation, you can run the Archive Server Configuration tool to add or change user and group assignments.
Performing the Archive Server Installation

1. Login locally or remotely as a user with local administrative rights on the system where you are installing the archive server.
2. Begin the installation, as described in Initiating Enterprise PDM Installations on page 37.
3. Complete the installation using the following instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup Type</td>
<td>Select Server Installation.</td>
</tr>
<tr>
<td>Server Installation</td>
<td>Select Archive Server and click Next.</td>
</tr>
<tr>
<td>Ready to Install the Program</td>
<td>Click Install.</td>
</tr>
<tr>
<td></td>
<td>If you see a message that your local security network access is set to “Guests only” and should be changed to “Classic,” click Yes to accept the change.</td>
</tr>
<tr>
<td></td>
<td>When the installation finishes, the Archive Server Configuration wizard appears.</td>
</tr>
</tbody>
</table>

   Archive Server Configuration Wizard

   Welcome  Click Next.

   Root folder
   1. Do one:
      - Accept the default location for the archive server root folder.
      - Change the location by doing one of the following:
        - Click Browse and browse to a folder.
        - Type the path.
      
      If the folder you specified does not exist, you are asked if it should be created.

      The root folder path is assigned the name Archives, which is used when setting up or attaching to a file vault from the View Setup wizard on a client.

      You must include the root folder and its subfolders (i.e., file vault archives) in the daily backup routines.

   2. Click Next.
### Archive Server Configuration Wizard

| **Admin password** | 1. Type and confirm a password for the Admin user.  
    The Admin user account is assigned full administrative rights to file vaults. Admin can create users, set up workflows, delete files, etc. It is the only user present in a newly created file vault.  
    You can change the password at any time using the Archive Server Configuration tool.  
    2. Click **Next**. |
| **SQL user login and password** | 1. Type the login information for the SQL user who will communicate with the file vault databases hosted on the SQL Server.  
    You can use the SQL Server system administrator user **sa**.  
    If you specify an SQL user with low permissions on the SQL Server, this user will be assigned **db_owner** access to any new file vaults created.  
    2. Click **Next**. |
<table>
<thead>
<tr>
<th><strong>Archive Server Configuration Wizard</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Security</strong></td>
</tr>
<tr>
<td>To define the Windows user accounts that are allowed access to this archive server, by select the accounts under <strong>Available users and groups</strong> and click the arrow pointing to <strong>Administrative access</strong> or <strong>Attach access</strong>.</td>
</tr>
<tr>
<td><strong>Available users and groups</strong></td>
</tr>
<tr>
<td>All local users and groups found on the system are listed by default.</td>
</tr>
<tr>
<td>To add domain accounts to the list:</td>
</tr>
<tr>
<td>1. Click <strong>Find User or Group</strong>.</td>
</tr>
<tr>
<td>2. In the Find User or Group dialog box, search for additional user or group accounts. To add a domain group, for example, type <code>domain\groupname</code> and click <strong>OK</strong>.</td>
</tr>
<tr>
<td><strong>Administrative access</strong></td>
</tr>
<tr>
<td>Provides sufficient access to create new file vaults, or remove, attach, or upgrade existing file vaults on this archive server.</td>
</tr>
<tr>
<td>When you create a file vault, enter the username and password of an account added to this section.</td>
</tr>
<tr>
<td><strong>Attach access</strong></td>
</tr>
<tr>
<td>Provides sufficient access to attach to existing file vaults managed by this archive server.</td>
</tr>
<tr>
<td>When you create a file vault view or connect to a file vault, enter the username and password of an account added to this section.</td>
</tr>
</tbody>
</table>
## Archive Server Configuration Wizard

**Login type**  
Select one of the following authentication methods to use by default when creating new file vaults managed by this archive server:

1. **Enterprise PDM login**  
   - Enterprise PDM user names and passwords are stored on the archive server. You can add and remove them using the Enterprise PDM administration tool on an Enterprise PDM client.

2. **Windows login**  
   - Synchronizes logins to a file vault with the logged-in Windows users (Active Directory). Passwords and names are defined using standard Windows account management.

   In the Windows login settings dialog box, select accounts under **Available users and groups** and add them to **Added users and groups** by clicking the right-arrow button.

   To add domain accounts to the list:
   1. Click **Find User or Group**.
   2. In the Find User or Group dialog box, search for additional user or group accounts. To add a domain group, for example, type `domain\ grouname` and click **OK**.

3. **LDAP login**  
   - Retrieves user accounts from a server using the LDAP method (for example, Novell servers). The users are available when adding users to a file vault using the Enterprise PDM administration tool. Passwords and user names are defined on the LDAP server managing the accounts.

   To define the connection settings to the server using LDAP:

   - **Server name**  
     - Type the name or IP address of an LDAP server.
   - **Port**  
     - Type the port used for LDAP on the server. The default port is 389.
   - **Contexts**  
     - Add at least one context with users that should be listed in the Enterprise PDM user manager.

     The context names must be entered as distinguished names; for example, `O=company, OU=department, O=company` or `CN=Users, DC=company, DC=com`.

### Table: Login Type Details

<table>
<thead>
<tr>
<th>Login Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enterprise PDM</td>
<td>User names and passwords are stored on the archive server. Can be added</td>
</tr>
<tr>
<td>login</td>
<td>and removed using the Enterprise PDM administration tool on an Enterprise</td>
</tr>
<tr>
<td>PDM</td>
<td>PDM client.</td>
</tr>
<tr>
<td>Windows login</td>
<td>Logins synchronize with the logged-in Windows users (Active Directory).</td>
</tr>
<tr>
<td>login</td>
<td>Passwords and names are defined using standard Windows account management.</td>
</tr>
<tr>
<td>LDAP login</td>
<td>Retrieves user accounts from a server using the LDAP method.</td>
</tr>
</tbody>
</table>

---

**User Context**
### Archive Server Configuration Wizard

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Context</td>
<td>Type a context for the user login used by the archive server to connect to the LDAP server.</td>
</tr>
<tr>
<td>Username</td>
<td>Type a username that exists in the user context selected. This user is used by the archive server to connect to the LDAP server.</td>
</tr>
<tr>
<td>Password</td>
<td>Type the password for the selected user.</td>
</tr>
</tbody>
</table>

Completed
Click Finish.

### Opening Ports for Client/Server Communication

Windows Server 2008, Windows 7, and Vista have built-in firewalls activated by default. These can restrict network access to applications requiring connections over the TCP/IP interface.

The archive server uses TCP port 3030 to communicate with the clients. This port must be fully opened in the firewall for an Enterprise PDM installation to work correctly. If the port is not opened, the archive server is not available.

To communicate with clients, the SQL Server TCP port 1433 must also be opened in the firewall.

### Opening Ports on Windows Server 2008, Windows Vista, and Windows 7


You create port rules that enable TCP and UPD ports 3030 and 1433 for both inbound and outbound Enterprise PDM traffic.

**To open the ports:**

1. From the Windows Start menu, click Control Panel.
2. On the Adjust your computer’s settings page, click System and Security.
3. In the right pane, click Windows Firewall.
4. In the left pane, click Advanced settings.
5. In the right pane, under View and create firewall rules, click Inbound Rules.
6. In the far right pane, under Actions, Inbound Rules, click New Rule.
7. In the New Inbound Rule Wizard, on the Rule Type screen, in the right pane, select Port and click Next.
8. In the right pane of the Protocol and Ports screen:
   a) Select TCP.
   b) Select Specific local ports and type 3030.
   c) Click Next.
9. In the right pane of the Action screen, select Allow the connection and click Next.
10. In the right pane of the Profile screen, clear **Public** and click **Next**.

11. In the Name screen, for **Name**, type the exception name – for example, **Enable TCP port 3030 for inbound Enterprise PDM traffic** and click **Finish**.

   The wizard closes and the rule is added to the list of inbound rules. It is enabled by default.

12. Repeat steps 6 through 11 to create an inbound rule for UDP port 3030, and inbound TCP and UDP rules port 1433.

13. In the left pane, click **Outbound Rules**.

14. Repeat the steps 6 and 11 four more times to create outbound rules for TCP and UDP ports 3030 and 1433.

15. Click **File > Exit** to close the Windows Firewall with Advanced Security window.


**Running the Archive Server on Windows Vista**

Windows Vista has a built-in firewall that is activated by default. This can restrict network access to applications requiring connections over the TCP/IP interface.

The archive server uses TCP port 3030 to communicate with the clients. This port must be fully opened in the firewall for an Enterprise PDM installation to work correctly. If the port is not opened, the archive server is not available.

To communicate with clients, the SQL Server TCP port 1433 must also be opened in the firewall.

**To set up the Windows Vista firewall for the archive server:**

1. From the Windows **Start** menu, click **Control Panel > Security Center**.

2. In the Windows Security Center dialog box, under **Manage security settings for**, select **Windows Firewall**.

3. In the Windows Firewall dialog box, select the option **Allow a program through Windows Firewall**.

4. Click **Add Port**.

5. In the Add a Port dialog box:
   a) For **Name**, type the exception name.
   b) For **Port Number**, specify **3030**.
   c) Select **TCP**.
   d) Click **Change Scope**.

6. In the Change Scope dialog box, select **My network (subnet) only** to restrict network access to only network computers. Click **OK** twice.

7. Create another exception for port 3030 by repeating steps 3 through 5, but select **UDP** as the protocol.

8. In the Windows Firewall dialog box, select both new port exceptions to activate them.

9. Click **OK**.
Adding Archive Servers in a WAN Environment

SolidWorks Enterprise PDM clients are normally set up to communicate with the Archive Server and SQL server using the server system names. These system names are resolved to IP addresses.

If this name lookup fails or is slow it can cause the following problems:

- Clients cannot find the servers at all. This is a common problem when using subnets or WAN configurations.
- Overall performance using Enterprise PDM features such as logging in, browsing, or adding files is slow.
- Replication between servers fails.

Verifying That the Server Name Can Be Resolved

To ensure optimal performance, make sure that the DNS server configuration is set up to resolve names correctly and efficiently.

1. Open the command prompt by clicking Start > Run > CMD.
2. Type Ping server_name.
   If the server can be reached by name, a reply with the server IP address appears. For example:
   
   PING SRV-DEV-15
   Reply from 192.168.1.71: bytes=32 time<1ms TTL=128

3. Verify that the correct IP is returned.
   If DNS returns the wrong IP address, a different system than the server responds.
   If the server name cannot be resolved, the DNS server configuration is not correctly configured. For example:
   
   PING SRV-DEV-15
   Ping request could not find host SRV-DEV-15. Please check the name and try again.

Configuring the Hosts File to Resolve the Server Name

If the DNS servers cannot be configured or performance is still bad, update the client’s hosts file with the correct server name and IP address. This ensures that the hosts file is queried for the server address directly instead of waiting for the DNS name resolve.

To configure the hosts file to resolve the server name:

   The default location is:
   C:\Windows\System32\Drivers\Etc\n
2. Open the file in a text editor (for example, Notepad).
3. Add a new line and enter the server IP address followed by the server name.
   For example:
   
   192.168.1.71 SRV-DEV-15
4. Repeat Step 3 for any additional servers used by Enterprise PDM.
5. Save and close the hosts file.

Installing SolidWorks Enterprise PDM Web Server

The SolidWorks Enterprise PDM Web server gives users live access to one or more file vaults from any system using Windows Internet Explorer over the Internet or an intranet.

To learn how to install and use the Web server and client, see the SolidWorks Enterprise PDM Web Server Guide, located in the \Support\Guides\ directory of the SolidWorks Enterprise PDM DVD.

Installing SolidWorks Enterprise PDM Client

For a system to work with an Enterprise PDM file vault, it must have the Enterprise PDM client installed.

The following types of Enterprise PDM clients are available:

<table>
<thead>
<tr>
<th>SolidWorks Enterprise PDM Editor</th>
<th>Supports working with all file types, including enhanced management and previewing of many CAD formats such as SolidWorks, AutoCAD, Inventor, SolidEdge, and Pro/ENGINEER. Should be used on any system working with CAD files.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>To work with Pro/ENGINEER files, install the Pro/ENGINEER CAD add-in after installing the Enterprise PDM client. As of SolidWorks Enterprise PDM 2012, the Pro/ENGINEER connector requires separate installation media. Contact your SolidWorks Value Added Reseller for more information.</td>
</tr>
<tr>
<td></td>
<td>Includes support for Enterprise PDM Web client access.</td>
</tr>
<tr>
<td>SolidWorks Enterprise PDM Contributor</td>
<td>Supports working with all file types, including CAD files. However, CAD add-ins are not supported on this client type.</td>
</tr>
<tr>
<td></td>
<td>Includes support for Enterprise PDM Web client access.</td>
</tr>
<tr>
<td>SolidWorks Enterprise PDM Viewer</td>
<td>Allows read-only access to file vaults; user cannot add or modify (check out, check in, update values) any files. CAD add-ins are not supported on this client type.</td>
</tr>
</tbody>
</table>

You can install clients:

- By using the installation wizard on the SolidWorks Enterprise PDM DVD. For details, see Installing Clients Using the Installation Wizard on page 52.
- By creating an administrative deployment image to install multiple seats. For details, see Creating an Enterprise PDM Client Administrative Image on page 53.

Before Installing Clients

- Find out the type of client your license agreement entitles you to use.
The floating license manager in Enterprise PDM prevents logging into a file vault if the wrong client type is installed.

- If you are installing the Enterprise PDM Editor Client, you can install CAD addins.
  Add-ins make version management features such as check out, check in, and get available from menus and toolbars within your CAD software. They are optional and do not affect which file formats can be managed by Enterprise PDM using the Windows Explorer interface or file open/save dialogs.

The following product-specific prerequisites apply:

**SolidWorks**  You can manage SolidWorks files without having SolidWorks installed. It is recommended to have the eDrawings viewer installed for previewing. EDrawings is normally installed automatically with the client.

**Autodesk Inventor**  To manage Inventor files (add, check out, check in, preview, etc.), the client system must have either the full Autodesk Inventor application or the Inventor Design Assistant software installed. For previewing Inventor files, Inventor View should be installed.

**Autodesk AutoCAD**  AutoCAD does not have to be installed to manage DWG/DXF files. It is recommended to have the eDrawings or DWG TrueView application installed for previewing DWG files and the DWF viewer for previewing DWF files.

**Solid Edge**  Enterprise PDM requires the full Solid Edge application installed for managing and previewing Solid Edge files.

**Pro/ENGINEER**  Enterprise PDM requires the full Pro/ENGINEER application installed for managing and previewing Pro/ENGINEER files.

As of SolidWorks Enterprise PDM 2012, the Pro/ENGINEER Connector requires a separate installation after the SolidWorks client installation. The software can be obtained from your SolidWorks Value Added Reseller.

For more information, log in to the Customer Portal and view the Knowledge Base solution S-029120.

These requirements apply to installations performed from the SolidWorks Enterprise PDM media or from an administrative image.
Installing Clients Using the Installation Wizard

1. Log on to the client computer as a user with local administrative rights.
2. Begin the installation, as described in Initiating Enterprise PDM Installations on page 37.
3. Complete the installation using the following instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setup Type</td>
<td>To install the client without Item Explorer, select Client Installation and click Next.</td>
</tr>
<tr>
<td></td>
<td>To include the Item Explorer in your installation:</td>
</tr>
<tr>
<td></td>
<td>1. Select Custom.</td>
</tr>
<tr>
<td></td>
<td>2. On the Custom Setup screen, under Client, click Item Explorer and select This feature will be installed on local hard drive.</td>
</tr>
<tr>
<td></td>
<td>3. Click Next.</td>
</tr>
<tr>
<td>Choose Product Type</td>
<td>1. Select the type of client to install, based on your license:</td>
</tr>
<tr>
<td></td>
<td>- SolidWorks Enterprise PDM Editor</td>
</tr>
<tr>
<td></td>
<td>- SolidWorks Enterprise PDM Contributor</td>
</tr>
<tr>
<td></td>
<td>- SolidWorks Enterprise PDM Viewer</td>
</tr>
<tr>
<td></td>
<td>2. Click Next.</td>
</tr>
<tr>
<td>Select Add-Ins</td>
<td>1. If the product type is SolidWorks Enterprise PDM Editor, you optionally can select the CAD software add-ins to install.</td>
</tr>
<tr>
<td></td>
<td>2. Click Next.</td>
</tr>
<tr>
<td>Ready to Install the Program</td>
<td>Click Install.</td>
</tr>
<tr>
<td>InstallShield Wizard Completed</td>
<td>Click Finish.</td>
</tr>
</tbody>
</table>

Enabling Logging to Troubleshoot Installation

An installation log is useful when troubleshooting a failing installation.

1. Open a command prompt.
2. Change directory to the appropriate setup folder on the SolidWorks Enterprise PDM DVD:
• For 32-bit systems: **Setup**
• For 64-bit systems: **Setup64**

3. Type the appropriate command to start a logged installation:
   • For 32-bit systems:
     ```
     MSIEXEC /i EnterprisePDM.msi /L*v C:\LOGFILE.TXT
     ```
   • For 64-bit systems:
     ```
     MSIEXEC /i EnterprisePDM64.msi /L*v C:\LOGFILE.TXT
     ```

An installation log is created with information about the installation.

**Creating an Enterprise PDM Client Administrative Image**

An administrative installation image lets you control the installation and upgrade of the client on multiple client machines.

You must create and deploy separate images depending on client license type or operating system (64-bit or 32-bit).

The installation wizard creates a setup package (**EnterprisePDM.msi** and required files) that you can distribute using Microsoft Active Directory or another distribution method.

Keep a copy of the administration image, which includes all options you select, to make it easier to uninstall when doing an upgrade.

**To create an administrative image:**

1. From the Windows **Start** menu, click **Run**.
2. Browse to or type the location of `setup.exe` on your SolidWorks Enterprise PDM DVD and add the command switch `/a`.
   For example:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>32-bit</td>
<td>E:\Setup\setup.exe /a</td>
</tr>
<tr>
<td>64-bit</td>
<td>E:\Setup64\setup.exe /a</td>
</tr>
</tbody>
</table>

3. Click **OK**.
4. Create the administrative image using these instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose Setup Language</td>
<td>Select the language for the setup wizard and click <strong>OK</strong>.</td>
</tr>
<tr>
<td>Screen</td>
<td>Action</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Welcome</td>
<td>Click Next.</td>
</tr>
<tr>
<td>License Agreement</td>
<td>Read and accept the license agreement and click Next.</td>
</tr>
<tr>
<td>Select default language</td>
<td>Select the language for the clients and click Next.</td>
</tr>
</tbody>
</table>
| Item Support                   | • To give clients installing from an administrative image access to the Item Explorer, select Item Explorer and click Next.  
   • To prevent access to the Item Explorer, click Next. |
| Choose Product Type            | 1. Select the type of client for which to create an administrative image, based on the license:  
   • Enterprise PDM Editor  
   • Enterprise PDM Contributor  
   • Enterprise PDM Viewer  
   2. Click Next. |
| Select Add-Ins                 | 1. (Optional) If the product type is Enterprise PDM Editor, select the CAD software add-ins to install.  
   2. Click Next. |
| Network Location               | Enter a location where the Enterprise PDM client administrative image should be created.  
   If you plan to distribute this image, place it on a network resource that is available to all client systems. |
| Ready to Install the Program   | Click Install.                                                         |
| Install Shield Wizard Completed | Click Finish.                                                          |

### Deploying Clients Using Windows Active Directory

By using the Group Policy features of Windows Active Directory, you can centrally deploy, install, and manage Enterprise PDM clients throughout an organization.

You can also perform routine maintenance tasks such as upgrading, patching, and removing clients from a central location, without going to individual workstations.
If you distribute the clients using an administrative image, you must deploy Microsoft XML Core Services (MSXML) 6.0 and .Net Framework 4.0 to all clients.


You are no longer required to deploy the SQL_DMO components to clients.

Only the Enterprise PDM client can be deployed using this method. Install the archieve server and database server using the standard installation method.

Active Directory deployment considerations:

• Because Enterprise PDM is installed on a computer level, before any user has logged on, the deployment package should be available (i.e., shared with sufficient access rights) to all systems assigned for deployment.
• To deploy Enterprise PDM on operating systems using a language other than English, activate the option Ignore language when deploying this application in the advanced deployment package settings.
• Once deployed, you can add file vault views to the clients:
  • Using a policy
    For details, see Distributing an Enterprise PDM File Vault View Using Microsoft Windows Active Directory on page 65.
  • Using a scripted view installation
    For details, see Scripting File Vault View Setup on page 64.

To deploy a client admin image using Windows 2003 Server Active Directory:

1. Create an administrative image (EnterprisePDM.msi) in a network location that is accessible by UNC path to all systems where Enterprise PDM should be deployed.
   For details, see Creating an Enterprise PDM Client Administrative Image on page 53.

2. From the Windows Start menu, click All Programs > Administrative Tools > Active Directory Users and Computers.

3. Create a security group, or use an existing security group.
   To create a security group:
   a) Right-click Users and select New > Group.
   b) In the New Object - Group dialog box, type a Group name.
   c) Under Group type, select Security and click OK.

4. Add the computers where Enterprise PDM should be deployed.
   To add domain computers to the security group:
   a) Right-click the security group and select Properties.
   b) On the Members tab, click Add and add the computers.

5. Right-click the top domain container (or any top organizational unit (OU) containing the target computers) and select Properties.

6. Create a new policy object:
   a) In the container’s Properties dialog box, on the Group Policy tab, click New.
   b) Name the policy object and click OK.
7. Select the new policy object and click **Properties**.
8. In the policy object’s Properties dialog box, on the Security tab, click **Add** to add the security group that contains the computers (created in Step 3.)
9. Select the security group. To assign the policy to the group, under **Permissions**, for the **Apply Group Policy** permission, click **Allow**.
   If you do not want to set the policy on other domain groups, select each group and clear the **Allow** checkbox for **Apply Group Policy**.
10. Click **OK**.
11. Select the new group policy object again and click **Edit**.
12. In the Group Policy Object Editor, navigate to **Computer Configuration > Software Settings > Software Installation**.
13. Right-click and select **New > Package**.
14. Browse to the **EnterprisePDM.msi** file in the location where you created the Enterprise PDM client administrative image.
   
   You should browse to the location through **My Network Places** to use the UNC path correctly. Do not use a mapped drive.

15. Click **Open**.
16. In the Deploy Software dialog box, select **Assigned** and click **OK**.

The client image is ready for deployment and will be installed to the computers in the security group the next time the systems start up.

**Enabling Logging When Deploying Enterprise PDM**

To troubleshoot installation problems that occur when you deploy an Enterprise PDM client administrative image using Windows Active Directory, you should enable logging of the installation procedure. This is done through a Group Policy.

1. On the Active Directory server, locate the OU where the deployment package is assigned.
2. Right-click the OU, and select **Properties**.
3. In the Properties dialog box, on the Group Policy tab, click **New** to add a new Group Policy object. Name the policy (for example, **Logging**) and click **OK**.
4. Select the new policy (or an existing deployment policy) and click **Edit**.
5. In the Group Policy Object Editor, expand **Computer Configuration > Administrative Templates > Windows Components > Windows Installer**.
6. In the right pane, double-click the **Logging** setting.
7. In the policy object’s Properties dialog box:
   a) Enable the policy.
   b) In the **Logging** text box, type the full logging arguments:

   ```
iwearucmpvo
   ```
   c) Click **OK**.
8. On the Group Policy tab, if you created a new group policy object, make sure that the new policy is listed at the top of the list.
When you deploy Enterprise PDM, an `.msi` installation log will be created in the `Temp` folder under the Windows system folder.

**Scripting a Silent Installation of Enterprise PDM**

You can script the client installation from an administrative image (for example, to run the installation from a `.bat` file).

To script a silent installation:

1. Create an administrative image for the client type you are installing to create the `EnterprisePDM.msi` installation package that is used in the following commands. For details, see [Creating an Enterprise PDM Client Administrative Image](#) on page 53.

2. Update your installation script with one of the following commands to launch a silent installation:
   - Silent installation with progress
     ```
     Msiexec /i EnterprisePDM.msi /qb
     ```
   - Silent installation without progress
     ```
     Msiexec /i EnterprisePDM.msi /qn
     ```
   - Silent installation with progress and automatic reboot (if required)
     ```
     Msiexec /i EnterprisePDM.msi /qb-
     ```
   - Silent installation without prompting for reboot
     ```
     Msiexec /i EnterprisePDM.msi /qb REBOOTYESNO=NO REBOOT=REALLYSUPPRESS
     ```
   - Silent installation with progress and without automatic eDrawings installation
     ```
     Msiexec /i EnterprisePDM.msi /qb REMOVE=eDrawings
     ```

If you upgrade a previous installation with this option, you must perform a reboot at the end of the installation to reload any replaced files that are in use.

If you omit the `REMOVE=eDrawings` switch, the eDrawings viewer will automatically be included when installing from an administrative image.

### Silent Installation Switches

<table>
<thead>
<tr>
<th>Switch</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/qn</td>
<td>No UI</td>
</tr>
<tr>
<td>/qb</td>
<td>Basic UI</td>
</tr>
<tr>
<td>Switch</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>/qr</td>
<td>Reduced UI with a modal dialog box displayed at the end of the installation</td>
</tr>
<tr>
<td>/qf</td>
<td>Full UI with a modal dialog box displayed at the end of the installation</td>
</tr>
<tr>
<td>/qn+</td>
<td>No UI except for a modal dialog box displayed at the end of the installation</td>
</tr>
<tr>
<td>/qb+</td>
<td>Basic UI with a modal dialog box displayed at the end of the installation</td>
</tr>
<tr>
<td>/qb-</td>
<td>Basic UI with no modal dialog boxes</td>
</tr>
<tr>
<td>REMOVE=[string]</td>
<td>Excludes a feature from installing</td>
</tr>
</tbody>
</table>
Creating and Distributing File Vault Views

Enterprise PDM file vaults store the files and information managed by Enterprise PDM.

To add a file to a file vault, you place it in a local file vault view, which is a working folder where all intermediate file modifications are performed.

The file vault view is directly connected to:

- The archive server, which stores the physical files in a file vault archive
- The file vault database, which stores information about files and activities in the file vault

You can access files and information stored in a file vault only from a system with the Enterprise PDM client installed by logging in as a user with sufficient access rights.

This chapter includes the following topics:

- Creating the File Vault
- Creating a File Vault View Using the View Setup Wizard
- Distributing an Enterprise PDM File Vault View Using Microsoft Windows Active Directory
- Distributing File Vault Views in a WAN Environment

Creating the File Vault

Use the Enterprise PDM Administration tool to create the file vault on the archive server.

See the section on creating a new file vault in the SolidWorks Enterprise PDM Administration Guide, located in the \Support\Guides\lang directory of the SolidWorks Enterprise PDM DVD.

Creating a File Vault View Using the View Setup Wizard

Users managing files must connect to a file vault through a local file vault view (working folder) created on each client.

To set up the file vault view, the Enterprise PDM client must be installed.

You also can create a local file vault view using the Enterprise PDM Administration tool. See the section on creating a local file vault view in the SolidWorks Enterprise PDM Administration Guide.
To create the file vault view using the View Setup wizard:

1. From the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > View Setup.
2. Create the file vault view using the following instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>Click Next.</td>
</tr>
<tr>
<td>Select archive server(s)</td>
<td>The available archive servers on the network are listed.</td>
</tr>
<tr>
<td></td>
<td>1. If the archive server you want to attach to is listed, select it.</td>
</tr>
<tr>
<td></td>
<td>2. If the archive server you want is not shown:</td>
</tr>
<tr>
<td></td>
<td>a. Click Add.</td>
</tr>
<tr>
<td></td>
<td>b. In the Add Server manually dialog box, type the system name and</td>
</tr>
<tr>
<td></td>
<td>click OK.</td>
</tr>
<tr>
<td></td>
<td>A login dialog box is displayed if your account does not have</td>
</tr>
<tr>
<td></td>
<td>sufficient access rights. Log in with a user account with</td>
</tr>
<tr>
<td></td>
<td>attach access to file vaults on the archive server.</td>
</tr>
<tr>
<td></td>
<td>c. Select the new archive server.</td>
</tr>
<tr>
<td></td>
<td>3. To connect to other archive servers with file vaults, select them.</td>
</tr>
<tr>
<td></td>
<td>4. Click Next.</td>
</tr>
<tr>
<td>Select vault(s)</td>
<td>All file vaults on the selected archive servers are listed.</td>
</tr>
<tr>
<td></td>
<td>1. Select the vaults for which you want to create a local file vault</td>
</tr>
<tr>
<td></td>
<td>view.</td>
</tr>
<tr>
<td></td>
<td>2. Click Next.</td>
</tr>
</tbody>
</table>
Creating and Distributing File Vault Views

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select location</td>
<td>1. Choose where the file vault view will be created.</td>
</tr>
<tr>
<td></td>
<td>You can place the view in any location; however, for a shared view</td>
</tr>
<tr>
<td></td>
<td>that is accessible to all profiles on the system, create it in the</td>
</tr>
<tr>
<td></td>
<td>root of the local hard drive to make it easily accessible.</td>
</tr>
<tr>
<td></td>
<td>2. Select the type of view to create:</td>
</tr>
<tr>
<td></td>
<td><strong>Only for me</strong> The local view is only accessible to the Windows</td>
</tr>
<tr>
<td></td>
<td>profile that is currently logged on the system. Use this option when</td>
</tr>
<tr>
<td></td>
<td>multiple users are using the same system; for example, in a terminal</td>
</tr>
<tr>
<td></td>
<td>server or Citrix environment. Place the local file vault view in a</td>
</tr>
<tr>
<td></td>
<td>user folder that is accessible to the currently logged-in profile.</td>
</tr>
<tr>
<td></td>
<td>For details, see <a href="#">Using Enterprise PDM on a Terminal Server</a> on</td>
</tr>
<tr>
<td></td>
<td>page 63.</td>
</tr>
<tr>
<td></td>
<td><strong>For all users on this computer</strong> The local view is accessible to</td>
</tr>
<tr>
<td></td>
<td>all Windows profiles on this system (preferred). The user currently</td>
</tr>
<tr>
<td></td>
<td>logged in must have local administrator rights to use this option</td>
</tr>
<tr>
<td></td>
<td>because it requires updating the local system registry.</td>
</tr>
<tr>
<td></td>
<td>For details, see [Using a Shared File Vault View with Multiple User</td>
</tr>
<tr>
<td></td>
<td>Profiles](#) on page 62.</td>
</tr>
<tr>
<td></td>
<td>3. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Review actions</td>
<td><strong>Click Finish.</strong></td>
</tr>
<tr>
<td>Completed</td>
<td><strong>Click Closed.</strong></td>
</tr>
</tbody>
</table>

**Enabling Broadcast with Windows Firewalls**

If you are running Enterprise PDM on a workstation where the Windows firewall is activated, you must enable broadcast to list archive servers when users create file vault views using View Setup.

This is because Enterprise PDM uses a broadcast method to get a list of all available archive servers on the network. This broadcast is sent to the default port 3030 on the server system from a dynamic port on the client. By default, Windows firewall only allows a three-second time period to return the broadcast result from the server to the dynamic client port. After that, the broadcast reply is stopped by the firewall.

For the archive server broadcast to work correctly on a client with Windows firewall active, you must allow the applications that request the broadcast through the firewall. For Enterprise PDM, these are the View Setup wizard ([ViewSetup.exe](#)) and the Enterprise PDM administration tool ([ConisioAdmin.exe](#)).
Enabling Broadcast on Windows Server 2008, Windows 7, and Vista

If you are running Enterprise PDM on Windows Server 2008, Windows 7, or Windows Vista, to enable broadcast, you add the applications to the list of allowed programs.

1. From the Windows Start menu, click Control Panel.
2. On the Adjust your computer’s settings page, click System and Security.
3. In the right pane, under Windows Firewall, click Allow a program through Windows Firewall.
4. On the Allow programs to communicate through Windows Firewall screen, under the list of allowed programs, click Allow another program.
5. In the Add a Program dialog box, click Browse to locate ViewSetup.exe (found by default in \Program Files\SolidWorks Enterprise PDM\) and then click Open.
6. Click Add.
   The dialog box closes and the program is added to the list of allowed programs and features.
7. Repeat steps 4 through 6 to add ConisioAdmin.exe, which displays list as Administration.
8. Click OK to close the Allow programs to communicate through Windows Firewall screen.
9. Close the Control Panel.

Using a Shared File Vault View with Multiple User Profiles

A shared file vault view is created by a user with local administrative Windows permissions. The local administrator group is, by default, given full file permissions to any files created (or cached) in that view.

On many systems, the local user or power user groups have only limited file permissions to folders in Windows. If a user with local administrative permissions caches a file in the shared vault view, other Windows user profiles with only user or power user access permissions might not have sufficient permissions to fully access the file or change the read-only state when checking out the file.

If you plan to use a shared file vault view with Windows user or power user profiles, you should define folder access permissions for those groups.

Changing Access Permissions on a Shared View Using the Properties Dialog Box

1. Log into the system as a user with local administrative permissions.
2. In Windows Explorer, navigate to the file vault view folder and select it.
3. Right-click the file vault view folder and select Properties.
4. In the file vault view’s Properties dialog box, click the Security tab.
5. Under **Group or user names**, select the Windows profile groups to use the shared file vault view and make sure that they have all access permissions checked (i.e., *Full Control*).
6. Click **OK**.

**Changing Access Permissions on a Shared View Using the Command Prompt**

1. Log into the system as a user with local administrative permissions.
2. Open a command prompt and open the parent folder containing the file vault view (usually `C:\`).
3. Use the `cacls` command to assign sufficient access control to the user and power user groups.

```bash
CACLS “vault_view_name” /E /G “group_or_username”:F
```

For example, to grant a local users group sufficient access control, type:

```bash
CACLS “c:\EPDM File Vault” /E /G “users”:F
```


**Using Enterprise PDM on a Terminal Server**

Enterprise PDM clients can be installed in a terminal environment, such as Microsoft Terminal Server or Citrix.

Keep in mind the following differences from installing standalone clients:

- The client software is installed once on the terminal server because all terminal profiles use the same core system and program files. You cannot combine different client license types on the same terminal system; the same license type is used by all terminal client profiles.
- When creating local file vault views for terminal clients, you must be logged in as the Windows profile that should have access to the view. Make the views private by using the *Only for me* attach type or *Not available to everyone* option.

To make it easier to administer views to multiple terminal client profiles, use the Enterprise PDM policy or create an administrative view setup file.

Only the Windows profile for which the view was created can log in to the file vault view because the view information is stored in the current user section of the registry, which is only available to the current profile.

- To have the private views rooted to the same location for all profiles, place them in the terminal user’s home folder. For example, use the environment variables `%HOMEDRIVE%\%HOMEPATH%`. These have the same path for most users.
- You should not create a shared view accessible by everyone on the terminal server in a terminal environment. If using a shared view, all terminal users will work in the same local cache, meaning they may overwrite each others file changes.
Creating a File Vault View Setup File

If you create a view setup file (.cvs), you can attach clients to a file vault by running the .cvs file, without having to use the View Setup wizard.

The .cvs file can also be launched silently using triggers, as described in Scripting File Vault View Setup on page 64.

You can create a .cvs file from any existing Enterprise PDM client.

To create the .cvs file:

1. Launch View Setup using the trigger /a.
   
   For example, from the Windows Start menu, click Run and then enter this command:
   ```
   "C:\Program Files\SolidWorks Enterprise PDM\ViewSetup.exe" /a
   ```

2. Step through the View Setup wizard as if creating local views.
   
   See Creating a File Vault View Using the View Setup Wizard on page 59. You can select any number of views.
   
   On the Review Actions screen, the available action is Save to file.

3. Click Finish and specify a location and filename for the view setup file.

4. Click Close.

Using a File Vault View Setup File

You can attach clients to a file vault by running the .cvs file, without having to use the View Setup wizard.

The .cvs file can also be launched silently using triggers, as described in Scripting File Vault View Setup on page 64.

To use the View Setup file:

1. Copy the .cvs file to a client that you want to attach to the file vault.

2. Double-click the .cvs file.
   
   The View Setup wizard opens to the Finish screen, which lists the vaults for which local views will be created.

3. Click Finish.

Scripting File Vault View Setup

The View Setup wizard can be launched using the ViewSetup.exe command with the following triggers to automate view installations. This can be useful when you want to distribute the file vault view using login scripts or a similar distribution method.

<table>
<thead>
<tr>
<th>Option or Argument</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>/a</td>
<td>Creates a view setup file.</td>
</tr>
</tbody>
</table>
**Option or Argument** | **Action**
---|---
`path_to_.cvs_file` | Opens the view setup file and lets you attach using the information from the file.  
The complete path to the `.cvs` file must be used.

`/q` | Performs attach silently without showing wizard. Will only work in combination with `/s` switch or a `.cvs` file.

`/s {VaultID}` | Find the Vault ID by selecting the properties of the vault in the Enterprise PDM administration tool.  
If you have more than one archive server hosting the vault, see **Distributing File Vault Views in a WAN Environment** on page 67.

---

**Examples**

- **Create a vault view silently from the `.cvs` file:**
  
  ```
  ViewSetup.exe PDMWEVault.cvs /q
  ```

- **Create a `.cvs` file with the two file vaults supplied by ID:**
  
  ```
  ViewSetup.exe /s {A0E07E93-F594-42c9-A01B-F613DBA53CB5}{699C4EC3-60FC-452f-940E-8786A7A51B2} /a
  ```

---

**Distributing an Enterprise PDM File Vault View Using Microsoft Windows Active Directory**

By using the Enterprise PDM user policy for Microsoft Windows Active Directory, you can centrally deploy file vault views on client workstations.

Before you configure Active Directory, find the unique vault ID of the vault view you want to distribute, as described in **Finding the Enterprise PDM Vault ID** on page 67.

Most policy dialog boxes have an Explain tab with descriptive text about the policy.

**To distribute a vault view using Windows Server Active Directory:**

1. From the Windows **Start** menu, click **All Programs** > **Administrative Tools** > **Active Directory Users and Computers**.
2. Create a security group (or use an existing group).
3. Right-click the security group and select **Properties**.
4. In the security group’s Properties dialog box, on the Members tab, add the users to which the Enterprise PDM file vault view should be deployed.
5. Right-click the top domain container (or any top organizational unit (OU) containing the target users) and select **Properties**.

6. In the domain Properties dialog box, on the Group Policy tab, click **New** to create a new policy object.

7. Select the new object and click **Properties**.

8. In the object’s Properties dialog box, on the Security tab:
   a) Add the group containing the users to the list and select it.
   b) Under **Permissions**, in the **Allow** column, select **Apply Group Policy** to assign the policy to the group.

   If you do not want the policy to be set on other domain groups, make sure that the permission is turned off on the other groups.

   c) Click **OK**.

9. In the domain Properties Object Editor, select the new object again and click **Edit**.

10. In the Group Policy Object Editor:
    a) Browse to **User Configuration > Administrative Templates**.
    b) Right-click and select **Add/Remove Templates**.

11. In the Policy Templates dialog box, add the **Enterprise PDM** policy template, located on the SolidWorks Enterprise PDM DVD under \Support\Policies\PDMWorks Enterprise.ADM.

12. When it is loaded, click **Close**.

    A new **SolidWorks Enterprise PDM Settings** option appears under the administrative templates.

13. Browse to the **View Setup** folder and double-click **Automatic View Setup**.

14. In the Automatic View Setup Properties dialog box:
    a) Select **Enabled**.
    b) Click **Show** to show the views to install.
    c) In the Show Contents dialog box, click **Add** to add the file vault view.
    d) In the Add Item dialog box, assign a name for the view to be distributed (preferably the same name as the file vault).
    e) Add the Vault ID to the item value field.
    f) Click **OK** three times.

    If you have more than one archive server hosting the vault, see **Distributing File Vault Views in a WAN Environment** on page 67.

15. For the new view to be announced when the user logs in, Enterprise PDM must be started. To automate this, browse to the **Login Manager** folder and enable the **Start Enterprise PDM Login manager at Windows login** policy.

16. Close the Policy Editor.
Finding the Enterprise PDM Vault ID

1. On a client computer, from the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Administration.
2. Right-click the vault view and click Properties.
3. In the File Vault Properties dialog box, you can copy the vault ID and paste it into a file.

You can also find the vault ID in the vault database SystemInfo table.

Receiving a Distributed File Vault View

When you distribute a file vault view, users receive automatic notifications.

- When users in the distributed group next log in, the following balloon tip informs them that a new vault view is available:

Your system administrator has assigned new vaults for you to attach. Click here to attach them.

Clicking the message box displays the Select Location screen of the View Setup wizard to let the user select where the view should be placed.

If the user does not click the message box before it disappears, clicking the Enterprise PDM icon in the system tray shows an Attach option where the distributed views are available.

- If the automatic view setup policy had the option Setup Views Silent selected, users see the following message:

Your system administrator has attached you to new vaults. Click here to browse.

Clicking the message box opens the vault view in Windows Explorer.

For the silent view setup policy to work, the domain user profiles that use the policy must be part of the Attach access (or administrative access) list in the security section of the Archive Server Configuration tool. Otherwise, the view must be manually created using the Attach option.

Distributing File Vault Views in a WAN Environment

By default, an archive server announces itself over the network to clients using a broadcast interface (over port 3030). When creating views, this lets the View Setup wizard or Administration tool list the archive server automatically.

When a script or Active Directory policy distributes a file vault view, the client uses the first archive server that is announced to it. In some situations such as a replicated environment with multiple servers, this may not be the correct server.

If you have problems using scripted views or policies over WAN or restricted networks, add the appropriate server manually using the SolidWorks Enterprise PDM Settings policy.
Manually Configuring the Archive Server That Is Announced to Enterprise PDM Clients

1. From the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Administration.
2. Under Local Settings, click Group Policies.
4. Disable the normal broadcast for the SolidWorks Enterprise PDM policy:
   a) In the right pane, double-click Disable broadcast.
   b) In the Disable Broadcast Properties dialog box, select Disabled, and click OK.
5. Add the archive server that clients should connect to:
   a) Click View Setup.
   b) Double-click Configure Select Server Page.
   c) In the Configure Select Server Page Properties dialog box, select Enabled.
   d) Click Show to show the default servers.
   e) In the Show Contents dialog box, click Add to add the server.
   f) In the Add Item dialog box, type the archive server name and port, normally 3030.
   g) Click OK to close each dialog box.

When file vault views are distributed, clients are forced to use the specified archive server.

Specifying SolidWorks Enterprise PDM Settings Group Policy Manually

You can use Windows Active Directory policy options to distribute the Enterprise PDM settings. If you are not using Active Directory to distribute group policies, you can add the SolidWorks Enterprise PDM Settings policy manually on a client as a local group policy.

For details about using Active Directory to distribute Enterprise PDM settings, see Distributing an Enterprise PDM File Vault View Using Microsoft Windows Active Directory on page 65.

To add the policy manually:

1. From the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Administration.
2. Select Local settings.
3. Right-click Group policies and click Open.
4. In the Group Policy dialog box, select User Configuration.
5. Right-click Administrative Templates and select Add/Remove Templates.
6. In the Add/Remove Templates dialog box, click Add.
7. In the Policy Templates dialog box, browse to the PDMWorks Enterprise.ADM policy template on the SolidWorks Enterprise PDM DVD under \Support\Policies and click Open.
8. Click Close.

The SolidWorks Enterprise PDM Settings policy options appear under Administrative Templates.
## SolidWorks Enterprise PDM Settings Policy Options

<table>
<thead>
<tr>
<th>Policy</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Settings</strong></td>
<td></td>
</tr>
<tr>
<td>Configure Broadcast Port</td>
<td>Defines the port used for broadcast, by default, port 3030. This port must match the archive server port. You should not have to change it.</td>
</tr>
<tr>
<td>Disable Broadcast</td>
<td>Prevents users from using broadcast to find archive servers on the local subnet. Only manually added servers will be used. Use this policy to make sure that a specific archive server is used.</td>
</tr>
<tr>
<td></td>
<td>For details, see <a href="#">Distributing an Enterprise PDM File Vault View Using Microsoft Windows Active Directory</a> on page 65.</td>
</tr>
<tr>
<td>Disable Automatic View Refresh</td>
<td>Normally, broadcast updates (refreshes) the Explorer file view when another Enterprise PDM client modifies something in the view (for example, by renaming or checking out a file).</td>
</tr>
<tr>
<td></td>
<td>Use this option to prevent views from being updated automatically. Users must press F5 to manually refresh the folder listing in a view.</td>
</tr>
<tr>
<td><strong>Login Manager Settings</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Alternative Servers</td>
<td>If a file vault is replicated, enabling this policy creates a list in the login dialog box of archive servers hosting the replicated vault that the user can connect to.</td>
</tr>
<tr>
<td></td>
<td>Use this policy if working on a laptop and working in both locations hosting a replicated vault. Only the servers that are broadcasted are listed. You might have to include the server in the Add alternative servers policy.</td>
</tr>
<tr>
<td>Start Enterprise PDM Login Manager at Windows Login</td>
<td>Set this policy when you distribute views with the Automatic View Setup policy. It starts the Enterprise PDM login manager at login so that views can be added.</td>
</tr>
<tr>
<td>Add Alternative Servers</td>
<td>The alternative servers list contains available broadcasted servers hosting the replicated vault. If the broadcast does not list the server, you might have to add it manually using this policy. Add the server name as the Value Name, and server port as the Value.</td>
</tr>
</tbody>
</table>

## View Setup settings
### Policy: Prevents the user from manually adding servers to the list of vault sources in the View Setup wizard. Use this policy in combination with **Disable Broadcast** and **Select Server page** to restrict clients to a specified set of servers.

### Policy: Controls the Select Location screen of the View Setup wizard. It should be defined when adding views silently.

- **Location**: Sets the default file vault attach location. This can be used in terminal services environments to force file vault views to be created in a specific directory (commonly the user's home drive).

- **Type**: Sets the default file vault attach type. A restricted Windows user does not typically have the right to add file vault views per computer.

### Policy: Controls the Select Archive Server screen of the View Setup wizard. Adds default archive server names to the list of servers to choose from in the wizard. Type the name of the archive server and the port (3030) as value.

Use this in combination with **Disable Broadcast** and **Disable Add Server** to force clients to use a specified set of servers. You should also use this policy when broadcast prevents archive servers from being listed in the View Setup wizard (for example, over a WAN).

### Policy: Use this policy to distribute file vault views to client computers. Add the vault name and vault ID for the views that should be announced.

When using **Setup views silent**, the views are added without any user interaction. When you use this option, to make sure that the view is created in the correct location, you should also define the **Select Attach Page** policy. If the client computers reside in different subnets and cannot receive broadcast, you must define the **Select Server Page** policy.

### Policy: Sets the workflow editor background to white in the Enterprise PDM administration tool.

### Policy: Explorer settings
<table>
<thead>
<tr>
<th>Policy</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure Thumbnails</td>
<td>Defines the size and color depth of thumbnails that are created on the archive server.</td>
</tr>
<tr>
<td>Drawing Extensions</td>
<td>Lets you add other extensions that should behave like drawings in the BOM view. By default, SLDDRW and IDW files are counted as drawings. When you clear the Bill Of Material view option <strong>Include selected</strong>, drawing files are normally not considered the top-node; therefore both drawing and assembly are excluded.</td>
</tr>
<tr>
<td>Remove Copy Tree From Root</td>
<td>Removes the <strong>Copy Tree</strong> item from the shortcut menu for the root of the vault.</td>
</tr>
<tr>
<td>Configure Get File</td>
<td>Configure thread options used when retrieving files to the client. Use a value between 1 and 20. The default is 5.</td>
</tr>
<tr>
<td><strong>SQL</strong></td>
<td></td>
</tr>
<tr>
<td>Configure bulk operations</td>
<td>Configures when to use bulk operations when communicating with the SQL server. When not doing bulk operations, the statement is built up by text and concatenated to the execute statement if possible. For use only when directed by SolidWorks support.</td>
</tr>
</tbody>
</table>
6 Configuring Content Search

When you index a file vault archive, the search tool can use the content search option to search a document’s contents or properties.

For example, you can search for all documents containing the word “product” or you can search for all Microsoft Office documents written by a specific author.

This chapter includes the following topics:

• Content Search Overview
• Recommended Computer Configuration
• Configuring the Index Service on the SQL Server System
• Configuring the Index Service on a Non-SQL Server System
• Adding Index Server Filters
• Managing File Vault Index Catalogs
• Removing a File Vault Index

Content Search Overview

SolidWorks Enterprise PDM content search uses the Microsoft Indexing Service to create a catalog for each indexed file vault. The catalog contains index information and stored properties for all versions of all documents in the file vault archive folders.

The Indexing Service periodically scans the file vault archive folders and extracts the content using filter components. Microsoft Indexing Service supplies filters for Microsoft Office files, HTML files, MIME messages, and plain-text files. You can install other document filters for content search in, for example, PDF files.

The indexing process creates a catalog with a master index that stores words and their locations within a set of indexed documents. Enterprise PDM content search queries the catalogs for word combinations using the master index as well as word lists and shadow indexes to execute content searches.

Recommended Computer Configuration

You should set up the Enterprise PDM index server for a file vault on the SQL Server hosting the file vault database. Hosting the indexing service catalog on another system can affect content search performance.

The minimum hardware configuration for the indexing service is the same as for the Enterprise PDM database server. However, the performance of the indexing and search tool depends on the number and size of documents to be indexed and the resources available to the indexing service.
The following table shows the recommended memory configuration for the indexing service.

<table>
<thead>
<tr>
<th>Number of Documents To Be Indexed</th>
<th>Minimum Memory (in Mb)</th>
<th>Recommended Memory (in Mb)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fewer than 100,000</td>
<td>64</td>
<td>64</td>
</tr>
<tr>
<td>From 100,000 through 250,000</td>
<td>64</td>
<td>From 64 through 128</td>
</tr>
<tr>
<td>From 250,000 through 500,000</td>
<td>64</td>
<td>From 128 through 256</td>
</tr>
<tr>
<td>500,000 or more</td>
<td>128</td>
<td>256 or more</td>
</tr>
</tbody>
</table>

If the number of documents (and versions) in the file vault is very large, insufficient memory will seriously affect performance. If performance is slow when the indexing service is running:

- Tune performance as described in the Windows Indexing Service help.
- Add more memory and increase the amount of memory dedicated to mapping the property cache.
- Use a faster CPU to improve the performance of indexing and the speed of processing queries.

The total size of the documents to be indexed affects the disk space required for storing Indexing Service data. On an NTFS file system, the space required for the catalog is about 15% of the amount of text indexed.

Configuring the Index Service on the SQL Server System

Configuring the Enterprise PDM index service on the SQL Server requires verifying the Microsoft Indexing Service installation, monitoring and tuning the indexing service, and then indexing the Enterprise PDM file vault archives.

Verifying Microsoft Indexing Service Installation

By default, the Indexing Service is not installed on a Windows Server 2008-based computer. For instructions on installing and configuring the Indexing Service on Windows Server 2008, see [http://support.microsoft.com/kb/954822](http://support.microsoft.com/kb/954822).

1. On the SQL Server hosting the file vault to be indexed, open Control Panel > Uninstall a program.
2. On the left side of the Uninstall or change a program screen, click Turn Windows features on or off.
3. In the Windows Features dialog box, verify that Indexing Service is enabled (checked). If not, select it to install it.
Monitoring and Tuning the Microsoft Indexing Service

1. In the Start menu, right-click Computer and select Manage.
2. In the Computer Management dialog box, expand Services and Application > Indexing Service.

Indexing Enterprise PDM File Vault Archives

This procedure describes index server setup when the index server and database server are installed on the SQL Server hosting the file vault databases.

To install the index server on a separate system, see Configuring the Index Service on a Non-SQL Server System on page 75.

Before indexing the file vault archives:

- Make sure that the database server has been installed and configured.
- Obtain the user name and password of a Enterprise PDM user with Can update index settings permissions.
- If the index server is located on a system other than the archive server, obtain one of the following:
  - The domain login information of a user with full (read and write) access to the UNC share to the archive folder.
  - The login information of a local Windows user on the index server.

To set up the index server on the SQL Server system:

1. On a client, from the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Administration.
2. Log into the file vault to be indexed as an Enterprise PDM user with Can update index settings permissions.
3. In the left pane, under the file vault, right-click Indexing and select Open.
4. If prompted, log into the archive server as a user with administrative access.
5. In the Index Settings dialog box, to enable content search in this file vault, select Index File Vault Archives.
6. Under Archive Locations, double-click the archive path.
7. In the Edit File Vault Archive Folder Path dialog box, in the second field, specify the path to the archive as seen from the system running the Indexing Service. You can use the Browse button to locate the archive folder.
   - If the index server (typically, the SQL Server) is located on the same system as the archive server, copy the path displayed in the first field and paste it into the second field.
   - If the index server is located on a system other than the archive server, provide a UNC path to the archive folder.

Type one of the following:

- The domain login of a user, such as the domain administrator, with full access to the UNC share
- The username and password of a local Windows user on the index server
8. Click OK and close the Index Settings dialog box.
A new index service catalog for the file vault, named Conisio_vaultID, is created on the index server. Any file vault archives containing supported file types are indexed when the indexing service runs, which may be instantly or somewhat delayed.

9. To verify, right-click My Computer and select Manage.
10. In the Computer Management dialog box, expand Services and Application > Indexing Service and ensure that the Conisio catalog has been created.

Configuring the Index Service on a Non-SQL Server System

To set up the indexing service, the Enterprise PDM database server and Microsoft SQL Server must be able to communicate with the system used as the index server.

To use a system other than the SQL Server as the index server, perform these steps before setting up the indexing for a file vault.

After the service accounts and file vault database have been configured, add the indexing service and index the file vault archives as described in Indexing Enterprise PDM File Vault Archives on page 74.

Updating the File Vault Database with the Index Server Name

1. From the Windows Start menu, click All Programs > Microsoft SQL Server 2005 > SQL Server Management Studio.
2. In the left pane, expand Databases > file_vault_database > Tables.
3. Right-click the SystemInfo table (dbo.SystemInfo) and select Open Table.
4. In the right pane, update the IndexServer column with the name of the index server system.
   If the server name includes hyphens (-), enclose the name in double quotes (" ").

   If you do not update the SystemInfo table with the correct index server name, the Microsoft Indexing Service on the SQL server is used as the index server.

5. Save your changes and exit the Management Studio.

Changing the Database Server Login Account

If the database and archive services and the index server service are running on separate systems, they must be able to communicate using a service account other than the system account.

Before changing the database server login account, obtain the login information of a Windows user with local administrative rights on the database server and the index server.

The user must have the same name, password, and local account privileges on both systems.
To change the login account for the database server:

1. From the Windows Start menu, click Control Panel > Administrative Tools > Services.
2. Right-click SolidWorks Enterprise PDM Database Server and select Properties.
3. In the SolidWorks Enterprise PDM Database Server Properties dialog box, on the Log On tab, under Log on as, select This account.
4. Specify a Windows user account, such as a domain administrator, with local administrative rights on both the system running the database server and the index server and click OK.
5. Stop and start the SolidWorks Enterprise PDM Database Server service.

If the database server cannot communicate with the index server, you will not be able to create or remove indexing for the file vault archives. The following error message may be displayed:

Access is denied.
The SolidWorks Enterprise PDM Database Server failed to contact servername.

Changing the SQL Server Login Account

If the SQL Server service and index server service are running on separate systems and are not part of the same domain, they must be able to communicate using a service account other than the system account. If they are in the same domain, this procedure is not necessary.

Before changing the SQL Server login account, obtain the login information of a Windows user with local administrative rights on the SQL Server and the index server.

The user must have the same name, password, and local account privileges on both systems.

To change the login account for the Microsoft SQL Server:

1. From the Windows Start menu, click Control Panel > Administrative Tools > Services.
2. Scroll down to the SQL Server (MSSQLSERVER), right-click it, and select Properties.
3. In the SQL Server (MSSQLSERVER) Properties dialog box, on the Log On tab, under Log on as, select This account.
4. Specify a Windows user account such as a domain administrator, with local administrative rights on both the system running the Microsoft SQL Server and the index server and click OK.
5. Stop and start the MSSQL Service.

If the SQL server cannot communicate with the index server, running a content search in Enterprise PDM fails and results in the following error message:

A communication link failure occurred when accessing the database server. The database service might have been restarted or the network might have gone down. Please try the operation again and contact your system administrator if the problem persists. “vaultname”
Adding Index Server Filters

By default, the Microsoft Indexing Service supports content indexing for the following file formats: Microsoft Office files, HTML files, MIME messages, and plain-text files. By installing index filters on the index server, you can include content search support for many other file formats.

Compressed Archives (gzip) Filter

To index compressed archives as well as add the Enterprise PDM GZ filter, install the GZ filter manually or by using the Enterprise PDM Installation wizard.

If older versions in the file vault archive are compressed, only the latest uncompressed version of a file will be indexed.

Installing the GZ Filter Using the Enterprise PDM Installation Wizard

1. Log in to the system configured for index search with administrator rights.
2. Insert the SolidWorks Enterprise PDM DVD.
3. Double-click `\setup\setup.exe`.
4. On the Program Maintenance screen, select Modify and click Next.
5. On the Custom Setup screen, specify to install the GZ Filter.

Installing the GZ Filter Manually

1. From the SolidWorks Enterprise PDM DVD, copy the file `\Support\Filters\GZFilter.dll` to a local folder on the index server.
2. Open a DOS window and change directory to the location of the filter.
3. Register the file using this command:
   ```
   regsvr32 GZFilter.dll
   ```

Rescanning the Index Catalog

If the indexing service has already indexed the uncompressed archives, you must launch a re-scan of the entire index catalog to refresh its content. You can do this from the indexing node under the catalog directory on the index server.

1. Right-click My Computer and select Manage.
2. In the Computer Management dialog box, expand Services and Applications > Indexing Service, Conisio_vaultID.
3. Click Directories.
4. In the right pane, right-click the directory and select All Tasks > Rescan (Full).

Microsoft Index Filters

You can download additional index filters (iFilters) from Microsoft to add content search support for many other file types; for example, PDF, DWF, MSG, StarOffice, ZIP, and RAR.

Follow the installation instructions for each filter.
You must launch a re-scan of the whole index catalog to refresh its content with the new file format support. For details, see Rescanning the Index Catalog on page 77.

Managing File Vault Index Catalogs

There are many ways to configure the behavior of the Microsoft indexing service.
For detailed information, see the Windows Help regarding the index server node and online at http://support.microsoft.com.

1. Right-click My Computer and select Manage.
2. In the Computer Management dialog box, expand Services and Applications.
3. To check the status of a file vault index, select Indexing Service.
   The right pane shows the status of a file vault archive index; for example, how many files are waiting to be indexed.
4. To stop and start the indexing service, right-click Indexing Service and select to stop or start the service.
5. To change the frequency an archive is scanned, right-click Indexing Service, and select All Tasks > Tune Performance.
6. Set the preferred option and click OK.

Removing a File Vault Index

When you remove a file vault index, only the index catalog is removed; no physical file archives are affected by this operation.

Before removing a file vault index, obtain login information for a user with the following permissions:
• Administrative access to the archive server
• Enterprise PDM permission to update index settings

To remove an index for a file vault archive:

1. On a client, from the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Administration.
2. Log into the file vault from which you want to remove the index.
3. Right-click Indexing and select Open.
4. If prompted, log into the archive server as a user that has administrative access to the archive server.
5. Clear Index File Vault Archives and click OK.
7

Backing Up and Restoring File Vaults

File vault backups should be part of the daily management of SolidWorks Enterprise PDM. They are also required before you upgrade your Enterprise PDM components.

You can use the SQL Maintenance Wizard to schedule a planned backup.

When backing up the vault, the latest updates in files that are still checked out and modified on client workstations are not included since they are stored in the local file vault view (cache) of the client. To ensure that the latest information of all files is always included in a backup, the files should be checked in.

This chapter includes the following topics:

- Backing Up the File Vault Database
- Backing Up the Enterprise PDM Master Database
- Backing Up the Archive Server Settings
- Backing Up the Archive Files
- Scheduling Database Backups Using a Maintenance Plan
- Restoring a File Vault

Backing Up the File Vault Database

Back up the file vault database hosted on the SQL Server using professional backup software such as Veritas Backup Exec with SQL agent. You can also perform the backup using the SQL Management tools that are included with the SQL Server.

1. From the Windows Start menu, click All Programs Microsoft SQL Server 2008 SQL Server Management Studio.
2. In Microsoft SQL Server Management Studio, expand the Databases folder.
3. Right-click the database to be backed up, and select Tasks > Back Up.
4. In the Back Up Databases dialog box, under Source:
   a) For Backup type, select Full.
   b) For Backup component, select Database.
5. Under Destination, click Add.
6. In the Select Backup Destination dialog box, enter a destination path and filename for the backed up database and click OK.
7. Click OK to start the backup.
8. When the backup completes, click OK.
9. Repeat the backup procedure for any additional file vault databases.
10. Exit the Management Studio.

Backing Up the Enterprise PDM Master Database

In addition to the file vault database(s), the Enterprise PDM master database called ConisioMasterDb must be backed up.

To back up this database, follow the same instructions used for backing up the file vault database. For details, see *Backing Up the File Vault Database* on page 79.

Backing Up the Archive Server Settings

The archive server contains file vault settings such as passwords and defined login types. It is also the physical location of the Enterprise PDM vault archive files. Backing up the archive server settings does not back up the archive files.

After backing up the archive server settings, include the backup file in your normal file backup.

**To backup the archive server settings:**

1. On the archive server, from the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Archive Server Configuration.
2. Select Tools > Backup settings.
3. In the Backup Settings dialog box:
   a) Select Include all vaults. (preferred setting)
      Alternatively, you can select Include selected vaults and specify the file vaults for which settings will be backed up.
   b) Specify or select the Backup location.
      The default location is the archive root folder.
   c) To schedule an automatic backup, click Schedule and specify the schedule.
   d) Type and confirm a password for the backup file.

   This password is required to restore settings.

   e) Do one of the following:
      - To perform the backup immediately, click Launch backup. When a message confirms the backup, click OK.
      - To perform the backup at the scheduled time, click OK.

The backup file is saved in the specified location and called Backup.dat.
Backing Up the Archive Files

The file vault archives contain the physical files that are stored in a file vault. A file added to the vault is stored in the archive folder specified by the archive server.

1. Locate the archive folder with the same name as the file vault.
   This folder is stored under the defined root folder path on the archive server. For details, see Installing SolidWorks Enterprise PDM Archive Server on page 41.
   If you are uncertain where the file vault archives are stored, view the registry key HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Applications\PDMWorks Enterprise\ArchiveServer\Vaults\vaultname\ArchiveTable.

2. Use a backup application such as Backup Exec to back up this folder and its contents.

Scheduling Database Backups Using a Maintenance Plan

To set up a recurring automatic backup of the file vault SQL databases, you can use the SQL Server Management Studio maintenance plans.

A maintenance plan lets you create complete backups of the databases, which you can include in your normal file backup routine.

Before scheduling database backups:

- The SSIS (Integration Services) must be installed on the SQL Server. The Integration Services are normally included as part of the Workstation Components step in the SQL Server install wizard.
  For more information, see:
  http://support.microsoft.com/kb/913967

- The SQL Server Agent must be running.

Install SQL Server 2005 SP2 or higher if you have trouble setting up or using the maintenance plans.

Starting the SQL Server Agent

If the SQL Server Agent is not running, you could see a message that the 'Agent XPs' component is turned off as part of the security configuration of your computer.

1. From the Windows Start menu, click All Programs > Microsoft SQL Server 2008 > Configuration tools > SQL Server Configuration Manager.
2. In the left pane, select SQL Server Services.
3. If the state of SQL Server Agent is Stopped, right-click it and select Start.
   Ensure that the Start Mode of the agent is set to Automatic. If it is not, right-click the agent and select Properties, then configure the Start Mode on the Services tab.
4. Exit the SQL Server Configuration Manager.
Setting Up a Maintenance Plan for Database Backup

The easiest way to set up a backup maintenance plan is using the SQL Maintenance wizard.

When the backup maintenance plan is run, the file vault databases are backed up and placed in a folder you specify. Include the backup folder in your normal daily backup procedure.

To set up a backup maintenance plan:

1. From the Windows Start menu, click All Programs > Microsoft SQL Server 2008 > SQL Server Management Studio.
2. In the left pane, under the SQL Server, expand Management.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server Maintenance Plan Wizard</td>
<td>Click Next.</td>
</tr>
</tbody>
</table>

Select Plan Properties

1. Enter a name and description for the maintenance plan.
2. Click Change to set up a schedule.
   - In the Job Schedule Properties dialog box, specify a name for the schedule and choose the recurring times to run the database backups. Set the times close to the start time of the normal daily file backups. The backup of a database to a hard drive usually completes within minutes.
3. Click OK.
4. Click Next.

Select Maintenance Tasks

1. Select Back Up Database (Full).

If you rely on daily backups, you can select Back Up Database (Differential) as well. You should create at least one full backup set each week.

2. Click Next.

Select Maintenance Task Order

1. Ensure that the backup task is listed.
2. Click Next.
### Define Back Up Database (Full) Task

1. Expand the **Databases** list.
2. Select **All user databases**.
   
   This selects all Enterprise PDM databases and excludes the SQL system databases, which are not required by Enterprise PDM.

   To select databases individually, select **These databases** and make your selections. Be sure to select the file vault database(s) and the **ConisioMasterDb** database.

3. Click **OK**.
4. Select **Backup set will expire** and define how many days the existing backup set files should be kept.
5. Select **Back up to Disk**.
6. Select **Create a backup file for every database**.
7. For **Folder**, enter a local path on the SQL Server to an existing folder where the backup files should be created.
8. Click **Next**.

### Select Report Options

1. For backup task report, select **Write a report to a text file** or **E-mail report**, and specify where it should be saved or sent.
2. Click **Next**.

### Complete the Wizard

Click **Finish**.

### Maintenance Plan Wizard Progress

When all tasks have been completed, click **Close**.
Restoring a File Vault

Restoring a file vault requires recent backups of the file vault databases, ConisioMasterDb database, archive server configuration settings, and file vault archive files.

**Restoring the SQL Server File Vault Databases**

1. Install the SQL Server:
   a) Configure the SQL login type to mixed mode.
   b) Select to install the management tools.
   For details, see Installing and Configuring SQL Server on page 16.

2. Apply the latest SQL service pack.

3. Restore the SQL database backup files to a temporary folder on the SQL Server.

4. From the Windows Start menu, click All Programs > Microsoft SQL Server 2008 > SQL Server Management Studio.

5. In the left pane, right-click Databases and select Restore Database.

6. In the Restore Database dialog box, in the To database field, enter the name of the file vault database exactly as it was named when backed up.

7. Under Source for restore, select From device and click the Browse button.

8. In the Specify Backup dialog box, click Add.

9. In the Locate Backup File dialog box, select the database backup file and click OK twice to return to the Restore Database dialog box.

10. Under Select the backup sets to restore, click Restore for the database to restore.

11. In the left pane, select Options.

12. In the right pane, verify that the paths to the database files are correct.
   SQL defaults to the paths used when backing up the database.

13. Click OK to start the restore.

14. Repeat this procedure for additional file vault databases, including the ConisioMasterDb database.

**Verifying the ConisioMasterDb Restore**

After you restore the ConisioMasterDb database, ensure that information in the VaultName and DatabaseName columns of the FileVaults table is correct. If either entry is missing, notifications cannot be processed.

1. From the Windows Start menu, click All Programs > Microsoft SQL Server 2008 > SQL Server Management Studio.

2. Expand Databases > ConisioMasterDb > Tables > dbo.FileVaults.

3. Click Columns, and verify the VaultName and DatabaseName.
Restoring the Archive Server and File Vault Archives

Use this procedure to restore the archive server setting to the previous settings, including all login settings and user information.

1. On the new archive server, restore the physical vault archives from the backup (folders 0-F) to the same location as before the backup.
2. Install the archive server.
   Use the settings you used in the original install. If unsure, use the default options.
   Define the root folder path as you defined it originally.
3. Restore the archive server configuration settings backup file Backup.dat to the archive root folder.
4. From the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Archive Server Configuration.
5. Select Tools > Backup settings.
6. In the Backup Settings dialog box, click Load Backup.
7. Locate the archive server settings backup file Backup.dat and click Open.
8. In the Enter Password dialog box, type the backup file password.
9. When the settings are restored, click OK.
You upgrade using the Enterprise PDM installation wizard. The wizard automatically uninstalls any old software components found and then installs the new software.

Follow these instructions when upgrading from a previous Conisio, PDMWorks Enterprise, or SolidWorks Enterprise PDM version or service pack.

To find out which version is currently installed, see Determining the Current Version on page 87.

This chapter includes the following topics:

- About Enterprise PDM Upgrade
- Upgrading the Archive Server
- Upgrading the Database Server
- Upgrading File Vaults
- Upgrading Toolbox in Enterprise PDM

About Enterprise PDM Upgrade

**Upgrading from Versions Older than Conisio 6.2**

The earliest Conisio version supported by the Enterprise PDM Upgrade Wizard is Conisio 6.2. If you are running Conisio 6.1 or earlier and want to upgrade to SolidWorks Enterprise PDM, you must first upgrade the file vault database and archives to Conisio 6.2 format or later. Follow the instructions included with that version.

For details, see Determining the Current Version on page 87.

**Upgrading the Enterprise PDM Web Server**

To upgrade Enterprise PDM Web Server components from Conisio version 5.3 or older to Enterprise PDM Web Server, uninstall the older Web server using Uninstall a program, and follow the installation instructions in the SolidWorks Enterprise PDM Web Server Guide. For newer versions, follow the standard upgrade procedures.

**Client Licenses**

A database upgrade to a new major version resets the license count to 0 users. After the upgrade, you must install a valid license for multiple users to log in.

When upgrading from an older service pack, for example Enterprise PDM 2012 SP1 to Enterprise PDM 2012 SP2, your existing license code is still valid.
Visual Basic 6 Add-ins

Visual Basic 6 is not supported in SolidWorks Enterprise PDM 2009 or later. All add-ins must be written as multi-threaded (using, for example, the Visual Studio .Net environment).

Before Upgrading

Perform these tasks before upgrading Enterprise PDM.

• Request a new license file from the SolidWorks customer center or your reseller.
• Check in all files.
• Back up:
  • SQL Server file vault database
    For details, see Scheduling Database Backups Using a Maintenance Plan on page 81.
  • Complete file vault archive
    For details, see Backing Up the Archive Files on page 81.
  • Archive server settings
    For details, see Backing Up the Archive Server Settings on page 80.
• Make sure that no users are working in the old file vault. On all clients, users should close all tools started using the file vault, click the Enterprise PDM icon on the right side of the task bar, and choose Log Off and Exit.
• Remove Visual Basic 6 compiled add-ins from the file vault.
  For details, see Removing Visual Basic 6 Add-ins on page 88.

Determining the Current Version

You can find out the current version of Conisio or Enterprise PDM software and the file vault database.

1. Open Windows Control Panel.
2. Double-click Uninstall a program.
3. On the Uninstall or change a program screen, locate Conisio or SolidWorks Enterprise PDM.
   The Version column shows the currently installed version.
   If the Version column is not shown, right-click the column headings and select Version.

You can also determine the current version by opening the SolidWorks Enterprise PDM Administration tool and clicking Help > About.

The version numbers correspond to the following installed versions:

<table>
<thead>
<tr>
<th>Publisher Version Number</th>
<th>Installed Product Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.02.0042</td>
<td>Conisio 6.2</td>
</tr>
<tr>
<td>Publisher Version Number</td>
<td>Installed Product Version</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------------------------------------------------</td>
</tr>
<tr>
<td>6.03.0095</td>
<td>Conisio 6.3</td>
</tr>
<tr>
<td>6.04.0022</td>
<td>Conisio 6.4</td>
</tr>
<tr>
<td>6.05.0016</td>
<td>PDMWorks Enterprise 2006</td>
</tr>
<tr>
<td>7.00.0027 through 7.05.0074</td>
<td>PDMWorks Enterprise 2007 32-bit Edition</td>
</tr>
<tr>
<td>7.07.0032 through 7.09.0042</td>
<td>PDMWorks Enterprise 2007 64-bit Edition</td>
</tr>
<tr>
<td>8.00.0090 through 8.04.0185</td>
<td>PDMWorks Enterprise 2008</td>
</tr>
<tr>
<td>9.00.0723 through 9.05.1225</td>
<td>SolidWorks Enterprise PDM 2009</td>
</tr>
<tr>
<td>10.00.0523 through 10.05.1077</td>
<td>SolidWorks Enterprise PDM 2010</td>
</tr>
<tr>
<td>11.00.0509 through 11.05.1015</td>
<td>SolidWorks Enterprise PDM 2011</td>
</tr>
<tr>
<td>12.00.0408 through</td>
<td>SolidWorks Enterprise PDM 2012</td>
</tr>
</tbody>
</table>

**Determining Which Updates Have Been Applied**

1. From the Windows **Start** menu, click **All Programs > SolidWorks Enterprise PDM > Administration**.
2. In the left pane, right-click on the file vault name and select **Properties**.
3. In the File Vault Properties dialog box, check the **Installed Updates** list. This list shows the update product, version, and upgrade date.

**Removing Visual Basic 6 Add-ins**

If an upgraded file vault contains add-ins created in Visual Basic 6, an error is generated when a client browses into the upgraded file vault view.

**To remove Visual Basic 6 compiled add-ins:**

1. From the Windows **Start** menu, click **All Programs > SolidWorks Enterprise PDM > Administration**.
2. In the left pane, select the file vault and log in as **Admin**.
3. Expand **Add-ins**.
4. Right-click the add-in created using Visual Basic 6 and click **Remove**.

**Upgrading the Archive Server**

If both the archive server and database server software are installed on the same system, you can upgrade or install both components at the same time.

All settings from the previous installation of the archive server are retained.
1. Log in locally or remotely as a user with local administrative rights on the system where the archive server is installed.
2. Insert the SolidWorks Enterprise PDM DVD.

You can also start the install wizard manually by running `\setup\setup.exe` from the CD; however, this bypasses the initial screen. Do not try to update the archive server using the `\Upgrade\Upgrade.exe` file; this file should only be used when performing a database upgrade.

3. On the SolidWorks Enterprise PDM installation screen, click **Upgrade**.
   A warning is displayed stating that older versions of the Enterprise PDM software have been found and will be upgraded.
4. Click **OK**.
5. Follow the install wizard steps by clicking **Next** at each screen.
6. On the Setup Type screen, select **Server Installation** and click **Next**.

   If you are upgrading multiple Enterprise PDM components on the same system, select **Custom**.

7. On the Server Installation screen, ensure that the **Archive Server** is selected and click **Next**.

   If the database server is installed on the same system, you can also select it.

8. When the upgrade is complete, click **Finish**.

## Upgrading the Database Server

If you upgraded the database server while upgrading the archive server, skip to **Upgrading the File Vault Database** on page 91.

Before upgrading the database server, obtain the following:

- Login information for a user with local administrative rights
- SQL Server name
- Name and password of an SQL user account with read/write access to all Enterprise PDM databases hosted on the SQL Server

If you do not know the name of a user with read and write access, you can use the SQL **sa** account that has these permissions. You can also create a login for this purpose. For details, see **Changing the SQL Server Login Account Used by Enterprise PDM** on page 34.

To upgrade the database server:

1. Log in locally or remotely to the SQL Server where the vault database is hosted.
2. Insert the SolidWorks Enterprise PDM DVD.
3. On the SolidWorks Enterprise PDM installation screen, click **Upgrade**.

   A message states that an older version of the Enterprise PDM server software has been found and will be upgraded.
4. Click **OK**.
5. Follow the install wizard steps by clicking **Next** at each screen.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Setup Type</strong></td>
<td>Select <strong>Server Installation</strong> and click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>To upgrade multiple Enterprise PDM components on the same system, select <strong>Custom</strong>.</td>
</tr>
<tr>
<td><strong>Server Installation</strong></td>
<td>Select <strong>Database Server</strong> and click <strong>Next</strong>.</td>
</tr>
<tr>
<td><strong>SolidWorks Enterprise PDM Database Server SQL Login</strong></td>
<td>1. Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Type the name of the SQL Server to host the file vault databases the database server will manage.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Browse</strong> to display a list of available SQL servers and instances on the network.</td>
</tr>
<tr>
<td></td>
<td>Select the appropriate name and click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. In the <strong>Login name</strong> field, type the name of an SQL user on the server who has read and write access (i.e., <strong>db_owner</strong> permission) to all Enterprise PDM databases hosted on the SQL Server (the file vault databases and <strong>ConisioMasterDb</strong>). Use the sa login if unsure.</td>
</tr>
<tr>
<td></td>
<td>3. In the <strong>Password</strong> field, type the SQL user’s password.</td>
</tr>
<tr>
<td></td>
<td>4. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>The login information is verified. If it is incorrect, a warning is displayed.</td>
</tr>
<tr>
<td><strong>Ready to Install the Program</strong></td>
<td>Click <strong>Install</strong>.</td>
</tr>
<tr>
<td><strong>InstallShield Wizard Completed</strong></td>
<td>Click <strong>Finish</strong>.</td>
</tr>
</tbody>
</table>
Upgrading File Vaults

To upgrade file vaults, you first upgrade the file vault database and then the file vault archives.

**Upgrading the File Vault Database**

You can run the Enterprise PDM Database Upgrade Wizard on the archive or database server, or from a system running Enterprise PDM client. However, all installed Enterprise PDM software on the system must match the upgrade wizard version. You cannot run the upgrade wizard on a client or server system that is still using an older version of the software. The database upgrade process may take some time to finish, depending on the database size and version.

Before upgrading the file vault database:

- Obtain a license file for the Enterprise PDM version to which you are upgrading.
- Make sure that no users are working in the vault.
- Back up the file vault database.
  
  For details, see [Backing Up the File Vault Database](#) on page 79.
- Install or upgrade the archive server software.
  
  For details, see [Upgrading the Archive Server](#) on page 88.
- Install or upgrade the database server software.
  
  For details, see [Upgrading the Database Server](#) on page 89.

Do not uninstall old clients until the database upgrade has been completed.

**To upgrade the file vault database:**

1. Insert the SolidWorks Enterprise PDM DVD.
2. On the SolidWorks Enterprise PDM installation screen, select **How to upgrade from a previous SolidWorks Enterprise PDM version**.
   
   A summary upgrade procedure is displayed
3. After Step 4 of the upgrade procedure, click **Upgrade Database** to start the database upgrade wizard.
   
   *Note* You can also start the upgrade wizard manually from the Upgrade folder on the install CD by running Upgrade.exe.
4. When a message box warns that the database and file vault upgrade wizard should only be run by administrators, click **Yes**.
5. Complete the steps of the Enterprise PDM Database Update Wizard.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Verify that you have performed all of the upgrade prerequisites, and click <strong>Next</strong>.</td>
</tr>
</tbody>
</table>
### Screen | Action
--- | ---
Step 2 | 1. From the server list, select the SQL Server hosting the file vault database you want to upgrade.  
   If the server is not listed, you can type the name of the SQL system.  
2. Click **Next**.  
3. In the login dialog box, type the user name and password of an SQL user with sysadmin permissions, such as `sa`, and click **Login**.

Step 3 | Select the file vault database(s) to upgrade and click **Next**.

Step 4 | Click **Next** to begin the upgrade process.

**Step 5** | When the file vault database upgrade finishes, a log is displayed with the actions and results of the upgrade.  
To keep a copy of the upgrade log, select and copy the results and paste them to a text file.  
Click **Finish**.

---

6. You should reboot the Microsoft SQL Server after the databases have been upgraded.  
   If you do not, you may experience performance drops until you reboot the server.

### After Upgrading File Vault Databases

SolidWorks Enterprise PDM 2009 SP02 or later includes functionality to create and manage items. If you install this version and then upgrade a vault database from a previous installation, the upgraded database will not include the default item cards, item BOM, or the serial number that is used to generate item numbers.

To work with items in this vault, use the Enterprise PDM Administration tool to import the following cards and serial number:

- `all(Item Card)_gb.crd`
- `all(Item Search Property)_gb.crd`
- `all(Item Search Simple)_gb.crd`
- `all(Item Search)_gb.crd`
- `all_Item Setup_languagecode.cex`, where `languagecode` is the code for your language.
Importing Item Cards

1. From the Windows **Start** menu, click **All Programs > SolidWorks Enterprise PDM > Administration**.
2. Right-click **Cards** and click **Open**.
3. In the Card Editor, click **File > Import**.
4. In the Open dialog box, for **Look in**, navigate to `install_dir\Default Cards`.
5. In the card list, select `all(item Card)_gb.crd`, and click **Open**.
6. Click **File > Save** to save the card to the vault.
7. Repeat Steps 3 through 6 to import the rest of the item data cards.

Importing the Serial Number and Item BOM

1. Right-click the upgraded vault and select **Import**.
2. In the Open dialog box, for **Look in**, navigate to `install_dir\Default Data`.
3. In the file list, select `all_Item Setup_language.cex`, and click **Open**.
4. In the confirmation message, click **OK**.

Upgrading File Vault Archives

After you upgrade the file vault database, you can upgrade the file vault archives using the Enterprise PDM administration tool, which is only available on client installations.

Upgrading file vault archives consists of these tasks:

- Upgrading or installing an initial Enterprise PDM client on the computer where you will upgrade the file vault archives.

  You will upgrade other clients after the file vault archives are updated.

- Upgrading the file vault archive using the Enterprise PDM administration tool on the initial client computer.
- Upgrading the remaining Enterprise PDM clients.

The vault archive upgrade process can take several hours to complete depending on the number of files and size of the archive. During the upgrade, users cannot work in the file vault.

Before upgrading the file vault archives:

- Back up the entire file vault archive. (For details, see **Backing Up and Restoring File Vaults** on page 79.)
- Make sure no users are logged on to Enterprise PDM.
- Obtain the login credentials of:
  - A Windows user account with administrative access to the archive server
  - An Enterprise PDM account with file vault management permission

Upgrading the Initial Enterprise PDM Client

1. Log in to a client workstation as a user with local administrative rights.
2. Insert the SolidWorks Enterprise PDM DVD.
3. On the SolidWorks Enterprise PDM installation screen:
   - If an older version of Enterprise PDM client is installed, click **Upgrade**.
     At the message that the current client software will be upgraded, click **OK**.
   - If Enterprise PDM client is not installed, click **Install**.

4. Follow the install wizard steps by clicking **Next** in each screen.

5. On the Setup Type screen, choose one of the following:
   - To upgrade or install the client without Item Explorer, select **Client Installation** and click **Next**.
   - To include the Item Explorer:
     1. Select **Custom**.
     2. On the Custom Setup screen, under **Client**, click **Item Explorer** and select **This feature will be installed on local hard drive**.
     3. Click **Next**.

If you are upgrading multiple Enterprise PDM components on the same system, select **Custom**.

6. Follow the installation wizard as you would if you were installing a new client.
   For details, see **Installing Clients Using the Installation Wizard** on page 52.

   On the Choose Product Type screen, select the correct product for your client license type.

**Upgrading the File Vault Archives**

1. From the Windows **Start** menu, click **All Programs** > **SolidWorks Enterprise PDM** > **Administration**.
2. If the archive server hosting the upgraded file vault is not shown in the left pane:
   a) Select **File** > **Add Server**.
   b) In the Add Server dialog box, select or type the name of the archive server, specify the port, and click **OK**.
   c) Log in to the archive server using a Windows user account with administrative access to the archive server.
3. Expand the archive server in the left pane. File vault archives that require upgrading are listed under the archive server with a red icon 🚫.
   - If the icon is not shown, refresh the view by right-clicking the archive server name and selecting **Refresh**.
   - If the icon is still not shown after refreshing, the file vault archive is up to date and no upgrade is required.
4. Right-click the archive name and click **Upgrade**.
   If you are prompted to log in, enter a Enterprise PDM username and password for a user with file vault management permission (usually **Admin**).
   Two messages are displayed:
The first warns that the upgrade can take a long time and that no users should be logged in.

The second states that a backup of the archive server should exist.

If you have met these prerequisites, click Yes for both.

During the archive upgrade, the Work Monitor window displays a progress bar. Do not abort the process until the word “Completed!” appears.

If you have multiple file vault archives to upgrade, you can start the upgrade on those also. They are added to the Work Monitor.

When the upgrade finishes, you can view a log of the upgrade results by clicking Show Log.

5. Close the Work Monitor.
6. To verify that the upgrade was successful, log in to the file vault view and try to retrieve a file.

Upgrading a Replicated File Vault Archive

Upgrading file vault archives replicated on other servers requires additional configuration processes.

When upgrading archive servers hosting a replicated file vault, file vaults that require upgrading are listed with a red icon 🔄.

If the icon is not shown, refresh the view by right-clicking the archive server name and selecting Refresh. If the icon is still not shown, no upgrade is required.

If the icon is shown:

• You must upgrade the archive server software on all servers hosting the replicated vault. The selected archive will still be upgraded and you will have to launch the archive upgrade for the replicated servers separately once the software is upgraded.
• If the archive server software is upgraded on all replicated archive servers and they show up in the administration tree, the replicated file vault archive will be upgraded on all servers simultaneously.
• If the vault is replicated and the replicated archive servers are not listed in the administration tree, a dialog is shown where you can select to attach to the replicated server. If you opt not to connect, only the selected archive will be upgraded and you will have to launch the archive upgrade for the replicated servers separately.

Upgrading the Remaining Clients

When the file vault database and archive have been upgraded, you can upgrade the remaining clients to Enterprise PDM.

Use the same procedure as when you upgraded the first client. For details, see Upgrading the Initial Enterprise PDM Client on page 93.

After Upgrading Clients

After updating Enterprise PDM clients, complete the post-processing configuration steps.

After upgrading:
• In the Enterprise PDM Administration tool, activate the new license file to allow multiple users to log in.
• Optionally, update the default Complete search and Users search cards. (You should do this if upgrading from version 2006 or earlier.)

Upgrading cards removes any changes you have made to them.

• Update add-ins.

Add-ins for SolidWorks Enterprise PDM 2009 and later must be multi-threaded.
• The PDMWorks Enterprise 2007 Dispatch module is single-threaded. Use the Dispatch modules on the SolidWorks Enterprise PDM DVD, which are compiled as multi-threaded, to update the Dispatch add-in.
• If the upgraded file vault contains add-ins created in Visual Basic 6, when clients browse into the upgraded file vault view, they receive error messages that the add-ins are not multi-threaded.

Remove Visual Basic 6 add-ins and replace them with add-ins that are built as multi-threaded.

When you perform these tasks on one client, they are distributed to other clients automatically.

**Activating a New License File**

1. From the Windows **Start** menu, click **All Programs > SolidWorks Enterprise PDM > Administration**.
2. Browse to the file vault in the left pane and log in as Admin.
3. Under the file vault, double-click **License**.
4. In the Set License dialog box, under **License File**, type the path to the new license file or browse to it, and click **OK**.

**Updating the Default Search Cards**

1. In the Enterprise PDM administration tool, under the file vault, expand right-click **Cards** and click **Open Card Editor**.
2. In the Card Editor, select **File > Import**.
3. Locate and open the **Complete** search card **all(Search Complete)_gb.crd**.

   By default, this is located in...
   
   Card are language-specific. Choose the appropriate card for your environment.

4. In the Card Editor dialog box, under **Card Properties**, assign the users and groups that may use the search card.
5. To save the search card, select **File > Save**. Assign a new name or overwrite the existing card, if needed.
6. Repeat Steps 4 through 7 for the search users card, **All(Search Users)_gb.crd**.
Upgrading Add-ins

1. In the Enterprise PDM administration tool, under the file vault, expand **Add-ins**.
2. To update the **Dispatch** add-in:
   a) Right-click **Dispatch** and click **Remove**.
   b) Click **Yes** to confirm that you want to remove the add-in.
   c) Right-click **Add-ins** and click **New Add-in**.
   d) Locate the appropriate Dispatch add-in on the SolidWorks Enterprise PDM DVD under \Support\Dispatch\.  

   On a 64-bit operating system, select both **Dispatch.dll** and **Dispatch64.dll**.
   e) Click **Open**.
3. In the Properties dialog box, click **OK**.
4. Repeat Steps 2 and 3 for any other add-ins that are not multi-threaded.

   The updated add-ins are distributed automatically to the other clients when they log in.

Upgrading the SolidWorks Task Add-in

To ensure that the latest, updated version of an add-in such as the SolidWorks Task Add-in is running, you must manually upgrade the add-in.

When you upgrade a file vault to a new service pack or version, existing add-ins are not automatically updated. This is to prevent updated information in the add-ins from overwriting your customizations.

For example, you may have customized the tasks controlled by the SolidWorks Task Add-in. You can continue to use your customized tasks and not upgrade. However, you will not be able to use new task functionality and may have problems starting tasks and processing upgraded SolidWorks files.

To allow you to manually upgrade tasks, .cex files containing updates for the SWTaskAdd-in and the Convert, Design Checker, and Print tasks are copied to the C:\Program Files\SolidWorks Enterprise PDM\Default Data\ folder. You import one or more of these files to update the SWTaskAdd-in and the tasks it supports.

Determining the Current Versions of Enterprise PDM and the SolidWorks Task Add-in

To ensure that you have the latest updates to the SolidWorks Task Add-in, the SolidWorks Enterprise PDM version and the SWTaskAddin version should be the same.

1. To determine the Enterprise PDM version, in the SolidWorks Enterprise PDM Administration tool, click **Help > About SolidWorks Enterprise PDM Administration**.
   The **Client version** field shows the version as:

   \YY.RR.BBBB

   where:
- **YY** is the last two digits of the major version. For example, 12 = 2012.
- **SS** is the service pack. For example, 03 = SP03.
- **BBBB** is the build number. For example, 903.

2. To determine the version number of the currently installed SWTTaskAddin:
   a) In the Windows notification area, right-click the SolidWorks Enterprise PDM icon and click **Task Host Configuration**.
   b) In the Task Host Configuration dialog box, select the vault for which you want to verify the SWTTaskAddin version.

   The **Version** column displays the version in the following format:

   \[ YYYYSSBBBB \]

   where:
   - **YYYY** is the major version.
   - **SS** is the service pack.
   - **BBBB** is the build number.

### Performing the SWTTaskAddin Upgrade

If the version of SWTTaskAddin is earlier than the version of Enterprise PDM, you can upgrade SWTTaskAddin by importing a .cex file.

1. From the Windows **Start** menu, click **All Programs > SolidWorks Enterprise PDM > Administration**.
2. Log in to the vault where you want to upgrade SWTTaskAddin as an administrator.
3. Click **File > Open**.
4. Navigate to `C:\Program Files\SolidWorks Enterprise PDM\Default Data\` and select `Convert_GB.cex`.
5. In the dialog box that appears, expand `Convert_GB.cex`, select **SWTaskAddin**, and drag it to the **Addins** node in the left pane.
6. In the message box, select **Yes** to update the existing add-in.
7. In the Windows notification area, right-click the SolidWorks Enterprise PDM icon and click **Task Host Configuration** to verify that SWTTaskAddin has been upgraded.

   If the client you just upgraded acts as a task host, exit Enterprise PDM and log in again before performing the verification.

### Upgrading Tasks

After you upgrade the SWTTaskAddin, you can import the latest versions of the Convert, Print, and Design Checker tasks.

This procedure describes how to upgrade the Convert task.

1. In the Administration tool, expand the **Tasks** node.
2. If any tasks have the default names Convert, Print, or Design Checker, rename them so that customizations you have made to the tasks are not overwritten.
3. Click **File > Open**.
4. To upgrade the Convert task, navigate to C:\Program Files\SolidWorks Enterprise PDM\Default Data\ and select Convert_GB.cex.

5. In the dialog box that appears, under Tasks, select Convert, and drag it to the Tasks node in the left pane.

6. Make changes to the newly imported task to match the previously used task and configure any new options as required.
   This includes the file paths and name formats, conversions types, which computers run as a task host, permissions for the task, notifications etc.

7. If the existing task had modifications to the Advanced Scripting options (accessed from the Output File Details page), make those changes to the new version of the script.
   The Advanced Script is often updated for a new version of Enterprise PDM to make use of new features in SolidWorks or to add new features to the task. Therefore you may need to merge the new scripting with your custom scripting.

   Add comments to the script to make it easier to understand and easier to transfer the customization the next time you update.

   Retain the default Convert task for reference and for testing if problems arise with a customized Convert task. Set permissions so that it can only be seen by the Admin user.

   For copies of the default Advanced Scripting Options scripts for several recent versions of Enterprise PDM and instructions for using them, see the Knowledge Base solution S-057908.

8. Modify workflow transitions that caused the original task to be executed and select the updated task as the task to execute.
   Save the workflow changes.

**Upgrading Toolbox in Enterprise PDM**

If you have integrated SolidWorks Toolbox with Enterprise PDM, when you upgrade the SolidWorks software, Toolbox is upgraded if parts have been added.

Before you run SolidWorks Installation Manager to start the upgrade, you must prepare the Toolbox folder.

- On the first computer to perform the upgrade, you must check out the Toolbox database so that the SolidWorks Installation Manager can write to it. Use Get Latest Version to download the Toolbox parts to the local cache so that the installer can verify whether parts need to be updated or added.
- To upgrade additional computers, get the latest versions of the Toolbox files from Enterprise PDM before running SolidWorks Installation Manager.

**To upgrade the first Enterprise PDM computer:**

1. In Windows Explorer, log in to the vault as a user with full permissions (check out, check in, add, delete).
2. Navigate to the Toolbox folder in the vault.
3. Right-click the Toolbox folder and click **Get Latest Version** to copy all Toolbox files and the toolbox database to the local cache.

   If your archive server is remote, this may take several minutes.

4. Check out the Toolbox database, *SWBrowser.mdb*, from `vault_name\Toolbox_folder_name\lang\your_language`.

5. Run the SolidWorks Installation Manager to upgrade the SolidWorks software (including SolidWorks Toolbox).

6. On the Summary screen, ensure that the **Toolbox Options** installation location is the location in the vault.
   
   If it is not, click **Change**, select **Reference or upgrade an existing Toolbox**, and browse to the Toolbox location in the vault.

7. When the upgrade completes, in Windows Explorer, check in the Toolbox folder to add any new or updated files to the vault.

8. For upgrades to SolidWorks 2012 or later, navigate to your Toolbox folder in the vault and ensure that the following are present:
   - `\Toolbox_folder_name\Updates`
   - `\Toolbox_folder_name\ToolboxStandards.xml`
   - `\Toolbox_folder_name\Browser\ToolboxFiles.index`

   If they are not, contact your Value Added Reseller.

To upgrade additional computers, before initiating the SolidWorks Enterprise PDM upgrade, use **Get Latest Version** to download the vault Toolbox folder to the local cache.

SolidWorks Installation Manager will verify that the Toolbox files are up to date when you run the installation.
Upgrading SolidWorks Files

The SolidWorks Enterprise PDM File Version Upgrade tool upgrades SolidWorks files from an earlier version to a later SolidWorks file format.

After you upgrade files, you cannot open them in older SolidWorks versions.

The tool automatically checks out, upgrades, and checks in SolidWorks files that are stored in Enterprise PDM vaults. File references, revision tags, and workflow states are kept intact.

The only file formats that are upgraded are .sldprt, .slddrw, and .sldasm. Upgrade SolidWorks template and block files manually.

Several workstations, each running the upgrade tool, can perform concurrent upgrades to reduce the upgrade time. The first workstation to run the upgrade tool acts as the master workstation, which creates the upgrade plan. The plan consists of several work instruction files, one for each workstation participating in the upgrade process. For instructions on creating work instruction files, see Creating and Using Work Instruction Files on page 122.
The work instruction files contain tree structures that reflect the parent-child relationships of the SolidWorks files. Both master and slave workstations can run additional work instruction files after they finish processing the first one. Although parts and subassemblies can be shared by other assemblies, each file is only upgraded once.

If an assembly references parts that are not at the latest version, you can choose a version setting that links the assembly with the latest version of the parts it references. Alternatively, you can choose a version setting that overwrites the existing version of referenced files with the latest version of the files. See Selecting Version Settings on page 104.

**Required Upgrade Utility Software**

Use a version of the upgrade software that corresponds to the version of SolidWorks to which you are upgrading.

<table>
<thead>
<tr>
<th>SolidWorks Version</th>
<th>Enterprise PDM Version</th>
<th>Upgrade Utility</th>
</tr>
</thead>
<tbody>
<tr>
<td>SolidWorks 2008</td>
<td>PDMWorks Enterprise 2008</td>
<td>From 2008 install disk</td>
</tr>
<tr>
<td></td>
<td>SolidWorks Enterprise PDM 2009</td>
<td>From 2009 install disk</td>
</tr>
<tr>
<td>SolidWorks 2009</td>
<td>SolidWorks Enterprise PDM 2009</td>
<td>From 2009 install disk</td>
</tr>
<tr>
<td>SolidWorks 2010</td>
<td>SolidWorks Enterprise PDM 2010</td>
<td>From 2010 install disk</td>
</tr>
<tr>
<td>SolidWorks 2011</td>
<td>SolidWorks Enterprise PDM 2011</td>
<td>From 2011 install disk</td>
</tr>
</tbody>
</table>
System Requirements

System requirements depend on the vault database being upgraded. They are affected by the structure of the database, including the number of files, versions, and references being converted.

Use powerful workstations. As files are opened and resaved in SolidWorks, it is important that the workstations used have sufficient resources to handle even the largest assembly structures. Ideally, use 64-bit workstations with at least 4GB RAM and plenty of free hard disk space.

Stop any non-essential processes to free up as many resources as possible on the workstations being used.

The following are specific recommendations:

- **Archive server**
  
  When the conversion is performed by overwriting existing versions of files, a backup is created for each overwritten file. The archive server must have disk capacity to store these backup files.

  Before the upgrade begins, a screen message notifies you of the space needed, based on the files you have selected to upgrade.

- **Workstations**

  All workstations that will be used for the upgrade must have enough RAM to open the largest assembly to be converted. A minimum of 4 GB RAM is recommended.

  SolidWorks recommends a minimum of 6 GB RAM (or more on Windows 7 x64 operating systems).

Installing the File Version Upgrade Utility

The File Version Upgrade Utility is provided on the SolidWorks Enterprise PDM installation media in the `\Support\File Version Upgrade\` directory.

To install the File Version Upgrade Utility:

1. Navigate to the `\Support\File Version Upgrade Utility\` on the Installation media.
3. In the Welcome screen, click Next.
4. Accept the license agreement and click Next.
5. Click Install.
6. Click Finish.

Preparing to Upgrade

Prepare the workstations involved in the upgrade before you begin the upgrade process.

Perform a complete vault backup, including:

- File vault database
See **Backing Up the File Vault Database** on page 79.

- Archive files
  
  See **Backing Up the Archive Files** on page 81.

On the master and slave workstations that are participating in the upgrade process:

1. Install the same version and revision level of Enterprise PDM client.
2. Create local views of the file vault to be upgraded.
3. Check all files into the vault.

On the master workstation:

1. Give participating clients read/write access to all files in the vault you are upgrading.
2. Create a folder for the work instruction files and share it with full (read/write) permissions for all participating clients.

### Selecting Version Settings

The Version Settings screen lets you specify which versions and revisions of your selected file type will be upgraded and whether old versions will be overwritten.

Before you perform a full conversion, test the conversion of older files by opening a sample set in the target version of SolidWorks to check for any conversion errors.

Select **Create new version of files** if you want only the most recent versions of files to be upgraded and to preserve the existing versions of the files in the older file format. New Enterprise PDM versions are created.

Select **Overwrite existing versions of files** if you want to:

- Overwrite all versions of files with upgraded files.
- Specify which versions of files to overwrite by selecting one or both of the following:
  - **Latest version** The tool upgrades the latest versions of files plus all files that they reference.
  - **Versions with a revision** The tool upgrades all files with revision tags.

If you choose to overwrite existing versions, the File Version Upgrade tool creates a backup of files before upgrading them. You can delete backed up files after confirming that the upgrade is successful. See **Managing Backup Files** on page 124.

Assemblies that contain cyclic references are not upgraded if you select to overwrite existing versions of files.

### Upgrade Scenarios

The following topics illustrate the possible upgrade scenarios for the set of files below.
Creating New Versions of Files

When you create new versions of files, the older versions still exist and can continue to be opened in the older version of SolidWorks.

Relinking to the Latest Version of Referenced Files

You can relink an assembly to the latest version of the files that it references.

If the assembly and its subassemblies reference versions of parts that are not the latest version, the references are moved to the latest versions of the parts.

Older versions of the parts, assembly, and subassembly are not upgraded and their references are not affected.

If the newer versions of referenced files have undergone geometry modifications, using this option could result in unwanted assembly changes or rebuild errors. In addition, if file properties such as Part Number, Description, or Material have changed, in the newer versions, this could cause changes in Bills of Materials.

Selections represented in the diagram below are:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>&lt;All SW file types&gt;</td>
</tr>
</tbody>
</table>
## Upgrading SolidWorks Files

### Screen | Option | Selections
--- | --- | ---
Version Settings | Create new version of files | Files referencing older versions
  - Are re-linked to the new version
  - Update revisions
  - Do not update revision

### Diagram

Reference links before upgrade
- Files before upgrade

Reference links after upgrade
- Upgraded files

### Moving Existing Revision Tags

You can move the latest revision tag to the latest version of a file you are upgrading. Selections represented in the diagram below are:
### Upgrading SolidWorks Files

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>&lt;All SW file types&gt;</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Create new version of files</td>
<td>Files referencing older versions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Are excluded</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Update revisions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Move revision</td>
</tr>
</tbody>
</table>

#### Diagram:
- **Files before upgrade, showing revision that is moved**
- **Upgraded files**
Incrementing Revision Tags

You can increment the revision tags on the latest versions of files as you upgrade the files.

Selections represented in the diagram below are:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>&lt;All SW file types&gt;</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Create new version of files</td>
<td>Files referencing older versions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Are re-linked to the new version</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Update revisions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Increment revision</td>
</tr>
</tbody>
</table>

Reference links before upgrade

Files before upgrade, showing revision that is moved and incremented
Overwriting Existing Versions of Files

When you overwrite the existing versions of files, the existing files are replaced with upgraded files. New versions are not created.

Overwriting All Versions

You can replace all versions of files with upgraded files.

Your choice of file type on the Search Files to Upgrade screen determines the files that are upgraded. Every file of the selected type is upgraded, regardless of whether it is the latest version, a referenced file, or a file with a revision tag.

Overwriting All SolidWorks Files

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>&lt;All SW file types&gt; All SolidWorks parts, assemblies, and drawings are upgraded.</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Overwrite existing versions of files</td>
<td>Overwrite all versions</td>
</tr>
</tbody>
</table>
Overwriting All Parts

All SolidWorks parts and the drawings that reference them are upgraded.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>*.sldprt</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Overwrite existing versions of files</td>
<td>Overwrite all versions</td>
</tr>
</tbody>
</table>
By default, part drawings are not upgraded. However, because drawings are parents to parts, a Broken reference warning screen lets you select to upgrade the drawings that reference the parts that are being upgraded.

**Overwriting All Assemblies**

All assemblies and the parts and subassemblies they reference are upgraded.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>*.sldasm</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Overwrite existing versions of files</td>
<td>Overwrite all versions</td>
</tr>
</tbody>
</table>
In a referenced version stream, the File Version Upgrade tool also upgrades the latest parts, as indicated by the blue boxes.

By default, part and assembly drawings are not upgraded. However, because drawings are parents to parts and assemblies, a Broken reference warning screen lets you select to upgrade the drawings that reference parts and assemblies that are being upgraded.

**Overwriting All Drawings**

All drawing and the assemblies and parts they reference are upgraded.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td><strong>Files of type</strong> <em>.slddrw</em></td>
<td></td>
</tr>
<tr>
<td>Version Settings</td>
<td><strong>Overwrite existing versions of files</strong></td>
<td><strong>Overwrite all versions</strong></td>
</tr>
</tbody>
</table>
Overwriting the Latest Versions of Files

You can upgrade by overwriting the latest version of all files of the selected file type. Any version of a file that is used in a reference from an upgraded file is also upgraded.

Overwriting the Latest Versions of All Files

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>&lt;All SW file types&gt;</td>
</tr>
</tbody>
</table>
### Upgrading SolidWorks Files

#### Overwriting the Latest Version of Parts

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>*.sldprt</td>
</tr>
</tbody>
</table>

#### Version Settings

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Version Settings</td>
<td>Overwrite existing versions of files</td>
<td>Overwrite</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latest version</td>
</tr>
</tbody>
</table>
### Selections and Option Screens

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Version Settings</td>
<td><strong>Overwrite existing versions of files</strong></td>
<td><strong>Overwrite</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• <strong>Latest version</strong></td>
</tr>
</tbody>
</table>

By default, part drawings are not upgraded. However, because drawings are parents to parts, a Broken reference warning screen lets you select to upgrade the drawings that reference the parts that are being upgraded.

### Overwriting the Latest Version of Assemblies

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td><strong>Files of type</strong></td>
<td>*<strong>.sldasm</strong></td>
</tr>
</tbody>
</table>
In a referenced version stream, the File Version Upgrade tool also upgrades the latest parts, as indicated by the blue boxes.

By default, part and assembly drawings are not upgraded. However, because drawings are parents to parts and assemblies, a Broken reference warning screen lets you select to upgrade the drawings that reference parts and assemblies that are being upgraded.

Overwriting the Latest Version of Drawings

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>*.slddrw</td>
</tr>
</tbody>
</table>
### Overwriting Files with Revision Tags

You can include files with revision tags as files that are upgraded. These examples show the files that are upgraded when you choose both **Latest version** and **Version with a revision**. Red boxes indicate files that are upgraded because they have revision tags, even though they are not the latest version.

### Overwriting All Files with Revision Tags

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>&lt;All SW file types&gt;</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Overwrite existing versions of files</td>
<td>Overwrite</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latest version</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Version with a revision</td>
</tr>
</tbody>
</table>
Overwriting Parts with Revision Tags

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td><strong>Files of type</strong></td>
<td>*.sldprt</td>
</tr>
<tr>
<td></td>
<td><strong>Overwrite existing versions of files</strong></td>
<td><strong>Overwrite</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latest version</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Version with a revision</td>
</tr>
</tbody>
</table>
By default, part drawings are not upgraded. However, because drawings are parents to parts, a Broken reference warning screen lets you select to upgrade the drawings that reference the parts that are being upgraded.

### Overwriting Assemblies with Revision Tags

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td><strong>Files of type</strong></td>
<td><code>.sldasm</code></td>
</tr>
<tr>
<td>Version Settings</td>
<td><strong>Overwrite existing versions of files</strong></td>
<td><strong>Overwrite</strong></td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latest version</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Version with a revision</td>
</tr>
</tbody>
</table>
In a referenced version stream, the File Version Upgrade tool also upgrades the latest parts, as indicated by the blue boxes.

By default, part and assembly drawings are not upgraded. However, because drawings are parents to parts and assemblies, a Broken reference warning screen lets you select to upgrade the drawings that reference parts and assemblies that are being upgraded.

**Overwriting Drawings with Revision Tags**

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>*.slddrw</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Overwrite existing versions of files</td>
<td>Overwrite</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latest version</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Version with a revision</td>
</tr>
</tbody>
</table>
Performing a Trial File Upgrade

Before upgrading the SolidWorks files in a production vault, perform the upgrade on a copy of the production vault to ensure that there are no upgrade problems. Contact your value added reseller for help creating a copy of your vault.

1. Restore a complete backup of the file vault to a separate server.
2. From the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > File Version Upgrade.
3. Follow the instructions in the upgrade wizard.
4. Verify that the upgrade is successful.
   See After Upgrading on page 123.

Running the Upgrade Utility

To run the upgrade utility:

2. On the Welcome screen, do one of the following:
   • To set up the upgrade, click Initiate a new upgrade process (Master Workstation).
   • To run a work instruction file created for the upgrade, click Participate in an upgrade process (Slave Workstation).
   • To retry an upgrade that was terminated unexpectedly, click Restart an interrupted upgrade process (Master and Slave Workstation).
3. Follow the instructions in the upgrade wizard.
Creating and Using Work Instruction Files

By creating work instruction files, you can run the upgrade tool concurrently on several workstations to reduce the upgrade time.

You create the work instruction files on the first workstation that runs the upgrade tool, which becomes the master workstation.

To create and use work instruction files:

1. Create a shared folder and give each workstation that will participate in the upgrade Read/Write access.
2. On the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > File Version Upgrade.
3. On the Welcome screen, select Initiate a new upgrade process (Master Workstation) and click Next.
4. Complete the wizard screens.
5. On the Upgrade Settings screen:
   a) Under Upgrade Settings, select Divide the upgrade work into multiple work instruction files.
   b) Specify the number of work instruction files to create.
   c) For Shared location for work instruction files, type the name of the shared folder you created in step 1 or click the browse button to navigate to the folder.
      
      The folder name must be in UNC format.
   d) Click Next.
6. On the Ready to Upgrade Files screen, do one of the following:
   - To upgrade now, click Yes.
     When a completion message appears, click OK.
   - To exit the upgrade utility and run work instruction files at a later time, click No.
7. If you selected No in step 6, run the File Version Upgrade tool again to perform the upgrade using the work instruction files.
8. On the Welcome screen, select Participate in an upgrade process [Slave Workstation].
9. On the Select Work Instruction File screen:
   a) Browse to the location of the work instruction files.
   b) Select the work instruction file to process.
   c) Click Next.
      The Work Instruction File Summary displays with a read-only summary of the settings specified for the upgrade.
   d) Click Next.
10. On the Ready to Upgrade Files screen:
    a) Click View Files to see a list of files that will be upgraded.
    b) To upgrade the files, click Yes.
    c) When a completion message appears, click OK.
Completing an Interrupted Upgrade

Sometimes an upgrade is interrupted unexpectedly, for example, when you lose a network connection or lose power.

To complete an interrupted upgrade:

1. Click Retry in the error message.
2. In the message indicating that the conversion did not complete successfully, click OK.
3. Click Exit.
4. Solve the problem that caused the interruption. For example, restore the network or restart the computer.
5. Run the Upgrade utility again.
6. On the Welcome screen, select Restart an interrupted upgrade process (Master and Slave Workstation).
7. On the Continue Interrupted Migration screen, click Next.

After Upgrading

When the upgrade is complete:

- View the upgrade log files.
- Manually upgrade files that the tool was unable to upgrade automatically.

Manual upgrade creates new versions. If you upgraded using Overwrite existing versions, manual upgrade will invalidate the reference structure.

- Optionally, use Get Latest Version to create local copies of files that were converted on other workstations.
- Open a subset of converted files in SolidWorks to verify that the conversion was successful.
- If you selected to overwrite existing versions of files, after ensuring that the upgrade was successful, remove the backup files from the archive server. See Locating and Removing Backup Files on page 125.

File Name Formats for Upgrade Logs

Files names in upgrade logs take the following formats:

- Files that have been upgraded
  Upgrade Utility <id>Batch<n>.log
  where:
  - <id> is a unique alphanumeric string
  - <n> is the number of the batch file for which the log was created
  Example: Upgrade Utility 471F2FDS Batch 4.log

- Files that could not be upgraded
Managing Backup Files

If you choose to overwrite existing versions of files when you upgrade, the upgrade tool creates a backup file for each overwritten file. These backup files remain after the upgrade. You can remove them after you verify that the upgrade succeeded.

**Backup File Creation**

It is not possible to disable the backup option, so ensure that you have sufficient free disk space on the archive server before you start the upgrade.

The Ready to Upgrade Files screen gives an estimate of the amount of space that is needed.

For each file that is overwritten:

1. The upgrade tool retrieves the original version of the file from the file archive folder to the client system that is running a work instruction file to perform the upgrade.
2. The tool opens the file in SolidWorks, upgrades it, and send it back to the archive folder when the batch process completes.
3. Before the version is replaced, the original version in the archive is renamed using the following format:
   
   \[
   \text{bak}\_\text{counter}\_\text{version}.\text{extension}
   \]

   Where:
   
   - \text{bak} is the prefix for all backup files.
   - \text{counter} is a unique counter in case the existing file with the same backup name exists from a previous upgrade.
   - \text{version} is the number, in hexadecimal format, of the file version that is being replaced.
   - \text{extension} is the file extension.

4. The upgrade tool places the upgraded version of the file in the archive using the original file name.

**Restoring an Incorrectly Upgraded Version from a Backup**

If an upgraded version of a file is incorrect, you can use the backup file to restore the original content of the file.

1. In the local file vault view, determine the name of the file to find.
2. From the Windows Start menu, click All Programs > Microsoft SQL Server > SQL Server Management Studio, and click Connect.
3. Expand Databases and select the vault containing the file you want to restore.
4. Click New Query.
5. In the right pane, type a query in the following format:

```sql
select * from documents
where filename like 'filename.ext'
```

For example:

```sql
select * from documents
where filename like 'speaker_frame.sldprt'
```

6. Click **Execute**.
   Record the files DocumentID, which is listed in the Results tab.

7. Exit the SQL Server Management Studio.

8. Use a calculator to convert the DocumentID to hexadecimal format.

9. In an Explorer window, navigate to `install_dir\Program Files\SolidWorks Enterprise PDM\Data\vault_name`.

10. Expand the vault archive that matches the last digit of the hexadecimal number.
    For example, if the hexadecimal number is 3B, expand the folder labeled B.

11. Expand the folder that matches the hexadecimal number.

12. Rename or delete the version of the file you want to restore.
    For example, rename `00000002.sldprt` to `00000002.backup`.

13. Rename the appropriate `bak_` file to the original file name.
    For example, rename `bak_0_00000002.sldprt` to `00000002.sldprt`.

### Locating and Removing Backup Files

When the upgrade is complete and you are satisfied that the upgraded files are correct, you can remove the backup files to free up disk space. Each file archive is stored under the file vault archive folder:

1. To locate the file vault archive folder:
   a) Run regedit.
   b) Navigate to `HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Applications\PDMWorks Enterprise\ArchiveServer\Vaults\vault_name\ArchiveTable`.

   The file archives are spread out over 16 subfolders.

   If the vault archive has been split up, some of those subfolders might be on different drives.

2. Use Windows search or another search method to search for all files under the vault archive with a name starting with `bak_`.

3. Delete all the files that are found.
This chapter includes the following topics:

- **Managing the SQL Transaction Log Size**
- **Configuring Enterprise PDM to Communicate Using IP Addresses Only**
- **Moving Server Components to Another System**

### Managing the SQL Transaction Log Size

Each SQL database contains one database file (.mdf) and at least one transaction log file (.ldf). The database file stores the physical data added to the database, and the transaction log keeps records of database modifications. The SQL Server uses the transaction log to maintain database integrity, particularly during recovery.

By default, the recovery method of an SQL database is set to full recovery model, which means that every change to the database is logged. A large transaction log can grow until it is out of disk space and causes the performance of the SQL Server to drop.

The full recovery model is preferred to restore to an exact point-in-time, but if you rely on nightly database backups and want to ensure that the transaction log does not grow and degrade SQL performance, you should change to the simple recovery model.

To reduce the size of a large transaction log after you change to simple recovery model, shrink the transaction log.

For more details about changing the recovery model, see the SQL Server books online and this Microsoft Knowledge Base article:

[http://support.microsoft.com/?kbid=873235](http://support.microsoft.com/?kbid=873235)

### Changing to the Simple Recovery Model

1. From the Windows Start menu, click All Programs > Microsoft SQL Server 2008 > SQL Server Management Studio.
2. In the left pane, expand the Databases folder, right-click the database name and select Properties.
3. In the Database Properties dialog box, in the left pane, select Options.
4. In the Recovery model list, select Simple and click OK.
Shrinking the Transaction Log

1. Right-click the database name, and select Tasks > Shrink > Files.
2. In the Shrink File dialog box, in the File type list, select Log.
3. Click OK.

Configuring Enterprise PDM to Communicate Using IP Addresses Only

By default, when setting up a Enterprise PDM environment, clients communicate with servers using system names. If the DNS lookup is unstable or not sufficient for the network setup, you can configure Enterprise PDM to use only IP-numbers to communicate.

This setup involves:

1. Updating the archive server
2. Updating the SQL Server
3. Updating the Enterprise PDM clients

When connecting to the archive server, you can remove and re-attach the file vault view using the archive server IP address instead of updating the registry manually.

Updating the Archive Server to Communicate Using IP Addresses

1. On the system running the archive server, from the Windows Start menu, click Run > regedit to open the registry.
2. Find the key for the archive server:
   HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Application\PDMWorks Enterprise\ArchiveServer
3. In the right pane, right-click and select New > String value and name the string value ServerName.
4. Double-click ServerName.
5. In the Edit string dialog box, in the Value data field, type the IP address of the archive server and click OK.
6. Find the key for the file vault:
   HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Applications\PDMWorks Enterprise\ArchiveServer\Vaults\vaultname
7. Double-click Server, update the Value data field with the IP address to the SQL Server hosting the vault database, and click OK.
8. Restart the archive server service.
Updating the SQL Server to Communicate Using IP Addresses

1. From the Windows Start menu, click All Programs > Microsoft SQL Server 2008 > SQL Server Management Studio.
2. In the left pane, expand Databases, the vault database, and Tables.
3. Right-click dbo.ArchiveServers and select Open Table.
4. Under ArchiveServerName, change the entry to the IP address of the archive server hosting the vault.
5. Right-click dbo.SystemInfo and select Open Table.
6. Under ArchiveServerName, change the entry to the IP address of the archive server hosting the vault.
7. Exit the Microsoft SQL Management Studio.

Updating Enterprise PDM Clients to Communicate Using IP Addresses

1. If started, exit Enterprise PDM by clicking the Enterprise PDM icon on the right side of the task bar and selecting Exit. Ensure the administration tool is not running.
2. On the system running the archive server, from the Windows Start menu, click Run > regedit to open the registry.
3. Find the key for the file vault view:
   
   HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Applications\PDMWorks Enterprise\Databases\vaultname

4. Update the DbServer value with the IP address to the SQL Server hosting the vault database.
5. Update the ServerLoc value with the IP address to the archive server hosting the vault archive.
6. If the administration tool was used on the client, delete the following key:
   
   HKEY_CURRENT_USER\Software\SolidWorks\Application\PDMWorks Enterprise\ConisioAdmin

   The key is recreated when starting the administration tool.
Verifying IP Address Communication

1. When all servers and clients are updated, verify that you can:
   - Log into the file vault.
   - Add a new file.
   - Retrieve an existing file.

2. If the vault is replicated, ensure you are using IP addresses in the replication settings dialog.

3. If you experience problems connecting with the new addresses:
   - Check the client and archive server log for errors.
   - Ensure that you can ping the servers from the client using the supplied IP addresses.

Moving Server Components to Another System

Use these procedures when moving Enterprise PDM server components from one system to another or when changing the name on the server system to verify which database and registry entries should be updated.

These instructions describe moving both the database and archive server. If you are moving only one, follow only those instructions that apply.

Before you start, make sure no one is using Enterprise PDM.

Copying Files to the New Server

1. On the old SQL Server, backup the file vault database and the ConisioMasterDb. For details, see Backing Up the File Vault Database on page 79.

2. Copy the backup file to the new server.

3. From the Windows Start menu, click All Programs > SolidWorks Enterprise PDM > Archive Server Configuration.

4. To make a backup of the archive server settings:
   a) Select Tools > Backup settings. For details, see Backing Up the Archive Server Settings on page 80.
   b) Clear or set a password, and click Launch backup.
   c) Copy the backup file (backup.dat) to the new server.

5. Copy the entire file vault archive folder from the old server to the new server, maintaining the same path.

If you are unsure where the archives are located, check this registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Application\PDMWorks Enterprise\ArchiveServer\Vaults\vaultname\ArchiveTable
**Configuring the Moved SQL File Vault Database**

1. On the new server, install the SQL Server software. For details, see *Installing SQL Server 2008* on page 17.

2. To keep the collation settings the same as the old server:
   a) From the Windows **Start** menu, click **All Programs** > **Microsoft SQL Server 2008 > SQL Server Management Studio**.
   b) Right-click the server and select **Properties**.
   c) In the Server Properties dialog box, in the right pane, note the **Server Collation** setting of the old server.
   d) During the new SQL install, select **Custom** and set the same collation.

3. Restore the backed-up database, keeping the original name.

   Stop the old SQL Server service or take the old databases offline so that you do not have two servers with the same vault database active.

4. In the restored file vault database, update with the new archive server name in tables **ArchiveServers** and **SystemInfo**.

   In a replicated environment, the **ArchiveServers** table contains each replicated server. Be sure to update only the moved server entry. Do not change the **VaultName** entry.

5. To allow indexing of the moved file vault database, created a linked server entry:
   a) In Microsoft SQL Management Studio, right-click on the moved file vault database and select **New Query**.
   b) Enter the following command in the query window, then press **Execute** (**F5**) to run the query.

   ```sql
   Exec Sys_IndexServerLink 1
   ```

   If indexing is already set up on the old server, remove and recreate the index catalog on the new server using the **Indexing** node in the Administration tool.

**Configuring the Moved Archive Server**

1. Install the archive server on the new server. Use the default settings used on the old server, if you can remember them. For details, see *Installing SolidWorks Enterprise PDM Archive Server* on page 41.

2. From the Windows **Start** menu, click **All Programs** > **SolidWorks Enterprise PDM > Archive Server Configuration**.

3. Select **Tools** > **Backup settings**.

4. In the Backup Settings dialog box, click **Load Backup**.
   The old archive server settings are imported.

5. On the new archive server, from the Windows **Start** menu, click **Run** > **regedit** to open the registry.
6. Update and verify the following keys, which may differ from the old server settings:
   - **HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Application\PDMWorks Enterprise\ArchiveServer\Computers\local\Archives**
     Ensure that the default value points to the correct root folder (=parent) where the file vault archive is stored (i.e., the path where the file vault archive folder was copied to). For example, type:
     
     C:\Program Files\SolidWorks Enterprise PDM\Data

   - **HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Application\PDMWorks Enterprise\ArchiveServer\Vaults\vaultname**
     Ensure that **Server** value is updated to the new SQL Server name and **SQLDbName** matches the restored file vault database name. Do not change the **DbName** entry.

   - **HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Application\PDMWorks Enterprise\ArchiveServer\Vaults\vaultname\ArchiveTable**
     Make sure all paths point to the file vault archive location where you copied the files to (from the old server.)

7. Stop the old archive server from running.
   Preferably disconnect the old server from the network so that it is not available until all clients are updated, or stop the archive server and SQL Server service.

### Updating Client Registry Keys

1. On each client, update the following registry key:
   - **HKEY_LOCAL_MACHINE\SOFTWARE\SolidWorks\Application\PDMWorks Enterprise\Databases\vaultname**
     Update the **DbServer** (database server) and **ServerLoc** (archive server) with the new server name.

     On 64-bit clients update the **DbServer** and **ServerLoc** in this registry key:
     
     HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SolidWorks\Application\PDMWorks Enterprise\Databases\vaultname

2. On each client, delete the following registry key:
   - **HKEY_CURRENT_USER\Software\SolidWorks\Application\PDMWorks Enterprise\ConisioAdmin**

### Updating Replication Settings

If you are moving the archive server components in a replicated environment, update the replication settings to reflect the new archive server name.

1. From an updated client, open the Administration tool and log in to the vault.
2. Right-click **Replication Settings** and click **Open**.
3. In the Replication Settings dialog box, under **Connections**, select the first row.
4. Under **Selected connection**, for **IP address or DNS name**, type the new IP address or name of the moved archive server.

5. Restart the archive server service on each archive server that is replicating the file vault.

**Verifying the Server Move**

1. Log in as the **Admin** user and see the file vault listing.
2. Make sure that the archive server fully works by adding a text file, checking it in, and deleting it.

If you cannot login or add, check out, modify, and check in the new file, verify the **Enterprise PDM configuration steps and registry changes**.