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The software discussed in this document is furnished under a license and may be used or
copied only in accordance with the terms of the license. All warranties given by DS SolidWorks
as to the software and documentation are set forth in the license agreement, and nothing
stated in, or implied by, this document or its contents shall be considered or deemed a
modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SOLIDWORKS® 3D mechanical CAD software is protected by U.S. Patents 5,815,154; 6,219,049;
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U.S. and foreign patents pending.

Trademarks and Product Names for SOLIDWORKS Products and Services
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FeatureWorks is a registered trademark of Geometric Ltd.
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Sustainability, SOLIDWORKS Plastics, SOLIDWORKS Electrical, SOLIDWORKS Composer, and
SOLIDWORKS MBD are product names of DS SolidWorks.

Other brand or product names are trademarks or registered trademarks of their respective
holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995),
consisting of “commercial computer software” and “commercial software documentation” as
such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government
(a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in
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All rights reserved.
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SOLIDWORKS Enterprise PDM
Installation Guide

Required and optional installation components, deployment
scenarios, and installation summary.

Installation Overview on page
11

SQL Server 2014 and SQL Server 2012 installation and
upgrade. Includes changing the SQL Server login account.

Installing and Configuring
SQL Server on page 17

The installation of Enterprise PDM database, archive,
SolidNetWork License Manager, Web servers, and Enterprise
PDM clients. Client installation includes creating and
deploying admin images, and scripting silent installations.

Installing SOLIDWORKS
Enterprise PDM on page 36

Creating file vault views using the View Setup wizard.
Includes applying licenses, using shared views, scripting file
vault view setup, and distributing file vault views.

Creating and Distributing File
Vault Views on page 68

Configuration of the Enterprise PDM Index Service. Includes
indexing file vault archives, updating the index server name,
changing login accounts, and adding index server filters.

Configuring Content Search
on page 90

Upgrade of the database, archive, and Web servers, the file
vault database and archives, and Enterprise PDM clients.

Upgrading Enterprise PDM on
page 105

Backing up the file vault database and Enterprise PDM Master
database, including archive server settings. Includes
scheduling database backups and restoring file vaults.

Backing Up and Restoring
File Vaults on page 98

Managing the SQL transaction log size, configuring Enterprise
PDM communication with IP addresses only, and moving
server components to another system.

Additional Configuration on
page 143
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2
Installation Overview

This chapter includes the following topics:

• Required Installation Components
• Optional Installation Components
• Enterprise PDM Deployment Scenarios
• System Requirements
• Installation Summary
• Installation Assistance

Required Installation Components
To use Enterprise PDM, these components must be installed and configured.

The Enterprise PDM file vault database must be
hosted on Microsoft SQL Server 2014, Microsoft SQL
Server 2012, or Microsoft SQL Server 2008 R2.

The SQL Server software is not included on the
SOLIDWORKS Enterprise PDM DVD and must be
installed separately.

Microsoft SQL Server

The database server periodically polls Enterprise PDM
databases for updates such as notifications, local view
refresh, replication schedule updates, and index
server changes. It also manages data import and
export rules.

SOLIDWORKS Enterprise PDM
database server

The archive server hosts the physical files stored in
a Enterprise PDM file vault, and manages users and
their credentials.

SOLIDWORKS Enterprise PDM
archive server

The SolidNetWork License Manager manages licensing
of SOLIDWORKS Enterprise PDM.

If you already have a SolidNetWork License Manager
installed for SOLIDWORKS, you can use it with
SOLIDWORKS Enterprise PDM. You must ensure that
it is updated to the Enterprise PDM release version.

SolidNetWork License Manager
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Each computer accessing the Enterprise PDM file vault
must have one of the following clients installed:

Supports working with all file
types, including enhanced
management and previewing
of CAD formats such as
SOLIDWORKS. CAD add-ins
allow users to access
Enterprise PDM from within
the CAD application.

SOLIDWORKS
Enterprise PDM
Professional CAD
Editor & Web

Supports working with all file
types, including CAD files.
However, the CAD add-ins are
not supported on this client
type.

SOLIDWORKS
Enterprise PDM
Professional
Contributor &Web

Allows read-only access to file
vaults; user cannot add or
modify (check out, check in,
update values) files or use
CAD add-ins.

SOLIDWORKS
Enterprise PDM
Professional
Viewer

Grants permission to run any
type of client, up to the
number specified for the
license.

SOLIDWORKS
Enterprise PDM
Professional
Processor License

SOLIDWORKS Enterprise PDM
client

Optional Installation Components
The following installation components are optional:

The Web server provides access to a file vault from the
Internet or an intranet.

Enterprise PDM Web server

The Enterprise PDM index server provides for full content
search in many file types stored in a Enterprise PDM file
vault.

Enterprise PDM index server
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Enterprise PDM Deployment Scenarios
The deployment of Enterprise PDM components depends on the size and type of
organization where Enterprise PDM is used.

Medium Office Network

A server running Microsoft SQL Server hosts the archive server, database server, and
SNL server. Windows workstations installed with the Enterprise PDM client attach to the
server.

Large Office Network

One server running SQL Server hosts the file vault databases and the database server.
One server hosts the archive server and another server hosts the SNL server. Workstations
installed with the Enterprise PDM client attach to the servers. A Web server allows access
over the Internet using Enterprise PDM Web clients.
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WAN Connected Offices

One main server running SQL Server hosts the central database server. A second server
hosts the archive server and a third server hosts the SNL server. Each WAN office has a
server hosting a local archive server with a replicated file vault archive.

Workstations installed with the Enterprise PDM client attach to their local archive server
and to the central database server.
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System Requirements
Enterprise PDM system requirements are available on the SOLIDWORKS Web site.

http://www.solidworks.com/sw/support/pdmsystemrequirements.html.
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Installation Summary
Although components can be installed in any order, the recommended sequence for a
LAN installation is described.

To install Enterprise PDM components:

1. Install SQL Server on the system that will host the Enterprise PDM file vault database,
unless you have an existing SQL Server running.
For details, see Installing and Configuring SQL Server on page 17.

2. Install the database server component on the system running the SQL Server.
For details, see Installing SOLIDWORKS Enterprise PDM Database Server on
page 38.

3. Install the archive server on the system running the SQL Server or on a separate
system.

For details, see Installing SOLIDWORKS Enterprise PDM Archive Server on
page 40.

4. Install and configure the SolidNetWork License Manager on a server that is accessible
to all clients, preferably the SQL database server.

For details, see Installing and Configuring SolidNetWork Licensing on page 49.

5. Install the Enterprise PDM client on all workstations that will work in the file vault.
For details, see Installing SOLIDWORKS Enterprise PDM Client on page 58.

6. Create a new file vault using the Enterprise PDM administration tool on a system
where the Enterprise PDM client is installed.
For details, see Vault Creation.

7. Attach the remaining clients to the archive server and create local file vault views
using the View Setup wizard.
For details, see Creating a File Vault View Using the View SetupWizard on page
76.

8. Optionally, set up the Enterprise PDM index server for content search support.
For details, see Configuring Content Search on page 90.

Installation Assistance
First level technical support for SOLIDWORKS products is provided by your reseller.

For help contacting your reseller:

• Refer to
http://www.solidworks.com/sw/support/customer-software-support.htm.

• Call 1-800-693-9000 from the USA or Canada.
• Call 1 978-371-5011 from other locations.
• Send e-mail to customercenterSR@solidworks.com.
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3
Installing and Configuring SQL
Server

SOLIDWORKS Enterprise PDM uses a Microsoft SQL-based database to store information about
files and activities in a file vault. File vaults require SQL Server 2014, SQL Server 2012, or
SQL Server 2008R2.

It is recommended that you use SQL Server 2014 to host the file vault database.

A Microsoft SQL Server 2014 DVD is included with the SOLIDWORKS Enterprise PDM media
kit. If you install from a downloaded kit, you must obtain Microsoft SQL Server software
separately; it is not included in the download.

If you already have the required version of SQL Server installed, continue to Installing
SOLIDWORKS Enterprise PDM on page 36.

If you are uncertain of which SQL Server version is installed, see Microsoft Knowledge Base
article 321185 to identify version and edition:

http://support.microsoft.com/default.aspx/kb/321185/en-us

This chapter includes the following topics:

• SQL Server 2014 Support
• Installing SQL Server 2014
• Upgrading to SQL Server 2014
• Installing SQL Server 2012
• Upgrading to SQL Server 2012
• SQL Server Troubleshooting
• Changing the SQL Server Login Account Used by Enterprise PDM

SQL Server 2014 Support
SOLIDWORKS Enterprise PDM 2015 supports the use of Microsoft SQL Server 2014.

For those customers who have obtained SQL Server 2014 through other channels,
SOLIDWORKS now supports its use with SOLIDWORKS Enterprise PDM 2015.
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Installing SQL Server 2014
The SQL Server 2014 installer provides help, including considerations for running on
Windows Vista or later. The SQL Server 2014 Books Online provide hardware and software
requirements and detailed installation instructions.

For details, see http://msdn.microsoft.com/en-in/library/bb545450.aspx.

Before Installing SQL Server 2014
For local installations, you must run Setup as an administrator. If you install SQL Server
2014 from a remote share, you must use a domain account that has read and execute
permissions on the remote share.

If Enterprise PDM is installed on the system, use Uninstall a program to uninstall the
Microsoft SQL Server 2012 Backward Compatibility package before starting the SQL
Server 2014 installation.

Microsoft .Net framework version 3.5 SP01 and Windows Installer 4.5 are required. If
they are not installed, the Installation Wizard installs them before starting the SQL Server
2014 installation. These installations may require you to restart your computer.

For Windows Server 2008 R2 x64, to install .Net framework 3.5 SP01, right-click My
Computer and selectManage > Features. In the Add Features Wizard, on the Features
page, expand .Net Framework 3.5.1 Features and select .Net Framework 3.5.1
(Installed).

Performing the SQL Server 2014 Installation

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2014 installation media. From the root folder, double-click

setup.exe and use the default selections unless otherwise instructed.

ActionScreen

In the left pane, click Installation.SQL Server Installation
Center/Planning

Click New SQL Server stand-alone installation or
add features to an existing installation.

SQL Server Installation
Center/Installation

The installer checks for problems that will prevent the
installation of the SQL Server support files:

• If no problems are reported, click OK.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Setup Support Rules
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ActionScreen

1. Select Enter the product key and type your license
key.

2. Click Next.

Product Key

1. Read and accept the license agreement.
2. Click Next.

License Terms

Click Install.Setup Support Files

The installer performs an additional check:

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Setup Support Rules

1. Under Instance Features, select Database Engine
Services.

2. Under Shared Features, select:

• Client Tools Connectivity
• Integration Services
• Client Tools Backward Compatibility
• Documentation Components
• Management Tools - Basic
• Management Tools - Complete

3. Click Next.

Feature Selection

If this is a new installation:

1. Select Default instance.
2. Click Next.

If SQL Server is already installed on the system and you
opted not to upgrade:

1. Select Named Instance.
2. Enter a unique instance name for this installation:

computername\instancename.

3. Click Next.

Instance Configuration

19

Installing and Configuring SQL Server



ActionScreen

If disk space requirements are met, click Next.

If disk space requirements are not met:

1. Note the space required.
2. Click Cancel.
3. Add the required space.
4. Run the installation again.

Disk Space Requirements

SQL Server Agent:

• Account Name: NT Service\SQLAgent$MSSQLSERVER
• Startup Type: Automatic

Server
Configuration/Service
Account tab

SQL Server Database Engine:

• Account Name: NT Service\MSSQL$MSSQLSERVER
• Startup Type: Automatic

SQL Server Integration Services 12.0:

• Account Name: NT Service\MsDtsServer120
• Startup Type: Automatic

SQL Server Browser:

• Account Name: NT AUTHORITY\LOCAL SERVICE
• Startup Type: Automatic

1. For Database Engine, click Customize.
2. In the dialog box, select Windows Collation
designator and sort order, and the Collation
designator that matches your locale. Keep the other
selections.

You cannot use Enterprise PDM on a server using
binary settings.

3. Click Next.

Server
Configuration/Collation tab
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ActionScreen

1. Select Mixed Mode (SQL Server Authentication
and Windows Authentication). Enterprise PDM
uses SQL Server authentication for database
communication.

2. Type a strong password for the system administrator
account (sa). Do not leave the password blank. For
password rules, click Help.

Retype the password to confirm it.

Remember the password for use when setting up
Enterprise PDM file vault databases.

3. Under Specify SQL Server administrators, click
Add.

4. In the Select Users, Computers, or Groups dialog
box, enter the name of the local administrator of the
system or the Administrators group.

5. Click Next.

Database Engine
Configuration/Account
Provisioning tab

Do not change settings
on the Data Directories
or Filestream tabs.

(Optional) To change the default folder where databases
created by Enterprise PDM are stored, change the
location for User database directory and User
database log directory.

Database Engine
Configuration/Data
Directories tab

Click Next.Error and Usage Reporting

The installer checks for problems that will prevent the
installation of SQL Server 2014.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Installation Rules

Click Install.Ready to Install

Installation may take a long time.

If you get an error regarding the SQL Server
Backwards-Compatibility Files, cancel the installation.
Use Uninstall a program to uninstall the Microsoft SQL
Server 2012 Backward Compatibility package. Then
restart the SQL Server 2014 installation.

When the progress bar shows Setup process
complete, click Next.

Installation Progress
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ActionScreen

Click Close.

If you receive a message that computer restart is
required, click OK. If a restart does not begin
automatically, manually restart your computer.

Complete

After Installing SQL Server 2014
To use secure SQL communication over the network and have a certificate server, you
can enable SSL encryption.

For details, see the Microsoft article:

http://support.microsoft.com/kb/318605/en-us

Verifying That SQL Server 2014 Was Installed Correctly

To verify that SQL Server 2014 was installed correctly:

1. Start the SQL Server Configuration Manager.
2. Click SQL Server 2014 Services and see whether SQL Server (MSSQLSERVER)

is running.
3. If it is not, start the service by right-clicking SQL Server (MSSQLSERVER) and

selecting Start.
4. Exit the SQL Server Configuration Manager.

Upgrading to SQL Server 2014
Follow these instructions to upgrade an existing SQL Server SQL 2008R2 or SQL Server
SQL 2012 instance to SQL Server 2014.

If upgrading to SQL Server 2014, see the SQL Server 2014 books online for detailed
instructions:

http://msdn.microsoft.com/en-in/library/bb677622.aspx

http://msdn.microsoft.com/en-in/library/bb545450.aspx

If you are uncertain of which SQL Server version is installed, refer to Microsoft Knowledge
Base article 321185 to identify version and edition:

http://support.microsoft.com/default.aspx/kb/321185/en-us

All file vault databases are automatically upgraded to SQL Server 2014 format when the
server instance is upgraded.
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Performing the Upgrade to SQL Server 2014

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2014 installation media, and from the root folder, double-click

setup.exe.
Use the default selections unless otherwise instructed.

ActionScreen

In the left pane, click Installation.SQL Server Installation
Center/Planning page

Click Upgrade from SQL Server 2005, SQL
Server 2008, SQL Server 2008 R2 or SQL
Server 2012.

SQL Server Installation
Center/Installation page

The installer checks for problems that will prevent
the installation of the SQL Server support files:

• If no problems are reported, click OK.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Setup Support Rules

1. Select Enter the product key and type your
license key.

2. Click Next.

Product Key

1. Read and accept the license agreement.
2. Click Next.

License Terms

Click Install.Setup Support Files

The installer performs an additional check.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Setup Support Rules

Select the SQL Server instance to upgrade.
MSSQLSERVER is the default.

Select Instance
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ActionScreen

Lists the installed SQL features that will be
upgraded.

Click Next.

Select Features

Lists the named instance that will be upgraded.

Click Next.

Instance Configuration

If disk space requirements are met, click Next.

If disk space requirements are not met:

1. Note the space required.
2. Click Cancel.
3. Add the required space.
4. Run the installation again.

Disk Space Requirements

Click Next.Server Configuration

Select Import and click Next.Full-text Upgrade

Click Next.Error and Usage Reporting

The installer checks for problems that will prevent
the upgrade to SQL Server 2014.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Upgrade Rules

Click Upgrade.Ready to Upgrade

When the upgrade finishes for all components,
click Next.

Upgrade Progress

Click Close.Complete

Click X in the upper right corner to close.SQL Server Installation Center

After Upgrading to SQL Server 2014

• Verify the upgrade.
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For details, see Verifying That SQL Server 2014 Was Installed Correctly on page
22.

• Troubleshoot problems.

For details, see SQL Server Troubleshooting on page 32.

Installing SQL Server 2012
The SQL Server 2012 installer provides help, including considerations for running on
Windows Vista or later. The SQL Server 2012 Books Online (SQL Server 2012
Documentation Components) provide hardware and software requirements and detailed
installation instructions.

For details, see
http://sqlish.com/installing-books-online-for-microsoft-sql-server-2012/.

Before Installing SQL Server 2012
For local installations, you must run Setup as an administrator. If you install SQL Server
2012 from a remote share, you must use a domain account that has read and execute
permissions on the remote share.

If Enterprise PDM is installed on the system, use Uninstall a program to uninstall the
Microsoft SQL Server 2008 Backward Compatibility package before starting the SQL
Server 2012 installation.

Microsoft .Net framework version 3.5 SP01 and Windows Installer 4.5 are required. If
they are not installed, the Installation Wizard installs them before starting the SQL Server
2012 installation. These installations may require you to restart your computer.

For Windows Server 2008 R2 x64, to install .Net framework 3.5 SP01, right-click My
Computer and selectManage > Features. In the Add Features Wizard, on the Features
page, expand .Net Framework 3.5.1 Features and select .Net Framework 3.5.1
(Installed).

Performing the SQL Server 2012 Installation

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2012 installation media. From the root folder, double-click

setup.exe and use the default selections unless otherwise instructed.

ActionScreen

In the left pane, click Installation.SQL Server Installation
Center/Planning

Click New SQL Server stand-alone installation or
add features to an existing installation.

SQL Server Installation
Center/Installation
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ActionScreen

The installer checks for problems that will prevent the
installation of the SQL Server support files:

• If no problems are reported, click OK.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Setup Support Rules

1. Select Enter the product key and type your license
key.

2. Click Next.

Product Key

1. Read and accept the license agreement.
2. Click Next.

License Terms

Click Install.Setup Support Files

The installer performs an additional check:

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Setup Support Rules

1. Under Instance Features, select Database Engine
Services.

2. Under Shared Features, select:

• Client Tools Connectivity
• Integration Services
• Client Tools Backward Compatibility
• Documentation Components
• Management Tools - Basic
• Management Tools - Complete

3. Click Next.

Feature Selection
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ActionScreen

If this is a new installation:

1. Select Default instance.
2. Click Next.

If SQL Server is already installed on the system and you
opted not to upgrade:

1. Select Named Instance.
2. Enter a unique instance name for this installation:

computername\instancename.

3. Click Next.

Instance Configuration

If disk space requirements are met, click Next.

If disk space requirements are not met:

1. Note the space required.
2. Click Cancel.
3. Add the required space.
4. Run the installation again.

Disk Space Requirements

SQL Server Agent and SQL Server Database
Engine:

• Account Name: NT AUTHORITY\SYSTEM
• Startup Type: Automatic

Server
Configuration/Service
Account tab

SQL Server Integration Services 10.0:

• Account Name: NT AUTHORITY\SYSTEM
• Startup Type: Automatic

SQL Server Browser:

• Account Name: NT AUTHORITY\LOCAL SERVICE
• Startup Type: Automatic

1. For Database Engine, click Customize.
2. In the dialog box, select Windows Collation
designator and sort order, and the Collation
designator that matches your locale. Keep the other
selections.

You cannot use Enterprise PDM on a server using
binary settings.

3. Click Next.

Server
Configuration/Collation tab
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ActionScreen

1. Select Mixed Mode (SQL Server Authentication
and Windows Authentication). Enterprise PDM
uses SQL Server authentication for database
communication.

2. Type a strong password for the system administrator
account (sa). Do not leave the password blank. For
password rules, click Help.

Retype the password to confirm it.

Remember the password for use when setting up
Enterprise PDM file vault databases.

3. Under Specify SQL Server administrators, click
Add.

4. In the Select Users, Computers, or Groups dialog
box, enter the name of the local administrator of the
system or the Administrators group.

5. Click Next.

Database Engine
Configuration/Account
Provisioning tab

Do not change settings
on the Data Directories
or Filestream tabs.

(Optional) To change the default folder where databases
created by Enterprise PDM are stored, change the
location for User database directory and User
database log directory.

Database Engine
Configuration/Data
Directories tab

Click Next.Error and Usage Reporting

The installer checks for problems that will prevent the
installation of SQL Server 2012.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components that
failed or prompted warnings.

2. Click Cancel to stop the installation and fix the
problems.

Installation Rules

Click Install.Ready to Install

Installation may take a long time.

If you get an error regarding the SQL Server
Backwards-Compatibility Files, cancel the installation.
Use Uninstall a program to uninstall the Microsoft SQL
Server 2008 Backward Compatibility package. Then
restart the SQL Server 2012 installation.

When the progress bar shows Setup process
complete, click Next.

Installation Progress
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ActionScreen

Click Close.

If you receive a message that computer restart is
required, click OK. If a restart does not begin
automatically, manually restart your computer.

Complete

After Installing SQL Server 2012
To use secure SQL communication over the network and have a certificate server, you
can enable SSL encryption.

For details, see the Microsoft articles:

http://support.microsoft.com/kb/318605/en-us

Related Topics
Verifying That SQL Server 2012 Was Installed Correctly on page 29
SQL Server Troubleshooting on page 32

Verifying That SQL Server 2012 Was Installed Correctly

To verify that SQL Server 2012 was installed correctly:

1. Start the SQL Server Configuration Manager.
2. Click SQL Server Services and see whether SQL Server (MSSQLSERVER) is

running.
3. If it is not, start the service by right-clicking SQL Server (MSSQLSERVER) and

selecting Start.
4. Exit the SQL Server Configuration Manager.

Upgrading to SQL Server 2012
Follow these instructions to upgrade an existing SQL Server SQL 2008 instance to SQL
Server 2012.

If upgrading to SQL Server 2012, see the SQL Server 2012 books online for detailed
instructions:

http://sqlish.com/installing-books-online-for-microsoft-sql-server-2012/

If upgrading to SQL Server 2008 R2, see
http://msdn.microsoft.com/en-us/library/bb677622(v=sql.105).aspx.

If you are uncertain of which SQL Server version is installed, refer to Microsoft Knowledge
Base article 321185 to identify version and edition:

http://support.microsoft.com/default.aspx/kb/321185/en-us

All file vault databases are automatically upgraded to SQL Server 2012 format when the
server instance is upgraded.
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Performing the Upgrade to SQL Server 2012

1. Close all Windows applications, including Windows Explorer.
2. Insert the SQL Server 2012 installation media, and from the root folder, double-click

setup.exe.
Use the default selections unless otherwise instructed.

ActionScreen

In the left pane, click Installation.SQL Server Installation
Center/Planning page

Click Upgrade from SQL Server 2008.SQL Server Installation
Center/Installation page

The installer checks for problems that will prevent
the installation of the SQL Server support files:

• If no problems are reported, click OK.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Setup Support Rules

1. Select Enter the product key and type your
license key.

2. Click Next.

Product Key

1. Read and accept the license agreement.
2. Click Next.

License Terms

Click Install.Setup Support Files

The installer performs an additional check.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Setup Support Rules

Select the SQL Server instance to upgrade.
MSSQLSERVER is the default.

Select Instance
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ActionScreen

Lists the installed SQL features that will be
upgraded.

Click Next.

Select Features

Lists the named instance that will be upgraded.

Click Next.

Instance Configuration

If disk space requirements are met, click Next.

If disk space requirements are not met:

1. Note the space required.
2. Click Cancel.
3. Add the required space.
4. Run the installation again.

Disk Space Requirements

Click Next.Server Configuration

Select Import and click Next.Full-text Upgrade

Click Next.Error and Usage Reporting

The installer checks for problems that will prevent
the upgrade to SQL Server 2012.

• If no problems are reported, click Next.
• If problems are reported:

1. Click Show details to list the components
that failed or prompted warnings.

2. Click Cancel to stop the installation and fix
the problems.

Upgrade Rules

Click Upgrade.Ready to Upgrade

When the upgrade finishes for all components,
click Next.

Upgrade Progress

Click Close.Complete

Click X in the upper right corner to close.SQL Server Installation Center

After Upgrading to SQL Server 2012

• Verify the upgrade.
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For details, see Verifying That SQL Server 2012 Was Installed Correctly on page
29.

• Troubleshoot problems.

For details, see SQL Server Troubleshooting on page 32 .

SQL Server Troubleshooting

Clients cannot work in the file vault

The SQL password has expired or the account has been locked
out.

Cause

Unlock the account by logging in using Windows Authentication.Solution

To unlock the SQL Server Account

1. Open Microsoft SQL Server Management Studio.
2. In the Connect to Server dialog box:

a) For Authentication, select Windows Authentication.
b) Click Connect.

3. In the left pane, expand Security and select Logins.
4. Right-click the SQL login that is defined for use in the archive server (typically the

sa account) and select Properties.
5. In the Login Properties dialog box, in the left pane, click Status.
6. Under Status, for SQL Server authentication, clear Login is locked out.
7. Exit Microsoft SQL Server Management Studio.

Enterprise PDM administrative features fail

Remote connections are not allowed.Cause

Enable the SQL Server remote access option.Solution

To enable the SQL server remote access option

1. Open Microsoft SQL Server Management Studio.
2. Log in as system administrator.
3. Right-click the server and select Properties.
4. In the Server Properties dialog box, click Connections.
5. In the right pane, under Remote server connections, verify that Allow remote

connections to this server is selected, and click OK.
6. Exit Microsoft SQL Server Management Studio.
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Enterprise PDM cannot connect to the server

TCP/IP is not enabled, or the TCP port is wrong.Cause

Activate the TCP/IP protocol for client connections and ensure
that TCP port 1433 is open.

Solution

To activate the SQL Server TCP/IP protocol:

1. Open the SQL Server Configuration Manager.
2. Log in as system administrator.
3. In the left pane, expand SQL Server 2008 Network Configuration, and click

Protocols for MSSQLSERVER.
4. In the right pane, verify that TCP/IP is enabled.
5. Right-click TCP/IP and select Properties.
6. On the IP Addresses tab, ensure that TCP is using port 1433.
7. Exit the SQL Server Configuration Manager.

Changing the SQL Server Login Account Used by Enterprise
PDM

The archive and/or database server services must be able to reach any Enterprise PDM
databases they manage using an SQL login that has at least db_owner access to the
databases. Normally when SQL Server is installed, a system administrator login (sa) is
created that has full access to all databases on the SQL Server.

Use this system administrator, or create a new user with db_owner access to the Enterprise
PDM databases.

If you plan to create new file vault databases using a db_owner SQL login, create this
SQL login first.

To create a new file vault database, you must log in as a SQL system administrator.
If you use a db_owner SQL login, you are prompted for the system administrator (sa)
login during vault creation.

Creating a New SQL Login Account

1. Open Microsoft SQL Server Management Studio.
2. Log in as a system administrator.
3. In the left pane, expand Security.
4. Right-click Logins and select New Login.
5. In the Login - New dialog box, select General:

a) Type a Login name for the new SQL user.
b) Select SQL Server Authentication and enter a password.
c) Clear Enforce password policy.
d) Click OK.

6. Close Microsoft SQL Server Management Studio.
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This login does not need any additional permissions to be used by Enterprise PDM.

Using the New SQL Login with the Enterprise PDM Archive

1. On the system running the Enterprise PDM archive server, open the SOLIDWORKS
Enterprise PDM Archive Server dialog box by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Startmenu, click All Programs > SOLIDWORKS Enterprise PDM
> Archive Server Configuration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Archive Server Configuration.

2. Select Tools > Default settings.
3. In the Settings dialog box, under SQL login, click Change.
4. In the Change SQL User Login dialog box, enter the SQL user login and password of

the new SQL user and click OK twice.

From now on, new file vault databases that are created are assigned db_owner
access for this user.

5. Exit the SOLIDWORKS Enterprise PDM Archive Server dialog box.
6. On the system running the Enterprise PDM database server, open the SOLIDWORKS

Enterprise PDM Database Server dialog box by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Startmenu, click All Programs > SOLIDWORKS Enterprise PDM
> Database Server Configuration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Database Server Configuration.

7. Enter the new SQL user login and password, and click OK.
8. Restart the SOLIDWORKS Enterprise PDM Database Server service.

Giving an SQL User db_owner Access to Existing
Enterprise PDM File Vault Databases

1. On the SQL server that hosts the new Enterprise PDM databases, open Microsoft SQL
Server Management Studio.

2. Log in as a system administrator.
3. In the left pane, expand Security and click Logins.
4. Right-click the SQL user and select Properties.
5. In the Login Properties dialog box:

a) In the left pane, select User Mapping.
b) In the right pane, under Users mapped to this login, selectMap for all Enterprise
PDM databases (file vault databases and ConisioMasterDb.)

c) For each database, under Database role membership, select db_owner.
d) Click OK.
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6. Right-click the server and select New Query.
7. In the right pane, enter the following query statement on the new db_owner user

and click Execute.
GRANT VIEW SERVER STATE TO [SQL_USER_NAME]

8. Exit Microsoft Microsoft SQL Server Management Studio.
9. On the system running the Enterprise PDM archive server, open the SOLIDWORKS

Enterprise PDM Archive Server dialog box by doing one of the following:

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Archive Server Configuration.

10. Select Tools > Default settings.
11. In the Settings dialog box, under SQL login, click Change.
12. In the Change SQL User Login dialog box, enter the SQL user login and password of

the new SQL user and click OK.
13. Close the SOLIDWORKS Enterprise PDM Archive Server dialog box.
14. On the system running the Enterprise PDM database server, open the SOLIDWORKS

Enterprise PDM Database Server dialog box by doing one of the following:

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Database Server Configuration.

15. Enter the new SQL user login and password and click OK.
16. Restart the SOLIDWORKS Enterprise PDM Database Server service.

Insufficient SQL Permissions
If you do not assign the SQL user sufficient SQL permissions, you cannot log in to any
file vault views.

Warning messages are displayed if the SQL user does not have at least db_owner access:

• To the ConisioMasterDb database

For example:

Could not log in to the database “filevault on Server servername".

• To the file vault database

For example:

Could not access the item in the database.

35

Installing and Configuring SQL Server



4
Installing SOLIDWORKSEnterprise
PDM

The SOLIDWORKS Enterprise PDM media contains the server and client components.

You can install each component separately, or select multiple components to install in a single
operation.

For example, to install the database server and archive server on the same computer, you
can select both options on the Server Installation screen.

When you install multiple components, the screens appropriate to those components are
displayed. For simplicity, the procedures in this chapter describe the component installations
separately.

This chapter includes the following topics:

• Initiating Enterprise PDM Installations
• Installing SOLIDWORKS Enterprise PDM Database Server
• Installing SOLIDWORKS Enterprise PDM Archive Server
• Installing and Configuring SolidNetWork Licensing
• Installing SOLIDWORKS Enterprise PDM Web Server
• Installing SOLIDWORKS Enterprise PDM Client

Initiating Enterprise PDM Installations
You perform the same initial steps to begin all Enterprise PDM installations.

The following components must be installed to install SOLIDWORKS Enterprise PDM:

• Windows Installer 3.1
• MSXML 6.0
• .Net Framework 4.0

Adobe Acrobat must be installed if you want to view documentation provided on the
SOLIDWORKS Enterprise PDM DVD.

To initiate the Enterprise PDM installation:

1. Insert the SOLIDWORKS Enterprise PDM DVD.
If the SOLIDWORKS Enterprise PDM Setup screen is not displayed, navigate to
Autorun.exe on the install disk and double-click.
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You can also start the installation wizard manually by running \setup\setup.exe
from the CD; however, this bypasses the initial installation screen.

2. On the SOLIDWORKS Enterprise PDM Setup screen, to change the setup screen
language and the language that is installed, place your cursor over the language icon

and select a language.
3. At the bottom of the screen, you can:

• Click the first two links to view summary installation instructions.
• Click Administration Guides to view installation and administration
documentation.

4. To begin the installation, click Install.
The installation wizard checks whether the required software components, Windows
Installer 3.1, MSXML 6.0, and .Net Framework 4.0, are installed on the system.

5. If a required component is missing, a dialog box listing the missing components is
displayed.
Click OK to install the components.

When done, the installation wizard continues. Initiate the installation using these
instructions:

ActionScreen

Click Next.Welcome

Accept the license agreement and click Next.License Agreement

1. Enter User Name and Organization.
2. Select the Default language.
3. Click Next.

Customer Information

To accept the default installation location, click Next.

To specify a different installation location:

1. Click Change.
2. Browse to the new location.
3. Click OK.
4. Click Next.

Destination Folder
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ActionScreen

• To install one or more Enterprise PDM servers, select Server
Installation.

For details, see:

• Installing SOLIDWORKS Enterprise PDM Database
Server on page 38

• Installing SOLIDWORKS Enterprise PDM Archive
Server on page 40

• Installing SOLIDWORKS Enterprise PDM Web Server
on page 58

• To install the Enterprise PDM client, select Client Installation.

For details, see Installing SOLIDWORKS Enterprise PDM
Client on page 58.

• To choose the features to be installed (including Item Explore
and the GZ filter for indexing compressed archives), select
Custom.

Setup Type

Installing SOLIDWORKS Enterprise PDM Database Server
The database server periodically polls Enterprise PDM databases for updates such as
notifications, local view refresh, replication schedule updates, and index server changes.

It must be installed for:

Workflow and other automatic notifications, such as change
state, check out, check in, add, and deadline

Automatic notifications

Automatic updates (refresh) of listings in file vault views
and add-ins

View updates

Periodic updates of card lists that use SQL queries for their
content

Card list updates

Updates of archive servers with changes made to cold store
schedules

Cold store scheduling

Updates of archive servers with changes made to replication
schedules

Replication scheduling

Administration of the indexing service for content searchesIndex server administration

Execution of data import and export rules at predefined
intervals

Data import/export
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It is recommended that you install the database server on the same system as Microsoft
SQL Server. You can install it on another system, but some network overhead may occur.

Before Installing the Database Server

• Ensure that the database server has access to the archive server over TCP port 3030
and to the SQL Server over TCP port 1433.

• Obtain the following information:

• SQL Server name
• Name and password of an SQL user account with read/write access

If you do not know the name of a user with read and write access, you can use the
SQL sa account that has these permissions. You can also create a login for this purpose.

For details, see Changing the SQL Server Login Account Used by Enterprise PDM.

Related Topics
Changing the SQL Server Login Account Used by Enterprise PDM on page 33

Performing the Database Server Installation

1. Login locally or remotely as a user with local administrative rights on the system
where you are installing the database server.

2. Begin the installation, as described in Initiating Enterprise PDM Installations on
page 36.

3. Complete the installation using these instructions:

ActionScreen

Select Server Installation and click Next.

To install multiple components on the same
system, such as client and server components,
or install additional components, select Custom.

Setup Type

Select Database Server and click Next.Server Installation
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ActionScreen

1. Specify the name of the SQL server to host the
file vault databases, by doing one of the following:

• Type the name of the SQL server.
• Click Browse to select from the list of available
SQL server instances on the network and click
OK.

If SQL server is installed on the system where
you are installing the database server, type or
select (local).

2. In the Login name field, type the name of an
SQL user on the server who has read and write
access (i.e., db_owner permission) to all
Enterprise PDM databases hosted on the SQL
server (the file vault databases and
ConisioMasterDb.)

3. In the Password field, enter the SQL user's
password.

4. Click Next.

The login information is verified. If it is incorrect, a
warning is displayed.

SOLIDWORKS Enterprise
PDM Database Server SQL
Login

Click Install.Ready to Install the
Program

Click Finish.InstallShield Wizard
Completed

Installing SOLIDWORKS Enterprise PDM Archive Server
The archive server hosts the physical files (drawings, documents, etc.) stored in a
Enterprise PDM file vault and manages Enterprise PDM users and their credentials.

All clients using Enterprise PDM must connect to one or more archive servers hosting one
or more file vault archives.

The archive server runs as a service on the system account of the computer where it is
installed, sending and receiving files between the clients and the file vault archive. It also
stores passwords and user login information. Only one archive server installation is
required per computer, hosting one or more file vault archives.

In a replicated environment, multiple archive servers can be set up to host replicated
copies of the same file vault archive. See the SOLIDWORKS Enterprise PDM Replication
Guide, located in the \Support\Guides\ directory of the SOLIDWORKS Enterprise PDM
DVD.
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To prevent problems attaching to the archive server, the server name should be 15
characters or less.

Before Installing the Archive Server
Set up the users, accounts, and permissions required to complete the archive server
installation.

The system account must have full access rights to create folders
and files under the folder to be designated as the archive server
root folder. The root folder can also be on a network share that
allows the archive server service to both read and write files.

You can change the archive server service log-on account to
users other than the system account in the service properties.

Root folder access

The SQL user that communicates with Enterprise PDM file vault
databases must have at least db_owner permissions to any
existing file vault databases on the SQL Server.

You can use the sa account that was created when the SQL
Server was installed.

For more information about SQL logins, see Changing the SQL
Server Login Account Used by Enterprise PDM.

SQL user account

If you want to assign user and group access rights to the archive
server during the installation, create the users and groups before
you begin.

To use domain users in Enterprise PDM, create a domain group
on the domain controller and add domain users that should
be able to log into SOLIDWORKS Enterprise PDM.

• During installation, add the domain group using the Find
User or Group dialog; the users will appear in the Enterprise
PDM administration tool.

• After installation, you can run the Archive Server
Configuration tool to add or change user and group
assignments.

User and group
accounts

Related Topics
Changing the SQL Server Login Account Used by Enterprise PDM on page 33
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Performing the Archive Server Installation

1. Login locally or remotely as a user with local administrative rights on the system
where you are installing the archive server.

2. Begin the installation, as described in Initiating Enterprise PDM Installations on
page 36.

3. Complete the installation using the following instructions:

ActionScreen

Select Server Installation.Setup Type

Select Archive Server and click Next.Server Installation

Click Install.

If you see a message that your local security
network access is set to “Guests only” and should
be changed to “Classic,” click Yes to accept the
change.

When the installation finishes, the Archive Server
Configuration wizard appears.

Ready to Install the
Program

Archive Server Configuration Wizard

Click Next.Welcome

1. Do one:

• Accept the default location for the archive server root folder.
• Change the location by doing one of the following:

• Click Browse and browse to a folder.
• Type the path.

If the folder you specified does not exist, you are asked
if it should be created.

The root folder path is assigned the name Archives, which
is used when setting up or attaching to a file vault from the
View Setup wizard on a client.

You must include the root folder and its subfolders (i.e.,
file vault archives) in the daily backup routines.

2. Click Next.

Root folder
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Archive Server Configuration Wizard

1. Type and confirm a password for the Admin user.

The Admin user account is assigned full administrative rights
to file vaults. Admin can create users, set up workflows, delete
files, etc. It is the only user present in a newly created file
vault.

You can change the password at any time using the Archive
Server Configuration tool.

2. Click Next.

Admin
password

1. Type the login information for the SQL user who will
communicate with the file vault databases hosted on the SQL
Server.

You can use the SQL Server system administrator user sa.

If you specify an SQL user with low permissions on the SQL
Server, this user will be assigned db_owner access to any new
file vaults created.

2. Click Next.

SQL user login
and password
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Archive Server Configuration Wizard

To define the Windows user accounts that are allowed access to
this archive server, by select the accounts under Available users
and groups and click the arrow pointing to Administrative
access or Attach access.

All local users and groups found on the system
are listed by default.

To add domain accounts to the list:

Available
users and
groups

1. Click Find User or Group.
2. In the Find User or Group dialog box, search
for additional user or group accounts. To add
a domain group, for example, type domain\
groupname and click OK.

Provides sufficient access to create new file
vaults, or remove, attach, or upgrade existing
file vaults on this archive server.

When you create a file vault, enter the username
and password of an account added to this
section.

Administrative
access

Provides sufficient access to attach to existing
file vaults managed by this archive server.

When you create a file vault view or connect to
a file vault, enter the username and password
of an account added to this section.

Attach access

Security
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Archive Server Configuration Wizard

Select one of the following authentication methods to use by
default when creating new file vaults managed by this archive
server:

Enterprise PDM user names and passwords are stored
on the archive server. You can add and remove them
using the Enterprise PDM administration tool on an
Enterprise PDM client.

Enterprise
PDM
login

Synchronizes logins to a file vault with the logged-in
Windows users (Active Directory). Passwords and
names are defined using standard Windows account
management.

In the Windows login settings dialog box, select
accounts under Available users and groups and
add them to Added users and groups by clicking
the right-arrow button.

To add domain accounts to the list:

Windows
login

1. Click Find User or Group.
2. In the Find User or Group dialog box, search for
additional user or group accounts. To add a
domain group, for example, type domain\
groupname and click OK.

Retrieves user accounts from a server using the LDAP
method (for example, Novell servers). The users are
available when adding users to a file vault using the
Enterprise PDM administration tool. Passwords and
user names are defined on the LDAP server managing
the accounts.

To define the connection settings to the server using
LDAP:

LDAP
login

Login type

Type the name or IP address of an LDAP server.Server name

Type the port used for LDAP on the server. The
default port is 389.

Port

Add at least one context with users that should
be listed in the Enterprise PDM user manager.

The context names must be entered as
distinguished names; for example, O-company,
OU=department, O=company or CN=Users,
DC=company, DC=com.

Contexts

User Context
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Archive Server Configuration Wizard

Type a context for the user login used by the
archive server to connect to the LDAP server.

Type a username that exists in the user context
selected. This user is used by the archive server
to connect to the LDAP server.

Username

Type the password for the selected user.Password

Click Finish.Completed

Opening Ports for Client/Server Communication
Windows Server, Windows 7, and Windows 8 have built-in firewalls activated by default.
These can restrict network access to applications requiring connections over the TCP/IP
interface.

The archive server uses TCP port 3030 to communicate with the clients. This port must
be fully opened in the firewall for an Enterprise PDM installation to accept incoming
connections. If the port is not opened, the archive server is not available.

It is recommended that you also allow inbound traffic on the corresponding UDP ports to
allow the servers to broadcast (announce themselves) on the network, for example by
showing the name in a drop-down list for users to attach to a server from a client.

To allow the SQL server to communicate with clients, you must open TCP ports 1433 and
1434. If you install the Enterprise PDM Web Server, you must open ports 80 and 443.

To check out a client license, you must open ports 25734 and 25735 on the SolidNetwork
License Server.

This table summarizes the ports that must be reachable. You open the firewall ports on
the listening/receiving side.

Communication Originating From

Listening/Receiving
Web ServerSQL ServerDatabase

Service
Archive
Server

Client

Client

3030303030303030Archive Server

Database
Service

1433/14341433/14341433/14341433/1434SQL Server

25734/2573525734/25735SNL Server

80/443Web Server
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Microsoft disables outbound filtering by default. However, your administrators may have
created outbound rules that restrict traffic to applications that are approved on the your
organization's network. If an Enterprise PDM client or replicated server cannot reach the
SQL server or Archive server, make sure that the network administrator has not restricted
access to the server ports in the Windows firewall settings.

Opening Ports on Windows and Windows Server Systems
You use Windows Firewall with Advanced Security to open the ports needed to
communicate with clients.

You create port rules that enable TCP and UPD ports for inbound Enterprise PDM traffic.

Open the ports for the archive server first. Then follow the same instructions to open the
ports for the SQL server and Web Server.

To open the ports for the archive server:

1. Open the Control Panel.
2. On the Adjust your computer’s settings page, click System and Security.
3. In the right pane, click Windows Firewall.
4. In the left pane, click Advanced settings.
5. In the right pane, under View and create firewall rules, click Inbound Rules.
6. In the far right pane, under Actions, Inbound Rules, click New Rule.
7. In the New Inbound Rule Wizard , on the Rule Type screen, in the right pane, select

Port and click Next.
8. In the right pane of the Protocol and Ports screen:

a) Select TCP.
b) Select Specific local ports and type 3030.
c) Click Next.

9. In the right pane of the Action screen, select Allow the connection and click Next.
10. In the right pane of the Profile screen, clear Public and click Next.
11. In the Name screen, for Name, type the exception name – for example, Enable TCP

port 3030 for inbound Enterprise PDM traffic and click Finish.
The wizard closes and the rule is added to the list of inbound rules. It is enabled by
default.

12. Repeat steps 6 through 11 to create an inbound rule for UDP port 3030.
13. On the system hosting the SQL Server, repeat steps 6 through 12 to create inbound

TCP and UDP rules for ports 1433 and 1434.
14. On the system hosting the SolidNetwork License Server, repeat steps 6 through 12

to create inbound TCP rules for ports 25734 and 25735.
15. On the system hosting the Web Server, repeat steps 6 through 12 to create inbound

TCP and UDP rules for ports 80 and 443.
16. Click File > Exit to close the Windows Firewall with Advanced Security window.
17. Close the Control Panel.
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Adding Archive Servers in a WAN Environment
SOLIDWORKS Enterprise PDM clients are normally set up to communicate with the Archive
Server and SQL server using the server system names. These system names are resolved
to IP addresses.

If this name lookup fails or is slow it can cause the following problems:

• Clients cannot find the servers at all. This is a common problem when using subnets
or WAN configurations.

• Overall performance using Enterprise PDM features such as logging in, browsing, or
adding files is slow.

• Replication between servers fails.

Verifying That the Server Name Can Be Resolved
To ensure optimal performance, make sure that the DNS server configuration is set up
to resolve names correctly and efficiently.

1. Open the command prompt by clicking Start > Run > CMD.
2. Type Ping server_name.

If the server can be reached by name, a reply with the server IP address appears.
For example:

PING SRV-DEV-15
Reply from 192.168.1.71: bytes=32 time<1ms TTL=128

3. Verify that the correct IP is returned.
If DNS returns the wrong IP address, a different system than the server responds.

If the server name cannot be resolved, the DNS server configuration is not correctly
configured. For example:

PING SRV-DEV-15
Ping request could not find host SRV-DEV-15. Please check the name and
try again.

Configuring the Hosts File to Resolve the Server Name
If the DNS servers cannot be configured or performance is still bad, update the client’s
hosts file with the correct server name and IP address. This ensures that the hosts file is
queried for the server address directly instead of waiting for the DNS name resolve.

To configure the hosts file to resolve the server name:

1. On the Enterprise PDM client, locate the Hosts file.
The default location is:

C:\Windows\System32\Drivers\Etc\

2. Open the file in a text editor (for example, Notepad).
3. Add a new line and enter the server IP address followed by the server name.

For example:

192.168.1.71 SRV-DEV-15
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4. Repeat Step 3 for any additional servers used by Enterprise PDM.
5. Save and close the hosts file.

Installing and Configuring SolidNetWork Licensing
SOLIDWORKS Enterprise PDM manages licensing using SolidNetWork License (SNL)
Manager.

Installing SolidNetWork Licensing includes:

• Installing the SolidNetWork License Manager.

If you already have a SolidNetWork License Manager installed for SOLIDWORKS,
you can use it with SOLIDWORKS Enterprise PDM. You must ensure that it is updated
to the Enterprise PDM release version.

• Activating client licenses.
• Configuring the SolidWorks NetWork License server for use with the file vault.
• Ensuring that the SolidNetWork License server is accessible to all clients.

Installing a SolidNetWork License Manager
You use the SolidNetWork License serial number to install the SolidNetWork License
Manager on a server that is accessible to all clients, preferably the SQL database server.

The SolidNetWork License software is included with the SOLIDWORKS Enterprise PDM
installation media.

Before beginning the installation, obtain the SolidNetWork License from the SOLIDWORKS
Customer Portal under My Products.

To install the SolidNetWork License Manager from the Enterprise PDM installer:

1. On the Custom Setup page or Server page, select License Server and click Next.
2. On the License Information page, enter the Enterprise PDM serial number.
3. Click Next.
4. Click Install.

To install SolidNetWork License Manager from the standalone installer:

1. Change directory to the appropriate setup folder on the SOLIDWORKS Enterprise PDM
DVD.

2. Start the installation by running \Setup\swlicmgr\setup.exe.
3. Enter the Enterprise PDM serial number.
4. Click Next.
5. Click Install.
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Activating a SolidNetWork License
You must activate a SolidNetWork License to log in to the Enterprise PDM vault as a client.

To activate the SolidNetWork License:

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager version.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager version.

2. When prompted to activate, click Yes.
If you have an activated SolidNetWork License, click Modify.

3. On the SolidNetWork License Server Information screen:

• If your company uses a firewall, select A firewall is in use on this server.

For more information, see Using SolidNetWork License Server with Firewalls
on page 50.

• Use the default value for Port Number (and for Vendor Daemon Port Number
if you have a firewall) or specify the port numbers your company uses.

The port number is a TCP/IP port number in the 1024-60000 range, used
exclusively by this process. Normally, the default (25734) is suitable and is
unlikely to be the same as any other FLEXnet server process currently on the
license manager server.

4. On the Activate Your SOLIDWORKS Product screen:

• Select the Internet or email procedure.
• Supply email contact information.
• Click Next to proceed.

• Internet: Activation occurs automatically.
• Email: Press Save to create a request file, then send the file to
activation@solidworks.com. When you receive the email containing the response
file, extract the file from email and then click Open to load it.

If necessary, you can exit and rerun the activation procedure to open the
response file.

5. Click Finish.

Using SolidNetWork License Server with Firewalls
If your server uses a firewall, you must configure ports to support SolidNetWork Licensing.

You must configure the firewall on the server side.
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Modifying SolidNetWork License Manager Settings for Windows
Firewall
If you are using Windows Firewall, you must modify the SolidNetWork License file to use
the firewall ports to distribute licenses to the license client computers.

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager version.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager version.

2. On the Server Administration tab, under License Server, click Stop. (Click Yes when
prompted for confirmation and OK to complete stopping the license server.)

3. Under License Information, click Modify.
4. Under Server Type, select the server arrangement for your network (Single or

Triad) and then click Next.
5. Under Server Information:

a) Select A firewall is in use on this server.
b) Port Number and Vendor Daemon Port Number should contain the port numbers
specified for the Windows Firewall.

c) Select Options File and click Browse to locate the file. Click Edit to change any
of its parameters.

The options file allows the license administrator to control various operating
parameters of FLEXnet Licensing.

The recommended location for the options file is in the SolidNetwork License
Manager installation directory (SolidNetwork_License_Manager_install_dir\
Licenses \sw_d.opt). This file must in the same directory as the sw_d.lic
file.

For more information about the options file, see the FLEXnet Publisher License
Administration Guide in the SolidNetwork License Manager installation directory
(\Docs\flexuser\licensingenduserguide.pdf).

d) Click Next and then click Finish.

6. On the Server Administration tab, under License Server, click Start.
7. Click OK to close the SolidNetWork License Manager.
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SolidNetWork License Administration
Tasks include starting, upgrading, and uninstalling the license manager licenses.

Starting the SolidNetWork License Manager
You can start the SolidNetWork License Manager from the Windows Start menu.

Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager version.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager version.

Upgrading the SolidNetWork License Manager
For major releases of SOLIDWORKS Enterprise PDM, upgrading the license manager
consists of uninstalling the old license manager, installing a new one, and re-activating
the SolidNetWork License.

To upgrade the SolidNetWork License Manager:

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager version.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager version.

2. On the License Usage tab, verify that no client computers on the network are running
SOLIDWORKS Enterprise PDM.

3. Uninstall the old license manager. For details, see Uninstalling the SolidNetWork
License Manager.

4. Install the new license manager and re-activate the SolidNetWork License on the
license manager server. For details, see Installing a SolidNetWork License
Manager on page 49.

Uninstalling the SolidNetWork License Manager
If you want to upgrade the SolidNetWork License Manager, you must uninstall it before
installing the new one. If you want to transfer the SolidNetWork License to another server,
you must transfer before removing it from this server.

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager version.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager version.

2. Verify that no clients on the network are running SOLIDWORKS Enterprise PDM.
The License Usage tab shows the clients using the licenses.
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3. On the Server Administration tab, under License Server, click Stop.
4. Click OK to exit the license manager.
5. In Windows, open Control Panel > Programs > Programs and Features.
6. Select SOLIDWORKS SolidNetWork License Manager, click Uninstall, and confirm

the deletion.

You now are ready to install a new version of the license manager. For details, see
Installing a SolidNetWork License Manager and Activating a SolidNetWork License
on page 50.

Transferring a SolidNetWork License
To transfer a SolidNetWork License to a new or upgraded server, first transfer the license
to the license key server at Dassault Systèmes SOLIDWORKS Corporation, then reactivate
it on the other server.

If you were unable to transfer the license to Dassault Systèmes SOLIDWORKS
Corporation (because of hard drive failure, for example), reactivation is still successful
in most cases. If not, contact your VAR for help.

You can have only one activated SolidNetWork License server per serial number.

To transfer a SolidNetWork License back to the server:

1. Start the SolidNetWork License Manager by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS version > SOLIDWORKS Tools >
SolidNetWork License Manager version.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Tools, click SolidNetWork License Manager version.

2. Under License Information, click Modify. The SOLIDWORKS Product Activation
wizard starts.

3. UnderWhat would you like to do?, select Transfer a software license and then
click Next.

4. Under How would you like to transfer?, select Automatically over the internet
(recommended).

5. Under Contact Information, specify an email contact address.
6. Click Next. The product license transfer completes.

Installing Temporary Licenses
The temporary "ANY" license can be used temporarily when the original SolidNetWork
License is not available.

By installing the "ANY" license file, you agree to implement the traditional license upon
receipt of a SolidNetWork license from Dassault Systèmes SOLIDWORKS Corporation.
Compliance with license restrictions still is required.
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To install an "ANY" license:

1. If you are an existing SolidNetWork user, uninstall the SolidNetWork License Manager
and delete the installation folder. For details, see Uninstalling the SolidNetWork License
Manager.

2. Install the SolidNetWork License Manager from SOLIDWORKS Enterprise PDM installer.

You can also install the SolidNetWork License Manager from a standalone installer.
For details, see Installing a SolidNetWork License Manager on page 49.

a) On the SOLIDWORKS SolidNetWork License Manager Setup page, enter the
SolidNetWork License serial number and click Next.

b) Click Install.

3. Start the SolidNetWork License Manager (Start > All Programs > SOLIDWORKS
version > SOLIDWORKS Tools > SolidNetWork License Manager version).

4. If you are prompted to activate, click No.
The Server Administration tab of the SOLIDWORKS SolidNetwork License Manager
appears.

5. Under Advanced Options, click Options.
The Advanced Options dialog box appears.

6. Under SolidNetWork Server License Mode, click Use a License File and click OK.
The Advanced Options dialog box closes.

7. Under License Information, click Modify.
The SolidNetWork License File Wizard appears.

8. Under Server Type, select Single and click Next.
9. When you see this message:

Could not read the dongle ID number. click Cancel.

The ID "ANY" appears automatically.

If your computer uses a firewall, you might have to make some additional
specifications on this screen. For more information, see Using SolidNetWork
License Server with Firewalls on page 50.

10. Continue with the installation.

Troubleshooting SolidNetWork Licenses
If the SolidNetWork License Manager installation fails, check for these possible
explanations.

Accessing the SolidNetWork License log files

When a license error occurs, the answer often appears in the SNL_Manager_install_dir\
lmgrd.log file.

Could not obtain a license for SOLIDWORKS Enterprise PDM or Cannot
connect to license server

Typically, these problems are caused by port settings.
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• Port settings between the SolidNetWork License Manager and the license client might
not match.

• Additional port settings for multiple versions of SolidNetWork License Managers might
not have been specified.

• Check that the client machine can accurately resolve and route to the server, given
the server name. Also, check that the server can accurately resolve and route to the
client, given the client machine name.

• Check that the port number in the log file under Server Administration tab is correct.
• Check that the firewall on the SolidNetWork License server does not block the port
access.

When a log error occurs, you can check the Log File in the Administration tool.

Licensing

License Types
Enterprise PDM uses floating client licenses. When you log in to a vault, the license installed
on your system is taken from a pool of licenses that are enabled by the registered license
file. When you log out or exit Enterprise PDM, the license is returned to the pool and can
be used by another client.

Available licenses are:

• SOLIDWORKS Enterprise PDM Professional CAD Editor & Web

Includes these license types:

Editor: Supports working with all file types, including management and previewing of
CAD formats such as SOLIDWORKS. CAD add-ins allow users to access Enterprise PDM
from within the CAD application.

Web: Remote users can use the WEB client to search the vault and perform basic
functions to enable remote work processes.

• SOLIDWORKS Enterprise PDM Professional Contributor & Web

Includes these license types:

Contributor: Users on a local area network (LAN), wide area network (WAN or virtual
private network (VPN) can perform the same functions as with the Editor license type,
except that CAD add-ins are not enabled.

Web: Remote users can use the WEB client to search the vault and perform basic
functions to enable remote work processes.

• SOLIDWORKS Enterprise PDM Professional Viewer

Allows read-only access to vaults. Users cannot add or modify (check out, check in,
update values) files or use CAD add-ins.

• SOLIDWORKS Enterprise PDM Professional Processor License

Grants permission to run any type of client, up to the number specified for the license.
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Changing the Client License Type
You select the client license type during installation.

Pre-requisites:

• To change the license type, you must have local administrative permissions to Windows.
• For clients installed from an administrative image (via active directory deployment or
a similar scripted install), you must reinstall the client using another administrative
image of the specified client type.

You can change the license type by:

• Using Control Panel > Programs > Uninstall a program to remove Enterprise PDM
and then reinstalling.

• Opening the Uninstall or change a program dialog box, and selecting SOLIDWORKS
Enterprise PDM > Change. In the SOLIDWORKS Enterprise PDM Installation Wizard,
select Modify.

• Using the About SOLIDWORKS Enterprise PDM dialog box.

To change the client license type from the About SOLIDWORKS Enterprise PDM
dialog box:

1. Click Help > SOLIDWORKS Enterprise PDM Administration.
2. Use the Client type drop-down list to select a different client license type.
3. Click OK.
4. When instructed to restart your computer, click OK.
5. Restart your computer.

Depending on the license type that was used when the client was installed, changing
to the CAD Editor license type from the About SOLIDWORKS Enterprise PDM dialog
box might not enable the CAD Add-in. If it does not, remove Enterprise PDM as
described above and select SOLIDWORKS Enterprise PDM Editor when you reinstall.

Viewing Version Information for Non-client Systems

To find the version of Enterprise PDM software on a server that does not have
a client installed:

1. Open the Control Panel > Programs > Uninstall a program.
2. Click SOLIDWORKS Enterprise PDM.

The Version column displays the currently installed version.

Viewing Version Information for Client Systems

To find the version of Enterprise PDM software on a client:

1. Log in to the Enterprise PDM Administration tool.
2. Click Help > SOLIDWORKS Enterprise PDM Administration.
3. View the Client version and click OK.
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Adding and Modifying SolidNetWork License Server
To log in to a vault from an Enterprise PDM client, a license that matches the currently
installed license type and version must be available. The license is retrieved from the
SolidNetWork License server that is defined in the license setting. To add or modify
SolidNetWork License server, you use the Set License dialog box available from the
Administration tool.

To add or modify license server:

1. Open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS Enterprise PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. Create a file vault or expand the existing file vault.
3. Right-click the License node and select Open.
4. On the Server List tab, click Add.
5. Enter the SolidNetWork License Manager's address in the form: port@SNLServerName

The default port number is 25734. You can enter either the host name or IP address
of the SolidNetWork License server for SNLServerName. Ensure that all clients are
able to connect to the server by IP address or host name.

6. Click OK.
7. Click the License Usage tab to ensure that Enterprise PDM licenses are available.
8. Click OK.

Set License Dialog Box
Use the Set License dialog box to add or modify license servers. To log in to a vault from
an Enterprise PDM client, a license that matches the currently installed license type and
version must be available.

Log in to the Administration tool and to open this dialog box do one of the
following:

• Double-click License.
• Right-click License and select Open.

Server

Lists the SolidNetWork License servers.

For example, Port@SNLServerName

Server List

Lets you add license servers.Add

Lets you remove selected license servers.Remove
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License Usage

Lets you select the SolidNetWork License server.Server

Lets you select an Enterprise PDM license type for getting more
details on it. The available license types are:

• SOLIDWORKS Enterprise PDM Professional CAD Editor &
Web

• SOLIDWORKS Enterprise PDM Professional Contributor &
Web

• SOLIDWORKS Enterprise PDM Professional Viewer
• SOLIDWORKS Enterprise PDM Professional Processor
License

For details, see License Types.

Product

Shows total number of licenses.Total licenses

Shows number of available licenses.Free licenses

Shows details of used licenses.Licenses used by

Installing SOLIDWORKS Enterprise PDM Web Server
The SOLIDWORKS Enterprise PDM Web server gives users live access to one or more file
vaults from any system using Windows Internet Explorer over the Internet or an intranet.

To learn how to install and use the Web server and client, see the SOLIDWORKS Enterprise
PDM Web Server Guide, located in the \Support\Guides\ directory of the SOLIDWORKS
Enterprise PDM DVD.

Installing SOLIDWORKS Enterprise PDM Client
For a system to work with an Enterprise PDM file vault, it must have the Enterprise PDM
client installed.

The following types of Enterprise PDM client are available:
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Supports working with all file types, including enhanced
management and previewing of many CAD formats such
as SOLIDWORKS, AutoCAD, Inventor, SolidEdge, and
Pro/ENGINEER. Should be used on any system working
with CAD files.

To work with Pro/ENGINEER files, install the
Pro/ENGINEER CAD add-in after installing the Enterprise
PDM client. As of SOLIDWORKS Enterprise PDM 2012,
the Pro/ENGINEER connector requires separate
installation media. Contact your SOLIDWORKS Value
Added Reseller for more information.

SOLIDWORKS Enterprise
PDM Professional CAD
Editor & Web

Includes support for Enterprise PDM Web client access.

Supports working with all file types, including CAD files.
However, CAD add-ins are not supported on this client
type.

SOLIDWORKS Enterprise
PDM Professional
Contributor & Web

Includes support for Enterprise PDM Web client access.

Allows read-only access to file vaults; user cannot add or
modify (check out, check in, update values) any files. CAD
add-ins are not supported on this client type.

SOLIDWORKS Enterprise
PDM Professional Viewer

Grants permission to run any type of client, up to the
number specified for the license.

SOLIDWORKS Enterprise
PDM Professional
Processor License

You can install clients:

• By using the installation wizard on the SOLIDWORKS Enterprise PDM DVD.
• By creating an administrative deployment image to install multiple seats.

Related Topics
Installing Clients Using the Installation Wizard on page 61
Creating an Enterprise PDM Client Administrative Image on page 62

Before Installing Clients

• Find out the type of client your license agreement entitles you to use.

The floating license manager in Enterprise PDM prevents logging into a file vault if the
wrong client type is installed.

• If you are installing the Enterprise PDM Editor Client, you can install CAD add-ins.

Add-ins make version management features such as check out, check in, and get
available from menus and toolbars within your CAD software. They are optional and
do not affect which file formats can be managed by Enterprise PDM using the Windows
Explorer interface or file open/save dialogs.

The following product-specific prerequisites apply:
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You can manage SolidWorks files without having SolidWorks installed.
It is recommended to have the eDrawings viewer installed for
previewing. EDrawings is normally installed automatically with the
client.

SolidWorks

To manage Inventor files (add, check out, check in, preview, etc.),
the client system must have either the full Autodesk Inventor
application or the Inventor Design Assistant software installed. For
previewing Inventor files, Inventor View should be installed.

Autodesk
Inventor

AutoCAD does not have to be installed to manage DWG/DXF files.
It is recommended to have the eDrawings or DWG TrueView
application installed for previewing DWG files and the DWF viewer
for previewing DWF files.

Autodesk
AutoCAD

You can install Microsoft Office Add-in when you install SOLIDWORKS
Enterprise PDM. You do not need additional licenses to use the
Microsoft Office Add-in but must have a Contributor, CAD Editor, or
PSL license to check files out and in.

Microsoft Office
Integration

Enterprise PDM requires the full Solid Edge application installed for
managing and previewing Solid Edge files.

Solid Edge

Enterprise PDM requires the full Pro/ENGINEER application installed
for managing and previewing Pro/ENGINEER files.

As of SolidWorks Enterprise PDM 2012, the Pro/ENGINEER
Connector requires a separate installation after the SolidWorks
client installation. The software can be obtained from your
SolidWorks Value Added Reseller.

Pro/ENGINEER

For more information, log in to the Customer Portal and view the Knowledge Base solution
S-029120.

These requirements apply to installations performed from the SolidWorks Enterprise PDM
media or from an administrative image.
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Installing Clients Using the Installation Wizard

1. Log on to the client computer as a user with local administrative rights.
2. Begin the installation, as described in Initiating Enterprise PDM Installations on

page 36.
3. Complete the installation using the following instructions:

ActionScreen

To install the client without Item Explorer, select
Client Installation and click Next.

To include the Item Explorer in your installation:

1. Select Custom.
2. On the Custom Setup screen, under Client,
click Item Explorer and select This feature
will be installed on local hard drive.

3. Click Next.

Setup Type

1. Select the type of client to install, based on
your license:

• SolidWorks Enterprise PDM Professional
CAD Editor & Web

• SolidWorks Enterprise PDM Professional
Contributor & Web

• SolidWorks Enterprise PDM Professional
Viewer

2. Click Next.

Choose Product Type

1. If the product type is SolidWorks Enterprise
PDM Editor, you optionally can select the CAD
software add-ins or Microsoft Office add-ins to
install.

2. Click Next.

Select Add-Ins

Click Install.Ready to Install the Program

Click Finish.InstallShield Wizard Completed
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Enabling Logging to Troubleshoot Installation
An installation log is useful when troubleshooting a failing installation.

1. Open a command prompt.
2. Change directory to the appropriate setup folder on the SOLIDWORKS Enterprise PDM

DVD:

• For 32-bit systems: Setup
• For 64-bit systems: Setup64

3. Type the appropriate command to start a logged installation:

• For 32-bit systems:

MSIEXEC /i EnterprisePDM.msi /L*v C:\LOGFILE.TXT

• For 64-bit systems:

MSIEXEC /i EnterprisePDM64.msi /L*v C:\LOGFILE.TXT

An installation log is created with information about the installation.

Creating an Enterprise PDM Client Administrative Image
An administrative installation image lets you control the installation and upgrade of the
client on multiple client machines.

You must create and deploy separate images depending on client license type or operating
system (64-bit or 32-bit).

The installation wizard creates a setup package (EnterprisePDM.msi and required files)
that you can distribute using Microsoft Active Directory or another distribution method.

Keep a copy of the administration image, which includes all options you select, to make
it easier to uninstall when doing an upgrade.

To create an administrative image:

1. From the Windows Start menu, click Run.
2. Browse to or type the location of setup.exe on your SOLIDWORKS Enterprise PDM

DVD and add the command switch /a.
For example:

CommandOperating System

E:\Setup\setup.exe /a32-bit

E:\Setup64\setup.exe /a64-bit
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3. Click OK.
4. Create the administrative image using these instructions:

ActionScreen

Select the language for the setup wizard and click
OK.

Choose Setup Language

Click Next.Welcome

Read and accept the license agreement and click
Next.

License Agreement

Select the language for the clients and click Next.Select default language

• To give clients installing from an administrative
image access to the Item Explorer, select Item
Explorer and click Next.

• To prevent access to the Item Explorer, click
Next.

Item Support

1. Select the type of client for which to create an
administrative image, based on the license:

• Enterprise PDM Editor
• Enterprise PDM Contributor
• Enterprise PDM Viewer

2. Click Next.

Choose Product Type

1. (Optional) If the product type is Enterprise PDM
Editor, select the CAD software add-ins to
install.

2. Click Next.

Select Add-Ins

Enter a location where the Enterprise PDM client
administrative image should be created.

If you plan to distribute this image, place it on
a network resource that is available to all client
systems.

Network Location

Click Install.Ready to Install the Program

Click Finish.InstallShield Wizard Completed
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Deploying Clients Using Windows Active Directory
By using the Group Policy features of Windows Active Directory, you can centrally deploy,
install, and manage Enterprise PDM clients throughout an organization.

You can also perform routine maintenance tasks such as upgrading, patching, and
removing clients from a central location, without going to individual workstations.

If you distribute the clients using an administrative image, you must deploy Microsoft
XML Core Services (MSXML) 6.0 and .Net Framework 4.0 to all clients.

For information on distributing MSXML and .Net Framework, see
http://msdn.microsoft.com/en-us/library/ee390831.aspx.

You are no longer required to deploy the SQL_DMO components to clients.

Only the Enterprise PDM client can be deployed using this method. Install the archive
server and database server using the standard installation method.

Active Directory deployment considerations:

• Because Enterprise PDM is installed on a computer level, before any user has logged
on, the deployment package should be available (i.e., shared with sufficient access
rights) to all systems assigned for deployment.

• To deploy Enterprise PDM on operating systems using a language other than English,
activate the option Ignore language when deploying this application in the
advanced deployment package settings.

• Once deployed, you can add file vault views to the clients:

• Using a policy

For details, see Distributing an Enterprise PDM File Vault View Using Microsoft
Windows Active Directory on page 82.

• Using a scripted view installation

For details, see Scripting File Vault View Setup on page 82.

To deploy a client admin image using Windows Server 2008 Active Directory:

1. Create an administrative image (EnterprisePDM.msi) in a network location that is
accessible by UNC path to all systems where Enterprise PDM should be deployed.
For details, see Creating an Enterprise PDM Client Administrative Image on
page 62.

2. Open the Control Panel and click System and Security > Administrative Tools
> Active Directory Users and Computers.

3. Create a security group, or use an existing security group.
To create a security group:
a) In the Active Directory User and Computers dialog box, right-click Users and select
New > Group.

b) In the New Object - Group dialog box, type a Group name.
c) Under Group type, select Security and click OK.
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4. Add the computers where Enterprise PDM should be deployed.
To add domain computers to the security group:
a) Right-click the security group and select Properties.
b) On the Members tab, click Add and add the computers.

5. Exit the Active Directory User and Computers dialog box.
6. In the Control Panel, click System and Security > Administrative Tools > Group

Policy Management.
7. In the Group Policy Management console, create a new group policy for the security

group you created in steps 3 and 4.
8. Expand Group Policy Objects in the forest and domain that contains the new group

policy and select the group policy.
9. In the right pane, on the Settings tab, right-click Computer Configuration and click

Edit.
10. In the Group Policy Management Editor, navigate to Computer Configuration >

Policies > Software Settings > Software Installation.
11. Right-click and select New > Package.
12. Browse to the EnterprisePDM.msi file in the location where you created the Enterprise

PDM client administrative image.

You should browse to the location through My Network Places to use the UNC
path correctly. Do not use a mapped drive.

13. Click Open.
14. In the Deploy Software dialog box, select Assigned and click OK.
15. Exit the Group Policy Management Editor and Group Policy Management console.

The client image is ready for deployment and will be installed to the computers in the
security group the next time the systems start up.

Enabling Logging When Deploying Enterprise PDM
To troubleshoot installation problems that occur when you deploy an Enterprise PDM
client administrative image using Windows Active Directory, you should enable logging
of the installation procedure. This is done through a Group Policy.

1. On the Active Directory server, locate the OU where the deployment package is
assigned.

2. Right-click the OU, and select Properties.
3. In the Properties dialog box, on the Group Policy tab, click New to add a new Group

Policy object. Name the policy (for example, Logging) and click OK.
4. Select the new policy (or an existing deployment policy) and click Edit.
5. In the Group Policy Object Editor, expand Computer Configuration >

Administrative Templates > Windows Components > Windows Installer.
6. In the right pane, double-click the Logging setting.
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7. In the policy object’s Properties dialog box:
a) Enable the policy.
b) In the Logging text box, type the full logging arguments:

iwearucmpvo

c) Click OK.

8. On the Group Policy tab, if you created a new group policy object, make sure that
the new policy is listed at the top of the list.

When you deploy Enterprise PDM, an .msi installation log will be created in the Temp
folder under the Windows system folder.

Scripting a Silent Installation of Enterprise PDM
You can script the client installation from an administrative image (for example, to run
the installation from a .bat file).

To script a silent installation:

1. Create an administrative image for the client type you are installing to create the
EnterprisePDM.msi installation package that is used in the following commands.
For details, see Creating an Enterprise PDM Client Administrative Image.

2. Update your installation script with one of the following commands to launch a silent
installation:

• Silent installation with progress

Msiexec /i EnterprisePDM.msi /qb

• Silent installation without progress

Msiexec /i EnterprisePDM.msi /qn

• Silent installation with progress and automatic reboot (if required)

Msiexec /i EnterprisePDM.msi /qb-

• Silent installation without prompting for reboot

Msiexec /i EnterprisePDM.msi /qb REBOOTYESNO=NO REBOOT=REALLYSUPPRESS

If you upgrade a previous installation with this option, you must perform a reboot
at the end of the installation to reload any replaced files that are in use.

• Silent installation with progress and without automatic eDrawings installation

Msiexec /i EnterprisePDM.msi /qb REMOVE=eDrawings

If you omit the REMOVE=eDrawings switch, the eDrawings viewer will automatically
be included when installing from an administrative image.
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Related Topics
Creating an Enterprise PDM Client Administrative Image on page 62

Silent Installation Switches

DescriptionSwitch

No UI/qn

Basic UI/qb

Reduced UI with a modal dialog box displayed at the end of the
installation

/qr

Full UI with a modal dialog box displayed at the end of the
installation

/qf

No UI except for a modal dialog box displayed at the end of the
installation

/qn+

Basic UI with a modal dialog box displayed at the end of the
installation

/qb+

Basic UI with no modal dialog boxes/qb-

Excludes a feature from installingREMOVE=[string]
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5
Creating and Distributing File Vault
Views

Enterprise PDM file vaults store the files and information managed by Enterprise PDM.

To add a file to a file vault, you place it in a local file vault view, which is a working folder
where all intermediate file modifications are performed.

The file vault view is directly connected to:

• The archive server, which stores the physical files in a file vault archive
• The file vault database, which stores information about files and activities in the file vault

You can access files and information stored in a file vault only from a system with the Enterprise
PDM client installed by logging in as a user with sufficient access rights.

This chapter includes the following topics:

• Vault Creation
• Configuring the SolidNetWork License Server for the File Vault
• Creating a File Vault View Using the View Setup Wizard
• Distributing an Enterprise PDM File Vault View Using Microsoft Windows Active

Directory
• Distributing File Vault Views in a WAN Environment

Vault Creation
Use the Enterprise PDM Administration tool to create the vault on the archive server.

Prerequisites

Before creating a vault:

• Verify that all Enterprise PDM components have been installed.
• Ensure the archive server is available.

If the archive server you want to use is on another system, you may need to add it.

The archive server may not be accessible if a firewall on the archive system is blocking
TCP port 3030.

• If the SQL Server is on a different system than the archive server, ensure that it is
available. It may not be accessible if a firewall is blocking port 1433.

• Ensure you have sufficient access rights.
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Your Windows user account must have Administrative access to the archive server. If
you create the vault on the same system as the archive server, the local administrator
has this access by default.

• Obtain SQL Server information.

You must know:

• The SQL server name.
• Login information for a user with sufficient system administrator privileges to create
a vault.

Related Topics
Installing SOLIDWORKS Enterprise PDM Archive Server on page 40
Installing SOLIDWORKS Enterprise PDM Database Server on page 38
Installing SOLIDWORKS Enterprise PDM Client on page 58
Installing and Configuring SQL Server on page 17

Adding an Archive Server
To create a vault, you must be able to connect to an archive server. If an archive server
is installed but is not visible in the Administration tool, you can add it.

1. Start the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. Click File > Add Server.
3. In the Add Server dialog box, for Server name, select or type the server to add.

Use the server system name, not the IP address, unless the environment is configured
for IP-only communication, as described in the Installation Guide.

When adding an archive server to a wide-area network (WAN), DNS can fail when
looking up the IP address of the server host name. As a workaround, ensure that the
client can successfully ping the server by name. If the ping does not work, update
the local HOSTS file. Microsoft Knowledge Base article 172218 describes these issues
in more detail:
http://support.microsoft.com/default.aspx?scid=kb;EN-US;172218.

4. Click OK.

Logging In to an Archive Server
Before creating a new vault, you may need to log in. If the account has create rights on
the archive server, login is not required.

To log in to an archive server:

1. In the Login dialog box, enter the Windows user name and password of a user with
access to vaults on the archive server.
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• To add the archive server and list its vaults, log in as a user who is a member of
the attach access list in the Archive Server Configuration tool.

• To perform administrative tasks such as creating, upgrading, or removing a vault,
log in as a user with administrative access.

2. If the Login dialog box includes a Domain list, do one:

• If you are using a local user account on the archive server, select the system name
that is followed by (local account).

• If you are using a domain account, select or type the correct domain.

3. Click Log In.

Creating a Vault

To create a vault:

1. Log in to a system where the Enterprise PDM client is installed.
2. Start the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

3. If the archive server you want to work with is not listed, add it as described in Adding
an Archive Server.

4. In the left pane, right-click the archive server in which to create the vault, then select
Create new vault.

If you are prompted to log in, see Logging In to an Archive Server.

5. In the vault setup wizard:

ActionScreen

Click Next.Welcome

Type a name and description for the new vault.

The name appears on all attached client systems and cannot
be changed later.

Choose vault name

Under Vault root folder, select the root folder in which to
store the vault archives.

The default root folder is Archives.

Select vault root
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ActionScreen

The vault database contains information about files and
activities in the vault.

Select or enter the SQL server to host the vault database in
Select database server.

Type the Database name.

If the SQL login dialog box appears, the stored SQL login has
insufficient privileges or is not a user on the SQL server.
Specify a SQL user such as sa with sufficient system
administrator privileges. This login is set to the vault-specific
SQL login settings for the new vault.

Choose database

Select the language to use in the vault.Language

Select the format to use when representing
dates in the vault. You can change this
setting later by right-clicking the vault and
selecting Properties.

Date format

Select regional
settings

Do one:

• Select Use the default 'admin' password for this
archive server.

The Admin user password defined during the archive server
installation is used for the vault's admin user.

• Clear the option to enter and confirm a password.

This login is set to the vault-specific admin login settings
for the new vault.

Create the admin
user
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ActionScreen

Do one:

• Use a configuration based on an administrative export
file (*.cex)

Browse to a .cex file containing the settings to use for the
vault, for example vault settings you have exported from
another vault.

• Use a standard configuration

Select one:

Creates a data folder with no files, which
makes it easier to import or create data cards,
workflows, and so on.

Empty

Installs the data set installed with previous
versions of Enterprise PDM.

Default

Installs a simple data set, including predefined
groups and permissions, which enable
companies installing Enterprise PDM for the
first time to quickly use the software in a
production environment.

Quick
Start

Configure vault
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ActionScreen

Select configuration
details
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ActionScreen

Your choice on the Configure vault screen determines what
is displayed on this screen.

• If you chose to use a configuration based on an
administrative export file, this screen does not display.

• If you chose the Default option, the following options are
available. Click an option name to display a description.

Add-ins • Dispatch

The SWTaskAddin is added to the vault
if you select Convert and Print under
Task Execution.

Bills of
Materials

• Standard Bill of Materials
• Weldment Bill of Materials
• Weldment Cut List

File and folder data cardsCards

• Adobe Acrobat
• AutoCAD
• Autodesk Inventor
• Bitmap Images
• CAL
• Default Folder Card
• Microsoft Office
• MP3
• Pro/ENGINEER

Requires a separate Pro/ENGINEER
Connector installation.

• SolidEdge
• SOLIDWORKS
• Text Files
• XML

Items • Support items

Support of items includes the item
search cards.

Displayed to users when they search the
vault

Search
Support
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ActionScreen

• Complete File Search
• User Search

Tasks available with the SWTaskAddin
.dll

• Convert
• Print

Task
Execution
(Server-side
Add-ins)

• If you chose Empty, no data options are installed to the
vault to make it easier to import custom .cex files you have
created.

• If you chose SOLIDWORKS Quick Start, the following
options, designed for an entry-level SOLIDWORKS
implementation, are installed:

Bills of
Materials

• Standard Bill of Materials
• Weldment Bill of Materials
• Weldment Cut List

Cards • Default Folder Card
• SOLIDWORKS

Single card used for all SOLIDWORKS
files.

Displayed to users when they search the
vault

Search
Support

• Complete File Search
• Quick Start Search

Review the vault parameters, then click Finish.Review Information

Click Close.Completed
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Configuring the SolidNetWork License Server for the File
Vault

You can configure the server for the file vault after you install the SolidNetWork License
Manager and activate the license on the server.

You need to configure the license server only once since all Enterprise PDM vaults on
the SQL server use the same SNL server.

1. Open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS Enterprise PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. Create a file vault or expand the existing file vault.
3. Right-click the License node and select Open.
4. On the Server List tab, click Add.
5. Enter the SolidNetWork License Manager's address in the form: port@SNLServerName.

The default port number is 25734. You can enter either the host name or IP address
of SolidNetWork License server for SNLServerName. All clients must be able to
connect to the server by IP address or host name.

6. Click OK.
7. Click the License Usage tab to ensure that Enterprise PDM licenses are available.
8. Click OK.

Creating a File Vault View Using the View Setup Wizard
Users managing files must connect to a file vault through a local file vault view (working
folder) created on each client.

To set up the file vault view, the Enterprise PDM client must be installed.

You also can create a local file vault view using the Enterprise PDM Administration tool.
See the section on creating a local file vault view in the SOLIDWORKS Enterprise PDM
Administration Guide.

To create the file vault view using the View Setup wizard:

1. Run View Setup by doing one of the following:
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• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS Enterprise PDM > View Setup.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click View Setup.

2. Create the file vault view using the following instructions:

ActionScreen

Click Next.Welcome

The available archive servers on the network are listed.

1. If the archive server you want to attach to is listed, select it.
2. If the archive server you want is not shown:

a. Click Add.
b. In the Add Server manually dialog box, type the system
name and click OK.

A login dialog box is displayed if your account does not have
sufficient access rights. Log in with a user account with
attach access to file vaults on the archive server.

c. Select the new archive server.

3. To connect to other archive servers with file vaults, select
them.

4. Click Next.

Select archive
server(s)

All file vaults on the selected archive servers are listed.

1. Select the vaults for which you want to create a local file vault
view.

2. Click Next.

Select vault(s)
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ActionScreen

1. Choose where the file vault view will be created.

You can place the view in any location; however, for a shared
view that is accessible to all profiles on the system, create it
in the root of the local hard drive to make it easily accessible.

2. Select the type of view to create:

The local view is only accessible to the Windows
profile that is currently logged on the system.
Use this option when multiple users are using
the same system; for example, in a terminal
server or Citrix environment. Place the local file
vault view in a user folder that is accessible to
the currently logged-in profile.

For details, see Using Enterprise PDM on a
Terminal Server.

Only for
me

The local view is accessible to all Windows
profiles on this system (preferred). The user
currently logged in must have local administrator
rights to use this option because it requires
updating the local system registry.

For details, see Using a Shared File Vault View
with Multiple User Profiles.

For all
users on
this
computer

3. Click Next.

Select location

Click Finish.Review actions

Click Closed.Completed

Related Topics
Using Enterprise PDM on a Terminal Server on page 80
Using a Shared File Vault View with Multiple User Profiles on page 79

Enabling Broadcast with Windows Firewalls
If you are running Enterprise PDM on a workstation where the Windows firewall is
activated, you must enable broadcast to list archive servers when users create file vault
views using View Setup.

This is because Enterprise PDM uses a broadcast method to get a list of all available
archive servers on the network. This broadcast is sent to the default port 3030 on the
server system from a dynamic port on the client. By default, Windows firewall only allows
a three-second time period to return the broadcast result from the server to the dynamic
client port. After that, the broadcast reply is stopped by the firewall.
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For the archive server broadcast to work correctly on a client with Windows firewall active,
you must allow the applications that request the broadcast through the firewall. For
Enterprise PDM, these are the View Setup wizard (ViewSetup.exe) and the Enterprise
PDM administration tool (ConisioAdmin.exe).

This Microsoft Knowledge Base article describes this issue in detail:

http://support.microsoft.com/?kbid=885345

Enabling Broadcast on Windows 7
If you are running Enterprise PDM on Windows 7 to enable broadcast, you add the
applications to the list of allowed programs.

1. From the Windows Start menu, click Control Panel.
2. On the Adjust your computer’s settings page, click Windows Firewall.
3. In the left pane, click Allow a program or feature through Windows Firewall.
4. On the Allow programs to communicate through Windows Firewall screen, under the

list of allowed programs, click Allow another program.
5. In the Add a Program dialog box, click Browse to locate ViewSetup.exe (found by

default in \Program Files\SOLIDWORKS Enterprise PDM\) and then click Open.
6. Click Add.

The dialog box closes and the program is added to the list of allowed programs and
features.

7. Repeat steps 4 through 6 to add ConisioAdmin.exe, which displays list as
Administration.

8. Click OK to close the Allow programs to communicate through Windows FIrewall
screen.

9. Close the Control Panel.

Using a Shared File Vault Viewwith Multiple User Profiles
A shared file vault view is created by a user with local administrative Windows permissions.
The local administrator group is, by default, given full file permissions to any files created
(or cached) in that view.

On many systems, the local user or power user groups have only limited file permissions
to folders in Windows. If a user with local administrative permissions caches a file in the
shared vault view, other Windows user profiles with only user or power user access
permissions might not have sufficient permissions to fully access the file or change the
read-only state when checking out the file.

If you plan to use a shared file vault view with Windows user or power user profiles, you
should define folder access permissions for those groups.

Changing Access Permissions on a Shared ViewUsing the Properties
Dialog Box

1. Log into the system as a user with local administrative permissions.
2. In Windows Explorer, navigate to the file vault view folder and select it.
3. Right-click the file vault view folder and select Properties.
4. In the file vault view’s Properties dialog box, click the Security tab.
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5. Under Group or user names, select the Windows profile groups to use the shared
file vault view and make sure that they have all access permissions checked (i.e.,
Full Control).

6. Click OK.

Changing Access Permissions on a Shared View Using the Command
Prompt

1. Log into the system as a user with local administrative permissions.
2. Open a command prompt and open the parent folder containing the file vault view

(usually C:\).
3. Use the cacls command to assign sufficient access control to the user and power

user groups.

CACLS “vault_view_name” /E /G “group_or_username”:F

For example, to grant a local users group sufficient access control, type:

CACLS “c:\EPDM File Vault” /E /G “users”:F

Read more about the cacls command at:
http://support.microsoft.com/kb/162786/EN-US/

Using Enterprise PDM on a Terminal Server
Enterprise PDM clients can be installed in a terminal environment, such as Microsoft
Terminal Server or Citrix.

Keep in mind the following differences from installing standalone clients:

• The client software is installed once on the terminal server because all terminal profiles
use the same core system and program files. You cannot combine different client license
types on the same terminal system; the same license type is used by all terminal client
profiles.

• When creating local file vault views for terminal clients, you must be logged in as the
Windows profile that should have access to the view. Make the views private by using
the Only for me attach type or Not available to everyone option.

To make it easier to administer views to multiple terminal client profiles, use the
Enterprise PDM policy or create an administrative view setup file.

Only the Windows profile for which the view was created can log in to the file vault
view because the view information is stored in the current user section of the registry,
which is only available to the current profile.

• To have the private views rooted to the same location for all profiles, place them in
the terminal user’s home folder. For example, use the environment variables
%HOMEDRIVE%%HOMEPATH%. These have the same path for most users.

• You should not create a shared view accessible by everyone on the terminal server in
a terminal environment. If using a shared view, all terminal users will work in the same
local cache, meaning they may overwrite each others file changes.
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Creating a File Vault View Setup File
If you create a view setup file (.cvs), you can attach clients to a file vault by running the
.cvs file, without having to use the View Setup wizard.

The .cvs file can also be launched silently using triggers, as described in Scripting File
Vault View Setup.

You can create a .cvs file from any existing Enterprise PDM client.

To create the .cvs file:

1. Launch View Setup using the trigger /a.
For example, from the Windows Startmenu, click Run and then enter this command:

“C:\Program Files\SOLIDWORKS Enterprise PDM\ViewSetup.exe” /a

2. Step through the View Setup wizard as if creating local views.
See Creating a File Vault View Using the View Setup Wizard. You can select any
number of views.

On the Review Actions screen, the available action is Save to file.

3. Click Finish and specify a location and filename for the view setup file.
4. Click Close.

Related Topics
Scripting File Vault View Setup on page 82
Creating a File Vault View Using the View Setup Wizard on page 76

Using a File Vault View Setup File
You can attach clients to a file vault by running the .cvs file, without having to use the
View Setup wizard.

The .cvs file can also be launched silently using triggers, as described in Scriptiing
File Vault View Setup.

To use the View Setup file:

1. Copy the .cvs file to a client that you want to attach to the file vault.
2. Double-click the .cvs file.

The View Setup wizard opens to the Finish screen, which lists the vaults for which
local views will be created.

3. Click Finish.

Related Topics
Scripting File Vault View Setup on page 82
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Scripting File Vault View Setup
The View Setup wizard can be launched using the ViewSetup.exe command with the
following triggers to automate view installations. This can be useful when you want to
distribute the file vault view using login scripts or a similar distribution method.

ActionOption or Argument

Creates a view setup file./a

Opens the view setup file and lets you attach using the
information from the file.

The complete path to the .cvs file must be used.

path_to_.cvs_file

Performs attach silently without showing wizard. Will only
work in combination with /s switch or a .cvs file.

/q

Find the Vault ID by selecting the properties of the vault
in the Enterprise PDM administration tool.

If you have more than one archive server hosting the
vault, see Distributing File Vault Views in a WAN
Environment.

/s {VaultID}

Examples
• Create a vault view silently from the .cvs file:

ViewSetup.exe PDMWEVault.cvs /q

• Create a .cvs file with the two file vaults supplied by ID:

ViewSetup.exe /s
{A8E07E93-F594-42c9-A01B-F613DBA53CB5}{699C4EC3-60FC-452f-940E-8786A7AAF1B2}
/a

Related Topics
Distributing File Vault Views in a WAN Environment on page 85

Distributing an Enterprise PDM File Vault View Using
Microsoft Windows Active Directory

By using the Enterprise PDM user policy for Microsoft Windows Active Directory, you can
centrally deploy file vault views on client workstations.

Before you configure Active Directory, find the unique vault ID of the vault view you want
to distribute, as described in Finding the Enterprise PDM Vault ID.
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Most policy dialog boxes have an Explain tab with descriptive text about the policy.

To distribute a vault view using Windows Server Active Directory:

1. Open the Control Panel and click System and Security > Administrative Tools
> Active Directory Users and Computers.

2. Create a security group (or use an existing group).
3. Right-click the security group and select Properties.
4. In the security group’s Properties dialog box, on the Members tab, add the users to

which the Enterprise PDM file vault view should be deployed.
5. Right-click the top domain container (or any top organizational unit (OU) containing

the target users) and select Properties.
6. In the domain Properties dialog box, on the Group Policy tab, click New to create a

new policy object.
7. Select the new object and click Properties.
8. In the object’s Properties dialog box, on the Security tab:

a) Add the group containing the users to the list and select it.
b) Under Permissions, in the Allow column, select Apply Group Policy to assign
the policy to the group.

If you do not want the policy to be set on other domain groups, make sure that
the permission is turned off on the other groups.

c) Click OK.

9. In the domain Properties dialog box, select the new object again and click Edit.
10. In the Group Policy Object Editor:

a) Browse to User Configuration > Administrative Templates.
b) Right-click and select Add/Remove Templates.

11. In the Policy Templates dialog box, on the SolidWorks Enterprise PDM DVD, navigate
to \Support\Policies. Select PDMWorks Enterprise.ADM and click Open.

12. When the policy is loaded, click Close.
A new SolidWorks Enterprise PDM Settings option appears under Administrative
Templates > Classic Administrative Templates (ADM).

13. Browse to the View Setup folder and double-click Automatic View Setup.
14. In the Automatic View Setup Properties dialog box:

a) Select Enabled.
b) Click Show to show the views to install.
c) In the Show Contents dialog box, click Add to add the file vault view.
d) In the Add Item dialog box, assign a name for the view to be distributed (preferably
the same name as the file vault).

e) Add the Vault ID to the item value field.
f) Click OK three times.

If you have more than one archive server hosting the vault, see Distributing File
Vault Views in a WAN Environment.
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15. For the new view to be announced when the user logs in, Enterprise PDM must be
started. To automate this, browse to the Login Manager folder and enable the Start
Enterprise PDM Login manager at Windows login policy.

16. Close the Policy Editor.

Related Topics
Finding the Enterprise PDM Vault ID on page 84
Distributing File Vault Views in a WAN Environment on page 85

Finding the Enterprise PDM Vault ID

1. On a client computer, open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, click All Programs > SolidWorks Enterprise PDM >
Administration

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SolidWorks Enterprise PDM, click Administration.

2. Right-click the vault view and click Properties.
3. In the File Vault Properties dialog box, you can copy the vault ID and paste it into a

file.

You can also find the vault ID in the vault database SystemInfo table.

Receiving a Distributed File Vault View
When you distribute a file vault view, users receive automatic notifications.

• When users in the distributed group next log in, the following balloon tip informs them
that a new vault view is available:

Your system administrator has assigned new vaults for you to attach.
Click here to attach them.

Clicking the message box displays the Select Location screen of the View Setup wizard
to let the user select where the view should be placed.

If the user does not click the message box before it disappears, clicking the Enterprise
PDM icon in the system tray shows an Attach option where the distributed views are
available.

• If the automatic view setup policy had the option Setup Views Silent selected, users
see the following message:

Your system administrator has attached you to new vaults.
Click here to browse.

Clicking the message box opens the vault view in Windows Explorer.

For the silent view setup policy to work, the domain user profiles that use the policy
must be part of the Attach access (or administrative access) list in the security section
of the Archive Server Configuration tool. Otherwise, the view must be manually created
using the Attach option.
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Distributing File Vault Views in a WAN Environment
By default, an archive server announces itself over the network to clients using a broadcast
interface (over port 3030). When creating views, this lets the View Setup wizard or
Administration tool list the archive server automatically.

When a script or Active Directory policy distributes a file vault view, the client uses the
first archive server that is announced to it. In some situations such as a replicated
environment with multiple servers, this may not be the correct server.

If you have problems using scripted views or policies over WAN or restricted networks,
add the appropriate server manually using the SOLIDWORKS Enterprise PDM Settings
policy.

Manually Configuring the Archive Server That Is
Announced to Enterprise PDM Clients

1. Open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS Enterprise PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. Under Local Settings, click Group Policies.
3. In the Group Policy dialog box, click User Configuration > Administrative

Templates > SOLIDWORKS Enterprise PDM Settings.
4. Disable the normal broadcast for the SOLIDWORKS Enterprise PDM policy:

a) In the right pane, double-click Disable broadcast.
b) In the Disable Broadcast Properties dialog box, select Disabled, and click OK.

5. Add the archive server that clients should connect to:
a) Click View Setup.
b) Double-click Configure Select Server Page.
c) In the Configure Select Server Page Properties dialog box, select Enabled.
d) Click Show to show the default servers.
e) In the Show Contents dialog box, click Add to add the server.
f) In the Add Item dialog box, type the archive server name and port, normally 3030.
g) Click OK to close each dialog box.

When file vault views are distributed, clients are forced to use the specified archive server.

Specifying SolidWorks Enterprise PDM Settings Group
Policy Manually
You can use Windows Active Directory policy options to distribute the Enterprise PDM
settings. If you are not using Active Directory to distribute group policies, you can add
the SolidWorks Enterprise PDM Settings policy manually on a client as a local group policy.

For details about using Active Directory to distribute Enterprise PDM settings, see
Distributing an Enterprise PDM File Vault View Using Microsoft Windows Active Directory.
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To add the policy manually:

1. Open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SolidWorks Enterprise PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SolidWorks Enterprise PDM, click Administration.

2. Select Local settings.
3. Right-click Group policies and click Open.
4. In the Group Policy dialog box, select User Configuration.
5. Right-click Administrative Templates and select Add/Remove Templates.
6. In the Add/Remove Templates dialog box, click Add.
7. In the Policy Templates dialog box, browse to the PDMWorks Enterprise.ADM policy

template on the SolidWorks Enterprise PDM DVD under \Support\Policies and click
Open.

8. Click Close.

The SolidWorks Enterprise PDM Settings policy options appear under Administrative
Templates > Classic Administrative Templates (ADM).

Related Topics
Distributing an Enterprise PDM File Vault View Using Microsoft Windows Active Directory
on page 82

SOLIDWORKS Enterprise PDM Settings Policy Options

DescriptionPolicy

Settings

Defines the port used for broadcast, by default, port 3030.
This port must match the archive server port. You should not
have to change it.

Configure Broadcast Port

Prevents users from using broadcast to find archive servers
on the local subnet. Only manually added servers will be used.
Use this policy to make sure that a specific archive server is
used.

For details, see Distributing an Enterprise PDM File Vault View
Using Microsoft Windows Active Directory.

Disable Broadcast

Normally, broadcast updates (refreshes) the Explorer file view
when another Enterprise PDM client modifies something in
the view (for example, by renaming or checking out a file).

Use this option to prevent views from being updated
automatically. Users must press F5 to manually refresh the
folder listing in a view.

Disable Automatic View
Refresh
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DescriptionPolicy

Login Manager Settings

If a file vault is replicated, enabling this policy creates a list
in the login dialog box of archive servers hosting the replicated
vault that the user can connect to.

Use this policy if working on a laptop and working in both
locations hosting a replicated vault. Only the servers that are
broadcasted are listed. You might have to include the server
in the Add alternative servers policy.

Enable Alternative Servers

Set this policy when you distribute views with the Automatic
View Setup policy. It starts the Enterprise PDM login
manager at login so that views can be added.

Start Enterprise PDM
Login Manager at
Windows Login

The alternative servers list contains available broadcasted
servers hosting the replicated vault. If the broadcast does
not list the server, you might have to add it manually using
this policy. Add the server name as the Value Name, and
server port as the Value.

Add Alternative Servers

DescriptionPolicy

View Setup settings

Prevents the user from manually adding servers to the list
of vault sources in the View Setup wizard. Use this policy in
combination with Disable Broadcast and Select Server
page to restrict clients to a specified set of servers.

Disable Add Server

Controls the Select Location screen of the View Setup wizard.
It should be defined when adding views silently.

Sets the default file vault attach location. This
can be used in terminal services environments
to force file vault views to be created in a specific
directory (commonly the user's home drive).

Location

Sets the default file vault attach type. A restricted
Windows user does not typically have the right
to add file vault views per computer.

Type

Select Attach Page
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DescriptionPolicy

Controls the Select Archive Server screen of the View Setup
wizard. Adds default archive server names to the list of
servers to choose from in the wizard. Type the name of the
archive server and the port (3030) as value.

Use this in combination with Disable Broadcast and Disable
Add Server to force clients to use a specified set of servers.
You should also use this policy when broadcast prevents
archive servers from being listed in the View Setup wizard
(for example, over a WAN).

Select Server Page

Use this policy to distribute file vault views to client
computers. Add the vault name and vault ID for the views
that should be announced.

When using Setup views silent, the views are added without
any user interaction. When you use this option, to make sure
that the view is created in the correct location, you should
also define the Select Attach Page policy. If the client
computers reside in different subnets and cannot receive
broadcast, you must define the Select Server Page policy.

Automatic View Setup

DescriptionPolicy

Workflow Editor settings

Sets the workflow editor background to white in the Enterprise
PDM administration tool.

Disable Workflow
Background

Explorer settings

Defines the size and color depth of thumbnails that are
created on the archive server.

Configure Thumbnails

Lets you can add other extensions that should behave like
drawings in the BOM view. By default, SLDDRW and IDW files
are counted as drawings.

When you clear the Bill Of Material view option Include
selected, drawing files are normally not considered the
top-node; therefore both drawing and assembly are excluded.

Drawing Extensions

Removes the Copy Tree item from the shortcut menu for
the root of the vault.

Remove Copy Tree From
Root

Configure thread options used when retrieving files to the
client. Use a value between 1 and 20. The default is 5.

Configure Get File

SQL
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DescriptionPolicy

Configures when to use bulk operations when communicating
with the SQL server.

When not doing bulk operations, the statement is built up by
text and concatenated to the execute statement if possible.

For use only when directed by SOLIDWORKS support.

Configure bulk operations

Related Topics
Distributing an Enterprise PDM File Vault View Using Microsoft Windows Active Directory
on page 82
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6
Configuring Content Search

When you index a file vault archive, the search tool can use the content search option to search
a document’s contents or properties.

For example, you can search for all documents containing the word “product” or you can search
for all Microsoft Office documents written by a specific author.

This chapter includes the following topics:

• Content Search Overview
• Recommended Computer Configuration
• Configuring the Index Service on the SQL Server System
• Configuring the Index Service on a Non-SQL Server System
• Adding Index Server Filters
• Managing File Vault Index Catalogs
• Removing a File Vault Index

Content Search Overview
SOLIDWORKS Enterprise PDM content search uses the Microsoft Indexing Service to
create a catalog for each indexed file vault. The catalog contains index information and
stored properties for all versions of all documents in the file vault archive folders.

The Indexing Service periodically scans the file vault archive folders and extracts the
content using filter components. Microsoft Indexing Service supplies filters for Microsoft
Office files, HTML files, MIME messages, and plain-text files. You can install other document
filters for content search in, for example, PDF files.

The indexing process creates a catalog with a master index that stores words and their
locations within a set of indexed documents. Enterprise PDM content search queries the
catalogs for word combinations using the master index as well as word lists and shadow
indexes to execute content searches.

Recommended Computer Configuration
You should set up the Enterprise PDM index server for a file vault on the SQL Server
hosting the file vault database. Hosting the indexing service catalog on another system
can affect content search performance.

The minimum hardware configuration for the indexing service is the same as for the
Enterprise PDM database server. However, the performance of the indexing and search
tool depends on the number and size of documents to be indexed and the resources
available to the indexing service.
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The following table shows the recommended memory configuration for the indexing
service.

Recommended Memory
(in Mb)

MinimumMemory (in Mb)Number of Documents To
Be Indexed

6464Fewer than 100,000

From 64 through 12864From 100,000 through
250,000

From 128 through 25664From 250,000 through
500,000

256 or more128500,000 or more

If the number of documents (and versions) in the file vault is very large, insufficient
memory will seriously affect performance. If performance is slow when the indexing
service is running:

• Tune performance as described in the Windows Indexing Service help.
• Add more memory and increase the amount of memory dedicated to mapping the
property cache.

• Use a faster CPU to improve the performance of indexing and the speed of processing
queries.

The total size of the documents to be indexed affects the disk space required for storing
Indexing Service data. On an NTFS file system, the space required for the catalog is about
15% of the amount of text indexed.

Configuring the Index Service on the SQL Server System
Configuring the Enterprise PDM index service on the SQL Server requires verifying the
Microsoft Indexing Service installation, monitoring and tuning the indexing service, and
then indexing the Enterprise PDM file vault archives.

Verifying Microsoft Indexing Service Installation

By default, the Indexing Service is not installed on a Windows Server 2008-based
computer. For instructions on installing and configuring the Indexing Service on Windows
Server 2008, see http://support.microsoft.com/kb/954822.

1. On the SQL Server hosting the file vault to be indexed, open Control Panel >
Uninstall a program.

2. On the left side of the Uninstall or change a program screen, click Turn Windows
features on or off.

3. In the Windows Features dialog box, verify that Indexing Service is enabled
(checked). If not, select it to install it.
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Monitoring and Tuning the Microsoft Indexing Service

1. In the Start menu, right-click Computer and select Manage.
2. In the Computer Management dialog box, expand Services and Application >

Indexing Service.

Indexing Enterprise PDM File Vault Archives
This procedure describes index server setup when the index server and database server
are installed on the SQL Server hosting the file vault databases.

To install the index server on a separate system, see Configuring the Index Service
on a Non-SQL Server System.

Before indexing the file vault archives:

• Make sure that the database server has been installed and configured.
• Obtain the user name and password of a Enterprise PDM user with Can update index
settings permissions.

• If the index server is located on a system other than the archive server, obtain one of
the following:

• The domain login information of a user with full (read and write) access to the UNC
share to the archive folder.

• The login information of a local Windows user on the index server.

To set up the index server on the SQL Server system:

1. On a client system, open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS Enterprise PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. Log into the file vault to be indexed as an Enterprise PDM user with Can update
index settings permissions.

3. In the left pane, under the file vault, right-click Indexing and select Open.
4. If prompted, log into the archive server as a user with administrative access.
5. In the Index Settings dialog box, to enable content search in this file vault, select

Index File Vault Archives.
6. Under Archive Locations, double-click the archive path.
7. In the Edit File Vault Archive Folder Path dialog box, in the second field, specify the

path to the archive as seen from the system running the Indexing Service. You can
use the Browse button to locate the archive folder.

• If the index server (typically, the SQL Server) is located on the same system as
the archive server, copy the path displayed in the first field and paste it into the
second field.

• If the index server is located on a system other than the archive server, provide a
UNC path to the archive folder.

Type one of the following:
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• The domain login of a user, such as the domain administrator, with full access
to the UNC share

• The username and password of a local Windows user on the index server

8. Click OK and close the Index Settings dialog box.
A new index service catalog for the file vault, named Conisio_vaultID, is created
on the index server. Any file vault archives containing supported file types are indexed
when the indexing service runs, which may be instantly or somewhat delayed.

9. To verify, right-click My Computer and select Manage.
10. In the Computer Management dialog box, expand Services and Application >

Indexing Service and ensure that the Conisio catalog has been created.

Related Topics
Configuring the Index Service on a Non-SQL Server System on page 93

Configuring the Index Service on a Non-SQL Server System
To set up the indexing service, the Enterprise PDM database server and Microsoft SQL
Server must be able to communicate with the system used as the index server.

To use a system other than the SQL Server as the index server, perform these steps
before setting up the indexing for a file vault.

After the service accounts and file vault database have been configured, add the indexing
service and index the file vault archives as described in Indexing Enterprise PDM File
Vault Archives.

Related Topics
Indexing Enterprise PDM File Vault Archives on page 92

Updating the File Vault Database with the Index Server
Name

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, expand Databases > file_vault_database > Tables.
3. Right-click the SystemInfo table (dbo.SystemInfo) and select Open Table.
4. In the right pane, update the IndexServer column with the name of the index server

system.

If the server name includes hyphens (-), enclose the name in double quotes (" ").

If you do not update the SystemInfo table with the correct index server name,
the Microsoft Indexing Service on the SQL server is used as the index server.

5. Save your changes and exit Microsoft SQL Server Management Studio.
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Changing the Database Server Login Account
If the database and archive services and the index server service are running on separate
systems, they must be able to communicate using a service account other than the system
account.

Before changing the database server login account, obtain the login information of a
Windows user with local administrative rights on the database server and the index server.

The user must have the same name, password, and local account privileges on both
systems.

To change the login account for the database server:

1. From the Windows Start menu, click Control Panel > Administrative Tools >
Services.

2. Right-click SOLIDWORKS Enterprise PDMDatabase Server and select Properties.
3. In the SOLIDWORKS Enterprise PDM Database Server Properties dialog box, on the

Log On tab, under Log on as, select This account.
4. Specify a Windows user account, such as a domain administrator, with local

administrative rights on both the system running the database server and the index
server and click OK.

5. Stop and start the SOLIDWORKS Enterprise PDM Database Server service.

If the database server cannot communicate with the index server, you will not be
able to create or remove indexing for the file vault archives. The following error
message may be displayed:

Access is denied.
The SOLIDWORKS Enterprise PDM Database Server failed to contact servername.

Changing the SQL Server Login Account
If the SQL Server service and index server service are running on separate systems and
are not part of the same domain, they must be able to communicate using a service
account other than the system account. If they are in the same domain, this procedure
is not necessary.

Before changing the SQL Server login account, obtain the login information of a Windows
user with local administrative rights on the SQL Server and the index server.

The user must have the same name, password, and local account privileges on both
systems.

To change the login account for the Microsoft SQL Server:

1. From the Windows Start menu, click Control Panel > Administrative Tools >
Services.

2. Scroll down to the SQL Server (MSSQLSERVER), right-click it, and select Properties.
3. In the SQL Server (MSSQLSERVER) Properties dialog box, on the Log On tab, under

Log on as, select This account.
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4. Specify a Windows user account such as a domain administrator, with local
administrative rights on both the system running the Microsoft SQL Server and the
index server and click OK.

5. Stop and start the MSSQL Service.

If the SQL server cannot communicate with the index server, running a content
search in Enterprise PDM fails and results in the following error message:

A communication link failure occurred when accessing the database
server. The database service might have been restarted or the network
might have gone down. Please try the operation again and contact your
system administrator if the problem persists. “vaultname”

Adding Index Server Filters
By default, the Microsoft Indexing Service supports content indexing for the following file
formats: Microsoft Office files, HTML files, MIME messages, and plain-text files. By installing
index filters on the index server, you can include content search support for many other
file formats.

Compressed Archives (gzip) Filter
To index compressed archives as well as add the Enterprise PDM GZ filter, install the GZ
filter manually or by using the Enterprise PDM Installation wizard.

If older versions in the file vault archive are compressed, only the latest uncompressed
version of a file will be indexed.

Installing the GZ Filter Using the Enterprise PDM InstallationWizard

1. Log in to the system configured for index search with administrator rights.
2. Insert the SOLIDWORKS Enterprise PDM DVD.
3. Double-click \setup\setup.exe.
4. On the Program Maintenance screen, select Modify and click Next.
5. On the Custom Setup screen, specify to install the GZ Filter.

Installing the GZ Filter Manually

1. From the SOLIDWORKS Enterprise PDM DVD, copy the file \Support\Filters\
GZFilter.dll to a local folder on the index server.

2. Open a DOS window and change directory to the location of the filter.
3. Register the file using this command:

regsvr32 GZFilter.dll
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Rescanning the Index Catalog
If the indexing service has already indexed the uncompressed archives, you must launch
a re-scan of the entire index catalog to refresh its content. You can do this from the
indexing node under the catalog directory on the index server.

1. Right-click My Computer and select Manage.
2. In the Computer Management dialog box, expand Services and Applications >

Indexing Service, Conisio_vaultID.
3. Click Directories.
4. In the right pane, right-click the directory and select All Tasks > Rescan (Full).

Microsoft Index Filters
You can download additional index filters (iFilters) from Microsoft to add content search
support for many other file types; for example, PDF, DWF, MSG, StarOffice, ZIP, and
RAR.

You can find the filters at http://gallery.live.com/results.aspx?tag=IFilter&bt=15.

Follow the installation instructions for each filter.

You must launch a re-scan of the whole index catalog to refresh its content with the new
file format support. For details, see Rescanning the Index Catalog on page 96.

Managing File Vault Index Catalogs
There are many ways to configure the behavior of the Microsoft indexing service.

For detailed information, see the Windows Help regarding the index server node and
online at http://support.microsoft.com.

1. Right-click My Computer and select Manage.
2. In the Computer Management dialog box, expand Services and Applications.
3. To check the status of a file vault index, select Indexing Service.

The right pane shows the status of a file vault archive index; for example, how many
files are waiting to be indexed.

4. To stop and start the indexing service, right-click Indexing Service and select to
stop or start the service.

5. To change the frequency an archive is scanned, right-click Indexing Service, and
select All Tasks > Tune Performance.

6. Set the preferred option and click OK.

Removing a File Vault Index
When you remove a file vault index, only the index catalog is removed; no physical file
archives are affected by this operation.

Before removing a file vault index, obtain login information for a user with the following
permissions:

• Administrative access to the archive server
• Enterprise PDM permission to update index settings
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To remove an index for a file vault archive:

1. On a client system, open the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, click
Start > All Programs > SOLIDWORKS Enterprise PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. Log into the file vault from which you want to remove the index.
3. Right-click Indexing and select Open.
4. If prompted, log into the archive server as a user that has administrative access to

the archive server.
5. Clear Index File Vault Archives and click OK.
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7
Backing Up and Restoring File
Vaults

File vault backups should be part of the daily management of SOLIDWORKS Enterprise PDM.
They are also required before you upgrade your Enterprise PDM components.

You can use the SQL Maintenance Wizard to schedule a planned backup.

When backing up the vault, the latest updates in files that are still checked out and modified
on client workstations are not included since they are stored in the local file vault view (cache)
of the client. To ensure that the latest information of all files is always included in a backup,
the files should be checked in.

This chapter includes the following topics:

• Backing Up the File Vault Database
• Backing Up the Enterprise PDM Master Database
• Backing Up the Archive Server Settings
• Backing Up the Archive Files
• Scheduling Database Backups Using a Maintenance Plan
• Restoring a File Vault

Backing Up the File Vault Database
Back up the file vault database hosted on the SQL Server ideally using a professional
backup solution that supports live SQL database backups. You can also perform the backup
using the SQL Management tools that are included with the SQL Server.

1. Open SQL Server Management Studio.
2. Expand the Databases folder.
3. Right-click the database to be backed up, and select Tasks > Back Up.
4. In the Back Up Databases dialog box, under Source:

a) For Backup type, select Full.
b) For Backup component, select Database.

5. Under Destination, click Add.
6. In the Select Backup Destination dialog box, enter a destination path and filename

for the backed up database and click OK.
7. Click OK to start the backup.
8. When the backup completes, click OK.
9. Repeat the backup procedure for any additional file vault databases.
10. Exit SQL Server Management Studio.
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Backing Up the Enterprise PDM Master Database
In addition to the file vault database(s), the Enterprise PDM master database called
ConisioMasterDb must be backed up.

To back up this database, follow the same instructions used for backing up the file vault
database. For details, see Backing Up the File Vault Database.

Related Topics
Backing Up the File Vault Database on page 98

Backing Up the Archive Server Settings
The archive server contains file vault settings such as passwords and defined login types.
It is also the physical location of the Enterprise PDM vault archive files. Backing up the
archive server settings does not back up the archive files.

After backing up the archive server settings, include the backup file in your normal file
backup.

To backup the archive server settings:

1. On the archive server, open the SolidWorks Enterprise PDM Archive Server dialog
box by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SolidWorks Enterprise PDM
> Archive Server Configuration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SolidWorks Enterprise PDM, click Archive Server Configuration.

2. Select Tools > Backup settings.
3. In the Backup Settings dialog box:

a) Select Include all vaults. (preferred setting)
Alternatively, you can select Include selected vaults and specify the file vaults
for which settings will be backed up.

b) Specify or select the Backup location.
The default location is the archive root folder.

c) To schedule an automatic backup, click Schedule and specify the schedule.
d) Type and confirm a password for the backup file.

This password is required to restore settings.

e) Do one of the following:

• To perform the backup immediately, click Launch backup. When a message
confirms the backup, click OK.

• To perform the backup at the scheduled time, click OK.

4. Close the SolidWorks Enterprise PDM Archive Server dialog box.

The backup file is saved in the specified location and called Backup.dat.
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Backing Up the Archive Files
The file vault archives contain the physical files that are stored in a file vault. A file added
to the vault is stored in the archive folder specified by the archive server.

1. Locate the archive folder with the same name as the file vault.
This folder is stored under the defined root folder path on the archive server. For
details, see Installing SOLIDWORKS Enterprise PDM Archive Server.

If you are uncertain where the file vault archives are stored, view the registry key
HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks Enterprise\
ArchiveServer\Vaults\vaultname\ArchiveTable.

2. Use a backup application such as Backup Exec to back up this folder and its contents.

Related Topics
Installing SOLIDWORKS Enterprise PDM Archive Server on page 40

Scheduling Database Backups Using a Maintenance Plan
To set up a recurring automatic backup of the file vault SQL databases, you can use the
SQL Server Management Studio maintenance plans.

A maintenance plan lets you create complete backups of the databases, which you can
include in your normal file backup routine.

Before scheduling database backups:

• The SSIS (Integration Services) must be installed on the SQL Server. The Integration
Services are normally included as part of the Workstation Components step in the SQL
Server install wizard.

For more information, see:

http://support.microsoft.com/kb/913967

• The SQL Server Agent must be running.

Install SQL Server 2005 SP2 or higher if you have trouble setting up or using the
maintenance plans.

Starting the SQL Server Agent
If the SQL Server Agent is not running, you could see a message that the ‘Agent XPs’
component is turned off as part of the security configuration of your computer.

1. Open the SQL Server Configuration Manager.
2. In the left pane, select SQL Server Services.
3. If the state of SQL Server Agent is Stopped, right-click it and select Start.

Ensure that the Start Mode of the agent is set to Automatic. If it is not, right-click
the agent and select Properties, then configure the Start Mode on the Services
tab.

4. Exit the SQL Server Configuration Manager.

100

Backing Up and Restoring File Vaults

http://support.microsoft.com/kb/913967


Setting Up a Maintenance Plan for Database Backup
The easiest way to set up a backup maintenance plan is using the SQL Maintenance
wizard.

When the backup maintenance plan is run, the file vault databases are backed up and
placed in a folder you specify. Include the backup folder in your normal daily backup
procedure.

To set up a backup maintenance plan:

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, under the SQL Server, expand Management.
3. Right-click Maintenance Plans and select Maintenance Plan Wizard.

ActionScreen

Click Next.SQL Server Maintenance Plan
Wizard

1. Enter a name and description for the maintenance
plan.

2. Click Change to set up a schedule.

In the Job Schedule Properties dialog box, specify
a name for the schedule and choose the recurring
times to run the database backups. Set the times
close to the start time of the normal daily file
backups. The backup of a database to a hard drive
usually completes within minutes.

3. Click OK.
4. Click Next.

Select Plan Properties

1. Select Back Up Database (Full).

If you rely on daily backups, you can select
Back Up Database (Differential) as well. You
should create at least one full backup set each
week.

2. Click Next.

Select Maintenance Tasks

1. Ensure that the backup task is listed.
2. Click Next.

Select Maintenance Task Order
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ActionScreen

1. Expand the Databases list.
2. Select All user databases.

This selects all Enterprise PDM databases and
excludes the SQL system databases, which are
not required by Enterprise PDM.

To select databases individually, select These
databases and make your selections. Be sure
to select the file vault database(s) and the
ConisioMasterDb database.

3. Click OK.
4. Select Backup set will expire and define how
many days the existing backup set files should be
kept.

5. Select Back up to Disk.
6. Select Create a backup file for every database.
7. For Folder, enter a local path on the SQL Server
to an existing folder where the backup files should
be created.

8. Click Next.

Define Back Up Database
(Full) Task

1. For backup task report, select Write a report to
a text file or E-mail report, and specify where
it should be saved or sent.

2. Click Next.

Select Report Options

Click Finish.Complete the Wizard

When all tasks have been completed, click Close.Maintenance Plan Wizard
Progress

4. Exit Microsoft SQL Server Management Studio.
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Restoring a File Vault
Restoring a file vault requires recent backups of the file vault databases, ConisioMasterDb
database, archive server configuration settings, and file vault archive files.

Restoring the SQL Server File Vault Databases

1. Install the SQL Server:
a) Configure the SQL login type to mixed mode.
b) Select to install the management tools.
For details, see Installing and Configuring SQL Server.

2. Apply the latest SQL service pack.
3. Restore the SQL database backup files to a temporary folder on the SQL Server.
4. Open Microsoft SQL Server Management Studio and click Connect.
5. In the left pane, right-click Databases and select Restore Database.
6. In the Restore Database dialog box, in the To database field, enter the name of the

file vault database exactly as it was named when backed up.
7. Under Source for restore, select From device and click the Browse button.
8. In the Specify Backup dialog box, click Add.
9. In the Locate Backup File dialog box, select the database backup file and click OK

twice to return to the Restore Database dialog box.
10. Under Select the backup sets to restore, click Restore for the database to restore.
11. In the left pane, select Options.
12. In the right pane, verify that the paths to the database files are correct.

SQL defaults to the paths used when backing up the database.

13. Click OK to start the restore.
14. Repeat this procedure for additional file vault databases, including the

ConisioMasterDb database.
15. Exit Microsoft SQL Server Management Studio.

Related Topics
Installing and Configuring SQL Server on page 17

Verifying the ConisioMasterDb Restore
After you restore the ConisioMasterDb database, ensure that information in the
VaultName and DatabaseName columns of the FileVaults table is correct. If either
entry is missing, notifications cannot be processed.

1. Open Microsoft SQL Server Management Studio and click Connect.
2. Expand Databases > ConisioMasterDb > Tables > dbo.FileVaults.
3. Click Columns, and verify the VaultName and DatabaseName.
4. Exit Microsoft SQL Server Management Studio.
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Restoring the Archive Server and File Vault Archives
Use this procedure to restore the archive server setting to the previous settings, including
all login settings and user information.

1. On the new archive server, restore the physical vault archives from the backup (folders
0-F) to the same location as before the backup.

2. Install the archive server.
Use the settings you used in the original install. If unsure, use the default options.
Define the root folder path as you defined it originally.

3. Restore the archive server configuration settings backup file Backup.dat to the archive
root folder.

4. Open the SOLIDWORKS Enterprise PDM Archive Server dialog box by doing one of
the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Archive Server Configuration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Archive Server Configuration.

5. Select Tools > Backup settings.
6. In the Backup Settings dialog box, click Load Backup.
7. Locate the archive server settings backup file Backup.dat and click Open.
8. In the Enter Password dialog box, type the backup file password.
9. When the settings are restored, click OK.
10. Close the SOLIDWORKS Enterprise PDM Archive Server dialog box.
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8
Upgrading Enterprise PDM

You upgrade using the Enterprise PDM installation wizard. The wizard automatically uninstalls
any old software components found and then installs the new software.

Follow these instructions when upgrading from a previous Conisio, PDMWorks Enterprise, or
SOLIDWORKS Enterprise PDM version or service pack.

To find out which version is currently installed, see Determining the Current Version on
page 106.

This chapter includes the following topics:

• About Enterprise PDM Upgrade
• Upgrading the Archive Server
• Upgrading the Database Server
• Installing or Upgrading the SolidNetWork License Manager
• Upgrading File Vaults
• Upgrading Toolbox in Enterprise PDM

About Enterprise PDM Upgrade

Upgrading from Versions Older than Conisio 6.2
The earliest Conisio version supported by the Enterprise PDM Upgrade Wizard is Conisio
6.2. If you are running Conisio 6.1 or earlier and want to upgrade to SOLIDWORKS
Enterprise PDM, you must first upgrade the file vault database and archives to Conisio
6.2 format or later. Follow the instructions included with that version.

For details, see Determining the Current Version.

Upgrading the Enterprise PDM Web Server

To upgrade Enterprise PDM Web Server components from Conisio version 5.3 or older to
Enterprise PDM Web Server, uninstall the older Web server using Uninstall a program,
and follow the installation instructions in the SOLIDWORKS Enterprise PDM Web Server
Guide. For newer versions, follow the standard upgrade procedures.

Client Licenses
A database upgrade to a new major version resets the license count to 0 users. After the
upgrade, you must install a valid license for multiple users to log in.

When upgrading from an older service pack, for example Enterprise PDM 2012 SP1 to
Enterprise PDM 2012 SP2, your existing license code is still valid.
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Visual Basic 6 Add-ins
Visual Basic 6 is not supported in SOLIDWORKS Enterprise PDM 2009 or later. All add-ins
must be written as multi-threaded (using, for example, the Visual Studio .Net
environment).

Before Upgrading
Perform these tasks before upgrading Enterprise PDM.

• Request a new license file from the SOLIDWORKS customer center or your reseller.
• Check in all files.
• Back up:

• SQL Server file vault database
• Complete file vault archive
• Archive server settings

• Make sure that no users are working in the old file vault. On all clients, users should
close all tools started using the file vault, click the Enterprise PDM icon on the right
side of the task bar, and choose Log Off and Exit.

• Remove Visual Basic 6 compiled add-ins from the file vault.

Related Topics
Scheduling Database Backups Using a Maintenance Plan on page 100
Backing Up the Archive Files on page 100
Backing Up the Archive Server Settings on page 99
Removing Visual Basic 6 Add-ins on page 107

Determining the Current Version
You can find out the current version of Conisio or Enterprise PDM software and the file
vault database.

1. Open Windows Control Panel.
2. Double-click Uninstall a program.
3. On the Uninstall or change a program screen, locate Conisio or SOLIDWORKS

Enterprise PDM.
The Version column shows the currently installed version.

If the Version column is not shown, right-click the column headings and select
Version.

You can also determine the current version by opening the SOLIDWORKS Enterprise
PDM Administration tool and clicking Help > About.

The version numbers correspond to the following installed versions:

Installed Product VersionPublisher Version Number

Conisio 6.26.02.0042

Conisio 6.36.03.0095
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Installed Product VersionPublisher Version Number

Conisio 6.46.04.0022

PDMWorks Enterprise 20066.05.0016

PDMWorks Enterprise 2007 32-bit Edition7.00.0027 through 7.05.0074

PDMWorks Enterprise 2007 64-bit Edition7.07.0032 through 7.09.0042

PDMWorks Enterprise 20088.00.0090 through 8.04.0185

SOLIDWORKS Enterprise PDM 20099.00.0723 through 9.05.1225

SOLIDWORKS Enterprise PDM 201010.00.0523 through 10.05.1077

SOLIDWORKS Enterprise PDM 201111.00.0509 through 11.05.1015

SOLIDWORKS Enterprise PDM 201212.00.0408 through 12.05.0916

SOLIDWORKS Enterprise PDM 201313.00.0511 through 13.05.1011

SOLIDWORKS Enterprise PDM 201414.00.0506 through 14.05.1017

Determining Which Updates Have Been Applied

1. Start the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. In the left pane, right-click on the file vault name and select Properties.
3. In the File Vault Properties dialog box, check the Installed Updates list.

This list shows the update product, version, and upgrade date.

Removing Visual Basic 6 Add-ins
If an upgraded file vault contains add-ins created in Visual Basic 6, an error is generated
when a client browses into the upgraded file vault view.

To remove Visual Basic 6 compiled add-ins:

1. Start the Administration tool by doing one of the following:
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• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. In the left pane, select the file vault and log in as Admin.
3. Expand Add-ins.
4. Right-click the add-in created using Visual Basic 6 and click Remove.

Upgrading the Archive Server
If both the archive server and database server software are installed on the same system,
you can upgrade or install both components at the same time.

All settings from the previous installation of the archive server are retained.

1. Log in locally or remotely as a user with local administrative rights on the system
where the archive server is installed.

2. Insert the SOLIDWORKS Enterprise PDM DVD.

You can also start the install wizard manually by running \setup\setup.exe from
the CD; however, this bypasses the initial screen. Do not try to update the archive
server using the \Upgrade\Upgrade.exe file; this file should only be used when
performing a database upgrade.

3. On the SOLIDWORKS Enterprise PDM installation screen, click Upgrade.
A warning is displayed stating that older versions of the Enterprise PDM software
have been found and will be upgraded.

4. Click OK.
5. Follow the install wizard steps by clicking Next at each screen.
6. On the Setup Type screen, select Server Installation and click Next.

If you are upgrading multiple Enterprise PDM components on the same system,
select Custom.

7. On the Server Installation screen, ensure that the Archive Server is selected and
click Next.

If the database server is installed on the same system, you can also select it.

8. When the upgrade is complete, click Finish.

Upgrading the Database Server
If you upgraded the database server while upgrading the archive server, skip to Upgrading
the File Vault Database on page 111.

Before upgrading the database server, obtain the following:
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• Login information for a user with local administrative rights
• SQL Server name
• Name and password of an SQL user account with read/write access to all Enterprise
PDM databases hosted on the SQL Server

If you do not know the name of a user with read and write access, you can use the
SQL sa account that has these permissions. You can also create a login for this
purpose. For details, see Changing the SQL Server Login Account Used by Enterprise
PDM.

To upgrade the database server:

1. Log in locally or remotely to the SQL Server where the vault database is hosted.
2. Insert the SOLIDWORKS Enterprise PDM DVD.
3. On the SOLIDWORKS Enterprise PDM installation screen, click Upgrade.

A message states that an older version of the Enterprise PDM server software has
been found and will be upgraded.

4. Click OK.
5. Follow the install wizard steps by clicking Next at each screen.

ActionScreen

Select Server Installation and click Next.

To upgrade multiple Enterprise PDM
components on the same system, select
Custom.

Setup Type

Select Database Server and click Next.Server Installation
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ActionScreen

1. Do one of the following:

• Type the name of the SQL Server to host
the file vault databases the database server
will manage.

• Click Browse to display a list of available
SQL servers and instances on the network.

Select the appropriate name and click OK.

2. In the Login name field, type the name of
an SQL user on the server who has read and
write access (i.e., db_owner permission) to
all Enterprise PDM databases hosted on the
SQL Server (the file vault databases and
ConisioMasterDb.)

Use the sa login if unsure.

3. In the Password field, type the SQL user’s
password.

4. Click Next.

The login information is verified. If it is incorrect,
a warning is displayed.

SOLIDWORKS Enterprise PDM
Database Server SQL Login

Click Install.Ready to Install the Program

Click Finish.InstallShield Wizard Completed

Related Topics
Changing the SQL Server Login Account Used by Enterprise PDM on page 33

Installing or Upgrading the SolidNetWork License Manager
If you upgrade SOLIDWORKS Enterprise PDM, you need to install or upgrade the
SolidNetWork License Manager.

To install or upgrade the SolidNetWork License Manager:

1. Upgrade the SOLIDWORKS Enterprise PDM archive server.
2. Upgrade the database server.
3. Upgrade the SolidNetWork License Manager.

For more information, see Upgrading the SolidNetWork License Manager on
page 52.
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Upgrading File Vaults
To upgrade file vaults, you first upgrade the file vault database and then the file vault
archives.

Upgrading the File Vault Database
You can run the Enterprise PDM Database Upgrade Wizard on the archive or database
server, or from a system running Enterprise PDM client. However, all installed Enterprise
PDM software on the system must match the upgrade wizard version. You cannot run the
upgrade wizard on a client or server system that is still using an older version of the
software. The database upgrade process may take some time to finish, depending on the
database size and version.

Before upgrading the file vault database:

• Obtain a license file for the Enterprise PDM version to which you are upgrading.
• Make sure that no users are working in the vault.
• Back up the file vault database.

For details, see Backing Up the File Vault Database on page 98.

• Install or upgrade the archive server software.

For details, see Upgrading the Archive Server on page 108.

• Install or upgrade the database server software.

For details, see Upgrading the Database Server on page 108.

Do not uninstall old clients until the database upgrade has been completed.

To upgrade the file vault database:

1. Insert the SOLIDWORKS Enterprise PDM DVD.
2. On the SOLIDWORKS Enterprise PDM installation screen, select How to upgrade

from a previous SOLIDWORKS Enterprise PDM version.
A summary upgrade procedure is displayed

3. After Step 4 of the upgrade procedure, click Upgrade Database to start the database
upgrade wizard.

Note You can also start the upgrade wizard manually from the Upgrade folder on
the install CD by running Upgrade.exe.

4. When a message box warns that the database and file vault upgrade wizard should
only be run by administrators, click Yes.

5. Complete the steps of the Enterprise PDM Database Update Wizard.

ActionScreen

Verify that you have performed all of the upgrade prerequisites,
and click Next.

Step 1
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ActionScreen

1. From the server list, select the SQL Server hosting the file
vault database you want to upgrade.

If the server is not listed, you can type the name of the SQL
system.

2. Click Next.
3. In the login dialog box, type the user name and password of
an SQL user with sysadmin permissions, such as sa, and click
Login.

Step 2

Select the file vault database(s) to upgrade and click Next.Step 3

Click Next to begin the upgrade process.

Do not close the upgrade wizard or turn off the SQL Server
until the upgrade is completed.

Step 4

When the file vault database upgrade finishes, a log is displayed
with the actions and results of the upgrade.

To keep a copy of the upgrade log, select and copy the results
and paste them to a text file.

Click Finish.

Step 5

6. You should reboot the Microsoft SQL Server after the databases have been upgraded.
If you do not, you may experience performance drops until you reboot the server.

After Upgrading File Vault Databases
SOLIDWORKS Enterprise PDM 2009 SP02 or later includes functionality to create and
manage items. If you install this version and then upgrade a vault database from a
previous installation, the upgraded database will not include the default item cards, item
BOM, or the serial number that is used to generate item numbers.

To work with items in this vault, use the Enterprise PDM Administration tool to import
the following cards and serial number:

• all(Item Card)_gb.crd
• all(Item Search Property)_gb.crd
• all(Item Search Simple)_gb.crd
• all(Item Search)_gb.crd
• all_Item Setup_languagecode.cex, where languagecode is the code for your
language

Importing Item Cards

1. Start the Administration tool by doing one of the following:
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• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. Right-click Cards and click Open.
3. In the Card Editor, click File > Import.
4. In the Open dialog box, for Look in, navigate to install_dir\Default Cards.
5. In the card list, select all(item Card)_gb.crd, and click Open.
6. Click File > Save to save the card to the vault.
7. Repeat Steps 3 through 6 to import the rest of the item data cards.

Importing the Serial Number and Item BOM

1. Right-click the upgraded vault and select Import.
2. In the Open dialog box, for Look in, navigate to install_dir\Default Data.
3. In the file list, select all_Item Setup_language.cex, and click Open.
4. In the confirmation message, click OK.

Upgrading File Vault Archives
After you upgrade the file vault database, you can upgrade the file vault archives using
the Enterprise PDM administration tool, which is only available on client installations.

Upgrading file vault archives consists of these tasks:

• Upgrading or installing an initial Enterprise PDM client on the computer where you will
upgrade the file vault archives.

You will upgrade other clients after the file vault archives are updated.

• Upgrading the file vault archive using the Enterprise PDM administration tool on the
initial client computer.

• Upgrading the remaining Enterprise PDM clients.

The vault archive upgrade process can take several hours to complete depending on the
number of files and size of the archive. During the upgrade, users cannot work in the file
vault.

Before upgrading the file vault archives:

• Back up the entire file vault archive. (For details, see Backing Up and Restoring File
Vaults.)

• Make sure no users are logged on to Enterprise PDM.
• Obtain the login credentials of:

• A Windows user account with administrative access to the archive server
• An Enterprise PDM account with file vault management permission

Related Topics
Backing Up and Restoring File Vaults on page 98
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Upgrading the Initial Enterprise PDM Client

1. Log in to a client workstation as a user with local administrative rights.
2. Insert the SOLIDWORKS Enterprise PDM DVD.
3. On the SOLIDWORKS Enterprise PDM installation screen:

• If an older version of Enterprise PDM client is installed, click Upgrade.

At the message that the current client software will be upgraded, click OK.

• If Enterprise PDM client is not installed, click Install.

4. Follow the install wizard steps by clicking Next in each screen.
5. On the Setup Type screen, choose one of the following:

• To upgrade or install the client without Item Explorer, select Client Installation
and click Next.

• To include the Item Explorer:

1. Select Custom.
2. On the Custom Setup screen, under Client, click Item Explorer and select
This feature will be installed on local hard drive.

3. Click Next.

If you are upgrading multiple Enterprise PDM components on the same system,
select Custom.

6. Follow the installation wizard as you would if you were installing a new client.
For details, see Installing Clients Using the Installation Wizard.

On the Choose Product Type screen, select the correct product for your client license
type.

Related Topics
Installing Clients Using the Installation Wizard on page 61

Upgrading the File Vault Archives

1. Start the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SolidWorks Enterprise PDM
> Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SolidWorks Enterprise PDM, click Administration.

2. If the archive server hosting the upgraded file vault is not shown in the left pane:
a) Select File > Add Server.
b) In the Add Server dialog box, select or type the name of the archive server, specify
the port, and click OK.

c) Log in to the archive server using a Windows user account with administrative
access to the archive server.
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3. Expand the archive server in the left pane. File vault archives that require upgrading
are listed under the archive server with a red icon .

• If the icon is not shown, refresh the view by right-clicking the archive server name
and selecting Refresh.

• If the icon is still not shown after refreshing, the file vault archive is up to date
and no upgrade is required.

4. Right-click the archive name and click Upgrade.
If you are prompted to log in, enter a Enterprise PDM username and password for a
user with file vault management permission (usually Admin).
Two messages are displayed:

• The first warns that the upgrade can take a long time and that no users should be
logged in.

• The second states that a backup of the archive server should exist.

If you have met these prerequisites, click Yes for both.

During the archive upgrade, the Work Monitor window displays a progress bar. Do
not abort the process until the word “Completed!” appears.

If you have multiple file vault archives to upgrade, you can start the upgrade on
those also. They are added to the Work Monitor.

When the upgrade finishes, you can view a log of the upgrade results by clicking
Show Log.

5. Close the Work Monitor.
6. To verify that the upgrade was successful, log in to the file vault view and try to

retrieve a file.

Upgrading a Replicated File Vault Archive
Upgrading file vault archives replicated on other servers requires additional configuration
processes.

When upgrading archive servers hosting a replicated file vault, file vaults that require
upgrading are listed with a red icon .

If the icon is not shown, refresh the view by right-clicking the archive server name and
selecting Refresh. If the icon is still now shown, no upgrade is required.

If the icon is shown:

• You must upgrade the archive server software on all servers hosting the replicated
vault. The selected archive will still be upgraded and you will have to launch the archive
upgrade for the replicated servers separately once the software is upgraded.

• If the archive server software is upgraded on all replicated archive servers and they
show up in the administration tree, the replicated file vault archive will be upgraded
on all servers simultaneously.

• If the vault is replicated and the replicated archive servers are not listed in the
administration tree, a dialog is shown where you can select to attach to the replicated
server. If you opt not to connect, only the selected archive will be upgraded and you
will have to launch the archive upgrade for the replicated servers separately.
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Upgrading the Remaining Clients
When the file vault database and archive have been upgraded, you can upgrade the
remaining clients to Enterprise PDM.

Use the same procedure as when you upgraded the first client. For details, see Upgrading
the Initial Enterprise PDM Client.

Related Topics
Upgrading the Initial Enterprise PDM Client on page 114

After Upgrading Clients
After updating Enterprise PDM clients, complete the post-processing configuration steps.

After upgrading:

• In the Enterprise PDM Administration tool, activate the new license file to allow multiple
users to log in.

• Optionally, update the default Complete search and Users search cards. (You should
do this if upgrading from version 2006 or earlier.)

Upgrading cards removes any changes you have made to them.

• Update add-ins.

Add-ins for SOLIDWORKS Enterprise PDM 2009 and later must be multi-threaded.

• The PDMWorks Enterprise 2007 Dispatch module is single-threaded. Use the Dispatch
modules on the SOLIDWORKS Enterprise PDM DVD, which are compiled as
multi-threaded, to update the Dispatch add-in.

• If the upgraded file vault contains add-ins created in Visual Basic 6, when clients
browse into the upgraded file vault view, they receive error messages that the add-ins
are not multi-threaded.

Remove Visual Basic 6 add-ins and replace them with add-ins that are built as
multi-threaded.

When you perform these tasks on one client, they are distributed to other clients
automatically.

Activating a New License File

1. Start the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. Browse to the file vault in the left pane and log in as Admin.
3. Under the file vault, double-click License.
4. In the Set License dialog box, under License File, type the path to the new license

file or browse to it, and click OK.
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Updating the Default Search Cards

1. In the Enterprise PDM administration tool, under the file vault, expand right-click
Cards and click Open Card Editor.

2. In the Card Editor, select File > Import.
3. Locate and open the Complete search card all(Search Complete)_gb.crd.

By default, this is located in …\Program Files\SOLIDWORKS Enterprise PDM\Default
Cards.

Card are language-specific. Choose the appropriate card for your environment.

4. In the Card Editor dialog box, under Card Properties, assign the users and groups
that may use the search card.

5. To save the search card, select File > Save. Assign a new name or overwrite the
existing card, if needed.

6. Repeat Steps 4 through 7 for the search users card, All(Search Users)_gb.crd.

Updating Add-ins

1. In the Enterprise PDM administration tool, under the file vault, expand Add-ins.
2. To update the Dispatch add-in:

a) Right-click Dispatch and click Remove.
b) Click Yes to confirm that you want to remove the add-in.
c) Right-click Add-ins and click New Add-in.
d) Locate the appropriate Dispatch add-in on the SOLIDWORKS Enterprise PDM DVD
under \Support\Dispatch\.

On a 64-bit operating system, select both Dispatch.dll and Dispatch64.dll.

e) Click Open.

3. In the Properties dialog box, click OK.
4. Repeat Steps 2 and 3 for any other add-ins that are not multi-threaded.

The updated add-ins are distributed automatically to the other clients when they log in.

Upgrading the SOLIDWORKS Task Add-in
To ensure that the latest, updated version of an add-in such as the SOLIDWORKS Task
Add-in is running, you must manually upgrade the add-in.

When you upgrade a file vault to a new service pack or version, existing add-ins are not
automatically updated. This is to prevent updated information in the add-ins from
overwriting your customizations.

For example, you may have customized the tasks controlled by the SOLIDWORKS Task
Add-in. You can continue to use your customized tasks and not upgrade. However, you
will not be able to use new task functionality and may have problems starting tasks and
processing upgraded SOLIDWORKS files.

To allow you to manually upgrade tasks, .cex files containing updates for the
SWTaskAdd-in and the Convert, Design Checker, and Print tasks are copied to the C:\
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Program Files\SOLIDWORKS Enterprise PDM\Default Data\ folder. You import one or
more of these files to update the SWTaskAdd-in and the tasks it supports.

Determining the Current Versions of Enterprise PDM and the
SOLIDWORKS Task Add-in
To ensure that you have the latest updates to the SOLIDWORKS Task Add-in, the
SOLIDWORKS Enterprise PDM version and the SWTaskAddin version should be the same.

1. To determine the Enterprise PDM version, in the SOLIDWORKS Enterprise PDM
Administration tool, click Help > About SOLIDWORKS Enterprise PDM
Administration.
The Client version field shows the version as:

YY.SS.BBBB

where:

• YY is the last two digits of the major version. For example, 12 = 2012.
• SS is the service pack. For example, 03 = SP03.
• BBBB is the build number. For example, 903.

2. To determine the version number of the currently installed SWTaskAddin:
a) In the Windows notification area, right-click the SOLIDWORKS Enterprise PDM icon

and click Task Host Configuration.
b) In the Task Host Configuration dialog box, select the vault for which you want to
verify the SWTaskAddin version.
The Version column displays the version in the following format:

YYYYSSBBBB

where:

• YYYY is the major version.
• SS is the service pack.
• BBBB is the build number.

Performing the SWTaskAddin Upgrade
If the version of SWTaskAddin is earlier than the version of Enterprise PDM, you can
upgrade SWTaskAddin by importing a .cex file.

1. Start the Administration tool by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Administration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Administration.

2. Log in to the vault where you want to upgrade SWTaskAddin as an administrator.
3. Click File > Open.
4. Navigate to C:\Program Files\SOLIDWORKS Enterprise PDM\Default Data\ and

select Convert_GB.cex.
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5. In the dialog box that appears, expand Convert_GB.cex, select SWTaskAddin, and
drag it to the Addins node in the left pane.

6. In the message box, select Yes to update the existing add-in.
7. In the Windows notification area, right-click the SOLIDWORKS Enterprise PDM icon

and click Task Host Configuration to verify that SWTaskAddin has been upgraded.

If the client you just upgraded acts as a task host, exit Enterprise PDM and log in
again before performing the verification.

Upgrading Tasks
After you upgrade the SWTaskAddin, you can import the latest versions of the Convert,
Print, and Design Checker tasks.

This procedure describes how to upgrade the Convert task.

1. In the Administration tool, expand the Tasks node.
2. If any tasks have the default names Convert, Print, or Design Checker, rename

them so that customizations you have made to the tasks are not overwritten.
3. Click File > Open.
4. To upgrade the Convert task, navigate to C:\Program Files\SOLIDWORKS Enterprise

PDM\Default Data\ and select Convert_GB.cex.
5. In the dialog box that appears, under Tasks, select Convert, and drag it to the Tasks

node in the left pane.
6. Make changes to the newly imported task to match the previously used task and

configure any new options as required.
This includes the file paths and name formats, conversions types, which computers
run as a task host, permissions for the task, notifications etc.

7. If the existing task had modifications to the Advanced Scripting options (accessed
from the Output File Details page), make those changes to the new version of the
script.
The Advanced Script is often updated for a new version of Enterprise PDM to make
use of new features in SOLIDWORKS or to add new features to the task. Therefore
you may need to merge the new scripting with your custom scripting.

Add comments to the script to make it easier to understand and easier to transfer
the customization the next time you update.

Retain the default Convert task for reference and for testing if problems arise with a
customized Convert task. Set permissions so that it can only be seen by the Admin
user.

For copies of the default Advanced Scripting Options scripts for several recent
versions of Enterprise PDM and instructions for using them, see the Knowledge
Base solution S-057908.

8. Modify workflow transitions that caused the original task to be executed and select
the updated task as the task to execute.
Save the workflow changes.
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Upgrading Toolbox in Enterprise PDM
If you have integrated SOLIDWORKS Toolbox with Enterprise PDM, when you upgrade
the SOLIDWORKS software, Toolbox is upgraded if parts have been added.

Before you run SOLIDWORKS Installation Manager to start the upgrade, you must prepare
the Toolbox folder.

• On the first computer to perform the upgrade, you must check out the Toolbox database
so that the SOLIDWORKS Installation Manager can write to it. Use Get Latest Version
to download the Toolbox parts to the local cache so that the installer can verify whether
parts need to be updated or added.

• To upgrade additional computers, get the latest versions of the Toolbox files from
Enterprise PDM before running SOLIDWORKS Installation Manager.

To upgrade the first Enterprise PDM computer:

1. In Windows Explorer, log in to the vault as a user with full permissions (check out,
check in, add, delete).

2. Navigate to the Toolbox folder in the vault.
3. Right-click the Toolbox folder and click Get Latest Version to copy all Toolbox files

and the toolbox database to the local cache.

If your archive server is remote, this may take several minutes.

4. For upgrades, you must check out the Toolbox database file:

• From SOLIDWORKS 2014 or earlier, check out: vault_name\Toolbox_folder_name\
lang\your_language\SWBrowser.mdb.

• From later versions of SOLIDWORKS, check out: vault_name\
Toolbox_folder_name\lang\your_language\swbrowser.sldedb.

5. Run the SOLIDWORKS Installation Manager to upgrade the SOLIDWORKS software
(including SOLIDWORKS Toolbox).

6. On the Summary screen, ensure that the Toolbox Options installation location is
the location in the vault.

If it is not, click Change, select Reference or upgrade an existing Toolbox, and
browse to the Toolbox location in the vault.

7. For upgrades from SOLIDWORKS 2014 or earlier, when the upgrade completes, in
Windows Explorer, browse to the folder noted in step 4 and add the Toolbox database
file swbrowser.sldedb to the vault.
You can add other local files that are created in this folder to the vault.

8. For all upgrades, check in the Toolbox folder to add any new or updated files to the
vault so that other users can work with Toolbox.

9. For upgrades to SOLIDWORKS 2012 or later, navigate to your Toolbox folder in the
vault and ensure that the following are present:

• \Toolbox_folder_name\Updates
• \Toolbox_folder_name\ToolboxStandards.xml
• \Toolbox_folder_name\Browser\ToolboxFiles.index

If they are not, contact your Value Added Reseller.
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To upgrade additional computers, before initiating the SOLIDWORKS Enterprise PDM
upgrade, use Get Latest Version to download the vault Toolbox folder to the local cache.

SOLIDWORKS Installation Manager will verify that the Toolbox files are up to date when
you run the installation.
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9
Upgrading SOLIDWORKS Files

This chapter includes the following topics:

• Upgrading SOLIDWORKS Files
• Required Upgrade Utility Software
• System Requirements
• Installing the File Version Upgrade Utility
• Preparing to Upgrade
• Selecting Version Settings
• Performing a Trial File Upgrade
• Running the Upgrade Utility
• Creating and Using Work Instruction Files
• Completing an Interrupted Upgrade
• After Upgrading
• Managing Backup Files

Upgrading SOLIDWORKS Files
The SOLIDWORKS Enterprise PDM File Version Upgrade tool upgrades SOLIDWORKS files
from an earlier version to a later SOLIDWORKS file format.

After you upgrade files, you cannot open them in older SOLIDWORKS versions.

The tool automatically checks out, upgrades, and checks in SOLIDWORKS files that are
stored in Enterprise PDM vaults. File references, revision tags, and workflow states are
kept intact.

The only file formats that are upgraded are .sldprt, .slddrw, and .sldasm. Upgrade
SOLIDWORKS template and block files manually.

Several workstations, each running the upgrade tool, can perform concurrent upgrades
to reduce the upgrade time. The first workstation to run the upgrade tool acts as the
master workstation, which creates the upgrade plan. The plan consists of several work
instruction files, one for each workstation participating in the upgrade process. For more
details, see Creating and Using Work Instruction Files.
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The work instruction files contain tree structures that reflect the parent-child relationships
of the SOLIDWORKS files. Both master and slave workstations can run additional work
instruction files after they finish processing the first one. Although parts and subassemblies
can be shared by other assemblies, each file is only upgraded once.

If an assembly references parts that are not at the latest version, you can choose a
version setting that links the assembly with the latest version of the parts it references.
Alternatively, you can choose a version setting that overwrites the existing version of
referenced files with the latest version of the files. See Selecting Version Settings.

Required Upgrade Utility Software
Use a version of the upgrade software that corresponds to the version of SOLIDWORKS
to which you are upgrading.

Upgrade UtilityEnterprise PDM VersionSOLIDWORKS
Version

From 2008 install disk

From 2009 install disk

PDMWorks Enterprise 2008

SOLIDWORKS Enterprise PDM
2009

SOLIDWORKS 2008

From 2009 install diskSOLIDWORKS Enterprise PDM
2009

SOLIDWORKS 2009

From 2010 install diskSOLIDWORKS Enterprise PDM
2010

SOLIDWORKS 2010
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Upgrade UtilityEnterprise PDM VersionSOLIDWORKS
Version

From 2011 install diskSOLIDWORKS Enterprise PDM
2011

SOLIDWORKS 2011

From 2012 install diskSOLIDWORKS Enterprise PDM
2012

SOLIDWORKS 2012

From 2013 install diskSOLIDWORKS Enterprise PDM
2013

SOLIDWORKS 2013

From 2014 install diskSOLIDWORKS Enterprise PDM
2014

SOLIDWORKS 2014

From 2015 install diskSOLIDWORKS Enterprise PDM
2015

SOLIDWORKS 2015

System Requirements
System requirements depend on the vault database being upgraded. They are affected
by the structure of the database, including the number of files, versions, and references
being converted.

Use powerful workstations. As files are opened and resaved in SOLIDWORKS, it is important
that the workstations used have sufficient resources to handle even the largest assembly
structures. Ideally, use 64-bit workstations with at least 4GB RAM and plenty of free hard
disk space.

Stop any non-essential processes to free up as many resources as possible on the
workstations being used.

The following are specific recommendations:

• Archive server

When the conversion is performed by overwriting existing versions of files, a backup
is created for each overwritten file. The archive server must have disk capacity to store
these backup files.

Before the upgrade begins, a screen message notifies you of the space needed, based
on the files you have selected to upgrade.

• Workstations

All workstations that will be used for the upgrade must have enough RAM to open the
largest assembly to be converted. A minimum of 4 GB RAM is recommended.

SOLIDWORKS recommends a minimum of 6 GB RAM (or more on Windows 7 x64
operating systems).

SOLIDWORKS Enterprise PDM 2015 does not support the File Version Upgrade Tool
on 32-bit operating systems.
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Installing the File Version Upgrade Utility
The File Version Upgrade Utility is provided on the SOLIDWORKS Enterprise PDM
installation media in the \Support\File Version Upgrade\ directory.

To install the File Version Upgrade Utility:

1. Navigate to the \Support\File Version Upgrade Utility\ on the Installation
media.

2. Double-click File Version Upgrade.exe.
3. In the Welcome screen, click Next.
4. Accept the license agreement and click Next.
5. Click Install.
6. Click Finish.

Preparing to Upgrade
Prepare the workstations involved in the upgrade before you begin the upgrade process.

Perform a complete vault backup, including:

• File vault database
• Archive files

On the master and slave workstations that are participating in the upgrade process:

1. Install the same version and revision level of Enterprise PDM client.
2. Create local views of the file vault to be upgraded.
3. Check all files into the vault.
4. Close SolidWorks.

On the master workstation:

1. Give participating clients read/write access to all files in the vault you are upgrading.
2. Create a folder for the work instruction files and share it with full (read/write)
permissions for all participating clients.

Related Topics
Backing Up the File Vault Database on page 98
Backing Up the Archive Files on page 100

Selecting Version Settings
The Version Settings screen lets you specify which versions and revisions of your selected
file type will be upgraded and whether old versions will be overwritten.

Before you perform a full conversion, test the conversion of older files by opening a
sample set in the target version of SOLIDWORKS to check for any conversion errors.

Select Create new version of files if you want only the most recent versions of files to
be upgraded and to preserve the existing versions of the files in the older file format.
New Enterprise PDM versions are created.

Select Overwrite existing versions of files if you want to:
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• Overwrite all versions of files with upgraded files.
• Specify which versions of files to overwrite by selecting one or both of the following:

• Latest version The tool upgrades the latest versions of files plus all files that they
reference.

• Versions with a revision The tool upgrades all files with revision tags.

If you choose to overwrite existing versions, the File Version Upgrade tool creates a
backup of files before upgrading them. You can delete backed up files after confirming
that the upgrade is successful. See Managing Backup Files.

Assemblies that contain cyclic references are not upgraded if you select to overwrite
existing versions of files.

Upgrade Scenarios

The following topics illustrate the possible upgrade scenarios for the set of files below.

version increment

reference
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Creating New Versions of Files
When you create new versions of files, the older versions still exist and can continue to
be opened in the older version of SOLIDWORKS.

Relinking to the Latest Version of Referenced Files
You can relink an assembly to the latest version of the files that it references.

If the assembly and its subassemblies reference versions of parts that are not the latest
version, the references are moved to the latest versions of the parts.

Older versions of the parts, assembly, and subassembly are not upgraded and their
references are not affected.

If the newer versions of referenced files have undergone geometry modifications, using
this option could result in unwanted assembly changes or rebuild errors. In addition,
if file properties such as Part Number, Description, or Material have changed, in the
newer versions, this could cause changes in Bills of Materials.

Selections represented In the diagram below are:

SelectionsOptionScreen

<All SW file types>Files of typeSearch Files to
Upgrade
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SelectionsOptionScreen

Files referencing older versions

• Are re-linked to the new version

Update revisions

• Do not update revision

Create new version
of files

Version Settings

Files before upgradeReference links before
upgrade

Upgraded filesReference links after
upgrade

Moving Existing Revision Tags
You can move the latest revision tag to the latest version of a file you are upgrading.

Selections represented In the diagram below are:

128

Upgrading SOLIDWORKS Files



SelectionsOptionScreen

<All SW file types>Files of typeSearch Files to
Upgrade

Files referencing older versions

• Are excluded

Update revisions

• Move revision

Create new version
of files

Version Settings

Files before upgrade, showing revision that is moved

Upgraded files
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Incrementing Revision Tags
You can increment the revision tags on the latest versions of files as you upgrade the
files.

Selections represented In the diagram below are:

SelectionsOptionScreen

<All SW file types>Files of typeSearch Files to
Upgrade

Files referencing older versions

• Are re-linked to the new version

Update revisions

• Increment revision

Create new version
of files

Version Settings

Files before upgrade, showing revision that
is moved and incremented

Reference links before
upgrade
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Upgraded filesReference links after
upgrade

Overwriting Existing Versions of Files
When you overwrite the existing versions of files, the existing files are replaced with
upgraded files. New versions are not created.

Overwriting the Latest Versions of Files
You can upgrade by overwriting the latest version of all files of the selected file type. Any
version of a file that is used in a reference from an upgraded file is also upgraded.

Overwriting the Latest Versions of All Files

SelectionsOptionScreen

<All SW file types>Files of typeSearch Files to
Upgrade

Overwrite

• Latest version

Overwrite existing
versions of files

Version Settings
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Overwriting the Latest Version of Parts

SelectionsOptionScreen

*.sldprtFiles of typeSearch Files to
Upgrade

Overwrite

• Latest version

Overwrite existing
versions of files

Version Settings

By default, part drawings are not upgraded. However, because drawings are parents
to parts, a Broken reference warning screen lets you select to upgrade the drawings
that reference the parts that are being upgraded.

Overwriting the Latest Version of Assemblies

SelectionsOptionScreen

*.sldasmFiles of typeSearch Files to
Upgrade
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SelectionsOptionScreen

Overwrite

• Latest version

Overwrite existing
versions of files

Version Settings

In a referenced version stream, the File Version Upgrade tool also upgrades the latest

parts, as indicated by the blue boxes.

By default, part and assembly drawings are not upgraded. However, because drawings
are parents to parts and assemblies, a Broken reference warning screen lets you select
to upgrade the drawings that reference parts and assembles that are being upgraded.

Overwriting the Latest Version of Drawings

SelectionsOptionScreen

*.slddrwFiles of typeSearch Files to
Upgrade
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SelectionsOptionScreen

Overwrite

• Latest version

Overwrite existing
versions of files

Version Settings

Overwriting Files with Revision Tags
You can include files with revision tags as files that are upgraded.

These examples show the files that are upgraded when you choose both Latest version
and Version with a revision. Red boxes indicate files that are upgraded because they
have revision tags, even though they are not the latest version.

Overwriting All Files with Revision Tags

SelectionsOptionScreen

<All SW file types>Files of typeSearch Files to
Upgrade

Overwrite

• Latest version
• Version with a revision

Overwrite existing
versions of files

Version Settings
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Overwriting Parts with Revision Tags

SelectionsOptionScreen

*.sldprtFiles of typeSearch Files to
Upgrade

Overwrite

• Latest version
• Version with a revision

Overwrite existing
versions of files

Version Settings
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By default, part drawings are not upgraded. However, because drawings are parents
to parts, a Broken reference warning screen lets you select to upgrade the drawings
that reference the parts that are being upgraded.

Overwriting Assemblies with Revision Tags

SelectionsOptionScreen

*.sldasmFiles of typeSearch Files to
Upgrade

Overwrite

• Latest version
• Version with a revision

Overwrite existing
versions of files

Version Settings
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In a referenced version stream, the File Version Upgrade tool also upgrades the latest

parts, as indicated by the blue boxes.

By default, part and assembly drawings are not upgraded. However, because drawings
are parents to parts and assemblies, a Broken reference warning screen lets you select
to upgrade the drawings that reference parts and assembles that are being upgraded.

Overwriting Drawings with Revision Tags

SelectionsOptionScreen

*.slddrwFiles of typeSearch Files to
Upgrade

Overwrite

• Latest version
• Version with a revision

Overwrite existing
versions of files

Version Settings
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Performing a Trial File Upgrade
Before upgrading the SOLIDWORKS files in a production vault, perform the upgrade on
a copy of the production vault to ensure that there are no upgrade problems. Contact
your value added reseller for help creating a copy of your vault.

1. Restore a complete backup of the file vault to a separate server.
2. Start the File Version Upgrade Utility by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > File Version Upgrade.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click File Version Upgrade.

3. Follow the instructions in the upgrade wizard.
4. Verify that the upgrade is successful.

See After Upgrading.

Running the Upgrade Utility
To run the upgrade utility:

1. Start the File Version Upgrade Utility by doing one of the following:
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• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > File Version Upgrade.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click File Version Upgrade.

2. On the Welcome screen, do one of the following:

• To set up the upgrade, click Initiate a new upgrade process (Master
Workstation).

• To run a work instruction file created for the upgrade, click Participate in an
upgrade process (Slave Workstation).

• To retry an upgrade that was terminated unexpectedly, click Restart an
interrupted upgrade process (Master and Slave Workstation).

3. Follow the instructions in the upgrade wizard.

Creating and Using Work Instruction Files
By creating work instruction files, you can run the upgrade tool concurrently on several
workstations to reduce the upgrade time.

You create the work instruction files on the first workstation that runs the upgrade tool,
which becomes the master workstation.

To create and use work instruction files:

1. Create a shared folder and give each workstation that will participate in the upgrade
Read/Write access.

2. Start the File Version Upgrade Utility by doing one of the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > File Version Upgrade.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click File Version Upgrade.

3. On the Welcome screen, select Initiate a new upgrade process (Master
Workstation) and click Next.

4. Complete the wizard screens.
5. On the Upgrade Settings screen:

a) Under Upgrade Settings, select Divide the upgrade work into multiple work
instruction files.

b) Specify the number of work instruction files to create.
c) For Shared location for work instruction files, type the name of the shared
folder you created in step 1 or click the browse button to navigate to the folder.

The folder name must be in UNC format.

d) Click Next.

6. On the Ready to Upgrade Files screen, do one of the following:

• To upgrade now, click Yes.
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When a completion message appears, click OK.

• To exit the upgrade utility and run work instruction files at a later time, click No.

7. If you selected No in step 6, run the File Version Upgrade tool again to perform the
upgrade using the work instruction files.

8. On the Welcome screen, select Participate in an upgrade process [Slave
Workstation].

9. On the Select Work Instruction File screen:
a) Browse to the location of the work instruction files.
b) Select the work instruction file to process.
c) Click Next.
The Work Instruction File Summary displays with a read-only summary of the
settings specified for the upgrade.

d) Click Next.

10. On the Ready to Upgrade Files screen:
a) Click View Files to see a list of files that will be upgraded.
b) To upgrade the files, click Yes.
c) When a completion message appears, click OK.

Completing an Interrupted Upgrade
Sometimes an upgrade is interrupted unexpectedly, for example, when you lose a network
connection or lose power.

To complete an interrupted upgrade:

1. Click Retry in the error message.
2. In the message indicating that the conversion did not complete successfully, click OK
3. Click Exit.
4. Solve the problem that caused the interruption.

For example, restore the network or restart the computer.

5. Run the Upgrade utility again.
6. On the Welcome screen, select Restart an interrupted upgrade process (Master

and Slave Workstation).
7. On the Continue Interrupted Migration screen, click Next.
8. On the Work Instruction File Summary screen, click Next.
9. On the Ready to Upgrade Files screen, click Finish.

After Upgrading
When the upgrade is complete:

• View the upgrade log files.
• Manually upgrade files that the tool was unable to upgrade automatically.

Manual upgrade creates new versions. If you upgraded using Overwrite
existing versions, manual upgrade will invalidate the reference structure.
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• Optionally, use Get Latest Version to create local copies of files that were converted
on other workstations.

• Open a subset of converted files in SOLIDWORKS to verify that the conversion was
successful.

• If you selected to overwrite existing versions of files, after ensuring that the upgrade
was successful, remove the backup files from the archive server.

Related Topics
Locating and Removing Backup Files

File Name Formats for Upgrade Logs

Files names in upgrade logs take the following formats:

• Files that have been upgraded

Upgrade Utility <id>Batch<n>.log

where:

• <id> is a unique alphanumeric string
• <n> is the number of the batch file for which the log was created

Example: Upgrade Utility 471F2FDS Batch 4.log

• Files that could not be upgraded

Upgrade Utility <id> Batch <n>.logExcluded.log

Example: Upgrade Utility 471F2FDS Batch 4.logExcluded.log

Managing Backup Files
If you choose to overwrite existing versions of files when you upgrade, the upgrade tool
creates a backup file for each overwritten file.

These backup files remain after the upgrade. You can remove them after you verify that
the upgrade succeeded.

Backup File Creation

It is not possible to disable the backup option, so ensure that you have sufficient free
disk space on the archive server before you start the upgrade.

The Ready to Upgrade Files screen gives an estimate of the amount of space that is
needed.

For each file that is overwritten:

1. The upgrade tool retrieves the original version of the file from the file archive folder
to the client system that is running a work instruction file to perform the upgrade.

2. The tool opens the file in SOLIDWORKS, upgrades it, and send it back to the archive
folder when the batch process completes.

3. Before the version is replaced, the original version in the archive is renamed using
the following format:
bak_counter_version.extension
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Where:

• bak is the prefix for all backup files.
• counter is a unique counter in case the existing file with the same backup name
exists from a previous upgrade.

• version is the number, in hexadecimal format, of the file version that is being
replaced.

• extension is the file extension.

4. The upgrade tool places the upgraded version of the file in the archive using the
original file name.

Restoring an Incorrectly Upgraded Version from a Backup
If an upgraded version of a file is incorrect, you can use the backup file to restore the
original content of the file.

1. In the local file vault view, determine the name of the file to find.
2. Open Microsoft SQL Server Management Studio and click Connect.
3. Expand Databases and select the vault containing the file you want to restore.
4. Click New Query.
5. In the right pane, type a query in the following format:

select * from documents
where filename like 'filename.ext'

For example:

select * from documents
where filename like 'speaker_frame.sldprt'

6. Click Execute.
Record the files DocumentID, which is listed in the Results tab.

7. Exit the SQl Server Management Studio.
8. Use a calculator to convert the DocumentID to hexadecimal format.
9. In an Explorer window, navigate to install_dir\Program Files\SOLIDWORKS

Enterprise PDM\Data\vault_name.
10. Expand the vault archive that matches the last digit of the hexadecimal number.

For example, if the hexadecimal number is 3B, expand the folder labeled B.

11. Expand the folder that matches the hexadecimal number.
12. Rename or delete the version of the file you want to restore.

For example, rename 00000002.sldprt to 00000002.backup.

13. Rename the appropriate bak_ file to the original file name.
For example, rename bak_0_00000002.sldprt to 00000002.sldprt.

14. Exit Microsoft SQL Server Management Studio.
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10
Additional Configuration

This chapter includes the following topics:

• Managing the SQL Transaction Log Size
• Configuring Enterprise PDM to Communicate Using IP Addresses Only
• Moving Server Components to Another System

Managing the SQL Transaction Log Size
Each SQL database contains one database file (.mdf) and at least one transaction log file
(.ldf). The database file stores the physical data added to the database, and the
transaction log keeps records of database modifications. The SQL Server uses the
transaction log to maintain database integrity, particularly during recovery.

By default, the recovery method of an SQL database is set to full recovery model, which
means that every change to the database is logged. A large transaction log can grow
until it is out of disk space and causes the performance of the SQL Server to drop.

The full recovery model is preferred to restore to an exact point-in-time, but if you rely
on nightly database backups and want to ensure that the transaction log does not grow
and degrade SQL performance, you should change to the simple recovery model.

To reduce the size of a large transaction log after you change to simple recovery model,
shrink the transaction log.

For more details about changing the recovery model, see the SQL Server books online
and this Microsoft Knowledge Base article:

http://support.microsoft.com/?kbid=873235

Changing to the Simple Recovery Model

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, expand the Databases folder, right-click the database name and

select Properties.
3. In the Database Properties dialog box, in the left pane, select Options.
4. In the Recovery model list, select Simple and click OK.
5. Close Microsoft SQL Server Management Studio.
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Shrinking the Transaction Log

1. Right-click the database name, and select Tasks > Shrink > Files.
2. In the Shrink File dialog box, in the File type list, select Log.
3. Click OK.

Configuring Enterprise PDM to Communicate Using IP
Addresses Only

By default, when setting up a Enterprise PDM environment, clients communicate with
servers using system names. If the DNS lookup is unstable or not sufficient for the network
setup, you can configure Enterprise PDM to use only IP-numbers to communicate.

This setup involves:

1. Updating the archive server
2. Updating the SQL Server
3. Updating the Enterprise PDM clients

When connecting to the archive server, you can remove and re-attach the file vault
view using the archive server IP address instead of updating the registry manually.

Updating the Archive Server to Communicate Using IP
Addresses

1. On the system running the archive server, from the Windows Start menu, click Run
> regedit to open the registry.

2. Find the key for the archive server:
HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Application\PDMWorks
Enterprise\ArchiveServer

3. In the right pane, right-click and select New > String value and name the string
value ServerName.

4. Double-click ServerName.
5. In the Edit string dialog box, in the Value data field, type the IP address of the archive

server and click OK.
6. Find the key for the file vault:

HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
Enterprise\ArchiveServer\Vaults\vaultname

7. Double-click Server, update the Value data field with the IP address to the SQL
Server hosting the vault database, and click OK.

8. Restart the archive server service.
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Updating the SQL Server to Communicate Using IP
Addresses

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, expand Databases, the vault database, and Tables.
3. Right-click dbo.ArchiveServers and select Open Table.
4. Under ArchiveServerName, change the entry to the IP address of the archive server

hosting the vault.
5. Right-click dbo.SystemInfo and select Open Table.
6. Under ArchiveServerName, change the entry to the IP address of the archive server

hosting the vault.
7. Exit Microsoft SQL Server Management Studio.

Updating Enterprise PDM Clients to Communicate Using
IP Addresses

1. If started, exit Enterprise PDM by clicking the Enterprise PDM icon on the right side
of the task bar and selecting Exit. Ensure the administration tool is not running.

2. On the system running the archive server, from the Windows Start menu, click Run
> regedit to open the registry.

3. Find the key for the file vault view:
HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
Enterprise\Databases\vaultname

4. Update the DbServer value with the IP address to the SQL Server hosting the vault
database.

5. Update the ServerLoc value with the IP address to the archive server hosting the
vault archive.

6. If the administration tool was used on the client, delete the following key:
HKEY_CURRENT_USER\Software\SOLIDWORKS\Application\PDMWorks
Enterprise\ConisioAdmin

The key is recreated when starting the administration tool.

Verifying IP Address Communication

1. When all servers and clients are updated, verify that you can:

• Log into the file vault.
• Add a new file.
• Retrieve an existing file.

2. If the vault is replicated, ensure you are using IP addresses in the replication settings
dialog.

3. If you experience problems connecting with the new addresses:

• Check the client and archive server log for errors.
• Ensure that you can ping the servers from the client using the supplied IP addresses.
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Moving Server Components to Another System
Use these procedures when moving Enterprise PDM server components from one system
to another or when changing the name on the server system to verify which database
and registry entries should be updated.

These instructions describe moving both the database and archive server. If you are
moving only one, follow only those instructions that apply.

Before you start, tell users to exit all Enterprise PDM vaults. Users can work off-line
while you are performing the move. After client registry keys are updated, users can
check the work they do off-line into the new vault location.

Copying Files to the New Server

1. On the old SQL Server, backup the file vault database and the ConisioMasterDb.
For details, see Backing Up the File Vault Database.

2. Copy the backup file to the new server.
3. Open the SOLIDWORKS Enterprise PDM Archive Server dialog box by doing one of

the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Archive Server Configuration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Archive Server Configuration.

4. To make a backup of the archive server settings:
a) Select Tools > Backup settings.
For details, see Backing Up the Archive Server Settings.

b) Clear or set a password, and click Launch backup.
c) Close the SOLIDWORKS Enterprise PDM Archive Server dialog box.
d) Copy the backup file (backup.dat) to the new server.

5. Copy the entire file vault archive folder from the old server to the new server,
maintaining the same path.

If you are unsure where the archives are located, check this registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Application\PDMWorks
Enterprise\ArchiveServer\Vaults\vaultname\ArchiveTable

Related Topics
Backing Up the File Vault Database on page 98
Backing Up the Archive Server Settings on page 99
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Configuring the Moved SQL File Vault Database

1. On the new server, install the SQL Server software.
For details, see Installing and Configuring SQL Server.

2. To keep the collation settings the same as the old server:
a) Open the Microsoft SQL Server Management Studio and click Connect.
b) Right-click the server and select Properties.
c) In the Server Properties dialog box, in the right pane, note the Server Collation
setting of the old server.

d) During the new SQL install, select Custom and set the same collation.

3. Restore the backed-up database, keeping the original name.

Stop the old SQL Server service or take the old databases offline so that you do
not have two servers with the same vault database active.

4. In the restored file vault database, update with the new archive server name in tables
ArchiveServers and SystemInfo.

In a replicated environment, the ArchiveServers table contains each replicated
server. Be sure to update only the moved server entry. Do not change the
VaultName entry.

5. To allow indexing of the moved file vault database, created a linked server entry:
a) Open Microsoft SQL Server Management Studio and click Connect.
b) Right-click on the moved file vault database and select New Query.
c) Enter the following command in the query window, then press Execute (F5) to
run the query.
Exec Sys_IndexServerLink 1

If indexing is already set up on the old server, remove and recreate the index
catalog on the new server using the Indexing node in the Administration tool.

6. Exit Microsoft SQL Server Management Studio.

Related Topics
Installing SQL Server 2012 on page 25

Moving the SolidNetWork License Manager
If you need to move your license manager software to another server, you must transfer
activated licenses to the license key server at Dassault Systèmes SOLIDWORKS
Corporation.

To move the SolidNetWork License Manager software:
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1. Transfer the activated license to the license key server.
For more information, see Transferring a SolidNetWork License on page 53.

2. Install the SolidNetwork License Manager on the new server.
3. Reactivate the license.

For more information, see Installing and Configuring SolidNetWork Licensing
on page 49.

Moving the SOLIDWORKS Enterprise PDMDatabase Server
If you move the Enterprise PDM database to a new system, you must move or reinstall
the database server component.

Moving or reinstalling the database server component ensures that the database server
receives updates such as notifications, local view refresh, replication schedule updates,
and index server changes from the Enterprise PDM database.

To move the SOLIDWORKS Enterprise PDM database server:

1. Uninstall the Enterprise PDM database server from the old server.
2. Install the Enterprise PDM database server on the new server.
3. When prompted to specify the SQL server that hosts the file vault databases, specify

the name of the SQL server where you have moved the vault database.
4. To verify the Mail Service configuration:

a) On the new server, expand the Start menu and type regedit in the Search
programs and files field.

b) Under Programs, right-click regedit.exe and click Run as administrator.
c) In the Registry Editor, expand HKEY_LOCAL_MACHINE > SOFTWARE >
SOLIDWORKS > Applications > PDMWorksEnterprise > MailService.

d) Verify the Server value.
The value is:

• Blank if you have installed the Enterprise PDM database server on the same
system as the SQL server and databases are running under the default SQL
instance.

• The SQL server name or instance name if the SQL server is on a different system
or using a named SQL instance.

Configuring the Moved Archive Server

1. Install the archive server on the new server. Use the default settings used on the old
server, if you can remember them.
For details, see Installing SOLIDWORKS Enterprise PDM Archive Server.

2. Open the SOLIDWORKS Enterprise PDM Archive Server dialog box by doing one of
the following:

• On Windows 7 and Windows Server systems prior to Windows Server 2012, from
the Windows Start menu, select All Programs > SOLIDWORKS Enterprise
PDM > Archive Server Configuration.

• On Windows 8 and Windows Server 2012 or later, on the Apps screen, under
SOLIDWORKS Enterprise PDM, click Archive Server Configuration.
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3. Select Tools > Backup settings.
4. In the Backup Settings dialog box, click Load Backup.

The old archive server settings are imported.

5. On the new archive server, from the Windows Start menu, click Run > regedit to
open the registry.

6. Update and verify the following keys, which may differ from the old server settings:

• HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Application\PDMWorks
Enterprise\ArchiveServer\Computers\local\Archives

Ensure that the default value points to the correct root folder (=parent) where the
file vault archive is stored (i.e., the path where the file vault archive folder was
copied to). For example, type:

C:\Program Files\SOLIDWORKS Enterprise PDM\Data

• HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Application\PDMWorks
Enterprise\ArchiveServer\Vaults\vaultname

Ensure that Server value is updated to the new SQL Server name and SQLDbName
matches the restored file vault database name. Do not change the DbName entry.

• HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Application\PDMWorks
Enterprise\ArchiveServer\Vaults\vaultname\ArchiveTable

Make sure all paths point to the file vault archive location where you copied the
files to (from the old server.)

7. Stop the old archive server from running.
Preferably disconnect the old server from the network so that it is not available until
all clients are updated, or stop the archive server and SQL Server service.

Related Topics
Installing SOLIDWORKS Enterprise PDM Archive Server on page 40

Updating Client Registry Keys

1. On each client, update the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Application\PDMWorks
Enterprise\Databases\vaultname

Update the DbServer (database server) and ServerLoc (archive server) with the
new server name.

On 64-bit clients update the DbServer and ServerLoc in this registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SOLIDWORKS\Application\PDMWorks
Enterprise\Databases\vaultname

2. On each client, delete the following registry key:
HKEY_CURRENT_USER\Software\SOLIDWORKS\Application\PDMWorks
Enterprise\ConisioAdmin
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Updating Replication Settings
If you are moving the archive server components in a replicated environment, update
the replication settings to reflect the new archive server name.

1. From an updated client, open the Administration tool and log in to the vault.
2. Right-click Replication Settings and click Open.
3. In the Replication Settings dialog box, under Connections, select the first row.
4. Under Selected connection, for IP address or DNS name, type the new IP address

or name of the moved archive server.
5. Restart the archive server service on each archive server that is replicating the file

vault.

Verifying the Server Move

1. Log in as the Admin user and view the file vault listing.
2. Make sure that the archive server fully works by adding a text file, checking it in, and

deleting it.

If you cannot login to the vault, or add, check out, or modify files, make sure that the
path to the file vault archive folder that you specified in step 5 of Copying Files to the
New Server is correct.

Related Topics
Copying Files to the New Server on page 146
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