INSTALLATION GUIDE
SOLIDWORKS PDM 2021/SOLIDWORKS Manage 2021
SOLIDWORKS PDM and SOLIDWORKS Manage Installation Guide

SOLIDWORKS® PDM and SOLIDWORKS Manage Installation Guide provides installation and configuration instructions for SOLIDWORKS PDM, SOLIDWORKS Manage, SQL Server Express, and SQL Server.

SOLIDWORKS PDM Standard is a new product based on SOLIDWORKS Enterprise PDM. It is included with SOLIDWORKS Professional and SOLIDWORKS Premium.

SOLIDWORKS PDM Professional is the name of the product previously called SOLIDWORKS Enterprise PDM. It is available as a separately purchased product.

<table>
<thead>
<tr>
<th>Installation Overview on page 9</th>
<th>Required and optional installation components, deployment scenarios, and installation summary.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installing and Configuring SQL Server on page 17</td>
<td>SQL Server 2014 installation and upgrade. Includes changing the SQL Server login account.</td>
</tr>
<tr>
<td>Installing and Configuring SQL Server Express</td>
<td>SQL Server 2014 Express installation.</td>
</tr>
</tbody>
</table>

| Installing SOLIDWORKS PDM on page 42 | The installation of SOLIDWORKS PDM database server, archive server, SolidNetWork License Manager, Web server, and SOLIDWORKS PDM clients. Client installation includes creating and deploying admin images, and scripting silent installations. |

| Creating and Distributing File Vault Views on page 93 | Creating file vault views using the View Setup wizard. Includes applying licenses, using shared views, scripting file vault view setup, and distributing file vault views. |

| Configuring Content Search (For SOLIDWORKS PDM Professional only) on page 117 | Configuration of the SOLIDWORKS PDM Professional Index Service. Includes indexing file vault archives, updating the index server name, changing login accounts, and adding index server filters. |

| Upgrading SOLIDWORKS PDM on page 133 | Upgrade of the database, archive, and Web servers, the file vault database and archives, and SOLIDWORKS PDM clients. |

| Backing Up and Restoring File Vaults on page 125 | Backing up the file vault database and SOLIDWORKS PDM Master database, including archive server settings. Includes scheduling database backups and restoring file vaults. |
SOLIDWORKS Manage Professional provides advanced data management tools to SOLIDWORKS PDM Professional. It offers capabilities for advanced version control, and for project, process, and item management. Users must have a SOLIDWORKS PDM Professional license to use SOLIDWORKS Manage.

SOLIDWORKS Manage Professional has a similar architecture as SOLIDWORKS PDM Professional. It uses a client-server architecture, with a Microsoft SQL Server database to manage item and project data. There are three services for database, file server, and web server functions, which support both thick clients and web browser clients. The three services can be hosted on the same server or separate servers. Users with SOLIDWORKS Manage Professional Editor licenses can use a SOLIDWORKS Manage Add-in to access Manage data directly from within SOLIDWORKS.

**Installation requirements and installation processes of SOLIDWORKS Manage Server and Client.**

**Configuring and logging into SOLIDWORKS Manage.**

**Managing the SQL transaction log size, configuring SOLIDWORKS PDM communication with IP addresses only, and moving server components to another system.**
Installation Overview

This chapter includes the following topics:

- Required Installation Components
- Optional Installation Components (SOLIDWORKS PDM Professional Only)
- SOLIDWORKS PDM Deployment Scenarios
- System Requirements
- Installation Summary
- Installation Assistance

You can install SOLIDWORKS PDM Standard or SOLIDWORKS PDM Professional using:

- SOLIDWORKS Installation Manager (SLDIM)
- SOLIDWORKS PDM InstallShield Wizard

Based on the installation method you use, client and server components are installed under different folders:

- Using SLDIM
  
  C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS PDM

- Using InstallShield Wizard

  C:\Program Files\SOLIDWORKS PDM

The installation guide refers to either path, use the path that is appropriate to your environment.

You must install the SolidNetWork License Manager separately.

You can install SOLIDWORKS PDM client and SOLIDWORKS PDM server either on different machines or on the same machine. To install both on the same machine, you must run the server install.

You cannot install client and server on the same machine by running separate installs.

You can select a product type based on the license available. The following add-ins specific to the product type are available.
## Product types and add-ins

<table>
<thead>
<tr>
<th>Client</th>
<th>Product types and add-ins</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLIDWORKS PDM Standard</td>
<td>SOLIDWORKS PDM CAD Editor • SOLIDWORKS • DraftSight</td>
</tr>
<tr>
<td></td>
<td>SOLIDWORKS PDM Contributor • DraftSight</td>
</tr>
<tr>
<td></td>
<td>SOLIDWORKS PDM Viewer: No add-in</td>
</tr>
<tr>
<td>SOLIDWORKS PDM Professional</td>
<td>SOLIDWORKS PDM CAD Editor • Microsoft Office Integration • SOLIDWORKS • DraftSight</td>
</tr>
<tr>
<td></td>
<td>SOLIDWORKS PDM Contributor • Microsoft Office Integration • DraftSight</td>
</tr>
<tr>
<td></td>
<td>SOLIDWORKS PDM Viewer • Microsoft Office Integration</td>
</tr>
</tbody>
</table>

## Required Installation Components

To use SOLIDWORKS PDM, these components must be installed and configured.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft SQL Server</td>
<td>The SOLIDWORKS PDM Professional file vault database must be hosted on SQL Server 2017, SQL Server 2016, or SQL Server 2014 Service Pack 3 or later. The SQL Server software is not included on the SOLIDWORKS DVD and must be installed separately.</td>
</tr>
<tr>
<td>Microsoft SQL Server Express</td>
<td>The SOLIDWORKS PDM Standard file vault database must be hosted on SQL Server 2014 Express Service Pack 3 or later.</td>
</tr>
<tr>
<td>SOLIDWORKS PDM database server</td>
<td>The database server periodically polls SOLIDWORKS PDM databases for updates such as notifications, local view refresh, replication schedule updates, and index server changes. It also manages data import and export rules.</td>
</tr>
<tr>
<td>SOLIDWORKS PDM archive server</td>
<td>The archive server hosts the physical files stored in a file vault, and manages users and their credentials.</td>
</tr>
</tbody>
</table>
| **SolidNetWork License Manager** | The SolidNetWork License Manager manages licensing of SOLIDWORKS PDM.
If you already have a SolidNetWork License Manager installed for SOLIDWORKS, you can use it with SOLIDWORKS PDM. Ensure that it is updated to the SOLIDWORKS PDM release version. |

| **SOLIDWORKS PDM Professional client** | Each computer accessing the SOLIDWORKS PDM Professional file vault must have one of the following clients installed:

- **SOLIDWORKS PDM Professional CAD Editor & Web**
  Supports working with all file types, including enhanced management and previewing of CAD formats such as SOLIDWORKS. CAD add-ins allow users to access SOLIDWORKS PDM Professional from within the CAD application.

- **SOLIDWORKS PDM Professional Contributor & Web**
  Supports working with all file types, including CAD files. However, the CAD add-ins are not supported on this client type.

- **SOLIDWORKS PDM Professional Viewer**
  Allows read-only access to file vaults; user cannot add or modify (check out, check in, update values) files or use CAD add-ins. |
Each computer accessing the SOLIDWORKS PDM Standard file vault must have one of the following clients installed:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLIDWORKS PDM Standard CAD Editor</td>
<td>Supports working with SOLIDWORKS, DWG/DXF format, Microsoft Word, and Microsoft Excel files. All file formats that Office plug-in handles behave in the same way in SOLIDWORKS PDM Standard except Preview.</td>
</tr>
<tr>
<td>SOLIDWORKS PDM Standard Contributor</td>
<td>Supports working with SOLIDWORKS, DWG/DXF format, Microsoft Word, and Microsoft Excel files.</td>
</tr>
<tr>
<td>SOLIDWORKS PDM Standard Viewer</td>
<td>Allows read-only access to file vaults; user cannot add or modify (check out, check in, update values) files.</td>
</tr>
</tbody>
</table>

Optional Installation Components (SOLIDWORKS PDM Professional Only)

The following installation components are optional:

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLIDWORKS PDM Web server</td>
<td>The Web server provides access to a file vault from the Internet or an intranet.</td>
</tr>
<tr>
<td>SOLIDWORKS PDM index server</td>
<td>The SOLIDWORKS PDM index server provides for full content search in many file types stored in a file vault.</td>
</tr>
<tr>
<td>SOLIDWORKS PDM Web API Server</td>
<td>EXALEAD® OnePart users can use a Web API server to index and retrieve SOLIDWORKS PDM data.</td>
</tr>
</tbody>
</table>

You must install Microsoft Internet Information Services 7 or higher versions (IIS).

SOLIDWORKS PDM Deployment Scenarios

The deployment of SOLIDWORKS PDM components depends on the size and type of organization where SOLIDWORKS PDM is used.

Medium Office Network

A server running SQL Server for SOLIDWORKS PDM Professional or SQL Server Express for SOLIDWORKS PDM Standard hosts the archive server, database server, and SNL.
server. Windows workstations installed with the SOLIDWORKS PDM client attach to the server.

1 SQL, Database, SNL, and Archive Servers
2 Clients

Large Office Network

One server running SQL Server hosts the file vault databases and the database server. One server hosts the archive server and another server hosts the SNL server. Workstations installed with the SOLIDWORKS PDM Professional client attach to the servers. A Web server allows access over the Internet using SOLIDWORKS PDM Web clients.
WAN Connected Offices

One main server running SQL Server hosts the central database server. A second server hosts the archive server and a third server hosts the SNL server. Each WAN office has a server hosting a local archive server with a replicated file vault archive.

Workstations installed with the SOLIDWORKS PDM Professional client attach to their local archive server and to the central database server.
System Requirements

SOLIDWORKS PDM system requirements are available on the SOLIDWORKS Web site.

Installation Summary

Although components can be installed in any order, the recommended sequence for a LAN installation is described.

To install SOLIDWORKS PDM Professional components:

1. Install SQL Server on the system that hosts the SOLIDWORKS PDM Professional file vault database or install SQL Express on the system that hosts the SOLIDWORKS PDM Standard file vault database, unless you have an existing SQL Server or SQL Express running.
   For details, see Installing and Configuring SQL Server on page 17.
2. Install the database server component on the system running the SQL Server.
   For details, see Installing SOLIDWORKS PDM Database Server on page 44.
3. Install the archive server on the system running the SQL Server or on a separate system.
   For details, see Installing SOLIDWORKS PDM Archive Server on page 47.
4. Install and configure the SolidNetWork License Manager on a server that is accessible to all clients, preferably the SQL database server.
   For details, see Installing and Configuring SolidNetWork Licensing on page 55.
5. Install the SOLIDWORKS PDM client on all workstations that will work in the file vault.
   For details, see Installing the SOLIDWORKS PDM Client on page 75.
6. Create a new file vault using the SOLIDWORKS PDM administration tool on a system where the SOLIDWORKS PDM client is installed.
   For details, see Vault Creation.
7. Attach the remaining clients to the archive server and create local file vault views using the View Setup wizard.
   For details, see Creating a File Vault View Using the View Setup Wizard on page 100.
8. Optionally, set up the SOLIDWORKS PDM Professional index server for content search support.
   For details, see Configuring Content Search (For SOLIDWORKS PDM Professional only) on page 117.

Installation Assistance

First level technical support for SOLIDWORKS products is provided by your reseller. For help contacting your reseller:

- Call 1-800-693-9000 from the USA or Canada.
- Call 1 978-371-5011 from other locations.
- Send e-mail to customercenterSR@solidworks.com.
Installing and Configuring SQL Server

This chapter includes the following topics:

- Installing SQL Server 2016, 2017, or 2019
- Upgrading to SQL Server 2016, 2017, or 2019
- SQL Server 2014 Support
- Installing SQL Server 2014
- Upgrading to SQL Server 2014
- SQL Server Troubleshooting
- Changing the SQL Server Login Account

SOLIDWORKS PDM Professional uses a Microsoft SQL-based database to store information about files and activities in a file vault. File vaults support SQL Server 2014 Service Pack 3 or later versions up to 2019.

Recommendation: Use SQL Server 2019 versions to host the file vault database.

If you already have the required version of SQL Server installed, continue to Installing SOLIDWORKS PDM on page 42.

If you are uncertain about which SQL Server version is installed, visit the Microsoft Support page and search for the Knowledge Base article 321185 to identify the version and edition.

The following table summarizes SOLIDWORKS PDM Professional versions and the supported SQL Server versions:

<table>
<thead>
<tr>
<th>SOLIDWORKS PDM Version</th>
<th>SQL Server Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>2016 and later</td>
<td>2014 SP3 and later</td>
</tr>
<tr>
<td>2017 and later</td>
<td>2016</td>
</tr>
<tr>
<td>2019 and later</td>
<td>2017 and earlier</td>
</tr>
<tr>
<td>2020 and later</td>
<td>2019 and earlier</td>
</tr>
</tbody>
</table>


SOLIDWORKS PDM Professional 2017 and later support the use of SQL Server 2016. SOLIDWORKS PDM Professional 2018 and later support the use of SQL Server 2017 and
earlier. SOLIDWORKS PDM Professional 2020 and later support the use of SQL Server 2019 and earlier.

SOLIDWORKS PDM 2021 and later require Cumulative Update 4 when using SQL Server 2019. For more information on Cumulative Update 4, visit the Microsoft Support page and search for the Knowledge Base article 4548597.

Ensure that there are sufficient SQL Client Access Licenses for the existing SQL server.

For details about Microsoft SQL Server support, see System Requirements.

Installing SQL Server 2016, 2017, or 2019


For hardware and software requirements and detailed installation instructions, see https://msdn.microsoft.com/en-us/library/bb500469.aspx.

Before Installing SQL Server 2016, 2017, or 2019

For local installations, you must run Setup as an administrator. If you install SQL Server 2016, 2017, or 2019 from a remote share, you must use a domain account that has read and execute permissions on the remote share.

Performing the SQL Server 2016, 2017, or 2019 Installation

1. Close all Windows applications, including Windows File Explorer.
2. Insert the SQL Server 2016, 2017, or 2019 installation media. From the root folder, double-click `setup.exe` and use the default selections unless otherwise instructed.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server Installation Center/Planning</td>
<td>In the left pane, click <strong>Installation</strong>.</td>
</tr>
<tr>
<td>SQL Server Installation Center/Installation</td>
<td>Click <strong>New SQL Server stand-alone installation or add features to an existing installation.</strong></td>
</tr>
<tr>
<td>Product Key</td>
<td>a. Select <strong>Enter the product key</strong> and enter your license key.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>License Terms</td>
<td>a. Read and accept the license agreement.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Install Rules</td>
<td>The installer performs an additional check:</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>a. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
<tr>
<td>Feature Selection</td>
<td>a. Under <strong>Instance Features</strong>, select <strong>Database Engine Services</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. Under <strong>Shared Features</strong>, select:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Client Tools Connectivity</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Integration Services</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Client Tools Backward Compatibility</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Documentation Components</strong></td>
</tr>
<tr>
<td></td>
<td>The <strong>Documentation Components</strong> option is available only when installing SQL Server 2016.</td>
</tr>
<tr>
<td></td>
<td>c. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Screen</td>
<td>Action</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Instance Configuration</td>
<td>If this is a new installation:</td>
</tr>
<tr>
<td></td>
<td>a. Select <strong>Default instance.</strong></td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next.</strong></td>
</tr>
<tr>
<td></td>
<td>If SQL Server is installed on the system and you opted not to upgrade:</td>
</tr>
<tr>
<td></td>
<td>a. Select <strong>Named Instance.</strong></td>
</tr>
<tr>
<td></td>
<td>b. Enter a unique instance name for this installation:</td>
</tr>
<tr>
<td></td>
<td><code>computername\instancename</code>.</td>
</tr>
<tr>
<td></td>
<td>c. Click <strong>Next.</strong></td>
</tr>
</tbody>
</table>

**Server Configuration/Service Account tab**

**SQL Server Agent:**
- **Account Name:** NT Service\SQLSERVERAGENT
- **Startup Type:** Automatic

**SQL Server Database Engine:**
- **Account Name:** NT Service\MSSQLSERVER
- **Startup Type:** Automatic

**SQL Server Integration Services 13.0:**
- **Account Name:** NT Service\MsDtsServer130
- **Startup Type:** Automatic

For SQL Server 2017:**SQL Server Integration Services 14.0**
- **Account Name:** NT Service\MsDtsServer140
- **Startup Type:** Automatic

For SQL Server 2019:**SQL Server Integration Services 15.0**
- **Account Name:** NT Service\MsDtsServer150
- **Startup Type:** Automatic

**SQL Server Browser:**
- **Account Name:** NT AUTHORITY\LOCAL SERVICE
- **Startup Type:** Automatic
### Screen | Action
--- | ---
Database Engine Configuration | a. Select **Mixed Mode (SQL Server authentication and Windows authentication)**. SOLIDWORKS PDM Professional uses SQL Server authentication for database communication.
b. Enter a strong password for the system administrator account (**sa**). Do not leave the password blank. For password rules, click **Help**. Re-enter the password to confirm it. Remember the password for use when setting up SOLIDWORKS PDM Professional file vault databases.
c. Under **Specify SQL Server administrators**, click **Add Current User**.
d. Click **Next**.

#### Installation Rules
The installer checks for problems that will prevent the installation.
- If no problems are reported, click **Next**.
- If problems are reported:
  a. Click **Show details** to list the components that failed or prompted warnings.
  b. Click **Cancel** to stop the installation and fix the problems.

#### Ready to Install
Click **Install**.

#### Installation Progress
Installation may take a long time.
If you get an error regarding the SQL Server Backwards-Compatibility Files, cancel the installation. Use **Uninstall a program** to uninstall the Microsoft SQL Server 2014 Backward Compatibility package. Then restart the SQL Server 2016, 2017, or 2019 installation.

When the progress bar shows **Setup process complete**, click **Next**.

#### Complete
Click **Close**.
If you receive a message that a computer restart is required, click **OK**. If a restart does not begin automatically, manually restart your computer.
After Installing SQL Server 2016, 2017, or 2019

To use secure SQL communication over the network and have a certificate server, you can enable SSL encryption.

For details, see the Microsoft articles:


Verifying SQL Server 2016, 2017, or 2019 Installation

To verify that SQL Server 2016, 2017, or 2019 was installed correctly:

1. Start the SQL Server Configuration Manager.
2. Click SQL Server 2016 Services or SQL Server 2017 Services or SQL Server 2019 Services, and see whether SQL Server (MSSQLSERVER) is running.
3. If it is not, start the service by right-clicking SQL Server (MSSQLSERVER) and clicking Start.
4. Exit the SQL Server Configuration Manager.

Upgrading to SQL Server 2016, 2017, or 2019

Follow these instructions to upgrade an existing SQL Server instance to SQL Server 2016, 2017, or 2019.

If upgrading to SQL Server 2016, 2017, or 2019, visit Microsoft Docs page and search for the upgrade information.

If you are uncertain about which SQL Server version is installed, visit Microsoft Support page and search for the Knowledge Base article 321185 to identify version and edition.

All file vault databases are automatically upgraded to the appropriate SQL Server version format when the server instance is upgraded.

Performing the Upgrade to SQL Server 2016, 2017, or 2019

1. Close all Windows applications, including Windows File Explorer.
2. Insert the SQL Server 2016, 2017, or 2019 installation media. From the root folder, double-click `setup.exe` and use the default selections unless otherwise instructed.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server Installation Center/Planning page</td>
<td>In the left pane, click <strong>Installation</strong>.</td>
</tr>
<tr>
<td>SQL Server Installation Center/Installation page</td>
<td>Click <strong>Upgrade from a previous version of SQL Server</strong>.</td>
</tr>
<tr>
<td>Product Key</td>
<td>a. Select <strong>Enter the product key</strong> and enter your license key.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>License Terms</td>
<td>a. Read and accept the license agreement.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Upgrade Rules</td>
<td>The installer performs an additional check.</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>a. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
<tr>
<td>Select Instance</td>
<td>Select the SQL Server instance to upgrade. <strong>MSSQLSERVER</strong> is the default.</td>
</tr>
<tr>
<td>Select Features</td>
<td>Lists the installed SQL features that will be upgraded. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Instance Configuration</td>
<td>Lists the named instance that will be upgraded. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Server Configuration</td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Upgrade Rules</td>
<td>The installer checks for problems that will prevent the upgrade.</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>a. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
</tbody>
</table>
### Screen | Action
--- | ---
Ready to Upgrade | Click **Upgrade**.
Upgrade Progress | When the upgrade finishes for all components, click **Next**.
Complete | Click **Close**.
SQL Server Installation Center | Click X in the upper right corner to close.

After Upgrading to SQL Server 2016, 2017, or 2019

- Verify the upgrade.
  For details, see [Verifying SQL Server 2016, 2017, or 2019 Installation](#) on page 22.
- Troubleshoot problems.
  For details, see [SQL Server Troubleshooting](#).

**SQL Server 2014 Support**

SOLIDWORKS PDM Professional 2020 supports the use of SQL Server 2014 Service Pack 3 or later.

- To upgrade your SQL Server 2014 or SQL Server 2014 Express installation to SP3, download the service pack [here](#).
- Ensure that there are sufficient SQL Client Access licenses for the existing SQL server.

**Installing SQL Server 2014**

The SQL Server 2014 installer provides help, including considerations for running on Windows Vista or later. The SQL Server 2014 Books Online provide hardware and software requirements and detailed installation instructions.

For details, see [https://docs.microsoft.com/en-us/previous-versions/sql/sql-server-2008/ms130214(v=sql.100)](https://docs.microsoft.com/en-us/previous-versions/sql/sql-server-2008/ms130214(v=sql.100)).

**Before Installing SQL Server 2014**

For local installations, you must run **Setup** as an administrator. If you install SQL Server 2014 from a remote share, you must use a domain account that has read and execute permissions on the remote share.

Microsoft .Net framework version 3.5 is required. If it is not installed, the Installation Wizard installs it before starting the SQL Server 2014 installation. This installation may require you to restart your computer.
Performing the SQL Server 2014 Installation

1. Close all Windows applications, including Windows File Explorer.
2. Insert the SQL Server 2014 installation media. From the root folder, double-click `setup.exe` and use the default selections unless otherwise instructed.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server Installation Center/Planning</td>
<td>In the left pane, click <strong>Installation</strong>.</td>
</tr>
<tr>
<td>SQL Server Installation Center/Installation</td>
<td>Click <strong>New SQL Server stand-alone installation or add features to an existing installation.</strong></td>
</tr>
<tr>
<td>Setup Support Rules</td>
<td>The installer checks for problems that will prevent the installation of the SQL Server support files:</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>a. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
<tr>
<td>Product Key</td>
<td>a. Select <strong>Enter the product key</strong> and enter your license key.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>License Terms</td>
<td>a. Read and accept the license agreement.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Setup Support Files</td>
<td>Click <strong>Install</strong>.</td>
</tr>
<tr>
<td>Setup Support Rules</td>
<td>The installer performs an additional check:</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>a. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
<tr>
<td>Screen</td>
<td>Action</td>
</tr>
<tr>
<td>-------------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Feature Selection       | a. Under **Instance Features**, select **Database Engine Services**.  
                          | b. Under **Shared Features**, select:  
                          | • **Client Tools Connectivity**  
                          | • **Integration Services**  
                          | • **Client Tools Backward Compatibility**  
                          | • **Documentation Components**  
                          | • **Management Tools - Basic**  
                          | • **Management Tools - Complete**  
                          | c. Click **Next**.                                                              |
| Instance Configuration  | If this is a new installation:  
                          | a. Select **Default instance**.  
                          | b. Click **Next**.                                                               |
|                         | If SQL Server is already installed on the system and you opted not to upgrade:  
                          | a. Select **Named Instance**.  
                          | b. Enter a unique instance name for this installation:  
                          |     computername\instancename.                                                             
                          | c. Click **Next**.                                                               |
| Disk Space Requirements | If disk space requirements are met, click **Next**.                                                                                   |
|                         | If disk space requirements are not met:  
                          | a. Note the space required.  
                          | b. Click **Cancel**.                                                             |
|                         | c. Add the required space.  
<pre><code>                      | d. Run the installation again.                                                  |
</code></pre>
<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
</table>
| Server Configuration/Service Account tab | **SQL Server Agent:**  
  - **Account Name:** NT Service\SQLAgent$*INSTANCENAME*  
  - **Startup Type:** Automatic |
| | **SQL Server Database Engine:**  
  - **Account Name:** NT Service\MSSQL$*INSTANCENAME*  
  - **Startup Type:** Automatic |
| | **SQL Server Integration Services 12.0:**  
  - **Account Name:** NT Service\MsDtsServer120  
  - **Startup Type:** Automatic |
| | **SQL Server Browser:**  
  - **Account Name:** NT AUTHORITY\LOCAL SERVICE  
  - **Startup Type:** Automatic |
| Server Configuration/Collation tab | a. For **Database Engine**, click **Customize**.  
  b. In the dialog box, select **Windows Collation designator and sort order**, and the **Collation designator** that matches your locale. Keep the other selections.  
  c. Click **Next**.  
  You cannot use SOLIDWORKS PDM on a server using binary settings. |
<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
</table>
   b. Type a strong password for the system administrator account (sa). Do not leave the password blank. For password rules, click Help.  
   Retype the password to confirm it.  
   Remember the password for use when setting up SOLIDWORKS PDM Professional file vault databases.  
   c. Under Specify SQL Server administrators, click Add.  
   d. In the Select Users, Computers, or Groups dialog box, enter the name of the local administrator of the system or the Administrators group.  
   e. Click Next. |
| Database Engine Configuration/Data Directories tab | (Optional) To change the default folder where databases created by SOLIDWORKS PDM Professional are stored, change the location for User database directory and User database log directory. |
| Error and Usage Reporting | Click Next. |
| Installation Rules | The installer checks for problems that will prevent the installation of SQL Server 2014.  
   • If no problems are reported, click Next.  
   • If problems are reported:  
     a. Click Show details to list the components that failed or prompted warnings.  
     b. Click Cancel to stop the installation and fix the problems. |
| Ready to Install | Click Install. |
| Installation Progress | Installation may take a long time.  
If you get an error regarding the SQL Server Backwards-Compatibility Files, cancel the installation.  
Use Uninstall a program to uninstall the Microsoft SQL Server 2012 Backward Compatibility package. Then restart the SQL Server 2014 installation.  
When the progress bar shows Setup process complete, click Next. |
After Installing SQL Server 2014

To use secure SQL communication over the network and have a certificate server, you can enable SSL encryption.

For details, visit Microsoft Support page and search for the Knowledge Base article 318605.

Verifying SQL Server 2014 Installation

To verify that SQL Server 2014 was installed correctly:

1. Start the SQL Server Configuration Manager.
2. Click SQL Server 2014 Services and see whether SQL Server (MSSQLSERVER) is running.
3. If it is not, start the service by right-clicking SQL Server (MSSQLSERVER) and selecting Start.
4. Exit the SQL Server Configuration Manager.

Upgrading to SQL Server 2014

Follow these instructions to upgrade an existing Server SQL 2008R2 or SQL Server SQL 2012 instance to SQL Server 2014 Service Pack 3 or later.

If you are upgrading to SQL Server 2014, visit the Microsoft Docs page and search for the upgrade information.

To upgrade your SQL Server 2014 or SQL Server 2014 Express installation to SP3, download the service pack here.

If you are uncertain about which SQL Server version is installed, visit the Microsoft Support page and search for the Knowledge Base article 321185 to identify the version and edition.

All file vault databases are automatically upgraded to the SQL Server 2014 format when the server instance is upgraded.

Performing the Upgrade to SQL Server 2014

1. Close all Windows applications, including Windows File Explorer.
2. Insert the SQL Server 2014 installation media, and from the root folder, double-click `setup.exe`.

   Use the default selections unless otherwise instructed.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server Installation Center/Planning page</td>
<td>In the left pane, click <strong>Installation</strong>.</td>
</tr>
<tr>
<td>SQL Server Installation Center/Installation page</td>
<td>Click <strong>Upgrade from SQL Server 2005, SQL Server 2008, SQL Server 2008 R2 or SQL Server 2012</strong>.</td>
</tr>
<tr>
<td>Setup Support Rules</td>
<td>The installer checks for problems that will prevent the installation of the SQL Server support files:</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>a. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
<tr>
<td>Product Key</td>
<td>a. Select <strong>Enter the product key</strong> and enter your license key.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>License Terms</td>
<td>a. Read and accept the license agreement.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Setup Support Files</td>
<td>Click <strong>Install</strong>.</td>
</tr>
<tr>
<td>Setup Support Rules</td>
<td>The installer performs an additional check.</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>a. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
<tr>
<td>Select Instance</td>
<td>Select the SQL Server instance to upgrade. <strong>MSSQLSERVER</strong> is the default.</td>
</tr>
<tr>
<td>Select Features</td>
<td>Lists the installed SQL features that will be upgraded. Click <strong>Next</strong>.</td>
</tr>
</tbody>
</table>
### Screen | Action
--- | ---
Instance Configuration | Lists the named instance that will be upgraded. Click **Next**.

Disk Space Requirements | If disk space requirements are met, click **Next**.
If disk space requirements are not met:
  a. Note the space required.
  b. Click **Cancel**.
  c. Add the required space.
  d. Run the installation again.

Server Configuration | Click **Next**.

Full-text Upgrade | Select **Import** and click **Next**.

Error and Usage Reporting | Click **Next**.

Upgrade Rules | The installer checks for problems that will prevent the upgrade to SQL Server 2014.
  - If no problems are reported, click **Next**.
  - If problems are reported:
    a. Click **Show details** to list the components that failed or prompted warnings.
    b. Click **Cancel** to stop the installation and fix the problems.

Ready to Upgrade | Click **Upgrade**.

Upgrade Progress | When the upgrade finishes for all components, click **Next**.

Complete | Click **Close**.

SQL Server Installation Center | Click **X** in the upper right corner to close.

---

**After Upgrading to SQL Server 2014**

- Verify the upgrade.
  For details, see **Verifying SQL Server 2014 Installation** on page 30.
- Troubleshoot problems.
  For details, see **SQL Server Troubleshooting** on page 33.
SQL Server Troubleshooting

Clients Cannot Work in the File Vault

**Cause**  
The SQL password has expired or the account has been locked out.

**Solution**  
Unlock the account by logging in using Windows Authentication.

**To unlock the SQL Server Account**
1. Open Microsoft SQL Server Management Studio.
2. In the Connect to Server dialog box:
   a) For **Authentication**, select **Windows Authentication**.
   b) Click **Connect**.
3. In the left pane, expand **Security** and select **Logins**.
4. Right-click the SQL login that is defined for use in the archive server (typically the **sa** account) and select **Properties**.
5. In the Login Properties dialog box, in the left pane, click **Status**.
6. Under **Status**, for **SQL Server authentication**, clear **Login is locked out**.
7. Exit Microsoft SQL Server Management Studio.

SOLIDWORKS PDM Administrative Features Fail

**Cause**  
Remote connections are not allowed.

**Solution**  
Enable the SQL Server remote access option.

**To enable the SQL server remote access option:**
1. Open Microsoft SQL Server Management Studio.
2. Log in as system administrator.
3. Right-click the server and select **Properties**.
4. In the Server Properties dialog box, click **Connections**.
5. In the right pane, under **Remote server connections**, verify that **Allow remote connections to this server** is selected, and click **OK**.

SOLIDWORKS PDM Cannot Connect to the Server

**Cause**  
TCP/IP is not enabled, or the TCP port is wrong.

**Solution**  
Activate the TCP/IP protocol for client connections and ensure that TCP port 1433 is open.

**To activate the SQL Server TCP/IP protocol:**
1. Open the SQL Server Configuration Manager.
2. In the left pane, expand **SQL Server 2008 Network Configuration**, and click **Protocols for MSSQLSERVER**.
3. In the right pane, verify that TCP/IP is enabled.
4. Right-click **TCP/IP** and select **Properties**.
5. On the IP Addresses tab, ensure that TCP is using port 1433.
6. Exit the SQL Server Configuration Manager.

**Changing the SQL Server Login Account**

The archive and database server services must be able to reach any SOLIDWORKS PDM Professional databases they manage using an SQL login that has at least db_owner access to the databases.

Normally, when you install the SQL Server, a system administrator login (**sa**) is created that has full access to all databases on the SQL Server.

Use this system administrator, or create a new user with db_owner access to the SOLIDWORKS PDM Professional databases.

**Creating a New SQL Login Account**

1. Open **Microsoft SQL Server Management Studio**.
2. Log in as a system administrator.
3. In the left pane, expand **Security**.
4. Right-click **Logins** and select **New Login**.
5. In the Login - New dialog box, select **General**:
   - a) Type a Login name for the new SQL user.
   - b) Select **SQL Server Authentication** and enter a password.
   - c) Clear **Enforce password policy**.
   - d) Click **OK**.
6. Close **Microsoft SQL Server Management Studio**.

**Using the New SQL Login with the SOLIDWORKS PDM Archive**

1. On the system running the SOLIDWORKS PDM archive server, from the Windows **Start** menu, select **SOLIDWORKS PDM > Archive Server Configuration**.
2. In the SOLIDWORKS PDM Archive Server dialog box, select **Tools > Default settings**.
3. In the Settings dialog box, under **SQL login**, click **Change**.
4. In the Change SQL User Login dialog box, enter the SQL user login and password of the new SQL user and click **OK** twice.
5. Exit the SOLIDWORKS PDM Archive Server dialog box.
6. On the system running the SOLIDWORKS PDM database server, from the Windows **Start** menu, select **SOLIDWORKS PDM > Database Server Configuration**.
7. In the SOLIDWORKS PDM Database Server dialog box, enter the new SQL user login and password, and click **OK**.
8. Restart the SOLIDWORKS PDM Database Server service.
Giving an SQL User db_owner Access to Existing SOLIDWORKS PDM File Vault Databases

1. On the SQL server that hosts the new SOLIDWORKS PDM databases, open Microsoft SQL Server Management Studio.
2. Log in as a system administrator.
3. In the left pane, expand Security and click Logins.
4. Right-click the SQL user and select Properties.
5. In the Login Properties dialog box:
   a) In the left pane, select User Mapping.
   b) In the right pane, under Users mapped to this login, select Map for all SOLIDWORKS PDM databases (file vault databases and ConisioMasterDb).
   c) For each database, under Database role membership, select db_owner.
   d) Click OK.
6. Right-click the server and select New Query.
7. In the right pane, enter the following query statements on the new db_owner user and click Execute.
   a) GRANT VIEW SERVER STATE TO [SQL_USER_NAME]
   b) GRANT ALTER ANY CONNECTION TO [SQL_USER_NAME]
8. Exit Microsoft Microsoft SQL Server Management Studio.
9. On the system running the SOLIDWORKS PDM archive server, from the Windows Start menu, select SOLIDWORKS PDM > Archive Server Configuration.
10. Select Tools > Default settings.
11. In the Settings dialog box, under SQL login, click Change.
12. In the Change SQL User Login dialog box, enter the SQL user login and password of the new SQL user and click OK.
13. Close the SOLIDWORKS PDM Archive Server dialog box.
14. On the system running the SOLIDWORKS PDM database server, from the Windows Start menu, select SOLIDWORKS PDM > Database Server Configuration.
15. Enter the new SQL user login and password and click OK.
16. Restart the SOLIDWORKS PDM Database Server service.

Insufficient SQL Permissions

If you do not assign the SQL user sufficient SQL permissions, you cannot log in to any file vault views.

Warning messages are displayed if the SQL user does not have at least db_owner access:

• To the ConisioMasterDb database
  For example:
  
  Could not log in to the database “filevault on Server servername”.

• To the file vault database
  For example:
  
  Could not access the item in the database.
Installing and Configuring SQL Server Express

SOLIDWORKS PDM Standard supports the use of Microsoft SQL Server 2014 Express.
SOLIDWORKS PDM Standard uses a Microsoft SQL Server Express database to store information about files and activities in a file vault.

Use SQL Server 2014 Express Service Pack 3 or later to host the file vault database. To upgrade the SQL Server 2014 Express installation to SP3, download the service pack here.

Installing and Managing SQL Server 2014 Express

To install and manage SQL Server 2014 Express, install the SQL Server database engine and the SQL Server Management Studio.

You can install the SQL Server database engine from the installation package that is available on the SOLIDWORKS installation media. For details, see Installing the SQL Server Express Database Engine on page 36. For more details on installing SQL Server Management Studio, click https://docs.microsoft.com/en-us/, SQL Server, and then click SQL Server Management Studio (SSMS).

To install the SQL Server database engine and the SQL Server Management Studio at the same time, download and install the combined installation package SQLEXPRWT_x64_ENU.exe available at https://www.microsoft.com/en-us/download/details.aspx?id=42299.

Before Installing SQL Server 2014 Express

For local installations, you must run the installation as an administrator.

Microsoft .Net framework version 3.5 is required. If it is not installed, the Installation Wizard installs it before starting the SQL Server 2014 Express installation. This installation may require you to restart your computer.

Installing the SQL Server Express Database Engine

1. Close all Windows applications, including Windows File Explorer.
2. Browse to \PreReqs\SQLServer\sqlexpr_x64_enu.exe and click Run as administrator.

The extraction begins and starts the InstallShield wizard.
3. Use the default selections unless otherwise instructed.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server Installation Center/Installation</td>
<td>Click <strong>New SQL Server stand-alone installation or add features to an existing installation.</strong></td>
</tr>
<tr>
<td>License Terms</td>
<td>a. Read and accept the license agreement.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next.</strong></td>
</tr>
<tr>
<td>Install Rules</td>
<td>The installer performs an additional check:</td>
</tr>
<tr>
<td></td>
<td>• If no problems are reported, click <strong>Next.</strong></td>
</tr>
<tr>
<td></td>
<td>• If problems are reported:</td>
</tr>
<tr>
<td></td>
<td>a. Click <strong>Show details</strong> to list the components that failed or prompted warnings.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Cancel</strong> to stop the installation and fix the problems.</td>
</tr>
<tr>
<td>Feature Selection</td>
<td>a. Under <strong>Instance Features</strong>, select <strong>Database Engine Services.</strong></td>
</tr>
<tr>
<td></td>
<td>b. Under <strong>Shared Features</strong>, select:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Client Tools Connectivity</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Client Tools Backward Compatibility</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Client Tools SDK</strong></td>
</tr>
<tr>
<td></td>
<td>c. Click <strong>Next.</strong></td>
</tr>
<tr>
<td>Instance Configuration</td>
<td>If this is a new installation:</td>
</tr>
<tr>
<td></td>
<td>a. Select <strong>Default instance.</strong></td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next.</strong></td>
</tr>
<tr>
<td></td>
<td>If SQL Server is already installed on the system and you opted not to upgrade:</td>
</tr>
<tr>
<td></td>
<td>a. Select <strong>Named Instance.</strong></td>
</tr>
<tr>
<td></td>
<td>b. Enter a unique instance name.</td>
</tr>
<tr>
<td></td>
<td>c. Click <strong>Next.</strong></td>
</tr>
<tr>
<td>Screen</td>
<td>Action</td>
</tr>
<tr>
<td>---------------------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Server Configuration/Service Accounts tab</td>
<td><strong>SQL Server Database Engine:</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Account Name:</strong> NT Service\MSSQL$<em>INSTANCENAME</em></td>
</tr>
<tr>
<td></td>
<td>• <strong>Startup Type:</strong> Automatic</td>
</tr>
<tr>
<td></td>
<td><strong>SQL Server Browser:</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>Account Name:</strong> NT AUTHORITY\LOCAL SERVICE</td>
</tr>
<tr>
<td></td>
<td>• <strong>Startup Type:</strong> Automatic</td>
</tr>
<tr>
<td></td>
<td><strong>Server Configuration/Collation tab</strong></td>
</tr>
<tr>
<td></td>
<td>a. Keep the default value, <strong>SQL_Latin1_General_CP1_CI_AS</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. Optionally, click <strong>Customize</strong>, select <strong>Windows collation designator</strong> and <strong>sort order</strong>, and the <strong>Collation designator</strong> that matches your locale. Keep the other selections.</td>
</tr>
<tr>
<td></td>
<td>c. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td><strong>You cannot use SOLIDWORKS PDM Standard on a server using binary settings.</strong></td>
</tr>
<tr>
<td>Screen</td>
<td>Action</td>
</tr>
<tr>
<td>--------</td>
<td>--------</td>
</tr>
</tbody>
</table>
| **Database Engine Configuration/Server Configuration tab** | a. Select **Mixed Mode (SQL Server Authentication and Windows Authentication)**. SOLIDWORKS PDM Standard uses SQL Server authentication for database communication.  
   b. Type a strong password for the system administrator account *(sa)*. Do not leave the password blank. For password rules, click **Help**.  
   Retype the password to confirm it.  
   Remember the password for use when setting up SOLIDWORKS PDM Standard file vault databases.  
   c. Under **Specify SQL Server administrators**, click **Add**.  
   d. In the Select Users, Computers, or Groups dialog box, enter the name of the local administrator of the system or the Administrators group.  
   e. Click **Next**. |
| **Database Engine Configuration/Data Directories tab/ FILESTREAM tab** | Optionally, set the remaining paths. Keep the default settings in the FILESTREAM tab. |
| **Installation Progress** | Installation may take a long time. If you get an error regarding the SQL Server Backwards-Compatibility Files, cancel the installation. Use **Uninstall a program** to uninstall the Microsoft SQL Server 2012 Backward Compatibility package. Then restart the SQL Server 2014 installation.  
   When the progress bar shows **Setup process complete**, click **Next**. |
| **Complete** | Click **Close**.  
   If you receive a message that computer restart is required, click **OK**. If a restart does not begin automatically, manually restart your computer. |
After Installing SQL Server 2014 Express

To connect to the SQL Server Express instance from remote clients ensure to configure the server to accept remote connections and enable the TCP/IP protocol. You must set the SQL server TCP port to a fixed port number instead of the default dynamic port number.

Enabling the SQL Server Remote Access Option

**To enable the SQL server remote access option:**
1. Open Microsoft SQL Server Management Studio.
2. Select the SQL Server instance name and log in as system administrator.
3. Right-click the server and select **Properties**.
4. In the Server Properties dialog box, click **Connections**.
5. In the right pane, under **Remote server connections**, verify that **Allow remote connections to this server** is selected, and click **OK**.

Activating the SQL Server TCP/IP Protocol

**To activate the SQL Server TCP/IP protocol:**
1. Open the SQL Server 2014 Configuration Manager.
2. In the left pane, expand **SQL Server Network Configuration**, and click **Protocols for <instance name>**.
3. In the right pane, verify that TCP/IP is enabled.
   If TCP/IP is disabled, right-click **TCP/IP** and select **Enable**.
4. In the left pane, select **SQL Server Services**.
5. Right-click **SQL Server(<instance name >)** and select **Restart**.
6. Exit the SQL Server Configuration Manager.

Configuring the SQL Server Express Instance to Listen to a Fixed TCP Port

The SQL Server Express instance listens to a dynamic port by default. When the SQL Server service starts up, the port number changes. If the server has a firewall enabled, it is difficult to configure the port exceptions to allow client access.

For details about configuring the firewall for SQL Server access, see [https://msdn.microsoft.com/en-us/library/cc646023(v=sql.120).aspx](https://msdn.microsoft.com/en-us/library/cc646023(v=sql.120).aspx).

**To configure the SQL Server Express Instance to Listen to a Fixed TCP Port:**
1. Open the SQL Server 2014 Configuration Manager.
2. In the left pane, expand **SQL Server Network Configuration**, and click **Protocols for <instance name>**.
3. Double-click **TCP/IP** and select the IP Addresses tab.
4. Under **IPAll**, clear the value in **TCP Dynamic Ports**.
5. Set the **TCP Port** to the static port number that you want the SQL Server Express instance to listen to.
   - If SQL Express is the only SQL Server instance on the system, set the port to 1433.
   - If other SQL Server instances exist on the system, set the port to a unique value, for example 1440.

6. Click **OK**.
7. In the left pane, select **SQL Server Services**.
8. Right-click **SQL Server(<instance name >)** and select **Restart**.
9. Double-click **SQL Server Browser** and select the Service tab.
10. Set the **Start Mode** to **Automatic** and click **OK**.
11. Right-click **SQL Server Browser** and start the service if it is not running.

**Verifying SQL Server 2014 Express Installation**

1. Start the SQL Server Configuration Manager.
2. Click **SQL Server Services** and see whether **SQL Server (<instance name >)** is running.
3. If it is not, start the service by right-clicking **SQL Server (<instance name >)** and selecting **Start**.
4. Exit the SQL Server Configuration Manager.

**Upgrading SQL Server Express 2014 to SQL Server 2014**

1. Close all Windows applications, including Windows File Explorer.
2. Insert the SQL Server 2014 installation media, and from the root folder, double-click **setup.exe**.
3. On the SQL Server Installation Center page, in the left pane, select **Maintenance**.
4. Select **Edition Upgrade**.
5. Complete the steps in the Upgrade the Edition for SQL Server 2014 dialog box.
6. Upgrade SQL Server 2014 to Service Pack 3 or later.
Installing SOLIDWORKS PDM

This chapter includes the following topics:

- **Downloading the Installation Media**
- **Initiating the Installation Via SOLIDWORKS Installation Manager**
- **Initiating the Installation via the InstallShield Wizard**
- **Installing SOLIDWORKS PDM Database Server**
- **Installing SOLIDWORKS PDM Archive Server**
- **Installing and Configuring SolidNetWork Licensing**
- **Installing SOLIDWORKS PDM Web2 (For SOLIDWORKS PDM Professional only)**
- **Installing SOLIDWORKS PDM Web API Server (For SOLIDWORKS PDM Professional Only)**
- **Installing the SOLIDWORKS PDM Client**

The SOLIDWORKS media contains the server and client components.

You can install each server component separately, or select multiple components to install in a single operation.

For example, to install the database server and archive server on the same computer, you can select both options on the Server Installation screen.

When you install multiple components, the screens appropriate to those components are displayed. For simplicity, the procedures in this chapter describe the component installations separately.

You can install SOLIDWORKS PDM Standard or SOLIDWORKS PDM Professional using:

- SOLIDWORKS PDM InstallShield Wizard
- **SOLIDWORKS Installation Manager (SLDIM)**

If you use SOLIDWORKS PDM InstallShield Wizard, you must install the SolidNetWork License Manager separately. The SolidNetWork License Manager can be installed with SOLIDWORKS PDM when using SLDIM.

You can install SOLIDWORKS PDM client and SOLIDWORKS PDM server either on different machines or on the same machine. To install both on the same machine, you must run the server install.

You cannot install client and server on the same machine by running separate installs.

Install the following components before you install SOLIDWORKS PDM:

- MSXML 6.0
- .NET Framework 4.0 or newer
Installing SOLIDWORKS PDM

- Visual C++ 2010 Redistributable - x86
- Visual C++ 2010 Redistributable - x64
- Visual C++ 2013 Redistributable - x86
- Visual C++ 2013 Redistributable - x64
- Visual C++ 2015 Redistributable - x64
- Visual C++ 2017 Redistributable - x64
- Microsoft ODBC Driver 17.3 or later

You can find the installation files for the prerequisite components on the Installation media under the \PreReqs\ directory.

If you use the SOLIDWORKS Installation Manager to install SOLIDWORKS PDM, the prerequisite components are automatically installed.

Install Microsoft ODBC driver 17.3 or later for SQL Server on the client and the servers.

Downloading the Installation Media

You can use SOLIDWORKS Installation Manager (SLDIM) to download the installation media. You can then use either SLDIM or the InstallShield Wizard to install SOLIDWORKS PDM.

To download the installation media:

1. Use the SOLIDWORKS Installation Manager to download the server and client products that you want to install.
   The downloaded files are your installation media.
2. Optional: To install on other computers, copy the installation media to a shared or portable drive.

Initiating the Installation Via SOLIDWORKS Installation Manager

To initiate the installation via SOLIDWORKS Installation Manager (SLDIM):

1. Browse to the installation media.
2. Run setup.exe.
   For details about installing via SLDIM, see Using SOLIDWORKS Installation Manager on page 86.

Initiating the Installation via the InstallShield Wizard

Ensure that you meet all prerequisites. For details, see Installing SOLIDWORKS PDM on page 42.

You perform the same initial steps to begin all SOLIDWORKS PDM installations.

To initiate the installation via the InstallShield Wizard:

1. Browse to the installation media.
2. In the SWPDMServer folder, run \SWPDMServer\setup.exe to install SOLIDWORKS PDM server.

3. In the SWPDMClient folder, run \SWPDMClient\setup.exe to install SOLIDWORKS PDM client.

When done, the installation wizard continues. Initiate the installation using these instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>Click Next.</td>
</tr>
<tr>
<td>License Agreement</td>
<td>Accept the license agreement and click Next.</td>
</tr>
<tr>
<td>Destination Folder</td>
<td>To accept the default installation location, click Next. To specify a different installation location: 1. Click Change. 2. Browse to the new location. 3. Click OK. 4. Click Next.</td>
</tr>
<tr>
<td>Select PDM Product</td>
<td>Select one of the following to install:  • SOLIDWORKS PDM Standard  • SOLIDWORKS PDM Professional</td>
</tr>
</tbody>
</table>

**Installing SOLIDWORKS PDM Database Server**

The database server periodically polls SOLIDWORKS PDM databases for updates such as notifications, local view refresh, replication schedule updates, and index server changes. It must be installed for:

<table>
<thead>
<tr>
<th>Automatic notifications</th>
<th>Workflow and other automatic notifications, such as change state, check out, check in, add, and deadline</th>
</tr>
</thead>
<tbody>
<tr>
<td>View updates</td>
<td>Automatic updates (refresh) of listings in file vault views and add-ins</td>
</tr>
<tr>
<td>Card list updates</td>
<td>Periodic updates of card lists that use SQL queries for their content</td>
</tr>
<tr>
<td>Cold store scheduling</td>
<td>Updates of archive servers with changes made to cold store schedules</td>
</tr>
<tr>
<td>Replication scheduling</td>
<td>Updates of archive servers with changes made to replication schedules</td>
</tr>
</tbody>
</table>
Index server administration  Administration of the indexing service for content searches

Data import/export  Execution of data import and export rules at predefined intervals

It is recommended that you install the database server on the same system as Microsoft SQL Server. You can install it on another system, but some network overhead may occur.

Before Installing the Database Server

- Ensure that the database server has access to the archive server over TCP port 3030 and to the SQL Server over TCP port 1433.
- Obtain the following information:
  - SQL Server name
  - Name and password of an SQL user account with read/write access

If you do not know the name of a user with read and write access, you can use the SQL sa account that has these permissions. You can also create a login for this purpose. For details, see Changing the SQL Server Login Account.

Performing the Database Server Installation

1. Log in locally or remotely as a user with local administrative rights on the system where you are installing the database server.
2. Begin the installation, as described in Initiating SOLIDWORKS PDM Installations.
3. Complete the installation using these instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Server Installation</strong></td>
<td>Select <strong>Database Server</strong> and click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>You can install multiple server components on the same system.</td>
</tr>
<tr>
<td></td>
<td>If you want to install SOLIDWORKS PDM client on the machine, you must also select <strong>Client</strong>. For details on client installation, see <em>Installing Clients using the Installation Wizard</em>.</td>
</tr>
</tbody>
</table>

**SOLIDWORKS PDM Database Server SQL Login**

- Enter the name of the SQL server to host the file vault databases.

  If the SQL server is running on a named instance, enter the server name in the format: `servername\instancename`

- In the **Login name** field, type the name of an SQL user on the server who has read and write access (i.e., db_owner permission) to all SOLIDWORKS PDM databases hosted on the SQL server (the file vault databases and **ConisioMasterDb**).

- In the **Password** field, enter the SQL user's password.

- Click **Next**.

  The login information is not validated. Ensure that the SQL server name and credentials are valid otherwise database server updates such as notifications fail to process.

**Ready to Install the Program**

Click **Install**.

**Install Shield Wizard Completed**

Click **Finish**.
Installing SOLIDWORKS PDM Archive Server

The archive server hosts the physical files (drawings, documents, etc.) stored in a file vault and manages users and their credentials.

All clients using SOLIDWORKS PDM must connect to one or more archive servers hosting one or more file vault archives.

The archive server runs as a service on the system account of the computer where it is installed, sending and receiving files between the clients and the file vault archive. It also stores passwords and user login information. Only one archive server installation is required per computer, hosting one or more file vault archives.

In a replicated environment, multiple archive servers can be set up to host replicated copies of the same file vault archive. See the SOLIDWORKS PDM Professional Replication Guide.

To prevent problems attaching to the archive server, the server name should be 15 characters or less.

Before Installing the Archive Server

Set up the users, accounts, and permissions required to complete the archive server installation.

<table>
<thead>
<tr>
<th>Archive folder access</th>
<th>The system account must have full access rights to create folders and files under the folder to be designated as the archive folder. The archive folder can also be on a network share that allows the archive server service to both read and write files.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>You can change the archive server service log-on account to users other than the system account in the service properties.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>SQL user account</th>
<th>The SQL user that communicates with file vault databases must have at least db_owner permissions to any existing file vault databases on the SQL Server. You can use the sa account that was created when the SQL Server was installed. For more information about SQL logins, see Changing the SQL Server Login Account.</th>
</tr>
</thead>
</table>


If you want to assign user and group access rights to the archive server during the installation, create the users and groups before you begin.

To use domain users, create a domain group on the domain controller and add domain users that should be able to log into SOLIDWORKS PDM Professional.

- During installation, add the domain group using the Find User or Group dialog; the users will appear in the SOLIDWORKS PDM administration tool.
- After installation, you can run the Archive Server Configuration tool to add or change user and group assignments.

## Performing the Archive Server Installation

1. Login as a user with local administrative rights on the system where you are installing the archive server.
2. Begin the installation, as described in **Initiating the Installation via the InstallShield Wizard** on page 43.
3. Complete the installation using the following instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Server Installation</strong></td>
<td>Select <em>Archive Server</em> and click <strong>Next</strong>. You can install multiple server components on the same system.</td>
</tr>
<tr>
<td></td>
<td>If you want to install SOLIDWORKS PDM client on the machine, you must also select <em>Client</em>. For details on client installation, see <em>Installing Clients using the Installation Wizard</em>.</td>
</tr>
<tr>
<td><strong>Ready to Install the Program</strong></td>
<td>Click <strong>Install</strong>. If you see a message that your local security network access is set to “Guests only” and should be changed to “Classic,” click <strong>Yes</strong> to accept the change.</td>
</tr>
<tr>
<td></td>
<td>If it is new install, when the installation finishes, the Archive Server Configuration wizard appears.</td>
</tr>
<tr>
<td><strong>Archive Server Configuration Wizard</strong></td>
<td>Click <strong>Next</strong>. The archive folder path is assigned the name <em>Archives</em>, which is used when setting up or attaching to a file vault from the View Setup wizard on a client.</td>
</tr>
<tr>
<td><strong>Welcome</strong></td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td><strong>Archive folder</strong></td>
<td>a. Do one:</td>
</tr>
<tr>
<td></td>
<td>• Accept the default location for the archive folder.</td>
</tr>
<tr>
<td></td>
<td>• Change the location by doing one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Browse</strong> and browse to a folder.</td>
</tr>
<tr>
<td></td>
<td>• Type the path.</td>
</tr>
<tr>
<td></td>
<td>If the folder you specified does not exist, you are asked if it should be created.</td>
</tr>
<tr>
<td></td>
<td>The archive folder path is assigned the name <em>Archives</em>, which is used when setting up or attaching to a file vault from the View Setup wizard on a client.</td>
</tr>
<tr>
<td></td>
<td>You must include the archive folder and its subfolders (i.e., file vault archives) in the daily backup routines.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
</tbody>
</table>
### Archive Server Configuration Wizard

| **Admin password** | a. Type and confirm a password for the Admin user.  
  The Admin user account is assigned full administrative rights to file vaults. Admin can create users, set up workflows, delete files, etc. It is the only user present in a newly created file vault.  
  You can change the password at any time using the Archive Server Configuration tool.  
  b. Click **Next**. |
|-------------------|--------------------------------------------------------------------------------------------------|
| **SQL user login and password** | a. Type the login information for the SQL user who will communicate with the file vault databases hosted on the SQL Server.  
  You can use the SQL Server system administrator user **sa**.  
  If you specify an SQL user with low permissions on the SQL Server, this user will be assigned db_owner access to any new file vaults created.  
  b. Click **Next**. |
| **Security** | To define the Windows user accounts that are allowed access to this archive server, by select the accounts under **Available users and groups** and click the arrow pointing to **Administrative access** or **Attach access**.  
| **Available users and groups** | All local users and groups found on the system are listed by default.  
  To add domain accounts to the list:  
  a. Click **Find User or Group**.  
  b. In the Find User or Group dialog box, search for additional user or group accounts. To add a domain group, for example, type **domain\groupname** and click **OK**. |
| **Administrative access** | Provides sufficient access to create new file vaults, or remove, attach, or upgrade existing file vaults on this archive server.  
  When you create a file vault, enter the username and password of an account added to this section. |
| **Attach access** | Provides sufficient access to attach to existing file vaults managed by this archive server.  
  When you create a file vault view or connect to a file vault, enter the username and password of an account added to this section. |
## Archive Server Configuration Wizard

### Login type

Select one of the following authentication methods to use by default when creating new file vaults managed by this archive server:

<table>
<thead>
<tr>
<th>Login type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>SOLIDWORKS PDM login</strong></td>
<td>SOLIDWORKS PDM user names and passwords are stored on the archive server. You can add and remove them using the administration tool on SOLIDWORKS PDM client.</td>
</tr>
</tbody>
</table>
| **Windows login** (SOLIDWORKS PDM Professional only) | Synchronizes logins to a file vault with the logged-in Windows users (Active Directory). Passwords and names are defined using standard Windows account management. In the Windows login settings dialog box, select accounts under **Available users and groups** and add them to **Added users and groups** by clicking the right-arrow button. To add domain accounts to the list:  
  a. Click **Find User or Group**.  
  b. In the Find User or Group dialog box, search for additional user or group accounts. To add a domain group, for example, type domain\groupname and click **OK**. |
| **LDAP login** (SOLIDWORKS PDM Professional only) | Retrieves user accounts from a server using the LDAP method (for example, Novell servers). The users are available when adding users to a file vault using the administration tool. Passwords and user names are defined on the LDAP server managing the accounts. To define the connection settings to the server using LDAP: |

| Server name | Type the name or IP address of an LDAP server. |
| Port | Type the port used for LDAP on the server. The default port is 389. |
| Contexts | Add at least one context with users that should be listed in the user manager. The context names must be entered as distinguished names; for example, O=company, OU=department, O=company or CN=Users, DC=company, DC=com. |
| User Context | Type a context for the user login used by the archive server to connect to the LDAP server. |
**Archive Server Configuration Wizard**

<table>
<thead>
<tr>
<th>Username</th>
<th>Type a username that exists in the user context selected. This user is used by the archive server to connect to the LDAP server.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Password</td>
<td>Type the password for the selected user.</td>
</tr>
</tbody>
</table>

Completed

Click **Finish**.

**Opening Ports for Client/Server Communication**

Windows Server and Windows 10 have built-in firewalls activated by default. These can restrict network access to applications requiring connections over the TCP/IP interface.

The archive server uses TCP port 3030 to communicate with the clients. This port must be fully opened in the firewall for a SOLIDWORKS PDM installation to accept incoming connections. If the port is not opened, the archive server is not available.

Recommendation: Allow inbound traffic on the corresponding UDP ports to allow the servers to broadcast (announce themselves) on the network. For example, by showing the name in a list for users to attach to a server from a client.

To allow the SQL server to communicate with clients, you must open TCP ports 1433 and 1434.

To check out a client license, you must open ports 25734 and 25735 on the SolidNetWork License Server.

This table summarizes the ports that must be reachable. You open the firewall ports on the listening/receiving side.

<table>
<thead>
<tr>
<th>Listening and Receiving</th>
<th>Communication Originating From</th>
<th>Client</th>
<th>Archive Server</th>
<th>Database Service</th>
<th>SQL Server</th>
<th>Web Server</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Client</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Archive Server</td>
<td>3030</td>
<td>3030</td>
<td>3030</td>
<td>3030</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Database Service</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SQL Server</td>
<td>1433/1434</td>
<td>1433/1434</td>
<td>1433/1434</td>
<td>1433/1434</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SNL Server</td>
<td>25734/25735</td>
<td></td>
<td></td>
<td></td>
<td>25734/25735</td>
<td></td>
</tr>
</tbody>
</table>

Microsoft disables outbound filtering by default. However, your administrators may have created outbound rules that restrict traffic to applications that are approved on your organization's network. If a SOLIDWORKS PDM client or replicated server cannot reach the SQL server or Archive server, make sure that the network administrator has not restricted access to the server ports in the Windows firewall settings.
SOLIDWORKS PDM Standard vaults use SQL Server Express that listens to a dynamic port by default. Set the SQL Server instance to a static port that you open in the firewall. This is also applicable to the additional named SQL Server instances. For details, see Configuring the SQL Server Express Instance to Listen to a Fixed TCP Port.

Opening Ports on Windows and Windows Server Systems

You use Windows Firewall with Advanced Security to open the ports needed to communicate with clients.

You create port rules that enable TCP and UPD ports for inbound SOLIDWORKS PDM traffic.

Open the ports for the archive server first. Then follow the same instructions to open the ports for the SQL server and Web Server.

To open the ports for the archive server:

1. Open the Control Panel.
2. On the Adjust your computer’s settings page, click System and Security.
3. In the right pane, click Windows Firewall.
4. In the left pane, click Advanced settings.
5. In the right pane, under View and create firewall rules, click Inbound Rules.
6. In the far right pane, under Actions, Inbound Rules, click New Rule.
7. In the New Inbound Rule Wizard, on the Rule Type screen, in the right pane, select Port and click Next.
8. In the right pane of the Protocol and Ports screen:
   a) Select TCP.
   b) Select Specific local ports and type 3030.
   c) Click Next.
9. In the right pane of the Action screen, select Allow the connection and click Next.
10. In the right pane of the Profile screen, clear Public and click Next.
11. In the Name screen, for Name, type the exception name – for example, Enable TCP port 3030 for inbound SOLIDWORKS PDM traffic and click Finish.

   The wizard closes and the rule is added to the list of inbound rules. It is enabled by default.

12. Repeat steps 6 through 11 to create an inbound rule for UDP port 3030.
13. On the system hosting the SQL Server, repeat steps 6 through 12 to create inbound TCP and UDP rules for ports 1433 and 1434.
14. On the system hosting the SolidNetwork License Server, repeat steps 6 through 12 to create inbound TCP rules for ports 25734 and 25735.
15. On the system hosting the Web Server, repeat steps 6 through 12 to create inbound TCP and UDP rules for ports 80 and 443.
16. Click File > Exit to close the Windows Firewall with Advanced Security window.
17. Close the Control Panel.
Adding Archive Servers in a WAN Environment

SOLIDWORKS PDM clients are normally set up to communicate with the Archive Server and SQL server using the server system names. These system names are resolved to IP addresses.

If this name lookup fails or is slow it can cause the following problems:

- Clients cannot find the servers at all. This is a common problem when using subnets or WAN configurations.
- Overall performance using SOLIDWORKS PDM features such as logging in, browsing, or adding files is slow.
- In case of SOLIDWORKS PDM Professional, replication between servers fails.

Verifying That the Server Name Can Be Resolved

To ensure optimal performance, make sure that the DNS server configuration is set up to resolve names correctly and efficiently.

1. Open the command prompt by clicking **Start > Run > CMD**.
2. Type `Ping server_name`. If the server can be reached by name, a reply with the server IP address appears. For example:
   ```
   PING SRV-DEV-15
   Reply from 192.168.1.71: bytes=32 time<1ms TTL=128
   ```
3. Verify that the correct IP is returned. If DNS returns the wrong IP address, a different system than the server responds. If the server name cannot be resolved, the DNS server configuration is not correctly configured. For example:
   ```
   PING SRV-DEV-15
   Ping request could not find host SRV-DEV-15. Please check the name and try again.
   ```

Configuring the Hosts File to Resolve the Server Name

If the DNS servers cannot be configured or performance is still bad, update the client’s hosts file with the correct server name and IP address. This ensures that the hosts file is queried for the server address directly instead of waiting for the DNS name resolve.

**To configure the hosts file to resolve the server name:**

1. On the SOLIDWORKS PDM client, locate the **Hosts** file. The default location is:
   ```
   C:\Windows\System32\Drivers\Etc\n   ```
2. Open the file as an administrator in a text editor (for example, Notepad).
3. Add a new line and enter the server IP address followed by the server name. For example:
   ```
   192.168.1.71 SRV-DEV-15
   ```
4. Repeat Step 3 for any additional servers used by SOLIDWORKS PDM.
5. Save and close the hosts file.

Installing and Configuring SolidNetWork Licensing

SOLIDWORKS PDM manages licensing using SolidNetWork License (SNL) Manager. Installing SolidNetWork Licensing includes:

- Installing the SolidNetWork License Manager.

  If you already have a SolidNetWork License Manager installed for SOLIDWORKS, you can use it with SOLIDWORKS PDM. You must ensure that it is updated to the SOLIDWORKS PDM release version.

- Activating client licenses.
- Configuring the SolidWorks NetWork License server for use with the file vault.
- Ensuring that the SolidNetWork License server is accessible to all clients.

Installing a SolidNetWork License Manager

You use the SolidNetWork License serial number to install the SolidNetWork License Manager on a server that is accessible to all clients, preferably the SQL database server. The SolidNetWork License software is included with the SOLIDWORKS installation media.

To install SolidNetWork License Manager from the standalone installer:

1. Change directory to the appropriate setup folder on the SOLIDWORKS installation media.
2. Cancel SOLIDWORKS Installation Manager, if it starts.
3. Start the installation by running `swlicmgr\setup.exe`.
4. Enter the SolidNetWork License serial number.
   If you have multiple serial numbers, enter and separate them by comma.
5. Retain the default install folder and click **Next**.
6. Click **Install**.

Activating a SolidNetWork License

You can activate a SolidNetWork License to log in to the SOLIDWORKS PDM vault as a client.

To activate the SolidNetWork License:

1. From the Windows **Start** menu, click **SOLIDWORKS Tools version** > **SolidNetWork License Manager Server version** to start the SolidNetWork License Manager.
2. When prompted to activate, click **Yes**.
   If you have an activated SolidNetWork License, click **Modify**.
3. On the SolidNetWork License Server Information screen:
   • If your company uses a firewall, select **A firewall is in use on this server**. For more information, see *Using SolidNetWork License Server with Firewalls* on page 56.
   • Use the default value for **Port Number** (and for **Vendor Daemon Port Number** if you have a firewall) or specify the port numbers your company uses.

   The port number is a TCP/IP port number in the 1024-60000 range, used exclusively by this process. Normally, the default (25734) is suitable and is unlikely to be the same as any other FlexNet server process available on the license manager server.

4. On the Activate Your SOLIDWORKS Product screen:
   • Select the internet or email procedure.
   • Supply email contact information.
   • Click **Next** to proceed.
     • Internet: Activation occurs automatically.
     • Email: Press **Save** to create a request file, then send the file to activation@solidworks.com. When you receive the email containing the response file, extract the file from email and then click **Open** to load it.

   If required, you can exit and rerun the activation procedure to open the response file.

5. Click **Finish**.

*Using SolidNetWork License Server with Firewalls*

If your server uses a firewall, you must configure ports to support SolidNetWork Licensing.

You must configure the firewall on the server side.

*Modifying SolidNetWork License Manager Settings for Windows Firewall*

If you are using Windows Firewall, you must modify the SolidNetWork License file to use the firewall ports to distribute licenses to the license client computers.

1. From the Windows **Start** menu, click **SOLIDWORKS Tools version > SolidNetWork License Manager Server version** to start the SolidNetWork License Manager.
2. On the Server Administration tab, under **License Server**, click **Stop**. (Click **Yes** when prompted for confirmation and **OK** to complete stopping the license server.)
3. Under **License Information**, click **Modify**.
4. Under **Server Type**, select the server arrangement for your network (**Single** or **Triad**) and then click **Next**.
5. **Under Server Information:**
   a) Select **A firewall is in use on this server.**
   b) Port Number and Vendor Daemon Port Number should contain the port numbers specified for the Windows Firewall.
   c) Select **Options File** and click **Browse** to locate the file. Click **Edit** to change any of its parameters.

   The options file allows the license administrator to control various operating parameters of FlexNet Licensing.

   Recommendation: The location for the options file is in the SolidNetWork License Manager installation directory
   (SolidNetWork_License_Manager_install_dir\Licenses \sw_d.opt). This file must be in the same directory as the sw_d.lic file.

   For more information about the options file, see the FlexNet Publisher **License Administration Guide** in the SolidNetWork License Manager installation directory (\Docs\flexuser\licensingenduserguide.pdf).

d) Click **Next** and then click **Finish**.

6. On the Server Administration tab, under **License Server**, click **Start**.

7. Click **OK** to close the **SolidNetWork License Manager**.

**SolidNetWork License Administration**

Tasks include starting, upgrading, and uninstalling the license manager licenses.

Starting the SolidNetWork License Manager

You can start the SolidNetWork License Manager from the Windows **Start** menu.

From the Windows **Start** menu, click **SOLIDWORKS Tools version > SolidNetWork License Manager Server version**.

Upgrading the SolidNetWork License Manager

For major releases of SOLIDWORKS PDM, upgrading the license manager consists of uninstalling the old license manager, installing a new one, andreactivating the SolidNetWork License.

**To upgrade the SolidNetWork License Manager:**

1. From the Windows **Start** menu, click **SOLIDWORKS Tools version > SolidNetWork License Manager Server version** to start the SolidNetWork License Manager.
2. On the License Usage tab, verify that no client computers on the network are running SOLIDWORKS PDM.
3. Uninstall the old license manager. For details, see **Uninstalling the SolidNetWork License Manager**.
4. Install the new license manager and reactivate the SolidNetWork License on the license manager server. For details, see **Installing a SolidNetWork License Manager** on page 55.
Uninstalling the SolidNetWork License Manager

If you want to upgrade the SolidNetWork License Manager, you must uninstall it before installing the new one. If you want to transfer the SolidNetWork License to another server, you must transfer it before removing it from this server.

1. From the Windows Start menu, click SOLIDWORKS Tools version > SolidNetWork License Manager Server version to start the SolidNetWork License Manager.
2. Verify that no clients on the network are running SOLIDWORKS PDM.
   The License Usage tab shows the clients using the licenses.
3. On the Server Administration tab, under License Server, click Stop.
4. Click OK to exit the license manager.
5. In Windows, open Control Panel > Programs > Programs and Features.
6. Select SOLIDWORKS SolidNetWork License Manager, click Uninstall, and confirm the deletion.

You now are ready to install a new version of the license manager. For details, see Installing a SolidNetWork License Manager and Activating a SolidNetWork License on page 55.

Transferring a SolidNetWork License

To transfer a SolidNetWork License to a new or upgraded server, first transfer the license to the license key server at Dassault Systèmes SolidWorks Corporation, then reactivate it on the other server.

If you were unable to transfer the license to Dassault Systèmes SOLIDWORKS Corporation (because of hard disk drive failure, for example), reactivation is still successful in most cases. If not, contact your VAR for help.

You can have only one activated SolidNetWork License server per serial number.

To transfer a SolidNetWork License back to the server:

1. From the Windows Start menu, click SOLIDWORKS Tools version > SolidNetWork License Manager Server version to start the SolidNetWork License Manager.
2. Under License Information, click Modify. The SOLIDWORKS Product Activation wizard starts.
3. Under What would you like to do?, select Transfer a software license and then click Next.
4. Under How would you like to transfer?, select Automatically over the internet (recommended).
5. Under Contact Information, specify an email contact address.
6. Click Next. The product license transfer completes.
Installing Temporary Licenses

You can use the temporary "ANY" license temporarily when the original SolidNetWork License is not available.

By installing the "ANY" license file, you agree to implement the traditional license on receipt of a SolidNetWork license from Dassault Systèmes SolidWorks Corporation. Compliance with license restrictions still is required.

To install an "ANY" license:

1. If you are an existing SolidNetWork user, uninstall the SolidNetWork License Manager and delete the installation folder. For details, see Uninstalling the SolidNetWork License Manager on page 58.
2. Install the SolidNetWork License Manager from SOLIDWORKS PDM installer.
   You can also install the SolidNetWork License Manager from a stand-alone installer. For details, see Installing a SolidNetWork License Manager on page 55.

   a) On the SOLIDWORKS SolidNetWork License Manager Setup page, enter the SolidNetWork License serial number and click Next.
   b) Click Install.
4. If you are prompted to activate, click No.
   The Server Administration tab of the SOLIDWORKS SolidNetWork License Manager appears.
5. Under Advanced Options, click Options.
   The Advanced Options dialog box appears.
6. Under SolidNetWork Server License Mode, click Use a License File and click OK.
   The Advanced Options dialog box closes.
7. Under License Information, click Modify.
   The SolidNetWork License File Wizard appears.
8. Under Server Type, select Single and click Next.
9. When you see this message:
   Could not read the dongle ID number. Click Cancel.
   The ID "ANY" appears automatically.

   If your computer uses a firewall, you might have to make some additional specifications on this screen. For more information, see Using SolidNetWork License Server with Firewalls on page 56.
10. Continue with the installation.
Troubleshooting SolidNetWork Licenses

If the SolidNetWork License Manager installation fails, check for these possible explanations.

Accessing the SolidNetWork License log files

When a license error occurs, the answer often appears in the
SNL_Manager_install_dir\lmgrd.log file.

Could not obtain a license for SOLIDWORKS PDM or Cannot connect to license server

Typically, these problems are caused by port settings.

- Port settings between the SolidNetWork License Manager and the license client might not match.
- Additional port settings for multiple versions of SolidNetWork License Managers might not have been specified.
- Check that the client machine can accurately resolve and route to the server, given the server name. Also, check that the server can accurately resolve and route to the client, given the client machine name.
- Check that the port number in the log file under Server Administration tab is correct.
- Check that the firewall on the SolidNetWork License server does not block the port access.

When a log error occurs, you can check the Log File in the Administration tool.

Licensing

License Types

SOLIDWORKS PDM uses floating client licenses. When you log in to a vault, the license installed on your system is taken from a pool of licenses that are managed by the SolidNetWork License Server. When you log out or exit SOLIDWORKS PDM, the license is returned to the pool and can be used by another client.

Licenses for SOLIDWORKS PDM Professional

<table>
<thead>
<tr>
<th>License</th>
<th>License Types Included</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLIDWORKS PDM Professional CAD Editor &amp; Web</td>
<td>Editor: Supports working with all file types, including enhanced management and previewing of CAD formats such as SOLIDWORKS. CAD add-ins allow users to access SOLIDWORKS PDM Professional functionality from within the CAD application. Web: Remote users can use the WEB client to search the vault and perform basic functions to enable remote work processes.</td>
</tr>
</tbody>
</table>
### License Types Included

<table>
<thead>
<tr>
<th>License</th>
<th>License Types Included</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLIDWORKS PDM Professional Contributor &amp; Web</td>
<td>Contributor: Users on a local area network (LAN), wide area network (WAN or virtual private network (VPN)) can perform the same functions as with the Editor license type, except that CAD add-ins are not enabled. Web: Remote users can use the WEB client to search the vault and perform basic functions to enable remote work processes.</td>
</tr>
<tr>
<td>SOLIDWORKS PDM Professional Viewer</td>
<td>Allows read-only access to vaults. Users cannot add or modify (check out, check in, update values) files or use CAD add-ins.</td>
</tr>
</tbody>
</table>

### Licenses for SOLIDWORKS PDM Standard

<table>
<thead>
<tr>
<th>License</th>
<th>License Types Included</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOLIDWORKS PDM Standard CAD Editor</td>
<td>Supports working with SOLIDWORKS, DWG/DXF format, Microsoft Word, and Microsoft Excel files. All file formats that Office plug-in handles behave in the same way in SOLIDWORKS PDM Standard except Preview.</td>
</tr>
<tr>
<td>SOLIDWORKS PDM Standard Contributor</td>
<td>Supports working with SOLIDWORKS, DWG/DXF format, Microsoft Word, and Microsoft Excel files.</td>
</tr>
<tr>
<td>SOLIDWORKS PDM Standard Viewer</td>
<td>Allows read-only access to file vaults; user cannot add or modify (check out, check in, update values) files.</td>
</tr>
</tbody>
</table>

### Changing the Client License Type

You select the client license type during installation.

To change the license type, you must have local administrative permissions to Windows.

You can change the license type by:

- Using **Control Panel > Programs > Uninstall a program** to remove SOLIDWORKS PDM and then reinstalling.
- Opening the Uninstall or change a program dialog box, and selecting **SOLIDWORKS PDM Client > Change**. In the SOLIDWORKS PDM Installation Wizard, select **Modify**.

In the Uninstall or change a program dialog box, **SOLIDWORKS PDM Client** or **SOLIDWORKS PDM Server** is listed if you have installed SOLIDWORKS PDM using MSIs. You must modify SOLIDWORKS installation if you have installed SOLIDWORKS PDM using SLDIM.

- Using the About SOLIDWORKS PDM dialog box.
To change the client license type from the About SOLIDWORKS PDM dialog box:
1. Click Help > SOLIDWORKS PDM Administration.
2. Use the Client type drop-down list to select a different client license type.
3. Click OK.
4. When instructed to restart your computer, click OK.
5. Restart your computer.

Depending on the license type that was used when the client was installed, changing to the CAD Editor license type from the About SOLIDWORKS PDM dialog box might not enable the CAD Add-in. If it does not, remove SOLIDWORKS PDM as described above and select SOLIDWORKS PDM CAD Editor when you reinstall.

Viewing Version Information for Non-client Systems

To find the version of SOLIDWORKS PDM software on a server that does not have a client installed:
1. Open the Control Panel > Programs > Uninstall a program.
2. Click SOLIDWORKS PDM Server.
   The Version column displays the currently installed version.

Viewing Version Information for Client Systems

To find the version of SOLIDWORKS PDM software on a client:
1. Log in to the SOLIDWORKS PDM Administration tool.
2. Click Help > SOLIDWORKS PDM Administration.
3. View the Client version and click OK.

Adding and Modifying SolidNetWork License Server

To log in to a vault from a SOLIDWORKS PDM client, a license that matches the installed license type and version must be available. The license is retrieved from the SolidNetWork License server that is defined in the license setting. To add or modify SolidNetWork License server, you use the Set License dialog box available from the Administration tool.

To add or modify license server:
1. From the Windows Start menu, click SOLIDWORKS PDM > Administration.
2. In the Administration tool, create a file vault or expand the existing file vault.
3. Right-click the License node and select Open.
5. Enter the SolidNetWork License Manager’s address in the form: port@SNLServerName
   The default port number is 25734. You can enter either the host name or IP address of the SolidNetWork License server for SNLServerName. Ensure that all clients are able to connect to the server by IP address or host name.
6. Click OK.
7. Click the License Usage tab to ensure that SOLIDWORKS PDM licenses are available.
8. Click OK.
Set License Dialog Box

Use the Set License dialog box to add or modify license servers. To log in to a vault from a SOLIDWORKS PDM client, a license that matches the currently installed license type and version must be available.

To open this dialog box, do one of the following:
• Double-click License.
• Right-click License and select Open.

Server

<table>
<thead>
<tr>
<th>Server List</th>
<th>Lists the SolidNetWork License servers. For example, Port@SNLServerName</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Add</th>
<th>Lets you add license servers.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Remove</th>
<th>Lets you remove selected license servers.</th>
</tr>
</thead>
</table>

License Usage

<table>
<thead>
<tr>
<th>Server</th>
<th>Lets you select the SolidNetWork License server.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product</td>
<td>Lets you select the SOLIDWORKS PDM license type to view license details. See License Types on page 60.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Total licenses</th>
<th>Shows total number of licenses.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Free licenses</td>
<td>Shows number of available licenses.</td>
</tr>
<tr>
<td>Licenses used by</td>
<td>Shows details of used licenses.</td>
</tr>
<tr>
<td>----------------</td>
<td>---------------------------------------------------------------------</td>
</tr>
</tbody>
</table>

Installing SOLIDWORKS PDM Web2 (For SOLIDWORKS PDM Professional only)

Web2 lets users connect to SOLIDWORKS PDM Professional vault from the most devices with an Internet browser. Web2 client is beneficial for external and internal users who are not connected to their office network or have an unsupported operating system.

Before Installing Web2

The following components must be installed to install Web2:
• Microsoft .NET 4
• Microsoft Internet Information Services 7 or higher versions (IIS)
You must install the SOLIDWORKS PDM client and create the local vault view that is accessed by Web2 on the server running IIS.

- Windows Server 2016 or higher operating systems
- Microsoft Visual C++ 2013 runtime

Installing Microsoft .NET Framework 4.0


Enabling Microsoft IIS on Windows 10

Recommendation: Do not use Microsoft Windows 10 for running SOLIDWORKS PDM Web2 in a production environment.

To enable Microsoft IIS on Windows 10:

1. In Windows, open **Control Panel > Programs > Programs and Features > Turn Windows features on or off**.
2. In the dialog box, turn on **Internet Information Services**.
3. Expand **Web Management Tools** and select **IIS Management Console**.
4. Expand **World Wide Web Services** and select the following options:

<table>
<thead>
<tr>
<th>Folder</th>
<th>Option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Development</td>
<td>.NET Extensibility 4.5</td>
</tr>
<tr>
<td></td>
<td>ASP.NET 4.5</td>
</tr>
<tr>
<td></td>
<td>ISAPI Extensions</td>
</tr>
<tr>
<td></td>
<td>ISAPI Filters</td>
</tr>
<tr>
<td></td>
<td>Server-Side Includes</td>
</tr>
<tr>
<td>Common HTTP Features</td>
<td>Static Content</td>
</tr>
<tr>
<td></td>
<td>Default Document</td>
</tr>
<tr>
<td></td>
<td>Directory Browsing</td>
</tr>
<tr>
<td></td>
<td>HTTP Errors</td>
</tr>
<tr>
<td>Health and Diagnostics</td>
<td>HTTP Logging</td>
</tr>
<tr>
<td>Performance Features</td>
<td>Static Content Compression</td>
</tr>
<tr>
<td>Security</td>
<td>Request Filtering</td>
</tr>
</tbody>
</table>
Performing the Web2 Server Installation

**To perform the Web2 server installation:**
1. Log on to the IIS system as a user with local administrative rights.
2. Browse to the installation media.
3. In the SWPDMServer folder, run \SWPDMServer\setup.exe.
4. Follow the instructions on the installation screens until you get to the Select PDM Product screen.
5. On the Select PDM Product screen, select SOLIDWORKS PDM Professional.
6. On the Server Installation screen, select **Web2 Server** and **Client**.
   - The Web2 server requires a client be installed on the same machine.
   - The client type must be a Contributor or CAD Editor if files are to be edited or added via Web2. If Web2 users are limited to Viewer functions only, a Viewer client must be installed or enabled on the server (regardless of the license type they choose on the log in screen).
   - You can install multiple server components on the same system.
7. On the Ready to Install the Program screen, click **Install**.
8. On the Install Shield Wizard Completed screen, click **Finish**.

SOLIDWORKS PDM 2021 supports OLE objects (such as Microsoft® Visio®, Microsoft Word, or Microsoft® Excel®) in SOLIDWORKS files. To see the WebGL-based preview of these objects in Web2, you must install the OLE application on the Web2 server.

Creating a Vault View on the IIS Server Running Web2

You can create a local file vault view to the file vault that is accessible by the Web2 server.
- Ensure that the view is created as a Shared view for all users.
- Later in this process, you define a Windows user as an application pool identity. This user must have browsed into the vault view and right-clicked a file or a folder at least once to ensure add-ins and registry settings are properly registered.

If the vault is using a Windows login, you must disable Automatic login to the vault view on the Web2 server by doing the following:
1. Start the SOLIDWORKS PDM Administration tool.
2. In the left pane, expand **Local Settings > Settings**.
3. In the Automatic Login tab, select the vault that is accessed by Web2 from the **Vault** list.
4. Turn off **Use server default** and **Use automatic login for this vault**.
5. Click **OK**.
Configuring SOLIDWORKS PDM Web2

You can configure SOLIDWORKS PDM Web2 by accessing the Application Settings function in the IIS Manager or by editing the Web.config file that is located at \inetpub\wwwroot\SOLIDWORKSPDM\Web2.

Editing the Web.config File

To access the file vaults for which you have created local file vault views on the IIS server, you must update the VaultName and VisibleVaults keys in the Web.config file.

You can edit the XML-based Web.config file using Notepad or any XML editing application.

Ensure that the Web.config file is not read-only. When you edit Web.config file, ensure to include values inside double quotes.

1. Open Web.config in the XML editing application.
2. Add the primary vault name that you want to access via Web2 to the VaultName key. For example:
   
   <add key="VaultName" value="PDM_Pro_Vault">
   This name is case-sensitive.
   
3. Optional: To access multiple vaults, enter their names separated by | for VisibleVaults.
   
   <add key="VisibleVaults" value="PDM_Test|PDM_Pro_Vault" />
4. Optional: To control download permissions for users and groups, add and configure the following settings into the `<configuration>` node of the Web.config file.

```xml
<vaultSettings>
    <vault name="EPDM" defaultDelimiter="" denyDownloadGroups=""
        <user name="admin" denyDownload="false"/>
    </vault>
</vaultSettings>
```

<table>
<thead>
<tr>
<th>Vault setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>The name of the vault. Create a separate <code>&lt;vaultSettings&gt;</code> section for each vault that needs download permissions controlled.</td>
</tr>
<tr>
<td>defaultDelimiter</td>
<td>The delimiter used to separate group names in the <code>denyDownloadGroups</code> setting. The default delimiter is <code>. </code></td>
</tr>
<tr>
<td>denyDownloadGroups</td>
<td>The groups that can have download denied in the specified vault. Group names can be separated by the delimiter specified in the <code>defaultDelimiter</code> setting.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>User setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>The login name of the user. Create a separate <code>&lt;user&gt;</code> node for each user.</td>
</tr>
<tr>
<td>denyDownload</td>
<td>The setting to deny or allow download for the specified user. If set to <code>false</code>, the groups can download the files. If set to <code>true</code>, the groups cannot download the files.</td>
</tr>
</tbody>
</table>

5. Optional: To change the default login license type to Viewer, set `DefaultLicenseType` to "Viewer".

```xml
<add key="DefaultLicenseType" value="Viewer"></add>
```

Configuring Microsoft IIS

1. In the Windows **Start** menu, type IIS to open Internet Information Services (IIS) Manager.
2. In the left pane, expand the computer name, select **Application Pools**.
3. Right-click **SOLIDWORKS PDM Web2 > Advanced Settings**.
4. Ensure that **Load User Profile** is set to **True**.
5. In the Advanced Settings dialog box, click the button to set the **Identity**.
   a) In the Application Pool Identity dialog box, select *Custom account* and click **Set**.
   b) In the Set Credentials dialog box, type windows credentials of the user that has currently logged into windows or a user that has logged into the IIS system, browsed the file vault, and clicked a folder at least once.
   c) Click **OK** thrice.

If the password for this user changes, the application pool stops working until the user updates the password.

Ensure that the custom account user is a member of the **IIS_IUSRS** group:
Right-click **Computer > Manage > Local Users and Groups > Groups > IIS_IUSRS**.

Ensure that the custom account user is a member of the local **Administrators** group.

When you upgrade SOLIDWORKS PDM Web2 server, you must configure Microsoft IIS to modify the application pool, **SOLIDWORKS PDM Web2**.

Accessing Web2

You can access Web2 on a computer or on a mobile device.

Type the following URL into the address field of a web browser:

http://ComputerName/SOLIDWORKSPDM

If the Web2 login page is not displayed, ensure that the Windows firewall on the IIS server allows access over port 80 and the IIS server service is started.

Creating a New Web2 Application

When you install the Web2 server, a Web2 application named **SOLIDWORKSPDM** is automatically created under the default web site.

**To create a new Web2 application:**

1. Open the Internet Information Services (IIS) Manager.
2. In the left pane, expand the computer name and expand **Sites**.
3. Right-click **Default Web Site** and select **Add Application**.
4. In the **Alias** field, type a name.
   This alias is a part of the connection address to the Web2 application i.e. http://ComputerName/applicationalias.
5. Click **Select** and choose **SOLIDWORKS PDM Web2** for **Application pool**.
6. For **Physical path**, browse to inetpub\wwwroot\SOLIDWORKSPDM\Web2.
7. Click **OK** twice.

If you want to create separate Web2 URL addresses to access different vaults you can copy the inetpub\wwwroot\SOLIDWORKSPDM\Web2 and point the new application physical path to this copy. Update the Web.config in the copied folder with the vault name to access.
## Settings in the Application Settings Dialog Box

You can configure SOLIDWORKS PDM Professional by accessing the Application Settings function in the IIS Manager or by editing the `Web.config` file located in the application files.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Type</th>
<th>Default Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>AllowDataCardEdit</td>
<td>True/False</td>
<td>True</td>
</tr>
<tr>
<td>AllowLicenseChange</td>
<td>True/False</td>
<td>True</td>
</tr>
<tr>
<td>ClientValidationEnabled</td>
<td>True/False</td>
<td>True</td>
</tr>
<tr>
<td>ColumnSetName</td>
<td>Text</td>
<td>Explorer</td>
</tr>
<tr>
<td>DateFormat</td>
<td>Text</td>
<td>MM/dd/yy</td>
</tr>
<tr>
<td>DefaultLanguage</td>
<td>Text</td>
<td>en</td>
</tr>
<tr>
<td>DefaultLicenseType</td>
<td>Text</td>
<td>Web</td>
</tr>
<tr>
<td>EditableDataCardVariables</td>
<td>Text</td>
<td>*</td>
</tr>
<tr>
<td>FileUploadPath</td>
<td>Text</td>
<td>\Content\Uploads\</td>
</tr>
<tr>
<td>FreeSearch</td>
<td>True/False</td>
<td>False</td>
</tr>
<tr>
<td>OnlySearchLatestVersion</td>
<td>True/False</td>
<td>True</td>
</tr>
<tr>
<td>PreviewGenerationTimeOut</td>
<td>Number</td>
<td>30</td>
</tr>
<tr>
<td>RememberMe_Days</td>
<td>Number</td>
<td>7</td>
</tr>
<tr>
<td>RememberMe_Visible</td>
<td>True/False</td>
<td>True</td>
</tr>
<tr>
<td>SearchDataCardVariables</td>
<td>Separated text list</td>
<td>Comment</td>
</tr>
<tr>
<td>UnobtrusiveJavaScriptEnabled</td>
<td>True/False</td>
<td>True</td>
</tr>
<tr>
<td>VaultName</td>
<td>Text</td>
<td>SWPDM</td>
</tr>
<tr>
<td>VisibleVaults</td>
<td>Separated text list</td>
<td>SWPDM_Test</td>
</tr>
</tbody>
</table>
### Variables in the Application Settings Dialog Box

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AllowDataCardEdit</td>
<td>If you set this variable to True, you can edit the value of data fields with checkout permissions assigned. Use this setting with the EditableDataCardVariables setting that controls variables to be edited.</td>
</tr>
<tr>
<td></td>
<td>SOLIDWORKS PDM Web2 does not automatically update all configuration values. Variable values that are set using transition actions update all configurations as specified.</td>
</tr>
<tr>
<td>AllowLicenseChange</td>
<td>If this variable is set to True, you can change the license type to use either the Web or Viewer license. If this variable is set to False, you can use only the license type specified by the DefaultLicenseType setting.</td>
</tr>
<tr>
<td>ClientValidationEnabled</td>
<td>Do not change.</td>
</tr>
<tr>
<td>ColumnSetName</td>
<td>SOLIDWORKS PDM Web2 displays the custom column set that is defined in your vault. You can display only one-column set and it is the same for all users.</td>
</tr>
<tr>
<td></td>
<td>Custom column sets that have columns defined as Name, Checked Out, Size, State, Modified, and Version are not supported because these names are reserved for default Web2 columns.</td>
</tr>
<tr>
<td>DateFormat</td>
<td></td>
</tr>
</tbody>
</table>
### Variable

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Controls the display of date fields in SOLIDWORKS PDM Web2. You can set the date using different delimiters. The following table describes options for displaying date fields:</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Month &quot;M&quot;</th>
<th>&quot;M&quot;&gt;1-12, &quot;MM&quot;&gt;01-12, &quot;MMM&quot;&gt;Dec, &quot;MMMM&quot;&gt;December</th>
</tr>
</thead>
<tbody>
<tr>
<td>Day &quot;d&quot;</td>
<td>&quot;d&quot;&gt;1-31, &quot;dd&quot;&gt;01-31, &quot;ddd&quot;&gt;Sat, &quot;dddd&quot;&gt;Saturday</td>
</tr>
<tr>
<td>Year &quot;y&quot;</td>
<td>&quot;y&quot;&gt;0-99, &quot;yy&quot;&gt;00-99, &quot;yyyy&quot;&gt;0000-9999</td>
</tr>
</tbody>
</table>

**Examples:**
- "MM/dd/yy">06/07/09
- "dddd, MMMM-d, yyyy">Sunday, June-7, 2009

### DefaultLanguage

Sets the default language, en, that appears in the first login. You can change the language from the Web2 user interface.

**The Web2 user interface displays the changed language until you clear internet cookies.**

The language codes used for this setting are:

<table>
<thead>
<tr>
<th>English</th>
<th>en</th>
<th>Spanish</th>
<th>es</th>
</tr>
</thead>
<tbody>
<tr>
<td>French</td>
<td>fr</td>
<td>Italian</td>
<td>it</td>
</tr>
<tr>
<td>Japanese</td>
<td>ja</td>
<td>Korean</td>
<td>ko</td>
</tr>
<tr>
<td>German</td>
<td>de</td>
<td>Polish</td>
<td>pl</td>
</tr>
<tr>
<td>Chinese simplified</td>
<td>zhs</td>
<td>Portuguese</td>
<td>pt</td>
</tr>
<tr>
<td>Chinese traditional</td>
<td>zht</td>
<td>Russian</td>
<td>ru</td>
</tr>
<tr>
<td>Czech</td>
<td>cs</td>
<td>Turkish</td>
<td>tr</td>
</tr>
<tr>
<td>Variable</td>
<td>Description</td>
<td></td>
<td></td>
</tr>
<tr>
<td>--------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SetsthedefaultlicensetypeforallusersontheWeb2loginpage. You can set the license type as Web or Viewer.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>EditableDataCardVariables</td>
<td>If AllowDataCardEdit is set to True, this setting controls variables to be edited. The default value is * that lets you edit all non-read-only variables. Separate multiple values with</td>
<td>Description and Number, enter “Description</td>
<td>Number”.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>FileUploadPath</td>
<td>When you upload new files or create new versions, SOLIDWORKS PDM Web2 copies the files to the Uploads folder. The full path to this folder depends on the location of Web2 application files. For example, if the Web2 application files are located in C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS PDM\Web2 then the path to the Uploads folder would be C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS PDM\Web2\Content\Uploads.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>FreeSearch</td>
<td>Enables SOLIDWORKS PDM Web2 to search all file and folder names, variable values, configuration names, comments, and labels.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>OnlySearchLatestVersion</td>
<td>When this option is set to True, the search finds values only in the latest versions.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>PreviewGenerationTimeOut</td>
<td>Controls how long the preview converter waits (in seconds) before ending the conversion operation. The minimum value for this setting is 30 seconds (with no limit on the maximum value). Large files and files with complex formatting or graphics take longer for the conversion process. Time out errors in the file preview page indicate that the conversion time required for a file exceeds this value. Increasing the timeout value allows the converter more time to complete the longer-running conversions.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RememberMe_Days</td>
<td>Sets the number of days the system remembers user login information for the vault name, license type, and user name.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>RememberMe_Visible</td>
<td>Controls the display of the Remember me check box on the log in screen.</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SearchDataCardVariables</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Variable Name and Variable Value Alias Settings

If a vault contains variable names that are not user friendly, you can set aliases so that the names that appear on the data card preview are meaningful.

For example: If a vault contains the variable, `PAR_NUM`, that holds a part number value, it is meaningful to display the variable as **Part Number** on the data card preview. You can set this in the property name alias setting.

The data card Preview page displays the variables and their values in list form. It does not display the data card as it appears in the thick clients or the existing web client, so any formatting, pictures, labels, and other card controls are not supported.

You can also specify an alias for the variable value. For example: If a text type variable is connected to a check box control that displays whether the file is a spare part or not, the values in SOLIDWORKS PDM Web2 appear as **1** or **0** depending on the check box selected or cleared. You can set the variable value to display **Yes** or **No** via the transform alias value settings.

Setting Variable Name Alias

1. **Open the Web.config file in either Notepad or an XML editing program.**

   <!-- Section used to handle property alias and value mappings -->
   `<propertySettings>  
   <property name="SPARE_PART" alias="Spare part">  
   <transform value="1" alias="Yes" />  
   <transform value="" alias="No" />
   </property>  
   </propertySettings>`

2. **Scroll down to the propertySettings section.**
3. Enter the following:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Action</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>Actual variable name</td>
<td>name=&quot;SPARE_PART&quot;</td>
</tr>
<tr>
<td>alias</td>
<td>Desired variable name</td>
<td>alias=&quot;Spare part&quot;</td>
</tr>
</tbody>
</table>

4. To set alias' for variable values, enter the actual values in the transform value attribute.
   This step is optional. You can delete the transform lines if the variable values do not need alias'.

<table>
<thead>
<tr>
<th>Alias</th>
<th>Value</th>
<th>Desired Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>value</td>
<td>&quot;1&quot;</td>
<td>alias=&quot;Yes&quot;</td>
</tr>
<tr>
<td>value</td>
<td>&quot;&quot;</td>
<td>alias=&quot;No&quot;</td>
</tr>
</tbody>
</table>

System Maintenance

You should monitor and empty two folders periodically for disk space availability.

The folders to be monitored are:

- **Uploads**: The folder in which the system adds files that are uploaded before they are copied into the vault.
- **tempFiles**: The folder that is located under the Content folder in the application file location and used for previewing purposes.

Installing SOLIDWORKS PDM Web API Server (For SOLIDWORKS PDM Professional Only)

EXALEAD® OnePart users can use Web API server to index and retrieve SOLIDWORKS PDM data.

They can install the Web API server on the same computer with other SOLIDWORKS PDM server components or separately on another computer.

**Before Installing the Web API Server**

You must install and enable Microsoft Internet Information Services 7 or higher versions (IIS).

**Performing the Web API Server Installation**

**To perform the Web API server installation:**

1. Log on to the IIS system as a user with local administrative rights.
Installing SOLIDWORKS PDM

2. Browse to the installation media.
3. Run \SWPDMServer\setup.exe to start the server install.
4. Follow the instructions on the installation screens until you get to the Select PDM Product screen.
5. On the Select PDM Product screen, select **SOLIDWORKS PDM Professional**.
6. On the Server Installation screen, select **Web API Server**.

   You can install multiple server components on the same system.

7. Optional: Specify a value for **HTTP port number** that is between 0 and 65535. The default value is 65453.
8. On the Ready to Install the Program screen, click **Install**.
9. On the InstallShield Wizard Completed screen, click **Finish**.

   The Web API server components are installed in the IIS directory.

Installing the SOLIDWORKS PDM Client

For a system to work with a SOLIDWORKS PDM file vault, it must have the SOLIDWORKS PDM client installed.

The following types of SOLIDWORKS PDM Professional client are available:

<table>
<thead>
<tr>
<th>SOLIDWORKS PDM Professional CAD Editor &amp; Web</th>
<th>Supports working with all file types, including enhanced management and previewing of many CAD formats such as SOLIDWORKS, AutoCAD, Inventor, SolidEdge, and Pro/ENGINEER. Should be used on any system working with CAD files.</th>
</tr>
</thead>
</table>

   To work with Pro/ENGINEER files, install the Pro/ENGINEER CAD add-in after installing the SOLIDWORKS PDM Professional client. The Pro/ENGINEER connector requires separate installation media. Contact your SOLIDWORKS Value Added Reseller for more information.

<table>
<thead>
<tr>
<th>SOLIDWORKS PDM Professional Contributor &amp; Web</th>
<th>Supports working with all file types, including CAD files. However, CAD add-ins are not supported on this client type. Includes support for SOLIDWORKS PDM Web client access.</th>
</tr>
</thead>
</table>

| SOLIDWORKS PDM Professional Professional Viewer | Allows read-only access to file vaults; user cannot add or modify (check out, check in, update values) any files. CAD add-ins are not supported on this client type. |

The following types of SOLIDWORKS PDM Standard client are available:

<table>
<thead>
<tr>
<th>SOLIDWORKS PDM Standard CAD Editor</th>
<th>Supports working with SOLIDWORKS, DWG/DXF format, and Microsoft Word, and Microsoft Excel files. All file formats that Office plug-in handles behave in the same way in SOLIDWORKS PDM Standard except Preview.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>SOLIDWORKS PDM Standard Contributor</th>
<th>Supports working with SOLIDWORKS, DWG/DXF format, and Microsoft Word, and Microsoft Excel files.</th>
</tr>
</thead>
</table>
**SOLIDWORKS PDM**

**Standard Viewer**

Allows read-only access to file vaults; user cannot add or modify (check out, check in, update values) files.

You can install clients:

- By using the InstallShield Wizard.
- By using the SOLIDWORKS Installation Manager.
- By creating an administrative deployment image to install multiple seats.

**Before Installing Clients**

- Find out the type of client your license agreement entitles you to use.
  
  The floating license manager in SOLIDWORKS PDM prevents logging into a file vault if the wrong client type is installed.

- If you are installing the SOLIDWORKS PDM Editor Client, you can install optional add-ins.
  
  Add-ins make version management features such as check out, check in, and get available from menus and toolbars within your CAD and Office software. They are optional and do not affect which file formats can be managed by SOLIDWORKS PDM using the Windows File Explorer interface or file open/save dialogs.

  **SOLIDWORKS PDM Standard provides DraftSight add-in and SOLIDWORKS add-in.**

- To log in to the Professional vault, you must have SOLIDWORKS PDM Professional license available on the license server. Similarly, to log in to the Standard vault, you must have SOLIDWORKS PDM Standard license available on the license server.

  **To install both client and server components, ensure to select Client option in the server installation.**

The following product-specific prerequisites apply:

**SOLIDWORKS**

You can manage SOLIDWORKS files without having SOLIDWORKS installed. It is recommended to have the eDrawings viewer installed for previewing.

**Microsoft Office Integration (For SOLIDWORKS PDM Professional only)**

You can install Microsoft Office Add-in when you install SOLIDWORKS PDM Professional. You do not need additional licenses to use the Microsoft Office Add-in but must have a Contributor, CAD Editor, or PSL license to check files out and in.

**Solid Edge (For SOLIDWORKS PDM Professional only)**

SOLIDWORKS PDM Professional requires the full Solid Edge application installed for managing and previewing Solid Edge files.
Installing SOLIDWORKS PDM

Pro/ENGINEER (For SOLIDWORKS PDM Professional only)

SOLIDWORKS PDM Professional requires the full Pro/ENGINEER application installed for managing and previewing Pro/ENGINEER files.

The Pro/ENGINEER Connector requires a separate installation after the SOLIDWORKS client installation. The software can be obtained from your SOLIDWORKS Value Added Reseller.

These requirements apply to installations performed from the SOLIDWORKS PDM media or from an administrative image.

Installing Clients Using the Installation Wizard

1. Log on to the client computer as a user with local administrative rights.
2. Begin the installation, as described in Initiating the Installation via the InstallShield Wizard on page 43.
3. Complete the installation using the following instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select PDM Product</td>
<td>Select the type of client to install:</td>
</tr>
<tr>
<td></td>
<td>• <strong>SOLIDWORKS PDM Professional</strong>: Select if you connect to SOLIDWORKS PDM Professional server only.</td>
</tr>
<tr>
<td></td>
<td>To install the client with Item Explorer, select <strong>Customize</strong> and click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td>• <strong>SOLIDWORKS PDM Standard</strong>: Select if you connect to SOLIDWORKS PDM Standard server only.</td>
</tr>
<tr>
<td>Custom Setup</td>
<td>Select <strong>Item Explorer</strong> and click <strong>Next</strong>.</td>
</tr>
<tr>
<td></td>
<td><strong>This option is available for SOLIDWORKS PDM Professional only.</strong></td>
</tr>
<tr>
<td>Choose Product Type</td>
<td>a. Select the type of client to install, based on your license:</td>
</tr>
<tr>
<td></td>
<td>• <strong>SOLIDWORKS PDM CAD Editor</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>SOLIDWORKS PDM Contributor</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>SOLIDWORKS PDM Viewer</strong></td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Select Add-Ins</td>
<td>If the product type is <strong>SOLIDWORKS PDM CAD Editor</strong>,</td>
</tr>
<tr>
<td></td>
<td>a. You can select:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Microsoft Office Integration</strong>, <strong>SOLIDWORKS</strong>, and <strong>DraftSight</strong> add-ins for SOLIDWORKS PDM Professional client.</td>
</tr>
<tr>
<td></td>
<td>• <strong>SOLIDWORKS</strong> and <strong>DraftSight</strong> add-ins for SOLIDWORKS PDM Standard client.</td>
</tr>
<tr>
<td></td>
<td>b. Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Ready to Install the Program</td>
<td><strong>Click Install.</strong></td>
</tr>
<tr>
<td>InstallShield Wizard Completed</td>
<td><strong>Click Finish.</strong></td>
</tr>
</tbody>
</table>
Installing eDrawings

You can install eDrawings on the SOLIDWORKS PDM client to preview SOLIDWORKS files. eDrawings® is also available as a free download.

**To install eDrawings:**
1. Browse to the installation media.
2. Run `\eDrawings\setup.exe`.
3. Click **Next**.
4. Do not enter the license keys and click **Next**.
   - eDrawings runs as a Professional license if it is installed on a SOLIDWORKS PDM Professional client.
5. Click **Install**.
   - The installation continues.
6. Click **Finish** after the installation is complete.

Upgrading the SOLIDWORKS PDM Standard Client/Server to Professional

If you have installed the Standard client/server via InstallShield Wizard, perform the following steps.

**To upgrade:**
1. In Windows, open **Control Panel > Programs and Features**.
2. Right-click **SOLIDWORKS PDM Client** or **SOLIDWORKS PDM Server** and select **Change**.
   - If you have installed the client via SLDIM, modify the SOLIDWORKS installation to upgrade the client install.
3. On the Welcome screen, click **Next**.
4. On the Program Maintenance screen, click **Modify**.
5. On Select PDM Product screen, select **SOLIDWORKS PDM Professional**.
6. Continue with the installation of SOLIDWORKS PDM Professional.
   - If you have installed the Standard client/server via SLDIM, modify **SOLIDWORKS 2016** listed under **Programs and Features** for an upgrade.

Enabling Logging to Troubleshoot Installation

An installation log is useful when troubleshooting a failing installation.

1. Open a command prompt.
2. Change directory to the appropriate setup folder where the msi files are loaded.
3. Type the appropriate command to start a logged installation:
   - For client:
     ```
     MSIEEXEC /i "SOLIDWORKS PDM Client.msi" /L*v C:\LOGFILE.TXT
     ```
   - For server:
     ```
     MSIEEXEC /i "SOLIDWORKS PDM Server.msi" /L*v C:\LOGFILE.TXT
     ```
An installation log is created with information about the installation.

Creating SOLIDWORKS PDM Client Administrative Image

An administrative installation image lets you control the installation and upgrade of the client on multiple client machines.

You can create one image for all client license types and select a script for a specific client type to install on a machine.

The installation wizard creates a setup package (SOLIDWORKS PDM Client.msi and required files) that you can distribute using Microsoft Active Directory or another distribution method.

Keep a copy of the administration image, which includes all options you select, to make it easier to uninstall when doing an upgrade.

To create an administrative image:
1. From the Windows Start menu, run command prompt.
2. Change directory to the appropriate setup folder where the setup.exe is loaded.
3. Add the command switch E:\SWPDMClient\setup.exe /a.
   You can drag setup.exe on the command prompt and add the command switch.
4. Click OK.
5. Create the administrative image using these instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>Click Next.</td>
</tr>
<tr>
<td>License Agreement</td>
<td>Read and accept the license agreement and click Next.</td>
</tr>
<tr>
<td>Network Location</td>
<td>Enter a location where the SOLIDWORKS PDM client administrative image should be created.</td>
</tr>
<tr>
<td></td>
<td>If you plan to distribute this image, place it on a network resource that is available to all client systems.</td>
</tr>
<tr>
<td>Ready to Install the Program</td>
<td>Click Install.</td>
</tr>
<tr>
<td>InstallShield Wizard Completed</td>
<td>Click Finish.</td>
</tr>
</tbody>
</table>

Deploying Clients Using Windows Active Directory

By using the Group Policy features of Windows Active Directory, you can centrally deploy, install, and manage SOLIDWORKS PDM clients throughout an organization.

You can also perform routine maintenance tasks such as upgrading, patching, and removing clients from a central location, without going to individual workstations.
If you distribute the clients using an administrative image, you must deploy Microsoft XML Core Services (MSXML) 6.0 and .Net Framework 4.0 to all clients.


Only the SOLIDWORKS PDM client can be deployed using this method. Install the archive server and database server using the standard installation method.

Active Directory deployment considerations:

- Because SOLIDWORKS PDM is installed on a computer level, before any user has logged on, the deployment package should be available (i.e. shared with sufficient access rights) to all systems assigned for deployment.

- When you deploy a client, SOLIDWORKS PDM changes the default language that matches the locale of the machine. If the locale is not a supported language, SOLIDWORKS PDM sets the default language as English.

- Once deployed, you can add file vault views to the clients:
  - Using a policy
    For details, see Distributing the File Vault View Using Microsoft Windows Active Directory on page 106.
  - Using a scripted view installation
    For details, see Scripting File Vault View Setup on page 106.

To deploy a client admin image using Windows Server 2016 Active Directory:

1. Create an administrative image (SOLIDWORKS PDM Client.msi) in a network location that is accessible by UNC path to all systems where SOLIDWORKS PDM should be deployed.
   For details, see Creating SOLIDWORKS PDM Client Administrative Image on page 80.


3. Create a security group, or use an existing security group.
   To create a security group:
   a) In the Active Directory User and Computers dialog box, right-click Users and select New > Group.
   b) In the New Object - Group dialog box, type a Group name.
   c) Under Group type, select Security and click OK.

4. Add the computers where SOLIDWORKS PDM should be deployed.
   To add domain computers to the security group:
   a) Right-click the security group and select Properties.
   b) On the Members tab, click Add and add the computers.

5. Exit the Active Directory User and Computers dialog box.


7. In the Group Policy Management console, create a new group policy for the security group you created in steps 3 and 4.
8. Expand **Group Policy Objects** in the forest and domain that contains the new group policy and select the group policy.

9. In the right pane, on the Settings tab, right-click **Computer Configuration** and click **Edit**.

10. In the Group Policy Management Editor, navigate to **Computer Configuration > Policies > Software Settings > Software Installation**.

11. Right-click and select **New > Package**.

12. Browse to the SOLIDWORKS PDM Client.msi file in the location where you created the SOLIDWORKS PDM client administrative image.

   You should browse to the location through **My Network Places** to use the UNC path correctly. Do not use a mapped drive.

13. Click **Open**.

14. In the Deploy Software dialog box, select **Assigned** and click **OK**.

15. Select **Advanced published** or **Assigned**.

16. On the **Modifications** tabbed page, click **Add** to select one or more transforms to be applied.

   Ensure that the transform files are available on a network drive that is accessible by remote computers, preferably where the source image is available.

   You can use MSI tools, like Orca, to generate the transform files. For syntax, see **Scripting a Silent Installation of SOLIDWORKS PDM**.

17. Exit the Group Policy Management Editor and Group Policy Management console.

   The client image is ready for deployment and will be installed to the computers in the security group the next time the systems start up.

---

**Enabling Logging When Deploying SOLIDWORKS PDM**

To troubleshoot installation problems that occur when you deploy a SOLIDWORKS PDM client administrative image using Windows Active Directory, you should enable logging of the installation procedure. This is done through a Group Policy.

1. On the Active Directory server, locate the OU where the deployment package is assigned.

2. Right-click the OU, and select **Properties**.

3. In the Properties dialog box, on the Group Policy tab, click **New** to add a new Group Policy object. Name the policy (for example, **Logging**) and click **OK**.

4. Select the new policy (or an existing deployment policy) and click **Edit**.

5. In the Group Policy Object Editor, expand **Computer Configuration > Administrative Templates > Windows Components > Windows Installer**.

6. In the right pane, double-click the **Logging** setting.

7. In the policy object’s Properties dialog box:

   a) Enable the policy.
   
   b) In the **Logging** text box, type the full logging arguments:

   ```plaintext
   iwearucmpvo
   ```
   
   c) Click **OK**.
8. On the Group Policy tab, if you created a new group policy object, make sure that the new policy is listed at the top of the list.

When you deploy SOLIDWORKS PDM, an .msi installation log will be created in the Temp folder under the Windows system folder.

Scripting a Silent Installation of SOLIDWORKS PDM

You can script the client installation from an administrative image (for example, to run the installation from a .bat file).

To script a silent installation:

1. Create an administrative image for the client type you are installing to create the SOLIDWORKS PDM Client.msi installation package that is used in the following commands.
   For details, see Creating SOLIDWORKS PDM Client Administrative Image.
2. Update your installation script using the following command line options in SOLIDWORKS PDM Command-Line Properties.

Silent Installation Switches

<table>
<thead>
<tr>
<th>Switch</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>/qn</td>
<td>No UI</td>
</tr>
<tr>
<td>/qb</td>
<td>Basic UI</td>
</tr>
<tr>
<td>/qr</td>
<td>Reduced UI with a modal dialog box displayed at the end of the installation</td>
</tr>
<tr>
<td>/qf</td>
<td>Full UI with a modal dialog box displayed at the end of the installation</td>
</tr>
<tr>
<td>/qn+</td>
<td>No UI except for a modal dialog box displayed at the end of the installation</td>
</tr>
<tr>
<td>/qb+</td>
<td>Basic UI with a modal dialog box displayed at the end of the installation</td>
</tr>
<tr>
<td>/qb-</td>
<td>Basic UI with no modal dialog boxes</td>
</tr>
<tr>
<td>REBOOT=YESNO=NO</td>
<td>Do not prompt for reboot</td>
</tr>
<tr>
<td>REBOOT=YESNO=REALLYSUPPRESS</td>
<td>Suppresses the prompt for reboot when used with REBOOT=YESNO</td>
</tr>
<tr>
<td></td>
<td>If you upgrade a previous installation with this option, you must perform a reboot at the end of the installation to reload any replaced files that are in use.</td>
</tr>
<tr>
<td>REMOVE=[string]</td>
<td>Excludes a feature from installing</td>
</tr>
</tbody>
</table>
SOLIDWORKS PDM Command-Line Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INSTALLDIR=[string]</td>
<td>Installation directory</td>
</tr>
<tr>
<td>PDMTYPE=0, 1</td>
<td>Client type</td>
</tr>
<tr>
<td></td>
<td>• 0 = PDM Standard</td>
</tr>
<tr>
<td></td>
<td>• 1 = PDM Professional</td>
</tr>
<tr>
<td>PTID=</td>
<td>SOLIDWORKS PDM Viewer {CC72DD26-1A34-4209-B50B-21C7DD5E29F6}</td>
</tr>
<tr>
<td></td>
<td>SOLIDWORKS PDM Contributor {E2BE88CF-6E17-43e2-A837-C1051F3E4EDB}</td>
</tr>
<tr>
<td></td>
<td>SOLIDWORKS PDM CAD Editor {05AD35C4-8A9A-4114-B51F-32186222ABA1}</td>
</tr>
<tr>
<td>ADDLOCAL=</td>
<td>Main feature      Client</td>
</tr>
<tr>
<td></td>
<td>Office Add-in   Office</td>
</tr>
<tr>
<td></td>
<td>SolidWorks Add-in SolidWorks</td>
</tr>
<tr>
<td></td>
<td>Oracle Viewer   InsoViewer</td>
</tr>
<tr>
<td></td>
<td>Web Client helper WebClient</td>
</tr>
<tr>
<td></td>
<td>Item Explorer   ItemExplorer</td>
</tr>
<tr>
<td></td>
<td>DraftSight Add-in DraftSight</td>
</tr>
<tr>
<td></td>
<td>Common files   Shared</td>
</tr>
<tr>
<td></td>
<td>Common Files 64-bit Shared64</td>
</tr>
</tbody>
</table>

For more details, refer to the following sample scripts:

- **SOLIDWORKS PDM Professional Viewer with no add-ins**
  
  Msiexec /I <path to SOLIDWORKS PDM Client.msi> INSTALLDIR="C:\Program Files\SOLIDWORKS PDM" PDMTYPE=1
  PTID={CC72DD26-1A34-4209-B50B-21C7DD5E29F6}
  ADDLOCAL=Client,Shared,Shared64,WebClient,InsoViewer /qb

- **SOLIDWORKS PDM Professional CAD Editor with SOLIDWORKS and Office Add-ins**
  
  Msiexec /I <path to SOLIDWORKS PDM Client.msi> INSTALLDIR="C:\Program Files\SOLIDWORKS PDM" PDMTYPE=1
  PTID={05AD35C4-8A9A-4114-B51F-32186222ABA1}
  ADDLOCAL=Client,Shared,Shared64,WebClient,InsoViewer,SolidWorks,Office /qb

- **SOLIDWORKS PDM Standard CAD Editor with SOLIDWORKS Add-in**
Installing SOLIDWORKS PDM

Msiexec /I <path to SOLIDWORKS PDM Client.msi> INSTALLDIR="C:\Program Files\SOLIDWORKS PDM" PDMTYPE=0
PTID={05AD35C4-8A9A-4114-B51F-32186222ABA1}
ADDLOCAL=Client,Shared,Shared64,SolidWorks /qb

When scripting upgrades, the administrator must add REINSTALLMODE=vomus
REINSTALL=ALL
Using SOLIDWORKS Installation Manager

This chapter includes the following topics:

• SOLIDWORKS PDM
• Listing of PDM Server Components
• Understanding Differences between PDM Clients
• Before Installing PDM Server
• Installing a PDM Server with the SOLIDWORKS Installation Manager
• Installing a PDM Client with the SOLIDWORKS Installation Manager

SOLIDWORKS Installation Manager (SLDIM) facilitates the installation of PDM servers and client components. To configure and troubleshoot PDM components and SQL Server databases refer to advanced topics in other sections of this guide.

SOLIDWORKS PDM

SOLIDWORKS PDM is a document management product based on the client/server architecture known formerly as SOLIDWORKS Enterprise PDM.

SOLIDWORKS PDM is available in two types:

• SOLIDWORKS PDM Standard
• SOLIDWORKS PDM Professional

SOLIDWORKS PDM uses a Microsoft SQL Server database to manage file vaults.

This table lists the database systems, server components, and client options available for each product type.

<table>
<thead>
<tr>
<th>Designed for</th>
<th>PDM Standard</th>
<th>PDM Professional</th>
</tr>
</thead>
<tbody>
<tr>
<td>Small to medium office networks, generally with less than 20 concurrent users.</td>
<td>Large office networks, large numbers of concurrent users</td>
<td></td>
</tr>
<tr>
<td>Limits</td>
<td>Lesser of 1 socket or 4 cores, 1 GB of RAM, and 10 GB database size</td>
<td>SQL Standard limits: Lesser of 4 sockets or 16 cores, 128 GB of RAM, and 524 PB database size</td>
</tr>
</tbody>
</table>
## Listing of PDM Server Components

This table summarizes the server components of the SOLIDWORKS PDM Server.

<table>
<thead>
<tr>
<th>Server</th>
<th>Function</th>
<th>Installation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft SQL Server Express for PDM Standard</td>
<td>Manages data in SOLIDWORKS PDM data vaults.</td>
<td>Can install with PDM Standard, or use a version previously licensed and installed.</td>
</tr>
<tr>
<td>Microsoft SQL Server for PDM Professional</td>
<td>Manages data in SOLIDWORKS PDM data vaults.</td>
<td>Required. You can also use a version previously licensed and installed.</td>
</tr>
</tbody>
</table>
### Server

<table>
<thead>
<tr>
<th>Server</th>
<th>Function</th>
<th>Installation</th>
</tr>
</thead>
<tbody>
<tr>
<td>SolidNetWork License Manager Client</td>
<td>Manages SOLIDWORKS PDM licenses.</td>
<td>Must be installed before new vaults can be created. Can be installed with SOLIDWORKS PDM server components when using the SOLIDWORKS Installation Manager.</td>
</tr>
<tr>
<td>Archive Server</td>
<td>Manages transfers of files between clients and the file vault archive, and manages users and their credentials.</td>
<td>Required. Install with PDM Standard or Professional.</td>
</tr>
<tr>
<td>Database Server</td>
<td>Polls PDM databases for updates, manages data import and export rules, manages the message system, and schedules replication and cold storage.</td>
<td>Required. Install with PDM Standard or Professional.</td>
</tr>
<tr>
<td>Web Server and Web2 Server</td>
<td>Provides access to file vaults over the internet from browser-based clients.</td>
<td>Optional. Install with PDM Professional only.</td>
</tr>
<tr>
<td>Web API Server</td>
<td>EXALEAD OnePart users can use a Web API server to index and retrieve SOLIDWORKS PDM data.</td>
<td>Optional. Install with PDM Professional only.</td>
</tr>
</tbody>
</table>

Archive servers run as services on the system account of the computers where they are installed. One archive server can host multiple file vaults on the same computer.

In a stand-alone installation, the archive server, database server, license server, and web API server, as well as the SQL Express or SQL Server database, can all be installed on the same machine.

In a distributed environment, the server components can reside on different machines. SOLIDWORKS PDM Professional also supports replication of file vault archives and the SQL server database to improve performance at remote locations. For more details, see the SOLIDWORKS PDM Professional Replication Guide.

### Understanding Differences between PDM Clients

Before installing the client software, you must determine what clients are needed depending on your PDM environment.

This table summarizes the clients for SOLIDWORKS PDM Standard:
Supports working with SOLIDWORKS, DWG/DXF format, Microsoft Word, and Microsoft Excel files. All file formats, that Office plug-in handles, behave in the same way in SOLIDWORKS PDM Standard except Preview.

Supports working with SOLIDWORKS, DWG/DXF format, Microsoft Word, and Microsoft Excel files.

Allows read-only access to file vaults. User can transition files through a workflow, but user cannot add or modify (checkout, check in, update values) files.

This table summarizes the clients for SOLIDWORKS PDM Professional:

<table>
<thead>
<tr>
<th>Professional Client type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CAD Editor &amp; Web</td>
<td>Supports working with all file types, including enhanced management and previewing of CAD formats such as SOLIDWORKS. CAD add-ins allow users to access SOLIDWORKS PDM Professional from within the CAD application. Remote users can search vaults and perform basic functions over the Internet using the Web and Web2 clients.</td>
</tr>
<tr>
<td>Contributor &amp; Web</td>
<td>Supports working with all file types, including CAD files. However, the CAD add-ins are not supported on this client type. Remote users can search vaults and perform basic functions over the Internet using the Web and Web2 clients.</td>
</tr>
<tr>
<td>Viewer</td>
<td>Allows read-only access to file vaults. User can transition files through a workflow, user cannot add or modify (checkout, check in, update values) files or use CAD add-ins.</td>
</tr>
</tbody>
</table>

Before Installing PDM Server

Keep these requirements in mind before installing PDM server components:

- Obtain full administrative rights to the machines on which you are going to install servers and clients.
• Ensure that the database server has access to the archive server over TCP port 3030 and to the SQL Server over TCP port 1433.
• If you are going to use an existing SQL Server Express or SQL Server database, obtain the name of the SQL Server database and the account ID and password of a SQL Server administrator or database owner with read/write access to the database. You cannot use the temp user.
• If a PDM client is already installed on the system, uninstall it. If you want the PDM Server and PDM Client on the same system, you can install them both from the Server products page in the SOLIDWORKS Installation Manager.

Installing a PDM Server with the SOLIDWORKS Installation Manager

When you install the PDM Server for PDM Standard, you can install the archive server, the database server, and the PDM CAD Editor client on the same machine. You do not need to run the client installation separately.

When installing the PDM Server for PDM Professional, you can include these components, and also the Web server, Web2 server, and Web API server.

To install a PDM Server and its components:
1. Start the SOLIDWORKS Installation Manager.
2. On the Welcome page, select Server Products, and check the following:
   • Install SOLIDWORKS PDM Server components on this computer.
   • Install SolidNetWork License Manager on this computer.
     If the SolidNetWork License Manager is installed, this option does not display.
3. If the SolidNetwork License Manager Options page displays, enter a serial number and specify a location for the directory, and click Next.
4. Follow instructions for system warnings and click Next.
5. On the Summary page, for SOLIDWORKS PDM Server, click Change.
6. In the SOLIDWORKS PDM Server Options page:
   a) For **Select Server Product**, click **SOLIDWORKS PDM Standard** or **Professional**.
   b) For **Installation Location**, click **Browse** to specify a file path.
   c) In **Select Features**:
      1. Click **Archive Server**, **Database Server**, and **Client** to install these components on the same machine. If you are in a distributed environment, you can install the archive server and database server by running the Installation Manager on another machine.
      
      If a PDM client is already installed on the machine, you must cancel the installation and uninstall the client. You can then run the SOLIDWORKS Installation Manager to install the PDM server with the client together.
      
      2. If you are installing PDM Professional, you can also click **Web server**, **Web2 server**, and **Web API Server**.
      
      If you are installing the Web API server, you can specify a value for **HTTP port number** that is between 0 and 65535. The default value is 65453.
      
      d) In **SQL Server**, you can install a new instance of the database tools that come with PDM Server (SQL Server Express for PDM Standard), or you can specify the database name, username, and password of an existing instance.
      
      A full version of SQL Server must be installed for SOLIDWORKS PDM Professional.
    
    e) Click **Back to Summary**.
   
7. On the Summary page, accept the terms of the SOLIDWORKS License Agreement and click **Install Now**.

   When the SOLIDWORKS Installation Manager completes installing, the Archive Server Configuration Tool starts. Follow the prompts in the wizard to configure the archive server.

To set up, configure, and troubleshoot the archive server, database server, Web and Web2 servers, and SQL Server databases, see the relevant topics in the **SOLIDWORKS PDM 2022 Installation Guide**.

### Installing a PDM Client with the SOLIDWORKS Installation Manager

The major version of the SOLIDWORKS PDM Client must match the major version of the SOLIDWORKS PDM Server. When you install or upgrade the SOLIDWORKS PDM Client, make sure the versions match.

**To install a PDM Client:**

1. Start the SOLIDWORKS Installation Manager.
2. On the Welcome page, select **Individual**.
3. On the Serial Number page, click **Next**.

SOLIDWORKS PDM clients do not require a separate serial number.

4. Follow instructions for system warnings and click **Next**.

5. On the Summary page, under Products, click **Change**.

6. On the Product Selection page, click **Select different packages or products**.

7. In the Select the package you want to show dialog box, select a version of SOLIDWORKS. Then click **OK**.

8. On the Product Selection page, select **SOLIDWORKS PDM Client**. Then select **eDrawings** to enable the PDM Preview functionality. If you are using SOLIDWORKS PDM Professional, you can also select **Item Explorer**.

9. On the Summary page, expand **SOLIDWORKS PDM Options** and click **Change**.

10. On the SOLIDWORKS PDM Client Options page, select the following and click **Back to Summary**:

    - **PDM product type**
    - **PDM client type**
    - **Add-ins**

11. On the Summary page, accept the terms of the SOLIDWORKS License Agreement and click **Install Now**.

Administrators can also use the Administrative Image Option Editor to create and deploy images of PDM clients. For details, see **Using Administrative Images** in the **SOLIDWORKS Installation and Administration Guide**.
Creating and Distributing File Vault Views

This chapter includes the following topics:

- **Vault Creation**
- **Configuring the SolidNetWork License Server for the File Vault**
- **Creating a File Vault View Using the View Setup Wizard**
- **Distributing the File Vault View Using Microsoft Windows Active Directory**
- **Distributing File Vault Views in a WAN Environment**

SOLIDWORKS PDM file vaults store the files and information managed by SOLIDWORKS PDM. To add a file to a file vault, you place it in a local file vault view, which is a working folder where all intermediate file modifications are performed.

The file vault view is directly connected to:

- The archive server, which stores the physical files in a file vault archive
- The file vault database, which stores information about files and activities in the file vault

You can access files and information stored in a file vault only from a system with the SOLIDWORKS PDM client installed by logging in as a user with sufficient access rights.

### Vault Creation

Use the SOLIDWORKS PDM Administration tool to create the vault on the archive server.

### Prerequisites

Before creating a vault:

- Verify that all SOLIDWORKS PDM components have been installed.
- Ensure the archive server is available.

  If the archive server you want to use is on another system, you may need to add it.

  The archive server may not be accessible if a firewall on the archive system is blocking TCP port 3030.

- If the SQL Server is on a different system than the archive server, ensure that it is available. It may not be accessible if a firewall is blocking port 1433.

  If the SQL server is using a named instance or is SQL Server Express, the TCP port may be set to a dynamic value instead of 1433. For details, see [Configuring the SQL Server Express Instance to Listen to a Fixed TCP Port](#).
• Ensure you have sufficient access rights.
  Your Windows user account must have Administrative access to the archive server. If you create the vault on the same system as the archive server, the local administrator has this access by default.

• Obtain SQL Server information.
  You must know:
  • The SQL server name.
  • Login information for a user with sufficient system administrator privileges to create a vault.

Adding an Archive Server

To create a vault, you must be able to connect to an archive server. If an archive server is installed but is not visible in the Administration tool, you can add it.

1. From the Windows Start menu, click SOLIDWORKS PDM > Administration to open the Administration tool.
2. Click File > Add Server.
3. In the Add Server dialog box, for Server name, select or enter the server to add.
   Use the server system name, not the IP address, unless the environment is configured for IP-only communication, as described in the Installation Guide.
   When adding an archive server to a wide-area network (WAN), DNS can fail when looking up the IP address of the server host name. As a workaround, ensure that the client can successfully ping the server by name. If the ping does not work, update the local HOSTS file.
   For details, see Adding Archive Servers in a WAN Environment in the SOLIDWORKS PDM/SOLIDWORKS Manage Installation Guide.
4. Click OK.

Logging In to an Archive Server

Before creating a new vault, you may need to log in. If the logged in Windows user account has administrative access on the archive server, login is not required.

To log in to an archive server:
1. In the Login dialog box, enter the Windows user name and password of a user with access to vaults on the archive server.
   • To add the archive server and list its vaults, log in as a user who is a member of the attach access list in the Archive Server Configuration tool.
   • To perform administrative tasks such as creating, upgrading, or removing a vault, log in as a user with administrative access.
2. If the Login dialog box includes a Domain list, do one of the following:
   • If you are using a local user account on the archive server, select the system name that is followed by (local account).
   • If you are using a domain account, select or type the correct domain.
3. Click **Log In**.

Creating a Vault

**To create a vault:**

1. Log in to a system where the SOLIDWORKS PDM client is installed.
2. From the Windows **Start** menu, click **SOLIDWORKS PDM > Administration** to open the Administration tool.
3. If the archive server you want to work with is not listed, add it as described in *Adding an Archive Server* on page 94.
4. In the left pane, right-click the archive server in which to create the vault, then select **Create new vault**.

   If you are prompted to log in, see *Logging In to an Archive Server*. 
5. In the vault setup wizard:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>Click Next.</td>
</tr>
</tbody>
</table>
| Choose Vault Type                   | Select either SOLIDWORKS PDM Standard Vault or SOLIDWORKS PDM Professional Vault.  
|                                    | This screen appears only for SOLIDWORKS PDM Professional.             |
| Choose vault name                   | Type a name and description for the new vault.                        |
| Select vault archive folder         | Under Vault archive folder, select the archive folder to store the vault archives.  
|                                    | The default archive folder is Archives.                               |
| Choose database                     | The vault database contains information about files and activities in the vault.  
|                                    | Select or enter the SQL Server Express to host the vault database in Select database server.  
|                                    | A Standard vault database must be hosted on SQL Server Express.        |
|                                    | Type the Database name.                                               
|                                    | The SQL login dialog box appears in one of the following cases:        |
|                                    | • Stored SQL login has insufficient privileges                        |
|                                    | • User is invalid on the SQL server                                  |
|                                    | • Username or password is incorrect                                  |
|                                    | Specify a SQL user such as sa with sufficient permissions.            |
| License Server for Vault            | Enter the SolidNetWork License server address in the form:            |
|                                    | port@SNLServerName.                                                   
|                                    | For SOLIDWORKS PDM Standard vault, add the server name that has activated license for the Standard vault.  
|                                    | For SOLIDWORKS PDM Professional vault, add the server name that has activated license for the Professional vault.  
<p>| Select regional settings Language   | Select the language to use in the vault.                              |</p>
<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create the admin user</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Select <strong>Use the default 'admin' password for this archive server.</strong></td>
</tr>
<tr>
<td></td>
<td>The Admin user password defined during the archive server installation is used for the vault's admin user.</td>
</tr>
<tr>
<td></td>
<td>• Clear the option to enter and confirm a password.</td>
</tr>
<tr>
<td></td>
<td>This login is set to the vault-specific admin login settings for the new vault.</td>
</tr>
<tr>
<td>Configure vault</td>
<td>Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Use a configuration based on an administrative export file (*.cex)</strong></td>
</tr>
<tr>
<td></td>
<td>Browse to a .cex file containing the settings to use for the vault, for example vault settings you have exported from another vault.</td>
</tr>
<tr>
<td></td>
<td>If you import a .cex file to use for a Standard vault, features specific to Standard get imported. Any feature that contains elements that are not supported by Standard will not be imported.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Use a predefined configuration</strong></td>
</tr>
<tr>
<td></td>
<td>Select one:</td>
</tr>
<tr>
<td></td>
<td><strong>Empty</strong></td>
</tr>
<tr>
<td></td>
<td>Creates a data folder with no files, which makes it easier to import or create data cards, workflows, and so on.</td>
</tr>
<tr>
<td></td>
<td><strong>Default</strong></td>
</tr>
<tr>
<td></td>
<td>Installs the data set installed with previous versions of SOLIDWORKS PDM.</td>
</tr>
<tr>
<td></td>
<td><strong>Quick Start</strong></td>
</tr>
<tr>
<td></td>
<td>Installs a simple data set, including predefined groups and permissions, which enable companies installing SOLIDWORKS PDM for the first time to quickly use the software in a production environment.</td>
</tr>
<tr>
<td>Select configuration</td>
<td>Your choice on the Configure vault screen determines what is displayed on this screen.</td>
</tr>
<tr>
<td>details</td>
<td>• If you chose to use a configuration based on an administrative export file, this screen does not display.</td>
</tr>
</tbody>
</table>
If you chose **Empty**, no data options are installed to the vault to make it easier to import custom .cex files you have created.

If you chose **SOLIDWORKS Quick Start**, the following options, designed for an entry-level SOLIDWORKS implementation, are installed:

**Bills of Materials**
- Standard Bill of Materials
- Weldment Bill of Materials
- Weldment Cut List

**Cards**
- Default Folder Card
- SOLIDWORKS
  - Single card used for all SOLIDWORKS files.

**Search Support**
Displayed to users when they search the vault
- Complete File Search
- Quick Start Search

If you chose the **Default** option, the following options are available. Click an option name to display a description.

**Add-ins**
- Dispatch (SOLIDWORKS PDM Professional)

The SWTaskAddin is added to the vault if you select **Convert** and **Print** under **Task Execution**.

**Bills of Materials**
- Standard Bill of Materials
- Weldment Bill of Materials
- Weldment Cut List
<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cards</strong>&lt;br&gt;File and folder data cards for SOLIDWORKS PDM Professional:</td>
<td></td>
</tr>
<tr>
<td>• Adobe Acrobat&lt;br&gt;• AutoCAD&lt;br&gt;• Autodesk Inventor&lt;br&gt;• Bitmap Images&lt;br&gt;• CAL&lt;br&gt;• Default Folder Card&lt;br&gt;• Microsoft Office&lt;br&gt;• MP3&lt;br&gt;• Pro/ENGINEER</td>
<td>Pro/ENGINEER requires a separate Pro/ENGINEER Connector installation.</td>
</tr>
<tr>
<td>• Solid Edge&lt;br&gt;• SOLIDWORKS&lt;br&gt;• Text Files&lt;br&gt;• XML</td>
<td></td>
</tr>
<tr>
<td>File and folder data cards for SOLIDWORKS PDM Standard:</td>
<td></td>
</tr>
<tr>
<td>• AutoCAD&lt;br&gt;• Default Folder Card&lt;br&gt;• Microsoft Office&lt;br&gt;• SOLIDWORKS&lt;br&gt;• Text Files</td>
<td></td>
</tr>
<tr>
<td><strong>Items (SOLIDWORKS PDM Professional)</strong></td>
<td></td>
</tr>
<tr>
<td>• Support items</td>
<td>Support of items includes the item search cards.</td>
</tr>
<tr>
<td><strong>Search Support</strong>&lt;br&gt;Displayed to users when they search the vault</td>
<td></td>
</tr>
<tr>
<td>• Complete File Search</td>
<td>Only the items that are supported for Standard are available.</td>
</tr>
<tr>
<td>• User Search</td>
<td></td>
</tr>
</tbody>
</table>
Creating and Distributing File Vault Views

### Configuring the SolidNetWork License Server for the File Vault

You can configure the server for the file vault after you install the SolidNetWork License Manager and activate the license on the server.

You need to configure the license server only once since all SOLIDWORKS PDM vaults on the SQL server use the same SNL server.

1. From the Windows **Start** menu, click **SOLIDWORKS PDM > Administration** to open the Administration tool.
2. Create a file vault or expand the existing file vault.
3. Right-click the **License** node and select **Open**.
4. On the Server List tab, click **Add**.
5. Enter the SolidNetWork License Manager's address in the form: `port@SNLServerName`.

   The default port number is 25734. You can enter either the host name or IP address of SolidNetWork License server for SNLServerName. All clients must be able to connect to the server by IP address or host name.

6. Click **OK**.
7. Click the License Usage tab to ensure that SOLIDWORKS PDM licenses are available.
8. Click **OK**.

### Creating a File Vault View Using the View Setup Wizard

Users managing files must connect to a file vault through a local file vault view (working folder) created on each client.

To set up the file vault view, the SOLIDWORKS PDM client must be installed.

You also can create a local file vault view using the SOLIDWORKS PDM Administration tool. See the section on creating a local file vault view in the **SOLIDWORKS PDM Administration Guide**.
To create the file vault view using the View Setup wizard:

1. From the Windows Start menu, click SOLIDWORKS PDM > View Setup.
2. Create the file vault view using the following instructions:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>Click <strong>Next</strong>.</td>
</tr>
</tbody>
</table>

**Select archive server(s)**

- The available archive servers on the network are listed.
  - If the archive server you want to attach to is listed, select it.
  - If the archive server you want is not shown:
    1. Click **Add**.
    2. In the Add Server manually dialog box, enter the system name and click **OK**.
       A login dialog box appears if your account does not have sufficient access rights. Log in with a user account with attach access to file vaults on the archive server.
    3. Select the new archive server.
  - To connect to other archive servers with file vaults, select them.
  - Click **Next**.

**Select vault(s)**

- All file vaults on the selected archive servers are listed.
  - Select the vaults for which you want to create a local file vault view.
  - Click **Next**.
Creating and Distributing File Vault Views

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select location</td>
<td>a. Choose where the file vault view will be created.</td>
</tr>
<tr>
<td></td>
<td>You can place the view in any location. However, for a shared view that is accessible to all profiles on the system, create it in the root of the local hard disk drive to make it easily accessible.</td>
</tr>
<tr>
<td></td>
<td>b. Select the type of view to create:</td>
</tr>
<tr>
<td></td>
<td>Only for me The local view is only accessible to the Windows profile that is logged in the system. Use this option when multiple users are using the same system. Place the local file vault view in a user folder that is accessible to the logged-in profile. For details, see <em>Using SOLIDWORKS PDM on a Terminal Server</em>.</td>
</tr>
<tr>
<td></td>
<td>For all users on this computer The local view is accessible to all Windows profiles on this system (preferred). The logged in user must have local administrator rights to use this option because it requires updating the local system registry. For details, see <em>Using a Shared File Vault View with Multiple User Profiles</em>.</td>
</tr>
<tr>
<td></td>
<td>c. Click Next.</td>
</tr>
<tr>
<td>Review actions</td>
<td>Click Finish.</td>
</tr>
<tr>
<td>Completed</td>
<td>Click Closed.</td>
</tr>
</tbody>
</table>

Enabling Broadcast with Windows Firewalls

If you are running SOLIDWORKS PDM on a workstation where the Windows firewall is activated, you must enable broadcast to list archive servers when users create file vault views using View Setup.

This is because SOLIDWORKS PDM uses a broadcast method to get a list of all available archive servers on the network. This broadcast is sent to the default port 3030 on the server system from a dynamic port on the client. By default, Windows firewall only allows a three-second time period to return the broadcast result from the server to the dynamic client port. After that, the broadcast reply is stopped by the firewall.

For the archive server broadcast to work correctly on a client with Windows firewall active, you must allow the applications that request the broadcast through the firewall. For SOLIDWORKS PDM, these are the View Setup wizard (*ViewSetup.exe*) and the SOLIDWORKS PDM administration tool (*ConisioAdmin.exe*).
Using a Shared File Vault View with Multiple User Profiles

A shared file vault view is created by a user with local administrative Windows permissions. The local administrator group is, by default, given full file permissions to any files created (or cached) in that view.

On many systems, the local user or power user groups have only limited file permissions to folders in Windows. If a user with local administrative permissions caches a file in the shared vault view, other Windows user profiles with only user or power user access permissions might not have sufficient permissions to fully access the file or change the read-only state when checking out the file.

If you plan to use a shared file vault view with Windows user or power user profiles, you should define folder access permissions for those groups.

Changing Access Permissions on a Shared View Using the Properties Dialog Box

1. Log into the system as a user with local administrative permissions.
2. In Windows File Explorer, navigate to the file vault view folder and select it.
3. Right-click the file vault view folder and select Properties.
4. In the file vault view’s Properties dialog box, click the Security tab.
5. Under Group or user names, select the Windows profile groups to use the shared file vault view and make sure that they have all access permissions checked (that is,, Full Control).
6. Click OK.

Changing Access Permissions on a Shared View Using the Command Prompt

1. Log into the system as a user with local administrative permissions.
2. Open a command prompt and open the parent folder containing the file vault view (usually \C:\). 
3. Use the cacls command to assign sufficient access control to the user and power user groups.

   \CACLS “vault_view_name” /E /G “group_or_username”:F

   For example, to grant a local users group sufficient access control, type:

   \CACLS “c:\EPDM File Vault” /E /G “users”:F

   For details about the cacls command, visit Microsoft Support page and search with the cacls keyword.

Using SOLIDWORKS PDM on a Terminal Server

The following recommendation applies to installing SOLIDWORKS PDM clients in a Terminal Server environment:

- The client software is installed once on the terminal server because all terminal profiles use the same core system and program files. You cannot combine different client license types on the same terminal system; the same license type is used by all terminal client profiles.
- When creating local file vault views for terminal clients, you must be logged in as the Windows profile that should have access to the view. Make the views private by selecting
the **Only for me** or **For all users on this computer (requires local administrator rights)** option.

To make it easier to administer views to multiple terminal client profiles, use the SOLIDWORKS PDM policy or create an administrative view setup file.

Only the Windows profile for which the view was created can log in to the file vault view because the view information is stored in the current user section of the registry, which is only available to the current profile.

- To have the private views rooted to the same location for all profiles, place them in the terminal user’s home folder. For example, use the environment variables %HOMEDRIVE%%HOMEPATH%. These have the same path for most users.
- You should not create a shared view accessible by everyone on the terminal server in a terminal environment. If using a shared view, all terminal users will work in the same local cache, meaning they may overwrite each others file changes.

Creating a File Vault View Setup File

If you create a view setup file (.cvs), you can attach clients to a file vault by running the .cvs file, without having to use the View Setup wizard.

The .cvs file can also be launched silently using triggers, as described in **Scripting File Vault View Setup**.

You can create a .cvs file from any existing SOLIDWORKS PDM client.

**To create the .cvs file:**

1. Launch View Setup using the trigger /a.
   For example, from the Windows **Start** menu, click **Run** and then enter this command:
   “C:\Program Files\SOLIDWORKS PDM\ViewSetup.exe” /a

2. Step through the View Setup wizard as if creating local views.
   See **Creating a File Vault View Using the View Setup Wizard**. You can select any number of views.
   On the Review Actions screen, the available action is **Save to file**.

3. Click **Finish** and specify a location and filename for the view setup file.

4. Click **Close**.

Using a File Vault View Setup File

You can attach clients to a file vault by running the .cvs file, without having to use the View Setup wizard.

**The .cvs file can also be launched silently using triggers, as described in Scripting File Vault View Setup.**

**To use the View Setup file:**

1. Copy the .cvs file to a client that you want to attach to the file vault.
2. Double-click the .cvs file.
   The View Setup wizard opens to the Finish screen, which lists the vaults for which local views will be created.

3. Click Finish.

Scripting File Vault View Setup

The View Setup wizard can be launched using the ViewSetup.exe command with the following triggers to automate view installations. This can be useful when you want to distribute the file vault view using login scripts or a similar distribution method.

<table>
<thead>
<tr>
<th>Option or Argument</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>/a</td>
<td>Creates a view setup file.</td>
</tr>
<tr>
<td>path_to_.cvs_file</td>
<td>Opens the view setup file and lets you attach using the information from the file. The complete path to the .cvs file must be used.</td>
</tr>
<tr>
<td>/q</td>
<td>Performs attach silently without showing wizard. Will only work in combination with /s switch or a .cvs file.</td>
</tr>
<tr>
<td>/s {VaultID}</td>
<td>Find the Vault ID by selecting the properties of the vault in the SOLIDWORKS PDM administration tool. If you have more than one archive server hosting the vault, see Distributing File Vault Views in a WAN Environment.</td>
</tr>
</tbody>
</table>

Examples

- Create a vault view silently from the .cvs file:
  ViewSetup.exe PDMWEVault.cvs /q

- Create a .cvs file with the two file vaults supplied by ID:
  ViewSetup.exe /s {A8E07E93-F594-42c9-A01B-F613DBA53CB5}{699C4EC3-60FC-452f-940E-8786A7AAF1B2} /a

Distributing the File Vault View Using Microsoft Windows Active Directory

By using the SOLIDWORKS PDM user policy for Microsoft Windows Active Directory, you can centrally deploy file vault views on client workstations.

Before you configure Active Directory, find the unique vault ID of the vault view you want to distribute, as described in Finding the SOLIDWORKS PDM Vault ID on page 108.
Most policy dialog boxes have an Explain tab with descriptive text about the policy.

**To distribute a vault view using Windows Server Active Directory:**

1. Open the Control Panel and click **System and Security > Administrative Tools > Active Directory Users and Computers.**
2. Create a security group (or use an existing group).
3. Right-click the security group and select **Properties.**
4. In the security group’s Properties dialog box, on the Members tab, add the users to which the SOLIDWORKS PDM file vault view should be deployed.
5. Right-click the top domain container (or any top organizational unit (OU) containing the target users) and select **Properties.**
6. In the domain Properties dialog box, on the Group Policy tab, click **New** to create a new policy object.
7. Select the new object and click **Properties.**
8. In the object’s Properties dialog box, on the Security tab:
   a) Add the group containing the users to the list and select it.
   b) Under **Permissions,** in the **Allow** column, select **Apply Group Policy** to assign the policy to the group.
   
   If you do not want the policy to be set on other domain groups, make sure that the permission is turned off on the other groups.

   c) Click **OK.**
9. In the domain Properties dialog box, select the new object again and click **Edit.**
10. In the Group Policy Object Editor:
    a) Browse to **User Configuration > Administrative Templates.**
    b) Right-click and select **Add/Remove Templates.**
11. In the Policy Templates dialog box, navigate to `\SWPDMClient\Support\Policies. Select PDMWorks Enterprise.ADM and click **Open.**
12. When the policy is loaded, click **Close.**
    A new **SOLIDWORKS PDM Settings** option appears under **Administrative Templates > Classic Administrative Templates (ADM).**
13. Browse to the **View Setup** folder and double-click **Automatic View Setup.**
14. In the Automatic View Setup Properties dialog box:
    a) Select **Enabled.**
    b) Click **Show** to show the views to install.
    c) In the Show Contents dialog box, click **Add** to add the file vault view.
    d) In the Add Item dialog box, assign a name for the view to be distributed (preferably the same name as the file vault).
    e) Add the Vault ID to the item value field.
    f) Click **OK** three times.

If you have more than one archive server hosting the vault, see **Distributing File Vault Views in a WAN Environment** on page 109.
15. For the new view to be announced when the user logs in, SOLIDWORKS PDM must be started. To automate this, browse to the Login Manager folder and enable the Start SOLIDWORKS PDM Login manager at Windows login policy.

16. Close the Policy Editor.

Finding the SOLIDWORKS PDM Vault ID

To find the vault ID:

1. On a client computer, from the Windows Start menu, click SOLIDWORKS PDM > Administration to open the Administration tool.
2. Right-click the vault view and click Properties.
3. In the File Vault Properties dialog box, you can copy the vault ID and paste it into a file.

You can also find the vault ID in the vault database SystemInfo table.

Receiving a Distributed File Vault View

When you distribute a file vault view, users receive automatic notifications.

• When users in the distributed group next log in, the following balloon tip informs them that a new vault view is available:

Your system administrator has assigned new vaults for you to attach. Click here to attach them.

Clicking the message box displays the Select Location screen of the View Setup wizard to let the user select where the view should be placed.

If the user does not click the message box before it disappears, clicking the SOLIDWORKS PDM icon in the system tray shows an Attach option where the distributed views are available.

• If the automatic view setup policy had the option Setup Views Silent selected, users see the following message:

Your system administrator has attached you to new vaults. Click here to browse.

Clicking the message box opens the vault view in Windows File Explorer.

For the silent view setup policy to work, the domain user profiles that use the policy must be part of the Attach access (or administrative access) list in the security section of the Archive Server Configuration tool. Otherwise, the view must be manually created using the Attach option.
Distributing File Vault Views in a WAN Environment

By default, an archive server announces itself over the network to clients using a broadcast interface (over port 3030). When creating views, this lets the View Setup wizard or Administration tool list the archive server automatically.

When a script or Active Directory policy distributes a file vault view, the client uses the first archive server that is announced to it. In some situations such as a replicated environment with multiple servers, this may not be the correct server.

If you have problems using scripted views or policies over WAN or restricted networks, add the appropriate server manually using the SOLIDWORKS PDM Settings policy.

Manually Configuring the Archive Server That Is Announced to SOLIDWORKS PDM Clients

To configure the Archive Server manually:

1. From the Windows Start menu, click SOLIDWORKS PDM > Administration to open the Administration tool.
2. Under Local Settings, click Group Policies.
3. In the Group Policy dialog box, click User Configuration > Administrative Templates > SOLIDWORKS PDM Settings.
4. Disable the normal broadcast for the SOLIDWORKS PDM policy:
   a) In the right pane, double-click Disable broadcast.
   b) In the Disable Broadcast Properties dialog box, select Disabled, and click OK.
5. Add the archive server to which the clients have to connect:
   a) Click View Setup.
   b) Double-click Configure Select Server Page.
   c) In the Configure Select Server Page Properties dialog box, select Enabled.
   d) Click Show to show the default servers.
   e) In the Show Contents dialog box, click Add to add the server.
   f) In the Add Item dialog box, enter the archive server name and port, normally 3030.
   g) Click OK to close each dialog box.

When file vault views are distributed, clients are forced to use the specified archive server.

Specifying SOLIDWORKS PDM Settings Group Policy Manually

You can use Windows Active Directory policy options to distribute the SOLIDWORKS PDM settings. If you are not using Active Directory to distribute group policies, you can add the SOLIDWORKS PDM Settings policy manually on a client as a local group policy.

For details about using Active Directory to distribute SOLIDWORKS PDM settings, see Distributing the File Vault View Using Microsoft Windows Active Directory on page 106.

To add the policy manually:

1. From the Windows Start menu, click SOLIDWORKS PDM > Administration to open the Administration tool.
2. Select **Local settings**.
3. Right-click **Group policies** and click **Open**.
4. In the Group Policy dialog box, select **User Configuration**.
5. Right-click **Administrative Templates** and select **Add/Remove Templates**.
6. In the Add/Remove Templates dialog box, click **Add**.
7. In the Policy Templates dialog box, browse to the `PDMWorks Enterprise.ADM` policy template in `\SWPDMClient\Support\Policies` and click **Open**.
8. Click **Close**.

The **SOLIDWORKS PDM Settings** policy options appear under **Administrative Templates > Classic Administrative Templates (ADM)**.

### SOLIDWORKS PDM Settings Policy Options

<table>
<thead>
<tr>
<th><strong>Policy</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Settings</strong></td>
<td></td>
</tr>
<tr>
<td>Configure Broadcast Port</td>
<td>Defines the port used for broadcast, by default, port 3030. This port must match the archive server port. You should not have to change it.</td>
</tr>
<tr>
<td>Disable Broadcast</td>
<td>Prevents users from using broadcast to find archive servers on the local subnet. Only manually added servers will be used. Use this policy to make sure that a specific archive server is used. For details, see <em>Distributing the File Vault View Using Microsoft Windows Active Directory</em>.</td>
</tr>
<tr>
<td>Disable Automatic View Refresh</td>
<td>Normally, broadcast updates (refreshes) the Explorer file view when another SOLIDWORKS PDM client modifies something in the view (for example, by renaming or checking out a file). Use this option to prevent views from being updated automatically. Users must press F5 to manually refresh the folder listing in a view.</td>
</tr>
<tr>
<td><strong>Login Manager Settings</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Alternative Servers</td>
<td>If a file vault is replicated, enabling this policy creates a list in the login dialog box of archive servers hosting the replicated vault that the user can connect to. Use this policy if working on a laptop and working in both locations hosting a replicated vault. Only the servers that are broadcasted are listed. You might have to include the server in the <strong>Add alternative servers</strong> policy.</td>
</tr>
<tr>
<td>Start SOLIDWORKS PDM Login Manager at Windows Login</td>
<td>Set this policy when you distribute views with the <strong>Automatic View Setup</strong> policy. It starts the SOLIDWORKS PDM login manager at login so that views can be added.</td>
</tr>
</tbody>
</table>
### Add Alternative Servers

The alternative servers list contains available broadcasted servers hosting the replicated vault. If the broadcast does not list the server, you might have to add it manually using this policy. Add the server name as the Value Name, and server port as the Value.

### View Setup settings

#### Disable Add Server

Prevents the user from manually adding servers to the list of vault sources in the View Setup wizard. Use this policy in combination with **Disable Broadcast** and **Select Server page** to restrict clients to a specified set of servers.

#### Select Attach Page

Controls the Select Location screen of the View Setup wizard. It should be defined when adding views silently.

- **Location**: Sets the default file vault attach location. This can be used in terminal services environments to force file vault views to be created in a specific directory (commonly the user's home drive).

- **Type**: Sets the default file vault attach type. A restricted Windows user does not typically have the right to add file vault views per computer.

#### Select Server Page

Controls the Select Archive Server screen of the View Setup wizard. Adds default archive server names to the list of servers to choose from in the wizard. Type the name of the archive server and the port (3030) as value.

Use this in combination with **Disable Broadcast** and **Disable Add Server** to force clients to use a specified set of servers. You should also use this policy when broadcast prevents archive servers from being listed in the View Setup wizard (for example, over a WAN).

#### Automatic View Setup

Use this policy to distribute file vault views to client computers. Add the vault name and vault ID for the views that should be announced.

When using **Setup views silent**, the views are added without any user interaction. When you use this option, to make sure that the view is created in the correct location, you should also define the **Select Attach Page** policy. If the client computers reside in different subnets and cannot receive broadcast, you must define the **Select Server Page** policy.
<table>
<thead>
<tr>
<th>Policy</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Explorer settings</strong></td>
<td></td>
</tr>
<tr>
<td>Configure Thumbnails</td>
<td>Defines the size and color depth of thumbnails that are created on the archive server.</td>
</tr>
<tr>
<td>Drawing Extensions</td>
<td>Lets you can add other extensions that should behave like drawings in the BOM view. By default, SLDDRW and IDW files are counted as drawings. When you clear the Bill Of Material view option <strong>Include selected</strong>, drawing files are normally not considered the top-node; therefore both drawing and assembly are excluded.</td>
</tr>
<tr>
<td>Remove Copy Tree From Root</td>
<td>Removes the <strong>Copy Tree</strong> item from the shortcut menu for the root of the vault.</td>
</tr>
<tr>
<td>Configure Get File</td>
<td>Configure thread options used when retrieving files to the client. Use a value between 1 and 20. The default is 5.</td>
</tr>
<tr>
<td><strong>SQL</strong></td>
<td></td>
</tr>
<tr>
<td>Configure bulk operations</td>
<td>Configures when to use bulk operations when communicating with the SQL server. When not doing bulk operations, the statement is built up by text and concatenated to the execute statement if possible. For use only when directed by SOLIDWORKS support.</td>
</tr>
</tbody>
</table>
Upgrading a Vault from Standard to Professional

This chapter includes the following topics:

- Upgrading the SolidNetWork License from Standard to Professional
- Activating the Professional License
- Upgrading the Standard Vault
- Upgrading the SOLIDWORKS PDM Standard Client/Server to Professional
- After Upgrading the File Vault

Once upgraded, you cannot downgrade a Professional vault to a Standard vault. The procedure cannot be undone without a backup.

**To upgrade a vault from Standard to Professional:**

1. Back up the file vault database for the SOLIDWORKS PDM Standard vault. For details, see Backing Up the File Vault Database on page 125.
2. Upgrade the license from Standard to Professional. For details, see Upgrading the SolidNetWork License from Standard to Professional on page 113.
3. Upgrade the vault.
5. Upgrade SOLIDWORKS PDM Standard Client/Server to Professional Client/Server. For details, see Upgrading the SOLIDWORKS PDM Standard Client/Server to Professional on page 79.

Upgrading the SolidNetWork License from Standard to Professional

Before you upgrade a vault, you must upgrade the SolidNetWork License from Standard to Professional.

**To upgrade the SolidNetWork License from Standard to Professional:**

1. In Windows, open Control Panel > Programs > Programs and Features.
2. On the current license server, right-click SOLIDWORKS SolidNetWork License Manager, click Change > Next.
3. On the Program Maintenance screen, select Modify.
4. On the License Information screen, type the serial number for Professional and click Next.
5. Click **Install**.

Activating the Professional License

You can activate the license to log in to the Professional vault.

**To activate the Professional license:**

1. From the Windows **Start** menu, click **SOLIDWORKS Tools version** > **SolidNetWork License Manager Server version** to open the SolidNetWork License Manager.
2. When prompted to activate, click **Yes**.
   
   If you have an activated SolidNetWork License, click **Modify**.
3. On the SolidNetWork License Server Information screen:
   
   • If your company uses a firewall, select **A firewall is in use on this server**.  
     For more information, see *Using SolidNetWork License Server with Firewalls*.
   
   • Use the default value for **Port Number** (and for **Vendor Daemon Port Number** if you have a firewall) or specify the port numbers your company uses.

   The port number is a TCP/IP port number in the 1024-60000 range, used exclusively by this process. Normally, the default (25734) is suitable and is unlikely to be the same as any other FlexNet server process on the license manager server.

4. On the Activate Your SOLIDWORKS Product screen:

   • Select the internet or email procedure.
   
   • Supply email contact information.
   
   • Click **Next** to proceed.
     
     • Internet: Activation occurs automatically.
     
     • Email: Click **Save** to create a request file, then email the file to **activation@solidworks.com**. When you receive the email containing the response file, extract the file from email and then click **Open** to load it.

   If required, you can exit and rerun the activation procedure to open the response file.

5. Click **Finish**.
Upgrading the Standard Vault

To upgrade a Standard vault to a Professional vault, you must have the Professional license activated on the license server.

**To upgrade a vault from Standard to Professional:**
1. Log in to the SOLIDWORKS PDM Administration tool with **File vault management** permission.

   You must log in to the computer with an account that has Administrative access on the Archive server. If you are not, you will be prompted to enter credentials for a user with Administrative access to the server.

2. Right-click the vault and select **Upgrade to Professional Vault**.
3. On Upgrade to Professional Vault screen, click **Next**.
4. Select the check box and click **Next**.
5. Select the license server that has activated Professional license.
6. Click **Finish**.

Upgrading the SOLIDWORKS PDM Standard Client/Server to Professional

If you have installed the Standard client/server via InstallShield Wizard, perform the following steps.

**To upgrade:**
1. In Windows, open **Control Panel > Programs and Features**.
2. Right-click **SOLIDWORKS PDM Client** or **SOLIDWORKS PDM Server** and select **Change**.
   
   If you have installed the client via SLDIM, modify the SOLIDWORKS installation to upgrade the client install.
3. On the Welcome screen, click **Next**.
4. On the Program Maintenance screen, click **Modify**.
5. On Select PDM Product screen, select **SOLIDWORKS PDM Professional**.
6. Continue with the installation of SOLIDWORKS PDM Professional.

   If you have installed the Standard client/server via SLDIM, modify **SOLIDWORKS 2016** listed under **Programs and Features** for an upgrade.

After Upgrading the File Vault

After upgrading the file vault, complete the post-processing configuration steps.

After upgrading to the Professional vault:

- The Administration tool displays the Professional specific features.
- Administrators must configure the Professional vault explicitly.
• **Administrative Permissions** and **Folder Permissions** (specific to Professional) are assigned to the built in admin user. The admin user must assign these permissions to users and groups.
• The admin user must reconfigure convert task and configure other tasks.
Configuring Content Search (For SOLIDWORKS PDM Professional only)

This chapter includes the following topics:

- Content Search Overview
- Recommended Computer Configuration
- Using Windows Search for Content Search
- Installing Windows Search Service
- Setting Up Windows Search
- Indexing the Archives for Windows Search
- Indexing SOLIDWORKS PDM Professional File Vault Archives
- Configuring the Index Service on a Non-SQL Server System
- Adding Index Server Filters
- Managing File Vault Index Catalogs
- Removing a File Vault Index

When you index a file vault archive, the search tool can use the content search option to search a document’s contents or properties.

For example, you can search for all documents containing the word “product” or you can search for all Microsoft Office documents written by a specific author.

Content Search Overview

SOLIDWORKS PDM Professional content search uses the Microsoft Indexing Service or Windows Search Service to create a catalog for each indexed file vault. The catalog contains index information and stored properties for all versions of all documents in the file vault archive folders.

Administrators can choose an indexing method, Indexing Service, or Windows Search. Administrators of upgraded systems can still use the Indexing Service, while administrators of new systems that have not been previously indexed can use Windows Search.

The following table summarizes content search category and the supported operating systems:

<table>
<thead>
<tr>
<th>Content Search Category</th>
<th>Operating System</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Search Service</td>
<td>Windows 10</td>
</tr>
<tr>
<td></td>
<td>Windows Server 2016 or later</td>
</tr>
</tbody>
</table>
The Indexing Server periodically scans the file vault archive folders and extracts the content using filter components. Microsoft Indexing Service supplies filters for Microsoft Office files, HTML files, MIME messages, and plain-text files. You can install other document filters for content search in, for example, PDF files.

The indexing process creates a catalog with a master index that stores words and their locations within a set of indexed documents. SOLIDWORKS PDM Professional content search queries the catalogs for word combinations using the master index as well as word lists and shadow indexes to execute content searches.

**Recommended Computer Configuration**

The minimum hardware configuration for the index server is the same as for the SOLIDWORKS PDM Professional database server. However, the performance of the indexing and search tool depends on the number and size of documents to be indexed and the resources available to the indexing service.

If the number of documents (and versions) in the file vault is very large, insufficient memory on the index server will seriously affect performance.

The total size of the documents to be indexed affects the disk space required for storing index server data. The space required for the catalog is about 15% of the amount of documents indexed.

**Using Windows Search for Content Search**

SOLIDWORKS PDM can use the Windows Search service to perform content searches. Microsoft does not support the Indexing Service for Windows 10 or Windows Server 2016 operating systems. SOLIDWORKS PDM uses the Windows Search service to support content search on these operating systems.

**To use the Windows Search for Content Search:**

- The administrator must configure the Windows Search service and index a file vault archive folder.
- The file vault archive folder that is being indexed must be:
  - On the same machine as the configured Windows Search service.
  - Accessible to the Windows Search service to build a system index.
- If the archive server is on a different machine than the SQL server:
  - The administrator must share the file vault archive folder.
  - The logged in user running the SQL server service must have full permission to the shared folder.
  - The Windows Search service must be installed on the SQL server machine as well as the Archive server hosting the vault archives.

Windows Search does not support indexing remote network shares or mapped network drives. The archive folders must be accessible on locally attached storage or SAN storage.
When the Windows Search service builds the system index, the administrator can set up SOLIDWORKS PDM to use the system index.

Installing Windows Search Service

Install the Windows Search Service on the Archive Server system. If the vault database is hosted on a separate SQL server system, you must also install Windows Search Service on that SQL server.

Enabling Windows Search Service

To enable Windows Search service on Windows Server 2016 and later:

1. In Windows, open Control Panel > System and Security > Administrative Tools > Server Manager.
2. Select Manage > Add Roles and Features.
3. On the Select Features page, select Windows Search Service and click Next.
4. Click Install.
5. After Windows Search is installed, click Close to exit the Add Roles and Features Wizard.

Setting Up Windows Search

Configuring the SOLIDWORKS PDM Professional Content Search to use Windows Search requires installing the Windows Search Service, adding the archive folder path to the indexing settings, and indexing the file vault archives.

To set up Windows Search:

1. In the Administration tool, log into the file vault to be indexed as SOLIDWORKS PDM user with Can update index settings permissions.
2. Right-click Indexing and click Open.
3. In the Indexing Settings dialog box, select Index File Vault Archives.
5. Under Archive Locations, double-click the archive path to configure index locations.
6. In the Edit File Vault Archive Folder Path dialog box, type a path to a file vault archive folder from the SQL server.

   - If the Archive server is on a different machine than the SQL server, enter a UNC path to the archive folder share.
   - The archive folders must be accessible on locally attached storage or SAN storage on the archive server machine.

7. Click OK twice.

For details, see SOLIDWORKS PDM/SOLIDWORKS Manage Installation Guide: Installing Windows Search Service.
Indexing the Archives for Windows Search

For SOLIDWORKS PDM content search to find indexed documents, the archive folders need to be indexed by the Windows Search Service.

**To index the Archives for Windows Search:**

1. On the archive server, on the Windows Search bar, enter Indexing Options, and select Indexing Options.
2. In the Indexing Options dialog box, click Modify.
3. In the Indexed Locations dialog box, browse to the folder containing the file vault archives.
   If the Archive Server hosts multiple file vault archives that should be indexed, add the archive folder of all archives in this dialog box.
4. Select the check box next to the archive folder and ensure that the individual 0-F subfolders are also included.
5. Click OK.
6. Make sure that the archive folder is listed under the Included Locations column.

The Windows Search indexer starts scanning the archive folders and builds an index of the content found in the files. This process runs in the background and depending on archive size can take several hours to complete. Content searches might be incomplete until the index is fully rebuilt.

Indexing SOLIDWORKS PDM Professional File Vault Archives

This procedure describes index server setup when the index server and database server are installed on the SQL Server hosting the file vault databases.

The indexing service is not supported on operating systems later than Windows 7.

To install the index server on a separate system, see **Configuring the Index Service on a Non-SQL Server System** on page 121.

Before indexing the file vault archives:

- Make sure that the database server has been installed and configured.
- Obtain the user name and password of a SOLIDWORKS PDM Professional user with Can update index settings permissions.
- If the index server is located on a system other than the archive server, obtain one of the following:
  - The domain login information of a user with full (read and write) access to the UNC share to the archive folder.
  - The login information of a local Windows user on the index server.

**To set up the index server on the SQL Server system:**

1. On a client system, to open the Administration tool, click Start > All Programs > SOLIDWORKS PDM > Administration.
2. Log into the file vault to be indexed as SOLIDWORKS PDM user with Can update index settings permissions.
3. In the left pane, under the file vault, right-click Indexing and select **Open**.
4. If prompted, log into the archive server as a user with administrative access.
5. In the Indexing Settings dialog box, to enable content search in this file vault, select **Index File Vault Archives**.
6. Under the **Select the File Vault Indexing Method**, select **Indexing Service**.
7. Under **Archive Locations**, double-click the archive path.
8. In the Edit File Vault Archive Folder Path dialog box, in the second field, specify the path to the archive as seen from the system running the Indexing Service. You can use the **Browse** button to locate the archive folder.
   - If the index server (typically, the SQL Server) is located on the same system as the archive server, copy the path displayed in the first field and paste it into the second field.
   - If the index server is located on a system other than the archive server, provide a UNC path to the archive folder.
   
   Type one of the following:
   - The domain login of a user, such as the domain administrator, with full access to the UNC share
   - The username and password of a local Windows user on the index server
9. Click **OK** and close the Index Settings dialog box.

### Configuring the Index Service on a Non-SQL Server System

To set up the indexing service, the SOLIDWORKS PDM database server and Microsoft SQL Server must be able to communicate with the system used as the index server.

To use a system other than the SQL Server as the index server, perform the following steps before setting up the indexing for a file vault:

1. Update the vault database with the index server name. For details, refer to **Updating the File Vault Database with the Index Server Name** on page 121.
   
   If the server name includes hyphens (-), enclose the name in double quotes (" ").

2. Change the database server login account. For details, refer to **Changing the Database Server Login Account** on page 122.
3. Change the SQL Server login account. For details, refer to **Changing the SQL Server Login Account** on page 122.
4. After you have configured the service accounts and file vault database, add the indexing service and index the file vault archives as described in **Indexing SOLIDWORKS PDM Professional File Vault Archives** on page 120.

### Updating the File Vault Database with the Index Server Name

1. Open Microsoft SQL Server Management Studio and click **Connect**.
2. In the left pane, expand **Databases > file_vault_database > Tables**.
3. Right-click the **SystemInfo** table (dbo.SystemInfo) and select **Open Table**.
4. In the right pane, update the **IndexServer** column with the name of the index server system.

   If the server name includes hyphens (-), enclose the name in double quotes (" ").

   If you do not update the **SystemInfo** table with the correct index server name, the Microsoft Indexing Service on the SQL server is used as the index server.

5. Save your changes and exit Microsoft SQL Server Management Studio.

**Changing the Database Server Login Account**

If the database and archive services and the index server service are running on separate systems, they must be able to communicate using a service account other than the system account.

Before changing the database server login account, obtain the login information of a Windows user with local administrative rights on the database server and the index server.

The user must have the same name, password, and local account privileges on both systems.

**To change the login account for the database server:**

1. From the Windows **Start** menu, click **Control Panel > Administrative Tools > Services**.
2. Right-click **SOLIDWORKS PDM Database Server** and select **Properties**.
3. In the SOLIDWORKS PDM Database Server Properties dialog box, on the Log On tab, under **Log on as**, select **This account**.
4. Specify a Windows user account, such as a domain administrator, with local administrative rights on both the system running the database server and the index server and click **OK**.
5. Stop and start the SOLIDWORKS PDM Database Server service.

   If the database server cannot communicate with the index server, you will not be able to create or remove indexing for the file vault archives. The following error message may be displayed: **Access is denied. The SOLIDWORKS PDM Database Server failed to contact servername.**

**Changing the SQL Server Login Account**

If the SQL Server service and index server service are running on separate systems and are not part of the same domain, they must be able to communicate using a service account other than the system account. If they are in the same domain, this procedure is not necessary.

Before changing the SQL Server login account, obtain the login information of a Windows user with local administrative rights on the SQL Server and the index server.

The user must have the same name, password, and local account privileges on both systems.

**To change the login account for the Microsoft SQL Server:**

1. From the Windows **Start** menu, click **Control Panel > Administrative Tools > Services**.
2. Scroll down to the SQL Server (MSSQLSERVER), right-click it, and select **Properties**.
3. In the SQL Server (MSSQLSERVER) Properties dialog box, on the Log On tab, under **Log on as**, select **This account**.
4. Specify a Windows user account such as a domain administrator, with local administrative rights on both the system running the Microsoft SQL Server and the index server and click **OK**.
5. Stop and start the MSSQL Service.

If the SQL server cannot communicate with the index server, running a content search in SOLIDWORKS PDM fails and results in the following error message:

> A communication link failure occurred when accessing the database server. The database service might have been restarted or the network might have gone down. Please try the operation again and contact your system administrator if the problem persists.

**“vaultname”**

### Adding Index Server Filters

By default, the Windows Search Service supports content indexing for the following file formats: Microsoft Office files, HTML files, MIME messages, and plain-text files. By installing third party index filters (iFilters) on the index server, you can include content search support for many other file formats.

After you install a new index filter on an Index Server that has already indexed the archives you will have to rebuild the indexes. For details, see **Rebuilding the Index Catalog**.

### Compressed Archives (gzip) Filter

When installing the SOLIDWORKS PDM Server components the GZ iFilter is automatically registered. This filter allows the index server to catalog archives that have been compressed using archive server compression (gzip).

**Rebuilding the Index Catalog**

If the index server has already indexed the archives, you must launch a re-scan of the entire index catalog to refresh its content.

Rebuilding the index can take several hours to complete. Content searches might be incomplete until the index is fully rebuilt.

**Rebuilding the Windows Search Service Catalog**

To rebuild the windows search service catalog:

1. On the archive server, on the Windows Search bar, enter **Indexing Options**, and select **Indexing Options**.
2. In the Indexing Options dialog box, click **Advanced**.
3. In the Advanced Options dialog box, click the Index Settings tab, and click **Rebuild**.
Rebuilding the Microsoft Indexing Service Catalog

1. Right-click My Computer and select Manage.
2. In the Computer Management dialog box, expand Services and Applications > Indexing Service, Conisio_vaultID.
3. Click Directories.
4. In the right pane, right-click the directory and select All Tasks > Rescan (Full).

Managing File Vault Index Catalogs

There are many ways to configure the behavior of the Microsoft indexing service. For detailed information, about configuring Windows Search and Microsoft Indexing service, see the Windows Help regarding the index server node and online at http://support.microsoft.com.

Removing a File Vault Index

When you remove a file vault index, only the index catalog is removed; no physical file archives are affected by this operation.

Before removing a file vault index, obtain login information for a user with the following permissions:

- Administrative access to the archive server
- SOLIDWORKS PDM permission to update index settings

To remove an index for a file vault archive:

1. On a client system, from the Windows Start menu, click SOLIDWORKS PDM > Administration to open the Administration tool.
2. Log into the file vault from which you want to remove the index.
3. Right-click Indexing and select Open.
4. If prompted, log into the archive server as a user that has administrative access to the archive server.
5. Clear Index File Vault Archives and click OK.
This chapter includes the following topics:

- **Backing Up the File Vault Database**
- **Backing Up the SOLIDWORKS PDM Master Database**
- **Backing Up the Archive Server Settings**
- **Backing Up the Archive Files**
- **Scheduling Database Backups**
- **Restoring a File Vault**

File vault backups must be part of the daily management of SOLIDWORKS PDM. They are also required before you upgrade your SOLIDWORKS PDM components.

You can use the SQL Maintenance Wizard in SQL Server Standard to schedule a planned backup of the file vault databases. The physical file vault archives on all archive servers must be backed up regularly using scheduled file backup software.

When backing up the vault, the latest updates in files that are still checked out and modified on client workstations are not included since they are stored in the local file vault view (cache) of the client. To ensure that the latest information of all files is always included in a backup, the files should be checked in.

A complete file vault backup must include backing up the file vault database and all physical file vault archive files. The database backup must be performed at the same time as the archive file backup to avoid any data loss from mismatched backup sets. Without both the database and archives it is not possible to recover the vault in case of failure.

### Backing Up the File Vault Database

Back up the file vault database hosted on the SQL Server ideally using a professional backup solution that supports live SQL database backups. You can also perform the backup using the SQL Management tools that are included with the SQL Server.

1. Open SQL Server Management Studio.
2. Expand the **Databases** folder.
3. Right-click the database to be backed up, and select **Tasks > Back Up**.
4. In the Back Up Databases dialog box, under **Source**:
   a) For **Backup type**, select **Full**.
   b) For **Backup component**, select **Database**.
5. Under **Destination**, click **Add**.
6. In the Select Backup Destination dialog box, enter a destination path and filename for the backed up database and click **OK**.
7. Click **OK** to start the backup.
8. When the backup completes, click **OK**.
9. Repeat the backup procedure for any additional file vault databases.

**Backing Up the SOLIDWORKS PDM Master Database**

In addition to the file vault database(s), the SOLIDWORKS PDM master database called **ConisioMasterDb** must be backed up.

To back up this database, follow the same instructions used for backing up the file vault database. For details, see *Backing Up the File Vault Database*.

**Backing Up the Archive Server Settings**

The archive server contains file vault settings such as passwords and defined login types. It is also the physical location of the SOLIDWORKS PDM vault archive files. Backing up the archive server settings does not back up the archive files.

After backing up the archive server settings, include the backup file in your normal file backup.

**To back up the archive server settings:**

1. On the archive server, from the Windows **Start** menu, click **SOLIDWORKS PDM > Archive Server Configuration**.
2. In the SOLIDWORKS PDM Archive Server dialog box, select **Tools > Backup settings**.
3. In the Backup Settings dialog box:
   a) Select **Include all vaults**. (preferred setting)
      Alternatively, you can select **Include selected vaults** and specify the file vaults for which settings will be backed up.
   b) Specify or select the **Backup location**.
      The default location is the archive folder.
   c) To schedule an automatic backup, click **Schedule** and specify the schedule.
   d) Type and confirm a password for the backup file.
      
      This password is required to restore settings.
   e) Do one of the following:
      - To perform the backup immediately, click **Launch backup**. When a message confirms the backup, click **OK**.
      - To perform the backup at the scheduled time, click **OK**.

4. Close the SOLIDWORKS PDM Archive Server dialog box.
The backup file is saved in the specified location and called **Backup.dat**.
Backing Up the Archive Files

The file vault archives contain the physical files that are stored in a file vault. A file added to the vault is stored in the archive folder specified by the archive server.

1. Locate the archive folder with the same name as the file vault.
   This folder is stored under the defined archive folder path on the archive server. For details, see *Installing SOLIDWORKS PDM Archive Server*.

   If you are uncertain where the file vault archives are stored, view the registry key
   HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks
   Enterprise\ArchiveServer\Vaults\vaultname\ArchiveTable.

2. Use a backup application such as Backup Exec to back up this folder and its contents.

Scheduling Database Backups

You can schedule database backups using a maintenance plan in SQL Server Standard edition. You must take daily file vault backups in SQL Express because there are no in built maintenance plans or automated backup options.

To set up a recurring automatic backup of the file vault SQL databases, you can use the SQL Server Management Studio maintenance plans. A maintenance plan lets you create complete backups of the databases, which you can include in your normal file backup routine.

Before scheduling database backups:

- The SSIS (Integration Services) must be installed on the SQL Server. The Integration Services are normally included as part of the Workstation Components step in the SQL Server install wizard.
- The SQL Server Agent must be running.

The SQL Server Express edition is a free version of SQL Server and does not include the SQL Management Tools and SQL agent. For Standard vaults, to set a daily file vault backup, visit Microsoft Support page and search for the Knowledge Base article 2019698.

Starting the SQL Server Agent

If the SQL Server Agent is not running, you could see a message that the ‘Agent XPs’ component is turned off as part of the security configuration of your computer.

1. Open the SQL Server Configuration Manager.
2. In the left pane, select **SQL Server Services**.
3. If the state of SQL Server Agent is **Stopped**, right-click it and select **Start**.

   Ensure that the **Start Mode** of the agent is set to **Automatic**. If it is not, right-click the agent and select **Properties**, then configure the **Start Mode** on the Services tab.

4. Exit the SQL Server Configuration Manager.
Setting Up a Maintenance Plan for Database Backup (For SOLIDWORKS PDM Professional only)

The easiest way to set up a backup maintenance plan in SQL Server Standard is using the SQL Maintenance wizard.

When the backup maintenance plan is run, the file vault databases are backed up and placed in a folder you specify. Include the backup folder in your normal daily backup procedure.

To set up a backup maintenance plan:

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, under the SQL Server, expand Management.
3. Right-click **Maintenance Plans** and select **Maintenance Plan Wizard**.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQL Server Maintenance Plan Wizard</td>
<td>Click <strong>Next</strong>.</td>
</tr>
<tr>
<td>Select Plan Properties</td>
<td></td>
</tr>
<tr>
<td>a. Enter a name and description for the maintenance plan.</td>
<td></td>
</tr>
<tr>
<td>b. Click <strong>Change</strong> to set up a schedule.</td>
<td></td>
</tr>
<tr>
<td>In the Job Schedule Properties dialog box, specify a name for the schedule and choose the recurring times to run the database backups. Set the times close to the start time of the normal daily file backups. The backup of a database to a hard drive usually completes within minutes.</td>
<td></td>
</tr>
<tr>
<td>c. Click <strong>OK</strong>.</td>
<td></td>
</tr>
<tr>
<td>d. Click <strong>Next</strong>.</td>
<td></td>
</tr>
<tr>
<td>Select Maintenance Tasks</td>
<td></td>
</tr>
<tr>
<td>a. Select <strong>Back Up Database (Full)</strong>.</td>
<td></td>
</tr>
<tr>
<td>If you rely on daily backups, you can select <strong>Back Up Database (Differential)</strong> as well. You should create at least one full backup set each week.</td>
<td></td>
</tr>
<tr>
<td>b. Click <strong>Next</strong>.</td>
<td></td>
</tr>
<tr>
<td>Select Maintenance Task Order</td>
<td></td>
</tr>
<tr>
<td>a. Ensure that the backup task is listed.</td>
<td></td>
</tr>
<tr>
<td>b. Click <strong>Next</strong>.</td>
<td></td>
</tr>
</tbody>
</table>
Define Back Up Database (Full) Task

a. Expand the **Databases** list.
b. Select **All user databases**.
   
   This selects all SOLIDWORKS PDM databases and excludes the SQL system databases, which are not required by SOLIDWORKS PDM.

   To select databases individually, select **These databases** and make your selections. Be sure to select the file vault database(s) and the **ConisioMasterDb** database.

c. Click **OK**.
d. Select **Backup set will expire** and define how many days the existing backup set files should be kept.
e. Select **Back up to Disk**.
f. Select **Create a backup file for every database**.
g. For **Folder**, enter a local path on the SQL Server to an existing folder where the backup files should be created.
h. Click **Next**.

Select Report Options

a. For backup task report, select **Write a report to a text file** or **E-mail report**, and specify where it should be saved or sent.
b. Click **Next**.

Complete the Wizard

Click **Finish**.

When all tasks have been completed, click **Close**.

4. Exit Microsoft SQL Server Management Studio.

Restoring a File Vault

Restoring a file vault requires recent backups of the file vault databases, ConisioMasterDb database, archive server configuration settings, and file vault archive files.

Use SQL Server Express to restore the Standard vault database.
Restoring the SQL Server File Vault Databases

1. Install the SQL Server:
   a) Configure the SQL login type to mixed mode.
   b) Select to install the management tools.
      For details, see *Installing and Configuring SQL Server*.
2. Apply the latest SQL service pack.
3. Restore the SQL database backup files to a temporary folder on the SQL Server.
4. Open Microsoft SQL Server Management Studio and click **Connect**.
5. In the left pane, right-click **Databases** and select **Restore Database**.
6. In the Restore Database dialog box, in the **To database** field, enter the name of the file vault database exactly as it was named when backed up.
7. Under **Source for restore**, select **From device** and click the **Browse** button.
8. In the Specify Backup dialog box, click **Add**.
9. In the Locate Backup File dialog box, select the database backup file and click **OK** twice to return to the Restore Database dialog box.
10. Under **Select the backup sets to restore**, click **Restore** for the database to restore.
11. In the left pane, select **Options**.
12. In the right pane, verify that the paths to the database files are correct.
    SQL defaults to the paths used when backing up the database.
13. Click **OK** to start the restore.
14. Repeat this procedure for additional file vault databases, including the **ConisioMasterDb** database.
15. Exit Microsoft SQL Server Management Studio.

Verifying the ConisioMasterDb Restore

After you restore the **ConisioMasterDb** database, ensure that information in the **VaultName** and **DatabaseName** columns of the **FileVaults** table is correct. If either entry is missing, notifications cannot be processed.

1. Open Microsoft SQL Server Management Studio and click **Connect**.
2. Expand **Databases > ConisioMasterDb > Tables > dbo.FileVaults**.
3. Click **Columns**, and verify the **VaultName** and **DatabaseName**.
4. Exit Microsoft SQL Server Management Studio.

Restoring the Archive Server and File Vault Archives

You can use this procedure to restore the archive server settings to the previous settings, including all login settings and user information.

1. On the new archive server, restore the physical vault archives from the backup (folders 0-F) to the same location as before the backup.
2. Install the archive server.
   Use the settings you used in the original install. If unsure, use the default options.
   Define the archive folder path as you defined it originally.
3. Restore the archive server configuration settings backup file `Backup.dat` to the archive folder.
4. From the Windows **Start** menu, click **SOLIDWORKS PDM > Archive Server Configuration**.
5. In the SOLIDWORKS PDM Archive Server dialog box, select **Tools > Backup settings**.
6. In the Backup Settings dialog box, click **Load Backup**.
7. Locate the archive server settings backup file `Backup.dat` and click **Open**.
8. In the Enter Password dialog box, enter the backup file password.
9. When the settings are restored, click **OK**.
10. Close the SOLIDWORKS PDM Archive Server dialog box.
Upgrading SOLIDWORKS PDM

This chapter includes the following topics:

- About Enterprise PDM Upgrade
- Upgrading the Archive Server
- Upgrading the Database Server
- Installing or Upgrading the SolidNetWork License Manager
- Upgrading File Vaults
- Upgrading Toolbox in SOLIDWORKS PDM

You can upgrade from Enterprise PDM 2015 or earlier to SOLIDWORKS PDM Professional using the SOLIDWORKS PDM installation wizard. The wizard automatically uninstalls any old software components found and then installs the new software.

You cannot upgrade from Enterprise PDM to SOLIDWORKS PDM Standard.

Follow these instructions when upgrading from a previous PDMWorks Enterprise or SOLIDWORKS PDM version or service pack. For preliminary System Requirements, see System Requirements.

SOLIDWORKS PDM allows a service pack mismatch between client and server components within the same major version.

To find out which version is currently installed, see Determining the Current Version on page 134.

About Enterprise PDM Upgrade

Before Upgrading

Perform these tasks before upgrading SOLIDWORKS PDM.

- Ensure your SOLIDWORKS PDM serial number has valid activated licenses for the new version.
- Check in all files.
- Back up:
  - SQL Server file vault database
  - Complete file vault archive
  - Archive server settings
• Make sure that no users are working in the old file vault. On all clients, users should close all tools started using the file vault, click the SOLIDWORKS PDM icon on the right side of the task bar, and choose Log Off.

Determining the Current Version

You can find out the current version of Conisio or SOLIDWORKS Enterprise PDM software and the file vault database.

1. Open Windows Control Panel.
2. Double-click Uninstall a program.
3. On the Uninstall or change a program screen, locate Conisio or SOLIDWORKS Enterprise PDM.
   - The Version column shows the currently installed version.
   - If the Version column is not shown, right-click the column headings and select Version.

You can also determine the current version by opening the SOLIDWORKS Enterprise PDM Administration tool and clicking Help > About.

The version numbers correspond to the following installed versions:

<table>
<thead>
<tr>
<th>Publisher Version Number</th>
<th>Installed Product Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>6.02</td>
<td>Conisio 6.2</td>
</tr>
<tr>
<td>6.03</td>
<td>Conisio 6.3</td>
</tr>
<tr>
<td>6.04</td>
<td>Conisio 6.4</td>
</tr>
<tr>
<td>6.05</td>
<td>PDMWorks Enterprise 2006</td>
</tr>
<tr>
<td>7.00.0027 through 7.05.0074</td>
<td>PDMWorks Enterprise 2007 32-bit Edition</td>
</tr>
<tr>
<td>7.07.0032 through 7.09.0042</td>
<td>PDMWorks Enterprise 2007 64-bit Edition</td>
</tr>
<tr>
<td>8.00</td>
<td>PDMWorks Enterprise 2008</td>
</tr>
<tr>
<td>9.00</td>
<td>SOLIDWORKS Enterprise PDM 2009</td>
</tr>
<tr>
<td>10.00</td>
<td>SOLIDWORKS Enterprise PDM 2010</td>
</tr>
<tr>
<td>11.00</td>
<td>SOLIDWORKS Enterprise PDM 2011</td>
</tr>
<tr>
<td>12.00</td>
<td>SOLIDWORKS Enterprise PDM 2012</td>
</tr>
<tr>
<td>13.00</td>
<td>SOLIDWORKS Enterprise PDM 2013</td>
</tr>
<tr>
<td>14.00</td>
<td>SOLIDWORKS Enterprise PDM 2014</td>
</tr>
</tbody>
</table>
Determining Which Updates Have Been Applied

1. From the Windows Start menu, click SOLIDWORKS Enterprise PDM > Administration to open the Administration tool.
2. In the left pane, right-click the file vault name and select Properties.
3. In the File Vault Properties dialog box, check the Installed Updates list.
   This list shows the updated product, version, and upgrade date.

Upgrading the Archive Server

If both the archive server and database server software are installed on the same system, you can upgrade and install both components at the same time.

All settings from the previous installation of the archive server are retained.

1. Log in locally or remotely as a user with local administrative rights on the system where the archive server is installed.
2. In the SWPDMServer folder, run \SWPDMServer\setup.exe to start the SOLIDWORKS PDM server upgrade.
   A warning is displayed stating that older versions of the SOLIDWORKS PDM software have been found and will be upgraded.
3. Click OK.
4. Follow the install wizard steps by clicking Next at each screen.
5. The Select Product screen defaults to SOLIDWORKS PDM Professional if upgrading from a previous Enterprise PDM or SOLIDWORKS PDM Professional version.
6. On the Setup Type screen, select Server Installation and click Next.
7. On the Server Installation screen, ensure that the Archive Server is selected and click Next.
   If you want to install SOLIDWORKS PDM client on the machine, you must also select Client.
8. When the upgrade is complete, click Finish.

Upgrading the Database Server

If you upgraded the database server while upgrading the archive server, skip to Upgrading the File Vault Database on page 138.

Before upgrading the database server, obtain the following:

- Login information for a user with local administrative rights
- SQL Server name
- Name and password of an SQL user with sysadmin permissions

You can use the SQL sa account that has these permissions.

**To upgrade the database server:**

1. Log in locally or remotely to the SQL Server where the vault database is hosted.
2. In the SWPDMServer folder, run setup.exe to start the SOLIDWORKS PDM server upgrade.
   A message states that an older version of the SOLIDWORKS PDM server software has been found and will be upgraded.
3. Click **OK**.
4. Follow the install wizard steps by clicking **Next** at each screen.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Server Installation</td>
<td>Select <strong>Database Server</strong> and click <strong>Next</strong>. If you want to install SOLIDWORKS PDM client on the machine, you must also select <strong>Client</strong>.</td>
</tr>
<tr>
<td>SOLIDWORKS PDM Database Server SQL Login</td>
<td>a. Do one of the following:</td>
</tr>
<tr>
<td></td>
<td>• Type the name of the SQL Server to host the file vault databases the database server will manage.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Browse</strong> to display a list of available SQL servers and instances on the network.</td>
</tr>
<tr>
<td></td>
<td>Select the appropriate name and click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. In the <strong>Login name</strong> field, enter the name of an SQL user on the server who has read and write access (that is, <strong>db_owner</strong> permission) to all SOLIDWORKS PDM databases hosted on the SQL Server (the file vault databases and <strong>ConisioMasterDb</strong>). Use the sa login if unsure.</td>
</tr>
<tr>
<td></td>
<td>c. In the <strong>Password</strong> field, enter the SQL user’s password.</td>
</tr>
<tr>
<td></td>
<td>d. Click <strong>Next</strong>. The login information is verified. If it is incorrect, a warning is displayed.</td>
</tr>
</tbody>
</table>

| Ready to Install the Program                | Click **Install**.                                                                                                                  |
| InstallShield Wizard Completed              | Click **Finish**.                                                                                                                   |

**Installing or Upgrading the SolidNetWork License Manager**

If you upgrade SOLIDWORKS PDM, you need to install or upgrade the SolidNetWork License Manager.

**Upgrade the SolidNetWork License Manager.**

For more information, see *Upgrading the SolidNetWork License Manager*. 
Upgrading File Vaults

To upgrade file vaults, you first upgrade the file vault database and then optionally the file vault archives.

Upgrading the File Vault Database

You can run the SOLIDWORKS PDM Database Upgrade Wizard on the archive or database server, or from a system running the SOLIDWORKS PDM client.

However, all installed SOLIDWORKS PDM software on the system must match the upgrade wizard version. You cannot run the upgrade wizard on a client or server system that is still using an older version of the software. The database upgrade process may take some time to finish, depending on the database size and version.

Before upgrading the file vault database:

• Ensure that your SOLIDWORKS PDM serial number has valid licenses for the new version.
• Make sure that no users are working in the vault.
• Back up the file vault database.

For details, see Backing Up the File Vault Database on page 125.

• Install or upgrade the archive server software.

For details, see Upgrading the Archive Server on page 135.

• Install or upgrade the database server software.

For details, see Upgrading the Database Server on page 135.

Do not uninstall old clients until the database upgrade has been completed.

You can upgrade the file vault from SOLIDWORKS Enterprise PDM 2015 or earlier to SOLIDWORKS PDM Professional. This tool is used for upgrading major versions or service packs and not for upgrading vaults from Standard to Professional.

To upgrade the file vault database:

1. In the SWPDMServer\Upgrade folder, run Upgrade.exe to start the upgrade wizard manually.
2. When a message box warns that the database and file vault upgrade wizard must only be run by administrators, click Yes.
3. Complete the steps of the SOLIDWORKS PDM Database Update Wizard.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Step 1</td>
<td>Verify that you have performed all of the upgrade prerequisites, and click <strong>Next</strong>.</td>
</tr>
</tbody>
</table>
| Step 2 | a. From the server list, select the SQL Server hosting the file vault database you want to upgrade. If the server is not listed, you can enter the name of the SQL system.  
   b. Click **Next**.  
   c. In the login dialog box, enter the user name and password of an SQL user with sysadmin permissions, such as *sa*, and click **Login**. |
| Step 3 | Select one or more file vault databases to upgrade and click **Next**. |
| Step 4 | Click **Next** to begin the upgrade process. |

- **Do not close the upgrade wizard or turn off the SQL Server until the upgrade is completed.**

| Step 5 | When the file vault database upgrade finishes, a log is displayed with the actions and results of the upgrade. To keep a copy of the upgrade log, select and copy the results and paste them to a text file.  
   Click **Finish**. |

4. Reboot the Microsoft SQL Server after the databases have been upgraded. If you do not, you may experience performance drops until you reboot the server.

**Upgrading File Vault Archives**

After you upgrade the file vault database, you can upgrade the file vault archives using the SOLIDWORKS PDM administration tool, which is only available on client installations.

- You must upgrade the file vault archive if you are upgrading a file vault from Enterprise PDM 2008 or earlier version.  
  Upgrading archives are not needed if upgrading newer versions.

Upgrading file vault archives consists of these tasks:

- Upgrading or installing an initial SOLIDWORKS PDM client on the computer where you will upgrade the file vault archives.
You will upgrade other clients after the file vault archives are updated.

- Upgrading the file vault archive using the SOLIDWORKS PDM administration tool on the initial client computer.
- Upgrading the remaining SOLIDWORKS PDM clients.

The vault archive upgrade process can take several hours to complete depending on the number of files and size of the archive. During the upgrade, users cannot work in the file vault.

Upgrading the Initial SOLIDWORKS PDM Client

1. Log into a client workstation as a user with local administrative rights.
2. Browse to the installation media.
3. Run `\SWPDMClient\setup.exe` to start the SOLIDWORKS PDM server upgrade.
4. On the SOLIDWORKS PDM installation screen:
   - If an older version of SOLIDWORKS PDM client is installed, click **Upgrade**.
   - At the message that the current client software will be upgraded, click **OK**.
5. On the Select PDM Product screen, ensure that **SOLIDWORKS PDM Professional** is selected.
6. To include the Item Explorer, select **Customize**.
7. On the Custom Setup screen, under **Client**, click **Item Explorer**, and select **This feature will be installed on local hard drive**.
8. Follow the install wizard steps by clicking **Next** in each screen.
9. Follow the installation wizard as you would if you were installing a new client.
   - For details, see **Installing Clients Using the Installation Wizard** on page 77.

On the Choose Product Type screen, select the correct product for your client license type.

Upgrading the File Vault Archives

Upgrading archives are only required if upgrading from EPDM 2008 or older.

To upgrade the file vault archive:

1. From the Windows **Start** menu, click **SOLIDWORKS PDM > Administration** to open the Administration tool.
2. If the archive server hosting the upgraded file vault does not appear in the left pane:
   a) Select **File > Add Server**.
   b) In the Add Server dialog box, select or enter the name of the archive server, specify the port, and click **OK**.
   c) Log in to the archive server using a Windows user account with administrative access to the archive server.
3. Expand the archive server in the left pane. File vault archives that require upgrading are listed under the archive server with a red icon.
   - If the icon is not shown, refresh the view by right-clicking the archive server name and selecting Refresh.
   - If the icon does not appear after refreshing, the file vault archive is up-to-date and no upgrade is required.

4. Right-click the archive name and click **Upgrade**.
   If you are prompted to log in, enter a SOLIDWORKS PDM username and password for a user with file vault management permission (usually **Admin**).

   Two messages appear:
   - The first warns that the upgrade can take a long time and that no users should be logged in.
   - The second states that a backup of the archive server should exist.

   If you have met these prerequisites, click **Yes** for both.

   During the archive upgrade, the Work Monitor window displays a progress bar. Do not end the process until the word “**Completed!**” appears.

   If you have multiple file vault archives to upgrade, you can start the upgrade on those also. They are added to the Work Monitor.

   When the upgrade finishes, you can view a log of the upgrade results by clicking **Show Log**.

5. Close the Work Monitor.

6. To verify that the upgrade was successful, log in to the file vault view and try to retrieve a file.

Upgrading a Replicated File Vault Archive (For SOLIDWORKS PDM Professional Only)

Upgrading file vault archives replicated on other servers requires additional configuration processes.

When upgrading archive servers hosting a replicated file vault, file vaults that require upgrading are listed with a red icon.

If the icon is not shown, refresh the view by right-clicking the archive server name and selecting **Refresh**. If the icon is still not shown, no upgrade is required.

If the icon is shown:

- You must upgrade the archive server software on all servers hosting the replicated vault. The selected archive will still be upgraded and you will have to launch the archive upgrade for the replicated servers separately once the software is upgraded.
- If the archive server software is upgraded on all replicated archive servers and they show up in the administration tree, the replicated file vault archive will be upgraded on all servers simultaneously.
- If the vault is replicated and the replicated archive servers are not listed in the administration tree, a dialog is shown where you can select to attach to the replicated server. If you opt not to connect, only the selected archive will be upgraded and you will have to launch the archive upgrade for the replicated servers separately.
After Upgrading File Vault Databases

SOLIDWORKS Enterprise PDM 2009 SP02 or later includes functionality to create and manage items. If you install this version and then upgrade a vault database from a previous installation, the upgraded database will not include the default item cards, item BOM, or the serial number that is used to generate item numbers.

To work with items in this vault, use the SOLIDWORKS PDM Administration tool to import the following cards and serial number:

- all(Item Card)_gb.crd
- all(Item Search Property)_gb.crd
- all(Item Search Simple)_gb.crd
- all(Item Search)_gb.crd
- all_Item Setup_languagecode.cex, where languagecode is the code for your language

Importing Item Cards (For SOLIDWORKS PDM Professional Professional Only)

1. From the Windows Start menu, click SOLIDWORKS PDM > Administration to open the Administration tool.
2. Right-click Cards and click Open.
3. In the Card Editor, click File > Import.
4. In the Open dialog box, for Look in, navigate to install_dir\Default Cards.
5. In the card list, select all(item Card)_gb.crd, and click Open.
6. Click File > Save to save the card to the vault.
7. Repeat steps 3 through 6 to import the rest of the item data cards.

Importing the Serial Number and Item BOM (For SOLIDWORKS PDM Professional Professional Only)

1. Right-click the upgraded vault and select Import.
2. In the Open dialog box, for Look in, navigate to install_dir\Default Data.
3. In the file list, select all_Item Setup_language.cex, and click Open.
4. In the confirmation message, click OK.

Upgrading the Remaining Clients

When the file vault database and archive have been upgraded and you have verified that the upgraded vault is accessible, you can upgrade the remaining clients to SOLIDWORKS PDM.

Use the same procedure as when you upgraded the first client. For details, see Upgrading the Initial SOLIDWORKS PDM Client.

After Upgrading Clients

After updating SOLIDWORKS PDM clients, complete the post-processing configuration steps.

After upgrading:

- In the SOLIDWORKS PDM administration tool, ensure that you have valid license.
- Update the dispatch and task add-ins.
When you perform these tasks on one client, they are distributed to other clients automatically.

Viewing the License Server for the Vault

1. From the Windows Start menu, click **SOLIDWORKS PDM > Administration** to open the Administration tool.
2. Browse to the file vault in the left pane and log in as Admin.
3. Under the file vault, double-click **License**.
4. In the Set License dialog box, ensure that a valid license server is displayed.

Updating Dispatch Add-in (For SOLIDWORKS PDM Professional Only)

1. In the SOLIDWORKS PDM administration tool, under the file vault, expand **Add-ins**.
2. To update the Dispatch add-in:
   a) Right-click **Dispatch** and click **Remove**.
   b) Click Yes to confirm that you want to remove the add-in.
   c) Select File > Open and browse to `C:\Program Files\SolidWorks Corp\SOLIDWORKS PDM\Default Data`.
   d) Change filter to show .caf files.
   e) Open Dispatch.caf.
   f) Drag and drop Dispatch add-in from the .caf file under the Add-ins node for the vault.
   g) Close the administration vault.

The updated add-ins are distributed automatically to the other clients when they log in.

Upgrading the SOLIDWORKS Task Add-in (For SOLIDWORKS PDM Professional Only)

To ensure that the latest, updated version of an add-in such as the SOLIDWORKS Task Add-in is running, you must manually upgrade the add-in.

When you upgrade a file vault to a new service pack or version, existing add-ins are not automatically updated. This is to prevent updated information in the add-ins from overwriting your customizations.

For example, you may have customized the tasks controlled by the SOLIDWORKS Task Add-in. You can continue to use your customized tasks and not upgrade. However, you will not be able to use new task functionality and may have problems starting tasks and processing upgraded SOLIDWORKS files.

To upgrade the tasks manually, copy the .cex files that contain updates for the SWTaskAdd-in, Convert, Design Checker, and Print tasks. The location of the .cex files depends on the method of installation of the client. If you install the client via the InstallShield Wizard, copy the .cex files to `C:\Program Files\SOLIDWORKS PDM\Default Data\` folder. If you install the client via the SOLIDWORKS Installation Manager, copy the .cex files to `C:\Program Files\SOLIDWORKS Corp\Default Data\` folder. You import one or more of these files to update the SWTaskAdd-in and the tasks it supports.
Determining the Current Versions of SOLIDWORKS PDM and the SOLIDWORKS Task Add-in

To ensure that you have the latest updates to the SOLIDWORKS Task Add-in, the SOLIDWORKS PDM Professional version and the SWTTaskAddin version should be the same.

1. To determine the SOLIDWORKS PDM version, in the SOLIDWORKS PDM administration tool, click Help > About SOLIDWORKS PDM Administration.
   The Build number field shows the version as:
   \[ TT.S(BB) \]
   where:
   - **TT** is the major release number since the year 1992. For example, 29 indicates 2021 version.
   - **S** is the service pack. For example, 3 = SP03.
   - **BB** is the build number. For example, 21.

2. To determine the version number of the currently installed SWTTaskAddin:
   a) In the Windows notification area, right-click the SOLIDWORKS PDM icon and click Task Host Configuration.
   b) In the Task Host Configuration dialog box, select the vault for which you want to verify the SWTTaskAddin version.
   The Version column displays the version in the following format:
   \[ TTSSBBBB \]
   where:
   - **TT** is the major release number since the year 1992.
   - **SS** is the service pack.
   - **BBBB** is the build number.

Performing the SWTTaskAddin Upgrade (For SOLIDWORKS PDM Professional Only)

If the version of SWTTaskAddin is earlier than the version of SOLIDWORKS PDM Professional, you can upgrade SWTTaskAddin by importing a .cex file.

1. From the Windows Start menu, click SOLIDWORKS PDM > Administration to open the Administration tool.
2. Log in to the vault where you want to upgrade SWTTaskAddin as an administrator.
3. Click File > Open.
4. Navigate to C:\Program Files\SOLIDWORKS PDM\Default Data\ and select Convert_GB.cex.
5. In the dialog box that appears, expand Convert_GB.cex, select SWTTaskAddin, and drag it to the Addins node in the left pane.
6. In the message box, select Yes to update the existing add-in.
7. In the Windows notification area, right-click the SOLIDWORKS PDM icon and click Task Host Configuration to verify that SWTaskAddin has been upgraded.

If the client you just upgraded acts as a task host, exit SOLIDWORKS PDM and log in again before performing the verification.

Upgrading Tasks

After you upgrade the SWTaskAddin, you can import the latest versions of the Convert, Print, and Design Checker tasks.

This procedure describes how to upgrade the Convert task.

1. In the Administration tool, expand the Tasks node.
2. If any tasks have the default names Convert, Print, or Design Checker, rename them so that customizations you have made to the tasks are not overwritten.
3. Click File > Open.
4. To upgrade the Convert task, navigate to C:\Program Files\SOLIDWORKS PDM\Default Data\ and select Convert_GB.cex.

   If the product is installed via SLDIM, the default path is C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS PDM.
5. In the dialog box that appears, under Tasks, select Convert, and drag it to the Tasks node in the left pane.
6. Make changes to the newly imported task to match the previously used task and configure any new options as required.

   This includes the file paths and name formats, conversion types, which computers run as a task host, permissions for the task, notifications etc.
7. If the existing task had modifications to the Advanced Scripting options (accessed from the Output File Details page), make those changes to the new version of the script.

   The Advanced Script is often updated for a new version of SOLIDWORKS PDM to make use of new features in SOLIDWORKS or to add new features to the task. Therefore you may need to merge the new scripting with your custom scripting.

   Add comments to the script to make it easier to understand and easier to transfer the customization the next time you update.

   Retain the default Convert task for reference and for testing if problems arise with a customized Convert task. Set permissions so that it can only be seen by the Admin user.
8. Modify workflow transitions that caused the original task to be executed and select the updated task as the task to execute.

   Save the workflow changes.
Upgrading Toolbox in SOLIDWORKS PDM

If you have integrated SOLIDWORKS Toolbox with SOLIDWORKS PDM, when you upgrade the SOLIDWORKS software, Toolbox is upgraded if parts have been added.

Before you run SOLIDWORKS Installation Manager to start the upgrade, you must prepare the Toolbox folder.

- On the first computer to perform the upgrade, you must check out the Toolbox database so that the SOLIDWORKS Installation Manager can write to it. Use Get Latest Version to download the Toolbox parts to the local cache so that the installer can verify whether parts need to be updated or added.
- To upgrade additional computers, get the latest versions of the Toolbox files from SOLIDWORKS PDM before running SOLIDWORKS Installation Manager.

To upgrade the first SOLIDWORKS PDM computer:

1. In Windows File Explorer, log in to the vault as a user with full permissions (check out, check in, add, delete).
2. Navigate to the Toolbox folder in the vault.
3. Right-click the Toolbox folder and click Get Latest Version to copy all Toolbox files and the toolbox database to the local cache.

   If your archive server is remote, this may take several minutes.

4. For upgrades, you must check out the Toolbox database file:
   - From SOLIDWORKS 2014 or earlier, check out:
     \vault_name\Toolbox_folder_name\lang\your_language\SWBrowser.mdb.
   - From later versions of SOLIDWORKS, check out:
     \vault_name\Toolbox_folder_name\lang\your_language\swbrowser.sldedb.

5. Run the SOLIDWORKS Installation Manager to upgrade the SOLIDWORKS software (including SOLIDWORKS Toolbox).
6. On the Summary screen, ensure that the Toolbox Options installation location is the location in the vault.
   If it is not, click Change, select Reference or upgrade an existing Toolbox, and browse to the Toolbox location in the vault.
7. For upgrades from SOLIDWORKS 2014 or earlier, when the upgrade completes, in Windows File Explorer, browse to the folder noted in step 4. Add the Toolbox database file swbrowser.sldedb to the vault.
   You can add other local files that are created in this folder to the vault.
8. For all upgrades, check in the Toolbox folder to add any new or updated files to the vault so that other users can work with Toolbox.
9. For upgrades to SOLIDWORKS 2012 or later, navigate to your Toolbox folder in the vault and ensure that the following are present:
   - \Toolbox_folder_name\Updates
   - \Toolbox_folder_name\ToolboxStandards.xml
   - \Toolbox_folder_name\Browser\ToolboxFiles.index

   If they are not, contact your Value Added Reseller.
To upgrade additional computers, before initiating the SOLIDWORKS PDM upgrade, use **Get Latest Version** to download the vault Toolbox folder to the local cache.

SOLIDWORKS Installation Manager will verify that the Toolbox files are up-to-date when you run the installation.
Upgrading SOLIDWORKS Files

This chapter includes the following topics:

- Upgrading SOLIDWORKS Files
- Required Upgrade Utility Software
- System Requirements
- Installing the File Version Upgrade Utility
- Preparing to Upgrade
- Selecting Version Settings
- Performing a Trial File Upgrade
- Running the Upgrade Utility
- Creating and Using Work Instruction Files
- Completing an Interrupted Upgrade
- After Upgrading
- Managing Backup Files

Upgrading SOLIDWORKS Files

The SOLIDWORKS® PDM File Version Upgrade tool upgrades SOLIDWORKS files from an earlier version to a later SOLIDWORKS file format.

After you upgrade files, you cannot open them in older SOLIDWORKS versions.

The tool automatically checks out, upgrades, and checks in SOLIDWORKS files that are stored in the SOLIDWORKS PDM vaults. File references, revision tags, and workflow states are kept intact.

The only file formats that are upgraded are .sldprt, .slddrw, and .sldasm. Upgrade SOLIDWORKS template and block files manually.

Several workstations, each running the upgrade tool, can perform concurrent upgrades to reduce the upgrade time. The first workstation to run the upgrade tool acts as the coordinator workstation, which creates the upgrade plan. The plan consists of several work instruction files, one for each workstation participating in the upgrade process. For more details, see Creating and Using Work Instruction Files.
The work instruction files contain tree structures that reflect the parent-child relationships of the SOLIDWORKS files. Both coordinator and agent workstations can run additional work instruction files after they finish processing the first one. Although parts and subassemblies can be shared by other assemblies, each file is only upgraded once.

If an assembly references parts that are not at the latest version, you can choose a version setting that links the assembly with the latest version of the parts it references. Alternatively, you can choose a version setting that overwrites the existing version of referenced files with the latest version of the files. See Selecting Version Settings.

Required Upgrade Utility Software

The SOLIDWORKS PDM 2021 file version upgrade tool can be used with SOLIDWORKS 2021, 2020, and 2019.

System Requirements

System requirements depend on the vault database being upgraded. They are affected by the structure of the database, including the number of files, versions, and references being converted.

Use powerful workstations. As files are opened and resaved in SOLIDWORKS, it is important that the workstations used have sufficient resources to handle even the largest assembly structures. Use powerful workstations with enough RAM and plenty of free hard disk space.

For more details, see System Requirements on the SOLIDWORKS website.

Stop any non-essential processes to free up as many resources as possible on the workstations being used.
The following are specific recommendations:

- **Archive server**
  
  When the conversion is performed by overwriting existing versions of files, a backup is created for each overwritten file. The archive server must have disk capacity to store these backup files.
  
  Before the upgrade begins, a screen message notifies you of the space needed, based on the files you have selected to upgrade.

- **Workstations**
  
  All workstations that will be used for the upgrade must have enough RAM to open the largest assembly to be converted.

### Installing the File Version Upgrade Utility

The File Version Upgrade Utility is provided on the SOLIDWORKS installation media in the `SWPDMClient\Support\File Version Upgrade\` directory.

**To install the File Version Upgrade Utility:**

1. Navigate to the `SWPDMClient\Support\File Version Upgrade\` on the Installation media.
2. Double-click **File Version Upgrade.exe**.
3. In the Welcome screen, click **Next**.
4. Accept the license agreement and click **Next**.
5. Click **Install**.
6. Click **Finish**.

### Preparing to Upgrade

Prepare the workstations involved in the upgrade before you begin the upgrade process.

Perform a complete vault backup, including:

- File vault database
- Archive files

On the coordinator and agent workstations that are participating in the upgrade process:

1. Install the same version and revision level of SOLIDWORKS PDM client.
2. Create local views of the file vault to be upgraded.
3. Check all files into the vault.
4. Close SOLIDWORKS.

On the coordinator workstation:

1. Give participating clients read/write access to all files in the vault you are upgrading.
2. Create a folder for the work instruction files and share it with full (read/write) permissions for all participating clients.
Selecting Version Settings

The Version Settings screen lets you specify which versions and revisions of your selected file type will be upgraded and whether old versions will be overwritten.

Before you perform a full conversion, test the conversion of older files by opening a sample set in the target version of SOLIDWORKS to check for any conversion errors.

Select **Create new version of files** if you want only the most recent versions of files to be upgraded and to preserve the existing versions of the files in the older file format. New SOLIDWORKS PDM versions are created.

Select **Overwrite existing versions of files** if you want to:
- Overwrite all versions of files with upgraded files.
- Specify which versions of files to overwrite by selecting one or both of the following:
  - **Latest version** The tool upgrades the latest versions of files plus all files that they reference.
  - **Versions with a revision** The tool upgrades all files with revision tags.

If you choose to overwrite existing versions, the File Version Upgrade tool creates a backup of files before upgrading them. You can delete backed up files after confirming that the upgrade is successful. See *Managing Backup Files*.

Assemblies that contain cyclic references are not upgraded if you select to overwrite existing versions of files.

Upgrade Scenarios

The following topics illustrate the possible upgrade scenarios for the set of files below.
Creating New Versions of Files

When you create new versions of files, the older versions still exist and can continue to be opened in the older version of SOLIDWORKS.

Relinking to the Latest Version of Referenced Files

You can relink an assembly to the latest version of the files that it references.

If the assembly and its subassemblies reference versions of parts that are not the latest version, the references are moved to the latest versions of the parts.

Older versions of the parts, assembly, and subassembly are not upgraded and their references are not affected.

If the newer versions of referenced files have undergone geometry modifications, using this option could result in unwanted assembly changes or rebuild errors. In addition, if file properties such as Part Number, Description, or Material have changed, in the newer versions, this could cause changes in Bills of Materials.

Selections represented In the diagram below are:

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to</td>
<td>Files of type</td>
<td>&lt;All SW file types&gt;</td>
</tr>
<tr>
<td>Upgrade</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

152
Upgrading SOLIDWORKS Files

### Screen | Option | Selections
--- | --- | ---
Version Settings | Create new version of files | Files referencing older versions
|  |  | • Are re-linked to the new version
|  |  | Update revisions
|  |  | • Do not update revision

Moving Existing Revision Tags

You can move the latest revision tag to the latest version of a file you are upgrading. Selections represented In the diagram below are:
Screen | Option | Selections
--- | --- | ---
Search Files to Upgrade | Files of type | <All SW file types>

Version Settings | Create new version of files | Files referencing older versions
• Are excluded

Update revisions
• Move revision

---

Files before upgrade, showing revision that is moved

Upgraded files

Incrementing Revision Tags

You can increment the revision tags on the latest versions of files as you upgrade the files.

Selections represented In the diagram below are:
### Upgrading SOLIDWORKS Files

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>&lt;All SW file types&gt;</td>
</tr>
</tbody>
</table>
| Version Settings | Create new version of files | Files referencing older versions  
  • Are re-linked to the new version  
  Update revisions  
  • Increment revision |

---

**Diagram:**

- Reference links before upgrade
- Files before upgrade, showing revision that is moved and incremented
- Reference links after upgrade
- Upgraded files
Overwriting Existing Versions of Files

When you overwrite the existing versions of files, the existing files are replaced with upgraded files. New versions are not created.

Overwriting the Latest Versions of Files

You can upgrade by overwriting the latest version of all files of the selected file type. Any version of a file that is used in a reference from an upgraded file is also upgraded.

**Overwriting the Latest Versions of All Files**

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>&lt;All SW file types&gt;</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Overwrite existing versions of files</td>
<td>Overwrite • Latest version</td>
</tr>
</tbody>
</table>

**Overwriting the Latest Version of Parts**

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>*.sldprt</td>
</tr>
</tbody>
</table>
By default, part drawings are not upgraded. However, because drawings are parents to parts, a Broken reference warning screen lets you select to upgrade the drawings that reference the parts that are being upgraded.

**Overwriting the Latest Version of Assemblies**
In a referenced version stream, the File Version Upgrade tool also upgrades the latest parts, as indicated by the blue boxes.

By default, part and assembly drawings are not upgraded. However, because drawings are parents to parts and assemblies, a Broken reference warning screen lets you select to upgrade the drawings that reference parts and assemblies that are being upgraded.

**Overwriting the Latest Version of Drawings**

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>*.slddrw</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Overwrite existing</td>
<td>Overwrite</td>
</tr>
<tr>
<td></td>
<td>versions of files</td>
<td>• Latest version</td>
</tr>
</tbody>
</table>
Overwriting Files with Revision Tags

You can include files with revision tags as files that are upgraded.

These examples show the files that are upgraded when you choose both Latest version and Version with a revision. Red boxes indicate files that are upgraded because they have revision tags, even though they are not the latest version.

Overwriting All Files with Revision Tags

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>&lt;All SW file types&gt;</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Overwrite existing</td>
<td>Overwrite</td>
</tr>
<tr>
<td></td>
<td>versions of files</td>
<td>• Latest version</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Version with a revision</td>
</tr>
</tbody>
</table>
Overwriting Parts with Revision Tags

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>*.sldprt</td>
</tr>
<tr>
<td>Version Settings</td>
<td>Overwrite existing versions of files</td>
<td>Overwrite</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latest version</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Version with a revision</td>
</tr>
</tbody>
</table>

Upgrading SOLIDWORKS Files
By default, part drawings are not upgraded. However, because drawings are parents to parts, a Broken reference warning screen lets you select to upgrade the drawings that reference the parts that are being upgraded.

Overwriting Assemblies with Revision Tags

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td>Files of type</td>
<td>*.sldasm</td>
</tr>
</tbody>
</table>
| Version Settings                | Overwrite existing versions of files | Overwrite  
  * Latest version  
  * Version with a revision |
In a referenced version stream, the File Version Upgrade tool also upgrades the latest parts, as indicated by the blue boxes.

By default, part and assembly drawings are not upgraded. However, because drawings are parents to parts and assemblies, a Broken reference warning screen lets you select to upgrade the drawings that reference parts and assemblies that are being upgraded.

**Overwriting Drawings with Revision Tags**

<table>
<thead>
<tr>
<th>Screen</th>
<th>Option</th>
<th>Selections</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Files to Upgrade</td>
<td><strong>Files of type</strong></td>
<td><em>.</em>.slddrw</td>
</tr>
<tr>
<td>Version Settings</td>
<td><strong>Overwrite existing versions of files</strong></td>
<td>Overwrite</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Latest version</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Version with a revision</td>
</tr>
</tbody>
</table>
Performing a Trial File Upgrade

Before upgrading the SOLIDWORKS files in a production vault, perform the upgrade on a copy of the production vault to ensure that there are no upgrade problems. You can contact your Value Added Reseller for help with creating a copy of your vault.

1. Restore a complete backup of the file vault to a separate server.
2. From the Windows Start menu, click SOLIDWORKS PDM > File Version Upgrade to start the File Version Upgrade Utility.
3. Follow the instructions in the upgrade wizard.
4. Verify that the upgrade is successful.
   See After Upgrading on page 165.

Running the Upgrade Utility

To run the upgrade utility:

1. From the Windows Start menu, click SOLIDWORKS PDM > File Version Upgrade to start the File Version Upgrade Utility.
2. On the Welcome screen, do one of the following:
   - To set up the upgrade, click Initiate a new upgrade process (Coordinator Workstation).
   - To run a work instruction file created for the upgrade, click Participate in an upgrade process (Agent Workstation).
   - To retry an upgrade that was terminated unexpectedly, click Restart an interrupted upgrade process (Coordinator and Agent Workstation).
3. Follow the instructions in the upgrade wizard.

Creating and Using Work Instruction Files

By creating work instruction files, you can run the upgrade tool concurrently on several workstations to reduce the upgrade time.

You create the work instruction files on the first workstation that runs the upgrade tool, which becomes the coordinator workstation.

To create and use work instruction files:
1. Create a shared folder and give each workstation that will participate in the upgrade Read/Write access.
2. From the Windows Start menu, click SOLIDWORKS PDM > File Version Upgrade to start the File Version Upgrade Utility.
3. On the Welcome screen, select Initiate a new upgrade process (Coordinator Workstation) and click Next.
4. Complete the wizard screens.
5. On the Upgrade Settings screen:
   a) Under Upgrade Settings, select Divide the upgrade work into multiple work instruction files.
   b) Specify the number of work instruction files to create.
   c) For Shared location for work instruction files, enter the name of the shared folder you created in step 1 or click the browse to navigate to the folder.
      The folder name must be in UNC format.
   d) Click Next.
6. On the Ready to Upgrade Files screen, do one of the following:
   • To upgrade now, click Yes.
     When a completion message appears, click OK.
   • To exit the upgrade utility and run work instruction files later, click No.
7. If you selected No in step 6, run the File Version Upgrade tool again to perform the upgrade using the work instruction files.
8. On the Welcome screen, select Participate in an upgrade process [Agent Workstation].
9. On the Select Work Instruction File screen:
   a) Browse to the location of the work instruction files.
   b) Select the work instruction file to process.
   c) Click Next.
      The Work Instruction File Summary displays with a read-only summary of the settings specified for the upgrade.
   d) Click Next.
10. On the Ready to Upgrade Files screen:
   a) Click **View Files** to see a list of files that will be upgraded.
   b) To upgrade the files, click **Yes**.
   c) When a completion message appears, click **OK**.

Completing an Interrupted Upgrade

Sometimes an upgrade is interrupted unexpectedly, for example, when you lose a network connection or lose power.

**To complete an interrupted upgrade:**

1. Click **Retry** in the error message.
2. In the message indicating that the conversion did not complete successfully, click **OK**.
3. Click **Exit**.
4. Solve the problem that caused the interruption.
   For example, restore the network or restart the computer.
5. Run the Upgrade utility again.
6. On the Welcome screen, select **Restart an interrupted upgrade process**
   *(Coordinator and Agent Workstation)*.
7. On the Continue Interrupted Migration screen, click **Next**.
8. On the Work Instruction File Summary screen, click **Next**.
9. On the Ready to Upgrade Files screen, click **Finish**.

After Upgrading

When the upgrade is complete:

- View the upgrade log files.
- Manually upgrade files that the tool was unable to upgrade automatically.

### Manual upgrade creates new versions. If you upgraded using Overwrite existing versions, manual upgrade will invalidate the reference structure.

- Optionally, use **Get Latest Version** to create local copies of files that were converted on other workstations.
- Open a subset of converted files in SOLIDWORKS to verify that the conversion was successful.
- If you selected to overwrite existing versions of files, after ensuring that the upgrade was successful, remove the backup files from the archive server.

File Name Formats for Upgrade Logs

Files names in upgrade logs take the following formats:

- Files that have been upgraded
  
  **Upgrade Utility <id>Batch<n>.log**
where:
- `<id>` is a unique alphanumeric string
- `<n>` is the number of the batch file for which the log was created

**Example:** Upgrade Utility 471F2FDS Batch 4.log

- Files that could not be upgraded

Upgrade Utility `<id>` Batch `<n>` .logExcluded.log

**Example:** Upgrade Utility 471F2FDS Batch 4.logExcluded.log

Managing Backup Files

If you choose to overwrite existing versions of files when you upgrade, the upgrade tool creates a backup file for each overwritten file. These backup files remain after the upgrade. You can remove them after you verify that the upgrade succeeded.

Backup File Creation

It is not possible to disable the backup option, so ensure that you have sufficient free disk space on the archive server before you start the upgrade.

The Ready to Upgrade Files screen gives an estimate of the amount of space that is needed.

For each file that is overwritten:

1. The upgrade tool retrieves the original version of the file from the file archive folder to the client system that is running a work instruction file to perform the upgrade.
2. The tool opens the file in SOLIDWORKS, upgrades it, and send it back to the archive folder when the batch process completes.
3. Before the version is replaced, the original version in the archive is renamed using the following format:

   `bak_counter_version.extension`

Where:

- `bak` is the prefix for all backup files.
- `counter` is a unique counter in case the existing file with the same backup name exists from a previous upgrade.
- `version` is the number, in hexadecimal format, of the file version that is being replaced.
- `extension` is the file extension.

4. The upgrade tool places the upgraded version of the file in the archive using the original file name.
Restoring an Incorrectly Upgraded Version from a Backup

If an upgraded version of a file is incorrect, you can use the backup file to restore the original content of the file.

1. In the local file vault view, determine the name of the file to find.
2. Open Microsoft SQL Server Management Studio and click **Connect**.
3. Expand **Databases** and select the vault containing the file you want to restore.
4. Click **New Query**.
5. In the right pane, type a query in the following format:
   ```sql
   select * from documents
   where filename like 'filename.ext'
   ```
   For example:
   ```sql
   select * from documents
   where filename like 'speaker_frame.sldprt'
   ```
6. Click **Execute**.
   Record the files DocumentID, which is listed in the Results tab.
7. Exit the SQL Server Management Studio.
8. Use a calculator to convert the DocumentID to hexadecimal format.
9. In an Explorer window, navigate to `install_dir\Program Files\SOLIDWORKS PDM\Data\vault_name`
10. Expand the vault archive that matches the last digit of the hexadecimal number.
    For example, if the hexadecimal number is 3B, expand the folder labeled **B**.
11. Expand the folder that matches the hexadecimal number.
12. Rename or delete the version of the file you want to restore.
    For example, rename `00000002.sldprt` to `00000002.backup`.
13. Rename the appropriate `bak_` file to the original file name.
    For example, rename `bak_0_00000002.sldprt` to `00000002.sldprt`.
Additional Configuration

This chapter includes the following topics:

- Managing the SQL Transaction Log Size
- Configuring SOLIDWORKS PDM to Communicate Using IP Addresses Only
- Moving Server Components to Another System

Managing the SQL Transaction Log Size

Each SQL database contains one database file (.mdf) and at least one transaction log file (.ldf). The database file stores the physical data added to the database, and the transaction log keeps records of database modifications. The SQL Server uses the transaction log to maintain database integrity, particularly during recovery.

By default, the recovery method of an SQL database is set to full recovery model, which means that every change to the database is logged. A large transaction log can grow until it is out of disk space and causes the performance of the SQL Server to drop.

The full recovery model is the best choice when you need to restore to an exact point in time. However, if you rely on nightly database backups, use the simple recovery model to limit transaction log size and maintain SQL Server performance.

To reduce the size of a large transaction log after you change to simple recovery model, shrink the transaction log.

For more details about changing the recovery model, see the SQL Server books online and search for Microsoft Knowledge Base article 873235 on https://support.microsoft.com/en-us.

Changing to the Simple Recovery Model

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, expand the Databases folder, right-click the database name and select Properties.
3. In the Database Properties dialog box, in the left pane, select Options.
4. In the Recovery model list, select Simple and click OK.
5. Close Microsoft SQL Server Management Studio.

Shrinking the Transaction Log

1. Right-click the database name, and select Tasks > Shrink > Files.
2. In the Shrink File dialog box, in the File type list, select Log.
3. Click OK.

Configuring SOLIDWORKS PDM to Communicate Using IP Addresses Only

By default, when setting up a SOLIDWORKS PDM environment, clients communicate with servers using system names. If the DNS lookup is unstable or not sufficient for the network setup, you can configure SOLIDWORKS PDM to use only IP-numbers to communicate.

This setup involves:
1. Updating the archive server
2. Updating the SQL Server
3. Updating the SOLIDWORKS PDM clients

When connecting to the archive server, you can remove and re-attach the file vault view using the archive server IP address instead of updating the registry manually.

Updating the Archive Server to Communicate Using IP Addresses

1. On the system running the archive server, from the Windows Start menu, click Run > regedit to open the registry.
2. Find the key for the archive server:
   HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks Enterprise\ArchiveServer
3. In the right pane, right-click and select New > String value and name the string value ServerName.
4. Double-click ServerName.
5. In the Edit string dialog box, in the Value data field, type the IP address of the archive server and click OK.
6. Find the key for the file vault:
   HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks Enterprise\ArchiveServer\Vaults\vaultname
7. Double-click Server, update the Value data field with the IP address to the SQL Server hosting the vault database, and click OK.
8. Restart the archive server service.

Updating the SQL Server to Communicate Using IP Addresses

1. Open Microsoft SQL Server Management Studio and click Connect.
2. In the left pane, expand Databases, the vault database, and Tables.
3. Right-click dbo.ArchiveServers and select Open Table.
4. Under ArchiveServerName, change the entry to the IP address of the archive server hosting the vault.
5. Right-click dbo.SystemInfo and select Open Table.
6. Under ArchiveServerName, change the entry to the IP address of the archive server hosting the vault.
7. Exit Microsoft SQL Server Management Studio.
Updating SOLIDWORKS PDM Clients to Communicate Using IP Addresses

1. If started, exit SOLIDWORKS PDM by clicking the SOLIDWORKS PDM icon on the right side of the task bar and selecting Exit. Ensure the administration tool is not running.

2. On the system running the archive server, from the Windows Start menu, click Run > regedit to open the registry.

3. Find the key for the file vault view:
   
   HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks Enterprise\Databases\vaultname

4. Update the DbServer value with the IP address to the SQL Server hosting the vault database.

5. Update the ServerLoc value with the IP address to the archive server hosting the vault archive.

6. If the administration tool was used on the client, delete the following key:
   
   HKEY_CURRENT_USER\Software\SOLIDWORKS\Applications\PDMWorks Enterprise\ConisioAdmin

   The key is recreated when starting the administration tool.

Verifying IP Address Communication

1. When all servers and clients are updated, verify that you can:
   - Log into the file vault.
   - Add a new file.
   - Retrieve an existing file.

2. If the vault is replicated, ensure you are using IP addresses in the replication settings dialog.

3. If you experience problems connecting with the new addresses:
   - Check the client and archive server log for errors.
   - Ensure that you can ping the servers from the client using the supplied IP addresses.

Moving Server Components to Another System

Use these procedures when moving SOLIDWORKS PDM server components from one system to another or when changing the name on the server system to verify which database and registry entries should be updated.

Ensure to move the components of SOLIDWORKS PDM Standard server on a machine that has SQL Server Express.

These instructions describe moving both the database and archive server. If you are moving only one, follow only those instructions that apply.
Before you start, tell users to exit all SOLIDWORKS PDM vaults. Users can work off-line while you are performing the move. After client registry keys are updated, users can check the work they do off-line into the new vault location.

Copying Files to the New Server

1. On the old SQL Server, back up the file vault database and the ConisioMasterDb. For details, see Backing Up the File Vault Database.
2. Copy the backup file to the new server.
3. From the Windows Start menu, click SOLIDWORKS PDM > Archive Server Configuration to open the SOLIDWORKS PDM Archive Server dialog box.
4. To make a backup of the archive server settings:
   a) Select Tools > Backup settings. For details, see Backing Up the Archive Server Settings.
   b) Clear or set a password, and click Launch backup.
   c) Close the SOLIDWORKS PDM Archive Server dialog box.
   d) Copy the backup file (backup.dat) to the new server.
5. Copy the entire file vault archive folder from the old server to the new server, maintaining the same path.

If you are unsure where the archives are located, check this registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks Enterprise\ArchiveServer\Vaults\vaultname\ArchiveTable

Configuring the Moved SQL File Vault Database

1. On the new server, install the SQL Server software. For details, see Installing and Configuring SQL Server.
2. To keep the collation settings the same as the old server:
   a) Open the Microsoft SQL Server Management Studio and click Connect.
   b) Right-click the server and select Properties.
   c) In the Server Properties dialog box, in the right pane, note the Server Collation setting of the old server.
   d) During the new SQL install, select Custom and set the same collation.
3. Restore the backed-up database, keeping the original name.

Stop the old SQL Server service or take the old databases offline so that you do not have two servers with the same vault database active.

4. In the restored file vault database, update with the new archive server name in tables ArchiveServers and SystemInfo.

In a replicated environment, the ArchiveServers table contains each replicated server. Be sure to update only the moved server entry. Do not change the VaultName entry.
Moving the SolidNetWork License Manager

If you need to move your license manager software to another server, you must transfer activated licenses to the license key server at Dassault Systèmes SOLIDWORKS Corporation.

To move the SolidNetWork License Manager software:
1. Transfer the activated license to the license key server. For more information, see Transferring a SolidNetWork License on page 58.
2. Install the SolidNetwork License Manager on the new server.
3. Reactivate the license. For more information, see Installing and Configuring SolidNetWork Licensing on page 55.

Moving the SOLIDWORKS PDM Database Server

If you move the SOLIDWORKS PDM database to a new system, you must move or reinstall the database server component.

Moving or reinstalling the database server component ensures that the database server receives updates such as notifications, local view refresh, replication schedule updates, and index server changes from the SOLIDWORKS PDM database.

To move the SOLIDWORKS PDM database server:
1. Uninstall the SOLIDWORKS PDM database server from the old server.
2. Install the SOLIDWORKS PDM database server on the new server.
3. When prompted to specify the SQL server that hosts the file vault databases, specify the name of the SQL server where you have moved the vault database.
4. To verify the Mail Service configuration:
   a) On the new server, expand the Start menu and type regedit in the Search programs and files field.
   b) Under Programs, right-click regedit.exe and click Run as administrator.
   c) In the Registry Editor, expand HKEY_LOCAL_MACHINE > SOFTWARE > SOLIDWORKS > Applications > PDMWorksEnterprise > MailService.
   d) Verify the Server value. The value is:
      • Blank if you have installed the SOLIDWORKS PDM database server on the same system as the SQL server and databases are running under the default SQL instance.
      • The SQL server name or instance name if the SQL server is on a different system or using a named SQL instance.

Configuring the Moved Archive Server

1. Install the archive server on the new server. Use the default settings used on the old server, if you can remember them.
   For details, see Installing SOLIDWORKS PDM Archive Server.
2. From the Windows Start menu, click SOLIDWORKS PDM > Archive Server Configuration.
3. In the SOLIDWORKS PDM Archive Server dialog box, select Tools > Backup settings.
4. In the Backup Settings dialog box, click Load Backup.
   The old archive server settings are imported.
5. On the new archive server, from the Windows Start menu, click Run > regedit to open the registry.
6. Update and verify the following keys, which may differ from the old server settings:
   - **HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks Enterprise\ArchiveServer\Computers\local\Archives**
     Ensure that the default value points to the correct archive folder (=parent) where
     the file vault archive is stored (that is, the path where the file vault archive folder
     was copied to). For example, type:
     
     C:\Program Files\SOLIDWORKS PDM\Data
     
     If the product is installed via SLDIM, the default path is C:\Program
     Files\SOLIDWORKS Corp\SOLIDWORKS PDM.
   - **HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks Enterprise\ArchiveServer\Vaults\vaultname**
     Ensure that Server value is updated to the new SQL Server name and SQLDbName
     matches the restored file vault database name. Do not change the DbName entry.
   - **HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorks Enterprise\ArchiveServer\Vaults\vaultname\ArchiveTable**
     Make sure all paths point to the file vault archive location where you copied the
     files to (from the old server.)
7. Stop the old archive server from running.
   Preferably disconnect the old server from the network so that it is not available until
   all clients are updated, or stop the archive server and SQL Server service.
Updating Client Registry Keys

1. On each client, update the following registry key:
   
   HKEY_LOCAL_MACHINE\SOFTWARE\SOLIDWORKS\Applications\PDMWorksEnterprise\Databases\vaultname

   Update the DbServer (database server) and ServerLoc (archive server) with the new server name.

   - On 64-bit clients update the DbServer and ServerLoc in this registry key:
     
     HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SOLIDWORKS\Applications\PDMWorksEnterprise\Databases\vaultname

   - For private vault views, update the DbServer and ServerLoc in this registry key:
     
     HKEY_CURRENT_USER\Software\Solidworks\Applications\PDMWorksEnterprise\Vaults\vaultname

2. On each client, delete the following registry key:
   
   HKEY_CURRENT_USER\Software\SOLIDWORKS\Applications\PDMWorksEnterprise\ConisioAdmin

Updating Replication Settings (For SOLIDWORKS PDM Professional only)

If you are moving the archive server components in a replicated environment, update the replication settings to reflect the new archive server name.

1. From an updated client, open the Administration tool and log in to the vault.
2. Right-click Replication Settings and click Open.
3. In the Replication Settings dialog box, under Connections, select the first row.
4. Under Selected connection, for IP address or DNS name, type the new IP address or name of the moved archive server.
5. Restart the archive server service on each archive server that is replicating the file vault.

Verifying the Server Move

1. Log in as the Admin user and view the file vault listing.
2. Make sure that the archive server fully works by adding a text file, checking it in, and deleting it.

   If you cannot log in to the vault, or add, check out, or modify files, make sure that the path to the file vault archive folder that you specified in step 5 of Copying Files to the New Server is correct.
Installing SOLIDWORKS Manage Professional

This chapter includes the following topics:

• Listing of SOLIDWORKS Manage Server Components
• SOLIDWORKS Manage Client Types and Licenses
• Prerequisites and System Requirements for SOLIDWORKS Manage
• Using SOLIDWORKS Installation Manager for SOLIDWORKS Manage
• Using a Command Prompt for SOLIDWORKS Manage Installation
• Editing the SOLIDWORKS Manage Configuration File

SOLIDWORKS Manage Professional has a similar architecture to SOLIDWORKS PDM Professional. It uses a client-server architecture, with a Microsoft SQL Server database to manage item and project data. There are three services for database, file server, and web server functions, which support both thick clients and web browser clients. The three services can be hosted on the same server or separate servers.

Listing of SOLIDWORKS Manage Server Components

This table summarizes the components of SOLIDWORKS Manage Server.

<table>
<thead>
<tr>
<th>Component</th>
<th>Function</th>
<th>Installation</th>
</tr>
</thead>
<tbody>
<tr>
<td>SolidNetWork License</td>
<td>Controls SOLIDWORKS Manage and SOLIDWORKS PDM licenses.</td>
<td>Can install with SOLIDWORKS Manage, or use a version previously installed for SOLIDWORKS PDM.</td>
</tr>
<tr>
<td>Manager</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SOLIDWORKS Manage File</td>
<td>Manages data, reports, and other elements of SOLIDWORKS Manage.</td>
<td>Required; install with SOLIDWORKS Manage.</td>
</tr>
<tr>
<td>Server</td>
<td></td>
<td></td>
</tr>
<tr>
<td>SOLIDWORKS Manage Web</td>
<td>Provides access to SOLIDWORKS Manage features over the Internet</td>
<td>Optional; install with SOLIDWORKS Manage.</td>
</tr>
<tr>
<td>Server</td>
<td>from browser-based clients.</td>
<td></td>
</tr>
<tr>
<td>SOLIDWORKS Manage Email</td>
<td>Allows SOLIDWORKS Manage to send email messages.</td>
<td>Optional; install with SOLIDWORKS Manage.</td>
</tr>
<tr>
<td>Server</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Installing SOLIDWORKS Manage Professional

<table>
<thead>
<tr>
<th>Component</th>
<th>Function</th>
<th>Installation</th>
</tr>
</thead>
<tbody>
<tr>
<td>SWmanage.swmc</td>
<td>Contains connection information for SOLIDWORKS Manage server and clients to the SQL Server database and the SolidNetWork License Manager.</td>
<td>Generated when the SOLIDWORKS Manage Server is installed.</td>
</tr>
</tbody>
</table>

SOLIDWORKS Manage Client Types and Licenses

Three client types are available for SOLIDWORKS Manage Professional:
- Editor
- Contributor
- Viewer

The SOLIDWORKS Manage clients all provide access to information stored in SOLIDWORKS Manage Professional and SOLIDWORKS PDM Professional, but the editing capabilities of each client type vary, as listed in the following table.

<table>
<thead>
<tr>
<th>Capability</th>
<th>Manage Editor</th>
<th>Manage Contributor</th>
<th>Manage Viewer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search, view and print documents and records</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>View CAD data</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Create and edit CAD data</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>View non-CAD data</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Create and edit non-CAD data</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>View project status and timesheets</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Update project status and timesheets</td>
<td>X</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>View dashboards, run and export reports</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>View processes and history</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
### Prerequisites and System Requirements for SOLIDWORKS Manage

Before installing SOLIDWORKS Manage Professional:

- Obtain full administrative rights to the machines on which you are going to install SOLIDWORKS Manage servers and clients.
- If you are going to use an existing SQL Server database, obtain the name of the SQL Server instance, and the account ID and password of a SQL Server administrator or database owner with read/write access to the database. You cannot use the tew user.

If you are installing a new SQL Server database for SOLIDWORKS Manage, follow the instructions in **Installing and Configuring SQL Server** on page 17.

---

<table>
<thead>
<tr>
<th>Capability</th>
<th>Manage Editor</th>
<th>Manage Contributor</th>
<th>Manage Viewer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start and update processes on any object</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Start processes via PDM Workflow action</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>View BOMs</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Create and edit BOMs</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>View Tasks</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Assign and update Tasks</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Participate in PDM workflows</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

Each SOLIDWORKS Manage Professional license includes a SOLIDWORKS PDM Professional license of the same client type. For example, a SOLIDWORKS Manage Professional Editor license includes a license to use SOLIDWORKS PDM Professional CAD Editor on the same machine.

You can upgrade existing licenses of SOLIDWORKS PDM Professional to SOLIDWORKS Manage licenses. With the upgrade, users can access both Manage Professional and PDM Professional on the same machine.

You must upgrade to SOLIDWORKS PDM Professional 2018 before licensing SOLIDWORKS Manage Professional. SOLIDWORKS Manage Professional does not work with SOLIDWORKS PDM 2017 or earlier versions.

Users with SOLIDWORKS Manage Professional Editor licenses can also run the SOLIDWORKS Manage Add-in to access Manage data directly from within the SOLIDWORKS software.
• If you are going to use a license server that has already been installed, obtain the port number and server name for the SolidNetWork (SNL) server.

• Microsoft .NET Framework 4.6.2 and Visual C++ Redistributable Runtimes (vc_redist.x64.exe) must be installed on the machine where the SOLIDWORKS Manage Server is installed. These files are automatically installed when you use the SOLIDWORKS Installation Manager to install SOLIDWORKS Manage.

• Install and configure Microsoft Internet Information Services (IIS). Instructions are available in Configuring SOLIDWORKS Manage Professional and Microsoft IIS on page 181.

SOLIDWORKS Manage Professional has the same system requirements as SOLIDWORKS PDM Professional. You can review requirements at http://www.solidworks.com/sw/support/pdmsystemrequirements.html.

Using SOLIDWORKS Installation Manager for SOLIDWORKS Manage

Installing the SOLIDWORKS Manage Server

When you install the SOLIDWORKS Manage Server, you can install the File Server, Web Server, and Email Server on the same machine. The File Server is required, but the Web Server and Email Server are optional.

To install the SOLIDWORKS Manage Server:

1. Start the SOLIDWORKS Installation Manager.

2. On the Welcome page, select Server Products, and select Install SOLIDWORKS Manage Server components on this computer.

   The Install SOLIDWORKS PDM Server components on this computer and the Install SolidNetWork License Manager (distributed licensing) on this computer boxes are selected automatically. Clear them if you do not want to install the SOLIDWORKS PDM Server or the SolidNetWork License Manager on this machine.

3. On the Summary page, for SOLIDWORKS Manage Server, click CHANGE.

   a) For Installation Location, accept the default path or click Browse to specify a different path.

   b) In the SQL Server section:

      1. For Name, accept the default or click Browse to specify a new host name.

      2. Enter the Login Name and password of a SQL Server administrator or database owner with read/write access to the database.

      3. To create a new database, select Create New Database, and select a template.

      4. To use an existing database, select Use Existing Database, and enter the name of the existing database or browse to it.

   c) In the License Server section, enter the port number and server name of the SolidNetwork (SNL) server.

   d) A File Server must be installed for the SOLIDWORKS Manage Server to operate. Clear options to install the Web Server and the Email Server if you do not want to install them.

   e) Click Back to Summary.
4. On the Summary page, accept the terms of the SOLIDWORKS License Agreement and click **Install Now**.

Installing the SOLIDWORKS Manage Client

This procedure lists the steps for installing the SOLIDWORKS Manage client with the SOLIDWORKS PDM client. If you already have the SOLIDWORKS PDM client installed or if you do not need to install the PDM client, the steps are slightly modified.

**To install a SOLIDWORKS Manage client:**

1. Start the SOLIDWORKS Installation Manager.
2. On the Welcome page, select **Individual**.
3. On the Serial Number page, click **Next**.
4. Follow instructions for system warnings and click **Next**.
5. On the Summary page, under Products, click **Change**.
6. On the Product Selection page, click **Select different packages or products**.
7. On the Product Selection page, select **SOLIDWORKS Manage Client**. The **SOLIDWORKS PDM Client** is also selected automatically. Click **Back to Summary**.
8. On the Product Selection page, select **SOLIDWORKS PDM Client**.
9. On the SOLIDWORKS PDM Client Options page:
   a) Select **SOLIDWORKS PDM Professional**.
   b) Select the PDM client type that matches your SOLIDWORKS Manage client type.
   c) If you have a license for SOLIDWORKS Manage Professional Editor, you can select **SOLIDWORKS Add-in** to access Manage data directly within the SOLIDWORKS software.
   d) Click **Back to Summary**.
10. On the Summary page, accept the terms of the SOLIDWORKS License Agreement and click **Install Now**.

   The SOLIDWORKS Manage client and the SOLIDWORKS PDM client does not have to be the same version or service pack as the SOLIDWORKS software.

Using a Command Prompt for SOLIDWORKS Manage Installation

You can install SOLIDWORKS Manage silently using a command prompt.

**To install SOLIDWORKS Manage using a command prompt:**

1. From the Windows **Start** menu, open a command prompt.
2. Enter the appropriate command from the following table to start installation. You can use the switch `/qn` for silent installation.

<table>
<thead>
<tr>
<th>Add-in</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Without any add-in</td>
<td><code>msiexec.exe /i &quot;&lt;path to SOLIDWORKS Manage Client.msi&gt;&quot; /qn</code></td>
</tr>
<tr>
<td>SOLIDWORKS add-in</td>
<td><code>msiexec.exe /i &quot;&lt;path to SOLIDWORKS Manage Client.msi&gt;&quot; ADDLOCAL=SWManageClient,Editor /qn</code></td>
</tr>
<tr>
<td>SOLIDWORKS and MS Office add-in</td>
<td><code>msiexec.exe /i &quot;&lt;path to SOLIDWORKS Manage Client.msi&gt;&quot; ADDLOCAL=SWManageClient,Editor,MSOfficeAddIn /qn</code></td>
</tr>
</tbody>
</table>

**Editing the SOLIDWORKS Manage Configuration File**

SOLIDWORKS Manage uses a configuration file named `SWmanage.swmc` that provides clients with information about the database server and the license server. This file stores the SQL Server user name and password, which are encrypted in the file, and the license server information that was entered during the server installation.

When you install SOLIDWORKS Manage Server, the configuration file is created automatically and stored in the SOLIDWORKS Manage Server installation folder, typically `C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Manage Server\Fileserver`. All users must have access to this configuration file. It cannot be stored in a PDM vault.

**To edit the SWmanage.swmc file:**

1. Browse to the **Server Utilities** folder located under the SOLIDWORKS Manage installation folder, typically `C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Manage Server\Server Utils`. Then double-click the **SWM.configwizrd.exe** file.
2. When the Configuration Wizard opens, click **Open** and browse to the Manage configuration file, `SWmanage.swmc`.
3. Type the SQL Server sa username entered during the server installation.
4. Modify any of the information in the file, if needed, and click **Save**.
5. Type a password for the file. This password can be the same as the SQL Server password used previously or different.
6. Copy and store the modified `.swmc` file in each of these server components.
   - Fileservers
   - Webforms
   - Notifications
7. Make sure that the modified `.swmc` file is available to every SOLIDWORKS Manage client.
This chapter includes the following topics:

- Logging In to SOLIDWORKS Manage for the First Time
- Using the SOLIDWORKS Manage Add-In for SOLIDWORKS PDM
- Using the SOLIDWORKS Manage Add-in for SOLIDWORKS
- Configuring IIS

Logging In to SOLIDWORKS Manage for the First Time

This procedure does not provide details on each of the dialog boxes in the wizard. It describes how to connect a PDM vault to SOLIDWORKS Manage with minimal configuration.

To log in to SOLIDWORKS Manage for the first time:

1. In Windows, click Start > SOLIDWORKS version > SOLIDWORKS Manage version.
   A warning that the configuration file does not exist appears.

2. Click OK.

3. In the SOLIDWORKS Manage dialog box:
   a) Click.
   b) Browse to the SOLIDWORKS Manage configuration file, SWmanage.swmc.
   c) (Optional.) Click Options to set interface schemes or set a different license type.
   d) Type the User Name and Password that have administrator privileges.
   e) Click OK.

4. In the SOLIDWORKS Manage dialog box, on the Options tab, click Administration Options.
   The System Administration dialog box appears, where you can configure SOLIDWORKS Manage and access the SOLIDWORKS PDM Administration tool.

5. Optional: In the System Administration dialog box, connect to a PDM vault:
   a) Click Structures.
   b) Click Documents & Records.
   c) Click New PDM Object.

6. In the SW PDM Configuration dialog box, on the Connection screen, click Next.
7. Under **Object:**
   a) Enter a **Name**.
      You can use any name, but it is typically the name of the PDM vault to which you connect.
   b) In **Numbering Scheme**, select **Simple**.
      Every object in SOLIDWORKS Manage requires a number. Even though part numbers for PDM records in SOLIDWORKS Manage often come from PDM variables, you must specify a **Numbering Scheme** in SOLIDWORKS Manage.
   c) (Optional.) In **Database**, select a vault.
      The SQL Server and PDM vault database are preselected. SOLIDWORKS Manage reads all of the PDM Professional vaults that exist on the server.
   d) Click **Next**.

8. On the **Fields** screen, click **Next**.

9. On the **Bill of Materials** screen, click **Next**.

10. On the **Part Number, Description, and Revision** mapping screen, click the following:
    a) (Optional.) **Auto map All**. SOLIDWORKS Manage uses PDM variables named **Number, Description, and Revision**. If a variable on each of the listed data cards exists with those names, it changes the values in the table.
    b) (Optional.) **Number, Description, and Revision**. Maps only those variables.
       On this screen, you can configure which PDM data card variables are used for the required **Part Number, Description, and Revision** fields. By default, SOLIDWORKS Manage uses the file name as the part number and description and the PDM version number for the revision. If the variables on your PDM data cards do not match the default names, you can set the variable for each item in the table.

       There are reported issues with auto mapping with the **Number** variable. If you experience this problem, manually set the **Number** variable.

    c) Click **Next**.

11. On the **Configuration Options** screen:
    a) Select **Create records based on the following conditions**, but do not enter any conditions.
       SOLIDWORKS Manage can create one record for each SOLIDWORKS part and assembly file or create records for all configurations. When records are created for each configuration, some configurations can be designated as **Active** so they can be used in items such as Bills of Materials, Processes, and Projects. **Inactive** configurations are not visible in the main areas of SOLIDWORKS Manage and only appear when viewing the details of a record.
       To automatically designate certain configurations as being **Active** or **Inactive**, you can configure conditions. If you select **Do not create records based on the following conditions** and no conditions are listed, then an active configuration record is created for every configuration in the SOLIDWORKS file. If you select **Create records based on the following conditions** and no conditions are listed, then only the PDM @ configuration is designated as active. For the purpose of this initial setup, you select **Create records based on the following conditions**.

    b) Click **Next**.
12. On the PDM Projects screen:
   a) In the folder structure list, click the root folder.
   b) Select Any State.
   c) Click Save.
   d) Click Next.

   SOLIDWORKS Manage can configure when a record is created for files in a SOLIDWORKS PDM Professional vault based on the PDM workflow state. This is helpful in a hybrid environment where SOLIDWORKS Manage and SOLIDWORKS PDM Professional users work in the same PDM vault or other scenarios. Once a record is created in SOLIDWORKS Manage for a PDM file, the only way you can edit it is with a SOLIDWORKS Manage client. SOLIDWORKS Manage licenses allow a logged in user to access a PDM vault.

   SOLIDWORKS Manage can automatically create a process whenever you send a file in SOLIDWORKS PDM Professional through a specific transition. For instance, this could be used to start an Engineering Change Request process when you use the Request Change transition. For the purposes of this initial setup, do not specify any processes to start.

13. On the SW PDM - SW Manage Users and Groups screen:
   a) In the Admin row, click the SW Manage User column and select Admin System.
   b) Click Next.

   SOLIDWORKS Manage can read and create users and groups from SOLIDWORKS PDM Professional. It is important to set up the system administrator for SOLIDWORKS Manage and SOLIDWORKS PDM Professional to be the same user with the same password. The other PDM users and groups should already be set.

14. On the Access Rights screen, accept the default settings where all users in the organization have Full control and click Next.

15. On the Attached Files screen, accept the default settings of only allowing Related Files and the Files folder and click Next.

   SOLIDWORKS Manage has different ways of connecting records to other records and noncontrolled files. Related files are noncontrolled files that you can attach to a record and are only visible from within the record. These files can be items such as email messages, image files, and reports. References are links to other records in SOLIDWORKS Manage. To organize Related Files, you can define a series of folders as required.

16. On the Tab Properties screen:
   a) Under Enabled, select the check boxes for Properties, BOM, SW Configurations, Related Files, Where Used, and ToDo.

   SOLIDWORKS Manage has property tabs that display information about each record, similar to the SOLIDWORKS PDM Professional tabs displayed in Windows File Explorer. Access rights are automatically assigned to all users.

   b) (Optional.) Change the tab names by clicking any row under Display Name.

   You can configure each property tab to change the Display Name and whether a certain user or group can see a particular tab.

   c) Click Next.
17. On the following screens, click Next:
   - Reports
   - Special Objects
   - Notifications

18. On the Email screen, click Finish.
19. If you are asked to resync the data, click Yes.
20. Close the SOLIDWORKS Manage Administration Tool dialog box.
21. Optional: In the SOLIDWORKS Manage dialog box, on the left pane, right-click an empty space and click Refresh Tree.
   This shows the SOLIDWORKS PDM Professional vault inside the SOLIDWORKS Manage Documents & Records.

Using the SOLIDWORKS Manage Add-In for SOLIDWORKS PDM

SOLIDWORKS Manage has an add-in for SOLIDWORKS PDM Professional so that SOLIDWORKS Manage functions and data are available within Windows File Explorer. This includes a tab in Windows File Explorer that displays SOLIDWORKS Manage information related to a selected file.

To use the SOLIDWORKS Manage Add-in for SOLIDWORKS PDM:
1. Open the SOLIDWORKS PDM Professional Administration tool.
2. Log in to the vault that you connected to in Logging In to SOLIDWORKS Manage for the First Time on page 181.
3. Right-click Add-ins and click New Add-in.
4. Navigate to the SOLIDWORKS Manage client installation (such as C:\Program Files\SOLIDWORKS Corp\SOLIDWORKS Manage Client) and select SWM.swpdm.dll and EPDM.Interop.epdm.dll.
5. Click Open.
6. Click OK twice to close the Add-in dialog box and the message about restarting client machines.
7. If you are logged in to SOLIDWORKS PDM Professional, right-click the icon in the taskbar and click Exit.
8. In the SOLIDWORKS Manage add-in, log in to the vault's local view. There is a SOLIDWORKS Manage tab and new menu items available.

Using the SOLIDWORKS Manage Add-in for SOLIDWORKS

SOLIDWORKS Manage has an add-in for the SOLIDWORKS software that you can use with the SOLIDWORKS PDM add-in. An advantage of the SOLIDWORKS Manage add-in is that it has a built-in search function. You can check files out and in from either add-in.

To use the SOLIDWORKS Manage add-in for SOLIDWORKS:
1. In SOLIDWORKS, click Tools > Add-Ins.
2. Select SOLIDWORKS Manage and click OK.
3. Log in to SOLIDWORKS Manage.
   Logging in does not consume another license.
   SOLIDWORKS Manage is available in the Task Pane.

Configuring IIS

To configure Internet Information Services (IIS):
1. In Windows, click Start > Control Panel.
2. In the Control Panel dialog box, click Programs.
3. Click Turn Windows features on or off.
4. In the Windows Features dialog box:
   a) Expand the following:
      1. Internet Information Services
      2. Web Management Tools
      3. World Wide Web Services
   b) Under Web Management Tools, select IIS Management Console.
   c) Under World Wide Web Services, select Application Development Features and the following:
      • .NET Extensibility
      • ASP
      • ASP.NET
      • CGI
      • ISAPI Extensions
      • ISAPI Filters
      • Server-Side Includes
   d) Under Common HTTP Features, select:
      • Default Document
      • Directory Browsing
      • HTTP Errors
      • HTTP Redirection
      • Static Content
   e) Under Health and Diagnostics, select:
      • HTTP Logging
      • Request Monitor
   f) Under Performance Features, select Static Content Compression.
   g) Under Security, select Request Filtering.
   h) Click OK.
5. Close the Control Panel.
Verifying the IIS File Server

After installing the SOLIDWORKS Manage Server, you must verify that the Internet Information Services (IIS) file server is operating. The IIS file server is a web service. SOLIDWORKS Manage Server creates a website in IIS called **SWManage**, and two application pools called **SWMfs** and **SWMweb**.

**To verify that the IIS File Server is operating:**
1. In the Windows **Start** menu, type **IIS** and select **Internet Information Services (IIS) Manager**.
2. Expand the **Sites** node and expand the **SWManage** node.
3. Select the **SWMfs** folder. Then in the **Actions** pane, under Manage Application, click **Browse *.port number**.
   
   Your default web browser opens. The server name, port number, and SWMfs (SOLIDWORKS Manage File Server website) appear in the address bar.

Troubleshooting IIS

If you are unable to browse to the SOLIDWORKS Manage File Server website, there are some items you can check. For more information, see Microsoft's help for Internet Information Services (IIS).

**To troubleshoot IIS:**
1. Right-click the **SWMfs** website and click **Edit Permissions**.
   
   This ensures that IIS users have proper access to the websites.
2. In the Fileserver Properties dialog box, on the Security tab, click **Edit**.
3. In the Permissions for Fileserver dialog box, click **Add**.
4. In the Select Users or Groups dialog box:
   a) Click **Advanced**.
   b) Click **Find Now**.
   c) Under **Search results**, select **IIS_USRS** and **IUSR**.
   d) Click **OK** twice.
5. In the Permissions for Fileserver dialog box, in the **Allow** column, select **Modify** for both groups and click **OK**.
6. In the Fileserver Properties dialog box, click **OK**.
Our 3DEXPERIENCE® platform powers our brand applications, serving 11 industries, and provides a rich portfolio of industry solution experiences.

Dassault Systèmes, the 3DEXPERIENCE Company, is a catalyst for human progress. We provide business and people with collaborative virtual environments to imagine sustainable innovations. By creating ‘virtual experience twins’ of the real world with our 3DEXPERIENCE platform and applications, our customers push the boundaries of innovation, learning and production.

Dassault Systèmes’ 20,000 employees are bringing value to more than 270,000 customers of all sizes, in all industries, in more than 140 countries. For more information, visit www.3ds.com.