WHAT'S NEW
SOLIDWORKS 2020
## Contents

[Legal Notices](#) .......................................................................................................................10

1 Welcome to SOLIDWORKS 2020 .......................................................................................13
   Top Enhancements ..................................................................................................................14
   What's New Videos ...............................................................................................................15
   Performance Improvements .................................................................................................16
   SPR Fixes ...............................................................................................................................17
   For More Information .........................................................................................................18

2 User Interface ......................................................................................................................20
   Markups ..................................................................................................................................20
      Drawing Markups with a Mouse .........................................................................................22
      Exporting Multiple Markups ..............................................................................................22
      Markup Previews .................................................................................................................22
   Changes to the CommandManager Menu ..........................................................................23
   Display Feature Names in a Different Language .................................................................23
   Drag Multiple Contiguous Features to a Folder ....................................................................24
   Enhanced Large Tooltips for Toolbars .................................................................................24
   File Types List ......................................................................................................................25
   Searching for Materials ........................................................................................................25
   Touch Mode ..........................................................................................................................26
   Troubleshooting Enhancements .........................................................................................26
   Updated Help Menu .............................................................................................................27
   View Recent Files .................................................................................................................28
   Welcome Dialog Box ............................................................................................................28

3 SOLIDWORKS Fundamentals ............................................................................................29
   3D Printing ............................................................................................................................29
      Checking the 3D Printer Size ..............................................................................................29
      Slicing Data for 3MF Export ..............................................................................................30
   Opening Documents .............................................................................................................32
      Improving Performance When Opening and Saving Files from a Previous Version .......32
      Open Modes from File Explorer or PDM Vault View .......................................................32
      Simplified Open Options .................................................................................................33
   Application Programming Interface ..................................................................................33
   Changes to System Options and Document Properties .....................................................34
   Closing a Document When Saving a Copy ...........................................................................36
   Selection Sets .......................................................................................................................36
      Adding a Selection to a Selection Set .................................................................................36
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Updating Entities in a Selection Set</td>
<td>37</td>
</tr>
<tr>
<td>Specifying the Up Axis for View Orientation</td>
<td>37</td>
</tr>
<tr>
<td><strong>4 Installation</strong></td>
<td><strong>38</strong></td>
</tr>
<tr>
<td>Improved Installation Manager Download Performance</td>
<td>38</td>
</tr>
<tr>
<td>Installing the 3DEXPERIENCE Marketplace Add-In</td>
<td>38</td>
</tr>
<tr>
<td>Installing the 3DEXPERIENCE Add-In</td>
<td>39</td>
</tr>
<tr>
<td>Installing SOLIDWORKS PCB Viewer</td>
<td>39</td>
</tr>
<tr>
<td>Installing Toolbox Software Without Installing Toolbox Data</td>
<td>40</td>
</tr>
<tr>
<td>SOLIDWORKS File Utilities Replaces SOLIDWORKS Explorer</td>
<td>40</td>
</tr>
<tr>
<td>Testing a Setup for a Push Deployment</td>
<td>40</td>
</tr>
<tr>
<td><strong>5 Administration</strong></td>
<td><strong>42</strong></td>
</tr>
<tr>
<td>Selecting a SOLIDWORKS Simulation License with a SolidNetWork License</td>
<td>42</td>
</tr>
<tr>
<td>SOLIDWORKS CEF Sub Process</td>
<td>43</td>
</tr>
<tr>
<td>SOLIDWORKS Rx Supports SOLIDWORKS Composer and SOLIDWORKS Electrical</td>
<td>43</td>
</tr>
<tr>
<td>Specifying Support Information</td>
<td>44</td>
</tr>
<tr>
<td><strong>6 Assemblies</strong></td>
<td><strong>45</strong></td>
</tr>
<tr>
<td>Envelope Publisher</td>
<td>45</td>
</tr>
<tr>
<td>Creating Envelopes for a Subassembly</td>
<td>46</td>
</tr>
<tr>
<td>Viewing Envelopes</td>
<td>47</td>
</tr>
<tr>
<td>Envelope Publisher PropertyManager</td>
<td>47</td>
</tr>
<tr>
<td>Flexible Components</td>
<td>48</td>
</tr>
<tr>
<td>Adding a Flexible Component</td>
<td>49</td>
</tr>
<tr>
<td>Editing External References of Flexible Components</td>
<td>51</td>
</tr>
<tr>
<td>Activate Flexible Component PropertyManager</td>
<td>51</td>
</tr>
<tr>
<td>Mates</td>
<td>52</td>
</tr>
<tr>
<td>Flip Alignment of Width Mates</td>
<td>52</td>
</tr>
<tr>
<td>Quick Mates Context Toolbar</td>
<td>52</td>
</tr>
<tr>
<td>Patterns</td>
<td>53</td>
</tr>
<tr>
<td>Component Pattern with Variable Instances</td>
<td>53</td>
</tr>
<tr>
<td>Mirror Components PropertyManager</td>
<td>55</td>
</tr>
<tr>
<td>Pattern Driven Component Patterns</td>
<td>61</td>
</tr>
<tr>
<td>Large Design Review</td>
<td>63</td>
</tr>
<tr>
<td>Create and Edit Component Patterns in Large Design Review</td>
<td>63</td>
</tr>
<tr>
<td>Create Mates to Reference Geometry in Large Design Review</td>
<td>64</td>
</tr>
<tr>
<td>Exploded Views</td>
<td>65</td>
</tr>
<tr>
<td>Auto-Space Components in Exploded Views</td>
<td>65</td>
</tr>
<tr>
<td>Reusing a Multibody Part Explode</td>
<td>66</td>
</tr>
<tr>
<td>External References Options</td>
<td>67</td>
</tr>
<tr>
<td>Isolating Interferences</td>
<td>67</td>
</tr>
<tr>
<td>Modify Configuration for Toolbox Components</td>
<td>68</td>
</tr>
<tr>
<td>Performance Improvements for Assemblies</td>
<td>68</td>
</tr>
</tbody>
</table>
Save as Copy with a Subset of Configurations .................................................................68

7 SOLIDWORKS CAM ..................................................................................................69
Customization Settings...............................................................................................69
Probing Routines .......................................................................................................69
Tab Cutting....................................................................................................................70
Tapered Multipoint Thread Tool.................................................................................70
Universal Post Generator............................................................................................70

8 SOLIDWORKS Composer .......................................................................................71
SOLIDWORKS Composer............................................................................................71
360 Degree Capture.....................................................................................................71
Basic Attach Type for Annotations..............................................................................71
BOM ID Callouts..........................................................................................................71
Exponent Shape for Callouts.......................................................................................72
Importing Appearances from SOLIDWORKS Files ....................................................72
Importing Exploded, Saved, and Named Views from SOLIDWORKS Files ...............72
Inlaid Text for Linear Arrows.......................................................................................72
Read-Only Mode Enhancement for Animation Library Templates............................72
Support of MP4 Format for Animations........................................................................73
Warning Message Before Breaking External Assembly Links.....................................73
SOLIDWORKS Composer Sync....................................................................................73
Importing Appearances from SOLIDWORKS Files ....................................................73
Importing Exploded, Saved, and Named Views from SOLIDWORKS Files ...............73

9 Detailing and Drawings ...........................................................................................74
Custom Scales for Drawing Sheets and Views............................................................74
Setting Custom Scales for Drawing Sheets.................................................................74
Setting Custom Scales for Drawing Views....................................................................75
Modifying the List of Available Scales..........................................................................76
Chain Dimensions .......................................................................................................76
Alternate Position Views..............................................................................................78
Detailing Mode..............................................................................................................80
Opening Drawings in Detailing Mode............................................................................82
Render Pipeline in Drawings.......................................................................................82
Hole Callouts...............................................................................................................82
Adding Hole Callouts in Section Views.......................................................................82
Applying All Uppercase to Dimensions and Hole Callouts........................................84
Annotations...............................................................................................................84
Flag Notes....................................................................................................................84
Symbols on Sheet Formats.........................................................................................84
Cosmetic Threads.......................................................................................................84
Adding Callouts for Non-Hole Wizard Holes...............................................................84
14 SOLIDWORKS Manage ................................................................. 110
  Process Management Enhancements ........................................... 111
    Adding Related Records .......................................................... 111
    Creating a Subprocess ............................................................ 111
  Project Management Enhancements ............................................ 112
    Project Gantt Charts ............................................................... 112
    Capacity and Demand Dashboards ........................................... 112
  Dashboard Viewer and Plenary Web Client ................................. 113
  Task Templates ........................................................................ 114
  Integration with Microsoft Outlook ............................................. 114
  Object Notes ........................................................................... 114
    Adding Object Notes .............................................................. 115
    Viewing Object Notes ............................................................ 115
  Adding Conditions to a Process Stage ........................................ 115
  BOM Editing ........................................................................... 116
  PDM Options Tab ...................................................................... 116
  Editing the Project Task Subject ............................................... 117
  Export Feature of BOM Compare Tool ....................................... 118
  Send to Process ....................................................................... 118
  Custom Procedures ................................................................... 118
  View Hidden Controls in the Workflow Designer ....................... 118
  Inactive Configuration Part Numbering ...................................... 119
  Main User Interface Controls for Records ................................. 119
  Customized Affected Item List .................................................. 119
  Process Task Assignment Controls ......................................... 119
  Copy Manual Quantities of BOM .............................................. 119

15 SOLIDWORKS MBD ................................................................ 120
  Annotations Folder ................................................................... 120
  3D PMI Compare ....................................................................... 121
  DimXpert .................................................................................. 121
    Annotation Name Format ........................................................ 121
    Pipe Threads and Compound Holes ........................................ 122

16 Model Display ......................................................................... 123
  Body Compare ........................................................................ 123
  Comparing Bodies .................................................................... 123
  Body Compare PropertyManager .............................................. 125

17 Parts and Features ................................................................... 127
  Graphics Mesh and Mesh BREP Bodies ..................................... 127
    Adding Coordinate Axes, Reference Axes, and Reference Planes 127
129 Decimating a Graphics Mesh Body
136 Expanded Support for Mesh BREP Bodies in Features
136 Holes
136 Defining Hole Depth up to Tip or up to Shoulder
137 Hole Wizard
137 Repairing Missing References for Fillets and Chamfers
140 Surfaces
140 Creating an Offset Surface Without Failed Faces
142 Specifying the Thicken Direction

146 18 SOLIDWORKS PCB
146 Duplicate Designators
146 Integration with SOLIDWORKS PDM
147 Rigid-Flex Support in SOLIDWORKS PCB

148 19 SOLIDWORKS PDM
148 Defining Child Reference State Conditions
149 Search User Interface
150 Customizable Variables - New Variable List Dialog Box
151 Using Quick Search
152 SOLIDWORKS PDM Performance Improvements
153 Performance Improvements in Browsing
153 Performance Improvements in the SOLIDWORKS PDM Add-in
154 Web2 Enhancements
154 Bill of Materials Tab in Web2
157 History Tab
157 List of Files to Download in Web2
159 Using AND, OR, and NOT Operators in Search
163 Searching in Multiple Variables
164 Creating a Search Card to Search Within Multiple Variables
164 Resizable Dialog Boxes
165 Logging Out from Windows Explorer
165 Reordering Columns in Search Results
165 Scaling the Paper Size in Print Task
165 Warning Users When Transitioning Files

166 20 SOLIDWORKS Plastics
166 Coolant Input Boundary Condition
166 Create Body from Deformed Shape
167 Domains Node
167 Enhanced Solid Mesh (Auto) Workflow
Contents

Streamlined Mesh Creation ................................................................. 168
Flow, Pack, and Cool Analyses Enhancements .................................. 168
Geometry-Based Boundary Conditions .............................................. 168
Legacy Plastics Simulation Studies ................................................... 169
Material Library Updates ................................................................. 169
Plastics Material Databases in 3D ContentCentral ............................. 171
Plastics Tutorials .............................................................................. 172
Study Creation and Management ..................................................... 172
Virtual Mold Design ......................................................................... 172

21 Routing ....................................................................................... 174
3D Route Changes in Flattened Routes ............................................. 174
Color for Electrical Coverings ......................................................... 174
Connector Blocks ............................................................................. 175
Create Multiple Connection Points ................................................ 175
Length Leaders for Flattened Routes ................................................. 176
Manufactured-Style Flattened Route ................................................ 177
Mass and Density of Cables and Wires ............................................. 177
Minimum Bend Radius ..................................................................... 177
Pipe Drawings ................................................................................. 178
Reimport Electrical Data ................................................................... 178
Show/Hide Flatten Route Items ....................................................... 178
Splices Without Components .......................................................... 179
Transparent Coverings ..................................................................... 180

22 Sheet Metal ................................................................................. 181
Convert to Sheet Metal ....................................................................... 181
Tab and Slot ...................................................................................... 181

23 SOLIDWORKS Simulation .......................................................... 182
Collapse Simulation Tree Folders .................................................... 182
Distributed Coupling for Pins and Bolts ......................................... 183
Draft and High-Quality Mesh Definition ....................................... 185
Free Body Forces for Nonlinear Studies ........................................ 186
Link Between Results and Model Files ........................................... 187
Repair Corrupt Studies .................................................................... 188
Simulation Evaluator ....................................................................... 188
Simulation Performance Improvements ........................................ 189
Stress Averaging at Mid-Side Nodes .............................................. 189
Thermal Loads for Beams ............................................................... 190
24 Sketching

Applying Torsion Continuity Relations ................................................................. 193
Baseline and Chain Dimensions in Sketches ........................................................ 195
Importing 2D DXF or DWG Files as Reference Sketches .................................... 195
Power Modify Tool ................................................................................................ 195
Silhouette Entities ................................................................................................ 197
Creating Silhouette Entities ................................................................................. 198
Silhouette Entities PropertyManager ..................................................................... 199

25 SOLIDWORKS Visualize

AMD ProRender Integration .................................................................................. 200
AxF Measured Materials ....................................................................................... 200
gltF Export for AR and VR .................................................................................... 201
IES Light Profiles ................................................................................................. 201
Finding IES Light Profiles .................................................................................... 201
Adding IES Profile Lights to Scenes ..................................................................... 202
Inline Rendering .................................................................................................. 203
Instancing ............................................................................................................ 203
MDL Support ....................................................................................................... 204
NVIDIA RTX Support .......................................................................................... 205
Scaling for High-Resolution Displays .................................................................. 205
SOLIDWORKS PDM Integration ........................................................................ 205

26 Structure System and Weldments

Options for Creating Primary Members Based on Points .................................... 207
Specifying the Member Profile ............................................................................ 208
Creating Primary Members Based on Point and Length ..................................... 208
Creating Primary Members Between Points ....................................................... 209
Creating Primary Members Based on Up to Point ............................................. 209
Creating Primary Members Based on Direction ................................................ 210
Creating Curved Beams and Merging Tangent Members .................................... 211
Split Members ..................................................................................................... 211

Pattern and Mirror Support .................................................................................. 213
Creating a Linear Pattern of a Structure System Feature ..................................... 214
Adding a Structure System Feature to an Existing Feature ............................... 215
Member and Corner Trim Enhancements ............................................................. 216
Cut List Properties for Weldment and Structure System Features ....................... 217
Legal Notices

© 1995-2019, Dassault Systemes SolidWorks Corporation, a Dassault Systèmes SE company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systemes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of the license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the license agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SOLIDWORKS® 3D mechanical CAD and/or Simulation software is protected by U.S. Patents 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; 8,581,902; 8,817,028; 8,910,078; 9,129,083; 9,153,072; 9,262,863; 9,465,894; 9,646,412; 9,870,436; 10,055,083; 10,073,600; 10,235,493 and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademarks and Product Names for SOLIDWORKS Products and Services

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360, and TolAnalyst are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of HCL Technologies Ltd.

SOLIDWORKS PCB powered by Altium, SOLIDWORKS PCB Connector powered by Altium, and SOLIDWORKS Visualize are product names of DS SolidWorks.

Other brand or product names are trademarks or registered trademarks of their respective holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of “commercial computer software” and “commercial software documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government (a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in 48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the Department of Defense, consistent with the policies set forth in 48 C.F.R. 227.7202-1 (JUN 1995) and 227.7202-4 (JUN 1995)

In the event that you receive a request from any agency of the U.S. Government to provide Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope of the request and DS SolidWorks will have five (5) business days to, in its sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systemes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SOLIDWORKS Standard, Premium, Professional, and Education Products

Portions of this software © 1986-2018 Siemens Product Lifecycle Management Software Inc. All rights reserved.


Portions of this software © 1998-2019 HCL Technologies Ltd.

Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.

Portions of this software © 2001-2019 Luxology, LLC. All rights reserved, patents pending.

Portions of this software © 2007-2019 DriveWorks Ltd.

© 2012, Microsoft Corporation. All rights reserved.

Includes Adobe® PDF Library technology.

Copyright 1984-2016 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SOLIDWORKS.
Copyright Notices for SOLIDWORKS Simulation Products
Portions of this software © 2008 Solversoft Corporation.
PCGLSS © 1992-2017 Computational Applications and System Integration, Inc. All rights reserved.

Copyright Notices for SOLIDWORKS PDM Professional Product
Outside In® Viewer Technology, © 1992-2012 Oracle
© 2012, Microsoft Corporation. All rights reserved.

Copyright Notices for eDrawings Products
Portions of this software © 2000-2014 Tech Soft 3D.
Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.
Portions of this software © 1998-2001 3Dconnexion.
Portions of this software © 1998-2017 Open Design Alliance. All rights reserved.
The eDrawings® for Windows® software is based in part on the work of the Independent JPEG Group.

Copyright Notices for SOLIDWORKS PCB Products
Portions of this software © 2017-2018 Altium Limited.

Copyright Notices for SOLIDWORKS Visualize Products
NVIDIA GameWorks™ Technology provided under license from NVIDIA Corporation.
Copyright © 2002-2015 NVIDIA Corporation. All rights reserved.
Welcome to SOLIDWORKS 2020

This chapter includes the following topics:

- Top Enhancements
- What’s New Videos
- Performance Improvements
- SPR Fixes
- For More Information

Model courtesy of Matt Lyle, SOLIDWORKS 2019 Beta Splash Screen Prize winner.

SOLIDWORKS® 2020 delivers many enhancements and improvements, most created in direct response to customer requests.
These enhancements help you speed up and improve your product development process – from concept design through manufactured products.

- **Workflow.** Refinements in design, simulation, manufacturing, and collaboration permit new workflows that improve time to market and product quality, and reduce manufacturing costs.
- **Performance.** Improvements in drawings and assemblies significantly speed up large assembly design and detailing.
- **Direct connection to the 3DEXPERIENCE® Platform.** Seamless integration with 3DEXPERIENCE applications provides scalability and flexibility to dramatically improve the way you develop concepts, design, and collaborate.

### Top Enhancements

The top enhancements for SOLIDWORKS® 2020 provide improvements to existing products and innovative new functionality.

Throughout this guide, look for the symbol in these areas:

#### Assemblies
- **Create and Edit Component Patterns in Large Design Review** on page 63
- **Create Mates to Reference Geometry in Large Design Review** on page 64
- **Envelope Publisher** on page 45
- **Flexible Components** on page 48

#### Detailing and Drawings
- **Adding Hole Callouts in Section Views** on page 82
- **Chain Dimensions** on page 76
- **Detailing Mode** on page 80
- **Render Pipeline in Drawings** on page 82

#### Fundamentals
- **Improved Performance When Opening and Saving Files from a Previous Version**

#### Model Display
- **Body Compare** on page 123

#### Parts and Features
- **Creating an Offset Surface Without Failed Faces** on page 140
- **Repairing Missing References for Fillets and Chamfers** on page 137
- **Expanded Support for Mesh BREP Bodies in Features** on page 136
- **Decimating a Graphics Mesh Body** on page 129

#### Routing
- **Create Multiple Connection Points** on page 175
- **Minimum Bend Radius** on page 177
- **Reimport Electrical Data** on page 178
Welcome to SOLIDWORKS 2020

**Sketching**
- Applying Torsion Continuity Relations on page 193
- Silhouette Entities on page 197

**SOLIDWORKS Composer**
- Importing Exploded, Saved, and Named Views from SOLIDWORKS Files on page 72
- Support of MP4 Format for Animations on page 73

**SOLIDWORKS Electrical**
- Leader Lines on page 96
- Reimport Electrical Data for Wires, Cables, and Harnesses on page 102
- Report Enhancements for Rows and Columns on page 103
- User Rights Manager on page 104

**SOLIDWORKS PDM**
- Bill of Materials Tab in Web2 on page 154
- Defining Child Reference State Conditions on page 148
- Performance Improvements in Browsing on page 153
- Search User Interface on page 149
- Using AND, OR, and NOT Operators in Search on page 159

**SOLIDWORKS Plastics**
- Geometry-Based Boundary Conditions on page 168
- Mesh Enhancements

**SOLIDWORKS Simulation**
- Draft and High-Quality Mesh Definition on page 185
- Distributed Coupling for Pins and Bolts on page 183
- Free Body Forces for Nonlinear Studies on page 186
- Simulation Evaluator on page 188
- Thermal Loads for Beams on page 190

**Structure System**
- Pattern and Mirror Support on page 213
- Options for Creating Primary Members Based on Points on page 207
- Split Members on page 211

What's New Videos

Some topics in this document include links to videos that provide more insight into the new functionality. Look for the links next to this image:
Performance Improvements

SOLIDWORKS 2020 includes the following performance and workflow improvements:

**Assemblies**

- Assembly performance is optimized for some tools and workflows so full rebuilds of assemblies or graphics occur less often.
- Most assemblies and drawings, that were saved in a previous version, open faster without having to save them in the new version. The improvement is greater for assemblies that use reference components in several configurations.

You do not have to fully rebuild assemblies and drawings with reference components in multiple configurations when opening a new version in SOLIDWORKS 2020. Also, you can make greater use of lightweight components and drawings without needing to convert them to the current version.

You can improve save performance by clearing the **Force referenced documents to save to current version** system option. When you clear the option, documents that were not modified in the current session are not saved to the current version of SOLIDWORKS. For an example, see *Improving Performance When Opening and Saving Files from a Previous Version* on page 32

This improvement also eliminates the need to run batch conversion tools such as the PDM File Version Upgrade Utility or the **Convert Files** task in the Task Scheduler.

**Detailing and Drawings**

When you create a drawing from an open assembly, the creation of the first view may be faster than in previous releases.

**eDrawings**

Performance is improved when you hover over and select entities using the **Measure** and **Markup Dimensions** tools.

**SOLIDWORKS PDM**

- SOLIDWORKS PDM loads the data in the background, which improves the browsing responsiveness.

  Browsing folders that have a large number of files is faster due to:
  - Faster database queries for custom columns.
  - Background loading and incremental loading of the data.

When you double-click a folder, SOLIDWORKS PDM loads data in this order:

1. All subfolders synchronously. You can browse subfolders while the remaining data loads in the folder.
2. Files with standard columns in the file list.
3. Information in custom columns. You can add more custom columns and maintain the same browsing speed.

When you select a file and switch between the Bill of Materials, Contains, and Where Used tabs, SOLIDWORKS PDM loads the data in the tabs in the background. When you switch to a different file or folder, the background loading stops and loading of the new file or folder starts.

Performance improves significantly for folders with a large number of files or for database servers with high latency.

- The SOLIDWORKS PDM task pane tree refreshes faster and the commands in the SOLIDWORKS PDM toolbar are correctly enabled in the task pane instantaneously when you select a file.
  - Data in the task pane tree loads in the background.
  - When you select a file in the task pane tree, calls to the database are eliminated.

In the FeatureManager design tree or in the graphics area, when you right-click a file and select SOLIDWORKS PDM, the menus are correctly enabled.

When you select a file in the graphics area or in the FeatureManager design tree, the file listed in task pane tree is selected and the commands in the SOLIDWORKS PDM toolbar are correctly enabled.

- You can perform the following actions faster:
  - Logging into the vault when you set a large number of files or folders for automatic caching.
  - Viewing the System History of a vault that includes a large number of items.
  - Opening a file from a folder that includes a large number of files.
  - Creating a new file or subfolder in a folder that contains large number of files.

Simulation

- Multiple load cases. You can use an optimized solution for distributed and rigid remote loads.
- Linear/quadratec tetra. You can replace quadratic elements as linear elements in certain parts of geometry (especially in bulky areas with fewer surface irregularities) to boost solver speed and performance.

SOLIDWORKS Visualize

SOLIDWORKS Visualize supports and defaults to Live rendering mode. This can improve performance and reduce memory consumption for final renders.

SPR Fixes

SOLIDWORKS 2020 focuses on fixing reproducible and difficult to reproduce stability issues. In addition, we target important SPRs (Software Performance Reports) that improve your design productivity.

Some of the high-impact SPRs that we fixed:
<table>
<thead>
<tr>
<th>SPR</th>
<th>Resolution</th>
</tr>
</thead>
<tbody>
<tr>
<td>389741</td>
<td>Notes with geometric tolerance symbols or surface finish symbols are saved with the sheet format.</td>
</tr>
<tr>
<td>551580</td>
<td>Angular dimensions display properly in broken views.</td>
</tr>
<tr>
<td>625475</td>
<td>An assembly properly exports as a STEP file even if an assembly's component has the same name as the assembly.</td>
</tr>
<tr>
<td>634314</td>
<td>A circular sketch pattern of a <strong>Hole Wizard</strong> hole creates accurate patterns.</td>
</tr>
<tr>
<td>675106</td>
<td>Hole and shaft fit appear in diameter dimensions for nominal fit dowel holes created in the <strong>Hole Wizard</strong>.</td>
</tr>
<tr>
<td>713849</td>
<td>File display is faster.</td>
</tr>
<tr>
<td>921300</td>
<td>Instant3D works correctly when you drag sketch entities.</td>
</tr>
<tr>
<td>960699</td>
<td>Dimension arrowheads keep the same styles when you use multi-jog leaders.</td>
</tr>
<tr>
<td>886991</td>
<td>Font sizes display properly when you use <strong>Publish to 3D PDF</strong> in SOLIDWORKS MBD.</td>
</tr>
<tr>
<td>1129989, 1129991, 1129992</td>
<td>In the SOLIDWORKS PDM Administration tool, results are filtered as you type in the Group Members, Add Group Members, and Users dialog boxes.</td>
</tr>
</tbody>
</table>

For More Information

Use the following resources to learn about SOLIDWORKS:

**What's New in PDF and HTML**

This guide is available in PDF and HTML formats. Click:

- Help > What's New > PDF
- Help > What's New > HTML

**Interactive What's New**

In SOLIDWORKS, click the 🔄 symbol to display the section of this manual that describes an enhancement. The symbol appears next to new menu items and the titles of new and changed Property Managers.

To enable Interactive What's New, click Help > What's New > Interactive.

**Sample files**

To open sample files for this book, go to

```
system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\chapter_name\file_name.
```
For example, C:\Users\Public\PublicDocuments\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\sketching\Block.sldprt.

**Online Help**
Contains complete coverage of our products, including details about the user interface, samples, and examples.

**Release Notes**
Provides information about late changes to our products, including changes to the *What's New* book, online help, and other documentation.
User Interface

This chapter includes the following topics:

- **Markups**
- Changes to the CommandManager Menu
- Display Feature Names in a Different Language
- Drag Multiple Contiguous Features to a Folder
- Enhanced Large Tooltips for Toolbars
- File Types List
- Searching for Materials
- Touch Mode
- Troubleshooting Enhancements
- Updated Help Menu
- View Recent Files
- Welcome Dialog Box

Markups

You can draw markups with a mouse on nontouch devices, display bounding boxes for markups, create markups in drawings, and use the context toolbar to access markup options.

To hide or show markups, click **Hide All Types > View Markups** on the Heads-up View toolbar. Right-click a markup in the FeatureManager design tree or in the graphics area and click **Hide** to hide markups.

**Markup Toolbar**

The Ink Markup toolbar is renamed to the Markup toolbar. To view the toolbar, click **View > Toolbars > Markup**. 
New options:

<table>
<thead>
<tr>
<th></th>
<th>Color</th>
<th>Specifies a color and thickness for the pen and mouse strokes.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Draw</td>
<td>Uses a mouse to draw ink strokes.</td>
</tr>
</tbody>
</table>

The toolbar displays different options depending on the device. **Touch** is not available for nontouch devices.

![Markup toolbar for touch devices](image1)

![Markup toolbar for nontouch devices](image2)

Ink strokes in markups are limited to devices that use Windows 10, version 1703 or later.

**Context Toolbar**

The following options are available when you right-click a markup:

<table>
<thead>
<tr>
<th></th>
<th>Edit Markup</th>
<th>Enters edit mode.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Suppress</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Orient</td>
<td>Zooms to the markup.</td>
</tr>
<tr>
<td></td>
<td>Hide</td>
<td></td>
</tr>
</tbody>
</table>

|          | Export Markup | Exports markups as one of the following file types: .pdf, .bmp, .jpg, .png, and .tif. |

**Markup Tab for the CommandManager**

To view the Markup tab for the CommandManager, right-click in the CommandManager and click **Tabs > Markup**.

**Markup Creation Information**

Markups save the creation date and time stamp, and the creator ID. This information appears when you preview a markup and export a markup to a file.
Markups for Drawings

For more information on markups for drawings, see Creating Markups for Drawings on page 87.

Drawing Markups with a Mouse

1. On a nontouch device, open a part or assembly.
2. Click View > Hide/Show > Markups.
3. Click Tools > Options > System Options > FeatureManager.
4. Under Hide/show tree items, select Show for Markups and click OK.
5. In the FeatureManager design tree, right-click Markups and click Insert Markup.
   The Markup toolbar appears.
6. Click Draw to draw with the mouse.
7. Optional: To change the color or the thickness of the line, click Color.

Exporting Multiple Markups

To export multiple markups:

1. In the FeatureManager design tree, under Markups, Ctrl + select multiple markups.
2. In the context toolbar, click Export Markup.
3. In the Export Markup dialog box, specify the file name and type, and click Save.
   When you select .pdf as the file type, one .pdf file is created and each page contains one markup. When you export multiple markups, the order in which you select the markups is the order of the pages in the .pdf file.
   When you select the other file types, each markup saves to an individual file in the specified folder. When you export multiple markups, the folder name is the name specified for File name in the Export Markup dialog box.

Markup Previews

When you hover over a markup in the FeatureManager design tree, a markup preview appears. In the graphics area, a bounding box with orange edges surrounds the markup. When you select the markup, the preview closes and a bounding box with blue edges surrounds the markup.
Changes to the CommandManager Menu

Many items have changed:

<table>
<thead>
<tr>
<th>Item</th>
<th>Description of Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>CommandManager</td>
<td>Renamed to <strong>Enable CommandManager</strong></td>
</tr>
<tr>
<td>List of CommandManager tabs</td>
<td>Moved under <strong>Tabs</strong></td>
</tr>
<tr>
<td>List of toolbars</td>
<td>Moved under <strong>Toolbars</strong></td>
</tr>
<tr>
<td><strong>Customize Menu</strong></td>
<td>Removed from the menu</td>
</tr>
</tbody>
</table>

To show toolbars in the CommandManager:

1. Right-click in the CommandManager.
2. Click **Toolbars** and then click a toolbar.

Display Feature Names in a Different Language

In the FeatureManager® design tree, for features that use the default name, you can view a feature name translated into a different language. The translation displays in a tooltip when you hover over the feature.

**To display feature names in a different language:**

1. In the FeatureManager design tree, right-click a top-level assembly or part and click **Tree Display**.
2. Click **Show Translated Feature Name in Tooltip** and click a language.
3. In the FeatureManager design tree, hover over a feature that has a default name. The tooltip displays the feature name and the translated feature name. For example, the French translation of Shell1 is Coque1:

![Shell1](shelle.png) ![Shell1 (French: Coque1)](shelle-fr.png)

4. Optional: To hide the tooltips, under Show Translated Feature Name in Tooltip, click Hide Tooltip.

### Drag Multiple Contiguous Features to a Folder

You can select multiple contiguous features and drag the features to a folder in the FeatureManager design tree. You can drag features to change their order in a folder if the features do not have parent-child relationships. You can drag folders and features into another folder.

When dragging a feature out of a folder, you can drag the feature above a contiguous feature in the FeatureManager design tree.

**To drag multiple contiguous features to a folder:**
1. Open a part that has multiple features.
2. If the part does not have a folder, in the FeatureManager design tree, right-click a feature and click Add to New Folder.
3. In the FeatureManager design tree, select one or more contiguous features and drag the features to Folder.
   - When the pointer changes to , drop the features to the selected folder.
4. Expand Folder and change the feature order.
   - When the pointer changes to , you can drag the features to the selected location.
5. Select multiple contiguous features from the Folder and drag the features from the folder to a location above the folder in the FeatureManager design tree.

### Enhanced Large Tooltips for Toolbars

Enhanced large tooltips provide expanded information for tools in a toolbar. Some enhanced tooltips include images or animations.

For example, the Bounding Box large tooltip provides information about viewing the bounding box properties and includes an image of a bounding box.
To use enhanced large tooltips:
1. Click **Tools > Customize** and under **Tooltips**, click **Show tooltips**.
2. Under **Show tooltips**, select an option:

<table>
<thead>
<tr>
<th>Large tooltips with images</th>
<th>Displays a brief description with the tooltip. Some tooltips may include an image or short animation.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Large tooltips without images</td>
<td>Displays a brief description with the tooltip.</td>
</tr>
<tr>
<td>Small tooltips</td>
<td>Displays the tool name.</td>
</tr>
</tbody>
</table>

3. Click **OK**.
4. Hover over a tool in a toolbar to view the enhanced tooltip.

**File Types List**

The file types list in the Open dialog box is consolidated and reorganized. The list is wider to accommodate longer file names.

In the Save As dialog box, the list of files types for **Save as type** is reorganized.

**Searching for Materials**

You can find materials by using the **Search** box in the upper left corner of the Material dialog box.

**To search for materials:**
1. From an open document, in the FeatureManager design tree, right-click **Material** and click **Edit Material**.
2. In the Material dialog box, enter an alphanumeric character or part of a material name in the search box.

   ![Material Search Example](image)

   This example searches for `plastic`. Matching results display materials in the material tree.

3. Select a material or click `X` to clear the search box.

**Touch Mode**

On the Touch toolbar, **Undo** appears after you perform an action. The **Escape** icon changed to `Esc`. The icon for the active model tab displays at the bottom of the toolbar.

**Model tabs:**
- Model
- Design Study
- 3D Views
- Motion Study

**Troubleshooting Enhancements**

The SOLIDWORKS software provides more information about possible causes of crashes and known solutions you can use to avoid them in the future. It also makes it easier for you to supply error reports that will help the SOLIDWORKS development team diagnose and resolve problems for you.

In the Welcome dialog box, the Troubleshooting tab displays messages for known solutions to problems you have encountered, and how many times those problems have occurred. The solutions include contacting Technical Support about installing hotfixes, checking for updates to see if you need to apply service packs, and making sure the machine has a certified or tested graphics driver.

When the SOLIDWORKS software starts, it scans log files to identify crashes that have known solutions, and creates messages about those solutions in the
solutionmessages.xml file. The file updates when it identifies additional problems and solutions, and when hotfixes and service packs are applied on the machine. The cumulative list of messages about problems and solutions, minus those solved by hotfixes and service packs that have already been applied, displays on the Troubleshooting tab.

**To find solutions for crash fixes:**

1. In the Welcome dialog box, click **Alerts > Troubleshooting**.
2. If there are crashes for this release of the SOLIDWORKS software on this machine, error messages display that tell you how many times the problems causing those crashes have occurred. The error messages also suggest solutions such as:
   
   • Contacting Technical Support about installing hotfixes.
   • Checking for updates to see if you need to apply service packs.
   • Making sure that the machine has certified or tested graphics drivers.

   Optional. Click **Close** on the right side of the message to delete it.

3. If **Check for Updates** or **System Diagnostics** displays, select it and follow instructions for that option.

A separate tab provides information about recovered documents. To view it from the Welcome dialog box, click **Alerts > Document Recovery**.

**Updated Help Menu**

On the **Help** menu, options are reorganized and renamed.

To view the menu, click **Help**.

**Activate Licenses, Deactivate Licenses,** and **Show Licenses** changed to **Activate,** **Deactivate,** and **Show,** and moved under **Licenses.**

**Get Support** is added to the list of options.

SOLIDWORKS is removed from some of the option names. For example, **SOLIDWORKS Tutorials** changed to **Tutorials.**
View Recent Files

You can view a list of recent files opened in the software in the following locations:

- Windows® Start menu: App list and tiles
- Search Windows: Search results for the SOLIDWORKS® 2020 software
- Windows taskbar

To view recent files:
1. From the Windows Start Menu, click Settings > Personalization > Start.
2. Verify that Show app list in Start menu and Show recently opened items in Jump Lists on Start or the taskbar are On.
3. Close the Windows Settings dialog box.
4. From the Windows Start Menu, right-click the SOLIDWORKS 2020 icon from the app list.
   A list of files appears under Recent.

Welcome Dialog Box

You can log in to SOLIDWORKS from the Welcome dialog box.

In the upper-right corner, click Log In.
This chapter includes the following topics:

- **3D Printing**
- **Opening Documents**
- **Application Programming Interface**
- **Changes to System Options and Document Properties**
- **Closing a Document When Saving a Copy**
- **Selection Sets**
- **Specifying the Up Axis for View Orientation**

### 3D Printing

**Video: What's New in SOLIDWORKS 2020 - 3D Printing**

#### Checking the 3D Printer Size

You can select a 3D printer from a list to determine if a model fits inside the 3D printer. You can mark a 3D printer as a favorite to make the 3D printer available as a selection in the Print3D PropertyManager.

When you add a printer as a favorite, the following read-only information appears:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Company</strong></td>
<td>Printer manufacturer.</td>
</tr>
<tr>
<td><strong>Model</strong></td>
<td>Model number for the printer.</td>
</tr>
<tr>
<td><strong>Bed Size of this 3D Printer</strong></td>
<td><strong>Height</strong>, <strong>Length</strong>, and <strong>Width</strong> of the printer.</td>
</tr>
<tr>
<td><strong>Technology</strong></td>
<td>Printer type. For example, FDM, SLS, or SLA.</td>
</tr>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Source URL</td>
<td>3D printer list from the Wohlers Report 2019 provided by Wohlers Associates, Inc.</td>
</tr>
</tbody>
</table>

**To check the 3D printer size:**

1. Open a part or assembly, and click **File > Print3D**.
2. On the Settings tab of the Print3D PropertyManager, click **3D Printer Name**, and click **Select Printer**.
   
   In the 3D Printers dialog box, a folder list alphabetized by company name appears.
3. Expand a folder to view a list of 3D printers, and select a printer.
4. Click **Add to Favorites**.
   
   The printer is added to the **Favorites** folder at the top of the folder list.
5. Close the dialog box.
6. In the PropertyManager, under **3D Printer Name**, select a printer.
7. For **Bottom plane of model**, in the graphics area, select a planar face or reference plane.
   
   The printer appears as a transparent box around the model. Sections of the model that do not fit in the printer area appear in red.

---

**Slicing Data for 3MF Export**

You can generate slices from precise SOLIDWORKS® geometry to export to a 3D Manufacturing Format (.3mf) file without saving the geometry to a mesh file.

Slices represent the highest fidelity of SOLIDWORKS geometry based on the minimum segment length, resulting in slices with the highest accuracy that a 3D printer can print.

**To slice data for 3MF export:**

1. Open a part and click **File > Print3D**.
2. On the Settings tab, for **Bottom plane of model**, select a plane.
3. On the Preview tab, specify options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Layer height" /></td>
<td>Specifies the layer height of the striation lines.</td>
</tr>
<tr>
<td>Generate slices (for 3MF export)</td>
<td>Saves slicing information when you export to a .3mf file. Available when you specify a bottom plane on the Settings tab.</td>
</tr>
<tr>
<td><img src="image2" alt="Minimum edge length" /></td>
<td>Specifies the smallest edge included in a polyline for a slice. This edge corresponds to the smallest linear segment that a 3D printer can print.</td>
</tr>
<tr>
<td>Preview Slices</td>
<td>Generates a preview of slices. Available when you specify a bottom plane on the Settings tab and a layer height on the Preview tab. To interrupt the preview generation, close the PropertyManager. If you change the bottom plane, layer height, or minimum edge length, click Preview Slices to regenerate the slices.</td>
</tr>
</tbody>
</table>

After you click **Preview Slices**, the slices appear in yellow on the part.

4. Click the Settings tab.
5. Expand the **Save To File** section.
6. For **Format**, select **3D Manufacturing Format (*.3mf)** and click **Save File**.
7. In the Save As dialog box:
   a) For Save as type, select 3D Manufacturing Format (.3mf).
   b) Click Options.
   c) In the System Options - STL/3MF/AMF dialog box, select Include slices to include slicing information in the exported file, and click OK.
   d) Click Save.
   The .3mf file contains slices generated from precise geometry. Use this file with a 3D printer that can read slice information.

Opening Documents

Improving Performance When Opening and Saving Files from a Previous Version

You can improve save performance by clearing the Force referenced documents to save to current version system option in the External References tab.

When you clear the option, only documents that are modified in the current session are saved to the current version of SOLIDWORKS. This reduces save times significantly on the first save of large assemblies and drawings.

To clear the system option:
1. Click Tools > Options and in System Options, click External References.
2. Clear Force referenced documents to save to current version.
4. Add a mate in the top-level assembly.
5. Click File > Save.

SOLIDWORKS saves the top-level assembly because you modified it by adding a mate. However, because you did not enable the system option, the parts that are saved with SOLIDWORKS 2019 are not converted to SOLIDWORKS 2020.

Open Modes from File Explorer or PDM Vault View

When you open SOLIDWORKS documents from File Explorer in Windows® or the PDM Vault View, you can access the Open dialog box before the file opens.

For example, you can search for a large assembly in PDM and then access the Open dialog box directly from the Vault View. The assembly prepopulates the Open dialog box and lets you change the open mode to Large Design Review.

Previously, to access the open modes, you had to bring up the Open dialog box and navigate again to the file you already found in File Explorer or PDM.

You can access the Open dialog box from File Explorer by right-clicking a .SLDPRTR, .SLDASM, or .SLDDRW file and clicking SOLIDWORKS > Open. Earlier versions of the software support this method, however, you must install SOLIDWORKS 2020 to update the SOLIDWORKS Launcher beforehand.

If the SOLIDWORKS software is already open, you can access the Open dialog box from the PDM Vault View or File Explorer by holding Alt and dragging a .SLDPRTR, .SLDASM, or .SLDDRW file into the graphics area. Alt and drag are not supported in earlier versions.
Simplified Open Options

The Open and the Welcome dialog boxes have reorganized and renamed options.

Renamed options:

<table>
<thead>
<tr>
<th>New Name</th>
<th>Previous Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Large Assembly Settings</td>
<td>Large Assembly Mode</td>
</tr>
<tr>
<td>Load hidden components</td>
<td>Do not load hidden components</td>
</tr>
<tr>
<td>Select Sheets</td>
<td>Select sheets to open</td>
</tr>
</tbody>
</table>

Large Assembly Settings

After opening an assembly, click Large Assembly Settings in the Assembly tab of the CommandManager to enable or disable these settings.

For Assemblies system options, the following large assembly options are renamed:

<table>
<thead>
<tr>
<th>New Name</th>
<th>Previous Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Lightweight mode and Large Assembly Settings when the number of</td>
<td>Use Large Assembly Mode to improve performance when the assembly contains more than this number of components</td>
</tr>
<tr>
<td>components exceeds</td>
<td></td>
</tr>
<tr>
<td>Use Large Design Review mode when the number of components exceeds</td>
<td>Use Large Design Review when the assembly contains more than this number of components</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

To access these options, click Tools > Options > System Options > Assemblies.

Application Programming Interface

See SOLIDWORKS API Help: Release Notes for late-breaking updates.

SOLIDWORKS® 2020 API includes the ability to:

- Append a new selection list to a previously suspended selection list.
- Create and edit:
  - Mirrored components.
  - Fillets and chamfers using new methods.
  - Multibody part exploded views.
- Find missing references in fillets and chamfers and reassign them to new edges.
- Get or set:
  - More properties in derived part and pattern feature data objects.
• Whether a sketch is editable.
• Whether to convert width polylines to solid fill hatches when importing to part sketches.
• Slice models into 2D sketch sections.
• Sort a body cut list folder.
• Use 3D Interconnect functionality.
• Use improved mass property reporting.

Changes to System Options and Document Properties

The following options are added, changed, or removed in the software.

**System Options**

These system options are accessible at **Tools > Options > System Options**. The Access column lists which subarea of **System Options** that the option is located.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Access</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Include subfolders for drawings search in Pack and Go</strong></td>
<td>Moved to Pack and Go.</td>
<td><strong>External References</strong></td>
</tr>
<tr>
<td><strong>Allow creation of references external to the model</strong></td>
<td>Permits the creation of external references.</td>
<td><strong>External References</strong></td>
</tr>
<tr>
<td></td>
<td>Renamed from <strong>Do not create references external to the model.</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Reference Component Type</strong></td>
<td>Specifies the type of reference component:</td>
<td><strong>External References</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Any Component</strong> Creates an external reference to any component.</td>
<td></td>
</tr>
<tr>
<td></td>
<td><strong>Only Envelope Component</strong> Creates an external reference only to envelope components.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Available when you select <strong>Allow creation of references external to the model.</strong></td>
<td></td>
</tr>
</tbody>
</table>
In the context of

Specifies the context of external references:

- **Top level assembly**: Creates an external reference to components in the top-level assembly.

- **Same subassembly**: Creates external references only to components in the same subassembly.

Available when you select **Allow creation of references external to the model**.

Force referenced documents to save to current version

For assemblies and drawings that are not saved in the current version, selecting this option saves all referenced documents to the current version of SOLIDWORKS when you save the assembly or drawing. Referenced documents are converted even if they are not modified in the current session. When cleared, only modified documents are saved in the current version. Clear the option to reduce save times or to allow users with earlier versions of the software to continue using the referenced documents.

Include slices

Includes slicing information for 3D printing when you export to a .3mf file.

Document Properties

These document properties are accessible at **Tools > Options > Document Properties**. The Access column lists which subarea of **Document Properties** that the option is located.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Access</th>
</tr>
</thead>
<tbody>
<tr>
<td>All uppercase for dimensions and hole callouts</td>
<td>Sets the default case used in new dimensions and hole callouts to all uppercase.</td>
<td>Drafting Standard &gt; Uppercase</td>
</tr>
<tr>
<td>Add overall dimension to chain dimensions</td>
<td>Automatically adds an overall dimension when you create a set of chain dimensions.</td>
<td>Dimensions &gt; Linear</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
<td>Access</td>
</tr>
<tr>
<td>---------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>Add last reference dimension</td>
<td>(Available if Add overall dimension to chain dimensions is selected.) Automatically adds a final reference dimension when you create a set of chain dimensions.</td>
<td>Dimensions &gt; Linear</td>
</tr>
<tr>
<td>Show type in thread callouts</td>
<td>Sets the default to include the thread Type in cosmetic thread callouts.</td>
<td>Annotations</td>
</tr>
</tbody>
</table>

Closing a Document When Saving a Copy

When you select **Save as copy and open** in the Save As dialog box, you can close the original document. If the original document has unsaved changes, the document remains open.

**To close the document when saving a copy:**

1. Open a model and click **File > Save As**.
2. In the Save As dialog box, click **Save as copy and open** and click **Save**.
3. When prompted by the **Save as copy and open** message, select **Close the original document**.

Selection Sets

You can add and remove selected items to new or existing selection sets. You can add selected items to multiple selection sets.

In assemblies, only the selection sets for the assembly show when you click **Save Selection**. In parts, only the selection sets for the part show. To view selection sets, in the FeatureManager® design tree, expand **Selection Sets**.

You can drag a selected item from the FeatureManager design tree or from a selection set to another selection set. You cannot drag items from an assembly selection set to a part selection set.

Adding a Selection to a Selection Set

**To add a selection to a selection set:**

1. Open a model and select multiple items in the FeatureManager design tree or graphics area.
2. Right-click the selections and click **Save Selection**.

   - To add an item to a new set, click **New Selection Set**.
   - To add an item to an existing set, click **Selection-Set#(##)** where # indicates the order of creation and ## indicates the number of items in the set.

   ![Selection Set Example](image)

   A check next to a selection set indicates that the selected item is a member of the selection set.

3. Expand **Selection Sets** to show the selection set.

Updating Entities in a Selection Set

   **To update entities in a Selection Set:**

   1. In the FeatureManager design tree, select a selection set under **Selection Sets**.
   2. In the FeatureManager design tree or in the graphics area, **CTRL** + select or clear highlighted items.
   3. Continue to press **CTRL** and right-click the selected items, and click **Update Selection Set**.

   Selected items are added to the selection set.

Specifying the Up Axis for View Orientation

You can specify the y-axis or the z-axis as the default up orientation for views. This option changes the view orientation for standard orthogonal, named, and child views.

To use this functionality, save the files in SOLIDWORKS 2020 or later.

**To specify the up axis for view orientation:**

1. Open a model.
2. Click **View Orientation** (View toolbar).
3. In the Orientation dialog box, click the **Up Axis** flyout and select an option:

   | **Apply Y-up views** | Uses the Y-axis as the up orientation for views. |
   | **Apply Z-up views** | Uses the Z-axis as the up orientation for views. |
Installation

This chapter includes the following topics:

- Improved Installation Manager Download Performance
- Installing the 3DEXPERIENCE Marketplace Add-In
- Installing the 3DEXPERIENCE Add-In
- Installing SOLIDWORKS PCB Viewer
- Installing Toolbox Software Without Installing Toolbox Data
- SOLIDWORKS File Utilities Replaces SOLIDWORKS Explorer
- Testing a Setup for a Push Deployment

Improved Installation Manager Download Performance

The download and extraction processes of the Installation Manager use parallel threading. The result is faster downloads. Users who are downloading more than one product will see the greatest benefit.

Installing the 3DEXPERIENCE Marketplace Add-In

The 3DEXPERIENCE Marketplace add-in installs by default with your installation of SOLIDWORKS 2020 SP01 and later.

3DEXPERIENCE Marketplace contains these services: PartSupply, Make, and Engineering. You access 3DEXPERIENCE Marketplace from the Task Pane.

The 3DEXPERIENCE Marketplace add-in allows easier interaction between 3DEXPERIENCE Marketplace and SOLIDWORKS by bringing the tools right into your modeling environment. It also lets you search and download parts and assemblies from an online catalog populated with models from component suppliers and individual SOLIDWORKS users. You can insert these parts and assemblies directly into your active SOLIDWORKS model from the Task Pane.

For information on PartSupply, Make, or Engineering, see the Frequently Asked Questions section (FAQs) available on each site.
Installing the 3DEXPERIENCE Add-In

The 3DEXPERIENCE add-in is a unified add-in that provides access to all the
3DEXPERIENCE services and apps that you are entitled to use based on your roles.

If you are a member of your organization’s 3DEXPERIENCE platform, you can download
and install additional add-in components that provide access to 3DEXPERIENCE
collaboration apps, file sharing, and data management, including the 3DEXPERIENCE
Marketplace services.

Prerequisites for installing the 3DEXPERIENCE add-in are:

- 3DEXPERIENCE platform credentials. You can sign in with your SOLIDWORKS ID and
  password if it uses the same email address your administrator used to invite you to
  3DEXPERIENCE platform.
- A web browser.
- The 64-bit version of the Java 11 JRE component or higher.
- A full product installation of SOLIDWORKS 2018 SP0 or later.

To install the 3DEXPERIENCE add-in:

1. Before you begin, exit SOLIDWORKS.
2. Log in to the 3DEXPERIENCE platform.
   If your company has an on-premise installation, contact your administrator to get
   the sign in link.
3. At the top bar of the 3D Dashboard, click the Compass
4. Under Me, click SOLIDWORKS.
5. Follow the prompts to download and install the 3DEXPERIENCE Launcher and more
   add-in components.
   The add-in components available to you depend on your platform roles. They download
   sequentially, so keep your browser window open and watch for prompts.
6. To use the 3DEXPERIENCE add-in for the first time:
   a) Return to the 3D Dashboard in your browser.
   b) Click the Compass and click SOLIDWORKS.
   c) Log in if required.

Installing SOLIDWORKS PCB Viewer

You can download and install SOLIDWORKS® PCB Viewer using the Installation Manager,
making it easier to install concurrently with SOLIDWORKS or other SOLIDWORKS products.
This free PCB viewer is available without a license.

You can use the viewer to access, print, and search through all of your team's design
files created in Altium Designer.

You can also add SOLIDWORKS PCB Viewer to your administrative image deployments.

You cannot install the SOLIDWORKS PCB Viewer on the same computer as SOLIDWORKS
PCB.
Installing Toolbox Software Without Installing Toolbox Data

If your environment has a PDM or shared Toolbox/Hole Wizard location, you can set client installations to not install or upgrade Toolbox data in that location.

Do this if:

- You did not yet set up the SOLIDWORKS PDM local view before installing the SOLIDWORKS software.
- The files in the location are in use and could block SOLIDWORKS installations from completing.
- The location is unavailable and could block SOLIDWORKS installations from completing.

When you set client installations to not install Toolbox data, the SOLIDWORKS software and settings point to the Toolbox/Hole Wizard location, but you must install the data in a central location later.

To install the SOLIDWORKS software without including Toolbox/Hole Wizard data, you must install SOLIDWORKS from an administrative image.

1. In the Administrative Image Option Editor, click Settings.
2. Expand Toolbox/Hole Wizard Options.
3. When asked if you want this client to install/upgradethe Toolbox files, select No, install the Toolbox software without including the data files.

At least one person, typically the SOLIDWORKS Administrator, must install or upgrade the Toolbox/Hole Wizard data in the central location or the software will not function properly. Anyone in the organization can handle this task with a single manual installation of the SOLIDWORKS software. If you manage Toolbox inside of SOLIDWORKS PDM, follow the steps outlined in the Toolbox section of the SOLIDWORKS PDM Administrator Guide to install or upgrade the Toolbox data.

SOLIDWORKS File Utilities Replaces SOLIDWORKS Explorer

SOLIDWORKS Explorer has been replaced by SOLIDWORKS File Utilities, which lets you rename, replace, copy, and move SOLIDWORKS files while maintaining file references.

You can install SOLIDWORKS File Utilities from the Installation Manager, the Administrative Image Options Editor, and its own installation wizard. It is also available from https://www.solidworks.com/sw/support/downloads.htm.

Testing a Setup for a Push Deployment

The Deploy Automatically tab in the Administrative Image Option Editor contains a test feature.

You can run a mock installation that exercises the systems used for the deployment, such as:

- Connecting to the target computer.
- Creating an install task on that computer.
- Completing the install task on that computer.
- Updating the status and logs on the administrative image.
• Detecting a program to run before or after the installation.

The test checks for file paths, validates permissions, and reports that the installation ended successfully. It does not install any software or modify the registry on the target system. If any one of the systems fails on any of the target computers, the test indicates which system failed.

Tooltips provide more information about failures. You can export the results to an .xml spreadsheet (or .csv), which is helpful for reviewing multiple failures or sharing results with other support personnel.

To test a setup for a push deployment:

1. Using the Installation Manager, create an Administrative image.
2. Start the Administrative Image Option Editor.
   
   You can start the option after the Installation Manager completes creating the administrative image or double-click sldAdminOptionEditor.exe in the administrative image folder.

3. On the Setup tab, add one or more computers.
4. Click Deploy Automatically:
   
   a) Supply a domain administrator's username and password.
   b) Select one or more computers to test.
   c) Click Test.

5. When the Setup Test appears, click Run Test.
6. Allow several minutes for the test to complete or click Cancel Test at any time.
7. Review and correct any setup problems.
This chapter includes the following topics:

- **Selecting a SOLIDWORKS Simulation License with a SolidNetWork License**
- **SOLIDWORKS CEF Sub Process**
- **SOLIDWORKS Rx Supports SOLIDWORKS Composer and SOLIDWORKS Electrical**
- **Specifying Support Information**

### Selecting a SOLIDWORKS Simulation License with a SolidNetWork License

SolidNetWork license users can control which of the SOLIDWORKS® Simulation licenses in their license pool to use when they add in SOLIDWORKS Simulation. They can also upgrade the SOLIDWORKS Simulation license without unloading the add-in in case they need a higher license type for more advanced studies.

1. To use a specific SOLIDWORKS Simulation license:
   a) In the SOLIDWORKS, click **Tools > Add-Ins** and in the Add-in dialog box, select **SOLIDWORKS Simulation**.
   b) On **SOLIDWORKS Simulation** (CommandManager), click the **Down** arrow to display a list of licenses on your server that can support Simulation.
   c) Select the appropriate SOLIDWORKS Simulation license.
2. To check or change your current SOLIDWORKS Simulation license, click the Down arrow on SOLIDWORKS Simulation (CommandManager).

The license that is in-use displays a check mark. If more advanced license types are available, you can upgrade.

You cannot downgrade a SOLIDWORKS Simulation license. Disable the SOLIDWORKS Simulation add-in and add the license back in at a lower level.

3. Optional: To disable the add-in, click SOLIDWORKS Simulation (CommandManager) or clear it from Tools > Add-Ins.

The following cases still use license order:

- When SOLIDWORKS Simulation starts running.
- If SOLIDWORKS Simulation is added in Tools > Add-Ins.
- If the you click SOLIDWORKS Simulation without specifying a license from the pull-down list.

SOLIDWORKS CEF Sub Process

SOLIDWORKS integrates the Chromium Embedded Framework (CEF). In the Microsoft Windows Task Manager, one or more instances of SOLIDWORKS CEF Sub Process, swCefSubProc.exe, appear when you use SOLIDWORKS.

SOLIDWORKS Rx Supports SOLIDWORKS Composer and SOLIDWORKS Electrical

SOLIDWORKS Rx is installed with SOLIDWORKS Electrical and SOLIDWORKS Composer.

The Problem Capture tab in SOLIDWORKS Rx collects files, videos, and settings for SOLIDWORKS Composer and SOLIDWORKS Electrical. In the Capture section, choose the application to capture. SOLIDWORKS Composer, SOLIDWORKS Electrical, or SOLIDWORKS display only if you installed them in the 2020 version of SOLIDWORKS, SOLIDWORKS Composer, or SOLIDWORKS Electrical.

If you select SOLIDWORKS Electrical or SOLIDWORKS Composer and click Record Video, SOLIDWORKS Rx:

1. Records the active SOLIDWORKS Electrical or SOLIDWORKS Composer session or starts a new session to record.
2. Lists the video in the Package section, along with system and other support information:
   - For SOLIDWORKS Electrical, this is the same information currently generated by the Support Information on the Help menu.
   - For SOLIDWORKS Composer, this information also includes logs and settings.
3. Lets you add more files to the Package section. For example, for SOLIDWORKS Electrical, you can add .tewzip files.

4. Lets you package the files in the Package section into a .ZIP file and send it, along with a description of the problem, to your technical support contact.

Specifying Support Information

Administrators can provide support information to users by using the Settings Administrator Tool.

To access the Settings Administrator Tool, you must first create an administrative image. See SOLIDWORKS Online Help: Creating an Administrative Image from SOLIDWORKS Installation Manager.

Support information appears when you click Get support in the following locations:

- Help
- Logged in
- Welcome dialog box under Resources
- SOLIDWORKS Error Report dialog box
- In SOLIDWORKS Rx, Help

To specify support information:

1. Start the Settings Administrator Tool from an administrative image.
2. In the SOLIDWORKS Setting Administration dialog box, select an option on the Welcome page and click Next until you reach the Support Information page.
3. Specify the contact information:

<table>
<thead>
<tr>
<th>Open the SOLIDWORKS Support website</th>
<th>Get Support opens this website if you do not specify contact information.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Provide support contact information in a dialog box</td>
<td>Specifies contact information to show in the SOLIDWORKS Support dialog box:</td>
</tr>
<tr>
<td>• Organization or person name</td>
<td>• Contact options:</td>
</tr>
<tr>
<td>• Contact options:</td>
<td>• Email</td>
</tr>
<tr>
<td>• Email</td>
<td>• Phone number</td>
</tr>
<tr>
<td>• Phone number</td>
<td>• Web address</td>
</tr>
<tr>
<td>• Web address</td>
<td>• Web address text</td>
</tr>
<tr>
<td>• Web address text</td>
<td>• Note</td>
</tr>
<tr>
<td>• Note</td>
<td>To view the SOLIDWORKS Support dialog box, click preview.</td>
</tr>
</tbody>
</table>
Assemblies

This chapter includes the following topics:

- **Envelope Publisher**
- **Flexible Components**
- **Mates**
- **Patterns**
- **Large Design Review**
- **Exploded Views**
- **External References Options**
- **Isolating Interferences**
- **Modify Configuration for Toolbox Components**
- **Performance Improvements for Assemblies**
- **Save as Copy with a Subset of Configurations**

**Envelope Publisher**

You can use the **Envelope Publisher** tool to include components from a top-level assembly as envelopes in a subassembly. You can work in the subassembly using the published envelopes as reference components in isolation from the top-level assembly. The envelope components inherit changes from the top-level assembly.

Multiple subassemblies can have the same envelope. Subassemblies can contain only one group of envelopes published by **Envelope Publisher**.

When you select a subassembly as a destination for the envelope, an external reference is created to the parent assembly. The **Published Envelopes** folder displays external reference symbols that indicate the reference state of the envelope.
**Envelope Publisher** is available when an assembly contains subassemblies. The tool is not available in Large Design Review mode.

Creating Envelopes for a Subassembly

**To create envelopes for a subassembly:**

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\assemblies\envelope_publisher\EnvelopePublisher.SLDASM.

2. Click **Tools > Envelope Publisher**. If **Envelope Publisher** is not available, check the **External References** system options:
   a) Click **Tools > Options > System Options > External References**.
   b) Under **Assemblies**, select:
      - Allow creation of references external to the model
      - Any component for Reference component type
      - Top level assembly for In the context of

3. In the Envelope Publisher PropertyManager, for **Components to use as envelopes** select the following components:
   a) Under **Connectors**, select all the connectors.
   b) Select **Ducting<1>**.
   c) Under **Building<1>** subassembly, select **DoorSubAssy<1>** and **DoorSubAssy<2>**.

4. For **Destination subassemblies**, select **PipeSubAssy<1>**.
5. Optional: Change the envelope group name from the default name of **Envelope Group1**.
6. Click **Add group**, and click ✔.
7. In the FeatureManager® design tree, right-click **PipeSubAssy<1>** and click **Open pipesubassy.SLDA**.
8. Optional: If prompted, click **Rebuild**.

You can work with the envelope components in the subassembly.

**Viewing Envelopes**

**To view envelopes:**

1. Click **View > Hide/Show**.
2. Select an option:

<table>
<thead>
<tr>
<th>View Component Envelopes</th>
<th>Displays envelopes that belong to components in the top-level assembly.</th>
</tr>
</thead>
<tbody>
<tr>
<td>View Top Level Envelopes</td>
<td>Displays envelopes that belong to the top-level assembly.</td>
</tr>
</tbody>
</table>

**Envelope Publisher PropertyManager**

**To open the Envelope Publisher PropertyManager:**

In an assembly that contains a subassembly, click **Tools > Envelope Publisher**.

If **Envelope Publisher** is not available, check the **External References** system options:

1. Click **Tools > Options > System Options > External References**.
2. Under **Assemblies**, select:
   - Allow creation of references external to the model
   - Any component for Reference component type
   - Top level assembly for In the context of

**Add a Group / Edit Group**

| Add or Edit Envelope Group |
|-----------------------------|--------------------------|
| Lists the group name.       |
Specifiesthecomponentstoincludeintheenvelope.

Flexiblesubassembliescannotbeenvelopecomponents.

Components to use as envelopes

Specifies the subassemblies to publish the envelopes. The published envelope creates external references to the parent assembly.

You cannot select the following subassemblies as a destination:

- Subassemblies that are a destination for a different envelope group.
  For assemblies that contain multiple instances of a subassembly, you can use only one of the instances as a destination subassembly.
- Subassemblies that are a component in an envelope.

Destination subassemblies

Add group

Adds the envelope group.

Reset

Resets the PropertyManager fields.

Done

Saves changes to the envelope group.

Envelope Groups

Lists envelope groups.

Flexible Components

You can define a part component as flexible to drive the geometry of flexible components by the assembly geometry.

For example, you model a spring in the context of an assembly where the length of the spring is driven by an external reference in the assembly. You insert the spring into a second assembly where the spring appears with an out-of-context reference. You can use the Make Part Flexible tool to remap the out-of-context reference to the second assembly. As a result, the spring is driven by the second assembly without affecting the nominal length of the spring.
You can use **Make Part Flexible** under the following conditions:

- A single part is selected.
- A part is in the top-level of the active assembly.
- A part has external references defined in the context of an assembly that is not the active assembly.

The external reference must be one of the following entity types:

<table>
<thead>
<tr>
<th>Arc or cylindrical edges</th>
<th>Partial cylindrical faces</th>
<th>Sketch arcs or circles</th>
</tr>
</thead>
<tbody>
<tr>
<td>Axes</td>
<td>Planar faces</td>
<td>Sketch lines (linear)</td>
</tr>
<tr>
<td>Cylindrical faces</td>
<td>Planes</td>
<td>Sketch points</td>
</tr>
<tr>
<td>Linear edges</td>
<td>Reference points</td>
<td>Vertices</td>
</tr>
</tbody>
</table>

The custom and configuration-specific properties of the flexible component are the same as these properties in the component's nominal state. Properties show the value from the nominal state. Select **Use mass property from rigid state** to apply the mass properties of the component in its rigid state to the activated flexible component.

The flexible component updates dynamically when an external reference changes.

In the FeatureManager design tree, ![Flexible Component](image) indicates flexible components.

To change a component from flexible to rigid, select the part and click **Make Part Rigid** in the context menu. The remapped external references are deleted and the component returns to its nominal state.

Adding a Flexible Component

**To add a flexible component:**

1. Open `system_dir:Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\assemblies\flexible_components\Destination_Assembly.SLDASM`
2. Click **Insert Components** (Assembly toolbar) and select `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\assemblies\flexible_components\Spring.SLDPRT`.

3. Create a coincident mate between **Collar<1>** and the red face of **Spring<1>**.

4. Click **View > Hide/Show > Axes**.

5. Create a concentric mate between the central axis of **Spring<1>** and the cylindrical shaft of **Shaft<1>**.

6. Click **✓**.
7. In the FeatureManager design tree, right-click Spring<1> and click Make Part Flexible in the context menu. In the graphics area, a preview of the unattached reference entity appears.

8. To reattach the reference entity, click a planar face on Shaft<1>.

9. Click ✔.
10. In the graphics area, move Collar<1> up and down.

Editing External References of Flexible Components

1. Right-click the component and click Edit Flexible Part References.
2. Modify the references listed in the Activate Flexible Component PropertyManager.

Activate Flexible Component PropertyManager

To open the Activate Flexible Component PropertyManager:

Open an assembly, right-click a part, and click Make Part Flexible in the context toolbar.
Flexible References

<table>
<thead>
<tr>
<th><strong>External References in the selected component</strong></th>
<th>Lists the flexible references that you need to remap. When you select a reference, a preview appears in the graphics area. Select an entity of the same type in the graphics area to specify the reference.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Indicates a reference that is not specified.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Indicates a reference that is specified.</td>
</tr>
<tr>
<td><strong>Use mass property from rigid state</strong></td>
<td>Applies the mass properties of the component in its rigid state to the activated flexible component as overridden mass properties.</td>
</tr>
</tbody>
</table>

Mates

**Video: What's New in SOLIDWORKS 2020 - Assembly Mates**

Flip Alignment of Width Mates

In the Mate PropertyManager, click Aligned and Anti-Aligned to flip the alignment of width mates. In the Copy with Mates PropertyManager and in the Quick Mates context toolbar, click Flip Mate Alignment.

**To flip the alignment of width mates:**
1. Open an assembly that contains a width mate.
2. In the FeatureManager design tree, expand Mates.
3. Right-click Width and click Flip Mate Alignment.

Quick Mates Context Toolbar

You can select the following mates and options from the Quick Mates context toolbar:

<p>| <strong>Lock rotation</strong> | Available for concentric mates. |
| <strong>Flip Mate Alignment</strong> | Available for mates that support the flip alignment option. |</p>
<table>
<thead>
<tr>
<th>Feature</th>
<th>Available options:</th>
</tr>
</thead>
</table>
| **Limit Distance Mate** | ![Flip Dimension](image1)  
|                    | ![Maximum Value](image2)  
|                    | ![Minimum Value](image3)  
|                    | ![Arc/Circle Measurements](image4)                                                |
| **Limit Angle Mate** | ![Flip Dimension](image1)  
|                     | ![Maximum Value](image2)  
|                     | ![Minimum Value](image3)  |
| **Slot Mate**       | ![Flip Dimension](image1)  
|                     | ![Slot Position](image5)  
| **Width Mate**      | ![Flip Dimension](image1)  
|                     | ![Width Position](image6)  

**Patterns**

Video: What's New in SOLIDWORKS 2020 - Assembly Patterns

Component Pattern with Variable Instances

You can vary the linear or angular spacing of individual instances of linear and circular component patterns to override the pattern spacing.

You can use these options in a callout to modify the spacing and direction of an instance:
<table>
<thead>
<tr>
<th>Distance from seed</th>
<th>Specifies the absolute value from the seed component. Use only positive values. Available for linear component patterns.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Angle from seed</td>
<td>Specifies the angle from the seed to the selected instance. Use only positive values. Available for circular component patterns.</td>
</tr>
</tbody>
</table>
| Offset from nominal | Specifies the relative value to the nominal position of the selected instance.  
The nominal position of the instance is the location of the instance before the modification.  
You can specify positive and negative values. For negative values, the absolute distance to the seed must be positive. Available for linear and circular component patterns. |

In the Linear Component Pattern and Circular Component Property Managers, **Instances to Skip** is renamed to **Instances to Override**. You can specify instances to skip in **Skipped instances** 🌈. Use **Modified instances** 🟢 to specify instances to modify.

Modifying an Instance in a Linear Component Pattern

**To modify an instance in a linear component pattern:**

1. **Open** system_dir: \Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\assemblies\patterns\Vary_Pattern.SLDASM.

2. In the FeatureManager design tree, right-click **LocalPattern1** 🟢 and click **Edit Feature** 📒.

3. In the PropertyManager, under **Instances to Override**, click in **Modified instances** 🟢. In the graphics area, pink selection orbs display on the pattern instances.

4. Click the selection orb for **4,1** and click **Modify Instance**.

5. **54**
5. In the callout, modify the value for **Dir 1 offset from nominal** to −60mm and click outside of the callout.

A shadow instance appears in the new position.

6. In the PropertyManager, click ✅.

The bracket is no longer behind the pipe.

**Mirror Components PropertyManager**

You can position a mirrored component by using the origin of that component. You can select multiple components in the component orientation field. You have more control over the orientation of copied components that are not opposite-hand versions.

New and changed options on the **Step 2: Set Orientation** page of the Mirror Components PropertyManager:

<table>
<thead>
<tr>
<th>Mirror Type</th>
<th>Component origin</th>
<th>Mirrors a component instance about the component origin of the selected reference plane. This instance is not an opposite-hand version.</th>
</tr>
</thead>
</table>
These options replace the **Reorient components** options.

<table>
<thead>
<tr>
<th>Orient Components</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="X mirrored, Y mirrored" /></td>
<td>X and Y axes mirror about the plane.</td>
</tr>
<tr>
<td><img src="image" alt="X mirrored and flipped, Y mirrored" /></td>
<td>X and Y axes mirror about the plane with the X axis direction reversed.</td>
</tr>
<tr>
<td><img src="image" alt="X mirrored, Y mirrored and flipped" /></td>
<td>X and Y axes mirror about the plane with the Y axis direction reversed.</td>
</tr>
<tr>
<td><img src="image" alt="X mirrored and flipped, Y mirrored and flipped" /></td>
<td>X and Y axes mirror about the plane with the X and Y axes direction reversed.</td>
</tr>
</tbody>
</table>

**Component Orientation Axis**

<table>
<thead>
<tr>
<th>Align to component origin</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculates the component orientation by mirroring and flipping about the X and Y axes of the component.</td>
</tr>
</tbody>
</table>

**Align to selection**

Calculates the component orientation by mirroring and flipping the component about the local X and Y axes. In the calculation, X is parallel to the mirror plane and Y is normal to the face or plane that you select in **Alignment Reference**.

A second reference triad appears in the graphics area and shows the X and Y rotation axes for the seed and the mirrored component. The axes change as you click the orientation icons.

**Alignment Reference**

Select an entity to align the up axis of the orientation axes. Available when you select **Align to selection**.

You can select the following items as references:

- Planes or planar faces that are perpendicular to the mirror plane.
- Linear edges or linear sketch segments that are parallel to the mirror plane.

Click **Flip alignment reference direction** to flip the direction of the reference.
Changes to the **Step 2: Set Orientation** page:

- The **Mirror Type** section moved.
- The **Orient Components** box as well as the **Components to Mirror** box on the **Step 1: Selections** page of the PropertyManager are resizable.
- Multiple components can be selected for **Orient Components**. **Shift** + select to select all items between the first and last selected items. **Ctrl** + select to select individual components. **Alt** + select items to designate an opposite hand component.
- **Create opposite hand version** moved to the right of the **Orient Components** options.
Comparing Component Orientation Options

To compare the component orientation options:

1. Open `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\assemblies\mirror_pattern\TopAssembly.SLDASM`.
2. Click **Linear Component Pattern > Mirror Components** (Assembly toolbar).
3. Select **Mirror Plane** for **Mirror Plane** and select **Valve assembly<1>** for **Component to Mirror**.
4. Click **Next** to **Step 2: Set Orientation**.
5. Under **Mirror Type**, select **Component origin**.
6. Under **Orient Components**, select a component orientation option.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Image</th>
</tr>
</thead>
<tbody>
<tr>
<td>X mirrored, Y mirrored</td>
<td>X and Y axes mirror about the plane.</td>
<td><img src="image1.png" alt="Image" /></td>
</tr>
<tr>
<td>X mirrored and flipped, Y mirrored</td>
<td>X and Y axes mirror about the plane with the X-axis direction reversed.</td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
<tr>
<td>X mirrored, Y mirrored and flipped</td>
<td>X and Y axes mirror about the plane with the Y-axis direction reversed.</td>
<td><img src="image3.png" alt="Image" /></td>
</tr>
<tr>
<td>X mirrored and flipped, Y mirrored and flipped</td>
<td>X and Y axes mirror about the plane with the X and Y axes direction reversed.</td>
<td><img src="image4.png" alt="Image" /></td>
</tr>
</tbody>
</table>

**Comparing Mirror Type Options**

**To compare the Mirror Type options:**

1. **Open** `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\assemblies\mirror_pattern\TopAssembly.SLDASM`. 
2. Click **Linear Component Pattern > Mirror Components** (Assembly toolbar).
3. Select **Mirror Plane** for **Mirror plane** and select **Valve assembly<1>** for **Component to Mirror**.
4. Click **Next** to **Step 2: Set Orientation**.
5. Under **Orient Components**, select **X mirrored, Y mirrored**.
6. Under **Mirror Type**, select an option.
   a) Optional: Click **View > Hide/Show** to view the bounding box, center of mass, or origins in the graphics area.

<table>
<thead>
<tr>
<th><strong>Center of bounding box</strong></th>
<th><img src="image" alt="Diagram" /></th>
</tr>
</thead>
<tbody>
<tr>
<td>The distance between the mirror plane and the center of the bounding box is equal for the seed and the mirrored instance.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Center of mass</strong></th>
<th><img src="image" alt="Diagram" /></th>
</tr>
</thead>
<tbody>
<tr>
<td>The distance between the mirror plane and the center of mass is equal for the seed and the mirrored instance.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Component origin</strong></th>
<th><img src="image" alt="Diagram" /></th>
</tr>
</thead>
<tbody>
<tr>
<td>The distance between the mirror plane and the origin is equal for the seed and the mirrored instance.</td>
<td></td>
</tr>
</tbody>
</table>

**Pattern Driven Component Patterns**

When a Pattern Driven Component Pattern uses a Hole Wizard feature as the driving feature, you can align the patterned instances to each hole axis.

In the Pattern Driven Property Manager, under **Driving Feature or Component**, you can select an alignment method when you select a hole wizard feature as the driving feature:

<table>
<thead>
<tr>
<th><strong>Align to holes</strong></th>
<th>Aligns instances to the Hole Wizard feature.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default alignment method for new pattern features.</td>
<td></td>
</tr>
</tbody>
</table>
Aligning Patterned Instances Using a Hole Wizard Feature

In the example, you pattern a rivet to a hole feature to connect 2 plates.

**To align patterned instances using a Hole Wizard feature:**

1. Open `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\assemblies\patterns\RivetedPlates.SLDASM`.

2. Click **Linear Component Pattern > Pattern Driven Component Pattern** (Assembly toolbar).

3. In the PropertyManager, select the following items:
   a) For **Components to Pattern**, select **round head rivets gb<2>**.

   ![Component Selection](image1)

   b) For **Driving feature or component**, select the **04.0 (4) Diameter Hole1** feature.

   ![Driving Feature Selection](image2)

   c) Click **Select Seed Position** and select the seed component.

   ![Seed Component Selection](image3)
4. Click **OK**.

The pattern for **round head rivets gb<2>** matches the hole pattern.

<table>
<thead>
<tr>
<th>Top view of 2 plates</th>
</tr>
</thead>
<tbody>
<tr>
<td>Side view of 2 plates</td>
</tr>
</tbody>
</table>

**Large Design Review**

Create and Edit Component Patterns in Large Design Review

You can create and edit linear and circular component patterns when you edit an assembly in Large Design Review mode. You can edit pattern driven and sketch driven component patterns. This functionality is available for top-level assemblies only.

You can use the following tools when you right-click a pattern feature in the FeatureManager design tree:

- **Edit Feature**
- **Suppress**
- **Unsuppress**
- **Hide Components**
- **Show Components**
- **Isolate Components**

For a component pattern that is driven by an unavailable entity, **LargeDesignReview** shows as a prefix to the entity name in the PropertyManager.

**Available Functionality by Component Pattern**

<table>
<thead>
<tr>
<th></th>
<th>Linear and Circular</th>
<th>Pattern Driven and Sketch Driven</th>
<th>Curve Driven and Chain</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create</td>
<td>✓</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delete</td>
<td>✓</td>
<td>✓</td>
<td>✓</td>
</tr>
</tbody>
</table>
Create Mates to Reference Geometry in Large Design Review

You can create mates to the reference geometry of components when you edit an assembly in Large Design Review.

In the FeatureManager design tree, you can view the following reference geometry for a component:

- Standard planes
- Origin
- Reference planes
- Axes - not temporary axes
- Reference points
- Coordinate systems

You can Hide or Show reference geometry in the top-level assembly and components.

You can create standard mates that reference the reference geometry. These mates are saved in the top-level assembly.

To use this functionality, save the assembly in SOLIDWORKS® 2020 and later.

To create mates to reference geometry in Large Design Review:

1. Click Open.
2. In the dialog box, select an assembly, and then in Mode, select Large Design Review.
3. Select Edit assembly.
4. Click Open.
5. Click **Mate** (Assembly toolbar).
6. Select options in the Mate PropertyManager to create a mate to reference geometry.
7. Click ✓.
8. In the FeatureManager design tree, expand **Mates** for the top-level assembly to view the mate.

Exploded Views

Auto-Space Components in Exploded Views

You can enable **Auto-space components** for existing explode steps. You can select center, rear, or front of the bounding box for the order of auto-spaced components.

**Auto-space components** is renamed from **Auto-space components on drag**.

**To use Auto-space components in exploded views:**

1. Open `system_dir: \Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\assemblies\explode\pillow_block.SLDASM`.
2. Click **Insert > Exploded View**.
3. In the PropertyManager, for **Explode Step Components**, select these components:
   - flatwasher<1>
   - lockwasher<2>
   - socket head cap screw<2>
4. Drag the **Y axis** to explode the components.
5. Under **Auto-space components**, select a bounding box option:

<table>
<thead>
<tr>
<th><strong>Bounding box center</strong></th>
<th><strong>Bounding box rear</strong></th>
<th><strong>Bounding box front</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Orders auto-spacing by the center of the bounding box.</td>
<td>Orders auto-spacing by the rear of the bounding box.</td>
<td>Orders auto-spacing by the front of the bounding box.</td>
</tr>
</tbody>
</table>

6. Click **Add Step**.

7. Click ✔️.

**Reusing a Multibody Part Explode**

You can reuse an exploded view from a multibody part in an assembly level exploded view. This behavior is similar to reusing a subassembly explode in an exploded view.

The reused explode step shows as fully exploded in the graphics area. If a multibody part has multiple exploded views, you can select the exploded view to use.

You cannot view individual steps reused from a multibody part. The individual steps are not animated when you use **Animate explode** or **Animate collapse**. The reused exploded view shows as a single step in the Explode PropertyManager.

**To reuse a multibody part explode:**

1. Open an assembly that contains a multibody part with an exploded view.
2. On Configuration Manager, right-click an exploded view and click **Edit Feature**.
3. In the PropertyManager, for **Explode Step Components** 🌐, select the multibody part.
4. Under **Options**, click **From Part**.

   The multibody part explodes in the graphics area. The exploded view from the multibody part is added as a step under **Explode Steps**.
5. Click 🔄.

External References Options

You can select options for **In the context of** to allow creation of external references in a top-level assembly or a subassembly. You can select options for **Reference Component Type** to limit external references to any component or only envelope components.

When you edit a part in the context of an assembly, the part turns blue and the assembly in which the external reference is created turns purple in the FeatureManager design tree.

To set external references options:
1. Click **Tools > Options > System Options > External References**.
2. Under **Assemblies**, specify:

<table>
<thead>
<tr>
<th>Allow creation of references external to the model</th>
<th>Permits the creation of external references. This option is renamed from <strong>Do not create references external to the model</strong>.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Reference Component Type</strong></td>
<td><strong>Any Component</strong> creates an external reference to any component. <strong>Only Envelope Component</strong> creates an external reference only to envelope components.</td>
</tr>
<tr>
<td><strong>In the context of</strong></td>
<td><strong>Top level assembly</strong> creates an external reference to components in the top-level assembly. <strong>Same subassembly</strong> creates external references only to components in the same subassembly.</td>
</tr>
</tbody>
</table>

3. Click **OK**.

Isolating Interferences

In the **Interference Detection** tool for assemblies and multibody parts, you can tag interference, components, or bodies for isolation after you exit the Interference Detection PropertyManager.

To isolate interferences:
1. Open an assembly or multibody part, and click **Interference Detection** (Evaluate toolbar).
2. In the PropertyManager, click **Calculate**.
3. Under **Results**, right-click an interference and click **Isolate when done**.

   Isolated interferences appear as 📋.

   When you select **Component View** for assemblies or **Body View** for multibody parts, you can click **Isolate when done** for the parent component, the child component, or the interference.

4. Click ✅.

   The tagged interferences appear in the graphics area.

5. Click **Exit Isolate** on the Isolate pop-up toolbar.

**Modify Configuration for Toolbox Components**

You can modify the configuration for Toolbox components by using the Modify Configurations dialog box.

**To modify configurations for toolbox components:**

- In the FeatureManager design tree, right-click a toolbox component and click **Configure Component** 📋.

In the Modify Configurations dialog box, you can create a configuration, switch to a different configuration, or suppress a component.

**Performance Improvements for Assemblies**

Assembly performance is optimized for some tools and workflows so full rebuilds of an assembly or graphics occur less often.

**Save as Copy with a Subset of Configurations**

You can save a copy of a part or assembly with a subset of configurations.

When selecting configurations to save, the active configuration is selected by default. The parent configuration of a derived configuration is selected with the derived configuration. You cannot clear the check box for the active configuration or the parent configuration.

Linked display states remain in the copied model.

**To save as a copy with a subset of configuration:**

1. Open a model, right-click a configuration in the ConfigurationManager, and click **Save Configurations**.
2. In the Save Configurations as a new Assembly/Part dialog box, select a configuration.
   To select all configurations, click 📐.
3. Click **Save Selected**.
4. In the Save As dialog box, click **Save**.
This chapter includes the following topics:

- Customization Settings
- Probing Routines
- Tab Cutting
- Tapered Multipoint Thread Tool
- Universal Post Generator

SOLIDWORKS CAM is offered in two versions. SOLIDWORKS CAM Standard is included with any SOLIDWORKS license that has SOLIDWORKS Subscription Service. SOLIDWORKS CAM Professional is available as a separately purchased product that you can use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Customization Settings

You can save and restore customization settings for a SOLIDWORKS CAM Technology Database.

The Customization Settings options are available in the Settings tab. Make sure the SOLIDWORKS software is not running when you save or restore settings.

Probing Routines

You can use a Probe tool to speed up the setup and manufacturing process.

The defined routines area includes:

- Single Point
- Pocket
- Boss
- 3 Point Boss
• 3 Point Hole

The **Probe** tool is only available in SOLIDWORKS CAM Professional.

Previously, the probing cycles were controlled through a custom post processor using drilling cycles in SOLIDWORKS® CAM.

**Tab Cutting**

You can create multiple tabs or micro-joints in parts for various fabrication workflows. The settings are available in the Contour tab.

The tabs or micro-joints are helpful when cutting parts in machines like a plasma, water jet, or laser. They keep small parts from tipping or falling through the cut process.

Previously, the **Avoid Area** options handled this functionality in SOLIDWORKS CAM.

**Tapered Multipoint Thread Tool**

A multipoint tapered threading tool is available in the library. The tool lets the thread angle align with tapered pockets. You can define tapered threads as single point, user defined, or automatic.

Previously, you could only use straight threading tools in either single or multipoint configurations.

**Universal Post Generator**

A free post editor is available. The editor adds template posts for turning that extend beyond milling.
SOLIDWORKS Composer

This chapter includes the following topics:

- **SOLIDWORKS Composer**
- **SOLIDWORKS Composer Sync**

### SOLIDWORKS Composer

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents for product communication and technical illustrations.

### 360 Degree Capture

When you create technical illustrations and high resolution images, you can capture a defined number of images of the model along a vertical axis performing a 360° clockwise rotation.

See [Composer Help: Working in Workshops > Technical Illustration Workshop > Multiple Tab](#) and [Working in Workshops > High Resolution Image Workshop > Multiple Tab](#).

### Basic Attach Type for Annotations

A basic attach type is available for annotations.

See [Composer Help: Editing Actor Properties > Annotation Properties > Attach](#).

### BOM ID Callouts

A BOM table property lets you display BOM table entries only for geometry actors with visible callouts that display the BOM ID.

See [Composer Help: Editing Actor Properties > BOM Table Properties > Filter](#).
Exponent Shape for Callouts

A callout property, **Exponent Shape**, displays a callout’s quantity exponent with a colored circular background.

See *Composer Help: Editing Actor Properties > Annotation Properties > Callout exponent*.

Importing Appearances from SOLIDWORKS Files

You have the option to import appearances from SOLIDWORKS files.

Previously, Composer silently imported all appearances whether you wanted them or not. See *Composer Help: Managing (Default) Document Properties > Advanced Properties > Properties > Input - Import*.

Importing Exploded, Saved, and Named Views from SOLIDWORKS Files

You can import exploded, saved, and named views from SOLIDWORKS files.


Inlaid Text for Linear Arrows

An **Inlaid Text** property displays text inside linear arrows.

See *Composer Help: Editing Actor Properties > Markup Properties*.

Read-Only Mode Enhancement for Animation Library Templates

You can make edits when property values are read-only.

With the **MakeAngleAxisDistPtEditable** parameter for Animation Library XML templates, you can make the angle, axis, and distance properties of animated actors editable in the Animation Library workshop when property values are read-only. See *Composer Help > Creating Animations > Custom Animation XML Example*.
Support of MP4 Format for Animations

You can save videos in FLV, MKV, and MP4 formats as well as AVI.

See Composer Help: Working in Workshops > Video Workshop and Working with the Ribbon > File Menu.

Warning Message Before Breaking External Assembly Links

A warning message appears if you start an operation that will break external assembly links.

The warning message appears in a Composer project (.SmgProj file) or in a fully shattered product structure (.SmgXml file). It prompts you to confirm the operation. See Composer Help: Importing and Opening Files > About Composer File Types > Breaking of External Assembly Links.

SOLIDWORKS Composer Sync

Importing Appearances from SOLIDWORKS Files

You have the option to import appearances from SOLIDWORKS files.


Importing Exploded, Saved, and Named Views from SOLIDWORKS Files

You can import exploded, saved, and named views from SOLIDWORKS files.

Detailing and Drawings

This chapter includes the following topics:

- Custom Scales for Drawing Sheets and Views
- Chain Dimensions
- Alternate Position Views
- Detailing Mode
- Render Pipeline in Drawings
- Hole Callouts
- Annotations
- Cosmetic Threads
- Creating Markups for Drawings
- Design Library
- Dimensions
- Link Child Views to Parent by Default
- Location for Saving a New Drawing
- Performance Improvements in Drawings

Custom Scales for Drawing Sheets and Views

Workflow is improved for setting custom scales for drawing sheets and views.

Setting Custom Scales for Drawing Sheets

The scale list on the status bar includes an option to specify a custom scale for drawing sheets.

To specify custom scales for drawing sheets:

1. In the status bar, click the scale.
2. In the list, click **User Defined**.

3. In the dialog box, enter a scale in the format $x:x$ or $x/x$.
4. Click **OK**.

Setting Custom Scales for Drawing Views

In the Drawing View Property Manager, you can select **Use custom scale** and immediately enter a custom scale.

Previously, after selecting **Use custom scale**, you had to click in the box, scroll up, select **User Defined**, and then enter the scale in another box.

**To set custom scales for drawing views:**

1. In a drawing, select an existing view or insert a new view.
2. In the Property Manager, under **Scale**, select **Use custom scale**.
3. In the box, enter a scale in the format $x:x$ or $x/x$.

You can also click and select a predefined scale from the list.
Modifying the List of Available Scales

You can control which scales appear in the list that you access from the status bar and Drawing View PropertyManager. The same list is used for both drawing sheets and drawing views.

The list is defined in a file named drawingscales.txt, which you can edit to add and remove scales. The file contains instructions for editing the list.

The default file location is:

`install_dir\SOLIDWORKS\lang\language`.

**To specify a different location for the file:**
1. Click **Tools > Options > File Locations**.
2. Under **Show folders for**, select **Drawing Scale Standards**.
3. Set the file location and click **OK**.

Chain Dimensions

You can create a chain of associated dimensions measuring from one feature to the next.

You can create chain dimensions in drawings and in sketches in parts and assemblies. Chain dimensions are reference dimensions driven by the geometry. You cannot change their values or use the values to drive the model.

When you create chain dimensions, your first selection defines the starting edge of the chain. Subsequent selections are measured from one selection to the next. You can select items such as edges, vertices, circles, and midpoints.

Creating Chain Dimensions

**To create chain dimensions:**

1. Click **Chain Dimension** (Dimension/Relations toolbar) or **Tools > Dimensions > Chain**.
2. Select the starting edge.
3. Click features to add to the chain set.

Adding Dimensions to Existing Chain Dimensions

To manually add an overall dimension to a set of chain dimensions:
- Right-click any dimension in the set and click Add Overall.

To add more dimensions to a set of chain dimensions:
- Right-click any dimension in the set, click Add to Chain, and then select other items to add to the chain.

You can delete a dimension from a set of chain dimensions. The surrounding dimensions automatically adjust to prevent gaps in the chain.

To automate some common chain dimension actions:
1. Click Tools > Options > Document Properties > Dimensions > Linear.
2. Under Chain Dimension, select options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add overall dimension to chain dimensions</td>
<td>Automatically adds an overall dimension when you create a set of chain dimensions.</td>
</tr>
<tr>
<td>Add last reference dimension</td>
<td>(Available if Add overall dimension to chain dimensions is selected.)</td>
</tr>
<tr>
<td></td>
<td>Automatically adds a final reference dimension when you create a set of chain dimensions.</td>
</tr>
</tbody>
</table>

Converting Between Baseline and Chain Dimensions

You can convert baseline dimensions to chain dimensions and vice versa.

To convert a chain dimension to a baseline dimension:
- Right-click any dimension in the set and click Convert to Base.
  The dimensions change to a baseline:
To convert a baseline dimension to a chain dimension:

- Right-click any dimension in the set and click **Convert to Chain**.

  The dimensions change to a chain:

Alternate Position Views

In part drawings, you can use **Alternate Position View** to overlay two configurations of a part in a single view. In assembly and part drawings, you can use **Edit Feature** to open a PropertyManager and define changes to the view.

Creating Alternate Position Views - Parts

In part drawings, you can use **Alternate Position View** to overlay two configurations of a part in a single view. The two configurations must already exist in the part model before you create the alternate position view.

This is useful for showing one part that you make from another. For example, you might purchase standard junction boxes that have mounting tabs, and then machine the tabs off. You can create a drawing view of the as-machined configuration, and then add an alternate position view to show the as-purchased configuration.

In this example, the part model has two configurations:
- Buy_01 for the as-purchased junction box (with tabs).
- Mod_99 for the as-machined junction box (without tabs).

**To create alternate position views for parts:**

1. Create a view of the as-machined junction box (Mod_99).

![Diagram](image.png)

2. Select the view and click **Alternate Position View** (Drawing toolbar).
3. In the PropertyManager, for **Existing configuration**, select the configuration for the as-purchased junction box (Buy_01).
4. Click ✅.
   Phantom lines show the tabs of the Buy_01 configuration.

![Diagram](image.png)

**Editing Alternate Position Views**

In part drawings, you can replace the alternate position configuration with an existing configuration from the part model.

In assembly drawings, you can replace an alternate position configuration with an existing configuration from the assembly model, or you can define a new configuration on the fly.

In assembly and part drawings, you can use **Edit Feature** to open a PropertyManager and make changes to the view.

In this example, the alternate position view shows the two tabs from the as-purchased configuration (Buy_01).

![Diagram](image.png)

You replace it with an as-purchased configuration that has different tab geometry (Buy_02).
To edit alternate position views for parts:
1. In the FeatureManager® design tree:
   a) Expand Sheet, and then expand the Drawing View that contains the alternate position view.
   b) Right-click Alternate Position and click Edit Feature.
2. In the PropertyManager, for Existing configuration, select a different configuration (Buy_02) to use as the alternate view.
3. Click .
   Phantom lines show the tabs of the Buy_02 configuration.

Detailing Mode

Video: What's New in SOLIDWORKS 2020 - Detailing Mode

You can use Detailing mode to open large drawings quickly. The model data is not loaded, but you can add and edit annotations within the drawing.
Detailing mode is useful if you need to make minor edits to drawings of large assemblies or drawings with many sheets, configurations, or resource-intensive views.

Creating Dimensions and Annotations

In Detailing mode, you create dimensions and annotations just as you would in Resolved mode.

Exception: You cannot create dimensions or annotations that require model information, such as hole callouts, cosmetic threads, or links to model properties.
If a drawing is open in Detailing mode and you change and save an associated part or assembly, then an out-of-date message appears.
The **Resolve Drawing** tool always appears in the CommandManager so you can resolve the drawing at any time.

**Saving**

You can save your changes to the existing drawing file without exiting Detailing mode. Saving in Detailing mode does not require a special save format.

- If you save the drawing in Detailing mode, and then close it and reopen it, you can continue to edit the items you created in Detailing mode.
- If you save the drawing in Resolved mode, the dimensions and annotations you created in Detailing mode are resolved and saved. Then if you close the drawing and reopen it in Detailing mode, the ability to edit the resolved dimensions and annotations is limited. You can only change their position or delete them.

**Capabilities Available in Detailing Mode**

You can create the following dimensions and annotations:

- Notes, including notes with leaders
- Linear and circular note patterns
- Surface finish symbols
- Revision symbols
- Revision clouds
- Locations labels
- Balloons
- Magnetic lines
- Weld callouts
- Geometric tolerances
- Datum feature symbols
- Datum target symbols
- Radial and linear dimensions, including use of the **Smart Dimension** tool
- Ordinate dimensions
- Angular running dimensions

In addition, you can do the following:

- Change the position, rotation, and labels of drawing views.
- Copy or cut drawing views and paste them onto the same or other sheets within the same drawing.
- Within annotations, add links to the displayed values of dimensions and other linkable annotations.
- Insert sketch blocks.
- Add general and revision tables. You cannot add other table types.
- Select displayed geometry, such as model edges and sketches. Use **Select Other** to find other selectable items. You cannot select model faces in any drawing views.
- Save the file as a PDF/DXF file, or print as a PDF.

**Limitations**

- You cannot create new drawing views.
- You cannot create centerlines, center marks, or hatching.
- You cannot use the **Undo** tool.
- Draft quality section views cannot be selected or exported to DXF/DWG.
- Detailing mode is not available for detached drawings.
Opening Drawings in Detailing Mode

You can use the Open tool to open drawings in Detailing mode. In Detailing mode, you can add and edit dimensions and annotations within the drawing, but the model data is not loaded.

To open drawings in Detailing mode:

1. Click Open (Standard toolbar) or File > Open, or press Ctrl+O.
2. In the dialog box, in Files of type, select SOLIDWORKS Drawing (*.drw; *.slddrw).
3. Browse to select a drawing.
4. In the dialog box, for Mode, select Detailing ✂.
5. Click Open.

When a drawing is in Detailing mode:

- ✂ appears on the top node of the FeatureManager design tree.
- [Detailing] is appended to the file name in the top bar of the SOLIDWORKS window.

Render Pipeline in Drawings

Drawings and drawing annotations benefit from the graphics architecture introduced in SOLIDWORKS 2019, which implemented graphics acceleration and image quality scaling across graphics cards.

This architecture provides a more responsive, real-time display especially for large models. It takes advantage of modern OpenGL (4.5) and hardware-accelerated rendering to maintain a high level of detail and frame rate when you pan, zoom, or rotate large models. These performance improvements scale up with the higher-end graphics cards not fully supported in previous versions of the SOLIDWORKS software.

Hole Callouts

Adding Hole Callouts in Section Views

You can apply hole callouts to cross-sectioned holes and slots.

You can apply the callouts in section views, broken-out section views, and detail views. You can apply the callouts to these features:

- Hole Wizard holes and slots
- Advanced Holes
- Holes created with Cut-Revolve
- Holes and slots created with Cut-Extrude
To add hole callouts in section views:

1. Click **Hole Callout** (Annotation toolbar) or **Insert > Annotations > Hole Callout**. The pointer changes to 📇.

2. Select any line segment of the cross-sectioned hole.
   - Click to select a side edge:
   - **Shift** + click to select a top or bottom edge:

3. Click to place the callout.
Applying All Uppercase to Dimensions and Hole Callouts

You can set dimensions and hole callouts to display characters in all uppercase in the graphics area.

You can apply all uppercase to selected dimensions and hole callouts. In any dimension or hole callout PropertyManager, under Dimension Text, select All uppercase.

You can set the default as all uppercase for all new dimensions and hole callouts in a document. In any part, assembly, or drawing, click Tools > Options > Document Properties > Drafting Standard. Under Uppercase, select All uppercase for dimensions and hole callouts.

Annotations

Flag Notes

Flag Note Bank

The Flag Note Bank appears only on drawings that have flag notes.

Sorting Flag Notes

To sort a stack of flag notes, right-click and select Sort Stack. For a stack of balloons that includes flag notes, the software sorts flag notes separately after it sorts the other balloons.

Symbols on Sheet Formats

You can include geometric tolerance and surface finish annotations on sheet formats. The annotations cannot include leaders.

Cosmetic Threads

Adding Callouts for Non-Hole Wizard Holes

You can add cosmetic thread callouts to holes not created with the Hole Wizard.

In a side view of a hole, use the Smart Dimension tool to add the thread callout as defined in the Cosmetic Thread feature in the source part or assembly.

1. Click Smart Dimension (Dimensions/Relations toolbar) or Tools > Dimensions > Smart.
2. Select the two silhouette edges of the cosmetic thread.

3. Click to place the dimension. The hole callout appears.

Adding Callouts for External Threads

In drawings, you can add cosmetic thread callouts to external cosmetic threads. The thread callout is defined in the Cosmetic Thread feature of the source part or assembly. You use the Smart Dimension tool to add the callout in a side view or section view of the external thread.

To add the callout:

1. Click Smart Dimension (Dimensions/Relations toolbar) or Tools > Dimensions > Smart.
2. Select the two silhouette edges of the cosmetic thread.

   The pointer changes to 📊 when it is over a silhouette edge of a cosmetic thread.

3. Click to place the dimension.

   The thread callout attaches to the outer geometry of the cylinder.

Simplifying Callouts

In parts, assemblies, and drawings, you can exclude the thread Type (such as Machine Threads or Straight Pipe Tapped Thread) from callouts for cosmetic threads.

To simplify callouts:

In the Cosmetic Thread PropertyManager, under Thread Callout, clear Show type.
To specify the default for Show type:
Click Tools > Options > Document Properties > Annotations and select or clear Show type in thread callouts.

Creating Markups for Drawings

You can add markups to drawings on touch and nontouch devices.

All markups show under Markups in the FeatureManager® design tree.

These options are available for an active sheet when you right-click Markup in the FeatureManager design tree:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit Markup</td>
<td>Edits the markup</td>
</tr>
<tr>
<td>Orient</td>
<td>Zooms to the markup</td>
</tr>
<tr>
<td>Hide</td>
<td>Hides the markup</td>
</tr>
<tr>
<td>Export Markup</td>
<td>Exports markups as one of the following file types: .pdf, .bmp, .jpg, .png, and .tif.</td>
</tr>
</tbody>
</table>

For more information on markup changes, see Markups on page 20.

To create markups in drawings:

1. On a nontouch device, open a drawing, and click the Markup tab in the CommandManager.
   
   If the Markup tab is not available, right-click in the CommandManager and click Tabs > Markup.
2. Click **Markup** on the Markup tab.

   In the FeatureManager design tree, a new markup shows under **Markups**.

3. Click **Draw** (Markup toolbar) to add markup content using the mouse.

4. Click **Exit Markup** to save the markup.

5. To export the markup, right-click **Markup** and click **Export Markup**.

6. In the dialog box, click **Save**.

---

**Design Library**

When you save a note that contains symbols and linked values to the Design Library, the software stores those symbols and values within the note. When you insert the note from the Design Library into another drawing, the stored symbols and values display correctly. The stored symbols and values are not linked to the original note from the original document.

Previously, the software did not store the symbols and linked values in the Design Library note and they displayed an error when inserted into another drawing.

This functionality is supported for notes added to the Design Library in SOLIDWORKS® 2020 or later. Notes added to the Design Library in earlier releases still show errors.

---

**Dimensions**

**Dimensioning Datum Targets**

In part and assembly models, you can use dimensions to control the position and shape of datum targets.

**Positioning Datum Targets Without Using Sketches**

You can use the **Smart Dimension** tool, without a sketch, to place driving and driven dimensions on datum targets. You can use driving dimensions to control the position of the attachment point of the datum target’s leader.

**Datum Target Shape Dimensions**

You can add dimensions directly to the datum target shape. You can drag to modify the position of these dimensions.

In the Datum Target PropertyManager, select **Show dimensions**.
**Foreshortened Dimensions**

**Arrow Styles**

Two new arrow styles are available for foreshortened dimensions.

Click **Tools > Options > Document Properties > Drafting Standard > Dimensions** > **Linear**. Under **Foreshortened**, the new options are:

<table>
<thead>
<tr>
<th>Arrow Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Straight</strong></td>
<td><img src="image" alt="Straight Arrow" /></td>
</tr>
<tr>
<td><strong>Single arrow</strong></td>
<td><img src="image" alt="Single Arrow" /></td>
</tr>
</tbody>
</table>

**Drafting Standards**

Foreshortened dimensions are available for all drafting standards. Previously, they were only available for the ANSI drafting standard.

**Link Child Views to Parent by Default**

When you create a projected view, the drawing view property **Use named configuration** is set to `<Link to parent>` by default. Previously, the property was set to **Default**.

This behavior applies only to projected views created in SOLIDWORKS 2020 or later.

**Location for Saving a New Drawing**

When you save a new drawing, the default folder location in the Save or Save As dialog box is the folder where the model in the drawing's first view is saved.

You can override this behavior by specifying a default folder in **Tools > Options > File Locations > Show folders for > Default Save Folder**.

**Performance Improvements in Drawings**

When you create a drawing from an open assembly, the creation of the first view may be faster than in previous releases.
This chapter includes the following topics:

- Virtual Reality
- Quality
- Manufacturing Models in the 3DEXPERIENCE Marketplace | Make
- Support for Configuration-Specific $PRPSHEET Properties
- Text Scale in 3D Views
- SOLIDWORKS Drawings Support
- eDrawings Performance

eDrawings® Professional is available in SOLIDWORKS® Professional and SOLIDWORKS Premium.

Virtual Reality

With Virtual Reality (VR), you can explore models at a 1:1 scale.

Using HTC VIVE™ and VIVE Pro™ VR headsets, you can walk around and through your model in VR. You can examine each part in assemblies and take apart assemblies one part at a time.

Computers with Microsoft Windows® 10 1709 and later using Valve SteamVR™ support VR in eDrawings.

Controller Interaction

The controller supports additional functionality when you interact with models.
<table>
<thead>
<tr>
<th>Button</th>
<th>Functionality</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Creates an exploded view of the model from the nondominant hand controller.</td>
</tr>
<tr>
<td>2</td>
<td>Resets the view and model.</td>
</tr>
</tbody>
</table>
| 3      | Scales/rotates the component. When you select the component (button 4) and hold down button 3, the scale or rotation is continuous. Previously you had to click multiple times to scale or rotate.  
  - Places the component.  
  - Changes the scale.  
  - Rotates the component.  
  When the component is not selected, button 3 teleports you to the location that you are pointing to with the dominant hand controller. |
| 4      | Selects the component with a single click. You can focus on manipulating the component with button 3 without holding down button 4 simultaneously. If you click button 4 again, the component returns to its original position. Previously you had to hold down button 4 to keep the component selected. |

**Custom Floor and Sky Environments**

You can add image files to create custom floor and sky environments in VR. Requirements include:

- **Floor.** Must be .png or .jpg files.
- **Sky.** Equirectangular .png or .jpg files. Skies must be equirectangular. Images must have an aspect ratio of 2:1. Cube maps are not supported.
To add image files for custom floors and skies, click **VR Options** (if you have a VR model open) or **Tools > VR Options**. In the dialog box, browse to a folder that includes the image files and click **OK**.

**Environment Pane**

You can change the **Floor Scale** in the Environment pane.

**Image Quality**

Image quality in VR has improved with:

- Full screen anti-aliasing
- Larger draw distances
- Realistic reflections and transparencies on models
Model Display

You can display models with:

- Ambient occlusion
- Dynamic shadows
- Non-RealView appearances

Opening Models

You can open multiple models in VR in eDrawings. Although you can view only one model at a time in the VR headset, you can switch between models on the desktop. eDrawings can have either VR or non-VR documents open, but not both at the same time. To switch between VR and non-VR documents, close all current documents in eDrawings.

Warning Messages

Warning messages help you use VR properly. They appear when:

- A laptop is not plugged into a charger when you click Play to view the model in a VR headset.
- The VR headset is not plugged in.

Quality

When you open a SOLIDWORKS or eDrawings part or assembly in eDrawings:

- 2D annotations, general tables, and BOMs in the Notes folder of the FeatureManager® design tree:
  - Behave the same as in the SOLIDWORKS software, with the same orientation and positioning.
  - Remain parallel to the screen when you rotate or zoom models.
• You can move tables anywhere in the graphics area.
• Cosmetic threads remain visible. (Only for SOLIDWORKS part/assembly files when you set Graphics boost to Fastest speed.)

Improvements in 2D notes include:

• Ability to zoom and turn notes on/off
• BOM display. Corrected background paper alignment, sizing, and highlighting plane.
• Color
• Geometric tolerance symbols. Corrected position, rotation, box lines, and specific angles for general tolerances.
• Surface finish symbols. Corrected symbol lines, text position, angle, and display.
• Text. Corrected mirrored notes, italics, angle, font, and note positioning.

Improvements in Unassigned Items and annotations:

• BOMs. Rotation with model and corrected background paper size.
• Notes. Corrected angle and positioning, notes move with model, zooming, and ability to turn notes on/off.

Improvements to general tables:

• Table lines and text are synced.
• Text is properly aligned.
• Tables move when you rotate models.
• Ability to show/hide tables.
• Background paper is properly sized.

These improvements apply to .SLDPRTR, .SLDASM, .EPRT, and .EASM files.

Manufacturing Models in the 3DEXPERIENCE Marketplace|Make

You can upload .stl files from eDrawings to the 3DEXPERIENCE Marketplace|Make for manufacturing. This helps you find vendors to provide you manufacturing quotes.

To manufacture models in 3DEXPERIENCE Marketplace|Make:
1. In eDrawings, open an .stl file.
2. Click Upload model for manufacturing to Marketplace.
3. Click OK to accept the warning that the document will be uploaded to the DS server.
4. In the 3DEXPERIENCE Marketplace|Make dialog box, click Get a quote and follow the instructions.

Support for Configuration-Specific $PRPSHEET Properties

When you change a configuration-specific property in a source file (.SLDPRT or .SLDASM), the $PRPSHEET property in the linked drawing displays the updated value. You do not need to open and save the drawing in the SOLIDWORKS software.
This improvement applies to the following:

- SOLIDWORKS Quick View
- eDrawings Desktop including the integration in SOLIDWORKS PDM Desktop client
- eDrawings Web Viewer embedded in SOLIDWORKS PDM Web2 client

Text Scale in 3D Views

When you publish a SOLIDWORKS model with 3D views to eDrawings, text remains at the same scale.

In SOLIDWORKS, clear **Always display text as the same size** in the Annotation Properties dialog box and set the **Text scale** for the 3D views. All 3D views in the eDrawings file retain the same text scale as in the SOLIDWORKS file.

This applies to .eprt and .easm files.

SOLIDWORKS Drawings Support

When you open SOLIDWORKS drawings from hyperlinks (even if the links have spaces in the path or file name), the drawings open properly in eDrawings.

eDrawings Performance

Performance is improved when you hover over and select entities using the **Measure** and **Markup Dimensions** tools.
This chapter includes the following topics:

- Leader Lines
- Minimum Bend Radius and Bend Factor
- Project Viewer
- Reimport Electrical Data for Wires, Cables, and Harnesses
- Report Enhancements for Rows and Columns
- User Rights Manager

SOLIDWORKS® Electrical is a separately purchased product.

### Leader Lines

You can create leader lines with blocks and notes in 2D panel layouts and harness drawings.

To create a leader line, on the Draw tab, under **Annotation**, click **Block leader** or **Text leader**.

#### Annotation

<table>
<thead>
<tr>
<th>Icon</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📝</td>
<td>Text leader</td>
<td>Opens the <strong>Text leader</strong> section under the Command panel.</td>
</tr>
<tr>
<td>📊</td>
<td>Block leader</td>
<td>Opens the <strong>Block leader</strong> section under the Command panel.</td>
</tr>
<tr>
<td>📊</td>
<td>Leader styles</td>
<td>Sets the leader style.</td>
</tr>
</tbody>
</table>
Text Leaders

To create text leaders:

- On the Draw tab, under Annotation, click Text leader.
- On the Cabinet layout tab, under Annotation, click Text leader.

Text Leader

You can draw leader lines freehand or by defining the coordinates in the Text leader section.

- **X** Closes the section.
- **Message** Prompts you to create a text leader.
- **Enter coordinates** Defines the starting point of the leader line.
- **✓** Validates the input.

Graphical Properties

When you select a text leader in the graphics area, the Properties panel displays the text leader line properties under the General, Overall, Leaders, and Text sections. You can set the following properties:

- **Arrowhead** Specifies the arrowhead type such as closed, dot, and oblique.
- **Justify** Specifies the text alignment.
- **Attachment type** Specifies the text attachment direction as horizontal or vertical.
- **Horizontal landing** Shows the horizontal landing line of the leader.
**Grips**

When you select a leader, four grips appear at the following positions:

<table>
<thead>
<tr>
<th>Callout</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Arrowhead</td>
</tr>
<tr>
<td>2</td>
<td>Start point of the landing line</td>
</tr>
<tr>
<td>3</td>
<td>End point of the landing line</td>
</tr>
<tr>
<td>4</td>
<td>Text position</td>
</tr>
</tbody>
</table>

**Block Leaders**

**To create block leaders:**

- On the Draw tab, under **Annotation**, click **Block leader**.
- On the Cabinet layout tab, under **Annotation**, click **Block leader**.

**Block Leader**

<table>
<thead>
<tr>
<th>X</th>
<th>Closes the section.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Message</td>
<td>Prompts you to create a block leader.</td>
</tr>
<tr>
<td>Enter coordinates</td>
<td>Defines the starting point of the leader line.</td>
</tr>
<tr>
<td>✔</td>
<td>Validates the input.</td>
</tr>
</tbody>
</table>

**Graphical Properties**

When you select a block leader in the graphics area, the Properties panel displays the block leader properties under the **General, Overall, Leaders**, and **Block** sections. You can set the following properties:

| Block Source | Sets the block source such as slot, circle, and box. |
**Horizontal landing**

Shows the horizontal landing line of the leader.

**With horizontal landing**

**Without horizontal landing**

---

**Grips**

When you select a leader, four grips appear at the following positions:

<table>
<thead>
<tr>
<th>Callout</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Arrowhead</td>
</tr>
<tr>
<td>2</td>
<td>Start point of the landing line</td>
</tr>
<tr>
<td>3</td>
<td>End point of the landing line</td>
</tr>
<tr>
<td>4</td>
<td>Text position</td>
</tr>
</tbody>
</table>

**Leader Styles Manager**

You use **Leader styles** to create, delete, edit, and set the current leader.

**To use the Leader Styles:**

- On the Tools tab, under **Drawing styles**, click **Leader styles**.

**Leader Styles Manager**

| New | Creates a new leader style. |
**Minimum Bend Radius and Bend Factor**

You can create a route part if the bend radius of the cable, core, or wire is less than the minimum bend radius.

You can define the minimum bend radius and the bend factor for cables and wires in SOLIDWORKS Electrical Schematics. The **Bend Radius (Diameter x Bend Radius Factor)** defines the minimum bend radius. The **Bend radius (x Diameter)** field is renamed to **Bend Radius Factor**.

In an electrical segment, the software considers the individual minimum bend radius for the cable and core.

To define the bend radius and bend factor:

- For wires, right-click a wire in schematic view, click **Wire style > Properties**, and enter a value for **Bend Radius Factor** and **Bend Radius (Diameter x Bend Radius Factor)**.
- For cables, right-click a cable in schematic view, click **Cable properties**, click the cable name, and enter a value for **Bend Radius Factor** and **Bend Radius (Diameter x Bend Radius Factor)**.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>The Bend Radius Factor</strong> and <strong>Bend Radius (Diameter x Bend Radius Factor)</strong> are interdependent. If you enter the value in one field, the value in the other field updates correspondingly.</td>
<td></td>
</tr>
</tbody>
</table>

---

**Project Viewer**

You can view SOLIDWORKS Electrical projects in the Project Viewer window.

To open Project Viewer, click **Projects manager > Preview**. The software displays the selected SOLIDWORKS Electrical project in read-only format.
<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous</td>
<td>Displays the previous page.</td>
</tr>
<tr>
<td>Next</td>
<td>Displays the next page.</td>
</tr>
<tr>
<td>Properties</td>
<td>Opens the properties dialog box of the selected record.</td>
</tr>
<tr>
<td>Reports</td>
<td>Opens the reports manager window.</td>
</tr>
<tr>
<td>Zoom Extents</td>
<td>Zooms to display the drawing extents.</td>
</tr>
<tr>
<td>Rectangular Zoom</td>
<td>Zooms to display an area specified by the rectangular window.</td>
</tr>
<tr>
<td>Dynamic Zoom</td>
<td>Real-time zoom.</td>
</tr>
<tr>
<td>Real-time Pan</td>
<td>Moves the view when you click and move the mouse.</td>
</tr>
<tr>
<td>Print</td>
<td>Opens the print manage window.</td>
</tr>
<tr>
<td>Export DWG files</td>
<td>Exports the drawings in DWG format.</td>
</tr>
<tr>
<td>Export PDF file</td>
<td>Exports the drawings in PDF format.</td>
</tr>
</tbody>
</table>

**Filters**

You can filter a specific document or component. When you open Documents tab, the software displays the **Document Search** and when you open Components tab, the software displays the **Component Search**.

**Side Panel**

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documents</td>
<td>Lists the project documents.</td>
</tr>
<tr>
<td>Components</td>
<td>Lists the components, which are sorted by location.</td>
</tr>
</tbody>
</table>

**Preview Zone**

Displays the drawings present in the selected Documents or Components tab. Click a drawing to open it in the viewer zone.
Viewer Zone

Displays the selected drawing. The software displays one drawing at a time. The drawings are read-only and you can only use zoom commands.

Reimport Electrical Data for Wires, Cables, and Harnesses

You can remove unused sketch segments from wires, cables, and harnesses.

If you remove a wire or core from electrical routes, cables or harnesses in SOLIDWORKS Electrical Schematics, when you reimport that model, the software removes the wire or core from the model in SOLIDWORKS Electrical 3D.

If you delete a wire style from a route assembly in SOLIDWORKS Electrical Schematics, when you reimport that model, the software deletes that particular route assembly from SOLIDWORKS Electrical 3D.

Routing Parameters

You can set the routing parameters to create electrical harnesses from the Route harnesses PropertyManager.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enhanced large assembly performance</td>
<td>Suppresses all the 3D parts of large assemblies to enhance performance.</td>
</tr>
<tr>
<td>Manual harness</td>
<td>Adds the components to the harness and creates guidelines. Select this to manually finish the harness.</td>
</tr>
<tr>
<td>Generate fan-outs</td>
<td>Creates fan-outs for multipin connectors. This option is enabled when you select Manual harness.</td>
</tr>
</tbody>
</table>
Report Enhancements for Rows and Columns

You can add a column that specifies the row number and controls the row height in reports.

Row Height in Reports

You can set the row height. The software ensures that the row height is not less than the font size.

To control the row height, on the Project tab, click Reports > Properties > Report configuration edition > Styles and set the Row height.

This functionality applies to Header, Content, and Total.

Row Style

<table>
<thead>
<tr>
<th>Automatic</th>
<th>Applies the default value for the row height.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum height</td>
<td>Applies the minimum height entered in Row height. Applicable for multiple lines in a row.</td>
</tr>
<tr>
<td>Fixed height</td>
<td>Applies the fixed height entered in Row height. Applicable for a single line in a row.</td>
</tr>
</tbody>
</table>

Row Height

Enter the row height.

Row Number Column in Reports

You can add a column in a report that specifies the row number of the report entity. You can configure the row number and define a base number in the report template. The row numbers are consecutive and auto assigned in the report manager and report drawings.

The row numbers are still consecutive when you apply the following operations:

- Filter
- Sort
- Merge
- Break
Use the following variables to keep row numbers consecutive after a break:

- **REPORT_ROW_GLOBAL**. Applies consecutive row numbers to the entire row.
- **REPORT_ROW**. Applies consecutive row numbers to each report table that has breaks.

**User Rights Manager**

You can archive custom user profiles, customize the feature grid, control the deletion rights of user profiles, and create a user-defined profile from the **User rights manager**.

**Archive Environment**

You can archive and unarchive the environment, user-defined profiles, and linked features. A notification appears when there is a mismatch between the number of profiles during archiving and unarchiving.

**Feature Grid**

Administrators can export the feature grid list to a `.csv` file.

**User Profile Customization**

Administrators can create new custom profiles and user groups from system profiles, edit custom profiles, and manage user rights in the **Feature grid**.

**User Profile**

<p>| <strong>New Profile</strong> | Opens the Create profile dialog box, where you enter the profile name. This option is enabled when you select an existing system profile. The new profile copies the feature list of the selected profile. |
| <strong>Edit Profile</strong> | Edits the rights of system and custom profiles. |
| <strong>Reset to Default</strong> | Sets the rights of the custom profile to the default rights of the system profile from which it was referenced. |
| <strong>Apply Changes</strong> |  |</p>
<table>
<thead>
<tr>
<th>☀️ Show empty profiles</th>
<th>Displays the profiles without groups and users.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Lets you organize the custom profiles.</td>
</tr>
</tbody>
</table>
SOLIDWORKS Flow Simulation

This chapter includes the following topics:

- **Altitude**
- **Fan Derating**
- **Logical Expressions in Formula Dependency**

SOLIDWORKS® Flow Simulation is a separately purchased product that you can use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

**Altitude**

You can use **Altitude** to set the atmospheric pressure and temperature. **Altitude** makes it easier to conduct what-if or optimization analyses.

**Fan Derating**

Fans are often set to run below their maximum capacity to reduce noise and increase their lifetime, but still achieve their thermal cooling requirements. Fans run at less than maximum capacity by reducing their RPMs, which derates the fan curve. The **Derating** factor simulates this reduction of the fan curve.
Logical Expressions in Formula Dependency

Boundary conditions depend on coordinates, time, and monitor parameters, such as goals. You can define sophisticated dependencies using conditional and Boolean expressions such as IF, AND, OR, XOR, NOT, >, <, and =.

For example, you can set the value of a heat source dependent on two different temperature sensors, defined as temperature goals, so that the dissipated power is downgraded depending on the temperature at the sensors.

$$\Delta P_d = DF^2 \cdot \Delta P$$

$$\dot{m}_d = DF \cdot \dot{m}$$
SOLIDWORKS 3D Interconnect

This chapter includes the following topics:

- Importing DXF and DWG Files
- Importing IFC Files
- Inserting CAD Files into Active SOLIDWORKS Files

Importing DXF and DWG Files

SOLIDWORKS 3D Interconnect supports importing BREP data from DXF or DWG files.

In the DXF/DWG Import dialog box, under Import to a new part as, click 3D curves or model and click Finish. The software imports the BREP data from the DXF or DWG file. You can do the following on the imported body:

- Edit feature
- Update model
- Break link

Importing IFC Files

SOLIDWORKS 3D Interconnect can import IFC files.

Imported IFC files have a hybrid body-mode feature that quickly converts complex faceted shapes to mesh bodies. This includes shapes such as humans, trees, and furniture. IFC files convert simple shapes like walls, roofs, beams, and columns into precise solid and surface bodies that you can directly use for modeling references. This functionality improves performance and reliability for large, imported IFC files and lets you model directly against major structural elements of buildings in the SOLIDWORKS software.
Inserting CAD Files into Active SOLIDWORKS Files

You can insert non-native (*.catpart, *.ipt, *.par, *.prt) or neutral (*.iges, *.igs, *.jt, *.sat, *.step, *.stp) CAD files into an active SOLIDWORKS part or assembly file. You can also drag a non-native or neutral CAD file into an active SOLIDWORKS part or assembly file.

**SOLIDWORKS Part Files**

To insert a non-native or neutral CAD file into an active SOLIDWORKS part, click **Insert > Part**.

When you drag the CAD files into the active SOLIDWORKS part file, a prompt appears: **Are you trying to make a derived part?**

- Click **Yes** to insert the part as a derived part feature.
- Click **No** to open the part in a new window as a new document.

**SOLIDWORKS Assembly Files**

To insert a non-native or neutral CAD file into an active SOLIDWORKS assembly, click **Insert > Component > Existing Part/Assembly**.
This chapter includes the following topics:

- **Process Management Enhancements**
- **Project Management Enhancements**
- **Dashboard Viewer and Plenary Web Client**
- **Task Templates**
- **Integration with Microsoft Outlook**
- **Object Notes**
- **Adding Conditions to a Process Stage**
- **BOM Editing**
- **PDM Options Tab**
- **Editing the Project Task Subject**
- **Export Feature of BOM Compare Tool**
- **Send to Process**
- **Custom Procedures**
- **View Hidden Controls in the Workflow Designer**
- **Inactive Configuration Part Numbering**
- **Main User Interface Controls for Records**
- **Customized Affected Item List**
- **Process Task Assignment Controls**
- **Copy Manual Quantities of BOM**

SOLIDWORKS® Manage is an advanced data management system that extends the global file management and application integrations enabled by SOLIDWORKS PDM Professional.

SOLIDWORKS Manage is the key element in providing Distributed Data Management.
Process Management Enhancements

When you start a process, you can add affected items and the related references. You can add multiple records at once even from different objects such as libraries and Bills Of Material.

You can associate special objects such as risks, project issues, and product requirements to a process. SOLIDWORKS Manage maintains parent and child relationships for processes.

Adding Related Records

You can add related records to the existing affected items, including assembly child records, parent records, and references.

To add related records:
1. Create a new process or edit an existing process.
2. Add one or more affected items.
3. Right-click an affected item and click Add related records.
4. Click BOMs, Where Used, or References icons.
5. Select the check box for each line item.
   
   Use the search and filter features to accelerate the process.

6. Optional: Click Add to add records.
7. Close the dialog box.

   The restriction for adding records from a single object still applies.

Creating a Subprocess

When you send multiple items through a process, you can split the selected items into a connected subprocess.

You can create a subprocess only if you enable it in the process object. The subprocess retains the history of the parent process. You can view all the subprocesses that are part of a parent process. You can keep some items in the parent process and send others to the subprocess.

To create a subprocess:
1. Select items in a process.
2. Right-click and click Create sub-process.

   A new process is created that includes the affected items.
3. Optional: To view affected items that are split into a subprocess, select Show sub-process.
4. Optional: To view the subprocesses and hierarchy of the processes, click the Sub-process tab.

Project Management Enhancements

Video: What's New in SOLIDWORKS Manage 2020 -
Project Management Enhancements

You can import projects as XML from other tools like Microsoft Project, visualize the life of a project, and plan the capacity of your resources.

Project Gantt Charts

You can use the improved Gantt chart tools and functionality to display and visualize your project data in formats such as PERT charts, Network diagrams, and Load and Schedule charts.

The functionality is also available in the Plenary Web Client.

Capacity and Demand Dashboards

You can automatically calculate availability of your resources and effort requirements for projects.

The dashboard of the Project Planning tool has two role-based user interfaces.

<table>
<thead>
<tr>
<th>Dashboard</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Capacity</td>
<td>Provides an overall view of the available capacity of resources in your team. Calculates capacity based on absences and on personal and public holidays. You can highlight the availability of your resources by color coding capacity levels.</td>
</tr>
<tr>
<td>Demand</td>
<td>Displays the work assigned to each resource. You can view the demand for resources either based on their projects or through their assigned tasks.</td>
</tr>
</tbody>
</table>
Dashboard Viewer and Plenary Web Client

Dashboard Viewer

The Dashboard Viewer lets organizations display a dashboard on a community monitor that updates periodically.

The application:

- Is available in the SOLIDWORKS Manage program group.
- Provides access to configured dashboards only.
- Can display dashboards in full-screen mode.
- Can refresh at regular intervals.
- Always keeps available data up-to-date.
- Requires a login credential.
- Requires at least one Viewer license.

Plenary Web Client

You can use the plenary web client from your internet browser to access the data remotely.

The SOLIDWORKS Installation Manager includes the Plenary Web Client. The enhancements made in the Plenary Web Client facilitate integration with a connected SOLIDWORKS PDM vault.

You can review your tasks and update projects without installing any software. You can check in, check out, and send SOLIDWORKS PDM data to processes that have PDM outputs.

<table>
<thead>
<tr>
<th>UI Elements</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search all pane</td>
<td>Provides preview and advanced search tools and is available in the right pane.</td>
</tr>
<tr>
<td>Projects module</td>
<td>Lets you interact with project records.</td>
</tr>
</tbody>
</table>
Task Templates

You can use task templates to quickly create and assign common tasks with predefined parameters.

Create a task template to redefine **Subject**, **Priority**, **Assign To**, **Time allocated**, and **Notes** of your repeatable activities.

Integration with Microsoft Outlook

The integration of SOLIDWORKS Manage with Microsoft® Outlook and the expanded integration with SOLIDWORKS PDM helps to streamline and access important information.

With the integration, you can:

- Link incoming emails directly to records to provide a complete history and improved visibility.
- Access emails from the **Emails** tab in the Property Card.
- Create records based on a message. For example, an organization can convert a customer request into a process or a case for evaluation.
- Access emails and other information saved in SOLIDWORKS Manage through the **Manage** tab in SOLIDWORKS PDM File Explorer.

Object Notes

The Object Notes feature lets administrators provide users with conceptual information about an object and steps to perform a task. The Object Notes feature is similar to Process Notes.

Highlights:

- Administrators can add different notes for individual field groups.
- Administrators must enable Object Notes before adding the notes.
- After administrators add information in Object Notes, it appears in every record within that particular object.
The data of notes is available in rich text format. Administrators can copy and paste notes from other applications such as Microsoft® Word.

Object Notes are not available for Process and Project objects.

Adding Object Notes

Administrators can add notes from the Administration tool.

**To add Object Notes:**
1. In the Administration tool, edit an object.
2. To add notes to the SOLIDWORKS PDM objects, go to the Fields wizard page and click **Object Notes**.
3. To add notes to the Document and Records objects:
   a) On the Options tab, select **Enable Object Notes**.
   b) Click **Save** to enable the object notes.
4. In the Field Group dialog box, click the Object Notes tab.
5. Add notes and click **Save**.

Viewing Object Notes

After Administrators add Object Notes, users can view them from a Field Group.

**To view Object Notes:**
1. Open a record for which the Administrator has enabled Object Notes and loaded data into the Field Group.
2. Click at the upper-right corner of the Property Card window to view the notes.

Adding Conditions to a Process Stage

You can add conditions to a process stage. This helps SW Manage to evaluate the field values of affected items and prevents the **Send to Next Stage** action, if any of the defined conditions is true.

Adding conditions in SOLIDWORKS Manage is similar to defining conditions for SOLIDWORKS PDM transitions. You can use the same Conditions node for stage conditions that you use for Decision controls.

**To add conditions to a process stage:**
1. In the Process configuration administration tool, go to the Workflow Properties page.
2. Select a process stage where you want to add a condition.
3. Select the **Condition** node.
4. Click **New**.
5. Create the required condition.
6. Click **Save** and close.
BOM Editing

In the dialog box called Open BOM in new window, enhancements include check out and editing controls.

The controls let you edit the lower-level BOMs faster.

The **Open BOM** icon added to the BOM tab controls lets you edit the BOM of a record without opening the property card.

PDM Options Tab

The PDM Options tab provides options that affect files in a SOLIDWORKS PDM vault.

**To view the PDM Options tab:**

1. In the Process Configuration wizard, on the Workflow Properties page, select the Output node.
2. Click the PDM Options tab.

The tab includes the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Do not increment version of PDM files</td>
<td>Prevents the creation of a new version each time an output updates SOLIDWORKS PDM variables or changes the status in SOLIDWORKS Manage. It is similar to the SOLIDWORKS PDM transition option to <strong>Overwrite Latest Version</strong>.</td>
</tr>
<tr>
<td></td>
<td>• This setting applies to the SOLIDWORKS Manage output only.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Use Overwrite Latest Version</strong> to prevent SOLIDWORKS PDM from creating a new version if:</td>
</tr>
<tr>
<td></td>
<td>• SOLIDWORKS Manage changes the state of the SOLIDWORKS PDM workflow.</td>
</tr>
<tr>
<td></td>
<td>• The SOLIDWORKS PDM transition updates a variable.</td>
</tr>
<tr>
<td></td>
<td>• If you include a large number of affected items in the process, it takes a longer time to complete.</td>
</tr>
<tr>
<td>Permissions: Use permissions from the logged in user</td>
<td>Uses permissions granted to the logged-in user.</td>
</tr>
</tbody>
</table>
## Editing the Project Task Subject

You can edit the subject of multiple project tasks to provide additional information.

You can add project-specific information, such as a project number, to the subject line to help users search and view the tasks related to a project. This information can appear before or after the original text.

**To edit the project task subject:**

1. Open a project record.
2. Optional: Go to the Planning tab and select the Tasks tab.
3. Go to the Tasks tab, if enabled.
4. Select and right-click a task or group of tasks to update.
5. Click **Subject**.
6. In the dialog box, select one or more options.
   The following table describes the options available in the dialog box.

### Option Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Permissions: Use permissions from the following user</strong></td>
<td>Allows a user logged in to the PDM vault to use permissions granted to the user whose credentials are available in the <strong>User Name</strong> and <strong>Password</strong> fields.</td>
</tr>
</tbody>
</table>

If you use permissions granted to another user:

- You have these permissions only until you change the state.
- You do not require transition permission in the SOLIDWORKS PDM workflow.
- Your name appears in the history and in the data card variables.

### Area Description

<table>
<thead>
<tr>
<th>Area</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Add/Remove</strong></td>
<td>Add amends the subject text.</td>
</tr>
<tr>
<td></td>
<td><strong>Remove</strong> removes previously added text.</td>
</tr>
<tr>
<td><strong>Position</strong></td>
<td><strong>Before</strong> places the text before the existing text.</td>
</tr>
<tr>
<td></td>
<td><strong>After</strong> places the text after the existing text.</td>
</tr>
<tr>
<td><strong>Text</strong></td>
<td><strong>Part Number</strong> adds a part number.</td>
</tr>
<tr>
<td></td>
<td><strong>Text</strong> adds text to the subject.</td>
</tr>
</tbody>
</table>

7. Click **Apply**.
Export Feature of BOM Compare Tool

The BOM Compare tool has an Export button that lets you export the comparison information to a Microsoft® Excel file.

The spreadsheet contains:
- Information on all records that are compared.
- A comparison of the two sides of the formatted output.

When you export the comparison information, the Microsoft® Excel file automatically creates the right and left sides of the comparison on a single sheet.

Send to Process

The Send to Process functionality lets you select a process for the selected record.

You can perform the following functions with Send to Process:

- Click to view the Send to Process dialog box.
- Click to view a list of available processes and select a process.

Custom Procedures

An option on the Search tool lets specific users or groups run administrator-defined queries of the database without accessing the database management applications.

Users can define customized procedures, which can include input parameters.

View Hidden Controls in the Workflow Designer

The icon on the Process Wizard page of the Workflow Designer displays hidden controls.

If administrators hide controls on the workflow in the Advanced tab by mistake, they can click the icon to view the controls.
Inactive Configuration Part Numbering

Administrators can assign part numbers to inactive configurations.

Administrators can use the root file’s name with the name of the configuration. This makes it less confusing for users because they can see the configuration name.

Main User Interface Controls for Records

You can use the **Back** and **Forward** buttons to navigate between records.

Customized Affected Item List

You can customize the grid where you view the affected items. You can add fields and apply conditional highlighting.

The enhancement provides similar customization capabilities available in the Bill of Materials (BOM) variants. You can add detailed information for each affected item.

Process Task Assignment Controls

When you create processes with predefined tasks, you can control the ownership and assignment of the tasks.

You can configure the ownership and assignments in the process object to make reassigning easier.

Copy Manual Quantities of BOM

When you edit a BOM using the Copy From dialog box, you can copy manual quantities by selecting **Copy Manual Quantities**.
This chapter includes the following topics:

- **Annotations Folder**
- **3D PMI Compare**
- **DimXpert**

SOLIDWORKS® MBD is a separately purchased product that you can use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

### Annotations Folder

In assemblies and parts, annotations appear in subfolders under the Annotations folder in the FeatureManager® design tree.

From the folder, you can sort the annotations and highlight them in the graphics area. When you select an annotation in the FeatureManager design tree, it is highlighted in the graphics area.
Sorting by Annotation View

By default, annotations appear in subfolders that correspond to the view they belong to, such as **Unassigned**, **Front**, **Right**, and **Top**.

Sorting by Annotation Type

You can sort annotations by type, such as **Smart Dimensions**, **Weld Symbols**, and **Balloons**. Right-click **Annotations** or a view subfolder and select **Sort by Annotation Type**. If you sort the **Annotations** folder, all annotations are sorted into annotation type subfolders.

If you sort a view subfolder, only the annotations within that subfolder are sorted. To return to the original order, right-click the same folder and clear **Sort by Annotation Type**.

3D PMI Compare

The **3D PMI Compare** tool performs a more thorough analysis of reference dimensions to identify more similarity scenarios based on geometry. It also checks annotation notes, reference dimensions, and geometric tolerances.

DimXpert

Annotation Name Format

Names of DimXpert annotations follow a new format.

The new format adds `@feature_name(value)` to the previous format.

Examples

<table>
<thead>
<tr>
<th>New Format</th>
<th>Previous Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>DistanceBetween3@Plane6(7.5)</td>
<td>DistanceBetween3</td>
</tr>
</tbody>
</table>
Pipe Threads and Compound Holes

You can create DimXpert hole callouts for pipe threads and many types of compound holes.

The DimXpert hole callout file has new elements to support new hole types. See system_dir:\Program Files\SOLIDWORKS Corp\SOLIDWORKS\lang\language\txcalloutformat.txt.
16

Model Display

This chapter includes the following topics:

- **Body Compare**
- **Comparing Bodies**
- **Body Compare PropertyManager**

### Body Compare

You can use **Body Compare** to compare two groups of bodies that are colocated in the same part or assembly. For example, you can compare a CAD model against a scan file, mesh file, or another CAD model.

For models that you reverse engineer, use **Body Compare** to compare these models to the original scan to find differences. For manufactured parts, you can scan the part and compare the scan to the source CAD model.

The deviations display on the source body to indicate where the two bodies do not match. When creating a body, select **Unmatched color** in the Body Compare PropertyManager to show where the source and the compare bodies do not match.

### Comparing Bodies

**To compare bodies:**

1. Open `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\model_display\Gear.SLDPRT`.

2. In the FeatureManager design tree, expand the **Solid Bodies** folder.
   
   If you do not see the folder, take the following steps:
   
   - Click **Tools > Options > System Options > FeatureManager**.
   - Under **Hide/show tree items**, select **Show** for **Solid Bodies** and click **OK**.
3. Compare the edges of the gear teeth for **Gear1** and **Gear2**.
   a) After viewing the filleted edges of **Gear1**, right-click **Gear1** and click **Hide**.
   b) Right-click **Gear2** and click **Show** to view the nonfilleted edges.

   ![Gear1: Filleted Edges vs Gear2: Nonfilleted Edges](image)

4. Click **View > Display > Body Compare**.

5. In the Property Manager, set the following options:
   a) For **Source Bodies**, select **Gear1**
   b) For **Compare Bodies**, select **Gear2**
   c) Move the **Legend Threshold** slider so the top and bottom numbers in the legend are approximately 1.00mm.

   In the graphics area, the red and yellow colors indicate where **Gear1** and **Gear2** do not match.

6. Click 

7. To clear the **Compare Body Legend**, in the graphics area, right-click the legend and click **Body Compare**.

   To open the Body Compare Property Manager, right-click the legend and click **Body Compare Properties**.
Body Compare PropertyManager

To open the Body Compare PropertyManager:

Click View > Display > Body Compare 📃. You can also select Body Compare from the Evaluate and Mesh Modeling tabs in the CommandManager.

Body Compare is not available if the part is a single body or if the assembly contains only one body component.

Specify options to compare bodies:

Bodies to Compare

<table>
<thead>
<tr>
<th>Dynamic Help</th>
<th>Displays detailed help when you hover over the controls.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Source Bodies</td>
<td>Specifies the source bodies from a scan, a mesh file, or a CAD model. Bodies can be any type: classic BREP bodies, mesh BREP bodies, or graphics bodies. Classic BREP and mesh BREP can be solid or surface bodies. Specify the display of the source bodies:</td>
</tr>
<tr>
<td>Current View</td>
<td></td>
</tr>
<tr>
<td>Hidden Display</td>
<td></td>
</tr>
<tr>
<td>Transparent Display</td>
<td></td>
</tr>
<tr>
<td>Wireframe Display</td>
<td></td>
</tr>
</tbody>
</table>

Compare Bodies | Specifies the CAD model bodies to compare. Bodies can be any type: classic BREP bodies, mesh BREP bodies, or graphics bodies. Classic BREP and mesh BREP can be solid or surface bodies. |

Color Settings

| Legend Threshold | Specifies the absolute value of deviation allowed by the scale. Move the slider to change the distances. |
| Show Legend on Screen | Displays the legend after closing the Body Compare PropertyManager. |
**Accuracy** Improves the accuracy of the body compare.

Higher accuracy might impact performance.

This slider is disabled when the compare bodies are graphics mesh bodies.

**Unmatched color** Identifies areas on the compare bodies that do not match the source bodies. For example, you compare bodies where the compare body is not a complete reproduction of the source body. The unmatched color appears in areas where there is no corresponding geometry on the source bodies. Either the geometry is missing or is too far away.

Click **Edit Color** to select a color.

After you create a body compare analysis, the analysis remains on display in the graphics area. To close the analysis, right-click in the graphics area and click **Body Compare**. To modify the analysis options, right-click in the graphics area and click **Body Compare Properties**.
Parts and Features

This chapter includes the following topics:

- **Graphics Mesh and Mesh BREP Bodies**
- **Holes**
- **Repairing Missing References for Fillets and Chamfers**
- **Surfaces**

**Graphics Mesh and Mesh BREP Bodies**

**Adding Coordinate Axes, Reference Axes, and Reference Planes**

You can add coordinate axes, references axes, and reference planes to a graphics mesh body or a mesh BREP body by selecting facets, fins, or vertices. You use facets as planar references, facet fins as linear edge references, and facet vertices as point references.

Coordinate axes, reference axes, and reference planes are useful when you create a model based on a graphics mesh body or a mesh BREP body and you want to add geometry. This functionality is available for parts and assemblies.

Before adding coordinate axes, reference axes, and reference planes, turn on the Selection Filter toolbar to select facets, facet fins (edges), and facet vertices in the graphics area. For **Cylindrical/Conical Faces** in the Reference Axis PropertyManager, use **Paint Select Facet** or **Tangent Select Facet** to select groups of facets.
To add a reference plane between two facets:

1. With a graphics body open, click **Plane** (Reference Geometry toolbar) or **Insert > Reference Geometry > Plane**.

2. Click **Toggle Selection Filter Toolbar** (Standard toolbar) or press **F5**.

3. Click **Filter Mesh Facets** to select only triangular facets.

4. In the graphics area:
   a) Select a facet for the **First Reference** as shown.

   b) Select another facet for the **Second Reference** as shown.

   The **Mid Plane** option is automatically selected for the first and second references in the PropertyManager.

5. Click **✓**.
The **Decimate Mesh** tool reduces the facet count in graphics mesh bodies. A lower facet count makes it easier to modify a graphics mesh body.

You can reduce the facet count for an entire body or a group of facets in the body. To select a group of facets, you can use the **Paint Select Facets** tool or the **Tangent Select Facets** tool.

This tool does not support mesh BREP bodies.

**To decimate a graphics mesh body:**

1. Before you open a graphics mesh file, specify these system options in **Tools > Options > Import:**
   a) For **File Format**, select **STL/OBJ/OFF/PLY/PLY2** and click **Import as Graphics Body**.
   b) For **Unit**, select **Millimeters**.
   c) Click **OK**.
2. Open `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\parts\piggy_bank.STL`.

3. Click **Insert > Mesh > Decimate Mesh**.

4. Hover over the body.
   
   A tooltip displays the total number of facets and vertices in the body.

5. In the graphics area, select the graphics mesh body.
   
   The PropertyManager lists the graphics mesh body in **Selections** and displays the total facet count in the body.
6. In the PropertyManager:
   a) Under **Facet Reduction**, for **Percentage Reduced By** \( \% \), enter 80.

   When you enter a percentage value, the tool automatically calculates the number of facets that the graphics mesh body is reduced to in **Reduced Facet Count** \#. This number is 12140.

   b) Click **Calculate**.

   A progress dialog reports decimation status. When the process is complete, a preview of the decimated body generates. The body does not decimate much.

   ![Decimation Preview]

   a) Click **Reset** to remove the preview and restore the body to its previous state.

   b) For **Maximum Error Tolerance** \( \varepsilon \), enter 25mm.

   This option sets the maximum deviation tolerance between the original and resulting mesh. Increasing this value allows for more notable decimation.

   c) Click **Calculate**.

   d) Click ☑️.
The facets in the graphics mesh body are substantially less dense than the original body.

7. Click **Undo** on the Standard toolbar to restore the graphics mesh body to its previous state.

Keep the model open to continue with the next task where you use **Paint Select Facets** to decimate a group of facets.

**Using Paint Select Facets to Decimate a Facet Group**

You can use the **Paint Select Facets** tool to select a wide or narrow area of facets in the body.

**To use Paint Select Facets to decimate a facet group:**

1. Using the same graphics mesh body, *piggy_bank.STL*, zoom to the left ear of the model.

2. Click **Insert > Mesh > Decimate Mesh**.

3. In the Decimate Mesh Body PropertyManager, under **Selections**, click **Paint Select Facets**.

4. In the Paint Select Facets dialog box, adjust the radius of the selection circle to .60. You can adjust the radius by clicking the **Up** and **Down** arrows.
5. Drag the pointer to select all facets in that ear.

6. Click ✓ to close the Paint Select Facets dialog box.

   The Decimate Mesh Body PropertyManager displays a total facet count for Facet Group <1>.

7. Reduce this facet count by half in the PropertyManager:
   a) For Percentage Reduced By %, enter 50.
   b) For Maximum Distance Deviation \( \bar{d} \), enter 25mm.
      This option sets the maximum deviation tolerance between the original and resulting mesh. Increasing this value allows for more notable decimation.
   c) Click Calculate.
      A progress dialog reports decimation status. When the process is complete, a preview of the decimated body generates.
   d) Click ✓.

Keep the model open to continue with the next task where you use Tangent Select Facets to decimate a group of facets that are tangent to a seed facet.
Using Tangent Select Facets to Decimate a Facet Group

You can use the **Tangent Select Facets** tool to select facets that are tangent from a seed facet.

**To use Tangent Select Facets to decimate a facet group:**

1. Using the same graphics mesh body, `piggy_bank.STL`, zoom to the right ear of the model.

2. Click **Insert > Mesh > Decimate Mesh**.

3. In the graphics area:
   a) Right-click and click **Tangent Select Facets**.
   b) Select one or more facets in an area where you want to reduce the facets in the ear. These facets are the seed facets.
4. In the Tangent Select Facets dialog box:
   a) Leave **Angle Tolerance** at its default value.
      A facet is included in a facet group only if the angle between its normal and the normal of a seed facet is less than or equal to the angle tolerance. You can adjust the **Angle Tolerance** by moving the slider or clicking the **Up** and **Down** arrows.
   b) Click **Adjacency Limit** and enter **10**.
      Only facets within the specified number from a seed facet are included in the facet group. For example, in this case, the tool only selects facets within 10 facets of the seed facet. You can click the **Up** or **Down** arrow to adjust how far to propagate adjacent facets to the seed facet.
   c) Click ✔ to close the Tangent Select Facets dialog box.
      The Decimation PropertyManager displays a total facet count for **Facet Group <1>**.

5. Reduce this facet count by half in the PropertyManager:
   a) For **Percentage Reduced By**, enter **50**.
   b) Set **Maximum Distance Deviation** to **2.5mm**.
      This option sets the maximum deviation tolerance between the original and resulting mesh. Increasing this value allows for more notable decimation.
   c) Click **Calculate**.
      A progress dialog reports decimation status. When the process is complete, a preview of the decimated body generates.
   d) Click ✔.
Expanded Support for Mesh BREP Bodies in Features

The following features now support mesh BREP bodies:

- Shell
- Fillet
- Draft
- Chamfer
- Delete Face
- Fill Face
- Mutual Trim
- Surface Knit
- Delete Hole

The Insert menu includes a submenu for Mesh specific tools:

- Convert to Mesh Body
- Segment Imported Mesh Body
- Surface from Mesh
- 3D Texture
- Decimate Mesh

Holes

Defining Hole Depth up to Tip or up to Shoulder

You can define the end condition of a hole to the depth up to the tip or to the shoulder. The options are available for all Hole Wizard features (including the Hole Wizard Assembly feature) and Advanced Hole types with the following end conditions:

- Blind
- Up to Vertex
• Up to Surface
• Offset from Surface

For legacy holes, the options are only available for holes with drill types such as simple, tapered, counterbore, countersunk, and counter drilled holes.

After creating the hole feature, you can switch between the two options. Hole callouts in drawings display dimensions based on the depth of the end condition.

Previously, the end condition of a hole was calculated only up to the full diameter of the shoulder.

Hole Wizard

Continuing improvements are available in the Hole Wizard.

For example:

• Thread depths are recalculated. Threads cannot be deeper than the hole, regardless of whether Automatically calculate blind hole depth is selected or cleared.
• Show custom sizing does not switch between selected and cleared in unexpected ways.
• Changes to Head Clearance are correctly reflected in the PropertyManager and Toolbox.

Additional improvements have been made in areas such as updating the tolerance of the fit between holes and shafts, and handling the Near side countersink option.

Repairing Missing References for Fillets and Chamfers

You can repair fillet and chamfer features that are missing edges.

When you edit fillet or chamfer features that have errors, all missing references display at the top of the Items to Fillet or Items to Chamfer box in the PropertyManager. You can right-click missing references to zoom to their location, repair individual or all missing references, or clear the list of missing references.
To repair, the software attempts to reattach missing references when the missing reference location in the model contains a valid physical edge, face, or loop. If it only repairs a subset of the missing references, the number of repaired edges display.

**To repair missing references:**

1. Open system_dir: \Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\parts\repair_references.SLDPRT.

2. When prompted to rebuild, click Don’t Rebuild.
3. Close the What’s Wrong dialog box.
4. In the FeatureManager design tree, right-click Fillet 1 and click Edit Feature 📝.
5. In the PropertyManager, right-click in Items to Fillet and click Repair All Missing References.
   
   All missing references are repaired except for **Missing Edge<8>**.

6. Under Items to Fillet, right-click **Missing Edge<8>** and click Clear All Missing References.
7. Click ✔️.
8. Right-click Fillet 2 and click Edit Feature.
9. Under Items to Fillet, right-click **MissingEdge**<1> and click Zoom to Selection.

10. Right-click in Items to Fillet and click Repair All Missing References.
11. Click ✓.

The tool repairs all fillet references at the base of the model.
Surfaces

Creating an Offset Surface Without Failed Faces

The Offset Surface tool identifies faces on a surface it cannot offset, and lets you create an offset surface without them.

When the tool starts to create an offset surface and encounters failure, it lists faces it cannot include in the offset surface. Those faces might fail because of one or more of the following:

- Their offset surface includes an area with a radius of curvature that is less than the offset distance.
- They self-intersect.
- They conflict or interfere with nearby faces.
- The offset surfaces are not connected, for example, because the offset has broken references or is based on faces from multiple parts.

If you click Remove All Failing Faces in the PropertyManager, the tool creates an offset surface with gaps caused by removing the failed faces. You can repair the gaps by manually adjusting the offsets of the failed faces and adding them back individually into the offset surface. An alternative if the tool fails is to reduce the offset distance, and run the tool again.

Previously, the Offset Surface tool failed when it could not create an offset for one or more faces of a surface. The tool did not identify which faces caused the failure, which made the offset surface difficult to complete.
To create an offset surface without failed faces:

1. Open `system_dir\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\parts\tree_gate.SLDPR.T`

2. Click Offset Surface (Surface toolbar) or Insert > Surface > Offset.

3. Select the model by clicking Edit > Select All.

4. In the PropertyManager, for Offset Distance, enter 10mm.

   **Flip Offset Direction** toggles the offset direction of the surface between outward to inward. This example uses the outward direction, which increases the thickness of the model and is the default direction.

5. Click ✔.

   A message displays that it is unable to offset the selected surfaces. When the tool completes the analysis, the PropertyManager lists and highlights the failing faces in Offset Parameters.

6. Click Remove All Failing Faces.

   The PropertyManager removes the failing faces from Offset Parameters and the model updates in the graphics area.
7. Click ✓.

The tool creates a **Surface-Offset** feature with missing faces, as noted in red.

8. In the graphics area, zoom to the missing faces.

You can use other surfacing techniques to repair these gaps and then use the feature to create additional surfaces.

**Specifying the Thicken Direction**

You can thicken a surface by specifying a direction other than normal to a face. This option is available for **Thicken** and **Thicken-Cut** features.

In the Thicken PropertyManager and Thicken Cut PropertyManager, you can specify the following entities as a **Direction** from the graphics area:

- Linear sketch entities
- Sketch points
- Reference planes
- Reference axis
- Linear edges
- Pair of vertices
- Cylindrical faces
- Conical faces
- Points in reference geometry
- Planar faces
To specify the thicken direction:

1. Open system_dir: \Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\parts\thicken_surface.SLDPRT.

2. Click Thicken ‾ (Features toolbar), or Insert > Boss/Base > Thicken.

3. In the PropertyManager:
   a) For Surface to Thicken, select Surface-Trim 2 in the flyout FeatureManager tree.
   b) For Thickness, type 50mm.
   c) Click in Direction of Thicken.
4. In the graphics area, select an entity to use as a direction and click ✓.

Examples of direction of thicken:

- The thicken surface is parallel to the linear sketch entity.

- The thicken surface is parallel to a line drawn between the two sketch points.

- The thicken surface is normal to the reference plane.
The thickened surface is normal to the reference axis.

The thickened surface thickens on both sides of the selected entity.
SOLIDWORKS PCB

This chapter includes the following topics:

- **Duplicate Designators**
- **Integration with SOLIDWORKS PDM**
- **Rigid-Flex Support in SOLIDWORKS PCB**

SOLIDWORKS PCB is a separately purchased product.

**Duplicate Designators**

ECAD-MCAD collaboration supports the use of duplicate pad designators in the footprint library and free pads in the PCB Editor in SOLIDWORKS PCB and Altium Designer.

**Integration with SOLIDWORKS PDM**

The SOLIDWORKS PDM-based design and data management workflow for electronic design uses SOLIDWORKS PDM Professional.

You can:

- Create SOLIDWORKS PCB projects and design files using SOLIDWORKS PDM.
- Design file check-in, check-out, and automated versioning of all electronic files through the SOLIDWORKS PDM File Explorer.
- Create data cards and Where Used items for design files.
- Centralize the storage of electronic design data under the control of the SOLIDWORKS PDM vault.
- Notify the workflow processes at specific milestones.
- Use a formal release process with electronic approvals and sign offs.

**SOLIDWORKS PCB-PDM Connector**

The SOLIDWORKS PCB-PDM Connector integrates SOLIDWORKS PCB and SOLIDWORKS PDM to extend SOLIDWORKS PDM-based design methodology.

The integration lets you:

- Synchronize SOLIDWORKS PCB/PDM variables and parameters.
- Create a SOLIDWORKS PDM-based Bill of Materials.
- Integrate projects and documentation check-in, check-out, and archive.
- Generate virtual data cards and Where Used items for electronics parts.
Rigid-Flex Support in SOLIDWORKS PCB

The **Rigid-Flex** support enables you to design rigid and flex portions of the board. The ECAD-MCAD collaboration enables you to modify the flex entities and create new bends in mechanical designs to suit the enclosure.

You can:
- Define advance layer stack-ups using **Layer Stack Manager**.
- Use board planning mode.
- Insert **Split Lines**.
- Insert **Bending Lines**.
- Create **Layer Stack Legend** tables.
- Remove routing obstacles.
- Enable 3D folded view.
- Enable 3D folded clearance.
- Support ECAD-MCAD Collaboration.
SOLIDWORKS PDM

This chapter includes the following topics:

- Defining Child Reference State Conditions
- Search User Interface
- SOLIDWORKS PDM Performance Improvements
- Web2 Enhancements
- Using AND, OR, and NOT Operators in Search
- Searching in Multiple Variables
- Resizable Dialog Boxes
- Logging Out from Windows Explorer
- Reordering Columns in Search Results
- Scaling the Paper Size in Print Task
- Warning Users When Transitioning Files

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately purchased license for non-SOLIDWORKS users. It offers standard data management capabilities for a small number of users.

SOLIDWORKS PDM Professional is a full-featured data management solution for a small and large number of users, and is available as a separately purchased product.

Defining Child Reference State Conditions

You can define conditions on the state of immediate child references to control the parent file transition.

When you define conditions, you can transition the parent file if:

- Its child references are not selected for transitioning with the parent file and are already in a state that meets the defined condition.
• Its child references are selected for transitioning with the parent file and, after transition, are in a state that meets the defined condition.

• The warning, **Child references do not meet the state conditions**, is not set to blocking.

By default, when this warning is not set to blocking, only those parent files that fulfill the child reference state condition are selected for transition.

To change the state of the parent file, in the Do Transition dialog box, select **Change state**.

The warning is set to blocking by default for new and upgraded users.

This helps avoid situations such as approving an assembly when the referenced parts are not approved or when the assembly uses obsolete parts.

**To define child reference state conditions:**

1. In the Administration tool, click a workflow transition.

2. In the transition's Properties dialog box, in the Conditions tab:
   a) Select **<Click here to add a condition>**.
   b) In the conditions list, select **Child Reference State**.
   c) Expand **Comparison** and select a comparison operator.
   d) Under **Value**, select the state if you selected the **Text Equal To** or **Text Not Equal To** comparison operator.

   For the **Text Compare** operator, enter the value in the *workflow name.state name* format. You can also use wildcard characters to specify the pattern.

   e) Under **Configuration / Path**, enter the wildcard characters to specify the file name or file path pattern.
      Leave **Configuration / Path** blank to apply the condition to all immediate child reference files.

3. Click **OK** and save the workflow.

**Search User Interface**

**Video: What's New in SOLIDWORKS PDM 2020 - Search**

You can perform a search with the quick search box in the SOLIDWORKS PDM File Explorer without setting up a search card.

The quick search box is available in the SOLIDWORKS PDM File Explorer as a part of the SOLIDWORKS PDM menu bar.

With the quick search box, you can:
• Define your search string using sample text.
• Select a string from a list of the previous five searches when you click in the quick search box.
• Use AND, OR, and NOT operators in the search string.
• Click in the quick search box, type, and select any string from the list of previously matching searches.
• Use the following keys:

<table>
<thead>
<tr>
<th>Key Combination</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl + F</td>
<td>Selects the search field</td>
</tr>
<tr>
<td>Arrow keys + Enter</td>
<td>Selects the search string</td>
</tr>
<tr>
<td>Enter</td>
<td>Starts the search</td>
</tr>
<tr>
<td>Esc</td>
<td>Closes the search</td>
</tr>
</tbody>
</table>

Customizable Variables - New Variable List Dialog Box

You can use this dialog box to specify the variables that you can search from the quick search for specific users or groups.

**To display Customizable Variables dialog box:**
1. In the Administration tool, expand **Lists**.
2. Right-click **Quick Search Variable List** and click **New List**.

**Name**

Enter the name of the new variable list.

**Variables**

<table>
<thead>
<tr>
<th>Action</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Adds the administrator-defined variables.</td>
</tr>
<tr>
<td></td>
<td>You can add up to five variables.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected variable.</td>
</tr>
<tr>
<td>Up and down arrows</td>
<td>Moves the listed variables up and down.</td>
</tr>
</tbody>
</table>

**Selected Variable**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable</td>
<td>Displays a selected variable and lets you select a variable to replace the selected variable.</td>
</tr>
<tr>
<td>Name</td>
<td>Displays the name of the selected variable.</td>
</tr>
</tbody>
</table>
**Users**

Lists users and lets you select the users who can select the variables in quick search.

**Groups**

Lists groups and lets you select the groups whose members can select the variables in quick search.

**Using Quick Search**

You can search faster using the quick search. The quick search box is available in the SOLIDWORKS PDM menu bar.

**To use quick search:**

1. In the SOLIDWORKS PDM File Explorer, navigate to the vault or folder to search.
2. Press **Ctrl + F** to access the quick search box.
3. Click the list arrow in the quick search box to specify the search settings.

<table>
<thead>
<tr>
<th>Search in All Folders</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Search For</strong></td>
<td></td>
</tr>
<tr>
<td>✓ File/Folder Name</td>
<td></td>
</tr>
<tr>
<td>✓ Keywords</td>
<td></td>
</tr>
<tr>
<td>✓ Description</td>
<td></td>
</tr>
<tr>
<td>✓ FileName</td>
<td></td>
</tr>
<tr>
<td>✓ Comment</td>
<td></td>
</tr>
<tr>
<td><strong>Search In</strong></td>
<td></td>
</tr>
<tr>
<td>✓ Current Folder</td>
<td></td>
</tr>
<tr>
<td>✓ Current Folder &amp; Subfolders</td>
<td></td>
</tr>
<tr>
<td>✓ All Folders</td>
<td></td>
</tr>
<tr>
<td><strong>Search Variables In</strong></td>
<td></td>
</tr>
<tr>
<td>✓ Latest Version</td>
<td></td>
</tr>
<tr>
<td>✓ All Versions</td>
<td></td>
</tr>
</tbody>
</table>
4. From **Search for**, **Search in**, and **Search variables in**, select the appropriate search categories.

<table>
<thead>
<tr>
<th>Search for</th>
<th>File/Folder name</th>
<th>Searches for the names of files or folders that match the search string.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Administrator-defined</td>
<td>A list of administrator-defined variables. Searches for the value of selected</td>
<td></td>
</tr>
<tr>
<td>variables</td>
<td>variables in the data card fields.</td>
<td></td>
</tr>
<tr>
<td>Search in</td>
<td><strong>Current Folder</strong></td>
<td>Searches for the string in the current folder.</td>
</tr>
<tr>
<td>Current Folder &amp; Subfolders</td>
<td>Searches for the string in the current folder and its subfolders.</td>
<td></td>
</tr>
<tr>
<td>All Folders</td>
<td>Searches for the string in all folders.</td>
<td></td>
</tr>
<tr>
<td>Search variables in</td>
<td><strong>Latest version</strong></td>
<td>Limits the search to the latest version.</td>
</tr>
<tr>
<td>All versions</td>
<td>Searches for the string in all versions.</td>
<td></td>
</tr>
</tbody>
</table>

The **Latest version** and **All versions** options are available based on the following settings in the Administration tool:

- Whether variables are selected in the Quick Search Variable Lists or not.
- Selection of **Always work with latest version of files**.

5. In the quick search box, enter the search strings and press **Enter**.
   The search results appear in the same window.

6. Click **Close Search** to clear the search results and to return the file list.

SOLIDWORKS PDM Performance Improvements

![Video: What's New in SOLIDWORKS PDM 2020 - Performance](image)

You can perform the following actions faster:
• Logging into the vault when you set a large number of files or folders for automatic caching.
• Viewing the System History of a vault that includes a large number of items.
• Opening a file from a folder that includes a large number of files.
• Creating a new file or subfolder in a folder that contains large number of files.

Performance Improvements in Browsing

SOLIDWORKS PDM loads the data in the background, which improves the browsing responsiveness.

Browsing folders that have a large number of files is faster due to:
• Faster database queries for custom columns.
• Background loading and incremental loading of the data.

When you double-click a folder, SOLIDWORKS PDM loads data in this order:
1. All subfolders synchronously. You can browse subfolders while the remaining data loads in the folder.
2. Files with standard columns in the file list.
3. Information in custom columns. You can add more custom columns and maintain the same browsing speed.

When you select a file and switch between the Bill of Materials, Contains, and Where Used tabs, SOLIDWORKS PDM loads the data in the tabs in the background. When you switch to a different file or folder, the background loading stops and loading of the new file or folder starts.

Performance improves significantly for folders with a large number of files or for database servers with high latency.

Performance Improvements in the SOLIDWORKS PDM Add-in

The SOLIDWORKS PDM task pane tree refreshes faster and the commands in the SOLIDWORKS PDM toolbar are correctly enabled in the task pane instantaneously when you select a file.
• Data in the task pane tree loads in the background.
• When you select a file in the task pane tree, calls to the database are eliminated.

In the FeatureManager design tree or in the graphics area, when you right-click a file and select SOLIDWORKS PDM, the menus are correctly enabled.

When you select a file in the graphics area or in the FeatureManager design tree, the file listed in task pane tree is selected and the commands in the SOLIDWORKS PDM toolbar are correctly enabled.
Web2 Enhancements

When you drag a folder to the file list, the Check In File Structure dialog box opens automatically.

In the Details section of the data card, in Comment, you can see version comments.

Bill of Materials Tab in Web2

SOLIDWORKS PDM Web2 lets you see a read-only view of the Bill of Materials.

In the large screen layout, the Bill of Materials tab is available in the file detail view. The supported BOM types are:

- Computed BOMs
- Weldment BOMs
- Weldment cut lists
- SOLIDWORKS BOMs

In the small screen layout, the Bill of Materials tab is available from the ellipsis menu. The tab contains two customizable columns.

Bill of Materials Tab in Web2

The Bill Of Materials tab displays the bill of materials of SOLIDWORKS PDM items or of a SOLIDWORKS assembly, drawing, part, or weldment part.

**To display the Bill of Materials tab:**

In the large screen layout, click the file name and click the Bill Of Materials tab.
Bill of Materials Tab

1. Expand or collapse
   Expands or collapses the indented BOMs.

2. Table view
   BOM
   Displays the selected item for **Indented** or **Top Level Only**.

3. BOM type and options
   Displays the name of the selected BOM at the top with the list of other BOMs and options based on the selected BOM.

<table>
<thead>
<tr>
<th>Selected BOM</th>
<th>List of BOMs</th>
<th>View option and reference version</th>
</tr>
</thead>
<tbody>
<tr>
<td>BOM</td>
<td>Computed BOM, Weldment BOM, Weldment cut list, SOLIDWORKS BOM</td>
<td>Indented, Parts Only, Top Level Only, As Built, Latest</td>
</tr>
<tr>
<td>Weldment BOM or Weldment cut list</td>
<td>Computed BOM, Weldment BOM, Weldment cut list</td>
<td>-</td>
</tr>
<tr>
<td>SOLIDWORKS BOM</td>
<td>Computed BOM, SOLIDWORKS BOM</td>
<td>-</td>
</tr>
</tbody>
</table>

4. Configurations or sheets
   Displays the name of the selected configuration or sheet for Computed BOM, Weldment cut list, and Weldment BOM.
5 Actions

- Change State
- Check Out
- Download
- Delete

Bill of Materials Tab - Small Screen Layout

The Bill of Materials tab contains two columns.

To display the Bill of Materials tab:

In the file detail view, click the ellipsis, and click Bill Of Materials.

<table>
<thead>
<tr>
<th>1</th>
<th>File name header</th>
<th>Displays the file name, selected BOM name, and configuration or sheet name.</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Row details</td>
<td>Displays the values of two columns and comma-separated values of remaining columns.</td>
</tr>
<tr>
<td>3</td>
<td>Settings control</td>
<td>Displays the selected BOM, view option, reference version, and configuration or sheet.</td>
</tr>
<tr>
<td>4</td>
<td>Columns control</td>
<td>Lets you select the left and right columns to display.</td>
</tr>
<tr>
<td>5</td>
<td>Expand/collapse control for row</td>
<td>Expands or collapses the row to display values of other columns.</td>
</tr>
</tbody>
</table>
History Tab

SOLIDWORKS PDM Web2 lets you see a read-only view of the history.

In the large screen layout, the History tab is available in the file detail view. It displays the table view that includes the Event column and customizable columns:

- Version
- User
- Date
- Comment

Click 🌓 and select or clear the columns to display.

In the small screen layout, to access the History tab, in the file detail view, click the ellipsis. The History tab has:

- A list of events in descending order of date and time.
- A separate row for each event.
- Information such as Version, User, Date, and Comment in each row for each event.
- A common control to expand or collapse all rows.
- Individual controls for each row.

List of Files to Download in Web2

SOLIDWORKS PDM Web2 displays the list of files to download.

In the large screen layout, the Download with References dialog box displays the collapsible Settings option and the list of files to download.
The file list displays the files based on these settings:

- **Version**
  - Latest
  - Referenced

- **Preserve relative paths**
- **Include subfolders**
- **Include drawing**
- **Include simulation**

The file list includes customizable columns such as **State**, **Version**, **Size**, and **Path**. Click 🌟 and select or clear the columns to display.
In the small screen layout, the Download with References dialog box displays the list of files to download in one column.

<table>
<thead>
<tr>
<th>Cancel</th>
<th>Download</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings</td>
<td></td>
</tr>
</tbody>
</table>

- **Speaker-Dual.SLDASM**
  - v2 / 2, Approved (8 days)

- **Magnet.SLDPRF**
  - v1 / 1, Under Editing (0 days)

- **Membrane.SLDPRF**
  - v1 / 1, Under Editing (0 days)

- **OuterRing.SLDPRF**
  - v1 / 1, Under Editing (0 days)

- **Second Speaker.SLDPRF**
  - v1 / 1, Under Editing (0 days)

- **Speaker Frame SLDPRF**
  - v1 / 1, Under Editing (0 days)

Click **Settings** to select the appropriate options. Click **Cancel** to access the file list.

**Using AND, OR, and NOT Operators in Search**

SOLIDWORKS PDM supports AND, OR, and NOT operators in input search criteria in edit-box type fields on search cards.

You can use these search operators in any search card, Web2 search, the SOLIDWORKS PDM Search tool, and quick search.

**Rules:**

- Search strings are case-insensitive.
- Operators are case-sensitive and must be capitalized.
- For variable values, the valid operators are: =, !=, <, <=, >, >=, and <>
- Rules for using escape symbol:
<table>
<thead>
<tr>
<th>Search for String with</th>
<th>Input String</th>
</tr>
</thead>
<tbody>
<tr>
<td>Double quotation marks</td>
<td>String with an escape symbol . For example, to search for &quot;speaker&quot;, enter the string as &quot;&quot;speaker&quot;&quot;</td>
</tr>
<tr>
<td>Double quotation marks that are a part of an explicit search</td>
<td>String with an escape symbol . For example, to search for 3&quot; pipe, enter the string as &quot;3&quot; pipe&quot;. The use of the escape symbol \ is optional in cases where you use a double quotation mark &quot; as an inch constant. For example, to search for 3&quot;, you may enter the string as 3&quot;.</td>
</tr>
</tbody>
</table>
If a string contains more than one word, you can use " " to search for the exact string. For example, to search for pipe tools, enter "pipe tools".

When you upgrade to SOLIDWORKS PDM 2020, the previously saved searches are upgraded to follow the new search rules while maintaining the previous behavior and search results.

**AND (&) Operator**

Searches for results that include both the term before and the term after the operator.

<table>
<thead>
<tr>
<th>Search String Examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>term1 AND term2</td>
<td>Returns the match that includes term1 and term2. Terms may appear in any order in the results.</td>
</tr>
<tr>
<td>TERM1 &amp; TERM2</td>
<td>Examples of valid search results:</td>
</tr>
<tr>
<td>AND: term1 term2</td>
<td>• term1 term2</td>
</tr>
<tr>
<td>&amp;: term1 term2</td>
<td>• term2 term1</td>
</tr>
<tr>
<td>(* term1 term2 *) &amp;</td>
<td>• term3 term1 term2</td>
</tr>
<tr>
<td>OR (term1 term2)</td>
<td><strong>AND is the implicit operator for the SPACE character.</strong></td>
</tr>
<tr>
<td>((*) term1 term2)</td>
<td>Returns the match that is enclosed in the parentheses and that contains term1 and term2.</td>
</tr>
<tr>
<td>&quot;(*) term1 term2&quot;</td>
<td>Examples of valid search results:</td>
</tr>
<tr>
<td>&quot;(* term1 term2 &quot;*)&quot; OR</td>
<td>• (term1 term2)</td>
</tr>
<tr>
<td>&quot;(*) term1 term2&quot; OR</td>
<td>• (term2 term1 term3)</td>
</tr>
<tr>
<td>&quot;(* &quot;term1 term2 &quot;&quot;)&quot;</td>
<td><strong>AND is the implicit operator for the SPACE character.</strong></td>
</tr>
<tr>
<td>or &quot;(&quot; term1 term2 &quot;&quot;)&quot;</td>
<td>Returns the match that is enclosed in the parentheses and that contains the string term1 term2.</td>
</tr>
<tr>
<td>&quot;(*) &quot;term1 term2 &quot;&quot;)&quot;</td>
<td>Examples of valid search results:</td>
</tr>
<tr>
<td>or &quot;(&quot; &quot;term1 term2 &quot;&quot;)&quot;</td>
<td>• (term1 term2)</td>
</tr>
</tbody>
</table>
| "(*) "term1 term2 "")"  | • (term3 term1 term2 term4) Searches for results that include the term before or after the operator or both.
OR (|) Operator

<table>
<thead>
<tr>
<th>Search String Examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>term1 OR term2</td>
<td>Returns the match that includes either or both term1 and term2.</td>
</tr>
<tr>
<td>OR: term1 term2</td>
<td>Examples of valid search results:</td>
</tr>
<tr>
<td></td>
<td>• term1</td>
</tr>
<tr>
<td></td>
<td>• term2</td>
</tr>
<tr>
<td></td>
<td>• term2 term1</td>
</tr>
<tr>
<td>&quot;(<em>) term1 OR term2 &quot;</em>&quot;</td>
<td>Returns the match that is enclosed in the parentheses and that includes either term1 or term2 or both.</td>
</tr>
<tr>
<td>or &quot;(*)&quot; (term1 OR term2)</td>
<td>Examples of valid search results:</td>
</tr>
<tr>
<td></td>
<td>• (term1)</td>
</tr>
<tr>
<td></td>
<td>• (term3 term2)</td>
</tr>
<tr>
<td></td>
<td>• (term2 term1 term4)</td>
</tr>
</tbody>
</table>

NOT (!) Operator

Searches for results that do not include the term after the operator.

<table>
<thead>
<tr>
<th>Search String Examples</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NOT TERM1</td>
<td>Returns values other than term1.</td>
</tr>
<tr>
<td></td>
<td>Examples of valid search results:</td>
</tr>
<tr>
<td></td>
<td>• term2</td>
</tr>
<tr>
<td></td>
<td>• term3 term4</td>
</tr>
<tr>
<td>!=&quot;term1 term2&quot;</td>
<td>Returns values other than string term1 term2.</td>
</tr>
<tr>
<td></td>
<td>Examples of valid search results:</td>
</tr>
<tr>
<td></td>
<td>• term3</td>
</tr>
<tr>
<td></td>
<td>• term2 term1</td>
</tr>
<tr>
<td></td>
<td>Examples of valid search results:</td>
</tr>
<tr>
<td></td>
<td>• 2019-02-12</td>
</tr>
<tr>
<td></td>
<td>• 2017-03-11</td>
</tr>
</tbody>
</table>
Searching in Multiple Variables

You can search for a value in multiple selected variables using the Edit-box control in a search card.

In the File Explorer, when you search for a value, SOLIDWORKS PDM considers OR as the implicit operator, and returns a match if it exists in any variable value.

**To specify a multiple-variable edit-box control on the search card:**

In the Card Editor, click **Edit** (Controls toolbar), and click in the card to place the edit box.

---

**Multi-variable**

Lets you select multiple variables from the existing variables defined in the vault.

When you select the variables, the edit box displays the variables separated by \| in alphanumerical order.
Default Values

Lets you define the variable values.
By default, SOLIDWORKS PDM considers the OR condition for the default values. The values can be the same or unique.

At run time, when you edit default values with Multi-variable selected, the default values in the single variable edit box (for example, in the Cards tab) are not updated automatically.

Creating a Search Card to Search Within Multiple Variables

You can create a search card that lets you search for values in multiple variables when you open it in the File Explorer.

To create a search card to search within multiple variables:
1. Create a search card.
2. Add controls to the card.
3. In the Card Editor, click Edit (Controls toolbar).
4. Click in the card to place the edit box.
5. Select Multi-variable.
6. From the list, select the variables to include.
7. Select the appropriate flags.
8. Click Default Values and select the variables you selected in step 6.
9. Assign values to the variables.
   The default values appear in the card controls.
10. Save the card.

Resizable Dialog Boxes

The following dialog boxes are now resizable:

- Edit Variable
- Serial Number - New Serial Number
- Indexing Settings
- Cold Storage Schema
- Dialog boxes in Data Import/Export node such as XML Variable Alias Sets, Export Rule, and Import Rule
- File Type Properties
- Customizable Columns
- Dialog boxes in Bill of Materials node such as BOM, Item BOM, Weldment BOM, and Weldment Cut List
- Edit Template
- Dialog boxes in Dispatch such as Administrate Actions and Properties
Logging Out from Windows Explorer

You can see the name of the logged in user in the File Explorer and log out from Windows® Explorer.

To see the name of the logged in user, hover over 🔄.

To log out from Windows Explorer:
1. Click 🔄.
2. Click Log Out.

Reordering Columns in Search Results

You can reorder the columns in the search results of the embedded search and the Search tool. SOLIDWORKS PDM saves the changes to the column ordering.

Scaling the Paper Size in Print Task

When configuring the Print task, you can select Scale to fit or Scale. When you select Scale, you can select Allow the user to change the scale to let users change the scale at run time.

Warning Users When Transitioning Files

For transitions that include dynamic notifications, you get a warning if you do not select any user or group to receive a notification.
SOLIDWORKS Plastics

This chapter includes the following topics:

- Coolant Input Boundary Condition
- Create Body from Deformed Shape
- Domains Node
- Enhanced Solid Mesh (Auto) Workflow
- Streamlined Mesh Creation
- Flow, Pack, and Cool Analyses Enhancements
- Geometry-Based Boundary Conditions
- Legacy Plastics Simulation Studies
- Material Library Updates
- Plastics Material Databases in 3D ContentCentral
- Plastics Tutorials
- Study Creation and Management
- Virtual Mold Design

SOLIDWORKS® Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS Plastics Premium are separately purchased products that you can use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Coolant Input Boundary Condition

The **Coolant Input** boundary condition replaces the Cooling System boundary conditions of **Cool Pipe**, **Coolant Flow Field**, and **Coolant Entrance**.

The **Coolant Input** boundary condition is more intuitive and easier to use than the previous boundary conditions. Assign the **Coolant Input** boundary condition directly on geometry entities. This boundary condition supports both solid body and sketch-based cooling channel designs.

Create Body from Deformed Shape

After running a warpage analysis, you can export the deformed shape as a SOLIDWORKS® part body.

**To open the Body from Deformed Shape PropertyManager:**

In the PlasticsManager, under **Results**, right-click **Warp Results**, and click **Create Body from Deformed Shape**.
Save the deformed body as a new configuration or a new part file. Use the Advanced Export to access alternative export formats, such as Surfaces and Tessellated body, to recreate geometry from a deformed shape.

Product designers can use this functionality to evaluate a part’s deformed shape and assembly fit requirements, while mold designers can size the mold accurately.

Designers of plastic optical lenses can use Body from Deformed Shape in their optical simulations to evaluate the effect of manufacturing-induced deformation on the performance of the lens.

Domains Node

The Domains node in the PlasticsManager tree lists the part bodies participating in the analysis and their domain classification.

The domain classification choices available for a study depend on the type of Injection Process and Analysis Procedure defined when creating a new study. For a Shell analysis procedure, the domain choice is limited to Cavity. For a Solid analysis procedure, the domain choices are: Cavity, Runner, Cooling Channel, Mold, and Insert.

The available domain choices depend on the installed SOLIDWORKS Plastics license.

Notes:

- You can select multiple part bodies to assign the same domain type, which is useful for models with a large number of bodies.
- You can access the Runner Design, Cooling Channel, and Virtual Mold Property Managers to create these features.
- You can assign the Order in which the cavities are injected for two-shot overmolding or multishot overmolding designs.
- You can exclude bodies from the analysis.

Before generating the mesh, every part body listed in the Domains node requires a domain assignment. You can exclude bodies that do not participate in the Plastics simulation by selecting Exclude from Analysis.

Enhanced Solid Mesh (Auto) Workflow

The Solid Mesh (Auto) workflow is enhanced to create hybrid meshes for single and multi-material models.

Hybrid meshes, which are composed of a mixture of prism elements at the surface and tetrahedral elements to fill the volume of a part, are best suited for analyses. In previous releases, the Solid Mesh (Auto) algorithm created marching hexahedral meshes.

A good-quality watertight surface mesh is a prerequisite for the successful creation of a hybrid mesh. If the hybrid mesh creation fails, the Solid Mesh (Auto) algorithm reverts to creating a marching hexahedral mesh.
Streamlined Mesh Creation

The Mesh PropertyManager is redesigned to simplify the mesh creation workflow. The number of steps in the mesh creation workflow is reduced. To access the Mesh PropertyManager, right-click Solid Mesh, or Shell Mesh. To create a solid mesh with the automatic mesh process, click OK in the Mesh PropertyManager. Follow a manual mesh creation workflow to specify the mesh type (Tetrahedral Hybrid or Hexahedral), mesh size, and curvature controls.

Flow, Pack, and Cool Analyses Enhancements

Analyses solvers are improved.
- For the Shell and Solid mesh procedures, the Flow and Pack analyses account for multipoint, variable specific heat (C), and thermal conductivity (k) material data. Specific heat (C) and thermal conductivity (k) material properties can vary as a function of temperature. You can now incorporate multi-point data provided by material suppliers into analyses.
- Prediction of pressure decay is more accurate with improved pressure calculations in the pure cooling phase.
- A new turbulence (k-ω) model calculates the flow of coolant in the cooling circuits. Cool simulations are more accurate using the new model.

Geometry-Based Boundary Conditions

You can assign more boundary conditions directly on geometric entities than you previously could.

The boundary conditions that you can apply on geometric entities are the following:
- Injection Location
- Control Valves
- Mold Wall Temperature
- Clamp Force
- Symmetry Face
- Insert Properties (previously, Insert Boundary)
- Air Vents
- Exclude from Warp (previously, Runner Element)
- **Filled Hot Runner**
- **Coolant Input**

Although the majority of the boundary conditions are geometry-based, the following boundary conditions remain mesh-based:

- **Warp Boundary**
- **Flow Injection Factor**
- **Modify Local Thickness**

The mesh-based boundary conditions are available after generating a mesh. To access the mesh-based boundary conditions, right-click **Mesh**.

### Legacy Plastics Simulation Studies

Legacy studies created in SOLIDWORKS Plastics 2019 and earlier are read-only in the 2020 release due to an architectural redesign.

You can open legacy studies in SOLIDWORKS Plastics 2020, but you can only edit post-processing features such as results export and report creation.

### Material Library Updates

The SOLIDWORKS Plastics material library features new polymer grades provided by material suppliers.

Sixteen polymer grades are added from the Chevron Phillips Chemical and thirteen polymer grades from the RadiciGroup material databases.
<table>
<thead>
<tr>
<th><strong>Chevron Phillips Chemical</strong></th>
<th><strong>RadiciGroup High Performance Polymers</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>HDPE / Marlex 9005</td>
<td>PA / Radistrong A RV500W 333BK</td>
</tr>
<tr>
<td>HDPE / Marlex 9006</td>
<td>PA6 / Radilon S CW300LW 339 E BK</td>
</tr>
<tr>
<td>HDPE / Marlex 9012</td>
<td>PA6 / Radilon S RV300W 333 BK</td>
</tr>
<tr>
<td>HDPE / Marlex 9018</td>
<td>PA6 / Radilon S RV350W 333BK</td>
</tr>
<tr>
<td>HDPE / Marlex 9035</td>
<td>PA610 / Radilon D RV300W 333 BK</td>
</tr>
<tr>
<td>HDPE / Marlex 9708</td>
<td>PA610 / Radilon D HSKC 106NT</td>
</tr>
<tr>
<td>HDPE / Marlex H525</td>
<td>PA610 / Radilon D RV600RKC 306BK</td>
</tr>
<tr>
<td>HDPE / Marlex HHM 4903</td>
<td>PA612 / Radilon DT RV300RKC2 106 NT</td>
</tr>
<tr>
<td>HDPE / Marlex HHM 5502BN</td>
<td>PA66 / Radilon A CF200 316 BK</td>
</tr>
<tr>
<td>HDPE / Marlex HMM 6060UV</td>
<td>PA66 / Radilon A RV300W 333BK</td>
</tr>
<tr>
<td>HDPE / Marlex HMM TR-938</td>
<td>PA66 / Radilon A RV350W 333 BK</td>
</tr>
<tr>
<td>HDPE / Marlex HMM TR-942</td>
<td>PA66 / Radistrong A RV600W 333 BK</td>
</tr>
<tr>
<td>DPE / Marlex HXM 50100</td>
<td>PPS / Raditeck P RV400K 1700NT</td>
</tr>
<tr>
<td>HDPE / Marlex TRB-432</td>
<td></td>
</tr>
<tr>
<td>LDPE / Marlex 1007</td>
<td></td>
</tr>
<tr>
<td>LDPE / Marlex KN226</td>
<td></td>
</tr>
</tbody>
</table>

The following obsolete material grades are removed from the database based on the supplier’s recommendation.
Plastics Material Databases in 3D ContentCentral

SOLIDWORKS partnered with the world’s largest plastics material suppliers to provide access to the most up-to-date and accurate plastics material databases.

To access the plastics material databases in 3D ContentCentral:
2. Click FIND > INJECTION MOLDING MATERIALS.

The complete catalog of plastics materials appears with information about the material supplier, material family, tradename, grade, and a short description (if available).

To download an individual material grade, click Download Plastics Material Data. Unzip the compressed binary file .bin to a local folder.

To add a material file from 3D ContentCentral to the SOLIDWORKS Plastics User-defined database:
1. In the PlasticsManager, under Material, right-click Polymer and click Open Database.
2. In the dialog box, click User-defined Database.
3. Click Import Plastic Material > File.
4. Browse to the location of the unzipped material data file and select it.
The new material is added under the **Plastics Database**. When new material grades become available, the material suppliers upload the data in 3D ContentCentral. New materials uploaded to 3D ContentCentral by material suppliers are included in subsequent service packs or future major releases of SOLIDWORKS Plastics.

**Plastics Tutorials**

Seven tutorials covering a range of SOLIDWORKS Plastics workflows are available. **To access the tutorials:**

From the SOLIDWORKS Plastics CommandManager, click **Settings and Help > Tutorials**.

**Study Creation and Management**

You can create a new Plastics study based on the current SOLIDWORKS configuration. Study management features for editing, deleting, and clearing a study are available.

In the SOLIDWORKS Plastics CommandManager, click **New Study**.

In the Study PropertyManager, type a name for the study, set the appropriate **Injection Process** parameters, and select a **Solid** or **Shell** mesh for the **Analysis Procedure**. The new study is based on the active SOLIDWORKS configuration.

After creating a new study, right-click the top study node in the PlasticsManager tree to access the study management features.

<table>
<thead>
<tr>
<th><strong>Edit Study</strong></th>
<th>Edits the study parameters.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Delete Study</strong></td>
<td>Deletes the study.</td>
</tr>
<tr>
<td><strong>Clear Study</strong></td>
<td>Resets the study to its default state. Deletes all boundary conditions, mesh, materials, process parameters, and results associated with the active configuration.</td>
</tr>
</tbody>
</table>

**Virtual Mold Design**

You can define the position of a virtual mold relative to the cavity with a bounding box or by setting global coordinates.

**To open the Virtual Mold PropertyManager:**

- In the PlasticsManager, right-click **Domains**, and click **Virtual Mold Design**.

**Specification Method**

<p>| <strong>Bounding Box</strong> | Centers the rectangular volume in space representing the mold on the approximate centroid of the part. |</p>
<table>
<thead>
<tr>
<th>Global coordinate</th>
<th>Specifies the location and dimensions of the rectangular volume in space representing the mold using the global coordinate system.</th>
</tr>
</thead>
</table>

**Parameters**

<table>
<thead>
<tr>
<th>+X, -X</th>
<th>Specifies the extents of the X coordinates of the volume in space.</th>
</tr>
</thead>
<tbody>
<tr>
<td>+Y, -Y</td>
<td>Specifies the extents of the Y coordinates of the volume in space.</td>
</tr>
<tr>
<td>+Z, -Z</td>
<td>Specifies the extents of the Z coordinates of the volume in space.</td>
</tr>
</tbody>
</table>

- Links the positive and negative coordinate extents, such that the negative extent varies simultaneously with the positive extent.
- Specifies the positive and negative coordinate extents independently.
Routing

This chapter includes the following topics:

- **3D Route Changes in Flattened Routes**
- **Color for Electrical Coverings**
- **Connector Blocks**
- **Create Multiple Connection Points**
- **Length Leaders for Flattened Routes**
- **Manufactured-Style Flattened Route**
- **Mass and Density of Cables and Wires**
- **Minimum Bend Radius**
- **Pipe Drawings**
- **Reimport Electrical Data**
- **Show/Hide Flatten Route Items**
- **Splices Without Components**
- **Transparent Coverings**

Routing is available in SOLIDWORKS® Premium.

3D Route Changes in Flattened Routes

You can update a 3D route by adding or deleting items such as connectors, clips, branches, and splices. When you flatten the 3D route, the software updates the flattened route with the 3D route changes.

Color for Electrical Coverings

You can set the color for electrical coverings through the Routing Library Manager and view the colors in the Coverings PropertyManager, under **Layer Properties**.

**Covering Library Wizard**

You can set the color for electrical coverings from the **Covering list**.

| **SWColor** | Specifies the color for electrical coverings. Double-click the color to set it. |
Connector Blocks

You can create connector blocks for parts and assembly connectors with the Create Connector Block PropertyManager and the Routing Library Manager.

The End View Creation PropertyManager is now the Create Connector Block PropertyManager. In this PropertyManager you can:

- Preview and select the view for connectors using standard views.
- Provide the pin information for the connector block. The pin information is visible on the flattened drawing view.

**To create connector blocks:**

- For parts and assembly connectors, click **Create Connector Block** (Electrical toolbar) or **Tools > Routing > Electrical > Create Connector Block**.
- For routing assemblies, in the FeatureManager design tree, expand **Components**, right-click any component, and click **Create Connector Block** or in the graphics area, right-click the connector and click **Create Connector Block**.

**Insert Pin Information**

<table>
<thead>
<tr>
<th>Selected Entities</th>
<th>Displays the selected entities.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pin Information</td>
<td>Displays the pin information, which you can edit.</td>
</tr>
<tr>
<td>Pin Text</td>
<td>Contains additional pin information that you enter.</td>
</tr>
</tbody>
</table>

Create Multiple Connection Points

You can create multiple connection points in parts.

Select the following parameters to create multiple connection points in parts:

- A sketch that has sketch points. The number of connection points is equal to the number of sketch points in a sketch.
- Multiple circular edges.
- Multiple circular and cylindrical faces.

Assign Port ID Information

You can assign port ID or pin information to the connection points through the Connection Point PropertyManager.

For the route type as **Electrical**, the software displays the **Assign Pin Information** section. For the route types as **Tube** and **Fabricated Pipe**, the software displays the **Assign Port ID Information** section.
Selected Entities
Displays the entities from the Selections section.

CPoint Name
Displays the connection point name, which you can edit.

Port ID or Pin Number
Displays the port ID or pin number, which you can edit.

To create the connection points for the Selected Entities, select the check box for each row.

View/Edit Connection Point Parameters

You can use this dialog box to view and edit connection point parameters. The software highlights the CPoint or ACPoint in the graphics area and FeatureManager design tree when you select or edit any parameter.

To access this dialog box:
1. Open a part that has connection points or an assembly that has assembly connection points.
2. In the FeatureManager design tree, right-click CPoint and click View/Edit Connection Point Parameters.

CPoint Name
Displays the connection point name.

Pin Number/Port ID
Displays the pin number or port number, which you can edit.

Stub Length
Displays the stub length, which you define when you create connection points. You can edit the stub length.

Reverse Direction
Reverses the direction of the route.

For assembly connection points, you can edit only the Pin Number/Port ID.

Length Leaders for Flattened Routes

You can show length leaders when you flatten routes with the Flatten Route PropertyManager.

To access the PropertyManager in the route assembly, click Tools > Routing > Electrical > Flatten Route.

Flatten Options

Show Length Leaders
Displays length leaders in the flattened route and on flattened drawings.
Manufactured-Style Flattened Route

You can adjust the angle of a line or an arc from the X-axis when you edit the manufactured-style flattened route.

To access the PropertyManager, right-click a manufacture-style flattened route in the FeatureManager design tree and click **Edit Flattened Route**.

**Edit Tools**

| Adjust angle from X-axis | Adjusts the angle of a line or an arc from the X-axis. |

Mass and Density of Cables and Wires

**Video: What's New in SOLIDWORKS Electrical 2020 - Mass Properties**

You can set the mass of cables, cores, and wires in the **Cable Wire Library Wizard** and the density for coverings in the **Covering Library Wizard** using the Routing Library Manager.

The cable wire library and the covering library define the mass properties of an electrical route that has cables, cores, wires, and coverings. The software calculates and applies these properties to the solid bodies based on the values set in the libraries. You can view the mass by using **SOLIDWORKS Mass Properties**.

You can also view the **Mass per Unit Length** and **Density** attributes in the following PropertyManagers. These values are read-only.

- Edit Wires PropertyManager under **Properties**.
- Covering PropertyManager under **Layer Properties**.
- Fixed Length Covering PropertyManager under **Layer Properties**.

Minimum Bend Radius

You can create a route part if the bend radius of the cable, core, or wire is less than the minimum.

Click **Tools > Options > System Options > Routing** and select **Create route part for segments if bend radius is less than the minimum**.
In a route part for segments, the software considers the individual minimum bend radius for the cable and core.

You can view the unit of measure for **Minimum Bend Radius** and **Outer Diameter** in the **Cable Wire Library Wizard** using the Routing Library manager.

When you save the XML file using the Routing Library manager, the XML file and the Routing Library manager use the same unit of measure.

### Pipe Drawings

You can specify the drawing template and the sheet format for pipe drawings with the Pipe Drawing PropertyManager.

To access the PropertyManager, click **Pipe Drawing** (Piping toolbar) or **Tools > Routing > Piping > Pipe Drawing**.

**Drawing Options**

<table>
<thead>
<tr>
<th>Drawing template</th>
<th>Uses the selected template for the pipe drawing.</th>
</tr>
</thead>
</table>

### Reimport Electrical Data

You can remove unused sketch segments and connectors from the route assembly when you update and reimport the From-To Excel or XML file using the Import Electrical Data PropertyManager.

**Update Options**

<table>
<thead>
<tr>
<th>Delete segments with no data</th>
<th>Deletes unused sketch segments.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delete connector</td>
<td>Deletes unused connectors.</td>
</tr>
</tbody>
</table>

### Show/Hide Flatten Route Items

You can create 3D connectors and connector blocks simultaneously when you create flattened route drawings for route assemblies.

When you flatten a route from the Flatten Route PropertyManager, in **Flatten Options**, you can select **Display 3D connectors** or **Use drawing connector blocks**. The software creates 3D connectors and connector blocks for flattened route drawings. You can select one or both types.
Connectors

<table>
<thead>
<tr>
<th><strong>3D Connectors</strong></th>
<th>Visible in the drawing view if you select <strong>Display 3D connectors</strong> when you flatten the route.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Connector Blocks</strong></td>
<td>Visible in the drawing view if you select <strong>Use drawing connector blocks</strong> when you flatten the route.</td>
</tr>
<tr>
<td><strong>Pin Text</strong></td>
<td>Enabled if you provide pin text when you define connector blocks.</td>
</tr>
<tr>
<td><strong>Pin Color</strong></td>
<td>Enabled if you provide a pin color when you define connector blocks.</td>
</tr>
</tbody>
</table>

Annotations

| **Component Reference** | Displays the connector name and reference in the drawing view. When you select **Display 3D connectors**, the connector and component name are highlighted when you click the connector table. When you select **Use drawing connector blocks**, the connector name is highlighted when you click the connector table in the drawing view. |

Accessory Components

- **Splices**
- **Inline Components**

Splices Without Components

You can add splices without components to electrical routes. A spherical image appears on a junction point without a CPoint or an RPoint when you add splices without components.

![Splice Image]

When you add splices to the route, the software adds a **Splices** folder to the FeatureManager design tree.

You can delete splices without components from the FeatureManager design tree or from the graphics area by deleting the splice junction point.
Add Splice PropertyManager

When you pin the Add Splice PropertyManager and select **Without Component** in **Splice Options**, you can assign properties to the splice and add multiple splices with the same properties.

### Splice Options

<table>
<thead>
<tr>
<th>With component</th>
<th>Adds splices with components.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Without Component</td>
<td>Adds splices without components and displays <strong>Additional Properties</strong>. You can create and modify properties.</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>Enter a name for a new property.</td>
</tr>
<tr>
<td><strong>Value</strong></td>
<td>Enter a value or text expression for a new property.</td>
</tr>
<tr>
<td><strong>Create/Edit</strong></td>
<td>Adds the new name and value to the Additional Properties list.</td>
</tr>
</tbody>
</table>

### Transparent Coverings

You can create transparent coverings for wires and cables.

Click **Tools > Options > System Options > Routing** and select **Create transparent coverings**.
Sheet Metal

This chapter includes the following topics:

- Convert to Sheet Metal
- Tab and Slot

Convert to Sheet Metal

With the Convert to Sheet Metal tool:

- There are improved flat pattern results.
- For sheet metal parts created in SOLIDWORKS® 2020 and later, you can:
  - Convert multiple disjoint tabs that share a common bend face.
  - Use relief cuts that:
    - Use improved logic to determine where to include relief cuts.
    - Behave similarly to relief cuts created with the Edge Flange tool.
    - Reflect the selected auto relief, type, and gap values more accurately.

Tab and Slot

When creating a Tab and Slot feature in a sheet metal part, you can set negative values.

In the Tab and Slot PropertyManager, under Slot, click Slot Length Offset or Slot Width Offset to set the values as negative. This does not create a negative offset in cases of a single body tab and slot or if the resulting tab and slot bodies are merged.
This chapter includes the following topics:

- Collapse Simulation Tree Folders
- Distributed Coupling for Pins and Bolts
- Draft and High-Quality Mesh Definition
- Free Body Forces for Nonlinear Studies
- Link Between Results and Model Files
- Repair Corrupt Studies
- Simulation Evaluator
- Simulation Performance Improvements
- Stress Averaging at Mid-Side Nodes
- Thermal Loads for Beams

SOLIDWORKS® Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS Simulation Premium are separately purchased products that you can use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Collapse Simulation Tree Folders

In a simulation study tree, you can collapse all folders and subfolders with a single command.

To collapse all folders and subfolders in a simulation study tree:

- Right-click a simulation folder or subfolder, and click Collapse Tree Items. You can also right-click an empty area next to a simulation folder to access Collapse Tree Items.
Distributed Coupling for Pins and Bolts

The introduction of distributed coupling enhances the formulation of pin and bolt connectors.

Distributed coupling allows the faces attached to pin and bolt connectors to deform, which delivers a more realistic representation of a connector’s behavior. Distributed coupling for pins and bolts is available for linear static studies only.

In the Connectors PropertyManager, under Connection Type, select Distributed.

For new pin and bolt connector definitions, the default Connection Type is Distributed. For legacy connector definitions, Connection Type is Rigid.

When you set Connection Type to Distributed, a distributed coupling formulation connects a reference node (beam element node of a bolt shank) to a group of coupling nodes inside the imprint regions of a bolt's head and nut. Distributing coupling constrains the motion of the coupling nodes to the translation and rotation of the reference node. Nodes located inside the head and nut imprint areas can deform relative to each other.

This constraint is enforced in an average sense in a way that enables control of the transmission of loads through weight factors at the coupling nodes. For example, the constraint distributes a bolt's pre-load such that the sum of the forces at the coupling nodes is equivalent to the total pre-load at the reference node. Uniform weight factors are applied in this case.

The distributed connection produces more realistic stress and displacement fields at a bolt's head and nut contact areas.

A rigid connection produces stress hot spot areas inside the head and nut regions of the connected components, because rigid bars introduce high stiffnesses. A distributed connection eliminates these high stresses.

The image shows two cylindrical components connected by a bolt with a prestress load of 1,000 N. No-penetration contact exists between the two components.
Results of a static analysis using rigid and distributed connection for this bolt.

<table>
<thead>
<tr>
<th>Rigid Bolt Connection</th>
<th>Distributed Bolt Connection</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Rigid Bolt Connection" /></td>
<td><img src="image2" alt="Distributed Bolt Connection" /></td>
</tr>
<tr>
<td>von Mises stress plot with hot spot at the head imprint region.</td>
<td>von Mises stress plot with smoother gradients at the head imprint region.</td>
</tr>
</tbody>
</table>

Yield strength: 6.204e+08

von Mises (N/m^2)
Draft and High-Quality Mesh Definition

An improved mesh formulation for linear static studies allows both draft and high-quality solid elements to coexist in a single mesh definition.

You can select which solid bodies to mesh with high-quality mesh or draft-quality mesh. The simulation runs with a hybrid mesh definition that has draft and high-quality tetrahedral elements. The hybrid mesh is available only for linear static studies with solid bodies.

- **To assign a draft-quality mesh to a solid body:**
  Right-click the body in a Simulation static study, and click **Apply Draft Quality Mesh**. An icon of a blue tetrahedron element with straight lines next to a body indicates a draft-quality mesh assignment.

- **To assign a high-quality mesh to a solid body:**
  Right-click the body, and click **Apply High Quality Mesh**. An icon of a blue tetrahedron element with curved lines next to a body indicates a high-quality mesh assignment.
• To assign a draft or high-quality mesh to all solid bodies in a study:

Right-click the Parts folder, and click Apply Draft Quality Mesh to All, or Apply High Quality Mesh to All.

You can also assign a draft or high-quality mesh quality to selected solid bodies from the Mesh Quality tab of the Mesh PropertyManager.

The image shows an assembly with draft and high-quality mesh assignments.

Results from Linear static studies with hybrid meshes are valid as input for dependent study types such as: Fatigue, Pressure Vessel, Design, and Submodeling studies.

Free Body Forces for Nonlinear Studies

Video: What’s New in SOLIDWORKS Simulation 2020 - Free Body Forces in NL Studies

After running a nonlinear static or nonlinear dynamic study, you can list the free body forces on select geometry entities at each solution step.

In the Nonlinear-Static dialog box, click Compute free body forces.

When the analysis completes, right-click Results, and click List Result Force. Under Options select Free Body Force.
Select geometry entities (face, edge, or vertex) or a body to list the free body forces that act on the selected entities for a defined solution step.

The free body forces can come from contact, external loads, restraints, or connectors. Free body calculations are not available for 2D simplification studies.

Table 1: Listing of Free Body Forces on Selected Faces

| FX  | 0.99 N |
| FY  | 269 N  |
| FZ  | 0.0344 N |
| FRax | 266 N |
| MX  | 1.33 N.m |
| MY  | -0.0462 N.m |
| MZ  | 5.0 N.m |
| MRes | 4.02 N.m |

Link Between Results and Model Files

The algorithm that links the results file (*.cwr) to the model file that generated the results is improved.

You can upload and view result plots from data saved in the most recent *.cwr file, even in cases where the software terminated before completing the analysis of all simulation studies. For example, during a batch analysis of multiple studies, if the program terminates before running the last study, the software validates the links to the completed *.cwr files for post-processing.

It is important to save the model after meshing. The same mesh data exist in both files for the software to establish the link between the results file and the model that generated the results.

The software checks for the results file in this order:
1. The results folder specified on the study's Properties dialog box.
2. The folder of the model file that generated the results.
3. The results folder specified on the Default Options > Results tab.
To re-establish a link between a valid *.cwr file and a model file, and be able to create result plots, start the **Simulation Evaluator**.

**Simulation Evaluator** lists the location of the model file and results folder. If a results file (*cwr) exists, click the link provided to validate the results file and link it to the current study. In the event that the software cannot establish a link between the active model and the results file in the designated results folder, a warning message lists the reasons of failure.

Renaming a model file or a simulation study after saving the results can invalidate the link to the results file. The software cannot reconstruct the link between the new file and the results saved in the original file `<model name-study name.cwr>`.

### Repair Corrupt Studies

The software identifies simulation studies with corrupt data, and issues a warning to delete the corrupted studies before saving the model.

When the software detects a simulation study with corrupt data, it flags the study tab with an error icon. When you save a model that has corrupt studies, the software issues a warning to delete the corrupt studies before proceeding.

**Simulation Evaluator**

Simulation Evaluator checks a study's setup to determine if the setup is optimal for a successful simulation.

**To run the Simulation Evaluator, do one of the following:**

- In the Simulation CommandManager, click **Simulation Evaluator**.
- In a Simulation study tree, right-click the top study icon, and click **Simulation Evaluator**.

**Simulation Evaluator** checks conditions related to the results folder, storage capacity of the results drive, materials used in the simulation, and the mesh volume. If conditions in the study prevent a successful simulation run, the Simulation Evaluator dialog box provides information for corrective actions.

In the Simulation Evaluator dialog box, click **Save** to save the content of the dialog box in a `.txt` document.
Simulation Performance Improvements

Performance improvements are implemented for linear static studies with multiple load cases and studies with contacts set to incompatible bonding.

**Linear Static Studies with Multiple Load Cases**

You see performance benefits while solving a simulation for linear static studies with multiple load cases defined with remote loads. The force and moment components of remote loads support the optimized solver performance. Translation, rotation, and mass components of remote loads remain unchanged for all load cases.

Performance is not improved when no-penetration contact or virtual wall contact are present in any load case.

The Intel Direct Sparse solver performs the global stiffness matrix factorization (which consumes the majority of the total solution time) only once, because the stiffness matrix remains the same for each load case.

The optimized reconfiguration of the Intel Direct Sparse solver was introduced in SOLIDWORKS Simulation 2019, and it was realized for pressure, force, and torque load types.

**Incompatible Bonding**

The algorithm of the surface-to-surface incompatible bonding is improved. The solver calculates correctly the zero-stress state and zero frequencies for rigid body modes.

The calculation of stresses at bonded interfaces with unmatched (incompatible) meshes is also improved.

The default option for bonded component contact is now set to Incompatible mesh. You can change the mesh setting for the Component contact (including the Global Contact option) to Compatible mesh or Incompatible mesh for a bonded contact type from Simulation Options > Default Options > Contact.

**Stress Averaging at Mid-Side Nodes**

The improved stress averaging algorithm applies to linear dynamic studies.

Before you run a linear dynamic study, in the Results Options PropertyManager, click Average stresses at mid-nodes (high-quality solid mesh only).

For a high-quality solid element, the stresses at the mid-side nodes are calculated by averaging the stress values at the adjacent corner nodes. This stress averaging method improves the calculation of stresses at mid-side notes for tetrahedral elements with high aspect ratios.

Example:
Thermal Loads for Beams

You can apply thermal loads on beam joints and beam bodies. After running thermal analysis on a model with beams, you can import the temperatures into a Linear Static, Nonlinear Static, Frequency, Buckling, or Nonlinear Dynamic study to perform stress analysis.

The table lists the type of thermal loads you can apply on beam and truss elements. Apply concentrated thermal loads on beam and truss joints and distributed thermal loads along the length of beam and truss bodies.

<table>
<thead>
<tr>
<th>Thermal Loads</th>
<th>Beam or Truss</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Joint</td>
<td>Body</td>
</tr>
<tr>
<td>Temperature</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Convection</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Heat Flux</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Heat Power</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Radiation to Ambient only</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>

Only heat flux supports non-uniform distribution of thermal load.

For example, to apply temperature to a joint or beam body, in the Temperature PropertyManager click Joints or Beams. In the graphics area, select the joints or beam bodies to apply the temperature loads.
After running a thermal study, you can view thermal plot results on beam models. The temperature result plot of a truss is shown.

To perform stress analysis based on temperatures from a thermal study:
1. Create a static study.
2. Open the static study Properties dialog box.

The resultant displacement plot of a truss model with temperature loads imported into a static study is shown.
Sketching

This chapter includes the following topics:

- Applying Torsion Continuity Relations
- Baseline and Chain Dimensions in Sketches
- Importing 2D DXF or DWG Files as Reference Sketches
- Power Modify Tool
- Silhouette Entities

Applying Torsion Continuity Relations

You can apply torsion continuity relations between splines and any other sketch entity in 2D sketches. The sketch entities must share an end point. These relations create a smooth continuity at the end point and apply equal curvature and an equal rate of curvature to the sketch entities.

You can apply torsion continuity relations to a spline and one of these sketch entities:

- Spline
- Arc
- Conic or elliptical arc
- Model edges that are linear, circular, conic, parabolic, elliptical, or spline-based

**To apply torsion continuity relations:**

1. Select a plane and open a sketch.
2. Click **Style Spline** (Sketch toolbar) or **Tools > Sketch Entities > Style Spline**.
3. Sketch a spline.

4. Right-click the spline and click **Show Curvature Combs**.

5. Click **3 Point Arc** (Sketch toolbar) or **Tools > Sketch Entities > 3 Point Arc**.

6. Sketch an arc that shares common end point with the spline.

7. Right-click the arc and click **Show Curvature Combs**.

8. **Ctrl** + select the spline and arc.

   The Add Relations/Properties PropertyManager appears.

9. In the Add Relations/Properties PropertyManager, under **Add Relations**, click **Torsion Continuity**.

10. Click ✓.

   The result is a smooth continuity with equal curvature and equal rate of curvature at the shared end point between the spline and arc.
Baseline and Chain Dimensions in Sketches

In assemblies and parts, **Baseline** and **Chain** dimension tools are available in Sketch mode.

- Baseline dimensions can be driving or driven.
- Chain dimensions can only be driven.

Importing 2D DXF or DWG Files as Reference Sketches

You can import 2D DXF or DWG files as reference sketches.

**To import 2D DXF or DWG files as reference sketches:**

1. Click **Open** (Standard toolbar) or **File > Open**.
2. In the Open dialog box, set **File of type** to Autodesk AutoCAD Files (*.dwg; *.dxf), browse to the file, and click **Open**.
3. In the DXF/DWG Import dialog box, under **Import to a new part as**, select 2D sketch and **Import as reference**.
4. Click **Finish**.

The software imports the DXF or DWG file as a reference sketch.

You cannot edit a reference sketch. In the FeatureManager® design tree, right-click the reference sketch and click **Make Edit Sketch**. The software converts the reference sketch to a regular sketch and you can edit it.

Power Modify Tool

**Power Modify** is a pen sketch mode that uses pen gestures to modify sketch geometry. **Power Modify** adds pink strokes that indicate where you want modifications such as adding fillets or trimming to take place.

You can only use the **Power Modify** tool with a touch device. On the touch device, you can use the tool with pen sketch mode, your finger, or a mouse.

Click or touch **Power Modify** (Sketch Ink toolbar).

<table>
<thead>
<tr>
<th><strong>Power Modify</strong></th>
<th>Modifies the sketch geometry when you use ink strokes as gestures to trim, extend, split, offset, and add fillets and chamfers to sketch geometry.</th>
</tr>
</thead>
</table>

After using **Power Modify**, you can further update the sketch geometry by using the following tools on the context toolbar:

<table>
<thead>
<tr>
<th><strong>Edit Power Modify</strong></th>
<th>Undoes the last <strong>Power Modify</strong> stroke.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Convert to sketch chamfer</td>
<td>Converts lines into chamfers.</td>
</tr>
<tr>
<td>---------------------------</td>
<td>------------------------------</td>
</tr>
<tr>
<td>Convert to sketch fillet</td>
<td>Converts arcs into fillets.</td>
</tr>
<tr>
<td>Convert to sketch extend</td>
<td>Extends lines or arcs up to the nearest sketch entity.</td>
</tr>
</tbody>
</table>

You can use the **Power Modify** ink strokes to do the following:

- **Add fillets by drawing an arc that intersects sketch geometry.**

![Diagram of adding fillets](image)

When you add multiple fillets quickly, the software converts all the pink strokes into fillets at the same time. The software considers them as consecutive fillets with the same radius and creates an automatic relation with the first fillet in the series.

- **Add chamfers by drawing a line that intersects sketch geometry.**

![Diagram of adding chamfers](image)

- **Power trim sketch entities by drawing a scribble gesture on sketch geometry.**

![Diagram of power trimming](image)
• Extend sketch entities along their natural paths by drawing a line or arc that partially overlaps the sketch geometry to which you want to extend.

• Split sketch entities by drawing two intersecting lines or arcs on sketch geometry.

• Offset sketch entities by drawing two parallel lines that intersect sketch geometry. You can offset the following sketch geometries:
  • Multiple lines, arcs, or splines
  • Multiple shaded sketch contours

Silhouette Entities

You can create multiple sketch entities by projecting the outline of the bodies in a part or components in an assembly onto a parallel sketch plane. Silhouette entities create parametric sketch constraints on the model. You can use silhouette entities when you use Sketch and 3D Sketch On Plane.
In Section View mode:

- The Silhouette Entities tool is available only when you clear the Graphics-only section option.
- Silhouette entities do not contain sketch constraints.
- You can silhouette a component that has only a single instance in an assembly.

To use silhouette entities, click Silhouette Entities (Sketch toolbar) or Tools > Sketch Tools > Silhouette Entities.

Creating Silhouette Entities

To create silhouette entities:

1. Open system_dir:Users/Public/Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\sketching\food_processor_silhouette.SLDASM.

2. In the FeatureManager design tree, select Plane4.

3. Click Sketch (Sketch toolbar).

4. Click Silhouette Entities (Sketch toolbar) or Tools > Sketch Tools > Silhouette Entities.

5. In the PropertyManager, for Entities to Silhouette, select base plate<1> from the FeatureManager design tree.
6. Clear **External silhouette** to create sketch entities of the outer body and the internal entities of the model.

![Diagram of external silhouette](image)

7. Click ✅.

To create entities of the external silhouette only, select **External silhouette**. Silhouette entities appear on the sketch.

**Silhouette Entities PropertyManager**

**To open the Silhouette Entities PropertyManager:**
1. In a part or assembly, open a sketch on a plane.
2. Click **Silhouette Entities** (Sketch toolbar) or **Tools > Sketch Tools > Silhouette Entities**.

**Entities to Silhouette**

| **Select bodies or components to create silhouette sketch entities** | Lists the selected bodies in parts or components in assemblies. |
| **External silhouette** | Creates the sketch entity from the silhouette of the outer boundary of the model. Clear this option to project the inner loops in the model. |
SOLIDWORKS Visualize

This chapter includes the following topics:

- **AMD ProRender Integration**
- **AxF Measured Materials**
- **glTF Export for AR and VR**
- **IES Light Profiles**
- **Inline Rendering**
- **Instancing**
- **MDL Support**
- **NVIDIA RTX Support**
- **Scaling for High-Resolution Displays**
- **SOLIDWORKS PDM Integration**

SOLIDWORKS® Visualize is a separately purchased product that you can use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate application.

**AMD ProRender Integration**

SOLIDWORKS Visualize supports AMD Radeon™ ProRender, a raytracing engine that is designed to run on AMD’s high-performance graphics cards.

To use ProRender, click **Tools > Options > 3D Viewport** and, under **Render Engine**, select **AMD Radeon ProRender**.

**AxF Measured Materials**

SOLIDWORKS Visualize supports AxF™ measured materials.

The .axf file format from X-Rite stores digital material representations, most notably measured materials, from their BTF scanning technology. To add .axf files to a project, drag from Windows Explorer into your scene or click **Palette >Appearances > Add > Import Appearances**.
glTF Export for AR and VR

You can use .gltf and .glb file formats to export your SOLIDWORKS Visualize project data for use in augmented and virtual reality viewers.

IES Light Profiles

You can use IES light profiles to modify light sources to mimic real-world lights. The profiles are generally used for interior and architectural scenes where the light is cast and readily seen on nearby objects like walls, ceilings, and floors.

Specifications from the Illuminating Engineering Society (IES) define the standards for describing light profiles in the form of .ies files. Lighting manufacturers provide .ies files that define the unique way in which each product emits light; for example, how it casts light rays and shadows.

Finding IES Light Profiles

From the internet, you can download IES light profiles from lighting manufacturers such as Philips and Lithonia, and add them to the Lights folder of the library in SOLIDWORKS Visualize.

The Lights folder contains samples of IES profiles. These profiles do not represent specific profiles from light manufacturers. However, you can use a sample profile if, for example, you have not yet decided on or obtained a specific IES profile to use. Also, you can use a sample profile if you want a unique look for a light source but do not need a specific profile.

To find IES light profiles:

1. Search the internet using a string such as "ies light profiles download" to find sources.

2. Download the files and copy them to the Lights folder in your SOLIDWORKS Visualize Content folder.
   By default, the content folder is located in your Documents folder.
Adding IES Profile Lights to Scenes

You can drag existing IES profile lights into scenes. You can also create IES profile lights by adding area lights to scenes and then editing parameters to make them IES profile lights.

Dragging IES Profile Lights into Scenes

You can drag IES profile lights from the File Libraries tab into your scenes.

1. In the Palette, on the File Libraries tab, select Lights from the list.
2. Drag an .ies file from the Palette into the scene and drop it in the location for the light.

The profile is placed using the Pick Position method and normal to the surface under the pointer.

You can also drag .ies files directly from File Explorer into the scene.

3. Optional: To make adjustments to the light, on the Scenes tab, select the light in the tree. Then you can:
   - Adjust the parameters of the light, such as Brightness and Color.
   - Use the Object Manipulation Tools (main toolbar) to adjust the position and direction of the light.

   To move the position and the target simultaneously, right-drag the arrow handles.

In Preview render mode, IES profile lights are represented as standard area lights. This provides enough information to adjust placement of the light, but does not represent the light profile accurately. Use Fast or Accurate modes for accurate representation of the light profile.

Creating IES Profile Lights from Area Lights

You can create IES profile lights by adding area lights to scenes and then editing parameters to make them IES profile lights.

You can use these lights as placeholders if, for example, you have not yet decided on or obtained a specific IES profile to use.

1. In the Palette, on the Scenes tab, click Add > New Light > Pick Position.
2. In the viewport, click a location for the light.
3. In the Palette, for Type, select IES Profile.

   A default IES profile is used. Now or later, you can change to a specific IES profile.

4. To change to a specific IES profile:
   a) On the Scenes tab, select the light in the tree.
   b) For IES Profile, click ..., browse to an .ies file, and click Open.
Inline Rendering

SOLIDWORKS® Visualize supports and defaults to the **Live** rendering mode for renders that you run from the Output Tools dialog box. The **Live** rendering mode blocks access to the application during the rendering process.

Previously, all renders that you ran from the Output Tools dialog box ran in the background so that you could continue working in the application. To continue this behavior, you can switch to the **Background** rendering mode.

**To switch render modes:**
1. Click **Tools > Options**.
2. On the 3D Viewport tab, under **Render Mode**, select one of the following:

<table>
<thead>
<tr>
<th>Mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Live</td>
<td>Provides faster rendering by blocking access to the application during the rendering process. This option can be useful when you use computers with minimum recommended configurations.</td>
</tr>
<tr>
<td>Background</td>
<td>Lets you continue working in the application during the rendering process. Performance might slow down, especially on computers with minimum recommended configurations.</td>
</tr>
</tbody>
</table>

Instancing

For SOLIDWORKS part and assembly models, SOLIDWORKS Visualize can handle duplicated geometry, such as patterned components from SOLIDWORKS assemblies, more efficiently.

Typically, for larger SOLIDWORKS assemblies, the use of duplicated geometry requires less GPU memory and reduces the likelihood of running out of GPU memory.

Appearance part-grouping mode does not support this functionality.
MDL Support

SOLIDWORKS Visualize supports full editing capabilities of NVIDIA® Material Definition Language (MDL) materials.

You can modulate textures and edit color fields and parameters.
Also, these materials are supported in Preview mode.
The creator of an MDL material defines its look and behavior. The creator specifies which parameters to show, and specifies the parameter names, value ranges, and whether the parameter can be textured.
Parameter names in MDL material are not localized.

Using MDL Materials

The NVIDIA vMaterials catalog provides access to a collection of MDL materials.
Before you begin, download and install the vMaterials catalog from the NVIDIA website:
1. Go to the NVIDIA vMATERIALS web page.
2. Click DOWNLOAD and follow the instructions.

To use MDL materials:
1. In SOLIDWORKS Visualize, open a new or existing project.
2. In Microsoft® File Explorer, browse to the folder where you installed the NVIDIA vMaterials catalog.
3. To assign a material to a part, drag any .mdl file and drop it on the part in SOLIDWORKS Visualize.
   One .mdl file can include definitions for multiple materials. SOLIDWORKS Visualize creates one appearance for each material.
4. To edit the material, select it in the viewport or in the Appearances tab, and then edit parameters in the Appearances tab.

If the creator of an MDL material specifies that a parameter can be textured, appears next to the parameter.
5. To add a texture to the parameter, click , browse to a texture, and click Open.
   
The texture appears on the model, and the texture's parameters appear in the Texture subtab.

   The changes you make affect only the copies of the appearance in the project. They do not affect the source appearance.

NVIDIA RTX Support

SOLIDWORKS Visualize has RT Core support for full RTX hardware acceleration for Accurate and Fast render modes on NVIDIA Turing™ TU10x GPUs.

Scaling for High-Resolution Displays

SOLIDWORKS Visualize supports displays with 4K and higher resolution.

Icons and buttons scale so that their appearance does not degrade or become blurry on high-resolution and high-pixel density displays.

Except for the viewport, all aspects of the user interface respond to the Microsoft Windows® display scaling setting. In dialog boxes and the Palette, the software uses the display scaling setting to display icons and buttons at an appropriate size. Icons associated with text are scaled to a size appropriate for the text.

The viewport, which includes the preview of ongoing renders, does not scale. It always appears in the actual device pixels of the screen. Therefore, when you use a 4K monitor, the viewport appears smaller compared to other user interface elements. To change the resolution of the viewport, click Tools > Options > 3D Viewport and change the value for Maximum Resolution.

SOLIDWORKS PDM Integration

You can use the integrated SOLIDWORKS PDM menu to access vault tools and view file information for files you open in SOLIDWORKS Visualize.

You must have SOLIDWORKS PDM Professional installed.

Most tools on the menu are available only if you open a project from the PDM vault.

Exceptions:

- **Search** is always available.
- **Select in Windows Explorer** is available if you open a project, whether from the PDM vault or another location.

To access these tools:

- On the menu bar, click SOLIDWORKS PDM.
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change State</td>
<td>Changes the workflow state. Workflow states represent where the file is in the design and approval process, such as <strong>Under Editing</strong>, <strong>Waiting for Approval</strong>, or <strong>Approved</strong>.</td>
</tr>
<tr>
<td>Check In</td>
<td>Checks in files after editing to make them available to users with appropriate rights. Until you check in a file, changes are saved in your local version only.</td>
</tr>
<tr>
<td>Check Out</td>
<td>Checks out a file to give you the exclusive right to edit it until you check it back in. Other users can open the file for viewing and copying but cannot change it.</td>
</tr>
<tr>
<td>Undo Check Out</td>
<td>Cancels a checkout without saving changes.</td>
</tr>
<tr>
<td>Get Latest Version</td>
<td>Changes the version of a file in your local cache to the latest available version.</td>
</tr>
<tr>
<td>Get Version</td>
<td>Changes the version of a file in your local cache to another version you select.</td>
</tr>
<tr>
<td>Search</td>
<td>(Always available, even if no files are open in SOLIDWORKS Visualize.) Searches for files and folders and for other data such as users and items.</td>
</tr>
<tr>
<td>Select in Windows Explorer</td>
<td>(Available if you open a project, whether from the PDM vault or another location.) Opens Windows Explorer to the folder that contains the file and selects the file.</td>
</tr>
<tr>
<td>Show Card</td>
<td>Opens the SOLIDWORKS PDM data card for the document you are viewing.</td>
</tr>
<tr>
<td>Local Version</td>
<td>Displays version information for the document in the local cache.</td>
</tr>
<tr>
<td>Local Revision</td>
<td>Displays revision information for the document in the local cache.</td>
</tr>
<tr>
<td>Checked Out By</td>
<td>Displays the name of the user who has checked out the file.</td>
</tr>
<tr>
<td>Checked Out In</td>
<td>Displays the location (system name and path) where the user checked out the file.</td>
</tr>
<tr>
<td>Workflow State</td>
<td>Displays the current state of the document as defined in the SOLIDWORKS PDM workflow.</td>
</tr>
</tbody>
</table>
Structure System and Weldments

This chapter includes the following topics:

- Options for Creating Primary Members Based on Points
- Creating Curved Beams and Merging Tangent Members
- Split Members
- Pattern and Mirror Support
- Member and Corner Trim Enhancements
- Cut List Properties for Weldment and Structure System Features

Video: What's New in SOLIDWORKS 2020 - Structure System

Options for Creating Primary Members Based on Points

When specifying **Point and Length**, you can set a direction for a primary member by selecting a sketch entity as a reference. The member extrudes in its direction. You can also reverse its direction.

Additional end condition types:

<table>
<thead>
<tr>
<th>Condition</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Point</strong></td>
<td>Extends a primary member from the start point to the end point. Click <strong>Chain Link</strong> to add members along a chain of points.</td>
</tr>
<tr>
<td><strong>Up to Point</strong></td>
<td>Extends a primary member up to the selected point.</td>
</tr>
<tr>
<td><strong>Up to Plane</strong></td>
<td>Extends a primary member from a point to a plane. The member extrudes in the direction of the reference plane.</td>
</tr>
</tbody>
</table>
Specifying the Member Profile

1. Open `system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\structure_system\point_length.SLDPRT`.

2. Click **Insert > Structure System > Structure System** to enter Structure System mode.

3. Click **Insert > Structure System > Primary Member** to add primary members.

4. Click **Pin** at the top of the PropertyManager.

5. In the Profile tab, set the following:
   a) For **Standard**, select **Iso**.
   b) For **Type**, select **pipe**.
   c) For **Size**, select **21.3 x 2.3**.

Creating Primary Members Based on Point and Length

To create primary members based on point and length:

1. In the Member tab, under **Primary Member Type**, click **Point Length Member**.
2. Under **End Condition**, select **Length** and enter **200.00mm**.
   
   The PropertyManager displays the following members:
   - **Point11@Point and point**
   - **Point5@Point and point**
   - **Point9@Point and point**
   - **Point7@Point and point**
3. In the graphics area, select the four sketch points on the **Point and point plane**.
4. Click ✅.
Creating Primary Members Between Points

To create primary members between points:
1. In the Member tab, under End Condition, select Point.
2. Under Points And Length, click Chain Link.
   The endpoint of one member is used as the beginning of the next pair in the chain.
3. In the graphics area, click each point at the corners of the rectangle on the Top plane.
   The PropertyManager lists the following pairs:
   • Point8@Base Point, Point6@Base Point
   • Point6@Base Point, Point7@Base Point
   • Point7@Base Point, Point5@Base Point
   • Point5@Base Point, Point8@Base Point
4. Click √.

Creating Primary Members Based on Up to Point

To create primary members based on up to point:
1. In the Member tab, under End Condition, select Up to Point.
2. Under End Condition, click in the End Condition box.
3. In the graphics area, select the point on the plane labeled **Up to point**.

![Up to point plane](image)

**Point1@Uptopoint** displays in the PropertyManager.

4. In the Member tab, click in the **Points And Length** box.
5. In the graphics area, select points 8, 5, and 7 as shown.

![Points and elements plane](image)

6. Click ✅.

Creating Primary Members Based on Direction

**To create primary members based on direction:**

1. In the Member tab, under **End Condition**, select **Length**.
2. Under **End Condition**, click in the **Direction of Member** box.
3. In the graphics area, select the sketch line that appears in a magenta color.
   When you select the sketch line, the color changes to orange.

![Sketch line](image)

The PropertyManager displays **Line1@For direction control**.

4. In the graphics area, click the remaining corner on the rectangle on the **Top** plane.
5. In the Member tab, enter **280.00mm** for **Length**.
6. Unpin the PropertyManager and click ✅.
7. Click **Structure System** in the Confirmation Corner to exit Structure System mode.
8. In the Corner Management PropertyManager, click ✅.
Creating Curved Beams and Merging Tangent Members

You can create curved beams from primary and secondary members in a structure system. Curved members behave the same way as linear members where you can add secondary members between them.

If you select a 3D curve or spline as a reference, the member can only pierce through the center of the profile. Also, in some scenarios, you cannot sweep members with 2D or 3D splines because of their curvature and radius.

You can also merge multiple members that are tangent to each other into a single member with the Merge Tangent Members option and add secondary members between merged members.

Split Members

You can split primary and secondary members by specifying references or dimensions.

For Reference type, you can select faces, reference planes, or members. For Dimension type, you can specify a dimension for length, direction vector, and the number of split member instances to create.

Splitting Members by Reference

To split members by reference:

1. Open system_dir:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\structure_system\split.SLDPR.T.
2. In the FeatureManager design tree, right-click **Structure System2** and click **Edit Feature**.

3. In the graphics area, select this member as shown.

![Diagram showing the selection of a member](image)

The Member Properties PropertyManager lists **Member8** in **Selected Members**.

4. Optional: **Ctrl +** select the two members above Member8 as shown in the graphics area.

![Diagram showing the selection of two members](image)

**Member20** and **Member16** are added to **Selected Members**.

5. In the PropertyManager, click **Split Member** and select **Based On Reference**.

6. In the graphics area, select the vertical member that intersects the horizontal members, as shown.

![Diagram showing the selection of a vertical member](image)

7. Click ✓.

Members 8, 20, and 16 split at their intersection of Member 15.

---

**Do not exit Structure System mode. Keep the model open to continue with the next step.**
Splitting Members by Dimension

**To split members by dimension:**

1. In the graphics area, select the longest horizontal member as shown.

   ![Image of a structure with a highlighted member]

   The PropertyManager lists **Member21** in Selected Members.

2. In the PropertyManager, click **Split Member** and select **Based On Dimension**.
3. Click **Instance** and enter 6.
4. Click ✓.
5. In the FeatureManager design tree, expand **Structure System2** and expand `<iso><square tube><20 x 20 x 2>(3)`.

   **Member21** lists the split instances from **Member21_1** to **Member21_6**.

   ![Image of a structure with split members]

Pattern and Mirror Support

You can pattern and mirror structure system members using the **Linear Pattern**, **Circular Pattern**, or **Mirror** tools.

In the Pattern PropertyManager, under **Bodies**, you can specify structure system features or individual members to pattern. You can also mirror members by specifying structure system features or individual members under **Bodies to Mirror** in the Mirror PropertyManager.

You can add secondary members as a separate structure system feature between patterned and mirrored members.

You can also create secondary members as part of a new structure system by selecting members from existing structure system features.
Creating a Linear Pattern of a Structure System Feature

1. Open system_dir:
   \Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS 2020\samples\whatsnew\structure_system\shed.SLDPRT.

2. Click Insert > Pattern/Mirror > Linear Pattern.

3. In the PropertyManager, for Direction 1:
   a) For Pattern Direction, select the edge shown in the graphics area.
   b) Select Up to reference.
   c) Click in Reference Geometry, and in the graphics area, rotate the model and select the face shown.
   d) For Spacing, enter 10mm.
   e) Click Number of Instances and enter 6.

4. 

5. In the PropertyManager, click Bodies and click in Structure System to Pattern.
6. In the flyout FeatureManager design tree, click **Structure System1**.

7. Click ✔.

The model adds six instances of the frame.

**Adding a Structure System Feature to an Existing Feature**

1. Click **Insert > Structure System** > **Structure System**.
2. Click **Insert > Structure System** > **Secondary Member**.
3. Click **Pin** at the top of the PropertyManager.
4. Click the Profile tab and set the following:
   a) For **Standard**, select **Iso**.
   b) For **Type**, select **square tube**.
   c) For **Size**, select **80 x 80 x 5**.
5. Click the Member tab, and for **Secondary Member Type**, click **Support Plane Member**.
6. Click in **Support Plane**, and in the flyout FeatureManager design tree, select **Plane2**.

7. Click in **Member Parameters** and click **Chain Link**.
8. In the graphics area, click **Right Orientation** (Heads-up View toolbar).
9. Click each of the vertical members and click ✓.

A row of secondary members displays along the right side of the model.

10. Right-click in Member Parameters and click Clear Selections.

11. In the graphics area, click Left Orientation (Heads-up View toolbar) and repeat steps 6 to 9 to generate another row of secondary members.

12. Unpin the PropertyManager and click ✓.

13. Click Structure System in the Confirmation Corner to exit Structure System mode.


Member and Corner Trim Enhancements

Enhancements and quality improvements for structure system features include:

- When creating Ref Plane and Face Plane intersection primary members, you can select faces in addition to reference planes.
- When creating Support Plane secondary members, you can select faces in addition to reference planes.
- You can delete input sketches and planes for individual members without deleting the Structure System feature.
- Issues with corner treatment, especially with creating complex corners, are resolved.
- You can define individual gap values for trimming corners.
• Original corner features are retained even after adding or deleting new members at the corner location.

Cut List Properties for Weldment and Structure System Features

Two cut list properties are available for structural members created by weldment as well as structure system features.

The **Angle Direction** property indicates whether the two ends face of the body are along the same direction or not. You can specify:

- **Same**
- **Opposite**
- **Out of Plane**
- **None**

The **Angle Twist** property indicates the angle between the normals of two end cut planes for out of plane trimming. You can set the angle 0–180 degrees.
Our 3DEXPERIENCE® platform powers our brand applications, serving 11 industries, and provides a rich portfolio of industry solution experiences.

Dassault Systèmes, the 3DEXPERIENCE Company, is a catalyst for human progress. We provide business and people with collaborative virtual environments to imagine sustainable innovations. By creating ‘virtual experience twins’ of the real world with our 3DEXPERIENCE platform and applications, our customers push the boundaries of innovation, learning and production.

Dassault Systèmes’ 20,000 employees are bringing value to more than 270,000 customers of all sizes, in all industries, in more than 140 countries. For more information, visit www.3ds.com.