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1
Welcome to SOLIDWORKS 2023

This chapter includes the following topics:

• Top Enhancements
• Performance
• For More Information

Model courtesy of Philipp Burgstaller, SOLIDWORKS 2022 Beta Splash Screen Prize Winner.
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Video: What's New in SOLIDWORKS 2023

At SOLIDWORKS®, we know that you create great designs, and that your great designs get
built. To streamline and accelerate your product development process from concept through
manufactured products, SOLIDWORKS 2023 contains new, user-driven enhancements focused
on:

• Working Smarter. Reduce your workload when designing large assemblies and detailing
drawings, and handle more complex electrical routing scenarios.

• Working Faster. Work with bills of materials (BOMs) more efficiently, improve the
performance for searching and saving assemblies, and design large assemblies faster.

• Working Together. Help teams share and manage data more productively with a
streamlined user interface, reduced latency, and improved upgrade performance in
SOLIDWORKS PDM. Communicate changes to design data better with the ability to customize
PDM notification templates.

Top Enhancements
The top enhancements for SOLIDWORKS® 2023 provide improvements to existing products
and innovative new functionality.

Parts and Features
on page 27

• Coordinate Systems
• Dimension Support for the Move/Copy Body Command
• Single-Line Fonts for Wrap Features

Sheet Metal on
page 35

• Sensors

Structure System
and Weldments on
page 39

• Corner Treatment to Similar Corners in Structure Systems
• Configuration-Specific Size of Weldment Members

Assemblies on page
44

• Automatically Optimize Resolved Mode
• Repairing a Missing Mate Reference
• Additional End Conditions for Cut Features

Detailing and
Drawings on page
64

• Overrides for Bills of Materials
• Filters for Bill of Materials

9
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SOLIDWORKS
Inspection on page
140

• Autoballoons for PDF Files
• Balloon Sequence
• Balloon Drawing Sheets Separately
• Export Sheets as Separate 2D PDF Files
• Export FAI Reports to Separate Microsoft® Excel® Documents
• User Interface Redesign

SOLIDWORKSMBD
on page 151

• Limiting Geometric Tolerances to a Standard
• Dimension Extension Lines

Performance
SOLIDWORKS® 2023 improves the performance of specific tools and workflows.

Some of the highlights for performance and workflow improvements are:

SOLIDWORKS Fundamentals
You can use the Level of detail system option to improve the performance when
manipulating views.

To access this option, click Tools > Options > System Options > Performance.

Performance is improved for Zoom In/Out, Pan, and Rotate in draft quality HLR/HLV
and wireframe modes of models.

Section Views of Models

Starting and exiting the Section View command is about five times faster than before.

While you are in the Section View command, adding or removing section planes is
instantaneous.

Assemblies
• Improved performance when searching with Include sub-folders selected.

• For assemblies that contain parts with multiple imported bodies and body level
appearances, performance is improved when:

• Opening a file
• Changing a configuration
• Applying, modifying, or removing an appearance
• Rolling back or rolling forward assembly items

• The save efficiency of assemblies is improved to avoid saving unchanged model data.
This performance improvement is most noticeable in very large assemblies.

10

Welcome to SOLIDWORKS 2023



Import/Export
Performance of importing third-party CAD files is improved using 3D Interconnect.

SOLIDWORKS PDM
• SOLIDWORKS PDM 2023 makes significant performance improvements in the presence

of high latency to SOLIDWORKS PDM servers.

The improvements might vary depending on the amount of latency, size of data
sets, and operations.

• The following operations perform better when latency to the database server is
high:

• Check-in
• Check-in with automatic transition
• Undo Check-out
• Interactive operations such as menus, shortcut menus, reference dialog boxes,

and SOLIDWORKS PDM File Explorer tabs

• The following operations perform better when latency to the archive server is high:

• Add files
• Change state on file modifications
• Get files
• Get latest version of files

• With performance improvements in the File Version Upgrade tool, you can upgrade
SOLIDWORKS files in a SOLIDWORKS PDM vault faster.

If you are upgrading assembly files and you select Overwrite and Latest Version in
the Version Settings page, the software skips upgrading and uploading references that
are not the latest in the assembly's as-built version. This improves the performance
of the upgrade process.

• In SOLIDWORKS PDM 2023 SP04, the mechanism for loading of SOLIDWORKS PDM
and custom add-ins is reworked. As a result, operations such as logging in to a vault
and starting the SOLIDWORKS PDM Search tool perform significantly better.

Structure System and Weldments
Performance is improved when you create or edit a corner management feature. A corner
gets trimmed when you select it under Corners in the Corner Management
PropertyManager or in the graphics area.

Previously, the corners were trimmed as soon as you created or edited the corner
management feature.

Performance is improved when you insert a structural member or change its profile to
the part that includes weld beads.

11
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Configuration Publisher (2023 SP3)
Performance of the Configuration Publisher dialog box is improved when you add lists
and check boxes from the palette into the Edit panel.

For More Information
Use the following resources to learn about SOLIDWORKS:

This guide is available in PDF and HTML formats. Click:What's New in PDF
and HTML

• > What's New > PDF

• > What's New > HTML

In SOLIDWORKS, appears next to new menu items and the
titles of new or significantly changed PropertyManagers. Click

Interactive What's
New

to display the topic in this guide that describes the
enhancement.

To enable Interactive What's New, click > What's New >
Interactive.

Contains complete coverage of our products, including details
about the user interface and examples.

Online Help

Contains posts from the SOLIDWORKS user community on the
3DEXPERIENCE® platform (login required).

SOLIDWORKS User
Forum

Provides information about late changes to our products,
including changes to the What's New book, online help, and
other documentation.

Release Notes

SOLIDWORKS Legal Notices are available online.Legal Notices
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2
Installation

This chapter includes the following topics:

• Adding Serial Numbers for SolidNetWork License Installations
• Renewing and Reactivating Term SNL Licenses
• Load SOLIDWORKS Flow Simulation Modules
• Faster Startup for Borrowed Licenses

Adding Serial Numbers for SolidNetWork License Installations

Adding serial numbers to licenses for all SOLIDWORKS applications and add-ins is much
simpler for CAD administrators to handle.

You can use the Product Activation Wizard from the SOLIDWORKS SolidNetWork License
Manager Server to add and activate serial numbers for perpetual and term licenses.
Previously, serial numbers were entered when installing the License Manager Server. The
new method makes it easier to add serial numbers to existing installations. You can also
use the Activation Wizard to remove serial numbers that have not been activated.
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Renewing and Reactivating Term SNL Licenses

For term licenses, renewal and reactivation warnings display in all SOLIDWORKS add-ins,
SOLIDWORKS PDM, and SOLIDWORKS Manage.

When users start these applications, if any term licenses are due to expire or require
activation within 30 days, warnings notify the users and prompt them to contact their
CAD administrator.

When you click Reactivate on the SolidNetWork License Manager Server Administration
tab, the Reactivate Licenses dialog box highlights in red all license expiration and
reactivation dates within 30 days. Asterisks mark licenses that require renewal. You can
also filter and view licenses associated with a specific serial number.
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Load SOLIDWORKS Flow Simulation Modules

As a SolidNetWork license customer, you can control how to load the HVAC and Electronics
Cooling add-in modules for Flow Simulation using two methods.

The first method lets you specify the default behavior for the add-ins when you load Flow
Simulation. The option Automatically load Flow Simulation add-in modules if
available is in the SolidNetWork License Manager Client > License Order tab. Clear
this option if you do not have a need for the Flow Simulation add-ins. The HVAC and
Electronics Cooling add-in modules do not load when Flow Simulation is added in with
existing methods.

The second method lets you override default behavior and include the HVAC and Electronics

Cooling add-in modules when you load Flow Simulation. Click the Down arrow on
SOLIDWORKS Flow Simulation (SOLIDWORKS® Add-ins toolbar) or SOLIDWORKS
Flow Simulation with one or both of the add-modules to load.

Without these methods, the licenses for the add-in modules are consumed whether or
not you need them and may be denied to other users on your network.
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Faster Startup for Borrowed Licenses

If you are working remotely and your SOLIDWORKS apps are slow to open, you can make
them faster by blocking license server queries and using only borrowed licenses.

License server queries are slow in some environments. Your apps will start faster if you
block these queries, but will only use the licenses you have borrowed.

To block license server queries and use only borrowed licenses, click Start >
SOLIDWORKS Tools 2023 > SolidNetWork License Manager Client > License
Borrowing > Only use borrowed licenses for faster startup and restart your apps.
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3
SOLIDWORKS Fundamentals

This chapter includes the following topics:

• Application Programming Interface
• Changes to System Options and Document Properties
• Ellipses
• Performance Improvement When Manipulating Views

Application Programming Interface
See SOLIDWORKS API Help: Release Notes for late-breaking updates.

Support
There is API support for:

• Mate controller features in assemblies
• Simple, two-member, and complex corner treatments in structure systems

Redesign
Sheet metal sketched bend features have been redesigned.

Other Enhancements
• Get whether an assembly configuration is defeatured
• Get and set whether to use gauge table values in a sheet metal sketched bend feature
• Get whether to override a preset bend angle in a sheet metal sketched bend feature
• Get and set whether to symmetrically thicken a bidirectional base flange feature
• Get and set whether to symmetrically thicken a bidirectional lofted bends feature
• Convert a solid body to a mesh body
• Create a surface body from a mesh body
• Create a surface body from a graphics body
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Changes to System Options and Document Properties
The following options have been added, changed, or removed in the software.

System Options

AccessDescriptionOption

ColorsChanges the default color of overridden
cells.

Drawings, Modified Cells
(BOM)

ColorsSpecifies a color for an explode line.Sketch, Exploded

PerformanceLoads component data as resolved when
you open an assembly.

Automatically optimize
resolved mode, hide
lightweight mode

PerformanceControls when a component loads in
lightweight or resolved mode.

Manually manage
resolved and lightweight
modes

PerformanceRenamed from Automatically load
components lightweight.

Load component
lightweight

ExportExports assemblies as atomic STEP files.Export assembly
components as separate
STEP files (recommended
for large assemblies)

ExportExports file's appearances with reduced
performance. Clear the option to skip
exporting appearances but make the
performance faster.

Export appearances

Document Properties

AccessDescriptionOption

Annotations >
Geometric
Tolerances

Includes all geometric tolerance symbols
regardless of the drafting standard.
Clear the option to limit symbols to the
document's drafting standard.

Allow tolerance symbols
for all drafting standards

DimXpert >
Display Options

Completes connection of dimension
extension lines to model.

Connect dimension
extension lines to model

18
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AccessDescriptionOption

Drawings >
Detailing

(Available for High quality drawing
views only). Shows edges behind
transparent components with solid lines.

See through transparent
components in HLR/HLV

ConfigurationsSpecifies a value for the default BOM
part number. Options are Document
Name or Configuration Name.

Default Bill of Materials
part number for new
configurations

Ellipses

When you sketch an ellipse, you can apply construction geometry to the major and minor
axes.

In the Ellipse PropertyManager, under Options, select Add construction lines.

Performance Improvement When Manipulating Views
You can use the Level of detail system option to improve the performance when
manipulating views.

To access this option, click Tools > Options > System Options > Performance.

Performance is improved for Zoom In/Out, Pan, and Rotate in draft quality HLR/HLV
and wireframe modes of models.
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4
User Interface

This chapter includes the following topics:

• Comments Enhancements
• Enforcing Legal File Names
• Restoring Default Settings
• Component Name Display

Video: What's New in SOLIDWORKS 2023 - User
Experience

Comments Enhancements
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Comments are enhanced to improve usability.

• You can choose different background colors and add bold , italics , and underline

to text.
• Click Options in the Background Colors tab to open the Tools > Options > Document

Properties > Model Display dialog box where you can specify the Comment
background colors. You can customize the names or reset all names back to the
default. You cannot customize the colors.

• Select Show at start in various places to show the comments in the View All Comments
dialog box when you reopen the file.

• In the View All Comments dialog box, in the Show at start column, you can select
the comments to show when you open the file. In the Show menu, you can specify
the comments to show at the start or based on a color. Click Apply to save changes
to the Show at start status of comments.

• When you right-click a comment, a context toolbar and shortcut menu appear so you
can directly edit features when you read the comments.
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• Comment tooltips show the text <image> to indicate that the full comment contains
an image. The tooltip name matches the name from the Comment background
colors section in the Model Display dialog box.

• Images in comments retain their current aspect ratio and the display quality is
improved.

• When you import images into comments, in the Open dialog box, the All files
(*.bmp,*.jpg,*.tif,*.tiff,*.png) option is the default to display all acceptable image
types.

• In the FeatureManager® design tree, comment indicators appear by default next to
features that have comments. The color circle matches the color of the comment.

To control the display of the comment indicators, in the FeatureManager design tree,
right-click the part node and click Tree Display > Show Comment Indicator.

22

User Interface



Enforcing Legal File Names

To ensure compatibility with the 3DEXPERIENCE platform, you cannot save new
SOLIDWORKS documents with preceding or trailing spaces in their names. The software
automatically removes the preceding or trailing spaces when you save the file. Spaces
in the middle of the file name are supported.

This enforcement applies in these cases:

• Save As dialog box, including the Advanced option
• Renaming parts and assemblies in the FeatureManager design tree
• Mirror Components PropertyManager
• Split PropertyManager and Save Bodies PropertyManager
• Pack and Go
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Restoring Default Settings

You can more easily restore the factory default settings in SOLIDWORKS®.

SOLIDWORKS Settings Wizard

The Copy Settings Wizard is renamed to the SOLIDWORKS Settings Wizard that has an
improved and simplified user interface with three options:

Saves SOLIDWORKS settings to a file. You choose the location
for the settings file and the settings to save.

Save Settings

Restores SOLIDWORKS settings from a file.Restore Settings

Resets all custom settings and returns SOLIDWORKS to the
factory defaults. You have the option to save all custom settings
to a file before resetting SOLIDWORKS to the factory defaults.

Reset Settings

Customize Dialog Box

• The button appears at the bottom of each tab in the Customize
dialog box so you can customize the settings to reset.

• The Customization tab is removed.
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The options from the Customization tab are reorganized as follows:

• Shortcut customization:
Removed because this was rarely used. The preferred
method is to keep the menu small and click to expand
the list

Show All

Moved to Menus tab > Reset shortcut menus.Reset to Default

• Menu customization:

25
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Removed because there was very little difference between
this command and Reset to Default for this customization.

Show All

Moved to Menus tab > Reset SOLIDWORKS menus.Reset to Default

Customizations and Upgrades

When you upgrade to a new version of SOLIDWORKS, the software keeps all the
customizations and also shows any new tabs, menus, toolbars, etc. that were added to
the software. Previously, warning dialogs prompted you to make choices that might have
led to lost settings.

Component Name Display

When you specify display options for component names in a drawing, the names in the
PropertyManager and View Palette match those in the FeatureManager design tree.

To specify display options for component names:

1. In the FeatureManager design tree, right-click the drawing name and click Tree
Display > Component Name and Description.

2. (Optional.) Under Primary, specify an option:

• Component Name
• Component Description

Based on the selection under Primary display options:

• The Model View and Standard 3 View PropertyManagers update the Open documents
field.

• The View Palette updates. The View Palette displays the part or assembly icon and the
file name.
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5
Parts and Features

This chapter includes the following topics:

• Allowance of Library Feature Errors
• Coordinate Systems
• Defeatured Parts as Derived Configurations (2023 SP1)
• Dimension Support for the Move/Copy Body Command
• Hybrid Mesh BREP Modeling Improvements
• Mesh BREP Display Improvements (2023 SP2)
• Section View Performance Improvements
• Section View through Axis
• Single-Line Fonts for Wrap Features
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Video: What's New in SOLIDWORKS 2023 - Parts and
Features

Allowance of Library Feature Errors

When you insert a library feature into a model and get error messages, you can keep the
results to view and manually repair the errors.

In the warning message, click Yes to keep the results. In the FeatureManager® design

tree, you can manually repair the library feature or click Undo to remove it. If you
click No in the warning message, in the Library Feature PropertyManager, you can modify

the selections or click to restore the FeatureManager design tree without the library
feature.

Previously, the warning message blocked you from inserting library features that generated
errors.
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Coordinate Systems

You can reference coordinate system elements from additional entities, features, and
commands, including the Select Other command.

DescriptionItem

Create sketch relations between 3D sketch
entities and coordinate system axes, planes,
and origin.

3D sketches

Create 2D sketch dimensions that reference
coordinate system axes, planes, and origin.

2D sketch dimensions

Select a coordinate system plane as the
mirror plane.

• Mirror features and bodies

• Mirror Components
• Insert > Mirror Part

Select a coordinate system axis to create a
new plane perpendicular to that axis. Use
a vertex or point from the model to position
the plane.

Reference Plane

Select coordinate system axes, planes, and
origin.

Select Other
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Defeatured Parts as Derived Configurations (2023 SP1)

You can save a defeatured version of a part as a derived configuration.

In the Defeature PropertyManager, on the Feature Removal Complete tab, under Results,
select Create a new configuration. You can quickly switch between the parent
configuration and the defeatured configuration. You also have fewer files to manage.
Previously, you could create only a separate external defeatured file.

Dimension Support for the Move/Copy Body Command
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When you use the Move/Copy Body command, you can control the Translate and
Rotate values with equations. You can add these equations to a design table and control
them there. You can double-click the dimensions in the graphics area and specify them
using the Modify dialog box.

Under Rotate, you can select Euler's angular rotation and specify values for Yaw
(side-to-side), Pitch (up-down), and Roll (twist). This method delivers the same resulting
rotation regardless of the order in which you specify these values.

If models have configurations, you can specify the configurations to which the dimensions
apply for Translate and for Rotate when you select Euler method of angular
dimensions.

Hybrid Mesh BREP Modeling Improvements

Hybrid mesh BREP modeling is improved to support more SOLIDWORKS® BREP features
that you can combine with mesh BREP geometry.

Hybrid mesh BREP modeling now supports features such as boss and cut sweeps, lofts,
and boundaries. For a complete list of supported features, see SOLIDWORKS Online Help:
List of Features Supporting Hybrid BREP Bodies.
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Mesh BREP Display Improvements (2023 SP2)

For mesh BREP bodies, you have the option to display or hide facet fins. In Tools >
Options > System Options > Display, select or clear the option Display facet fins
in mesh BREP bodies.

This includes bodies you create with the Convert to Mesh Body tool. It also includes
bodies imported from *.stl and *.3mf files with the Graphics Body import option
selected and that you later convert to mesh BREP bodies.

This option does not affect the display of regular edges on mesh BREP bodies, which
includes edges created directly on import or created later with the Segment Imported
Mesh Body tool.

Previously, there was no option to control the display of facet fins.

Section View Performance Improvements
Performance is improved when you work with section views in models.

Starting and exiting the Section View command is about five times faster than before.

While you are in the Section View command, adding or removing section planes is
instantaneous.
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Section View through Axis

You can define a section view through an axis without constraining it to a secondary point,
such as a vertex. Previously, a secondary selection was mandatory. When you click Plane

about axis , you can click Reverse Section Direction to flip the section view
across the created plane.

Single-Line Fonts for Wrap Features
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You can create wrap features from sketches that use single-line fonts when you select
Scribe for Wrap Type in the Wrap PropertyManager. Previously, wrap features did
not support single-line fonts.

Single-line fonts are also called stick fonts. This functionality is particularly helpful for
users who want to engrave stick fonts on parts.

If text or characters do not display properly, you may be using an inauthentic single-line
font. To check the font, dissolve the sketch text and review the text entities.
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6
Sheet Metal

This chapter includes the following topics:

• Gauge Values in Cut List Properties
• Sensors
• Sensor PropertyManager
• Symmetrical Thickness

Video: What's New in SOLIDWORKS 2023 - Sheet Metal

Gauge Values in Cut List Properties
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If you use gauge tables to define the thickness of sheet metal parts, the gauge number
appears in the Cut-List Properties dialog box. In the associated drawing, the gauge value
is available for annotations and cut lists.

In the Cut-List Properties dialog box, the Evaluated Value for Sheet Metal Gauge is
Gauge Number GA. For example, if you use a 3 Gauge in a sheet metal part, the
Evaluated Value is 3 GA.

In drawings, you can link an annotation to the Sheet Metal Gauge property and you
include the property in a cut list.

To link annotations to gauge values:

1. In a drawing of a sheet metal part, click an annotation, such as Note .

2. In the PropertyManager, click Link to Property .
3. In the Link to property dialog box, in Property name, select Sheet Metal Gauge.

To include gauge value properties in cut lists:

1. Right-click a flat pattern view and select Annotations > Cut List Properties.
2. Click in the sheet to place the cut list properties.

Sensors

You can use sensors to alert you when sheet metal models deviate from the limits specified
for a bounding box. In multibody parts, you can create sensors for individual bodies.

During the design process, if the model exceeds the bounding box parameters, an alert
appears in the FeatureManager® design tree. You can double-click an alert to see the
values in the Cut-List Properties dialog box.
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Sensor PropertyManager
Updates to the Sensor PropertyManager include support for sheet metal models.

Message
Displays a message if you do not select Create Cut Lists Automatically and Update
Automatically. Sheet metal bounding box sensors depend on up-to-date cut list

properties. In the FeatureManager design tree, right-click Cut list and select Create
Cut Lists Automatically and Update Automatically to generate automatic alerts.

Sensor Type

Specifies the smallest rectangle in which the flat pattern
can fit.

Sheet Metal
Bounding Box
Properties

Properties

Specifies the longest side of the bounding box.
For multibody parts, this is the sum of the bounding box
length for all bodies in the part.

For assemblies, this is the sum of the bounding box length
for all parts in the assembly.

Sheet Metal
Bounding Box
Length

Specifies the shortest side of the bounding box.
For multibody parts, this is the sum of the bounding box
width for all bodies in the part.

For assemblies, this is the sum of the bounding box width
for all parts in the assembly.

Sheet Metal
Bounding Box
Width

Sheet Metal Bounding Box Length x Sheet Metal
Bounding Box Width

For multibody parts, this is the sum of the bounding box
area for all bodies in the part.

For assemblies, this is the sum of the bounding box area
for all parts in the assembly.

Sheet Metal
Bounding Box
Area
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Specifies the area of the flat pattern excluding through
cut-outs.
For multibody parts, this is the sum of the bounding box
area blank for all bodies in the part.

For assemblies, this is the sum of the bounding box area
blank for all parts in the assembly.

Sheet Metal
Bounding Box
Area Blank

Specifies the individual body or bodies to which the sensor
applies.

Sheet Metal
Bodies to Monitor

Symmetrical Thickness

When you create a sheet metal part as a base flange or lofted bend (with the Bent
Manufacturing Method), you can specify a symmetrical thickness that adds an equal
amount of material to both sides of the sketch.

Symmetrical thickness helps you create sheet metal parts from sketches to help achieve
equal bend radii for upward and downward bends. In the image above, Symmetric is
cleared for the example on the left and selected for the example on the right.

In the Base Flange or Lofted Bends PropertyManager, under Sheet Metal Parameters,
select Symmetric.
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7
Structure System and Weldments

This chapter includes the following topics:

• Corner Treatment to Similar Corners in Structure System
• Pattern Connection Element PropertyManager
• Configuration-Specific Size of Weldment Members
• Structure System and Weldments Performance Improvement (2023 SP4)

Video: What's New in SOLIDWORKS 2023 - Structure
Systems

Corner Treatment to Similar Corners in Structure System
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You can use Group Similar Corners to group similar corners, apply a corner treatment
to the group, and edit the groups as required.

This is helpful for large structure system files that have multiple corners.

1. Open the structure system file.
2. In the FeatureManager® design tree, click Corner Management and select Edit

Feature.
3. In the Corner Management PropertyManager, under Corners, select a corner.
4. Click Group Similar Corners.

The similar corners are grouped together, appear as Corner Group xx under
Corners in the PropertyManager, and highlighted with arrows in the graphics area.

5. Apply corner treatment to the group.

The FeatureManager design tree groups the similar corners as Corner Group XX. In the
Corner Management PropertyManager, you can edit a group of similar corners and remove
a corner from the group. You can add this corner back to the group of similar corners, if
required.

• Right-click a corner of the group and select one of the following:

Removes the selected corner from the
group of similar corners

Right-click the removed corner and
select Include back to Corner group.

Remove from Corner group

Zooms in the selected cornerZoom to Selection

Degroups the corners

To degroup the corners, you can also
right-click the group and select Dissolve
Corner group.

Clear Selections

Lets you select the context menuCustomize Menu

You can use similar corner treatment for simple, two member, and complex corners.
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Pattern Connection Element PropertyManager

In the Pattern Connection Element PropertyManager, you can insert a connection element
that is at a corner to similar corners.

To access this PropertyManager, click Insert > Structure System > Pattern
Connection.

Pattern Connection Element PropertyManager
Select the connection element in the graphics area. Similar corners are highlighted with
arrows and previews of connection elements appear at the corners.

Displays the name of the selected
connection element.

Selected Connection Element

Lists similar corners on which you can insert
the connection element.
You can right-click a corner and select Skip
Instance to exclude a connection element.

Identify Similar Corners

Excludes corners with connection elements.Ignore corners that have connection
elements

Lists the corners that you excluded using
Skip Instance.

Instances to Skip
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Configuration-Specific Size of Weldment Members

If you select a set of weldment members of the same size and type, in the Profile tab,
you can change the size of the members for specific configurations.

Using Zoom to Selection for Corners

If the structural member has multiple corners, you can zoom to a corner from the
FeatureManager design tree or the Corner Management PropertyManager using Zoom
to Selection.

Configuring the Size for Configurations in Structure System

To configure the size for configurations of structure system:

1. Edit the structure system from the FeatureManager design tree.
2. Select the members in the graphics area.
3. Optional: To edit a specific member, in the graphics area, right-click the member,

and select Edit Feature.
4. In Profile tab, change the size.
5. Under Configurations, select specific configuration and click OK.

Structure System and Weldments Performance Improvement (2023 SP4)
Performance is improved when you create or edit a corner management feature.

A corner gets trimmed when you select it from the Corners group in the Corner
Management PropertyManager or in the graphics area.

Previously, corners were trimmed when you created or edited the corner management
feature.
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Performance is improved when you insert a structural member or change its profile to
the part that includes weld beads.
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8
Assemblies

This chapter includes the following topics:

• Automatically Optimize Resolved Mode
• Repairing a Missing Mate Reference
• Delete Missing Components from a Model (2023 SP1)
• Additional End Conditions for Cut Features
• Previewing a Replacement Component
• Specifying a Color for an Explode Line
• Selecting a Configuration for Skipped Instances
• Specifying a Default BOM Part Number
• Magnetic Mates
• Overriding Calculated Values in a Design Table
• Assembly Visualization
• Configuration Publisher: Updating a Multiple-Configuration Model
• Fix and Float Options When Inserting a Component (2023 SP2)
• Selecting Flexible Subassemblies and Components (2023 SP2)
• Width Mate Selections (2023 SP2)
• Displaying Component Descriptions and Configuration Descriptions (2023 SP3)
• Propagating Assembly Features to Parts Blocked for Toolbox Parts
• Assembly Performance Improvements
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Video: What's New in SOLIDWORKS 2023 - Assemblies

Automatically Optimize Resolved Mode

You can optimize resolved mode automatically. Using this system option improves
performance by selectively using lightweight technology when you load components in
resolved mode.

Not available when your environment includes SOLIDWORKS PDM.

Options for lightweight and resolved modes are hidden as the components load as resolved.
Lightweight states do not appear in the FeatureManager® design tree.

You can manually manage when to resolve lightweight components by selectingManually
manage resolved and lightweight modes.

Automatically load components lightweight is renamed to Load component
lightweight.

To automatically optimize resolved mode:

1. Click Tools > Options > System Options > Performance.
2. Under Assembly loading, select Automatically optimize resolved mode, hide

lightweight mode.
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Repairing a Missing Mate Reference

You can repair missing mate references for references to faces, edges, planes, axes, and
points.

SOLIDWORKS® repairs the missing reference for a component by selecting a reference
on the component that is in the same location and orientation to the missing reference.

For models that contain multiple missing mate references, right-click theMates folder

and click Auto Repair .

To repair a missing mate reference:

1. Open a model that contains a mate error.

2. Right-click the mate and in the context toolbar for the mate, click Auto Repair .

If SOLIDWORKS cannot repair the error, you are prompted to solve the mate
manually.
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Delete Missing Components from a Model (2023 SP1)

You can delete all missing components from a model in the Find References dialog box.

In the dialog box, Delete Missing References displays when the model has missing
components.

Delete Missing References does not delete missing external references like derived
parts, mirror parts, or split parts.

To delete missing components:

1. Open a model that has missing components.
2. Click File > Find References.

In the dialog box, under In Folder, File not found appears for the missing
components.

3. Click Delete Missing References.

The Confirm Delete dialog box opens.

If you previously selected Don't show again in the Confirm Delete dialog box, the
dialog box does not open, and the missing components are deleted when you click
Delete Missing References.

To show the dialog box, click Tools > Options and under
Messages/Errors/Warnings, click Dismissed messages. Clear Do you really
want to delete the following item(s)?.

4. In the Confirm Delete dialog box, click Yes to All to delete all the missing components.
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Additional End Conditions for Cut Features

More end conditions are available for cut features in assemblies.

You can select these options for Direction 1 and Direction 2:

• Up To Next
• Up To Vertex
• Up To Surface
• Offset From Surface
• Up To Body

To select an end condition for a cut feature:

1. Open a model and create a sketch.
2. Click Insert > Assembly Feature > Cut > Extrude.
3. In Direction 1, select an end condition.
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Previewing a Replacement Component

You can preview a replacement component in the Replace PropertyManager. You can
specify the scope of the replacement.

In the PropertyManager, Instances to replace replaces All instances. To specify the
scope of the replacement, select an option for Instances to replace:

Replaces only the selected instance.Only selected

Replaces all instances of the selected component that
are in the same assembly level.
If a selected component is in the top-level assembly,
only instances in the top level are replaced. If a selected
component is in a subassembly, only instances in the
subassembly are replaced.

All in same parent assembly

All instances of the component are replaced in the
assembly and all subassemblies.

All

To preview a replacement component:

1. Open a model and click File > Replace.

2. In Replace these component(s) , select a component.
3. For Instances to replace, select an option.

4. In the PropertyManager, select a component for With this one .

The selected component appears under Thumbnail Preview.
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Specifying a Color for an Explode Line

You can use a system option to specify an explode color. You can change the color of
explode lines in an exploded view.

To specify a color for an explode line:

1. Click Options > System Options > Colors.
2. Under Color scheme settings, select Sketch, Exploded.

To change the sketch color in an exploded view:

1. Open a model that has an exploded view.

2. In the ConfigurationManager tab, click to expand Exploded View .

3. Right-click 3DExplode and click Sketch Color .
4. In the Sketch/Curve Color PropertyManager, select a color.
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Selecting a Configuration for Skipped Instances

You can select This Configuration , All Configurations , or Specify

Configurations for skipped instances in assembly component patterns.

The configuration option is available for these assembly component patterns:

• Linear Component Pattern
• Circular Component Pattern
• Pattern Driven Component Pattern
• Sketch Driven Component Pattern
• Curve Driven Component Pattern

In a design table, you can use $skip@<type of pattern><number> to specify skipped
instances. For example, $skip@Lpattern1. If there is more than one skipped instance,
use a semicolon to separate values. For example: 10,1;10,2;.

To select a configuration for skipped instances:

1. Open a model with multiple configurations and edit a pattern feature.
2. In the PropertyManager, select an instance to skip and select This Configuration

, All Configurations , or Specify Configurations .
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Specifying a Default BOM Part Number

In a model, you can select Document Name or Configuration Name as the default Bill
of Materials (BOM) part number for new configurations.

This option does not apply to derived configurations.

The selected default value shows in the Configuration Properties PropertyManager under
Bill of Materials Options for Part number displayed when used in a bill of
materials.

To specify a default BOM part number:

1. Open a model and click Tools > Options > Document Properties.
2. Click Configurations.
3. Under Default Bill of Materials part number for new configurations, select

Document Name or Configuration Name.
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Magnetic Mates

You can suppress magnetic mates and connection points.

When you suppress a component, magnetic mates associated with the component are
suppressed. Suppressed connection points are not available when you create a magnetic
mate.

When you have unused connection points and move a component chain, magnetic mates
are no longer created between components within the chain. When you move a component,
the color for all connection points is magenta.

To suppress a magnetic mate:

1. Open a model that contains magnetic mates.

2. In the FeatureManager design tree, expand the Mates folder.

3. Right-click Magnetic Mate and click Suppress .

To suppress a connection point:

1. Open a model that contains magnetic mates.
2. In the FeatureManager design tree, expand a component and then expand Published

References .

3. Right-click Connector and click Suppress .

53

Assemblies



Overriding Calculated Values in a Design Table

When you close a design table that contains manually entered values for $SW-MASS and
$SW-COG, SOLIDWORKS prompts you to use either the manually entered values or the
values calculated from the model geometry.

The prompt provides these options:

Enables Override mass or Override center of mass
and assigns the manually entered values to the mass
properties.

Use the mass value
specified in the Design Table

Deletes the $SW-MASS column or the $SW-COG column
that has the manually entered values. The model uses
values calculated from the model geometry.

Use the mass value
calculated from the model
geometry

To override calculated values in a design table:

1. Open a model that has a design table with a $SW-MASS column or a $SW-COG column.
2. Clear the override properties:

a. Click Tools > Evaluate > Mass Properties.
b. Click Override Mass Properties.
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c. In the Override Mass Properties dialog box:

• For $SW-MASS, clear Override mass.
• For $SW-COG, clear Override center of mass.

If these override options are enabled, the prompt does not show and the model is
saved with the manually entered values.

3. In the ConfigurationManager tab, expand Tables .

4. Right-click Excel Design Table and click Edit Table.

5. In the table, manually enter values for $SW-MASS or $SW-COG.
6. Close the design table.
7. When prompted, select Use the mass value specified in the Design Table to

override the calculated values with the manually entered values.
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Assembly Visualization

In lightweight mode, SOLIDWORKS calculates more Assembly Visualization columns
without setting the lightweight components to resolved.

If SOLIDWORKS cannot calculate a column value for a component and you selectManually
manage resolved and lightweight modes and Prompt for Resolve lightweight
components, SOLIDWORKS prompts you to resolve the component.

To modify these options, click Options > System Options > Performance.

In the Custom Column dialog box, the columns display in alphabetical order. The Assembly
Visualization rollback bar increases in size when hovering over the bar. The font color is
black for all column values. You can add more than seven columns.

To view the Assembly Visualization improvements:

1. Open a model in lightweight mode.
2. Click Tools > Evaluate > Assembly Visualization.

All column values display in a black font color and the rollback bar is wider when you
hover over the bar. For calculated properties like Mass, the calculated values display
instead of 0.00.
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3. To open the Custom Column dialog box, in the Assembly Visualization panel, click
the arrow to the right of the column headers and click More.

4. In the dialog box, click Properties.

The columns display in alphabetical order.

Configuration Publisher: Updating a Multiple-Configuration Model

For models that have multiple configurations created with a custom PropertyManager,

the PropertyManager icon changes to after you manually add, delete, or rename a
configuration. Update appears when you right-click PropertyManager.

To update a multiple-configuration model:

1. Open a model with multiple configurations created with a custom PropertyManager.

Use Configuration Publisher to create a custom PropertyManager.

2. In the ConfigurationManager tab, add a configuration.

The PropertyManager icon changes to .

3. Right-click PropertyManager and click Update.

After clicking Update, the Excel design table opens, updates, and closes. The

PropertyManager icon changes to .
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Fix and Float Options When Inserting a Component (2023 SP2)

In the Insert Component PropertyManager, you can specify the position of a component
as Only fix first component, Fix, or Float.

You can select Float when inserting the first component. Previously, the default behavior
positioned the first component as fixed. You can use Only fix first component to position
only the first component as fixed in the model.

To specify a component position:

1. Create a new assembly.
2. Click Insert > Component > Existing Part/Assembly.
3. Select a part.

4. In the PropertyManager, click Keep Visible to keep the PropertyManager open.
5. Under Fix /float component on insert, select Only fix first component.
6. Insert the component twice.

The first component has a fixed position. The second component has a floating position.
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Selecting Flexible Subassemblies and Components (2023 SP2)

In the Advanced Component Selection dialog box, you can specify Flexible, Envelope,
and Excluded from BOM for Component Status. From the Select flyout, you can use
Select Flexible Subassembly to select flexible subassemblies in the model.

To select a value for Component Status:

1. Open a model.

2. On the Standard toolbar, click the Select flyout and click Advanced Select.
3. For Category1, select Component Status.
4. For Value, click the down arrow.

Flexible, Envelope, and Excluded from BOM are available as options.

To select flexible subassemblies:

1. Open a model that has a flexible subassembly.

2. On the Standard toolbar, expand the Select flyout and click Select Flexible
Subassembly.
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In the FeatureManager design tree, the flexible subassembly is highlighted.

Width Mate Selections (2023 SP2)
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In the Mates PropertyManager, the width mate options Width selections and Tab
selections are renamed to Width selections 1 and Width selections 2.

You can select the smaller selection set in eitherWidth selections 1 orWidth selections
2, and all constraint types are available. Previously, the tab selections had to have the
same or a smaller distance as the distance between the width selections. If the distances
are equal, only the Centered constraint type is available.

ForWidth selections 1, you can select a cylindrical face or an axis. Previously, only tab
selections allowed a cylindrical face or an axis selection.

To select a constraint type for width mates:

1. Open a model with a width mate where the selection sets are different sizes.

For example, this model has an existing width mate between two parts. The selection
set for Width selections 1 has a distance that is smaller than the selection set in
Width selections 2.

2. Edit the width mate and select Dimension for the constraint type.

Displaying Component Descriptions and Configuration Descriptions (2023
SP3)
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In the Insert Component / Begin Assembly PropertyManager, under Open documents,
the component name includes the component description. In the Replace PropertyManager,
under With this one, the component name includes the component description.

In the Modify Configurations dialog box and the Configuration Table dialog box, under
Configuration Name and Configuration, the configuration name includes the
configuration description. You can hover over the header of a parameter column to view
the component description.

Propagating Assembly Features to Parts Blocked for Toolbox Parts

Assembly features cannot be propagated to Toolbox parts.

In an assembly feature PropertyManager, SOLIDWORKS displays a warning and removes

any Toolbox parts from Components to Affect when you have Selected components
and Propagate features to parts selected.

When you select All components and Propagate features to parts under Feature
Scope and the model contains Toolbox parts, the warning does not appear. The assembly
features are not propagated to the Toolbox parts.

When Propagate features to parts is selected, you cannot select a Toolbox part.

For assembly features like fillets and chamfers that do not have the All components
and Selected components options, the warning does not appear and the assembly
features are not propagated to Toolbox parts. You cannot select a Toolbox part for a Hole
Series as this assembly feature is always propagated to parts.

To view the warning:

1. Open a model that contains a Toolbox part.
2. Select a sketch and click Insert > Assembly Feature > Cut > Extrude.
3. In the PropertyManager, under Feature Scope, clear Auto-select.

4. For Components to Affect , select a Toolbox part.
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5. Select Propagate features to parts.

SOLIDWORKS removes the Toolbox part from Components to Affect and the
warning appears in the graphics area.

Assembly Performance Improvements
Assembly performance is improved when:

• Searching with Include sub-folders selected.

To select this option, click Tools > Options > External References > Reference
Documents specified in File Locations > Include sub-folders.

• For assemblies that contain parts with multiple imported bodies and body level
appearances:

• Opening a file
• Changing a configuration
• Applying, modifying, or removing an appearance
• Rolling back or rolling forward assembly items

• Saving assemblies is faster as only changed model data is saved. This improvement
is noticeable in very large assemblies. Previously, SOLIDWORKS saved all model data
when an assembly or a component changed.
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9
Detailing and Drawings

This chapter includes the following topics:

• Overrides for Bills of Materials
• Displaying Transparent Models
• Filtering Bill of Materials Columns
• Component Name Display
• Limiting Geometric Tolerances to a Standard
• Detached Drawings
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Video: What's New in SOLIDWORKS 2023 - Drawings

Overrides for Bills of Materials

When you override a value in a bill of materials (BOM) using Break Link, the value turns
blue.

You can:

• Change the highlight color (default is blue) when you override values using Break
Link. Click Tools > Options > System Options > Colors, and specify the color for
Drawings, Modified Cells (BOM).

• Restore overridden values to their original values. Right-click a row, column, or the
entire BOM and click Restore Original Value.

• Prevent unwanted changes to BOMs. Click a table cell, row, or column, and click the

lock in the context toolbar. To unlock, click the lock in the context toolbar.
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Displaying Transparent Models

You can display transparent models in drawings with Hidden Lines Removed (HLR)

and Hidden Lines Visible (HLV) modes.

You can see through transparent bodies in HLR and HLV display states including
components in assemblies and bodies in multibody parts.

Available for High quality drawing views only.

To display transparent models:

1. Click Tools > Options > Document Properties > Detailing .
2. Select See through transparent components in HLR/HLV.
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Filtering Bill of Materials Columns

Filtering a bill of materials (BOM) lets you focus on what you need to see.

When you filter a BOM:

• You can filter a range of data based on your criteria. When you hover over the BOM
column headers, there is an arrow in each column.

• Only the balloons for the filtered items appear in the view.
• To filter BOM columns:

1. Click in the column to filter.
2. In the dialog box, select filter criteria.

The changes to indicating that the filter applies to the column.
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Component Name Display

When you specify display options for component names in a drawing, the names in the
PropertyManager and View Palette match those in the FeatureManager design tree.

To specify display options for component names:

1. In the FeatureManager design tree, right-click the drawing name and click Tree
Display > Component Name and Description.

2. (Optional.) Under Primary, specify an option:

• Component Name
• Component Description

Based on the selection under Primary display options:

• The Model View and Standard 3 View PropertyManagers update the Open documents
field.

• The View Palette updates. The View Palette displays the part or assembly icon and the
file name.

Limiting Geometric Tolerances to a Standard
You can choose all symbols for geometric tolerances or limit symbols to a standard with
the Allow tolerance symbols for all drafting standards option.

For example, if you select the ISO standard and clear Allow tolerance symbols for all
drafting standards, you limit the symbols and values to ISO standards.

If you select Allow tolerance symbols for all drafting standards, all symbols and
values are available regardless of the tolerancing standard.
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To limit geometric tolerances to a standard:

1. In a drawing, click Tools > Options > Document Properties > Annotations >
Geometric Tolerances.

2. Under Base geometric tolerance standard, select:

a. A standard.
b. Clear Allow tolerance symbols for all drafting standards.

Detached Drawings
Detached drawings are no longer supported.

Detached drawings are no longer supported as of SOLIDWORKS 2023. Detailing mode is
available. Existing detached drawings continue to work as they do today. Once you save
a detached drawing back to a regular drawing, you cannot save it as a detached drawing
in SOLIDWORKS 2023.
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10
Import/Export

This chapter includes the following topics:

• Import of Third-Party CAD Files (2023 SP2)
• Import System Options (2023 SP2)
• Exporting Large Assemblies as STEP Files
• Improved Display of CGR Files (2023 SP2)
• Installing the 3DEXPERIENCE Exchange Add-In
• OBJ Mesh Import Improvements

Import of Third-Party CAD Files (2023 SP2)
Performance of importing third-party CAD files is improved with 3D Interconnect. You
can import third-party CAD files without creating 3D Interconnect links faster.

Import System Options (2023 SP2)
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The system options for importing third-party CAD files with links using 3D Interconnect
are improved for usability.

To access the import system options:

1. Click Tools > Options > System Options > Import.
2. Select Enable 3D Interconnect. When selected, you can specify additional options:

• Create 3D Interconnect links. Imports the 3D Interconnect feature and
component links. (Third-party files consist of multiple components (for assemblies)
and each component has features.)

• Feature and Component Level or Feature Level. Displays the component links
and feature links with an arrow symbol on each component and feature in the
FeatureManager design tree after import.

When you import, the component and feature links have an arrow on each component
and feature in the FeatureManager design tree.

After importing the file with links, you can manually break the links by
right-clicking and selecting Break Link in the FeatureManager design
tree. The output of the link depends on the following options:

• Create external files. Breaks the 3D Interconnect component link and
creates the resulting part or assembly as an external file.

• Create virtual components. Creates the resulting part or assembly as
an internal file (virtual component).

Exporting Large Assemblies as STEP Files
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You can export large SOLIDWORKS® assemblies as STEP files.

In Tools > Options > System Options > Export > STEP, select Export assembly
components as separate STEP files (recommended for large assemblies). This
option exports assemblies as atomic STEP files. Separate STEP files get created for each
component in the assembly.

Improved Display of CGR Files (2023 SP2)

When you import *.cgr files, facet fins are always hidden, which delivers models that
are visually equal to SOLIDWORKS models. The amount of time to open *.cgr files is
reduced.

If you import *.cgr files as mesh BREP bodies, you have the option to display or hide
facet fins. In Tools > Options > System Options > Display, select or clear the option
Display facet fins in mesh BREP bodies.

This option does not affect the display of regular edges on mesh BREP bodies, which
includes edges created directly on import or created later with the Segment Imported
Mesh Body tool.

Previously, imported *.cgr files always displayed facet fins and did not visually match
SOLIDWORKS models.
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Installing the 3DEXPERIENCE Exchange Add-In

The 3DEXPERIENCE Exchange add-in installs by default with your installation.

The 3DEXPERIENCE Exchange add-in lets SOLIDWORKS users safely work with a package
of content from a 3DEXPERIENCE source, such as SOLIDWORKS Connected or the Design
with SOLIDWORKS app. SOLIDWORKS users can seamlessly open the package, modify
files, and return the 3DEXPERIENCE content package to the 3DEXPERIENCE source.

To enable the add-in, in SOLIDWORKS, click Tools > Add-ins and under Other Add-ins,

select 3DEXPERIENCE Exchange. The 3DEXPERIENCE Exchange appears in the Task
Pane.

See SOLIDWORKS Help: Import and Export > 3DEXPERIENCE Exchange.

OBJ Mesh Import Improvements
Textured .OBJ import by ScanTo3D is improved.

.OBJ import to graphics body supports textures, excluding bump maps.
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11
SOLIDWORKS PDM

This chapter includes the following topics:

• Managing Deleted Users
• Configuring Transition Actions
• Adding Tooltips to the Data Card Controls
• Automatic login to the Administration Tool
• Data Card Controls (2023 SP2)
• Performance Improvements for File Version Upgrade Tool
• Logging File Retrieval Operations
• Support for Microsoft Edge WebView2-Based Controls
• Removing Computers from the Task Execution List
• Display Groups for Inherited Permissions
• Notification Templates
• Synchronizing Users with Windows Active Directory (2023 SP1)
• Days in State Variable (2023 SP1)
• Archive Workflow States (2023 SP2)
• Grid View in Web2 (2023 SP2)
• Administrative Permissions for Tasks (2023 SP2)
• SOLIDWORKS PDM Performance Improvements (2023 SP04)
• Other SOLIDWORKS PDM Enhancements

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately
purchased license for non-SOLIDWORKS users. It offers standard data management capabilities
for a small number of users.

SOLIDWORKS PDM Professional is a full-featured data management solution for a small and
large number of users, and is available as a separately purchased license.
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Video:What's New in SOLIDWORKS 2023 - SOLIDWORKS
PDM

Managing Deleted Users

You can use the Administration tool to restore deleted users and to refuse login to users.

You must have Can administrate users administrative permission.

To restore a deleted user, expand Users and Groups Management, right-click Users,
and select Deleted users. In the Deleted Users dialog box, select the user in the Restore
login column.

To refuse login to a user, expand Users and Groups Management, right-click Users,
and select Open. In the Users dialog box, select a user in the Refuse login column.

Deleted Users Dialog Box

Use the Deleted Users dialog box to restore the login for deleted users.

To display this dialog box:

Expand Users and Groups Management, right-click Users, and select Deleted users.

Name the user enters in the login dialog box.Name
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The user's full name.
The default is the user's login name.

Full Name

The user's initials.
The default is the first letter of the user's login name.

Initials

ID that is unique for each user.ID

When selected, restores the login of the selected user.Restore login

Displays a warning message if the login name you are
attempting to restore is already active.

Warning

To save changes, click Save or close the dialog box and click Yes when prompted to save
changes.

Configuring Transition Actions

The variable list in the Transition Action dialog box includes the user properties fields that
were introduced in SOLIDWORKS PDM 2022.

These fields are:

• First name
• Last name
• Middle name
• Prefix
• Suffix
• E-mail
• E-mail2
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• E-mail3
• User Data
• User Data2
• User Data3
• Work phone
• Home phone
• Cellphone
• Company
• Department
• Job title
• Office
• Address
• Zipcode
• City
• State
• Country

These are available under the User list and administrators can use these fields in the
following transition actions:

• Import data from XML
• Inc. Revision
• Send Mail
• Set Variable

Adding Tooltips to the Data Card Controls

In the Card Editor, you can add tooltips to the data card controls.

In the Tooltip pane, enter the Title and Body of the tooltip.
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You cannot specify tooltips for tab and frame controls.

In SOLIDWORKS PDM File Explorer, when you hover over the corresponding data card
control, the tooltip displays.

Automatic login to the Administration Tool

You can configure SOLIDWORKS PDM to log you in to the Administration tool using a
specific name or the name of the current Microsoft® Windows® profile.

In the Administration tool, under Local Settings, double-click Settings or right-click
Settings and click Open.

In the dialog box, under Administration Login, select a Vault and Use automatic
login for this vault. You can specify:

• Login as the following user. Logs you in using the specified user name and password.
• Log in as the currently logged in user in Windows. Logs you in using the user

name and password of the current Microsoft Windows profile. (Available only for vaults
that are configured to use a Microsoft Windows login.)
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Data Card Controls (2023 SP2)

You can apply control logic in data cards more easily.

In addition to the Control menu, you can also access the Control Logic command when
you:

• Click in the Controls toolbar.
• Click Control Logic in the properties pane.

Not available for card search control and variable search control.

When adding control logic, you have more flexibility in selecting the behavior of a control.
In the Control Logic dialog box, the Hide - Clear value and Hide - Retain value options
let you specify whether the hide action in the control logic clears or retains the value.
Previously, only the Grey out and Hide options were available.

In the Controls toolbar, if you select Show Controls with Control Logic, an indicator
appears in the top-left corner of the controls that have control logic applied.
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You can also configure the Find User command type for a button control to return more
user properties. Previously, only Login name was available as the user value to populate
the Destination variable for the Find User list.

Performance Improvements for File Version Upgrade Tool
You can upgrade SOLIDWORKS files in a SOLIDWORKS PDM vault faster.

If you are upgrading assembly files and you select Overwrite and Latest Version in
the Version Settings page, the software skips upgrading and uploading references that
are not the latest in the assembly's as-built version. This improves the performance of
the upgrade process.

Logging File Retrieval Operations
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You can maintain a server-side log of files retrieved for a vault. (SOLIDWORKS PDM
Professional only.)

To enable logging, in the Administration tool, right-click a vault and select Properties.
In the File Vault Properties dialog box, under Logging operations, select Get. This
enables logging of the Get operation for the vault on all archive servers.

You must have File vault management administrative permission.

To view the file retrieval log, in the Administration tool, right-click a vault, and select
Show the Get Log. The Log File dialog box displays log information for each file in the
vault that is downloaded from the archive server to the local view of a client machine,
Web2 server, or Web API server.

Log File - Get Operations Dialog Box

The Get Operations dialog box lets you view informational and error events for the files
retrieved for a vault on all archive servers.

To display the log file:

In the Administration tool, right-click a vault, and select Show the Get Log.

Event type: error, informational, or warning.Type

Date and time of the event.Date

Method used to invoke the Get operation:
• Desktop client
• COM API
• Web API
• Web2 server

Description

Name of the destination machine that receives data from the
archive server.

Destination Machine

IP address of the client machine

For file retrieval operations through Web2 or Web API
servers, the IP address of the server machine is logged.

Client IP Address

Login name of the user who performed the Get operation.User

ID of the documentDocument ID

Name of the documentDocument Name

Version of the documentVersion

Path of the document in the vaultDocument Path

Name of the archive server on which the event occurred.Archive Server
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Support for Microsoft Edge WebView2-Based Controls
In SOLIDWORKS PDM, the Internet Explorer-based controls are replaced with
WebView2-based controls.

This applies for:

• Preview pane in SOLIDWORKS PDM File Explorer. You can preview the HTML documents
that are present in the vault.

• EXALEAD OnePart Search view
• Web Card Configuration Editor dialog box

You must have the WebView2 runtime installed on your machine.

Removing Computers from the Task Execution List

You can remove computers from the list of hosts that support task execution.

In the Administration tool, open the task's Properties dialog box. In the left pane, click
Execution Method. In the Computers supporting the task list, right-click a computer,
and select one of the following:

• Remove from Add-in Name. This removes the computer as a supported host for all
tasks that use the same add-in.

• Remove from All Add-ins. This removes the computer as a supported host for all
task add-ins.

A confirmation message lists all the affected tasks.

The Task History dialog box displays a list of computers that are removed for that task.
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Display Groups for Inherited Permissions

In the Administration tool, in the user Properties pages, you can hover over the group
icon of a permission to view the groups from which the permission is granted to the user.

A pop-up dialog box appears that lists these groups.

Notification Templates
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SOLIDWORKS PDM lets administrators customize the templates for automatic notifications
for a vault. This helps to display information that is more relevant to the user.

• You must have Can update mail configuration administrative permission.
• You can customize notifications only for files and not for items and Bills of Material

(BOMs).

You can customize notification templates for the following file operations:

• Added
• Changed State
• Checked In
• Checked Out
• Delayed in State

You can edit the subject and body of the template in HTML format and also use variables
in the notification message.

You can also export notification templates. To export:

• All notification templates. Right-click the Notification Templates node and select
Export.

• File notification templates. Expand Notification Templates, right-click File
Notifications, and select Export.

• The notification template for a file operation. Expand Notification Templates > File
Notifications, right-click a file operation, and select Export.

Customize Notification Dialog Box

This dialog box lets you customize the templates for automatic notifications for a vault.

To access this dialog box, do one of the following:

• Expand Notification Templates > File Notifications, right-click a subnode, and
select Open.

• Expand Notification Templates > File Notifications, and double-click a subnode.
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Displays the name of the notification template. This field is
read-only.

Name

Displays how the template appears to users.Preview

Lets you select either of the notification templates:

• Default
• Custom

If you select Custom, the fields listed below in the table are
enabled. This lets you customize the notification template.

Template

Displays the notification subject. You can edit the notification

subject for custom notifications. To include variables, click
and select a variable.

Subject

Displays the notification body. You can edit the notification

body for custom notifications. To include variables, click
and select a variable.

Body

Imports HTML text into the body of the notification.Load from File

Resets the notification template to the default template.Reset

Synchronizing Users with Windows Active Directory (2023 SP1)
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You can synchronize users and groups in a vault with Windows® Active Directory as an
on-demand operation.

You must have Can administrate users administrative permission.

You can define preferences for sync in the Active Directory Sync Settings dialog box. To
access this dialog box, right-click the Users and Groups Management node and select
Active Directory Sync > Settings.

To perform Active Directory sync, right-click the Users and Groups Management node
and select Active Directory Sync > Run Sync.

The Update from Active Directory command is now also available for Windows users
in a vault. Previously, it was available only for Windows groups in a vault.

Active Directory Sync Settings Dialog Box

Use the Active Directory Sync Settings dialog box to define preferences for on-demand
sync of users and groups in a vault with Windows Active Directory.

To access this dialog box:

Right-click the Users and Groups Management node and select Active Directory
Sync > Settings.

Groups

Removes Windows groups from SOLIDWORKS PDM vault that
no longer exist in Active Directory.

Remove Groups

Update Groups

Adds existing users or creates new users in the vault based on
the group membership in the Active Directory group.

Creates new users in a vault even if
they are not found on the archive
server.

Add users not found
on the archive server

For new users, copies permissions
and settings from the selected user.

Copy permissions
and settings from

Add users

Removes Windows users from the SOLIDWORKS PDM group
who are no longer members of the Active Directory group.

Remove users from
group

Updates Windows user properties for existing members of a
Windows users group with the attributes of the user account
in Active Directory.

Update users
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Users

Adds new Windows users that exist in users and groups defined
in the Windows login settings on the archive server but not in
the vault.

For new users, copies permissions
and settings from the selected user.

Copy permissions
and settings from

Add users

Removes Windows users from the vault if they no longer exist
in the Windows login settings on the archive server.

Deletes the user from the
SOLIDWORKS PDM vault.

Delete

Specifies the Refuse Login option
in the Administrative permissions
page of user properties.

Refuse login

Remove users

Updates user properties for existing Windows users with the
attributes of the user account in the Active Directory.

Update users

Days in State Variable (2023 SP1)
In the Customizable Columns dialog box, for a column, you can select Days in State as
Variable.

This system variable is available for the following column set types:

• File List
• Quick Search Result
• Search Result
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Archive Workflow States (2023 SP2)

You can archive a workflow state that is not connected to any transition. This lets you
see a workflow without any obsolete states in the view. Administrators can view archived
states and unarchive them.

You cannot archive states that are connected to other states.

On the Workflow toolbar, click to display the Workflow State Archive pane. In this
pane, you can view all the archived states. You can also sort the list alphabetically.

To archive a workflow state:

• Right-click the state and select Archive.
• Drag the state to the Workflow State Archive pane.

To unarchive a workflow state:

• In the Workflow State Archive pane, right-click the state and select Unarchive.
• Drag the state from the Workflow State Archive pane to the workflow.
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Grid View in Web2 (2023 SP2)

In the Web2 client, you can see a grid view of thumbnail previews in file lists and search
results.

The grid view layout is available in the following pages of large screen and small screen
layouts:

• File or folder list
• Search results

To switch the layout from the list view to the grid view:

• In the large screen layout, click and select Grid View. In this view, you can click

and select a direction and parameter to sort the list.
• In the small screen layout, touch the ellipsis, expand List View, and then select Grid

View. To sort the list, expand Sort By and select a direction and parameter.

The Select All and Deselect All options are available in the grid view layout.

To view more information for a file, you can access the File View tabs through the quick
links menu. To access this menu in:

Hover over a row and click or right-click the file.List view

Click or right-click the file.Grid view
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The quick links menu is available only in:

• File or folder lists
• File details view
• Search results

Administrative Permissions for Tasks (2023 SP2)
Administrative permissions for tasks are redefined.

DescriptionPermission

View the task list and perform all the actions that are available
in the Task List dialog box.

Can view task lists

Create and modify tasks.Can update task
settings

SOLIDWORKS PDM Performance Improvements (2023 SP04)
SOLIDWORKS PDM 2023 makes significant performance improvements in the presence
of high latency to SOLIDWORKS PDM servers.

The improvements might vary depending on the amount of latency, size of datasets,
and operations.

• The following operations perform better when latency to the database server is high:

• Check-in
• Check-in with automatic transition
• Undo Check-out
• Interactive operations such as menus, shortcut menus, reference dialog boxes,

SOLIDWORKS PDM File Explorer tabs

• The following operations perform better when latency to the archive server is high:

• Add files
• Change state on file modifications
• Get files
• Get latest version of files

In SOLIDWORKS PDM 2023 SP04, the mechanism for loading of SOLIDWORKS PDM and
custom add-ins is reworked. As a result, operations such as logging in to a vault and
starting the SOLIDWORKS PDM Search tool perform significantly better.
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Other SOLIDWORKS PDM Enhancements
SOLIDWORKS PDM 2023 offers enhanced data security, support for the latest Windows®
operating system, and other improvements.

• SOLIDWORKS PDM encrypts all the data traffic to and from the archive server.
• SOLIDWORKS PDM 2023 supports the Windows® 11 operating system.
• In SOLIDWORKS PDM File Explorer, you can copy static text from data cards.
• The language for the user interface of eDrawings® Web Viewer follows the language

specified in Web2.
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12
SOLIDWORKS Manage

This chapter includes the following topics:

• Automatic Update of Mapped Linked Record Properties
• Using the New From Option
• Task Administration Access
• Linked Record BOM Compare Field Selection
• Support for Variable Driven BOM Quantities
• Timesheets to Approve Node
• Cancelled Task Line in Capacity Planning
• Capacity Planning User Efficiency
• Hide Labels
• Marking Tasks as Complete
• Task Snooze Reminder Time
• Tasks Board Time Display

SOLIDWORKS® Manage is an advanced data management system that extends the global file
management and application integrations enabled by SOLIDWORKS PDM Professional.

SOLIDWORKS Manage is the key element in providing Distributed Data Management.
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Automatic Update of Mapped Linked Record Properties

You can update mapped properties automatically to connect primary references and the
linked record they are associated with.

The Linked Record updates when the Primary Reference changes and the record is
checked in. Previously, you must check out the linked record and click Get values from
Primary Reference. You can define each mapped field to update automatically.

Updating Mapped Fields Automatically

1. In the SOLIDWORKS Manage Administration Settings tool, edit the Primary Reference
object.

2. On the Linked Record Object wizard page (for PDM objects) or on the Linked Record
tab for document objects, click Configure.

3. On the Fields Mapping wizard page:
a) Select the check box in the Update Automatically column for the field to update

automatically.
b) In the right pane, for Linked Record with the status, select a status to update

when the primary reference is updated.
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Using the New From Option

New From lets you copy a field within an object to create new fields with the same
settings.

It saves the time required for administrators to configure objects.

New From is not available when you configure BOM fields or process item fields.

To use the New From option:

1. In the Administration tool, edit an object or right-click an object in the main user
interface.

2. Navigate to the Fields tab or wizard page.
3. Right-click a field and select New From.
4. In the New From dialog box, enter a display name for the new field and do one of the

following:

• Click Save to create the new field and close the dialog box.
• Save and create a new field based on the originally selected field.
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Task Administration Access

You can open the Task Administration dialog box using the Tasks option.

To open the dialog box, in the Administration tool, click All Tasks > Administration >
Tasks.

Linked Record BOM Compare Field Selection
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When you compare a linked record BOM to the BOM of its primary references, you can
select fields to compare.

For example, when you assign a new part number to the linked records, the field is always
different from the primary reference part number. So you can exclude this field from
comparison because it always shows a difference.

Support for Variable Driven BOM Quantities

SOLIDWORKS Manage reads the BOM quantity from a SOLIDWORKS PDM variable set
and uses it for the UNIT_OF_MEASURE attribute.

Previously, SOLIDWORKS Manage used the instance count for the UNIT_OF_MEASURE
attribute.
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Timesheets to Approve Node

Timesheets to approve lets you see the timesheets that a user needs to work on, to
complete the timesheet approval process.

Cancelled Task Line in Capacity Planning
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You can see the number of hours of cancelled tasks in the Cancelled row of the User
Details dialog box.

The Assigned Tasks row displays total assigned task hours including the cancelled task
hours. The Available capacity row displays assigned task hours minus cancelled task
hours.

Capacity Planning User Efficiency
When you view user details, the Efficiency (%) value that appears in the Capacity
Planning dialog box is applied to the user’s time.

Previously, the Efficiency in user details was 100% regardless of the setting in the
Capacity Planning dialog box.

Hide Labels

Hide Labels lets you hide captions. This creates more space in the software so you can
see the displayed tabs on the user interface.

To hide captions for the following items, right-click tabs, and select Hide Labels:

• Bottom tabs in the main user interface for all objects
• Property card tabs for processes
• Administration for document and record objects (not SOLIDWORKS PDM)
• Administration for relationships and resource objects

To hide labels for property cards for document and record objects, click .
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Marking Tasks as Complete

In the System Administration dialog box, you can select a check box that enables Mark
as Completed for a task that is assigned to multiple users.

Previously, the assigned user must enter the required time in the progress area to mark
the task as complete.

Task Snooze Reminder Time
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The SOLIDWORKS Manage Reminder saves the last task snooze time.

If you want to keep the same reminder time, only click Snooze. Previously, the task
snooze time was 5 minutes by default so every time user must change the time.

Tasks Board Time Display

The Tasks Board displays the time required for completion, total assigned time, and
number of due days until the next task.

The text is color coded depending on the state of the task. Green indicates complete
tasks, red indicates overdue tasks, and gray indicates tasks that are not overdue.
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13
SOLIDWORKS Simulation

This chapter includes the following topics:

• Bonding Interactions
• Diagnostic Tools
• Linkage Rod Connector
• Penalty Stiffness Control for Contact
• Simulation Solvers
• SOLIDWORKS Simulation Knowledge Base (2023 SP1)
• Underconstrained Bodies

SOLIDWORKS® Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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Video:What's New in SOLIDWORKS 2023 - SOLIDWORKS
Simulation

Bonding Interactions

An improved surface-to-surface bonding algorithm enforces bonding interactions for faces
that are not facing each other and have no projection area between them.

A pair of faces qualifies for bonding if these conditions apply:

• The angle between the faces is less than a threshold value.

If the angle between the faces exceeds the threshold value, the pair of faces does not
qualify for bonding.

• At least one face of the pair is a flat face (selected as Set 1 or Set 2 in the Local
Interactions PropertyManager).

The solver considers the flat face as the target face to enforce bonding. The source
face can be either flat or curved.

The enhanced bonding algorithm applies to the surface-to-surface formulation and is
available for bonded interaction sets that you define using the Local Interactions
PropertyManager. It applies to these studies: linear static, frequency, buckling, linear
dynamic studies, and also fatigue and design studies associated with linear static studies.
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Diagnostic Tools

You can access the diagnostic tools available for simulations from the CommandManager.

To access the diagnostic tools:

From the Simulation toolbar, click Diagnostic Tools.

Linkage Rod Connector
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The application of Linkage Rod connectors is extended to nonlinear static and nonlinear
dynamic studies.

You can specify a Linkage Rod connector between cylindrical faces, circular edges (for
shells), or vertices to model the behavior of connecting rods.

To open the Linkage Rod PropertyManager:

In the simulation study tree, right-click Connections and click Linkage Rod .

You can list a linkage rod connector's forces such as shear force, axial force, bending

moments, and torque after you run a simulation. Right-click Results and click List
Connector Force.

Penalty Stiffness Control for Contact

You can specify a scale factor for the penalty stiffness for contact that is used in linear
static studies.

SOLIDWORKS Simulation uses a default scale factor of 1.0 for the penalty stiffness to
reach an accurate solution for linear static studies with contact interactions. However,
you can select a lower scale factor to obtain an approximate solution faster to assess
design iterations and the overall behavior of a model.

You can set the study-level scale factor for the penalty stiffness in the Study Properties
dialog box. For global-level settings, select Simulation > Options > Default Options
> Interactions.
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Simulation Solvers

Function-based processing for the FFEPlus iterative solver is extended to frequency and
buckling studies, and to the linear static studies that include node-to-surface interactions
and virtual wall definitions.

• FFEPlus Iterative Solver

The transfer of stiffness data to solve the systems of equations is optimized for linear
static, frequency, and buckling studies because file-based processing is replaced with
function-based processing. Solution performance is improved for frequency and buckling
studies. The image illustrates the solution performance for a typical frequency study.

In addition, solution performance is improved for linear static studies that contain:

• Node-to-surface bonding and contact interactions
• Virtual wall definitions

• The FEEPlus and Large Problem Direct Sparse solvers can now handle multiple
translational and rotational degrees of freedom that are applied remotely with the
distributed connection type.
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SOLIDWORKS Simulation Knowledge Base (2023 SP1)

The SOLIDWORKS Simulation Knowledge Base articles have migrated from the
SOLIDWORKS Knowledge Base portal to the Dassault Systèmes Knowledge Base portal.

The hyperlinks to the Knowledge Base articles that appear in the simulation solver error
messages direct you to the Q&A articles in the Dassault Systèmes Knowledge portal.

You can use the Solution ID of an article published in the SOLIDWORKS Knowledge Base
to search for the corresponding Q&A article in the Dassault Systèmes Knowledge Base.
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Underconstrained Bodies

In SOLIDWORKS Simulation Professional and SOLIDWORKS Simulation Premium, for
static studies only, the Underconstrained Bodies algorithm includes contact interactions
and bolt connectors when detecting rigid (or free) body modes of components.

In SOLIDWORKS Simulation Standard and SOLIDWORKS Premium, the Underconstrained
Bodies algorithm does not include these improvements and remains unchanged from
previous releases.

To open the Underconstrained Bodies PropertyManager:

In the Simulation study tree, right-click the Connections node, and click Find
Underconstrained Bodies.

The improved algorithm offers the following advantages compared to the legacy
Underconstrained Bodies functionality:

• Faster detection of free body modes because the solver performs Singular Value
Decomposition (SVD) over the reduced stiffness matrix.

• Inclusion of contact interactions and bolt connectors when analyzing free body modes.
• Realistic visualization of free body modes in planes that are inclined to the orthogonal

planes that are defined by the global X-, Y-, and Z-axes.
• Improved visualization of unconstrained displacements for the whole assembly.
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14
SOLIDWORKS Visualize

This chapter includes the following topics:

• Color Picker
• DSPBR Material Support
• Importing Options
• Interactive Images (SW2023 SP2)
• PhotoView 360
• Shadow Catcher Support with Stellar Physically Correct (2023 SP2)
• Stellar Physically Correct
• System Info
• Sunlight Environment
• Transform Manipulator
• Render Wizard

SOLIDWORKS® Visualize is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application.
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Video:What's New in SOLIDWORKS 2023 - SOLIDWORKS
Visualize

Color Picker

In the Color Picker, you have more ways to define colors, you can display recently used
colors, and you can import and export color swatch palettes.

The Color Picker includes two tabs: Color and Swatches.

On the Color tab you can:

• Define color codes including:

• CMYK, which lets you modify color through CMYK components.
• HEX, which lets you view and edit the hexadecimal code.

• Access the most recently used colors in Recent Colors.

On the Swatches tab you can:

• Click Import Swatch Palette to import existing color swatch palettes from:

• SOLIDWORKS Palettes (.sldclr)
• ACO files (.aco)
• SVG files (.svg)
• HTML files
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• Click Export Swatch Palette to export color swatch palettes from SOLIDWORKS
Visualize and use them in SOLIDWORKS.

• Select preset swatch palette libraries such as Bright, Pastel, and Grayscale.
• Manage existing or new swatch palettes by adding, naming, duplicating, deleting, and

locking them.

DSPBR Material Support

In the Preview render mode, display has improved for Physically Based Rendering (PBR)
materials, as well as NVIDIA® Material Definition Language (MDL) appearances, and AxF™
appearances.

Improvements include the display of:

• Physically based rendering appearances for better render consistency.
• Materials that use texture distilling in the background, such as MDL and AxF

appearances.
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Importing Options

When you import SOLIDWORKS parts and assemblies in SOLIDWORKS Visualize, the
Part Grouping options include only two choices to streamline the import process.

To access the importing options:

1. Open a project.
2. Click File > Import.
3. Browse to a .SLDPRT or .SLDASM and click Open.
4. In the dialog box, on the Geometry tab, specify Part Grouping options.

Part Grouping includes:

• The Part Grouping menu, which provides two choices when importing SOLIDWORKS
.SLDPRT or .SLDASM files.

• Component/Part/Body

• Creates nested SOLIDWORKS Visualize groups for SOLIDWORKS assembly
components down to the SOLIDWORKS parts and bodies.

• Creates nested groups for subassembly components, mirror components, pattern
components, and SOLIDWORKS folders.

• Refines SOLIDWORKS Visualize parts based on appearance assignments in each
SOLIDWORKS body.

• Imports saved SOLIDWORKS configurations, animations, and supports Monitor
File functionality.

• Appearance

• Creates a SOLIDWORKS Visualize part based on every unique SOLIDWORKS
appearance.

• Combines SOLIDWORKS geometry having the same appearance into a single
SOLIDWORKS Visualize part.
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• Imports saved SOLIDWORKS configurations.
• Does not import saved SOLIDWORKS animations and does not support Monitor

File functionality.

Imported part names are based on their ancestry. Previously, the name was based on
the imported appearance.

Interactive Images (SW2023 SP2)

You have more ways to display interactive images.

You can:

• Scale the output file in web browsers.

• Switch (toggle) between Actual and Fit . To resize the image to its native
resolution, click Actual. To fit the image to the screen, click Fit.

• Lock the actual size of the image.
• Generate .html files when rendering images.

• To generate an .html page, double-click the .html thumbnail (Open.html).

• Scrub through a web-compiled image of animations.
• Export files in output formats including .png and .jpg. Previously, the output format

was in .jpg only.
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PhotoView 360
SOLIDWORKS 2023 SP5 is the last supported release of PhotoView 360.

Shadow Catcher Support with Stellar Physically Correct (2023 SP2)

Stellar Physically Correct supports the shadow catcher feature and the ambient occlusion
output layer.

You can:

• Simulate any geometry as a shadow catcher to receive shadows from the scene lighting.
• Render an ambient occlusion layer to boost contrast in areas including small crevices

and corners.

• Use ambient occlusion for Accurate mode when rendering with NVIDIA® Iray®.
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Stellar Physically Correct
Stellar Physically Correct yields photo-realistic rendering results.

SOLIDWORKS Visualize supports Stellar Physically Correct, Dassault Systèmes Global
Illumination renderer, using the Deep Learning AI Denoiser for optimal rendering
performance. It is designed to run on high-performance devices like GPUs or multicore
CPUs.

To use Stellar Physically Correct:

1. Click Tools > Options > 3D Viewport.
2. Under Render Engine, select Stellar Physically Correct.

System Info
In the System Info dialog box, you can view the requirements and hardware status of a
given renderer and every GPU on your system.

To access the System Info dialog box, click Help > System Info.

Because SOLIDWORKS Visualize supports multiple renderers, the System Info dialog
box only reports on the renderer actively running on your system. To select a renderer,
click Tools > Options > 3D Viewport. Under Render Engine, select a renderer.

Sunlight Environment
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With a sunlight environment, you can stage a model under a realistic sky and light from
the sun at a specific time of year and location on earth.

To create a sunlight environment, click New Project > Scenes > New Sunlight
Environment or import sunlight data from SOLIDWORKS. In SOLIDWORKS, click
SOLIDWORKS Visualize > Export Advanced.

You can:

• Specify the north direction using the compass manipulator.

• Specify an exact date, time, location, and time zone.

• Use the Animation Wizard to animate the sunlight environment and study the
design over the course of time.

Transform Manipulator
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You can use the transform manipulator to move, scale, and rotate objects in a scene.

Previously, you had two separate tools to move and rotate and another to scale. The
transform manipulator includes move, rotate, and scale in one tool.

To use the transform manipulator:

1. On the toolbar, click Selection Tool > Model .
2. In the 3D Viewport, select the target model.

3. On the toolbar, click Object Manipulation Tools > Transform .

The transform manipulator appears on the selected model.

4. Use the table below to use the transform manipulator.

DescriptionAction

Select an axis and drag to move the
object along that axis. Use the green, red,

Move the model

or blue planes to move the objects in
those planes.

Select a ring around an axis and drag to
rotate the object around the axis.

Rotate the model

Select a red, green, or blue cube to scale
the object along that axis. Use the yellow
cube to scale uniformly.

Scale the model

When you select a handle and drag, the main gray circle and the handle you drag
appears. The rest of the transform manipulator is hidden while you drag.

Keyboard shortcuts allow for quick access to functionality without using the transform
manipulator.
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DescriptionKeyboard Shortcut

Move selection in the camera plane.g

Rotate selection in camera planer

Scale selection uniformlye

Move, rotate, or scale locked to the X-axisg/r/e followed by x

Move, rotate, or scale locked to the Y-axisg/r/e followed by y

Move, rotate, or scale locked to the Z-axisg/r/e followed by z

Move, rotate, or scale locked to the YZ planeg/r/e followed by Shift + x

Move, rotate, or scale locked to the XZ
plane

g/r/e followed by Shift + y

Move, rotate, or scale locked to the XY planeg/r/e followed by Shift + z

Render Wizard

The Render Output Wizard simplifies the process of specifying parameters and creating
presets for rendering output. It makes it easier for you to create high quality, realistic
images, videos, and interactive experiences the way you want them.

The wizard provides an easy to use interface for setting up five render types:

• Snapshot
• Images
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• Animations
• 360 panoramic views for virtual reality
• Interactive views for websites

When you select a render type, the wizard steps you through all the parameters available
for that type. Depending on the render type, these parameters can include settings for
media (image formats), size, image quality, animation, and interactive experiences.

The wizard also makes it easy to create render presets and reuse them every time you
want to generate output with the same settings.

To use the Render Output Wizard:

1. In the main toolbar, click Render Wizard .
2. In the Welcome page, select the render Type and select a render Preset from the

list or create a preset using the Smart Control Bar.

3. Navigate through the steps presented by the wizard to adjust the parameters available
for the render type.

4. Do one of the following:

• Click Render to begin the rendering process.
• Select Queue in the rendering options to add the current rendering to the

SOLIDWORKS Visualize Queue so you can render it later.

When finished, the rendering is saved in the Images library at SOLIDWORKS Visualize
Content\Images.
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15
SOLIDWORKS CAM

This chapter includes the following topics:

• Barrel Tool Support
• Geometry Tab in Operations Parameters Dialog Box
• Improved Leadin and Leadout Calculations for Contour Mill Toolpaths
• Lines Only Option in VoluMill Toolpath
• Update to Machine to Mean Calculation

SOLIDWORKS® CAM is offered in two versions. SOLIDWORKS CAM Standard is included with
any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can
use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Barrel Tool Support
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You can define barrel tools to generate toolpaths, mainly for multiaxis finishing operations
in SOLIDWORKS CAM and the Technology Database. An advantage to using barrel tools
is that they provide a larger area of contact, which results in a better surface finish.

In the Operations Parameters dialog box, under the Tool tab, you can select Standard,
Conical Tangent, Tapered, Lens, or Advanced as the barrel tool type. You can also
define profiles to create custom barrel tools.

Geometry Tab in Operations Parameters Dialog Box
The Geometry tab in the Operations Parameters dialog box lets you define and modify
Multisurface features, Avoid features, and Contain and Avoid areas for 3 axis
milling.

The tab also includes group boxes for Automatic contain area and Avoid small profiles
formerly in the Advanced tab.

Improved Leadin and Leadout Calculations for Contour Mill Toolpaths

The calculation of Leadin and Leadout moves is improved so that the XY start and end
points are accurately represented in a compensated toolpath.

In addition to maintaining the same XY start and end points, SOLIDWORKS CAM
automatically adds the tool radius to any arc moves you specify for Leadins and
Leadouts.

For example, if you use a 10mm diameter tool with an arc Leadin of 3mm, the calculated
Leadin arc value is 8mm. When the toolpath is compensated on the machine, the resulting
motion produces an arc move of 3mm. For other types of Leadin and Leadout moves,
the length and angle of the Leadin and Leadout line segments automatically adjust.
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For legacy parts, you need to regenerate contour mill toolpaths for these changes to
take effect.

Lines Only Option in VoluMill Toolpath

You can split arcs that are larger than 90 degrees into smaller lines using Lines only.
This option is available in the VoluMill Settings dialog box in SOLIDWORKS CAM and
Technology Database, and applies to 2.5 axis and 3 axis VoluMill toolpaths.

You can specify a deviation for this option. This value splits the arcs into linear moves.

Also when you use a pattern with the VoluMill module, you can select an option to Convert
rapid moves to high feed moves in the F/S tab of the Operations Parameters dialog
box.

Update to Machine to Mean Calculation
SOLIDWORKS CAM tolerance-based machining only uses dimensional tolerances for the
Machine to Mean value of a feature. It no longer uses positional tolerances to calculate
the Machine to Mean value.

When a feature includes asymmetrical tolerances, the tolerance allowance automatically
calculates to the Maximum Material Condition. Positional tolerances are not used because
they can overcut or undercut a feature.
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16
SOLIDWORKS Composer

This chapter includes the following topics:

• Accessing Online Help for SOLIDWORKS Composer Products
• Creating View Collections
• Player Documentation No Longer Bundled in Composer Packages
• Data Management with ENOVIA 3DLive
• Composer Player 64-Bit Version
• Supported Import Formats
• Support of Meta-Properties from Pro/E Creo and STEP Files
• Other SOLIDWORKS Composer Enhancements

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents
for product communication and technical illustrations.

Accessing Online Help for SOLIDWORKS Composer Products

You can access the online help for all SOLIDWORKS Composer products.

Click Help > Use Web Help to access the online help, clear it to access the local help.
Previously, only local help was available. See Composer Help: Working with the Ribbon
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> Help Menu, Sync Help: Menus and Commands, and Player Help: Interface Description
> Menu Bar > Help Menu.

Creating View Collections

You can manage and organize views into collections in the Views pane.

You can also:

• Drag views into collections
• Expand or collapse collections
• Rename collections
• Activate or deactivate collections
• Delete collection views

You can create a collection of views in the Views pane by doing the following:

• In the Views pane, click Create View Collection .
• Right-click a view and select Add Collection.

See Composer Help: Working with Views > View Collections and Working with the Left
Panes > Views Pane.

Player Documentation No Longer Bundled in Composer Packages
When you save the active Composer document as an auto-executable package (.exe
file), the Player documentation is no longer bundled in the package.

You can access the Player documentation online from the Player. See Composer Help:
Importing and Opening Files > About Composer File Types, Interface Description > Dialog
Boxes > Save Package As, and Interface Description > Dialog Boxes > Send by E-mail.
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Data Management with ENOVIA 3DLive
You can no longer import and update models from an ENOVIA® 3DLive session.

The following commands are removed from the user interface:

• Import from 3DLive and Update from 3DLive from the File menu.
• ENOVIA 3DLive > Import and ENOVIA 3DLive > Open in ENOVIA 3DLive

right-click commands from the Assembly pane.

Composer Player 64-Bit Version
The Use Composer Player 64-bit version option is removed from the Package options
in (Default) Document Properties > Output.

See Composer Help: Managing (Default) Document Properties > Output.

Supported Import Formats
SOLIDWORKS Composer and SOLIDWORKS Composer Sync support higher versions of
several import formats.

See Composer Help: Importing and Opening Files > About Supported Import Formats
and Sync Help: About Import Formats and File Types > About Supported Import Formats.

Support of Meta-Properties from Pro/E Creo and STEP Files
You can import meta-properties from Pro/E Creo (*.prt, *.asm), and STEP (*.stp,
*.step) files in SOLIDWORKS Composer and SOLIDWORKS Composer Sync.

Meta-properties are user-defined attributes such as part number (P/N), designation, and
revision number. They appear as user properties of the string type in the Properties pane.
See Composer Help: Managing (Default) Document Properties > Input and Sync Help:
Managing Default Document Properties > Input.

Other SOLIDWORKS Composer Enhancements
SOLIDWORKS Composer products have additional enhancements.

• In the Technical Illustration workshop, you can no longer select SVGZ as the format
for saving vector images. The SVG format is still available. If the SVG file is too large,
you can convert it into the SVGZ compressed format using a standard file compression
tool. See Composer Help: Working in Workshops > Technical Illustration Workshop.

• On the Publish page, you can no longer select SVGZ as the output format for vector
images. The SVG format is still available. If the SVG file is too large, you can convert
it into the SVGZ compressed format using a standard file compression tool. See Sync
Help: Configuring Conversion Properties > Publish.

• In SOLIDWORKS Composer Player, you can see views grouped into collections in the
Views pane.
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17
SOLIDWORKS Electrical

This chapter includes the following topics:

• Defining Open-Ended Wires for Routes
• Propagating Electrical Properties from 2D to 3D
• Associate Feature Improvements
• Electrical Manager Tree Improvements
• Dynamic Connection Labels
• Origin-Destination Symbol
• Displaying Column Header Text in All Electrical Project Languages
• Manufacturer Part Weight
• Automatic Orientation in PDF Export
• Deleting Components
• Additional Variables in Origin-Destination Formula
• Resetting Dismissed Messages
• Multilingual Attributes
• Microsoft Excel Automation Improvements
• Embedding Report Tables
• Additional File Formats for Images
• Removing Assembly Link While Duplicating Projects (2023 SP3)
• Display Warning While Creating a Graph (2023 SP3)
• Route Active Location Only (2023 SP3)

SOLIDWORKS® Electrical is a separately purchased product.
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Video:What's New in SOLIDWORKS 2023 - SOLIDWORKS
Electrical

Defining Open-Ended Wires for Routes

Open-ended wires have one extremity that is disconnected from a component or terminal.

The open-ended wire property automatically propagates to the From-To list for routes.

126

SOLIDWORKS Electrical

https://youtu.be/9j0jTv8s9pM
https://youtu.be/9j0jTv8s9pM


Propagating Electrical Properties from 2D to 3D

For each component, you can propagate the electrical properties to the 3D part or
assembly.

If you modify the electrical properties in the 2D application, you must click Update BOM
Properties in the SOLIDWORKS Electrical menu, to update the 3D part properties.

You can use these properties to complete tables like the Bill of Materials.

Associate Feature Improvements
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In SOLIDWORKS Electrical 3D, the Associate command lets you associate electrical
components with 3D parts or assemblies.

The Associate Component PropertyManager lets you:

• Select several components to associate them with several 3D parts or assemblies.
• Display the properties of the selected component to check the consistency with the

3D part or the assembly.

Electrical Manager Tree Improvements

In SOLIDWORKS Electrical 3D, the Electrical Manager tree displays the list of components
in the electrical project.

In the Electrical Manager tree, an icon before each component indicates whether the
component is associated or not associated with an assembly or a 3D part. Selecting a
component in the tree highlights the associated assembly or 3D part in the graphical
area.

Selecting the location from the Electrical Manager highlights the assembly in the Feature
Manager tree if the corresponding assembly is inserted in the main assembly.

The Electrical Manager lets you:

• Show or hide inserted components
• Expand or collapse all tree nodes
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Dynamic Connection Labels

Dynamic connection labels are specific symbols that display connection information about
a component. You can dynamically insert the symbols into schemes.

The dynamic connection labels use configuration files where you enter the parameters
to draw them. Click Electrical project > Configurations > Connection label to manage
the configuration files.

To insert dynamic connection labels, click Schematic > Connection label > Insert a
dynamic connection label for a component.
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Origin-Destination Symbol

You can manually insert origin-destination arrow symbols at the end of the wires. You
associate a group number with each inserted symbol. All the wires connected on the same
group number have the same equipotential number.

To insert an origin-destination symbol, click Schematic > Origin – destination arrows
> Insert a single origin - destination arrow symbol.

Displaying Column Header Text in All Electrical Project Languages
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In the report, you can display column header text in all three languages specified in the
electrical project configuration.

To activate this feature, in the report configuration, select Show all project languages.

Manufacturer Part Weight

You can manage the weight of a manufacturer part.

The weight propagates to the Mass properties of the 3D assembly associated with the
component on which you assign the manufacturer part. For components that are cut, like
rails or ducts, the weight updates according to the Depth value that you use in the cabinet
layout.
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Automatic Orientation in PDF Export

When you export the electrical project drawings to a PDF file, you can keep the same
page orientation.

Drawings in Landscape orientation convert to PDF pages in Landscape orientation, and
drawings in Portrait convert to PDF pages in Portrait orientation.

Select the Automatic option, available in Import/Export > Export PDF files.

Deleting Components
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In the Components dockable panel, you can delete a component and all the symbols
representing it in the drawings.

A component without inserted symbols is automatically deleted. If you want to delete a
component with inserted symbols in the drawings, a dialog box opens, lets you select the
option to delete all the symbols associated with this component. If the component is
associated with a 3D part or assembly, it is automatically dissociated.

Additional Variables in Origin-Destination Formula

New variables for components and wires are available in the Formula Management dialog
box.

To use these variables, open the electrical project configuration, and in the Text tab,
click the FX cell for Origin - destination.
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Resetting Dismissed Messages

A new option lets you manage dismissed messages.

Some dialog boxes have the Do not show again option to permanently dismiss them.
To reset this status, in the Interface configuration dialog box, in the Preferences tab,
select the dialog boxes to show again.

Multilingual Attributes
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The multilingual attributes are specific attributes that propagate a multilingual text. This
multilingual text displays the desired language when you change the main language of
the electrical project.

You can use this type of attribute in title blocks or specific symbols like wiring cable labels.
You manage multilingual attributes in the title block editor or the symbol.

Microsoft Excel Automation Improvements

Excel automation allows you to automatically generate schematic drawings from data
contained in a Microsoft® Excel® file.

With the Excel automation, you can:

• Manage the origin and destination arrows
• Replace a symbol while inserting a macro
• Select the folder for the generated drawings
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Embedding Report Tables

You can insert report tables anywhere into electrical project drawings.

According to configuration parameters, you can automatically insert specific report tables
into graphical drawings like schematic, wiring line diagram, or 2D cabinet layout schemes.

After changes of the electrical project data, you can update the report content.

Additional File Formats for Images
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You can use several file formats to insert or attach images to drawings.

The supported file formats are:

• Bitmap images (*.bmp)
• DIB images (*.dib)
• JPEG File Interchange Format (*.jpg)
• Portable Network Graphics (*.png)
• Tagged Image File Format (*.tiff)
• Graphics Interchange Format (*.gif)

Removing Assembly Link While Duplicating Projects (2023 SP3)

When you duplicate a project, you can remove the link of the SOLIDWORKS assembly to
its original path.

To remove the link, from Tools > Application settings > 3D, select Exclude linked
SOLIDWORKS assembly shortcut while duplicating a project.

To relink an existing assembly file inside a project to another already existing SOLIDWORKS
assembly, you can browse and select the new SOLIDWORKS assembly from the Creation
of assembly files dialog box. SOLIDWORKS Electrical retains the association of the 3D
components after you select an existing assembly file from the required location if the
same 3D part files are found. Previously, it was impossible to relink the existing
SOLIDWORKS assembly file in a duplicated project to a new SOLIDWORKS assembly.

This is available only for the SOLIDWORKS Electrical 3D add-in.
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Display Warning While Creating a Graph (2023 SP3)

When you draw graphs, dialog boxes and warning messages appear to guide you.

When you draw a graph, a progress dialog box with a Cancel button appears. The progress
dialog box reports the steps involved in the graph creation process. To end the command
without closing the SOLIDWORKS session, click Cancel.

When you use Draw Graph, if the graph is for a very complex assembly, a warning
message appears and prompts you to continue drawing the graph or cancel the operation.
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Route Active Location Only (2023 SP3)

You can define the depth of the routing process by limiting it to the active location instead
of repeatedly rebuilding all the sublevels (sublocations) routes.

To limit the routing to the top-level assembly for wires, cables, or harness, do the
following:

• In the Route Wires PropertyManager, under Components to route > All components,
select Route active location only.

• In the Route Cables PropertyManager, under Cables to route > All cables, select
Route active location only.

• In the Route Harnesses PropertyManager, under Harness selection > All harnesses,
select Route active location only.

This capability reduces the overall design time spent while working on large electrical
projects with nested locations. You can limit the routing process to the active or top
location only instead of routing or updating the sublocations each time you execute the
route command on the top-level assembly.
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18
SOLIDWORKS Inspection

This chapter includes the following topics:

• SOLIDWORKS Inspection Add-in
• SOLIDWORKS Inspection Standalone

SOLIDWORKS® Inspection is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application (see SOLIDWORKS Inspection Standalone).
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Video:What's New in SOLIDWORKS 2023 - SOLIDWORKS
Inspection

SOLIDWORKS Inspection Add-in

Balloon Sequence

You can use the Balloon Sequence tool to define the balloon numbering sequence in
multisheet drawings.

In the SOLIDWORKS Inspection add-in, click Balloon Sequence (SOLIDWORKS
Inspection toolbar) and specify options in the PropertyManager.

Balloon Sequence PropertyManager

To open this PropertyManager, in the SOLIDWORKS Inspection add-in, click Balloon

Sequence (SOLIDWORKS Inspection toolbar).

Sequence Name
Specifies the different balloon sequences to define. You can change the name of the
sequences.

Starting Value
Specifies the starting numeric value (whole numbers only) of each balloon sequence.

141

SOLIDWORKS Inspection

https://youtu.be/6Ak9p8BGCLs
https://youtu.be/6Ak9p8BGCLs


Add
Adds a row to the balloon sequence table.

Delete
Removes a selected row from the balloon sequence table.

Balloon Drawing Sheets Separately

In multisheet drawings, you can specify sheets to balloon instead of ballooning all sheets
in a drawing.

In the Create Inspection Project PropertyManager, under Sheets, select Include All or
you can specify sheets. With Include All, the entire drawing is ballooned. When you
select sheets, you can specify each sheet in the drawing to balloon in inspection reports.
You can also specify the balloon sequence. You define the balloon sequence with the

Balloon Sequence tool or by entering it in Sequence/Starting Value.

If you have two or more sheets to balloon continuously, in Sequence/Starting Value,
select Continue from previous sheet.
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Export Sheets as Separate 2D PDF Files

If you balloon drawing sheets separately, you can export the Microsoft® Excel® and .pdf
reports separately. Previously, the reports exported as a continuous report with all sheets
included.

In the SOLIDWORKS Inspection add-in, click Export to 2D PDF (SOLIDWORKS
Inspection toolbar). In the 2D PDF Export dialog box, specify options:

• Export drawing as single PDF. Exports the entire drawing as a single .pdf file.
• Export sheets as separate PDFs. Exports each drawing sheet as a separate .pdf

file.
• Selected Sheets. Specifies the drawing sheets to save in the .pdf file.
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Export FAI Reports to Separate Microsoft Excel Documents

When you export a First Article Inspection (FAI) report to Microsoft® Excel®, you can export
characteristics to multiple spreadsheets.

In the SOLIDWORKS Inspection add-in, click Export to Excel . In the Exporting
PropertyManager, under Excel Export Settings, specify options:

• Export drawing to single excel. Exports all characteristics from the specified sheets
to one Microsoft Excel spreadsheet.

• Export sheets to separate excel. Exports all characteristics from the specified sheets
to separate Microsoft Excel spreadsheets.

144

SOLIDWORKS Inspection



SOLIDWORKS Inspection Manager

The SOLIDWORKS Inspection Manager contains a Characteristics section with tabs for
Characteristic Table and Characteristic Tree. If you select an item in the characteristic
table or characteristic tree, the corresponding entity highlights in the graphics area.

The characteristic table is existing functionality that contains the Bill of Characteristics,
which lists each ballooned entity. You can select multiple balloons from the same view
and reorder them in the characteristic table. When you drag a balloon to reorder it in the
table, scrolling speed and usability is improved. The View column in the table lists the
view to which each characteristic belongs.

The characteristic tree contains information for each sheet and view in the drawing. It
only displays sheets and views that have ballooned items. In the characteristic tree, you
can reorder:

• Balloons by dragging views.
• Views that belong to the same sheet.
• Sheets. The sheet and its views are reordered and renumbered according to the new

position in the characteristic tree.

SOLIDWORKS Inspection Standalone
SOLIDWORKS® Inspection is a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as
a completely separate application (see SOLIDWORKS Inspection Standalone).
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Autoballoons for PDF Files

The Auto Extract tool automatically applies balloons to characteristics in PDF files, which
reduces the time and effort needed to balloon PDF files.

Auto Extract uses a machine learning technique to locate the positions and types of
annotations, then attaches balloons to them. You can also use this tool to automatically
apply balloons to CAD files. The Auto Extract tool replaces the Smart Extract tool.

In a PDF file, on the Document ribbon, click Auto Extract . Auto Extract does not
support notes or weld symbols.

You can also manually extract characteristics with theManual Extract tool (Document
ribbon).

Autoballooning PDF Files

To autoballoon PDF files:

1. In SOLIDWORKS Inspection Standalone, click New .

2. In the Project Template dialog box, select a template and click .
3. In the Open CAD/PDF File dialog box, select a PDF file and click Open.

4. Click Auto Extract (Document ribbon).
5. Specify settings in the Auto Extract PropertyManager and click .
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Auto Extract PropertyManager

You can use the Auto Extract PropertyManager to automatically apply balloons to
characteristics in CAD models, drawings, and PDF files.

To open the Auto Extract PropertyManager, in a model, drawing, or PDF file, click Auto

Extract .

Extraction Settings
(PDF files only.) Specifies the characteristics to balloon. Notes and weld symbols are not
supported.

Balloons all dimensions, geometric tolerance
symbols, surface finish symbols, and datums
in the file.

Include All

Balloons all dimensions.Dimensions

Balloons all geometric tolerance symbols.GD&Ts

Balloons all surface finish symbols.Surface Finishes

Balloons all datums.Datum

Dimensions
(CAD models and drawings only.)

Balloons all basic, feature, and reference
dimensions.
Clear Include to select individual Basic,
Feature, or Reference dimensions.

Include

Balloons all inspection dimensions.Inspection Only

(SOLIDWORKS files only.) Balloons and
splits compound hole callouts into
subballoons.

Auto-explode hole callouts

Notes
(CAD models and drawings only.)
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Balloons all datum feature, datum target,
and flag note symbols.
Clear Include to select individual Datums,
Datum Targets, Flag Notes, Correlate
Flag Notes, or Auto-explode multi-line
notes.

Include

GD&Ts
(CAD models and drawings only.)

Balloons all geometric dimensioning and
tolerancing feature control frames.

Include

Welds
(CAD models and drawings only.)

Balloons all weld symbols.Include

Surface Finishes
(CAD models and drawings only.)

Balloons all surface finish symbols.Include

Geometry Options
(CAD models and drawings only.)

Loads hidden components into
SOLIDWORKS Inspection.

Load Invisible Components

Page 2 of PropertyManager
Click Next in the PropertyManager to access these options.

(Drawings and PDF files only.) Balloons all
characteristics in the document.

Sheets, Include All, sheetn

Entire Drawing
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Entire Document
(CAD models only.)

Balloons all characteristics in the document.Entire Document

Includes all annotation views, otherwise you
can select individual annotation views.

Include All

Captures

Balloons all model based definition screen
captures, or you can specify screen captures
to include.

Include All

Views

Balloons all annotation views, or you can
specify views to include.

Include All

Manually Ballooning PDF Files

The Manual Extract tool replaces the optical character recognition (OCR) editor tool. It
is streamlined to make manual extraction of annotations quicker to balloon.

To manually balloon PDF files:

1. In SOLIDWORKS Inspection Standalone, click New .
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2. In the Project Template dialog box, select a template and click .
3. In the Open CAD/PDF File dialog box, select a PDF file and click Open.

4. Click Manual Extract (Document ribbon) and select the type of annotation to
balloon:

• Dimension
• Geometric Tolerances
• Note
• Surface Finish
• Weld
• Other. Includes annotations such as temperature, torque, and electrical resistance.

5. In the PDF file, box-select an annotation of the type you selected in the previous step.
6. In the Properties/Preferences PropertyManager, under General, Inspection,

Ballooning, and Custom, enter values for the remaining data in the annotation.

User Interface Redesign

The user interface for SOLIDWORKS Inspection Standalone is redesigned to provide better
support for high-resolution, high-pixel-density displays. Icons are consistent with those
in SOLIDWORKS.

Icons are more crisp and readable, and they scale properly when used with high-resolution
displays.
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19
SOLIDWORKS MBD

This chapter includes the following topics:

• Annotations and Dimensions in 3D PDF Files
• Dimension Extension Lines
• Editing Compound Features
• ISO Tolerance-Modifying Symbols
• Wedges

SOLIDWORKS® MBD is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Annotations and Dimensions in 3D PDF Files

When you create a 3D PDF for an assembly, you can view all dimensions in the assembly
and 3D views, even in the viewport, with no data loss.

You can view component dimensions in 3D PDF files, including feature dimensions,
reference dimensions, and DimXpert annotations.
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Dimension Extension Lines

You can use dimension extension lines to connect the dimensions to the model.

To show dimension extension lines:

1. Click Tools > Options > Document Properties > DimXpert > Display Options.
2. Under Linear Dimension, select Connect dimension extension lines to model.

Editing Compound Features
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You can add or remove faces on an existing compound feature while maintaining the
annotations.

You can edit compound planes, holes, and cylinders.

To edit compound features:

1. In the DimXpertManager, right-click the compound feature and click Edit Feature.
2. Select features to add or remove from the compound feature.

• To add a face, select a feature and click OK.
• To remove a face, right-click a feature and select Delete.

ISO Tolerance-Modifying Symbols

You can apply ISO 14405-1:2016 standards-based symbols to dimensions and tolerances
in DimXpert.

You can add symbols and other text directly to ISO dimensions and their tolerances from
the Tolerance Modifier section in the DimXpert PropertyManager.
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Wedges

MBD supports wedge features. A wedge has two nonparallel planes with opposing vectors.

To create a wedge:

1. Click Size Dimension (MBD Dimension toolbar).
2. Select the first plane.

3. From the Feature Selector, click Create Width/Wedge Feature .
4. Select the second plane.
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5. In the Feature Selector, click .
6. Click to place the dimension.
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20
eDrawings

This chapter includes the following topics:

• Assembly Graphics
• Configuration Pane
• Components Pane (2023 SP1)
• Configuration Support on Mobile Devices
• Display States
• Display Styles
• Measurement Callouts (2023 SP2)
• Supported Versions of File Types
• Using Localized Versions of eDrawings Web HTML
• Using Fractional Measurements

eDrawings® Professional is available in SOLIDWORKS® Professional and SOLIDWORKS Premium.

Assembly Graphics
Graphics in eDrawings assemblies have improved. When you publish SOLIDWORKS
assemblies as eDrawings assemblies, the graphics more closely resemble the original
SOLIDWORKS files.

If the eDrawings assembly contains linked display states, the Configuration pane shows
Display States (Linked).
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Configuration Pane

When you open files in eDrawings that have only one configuration, the Configuration
pane is available. Previously, there was no Configuration pane.

Components Pane (2023 SP1)
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You can display component properties in the assembly tree of the eDrawings Components
pane.

Component properties are only available if you published an .EASM file from SOLIDWORKS
with Save file properties for each component in the assembly selected.

On the Components pane, click Options and select Show property. This displays
the specified property when you open the Components pane. You can also filter on the
text to find components in a large assembly tree.

Configuration Support on Mobile Devices

You can specify configurations of SOLIDWORKS parts and assemblies to be available when
you open the models in eDrawings for iOS™ and eDrawings for Android™.

In the SOLIDWORKS software, set configurations with Add Display Data Mark to view
the configurations in eDrawings. For information, see SOLIDWORKS Help: Generating
Display Lists.
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Display States

When you publish SOLIDWORKS assemblies as eDrawings assemblies (.EASM), display
state data (for the selected configurations in the Save Configurations to eDrawings file
dialog box) is stored in the eDrawings assembly files. This gives you important information
to communicate and collaborate in eDrawings.

Display state data is also supported when you save an assembly as an eDrawings Web
HTML file from eDrawings Professional. You can view the display states in supported
browsers and in SOLIDWORKS PDM Web2.

On the Configuration pane, the option, Link display states to configurations, is
removed. Display states are linked or unlinked based on the setting in the SOLIDWORKS
assembly at the time of publishing the eDrawings assembly file from SOLIDWORKS. When
the display states are linked to the configuration, only the display states that are associated
with the selected configurations are published. If display states are linked to the
configurations, the header says Display States (Linked).

Textures are not supported in the display state data.
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Display Styles

You can view models in hidden lines visible (HLV) and wireframe modes. The tooltip for
Wireframe has changed to Hidden Lines Removed (HLR).

Click Display Style (Heads-up View toolbar) and select Hidden Lines Visible ,

Hidden Lines Removed , or Wireframe .
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Measurement Callouts (2023 SP2)

When you measure two parallel entities, the normal distance is displayed in the graphics
area. Previously the distance was displayed in the Measure pane only.

Normal distance is the distance of a line perpendicular to the parallel entities. By having
the distance displayed in the graphics area, you can see the measurement directly in the
model instead of looking in the Measure pane. In the image above, the yellow line is the
projection of the entity when the two parallel entities are offset to create the normal
distance line, which is purple.

Supported Versions of File Types
eDrawings has updated the supported versions for several file types.

VersionFormat

Up to 2020ACIS (.sat, .sab)

Up to 2022Autodesk® Inventor® (.ipt., .iam)

Up to 4.2.5CATIA V4 (.MODEL, .SESSION, .DLV, .EXP)

Up to V5_6R2021CATIA V5 (.CATDrawing, .CATPart,
.CATProduct, .CATShape, .CGR)

Up to V5-6 R2019 (R29)CATIA V6 / 3DEXPERIENCE (.3DXML)

Pro/Engineer 19.0 to Creo 8.0Creo - Pro/Engineer (.ASM, .NEU, .PRT,
.XAS, .XPR)
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VersionFormat

5.1, 5.2, 5.3IGES (.igs, .iges)

Up to v10.5JT (.jt)

V11 to v18, NX to NX12, NX1847 Series to
NX1980 Series

NX (Unigraphics) (.prt)

Up to 33.1Parasolid (.x_b, .x_t, .xmt, .xmt_txt)

V19-20, ST-ST10, 2021Solid Edge (.asm, .par, .pwd, .psm)

AP 203 E1/E2, AP 214, AP 242STEP (.stp, .step, .stpz)

AnyWavefront OBJ (.obj)

Using Localized Versions of eDrawings Web HTML

(Available in eDrawings Professional.) When you save a file as eDrawings Web HTML,
then open the .html file, you can select a language to display the user interface in the
localized language. The file itself retains its native language.

This is helpful if you share the file with a user who speaks a different language.

To use a localized version of eDrawings Web HTML:

1. In eDrawings, click File > Save As.
2. In the dialog box, in Save as type, select eDrawings Web HTML Files (*.html).
3. Double-click the file that you saved.
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4. In eDrawings Web HTML, click Languages and select a language.

Using Fractional Measurements

If you use the English unit system to measure eDrawings models, you can display
measurements as fractions with the Measure tool.

To use fractional measurements:

1. Click Measure .
2. On the Measure pane, under Units:

a. In Length, select Inches or Feet and Inches.
b. Select Display In Fractions.
c. For Denominator, enter the maximum digits for the fraction denominator.
d. Optional: Select Round to nearest fraction to round to the next highest fraction

if the measurement does not have a fractional value for the denominator.
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21
SOLIDWORKS Plastics

This chapter includes the following topics:

• Plastics Materials Database - Material Grades
• Plastics Materials Database Manager
• Summary and Report

SOLIDWORKS® Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS
Plastics Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Plastics Materials Database - Material Grades

The Plastics material database is updated according to the latest data from the material
manufacturers.

DescriptionMaterials

Added 14 new material grades from material manufacturer
EMS-GRIVORY.

New Materials
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DescriptionMaterials

Updated 54 material grades with the latest material property values
from material manufacturer EMS-GRIVORY.

Modified Materials

Removed obsolete material grades from the database:
• EMS-GRIVORY: 1
• CHI MEI Corporation: 37

Removed Materials

Plastics Materials Database Manager

Several user interface enhancements to the Plastics Materials Database Manager improve
its usability.

Display enhancements:

• Gray color border and gray gridlines replace the yellow color border and gridlines to
improve the readability of the material properties.

• The Elastic Modulus, Poisson’s Ratio, and Thermal Expansion Coefficient plots
are removed.

• The material's polymer family and manufacturer name are removed from the title bar
and are listed in separate material property fields.

Material properties enhancements:

• The database stores detailed fiber and filler properties for filled materials. You can
view these properties under the Filler Properties section.
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• In addition to the material's solid density, the database stores its melt density. You
can view the material densities under the Density section.

• The database stores the following Thermoset material properties, if they are available
from the manufacturers:

• PVT data for the cured and uncured states.
• Heat of Reaction and Induction Time Constants.
• Ejection Conversion and Initial Conversion.

The solver is also enhanced to account for these additional material properties (when
available) to improve the accuracy of Fill, Pack, and Warp simulations.

The classifications of the material's Data Source and Information field are revised.

DescriptionClassification

Name of the manufacturer who provided
the grade-specific material data.

Manufacturer Name

The Pressure Volume Temperature (PVT)
data are generic, while the rest of the data
are grade-specific and provided by the
material manufacturer.

Manufacturer Name; Generic PVT Data

The material manufacturer is planning to
phase out the specific material grade.

Manufacturer Name;*to be phased out
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DescriptionClassification

The material data are from a legacy source
and are not updated.

SIMPOE

The material data are from a legacy source
and have been updated from constant
density to generic PVT data to improve the
accuracy of Fill, Pack, and Warp simulations.

SIMPOE; Generic PVT Data

Summary and Report

You can access the Summary and Report features from the PlasticsManager
independently. In addition, there are several enhancements for the Summary and Report.

• To access the Summary:

In the PlasticsManager, right-click Results and click Summary.

• To access the Report:

In the PlasticsManager, right-click Results and click Report.

Enhancements to the Summary feature include:

• Quick access to key results.
• Improved content organization into three sections for the Model tab:

Lists the following features: study name, injection process,
number of injection units, analysis mesh procedure, and
the simulation sequence.

Study Characteristics
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Lists the following features for each injection unit: polymer
material and the material's melt, mold, transition, and
ejection temperatures.

Injection Unit Settings

Lists the model volume, mass, and overall dimensions.Physical Attributes

• Addition of the plastic part's mass at the end of packing in the Pack tab.

Enhancements to the Report feature include:

• Updated Microsoft Word report templates. The Classic and Light report templates of
previous versions are replaced with a single template that has a more modern look
and feel.

• Additional formats are available for saving a report. In addition to Microsoft Word, you
can save a report as a Microsoft PowerPoint or HTML document. The default option All
(HTML, MS Word, MS PowerPoint) saves a report to all three formats.
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22
Routing

This chapter includes the following topics:

• Routing Library Manager Enhancements
• Complex Splices
• Displaying the Cross Section of a Harness Segment
• Flatten Route Improvements
• Reorienting Connectors in Flattened Routes

Routing is available in SOLIDWORKS® Premium.

Video: What's New in SOLIDWORKS 2023 - Routing

Routing Library Manager Enhancements
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The Routing Library Manager has improved ergonomics and usability, several
enhancements have been done:

• Improved discoverability and guidance in the user interface by tooltips.
• Better management of the connection points and Mate References (create, edit, and

delete workflows).
• Improved saving and canceling of modifications.

Complex Splices

A complex splice has multiple circuits to which you connect wires or cable cores.

To connect wires or cable cores to a complex splice, you must insert the CPoints, and the
RPoints if the wire crosses the splice, corresponding to the different circuits.

You can use complex splices in a manual routing or using the From-To list.

The complex splices are not supported in the flattening.
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Displaying the Cross Section of a Harness Segment

You can access the cross section of a harness segment.

In the Electrical Attibutes PropertyManager, select Show Cross Section to view a graphical
cross section of the harness segment. The formula to calculate the diameter of this
segment takes into consideration if it contains a cable.

Flatten Route Improvements
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Improvements to the flatten route design deliver higher-quality flatten route drawings.

Improvements relate to the following items:

• The Auto-Balloon option applies to balloons for connectors and wires
• When you modify a connector table, you can apply this change to all existing connector

tables
• The Show/Hide Flatten Route Items command is available in the Electrical toolbar
• In the Flatten Route Items PropertyManager, you can select Manufacturer

(component name) to split the text displayed for the component in the flattened
route drawing

Reorienting Connectors in Flattened Routes

You can reorient the connectors to be parallel to a selected plane.

In the Edit Flattened Route PropertyManager, select a plane in Faces and Planes.
This does not affect the Maintain 3D Orientation process.

173

Routing



23
DraftSight

This chapter includes the following topics:

• Contextual Ribbon Tabs (2023 SP1)
• Cycling Selection (2023 SP1)
• Data Extraction (2023 SP1)
• Page Layout Manager (2023 SP1)
• Annotation Monitor (2023 SP1)

DraftSight® is a separately purchased product that you can use to create professional CAD
drawings. It is available as DraftSight Professional and DraftSight Premium. In addition,
DraftSight Enterprise and Enterprise Plus are available on network license. 3DEXPERIENCE
DraftSight is a combined solution of DraftSight with the power of 3DEXPERIENCE platform.

Contextual Ribbon Tabs (2023 SP1)

You can display specific tools on the ribbon when you select particular entities or run the
commands to create new entities.

The contextual ribbon tab provides:

• An uninterrupted view of the graphics area because it is not blocked by the dialog box
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• Immediate visibility of changes that you apply to entities
• Relevant tools for completing a task

DraftSight offers contextual ribbon tabs for the following operations:

• Creating and editing hatches
• Editing table cells
• Editing PDF and DGN underlays
• Editing images and external references
• Editing annotation entities, dimensions, leaders, multileaders, and tolerance symbols.

Cycling Selection (2023 SP1)

You can select specific entities from the list of overlapped entities displayed in the Cycling
Selection dialog box.

In previous releases, it was difficult to select an overlapped entity when working on a
complex drawing.
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Data Extraction (2023 SP1)

You can use the Data Extraction wizard to specify a set of entities or blocks and extract
properties and attributes information.

You can:

• Create a bill of materials from the set of entities.
• Display the result in a table on the drawing.
• Save the result in an external file that you can exchange with others.

Use the ExtractData command to open the Data Extraction wizard.

Options in the Data Extraction wizard let you:

• Specify the set of drawings or folders.
• Filter entities.
• Organize the extracted data.
• Specify an output format.
• Format the output data in a table.

DraftSight saves the data source selections, entities and property selection, and table
formatting in a Data Extraction File (.det). You can use the already created Data Extraction
File as a template to perform the same type of extraction for another drawing.
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Page Layout Manager (2023 SP1)

You can use Page Layout Manager to save the print settings in a drawing file.

In previous versions, the Print Configuration Manager saved the print settings in the
.CFG file. When you shared the drawing file with users, you had to share the .CFG file to
retain the print settings.

Under System Options > Printing > General Options, select Use Page Layout
Manager.

DraftSight reads and lets you print the print settings of a drawing file created in other
software, for example AutoCAD®.
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Annotation Monitor (2023 SP1)

Annotation Monitor identifies annotations that are no longer associated with their related
geometry.

DraftSight displays the Reassociate and Delete options. You can either reassociate the
annotations or delete them.
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Our 3DEXPERIENCE® platform powers our brand applications, serving 12 industries, and 
provides a rich portfolio of industry solution experiences.
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