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1
Welcome to SOLIDWORKS 2024

This chapter includes the following topics:

• Top Enhancements
• Performance
• For More Information

At SOLIDWORKS®, we know that you create great designs, and that your great designs get
built. To streamline and accelerate your product development process from concept through
manufactured products, SOLIDWORKS 2024 contains new, user-driven enhancements focused
on:

• Working Smarter. Reduce your workload in SOLIDWORKS with the ability to defeature
models more efficiently, add part features to assemblies by first associatively inserting an
assembly into a part, and include unit of measure as a custom property in your notes and
tables.

• Working Faster. Work more efficiently in SOLIDWORKS with intelligent, instant creation
of sketch dimensions, improvements to collinear dimensioning for chain dimensions in
drawings, and access to new components in Toolbox.

• Working Together. SOLIDWORKS is better together with your friends! Empower others
across product development disciplines with enhancements to SOLIDWORKS products
including PDM, Simulation, Electrical, Visualize, MBD, Composer, and more. Best yet,
SOLIDWORKS now includes access to the 3DEXPERIENCE® platform.
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This document covers all enhancements that affect how you interact with the 3DEXPERIENCE
platform. This includes both of the platform-connected versions of SOLIDWORKS -
SOLIDWORKS Connected and SOLIDWORKS with the 3DEXPERIENCE (Design with
SOLIDWORKS) add-in. It also includes other apps that can connect to the platform such as
DraftSight.

Top Enhancements
The top enhancements for SOLIDWORKS® 2024 provide improvements to existing products
and innovative new functionality.

Parts and Features • Hole Wizard on page 86
• Making Multibody Parts from Assemblies on page 87

Sheet Metal • Slot Propagation on page 97
• Stamp Tool on page 99
• Normal Cut in Tab and Slot on page 101

Structure Systems
and Weldments

• Corner Management on page 102

Assemblies • Defeature Rule Sets on page 118
• Repairing Missing References in Linear or Circular
Component Patterns on page 124

Drawings and
Detailing

• Overridden Dimensions on page 131
• Keeping Chain Dimensions Collinear on page 130
• Reattaching Dangling Dimensions on page 132

SOLIDWORKS MBD • Hole Tables on page 234
• Repairing Dangling Dimensions on page 234

Performance
SOLIDWORKS® 2024 improves the performance of specific tools and workflows.

Some of the highlights for performance and workflow improvements are:

SOLIDWORKS Fundamentals
• Graphics rebuild after exiting SOLIDWORKS options.

SOLIDWORKS checks the changed options when you click OK to exit the Options dialog
box. SOLIDWORKS only performs a graphics rebuild on the active document if the
changed options require it. In earlier releases, SOLIDWORKS always performed a
graphics rebuild on the active document.
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• Silhouette edges.

You can enable the GPU hardware to improve the display of silhouette edges in HLR,
HLV, and wireframe views.

In Tools > Options > System Options > Performance, select Hardware
accelerated silhouette edges.

Sketching
Equal relations solve more efficiently which improves 3D sketch performance.

Sheet Metal
When rebuilding complex sheet metal parts with large numbers of sketched bends or
jogs, rebuild time is improved by up to 50%.

Import/Export
The performance of importing STEP, IGES, and IFC assemblies as multibody parts is
improved up to 30%.

SOLIDWORKS PDM
SOLIDWORKS PDM 2024 has improved the performance of file-based operations.

The following operations are approximately two times faster:

• Add files
• Change state
• Copy tree

The copy tree to compressed archive operation is orders of magnitude faster.

SOLIDWORKS Electrical
• Archiving a project for remote users (VPN connection) is improved and is much faster.
• The automatic routing issue that caused the creation of loops while routing wires
through splices is fixed. This allows cleaner and faster flattening of harnesses.

eDrawings
Performance improvements include:

• Measure tool. Up to 20 times faster when opening the Measure pane, entity selection,
and changing units.

• Markup tool. Up to 10 times faster when creating markups.
• Reset tool. Up to 1.5 times faster when resetting a model.
• Faster rendering and printing with software OpenGL.
• Faster times for closing files.
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For More Information
Use the following resources to learn about SOLIDWORKS:

This guide is available in PDF and HTML formats. Click:What's New in PDF
and HTML

• > What's New > PDF

• > What's New > HTML

In SOLIDWORKS, appears next to new menu items and the
titles of new or significantly changed PropertyManagers. Click

Interactive What's
New

to display the topic in this guide that describes the
enhancement.

To enable Interactive What's New, click > What's New >
Interactive.

Contains complete coverage of our products, including details
about the user interface and examples.

Online Help

Contains posts from the SOLIDWORKS user community on the
3DEXPERIENCE® platform (login required).

SOLIDWORKS User
Forum

Provides information about late changes to our products,
including changes to the What's New book, online help, and
other documentation.

Release Notes

SOLIDWORKS Legal Notices are available online.Legal Notices

14

Welcome to SOLIDWORKS 2024

https://r1132100503382-eu1-3dswym.3dexperience.3ds.com/#community:yUw32GbYTEqKdgY7-jbZPg
https://r1132100503382-eu1-3dswym.3dexperience.3ds.com/#community:yUw32GbYTEqKdgY7-jbZPg
https://help.solidworks.com/Help.aspx?P=1&V=2024&F=sldworks/c_copyright_solidworks.htm


2
Using SOLIDWORKS on the 3DEXPERIENCE Platform

This chapter includes the following topics:

• SP4-FD04
• SP3-FD03
• SP2-FD02
• SP1-FD01
• SP0_GA

This chapter covers all enhancements that affect how you use SOLIDWORKS with the
3DEXPERIENCE platform. Unless otherwise noted, the entries in this chapter are available
in both SOLIDWORKS Connected (3DEXPERIENCE SOLIDWORKS roles) and in SOLIDWORKS
with the 3DEXPERIENCE (Design with SOLIDWORKS) add-in (Collaborative Designer for
SOLIDWORKS role).

SP4-FD04

SOLIDWORKS Connected Tutorials (2024 FD04, FD03, 2024 FD01)
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You can access interactive SOLIDWORKS Connected tutorials that open in a resizeable
viewer panel on the right side of your browser. Additional SOLIDWORKS Connected
tutorials are available.

Benefits: You can access interactive tutorials directly in the app to help you learn
SOLIDWORKS Connected. In previous releases, you had to use a browser to access these
tutorials.

To access the tutorials, in the Welcome dialog box, click Learn > Step-by-Step Tutorials,
or in the app, click Help > Tutorials.

The following tutorials are available:

TutorialsArea

• Assembly Mates
• Import/Export
• Sheet Metal: Forming Tools
• Surfaces

Basic Techniques

• 3D Sketching
• 3D Sketching with Planes
• Advanced Design Techniques
• Assembly Visualization
• Equations
• Mold Design
• Molded Product Design - Advanced
• Multibody Parts
• Routing - Electrical
• Routing - Pipes and Tubes
• Sketch Blocks

Advanced Techniques

• Animation
• DimXpert
• Event-based Motion

Design Evaluation

• Design Checker
• Mouse Gestures
• Smart Components
• SOLIDWORKS Utilities

Productivity Tools

Several tutorials include downloadable models that you use to accomplish hands-on tasks
to help support learning.

All of our existing SOLIDWORKS Connected tutorials remain available at
help.solidworks.com.
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SP3-FD03

SOLIDWORKS PDM Add-In for SOLIDWORKS Connected (2024 FD03)

In SOLIDWORKS Connected, the default data management system is the 3DEXPERIENCE
platform, but you can choose another system, such as the SOLIDWORKS PDM add-in.

Benefits: For dedicated PDM users, it is advisable to switch to the Data Management
option, SOLIDWORKS PDM or other separately installed data management. This
action deactivates 3DEXPERIENCE integrations, which may cause conflicts or distractions
for SOLIDWORKS PDM users.

To use a different data management system:

1. Click Tools > Options > 3DEXPERIENCE Integration and select SOLIDWORKS
PDM or other data management installed separately.

2. Click OK.

This option requires a SOLIDWORKS restart.

Selecting another system removes the 3DEXPERIENCE platform elements responsible for
managing documents in collaborative spaces:

• MySession does not appear in the 3DEXPERIENCE Task Pane.
• Lifecycle and Collaboration tools are not available in the CommandManager and menus.
• Open and Save operations cannot access the 3DEXPERIENCE platform.
• The 3DEXPERIENCE Files on This PC tab does not appear.

You can share files with 3DDrive and 3DEXPERIENCE Marketplace regardless of the data
management system.

You can install SOLIDWORKS PDM separately, following the guidelines outlined in the
SOLIDWORKS® PDM and SOLIDWORKS Manage Installation Guide. If SOLIDWORKS PDM
is already installed, users can activate it through the Add-Ins dialog box from Tools >
Add-Ins , whether or not they choose to modify the Data Management option.

Improved Licensing Support for SOLIDWORKS Flow Simulation and SOLIDWORKS
Plastics Add-Ins (2024 FD03)

If you own licenses for SOLIDWORKS Flow Simulation and SOLIDWORKS Plastics, you
can enable them to run in SOLIDWORKS Connected.

Benefits: The add-ins install automatically, making these tools readily available within
SOLIDWORKS Connected.

When installing SOLIDWORKS Connected, optionally select SOLIDWORKS Flow Simulation
or SOLIDWORKS Plastics and enter your serial number. In the case of a network license,
you must specify the address (port@server) of your SolidNetWork (SNL) License server.

Once you install SOLIDWORKS Flow Simulation and SOLIDWORKS Plastics:

• You can activate or deactivate standalone versions from the Helpmenu in SOLIDWORKS
Connected.

• SNL versions retrieve a license from the license server when you add them in.
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File Preparation Assistant - Additional Checks (2024 FD03)

The File Preparation Assistant performs additional checks, including for files older than
SOLIDWORKS 2021. This lets you find old files and save files in the latest version of
SOLIDWORKS.

Benefits: More checks improve the success of saving your files to the 3DEXPERIENCE
platform.

Designate a Single Physical Product (2024 FD03)

When you use the 3DEXPERIENCE Integration Rules Editor to designate a single physical
product, you cannot add more physical products.

Benefits: You can define a single physical product in a consistent manner.

When you use the Single physical product with representations option in the
3DEXPERIENCE Integration Rules Editor, the parts and assemblies within the scope of
that rule should have the mono-physical product status, such as no CAD family in the
ConfigurationManager.

In earlier releases, the model had a single physical product, however the model was not
designated as a single physical product and you could add more physical products.
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Refreshing PLM Information Only When Required (2024 FD03)

MySession content is refreshed only when required.

Benefits: This improves the performance of SOLIDWORKS as the time required to maintain
the PLM information is saved.

With this change MySession content is refreshed only when any one of the following
happens:

• Opening MySession from View > Task Pane option.
• Showing PLM information on the SOLIDWORKS feature manage tree.
• Accessing PLM commands from SOLIDWORKS.
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Creating a Make From Relationship (2024 FD03)

You can use the Make From tab in the Information panel of an object to create a
Make From relationship to a physical product or its subtypes.

Benefits: You can review the materials assigned to a SOLIDWORKS product and if the
materials are not assigned, assign them before releasing the document.

The Make From tab shows the name and quantity of objects needed to make the
physical product. For an object when you select a 3D part, other physical products, raw
materials, and their sub-types using the Make From option, a make from relationship is

established between the two. This relationship is visible in the Relations tab of the
Information panel.

To access Make From , from the View tab of action bar, click Display Side Panel.

TheMake From tab displays the details of the object that is added as a material from
which the object is made. Using the Make From command on this tab, you can link the
objects.
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Viewing Approval Details in Drawing Annotations (2024 FD03)

The extended attributes for a drawing in annotations are now expanded to display the
approval details. You can now view the details of the approver through the annotations
in 3DPlay or 3DMarkup.

Benefits: You can track the lifecycle of a drawing by viewing its properties in the preview.

The drawing release process involves several approvers. If you view a drawing in 3DPlay
or 3DMarkup, the information about the drawing release process (the list of approvers,
the associated task, and the date of approval) are visible through the annotations.

The $PLMPRP properties are indexed corresponding to the approval order. The supported
attributes are:

• ea_releasedby.i: represents the ith (in time) approver of the drawing.
• ea_releaseddate.i: represents the date when the ith (in time) approval is defined
on the drawing.

• ea_releasedtask.i: represents the task title used when the ith (in time) approval is
defined on the drawing.

In the SOLIDWORKS properties dialog box, by default you can propose 3 approvers, but
you can increase the number of approvers.
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Installing Sync Client for 3DDrive (2024 FD03)

When you open a file from 3DDrive using the Open With > Design with Solidworks
command, you can choose if you want to install the 3DEXPERIENCE Drive for Windows.

Benefits: The app behaves differently depending on how you choose to install it. You
can open the selected file in SOLIDWORKS even if the client is not installed on the machine.

A notification appears if you do not have 3DEXPERIENCE Drive for Windows installed.

• If you choose Install, there is no change in the behavior of 3DDrive. You can work
simultaneously with the files in SOLIDWORKS and keep it synced with 3DDrive.

• If you choose Continue without Install, the files will not be synced automatically.
However, you can perform all the operations of upload, download, and drag a file from
3DDrive to SOLIDWORKS.
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Accessing latest SOLIDWORKS Templates (2024 FD03)

When multiple revisions of the same template exist on the 3DEXPERIENCE platform, only
latest revision is downloaded.

Benefits: You always have access to the latest SOLIDWORKS templates stored in the
3DEXPERIENCE platform.

If there are multiple templates with same filename, a single random template is
downloaded. Also, if no modifications are done since the last download, the templates
are not downloaded again locally.
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Deleting Virtual Components (2024 FD03)

You can now delete a virtual part or a virtual assembly even if you are an Author.

Benefits: Deleting the virtual components in not dependent on the roles.

Now even if you delete the virtual components the save process does not get blocked.
However the save process is blocked if you delete a configuration. To delete a configuration
you must have the Leader role.
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Opening 3DSwym from SOLIDWORKS (2024 FD03)

You can now open the 3DSwym app and notifications from the SOLIDWORKS task pane.

Benefits: You can access more 3DEXPERIENCE platform functionality without leaving
the SOLIDWORKS environment. The 3DEXPERIENCE platform apps do not open in a
separate web browser and thus saves the reloading time.

3DSwym helps you to collaborate and access communities and conversations. Once you
open 3DSwymand then open any other app, you can reopen it again from the top bar by

clicking . The notifications from the apps like Collaborative Tasks or 3DSwym
Conversations open within the SOLIDWORKS task pane.
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Applying Material to SOLIDWORKS Objects (2024 FD03)

When you apply material to a part or body in SOLIDWORKS, the same material assignment
and tree order structure is replicated in the 3DEXPERIENCE platform.

Benefits: You can maintain the same design structure for structures that involve multibody
parts.

In the earlier releases, when material was applied at part level or body level, the material
definition was lost while saving it to the 3DEXPERIENCE platform. Now when you apply
material to a SOLIDWORKS part and save it to the 3DEXPERIENCE platform, material
exposition is managed in any of the following ways:

• Material applied at the part level is applied at the 3DPart level in the 3DEXPERIENCE
platform.

• Material applied at the body level is applied at the body level in the 3DEXPERIENCE
platform.

• Material applied at the part and body level is applied at the 3DPart and body level in
the 3DEXPERIENCE platform. For multibody structure, if material is applied at part
level and some bodies, the material definition was applied to the bodies that did not
have material definition. But now the bodies that do not have any material definition,
do not display any material definition.
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Updates to System Maintenance Tab in SOLIDWORKS RX (2024 FD03)

Two new tasks are available in the System Maintenance tab.

Benefits: These tasks simplify the diagnosis of technical issues.

• Clean the temporary swcef cache directory
• Clean the 3DEXPERIENCE temporary directory

The Clean the 3DEXPERIENCE temporary directory task is only available when the
Collaborative Designer for SOLIDWORKS app or 3DEXPERIENCE SOLIDWORKS is
installed.

When you work with support representatives, they may ask you to run these tasks to
clean temporary files as a troubleshooting or corrective step. Content in these directories
is recreated as necessary during normal SOLIDWORKS use.

These new tasks replace the following tasks:

• Clean the temporary files in SOLIDWORKS data folders
• Run checkdisk to check for disk errors
• Run Windows Defragmenter

27

Using SOLIDWORKS on the 3DEXPERIENCE Platform



SP2-FD02

Support for the Turkish Language (2024 FD02)

SOLIDWORKS Connected supports Turkish menus and the user interface.

Benefits: This enhancement increases usability for Turkish users.

If you install SOLIDWORKS Connected 2024x HF2 on a Turkish version of Windows, you
can use it with Turkish menus and interface. The 3DEXPERIENCE Task Pane in
SOLIDWORKS Connected does not support Turkish until a future release of
the 3DEXPERIENCE platform.
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Improved Licensing Support for SOLIDWORKS Simulation and SOLIDWORKS Motion
Add-ins (2024 FD02)

If you own licenses for SOLIDWORKS Simulation and SOLIDWORKS Motion, you can
enable them to run in SOLIDWORKS Connected. During the installation of SOLIDWORKS
Connected, you can select SOLIDWORKS Simulation or SOLIDWORKS Motion when
prompted.

Benefits: The add-ins install automatically. There is no need to run the
addswxlicenses.exe tool.

In the installation wizard, enter your serial number. For network licenses, you must
provide an address, such as port@server, of your SolidNetWork License server.

After installing SOLIDWORKS Simulation and SOLIDWORKS Motion:

• You can activate or deactivate standalone versions through the Help menu in
SOLIDWORKS Connected.

• The SolidNetWork License server retrieves licenses when you add them.

Notification of Updated Status When Opening Files (2024 FD02)

When the system opens 3DEXPERIENCE files from your computer, the message bar
notifies you about the new updates to the files on the platform.

Benefits: The notifications help ensure that you are always working with the latest version
of your files.

Save Status

When the system opens 3DEXPERIENCE files from your computer, the message bar
notifies you about the new updates to the files on the platform.
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When you refresh MySession, if any files have newer updates available on the platform,
an orange dot on the cloud icon and a tooltip alert you in the title bar. You can select to
show the outdated components or reload them from the server.

Revision Status

When the system opens individual or multiple 3DEXPERIENCE assembly files from your
computer, and where one or more components of the assembly have newer revisions on
the platform, message bars notify you about the new revisions available on the platform.

For files with revisions, you can update the revisions in the Update Revisions dialog box.

To see this functionality, in MySession, on the action bar, click Tools > Options >
Open and select Refresh MySession after opening files. Some scenarios might
require a manual refresh of MySession.

In earlier releases, if you work with assemblies with a large number of components, you
may have missed the visual status indicators in MySession.
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Bookmarks (2024 FD02)

There are multiple enhancements to bookmarks.

Benefits: Improved organization, new tools and tooltips, and usability improvements help
you work more efficiently.

Reorganized Commands

All bookmark commands are organized to appear on the Lifecycle and Collaboration

CommandManager tab under the Bookmark tool.

• Add to Bookmark

• Add to Recent Bookmark (new)

• Open Bookmark Editor

• Copy Bookmark Link (new)

New Tools

The Add to Recent Bookmark tool adds a file or selected objects to a Recent
Bookmark. You can add a bookmark to the 30 most-recent bookmarks. Select the object,

click Add to Recent Bookmark , and select the recent bookmark to which to add the
objects.

The Copy Bookmark Link tool creates a link to bookmarked objects that you can

share with others. Select components and click Copy Bookmark Link to open the
Bookmark List. Select a bookmark and click Copy Link. The system notifies you of the
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copy. You can then share that link with others in 3DSwym, email, or other methods of
communication.

Tooltips

When you use the Add to Bookmark command, in the Select a Bookmark dialog
box that appears, tooltips list the full names of all the selected components that you are
bookmarking. In earlier releases, the full names were truncated. In addition, if you add
multiple files to a bookmark, for example from an assembly FeatureManager design tree,
the number of components appears at the bottom of the Select a Bookmark dialog box.
Hover over that text to reveal the full names of the components.

Usability

When you click Open Bookmark Editor and have already bookmarked files, the editor
navigates to the bookmarked location of the file. If the file has not been bookmarked,
the editor navigates to the last interacted bookmark location. In earlier releases, the
Bookmark Editor opened with no predetermined location.

In the Open from 3DEXPERIENCE dialog box:

• On the Recent tab, under the list of recently visited bookmarks, you can right-click a
bookmark and click Clear to clear that recent bookmark, or click Clear All to clear all
recent bookmarks.

• On the Recent tab, in the upper-right corner, you can click Remove and select to
remove Unpinned items or All Items from the tiled list of recent items.
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Bookmark Support for File Locations

The number of File Locations that support bookmarks is enhanced. 3DEXPERIENCE
users can save content for practically all File Locations to bookmarks, with a few
exceptions.

All File Locations support bookmarks except for the following:

• Document Templates
• Referenced Documents
• Materials Databases
• Search Paths
• Default Save Folder
• Inspection Default Export Folder

For more information, see Adding Bookmarks for SOLIDWORKS File Locations.
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Sharing Pack and Go Files to 3DDrive (2024 FD02)

3DEXPERIENCE users can share Pack and Go files to 3DDrive from the Pack and Go dialog
box or the Share dialog box.

Benefits: You can easily share Pack and Go files with others by 3DDrive.

To share files to 3DDrive from Pack and Go:

1. In SOLIDWORKS, open the files to share.
2. Click File > Pack and Go.
3. In the dialog box, click Upload to 3DDrive and click Browse to open the Select

Folder dialog box.
4. Select the 3DDrive folder where you want to share the files and click OK.

The Pack and Go dialog box reappears.

5. Click Save to upload the files to the selected 3DDrive folder.

To share Pack and Go assemblies to 3DDrive from the Share dialog box:

1. In SOLIDWORKS, open the assembly file.
2. Click File > Share.
3. In the Share dialog box, click Share file.
4. For File type, select SOLIDWORKS Assembly (*.sldasm, *.zip).
5. Click Continue to open the Pack and Go dialog box. The Upload to 3DDrive option

is selected by default.
6. Next to Upload to 3DDrive, click Browse to open the Select Folder dialog box.
7. Select the 3DDrive folder where you want to share the files and click OK.

The Pack and Go dialog box reappears.

8. Click Save to upload the files to the selected 3DDrive folder.

Pack and Go Dialog Box Changes
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2024 Option Name2023 Option Name

Save to this PCSave to folder

Upload to 3DDriveSave to Zip File

Save as zip fileNone

The Save as zip file option packages the files into a zip file. The path to the zipped
package appears in Save to this PC or Upload to 3DDrive, depending on your selection.

If you run Pack and Go from File Explorer as a stand-alone tool, the Upload to 3DDrive
option is not available.

Quick Tours (2024 FD02)

3DEXPERIENCE users can follow compact, integrated learning modules called Quick Tours.
Each Quick Tour has a sequence of steps shown as interactive popups that point to
elements in the user interface.

Benefits: You can interactively learn the 3DEXPERIENCE apps to help you quickly
understand basic functionality and concepts.

Available Quick Tours:

• User Interface Overview
• Save to 3DEXPERIENCE
• Open from 3DEXPERIENCE

To access Quick Tours, in the Welcome dialog box, on the Learn tab, click Quick Tours.

To start a Quick Tour, click the named button, for example User Interface Overview.
To progress through the steps, click Next inside the popup step. The popups include the
step numbers so you can gauge your progress.
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To exit a Quick Tour, in a step, click X. A message confirms you are exiting the Quick
Tour. You can restart the Quick Tour from the Learn tab.

Managing Missing Fonts (2024 FD02)

When you open a document that is missing fonts, you can permanently turn off all missing
font warnings for that document and all other documents you open in the future that are
missing fonts.

Benefits: You have fewer interruptions to your design work because fewer missing font
dialog boxes appear.

In the missing fonts dialog box, first select Don't show again and then select
Temporarily replace all missing fonts.

The missing fonts dialog box automatically dismisses itself after a configurable time that
you specify in Tools > Options > System Options > Messages/Errors/Warnings
> Assemblies > Automatically dismiss reference and update messages after n
seconds. If the dialog box automatically dismisses itself, the document uses the
Temporary replace all missing fonts option.

In earlier releases, in the missing fonts dialog box, you had only the first two options to
select a new font or temporarily replace a missing font.
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Saving File Preparation Assistant Results to HTML (2024 FD02)

For 3DEXPERIENCE users, the File Preparation Assistant automatically saves the results
to an HTML file that is saved in the default location used for the log files. This HTML file
replaces the previously output a CSV file.

Benefits: You can study the File Preparation Assistant results in a more-user-friendly
HTML file.

To display the required data, click Statistics as shown earlier or Alerts as shown below.
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To download individual reports as CSV files from the HTML analysis, click next to the
report.

You can review this HTML output to evaluate potential issues that might impact uploading
the file to the 3DEXPERIENCE platform.
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Accessing 3DDrive in Export as Package (2024 FD02)

You can use the Open 3DDrive after export option as part of your workflow for exporting
a package.

Benefits: 3DDrive opens in the task pane without explicitly opening in a web browser.
This improves the experience as you do not need to switch windows.

In earlier releases, you had to upload the package to 3DDrive and then open 3DDrive
manually to share the package. With the Open 3DDrive after export option, 3DDrive
opens in the task pane and highlights the uploaded package. This helps you to quickly
identify the uploaded package and perform different actions like share, preview, add to
favorites, move to.
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Installing Sync Client for 3DDrive (2024 FD02)

You can now choose if you want to install the 3DEXPERIENCE Drive for Windows. In
earlier releases opening 3DDrive or performing any actions in the files located in 3DDrive
required mandatory installation of 3DEXPERIENCE Drive for Windows.

Benefits: As per the preference for installation of 3DDrive, the usability of the app
changes.

While uploading or downloading files, a dialog box displays the options to install the
3DEXPERIENCE Drive or continue without installing 3DEXPERIENCE Drive.

If you choose Install, there is no change in the behavior of 3DDrive. You can work
simultaneously with the files in SOLIDWORKS and keep it synced with 3DDrive.

If you choose Continue without Install, the files will not be synced automatically.
However, you can perform all the operations of upload, download, and drag a file from
3DDrive to SOLIDWORKS. Also, when you drag multiple files from 3DDrive to SOLIDWORKS
all the selected files open in SOLIDWORKS. But if you drag an assembly structure in
SOLIDWORKS, only the assembly is downloaded and opened in SOLIDWORKS. The
reference files are not downloaded.
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Informing Users about Unsupported SOLIDWORKS Version (2024 FD02)

An appropriate message appears if the installed SOLIDWORKS version is not compatible
with the current version of the 3DEXPERIENCE Platform.

Benefits: You are informed to install the supported version so that you can continue
working in compatible environments.

Depending on the installed SOLIDWORKS version and its compatibility with the
3DEXPERIENCE Platform, you can either continue using SOLIDWORKS or get blocked.

For a given 3DEXPERIENCE Platform release X, one of the following situations might
occur:

• The last 3 SOLIDWORKS versions are supported: X, X-1, and X-2.
• A warning is displayed if the SOLIDWORKS version is X-3. Here, the message suggests
you upgrade to a higher version that is compatible with the 3DEXPERIENCE Platform.
You can continue using SOLIDWORKS, but the version will be deprecated in the
subsequent releases.

• An error message is displayed if the SOLIDWORKS version is X-4. In this case, you
can proceed only when you install a higher version.
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Viewing the Drawing Annotations (2024 FD02)

You can now view the annotations for the extended attributes of a drawing in 3DPlay or
3DMarkup.

Benefits: You can track the lifecycle of a drawing by viewing its properties in the preview.

In earlier releases, when you changed the maturity state of a drawing to Released you
were able to view its properties only through the Properties page. Now, if you view the
drawing in 3DPlay or 3DMarkup along with the PLM properties, the extended properties
are also visible.

The supported extended attributes are:

• $PLMPRP.ea_releaseddate.1
• $PLMPRP.ea_releasedby.1
• $PLMPRP.ea_createdby

The annotations for the extended attributes are visible only if the drawing is released
using the Change Maturity command in the Collaborative Lifecycle app.
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Selecting the Tree View for Objects in MySession (2024 FD02)

You can choose the way the objects and their associated instances appear inMySession.

Benefits: You can view the unique references and the number of the references used in
a particular product structure. These enhancements help you to review and evaluate the
product design and quickly analyse the Bill of Material.

In the Options dialog box, a new tab MySession is added. In this tab, you can choose
a type of tree view that appears in MySession.
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The types of tree view are: Instance View, Reference View, and FeatureManager
Tree View. Based on the view selected, the objects and their associated instances appear
in MySession. Also a Quantity column is added in MySession that displays the number
of associated instances.

On-Premise: Using the Derived Format Converter for Generating Output (2024 FD02)

You can now generate output for SOLIDWORKS files asynchronously only by using the
Derived Format Converter.

Benefits: This improves the quality of the output and also the efficiency of the save
process.

Earlier the CGR and UDL output formats were not supported for save process through
Batch Save to 3DEXPERIENCE command or asynchronous save. To overcome this
situation, install the Derived Format Converter.
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Viewing PartSupply Components SOLIDWORKS (2024 FD02)

The PartSupply app now opens in the SOLIDWORKS task pane.

Benefits: This improves the user experience of accessing the app and saves the reloading
time.

When you open PartSupply in any of the following ways, it opens in the SOLIDWORKS
task pane.

• Design Library
• Insert Components
• Compass > As a Business Model
• Compass > Part Supply Optimised Components

Also PartSupply is added to the list of apps and you can switch between different apps

easily from the top bar by clicking .
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Opening Route Management in SOLIDWORKS (2024 FD02)

You can now open the Route Management app in the SOLIDWORKS task pane.

Benefits: This enhances the experience of using the different 3DEXPERIENCE platform
apps without opening them in a web browser and thus saves the reloading time.

Route Management helps to create, access, and manage routes and route templates.
The app is added to the list of apps and you can switch between different apps easily

from the top bar by clicking . You can also open the notifications received from this
app within the SOLIDWORKS task pane.

Managing Bookmark Reference in Batch Save (2024 FD02)
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An option Assign Bookmark to referenced data located outside selected folder is
added to the Batch Save to 3DEXPERIENCE dialog box.

Benefits: You get the flexibility to attach the referenced files to the bookmarks.

While saving with Batch Save to 3DEXPERIENCE, if in a folder there are files with
references in other folder, and the Include referenced files located outside the
selected folder and Assign Bookmark to referenced data located outside selected
folder options are selected, the references get added to the selected bookmark.

SP1-FD01

Sharing Files (2024 FD01)

The various methods of sharing files are unified into a single Share tool on the Lifecycle
and Collaboration toolbar.

Benefits: You have a consistent method that simplifies and accelerates sharing files.

To access this tool, you can also click File > Share. The Share tool lets you share files
using one dialog box. You can:

• Share by 3DDrive
• Share by 3DSwym communities and conversations
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Automatically Fix Missing References (2024 FD01)

If you open a 3DEXPERIENCE file from your computer and some of the references are
missing on your machine, you can use the Unable to Locate References dialog box to fix
the missing references.

In the dialog box, you can select Reload from server to download all the missing
references from the platform or Suppress all references to fix the missing references
later.

Benefits: You can more easily fix broken references to files. In previous releases, you
had to individually find and download all missing references from the 3DEXPERIENCE
platform.

Missing references typically happen if the file is already saved to your local cache and
some of the references were deleted from the local cache.

If you are not connected to the 3DEXPERIENCE platform, the existing dialog box appears
and is unchanged. You can select Browse for file, Suppress this component, or
Suppress all missing components.
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Double-Clicking SOLIDWORKS Files to Open SOLIDWORKS Connected (2024 FD01)

From File Explorer, you can double-click or right-click > Open a SOLIDWORKS file to
start SOLIDWORKS Connected and open the file. In previous releases, you could open
SOLIDWORKS Connected only from the Compass in a browser or from a desktop shortcut.

Benefits: You can more quickly and conveniently open the SOLIDWORKS Connected app
to view files.

• If you are required to log in, SOLIDWORKS Connected prompts you for your username
and password when you double-click a file.

• If you have installed both SOLIDWORKS Connected and SOLIDWORKS, the software
prompts you to choose the app to open.

• If SOLIDWORKS Connected cannot find the last-used tenant, the software prompts
you to open the app from the Compass or a desktop shortcut.
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Collaborative Space Selection Menu (2024 FD01)

The collaborative space selection menu now appears in only two locations: The Save to
3DEXPERIENCE dialog box and inMySession > Edit preferences. The menu is removed
from all other locations where it was previously located.

Benefits: The collaborative space selection workflow is clearer and more understandable.

Specifying a New Part or Assembly as a Single Physical Product (2024 FD01)

You can designate a new part or assembly as a single physical product.

When you select Update SOLIDWORKS files for compatiblity with the
3DEXPERIENCE platform, these options are available:
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Uses representations to show different
configurations of a model.
Select this option if you do not use unique
part numbers for your configurations.

Allow a single physical product in new
parts and assemblies

Uses physical products to show different
configurations of a model.
Select this option if you use unique part
numbers for your configurations.

Allowmultiple physical products in new
parts and assemblies

To specify a new part or assembly as a single physical object:

1. Click Tools > Options > System Options > 3DEXPERIENCE Integration.
2. Select Update SOLIDWORKS files for compatibility with the 3DEXPERIENCE

platform.
3. Select an option:

• Allow a single physical product in new parts and assemblies
• Allow multiple physical products in new parts and assemblies

4. Create a new part.
5. Save the part to the 3DEXPERIENCE platform.

Selecting Recently-Accessed Bookmarks (2024 FD01)

You can select from recently-accessed bookmarks in the Save to 3DEXPERIENCE dialog
box.

Benefits: You can quickly select the bookmarks that you have used recently as part of
the Save workflow.

In the Save to 3DEXPERIENCE dialog box, the Select from Recent option in the Select
Bookmark list lists the 10 most recently accessed bookmarks. Each time a bookmark is
chosen from the Select Bookmark dialog box, the recent list is updated.

Managing Deleted Configurations (2024 FD01)

If a structure has physical products that are deleted locally, the save process is blocked
and an appropriate warning is displayed in the Status column of the Save dialog box.

Benefits: You can troubleshoot more easily when the save process fails.

If you continue to save a structure that contains deleted physical products, the Relations
app opens, allowing you to change the reference relationships and remove the
dependencies.
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Editing the Properties of an Object (2024 FD01)

You can edit the properties of an object from the Action Bar > View > Display Side

Panel > Properties. In the Properties tab of Display Side Panel, click Edit to
edit the attributes of the object.

Benefits: In earlier releases the properties of an object from Display Side Panel were
not editable.

Once the attributes are edited, the changes that impact SOLIDWORKS files are propgated
to the Properties dialog box.

Selecting an Appropriate Collaborative Space (2024 FD01)

If multiple organizations belong to a common collaborative space, the collaborative space
list in the Save dialog box and the Destination column in the Batch Save to
3DEXPERIENCE dialog box display the name of the collaborative space and the name of
the organization.

Benefits: You can easily select a collaborative space that has write access before the save
operation starts.

The save operation is blocked if you have read access to the selected collaborative space.
An error message in the Status column indicates whether you have write access to the
selected collaborative space.

Connecting to the 3DEXPERIENCE Platform from SOLIDWORKS (2024 FD01)

A Welcome dialog box appears when you connect to the 3DEXPERIENCE platform for
the first time. Also, a notification is displayed when a connection is established with the
3DEXPERIENCE platform.

Benefits: The intuitive messages inform you if the connection to the 3DEXPERIENCE
platform is successful or not.

The Welcome dialog box provides a way to open documents, view folders, and access
SOLIDWORKS resources. You can view the user name and the profile picture of the logged
user in the upper-right corner of the Welcome dialog box and SOLIDWORKS window.
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File Preparation Assistant - Additional Checks (2024 FD01)

The File Preparation Assistant dialog box contains two additional options to check for
out-of-date configuration data and incompatible files. The software also silently performs
two other checks for file names and the number of configurations.

Benefits: More checks improve the success of saving your files to the 3DEXPERIENCE
platform.

DescriptionAdditional Check

Lists information about outdated
configurations. This could happen if you

Detect out-of-date configuration data

delete a configuration and do not rebuild
the model. Rebuild the documents before
saving them to the 3DEXPERIENCE
platform.

Runs the compatibility check on the selected
files, which verifies if the files have been

Detect files not updated for
3DEXPERIENCE compatibility

updated to the new 3DEXPERIENCE
Configuration Manager.

To automatically update files for
3DEXPERIENCE compatibility, click Tools
> Options > System Options >
3DEXPERIENCE Integration and select
Update SOLIDWORKS files for
compatibility with the 3DEXPERIENCE
platform. For more information, see
SOLIDWORKS Help: 3DEXPERIENCE
Integration Options.
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DescriptionAdditional Check

To manually update files for 3DEXPERIENCE
compatibility, with a model open in the
FeatureManager design tree, right-click the
top item and select Update for
3DEXPERIENCE Compatibility. For more
information, see SOLIDWORKS Help:
Updating Models for 3DEXPERIENCE
Compatibility.

The File Preparation Assistant automatically performs two additional silent checks.

DescriptionAdditional Silent Check

Updates files that have old file format
extensions (.prt, .asm, .drw) to the

Updates file extension

current file extensions (.SLDPRT, .SLDASM,
.SLDDRW).

Counts the number of configurations and
displays that information in the log file.

Number of configurations

CAD Family Tab (2024 FD01)

Models updated to the 3DEXPERIENCE platform can use only the CAD Family tab for
configuration views.

Previously, updated models appeared in the CAD Family tab and the
ConfigurationManager tab when you selected Both CAD Family and Configurations.
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In Tools > Options > System Options > FeatureManager, the Only CAD Family
View and the Both CAD Family and Configurations options have been removed.

Updating the Server Information in the 3DEXPERIENCE Files on This PC Tab (2024 FD01)

The current server information for the files on the 3DEXPERIENCE Files on This PC tab
might become outdated. To overcome this, the Refresh command is replaced with two

options: Refresh View and Refresh from Server .

Benefits: You can synchronize cache files with the 3DEXPERIENCE platform. While the
refresh operation is in progress, you can continue using SOLIDWORKS.

Refresh from Server is also available on the shortcut menu.

While the refresh operation is continuing, a progress message informs you about the
estimated time for the operation and the number of files in the queue to be refreshed.

When the operation finishes, a notification message gives details about the number of
files refreshed from the 3DEXPERIENCE platform.

The 3DEXPERIENCE Files on This PC tab includes the Last Refreshed column, which
displays the time when the files were last synchronized with the 3DEXPERIENCE plaform.

Selecting the Position of Work Under (2024 FD01)

When MySession is loading, you can hide or display the Work Under and also select
its position.

Benefits: You can control the visibility and position of theWork Under, so that it reduces
the probability of wrong operations.

On the Preference page, you can select the Display Work Under option to decide its
visibility. Using theWork Under Postion option, you can choose the position where the
Work Under is displayed.
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Linking PLM Custom Properties of Representations to Physical Products (2024 SP1)

The software links the PLM attributes of custom properties of representations to the parent
physical products.

The software adds **** as a prefix to Evaluated Value and displays a footnote if the:

• Configuration is a representation
• Custom property has at least one PLM attribute that it inherits from the parent physical
product

Previously, for a PLM property, the software did not display a value for a representation
of a parent physical product.

Click Tools > Options > 3DEXPERIENCE Integration and select Update
SOLIDWORKS files for compatibility with the 3DEXPERIENCE platform.

In the Properties dialog box, when you select a representation, the evaluated value
appears for the PLM property that you select.

Support for the 3DEXPERIENCE (Design with SOLIDWORKS) Add-In in Routing (2024
SP1)

With the 3DEXPERIENCE (Design with SOLIDWORKS) add-in, you can use routing
components or assemblies from the 3DEXPERIENCE platform.

For more information, see Using the 3DEXPERIENCE Add-In with Routing (2024
SP1) on page 276.
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Defining Rules for Updating Models to the 3DEXPERIENCE Platform

You can use the 3DEXPERIENCE Integration Rules Editor to specify if a configuration is
mapped as a physical product or a representation when you update a model to the
3DEXPERIENCE platform.

When creating a sub-type rule, you specify document level criteria like filename, custom
properties, and weldments and sheet metal file types. You can use these rules to group
parts and assemblies.

For each sub-type rule, you define a configuration mapping rule to specify if the
configuration is a physical product or a representation.

To save a part configuration that is referenced by an assembly as a physical product, you
must create a sub-type rule. Previously, the part configuration was always saved as a
physical product.

You can save the rules in the 3DEXPERIENCE Integration Rules Folder.

New configurations are not created when you update a model.

To open the 3DEXPERIENCE Integration Rules Editor:

1. Open a model and click Tools > Options > 3DEXPERIENCE Integration.
2. Click 3DEXPERIENCE Intergration Rules Editor.
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Creating a Single Physical Product

In the Design with SOLIDWORKS app, you can use Remove CAD Family to designate
a part or an assembly as a single physical product.

When you remove the CAD Family, the following changes occur:

• The part or assembly becomes a physical product.
• If the physical product is the active configuration, SOLIDWORKS uses the physical
product as the single physical product. If the representation is the active configuration,
SOLIDWORKS uses the parent physical product of the representation as the single
physical product.

• Other configurations change to representations of the single physical product.

• Inserts new physical product is disabled.
• The ConfigurationManager title changes from Configurations: <CAD Family> to
Configurations.

When you have a single physical product, you can change the configuration used for the
physical product. Right-click a representation and click Convert to Physical Product
.

You can add a CAD Family object to a single physical product. Right-click the physical
product and click Create CAD Family.

You cannot use Convert to Physical Product on the following configurations:

• Speedpak configurations
• Exploded views
• Model Break views
• Defeature configurations
• Child configurations that required a parent configuration

To create a single physical product:

1. Open a model that has multiple physical products.
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2. Right-click the CAD Family and click Remove CAD Family.
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3
Installation

This chapter includes the following topics:

• Installation Access Starting with SP0 for SOLIDWORKS Student and Education
Editions

• Render Installation Manager with Microsoft Edge WebView 2
• Inactivity Timeout for SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation,

and SOLIDWORKS Plastics
• Show Install Progress in Windows Taskbar

Installation Access Starting with SP0 for SOLIDWORKSStudent and Education
Editions

Users with Student and Education licenses can install SOLIDWORKS version 2024 starting
with SP0. Previously, these users could not access SOLIDWORKS until SP2.

Render Installation Manager with Microsoft Edge WebView 2
The SOLIDWORKS Installation Manager uses Microsoft Edge WebView2 to render the
Installation Manager pages. WebView2 installs if not found on your machine.

Previously, the Installation Manager pages were rendered with Microsoft Internet Explorer.

Inactivity Timeout for SOLIDWORKS Simulation, SOLIDWORKS Flow
Simulation, and SOLIDWORKS Plastics

When you run SOLIDWORKS Simulation, Plastics, or Flow Simulation studies, the network
licenses remain active and do not time out. SOLIDWORKS holds the licenses during the
calculation process, which is considered an activity.

Inactivity periods, defined by a TIMEOUT option, only take effect after the studies finish
calculating.

Previously, licenses could time out while studies were still running. In situations with
limited licenses, another user in the network could take your licenses, leaving you without
licenses to resume an analysis after completing a study.
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Show Install Progress in Windows Taskbar

When you open the SOLIDWORKS Installation Manager (SLDIM) and select installation
options, the progress bar shown in the SLDIM reflects in the Windows taskbar.

These operations include:

• Download Progress
• Install Progress
• Modify Progress
• Repair Progress
• Uninstall Progress
• Create Admin Image Progress
• Installations from Admin Image where the progress bar displays
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4
SOLIDWORKS Fundamentals

This chapter includes the following topics:

• Managing Missing Fonts (2024 FD02)
• 3DEXPERIENCE Compatibility Updates in the SOLIDWORKS Task Scheduler (2024

SP1)
• Changes to System Options and Document Properties
• Accelerate the Display of Silhouette Edges
• Application Programming Interface
• Saving SOLIDWORKS Documents as Previous Versions

Managing Missing Fonts (2024 FD02)

When you open a document that is missing fonts, you can permanently turn off all missing
font warnings for that document and all other documents you open in the future that are
missing fonts.

Benefits: You have fewer interruptions to your design work because fewer missing font
dialog boxes appear.

In the missing fonts dialog box, first select Don't show again and then select
Temporarily replace all missing fonts.
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The missing fonts dialog box automatically dismisses itself after a configurable time that
you specify in Tools > Options > System Options > Messages/Errors/Warnings
> Assemblies > Automatically dismiss reference and update messages after n
seconds. If the dialog box automatically dismisses itself, the document uses the
Temporary replace all missing fonts option.

In earlier releases, in the missing fonts dialog box, you had only the first two options to
select a new font or temporarily replace a missing font.

3DEXPERIENCECompatibility Updates in the SOLIDWORKSTask Scheduler
(2024 SP1)

You can schedule a task to update SOLIDWORKS parts and assemblies for 3DEXPERIENCE
compatibility. The update modifies custom properties and configuration behavior to align
with the 3DEXPERIENCE requirements.

You can also apply 3DEXPERIENCE integration rules to the task. The rules map parts and
assemblies to physical products and representations in the platform. For details about
using 3DEXPERIENCE integration rules, see SOLIDWORKS Help: 3DEXPERIENCE Integration
Options.

This task is exclusively intended for customers who are preparing to save their models
to the 3DEXPERIENCE platform. Once the update is applied, you cannot revert the
changes.

To create a 3DEXPERIENCE compatibility update task in the SOLIDWORKS Task
Scheduler:

1. In SOLIDWORKS, go to Tools > SOLIDWORKS Applications > SOLIDWORKS
Task Scheduler.

2. Click 3DEXPERIENCE Compatibility on the sidebar.
3. Specify the following:

• Title
• Optional 3DEXPERIENCE integration rules file

4. Add the files or folders that you want to update.
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5. Schedule the task, specify the backup location and advanced options.
6. Click Finish.

Changes to System Options and Document Properties
The following options have been added, changed, or removed in the software.

System Options

AccessDescriptionOption

AssembliesDefines default values for Add Prefix
and Add Suffix when creating
opposite-hand components.

Opposite hand mirror
components

AssembliesDefines a default prefix for virtual
components that are created from
external files.

Prefix for virtual
components created from
external files

DisplayControls the visibility of dimensions.Display DimXpert
dimensions on top of
model

DisplayChanged to a slider that allows the user
to increase or decrease the transparency
of the graphics circle.

Display SpeedPak
graphics circle

ColorsSpecifies a color for overridden
dimensions.

Drawings, Overridden
dimensions

PerformanceEnables the GPU hardware to improve
the display of silhouette edges in HLR,
HLV, and wireframe view modes.

Hardware accelerated
silhouette edges

SketchTurns on sketch dimension previews.Preview sketch
dimensionwhen selected

Drawings >
Performance

Opens a drawing by default in Detailing
mode.

Always open a drawing
in detailing mode

File LocationsUnder Show folders for, specifies a
location for defeature rule sets,
*.slddrs, and related log files.

Defeature Rule Sets

FeatureManagerRemoved from system options.Only CAD Family View
and Both CAD Family and
Configurations
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Document Properties

AccessDescriptionOption

Annotations >
Geometric
Tolerances

Specifies a value for the Decimal
Separator. Options are Comma or
Period.

Decimal Separator

DetailingHighlights the associated elements of a
dimension.

Highlight associated
elements of dimension
selection

Dimensions >
Linear

Places dimension text that cannot fit
within the extension lines outside of the
extension lines on an extended
dimension line.

Offset text automatically
when space is limited

Dimensions >
Linear

Specifies arrowhead replacements when
arrowheads overlap. Options are Points
or Oblique Strokes.

When arrowhead
overlaps substitute
arrowhead termination
automatically with:

Drafting
Standard >
Tables

(Available for parts only). Specifies the
options for hole tables in the active
document.

Hole

DimensionsDisplays the color of overridden
dimensions.

Highlight overridden
dimensions in a different
color
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Accelerate the Display of Silhouette Edges

You can enable the GPU hardware to improve the display of silhouette edges in HLR, HLV,
and wireframe views.

In Tools > Options > System Options > Performance, select Hardware accelerated
silhouette edges.

Application Programming Interface
See SOLIDWORKS API Help: Release Notes for late-breaking updates.

• Access the configuration-specific custom PropertyManagers of cut lists and assembly
components

• Retrieve errors that occurred during the last call to IFeatureManager::CreateFeature
• Use the option, Exclude parent surface, to exclude the parent surface from the
Surface-Untrim feature result

• Insert bills of materials (BOMs) in parts, assemblies, and drawings with detailed cut
lists and specify whether to dissolve components in indented BOMs

• Get and set whether to display dual unit values in dimension range lengths of geometric
tolerance symbols

• Get and set the decimal separator type for geometric tolerance symbols
• Get the diameter of a model's spherical bounding box
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Saving SOLIDWORKS Documents as Previous Versions

Beginning with SOLIDWORKS 2024, you can save SOLIDWORKS parts, assemblies, and
drawings created or saved in the latest version of SOLIDWORKS as fully functional
documents in a previous version of SOLIDWORKS. You can save documents back to the
previous two releases. Pack and Go also supports this functionality.

You can save SOLIDWORKS 2024 files as SOLIDWORKS 2023 or SOLIDWORKS 2022
versions. This previous release compatibility lets you share files with others who use one
of the two previous versions of SOLIDWORKS. You cannot extend the previous release
compatibility beyond those two releases.

SOLIDWORKS users must have an active subscription license to access this functionality.
3DEXPERIENCE users are active subscribers by default.

Workflow

You must manually address incompatible items in this process. Incompatible items, as
described in the table below, are items that do not exist or are not supported in the
selected previous release.

Recommendation: Addressing incompatible items might significantly change a model.
Save a copy of the current model and address incompatible items in that copy before
saving it as a previous version.

To save a SOLIDWORKS document as a previous version:

1. Open or save a SOLIDWORKS document in the latest version of SOLIDWORKS.
2. Click File > Save As.
3. In the dialog box, for Save as type, select the previous version to which to save the

document and click Save.
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If the document contains Incompatible Items or Other Items as described below, the
Previous Release Check dialog box appears. Otherwise, the software saves the
document as the previous version.

To open this dialog box at any time, click Tools > Evaluate > Previous Release

Check .

DescriptionTab

Lists items that you must manually
address before you can save the file as a
previous version of SOLIDWORKS. If you
remove or edit the incompatible items, it
might change the mass properties, size,
shape, or rebuild behavior of the model.
In some instances, you must delete the
incompatible item. In other instances,
changing a feature option might address
the incompatible item. The list of
incompatible items is in the order that
they first appear in the FeatureManager
design tree.

Incompatible Items

Lists items that the software will
automatically remove in the save process.
These are items that do not impact the
rebuild, mass properties, or topology of
the document, such as display items like
annotations or information on drawings.

Other Items
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If the document contains only Other Items and no Incompatible Items, on the Other
Items tab, click ProceedWith Save to save the document to the previous version.

After you address all the Incompatible Items, a message confirms that the document
is fully compatible with the selected previous release.

4. Repeat the save process to save the file as the previous version.
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5
User Interface

This chapter includes the following topics:

• Deleting Rolled-Back Features (2024 SP2)
• Usability
• Hide and Show
• Icon Updates for Open, Save, and Properties Commands

Deleting Rolled-Back Features (2024 SP2)

You can delete features that are in a rolled-back state from models.

Benefits: You can delete rolled-back features that might have blocked you from completing
your design.

To delete rolled-back features:

1. In the FeatureManager design tree of your model, drag the rollback bar to roll back
some features.
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2. Right-click a rolled-back feature (below the rollback bar) to delete and click Delete

.

3. In the Confirm Delete dialog box, verify that you accept the deletion and click Yes.

The feature and dependent items that you agreed to delete are deleted from the
model. You can now drag the rollback bar to the bottom of the FeatureManager design
tree to exit the rolled-back state.
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Usability

Usability (2024 SP2)

The user interface is enhanced to improve productivity.

The following items appear with SOLIDWORKS 2024 SP2.

Issues indicator
for folders in the
FeatureManager
design tree

A prefix (-) appears next to the folder name to indicate that the folder has
components with some issues.

In parts, the prefix indicates that some features have underdefined sketches
or missing references. In assemblies, the prefix indicates that some
components are underconstrained.

The prefix also appears if subfolders contain features or components that
have these issues.

Tools > Selection
submenu

Under Tools, the Selection submenu contains all the selection commands
that were previously listed directly under Tools. This gives you quicker
access to the entire Tools menu.
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Restructured
CommandManager
tab - Evaluate

The Evaluate CommandManager tab for parts and assemblies is reorganized
to provide quicker access to commands. The tab is unchanged for drawings.

Larger dragger
and splitter lines

The drag zone for lines that you use to drag or split sections of the user
interface are consistently sized. For example, the drag line in the Task Pane
and the vertical adjuster line in Motion Studies are double the size of
previous versions. This improves selection and dragging.

Searching the
Design Library
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You can use the Search bar to search the Design Library or within a specific
library. To limit the search to a specific library, click the down arrow and
select a library.

In earlier releases, there was no search functionality for the Design Library.

If you select Toolbox but did not configure it, a prompt appears directing
you to add in Toolbox.

Dialog box for
default templates

When there are issues with your default template not being available for
parts, assemblies, or drawings, the Default template not available dialog
box appears with these options:

• Use a blank template. Creates a default template.
• Select a template. Opens the New SOLIDWORKS Document dialog box
where you can select a template to use.

• Add the selection as the default template check box. Applies the
selected template to all files that you are opening. When you select this
option, the Default template not available dialog box no longer
appears for files that you open in the future that have issues with their
default templates. Those files use the default templates that you have
specify here.

In earlier releases, you received this alert.
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It appeared when you upgraded your version of SOLIDWORKS and had
issues with the default templates, such as incorrect paths. Also, when
3DEXPERIENCE users downloaded files from the platform, such as in an
assembly, as the components downloaded, this alert appeared for each
component with no option to apply your selected template to all the
subsequent components.

Usability (2024 SP0)

The user interface is enhanced to improve productivity.

The following items appear with SOLIDWORKS 2024 SP0.

Coordinate
System to
Save

In the Save As dialog box, you can choose which coordinate system to
save with a file. In the dialog box, in Output Coordinate System,
specify the coordinate system to save. When you open the file, the new
coordinate system is the origin.

This functionality does not apply to parts or assemblies. It applies to
the following file types:

• 3D Manufacturing Format (*.3mf)
• ACIS (*.sat)
• Additive Manufacturing File (*.amf)
• IFC 2x3 (*.ifc)
• IFC 4 (*.ifc)
• IGES (*.igs)
• Parasolid (*.x_t;*.x_b)
• STEP AP203 (*.step;*.stp)
• STEP AP214 (*.step;*.stp)
• STL (*.stl)
• VDAFS (*.vda)
• VRML (*.wrl)
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Opening
SOLIDWORKS
Files from
Shortcuts

You can drop a shortcut to a SOLIDWORKS file directly from a local
drive into SOLIDWORKS to open the file.

Selecting
Materials

In the Material dialog box, you can double-click a material to
automatically apply the material to the model and close the dialog box.
You can still click Apply to review the material properties before applying
the material.

Hide and Show

When you multiselect bodies, planes, or sketches that have a combination of shown and
hidden states in the FeatureManager® design tree, the context toolbar shows both the

Hide and Show tools. You can click Hide or Show to change the visibility state of
all the selected entities.

The Hide and Show tools also appear when you multiselect a combination of hidden and

shown planes and sketches. The Show Hidden Bodies tool is added to the Tools >
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Customize > Commands > Features tab so you can add it to toolbars and the

CommandManager. You can use the Search tool or the S key to find Show Hidden

Bodies and Show Hidden Components .

Icon Updates for Open, Save, and Properties Commands
Tool icons are updated for Open, Save, and Properties commands for SOLIDWORKS and
SOLIDWORKS 3DEXPERIENCE apps.

Change20242023Tool

Arrow colorOpen

Arrow colorOpen Drawing

Removed label lines
and modernized

Save

Removed label lines
and moved pencil

Save As

Removed label lines
and modernized

Save All

New icon with cloudSave to
3DEXPERIENCE
(3DEXPERIENCE
users only)

Removed label lines
and modernized

Save to This PC
(3DEXPERIENCE
users only)

Removed label lines
and modernized

Older Version File

New icon to
distinguish it from
standard Properties
icon

PLM Properties
(3DEXPERIENCE
users only)
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6
Sketching

This chapter includes the following topics:

• Convert Entities as Construction Geometry (2024 SP1)
• Sketch Blocks
• Sketch Dimension Previews

Convert Entities as Construction Geometry (2024 SP1)

In the Convert Entities PropertyManager, you can convert selected sketch entities into
construction geometry.

To convert the entities into construction geometry in a sketch,

1. Click Convert Entities
2. Select the sketch entities to convert
3. Select For construction.
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Sketch Blocks

In the FeatureManager® design tree, you can hide and show individual blocks in sketches.
You can also see whether a block is under defined (-), over defined (+), or fully defined.

To hide and show individual blocks in sketches, right-click the sketch block in the
FeatureManager design tree and click Hide or Show.

Sketch Dimension Previews
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You can preview sketch dimensions when you select a sketch entity.

You can select the dimension to edit it. When you click anywhere else in the graphics
area, the preview dimension disappears.

To turn on sketch dimension previews, click Tools > Options > System Options >
Sketch and select Preview sketch dimension when selected.

To change the dimension preview color, click Tools > Options > System Options >
Colors. Under Color scheme settings, edit the color for Dimensions, Preview.

Sketch dimension previews are not supported for path lengths.
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7
Parts and Features

This chapter includes the following topics:

• Selection Accelerator Toolbar for Chamfers (2024 SP2)
• Graphics Triangle and Face Count (2024 SP1)
• Measuring the Angular Rotation between Coordinate Systems (2024 SP1)
• Measuring the Projected Surface Area of Bodies (2024 SP1)
• Hole Wizard
• Making Multibody Parts from Assemblies
• Body Transparency for Combine Features
• Cylindrical Bounding Boxes
• Excluding Parent Surfaces in Untrim Features
• Flip Side to Cut for Cut Revolves
• SelectionManager for Projected Curves
• Stud Wizard
• Symmetrical Linear Patterns

Selection Accelerator Toolbar for Chamfers (2024 SP2)
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A selection accelerator toolbar is available for chamfers so you can quickly select edges
to chamfer.

Benefits: You spend less time on details and have more time for design.

To use the selection accelerator toolbar:

1. In the Chamfer PropertyManager, click Show selection toolbar to activate the
toolbar.

2. For Items to Chamfer, select an edge to display the selection toolbar in the graphics
area.

3. Hover over the available selections on the toolbar to display the selected edges on
the model in the graphics area. To select those edges, click the item on the toolbar.

The selection accelerator toolbar is available for these types of chamfers:

• Angle Distance

• Distance Distance

• Offset Face

Graphics Triangle and Face Count (2024 SP1)

For parts, the Performance Evaluation dialog box displays the total number of graphics
triangles and faces of all bodies combined plus other useful information.

The dialog box also displays the number of solid, graphics, and surface bodies, and the
total rebuild time in seconds. To access this information, with a part open, click

Performance Evaluation (Evaluate toolbar) or Tools > Evaluate > Performance
Evaluation.
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This information helps you determine the complexity of the model's geometry and the
potential impact on performance.

Measuring the Angular Rotation between Coordinate Systems (2024 SP1)

You can measure the angular rotation between two coordinate systems.

ClickMeasure (Tools toolbar) or Tools > Evaluate >Measure. In the graphics area,
select the two coordinate systems. The results appear in the output section as roll (Phi
Φ - X-axes), pitch (Theta Θ - Y-axes), and yaw (Psi Ψ - Z-axes).

Scroll to the bottom of the Measure dialog box to see the results.

The software calculates the angle of rotation based on the Tait-Bryan (XYZ method)
rotation theory.

All angles appear with positive values. Parallel angles appear as zero or 360 degrees while
perpendicular angles appear as 90 or 270 degrees. Text also appears to indicate parallel
or perpendicular angles.
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Measuring the Projected Surface Area of Bodies (2024 SP1)

You can measure the projected surface area of bodies, faces, and components. The
selections must be solid or surface bodies. In previous releases, you had to create a
sketch and use silhouette entities to calculate this value.

The projected surface area is useful in designing molds for plastic parts. Combined with
the pull direction, the projected surface area helps you calculate the cost of the part and
the machine tonnage.

To measure the projected surface area of a model:

1. Click Measure (Tools toolbar) or Tools > Evaluate > Measure.
2. Select solid or surface bodies, faces, or components of the model.

3. In the dialog box, in Projected On , click Select Face/Plane, and select the
planar face onto which to project the bodies, faces, or components.

The software projects a silhouette of the selections onto the selected planar face and
calculates the projected area.

In the dialog box, Projected Area shows the value for the projected surface area of
the bodies, faces, and components.
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Hole Wizard

Sketching with the Hole Wizard is enhanced when you use the Positions tab of the
PropertyManager.

Under Hole Positions, you can click Existing 2D Sketch and select an existing 2D
sketch to position and automatically create the holes at all endpoints, vertices, and points
of the sketch geometry. You can select sketch entities like lines, rectangles, slots, and
splines. Sketch Options specify the geometry used to automatically create the instances.

Under Sketch Options, there are two options:

• Create instances on sketch geometry (Enabled by default). Positions holes at all
endpoints, vertices, and points of the sketch geometry.

• Create instances on construction geometry. Positions holes at all endpoints,
vertices, and points of the construction geometry.

You can skip hole instances. Under Instances to Skip , select hole instances to skip
in the graphics area.

When you delete a Hole Wizard feature, you can retain the hole position sketch. In the
Confirm Delete dialog box, clear the Delete absorbed features option to delete only
the hole profile sketch and keep the hole position sketch. To delete the hole position
sketch, select Delete absorbed features.
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Making Multibody Parts from Assemblies

The Make Multibody Part tool converts an entire assembly into a separate, single
multibody part that is linked to the parent assembly.

The multibody part reflects all the assembly features that you create in the parent
assembly. Features that you create on the multibody part will not be reflected in the
parent assembly. You can perform post-assembly operations on the multibody part, such
as material removal, and these appear in downstream platform applications.

To create a multibody part, in an assembly, click Tools > Make Multibody Part.

The Make Multibody Part feature appears in the FeatureManager® design tree. Solid
bodies are transferred by default. You can decide which other assembly entities to transfer

87

Parts and Features



such as surface bodies, reference geometry, and materials. Under the Make Multibody
Part feature, the tool groups the entities into folders that show the number of instances.

All the bodies in the multibody part inherit their names from the assembly. They also
match the position of the parts relative to the origin in the parent assembly. You can
choose the configuration to create the multibody part.

Body Transparency for Combine Features

In the Combine PropertyManager, for the Subtract operation, you can make the main
body transparent. This helps you select smaller bodies that are completely immersed
inside the main body.

Click Insert > Features > Combine. In the PropertyManager, under Operation Type,
select Subtract and under Main Body, select Make main body transparent.
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Cylindrical Bounding Boxes

You can create cylindrical bounding boxes that are useful for bodies with cylindrical
geometry such as rotational, circular, or turned parts. SOLIDWORKS® captures the
bounding box parameters and records them in the Custom Properties dialog box.

Click Insert > Reference Geometry > Bounding Box. In the PropertyManager, under
Type of Bounding Box, select Cylindrical. SOLIDWORKS generates the smallest
cylindrical bounding box that fits the model.

Excluding Parent Surfaces in Untrim Features
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You can exclude the parent surface from the results of Surface-Untrim features. In the
Untrim Surface PropertyManager, under Options, select Exclude parent surface to
exclude the parent surface from the Surface-Untrim feature results.

To view the Surface-Untrim feature, hide the parent surface. This option simplifies the
control of the untrimmed surfaces. In earlier releases, you had to use multiple tools to
achieve the required results.

Flip Side to Cut for Cut Revolves

You can flip the side to cut for cut-revolve features, similar to cut-extrude features. This
retains the inner portion of a sketch and discards the region outside the sketch.

In the Cut-Revolve PropertyManager, under Direction 1, select Flip side to cut. In
earlier releases, this option did not exist and required extra steps to achieve the required
results.
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SelectionManager for Projected Curves

In the Projected Curve PropertyManager or if you right-click in the graphics area, you
can use the SelectionManager to select portions of sketches to create projected curves.

To access the Projected Curve PropertyManager, click Insert > Curve > Projected.

With the SelectionManager, you can select only one continuous group of entities. You
cannot select multiple disconnected entities.

In earlier releases, the SelectionManager was not available and you could project only
the entire sketch.
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Stud Wizard

You can apply a StudWizard feature to a shaft that has the same diameter as the thread.
You can modify the size of Stud Wizard features created in previous versions of
SOLIDWORKS so the thread diameter matches the shaft diameter.

The software supports this functionality for studs created on a cylindrical body or surface.
In earlier releases, the thread diameter had to be smaller than the shaft diameter.

Symmetrical Linear Patterns

92

Parts and Features



You can create symmetrical linear patterns from a seed feature. The linear pattern uses
the parameters from Direction 1 to create a symmetrical linear pattern in Direction 2.

In the Linear Pattern PropertyManager, under Direction 2, click Symmetric to create a
symmetrical linear pattern using the Direction 1 parameters.
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8
Model Display

Materials for 3DEXPERIENCE Models (2024 SP2)

The software maps SOLIDWORKS physical materials applied to bodies and parts in
SOLIDWORKS models to bodies and parts of models on the 3DEXPERIENCE platform. In
previous releases, mapping was not supported.

For information about prerequisites for SOLIDWORKS physical materials, see
https://help.3ds.com/HelpDS.aspx?P=11&F=SwsUserMap/sws-t-materialmgmt.htm
Managing Materials in 3DEXPERIENCE.
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9
Sheet Metal

This chapter includes the following topics:

• Rip Tool
• Slot Propagation
• Stamp Tool
• Normal Cut in Tab and Slot

Rip Tool

You can use the Rip tool to create rips in hollow or thin-walled cylindrical and conical
bodies. By selecting an edge on a cylindrical or conical face, you can flatten the part as
sheet metal.

In earlier releases, if you had a cylindrical or conical part, you had to create an intentional
gap in the base sketch to convert the part to sheet metal.

SOLIDWORKS supports straight cuts only, not slanted cuts.

To use the rip tool in a cylindrical part:

1. In a hollow or thin-walled cylindrical or conical part, click Rip (Sheet Metal toolbar).
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2. In the graphics area, select:

a. An edge.

b. A reference point on the model.

The reference point can be on the model or anywhere in the graphics area. If you
select a reference point that is not on the model, the software projects the point
onto the model.

3. Specify options in the PropertyManager and click .
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With the rip completed, you can convert the part to sheet metal using the Insert
Bends tool.

Slot Propagation

When creating a tab and slot feature in an assembly component, you can propagate the
slots to other instances of the same component in the assembly.

If an assembly has a component with a tab previously created with the Tab and Slot
tool, you can propagate slots for that tab to other instances of the component in the
assembly as well.

For example, if you have an assembly with multiple instances of a part with a tab, you
can propagate slots for the corresponding instances.

Slots propagate only when the tab component intersects with the slot component.

If you pattern or mirror a component with a tab, you can select Propagate Slots in the
PropertyManager to apply slots to intersecting components in the assembly.

To use slot propagation for assemblies when creating tab and slot features:

1. In an assembly, click Tab and Slot (Sheet metal toolbar).
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2. In the graphics area, select an edge for the tabs and a corresponding face for the
slots.

3. Specify options in the PropertyManager.

If SOLIDWORKS detects multiple instances of the component in the assembly, you
can specify options under Propagate Slots:

• Only selected. Propagates slots to the selected component only.
• All instances in same parent assembly. Propagates slots to all instances of the
selected component that are in the same parent assembly.

• All instances. Propagates slots to all instances of the selected component.

4. Click .

To use slot propagation for assemblies with existing tab and slot features:

1. In an assembly with a component that has a tab and slot, right-click the component
and click Propagate Slots.

2. In the Slot Propagation PropertyManager, under Instances for slot propagation,
specify an option:

• Only selected. Propagates slots to the selected component only.
• All instances in same parent assembly. Propagates slots to all instances of the
selected component that are in the same parent assembly.

• All instances. Propagates slots to all instances of the selected component.

3. Click .

Slot Propagation PropertyManager

To open this PropertyManager:

1. In an assembly with a component that has a tab and slot, right-click the component
and click Propagate Slots.

Selection

Lists the components to apply the slots to.Propagate slots for
these component(s)

Specifies which components to propagate slots to:
• Only selected. Propagates slots to the selected
components. With this option, you can delete specific
components from the list.

• All instances in the same parent assembly. Propagates
slots to all instances of the selected components that are in
the same parent assembly.

• All instances. Propagates slots to all instances of the
selected components. With this option, if some components
already have a slot, they are ignored.

Instances for slot
propagation
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Stamp Tool

You can use the Stamp tool to create sketch-based parametric forming tools to apply to
sheet metal parts. With sketch-based forming tools, you can create a sketch with a few
parameters to stamp or form the sheet metal.

In earlier releases, you had to define all sketches and features, save the forming tool as
a part (.SLDFTP), then apply it to sheet metal.

Using sketches to create forming tools is a faster way to apply forming tools to sheet
metal parts. The Stamp tool allows more flexibility to experiment with different designs
and parameters.

Using the Stamp Tool

To use the stamp tool:

1. In a sheet metal part, click Stamp (Sheet metal toolbar) or Insert > Sheet
Metal > Stamp.
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2. Sketch a closed profile sketch on the part for the stamp shape.

3. In the PropertyManager, specify options and click .

Stamp PropertyManager

To open this PropertyManager:

1. In a sheet metal part, click Stamp (Sheet metal toolbar) or Insert > Sheet Metal
> Stamp.

Stamp Parameters

Specifies the stamp depth from the top or bottom of the
sheet metal face.

Depth

Reverses the direction of the stamp.Reverse Direction

Specifies the taper angle to apply to the stamp side faces.Draft Angle

Fillet
If you specify a radius in the sketch before creating a stamp, the sketch radius is prioritized
when creating the stamp.
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Specifies the radius created by the die.Die Radius (R1)1

Specifies the radius created by the punch.Punch Radius (R2)2

Adds a corner punch radius.

Specify the Radius created by the corner
punch.

Punch Side Corner
Radius

3

Normal Cut in Tab and Slot

When you use the Tab and Slot tool, you can specify that the slot is normal to the sheet
even if the tab is at an angle to the slot. Slots that are normal to are essential in the
manufacturing process.

In the Tab and Slot PropertyManager, under Slot, select Normal Cut.
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10
Structure System and Weldments

This chapter includes the following topics:

• Corner Management
• Displaying Units in File Properties
• Structure System
• Copying Cut List Properties to Cut List Items (2024 SP1)

Corner Management

You can apply corner treatments manually or automatically.

To open the Corner Management PropertyManager:

1. Open a part and click Structure System > Primary Member.
2. Create primary members and exit the structure system mode.
3. In the PropertyManager, specify an option:

• Automatic. Groups similar corners and applies the corner treatment.
• Manual. Lets you group similar corners and apply the corner treatment.

4. Select Automatic.
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SOLIDWORKS selects a plane that determines the trim order of members. You can
then modify the base plane reference, groups, and corner treatment, if required.

5. Specify a Trim option.

6. Click Next to continue with the corner treatment.

Two Member PropertyManager

The user interface of the Two Member PropertyManager is enhanced.

Enhancements include:

• Changes to trim types and trim options under Corner Treatment. You can select one
of the following trim types:

Trim optionsTrim typeIcon

Planar Trim or Body TrimEnd Butt1

Planar Trim or Body TrimEnd Butt2

Miter Trim

First contact planar trim or Full
contact planar trim

Open Corner

• You can use the End Butt1 and End Butt2 trim options for swapping. Previously, you
could swap the tool and body to trim using the arrows .

• Updated icons:

Trim OptionIcon

Planar Trim

Body Trim

Miter Trim

• Open corner . Trims both members and creates an open corner.
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• The Trim Tool shortcut menu is available in the graphics area. It lets you swap the
member to trim.

• In the PropertyManager, for Trim Tool, you can select Automatic or User Defined.
The User Defined option lets you select a face or a plane to trim.

Complex Corner PropertyManager

The user interface of the Complex Corner PropertyManager is enhanced.

You can use Trim order for Planar Trim. Previously, you could use it only for Body
Trim.
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Editing the Corner Management Options

You can modify the corner treatment.

To edit the corner management options:

1. In the FeatureManager designTree, right-click Corner Management and click Edit
Feature.

2. In the PropertyManager, click Back .
3. Click Reset all corners to clear all corner management settings.

If you edit the structure system and add new corners, the corner management
settings apply to the new corners.
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Displaying Units in File Properties

You can capture and display the units for the Text type of file properties.

To display units in file properties:

1. Click Properties (Standard toolbar).
2. In the Properties dialog box, on the Custom and Configuration Properties tabs, select

a property name.
3. For Type, select Text.
4. Click in Value/Text Expression.
5. From the Properties flyout, select a property to display the evaluated value.
6. From the Units flyout, select a unit.

In previous versions, you could not capture the units for file properties.
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Structure System

Structure system has improved usability in the graphics area and PropertyManager.

• When editing the structure system in the graphics area, you can change the length of
the point length member.

To change the length, double-click the member and click the dimensions. Previously,
you had to edit the length of the point length member from the Primary Member
PropertyManager.

• You can use corner management for profiles of less than 2mm.
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Copying Cut List Properties to Cut List Items (2024 SP1)

You can create cut list properties and copy them to other cut list items.

To copy cut list properties to cut list items:

1. Open a part.
2. In the FeatureManager design tree, right-click a cut list item and select Properties.
3. In the Cut-List Properties dialog box, on the Cut List Summary tab, create a cut list

property.
4. Select the property, click Copy to, and select one of the following:

Copies the selected property to all cut list items.All cut list items

Copies the selected property to specific cut list
items.

Specific cut list items

Copy to is available for user-defined properties only for files that use a new architecture.

Copy to copies the property of a cut list item to:

• All or specific cut list items that are available in the active configuration.
• The same cut list items that are available in the remaining configurations.

Copy Property to Cut List Items Dialog Box

You can use this dialog box to copy a cut list property to specific cut list items.

To access this dialog box, in the Cut-List Properties dialog box, on the Cut List Summary
tab, click Copy to > Specific cut list items.
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DescriptionOption

Selects all cut list itemsSelect All

Resets the selectionReset Selection

Copies the cut list property to the selected
cut list items

OK
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11
Assemblies

This chapter includes the following topics:

• Changing the Transparency of the SpeedPak Graphics Circle (2024 SP3)
• Detecting Interference between Surface Bodies (2024 SP3)
• Selecting an Origin for a New Subassembly (2024 SP2)
• Unsolved Prefix Displays for Suppressed Mates (2024 SP2)
• Component Preview Window Available in Large Design Review (2024 SP2)
• Selection Breadcrumbs Available in Large Design Review (2024 SP1)
• Folder Prefixes (2024 SP1)
• Defeature Rule Sets
• Propagating Visual Properties in Defeature Groups
• Repairing Missing References in Linear or Circular Component Patterns
• Mate References
• Auto-Repair for Missing Mate References
• Assigning Component References to Top-Level Components
• Specifying a Prefix and Suffix for Components

Changing the Transparency of the SpeedPak Graphics Circle (2024 SP3)
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You can use the Display SpeedPak graphics circle slider to change the transparency
of the SpeedPak circle.

When the slider is at 100%, the graphics are transparent. When the slider is Off, the
SpeedPak graphics circle does not display and the pointer changes to an arrow with a

SpeedPak image, .

To change the transparency of the SpeedPak graphics circle:

1. Click Tools > Options > System Options > Display.
2. For Display SpeedPak graphics circle, move the slider to change the transparency.

SpeedPak Graphics CircleSlider
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SpeedPak Graphics CircleSlider

Detecting Interference between Surface Bodies (2024 SP3)

You can use interference detection between surface bodies for assemblies and multibody
parts.

Benefits: You can find and fix interference issues for surface bodies.

To detect interference between surface bodies:

1. Open a model or multibody part that has an interference between surface bodies.

2. Click Tools > Evaluate > Interference Detection .
3. In the PropertyManager, under Options, click Include surface bodies.
4. Under Selected Components, click Calculate.
5. Under Results, scroll to the end for the surface body results.
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When you select the surface interference, the intersecting faces appear in red in the
graphics area.

Selecting an Origin for a New Subassembly (2024 SP2)

You can select an origin when creating a subassembly.

Origin options:

Uses the origin of the parent assembly as
the origin of the subassembly.

Origin of parent assembly

Uses the origin of the first selected
component as the origin of the
subassembly.

Origin of the first selected component

Uses a point or a vertex as the origin of the
subassembly.

Point or vertex

To select an origin for a new subassembly:

1. Open a model and select a component.
2. Right-click the selected component and click Form New Subassembly.
3. In the dialog box, select an option for the origin of the subassembly.
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Unsolved Prefix Displays for Suppressed Mates (2024 SP2)

In a model, the unsolved prefix (?) displays in the mate name when a suppressed mate
has a missing reference.

To view the unsolved prefix:

1. Open a model that has a suppressed mate with a missing reference.
2. In the FeatureManager design tree, expand the Mate folder.

The unsolved prefix (?) shows in the mate name.
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Component Preview Window Available in Large Design Review (2024 SP2)

You can use the Component Preview window when you open an assembly in Large Design
Review mode.

To open the Component Preview Window:

1. Open a model in Large Design Review mode.

2. Right-click a component and click Component Preview Window .
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Selection Breadcrumbs Available in Large Design Review (2024 SP1)

You can use breadcrumbs when you open a model in Large Design Review mode. With
Edit Assembly selected, mates for the selected item show in the breadcrumbs.

To use selection breadcrumbs:

1. Enable breadcrumbs by clicking Tools > Options > System Options > Display
and selecting Show breadcrumbs on selection.

2. Open a model in Large Design Review.
3. In the graphics area or in the FeatureManager design tree, select a component.

The breadcrumbs display in the upper left corner.
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Folder Prefixes (2024 SP1)

In a model, prefixes show in a folder name when the folder contains over defined
components, under defined components, and only fixed components.

Folder prefixes:

Contains at least one over defined component.(+)

Contains at least one under-defined component.(–)

Contains only fixed components.
If a folder contains a component that is not fixed, the fixed prefix does not
show in the folder name.

(f)

Prefixes do not show for folders that contain only well-defined components.

To view a folder prefix:

1. Open a model that has an under-defined component.
2. In the FeatureManager design tree, right-click an under-defined component and click

Add to New Folder.
3. Enter a folder name and click Enter.

The under-defined prefix shows in the folder name.
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Defeature Rule Sets

Using the Defeature Silhouette method, you can create a set of rules to simplify the
components in a model. You can specify criteria for component selection, defeature
method, and a defeature orientation. You can enclose the components in one body and
propagate visual properties.

For example, you can create a rule to simplify fasteners as cyclinders when the filename
for a fastener contains bolt, nut, or washer.

You can save the rule set to use with other models. You can specify a file location for
saved rule sets. You can use a rule set with a defeature group to defeature a model.

Specifying a File Location for Defeature Rule Sets

You can save defeature rule sets and log files to a designated folder.

You can use a saved defeature rule set with a different model. A log file shows the outcome
of applying a defeature rule set to a model. The log file includes a list of components with
a status of OK or Failed.

To specify a file location for defeature rule sets:

1. Click Tools > Options > System Options > File Locations.
2. Under Show folders for, select Defeature Rule Sets.
3. Click Add and select a location.

Creating Defeature Rule Sets

You can use a defeature rule set to simplify your model.

To create a defeature rule set:

1. Open a model, and click Defeature (Tools toolbar) or Tools > Defeature.
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2. In the PropertyManager, select Silhouette .

3. Click Next .
4. Under Apply Defeature Rules to Assembly, click Edit Rules.
5. In the Defeature Rules Editor dialog box, under Name, enter a name.

6. Under Selection Criteria, click Define selection criteria.
7. In the Advanced Component Selection dialog box, select search criteria.

For example, search for fasteners where the filename contains bolt.

8. In the Defeature Rules Editor dialog box, specify the Defeature Type and Defeature
Orientation.

For each rule, Name, Selection Criteria, Defeature Type, and Defeature
Orientation must be populated.

9. Optional: Click Save to save the rules as a defeature rule set, .slddrs.
10. In the Defeature Rules Editor dialog box, click OK to return to the PropertyManager.

Under Apply Defeature Rules to Assembly, the rule status is Pending.

11. Click Apply.

After SOLIDWORKS® applies the rule to the model, the status changes to Done (x
of y bodies OK).
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12. Optional: Click Save log to save the results to a log file.

When you open the log file, you see a list of the defeatured components and the
defeatured status.

Log for defeature silhouette rules applied to C:\Lifts\LIFT.SLDASM

### Rule: Fasteners - bolts ###
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-3@4545: OK
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-2@4545: OK
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-1@4545: OK
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-2@4568: OK
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-3@4568: OK
Hex@12mm NOM x 70mm LG, METRIC SHOULDER BOLT-1@4568: OK
Rule complete: 6 OK, 0 Failed

Defeature - Apply Defeature Rule Sets PropertyManager

In assemblies, you can create a defeature rule set to simplify a model.

You can use a rule set with a defeature group to defeature a model.

To open the Defeature - Apply Defeature Rule Sets PropertyManager:

1. Open a model and click Defeature (Tools toolbar) or Tools > Defeature.

2. In the PropertyManager, select Silhouette .

3. Click Next until the Apply Defeature Rule Sets page appears.

Defeature Rule Sets

Specifies the rule set to load.
None displays when there are no loaded rule sets. Saved
rule sets display in the list.

To specify the file location for the saved rule set, click
Tools > Options > SystemOptions > File Locations.
Under Show folders for, select Defeature Rule Sets.
Click Add to specify a location.

Load a saved Defeature
Rule Set

Apply Defeature Rules to Assembly

Lists the rules.Rule
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Displays the results of applying the rule:

• Pending. Displays when the rule is not applied or when an
existing rule is modified but not reapplied.

• Done (x of y bodies OK). After applying the rule, displays the
number of components processed, x, and the number of
components, y that meet the criteria.

Status

Applies all rules to the model in the order that the rules are listed.
The defeatured geometry generates and a preview displays in the
graphics area.
After a rule is applied to a component, no other rules are applied
to that component.

After saving the model as a part, the defeature components display
in the FeatureManager design tree.

The log file includes a list of components with a status of OK where
components are defeatured or Failed where components are not
defeatured.

Rules apply to part level components. Rules do not apply to
subassemblies.

Apply

Removes all the rules and deletes the simplified geometry applied
to the model.

Clear

Opens the Defeature Rules Editor dialog box.Edit Rules

Saves the log file.Save log

Defeature Rules Editor Dialog Box

You can create a set of rules to automatically simplify the components in a model.

To open the Defeature Rules Editor dialog box:

1. Open a model and click Defeature (Tools toolbar) or Tools > Defeature.

2. In the PropertyManager, select Silhouette .

3. Click Next until the Apply Defeature Rule Sets page appears.
4. Under Apply Defeature Rules to Assembly, click Edit Rules.

Creates a new rule set.New

Opens an existing rule set.Open

Saves the rule set in a Defeature Rule Set file, .slddrs.Save
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Specifies a name for the rule set.Name

Displays the selection criteria.
For a new rule, click Define selection criteria to open
the Advanced Component Selection dialog box where
you define the selection rules.

To modify a rule, click the selection criteria for the rule.
Under Rule Definition, click Selection Criteria.

In the Advanced Component Selection dialog box, the
following functionality is not available when you open
the dialog box from the Defeature PropertyManager:

• Manage Searches tab
• Name of Search
• Apply

Selection Criteria

Specifies a simplification method:
Creates a cuboid bounding box.Bounding Box

Creates a cylinder derived from the
dimensions of a cuboid bounding
box.

Cylinder

Creates an extruded polygon that
fits around the outline of the
selected bodies and components.

Polygon
Outline

Creates an extruded body by using
the outlines of the selected bodies
and components.

Tight Fit
Outline

Creates an exact copy of the
selected bodies and components.

None (Copy
Geometry)

Defeature Type

Creates a single body that includes the specified
components.
• Off
• Per part
• Entire group

When you select Cylinder or None (Copy
Geometry) for Defeature Type, Enclose in one
body is set to Off.

Enclose in one
body
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Specifies a defeature orientation:
• Automatic
• Component XY
• Component YZ
• Component XZ
• Global XY
• Global YZ
• Global XZ

Defeature
Orientation

Includes appearances and textures
in the defeatured model.

Propagate

Omits appearances and textures
from the defeatured model.

Don't
propagate

Visual properties

Displays the selected rule.
Click Selection Criteria to modify the rule.

Rule Definition

Propagating Visual Properties in Defeature Groups

You can include appearances and textures in a defeatured group.

To propagate visual properties in defeature groups:

1. Open a model, and click Defeature (Tools toolbar) or Tools > Defeature.

2. In the PropertyManager, select Silhouette .

3. Click Next until the Defeature - Define Groups page appears.
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4. Under Simplification Method, select Propagate visual properties.

Repairing Missing References in Linear or Circular Component Patterns

You can repair missing direction references in linear component patterns and circular
component patterns.

For linear component patterns, SOLIDWORKS repairs the missing direction reference by
selecting a reference on the component that is the same type and orientation, and is
either the same location or the closest entity to the missing reference.

For circular component patterns, SOLIDWORKS repairs the missing direction reference
by selecting a reference on the component that is the same entity and is coaxial with the
missing axis. If there are multiple options for a replacement axis, SOLIDWORKS selects
the closest to the missing axis.

You cannot use Auto Repair in Large Design Review mode.

To repair missing references in linear or circular component patterns:

1. Open a model that contains a linear component pattern or a circular component
pattern with a missing direction reference.

2. Right-click the pattern and in the context toolbar, click Auto Repair .

If SOLIDWORKS cannot repair the error, you are prompted to repair the pattern
manually.
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Mate References

When creating mate references, you can select Create mates only when names match
to create mate references only when the mate reference names are the same. The name
match applies to primary, secondary, and tertiary reference entities.

To use Create mates only when names match, you must select this option on both
components in the mate reference.

When more than one mate reference is available, the Select Mate Reference dialog
box displays a list of mate references.

The dialog box can appear when using these workflows:

• Inserting a component.
• Dragging a component from the FeatureManager® design tree.
• Dragging a file from the File Explorer tab in the Task Pane.
• Dragging a file from the Design Library tab in the Task Pane.

In the Mate Reference PropertyManager, you can select Lock Rotation for Concentric
mates.

To create mates only when the names match:

1. Open a model with a mate reference where the name of the mate reference is different
for each component.

2. Open one of the components from the mate reference.
3. In the FeatureManager design tree for the component, under the Mate References

folder, right-click a mate reference and click Edit Definition.
4. In the Mate Reference PropertyManager, under Reference Name, select Create

mates only when names match.
5. Copy the Reference Name value to use later.

125

Assemblies



6. Open the other component in the mate reference and repeat the steps to enable
Create mates only when names match.

7. For Reference Name, enter the name from the first component.
8. Close both components.
9. In a model, click Insert > Reference Geometry > Mate Reference.
10. Under References, select Create mates only when names match.
11. Select the two components to mate.

To select a mate reference in the Select Mate Reference dialog box:

1. Open a model where multiple references are available between two components.

In this example, you create a mate reference between a knob and a plate. The plate
has several positions that you can select.

2. Drop the knob over the plate.

Select Mate Reference appears when the knob is over the plate.

3. In the Select Mate Reference dialog box, select a reference.
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Auto-Repair for Missing Mate References

Improvements to Auto Repair for concentric and parallel mates add more criteria for
identifying replacement entities.

For concentric mates, SOLIDWORKS repairs the missing reference by selecting a face on
the same component that has a different diameter and the same axis position.

For parallel mates, SOLIDWORKS repairs the missing reference by selecting a reference
on the same component that has a different position. For planar faces, the missing
reference is repaired with a different planar face that has the same orientation. For plane
references, the missing reference is repaired with a different plane that has the same
orientation. If a matching plane is not available, SOLIDWORKS uses a planar face that
has the same orientation to repair the missing plane reference.

To auto-repair missing mate references:

1. Open a model that contains a concentric mate error.

2. Right-click the mate and in the context toolbar for the mate, click Auto Repair .

If SOLIDWORKS cannot repair the error, you are prompted to solve the mate
manually.
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Assigning Component References to Top-Level Components

In the Component References dialog box, you can enter component references for all
top-level components. You can use the tree order from the FeatureManager design tree
as the component reference.

To assign component references to top-level components:

1. Open a model.
2. Right-click the assembly name in the FeatureManager design tree and click Edit

Component References.
3. In the Component References dialog box, under Component Reference, enter a

component reference for each component.

To use the component order from the FeatureManager design tree, click Use Tree
Order. Existing component references are overwritten.
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Specifying a Prefix and Suffix for Components

You can use a system option to specify a default prefix and a default suffix for
opposite-hand versions of mirrored components. You can also specify a default prefix for
virtual components created from external files.

To specify a prefix andsuffix for components:

1. Click Tools > Options > System Options > Assemblies.
2. Under Prefix / Suffix defaults, specify options:

a. For Opposite hand mirror components, select Add Prefix or Add Suffix, and
enter text.

b. For Prefix for virtual components created from external files, enter text.

3. Click OK.
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12
Detailing and Drawings

This chapter includes the following topics:

• Keeping Chain Dimensions Collinear
• Overridden Dimensions
• Reattaching Dangling Dimensions
• Excluding Hidden Sketches from Flat Pattern DXF Files
• Highlighting Referenced Elements
• Highlighting Associated Center Marks on Center Mark Dimensions
• Keep Link to Property Dialog Box Open
• Opening a Drawing in Detailing Mode by Default
• Select Multiple Layers

Keeping Chain Dimensions Collinear

You can ensure that chain dimensions remain collinear even with limited space.

When dimension text and arrowheads overlap, you can select options for the best fit.

To keep chain dimensions collinear when dimension text overlaps:
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1. Click Tools > Options > Document Properties > Dimensions > Linear > Chain
Dimension.

2. Under Collinearity Options, select Offset text automatically when space is
limited.

For ISO and ANSI, this option is selected by default.

To keep chain dimensions collinear when arrowheads overlap:

1. Click Tools > Options > Document Properties > Dimensions > Linear > Chain
Dimension.

2. Under Collinearity Options, select When arrowhead overlaps substitute
arrowhead termination automatically with: and specify an option:

• Points. Replaces arrowheads with points.
• Oblique Strokes. Replaces arrowheads with oblique strokes.

For ISO, this option is selected by default.

Overridden Dimensions

You can choose to automatically change the color of overridden dimensions.

Previously, you had to click every dimension and view its properties to see overrides.

You can:

• Change the color of overridden dimensions automatically.

To specify the color, click Tools > Options > System Options > Colors. Under
Color scheme settings, edit the color for Drawings, Overridden dimensions.

To display the color, click Tools > Options > Document Properties > Dimensions
and select Highlight overridden dimensions in a different color.
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• Restore the overridden dimension values to their original values.

Right-click the overridden dimension and select Restore Original Value.

Reattaching Dangling Dimensions

You can reattach dangling dimensions in a way that makes the process more reliable.
You can reattach dimensions that are not dangling the same way.

The feature does not support:

• Imported dimensions
• DimXpert dimensions
• Chain dimensions
• Symmetric linear diameter dimensions
• Path length dimensions

To reattach dangling dimensions:

1. Right-click the dangling dimension and click Reattach.

SOLIDWORKS® highlights the dangling point with an X on the first extension line.

2. Select a point on the model to reattach the dangling point to.

The dangling point reattaches to the new selection.

SOLIDWORKS highlights the dangling point with an X on the next extension line.

3. Select a point on the model to reattach the dangling point to.

The dangling point reattaches to the new selection.
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Excluding Hidden Sketches from Flat Pattern DXF Files

In the DXF / DWG Output PropertyManager, when you export a sheet metal flat pattern
as a .dxf file, you can exclude hidden sketches.

To exclude hidden sketches from flat pattern DXF files:

1. In the PropertyManager:

a. Under Export, select Sheet metal.
b. Under Entities to Export, select Sketches and under Sketches, select Exclude

hidden sketches.
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Highlighting Referenced Elements

When you select a dimension, you can highlight the associated elements as well.

The feature does not support the following dimensions:

• DimXpert or sketch dimensions, such as angular running dimensions and ordinate
dimensions

• Cosmetic threads
• Feature dimensions
• Blocked highlight for silhouette edge endpoints
• Referenced edges or points blocked for break view and Detailing mode legacy
dimensions

To highlight referenced elements:

1. Click Tools > Options > Document Properties > Detailing.
2. Select Highlight associated elements on reference dimension selection.
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Highlighting Associated Center Marks on Center Mark Dimensions

When you select a center mark dimension, the associated center marks highlight as well.

To highlight associated center marks on center mark dimensions:

1. Click Tools > Options > Document Properties > Detailing.
2. Select Highlight associated elements on reference dimension selection.

Keep Link to Property Dialog Box Open
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When you create a note in a drawing, in the Link to Property dialog box, you can click
Add to keep the Link to Property dialog box open. You can enter more text or select
another property. The dialog box remains open until you click OK or exit the note.

Previously, you had to close the dialog box and reopen it. Now you can do everything at
once.

Opening a Drawing in Detailing Mode by Default

You can open a drawing in Detailing mode by default.

You can use this to automatically open large drawings quickly.

To open a drawing in Detailing mode by default:

1. Click Tools > Options > System Options > Drawings > Performance.
2. Select Always open a drawing in detailing mode.
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Select Multiple Layers

You can select multiple layers at once to modify.

Previously, you had to select one layer at a time to modify.

You can:

• Ctrl + select each layer that you want.
• Shift + select a range of layers.
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13
Import/Export

This chapter includes the following topics:

• Performance Improvements When Opening 3MF Files (2024 SP3)
• Exporting IFC File - Support for Advanced Surface BREP (2024 SP2)
• Opening Third-Party CAD Files (2024 SP2)
• Using Filters to Import STEP Files (2024 SP1)
• Importing 3MF Files - Support for 3MF Beam Lattice Extension (2024 SP1)
• Canceling the Import of Third-Party CAD Files
• Importing STEP Assemblies as Multibody Parts
• Exporting to Extended Reality

Performance Improvements When Opening 3MF Files (2024 SP3)
Improved performance when opening 3MF files.

Exporting IFC File - Support for Advanced Surface BREP (2024 SP2)
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You can export BREP IFC files with cleaner faces.

For example, in the exported files, you can view:

• Planar faces instead of multiple coplanar facets
• Cylindrical faces instead of multiple facets that represent a cylinder

Opening Third-Party CAD Files (2024 SP2)
When importing file formats, SOLIDWORKS uses the latest conversion technology even
if you clear Enable 3D Interconnect in Tools > Options > System Options > Import.

The conversion technology applies to these file formats:

• ACIS™

• Autodesk Inventor®

• CATIA® V5
• PTC Creo®

• IFC
• IGES
• Solid Edge®

• STEP
• NX™ software
• xDesign SLDXML

Using Filters to Import STEP Files (2024 SP1)
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While importing a large STEP file using 3D Interconnect, you can apply filters before
import. This lets you import selected components from the file using the Import Filter
window.

When you select Enable Filter while importing STEP file (File > Open), you can:

• View the STEP product structure similar to the FeatureManager design tree.
• Select and remove components from the STEP product structure.
• Right-click components and click Keep Components or Exclude Components to
select or remove multiple components at once.

• Generate a minimalistic graphics preview (with fewer details such as excluding

appearances) in the graphics area with Generate 3D Preview .

• Click Import Model or Cancel. after previewing the filtered minimalistic model or
directly without generating the graphics preview.

Importing a large STEP file is faster with improved performance depending on the number
of objects that you select while applying filters. It also helps working with a simplified
model.
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Importing 3MF Files - Support for 3MF Beam Lattice Extension (2024 SP1)

When importing 3MF files containing beam lattices, you can import .3mf beam lattices.

In the FeatureManager design tree, each lattice in the imported file appears as an

independent lattice feature containing one or more disjoint lattice bodies . Lattice
bodies are lightweight bodies with thin lines representing the centerline of the beams.

With the lattice bodies and features, you can:

• Convert them to mesh bodies

This generates the full geometry of the lattice (including the beam diameter, variable
beam diameter, and connecting spheres) as mesh BREP geometry. For more
information, see SOLIDWORKS Help: Graphics Mesh and Mesh BREP Bodies.

• Hide or show them in the graphics area
• Create section views
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Canceling the Import of Third-Party CAD Files

You can cancel the import of a third-party CAD file with 3D Interconnect if importing takes
too long.

To cancel the import of third-party CAD files:

1. Click File > Open.
2. Optional: 3DEXPERIENCE® Users: If the Open from 3DEXPERIENCE dialog box appears,

click This PC.
3. In the Open dialog box, select a third-party CAD file and click Open.
4. In the Open Progress dialog box, while the import status is Reading model, click

Cancel or press Esc.

You cannot cancel when the import status changes to Loading model.

5. In the confirmation dialog box, click Yes.

Importing STEP Assemblies as Multibody Parts
Enhancements related to importing STEP, IGES, and IFC assemblies as multibody parts
include:

• Import is available with a SOLDWORKS® parts-only OEM version.
• The performance of importing STEP, IGES, and IFC assemblies as multibody parts is
improved up to 30%.
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Exporting to Extended Reality

You can export SOLIDWORKS CAD files to .glb or .gltf file formats.

The files contain information such as geometry, appearances, textures, animations, motion
studies, configurations, display states, exploded views, lights, and metadata. For large
files, the export supports Draco, the standard file compression mechanism for .glb and
.gltf files.
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14
SOLIDWORKS PDM

This chapter includes the following topics:

• Displaying the Preview Tab for Search Results (2024 SP2)
• Bill of Materials (BOM) View - Flattened Type (2024 SP2)
• SOLIDWORKS PDM Add-in Enhancements (2024 SP1)
• Assigning Data Cards to Files and Folders of a Template (2024 SP1)
• Folder Card Variables in Web2 (2024 SP1)
• Progress Dialog Boxes (2024 SP1)
• Data Security Enhancements (2024 SP1)
• Assembly Visualization
• Downloading Specific Versions of a File in Web2
• File Type Icons
• Check Out Option in Change State Command
• Viewing Check-Out Event Details
• System Variables
• Viewing License Usage
• SOLIDWORKS PDM Performance Improvements

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately
purchased license for non-SOLIDWORKS users. It offers standard data management capabilities
for a small number of users.

SOLIDWORKS PDM Professional is a full-featured data management solution for a small and
large number of users, and is available as a separately purchased license.
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Displaying the Preview Tab for Search Results (2024 SP2)

In the SOLIDWORKS PDM File Explorer, you can display the Preview tab for an item in
the search result (Quick, Integrated, and Standalone search) at the bottom or to the right
side of the window using the existing Preview Placement option.

Bill of Materials (BOM) View - Flattened Type (2024 SP2)
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In the SOLIDWORKS PDM File Explorer, in the BOM view of the Bill of Materials tab,

you can use the new type Flattened to view the total number of quantities required
of a component present in the product structure.

This option saves time and effort in calculating the total number of quantities of the
components.

The Flattened BOM view displays:

• The product structure as a list of components without indentation.
• The component only once if it is present at multiple levels of the product structure.
• The quantity of the component by adding the quantities at each level.

The Flattened type is available when viewing the computed BOMs in the desktop client
and in Web2.

SOLIDWORKS PDM Add-in Enhancements (2024 SP1)

• When you save an assembly file as a part file, an internal component (saved as an
external file in the vault), or a mirror component using the Save as command, a data
card for the new file displays generating serial numbers and default values if set in the
card.

• The SOLIDWORKS PDM add-in displays an icon overlay and supports all SOLIDWORKS
PDM operations for components that are open in lightweight mode.

• You can enable the Automatically optimize resolved mode, hide lightweight
mode option even when the SOLIDWORKS PDM add-in is active.
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Handling Large Design Review (LDR) and Detailing Mode in the SOLIDWORKS PDM
Add-in (2024 SP2)

For assemblies opened in Large Design Review (LDR) mode and for drawings opened

in Detailing mode, you can view the SOLIDWORKS files structure in the SOLIDWORKS
PDM Task Pane (along with icons) similar to the FeatureManager design tree.

Because the display of both the FeatureManager design tree and the Task Pane tree are
identical, you can work on the product structure with more clarity and ease.

For the Detailing mode, the PDM Task Pane tree displays child components only to the
first level similar to the FeatureManager design tree.
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For the Large Design Review (LDR) mode, you can perform SOLIDWORKS PDM
operations such as Check in and Check out on the components from both the
FeatureManager design tree and the Task Pane assembly tree.

Assigning Data Cards to Files and Folders of a Template (2024 SP1)

In the SOLIDWORKS PDM Administration tool, while creating and editing a template, you
can assign a folder card and multiple file cards to a folder.

In SOLIDWORKS PDM File Explorer, right-click and click New in the right pane. When
the software creates the files and folders structure, the respective data cards are assigned
automatically.

Changes to the file extensions for a card, assigned to a template, outside of the template
configuration are not recognized.
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In the SOLDWORKS Administration tool, under Cards , for each file, folder, and template
card, you can right-click and see where the card is used. For example, click Cards >
Folder Cards > Folder Card > ShowWhere Used. This option is useful when deleting
a file or a folder data card.

Where Used Card Dialog Box

You can use this dialog box to display where a file, folder, or template card is used.

To open this dialog box:

1. In the Administration tool, expand Cards .
2. Expand a file, folder, or template card menu, for example Folder Card
3. Right-click the card.

You can see a list of all the places where the card is used:

Displays the template using the card.Name

Displays where the card is used.Used In

Folder Card Variables in Web2 (2024 SP1)
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In Web2, you can view data card variables for folders in a folder list. The values for custom
columns for the folders are displayed in the list view of the large screen layout.

Progress Dialog Boxes (2024 SP1)

In the SOLIDWORKS PDM File Explorer, the progress dialog box of certain operations
displays more information.

The Change State and Copy Tree progress dialog boxes have two progress bars:

• The first progress bar has the primary steps or actions of the overall operation, such
as Copying Files and Copying Variables.

• The second progress bar has detailed information such as secondary steps, total number
of files, etc.

The Check In and Reading File References progress dialog boxes have a single progress
bar that displays the current action and file names.
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Data Security Enhancements (2024 SP1)

In SOLIDWORKS PDM File Explorer and Web2, unauthorized users cannot view file
information in file view tabs or in file operations and file reference dialog boxes.

The warning message No rights to get latest or attached version displays for the
following:

• File view tabs:

• Contains
• Where Used
• Bill of Materials (Computed BOMs and Named BOMs)

• File operations dialog boxes
• File reference dialog boxes
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Assembly Visualization

You can access SOLIDWORKS PDM variables in the SOLIDWORKS Assembly Visualization
tool.

The SOLIDWORKS PDM variables are listed under Properties in the Custom Column
dialog box of the Assembly Visualization tool. You can select variables, for example,
PDM-<Checked Out By> or PDM-Dateunder the SOLIDWORKS PDM section in
Properties and then view them in the Assembly Visualization panel.

To view SOLIDWORKS PDM custom variables in Assembly Visualization:

1. In the SOLIDWORKS PDM Administration tool, right-click SOLIDWORKS > Assembly
Visualization Propertiesand click New List.

2. In the Customize Assembly Visualization Properties - Visualization Properties List
dialog box, create a property list from the available variables.You can create multiple
lists of properties and view them in Assembly Visualization depending on the
permissions.
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Customize Assembly Visualization Properties Dialog Box

You can use this dialog box to specify variables for specific users or groups that they can
view in the SOLIDWORKS Assembly Visualization tool.

To open this dialog box:

1. In the Administration tool, expand SOLIDWORKS.
2. Right-click Assembly Visualization Properties and select New List.

Name
Specifies the name of the new properties list.

Variables

Displays the selected variable.Variable

Displays the name of the selected variable.Name

Adds the selected variable.Add

Deletes the selected variable.Delete

Moves the selected variables up or down.Up and down arrows

Selected Variable

Displays the list of available variables and lets you select a
variable from the list.

Variable

Displays the name of the selected variable and lets you update
the name.

Name

Users
Lists users and lets you specify users who can select the variables and view the list.

Groups
Lists groups and lets you specify groups whose members can select the variables and
view the list.
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Downloading Specific Versions of a File in Web2

SOLIDWORKS PDM Web2 lets you download a specific version of a file and its references.

You cannot select and download multiple files in a single operation.

The Download Version dialog box lets you select the version and settings for download.
To access this dialog box:

1. In the File list, select a file:

• Large screen layout. Click Download > Download Version.
• Small screen layout. Touch Download and then touch Download Version.

Download Version Dialog Box

You can use the Download Version dialog box to download a specific version of a file and
its references.

To open this dialog box:

• Select a file and click Download > Download Version.

Version
Select the version of the file to download.

Settings
The collapsible option that displays the download settings options for files.
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Downloads the file with its references.Download with
references

Downloads the latest version.Latest

Downloads the referenced versions.Referenced

Version

Preserves the paths of references relative to the parent file and
creates a folder structure as required.
When cleared, the folder hierarchy is flattened, and all
referenced files are uploaded to the same destination folder as
the parent file.

Preserve relative
paths

Downloads the drawing files associated with the file selected
to download.

Include drawing

Downloads the SOLIDWORKS Simulation results associated
with the selected files.

Include simulation

Files
Lists the file references to download. The file list includes customizable columns such as

State, Version, Size, and Path. Click ShowMore and specify the columns to display.

Total Files to Download
Displays the total number of files and the count of individual files to download.

Download
Downloads the selected files. When the download is complete, a message appears with
the number of downloaded files on the upper bar. If Web2 cannot download any references,
a warning message appears.

Download Version Dialog Box - Small Screen Layout

You can use the Download Version dialog box to download a specific version of a file and
its references.

To open this dialog box:

1. Select a file and touch Download.
2. Touch Download Version.

Displays the version list and where you can select a version to
download.

Filename and latest
version

Lets you specify options.Settings
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File Type Icons

You can view the file type icons for weldment cut list items and the files that were shared
using pasted shared overlays.

These icons are available in the dialog boxes for:

• File Details
• File Operations
• Web2

The type icons for cut list items are not available for SOLIDWORKS BOMs.
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Check Out Option in Change State Command

You can check out a file after the change state operation completes.

You can customize the column set of the Do Transition dialog box to include the Check
Out system variable. If you select Change State and Check Out for a file, the file is
checked out after its state changes.

Viewing Check-Out Event Details
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In SOLIDWORKS PDM File Explorer, you can view details of check-out and undo check-out
events in the History dialog box of a file.

Along with the other details, you can see which user has performed the operation.

System Variables

System variables are more available and easier to access.

• The following system variables are available in the File List, Quick Search Result,
and Search Result column set types:

• <Last historic state>
• <Last historic workflow>
• <Revision (Latest version)>
• <Revision (Local version)>

• The <Days in State> system variable is available as a default column in File list.
• The SOLIDWORKS PDM task pane add-in has more system variables.
• In SOLIDWORKS PDM File Explorer, the addition of more system variables improves
the user interface of the Version tab.
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Viewing License Usage

You can view license details without any special administrative permissions.

In the Administration tool, the License node has the following subnodes:

• Server List. Lets you edit license servers.
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The administrative permission Can update license keys is renamed as Can update
license server. You need this permission to edit license servers.

• License Usage. Lets you view license details. This helps you to ask users to log out
if they are not using the tool, request more licenses from the administrator, or decide
whether you need to switch to a different license type.

SOLIDWORKS PDM Performance Improvements
SOLIDWORKS PDM 2024 has improved the performance of file-based operations.

The following operations are approximately two times faster:

• Add files
• Change state
• Copy tree

The copy tree to compressed archive operation is orders of magnitude faster.
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15
SOLIDWORKS Manage

This chapter includes the following topics:

• Measuring in a Document Preview
• Plenary Web Client CAD File Preview
• Field Conditions for Affected Items
• Task Automation
• Task Burn Down Chart
• Timesheet Working Hours
• Bill of Materials Quantity
• Process Output for Replacing BOM Items
• Adding Child Conditions to BOMs

SOLIDWORKS® Manage is an advanced data management system that extends the global file
management and application integrations enabled by SOLIDWORKS PDM Professional.

SOLIDWORKS Manage is the key element in providing Distributed Data Management.

Measuring in a Document Preview
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You can measure geometry in the Document Preview area.

You can use the measure tool when you preview a document supported by the eDrawings
Viewer.

To measure in a Document Preview:

1. In the main grid, select a part, assembly, or drawing record.

2. Click Document Preview .

The eDrawings® preview displays the selected SOLIDWORKS record.

3. Click Measure .
4. Select geometry to measure in the preview.

Plenary Web Client CAD File Preview

You can dynamically preview CAD files in the Plenary web client windows.

The preview is based on eDrawings and supports the same file type and functionality.

In previous releases, to get a dynamic preview you had to click a preview link to open
the SOLIDWORKS PDM Web 2 client.
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Field Conditions for Affected Items

You can add conditions for Affected Items mapped fields to control their existence and
default values.

When a field has a condition for its existence, that is, if the condition is required or not,
a blue asterisk appears in the column name. If you do not define a condition, the field is
always available, and a red asterisk appears.

Adding Required Fields to an Affected Item Field

To add required fields to an affected item field:

1. In the System Administration tool, open the Process Wizard.
To open the Process Wizard, right-click a process and click Administration.

2. If the process does not have at least one custom field, open the Item Fields wizard
and add a custom field.

You cannot define mapped fields as required fields.

3. Open the Workflow Properties wizard and select a stage in the workflow diagram.
4. Click Item Fields.
5. Select Required.

To add a condition, click ellipses in the first Condition column to open the Conditions
dialog box.

You can also add Item Fields to define the condition.

6. Click Save.
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Adding Default Values to an Affected Item Field

To add default values to an affected item field:

1. In the Administration Options tool, open the Process Wizard.
To open the Process Wizard, right-click a process and click Administration.

2. If the process does not have at least one custom field, open the Item Fields wizard
and add a custom field.

You cannot define mapped fields as required fields.

3. Open the Workflow Properties wizard and select a stage in the workflow diagram.
4. Click Item Fields.
5. Click the Default column and select a value from the list or enter a value.

Mapped fields cannot have a default value.

6. In the When column, select Start or Finish to specify when to enter the default
value to the field.
To add a condition, click ellipses in the second Condition column to open the
Conditions dialog box.

You can also add Item Fields to define the condition.

Task Automation

Task automation streamlines the preconfiguration process of handling tasks.

You can add conditions to control the creation of individual tasks. This helps to create
tasks that are based on process field values. For example, if multiple departments can
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participate in a process, each with their own task, you can add conditions to create the
tasks for the required departments.

Adding Task Conditions

You can add conditions to control the creation of individual tasks.

To add task conditions:

1. Open the Process Wizard for an existing process and navigate to the Workflow
Properties wizard.

2. Select a stage and click Tasks.
3. Click a task and select Enable conditions for selected Task.
4. Specify the task conditions.

Defining Task Completion Requirements

You can define individual tasks to complete before processes can move forward.

In previous releases, the only options to move a process forward was to complete all
tasks.

To define task completion requirements:

1. Open the Process wizard for an existing process and navigate to the Workflow
Properties wizard.

2. Select a stage and click Tasks.
3. Select a task.
4. Clear All tasks must be completed before this stage is completed.
5. In the task list, select the check box in the Complete column for each task to

complete.
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Task Burn Down Chart

The task burn down chart shows the progression of all project tasks.

The chart shows the number of tasks at the start of the project and the number of
remaining tasks at the end of the selected period. You can see only uncompleted tasks
using the option, Show uncompleted tasks only.

The burn down chart does not show canceled tasks.

To open the burn down chart, in the Home module, click Tasks.
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Timesheet Working Hours

The Working Hours in a timesheet lets employees enter their daily working time for a
week.

This helps employers track the working hours and breaks of employees.

Configuring Timesheet Working Hours

To configure timesheet working hours:

1. In the System Administration tool, clickStructures > Timesheets.
2. Under Working Hours, select Enabled.

Working Hours appears in all new and existing timesheets.
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3. Specify Working Hours options:

DescriptionOption

Lets you specify working hours options.Enabled

Allows total hours for a day other than
zero.

If you select Show Type row and if
the value for Exclusions matches the
type you enter, you can enter total
hours as 0.

Working hours are required

Lets you enter values corresponding to
the Type.Exclusions

Creates workweek templates to reduce
the number of entries in a template.

Configure Templates

Lets you add comments for each day and
time slot.

Configure Comments

Displays a Type row for you to select a
type from the list.

Show Type row

Specifies the required Type options.Configure Types

Specifies the days in the workweek.Working Days

Configuring Templates

You can create and configure workweek templates to reduce the number of entries in a
template.

To configure templates:

1. Click Configure Templates.
2. In the Templates dialog box, click New.
3. In the Template Properties dialog box, enter a name for the template.
4. Optional: Select Default to specify this template as the default whenever you create

a new timesheet.

168

SOLIDWORKS Manage



5. Enter time values in each day or click arrows to select values for the following:

FormatValueOption

24-hourWork start time for a dayStart

hh:mmBreak time during the dayPause duration

24-hourWork end time for a dayEnd

Calculated based on the
other values you specify

Total Time

Configuring Comments

You can add comments for each day and time slot.

Administrators can add comments by clicking Configure Comments and entering values
in a list format. You can modify a comment from the list or enter new text.

Bill of Materials Quantity

You can see the number of component BOMs on the Where Used tab.

On the Where Used tab, under BOM Source, you can see the number of BOMs displayed
in parenthesis. In previous releases, you had to open the parent record to search for
component BOMs.
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Adding Custom Columns to the Where Used Tab

You can define custom field columns on the Where Used tab. This displays the custom
field information with the standard system fields.

To add custom columns to the Where Used tab:

1. Log in to the SOLIDWORKS Manage desktop client as an administrator.
2. Open the property card for a record in the object to which you want to add a custom

column.
3. Select the Where Used tab.
4. Select the BOM tab.

5. Click (Where Used toolbar).
6. In the Custom Fields dialog box, click New.
7. In the Field Properties dialog box, enter a Display Name.
8. Click Type and select a data type.
9. Click a cell in the Field column of the required object and select a field to display.
10. Repeat the previous step for required objects to get field values from.
11. Click Save and Close.
12. Add additional custom fields as required.

Process Output for Replacing BOM Items

In BOMs, you can replace a record with another record.

You can replace a line item used in many assemblies without editing each assembly. The
output is called Replace BOM items. To use Replace BOM items, you need two object
type fields: one object type field holds a source item and other holds a target item.

Mass replace works only for record objects and not for SOLIDWORKS CAD references.
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Enabling Mass Replace in a Process

To enable mass replace in a process:

1. In the System Administration tool, under Structures > Processes, edit an existing
Process object.

2. In the Process Wizard, open the Fields page.
3. Click New Field to create a new object type field.
4. Enter a display name and select Object Type as the field type.
5. Click Finish.
6. In the Object Type Field Properties dialog box, click Next.

Do not select Allow Multiple Items. You can replace a single record only.

7. Click Next again.
8. On the Select Object(s) page, select the objects where the items to replace come

from.
9. Click Next.
10. On the Select Columns page, specify options.
11. Click Next.
12. On the Choose User Rights page, specify access permissions for the field.
13. Click Finish.
14. Repeat steps 3 to 13 to add an object type field to hold the target item.
15. In the Process Wizard, open the Workflow Properties wizard.
16. Select the stage where you want to replace the record.

17. Click Outputs and click Add .
18. In the Outputs dialog box, in Select Type, select Replace BOM items and click

Save.
19. In the Replace BOM items dialog box, under Step 1, select the object type field for

the source item in Item to replace and the target object type field in Item to
replace with.

20. Under Step 2, specify the behavior for the target parent objects to update.

Select the parent objects to add as affected items in the process.

21. Click Save and Close.

Replacing BOM Items

To replace BOM items:

1. In SOLIDWORKS Manage, navigate to the process object of the Replace BOM items
output.

2. Click New (Main toolbar).
3. Select the item to replace and the item to replace with in the object type fields.

4. On the Affected Items tab, click BOM replacements analysis .
5. In the Replacement Analysis dialog box, select the required parent records to have

the items replaced.
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6. Click Add to list to close the dialog box and add the selected records to the affected
item list.

7. Move the process through its workflow past the stage where you added the Replace
BOM items output.
To see the updated BOMs, open the record for an affected item.

Adding Child Conditions to BOMs

You can add conditions to restrict the addition of child item records based on the record’s
status and field values. This helps apply company policies for adding records to BOMs.

To add child conditions to BOMs:

1. In the System Administration tool, under Structures, select an object and click Edit
.

2. Open the Bill of Materials wizard.

If you edit a record or document object other than a SOLIDWORKS PDM object, click
the BOM tab.

3. Select the Bill of Material object in the list and click Edit .
4. In the BOM Properties dialog box, click the Children tab.
5. Click the cell under Statuses allowed for the BOM variant and select the required

status.
6. In the Conditions column for a BOM object, click ellipses in the cell to add conditions

that restrict items to add to the BOM.
7. In the Do not allow adding items to BOM if these conditions are met dialog box, enter

the required conditions and warning message.
8. Click Save and Close.
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16
SOLIDWORKS Simulation

This chapter includes the following topics:

• 3DEXPERIENCE SOLIDWORKS Simulation Designer Role (2024 SP1)
• Extra Frequencies for Harmonic and Random Vibration Response (2024 SP1)
• Automatic Saving of a Model File
• Bonding Interactions for Shells
• Convergence Check Plot
• Decoupling Mixed Free Body Modes
• Direct Sparse Solver Retired
• Enhanced Bearing Connectors
• Excluding Mesh and Results When Copying a Study
• Exporting Mode Shape Data
• Mesh Performance
• Performance Enhancements
• Underconstrained Bodies Detection

SOLIDWORKS® Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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3DEXPERIENCE SOLIDWORKS Simulation Designer Role (2024 SP1)

3DEXPERIENCE SOLIDWORKS roles, such as 3DEXPERIENCE SOLIDWORKS Standard,
3DEXPERIENCE SOLIDWORKS Professional, and 3DEXPERIENCE SOLIDWORKS Premium,
now support SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional,
SOLIDWORKS Simulation Premium, and SOLIDWORKS Motion licenses.

Extra Frequencies for Harmonic and RandomVibration Response (2024 SP1)
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You can include up to 20 extra frequencies of interest when calculating the response
parameters for harmonic and random vibration studies.

From the Harmonic > Advanced Options or Random Vibration > Advanced dialog
boxes, select Include extra frequencies for response.

For more information, see Harmonic - Advanced Options or Random Vibration - Advanced.

Automatic Saving of a Model File

You can save a model file after meshing and after the analysis completes.

To turn on automatic saving of a model file:

From the System Options > General tab, select Save file after meshing and after
the analysis completes.

Saving a model file automatically after meshing and after the completion of analysis
prevents data loss in case of unexpected system crashes or power outages.
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Bonding Interactions for Shells

The enforcement of bonding interactions between sets of shell elements that have a
physical gap is more robust.

The image above shows a model with three shell surfaces. One pair of shells has a physical
gap of 1mm, while the second pair of shells has a gap of 1.1mm. By setting a user-defined
Maximum gap for bonding to 1mm (the maximum gap between geometric entities to
enforce local bonding interactions), only the pair of shells with a gap of 1mm should be
bonded.

An improved algorithm enforces the proper bonding interactions irrespective of the mesh
size. In previous releases, if you applied a coarse shell mesh to the three surfaces, the
algorithm erroneously enforced a bonding interaction to the second shell pair with a
1.1mm gap.
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Convergence Check Plot

The Convergence Check Plot detects regions of the model where the solver has
encountered contact convergence issues.

To access the Convergence Check Plot:

Do one of the following:

• Click Diagnostic Tools > Convergence Check Plot (Simulation CommandManager).
• In a simulation study tree, right-click Results and click Convergence Check Plot.
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Decoupling Mixed Free Body Modes

An algorithm can detect and decouple the mixed free body modes while calculating mode
shapes.

From the Study Properties dialog box, select Decouple the mixed free body modes.
In cases where mixed free body modes exist in a model, the algorithm resolves the mixed
motion associated with a rigid body mode and provides the precise mode shape of a rigid
body mode.

The option to decouple the mixed free body modes is available in Frequency, Linear
Dynamic, Harmonic, Random Vibration, and Response Spectrum Analysis studies.
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Direct Sparse Solver Retired

The Direct Sparse solver is removed from the list of solvers for simulation studies.

For legacy studies that use the Direct Sparse solver, SOLIDWORKS Simulation uses the
Intel® Direct Sparse solver.

Enhanced Bearing Connectors
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The introduction of Distributed coupling and Tilt stiffness enhances the formulation of
bearing connectors.

The bearing connector is enhanced as follows:

• A Distributed type is added to the connector's Connection Type options. For a new
bearing connector definition, the default Connection Type is Distributed.

• The addition of Tilt stiffness accounts for the bending stiffness of the shaft.

To simulate the Allow Self-alignment option, which was available in prior releases,
set the Tilt stiffness to zero.

• You can apply a user-defined torsional stiffness to stabilize the shaft rotation.

The bearing connector enhancements are available for Linear static, Frequency, Buckling,
and Linear dynamic studies.

Excluding Mesh and Results When Copying a Study

You can save time by excluding mesh and results data when copying a simulation study
to a new study.

You can specify global default settings to include or exclude mesh and results when
copying a study from the Default Options > Solver and Results > Copy study dialog
box.

For individual studies, you can modify the default settings for Include mesh and Include
results in the Copy Study PropertyManager.
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Exporting Mode Shape Data

You can export mode shape data to the study's study_name.out file.

From the Frequency > Options dialog box, select Export mode shape data.

The mode shape data are saved to the study's .out file, located in the Results folder.
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Mesh Performance

The meshing time with the Blended curvature-based mesher is reduced for assemblies
that have multiple identical parts.

This mesh enhancement is available with the SOLIDWORKS Simulation Premium and
SOLIDWORKS Simulation Professional licenses.

An improved mesh algorithm based on the Blended curvature-based mesher identifies
identical parts that are repeated in an assembly. The algorithm reuses the same mesh
for the identical parts instead of meshing each of them independently, thus saving meshing
time.

To use the improved mesh algorithm, from the Default Options > Mesh dialog box,
select Reuse mesh for identical parts in an assembly (Blended curvature-based
mesher only).
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Performance Enhancements

Several feature enhancements improve the performance and accuracy of simulation
studies.

• Results from studies with remote displacements or remote rotations that are applied
to large faces with the Distributed connection are more accurate.

The solution time for these studies is shorter with the Intel Direct Sparse solver. In
previous releases, when the number of coupling nodes was very large, only a subset
of the coupling nodes participated in the distributed coupling constraints. In
SOLIDWORKS Simulation 2024, the distributed coupling constraints for remote
displacements or remote rotations include all coupling nodes.

The image illustrates the performance gain of the Intel Direct Sparse solver for a model
that has a remote displacement applied with distributed coupling to approximately
29,600 coupling nodes.

The solution time with the FFEPlus iterative solver for similar studies is not faster in
SOLIDWORKS Simulation 2024. However, the stress results are more accurate
because all coupling nodes are considered in the distributed coupling formulation.

• Running larger linear dynamic studies is more efficient. The stress calculation of larger
linear dynamic studies is optimized because of improved memory allocation by the
solver.

• Improved memory estimate, allocation, and management by the solver allows the
completion of large surface-to-surface bonded interaction sets that previously failed
because of insufficient memory. This improvement applies to the SOLIDWORKS
Simulation Professional and SOLIDWORKS Simulation Premium licenses.

• The total solution time for most static and thermal studies solved with the Intel Direct
Sparse solver is reduced by more than 10%. Updating the Intel Direct Sparse solver
with the new Intel MKL libraries and using parallel reordering with the variable block
sparse row (VBSR) format improved the solver's performance.
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Underconstrained Bodies Detection

There are several usability enhancements for the Underconstrained Bodies
PropertyManager.

• You can copy the results of the underconstrained bodies detection tool to the clipboard.
• The list that shows the bodies that are not sufficiently constrained in the Results
section is expandable for improved readability.

• It takes less time to show the animations of underconstrained bodies. The graphics
quality of the animations that highlight underconstrained bodies is improved.
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17
SOLIDWORKS Visualize

This chapter includes the following topics:

• Transformative Performance with Stellar Render Engine (2024 FD02)
• Turkish Language Support (2024 FD02)
• File Export Formats (2024 SP1)
• Enhanced Capabilities for Creating Compelling Appearances

SOLIDWORKS® Visualize is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application.

Transformative Performance with Stellar Render Engine (2024 FD02)
Significant improvements to the Stellar render engine have measurably enhanced the
render performance in SOLIDWORKS Visualize.

This functionality enhances the Viewport experience, particularly for larger resolutions
and high-end GPUs.

Benefits: Interactions with the Viewport are smoother and more interactive. This
improvement also results in a more responsive user interface.

Turkish Language Support (2024 FD02)
SOLIDWORKS Visualize Connected offers full support for the Turkish language in the user
interface.

Benefits: If you install SOLIDWORKS Visualize Connected on a Turkish version of Windows,
it automatically configures to Turkish.

You can also change the language in Tools > Options > User Interface > Language.

File Export Formats (2024 SP1)
The .GLTF, .OBJ, and .FBX file formats support the exporting of DSPBR appearance
parameters.

The .GLTF and .OBJ file formats export the following DSPBR parameters and associated
textures:

• Albedo
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• Metallic
• Roughness
• Alpha
• Normal

The .FBX file format exports these DSPBR parameters:

• Diffuse color
• Diffuse texture

Enhanced Capabilities for Creating Compelling Appearances

SOLIDWORKS Visualize uses Dassault Systèmes' Enterprise PBR Shading Model (DSPBR)
to closely replicate the realistic appearance of metal, glass, plastic, and other surfaces.

DSPBR is an appearance model for physically based rendering, supported by many
renderers in the 3DEXPERIENCE® platform. The shading model is easy to use and renderer
independent. It combines parameters to describe metallic and nonmetallic appearances,
including transparency for thin-walled and volumetric objects. It also provides effects,
such as emission, clear coat, metallic flakes, and sheen, to cover a wide range of
appearances.

SOLIDWORKS Visualize provides appearances for an expanded range of material types
and subtypes. The full Enterprise PBR Shading Model consists of more than 30
parameters, which can be complex. The software organizes these parameters into
categories that are relevant to specific Appearance Types. This simplifies the user
interface and enhances usability while keeping unnecessary parameters hidden. The
Appearance Types available are Car Paint,Metal, Basic, Emissive, Textile, Leather,
Wood, Glass, and Plastic.

Enhancements include:

• A simplified interface for selecting appearance types and optimizing their parameters.
You can select appearance types from a list or by clicking thumbnail images.
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• The ability to adjust textures and texture maps for almost all parameters, with greater
control and fidelity.

• The ability to combine normal and displacement maps and to apply vector displacement.
• Sample projects and other assets are updated and improved for showcasing DSPBR
appearances. Additional appearances and assets are available in the Cloud content
library.

You do not need to convert existing files to the DSPBR appearances. You can continue
working with files created with legacy appearance types or convert them to the DSPBR
types. New files must use the DSPBR appearance types.

Parameters for Basic Appearance Type

The Basic Appearance Type is made up of a few parameters that are sufficient to
simulate the most commonly used real-world appearances.

If you are new to applying appearances, start with Basic. Descriptions for all the DSPBR
appearances and how to apply textures are available in the SOLIDWORKS Visualize help.

ValueDescriptionParameter

RGB colorSpecifies the overall RGB color of a
material. You can use it to apply color to
thin walled transparent materials.

Albedo

Decimal. [0..1]Determines the level of metallicness of a
surface.

Metallic

Decimal. [0..1]Controls the level of shininess or
roughness of a surface.

Roughness

TextureAdds the appearance of details such as
bumps and dents to the surface of a
model without changing the size of the
geometry.

Normal

TextureModifies the position of surface points
using a texture that specifies the length
and direction of displacement for each
point.

Displacement

Decimal. [0..1]Adds a texture of holes to a surface
without adding extra polygons to the
geometry.

Cut-Out Opacity
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18
SOLIDWORKS CAM

This chapter includes the following topics:

• Additional Probe Cycle Parameters
• Canned Cycle Threading for Reverse Cuts
• Correct Feed/Speed Data for Parts Comprising Assemblies
• Heidenhain Probe Type
• End Conditions for Islands in the 2.5 Axis Feature Wizard
• Leadin and Leadout Parameters for Linked Contour Mill Operations
• Minimum Hole Diameter for Thread Mill Operations
• Post Processor Path
• Probe Cycles
• Probe Tool Output Options
• Probing Cycles in Assembly Mode
• Setup Sheets
• Shank Types for Mill Tools
• Tool Select Filter Dialog Box
• Tool Selection - Flute Length
• Tool Selection - Tool Crib Priority

SOLIDWORKS® CAM is offered in two versions. SOLIDWORKS CAM Standard is included with
any SOLIDWORKS license that has SOLIDWORKS Subscription Service.

SOLIDWORKS CAM Professional is available as a separately purchased product that you can
use with SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.
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Additional Probe Cycle Parameters

The Additional Probe Cycle Parameters dialog box contains options for Stop if tolerance
exceeded and Print (Ww) / Measuring Log.

Stop If Tolerance Exceeded

If a probe cycle goes beyond tolerance limits, the Stop if tolerance exceeded parameter
specifies whether to interrupt the program and display the details of the violation.

Values you can specify for this parameter:

• 0. Does not interrupt the machining program or display the violation details if tolerance
limits are violated.

• 1. Interrupts the machining program and displays the violation details on the controller.

The command associated with this parameter in the posted code is

Q309=1 ;PGM STOP TOLERANCE

Print (Ww) / Measuring Log

The Print (Ww) parameter is renamed to Print (Ww) / Measuring Log.

The functionality for Print (Ww) / Measuring Log depends on the Probe Type selected.

Print (Ww) / Measuring Log FunctionalityProbe Type

Indicates whether the data is output in the post-processed code.Renishaw

Indicates whether to create, save, or display the measuring log.Heidenhain

Values you can specify for this parameter:
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• 0. Does not create the measuring log.
• 1. Creates the measuring log and saves it to the controller.
• 2. Interrupts the NC program and displays the measuring log.

Canned Cycle Threading for Reverse Cuts
For threading operations, SOLIDWORKS CAM supports the Canned cycle output option
for reverse cut types.

In the Operation Parameters dialog box, on the Thread tab, under:

• Cut type, select Reverse.
• Program point, select Canned cycle output.

Correct Feed/Speed Data for Parts Comprising Assemblies

In Assembly mode, if the different parts or the multiple instances of a part comprising
an assembly have different stock materials, then for each part or instance, the correct
stock material appears.

The associated stock material appears in the Operation Parameters dialog box on the F/S
tab for Stock material. The Feed/Speed Editor uses the Stock material for feed/speed
calculation.

In previous releases, in Mill Assembly mode, when an assembly contained parts that had
different stock materials or split part instances had different stock materials, the
feed/speed computations were often inaccurate. This occurred because SOLIDWORKS
CAM only considered the stock material assigned to the first part listed in the Part Manager
for feed/speed computation. SOLIDWORKS CAM assigned the calculated the feed/speed
values to the other parts that constituted the assembly though they had different stock
materials. This resulted in erroneous feed/speed values.
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Heidenhain Probe Type

SOLIDWORKS CAM supports probing operations on machine tools that use Heidenhain
controllers.

In the Machine dialog box, on the Posting tab, under Probe Options, in Probe Type,
select Heidenhain.

End Conditions for Islands in the 2.5 Axis Feature Wizard
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You can define the height of islands for 2.5 Axis features in two directions.

In previous releases, SOLIDWORKS CAM automatically specified island height from the
topmost point of the island face to the bottom of the feature. If the island face was a
different height than the top face of the feature, the resultant island was shorter compared
to the feature height. You could not increase the island height in the other direction to
match the feature height.

In the 2.5 Axis Feature: Island Entities PropertyManager, you can specify island height
under End condition - Direction 2. You can define the height in Z+ and Z- directions.
The direction associated with End Condition - Direction 2 is opposite to the bottom
profile of the island feature.

Leadin and Leadout Parameters for Linked Contour Mill Operations

For linked Contour Mill operations, you can specify an option to copy the Leadin and
Leadout parameters of the first Contour Mill operation to the other linked operations.

In the Operation Parameters dialog box, on the Leadin tab, select Apply leadin/out to
All. SOLIDWORKS CAM does not link these operation parameters because they are
feature-specific:

• Leadin/out point
• All parameters under Links between
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Minimum Hole Diameter for Thread Mill Operations

You can specify the minimum hole diameter for thread mill operations. In previous releases,
this parameter was read-only.

In the Technology Database (TechDB), on the Mill Tooling tab, select a Threading Tool
and specify Min. hole dia.

You can also specify Minimum hole dia in the Operation Parameters dialog box, on the
Tool tab, on the Thread Mill Tool secondary tab, under Tool Dimensions. Changes in
the Operation Parameters dialog box are not saved to the TechDB.
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Post Processor Path

You can specify the default location of the folder containing post processors on the Settings
tab of the Technology Database (TechDB). Under General, specify Post Processor Path.
You do not need to reselect the post processor for every part or assembly.

When you change the location of the folder containing post processors and you open a
previously programmed part or assembly in SOLIDWORKS CAM, the following occurs:

1. SOLIDWORKS CAM determines whether the post processor file is available in the
folder for Active post processor.

If the folder is unavailable, the software loads the Post Processor Path.

2. SOLIDWORKS CAM searches for the post processor file in Post Processor Path.
3. When SOLIDWORKS CAM finds the post processor file, it displays the file path of the

post processor file in the Machine dialog box on the Post Processor tab for Active
post processor.
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Probe Cycles
SOLIDWORKS CAM includes additional probing cycles to calibrate and measure planes
and axes.

Probing cycles include:

• 3 Point Plane
• Angle Measurement (X Axis)
• Angle Measurement (Y Axis)
• 4th Axis Measurement (X Axis)
• 4th Axis Measurement (Y Axis)

You can access probe cycles in the Operation Parameters dialog box on the Probe tab,
under Probe Cycle.

Three Point Plane

With the 3 Point Plane probe cycle, SOLIDWORKS CAM measures the selected surface
using three points on that surface. The probed points establish a plane.

When you select 3 Point Plane, SOLIDWORKS CAM positions the three points at default
offset values. You can modify the offset values and probe the points at the required
locations.
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Angle Measurement (X/Y Axis)

The Angle Measurement (X Axis) and Angle Measurement (Y Axis) probe cycles
probe two points on a selected surface and calculate the angle of the face with respect
to the X or Y axis, respectively.

SOLIDWORKS CAM positions the two points symmetrically around the centroid of the
selected face. In the Operation Parameters dialog box, on the Probe tab, under Probe
Cycle, you can specify the distance between the points in Incremental Distance for X
location and Y location.

The normal of the selected planar face must be perpendicular to the Z axis of the setup
where you insert the probe.

196

SOLIDWORKS CAM



4th Axis Measurement (X/Y Axis)

This probe cycle measures the slope of a selected surface between two points with respect
to the fourth axis.

The selected surface must be such that the slope between the probed points is measured
in the X or Y axis. You can use the resultant value to compensate the rotary axis.

The X and Y coordinates of the centroid of the surface are the start point of the toolpath.
SOLIDWORKS CAM positions the probing points symmetrically about this start point based
on the assigned distance between the two probing points.

The probe movements are parallel to the axis. SOLIDWORKS CAM measures the clearance
distance from the reference point on the surface. For the probing moves, the clearance
distance can be more or less than the defined.
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Probe Tool Output Options

You can specify the Output through parameter for probe tools. This parameter generates
the toolpath and G-code with the set tool reference point.

In the Operation Parameters dialog box, on the Tool tab, on the Probe Tool tab, under
Properties, you can specify options for Output through:

• Tip. Generates the toolpath with reference to the tip of the probe tool.
• Center. Generates the toolpath with reference to the center of the probe tool.
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Probing Cycles in Assembly Mode

You can assign appropriate part instance and mill part setups for each probe operation
generated in Assembly mode. This ensures an accurate Part Setup Origin while posting
the toolpath of the probe operation.

In previous releases, if only probe operations existed under an operation setup of an
assembly, SOLIDWORKS CAM measured their coordinates from the fixture coordinate
system (FCS). SOLIDWORKS CAM did not list the instance and relevant feature setup on
the Offset tab in the Setup Parameters dialog box. Even if you specified the output origin
as Part Setup Origin, the toolpath coordinates referred to the FCS, leading to inaccurate
posted code.

In the Operation Parameters dialog box, on the Posting tab, under Part/Setup, you can
specify parameters in Assembly mode.

DescriptionParameter

Enables the Reference part and Reference setup parameters.Assign reference
part and setup

Lists all parts in the Part Manager.
The default selection is the part (with the part instance as a suffix
if there are multiple part instances) whose face you selected in the
Probe tab for the Probe operation. If you did not select a face,
SOLIDWORKS CAM uses the first part listed in the Part Manager.

If the post processing requires you to specify the Part Setup
Origin, SOLIDWORKS CAM uses the values of the origin of the
selected part as reference. SOLIDWORKS CAM also uses the Part
Setup Origin to calculate the coordinates when executing Step
Through Toolpath and simulation commands.

Reference part

199

SOLIDWORKS CAM



DescriptionParameter

Lists all the part setups associated with the part or part instance
selected in Reference Part.

The default selection is the valid feature setup for the part or part
instance selected for Reference Part whose features can be
machined from the selected operation setup.

SOLIDWORKS CAM uses the origin of the part setup that you select
to compute the coordinates of the toolpath while posting.

Reference setup

For Probe operations, the selections you make for Reference part and Reference setup
are displayed in the part instances and work coordinates on the Offset tab of the Setup
Parameters dialog box.
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Setup Sheets

The default format for Setup Sheets is .xslt for compatibility with the latest browsers.

Shank Types for Mill Tools

You can define shank types (Straight, Tapered, or Neck) for any Mill Tool.

In previous releases, only certain Mill Tools could have shank types. You can specify shank
types for the noncutting portion of these additional tools:
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• Bore Tool
• Center Drill
• Countersink Tool
• Dovetail Tool
• Keyway Tool
• Lollipop Tool

Neck. You can define the
shoulder diameter, shoulder
length, shank diameter, and
shank length. The neck
portion of the tool is the
noncutting portion of the
cutting tool.

Tapered. You can define the
shoulder diameter, shoulder
length, shank diameter, and
shank length. The tapered
portion of the tool is the
noncutting portion of the
cutting tool.

Straight. You can define the
shoulder length and shank
diameter.

• D2 = Shank diameter
• D4 = Shoulder diameter
• L4 = Shoulder length
• L6 = Shank length
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Tool Select Filter Dialog Box

You can resize the Tool Select Filter dialog box to see additional table columns.

Tool Selection - Flute Length

When you specify tool selection criteria based on Use Expression and not on a specific
tool, SOLIDWORKS CAM accounts for the tool's flute length.

When you run Generate Operation Plan, for each operation that you define the tool
selection criteria with a Tool diameter lower/upper expression, the following rules apply:
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• If the tool crib has two or more tools with identical diameter values matching the
expression criteria, SOLIDWORKS CAM accounts for the flute length to assign the tool.
It selects the tool with a flute length more than the feature depth. If all tools have a
flute length more than the feature depth, SOLIDWORKS CAM selects the tool with a
flute length closest to the feature depth.

• If SOLIDWORKS CAM still finds two or more tools, it uses the rules of Stock/Tool
Material Mapping to select a tool.

For example, consider a rectangular pocket with a feature depth of 75mm. Based on the
feature strategy assigned to this feature, the tool selection criteria selects a 25mm Flat
End Mill. The tool crib has two Flat End Mill tools with identical diameters of 25mm.
However, one tool has a 50mm flute length and the other has an 80mm flute length.
SOLIDWORKS CAM selects the tool with the 80mm flute length because it is closer in
value to the feature depth.

Tool Selection - Tool Crib Priority

SOLIDWORKS CAM has better tool selection logic when you select Tool crib priority in
the Technology Database (TechDB).

SOLIDWORKS CAM has optimized tool selection logic so appropriate tools are available
in the active tool crib:

• If the tool assigned in the TechDB for a specific operation is not in the active tool crib,
SOLIDWORKS CAM adds it to the tool crib even though smaller tools might be in the
active tool crib. (If you selected a tool by referencing it to a specific Machine ID in
the TechDB.) If another tool with similar parameters is in the active tool crib,
SOLIDWORKS CAM uses that tool.

• If you specify that the resultant tool derived from the expressions defined in the TechDB
as inactive, SOLIDWORKS CAM does not add it to the active tool crib. It uses the
subsequent tool selection rules to add an active tool to the tool crib.

204

SOLIDWORKS CAM



19
CircuitWorks

This chapter includes the following topics:

• User Interface Redesign (2024 SP4)
• CircuitWorks in SOLIDWORKS Standard (2024 FD02)
• SOLIDWORKS Connected Support for CircuitWorks (2024 FD01)

CircuitWorks™ is available in SOLIDWORKS® Standard, SOLIDWORKS Professional, and
SOLIDWORKS Premium.

User Interface Redesign (2024 SP4)

The user interface for CircuitWorks is redesigned to be more consistent with SOLIDWORKS.

The Quick Access toolbar, CommandManager, and the CircuitWorks tree look and work
similarly to those in SOLIDWORKS.
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CircuitWorks in SOLIDWORKS Standard (2024 FD02)
CircuitWorks is available in all versions of SOLIDWORKS, including SOLIDWORKS Standard.

SOLIDWORKS Connected Support for CircuitWorks (2024 FD01)

SOLIDWORKS Connected supports additional CircuitWorks functionality.

• The Push and Pull tools (EDMD toolbar) let you send and receive IDX 3 files
from ECAD.

• Associate Model lists electronic component data models from the 3DEXPERIENCE
platform. You can associate each CircuitWorks tree component with SOLIDWORKS part
or assembly files. After you associate a model from the 3DEXPERIENCE platform, the
asterisk in the CircuitWorks tree disappears.

• In the Component Properties panel and the CircuitWorks Component Library, for
SOLIDWORKS component, click Browse for component to list electronic
component data models from the 3DEXPERIENCE platform.

• When you create an assembly in SOLIDWORKS Connected, the Open dialog box lists
electronic component data models from the 3DEXPERIENCE platform that you can use
in the assembly.
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Reference Designators for Comparing Mechanical Component Modifications (2024 SP3)

CircuitWorks assigns a temporary reference designator (Ref. Des.) to each instance of a
mechanical component if the component does not have a Ref. Des. already associated
with it.

When you open an IDX 3 file in CircuitWorks, the software assigns the Ref. Des. that is
also available in SOLIDWORKS when you build the model. The Ref. Des. appears in the
CircuitWorks tree with the instance name. The same Ref. Des. appears in the SOLIDWORKS
FeatureManager design tree after you model the mechanical components in SOLIDWORKS.

By having Ref. Des. indicators on each component, you get:

• More accuracy when viewing modification results when you export the board assembly
from SOLIDWORKS to CircuitWorks using the Export to CircuitWorks tool. Any
modifications to the mechanical components in SOLIDWORKS appear in the Sync with
ECAD dialog box and in the Changes tree in the CircuitWorks window.

• More accurate results when viewing modification results when you import or export
the board assembly from CircuitWorks to an ECAD designer using the Sync with ECAD
tool. Any modifications to the mechanical components appear in the Sync with ECAD
dialog box.

Pushing Tasks to the 3DEXPERIENCE Platform

To push tasks to the 3DEXPERIENCE platform:

1. From CircuitWorks, click File > Options.
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2. On the Prostep EDMD tab:

• Select Use Prostep EDMD.
• In Read and write Prostep version, select v 3.0.
• In Shared folder, specify where to share Prostep EDMD files between CircuitWorks
and the ECAD application. Ensure that you have write permission for this folder.

• Select Use GMT style date in IDX communication.
• (Optional) Select Animate change in preview image on tree selection.
• (Optional) Select Reverse rotation direction of components on the underside
of the board. When cleared, the component does not rotate - it goes on the
underside of the board instead of on top, as a mirror image of the component.

• (Optional) Select Check for changes made in SOLIDWORKS before applying
changes from ECAD.

3. On the SOLIDWORKS Import tab, under Conductive layer modeling, select
Complete (slower).
SOLIDWORKS creates all the layers so you can see each layer of the board.

4. Click OK, then restart SOLIDWORKS.
5. From CircuitWorks, click Push (EDMD toolbar).
6. In the EDMDPushPull dialog box, under Ready to push change:

a) For Collaborator, enter a name.
You can enter the first, last, or both names.

b) Click Check Name and search for a name to add.
c) (Optional) Enter Comments.
d) Click OK.

The baseline data is pushed to the 3DEXPERIENCE platform in Prostep EDMD IDX 3
format through the 3DEXPERIENCE Collaborative Tasks. The task is assigned to the
ECAD engineer. If you push a change or response file, the software prepopulates the
Collaborator or you can change the name.

Building Models (2024 FD01)

In CircuitWorks Connected, you can use the Build Model tool to build and save board
models and components to the 3DEXPERIENCE platform. In earlier releases, you had to
save the board model and each component separately.

CircuitWorks Connected builds the board model and corresponding components regardless
of whether you already built the board model and components.

After CircuitWorks builds the modelScenario

CircuitWorks saves the board and its components to the local cache.
Choose options:

• Save to 3DEXPERIENCE. Saves all models to the
3DEXPERIENCE platform.

• Don't Save. Closes the dialog box. You can save the models to
the 3DEXPERIENCE platform later on in the SOLIDWORKS
software.

First time building
the model
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After CircuitWorks builds the modelScenario

Choose options:
• Overwrite. Creates a new board model and saves it to the
3DEXPERIENCE platform.

• Use Existing. Downloads the board model from the
3DEXPERIENCE platform and uses it in the SOLIDWORKS
assembly.

• Cancel. Cancels the build model operation.

Board model may
or may not be in
the local cache but
exists in the local
CircuitWorks
database

Choose options for the components:
• Yes. Uses the existing model.
• Yes to All. Uses the existing models for all components in the
board model.

• No. Builds a new model.
• No to All. Builds new models for all components in the board
model.

Board model's
components exist
in the local
CircuitWorks
database

Choose options:
• Overwrite. Creates a new board model and saves it to the
3DEXPERIENCE platform.

• Use Existing. Downloads the board model from the
3DEXPERIENCE platform and uses it in the SOLIDWORKS
assembly.

• Cancel. Cancels the build model operation.

Board model is in
the local
CircuitWorks
database and
already on the
3DEXPERIENCE
platform but not in
the local cache

After the build model process finishes, you can specify an option to save the board model
and its components to the 3DEXPERIENCE platform automatically. In CircuitWorks, click
Options > SOLIDWORKS Import and select Automatically Save to
3DEXPERIENCE after Build Model is complete.

If you decide not to save the board model right after building the board in CircuitWorks,
you can save it later when in the SOLIDWORKS software. In SOLIDWORKS, click Save

to 3DEXPERIENCE (CircuitWorks toolbar) or Tools > CircuitWorks > Save to
3DEXPERIENCE.

Board Outline and Cutout Changes from CircuitWorks (2024 SP2)

CircuitWorks can generate MCAD change files based on board outline and cutout changes.
You can then send these changes as IDX 3 files to Cadence® Allegro®.

ECAD either accepts or rejects each of these changes. Based on the ECAD IDX 3 response
file, rejected changes reappear in CircuitWorks. Click Build Model to apply those changes
to the SOLIDWORKS assembly.

When you make board outline or cutout changes, any other changes are omitted from
the same change file (such as components, holes, or keep in/keep out areas). You need
to send those as additional changes later.
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Board Outline and Cutout Changes from ECAD (2024 SP3)

ECAD designers can generate IDX 3 change files based on board outline and cutout
changes. You can then open these changes in CircuitWorks.

In CircuitWorks, you can accept or reject each of these changes. Click Build Model to
apply those changes to the SOLIDWORKS assembly. Based on the CircuitWorks response
file, rejected changes reappear in the ECAD system.

210

CircuitWorks



20
SOLIDWORKS Composer

This chapter includes the following topics:

• Offline Help for SOLIDWORKS Composer Products
• Support for SpeedPak Configurations in SOLIDWORKS Composer

SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical contents
for product communication and technical illustrations.

Offline Help for SOLIDWORKS Composer Products
Offline Help for all SOLIDWORKS Composer products is available as a PDF instead of in
HTML format.

In earlier releases, offline Help worked only in Microsoft Internet Explorer. Now it is
browser independent.

Support for SpeedPak Configurations in SOLIDWORKS Composer
You can translate SOLIDWORKS assembly files containing components in SpeedPak
configurations to SOLIDWORKS Composer.

The SpeedPak components are switched to their parent configurations to enable translation
of these components to SOLIDWORKS Composer.
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21
SOLIDWORKS Electrical

This chapter includes the following topics:

• Annotate Tab (2024 SP3)
• Terminal Strip Drawings (2024 SP3)
• 6W Tags Enhancements in ECP(2024 FD03)
• Drawing Mark Numbers (2024 SP2)
• Exporting Data Files (2024 SP2)
• Import Options to Manage Cable References and Manufacturer Parts (2024 SP2)
• Restructuring the Electrical Component Tree
• SOLIDWORKS Electrical Tutorials (2024 FD01)
• Cable Management (2024 SP1)
• Dynamic Link Between Drawings (2024 SP1)
• Sharing Links in the Electrical Content Portal (2024 SP1)
• Single Entry for Cables or Wires in BOM Tables (2024 SP1)
• Zoom to Fit When Opening Drawings (2024 SP1)
• Aligning Components
• Changing the Length of Multiple Rails and Ducts
• Filtering Auxiliary and Accessory Parts
• Auto Balloons in 2D Cabinets
• Removing Manufacturer Part Data
• Resetting an Undefined Macro Variable
• Shortening Lists Using Ranges
• SOLIDWORKS Electrical Schematic Enhancements
• SOLIDWORKS Electrical Performance Improvement

SOLIDWORKS® Electrical is a separately purchased product.
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Annotate Tab (2024 SP3)

In SOLIDWORKS Electrical Schematic, the Annotate tab is added to the ribbon. From
this tab, you can make changes to 2D drawings from 3D and flattened routing documents.
It saves time and makes customization tasks simpler.

Several existing commands from the Cabinet layout tab are also available under the
Annotate tab:

• Connection label
• Insert report table
• Erase background
• Align blocks
• Order
• Auto balloon
• Text leader
• Block leader
• Leader style
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Terminal Strip Drawings (2024 SP3)

You can organize wires and cables by destination part. This makes terminal strip layouts
tidier and more organized.

Enhancements:

• The option Detail cable destination is renamed to Detail destination component.
It has the following options:

• None
• For cables
• For wires
• For cables and wires

This option displays a box containing the destination symbol for cables and wires. For
successive wires associated with the same component, the software draws only one
component.

• A Destination cable core length is renamed to A Destination line length. This
option applies to wire components too.

• In the Terminal strip editor dialog box, a new column appears between
Destination and Cable. It contains the mark of the component terminal where the
wire is connected.
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6W Tags Enhancements in ECP(2024 FD03)

The 6W Tags feature in the Electrical Content Portal is enhanced to quickly find specific
information in the 6WTags. This helps you organize data and track tasks more effectively.

Enhancements in the Catalog Content page:

• The Classification is available under theWhat node. When you select a classification,
the associated sub-classes are displayed. When you select a sub-class, the next level
is displayed. This helps you to filter and navigate through the structure systematically.

• The Creation date node in the When hierarchy is modified to display the year only.
Once you select a year, the corresponding months and dates are displayed under it.

• The Search Tags field is added at the top of the 6W Tags area to search for specific
values in 6WTags.
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Drawing Mark Numbers (2024 SP2)

You can number drawings by folder.This lets you assign the same drawing number across
multiple folders. Previously drawing marks were unique per book.

In the Electrical Project Configuration dialog box, underMarks unique by, for Drawing,
specify Electrical Project, Folder, or Book.

Exporting Data Files (2024 SP2)
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In Link to PDM Configuration dialog box, you can include the data files in the exported
PDF file.

To export data files, click Link to PDM Configuration > PDF and select Export data
files. The option One file per book is renamed as Export one PDF file by book.

Import Options to Manage Cable References and Manufacturer Parts (2024
SP2)

Two new commands are available in Cable reference management andManufacturer
part management:

• Create new file for import
• Import Excel file

In Cable reference management, you can access the commands from:

• Library > Cable reference management. In Cable reference management, click

Import > Create new file for import .
• Library > Cable reference management. In Cable reference management, click

Import > Import Excel file .

In Manufacturer part management, you can access the commands from:

• Library > Manufacturer part management. In Manufacturer part management,

click Import > Create new file for import .
• Library > Manufacturer part management. In Manufacturer part management,

click Import > Import Excel file .
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Creating a New Excel File from Template

You can create a new Excel file for import and adapt it to the input language and class
of manufacturer parts or cable references.

You can import all the data from the cable references and manufacturer parts, which were
previously missing in the file, like cable core details, complex cable core properties,
circuits, and connections points in manufacturer parts.

To create a new Excel file from the template for cable references:

1. Click Library > Cable reference management .
2. In the Cable reference management dialog box, click Import > Create new file for

import .
3. In the Create new Excel file for cable reference import dialog box, select the following:

• For Language, select the language from the list. The default language is set to
match the interface language. The list contains the 14 languages that correspond
to the interface languages.

• For Class, click to open the Class selector and select the base class for cable
reference. If you do not select any class then all the classes and subclasses are
available in the Excel file.

• For Template available, select the Excel file found in the template folder.
• Select Open created template to open the created template.

4. Click OK.
5. In the Save As dialog box, save the new Excel file in the required location. The file

opens automatically.
6. Edit the data in the Excel file to import the new data to the cable references.

• Reference is the mandatory field for the successful import of the data.
• Manufacturer, Class, Library, Family, Cable type, etc. are required fields. If
you leave these fields empty, the software warns you and imports the data with
errors.

• Article Number, External ID, Translatable data, etc. are optional fields. If
you leave these fields empty, no errors occur.

• Column A (can be hidden) contains key code, for example, to identify the language
of the header.

• The last row of header (can be hidden) contains the name of fields associated with
columns like #car_reference. Do not remove this information.

• You can add more columns for translated data to enter more languages at the
same time. Modify the language code in the field name, like .en in #car.ctr_0.en
for cable description.

• The hidden page _ValidationList_ contains the named range used to show
drop-down items in some columns, based on the Excel feature Data Validation.

You can also create a new Excel file for import of the Manufacturer part using the
same steps as above. Access the command from Library > Manufacturer part
management. In Manufacturer part management, click Import > Create

new file for import .
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Importing the Template

You can reimport the filled Excel file that you created earlier using the Create new file
for import command. You can only import new data.

To import the Excel file:

1. Click Library > Cable reference management .

2. In Cable reference management, click Import > Import Excel file .
3. In the Open dialog box, select the Excel file to import and click Open.
4. In the Cable references import dialog box, do the following:

• Click Select file to open the Open dialog box and select the Excel file to import.
Excel import file displays the path of the imported Excel file.

• Under Format selection and separator, for Row format, choose from:

• One line per cable core
• One line per reference

For Cable core separator, choose from:

• Colon ':'
• Line break
• Pipe '|'
• Semi colon ';'

This option appears only if you select One line per reference for Row
format.

• Under File preview, the preview of the imported file appears.

• Click Compare to simulate cable reference import. A log file is created with
the same name as the Excel file. If there are errors, you can open the Excel sheet
and rectify the errors.

• Click Open to open the selected Excel file for editing.

• Click Import to import the manufacturer cable reference to the library.

You can also import the template for the Manufacturer part using the same steps
as above. Access the command from Library >Manufacturer part management.

In Manufacturer part management, click Import > Import Excel file .
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Restructuring the Electrical Component Tree

The electrical component tree is restructured and simplified to display the 2D footprints,
3D parts, and the connection labels associated with a manufacturer part. You can quickly
identify these items for a particular manufacturer part in the electrical component tree.

In earlier releases, all the 2D footprints, 3D parts, and the connection labels inserted
appeared as subitems in the electrical component tree. You could not distinguish between
the 2D footprint and connection labels applicable to a particular manufacturer part.

Components
Under each component, there is a node for each manufacturer part associated with the
component and an intermediate node for each symbol (2D footprint or connection label)
representing that manufacturer part. The node for each manufacturer part contains all
the corresponding 2D footprints, connection labels, and the 3D part or assembly items.

You can control the visibility of the tree items for the manufacturer parts. In the component
tree, right-click the top item of the project, select View > Manufacturer part, and
choose from the following three options:

• Hide. Hides the node for manufacturer parts. The tree items relative to the
manufacturer parts appear directly under the component.

• With graphics. Creates intermediate tree items only for the manufacturer parts that
have graphics (2D footprints, connection labels, etc.) associated with it. This is the
default option.

• All. Creates items for all the manufacturer parts whether they have graphics associated
with them or not.
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Locations
An item in the component tree groups all manufacturer parts of the location. The node
contains the 2D footprints and the connection labels associated with each manufacturer
part associated with the location.

You can right-click the node and select the following:

• Properties. Opens the Properties dialog box of the selected manufacturer part. If you
select several manufacturer parts, the Properties dialog box displays only the common
properties.

• Delete manufacturer parts. Deletes the selected manufacturer parts.

Cabinet Layout
The Intermediate node for location parts is also applicable for the 2D or 3D cabinet layout
tree. All the manufacturer parts appear even if they do not have any graphics associated
with them.

SOLIDWORKS Electrical Tutorials (2024 FD01)

SOLIDWORKS Electrical tutorials are integrated into the SOLIDWORKS Electrical help.
The tutorials are more complete and consistent with existing SOLIDWORKS documentation.

At http://help.solidworks.com, click SOLIDWORKS Electrical > SOLIDWORKS
Electrical Tutorials.
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Cable Management (2024 SP1)

Cable Management has a streamlined workflow that saves you time.

The enhancements include:

• Replace cable is more flexible. You can replace a miscellaneous cable core type with
a neutral cable core type with no system warnings.

• New commands are available in the shortcut menu. You can use:

• Properties to view the properties of the selected cable.
• Go to drawing to go to the location of the drawing, generally a line diagram from
cable core item.

• Go to browser to show the origin component of the cable core.

• When you delete cables used in the scheme or line diagram, the wires associated with
their cable cores are dissociated automatically.

• The Cable Reference properties dialog box includes a new Conductors section with
Conductor section and Conductor diameter listed under it. The section
Characteristics is renamed as Cable characteristics.

Dynamic Link Between Drawings (2024 SP1)
When you modify a .SLDDRW drawing file inside SOLIDWORKS® and save it, the software
updates the corresponding drawing file (.EWG) inside the SOLIDWORKS Electrical
project folder automatically.

In earlier releases, when you modified a drawing file inside SOLIDWORKS® and saved it,
the corresponding drawing file inside SOLIDWORKS Electrical project folder was not
updated automatically. You had to click Create Project Drawing command again to
update the drawing file.
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Sharing Links in the Electrical Content Portal (2024 SP1)

You can share links to an item (the manufacturer part, symbol, etc.) or the electrical
package containing the item in the Electrical Content Portal.

You can select the list next to an item to:

• Download the item
• Link to the item
• Download the electrical package
• Link to the electrical package

In previous releases, you could only download the content and automatically unarchive
it into the respective libraries.

Single Entry for Cables or Wires in BOM Tables (2024 SP1)
The BOM table created for cables and wires after routing contains only one entry for each
wire style or cable reference.

This single entry displays the sum of the length of each wire style or cable reference. You
can have a cable or wire BOM table in PDM with the required length.
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Zoom to Fit When Opening Drawings (2024 SP1)

When you open a drawing, you have the option to have it automatically zoom to fit your
graphics area. The drawing can be a project drawing, a title block, a symbol, or a dwg
file.

To activate this option, click Interface configuration > Preferences. Under Behavior,
select Zoom to fit when opening drawing. This option helps you automatically view
the entire extents of the drawing without additional Zoom commands.
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Aligning Components

When you use Align Components while designing 3D cabinet layouts, you can preview
changes in the graphics area.

This significantly reduces the effort required to align SOLIDWORKS components in 3D
cabinet layouts.

The Align Component PropertyManager has a simplified and improved workflow.

Changing the Length of Multiple Rails and Ducts
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You can change the length of multiple rails and ducts simultaneously. In earlier releases,
you could only change the length of a single rail or duct. The multiselection of rails and
ducts makes the process of 3D cabinet creation faster.

To change the length of multiple rails and ducts:

1. In the SOLIDWORKS Electrical 3D menu, click Change Length of Rails and Ducts

.
2. In the PropertyManager, under Define Length > Select Components, select

multiple rails and ducts in the graphics area.

Filtering Auxiliary and Accessory Parts

In SOLIDWORKS Electrical, you can filter manufacturer parts based on your selection.
You can filter:

• Associated manufacturer parts
• Accessory manufacturer parts
• Auxiliary manufacturer parts
• Manufacturer parts excluded from the BOM

You can use the list in Filter Manufacturer Parts in the Electrical Manager tree to
filter various types of manufacturer parts. Show/Hide Associated Components is
replaced by this filter option.

This feature is also available in the 2D cabinet layout of SOLIDWORKS Electrical
Schematic.
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Auto Balloons in 2D Cabinets

You can insert auto balloons in SOLIDWORKS Electrical 2D cabinet layout drawings.

Inserting Auto Balloons in 2D Cabinets

To insert auto balloons in 2D cabinets:

1. Click Cabinet Layout > Auto Balloon .
2. Select a drawing view in which to insert the balloons.

3. In the PropertyManager, specify options and click .

Auto Balloon PropertyManager

To open this PropertyManager:

1. Click Cabinet Layout > Auto Balloon .

Leader styles

Specifies the predefined style to apply to leaders.Leader style

Specifies the block to use for the balloons.Block

Specifies a number for the scale to apply to the block used
for balloons.

Scale
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Balloon layout
Specifies the Pattern type.

For balloon marks, you can specify only the numeric values. Specifying formulas is not
supported.

Displays balloons on the top of the cabinet drawing.Top

Displays balloons on the bottom of the cabinet drawing.Bottom

Displays balloons on the left of the cabinet drawing.Left

Displays balloons on the right of the cabinet drawing.Right

Displays balloons in a square surrounding the cabinet
drawing.

Square

Displays the arrows of the grouped balloons with less tilt.Group balloons

Inserts balloons only for the first instance of the same
manufacturer part.

Ignore multiple
instances

Does not insert balloons for the terminal strip.Ignore terminals

Layer
Specifies the layer on which to insert the balloons.

Options
Insert report table. Inserts a report table filtered from the content of the current
document.

To insert a report table, select Insert report table in the Auto Balloon PropertyManager.
Click , to open the panel to automatically insert the auto-ballooning report.
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• If one or more report tables are already inserted, select Update report table to
update the report tables.

• The Auto-balloon mark is data stored in the database, retrievable through a query,
while the Report_Row is computed during report generation. There is no direct
relationship between them.

Removing Manufacturer Part Data

You can clear manufacturer part information when deleting or replacing a part from a
component.

To remove manufacturer part data, click Electrical Project > Configurations > Project.
In the Electrical Project Configuration dialog box, in the General tab, under Options,
select Reset manufacturer part information from component. This resets the related
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information such as manufacturer data, terminal mark when you delete or replace it with
a different part.

The option is cleared by default. If you clear this option, the part retains the terminal
numbers even after you delete or replace it.

Resetting an Undefined Macro Variable

Excel automation lets you automatically reset undefined macro variables.

To reset undefined macro variables, click SOLIDWORKS Electrical > Configurations
> Project. In the Electrical Project Configuration dialog box, on the General tab, under
Excel automation, select Reset undefined macro variable. When you select this
option, the %xxx% variable does not remain in the inserted macro. It is replaced by:

• An empty string
• A removed object
• Associated default object (like function or location)
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Shortening Lists Using Ranges

In report configuration, when you merge rows, the software lists consecutive values as
a range for merged rows instead of listing each individual value in the range.

In the Report configuration edition dialog box, under Columns, select Value range. To
activate this option, selectMerge rows. You can activate this option for multiple columns
at once.

SOLIDWORKS Electrical Schematic Enhancements
SOLIDWORKS Electrical Schematic offers an improved user experience.

• In drawings, you can move entities using the arrow keys.
• The grid point size for the project sheets adapts automatically to the screen resolution.
• In a schematic project, when you set the side panels to Auto Hide, the panels retain
the auto hide setting. This behavior increases the app's usability.

SOLIDWORKS Electrical Performance Improvement
Performance improvements include:

• Archiving a project for remote users (VPN connection) is improved and is much faster
now.

• The automatic routing issue that caused the creation of loops while routing wires
through splices is fixed. This allows cleaner and faster flattening of harnesses.
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22
SOLIDWORKS Inspection

SOLIDWORKS® Inspection is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium, or as a completely separate
application (see SOLIDWORKS Inspection Standalone).

Welcome Page

The redesigned Welcome to SOLIDWORKS Inspection page in SOLIDWORKS Inspection
Standalone improves usability.

The welcome page includes:

• Recent Documents
• Recent Folders
• Recent Projects
• Resources
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23
SOLIDWORKS MBD

This chapter includes the following topics:

• Specifying STEP Export Controls to STEP 242 (2024 SP3)
• Hole Tables
• Repairing Dangling Dimensions
• Adding a Decimal Separator in Geometric Tolerance Symbols
• Controlling Visibility of Annotations through Solid Geometry
• Displaying Dual Dimensions in Geometric Tolerance Symbols
• Creating Thickness Dimensions for Curved Surfaces
• Displaying Half Angles of Conical Dimensions
• Exporting Custom Properties to STEP 242
• Viewing Annotations and Dimensions

SOLIDWORKS® MBD is a separately purchased product that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Specifying STEP Export Controls to STEP 242 (2024 SP3)
In the Publish to STEP242 PropertyManager, you can specify STEP export controls to add
data to or remove data from a STEP 242 file.

To specify STEP export controls to STEP 242:

1. Click Publish STEP 242 File (MBD toolbar).
2. In the Publish to STEP242 PropertyManager, under Step Export Settings, specify

an option:

• Split periodic faces. Splits periodic faces, such as cylindrical faces, into two.
• Export face/edge properties. Exports face and edge properties.

3. Click .
4. In the Save As dialog box, enter a file name.
5. Click Save.
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Hole Tables

You can include a hole table when you publish a part to 3D PDF.

Repairing Dangling Dimensions

You can repair dangling DimXpert dimensions.

You can edit the dangling dimensions to reattach them to a feature in the model. This

applies to dimensions created using the DimXpert tools, such as Size Dimension ,
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Location Dimension , and the Angle Dimension tool. This tool is available for
DimXpert dimensions only.

To repair dangling dimensions:

1. Open a part or assembly that contains dangling dimensions created with DimXpert
tools.

2. In the DimXpertManager, right-click a feature and select Edit Feature.
3. In the PropertyManager, select the missing reference with the dangling dimension

and click .

Adding a Decimal Separator in Geometric Tolerance Symbols

You can add a decimal separator in geometric tolerance symbols.

To add a decimal separator in geometric tolerance symbols:

1. Click Tools > Options > Document Properties > Annotations > Geometric
Tolerances.

2. Under Decimal Separator, specify an option:

• Comma. Inserts a comma.
• Period. Inserts a period.
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Controlling Visibility of Annotations through Solid Geometry

You can make annotations, such as dimensions, stay on top of the model. This lets you
see dimensions and extension lines if you rotate the model.

To control visibility of annotations through solid geometry:

1. Click Tools > Options > System Options > Display.
2. Select Display DimXpert dimensions on top of model.

Displaying Dual Dimensions in Geometric Tolerance Symbols
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When you create geometric tolerance symbols, you can display dual dimensions, which
show two sets of values, such as inches and millimeters, within a single dimension.

To display dual dimensions in geometric tolerance symbols:

1. In a part or drawing, click Geometric Tolerance (MBD Dimension toolbar).
2. In the graphics area, click to place the symbol.
3. Select Range in the Tolerance dialog box and the Geometric Tolerance

PropertyManager and select Display Dual Dimensions.

Creating Thickness Dimensions for Curved Surfaces

You can create thickness dimensions for curved surfaces.

This helps show the relationships between surfaces. You can apply thickness dimensions
to:

• Cylinders
• Bosses
• Simple holes

You can create thickness dimensions between two concentric DimXpert features for:

• An inside and outside diameter, where the inside diameter is a cylinder or a simple
hole, and the outside diameter is a cylinder or a boss.

• Two inside diameters of a cylinder or simple hole.
• Two outside diameters of a cylinder or boss. For example:
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To create thickness dimensions for curved surfaces:

1. Click Location Dimension (MBD Dimension toolbar).

Steps 2 and 3 require that you select two features. For thickness dimensions, the
two features must be cylindrical, concentric, and have different diameters.

2. Select the face of the origin feature.
3. Select the face of the tolerance feature.
4. Click to place the dimension.

5. Specify options in the PropertyManager and click .

Displaying Half Angles of Conical Dimensions
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You can display a conical angle dimension as a half angle. This lets you convert a full
angle of a cone to a half angle.

To display half angles of conical dimensions:

1. In the DimXpert Value PropertyManager, under Primary Value, select Show as half
angle.

Exporting Custom Properties to STEP 242

You can export custom properties from a part or assembly to the STEP 242 format.

To export custom properties to STEP 242:

1. Click Publish STEP 242 File (MBD toolbar).
2. In the Publish to STEP242 PropertyManager, specify custom properties to export and

click .
3. In the Save As dialog box, enter a file name.
4. Click Save.

Viewing Annotations and Dimensions
You can view annotations and dimensions in a more organized way.

As of SOLIDWORKS 2024 and later, you do not need a SOLIDWORKS MBD license for
this functionality.

You can use the following features:

• List annotations in a tree view. When you select an annotation in the FeatureManager
design tree, it highlights the annotation in the graphics area, and you can hide or show
annotations.
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• Sort by annotation type. You can sort annotations by type, such as smart dimensions,
weld symbols, and balloons for better organization.
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24
DraftSight

This chapter includes the following topics:

• Hatch Commands (DraftSight Mechanical Only) (2024 SP3)
• Templates on the 3DEXPERIENCE Platform (DraftSight Connected Only) (2024

FD01)
• Saving a File to the 3DEXPERIENCE Platform (DraftSight Connected Only) (2024

FD01)
• Accessing the DraftSight User Forum (2024 SP1)
• Section Line Command (DraftSight Mechanical Only) (2024 SP1)
• Datum Identifier Commands (DraftSight Mechanical Only) (2024 SP1)
• Measure Geometry Command
• Selecting Multiple Files and Inserting as Reference
• Export Sheet Command
• Tool Palettes
• Layer Manager Palette
• Make Flat Snapshot Command
• View Navigator
• Merge Layer Command
• Reshaping Hatches
• Importing and Exporting Blocks (DraftSight Connected Only) (2024 FD04)

DraftSight® is a separately purchased product that you can use to create professional CAD
drawings. It is available as DraftSight Professional, DraftSight Premium, and DraftSight
Mechanical. In addition, DraftSight Enterprise and Enterprise Plus are available on network
license. 3DEXPERIENCE® DraftSight is a combined solution of DraftSight with the power of the
3DEXPERIENCE platform.
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Hatch Commands (DraftSight Mechanical Only) (2024 SP3)

You can run the AM_UserHatch command to apply user-defined or predefined hatches
on enclosed geometry.

You can run the AM_UserHatchEdit command to edit the hatches.

When you run these commands, the Hatch dialog box opens where you can:

• Specify the angle of hatch lines.
• Specify spacing between hatch lines.
• Specify the number of hatch lines if the area to hatch is small enough to match the
specified pattern.

• Calculate the new boundaries of an area when editing a hatch.

Applying User-Defined or Predefined Hatches

You can apply user-defined or predefined hatches on geometry in the graphics area.

To apply user-defined or predefined hatches:

1. Type AM_UserHatch in the command window.
2. In the dialog box, from Style, select User-defined.

a) In Angle, enter the angle of the hatch lines.
b) In Spacing, enter the spacing between hatch lines.
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3. Optional: Select one of the following predefined hatches.

The software creates hatch patterns with specific angle and spacing between hatch
lines.

You can override the Angle and Spacing values of predefined hatches.

SpacingAngleHatch

2.5 mm or 0.1 in45°

5 mm or 0.22 in45°

13 mm or 0.5 in45°

2.7 mm or 0.12 in135°

4.7 mm or 0.19 in135°

11 mm or 0.4 in135°

2.3 mm or 0.09 in45°/135°

4. Optional: Select Double to create the cross pattern with hatch lines perpendicular
to the primary lines.

5. Optional: In Adapt hatch distance at less than, enter the number of hatch lines
if the area to hatch is small enough to match the specified pattern.
The default number of lines is 5.

6. Click OK.
7. In the graphics area, specify an internal point in an enclosed area of the geometry.

Editing User-Defined Hatches

You can quickly edit user-defined hatches in the graphics area.

To edit user-defined hatches:

1. Type AM_UserHatchEdit in the command window.
2. In the graphics area, select a user-defined hatch.
3. In the dialog box, from Style, select a new predefined hatch pattern.
4. In Angle, edit the hatch angle value.
5. In Spacing, edit the distance between the hatch lines.
6. Select Double to create a cross pattern with hatch lines perpendicular to the primary

lines.
7. Select Calculate boundary to create new boundaries of the hatch area.

a) In the graphics area, specify a point in an area to hatch.
Alternatively, you can select Specify entities and specify the entities to hatch.

DraftSight deletes the hatch that you selected in step 2.
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8. Optional: In Adapt hatch distance at less than, enter the number of hatch lines
if the area to hatch is small enough to match the specified pattern.
The default number of lines is 5.

9. Click OK.

Templates on the 3DEXPERIENCE Platform (DraftSight Connected Only)
(2024 FD01)

You can create, save, and manage templates on the 3DEXPERIENCE platform. You can
access these templates to create new drawings.

Previously, you could save and access your templates locally only.

Creating a Template from a Drawing

You can create a new template from the locally saved drawing file.

To create a template from a drawing:

1. In the My Session widget, from the action bar, click Manage Templates.

The Manage Templates dialog box displays the templates created on the platform.

2. Click Add template.
a) In the Create Template - Drawing dialog box, enter the Title and Description.

You can have multiple templates with the same name.

b) For Target 3DEXPERIENCE Type, select Drawing.
c) Click Browse and select a locally saved drawing file.

You cannot attach one drawing file to multiple templates.

d) Click Create As Released or Create As Draft.

3. Optional: Click Edit Template to edit the templates that are not in the released state.
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4. Optional: Click Download Template to download the drawing file associated with
the template.

The software downloads the file to C://3DEXPERIENCE/MyWork.

5. Optional: Click Maturity to change the maturity state.
6. Optional: Click Delete Template to delete the template.
7. Optional: Click Reload Template to reload the list of templates.

If you create a template as released, you cannot edit or delete it, or change its
maturity state.

Creating a Drawing from a Template

You can create a drawing from the template saved on the 3DEXPERIENCE platform.

To create a drawing from the template:

1. In the My Session widget, from the action bar, click New From Template.
2. In the dialog box, select the template saved on the platform.
3. Enter the file name and click OK.
4. Optional: Save the drawing file on the platform.

Saving a File to the 3DEXPERIENCE Platform (DraftSight Connected Only)
(2024 FD01)

You can select a bookmark, change the collaborative space, and update the title of new
files from the Save to 3DEXPERIENCE dialog box.

The Save as New dialog box lets you save a file that is saved on the 3DEXPERIENCE
platform with a new name.
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When you save a file to the 3DEXPERIENCE platform, the progress bar displays a message
that includes the file name and name of the collaborative space.

Save as New Dialog Box

You can use this dialog box to save a file that is saved on the 3DEXPERIENCE platform
with a new name.

To access the dialog box, do one of the following:

• Right-click the drawing tab and click Save as New.
• Enter the SAVEASNEW command in the command window.

DescriptionOption

Displays the collaborative space on which
you have saved the file.

Collaborative Space on 3DEXPERIENCE

Displays the title with new as suffix.

You can edit the title.

Title

Available only when the file has references.Include References

Exports DraftSight files locally.Export

Saves the file on the 3DEXPERIENCE
platform.

Save

Accessing the DraftSight User Forum (2024 SP1)
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You can access the DraftSight user forum that contains posts from the DraftSight user
community.

To access the user forum:

Do one of the following:

• Click and select User Forum.
• Type UserForum in the command window.

When you click User Forum, DraftSight redirects you to the 3DEXPERIENCE platform.
Access to the 3DEXPERIENCE platform requires 3DEXPERIENCE credentials.

Section Line Command (DraftSight Mechanical Only) (2024 SP1)

You can create a section line at the cutting plane of the section and insert the
corresponding section view label in the drawing area.

Enter the AM_SectionLine command to draw section lines. The command creates the
following entities:
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DescriptionEntity

Section line1

Section view label2

Section view identifier3

Direction arrow4

The command lets you control the appearance of different entities of the section line,
such as arrows, lines, and name. You can create multiple sections on an entity for the
following types of section views:

DescriptionType of section view

The cutting plane passes through the entire
length of the entity.

Full section

Two nonparallel cutting planes pass through
the entity. Use these sections on cylindrical
entities.

Aligned section

The cutting plane passes through a portion
of the entity to section.

Half section

The cutting plane bends to pass through the
features of the entity. Use these sections
on entities that are not in a straight line.

Offset section
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Datum Identifier Commands (DraftSight Mechanical Only) (2024 SP1)

You can use datum identifier commands to add a datum identifier and attach it to areas
in a drawing.

A datum is a plane, a straight line, or a point used as a reference to measure and locate
geometric entities and geometric tolerances. You can use the following commands:

• AM_DatumIdentifier to create datum identifier symbols.
• AM_DatumIdentifierEdit to edit datum identifier symbols.

Datum identifier symbols identify datum features for feature control frame symbols. For
example, you can use a datum identifier symbol to mark the center of a hole.

Elements of datum identifier symbols include:

Square frame1

Datum identifier of two capital letters
maximum

2

Leader arrow3

Triangle symbol4

When you create a datum identifier symbol in a drawing, the software generates a label
that contains the datum identifier enclosed in a rectangle. The datum identifier appears
in all feature control frames that use the datum as a reference. A leader line connects
the label to the datum on the drawing. The leader line may include a filled or empty
triangle. The position of the triangle indicates the corresponding datum.

You can attach datum identifier symbols on:

• A surface or on one extension line of a surface
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• Visible lines such as extension lines, dimensions, or axes
• A hole, leader pointing to a hole, or feature control frame

Measure Geometry Command

You can use the MEASUREGEOM command to measure an area, angle, distance, and radius.

In previous releases, you had to run commands like AREA, DIST, and GETANGLE.

To access the Measure Geometry command:,

Do one of the following:

• On the ribbon, click Home > Tools > Measure Geometry.
• Enter MEASUREGEOM in the command window.
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Selecting Multiple Files and Inserting as Reference

You can select multiple files and folders and insert them as external references to the
DWG™ file. This reduces the number of clicks required to insert multiple files and the
possibility of failing to insert a file.

To select multiple files and insert them as references:

Do one of the following:

• On the ribbon, click Insert > Block > References Manager.
• On the ribbon, click Attach.
• On the menu, click Tools > References Manager.
• Enter REFERENCES in the command window.
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Export Sheet Command

You can export all visible entities from an active sheet viewport and entities from the
sheets to the new drawing.

This lets you edit the representation created in the new drawing using commands like
TRIM, COPY/PASTE, EXPLODE, STRETCH.

To access the Export Sheet command:

Do one of the following:

• On the ribbon, click Sheet > Sheets > Export Sheet.
• On the menu, click File > Export > Export Sheet.
• Enter EXPORTSHEET in the command window.
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Tool Palettes

You can find frequently used tools and data in the Tool Palettes.

The palettes include all generic properties like docking and auto-hide. You can also create
your own palette to store tools and data.

To access the Tool Palettes:

Do one of the following:

• On the ribbon, click Insert > Palettes > Tool Palettes.
• On the menu, click Tools > Tool Palettes.
• Enter TOOLPALETTES in the command window.
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Layer Manager Palette

You can use the Layer Manager dialog box as a palette that you can float or dock on the
side.

In the Layer Manager palette, you have quick access to layers, layer states, layer previews,
or isolating layers.

To open the Layer Manager palette:

• On the ribbon, click Home > Layer > Layers Manager.
• On the menu, click Format > Layer.
• Enter LAYER in the command window.
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Make Flat Snapshot Command

You can use the enhanced features of the MAKEFLATSNAPSHOT command for formatting
the foreground and hidden lines, and displaying tangent edges.

To access the Make Flat Snapshot command:

Do one of the following:

• On the ribbon, click Home > Snapshot > Make Flat Snapshot.
• On the menu, click Solids > Solid Editing > Make Flat Snapshot.
• Enter MAKEFLATSNAPSHOT in the command window.

The enhanced features include:

• Foreground lines. LineColor and LineStyle specify the line color and style of
foreground lines.

• Hidden lines. Show displays the hidden lines. LineColor and LineStyle specify the
line color and style of hidden lines.

• Show tangent edges. Displays tangent edges in the flat representation.
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View Navigator

View Navigator lets you switch between standard and isometric views or parallel and
perspective views of a model.

Its interface acts as a 3D orientation indicator that lets you see the current view direction.

To access the View Navigator command:

• On the ribbon, click View > Views > View Navigator.
• On the menu, click View > View Navigator.
• Enter VIEWNAVIGATOR in the command window.
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Merge Layer Command

You can use the MERGELAYER command to reorganize layers.

This command is available from the Layer Manager palette that helps you merge the
content of selected layers into other layers.

To access the Merge Layer command:

• On the ribbon, click Home > Layers > Merge Layers.
• On the menu, click Format > Layer Tools > Merge Layers.
• Enter MERGELAYER in the command window.
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Reshaping Hatches

You can adjust the contour of hatches or gradient hatches.

When you select a hatch entity, the grips appear that help you adjust the shape. When
you hover over a grip, the shortcut menu appears with editing options.

Importing and Exporting Blocks (DraftSight Connected Only) (2024 FD04)
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You can insert drawings from the 3DEXPERIENCE platform as blocks to the existing
drawing. You can export the blocks to the 3DEXPERIENCE platform as drawings. You can
edit a block and save it to the 3DEXPERIENCE platform as a separate drawing.

Inserting Blocks from the 3DEXPERIENCE Platform

You can insert drawings from the 3DEXPERIENCE platform as blocks to the existing
drawing.

To insert blocks from the 3DEXPERIENCE platform:

1. Click Insert > Block (or type InsertBlock).
2. In the Insert Block dialog box, click Browse.
3. In the Open dialog box, click Open from 3DEXPERIENCE.
4. Select the recently opened DWG file or a drawing file from 3DSearch, My Content,

or Bookmarks and click Open.

The Insert Block dialog box displays the name of the selected drawing file, its location,
and preview.

5. Click OK.

The selected drawing is added as a block in the active drawing. For more details, see
Inserting Blocks.

Exporting Blocks as Drawings to the 3DEXPERIENCE Platform

You can export the blocks as drawings (.DWG files) to the 3DEXPERIENCE platform.

To export blocks as drawings to the 3DEXPERIENCE platform:

1. Click File > Export > Export Drawing (or type ExportDrawing).
2. In the Save File dialog box, click Browse for the destination folder.
3. Click Save to 3DEXPERIENCE to export the block as a drawing to the platform.
4. In the Save to 3DEXPERIENCE dialog box, click Save.

When you edit a block, you can save it to the 3DEXPERIENCE platform as a separate
drawing.

For more details on saving a file using the ExportDrawing command, see Saving
Blocks to File.
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25
eDrawings

This chapter includes the following topics:

• Display Styles in Drawings
• Supported File Types
• eDrawings Performance Improvements

eDrawings® Professional is available in SOLIDWORKS® Professional and SOLIDWORKS Premium.

Display Styles in Drawings

If you saved a SOLIDWORKS drawing with specific display styles in drawing views,
eDrawings supports each display style for any .EDRW file that you save in eDrawings 2024
and later.

In the Heads-up View toolbar, eDrawings shows all display states if the drawing views
have shaded data: Shaded with Edges, Shaded, Hidden Lines Removed, Hidden
Lines Visible, and Wireframe. The Display Style tool is only available for drawings
with shaded data.

If you change the display style of a drawing view in eDrawings, only the selected view
updates with the new display style. All other views remain the same. However, if you
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change the display style when you have not selected a drawing view, all views change
to the selected display style.

If you rotate a drawing view, the display style is unaffected.

Supported File Types
eDrawings has updated the supported versions for several file types.

VersionFormat

Up to 2021ACIS (.sat, .sab)

Up to 2023Autodesk® Inventor® (.ipt, .iam)

Up to V5_V62023CATIA® V5 (.CATPart, .CATProduct)

Pro/Engineer 19.0 to Creo 9.0Creo® - Pro/Engineer® (.ASM, .NEU, .PRT,
.XAS, .XPR)

Up to v10.6JT (.jt)

NX1847 Series to NX2212NX™ (Unigraphics®) (.prt)

Up to 35.1Parasolid™ (.x_b, .x_t, .xmt, .xmt_txt)

V19 - 20, ST - ST10, 2023Solid Edge® (.asm, .par, .pwd, .psm)

eDrawings Performance Improvements
eDrawings performance is improved with various tools, rendering, printing, and file closure
times.

Performance improvements include:

• Measure tool. Up to 20 times faster when opening the Measure pane, entity selection,
and changing units.

• Markup tool. Up to 10 times faster when creating markups.
• Reset tool. Up to 1.5 times faster when resetting a model.
• Faster rendering and printing with software OpenGL.
• Faster times for closing files.
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26
SOLIDWORKS Flow Simulation

This chapter includes the following topics:

• Importing and Exporting Component Lists
• Mesh Generation
• Mesh Boolean Operations

SOLIDWORKS® Flow Simulation is a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

For installation of SOLIDWORKS Flow Simulation, see Load SOLIDWORKS Flow Simulation
Modules.

Importing and Exporting Component Lists

In the Component Explorer dialog box, you can export component lists to a Microsoft®
Excel® spreadsheet, edit the properties, and import the component lists back.

By using a spreadsheet, you can manage component properties. You can edit:

• Materials
• Volume Sources
• Two-Resistor Components (library and power)

262



• LEDs (library and current)

Mesh Generation

With the Smart Cell Cartesian mesh generator, you can generate meshes faster and with
smaller file sizes.

Speeds are 9-12 times faster on 32 cores for 10-20M cell models in Flow Simulation 2024
compared to 3-7 times faster in 2023. Meshing speed is about 2-3 times faster on 32
cores in 2024 because of scalability.

Mesh Boolean Operations
The Mesh Boolean Operation (MBO) handles complex and extremely bad geometry faster
and easier. When SOLIDWORKS cannot conduct Boolean operations successfully because
of bad geometry (such as bad topology with missing entities or self-intersecting faces),
you can use MBO.

MBO meshes bodies separately and then conducts Boolean operations on the meshed
bodies without using CAD Boolean operations.

This technology prepares and meshes even very bad models 5-15 times faster without
prior user adjustments or automatic model healing. You can use MBO with the CAD
Boolean diagnostic, combining the power of Mesh Boolean and the convenience of getting
additional information, such as a diagnostic of the fluid domain.

If the CAD Boolean diagnostic fails to detect the fluid domain, you can still mesh the
model with Mesh Boolean. In these cases, the Solver Monitor dialog box shows additional
subdomain diagnostics. You can specify how to handle the geometry (CAD Boolean,
Preprocessor Boolean (formerly called Improved Geometry Handling), or Mesh Boolean),
and you can turn off the CAD Boolean diagnostics.
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27
SOLIDWORKS Plastics

This chapter includes the following topics:

• Batch Manager
• Compare Results
• Cool Solver
• Hot and Cold Runners
• Injection Location Advisor
• Materials with Pressure-Dependent Viscosity
• Material Database
• Mesh Enhancements

SOLIDWORKS® Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS
Plastics Premium are separately purchased products that you can use with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Batch Manager
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The Batch Manager PropertyManager is redesigned to improve usability.

• Rearrangement of the user interface elements in sections provides a streamlined
workflow for the Batch Manager.

• Ability to specity the maximum number of CPUs for an analysis task.
• Improved visibility for the simulation type assigned to an analysis task and for controls
to add, run, and pause an analysis task.
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Compare Results

You can display four different results plots from one study using split view panes.

To display multiple result plots after running a study:

Do one of the following:

• Click Compare Results (Plastics CommandManager).
• In a study's PlasticsManager tree, right-click Results and click Compare Results.

In the Compare Results PropertyManager, you have these options:

DescriptionOption

Applies the same view orientation to all view panes.Synchronize
Views

Saves the split view of the multiple result plots to a .png image
format.

Save Image

You can also specify the maximum and minimum values of the results shown on the view
panes, view an isosurface mode, and use available tools to display animations.
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Cool Solver

Solver options for ejection criteria enhance the performance of plastic injection simulations
for thermoplastic materials.

You can either specify the cooling time or let the cool solver estimate a cooling time based
on the following temperature ejection criteria for thermoplastic materials.

DescriptionOption

Specifies the percentage of the mold's
volume that needs to cool down below the
ejection temperature. The default is 90%.

Volume % frozen at ejection

Excludes the cooling state of the sprue and
runner segments from the ejection criteria.

Exclude Runner from Ejection
Temperature Criteria

It is common to reduce the overall
manufacturing time by ejecting the part
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DescriptionOption

before the sprue and runner segments have
cooled completely.

Hot and Cold Runners

You can more easily assign hot or cold runner domains to components of a plastic injection
simulation.

To assign a runner domain type to a body listed under the Domains node, right-click the
body and click Hot Runner or Cold Runner.
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Injection Location Advisor

The Injection Location Advisor can iteratively determine an optimal number of injection
locations (maximum of 10) to fill a cavity.

The default for Number of locations is Automatic, which activates the iterative approach
for finding an optimal number of injection locations. To specify a custom number of
injection locations, select User defined.

Materials with Pressure-Dependent Viscosity
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Fill and Pack simulations support materials with pressure-dependent viscosity.

Materials that have pressure-dependent viscosity are listed in the Plastics Materials

Database with an information icon .

Accounting for pressure-dependent viscosity is important for parts that contain long flow
lengths or very thin walls, or for cases where you need high injection pressures.

For more information, see Material Properties (Polymer, Mold, and Coolant Domains).

Material Database
The Plastics material database includes the latest data from the material manufacturers.

DescriptionMaterials

Added 417 new material grades from the
following material suppliers:
• CHIMEI®: 42
• DuPont: 2
• EMS-GRIVORY®: 4
• KRAIBURG TPE: 4
• LG Chem: 85
• MOCOM®: 128
• ORLEN Unipetrol RPA: 20
• RadiciGroup High Performance Polymer:
2

• SABIC Specialties®: 126
• Solvay Specialty Polymers®: 1
• Trinseo®: 3

New Materials

Updated 40 material grades with the latest
material property values provided by the
following material suppliers:
• Borealis: 1
• CHIMEI®: 2
• EMS-GRIVORY®: 10
• ORLEN Unipetrol RPA: 20
• SABIC Specialties®: 7

Modified Materials
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DescriptionMaterials

Removed 292 obsolete material grades from
the following material suppliers:
• 3M: 1
• ALBIS: 4
• Borealis: 1
• DuPont: 2
• DuPont Engineering Polymers: 2
• KRAIBURG TPE: 1
• LANXESS GmbH: 3
• LG Chemical: 56
• SABIC Specialties®: 211
• Solvay Specialty Polymers®: 11

Removed Materials

Mesh Enhancements

You can save the mesh settings of a study without creating a mesh. You can also preview
a surface mesh before creating a solid mesh.

The meshing options are available from the Solid Mesh - Tetrahedral, Solid Mesh -
Hexahedral, and Shell Mesh PropertyManagers.

DescriptionOption

You can save the mesh settings of a model (mesh size,
refinement method, and advanced mesh control) without

Save settings without
meshing

creating the mesh. When you run a study, the mesh settings

271

SOLIDWORKS Plastics



DescriptionOption

are applied automatically to generate the mesh. In a study's
PlasticsManager tree, the icon next to Solid Mesh or
Shell Mesh indicates that you saved the mesh settings for
the model.

You can preview a surface mesh before creating a solid mesh
to check the mesh validity for a model.

Show preview
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Routing

This chapter includes the following topics:

• Better Positioning of Complex Splices and Loop Segments in Flattened Routes
(2024 SP3)

• Reverse Direction and Specify Percentage Options for Discrete Wires (2024 SP3)
• Aligning a Route Subassembly to the Origin (2024 SP3)
• Quality Improvements to Flattened Route Updates (2024 SP3)
• Using the 3DEXPERIENCE Add-In with Routing (2024 SP1)
• Naming Wires and Cables in the FeatureManager Design Tree
• Discrete Wires with Auto Route

Routing is available in SOLIDWORKS® Premium.

Better Positioning of Complex Splices and Loop Segments in Flattened Routes
(2024 SP3)

The Flatten Route tool offers improved support for complex and multi-circuit splices.

The Flatten Route tool automatically performs the following functions:

• Identifies the junction points in loop segments and moves them to the flattened plane.
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• Directs fanouts away from the route segment rather than integrating them into the
route segment.

Reverse Direction and Specify Percentage Options for Discrete Wires (2024
SP3)

The Edit Flattened Route PropertyManager lets you reverse the direction of route segments
when you straighten flattened discrete wires.

You can also specify a percentage to straighten segments instead of straightening an
entire discrete wire segment.

To access these options, open a manufactured route assembly of discrete wires and click

Edit Flattened Route . In the PropertyManager, click Route Segment and select a
spline from the subassembly or flyout tree. Then click Straigthen , enter a value for
%, and select Reverse Direction.
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Aligning a Route Subassembly to the Origin (2024 SP3)

When creating a new route subassembly, you can align and position it according to your
design requirements using the Route Properties PropertyManager.

Choices for defining the origin include:

• Top-Level Assembly Origin

The origin of the routing subassembly aligns coincidentally with the origin of the
top-level assembly.

• Origin of the component being dropped

The origin of the routing subassembly aligns coincidentally with the origin of the fitting
being added.

• Select manually

The origin of the routing subassembly aligns coincidentally with a sketch point or vertex
that you specify. You can also select the C-point or R-point of the fitting.

Quality Improvements to Flattened Route Updates (2024 SP3)
Continuing efforts to enhance quality and consistency while working with flattened routes
in 3D, the Routing add-in has implemented the following updates:

• Changes made in the 3D route instantly reflect in the flattened route, reducing
differences between them.

• The software accurately mirrors re-imported changes in the flattened route.
• Enhanced flexibility for edited and non-open end route segments allows them to adapt
to changes in length without affecting the entire segment.

• Implemented the Split Route segment functionality for managing edits in a flattened
configuration.

275

Routing



Using the 3DEXPERIENCE Add-In with Routing (2024 SP1)

The 3DEXPERIENCE add-in enables you to store and manage your routing components
and assemblies from a collaborative space on the 3DEXPERIENCE platform. Additionally,
you can access services, including free 3D routing components, through the 3DEXPERIENCE
Marketplace | PartSupply app.

Within the Routing Library Manager, using the 3DEXPERIENCE add-in, you can perform
the following tasks:

TaskTab

• Batch upload the routing component
library from a local computer to the
3DEXPERIENCE platform. Click Batch
Save to 3DEXPERIENCE.

You can save only SOLIDWORKS files
to the 3DEXPERIENCE platform with
batch uploading.

• Batch download the routing component
library from the 3DEXPERIENCE platform.
For Routing template, click Browse to
locate a folder. In the dialog box, click
Select from 3DEXPERIENCE.

Routing File Locations and Settings

Create new or modify existing components
in the library on the local computer or
3DEXPERIENCE platform.

Component Library Wizard
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TaskTab

Save the defined component on the local
computer or the 3DEXPERIENCE platform.

Routing Component Wizard

Access all configurations of the components,
Uploaded or Not uploaded to the
3DEXPERIENCE platform, using
Component status.

Piping and Tubing Database

You can also open a routing assembly or component from the 3DEXPERIENCE platform
from the:

• Route Properties PropertyManager for pipes and elbows. For example, click Browse
for Custom elbow in the Bend - Elbows dialog box.

• Start by From/To, for example after clicking Browse for Insert Component.
• Reuse Route tools.
• Add Splice and Edit Splice options.

To learn more about the platform, see Working with the 3DEXPERIENCE Platform
and 3DEXPERIENCE Apps.

To access free 3D components from the platform, see Using 3DMarketplace | Part
Supply.
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Naming Wires and Cables in the FeatureManager Design Tree

You can view the marks or names of 3D wires, cables, and their cores under Route Parts
in the FeatureManager® design tree for a routing assembly. The Electrical Attributes
PropertyManager automatically preassigns the marks or names.

This helps you correlate the 3D routes in the FeatureManager design tree with the marks
or names of the wires, cables, and their cores displayed on the schematic drawing.

The naming convention uses the following to uniquely identify different routes:

• Wire, cable, and cable core marks from the Electrical Attributes PropertyManager.
• Sequential numbers as suffixes (n). Where n is proportional to the number of splits
(with split route) and 1 (without split route).

• The directions (FROM/TO) that they connect to the components.

For example, the above image shows the naming for a routing assembly with four wires
as follows:

• The three wires red, white, and yellow do not have Split Route applied and the naming
convention is:

Wire mark_1

For example, 20g_red_2_1

• The blue wire has a Split Route applied at two points with three split bodies created
and the naming convention is:

• For the two extreme ends connected to the components:

Wire Mark_FROM/TO_Component Mark

For example,

20g blue_1_FROM_Component1

20g blue_1_TO_Component2
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• In-between cable bodies not connected to the components:

Wire Mark_n

For example,

20g blue_1_1

Discrete Wires with Auto Route

You can visualize each wire in a bundle distinctly in 3D and flatten them.

The Auto Route PropertyManager, Routing Options include:

• Merge wires into single route. Routes the selected wires along a single route.
• Create a distinct route for each wire. Routes the selected wires as distinct routes.

You can edit discrete wires by:

• Adding a route to the bundle with Add Route to Discrete Bundle.
• Removing a route from the bundle with Remove Route from Discrete Bundle.
• Moving the bundle by dragging a spline point on the discrete wire.
• Merging two bundles with Merge Discrete Bundle.
• Splitting a single route segment from the bundle.
• Creating a single junction point for multiple discrete bundles coming out from the
connector or separate junction point for each discrete bundle.

• Routing the bundle through a clip by selecting one of its splines.
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SOLIDWORKS Toolbox

SOLIDWORKS® Toolbox is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

Additional Toolbox Hardware
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More hardware is available in the ANSI Inch and Metric Toolbox libraries.

Additional HardwareAdditional FoldersStandard

• The Bolts and Screws > Self
Tapping Screws folder includes
a large hex head tapping screw.

• The Bolts and Screws >
Machine Screws folder includes
a large hex screw.

• The Washers folder includes:

• Circular Washers
• Square Beveled Washers

• The Nuts folder includes
subfolders for:

• Hex Nuts - Prevailing
Torque Nuts

• Wing Nuts

• The Pins folder includes
subfolders for:

• Clevis Pins
• Cotter Pins
• Grooved Pins
• Spring Pins
• Straight Pins
• Tapered Pins

ANSI Inch

Pins. Includes coiled spring pins.ANSI Metric

In the ANSI Inch standard, the hex head tapping screw_ai.SLDPRT in Bolts and
Screws > Self Tapping Screws > Hex Head Tapping Screw has been updated. If
you copy the updated file, you will lose any customization to the existing file.
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Our 3DEXPERIENCE® platform powers our brand applications, serving 12 industries, and 
provides a rich portfolio of industry solution experiences.

Dassault Systèmes, the 3DEXPERIENCE Company, is a catalyst for human progress. We provide business and people with 
collaborative virtual environments to imagine sustainable innovations. By creating virtual twin experiences of the real world 
with our 3DEXPERIENCE platform and applications, our customers can redefine the creation, production and life-cycle-
management processes of their offer and thus have a meaningful impact to make the world more sustainable. The beauty 
of the Experience Economy is that it is a human-centered economy for the benefit of all –consumers, patients and citizens.

Dassault Systèmes brings value to more than 300,000 customers of all sizes, in all industries, in more than 150 countries. 
For more information, visit www.3ds.com.


	Contents
	Welcome to SOLIDWORKS 2024
	Top Enhancements
	Performance
	For More Information

	Using SOLIDWORKS on the 3DEXPERIENCE Platform
	SP4-FD04
	SOLIDWORKS Connected Tutorials (2024 FD04, FD03, 2024 FD01)

	SP3-FD03
	SOLIDWORKS PDM Add-In for SOLIDWORKS Connected (2024 FD03)
	Improved Licensing Support for SOLIDWORKS Flow Simulation and SOLIDWORKS Plastics Add-Ins (2024 FD03)
	File Preparation Assistant - Additional Checks (2024 FD03)
	Designate a Single Physical Product (2024 FD03)
	Refreshing PLM Information Only When Required (2024 FD03)
	Creating a Make From Relationship (2024 FD03)
	Viewing Approval Details in Drawing Annotations (2024 FD03)
	Installing Sync Client for 3DDrive (2024 FD03)
	Accessing latest SOLIDWORKS Templates (2024 FD03)
	Deleting Virtual Components (2024 FD03)
	Opening 3DSwym from SOLIDWORKS (2024 FD03)
	Applying Material to SOLIDWORKS Objects (2024 FD03)
	Updates to System Maintenance Tab in SOLIDWORKS RX (2024 FD03)

	SP2-FD02
	Support for the Turkish Language (2024 FD02)
	Improved Licensing Support for SOLIDWORKS Simulation and SOLIDWORKS Motion Add-ins (2024 FD02)
	Notification of Updated Status When Opening Files (2024 FD02)
	Bookmarks (2024 FD02)
	Sharing Pack and Go Files to 3DDrive (2024 FD02)
	Quick Tours (2024 FD02)
	Managing Missing Fonts (2024 FD02)
	Saving File Preparation Assistant Results to HTML (2024 FD02)
	Accessing 3DDrive in Export as Package (2024 FD02)
	Installing Sync Client for 3DDrive (2024 FD02)
	Informing Users about Unsupported SOLIDWORKS Version (2024 FD02)
	Viewing the Drawing Annotations (2024 FD02)
	Selecting the Tree View for Objects in MySession (2024 FD02)
	On-Premise: Using the Derived Format Converter for Generating Output (2024 FD02)
	Viewing PartSupply Components SOLIDWORKS (2024 FD02)
	Opening Route Management in SOLIDWORKS (2024 FD02)
	Managing Bookmark Reference in Batch Save (2024 FD02)

	SP1-FD01
	Sharing Files (2024 FD01)
	Automatically Fix Missing References (2024 FD01)
	Double-Clicking SOLIDWORKS Files to Open SOLIDWORKS Connected (2024 FD01)
	Collaborative Space Selection Menu (2024 FD01)
	Specifying a New Part or Assembly as a Single Physical Product (2024 FD01)
	Selecting Recently-Accessed Bookmarks (2024 FD01)
	Managing Deleted Configurations (2024 FD01)
	Editing the Properties of an Object (2024 FD01)
	Selecting an Appropriate Collaborative Space (2024 FD01)
	Connecting to the 3DEXPERIENCE Platform from SOLIDWORKS (2024 FD01)
	File Preparation Assistant - Additional Checks (2024 FD01)
	CAD Family Tab (2024 FD01)
	Updating the Server Information in the 3DEXPERIENCE Files on This PC Tab (2024 FD01)
	Selecting the Position of Work Under (2024 FD01)
	Linking PLM Custom Properties of Representations to Physical Products (2024 SP1)
	Support for the 3DEXPERIENCE (Design with SOLIDWORKS) Add-In in Routing (2024 SP1)

	SP0_GA
	Defining Rules for Updating Models to the 3DEXPERIENCE Platform
	Creating a Single Physical Product


	Installation
	Installation Access Starting with SP0 for SOLIDWORKS Student and Education Editions
	Render Installation Manager with Microsoft Edge WebView 2
	Inactivity Timeout for SOLIDWORKS Simulation, SOLIDWORKS Flow Simulation, and SOLIDWORKS Plastics
	Show Install Progress in Windows Taskbar

	SOLIDWORKS Fundamentals
	Managing Missing Fonts (2024 FD02)
	3DEXPERIENCE Compatibility Updates in the SOLIDWORKS Task Scheduler (2024 SP1)
	Changes to System Options and Document Properties
	Accelerate the Display of Silhouette Edges
	Application Programming Interface
	Saving SOLIDWORKS Documents as Previous Versions

	User Interface
	Deleting Rolled-Back Features (2024 SP2)
	Usability
	Usability (2024 SP2)
	Usability (2024 SP0)

	Hide and Show
	Icon Updates for Open, Save, and Properties Commands

	Sketching
	Convert Entities as Construction Geometry (2024 SP1)
	Sketch Blocks
	Sketch Dimension Previews

	Parts and Features
	Selection Accelerator Toolbar for Chamfers (2024 SP2)
	Graphics Triangle and Face Count (2024 SP1)
	Measuring the Angular Rotation between Coordinate Systems (2024 SP1)
	Measuring the Projected Surface Area of Bodies (2024 SP1)
	Hole Wizard
	Making Multibody Parts from Assemblies
	Body Transparency for Combine Features
	Cylindrical Bounding Boxes
	Excluding Parent Surfaces in Untrim Features
	Flip Side to Cut for Cut Revolves
	SelectionManager for Projected Curves
	Stud Wizard
	Symmetrical Linear Patterns

	Model Display
	Materials for 3DEXPERIENCE Models (2024 SP2)

	Sheet Metal
	Rip Tool
	Slot Propagation
	Slot Propagation PropertyManager

	Stamp Tool
	Using the Stamp Tool
	Stamp PropertyManager

	Normal Cut in Tab and Slot

	Structure System and Weldments
	Corner Management
	Two Member PropertyManager
	Complex Corner PropertyManager
	Editing the Corner Management Options

	Displaying Units in File Properties
	Structure System
	Copying Cut List Properties to Cut List Items (2024 SP1)
	Copy Property to Cut List Items Dialog Box


	Assemblies
	Changing the Transparency of the SpeedPak Graphics Circle (2024 SP3)
	Detecting Interference between Surface Bodies (2024 SP3)
	Selecting an Origin for a New Subassembly (2024 SP2)
	Unsolved Prefix Displays for Suppressed Mates (2024 SP2)
	Component Preview Window Available in Large Design Review (2024 SP2)
	Selection Breadcrumbs Available in Large Design Review (2024 SP1)
	Folder Prefixes (2024 SP1)
	Defeature Rule Sets
	Specifying a File Location for Defeature Rule Sets
	Creating Defeature Rule Sets
	Defeature - Apply Defeature Rule Sets PropertyManager
	Defeature Rules Editor Dialog Box

	Propagating Visual Properties in Defeature Groups
	Repairing Missing References in Linear or Circular Component Patterns
	Mate References
	Auto-Repair for Missing Mate References
	Assigning Component References to Top-Level Components
	Specifying a Prefix and Suffix for Components

	Detailing and Drawings
	Keeping Chain Dimensions Collinear
	Overridden Dimensions
	Reattaching Dangling Dimensions
	Excluding Hidden Sketches from Flat Pattern DXF Files
	Highlighting Referenced Elements
	Highlighting Associated Center Marks on Center Mark Dimensions
	Keep Link to Property Dialog Box Open
	Opening a Drawing in Detailing Mode by Default
	Select Multiple Layers

	Import/Export
	Performance Improvements When Opening 3MF Files (2024 SP3)
	Exporting IFC File - Support for Advanced Surface BREP (2024 SP2)
	Opening Third-Party CAD Files (2024 SP2)
	Using Filters to Import STEP Files (2024 SP1)
	Importing 3MF Files - Support for 3MF Beam Lattice Extension (2024 SP1)
	Canceling the Import of Third-Party CAD Files
	Importing STEP Assemblies as Multibody Parts
	Exporting to Extended Reality

	SOLIDWORKS PDM
	Displaying the Preview Tab for Search Results (2024 SP2)
	Bill of Materials (BOM) View - Flattened Type (2024 SP2)
	SOLIDWORKS PDM Add-in Enhancements (2024 SP1)
	Handling Large Design Review (LDR) and Detailing Mode in the SOLIDWORKS PDM Add-in (2024 SP2)

	Assigning Data Cards to Files and Folders of a Template (2024 SP1)
	Where Used Card Dialog Box

	Folder Card Variables in Web2 (2024 SP1)
	Progress Dialog Boxes (2024 SP1)
	Data Security Enhancements (2024 SP1)
	Assembly Visualization
	Customize Assembly Visualization Properties Dialog Box

	Downloading Specific Versions of a File in Web2
	Download Version Dialog Box
	Download Version Dialog Box - Small Screen Layout

	File Type Icons
	Check Out Option in Change State Command
	Viewing Check-Out Event Details
	System Variables
	Viewing License Usage
	SOLIDWORKS PDM Performance Improvements

	SOLIDWORKS Manage
	Measuring in a Document Preview
	Plenary Web Client CAD File Preview
	Field Conditions for Affected Items
	Adding Required Fields to an Affected Item Field
	Adding Default Values to an Affected Item Field

	Task Automation
	Adding Task Conditions
	Defining Task Completion Requirements

	Task Burn Down Chart
	Timesheet Working Hours
	Configuring Timesheet Working Hours
	Configuring Templates
	Configuring Comments

	Bill of Materials Quantity
	Adding Custom Columns to the Where Used Tab

	Process Output for Replacing BOM Items
	Enabling Mass Replace in a Process
	Replacing BOM Items

	Adding Child Conditions to BOMs

	SOLIDWORKS Simulation
	3DEXPERIENCE SOLIDWORKS Simulation Designer Role (2024 SP1)
	Extra Frequencies for Harmonic and Random Vibration Response (2024 SP1)
	Automatic Saving of a Model File
	Bonding Interactions for Shells
	Convergence Check Plot
	Decoupling Mixed Free Body Modes
	Direct Sparse Solver Retired
	Enhanced Bearing Connectors
	Excluding Mesh and Results When Copying a Study
	Exporting Mode Shape Data
	Mesh Performance
	Performance Enhancements
	Underconstrained Bodies Detection

	SOLIDWORKS Visualize
	Transformative Performance with Stellar Render Engine (2024 FD02)
	Turkish Language Support (2024 FD02)
	File Export Formats (2024 SP1)
	Enhanced Capabilities for Creating Compelling Appearances
	Parameters for Basic Appearance Type


	SOLIDWORKS CAM
	Additional Probe Cycle Parameters
	Stop If Tolerance Exceeded
	Print (Ww) / Measuring Log

	Canned Cycle Threading for Reverse Cuts
	Correct Feed/Speed Data for Parts Comprising Assemblies
	Heidenhain Probe Type
	End Conditions for Islands in the 2.5 Axis Feature Wizard
	Leadin and Leadout Parameters for Linked Contour Mill Operations
	Minimum Hole Diameter for Thread Mill Operations
	Post Processor Path
	Probe Cycles
	Three Point Plane
	Angle Measurement (X/Y Axis)
	4th Axis Measurement (X/Y Axis)

	Probe Tool Output Options
	Probing Cycles in Assembly Mode
	Setup Sheets
	Shank Types for Mill Tools
	Tool Select Filter Dialog Box
	Tool Selection - Flute Length
	Tool Selection - Tool Crib Priority

	CircuitWorks
	User Interface Redesign (2024 SP4)
	CircuitWorks in SOLIDWORKS Standard (2024 FD02)
	SOLIDWORKS Connected Support for CircuitWorks (2024 FD01)
	Reference Designators for Comparing Mechanical Component Modifications (2024 SP3)
	Pushing Tasks to the 3DEXPERIENCE Platform
	Building Models (2024 FD01)
	Board Outline and Cutout Changes from CircuitWorks (2024 SP2)
	Board Outline and Cutout Changes from ECAD (2024 SP3)


	SOLIDWORKS Composer
	Offline Help for SOLIDWORKS Composer Products
	Support for SpeedPak Configurations in SOLIDWORKS Composer

	SOLIDWORKS Electrical
	Annotate Tab (2024 SP3)
	Terminal Strip Drawings (2024 SP3)
	6W Tags Enhancements in ECP(2024 FD03)
	Drawing Mark Numbers (2024 SP2)
	Exporting Data Files (2024 SP2)
	Import Options to Manage Cable References and Manufacturer Parts (2024 SP2)
	Restructuring the Electrical Component Tree
	SOLIDWORKS Electrical Tutorials (2024 FD01)
	Cable Management (2024 SP1)
	Dynamic Link Between Drawings (2024 SP1)
	Sharing Links in the Electrical Content Portal (2024 SP1)
	Single Entry for Cables or Wires in BOM Tables (2024 SP1)
	Zoom to Fit When Opening Drawings (2024 SP1)
	Aligning Components
	Changing the Length of Multiple Rails and Ducts
	Filtering Auxiliary and Accessory Parts
	Auto Balloons in 2D Cabinets
	Inserting Auto Balloons in 2D Cabinets
	Auto Balloon PropertyManager

	Removing Manufacturer Part Data
	Resetting an Undefined Macro Variable
	Shortening Lists Using Ranges
	SOLIDWORKS Electrical Schematic Enhancements
	SOLIDWORKS Electrical Performance Improvement

	SOLIDWORKS Inspection
	Welcome Page

	SOLIDWORKS MBD
	Specifying STEP Export Controls to STEP 242 (2024 SP3)
	Hole Tables
	Repairing Dangling Dimensions
	Adding a Decimal Separator in Geometric Tolerance Symbols
	Controlling Visibility of Annotations through Solid Geometry
	Displaying Dual Dimensions in Geometric Tolerance Symbols
	Creating Thickness Dimensions for Curved Surfaces
	Displaying Half Angles of Conical Dimensions
	Exporting Custom Properties to STEP 242
	Viewing Annotations and Dimensions

	DraftSight
	Hatch Commands (DraftSight Mechanical Only) (2024 SP3)
	Applying User-Defined or Predefined Hatches
	Editing User-Defined Hatches

	Templates on the 3DEXPERIENCE Platform (DraftSight Connected Only) (2024 FD01)
	Creating a Template from a Drawing
	Creating a Drawing from a Template

	Saving a File to the 3DEXPERIENCE Platform (DraftSight Connected Only) (2024 FD01)
	Save as New Dialog Box

	Accessing the DraftSight User Forum (2024 SP1)
	Section Line Command (DraftSight Mechanical Only) (2024 SP1)
	Datum Identifier Commands (DraftSight Mechanical Only) (2024 SP1)
	Measure Geometry Command
	Selecting Multiple Files and Inserting as Reference
	Export Sheet Command
	Tool Palettes
	Layer Manager Palette
	Make Flat Snapshot Command
	View Navigator
	Merge Layer Command
	Reshaping Hatches
	Importing and Exporting Blocks (DraftSight Connected Only) (2024 FD04)
	Inserting Blocks from the 3DEXPERIENCE Platform
	Exporting Blocks as Drawings to the 3DEXPERIENCE Platform


	eDrawings
	Display Styles in Drawings
	Supported File Types
	eDrawings Performance Improvements

	SOLIDWORKS Flow Simulation
	Importing and Exporting Component Lists
	Mesh Generation
	Mesh Boolean Operations

	SOLIDWORKS Plastics
	Batch Manager
	Compare Results
	Cool Solver
	Hot and Cold Runners
	Injection Location Advisor
	Materials with Pressure-Dependent Viscosity
	Material Database
	Mesh Enhancements

	Routing
	Better Positioning of Complex Splices and Loop Segments in Flattened Routes (2024 SP3)
	Reverse Direction and Specify Percentage Options for Discrete Wires (2024 SP3)
	Aligning a Route Subassembly to the Origin (2024 SP3)
	Quality Improvements to Flattened Route Updates (2024 SP3)
	Using the 3DEXPERIENCE Add-In with Routing (2024 SP1)
	Naming Wires and Cables in the FeatureManager Design Tree
	Discrete Wires with Auto Route

	SOLIDWORKS Toolbox
	Additional Toolbox Hardware


