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Welcome to DraftSight 
a valuable tool for any AEC professional!
DraftSight is more than a free, professional-grade 2D CAD product.  The product runs on 
Microsoft® Windows 7®, Windows Vista®, Windows® XP, Mac® and Linux® and takes just a few 
minutes to download at DraftSight.com.  With its layering functionality and the ability to specify 
units as Architectural, DraftSight is a great way to provide professional-grade construction 
drawings and is a valuable tool for any AEC professional.  Check out DraftSight today!

From this guide, AEC professionals will learn how to:

•Activate DraftSight, open a DWG file, and use that file to explain DraftSight’s basic operations like 

   zoom in and zoom out, among others. 

•Draw lines and circles using DraftSight. There are various ways of drawing lines, but for the 

  practical purpose, you will learn two methods, one using the coordinates and the other using the

   “Entity snap”. 

•Use a special DraftSight feature entitled “Image Layer Functionality”.

•Operate commands like Copy, Trim, and Extend that are frequently used to edit drawings. You will 

  also enter texts and dimensions.

•Reference other drawings within a drawing.

•Print a drawing using DraftSight.

Before getting started, please download these sample DWG files that accompany the Guide.

We hope you’ll enjoy the DraftSight experience.

For more information about DraftSight or to download the product, please visit DraftSight.com.

http://www.3ds.com/products/draftsight/download-draftsight/
http://www2.3ds.com/fileadmin/QUOTES-IMG/AEC_Spiral/DraftSight/Sample_DWG_Files.zip
http://www.3ds.com/products/draftsight/free-cad-software/
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1. Activate DraftSight

① Select "File" -> "Open" from the Menu.

2. Open the DWG file

DraftSight starts up by opening a new drawing 
where nothing is drawn.

① Double-click the "DraftSight" icon on the 
desktop. Or, select "Start" button -> "Dassault 
Systemes" ->"DraftSight" to start the DraftSight 
application. Double-click the “DraftSight” icon on 
the desktop. Or, select “Start” button -> “Dassault 
Systemes” ->”DraftSight” to start the DraftSight 
application.

In this section, we will activate DraftSight, open a DWG file, and use that file to explain DraftSight’s  basic 
operations like zoom in and zoom out, among others.s.

Let’s open a DWG file and see what we have

REMINDER:  Before getting started with this Guide, please download these sample DWG files that 
accompany the Guide.

http://www.3ds.com/fileadmin/QUOTES-IMG/AEC_Spiral/DraftSight/Sample%20DWG%20Files.zip
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3. Operate the screen (window zoom)

The DWG file will be opened

② From the “Open” dialog box that appears, select 
the downloaded file “Plan_1F.dwg” and click 
“Open”.

Window zoom functionality is used to enlarge the 
specific area of the drawing by surrounding the 
desired area with the boundary of the window and 
displaying the area captured within the boundary 
fully on the window.

① Select “View” -> “Zoom” -> “Window” from 
the Menu.

Memo: In addition to the DWG file, 
DraftSight allows you to open the DWT 
file.
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② Click the lower left point of the window 
(rectangle) for surrounding the area that you want 
to enlarge.

③ Then click the upper right point of this window. 
(The temporary window will be displayed on the 
drawing.)

The area specified by the window is enlarged 
to the extent that it fully occupies the drawing 
workspace.



7
© 2012 Dassault Systèmes

4. “Previous screen”

5. Use the wheel button (central button) of the 
mouse to zoom in / out.  The drawing can be 
zoomed in / out by turning the mouse wheel 
button

By using the “Previous screen” command, go back 
one step before the drawing zoomed in.
① Do so by clicking “Previous screen” on the tool 
bar.

The drawing returns to the state shown before 
operating the window zoom functionality.

① Turn the mouse wheel button forward.
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The drawing zooms in from the center of where 
the mouse pointer is pointing.

② Turn the mouse wheel button backward.

The wheel button (central button) of the mouse 
can be used to move (drag) the drawing.

① Push the mouse wheel button and see that the 
cursor changes to hand shape.

② While pressing the button, drag the drawing 
towards the left and release the button.

The drawing shifts to the left dynamically and 
only the right side of the drawing is now shown 
on the screen.

6. Use the wheel button (central button) of the 
mouse to move the drawing dynamically.
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③ Press the mouse wheel button again, and while 
pressing it, drag the drawing to the right and then 
release the button.

The drawing now shifts to the right dynamically 
and only the left side of the drawing is shown on 
the screen.

7. Display the entire drawing.

Use the “Boundary zoom” command to display 
the entire drawing. By using the “Bounds” 
command, you can make all the entities of the 
drawing appear on the drawing workspace.
① Select “View” -> “Zoom” -> “Bounds” from the 
Menu.
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The area where entities exist or the entire drawing 
within the boundary (whichever is larger) is 
displayed on the screen. Also include “double-
click” of the scroll wheel to zoom bounds.

8. End the operation using DraftSight.

To end the operation using DraftSight, follow the 
procedure below.

① Click the “X” button on the upper right corner 
of the window.

② Since the data has been edited, a message will 
appear asking “Do you want to save the file?” The 
editing work you performed on the drawing this 
time does not require you to save the changes.

As a result, click “No” to close the file that has 
been opened. The DraftSight application also 
terminates through this ending operation.
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In this section, we will draw lines and circles using DraftSight. There are various ways of drawing lines, 
but for the practical purpose, we will focus on two methods, one using the coordinates and the other 
using the “Entity snap”..In this section, we will draw lines and circles using DraftSight. There are various ways of 
drawing lines, but for the practical purpose, we will focus on two methods, one using the coordinates and the other 
using the “Entity snap”.

Drawing lines

1. Activate DraftSight and open the file named 
“02.dwg”.

An empty DWG file is opened. A blank window 
appears.

To draw a line by using the coordinate system, 
follow the procedure below.

① Click “Line segment” from the tool bar.

Memo: The coordinate system is defined 
by X and Y directions, where X and Y 
respectively represent the horizontal 
and vertical directions. Each coordinate 
value is specified by X or Y. There are 
two ways of specifying the coordinates 
to execute a command. You can either 
select the absolute coordinate method 
or the relative coordinate method. When 
absolute coordinate method is selected 
the coordinate values you enter are based 
on the point of origin (the lower left point 
where the arrow of the XY pointer is 
displayed) that is fixed to 0,0.  When the 
relative coordinate system is selected, the 
last point you enter becomes the point of 
origin (0,0) and  “@” mark is displayed in 
front of the coordinate value entered last. 



12
© 2012 Dassault Systèmes

② As the command for specifying the 
starting point, enter “1000,0” as the absolute 
coordinates by using the keyboard and press 
“Enter”. Then a line will be drawn to point, 
1000 in X direction and point, 0 in Y direction 
from the point of origin (0,0).

③ Next, specify “1000,1000” as the next point 
and press “Enter”. Then a line segment will be 
drawn to point 1000 in X direction and point 1000 
in Y direction from the point of origin.

④ Next, specify “2000,1000” as the next point 
and press “Enter”. Then a line segment will be 
drawn to point 2000 in X direction and point 1000 
in Y direction from the point of origin.
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Now, let’s draw a line using the relative coordinate 
method.

⑤ Specify “@0,-1000” as the next point and 
press “Enter”. Then a line segment will be drawn 
to point, 0 in X direction and point -1000 in Y 
direction from the specified point.

Next, let’s draw a line by specifying the angle 
using the Polar Coordinate method.

⑥ Specify “@1000<180” as the next point and 
press “Enter”. Then a line stretching for 1000 from 
the point specified last will be drawn at the angle 
of 180 degrees.

⑦ Press “Enter” to end the “Line segment” 
command. You have finished drawing a square.
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2 . Draw a line by using the “Entity Snap” 
      functionality.

Let’s now draw a diagonal line by using the 
“Entity Snap” functionality.
① Click “Line command” from the tool bar.

* Right-click on the Esnap button to access the Options dialog.                                                                                                                                 

Memo: Entity Snap will enable you to 
specify the edge points and intersection 
points accurately. 
When you enlarge the lines drawn without 
specifying the points with Entity Snap, you 
will notice that they are not very accurate. 

② After confirming that “Entity Snap” in the 
status bar is active, place the cursor on the lower 
left vertex of the square. 

③ To specify the starting point of the line 
command, place the cursor at the position where 
the Endpoint Snap (yellow square shape) appears, 
and click.
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④ Move the cursor to the direction of the diagonal 
line, and place it on the upper right vertex of the 
square. Just like in the previous step, place the 
cursor at the position where the Endpoint Snap 
appears, and then click to specify the end point of 
the line segment.

⑤ Press “Enter” to end the “Line  segment“ 
command.

You now have drawn an accurate diagonal line 
running through a square.

3. Draw a circle inscribed in the square.

Use the “Circle” command to draw a circle.
① Click “Circle” command from the tool bar.
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To specify the central point, use Entity Snap to 
specify the midpoint of the diagonal line.

② Move the cursor to the middle of the diagonal 
line. Place the cursor at the position where the 
“midpoint” snap (yellow triangle) appears, and 
click.

Move the cursor to the left side of the square. The 
“tangent” snap appears. This snap can specify. 
But since we want to use the midpoint snap, we 
will use the Esnap Overrides.

③ Right-click to display the Menu.

④ Select “Esnap Overwrite” -> “Midpoint”.

The detail of Entity Snaps 
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⑤ Move the cursor to the middle of the left side of 
the square. At this point, only the Midpoint Snap 
can be used. Place the cursor at the position where 
the Midpoint Snap appears, and click to specify 
the midpoint of the left side.

You now have drawn a circle inscribed in a square.

Summary
To create an accurate drawing using 
DraftSight, there is a need to accurately 
specify the points to draw lines and other 
shapes by making use of the coordinate 
system or “Entity Snap”. Beside the type 
of snap introduced in this section, there 
are many other types that the users should 
know so that they can make the best use of 
what DraftSight can offer. 
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Let’s now use one of the special features of DraftSight called the Layer functionality. Layer is a 
functionality that sorts the different areas and types of information (like “text” and “wall”) that constitute 
a drawing in separate layers. Layers can be easily switched to show or hide mode. When you want to edit 
a drawing, it is normally easier to work on it by making DraftSight show only the layers that you want to 
view, and hide the rest. The same applies when you want to print out a drawing that shows only the layers 
that you want to see. In this section, we will see how the drawing will be displayed when specific layers 
are switched to show mode or hide mode, and also try changing the graphics placed in specific layers..Let’s 
now use one of the special features of DraftSight called the Layer functionality. Layer is a functionality that sorts the 
different areas and types of information (like “text” and “wall”) that constitute a drawing in separate layers. Layers 
can be easily switched to show or hide mode. When you want to edit a drawing, it is normally easier to work on it by 
making DraftSight show only the layers that you want to view, and hide the rest. The same applies when you want 
to print out a drawing that shows only the layers that you want to see. In this section, we will see how 
the drawing will be displayed when specific layers are switched to show mode or hide mode, and also try 
changing the graphics placed in specific layers.Let’s now use one of the special features of DraftSight called the 
Layer functionality. Layer is a functionality that sorts the different areas and types of information (like “text” and 
“wall”) that constitute a drawing in separate layers. Layers can be easily switched to show or hide mode. When you 
want to edit a drawing, it is normally easier to work on it by making DraftSight show only the layers that you want to 
view, and hide the rest. The same applies when you want to print out a drawing that shows only the layers that you 
want to see. In this section, we will see how the drawing will be displayed when specific layers are switched to show 
mode or hide mode, and also try changing the graphics placed in specific layers.In this section, we will draw lines and 
circles using DraftSight. There are various ways of drawing lines, but for the practical purpose, we will focus on two 
methods, one using the coordinates and the other using the “Entity snap”.

Operating the Layers

1. Activate DraftSight and open the file named “Plan_1F.
dwg”.

2. Show or hide the Layer.

① Activate DraftSight and open the file named 
“Plan_1F.dwg”.

The specified DWG file opens, and the drawing 
stored in this file appears on the screen.

Enlarge the displayed drawing by selecting “View” 
-> “Zoom” -> “Fit” from the Menu.

Hide the center line of the wall.

① Select “Format” -> “Layer” from the Menu to 
display the Layer Manager.
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② On the Layers Manager that will be displayed, 
select the row that says “Center “ under the Name 
column, and click.

③  Click the green circle in the same row under the 
“Display” column to change its color to grey.

④ Click the “OK” button located at the lower right 
to close the Layers Manager.

The center line of the wall is no longer shown in 
the drawing.
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3. Find the Image Layer where the graphics are, 
and hide the graphics.

Let’s hide the automobile existing in one of the 
Layers.                            

① We don’t know in which Layer the graphics 
for the automobile is sorted.   Let’s find out. Place 
the cursor on the automobile and click it to put it 
into the selected state. See the Property palette 
on the left-hand side. In the Layer field, the name 
of the layer of where the selected graphics is 
sorted appears. It says “Exterior”. To deselect the 
automobile, press the “ESC” key.

② In the same procedure explained earlier, display 
the Layer Manager, change the color of the circle 
in the row “Exterior “ under the “Show” column 
to grey, and click the OK button to close the Layer 
Manager.

 

Memo
When the Property panel is not displayed, 
you can make it appear by selecting 
“Tools” -> “Properties” from the Menu. 
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Then the Layers “External Element” will be 
switched to hide the mode. As a result, the 
automobile as well as all other objects belonging 
to the “Exterior” group will no longer appear on 
the displayed drawing.

4. Show all the image layers

To put the displayed drawing back to the original 
state, show all the image layers.

① To do so, select Format -> Layer Tool
 -> Show All Layers from the Menu.

When all the Layers are switched to the Show 
mode, the Layers that have been switched earlier 
to the Hide mode will also reappear.

Memo: In addition to switching the Show / 
Hide mode of the Layers, they can also be set 
to the “Freeze” or “Lock” mode. The graphics 
on the Layer set to the Freeze mode will not 
appear until the Freeze mode is released.  While 
the Freeze mode is active, the users cannot 
switch the Show / Hide mode of the graphics, 
nor can they edit them. On the other hand, 
when the graphics on the Layer is set to the 
Lock mode, the users can switch the Show / 
Hide mode of the graphics, but cannot edit 
them. 
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5. Change the Layers where the graphics are 
sorted.

Change the Layers where the table and chairs in 
the Living / Dining room are sorted to “Furniture”. 
To do so, first change the name of the Layer where 
the table is sorted, by using the Property Palette.

① Enlarge the area around the table.

② Click the table. You will notice that the name 
of the Layer containing the table is displayed as 
“Equipment” in the Property Palette.

③ Select “Furniture” from the pull-down list of 
the Layer column in the Property Palette.
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Then the By Layer color of the table in the  Layer 
“Furniture” will become grey.

④ Release the table from the selected state by 
pressing the “ESC” key.

Now, we need to do the same for the Layer 
where the chairs are sorted. This time, rather than 
following the same procedure taken to change 
the name of the Layer where the table is sorted, 
we will try another method, which is to copy the 
Layer property of the table.

⑤ Select “Modify” -> “Property Painter” from the 
Menu.

⑥ For “Specify the Source Entity»”, click the table 
to select it as the source entity.
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⑦ For “Specify the Target Entity»”, click four 
chairs and put them in the selected state.

Summary
Drawing data that contain well-managed 
Layers are easy to handle and view. If 
the data entered in the drawing data 
are not properly sorted in layers, some 
graphics contained in the drawing may go 
unnoticed, serving no purpose. As a result, 
the reliability of the data itself may be ill-
affected. Therefore, it is very important to 
enter and manage the drawing elements 
properly in layers to keep the drawing data 
clean. 
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Editing the Drawings

In this section, we will master commands like Copy, Trim, and Extend that are frequently used to edit 
drawings. We will also enter texts and dimensions. As the scenario for this section, we will add a new level 
to the porch located on the left side of the front gate. The key points of this operation are to execute the 
commands with an image of the result of the operation in mind, and to align the operation with the pre-
defined Image Layer settings as well as with the pre-entered annotations (text, dimensions, etc).

1. Activate DraftSight and open the file named 
“Plan_1F.dwg”.

① Activate DraftSight and open the file named 
“Plan_1F.dwg”. The specified DWG file opens, 
and the drawing stored in this file appears on 
the screen.Activate DraftSight and open the file 
named “Plan_1F.dwg”. The specified DWG file 
opens, and the drawing stored in this file appears 
on the screen.

2. Draw the lines to represent the new level of 
the porch.

Use the Offset Command to draw the different 
levels of the porch. Draw a porch that is 900 in 
width and 300 in elevated level.

① Enlarge the left side of the front gate.

② Select “Offset” from the tool bar on the right 
side, and        
     click.
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③ You now want to draw a line that ends at a 
position 900mm away from the outer wall surface 
Enter “900” by using the keyboard and press 
“Enter”.

④ ”Specify the source entity»”, click the outer wall 
line.

⑤ To “Specify the side for destination”, click a 
screen position on the left side.
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Then the outer wall line is copied 900mm in 
parallel to the left.

3. Extend the line.

Extend the line that has been offset. 
① Click “Extend” from the tool bar on the right.

Specify the border line to which the line is 
extended.

② For Specify the boundary edge» click the grey 
line located on the lower side of the external 
element area. 

③ Press “Enter” to end the operation of selecting 
the boundary edge.
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To put the displayed drawing back to the original 
state, show all the image layers. 

④ To Specify segments to extend >>click the 
lower side of the offset line. Then the line will be 
extended to the specified boundary edge.

⑤ Press “Enter” to end the operation of extending 
the specified line.
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4. Trim (shorten) the line

Trim the offset line.
① Click “Trim” from the tool bar on the right.

② For Specify cutting edges>> click the grey line 
located on the lower side of the external element 
area. Press “Enter” to end the operation of 
selecting the cutting edges.

③ For specify segments to remove>>click the 
area located on the upper side of the border of the 
offset line.
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Then the line will be cut at the border line. 

④ Press “Enter” to end the Trim command.

5. Change the Image Layer

 

The offset line currently belongs to the Offset 
Source Property, and is sorted in the Layer called 
“Finish”. We will change the Layer for the Offset 
Line to “Exterior”.

① Click the line that has been offset and edited in 
order to put it in the selected state.
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② From the pull-down menu that lists the Layer 
items located in the Property Pallet on the left, 
select “Exterior” to change the Layer for the offset 
line to this item.

③ Release the offset line from the selected state 
by pressing the “ESC” key.

6. Copy the offset line.

 

Copy the offset line to the position 300mm left 
of this line to represent the additional level of the 
porch. 
① Click “Copy” from the tool bar on the right.

② To specify entities>>click the offset line to put 
it into the selected state.

③ Press “Enter” to end the operation for selecting 
the border line.
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④ To specify the starting pint point >>click any 
point randomly

⑤ To “Specify second point»”, enter the coordinate 
values “@-300,0” by using the keyboard, and 
press “Enter”. Then a duplicate line will appear at 
point -300 in X direction and point 0 in Y direction 
from the starting point.

⑥ Press “Enter” to end the Copy command.
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7. Enter the text “Porch”.

Enter the text “Porch” anywhere close to the line 
that has just been added. Since we are going to 
enter text, we need to change the active layer to 
“Text”.

① From the pull-down menu opened on the upper 
left side, select “Text” as the active image layer.

② Select Draw > text > Simple Note from the 
Menu

③ Then the Insert Simple Note dialog box will 
appear. Enter the following information in the 
specific fields:

Text: “Porch”

Insertion point: Place a check next to “Select in the 
graphics area”.

Insertion orientation: Select the radio button at 
Center.

Height: 150

After completing the above entries, click “OK”.

Memo: The height of the text is set by considering how the text will appear when the drawing is 
printed out. If we want to make the text appear 3mm tall when printed in 1/50 size, the calculation 
will be 50×3mm=150.
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④ Click any desirable position randomly to specify 
it as the location to enter the text.

Enter the text.

8. Enter the dimensions.

Now, let’s enter the dimensions that represent the 
width and the elevated level of the porch. Since 
we are going to enter the dimensions, we need to 
change the active Layer to “Dimensions”.

① From the pull-down menu opened on the upper 
left side, select “Dimensions” as the active Layer.
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② Select Dimension>Linear from the Menu

③ To be capitalized first extension line 
position>>place the cursor to the point where the 
grey line of the external element and the outer 
wall line intersect, and click when the endpoint 
snap appears.  

④ To be capitalized second extension line 
position>>place the cursor to the edge point of 
the line that has been offset in the beginning, and 
click when the endpoint snap appears.  
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⑤ To Specify dimension line position>>move the 
cursor upward and click any desirable position 
randomly.

Enter the dimensions.

Enter the dimension of the elevated level of the 
porch. Here, we will use the Continue command 
because we are going to enter another dimension 
in series.

⑥ Select Dimension> Continue from the Menu.
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⑦ To specify second extension line 
position>>place the cursor to the edge point of 
the elevated level that has been copied,  and click 
when the endpoint snap appears.  

End the “Continue” command by pressing the 
“ESC” key. The operation to enter the dimensions 
is now completed.

Summary
This section focused on introducing the 
frequently-used commands like Trim and 
Copy. But DraftSight has many more 
commands that are useful. By knowing 
them and being able to use them 
effectively in suitable situations, users 
will be able to improve the efficiency of 
their edit work considerably. Therefore, 
please make it a point to use the 
command references and other sources of 
information to gain a good knowledge of 
all the available commands. 



38
© 2012 Dassault Systèmes

A block is used to handle as a component like furniture or equipment as one graphical object. By 
collectively defining the lines and circles and all other graphical elements that constitute the component 
as one block, these graphical elements can be reused by inserting in block units for the amount required. 
Moreover, the modifications and changes necessary for these graphical elements belonging to the same 
block can also be executed at once. In this section, we will look at the procedures for creating, inserting, 
and editing blocks, as well as the distinctive features of the block.

Creating and Inserting Blocks

1. Activate DraftSight and open the file named 
   “Plan_1F.dwg”.

2. Create a block.

① Activate DraftSight and open the file named 
“Plan_1F.dwg”.The specified DWG file opens, 
and the drawing stored in this file appears on the 
screen.

Group multiple graphical elements into a single 
block. Here, we will group the dining table and 
four chairs into one block. 

① Enlarge the area around the dining table.

② Select “Draw” -> “Block” -> “Define” from the 
Menu.
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③ ”Block Definition” dialog box will appear. Enter 
“Dining Set” as the name of the block. Place a 
tick next to the “Convert to block” item under 
the “Block entities” section. Then click “Select in 
graphics area”.

④  To “Specify  entities»”, click the table and the 
four chairs to put them in the selected state.

⑤ After selecting them, press “Enter”.
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The dialog box will reappear.
You will see the selected graphical elements shown 
on the upper right thumbnail section.

⑥ Then click  “Select in graphics area” item under 
the “Base Point” section.

⑦ To “Specify insertion base point»”, place the 
cursor in the lower left corner of the table, click 
when the endpoint snap appears.
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⑧ The dialog box will reappear again.
Click the “OK” button and close the dialog box.

Confirm that the selected graphical elements are 
grouped in one block.

⑨ Click one of the lines of the table to put the 
table into the selected state. You should be able to 
see that the table as well as the chairs are in the 
selected state. The bottom field in the Property 
palette should display “Dining Set”.  If you can 
confirm all of them as described, you know that 
they have been successfully grouped into one 
block.

⑩ Release these elements from the selected state 
by pressing the “ESC” key.

3. Insert the block.

 

 

Insert the block called “Dining Set” that you have 
just created.

① Move the drawing so that there will be an open 
space on the right side of the screen.
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② Select “Insert” -> “Block” from the Menu

③ ”Insert Block” dialog box will appear. Select 
“Dining Set” from the pull-down list opened at the 
Name field. Place a check next to “Specify later” 
under the Position column. Then click “OK”.
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④ The “Dining Set” block will appear on the 
cursor. To “Specify destination>> select a desirable 
point randomly somewhere in the open space on 
the right side of the screen, and click to insert the 
block.

Memo: The pull-down list opened from 
the “Block Insert” dialog box lists. You 
can also enter a DWG file as a block.

4 . Edit the block

Edit the chairs belonging to the “Dining Set” block 
to change them to round chairs.

① Enlarge the dining Set area that you just 
inserted.
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② Select “Modify” -> “Component” -> “Edit” 
from the Menu.

③ For “Specify  component»”, click the dining Set 
that has been inserted.

 

④ ”Edit Component” dialog box appears. 
Confirm that “Dining Set” displayed in the list is 
highlighted (reversed display). Then click “OK”.

The background color of the screen will turn grey.

⑤ Select the “Circle” command to draw a round 
circle.
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⑥ To Specify center point» place the cursor on the 
midpoint of the horizontal line running across the 
chair.

⑦ To “Specify radius»”, place the cursor on the left 
edge point of the line, and click it when endpoint 
snap appears.  Then draw a circle.
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⑧ Since there is a need to copy the drawn circle, 
select the “Copy” command.

⑨ To “Specify entities»”, click the circle and put 
it into the selected state. Then press “Enter” to 
finalize the entity to be copied.

⑩ To “Specify the strating point»”, specify the 
midpoint that is at the same position as the point 
specified at the center of the circle by using the 
midpoint snap method.

⑪ To “Specify  second point»”, specify the same 
midpoint for all three remaining chairs by using 
the midpoint snap, and copy them.
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A circle is now drawn respectively on all the four 
chairs.

*Need to press ENTER to exit copy command.

⑫ Now, we are going to delete the original square 
chairs. Click the delete icon

⑬ To “Specify entities»”, click the original four 
square chairs to put them into the selected state, 
and delete them by pressing “Enter”.
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The editing work is over. So we will now end the 
“Edit Component” dialog.

⑭ Right-click and select “Close Component” from 
the displayed items.

⑮ A message asking “Do you want to save 
“Dining Set”?” will appear. Click “Save”. Now the 
block “Dining Set” has been updated to the edited 
version.

⑯ Zoom out the drawing so that the Living / 
Dining area will appear on the screen. You should 
be able to confirm that the block “Dining Set” 
that you created is now updated, showing the 
four “round” chairs as edited. Once a block is 
edited and updated, the edited information is also 
reflected on the blocks with the same name.

Summary
The blocks are useful and effective in 
omitting repetition of same entries and in 
minimizing the edit work. The graphical 
elements to be grouped into a block should 
be determined according to the number of 
components used in the drawing project, 
and the probability of later editing work. 
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DraftSight is equipped with a functionality to reference other DWG files and image files. By setting another 
file or files as the source of reference, the user will be able to view the reference files within his (or her) 
drawing, and also view the latest version of the reference files just by reloading them. The advantage 
of using reference data is that, unlike the block, it will not be stored together in the user’s DWG file. 
Therefore, the user will be able to prevent his file from becoming too big. However, the user must not 
forget to include all the reference data as well in the deliverable when he sends out his finished drawing. In 
this section, we will reference the premise data to enhance the contents of the drawing in work..

Referencing Other Drawings within the Drawing in Work

1. Activate DraftSight and open the file named 
    “ Plan_1F.dwg “.

① The specified DWG file opens, and the drawing 
stored in this file appears on the screen.

2.  Delete the original graphics representing the 
premise.

Delete the layer called the “Site” and the entire 
data sorted in this layer.

① Select “Format” -> “Layer Tools” -> “Delete” 
from the Menu.
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② To “Select the entity and specify the Layer»”, 
click any line that is in the Site.

③ “Do you want to delete the Layer “Site” and all 
the referenced  entities? Specify Yes (Y) or No (N) 
»”, press the “y” key and “Enter”.

The data sorted in the Layer “Site” are now 
deleted.
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3. Set other Site drawing file as the reference.

① Select “Reference” from the lower tab in the 
palette on the left.

② Click “Attach Drawing” located on the upper 
side of the Reference palette.

③ When the file selection dialog window appears, 
select “Site.dwg”. Click the “Open” button and 
close the dialog window.

“Attach Reference” dialog box will appear.

④ Open the pull-down menu of the “Path type” 
field, and change the item to “Relative”.

⑤ Click “OK”.

Memo: When the Path type is set to “Full”, 
the data saved will be the full-path data 
from the drive.  When it is set to “Relative”, 
the path from the current DWG file will be 
saved. For sending out the drawing as the 
deliverable, the data transmission time will 
be shorter and the receiver of the deliverable 
will find it easier to view the reference data 
when the Path type is set to “Relative”.
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The selected reference data “Site.dwg” will be 
downloaded.

Hide the data contained in the downloaded site 
file.

Activate the Layer Manager.
Select the layer named “Site” at the lower side, 
and click the circle under the “Show” column to 
change its color to grey. Then click “OK”.

Memo: The name of the layer will be 
displayed as “Reference file name | 
layer name”. 

The unnecessary data will not be displayed, and 
the referenced drawing of the premise will appear 
clearly.
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4. Edit the reference source file, and reflect the changes 
made.

Edit the bearing mark of the reference source file 
“Site.dwg”, and make the changes made in this 
source file appear on the current drawing. Leave 
the current drawing as it is, and open “Site.dwg”.

① Select “File” -> “Open” from the Menu.

② Select “Site.dwg” and open it.

The reference source file “Site.dwg” opens.
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Enlarge the area around the bearing mark.

Rotate the bearing mark.
③ Select “Modify” -> “Rotate” from the Menu.

To “Specify entities»”, click the lower left point 
of the rectangle surrounding the bearing mark to 
select it to rotated the bearing mark and display 
it on the window. A blue rectangle will appear as 
a temporary rectangle. Click the upper right point 
of this rectangle. Press “Enter” to complete the 
selection of the graphics.

Memo: When the two rectangle diagonal 
corners are selected in the order from left to 
right, the selection mode will be “Window”. 
When these points are selected in the order 
from right to left, the selection mode will be 
“Crossing”. In “Window” mode, the entity 
that is fully surrounded by the rectangle 
will be selected. In “Crossing” mode, any 
entity crossing the rectangle will be selected. 
DraftSight provides various other methods of 
entity selection. To view the other options, 
enter “?” when a dialog appears asking you to 
“Specify entities”. 
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④ To “Specify pivot point»”, specify the point that 
would be the center of rotation.
Place the cursor at the center of the bearing mark, 
and click when the endpoint snap appears.

⑤ To “Specify rotation angle»”, enter “-45” with 
the keyboard and press “Enter”.

The bearing is rotated clockwise to 45 degrees.
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Zoom in to the original size.
⑥ Select “View” -> “Zoom” -> “Fit” from the 
Menu.

⑦ Save the changes made through editing. Click 
“Save” from the tool bar.

5. Reload the reference drawing.

Return to the drawing you have been working on. 
① Select “Window” -> “Plan_1F.dwg” from the 
Menu.
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② Click “Reload all” on the Reference palette.

Summary
The functionality to reference other 
drawings is very useful because it will not 
make the user’s DWG file larger and yet 
will enable the user to display the latest 
up-to-date data. For example, when the 
user selects a 2D detailed drawing as the 
reference data, he will be able to view this 
detailed drawing by switching the show or 
hide mode of the layer where the detailed 
data is sorted and at the same time, keep his 
drawing in plain 2D plan view.  When there 
is a need to edit his drawing, he will only 
need to edit the detailed drawing, because 
whatever he edits will be reflected on his 
plain 2D plan view. This functionality, as a 
result, can significantly improve the user’s 
work efficiency. 
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To print a drawing using DraftSight, two tabs are used. One is the “Model” tab for entering the drawing, 
and the other is the “Sheet” tab for setting and viewing the drawing’s print layout. To print, the user must 
create a view on the Sheet tab that displays the drawing entered in the Model tab. The user can create 
multiple sheets of print views with different print settings respectively. In this section, we will work on 
a scenario requiring us to output a A3-sized, black-and-white drawing on a scale of 1/50 as a PDF file 
instead of printing it out on paper. To meet the requirements of this scenario, we need to set the scale of 
the view created on the Sheet tab to 1/50, and output the sheet as 1/1.

Printing out the Drawing

1.Activate DraftSight and open the file named 
“Plan_1F.dwg”.

① Activate DraftSight and open the file named 
“Plan_1F.dwg”. The specified DWG file opens, 
and the drawing stored in this file appears on the 
screen.

2. Configure the sheet.

Configure the sheet for printing by specifying 
the printer and paper size using the Printing 
Configuration functionality.

① Click the sheet that says “1/50”, located below 
the drawing area.



59
© 2012 Dassault Systèmes

② Place the cursor over the sheet name, and 
right click. Then select “Printing Configuration 
Manager…”.

③ ”Printing Configuration Manager” dialog 
window appears. Click “New”.

Memo 
If there is an existing configuration file, 
the Printing Configuration Manager will 
allow you to complete the configuration 
easily by downloading it. Since there is 
no existing configuration file available 
for this scenario, we will create a new 
configuration file. 

④ Now, we need to select a configuration that 
will be used as the basis for creating a new 
configuration. Select “Default” and click “OK”.
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⑤ Enter the name of the configuration that is 
Enter “A3_PDF” and click “OK”.

⑥ ”Print Configuration” dialog window appears. 
Select “PDF” from the drop-down list of the field 
for specifying the printer name. Then click the 
“Property” button next to this field.

⑦ ”Custom Printer Properties” dialog window 
appears. For the type of “Paper”, select “ISO_
A3_(420.00_X_297.00_MM)”. Set “6” for all 
the margins (Upper / Lower / Left / Right) of the 
“Printable  area”. Click “OK” after completing the 
above setting.
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⑧ On the “Printing Configuration” dialog window,  
select “ISO_A3_(420.00_X_297.00_MM)” as 
the “Paper size”. Select the radio button next to 
“Horizontal” for the “Geometry orientation”. Then 
select “Save”.

Activate the newly created printing configuration 
to set it on the selected Sheet tab. “Print 
Configuration Manager” dialog window reappears. 
Select the created “A3_PDF” from the list, and 
click the “Activate” button.

Click “Close” from the Print Configuration 
Manager

Memo
The printing configuration that has been set 
is saved in the folder selected at the optional 
file location. 
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3. Create the view on the sheet.

Create the ViewPort to display the model on the 
sheet.

① If there is a ViewPort already on the sheet, 
delete it. Click the rectangular frame of the view to 
put it to the selected state.Press the “Delete” key 
on the keyboard to delete the selected view.

② Select “View” -> “View Tiles” -> “Single Tile” 
from the Menu.

③ To “Specify start corner»”, enter “f” for fit, and 
press “Enter”.
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By using the ViewPort that has been adjusted to 
be as large as the printing area, create the view for 
displaying the model.

④ Click the frame of the created view to put it to 
the selected state. Change the item selected in the 
Property palette on the left to “Defpoints”, which 
is the item that will prevent the image layer from 
being printed.

Memo
“Defpoints” is the name of a special 
image layer that is set to be non-
printable. 

Set the scale of the view to 1/50.

⑤ Among the standard scale options in the 
Property palette on the left. select “1:50”, the 
fourth item from the bottom. Then the view will 
show the model set to 1/50.

⑥ Press the “ESC” key to release the view frame 
from the selected state. This completes the 
configuration of the Sheet tab for displaying the 
model set to 1/50 view.

Memo
By creating multiple views with a different 
scale set for each, and specifying 1/1 for the 
number of sheets to be printed,  it is possible 
to print out multiple drawings of different 
scales on one sheet. 4. Set other printing items.

Set other printing items, such as the line color. 
① Click the tool bar “Print” button.
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② ”Print” dialog window appears.
Confirm that the scale is set to “1:1” and click the 
“Print preview” button.

Print preview appears in color mode. By clicking 
the “Print” button, the targeted “PDF” file will be 
created. But to meet the requirement for a black-
and-white printout, we need to change from color 
mode to monochrome mode.
Close the Print preview window by pressing the 
“X” button on the upper left.

③ Click “Additional options” on the “Print” 
dialog window.
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④ ”Additional Print Options” dialog window 
appears. Click “New” under “Print style table”.

Memo
Two print styles called “ctb” and “stb” are 
available. With “ctb”, the user can specify 
the line width for every displayed color. 
With “stb”, the user can specify the line 
width and color for each entity, and the 
user-defined settings are fixed by specifying 
a print style name. The user can choose 
which print style to use only when the user 
starts to create the drawing.

Memo
The print style can be viewed on Image 
Layer Manager. When the line type and 
line width are not specified for each 
entity, the values pre-defined on that 
particular image layer will be used. 

⑤Back on the “Additional Print Options” dialog 
window, press “OK” and close this dialog window.

Memo: The configured print style is saved in the 
folder specified in “System Option” page. 
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⑥ Save the configured style details to use them 
as the sheet definition by selecting “Save the 
configuration” button.

⑦ Select the sheet “A3_PDF.cfg” that is currently 
activated. Click “Save”. The message asking you to 
confirm whether you want to overwrite the data 
or not appears. Click “Yes” to reflect the edited 
contents on the printing configuration.

Memo: Unless the active printing 
configuration is saved, the edited 
contents of the printing configuration 
will not be saved on the sheet. 

⑧ On the “Print Preview” dialog window, click 
“Print preview”.
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⑨ Confirm that the preview is displayed now in 
black and white. Then click “Print” icon on the 
upper left.

⑩ When asked what the name of the PDF file is, 
enter an appropriate filename. For this particular 
scenario, enter “A3_1-50”, and click “Save”.

The intended PDF file is now created.

Summary
Defining the printing configuration is a 
slightly complicated process.  It may be 
useful for the users to remember: for sheet 
definition, set the printing configuration; and 
for defining the line width and type of pen, 
configure the print style.  



For more information about DraftSight and its  
affordable support and services, visit DraftSight.com


