INTRODUCING SOLIDWORKS
# Contents

Legal Notices.................................................................................................................................6  
Introduction.....................................................................................................................................9  
  The SOLIDWORKS Software..........................................................................................................9  
  Intended Audience .........................................................................................................................9  
  System Requirements ......................................................................................................................9  
  Document Structure ........................................................................................................................9  
  Conventions Used in this Document ..............................................................................................10  
1 SOLIDWORKS Fundamentals........................................................................................................11  
  Concepts ........................................................................................................................................11  
  3D Design ....................................................................................................................................11  
  Component Based ..........................................................................................................................12  
  Terminology ..................................................................................................................................14  
  User Interface ..................................................................................................................................15  
    Windows Functions .........................................................................................................................15  
    SOLIDWORKS Document Windows ..........................................................................................15  
    Function Selection and Feedback ...............................................................................................17  
  Design Process ................................................................................................................................23  
  Design Intent ..................................................................................................................................23  
  Design Method ................................................................................................................................24  
  Sketches .........................................................................................................................................24  
    Origin .........................................................................................................................................25  
    Planes ..........................................................................................................................................25  
    Dimensions ..................................................................................................................................26  
    Relations ......................................................................................................................................29  
  Features .........................................................................................................................................32  
  Assemblies ......................................................................................................................................33  
  Drawings .........................................................................................................................................34  
  Model Editing ..................................................................................................................................34  
2 Parts..............................................................................................................................................37  
  Overview .......................................................................................................................................38  
  Countertop .....................................................................................................................................38  
    Design Approach............................................................................................................................38  
    Create the Base Feature with an Extrude ......................................................................................39  
    Add an Extrude to the Base ............................................................................................................39
3 Assemblies ...............................................................................................................54

Remove Material with the Cut-Extrude ........................................................................40
Use a Loft to Make a Solid ..............................................................................................41
Shell the Part ......................................................................................................................42
Round Sharp Edges with Fillets ........................................................................................42

Faucet .................................................................................................................................43
  Design Approach ..............................................................................................................43
  Create the Sweep .............................................................................................................43

Faucet Handle ......................................................................................................................44
  Design Approach ..............................................................................................................44
  Revolve the Sketch .........................................................................................................45

Cabinet Door ......................................................................................................................46
  Design Approach ..............................................................................................................46
  Create Beveled Edges with the Chamfer Tool .................................................................47

Moldings ..............................................................................................................................47
  Design Approach ..............................................................................................................47
  Design a Mid-Plane Extrude ............................................................................................48
  Sketch a Profile for the Cut-Extrude ..............................................................................48
  Mirror the Cut ..................................................................................................................49
  Use Configurations of a Part ............................................................................................49

Hinge ....................................................................................................................................50
  Design Approach ..............................................................................................................50
  Create Sheet Metal with the Base Flange .......................................................................50
  Make the Tab .....................................................................................................................51
  Generate the Linear Pattern ............................................................................................51
  Add the Hem .....................................................................................................................52
  Alternate Design Approach .............................................................................................52

3 Assemblies ...............................................................................................................54

Assembly Definition .........................................................................................................54
Assembly Design Methods .................................................................................................55
  Bottom-up Design ............................................................................................................55
  Top-down Design .............................................................................................................55

Prepare an Assembly ........................................................................................................56

Mates ....................................................................................................................................57
  Faucet Subassembly ........................................................................................................57
  Faucet Subassembly - Alternate Design Approach ..........................................................61
  Door Subassembly ..........................................................................................................62
  Cabinet Subassembly ......................................................................................................63

In-Context Design ............................................................................................................64
  Create an Assembly Component In-Context ................................................................64
  Modify a Part In-Context of an Assembly .....................................................................65

Load an Assembly .............................................................................................................66
4 Drawings..................................................................................................................69
  Drawing Documents........................................................................................................69
  Drawing Templates............................................................................................................70
  Drawing Sheets................................................................................................................70
  Sheet Formats.....................................................................................................................71
  Drawing Views...................................................................................................................71
  Vanity Cabinet Drawing Sheet..........................................................................................72
    Standard Views...............................................................................................................72
    View Display and Alignment............................................................................................74
    Dimensions.......................................................................................................................75
    Annotations......................................................................................................................77
  Faucet Assembly Drawing Sheet........................................................................................79
    Explode Lines..................................................................................................................79
    Derived Views................................................................................................................79
    Notes and Other Annotations.........................................................................................82
  Vanity Assembly Drawing Sheet.........................................................................................83
    Exploded Views...............................................................................................................83
    Bill of Materials..............................................................................................................84
    Balloons and Stacked Balloons.......................................................................................85

5 Engineering Tasks....................................................................................................86
  Building Multiple Configurations of Parts.........................................................................86
  Updating Models Automatically........................................................................................88
    Loading the Latest Models..............................................................................................89
    Replacing Referenced Models.........................................................................................89
  Importing and Exporting Files..........................................................................................89
    Recognizing Features in Non-SOLIDWORKS Parts.........................................................90
  Performing Stress Analysis...............................................................................................90
  Customizing SOLIDWORKS..............................................................................................91
  Sharing Models..................................................................................................................91
  Creating Photo-Realistic Images of Models.......................................................................93
  Animating Assemblies........................................................................................................94
  Managing SOLIDWORKS Files.........................................................................................94
  Accessing a Library of Standard Parts...............................................................................94
  Examining and Editing Model Geometry...........................................................................96

A Step-by-Step Lesson.........................................................................................................98
  Getting Ready for the Lesson............................................................................................98
Contents

Creating a Box ........................................................................................................................................... 100
  Opening a New Part ............................................................................................................................. 100
  Setting the Drafting Standard and Units ............................................................................................. 100
  Sketching a Rectangle ........................................................................................................................... 101
  Dimensioning the Sketch ....................................................................................................................... 102
  Extruding the Sketch ............................................................................................................................. 103
  Creating a Hollow Model ....................................................................................................................... 104
  Saving the Part ....................................................................................................................................... 105

Creating a Lid for the Box ........................................................................................................................ 105
  Opening a New Part ............................................................................................................................. 105
  Setting the Drafting Standard and Units ............................................................................................. 106
  Sketching a Rectangle ........................................................................................................................... 106
  Dimensioning the Sketch ....................................................................................................................... 107
  Extruding the Sketch ............................................................................................................................. 108
  Creating a Lip on the Cover ................................................................................................................... 109
  Dimensioning the Sketch ....................................................................................................................... 110
  Extruding the Sketch ............................................................................................................................. 112
  Saving the Part ....................................................................................................................................... 114

Putting the Box and Lid Together .......................................................................................................... 114
  Opening a New Assembly ...................................................................................................................... 114
  Inserting Parts into the Assembly ......................................................................................................... 114
  Moving a Component ............................................................................................................................ 115
  Rotating a Component .......................................................................................................................... 116
  Mating the Components ......................................................................................................................... 117
  Saving the Assembly ............................................................................................................................... 119

Creating a Drawing .................................................................................................................................... 120
  Opening a New Drawing ....................................................................................................................... 120
  Setting the Drafting Standard and Units ............................................................................................. 120
  Inserting Standard 3 Views ................................................................................................................... 120
  Inserting an Isometric Model View ...................................................................................................... 121
  Dimensioning the Drawing ..................................................................................................................... 122

B Exercises ............................................................................................................................................... 124
  Covered Can ......................................................................................................................................... 124
  Bolt, Washer, and Nut ............................................................................................................................. 126
Legal Notices

© 1995-2014, Dassault Systèmes SolidWorks Corporation, a Dassault Systèmes S.A. company, 175 Wyman Street, Waltham, Mass. 02451 USA. All Rights Reserved.

The information and the software discussed in this document are subject to change without notice and are not commitments by Dassault Systèmes SolidWorks Corporation (DS SolidWorks).

No material may be reproduced or transmitted in any form or by any means, electronically or manually, for any purpose without the express written permission of DS SolidWorks.

The software discussed in this document is furnished under a license and may be used or copied only in accordance with the terms of the license. All warranties given by DS SolidWorks as to the software and documentation are set forth in the license agreement, and nothing stated in, or implied by, this document or its contents shall be considered or deemed a modification or amendment of any terms, including warranties, in the license agreement.

Patent Notices

SOLIDWORKS® 3D mechanical CAD software is protected by U.S. Patents 5,815,154; 6,219,049; 6,219,055; 6,611,725; 6,844,877; 6,898,560; 6,906,712; 7,079,990; 7,477,262; 7,558,705; 7,571,079; 7,590,497; 7,643,027; 7,672,822; 7,688,318; 7,694,238; 7,853,940; 8,305,376; 8,581,902, and foreign patents, (e.g., EP 1,116,190 B1 and JP 3,517,643).

eDrawings® software is protected by U.S. Patent 7,184,044; U.S. Patent 7,502,027; and Canadian Patent 2,318,706.

U.S. and foreign patents pending.

Trademarks and Product Names for SOLIDWORKS Products and Services

SOLIDWORKS, 3D ContentCentral, 3D PartStream.NET, eDrawings, and the eDrawings logo are registered trademarks and FeatureManager is a jointly owned registered trademark of DS SolidWorks.

CircuitWorks, FloXpress, PhotoView 360, and TolAnalyst are trademarks of DS SolidWorks.

FeatureWorks is a registered trademark of Geometric Ltd.


Other brand or product names are trademarks or registered trademarks of their respective holders.

COMMERCIAL COMPUTER SOFTWARE - PROPRIETARY

The Software is a “commercial item” as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of “commercial computer software” and “commercial software documentation” as such terms are used in 48 C.F.R. 12.212 (SEPT 1995) and is provided to the U.S. Government (a) for acquisition by or on behalf of civilian agencies, consistent with the policy set forth in 48 C.F.R. 12.212; or (b) for acquisition by or on behalf of units of the Department of Defense,

In the event that you receive a request from any agency of the U.S. Government to provide Software with rights beyond those set forth above, you will notify DS SolidWorks of the scope of the request and DS SolidWorks will have five (5) business days to, in its sole discretion, accept or reject such request. Contractor/Manufacturer: Dassault Systèmes SolidWorks Corporation, 175 Wyman Street, Waltham, Massachusetts 02451 USA.

Copyright Notices for SOLIDWORKS Standard, Premium, Professional, and Education Products

Portions of this software © 1986-2014 Siemens Product Lifecycle Management Software Inc. All rights reserved.

This work contains the following software owned by Siemens Industry Software Limited:

Portions of this software © 1998-2014 Geometric Ltd.
Portions of this software incorporate PhysX™ by NVIDIA 2006-2010.
Portions of this software © 2001-2014 Luxology, LLC. All rights reserved, patents pending.
Portions of this software © 2007-2014 DriveWorks Ltd.

Copyright 1984-2010 Adobe Systems Inc. and its licensors. All rights reserved. Protected by U.S. Patents 5,929,866; 5,943,063; 6,289,364; 6,563,502; 6,639,593; 6,754,382; Patents Pending.

Adobe, the Adobe logo, Acrobat, the Adobe PDF logo, Distiller and Reader are registered trademarks or trademarks of Adobe Systems Inc. in the U.S. and other countries.

For more DS SolidWorks copyright information, see Help > About SOLIDWORKS.

Copyright Notices for SOLIDWORKS Simulation Products

Portions of this software © 2008 Solversoft Corporation.

PCGLSS © 1992-2014 Computational Applications and System Integration, Inc. All rights reserved.

Copyright Notices for SOLIDWORKS Enterprise PDM Product

Outside In® Viewer Technology, © 1992-2012 Oracle
© 2011, Microsoft Corporation. All rights reserved.

Copyright Notices for eDrawings Products

Portions of this software © 2000-2014 Tech Soft 3D.
Portions of this software © 1995-1998 Jean-Loup Gailly and Mark Adler.
Portions of this software © 1998-2001 3Dconnexion.
Portions of this software © 1998-2014 Open Design Alliance. All rights reserved.
Portions of this software © 1995-2012 Spatial Corporation.
The eDrawings® for Windows® software is based in part on the work of the Independent JPEG Group.
Introduction

This chapter includes the following topics:

- **The SOLIDWORKS Software**

The SOLIDWORKS Software

The SOLIDWORKS® CAD software is a mechanical design automation application that lets designers quickly sketch out ideas, experiment with features and dimensions, and produce models and detailed drawings.

This document discusses concepts and terminology used throughout the SOLIDWORKS application. It familiarizes you with the commonly used functions of SOLIDWORKS.

Intended Audience

This document is for new SOLIDWORKS users. In this document, you are introduced to concepts and design processes in a high-level approach. The Step-by-Step Lesson on page 98 is hands-on training that guides you through each step in a process and shows the results.

SOLIDWORKS Help contains a comprehensive set of tutorials that provide step-by-step instruction on many of the features of SOLIDWORKS. After you complete the Step-by-Step Lesson in this document, progress to Lessons 1, 2, and 3 in the SOLIDWORKS tutorials.

System Requirements

For system requirements, see the SOLIDWORKS Web site:

**System requirements**
http://www.solidworks.com/sw/support/SystemRequirements.html

**Graphics card requirements**
http://www.solidworks.com/sw/support/videocardtesting.html

Document Structure

This document is organized to reflect the way that you use the SOLIDWORKS software. It is structured around the basic SOLIDWORKS document types: parts, assemblies, and drawings. For example, you create a part before you create an assembly.

Throughout the document, a bathroom vanity (including a cabinet, a countertop, a faucet, and pipes) illustrates various tools and functions available to you in the software:
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
<th>Topics Discussed</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Fundamentals</td>
<td>Introduces design concepts, SOLIDWORKS terminology, and provides an overview of help options.</td>
</tr>
<tr>
<td>2</td>
<td>Parts</td>
<td>Demonstrates design methods, tools, and features commonly used to make parts.</td>
</tr>
<tr>
<td>3</td>
<td>Assemblies</td>
<td>Shows how to add parts to an assembly, specify mates, and use in-context design methods.</td>
</tr>
<tr>
<td>4</td>
<td>Drawings</td>
<td>Discusses drawing sheet formats, views, dimensions, annotations, and bills of materials.</td>
</tr>
<tr>
<td>5</td>
<td>Engineering Tasks</td>
<td>Examines add-in applications, utilities, and other resources to complete advanced tasks.</td>
</tr>
<tr>
<td></td>
<td>Step-by-Step Lesson</td>
<td>Provides guided instruction to perform basic tasks.</td>
</tr>
<tr>
<td></td>
<td>Exercises</td>
<td>Provides sample exercises to practice the material.</td>
</tr>
</tbody>
</table>

**Conventions Used in this Document**

<table>
<thead>
<tr>
<th>Convention</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Any SOLIDWORKS user interface element that you can select such as a tool or menu item</td>
</tr>
<tr>
<td><em>Italic</em></td>
<td>References to books and other documents, or to emphasize text</td>
</tr>
<tr>
<td>🌐</td>
<td>Reference to online tutorial</td>
</tr>
<tr>
<td>Access the <strong>Online Tutorial</strong> from the <strong>Help</strong> menu in the SOLIDWORKS software.</td>
<td></td>
</tr>
<tr>
<td>👇</td>
<td>Reference to Help</td>
</tr>
<tr>
<td>Access <strong>Help</strong> from the <strong>Help</strong> menu in the SOLIDWORKS software.</td>
<td></td>
</tr>
<tr>
<td>💡</td>
<td>Tip</td>
</tr>
</tbody>
</table>
This chapter includes the following topics:

- **Concepts**
- **Terminology**
- **User Interface**
- **Design Process**
- **Design Intent**
- **Design Method**
- **Sketches**
- **Features**
- **Assemblies**
- **Drawings**
- **Model Editing**

### Concepts

Parts are the basic building blocks in the SOLIDWORKS software. Assemblies contain parts or other assemblies, called subassemblies.

A SOLIDWORKS model consists of 3D geometry that defines its edges, faces, and surfaces. The SOLIDWORKS software lets you design models quickly and precisely. SOLIDWORKS models are:

- Defined by 3D design
- Based on components

### 3D Design

SOLIDWORKS uses a 3D design approach. As you design a part, from the initial sketch to the final result, you create a 3D model. From this model, you can create 2D drawings or mate components consisting of parts or subassemblies to create 3D assemblies. You can also create 2D drawings of 3D assemblies.

When designing a model using SOLIDWORKS, you can visualize it in three dimensions, the way the model exists once it is manufactured.
Component Based

One of the most powerful features in the SOLIDWORKS application is that any change you make to a part is reflected in all associated drawings or assemblies.
This section uses the following terminology for the models:

**Faucet:**

**Faucet handle:**

**Faucet base**

**Faucet stem**
Waste pipe:

Terminology

These terms appear throughout the SOLIDWORKS software and documentation.

**Origin**
Appears as two blue arrows and represents the (0,0,0) coordinate of the model. When a sketch is active, a sketch origin appears in red and represents the (0,0,0) coordinate of the sketch. You can add dimensions and relations to a *model* origin, but not to a sketch origin.

**Plane**
Flat construction geometry. You can use planes for adding a 2D sketch, section view of a model, or a neutral plane in a draft feature, for example.

**Axis**
Straight line used to create model geometry, features, or patterns. You can create an axis in different ways, including intersecting two planes. The SOLIDWORKS application creates temporary axes implicitly for every conical or cylindrical face in a model.

**Face**
Boundaries that help define the shape of a model or a surface. A face is a selectable area (planar or nonplanar) of a model or surface. For example, a rectangular solid has six faces.

**Edge**
Location where two or more faces intersect and are joined together. You can select edges for sketching and dimensioning, for example.

**Vertex**
Point at which two or more lines or edges intersect. You can select vertices for sketching and dimensioning, for example.
User Interface

The SOLIDWORKS application includes user interface tools and capabilities to help you create and edit models efficiently, including:

Windows Functions

The SOLIDWORKS application includes familiar Windows functions, such as dragging and resizing windows. Many of the same icons, such as print, open, save, cut, and paste are also part of the SOLIDWORKS application.

SOLIDWORKS Document Windows

SOLIDWORKS document windows have two panels. The left panel, or Manager Pane, contains:
**FeatureManager® design tree**
Displays the structure of the part, assembly, or drawing. Select an item from the FeatureManager design tree to edit the underlying sketch, edit the feature, and suppress and unsuppress the feature or component, for example.

**PropertyManager**
Provides settings for many functions such as sketches, fillet features, and assembly mates.

**ConfigurationManager**
Lets you create, select, and view multiple configurations of parts and assemblies in a document. Configurations are variations of a part or assembly within a single document. For example, you can use configurations of a bolt to specify different lengths and diameters.
You can split the left panel to display more than one tab at a time. For example, you can display the FeatureManager design tree on the top portion and the PropertyManager tab for a feature you want to implement on the bottom portion.

The right panel is the graphics area, where you create and manipulate a part, assembly, or drawing.

Function Selection and Feedback

The SOLIDWORKS application lets you perform tasks in different ways. It also provides feedback as you perform a task such as sketching an entity or applying a feature. Examples of feedback include pointers, inference lines, and previews.

Menus

You can access all SOLIDWORKS commands using menus. SOLIDWORKS menus use Windows conventions, including submenus and checkmarks to indicate that an item is active. You can also use context-sensitive shortcut menus by clicking the right mouse button.
Toolbars

You can access SOLIDWORKS functions using toolbars. Toolbars are organized by function, for example, the Sketch or Assembly toolbar. Each toolbar comprises individual icons for specific tools, such as Rotate View, Circular Pattern, and Circle.

You can display or hide toolbars, dock them around the four borders of the SOLIDWORKS window, or float them anywhere on your screen. The SOLIDWORKS software remembers the state of the toolbars from session to session. You can also add or delete tools to customize the toolbars. Tooltips display when you hover over each icon.

CommandManager

The CommandManager is a context-sensitive toolbar that dynamically updates based on the active document type.

When you click a tab below the CommandManager, it updates to show the related tools. Each document type, such as part, assembly, or drawing, has different tabs defined for its tasks. The content of the tabs is customizable, similar to toolbars. For example, if you click the Features tab, tools related to features appear. You can also add or delete tools to customize the CommandManager. Tooltips display when you hover over each icon.
Shortcut Bars
Customizable shortcut bars let you create your own sets of commands for part, assembly, drawing, and sketch mode. To access the bars, you press a user-defined keyboard shortcut, by default, the S key.

Context Toolbars
Context toolbars appear when you select items in the graphics area or FeatureManager design tree. They provide access to frequently performed actions for that context. Context toolbars are available for parts, assemblies, and sketches.
Mouse Buttons

Mouse buttons operate in the following ways:

**Left**  
Selects menu items, entities in the graphics area, and objects in the FeatureManager design tree.

**Right**  
Displays the context-sensitive shortcut menus.

**Middle**  
Rotates, pans, and zooms a part or an assembly, and pans in a drawing.
You can use a mouse gesture as a shortcut to execute a command, similar to a keyboard shortcut. Once you learn command mappings, you can use mouse gestures to invoke mapped commands quickly.

To activate a mouse gesture, from the graphics area, right-drag in the gesture direction that corresponds to the command.

When you right-drag, a guide appears, showing the command mappings for the gesture directions.

Sketch guide with eight gestures  Drawings guide with eight gestures

The guide highlights the command you are about to select.

**Customizing the User Interface**

You can customize the toolbars, menus, keyboard shortcuts, and other elements of the user interface.

For a lesson on customizing the SOLIDWORKS user interface, see the *Customizing SOLIDWORKS* tutorial.

**Handles**

You can use the PropertyManager to set values such as the depth of an extrude. You can also use graphic handles to drag and set parameters dynamically without leaving the graphics area.
Previews

With most features, the graphics area displays a preview of the feature you want to create. Previews are displayed with features such as base or boss extrudes, cut extrudes, sweeps, lofts, patterns, and surfaces.

Loft preview

Pointer Feedback

In the SOLIDWORKS application, the pointer changes to show the type of object, for example, a vertex, an edge, or a face. In sketches, the pointer changes dynamically, providing data about the type of sketch entity and the position of the pointer relative to other sketch entities. For example:

- Indicates a rectangular sketch.

- Indicates the midpoint of a sketch line or edge. To select a midpoint, right-click the line or edge, then click Select Midpoint.
Selection Filters

Selection filters help you select a particular type of entity, thereby excluding selection of other entity types in the graphics area. For example, to select an edge in a complex part or assembly, select Filter Edges to exclude other entities.

Filters are not restricted to entities such as faces, surfaces, or axes. You can also use the selection filter to select specific drawing annotations, such as notes and balloons, weld symbols, and geometric tolerances.

Additionally, you can select multiple entities using selection filters. For example, to apply a fillet, a feature that rounds off edges, you can select a loop composed of multiple adjacent edges.

For more information on using filters, see Selection Filter in the Help.

Select Other

Use the Select other tool to select entities that are visually obscured by other entities. The tool hides the obscuring entities or lets you select from a list of obscured entities.

Design Process

The design process usually involves the following steps:

- Identify the model requirements.
- Conceptualize the model based on the identified needs.
- Develop the model based on the concepts.
- Analyze the model.
- Prototype the model.
- Construct the model.
- Edit the model, if needed.

Design Intent

Design intent determines how you want your model to react as a result of the changes you need to make to the model.

For example, if you make a boss with a hole in it, the hole should move when the boss moves:

- Original part
- Design intent maintained when boss moves
- Design intent not maintained when boss moves
Design intent is primarily about planning. How you create the model determines how changes affect it. The closer your design implementation is to your design intent, the greater the integrity of the model.

Various factors contribute to the design process, including:

- **Current needs**: Understand the purpose of the model to design it efficiently.
- **Future considerations**: Anticipate potential requirements to minimize redesign efforts.

**Design Method**

Before you actually design the model, it is helpful to plan out a method of how to create the model.

After you identify needs and isolate the appropriate concepts, you can develop the model:

- **Sketches**: Create the sketches and decide how to dimension and where to apply relations.
- **Features**: Select the appropriate features, such as extrudes and fillets, determine the best features to apply, and decide in what order to apply those features.
- **Assemblies**: Select the components to mate and the types of mates to apply.

A model almost always includes one or more sketches and one or more features. Not all models, however, include assemblies.

**Sketches**

The sketch is the basis for most 3D models.

Creating a model usually begins with a sketch. From the sketch, you can create features. You can combine one or more features to make a part. Then, you can combine and mate the appropriate parts to create an assembly. From the parts or assemblies, you can then create drawings.

A sketch is a 2D profile or cross section. To create a 2D sketch, you use a plane or a planar face. In addition to 2D sketches, you can also create 3D sketches that include a Z axis, as well as the X and Y axes.

There are various ways of creating a sketch. All sketches include the following elements:
**Origin**

In many instances, you start the sketch at the origin, which provides an anchor for the sketch.

The sketch on the right also includes a centerline. The centerline is sketched through the origin and is used to create the revolve.

Although a centerline is not always needed in a sketch, a centerline helps to establish symmetry. You can also use a centerline to apply a mirror relation and to establish equal and symmetrical relations between sketch entities. Symmetry is an important tool to help create your axis-symmetric models quicker.

**Planes**

You can create planes in part or assembly documents. You can sketch on planes with sketch tools such as the **Line** or **Rectangle** tool and create a section view of a model. On some models, the plane you sketch on affects only the way the model appears in a standard isometric view (3D). It does not affect the design intent. With other models, selecting the correct initial plane on which to sketch helps you create a more efficient model.

Choose a plane on which to sketch. The standard planes are front, top, and right orientations. You can also add and position planes as needed. This example uses the top plane.
For more information on planes, see Where to Start a Sketch in the Help.

**Dimensions**

You can specify dimensions between entities such as lengths and radii. When you change dimensions, the size and shape of the part changes. Depending on how you dimension the part, you can preserve the design intent. See Design Intent on page 23.

The software uses two types of dimensions: driving dimensions and driven dimensions.

**Driving Dimensions**

You create driving dimensions with the Dimension tool. Driving dimensions change the size of the model when you change their values. For example, in the faucet handle, you can change the height of the faucet handle from 40mm to 55mm. Note how the shape of the revolved part changes because the spline is not dimensioned.

To maintain a uniform shape generated by the spline, you need to dimension the spline.
Driven Dimensions

Some dimensions associated with the model are driven. You can create driven, or reference dimensions, for informational purposes using the Dimension tool. The value of driven dimensions changes when you modify driving dimensions or relations in the model. You cannot modify the values of driven dimensions directly unless you convert them to driving dimensions.

In the faucet handle, if you dimension the total height as 40mm, the vertical section below the spline as 7mm, and the spline segment as 25mm, the vertical segment above the spline is calculated as 8mm (as shown by the driven dimension).

You control design intent by where you place the driving dimensions and relations. For example, if you dimension the total height as 40mm and create an equal relation between the top and bottom vertical segments, the top segment becomes 7mm. The 25mm vertical dimension conflicts with the other dimensions and relations (because 40-7-7=26, not 25). Changing the 25mm dimension to a driven dimension removes the conflict and shows that the spline length must be 26mm.

See Relations on page 29 for more information.
**Sketch Definitions**

Sketches can be fully defined, under defined, or over defined.

In fully defined sketches, all the lines and curves in the sketch, and their positions, are described by dimensions or relations, or both. You do not have to fully define sketches before you use them to create features. However, you should fully define sketches to maintain your design intent.

Fully defined sketches appear in black.

![Fully defined sketch](image)

By displaying the entities of the sketch that are under defined, you can determine what dimensions or relations you need to add to fully define the sketch. You can use the color cues to determine if a sketch is under defined. Under defined sketches appear in blue. In addition to color cues, entities in under defined sketches are not fixed within the sketch, so you can drag them.

![Under defined sketch](image)

Over defined sketches include redundant dimensions or relations that are in conflict. You can delete over defined dimensions or relations, but you cannot edit them.

Over defined sketches appear in yellow. This sketch is over defined because both vertical lines of the rectangle are dimensioned. By definition, a rectangle has two sets of equal sides. Therefore, only one 35mm dimension is necessary.
Relations

Relations establish geometric relationships such as equality and tangency between sketch entities. For example, you can establish equality between the two horizontal 100mm entities below. You can dimension each horizontal entity individually, but by establishing an equal relation between the two horizontal entities, you need to update only one dimension if the length changes.

The green symbols indicate that there is an equal relation between the horizontal lines:

Relations are saved with the sketch. You can apply relations in the following ways:

**Inference** Some relations are created by inference. For example, as you sketch the two horizontal entities to create the base extrude for the faucet base, horizontal and parallel relations are created by inference.

This example shows the concept of relations. The SOLIDWORKS application has a sketch slot tool to make this shape easily, as well as other types of slots.
**Add Relations** You can also use the Add Relations tool. For example, to create the faucet stems, you sketch a pair of arcs for each stem.

To position the stems, you add a tangent relation between the outer arcs and the top construction line horizontal (displayed as a broken line). For each stem, you also add a concentric relation between the inner and outer arcs.

**Sketch Complexity**

A simple sketch is easy to create and update, and it rebuilds quicker.

One way to simplify sketching is to apply relations as you sketch. You can also take advantage of repetition and symmetry. For example, the faucet stems on the faucet base include repeated sketched circles:

Here is one way you can create this sketch:

First, sketch a centerline through the origin. Centerlines help to create symmetrical sketch entities.

This centerline is considered construction geometry, which is different from actual geometry that is used in creating a part. Construction geometry is used only to assist in creating the sketch entities and geometry that are ultimately incorporated into the part.
Second, use the **Dynamic Mirror** tool to designate the centerline as the entity about which to mirror the sketched circles.

Next, sketch a circle by inferencing the sketch origin.

When you use dynamic mirroring with the centerline, anything you sketch on one side is mirrored on the other side of the centerline.

You create the circles on the left and they are mirrored to the right of the centerline.

Finally, dimension and add a concentric relation between one of the circles and the outer arc of the base, and then use symmetry for the other.
Features

Once you complete the sketch, you can create a 3D model using features such as an extrude (the base of the faucet) or a revolve (the faucet handle).

Create the sketch

Dimension the sketch

Extrude the sketch 10mm

Some sketch-based features are shapes such as bosses, cuts, and holes. Other sketch-based features such as lofts and sweeps use a profile along a path.

Another type of feature is called an applied feature, which does not require a sketch. Applied features include fillets, chamfers, or shells. They are called “applied” because they are applied to existing geometry using dimensions and other characteristics to create the feature.

Typically, you create parts by including sketch-based features such as bosses and holes. Then you add applied features.

It is possible to create a part without sketch-based features. For example, you can import a body or use a derived sketch. The exercises in this document show sketch-based features.
Applied feature: Fillets for rounding off edges

Several factors influence how you choose which features to use. For example, you can select between different features such as sweeps or lofts to achieve the same results and you can add features to a model in a specific order. For more information on features, see Parts on page 37.

Assemblies

You can combine multiple parts that fit together to create assemblies.

You integrate the parts in an assembly using Mates, such as Concentric and Coincident. Mates define the allowable direction of movement of the components. In the faucet assembly, the faucet base and handles have concentric and coincident mates.

With tools such as Move Component or Rotate Component, you can see how the parts in an assembly function in a 3D context.

To ensure that the assembly functions correctly, you can use assembly tools such as Collision Detection. Collision Detection lets you find collisions with other components when moving or rotating a component.
Faucet assembly with **Collision Detection, Stop at collision** option enabled

**Drawings**

You create drawings from part or assembly models.

Drawings are available in multiple views such as standard 3 views and isometric views (3D). You can import the dimensions from the model document and add annotations such as datum target symbols.

**Model Editing**

Use the SOLIDWORKS FeatureManager design tree and the PropertyManager to edit sketches, drawings, parts, or assemblies. You can also edit features and sketches by selecting them directly from the graphics area. This visual approach eliminates the need to know the name of the feature.

Editing capabilities include:
You can select a sketch in the FeatureManager design tree and edit it. For example, you can edit sketch entities, change dimensions, view or delete existing relations, add new relations between sketch entities, or change the size of dimension displays. You can also select the feature to edit directly from the graphics area.

Once you create a feature, you can change most of its values. Use Edit Feature to display the appropriate PropertyManager. For example, if you apply a Constant radius fillet to an edge, you display the Fillet PropertyManager where you can change the radius. You can also edit dimensions by double-clicking the feature or sketch in the graphics area to show the dimensions and then change them in place.

No fillet feature

Fillet feature: 12mm applied

Fillet feature: 18mm applied
**Hide and show**  With certain geometry such as multiple surface bodies in a single model, you can hide or show one or more surface bodies. You can hide and show sketches, planes, and axes in all documents, and views, lines, and components in drawings.

**Suppress and unsuppress**  You can select any feature from the FeatureManager design tree and suppress the feature to view the model without that feature. When a feature is suppressed, it is temporarily removed from the model (but not deleted). The feature disappears from the model view. You can then unsuppress the feature to display the model in its original state. You can suppress and unsuppress components in assemblies as well (see Assembly Design Methods on page 55).

**Rollback**  When you are working on a model with multiple features, you can roll the FeatureManager design tree back to a prior state. Moving the rollback bar displays all features in the model up to the rollback state, until you revert the FeatureManager design tree back to its original state. Rollback is useful for inserting features before other features, speeding up time to rebuild a model while editing it, or learning how a model was built.
Parts are the building blocks of every SOLIDWORKS model. Each assembly and drawing you create is made from parts.

This chapter includes the following topics:

- Overview
- Countertop
- Faucet
- Faucet Handle
- Cabinet Door
- Moldings
- Hinge
Overview

In this section, you learn about common tools for making parts in the SOLIDWORKS software. These tools are used for many parts, so they are discussed in detail only the first time they appear.

Each section begins with the design approach for each part, including a high-level overview of the tools that create the part. The overview provides an outline of the features, so you can skim those that you already understand.

The cabinet, waste pipe, and supply pipes used in the vanity are not discussed in this section because they repeat the tools already presented. You will see these parts in later sections.

Countertop

The countertop is a single part that includes a sink and counter. First you create the counter, then you make the sink.

This countertop uses several common SOLIDWORKS tools, including extrudes, a sweep, a shell, and fillets.

Design Approach

1. Extrude

2. Extrude

3. Cut-Extrude

4. Loft

5. Shell

6. Fillet
Create the Base Feature with an Extrude

Before you create an extrude feature, you need to make a sketch. For example, this rectangular sketch is dimensioned at 600mm x 580mm.

The sketch begins at the origin, the (0,0) coordinate of a 2D sketch. The origin is a helpful reference point for sketches. If you begin a sketch at the origin, the sketch position is set. When you add dimensions and relations to the sketch, it becomes fully defined.

After you sketch the rectangle, use the Extrude tool to create a 3D base feature. The sketch is extruded 34mm normal to the sketch plane. This model is displayed in an isometric view so you can see the model structure.

To design a 3D model, first make the 2D sketch, then create the 3D feature.

Add an Extrude to the Base

The second extrude adds material to a part by building upon the base. In this example, you extrude two of the countertop edges.
First, you create the sketch for the extrude with the **Convert Entities** tool.

The **Convert Entities** tool lets you create a sketch by projecting a set of edges onto the sketch plane. In this example, the left and upper edges are projected.

Next, you use the **Extrude** tool to create the countertop edges.

---

**Remove Material with the Cut-Extrude**

The **Cut-Extrude** tool is similar to an extrude feature, except that it removes material from the model instead of adding material.

First you create a 2D sketch, then you make the cut-extrude. In this example, you use the **Ellipse** tool to make an oblong sketch.

When the cut-extrude is complete, the countertop has an opening for the sink.
For a lesson that includes extrude features, see the Lesson 1 - Parts tutorial.

**Use a Loft to Make a Solid**

After you make the cut-extrude feature, you create the sink with the Loft tool. A loft creates a feature by making transitions between two or more sketch profiles.

When you create a loft, the sketch profiles must reside on different planes (or planar faces).

In this example, the loft creates the sink by connecting an elliptical sketch and a circular sketch.

First, create a sketched ellipse on the bottom of the countertop with the Convert Entities tool. This tool creates a sketch by projecting the existing ellipse from the Cut-Extrude onto the bottom of the countertop.

Second, create a new plane, **Plane1**, by offsetting it from the **Top** plane. **Plane1** is parallel to the **Top** plane.

Next, use the Circle tool to sketch a circle on **Plane1**.

Now that you have two sketch profiles, use the Loft tool to connect them. The SOLIDWORKS software uses a shaded preview to illustrate what the model will look like before you accept the feature.
Shell the Part

Because the loft creates a solid feature, you need to cut out material to make the sink. The Shell tool hollows out the sink and removes the top face. When you shell a part in SOLIDWORKS, selected faces are removed and thin faces remain on the rest of the part.

Round Sharp Edges with Fillets

To complete the countertop, you round off sharp edges by adding fillet features to the model. When you create a fillet, you set the radius to determine the smoothness of the edges.

It is best to save cosmetic fillets for the last step, after all of the geometry is in place. Models rebuild faster when fillets are made at the end of the design process.

Fillets are applied features, not sketch features. This means that fillets do not require you to create a sketch. Instead, you select the edges of an existing feature, set the fillet radius, and create the fillet. As you increase the radius, the edges or faces become rounder.

For a lesson on shells, see the Lofts tutorial.

For a lesson that includes shells, see the Lesson 1 - Parts tutorial.

For a lesson on fillets, see the Fillets tutorial.
Faucet

Most parts have extrude and fillet features. The faucet uses these tools, in addition to a sweep. In the following example, a sweep creates the faucet spigot.

**Design Approach**

1. Extrude

![Extrude](image)

2. Extrude

![Extrude](image)

3. Sweep

![Sweep](image)

4. Additional Extrudes and Fillets

![Additional Extrudes and Fillets](image)

**Create the Sweep**

The faucet base is made from two extrude features. After you create the two extrudes, the model appears as shown.
Use the **Sweep** tool to make the spigot by projecting a profile along a path. In this example, the *profile* is a circular sketch, and the *path* is a sketched arc and a tangent vertical line. The circular profile remains the same shape and diameter for the entire sweep.

When you sketch the profile and path, make sure the starting point of the path lies on the same plane as the profile.

After you create some additional extrudes and fillets as shown, the faucet is complete.

**Faucet Handle**

The faucet handle is built with two revolve features. The model uses a simple design approach, although the revolves require detailed sketches. The **Revolves** tool revolves a sketch profile around a centerline at a specified angle. In the following examples, the revolve angles are set to 360°.

**Design Approach**

1. Revolve

2. Revolve
3. Fillets

Revolve the Sketch

Create the First Revolve

A revolve creates the base of the handle, and completes the first feature in the faucet handle.

First, you create a sketch with the Line and Spline tools. In some cases, you can add an axis of revolution with the Centerline tool. A centerline creates an axis that is construction geometry; it is not built into the feature.

You then use the Revolve tool to rotate the sketch and create a solid feature.
Create the Second Revolve

You create a second revolve feature to add the faucet handle.

Again, you begin with a sketch, as shown, then create a 3D solid with the revolve. This sketch uses the **Line**, **Tangent Arc**, and **Spline** tools.

The **Revolve** tool revolves the sketch to generate a solid.

After you add cosmetic fillets, the faucet handle is complete.

For a lesson on revolves, see the *Revolves and Sweeps* tutorial.

Cabinet Door

The cabinet door uses an extrude and a cut-extrude to make the exterior detail.

**Design Approach**

1. Extrude
2. Cut-Extrude
3. Chamfer
Create Beveled Edges with the Chamfer Tool

The Chamfer tool creates beveled faces. A chamfer, like a fillet, is an applied feature, and does not require you to make a sketch to create the feature.

In this example, the face with the extruded cut has chamfered edges.

Moldings

The moldings around the edges of the door use an extruded sketch, an extruded cut, and a mirror feature. Only one part file is created, although there are four pieces of molding on the door. With configurations, you create the different molding lengths within one part.

Design Approach

1. Extrude
2. Cut-Extrude
Design a Mid-Plane Extrude

The molding sketch uses a mid-plane extrusion. Instead of extruding the sketch in one direction, you extrude the sketch equally in both directions perpendicular to the sketch plane.

Although you do not have to use a mid-plane extrusion, it ensures that you have equal lengths of material on both sides of the sketch.

Sketch a Profile for the Cut-Extrude

Next, you cut the molding at a 45° angle. The 45° cut ensures that the molding pieces fit together accurately.
When you sketch a profile to cut, make the sketch larger than the model so that you make a clean cut through the entire molding.

**Mirror the Cut**

Finally, to cut the model at the same angle on the opposite side, use the **Mirror** tool to mirror the original cut about the plane of symmetry.

**Use Configurations of a Part**

Configurations create multiple variations of a part within a single part file.

When you design a part, the SOLIDWORKS software automatically creates the **Default** configuration. In the molding that you created, the default configuration matches the length of the shorter sides of the door. To easily identify the configuration, rename the default configuration to **short**.

In the same document you create another configuration and name it **long**. This configuration increases the length to match the longer sides of the door.

The SOLIDWORKS Configuration Manager displays the two configurations in the document. When you double-click a configuration name, the graphics area displays that configuration. Later on, you insert different configurations of the same part into an assembly.

For a lesson that includes mirroring and configurations, see the *Advanced Design* tutorial.
Hinge

The hinge connecting the cabinet door to the vanity is a sheet metal part. By definition, sheet metal parts are constructed of uniform thickness and have a specified bend radius.

When you design sheet metal in the SOLIDWORKS software, you can use a base flange instead of an extrude to create the base of the part. The base flange is the first feature in a sheet metal part, and it designates the part as sheet metal. The SOLIDWORKS software has several tools that are specific to sheet metal, including the tab and the hem, which you use in the hinge design.

Design Approach

1. Base Flange
2. Tab
3. Linear Pattern
4. Hem

Create Sheet Metal with the Base Flange

As with other base features, you first create a sketch. In the hinge, you make a sketch with the Rectangle tool.

The base of the hinge is an example where a simple sketch allows for easier creation of the model.

Next, you use the Base Flange/Tab tool to automatically create a sheet metal part.
Make the Tab

The Tab tool adds a tab to the sheet metal part. The depth of the tab automatically matches the thickness of the sheet metal part. The direction of the depth automatically coincides with the sheet metal part to prevent a disjoint body.

When you make the sketch for the tab, you sketch on the face where you want the tab to appear. You make this sketch with the Rectangle tool on the front face.

After you complete the sketch, use the Base Flange/Tab tool to add the tab.

For more information on tabs, see Sheet Metal Tab in the help.

Generate the Linear Pattern

To make tabs that span the length of the hinge, use the Linear Pattern tool to copy the original tab a specified number of times. The linear pattern creates multiple instances of a selected feature along a linear path.

When you make a linear pattern, you specify the number of instances and the distance between each tab. In the hinge, there are 13 tabs separated by 50mm.
This is the first piece of the hinge. When you create the second piece, you change the location of the tabs so both pieces fit together.

For more information, see Linear Patterns in the Help.

Add the Hem

A Hem is a sheet metal tool that folds the edge of a part and uses the same model thickness as the base flange.

In this example, you add a rolled hem to each tab to curl the sheet metal.

For a lesson on sheet metal, see the Sheet Metal tutorial.

Alternate Design Approach

Another way to design the hinge is to build the rolled section as part of the base flange. In this example, you do not need the Hem tool.
First, create a sketch with the **Line** and **Tangent Arc** tools.

Second, extrude the sketch with the **Base Flange** tool.

Next, create the first tab with an extruded cut.

Finally, use the **Linear Pattern** tool to create multiple cuts.

💡 Using the **Hem** tool gives you more flexibility if you need to change the radius, hem type, and position.
3

Assemblies

In this section, you use the vanity cabinet parts described and built in Chapter 2 “Parts” to build subassemblies, such as the spigot and the faucet handles. Then you bring the subassemblies together to create an assembly, the vanity.

This chapter includes the following topics:

- Assembly Definition
- Assembly Design Methods
- Prepare an Assembly
- Mates
- In-Context Design
- Load an Assembly
- Examine the Assembly

Assembly Definition

An assembly is a collection of related parts saved in one SOLIDWORKS document file with a .sldasm extension.

Assemblies:
• Contain anywhere from two to over one thousand components, which can be parts or other assemblies called subassemblies
• Display movement between related parts within their degrees of freedom

The components in an assembly are defined in relation to each other using assembly mates. You attach the assembly components using various types of mates such as coincident, concentric, and distance mates. For example, the faucet handle components are mated to the faucet base component using concentric and coincident mates. The mated components create the spigot subassembly. Later, you include this subassembly in the main vanity assembly, mating it to the other components in the vanity assembly.

Assembly Design Methods

You create assemblies using two basic methods: bottom-up design and top-down design. You can also use a combination of the two methods. With either method, your objective is to mate the components to create the assembly or subassembly (see Mates on page 57).

Bottom-up Design

In bottom-up design, you create parts, insert them into an assembly, and mate them as required by your design. Bottom-up design is the preferred technique when you use previously constructed, off-the-shelf parts.

An advantage of bottom-up design is that because components are designed independently, their relationships and regeneration behavior are simpler than in top-down design. Working bottom-up allows you to focus on the individual parts. It is a good method to use if you do not need to create references that control the size or shape of parts with respect to each other.

Most of the vanity cabinet uses bottom-up design. You create the components such as the sink and the spigot in their own part windows. Then you open an assembly document, bring the components into the assembly, and add various mates.

Top-down Design

In top-down design, you start your work in the assembly. You can use the geometry of one part to help define other parts, to create features that affect multiple parts, or to create machined features that are added only after the parts are assembled. For instance, you can start with a layout sketch or define fixed part locations, then design the parts referencing these definitions.

Top-down design is also known as in-context design.

For example, you can insert a part in an assembly, then build a fixture based on this part. Working top-down, creating the fixture in context, allows you to reference model geometry, so you can control the dimensions of the fixture by creating geometric relations to the original part. That way, if you change a dimension of the part, the fixture is updated automatically.

The vanity cabinet also uses top-down design. You create the two supply pipes within the context of the assembly. Then you reference the size and location of the faucet subassembly and the vanity cabinet to define the supply pipes.
Supply pipes

Prepare an Assembly

Before you build an assembly, you need to prepare the assembly components. Throughout this section, you use the parts for the vanity cabinet created in Parts on page 37. The vanity includes the following subassemblies:

- Faucet and faucet handles
- Door and moldings
- Door subassembly, cabinet, and hinge
Door subassembly, cabinet, and hinge

For each subassembly document, you do the following prior to mating the components:
• Load and anchor the first component to the assembly origin
• Load the additional components
• Move and position the components

Mates

Mates position the components in an assembly precisely with respect to each other.
Positioning the components defines how they move and rotate with respect to each other.
Mates create geometric relations, such as coincident, perpendicular, and tangent. Each mate is valid for specific combinations of geometry such as cones, cylinders, planes, and extrusions. For example, if you mate a cone to another cone, the valid types of mates you can use include coincident, concentric, and distance (see Coincident Mate on page 60).

Faucet Subassembly

Depending on the complexity of the assembly (the number of separate components), you can open one or all of your components. In the faucet example, there are only two components (the faucet and the handle), so you can tile the two documents. After you open the components, you need to open a new assembly document into which you bring the components.
You can add more than one instance of the same part to an assembly. You do not have to create a unique part for each component in the assembly.

You want to place the bottom of the handle component on the flat base of the faucet component, so the handle sits on the faucet. You also need to center the handle components over the faucet stems to position them correctly. To position the components, you apply a coincident mate and a concentric mate.

**Load the First Assembly Component**

When creating an assembly, start with the component that does not move with respect to the other components. This is the component you anchor or fix to the assembly origin. In the example of the faucet subassembly, you anchor the faucet component.

Anchoring the first component ensures that the planes in both documents are aligned.

Bring the first component into the .sldasm document as follows:

- Select the component name in the FeatureManager design tree of the .sldprt document and drag it into the .sldasm document.
- To position the first component on the origin of the .sldasm document, drop it on the origin in the graphics area or anywhere in the FeatureManager design tree. Dropping it in the FeatureManager design tree requires less fine mouse movement and will automatically align the part’s origin and the assembly origin.

As you bring each component into the .sldasm document, the component appears in the FeatureManager design tree.
Load the Additional Components

You load the other components of the assembly by selecting the component in the FeatureManager design tree of the .sldprt document, and dragging the component into the graphics area of the .sldasm document. In the example of the faucet subassembly, you drag in two instances of the handle.

The first component you add to an assembly is fixed in space by default, which is useful for mating of components. It is common to choose a component that you wish to be fixed; however, you can change which component is fixed later.

Faucet component with origin (assembly origin and component origin)  First handle component added

Second handle component added

Position the Additional Components

When you bring the additional components into the assembly, you can position them anywhere in the graphics area. Then you can use the left mouse button to drag a component closer to the first, anchored component. You can use the right mouse button to rotate a component into the proper orientation.
Leave some space between components to view the relevant component areas. You can use the following methods to change the orientation of the components:

- Middle mouse button: Rotates all components.
- Middle mouse button with Ctrl: Pans all components.
- Middle mouse wheel: Zooms all components in or out.

These mouse functions help select edges, faces, or other entities needed to apply mates.

**Coincident Mate**

To create a coincident mate between the handle component and the faucet component, attach the flat bottom face of the handles to the flat top face of the faucet.

When you apply the coincident mate, the faucet handle component moves closer to the faucet component. Note that you can still slide the handle anywhere along the top face of the faucet by dragging it with the left mouse button, indicating that a second mate is required to further define the position of the two components.

**Concentric Mate**

Select any round face on the faucet handle. Then select the round face of the faucet stem (the portion of the component that slides into the counter top, and connects to the supply pipe).
Once you apply the concentric mate between the faucet handle component and the faucet component, you can no longer move the faucet handle along the top face of the faucet to shift its position. You can, however, use the left mouse button to drag the faucet handle on its axis.

For a lesson on assembly mates, see the Assembly Mates tutorial.

**Faucet Subassembly - Alternate Design Approach**

Another approach to mating the faucet and handle components is to use SmartMates. With SmartMates, the system automatically creates some mates. SmartMates are based on the entity you use to drag the component.

When you drag components into assemblies, you infer the geometry of existing components to create mates. SmartMates automatically infer mate partners and eliminate the need to use the Mate PropertyManager.

There are different types of SmartMates. You can use geometry-based SmartMates to create coincident mates between planar faces. For example, use SmartMates to create a coincident mate between the faucet component and each of the faucet handles in the faucet subassembly. Use **Alt** and drag the bottom face of the handle to create a coincident mate between the handle and faucet.
You can use another type of geometry-based SmartMate to create the concentric mate between the two round faces to completely define the faucet subassembly.

There are other types of SmartMates, including feature-based SmartMates and pattern-based SmartMates. For more information, see SmartMates Overview in the Help.

**Door Subassembly**

The cabinet door uses coincident mates between the door component and the four molding components. It also uses configurations of the molding as a time-saving design step.

Configurations let you create multiple variations of a part or an assembly within a single document. Configurations provide a convenient way to develop and manage families of models with different dimensions, components, or other parameters (see Use Configurations of a Part on page 49).

As stated earlier, you can use the same part more than once in an assembly. Each instance of the part can also use a different configuration.

The door subassembly uses configurations. There are four instances of the molding component. Two of the instances use the short configuration and fit across the short sides of the door. The other two instances use the long configuration.
Door subassembly with molding components

**Cabinet Subassembly**

The cabinet subassembly uses concentric and coincident mates. It also uses a distance mate between the cabinet and one of the hinge components.

**Distance Mate**

A distance mate uses a value you assign to separate the two entities.

In the vanity cabinet, the distance mate positions the hinge optimally, so that it functions freely. You determine the correct mate distance using the **Measure** tool.

By measuring the entities of different components, you can determine at what position to place the hinge so that it does not bind when you open the cabinet door. Once you know the thickness of the door opening and the width of the hinge, you can position the hinge using a distance mate.

Measure the width of the inside for the cabinet door opening.

Measure the width of the hinge that you attach to the inside of the cabinet door opening.
Apply a distance mate, based on measurements of the cabinet and of the hinge.

**In-Context Design**

You can create a new part within an assembly document (in the context of an assembly).

In addition to creating or editing components in their own part windows, the SOLIDWORKS software lets you create or edit components in the assembly window. The advantage is that you can reference the geometry of one component to create or modify another component. By referencing the geometry of another component, you ensure that the components fit together correctly. This method of design is called top-down or in-context design because you are working in the context of the assembly.

In the vanity assembly, there are two examples of in-context design. One example is the diameter of the supply pipe component and the waste pipe component. The pipe components are both new parts that you create in the context of the assembly. The other example is the cut feature for the holes in the back of the vanity cabinet. The vanity cabinet is an existing part that you edit in the context of the assembly. These examples are discussed in the next two sections.

As you create an in-context part, the software includes notations and options with information about the relationships in the features.

For more information on creating in-context components, see *Creating a Part in an Assembly* in the Help.

**Create an Assembly Component In-Context**

The diameter of the supply pipe component depends on the diameter of the faucet stem. It is a good idea to create the supply pipe component in the assembly so you can reference the geometry of the faucet stem. You use the **Convert Entities** and **Offset Entities** sketch tools to reference the geometry of the faucet stem for a sketch in the supply pipe component. This reference ensures that the size of the supply pipe changes if you change
the size of the faucet stem. You can use the same method to create the waste pipe component, which depends on the diameter of the exit stem at the bottom of the basin.

Use **Convert Entities** and **Offset Entities** to create the sleeve between the faucet stem and the supply pipe.

Extrude the sketch to create the sleeve between the faucet stem and the supply pipe.

**Modify a Part In-Context of an Assembly**

The positions of the holes in the back of the vanity cabinet depend on the length of the supply pipe and the waste pipe components. It is a good idea to edit the vanity cabinet component in the assembly so you can reference the geometry of the supply pipes and waste pipe. You use the **Offset Entities** sketch tool to reference the geometry of the pipes for a sketch of the cut in the vanity cabinet component. This reference ensures that the position and size of the holes changes if you change the position and size of the supply pipes or waste pipe.

Supply and waste piping before in-context cut

Supply and waste piping after in-context cut
Load an Assembly

You can improve performance of large assemblies significantly by using lightweight components.

After you create an assembly, you can load it with its active components fully resolved or lightweight.

- When a component is fully resolved, all of its model data is loaded in memory.
- When a component is lightweight, only a subset of its model data is loaded in memory. The remaining model data is loaded on an as-needed basis.

Loading an assembly with lightweight components is faster than loading the same assembly with fully resolved components.

Lightweight components are efficient because the full model data for the components is loaded only as it is needed.

Assemblies with lightweight components rebuild faster because fewer details are evaluated. However, mates on a lightweight component are solved, and you can edit existing mates.

The vanity cabinet is a relatively simple assembly, so any performance gains using lightweight components are minimal.

Examine the Assembly

The SOLIDWORKS software includes various assembly tools that can display, test, and measure your assembly components once you apply the mates.

Some of the assembly tools include:

Hide and Show Components

You can hide or show components in the graphics area. Hiding components often facilitates component selection when you add mates or when you create in-context parts. For example, to select the inner and outer diameters of the faucet stems, you can hide all components except the faucet subassembly, and then zoom, rotate, or change the view as needed.

Hide all components except the one you need

Zoom, rotate, and change the view if necessary to select the feature
**Hide Components** and **Show Components** do not affect the mates between the components. They affect only the display.

**Explode the Assembly**

An exploded view separates the components in an assembly to facilitate viewing. Exploded views include many options such as which components to include, what distances to use, and in which direction to display the exploded components. The exploded view is saved with a configuration of the assembly or subassembly.

**Detect Collisions Between Components**

You can detect collisions with other components when you move or rotate a component. The SOLIDWORKS software can detect collisions with the entire assembly or a selected group of components that move as a result of mates.

In the faucet subassembly, note how the faucet handles collide with the faucet. You can set the **Stop at collision** option to determine where the components collide.
Normal position of handles

Collison Detection without Stop at collision active. Notice the handle moves inside the faucet.

Collison Detection with Stop at collision active. Notice the handle cannot move inside the faucet.
4

Drawings

Drawings are 2D documents that convey a design to manufacturing.

This chapter includes the following topics:

- **Drawing Documents**
- **Vanity Cabinet Drawing Sheet**
- **Faucet Assembly Drawing Sheet**
- **Vanity Assembly Drawing Sheet**

**Drawing Documents**

You create drawings from drawing templates. Within a drawing document are drawing sheets that contain drawing views. The drawing sheets have underlying formats.
Drawing templates and sheet formats are two distinct entities. The software comes with one drawing template and a set of sheet formats (in English and metric). When you begin a new drawing using the default drawing template, the size of the drawing is undefined. The software prompts you to select a sheet format. The sheet format controls:

- Size of the drawing sheet
- Drawing borders
- Title block
- Sheet scale

**Drawing Templates**

To start the drawing document, you open a drawing template. Drawing templates contain basic document information. You choose from templates supplied with the SOLIDWORKS software containing default drawing sheets or templates you customize. You can create custom drawing templates with any of the following characteristics:

- Drawing sheet size (for example, A, B, and C)
- Drawing standard (for example, ISO and ANSI)
- Units (for example, millimeters and inches)
- Company name and logo, author’s name, and other information

**Drawing Sheets**

For the vanity drawings, a drawing template with a C-size drawing sheet in landscape orientation is appropriate. The standard drawing sheet formats contain borders and title blocks for the C-size landscape format:
The drawing document for the vanity contains three sheets. You can have any number of drawing sheets in a drawing document, like a set of drawings. You can add sheets at any time using any format, regardless of the format of other sheets in the document. Tabs with sheet names appear at the bottom of the graphics area.

**Sheet Formats**

The bottom right corner of the default sheet format contains a title block.

After changing the sheet scale, adding two sheets, and editing and adding notes, the title block appears as shown. The scale and page numbers are linked to system variables and updated automatically.

The sheet format underlies the drawing sheet and is separate from the drawing sheet. You edit the sheet format separately from the drawing sheet. Sheet formats can contain items such as lines, note text, bitmaps, and the bill of materials anchor point. You can link the notes to system properties and custom properties.

**Drawing Views**

Drawing views are placed on drawing sheets and contain the images of the models, plus dimensions and annotations.
Drawings begin with standard views. From those views, you can derive other types of views, such as projected, section, and detail.

For a lesson on drawing documents, inserting standard views, and adding dimensions to drawings, see the Lesson 3 - Drawings tutorial.

For more information on document templates, drawing sheets, and drawing views, see the Help.

Vanity Cabinet Drawing Sheet

The vanity cabinet sheet contains standard 3 views and named views that are generated from the part. The views are displayed in different modes and contain dimensions and annotations.

Standard Views

Drawings generally start with a standard 3 view or some type of named view, for example, front, top, isometric, or exploded. You can insert these views from an open part or assembly document, from a file, or from other views in the same drawing document.

Standard 3 Views

Standard 3 views, as the name implies, comprise three views: front, top, and right (third angle projection) or front, top, and left (first angle projection). In third angle projection, the default front view is displayed at the lower left. In first angle projection, the front view is displayed at the upper left. First angle projection is typically used in Europe. Third
angle projection is typically used in the United States. The example in this section uses third angle projection.

For more information on first and third angle projection, see *First Angle and Third Angle Projection* in the Help.

The standard 3 views of the vanity cabinet are the first views that are placed on this sheet.

**Named Views**

Views are named in the model documents. Named views include:

- Standard orientations, for example, front, top, and isometric
- Current model view
- Custom named views

Next, you add an isometric view of the cabinet (a named view) to the drawing sheet.
You select the view orientation as you bring the view into the drawing.

**Projected Views**

Projected views are orthographic projections of existing views. The vanity has details in the back that are important to show. To create a back view, project the right view and place it to the right.

**View Display and Alignment**

You can choose various display modes for drawing views. On the Vanity Cabinet sheet, the back view is displayed with **Hidden Lines Removed**. The standard 3 views are displayed with **Hidden Lines Visible**. (Hidden lines appear gray on screen, but as dashed lines when printed.) The isometric view is displayed with **Shaded With Edges**.
Some views are aligned automatically, but you can break the alignments. Standard 3 views are aligned so that if you drag the front view, both the top and right views move with it. The right view moves independently in the horizontal direction, but not vertically. The top view moves independently in the vertical direction, but not horizontally.

Section views, projected views, and auxiliary views automatically align in the direction of the view arrows. Detail views are not aligned by default.

You can align views that are not automatically aligned. For example, the back view of the cabinet is aligned horizontally with the right view, which is aligned with the front view by default.

For more information on displaying, hiding, and aligning views, see Drawing View Alignment and Display in the Help.

**Dimensions**

Dimensions in a SOLIDWORKS drawing are associated with the model. Changes in the model are reflected in the drawing, and vice versa.

Typically, you create dimensions as you create each feature in a part, then insert those dimensions into the drawing views. Changing a dimension in the model updates the drawing, and changing a model dimension in a drawing changes the model.

You can also add dimensions in the drawing document, but these are reference dimensions, and are driven; you cannot edit the value of reference dimensions to change the model. The values of reference dimensions change when the model dimensions change.

You can set the units (for example, millimeters or inches) and the drawing standard (for example, ISO or ANSI) in the detailing options. The vanity is in millimeters in the ISO standard.

For more information about dimensions in drawings, see Dimensions Overview in the Help.
**Insert Model Items**

You use the **Insert Model Items** tool as a convenient way to insert existing model dimensions into the cabinet drawing. Insert items for a selected feature, an assembly component, a drawing view, or all views.

When inserted into all views (as in the example), dimensions and annotations appear in the most appropriate view. Features that appear in partial views, such as detail or section views, are dimensioned in those views first.

Once you insert the dimensions, you can manipulate them. For example, you can drag them into position, drag them to other views, hide them, or edit properties.

If the model contains annotations, you can also insert the annotations into drawings by the same procedure.

**Reference Dimensions**

The back view on the Vanity Cabinet sheet is included to show the dimensions of the holes in the cabinet for the supply and waste pipes.

Reference dimensions help you to locate the holes. You can choose whether to enclose reference dimensions in parentheses automatically.
Other types of reference dimensions include baseline dimensions and ordinate dimensions. For example, you might add ordinate dimensions to the front view of the cabinet as shown. You can dimension to edges, vertices, and arcs. The dimensions jog automatically to avoid overlapping. You can display ordinate dimensions without the chain (the arrows between the dimension extension lines).

**Hole Callouts**

You can specify hole callouts when creating holes in models with the Hole Wizard. The Hole Wizard creates and positions holes you define for fasteners such as counterbore and countersunk screws and tap holes. Hole Wizard design data, such as diameter, depth, and counterbore, becomes part of the hole callout automatically.

Hole callouts help you to specify the size and depth of the holes in the cabinet. Hole callouts are annotations that are also dimensions. These hole callouts are in the back view.

**Annotations**

In addition to dimensions, you can add other types of annotations to your models and drawings to convey manufacturing information:

- Notes
- Geometric tolerance symbols
- Datum feature symbol
- Center marks
- Surface finish symbols
- Datum target symbols
- Weld symbols
- Balloons and stacked balloons
- Blocks
• Multi-jog leaders
• Area hatches
• Dowel pin symbols

Most annotations can be added in part and assembly documents and inserted automatically into drawings in the same way that dimensions are inserted into drawings. Some annotations (center marks, multi-jog leaders, hole callouts, area hatch, and dowel pin symbols) are available in drawings only.

For more information on annotations, see Annotations Overview in the Help.

**Geometric Tolerance and Datum Feature Symbols**

Geometric tolerance symbols display various manufacturing specifications, often in conjunction with datum feature symbols as shown in the example. You can insert these symbols in sketches and in part, assembly, and drawing documents.

In the right view of the cabinet, the back edge is specified with a geometric tolerance symbol as parallel to the front edge within 10mm.

**Center Marks**

Center marks are annotations that mark circle or arc centers and describe the geometry size on the drawing.

In this example, center marks are added to the holes in the back view of the cabinet. You can place center marks on circles or arcs. Center marks can be used as reference points for dimensioning.

You can rotate center marks, specify their sizes, and choose whether or not to display extended axis lines.

For a lesson on adding derived views, annotations, and exploded views to drawings, see the Advanced Drawings tutorial.
Here is the completed vanity cabinet drawing sheet.

Faucet Assembly Drawing Sheet

The faucet assembly drawing sheet displays several derived views and annotations.

**Explode Lines**

The faucet assembly is shown in an isometric named view in its exploded configuration. Explode lines show the relationships between assembly components.

You add the explode lines to the assembly document in an explode line sketch. You can also jog the lines as needed. The lines are displayed in phantom line font.

**Derived Views**

Derived views are created from the standard views. With standard 3 views or a named view in a drawing, you can create other views without going back to the model.
**Section Views**

You can create a section view in a drawing by cutting the parent view with a section line. A section view of the faucet in the faucet assembly drawing shows the faucet pipe walls and connections. In this example, you insert a top view of the faucet assembly as the basis for the section view.

There are other types of section views, such as aligned section views and broken-out section views.

The sectioned components automatically display crosshatching. You can edit the properties of the crosshatching (pattern, scale, and angle).

**Detail Views**

Detail views show a portion of an orthographic, 3D, or section view, usually at an enlarged scale.

The connection of the faucet is shown in a detail view. The parent view is the section view.
**Additional Drawing Views**

Alternate position views display overlays of two or more positions on the same view, often to show range of motion of an assembly component. The overlay views are displayed in the drawing in phantom lines.

The faucet handles are shown on the faucet assembly sheet in an alternate position view to display the range of motion of the handles.

Other drawing views include:

- **Auxiliary view**: A projection normal to a reference edge
- **Crop view**: Everything outside a sketched profile removed
- **Broken-out section**: Material inside a profile removed to expose inner details
- **Broken view**: Portion of a long part with a uniform cross-section removed

For more information about drawing views, see *Derived Drawing Views* in the Help.
Notes and Other Annotations

Notes and Multi-Jog Leaders

The alternate position view has a note with a degree symbol. In the exploded faucet view, the note uses a multi-jog leader.

A note can be free floating, as in the first example, or pointing to an item (face, edge, or vertex) in the document, as in the second example.

Surface Finish Symbols

You can add surface finish symbols to part, assembly, or drawing documents. You can insert multiple symbols and multiple copies of a symbol.

Some of the characteristics that you can specify for a surface finish symbol include type of symbol, direction of lay, roughness, production method, material removal, and rotation.

The surface finish symbol attached to the faucet handle specifies a circular finish and the maximum roughness of the surface.
Here is the completed faucet assembly drawing sheet.

Vanity Assembly Drawing Sheet

This drawing sheet contains an exploded view, a bill of materials, and balloons.

**Exploded Views**

Exploded views are versions of named views defined in configurations in the assembly document. This drawing contains an exploded view of the vanity assembly.

The drawing also contains an isometric named view of the complete assembly, unexploded, at the lower left.
Bill of Materials

A bill of materials (BOM) is a table that lists the components of an assembly along with information needed in the manufacturing process. If the assembly or its components change, the BOM updates to reflect the changes.

<table>
<thead>
<tr>
<th>ITEM NO.</th>
<th>PART NUMBER</th>
<th>DESCRIPTION</th>
<th>QTY.</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>cabinet_bath</td>
<td>Cabinet</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>hingeassy</td>
<td>Hinge assembly</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>hinge_1</td>
<td>Sheet metal hinge</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>pin</td>
<td>Hinge pin</td>
<td>1</td>
</tr>
<tr>
<td>5</td>
<td>door</td>
<td>Door assembly</td>
<td>1</td>
</tr>
<tr>
<td>6</td>
<td>molding</td>
<td>Molding long</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td>molding</td>
<td>Molding short</td>
<td>2</td>
</tr>
<tr>
<td>6</td>
<td>waste_piping</td>
<td>Pipe, waste</td>
<td>1</td>
</tr>
<tr>
<td>7</td>
<td>supply_piping</td>
<td>Pipe, supply</td>
<td>2</td>
</tr>
<tr>
<td>8</td>
<td>ctrim</td>
<td>Counter top</td>
<td>1</td>
</tr>
<tr>
<td>9</td>
<td>faucet</td>
<td>Faucet assembly</td>
<td>1</td>
</tr>
<tr>
<td>10</td>
<td>faucet</td>
<td>Faucet long</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>faucet</td>
<td>Standard handle</td>
<td>2</td>
</tr>
</tbody>
</table>

When you insert a BOM, you have a choice of BOM templates with various columns for data such as item number, quantity, part number, description, material, stock size, vendor number, and weight. You can also edit and save a custom BOM template.

The SOLIDWORKS software populates the item number, quantity, and part number columns automatically. The item numbers reflect the sequence in which the model was assembled.

You set the anchor point for the BOM in the drawing sheet format.

💡 For more information, see Bill of Materials - Overview in the Help.
Balloons and Stacked Balloons

You can insert balloons in assembly and drawing documents. You can set the style, size, and type of information for balloons. In the example, the balloons display the item number corresponding to the BOM in a circle.

The exploded vanity assembly includes balloons and stacked balloons for each component. The item numbers appear in the balloons automatically.

Stacked balloons have one leader for a series of balloons. You can stack the balloons vertically or horizontally.

For a lesson on bills of materials and balloons, see the Advanced Drawings tutorial.

Here is the completed vanity assembly drawing sheet.
The SOLIDWORKS software contains several tools to help you complete engineering tasks such as creating variations of parts and importing files from legacy CAD systems to your SOLIDWORKS models.

The SOLIDWORKS software is available in SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium. For more information on which tools are available with the different packages, see the Product Matrix (http://www.solidworks.com/sw/mechanical-design-software-matrix.htm).

This chapter includes the following topics:

- Building Multiple Configurations of Parts
- Updating Models Automatically
- Importing and Exporting Files
- Performing Stress Analysis
- Customizing SOLIDWORKS
- Sharing Models
- Creating Photo-Realistic Images of Models
- Animating Assemblies
- Managing SOLIDWORKS Files
- Accessing a Library of Standard Parts
- Examining and Editing Model Geometry

### Building Multiple Configurations of Parts

Design tables let you build several configurations of a part by applying the values in the table to the dimensions of the part.

In Parts on page 37, you saw how configurations could be used to build two different lengths of the molding in one part file. The following example illustrates how design tables help organize several configurations.

For example, you may want to create multiple configurations of the faucet handle. After all, not every customer wants the same handle style. In the SOLIDWORKS software, you can create different handle styles within one part file using a design table.

This design table shows the parameters used to create variations of the faucet handle:
The first column lists the different configuration names. These configuration names describe the type of handle generated from the design table.

Give a meaningful name for each configuration to reduce confusion in complex parts and assemblies and to help others who use the models.

The next four columns show the dimension names and values. When you change a dimension value in a design table, the configuration updates with the specified value.

The final column shows the suppression state of a fillet feature. In addition to changing dimension values, you can also change the suppression state of a feature in design tables. A feature can be suppressed (S) or unsuppressed (U).

The values and suppression states define each configuration:

<table>
<thead>
<tr>
<th>Configuration name</th>
<th>Model view</th>
</tr>
</thead>
<tbody>
<tr>
<td>standard_handle</td>
<td><img src="image1" alt="standard_handle" /></td>
</tr>
<tr>
<td>wide_handle</td>
<td><img src="image2" alt="wide_handle" /></td>
</tr>
<tr>
<td>tall_handle</td>
<td><img src="image3" alt="tall_handle" /></td>
</tr>
</tbody>
</table>
Updating Models Automatically

When you change a model dimension, any SOLIDWORKS document that references that model also updates. For example, if you change the length of an extrude in a part, the associated assembly and drawing also change.

More specifically, you designed the faucet to be 100mm in length for a vanity countertop. However, your customer needs a longer faucet to accommodate a utility sink. You can modify the dimension of the faucet to make it any length, and the associated assembly and drawing also update.

- Original faucet
- Revised faucet
- Revised assembly
- Revised drawing
Loading the Latest Models

You can refresh shared documents to load the latest version, including any changes made by one of your colleagues.

Suppose that you are working on a SOLIDWORKS assembly document, and a coworker just updated one of the assembly components. You can reload the revised component, and the SOLIDWORKS software automatically updates the assembly. Reloading is easier than closing and reopening the assembly with the revised part.

Replacing Referenced Models

You can replace a referenced document with another document from anywhere on a network.

For example, consider that you are working on the faucet subassembly. Meanwhile, another engineer in your group designs a more cost-effective faucet handle. You can globally replace the current handles with the new ones, without having to delete and replace each handle.

When you replace a component, mates used in the original part are applied to the replacement part wherever possible.

To ensure that the mates are preserved, rename the corresponding edges and faces on a replacement part to match the edge and face names on the original part.

Importing and Exporting Files

You can import and export several different file formats to and from the SOLIDWORKS software so you can share files amongst a broad user base.

Consider that your company works with a vendor that uses another CAD system. With the SOLIDWORKS import and export functions, you can share files between companies, allowing you more flexibility in the design process.
Recognizing Features in Non-SOLIDWORKS Parts

FeatureWorks® is an application that recognizes features on an imported solid body in a SOLIDWORKS part document.

Recognized features are treated the same as features that you create in the SOLIDWORKS software. You can edit the definition of recognized features to change their parameters. For features that are based on sketches, you can edit the sketches to change the geometry of the features. The FeatureWorks software is intended primarily for machined and sheet metal parts.

Suppose you have legacy .step files at your company, and you want to use them in the SOLIDWORKS software. You can use the FeatureWorks software to recognize each feature as a SOLIDWORKS feature. This way, you do not have to remodel the same part in the SOLIDWORKS application.

Performing Stress Analysis

SOLIDWORKS SimulationXpress provides an easy-to-use first pass stress analysis tool for SOLIDWORKS parts.

SimulationXpress helps you reduce cost and time-to-market by testing your designs on the computer instead of expensive and time-consuming field tests.

For example, you can examine the effects of a force applied to the faucet. SimulationXpress simulates the effect of the force and provides displacement and stress results. It also shows critical areas and safety levels at various regions in the faucet. Based on these results, you can strengthen unsafe regions and remove material from overdesigned areas.
Customizing SOLIDWORKS

The SOLIDWORKS Application Programming Interface (API) is an OLE programming interface to the SOLIDWORKS software.

The API contains thousands of functions that can be called from C#, C++, VB.NET, and VBA (for example, Microsoft® Access® and Microsoft Excel®) or SOLIDWORKS macro files. These functions provide you with direct access to SOLIDWORKS functionality.

With the API, you can customize the SOLIDWORKS application to help reduce design time. For example, you can perform batch operations, automatically populate drawing documents with model views or dimensions, and create your own Property Managers.

For instance, when you use any software application, you probably set system options to customize your working environment. In the SOLIDWORKS software, these options include system colors, default templates, and performance settings. With the API, you can set the system options without setting each one individually. Instead, use the API to automatically set all of your options. This way, you save time by programming the settings only once.

For more information, see the API Help, or the API Support page on the SOLIDWORKS Web site (www.solidworks.com/sw/support/apisupport.htm).

For lessons on the API, see the SOLIDWORKS API Tutorials.

Sharing Models

eDrawings® eliminates the communication barriers that designers and engineers deal with daily. You can create eDrawings files from part, assembly, or drawing documents, then email these eDrawings files to others for instant viewing.

For example, if you work with a client in a remote location, you might need to send a model for their approval. Oftentimes, the file size is too big to send through email. However, if you save your SOLIDWORKS model as an eDrawings file, you can send a much smaller version of the file to your client.

You view eDrawings files with the eDrawings Viewer that you can download from the SOLIDWORKS Web site for free, or you can embed the eDrawings Viewer in the eDrawings file.

eDrawings files have the following features:

- **Ultra Compact Files** Send eDrawings files through email. Substantially smaller in size than the original files, eDrawings makes it practical to send files via email, even over slow connections.
eDrawings files are also significantly easier to understand than standard 2D drawings. The following features help you overcome common barriers for effective 2D drawing communication:

**Built-in Viewer** View eDrawings files immediately. Anyone with a Windows-based or Macintosh computer can view eDrawings. No additional CAD software is required. You can embed the eDrawings Viewer when you email an eDrawings file.

**eDrawings files** are also significantly easier to understand than standard 2D drawings. The following features help you overcome common barriers for effective 2D drawing communication:

**Layouts**
Open individual views in a drawing and arrange them in any way you desire, regardless of how the views were arranged in the original drawing. Layouts enable the eDrawings recipient to print and export any subset of a drawing.

**Hyperlinking**
Navigate through views automatically, eliminating searches for views or details. Click the view annotation, and the section view or detail is immediately added to your layout.

**3D Pointer**
Identify and match geometry in multiple views. The 3D Pointer helps orient you when you check features in multiple views.

**Animation**
Create animation sequences of eDrawings views.

**SOLIDWORKS Simulation Data**
Display SOLIDWORKS Simulation and SOLIDWORKS SimulationXpress data, when available, in eDrawings part or assembly files.

The optional eDrawings Professional version provides the following additional capabilities:

**Cross Sections**
Create cross-section views with a variety of planes to fully examine a model.

**Markup**
Mark up files using clouds, text, or geometric elements. The markup elements are inserted as comments in the file.

**Measure**
Measure the distance between entities or measure dimensions in part, assembly, and drawing documents.

**Move Components**
Move components in an assembly or drawing file.

**SOLIDWORKS Animator Output**
View animations created with SOLIDWORKS® Animator and observe in real time how moving parts interact as true solids.

**Configurations**
Save SOLIDWORKS configuration data and see the configurations in the eDrawings Viewer.

**Exploded Views**
Save SOLIDWORKS exploded view information and see the exploded views in the eDrawings Viewer.
Cross-section view of the vanity with dimensions and comments

For a lesson on the eDrawings software, see the eDrawings tutorial.

Creating Photo-Realistic Images of Models

PhotoView 360 lets you create photo-realistic rendered images directly from SOLIDWORKS models.

In the SOLIDWORKS software, you specify model appearances, scenes, and lighting. Then use PhotoView 360 to render the model.

Examples of models rendered in PhotoView 360:

For more information on PhotoView 360, see Rendering with PhotoView 360 in the Help.
Animating Assemblies

You can create animated motion studies to capture the motion of SOLIDWORKS assemblies in .avi files.

By incorporating Appearances and RealView Graphics, you can produce photo-realistic animations.

Suppose that your company is at a convention with competing companies. To stand out from the competition, you can create .avi files that animate your products. This way, your customers can see a vanity door open and close, or faucet handles move. Animation helps your customers visualize models in a real-world situation.

You can create rotated animations, exploded view animations, or collapsed view animations. You can also import assembly motion from other types of motion studies.

For a lesson on animated motion studies, see the Animation tutorial.

Managing SOLIDWORKS Files

SOLIDWORKS Explorer is a file management tool designed to help you accomplish tasks such as renaming, replacing, and copying SOLIDWORKS documents.

SOLIDWORKS Explorer lets you:
- View document dependencies for drawings, parts, and assemblies, in a tree structure.
- Copy, rename, or replace referenced documents. You have the option to find and update references to documents.
- View data and previews or input data, according to the active function.

For example, consider that you want to rename the countertop part from countertop.sldprt to countertop_with_sink.sldprt. If you rename the part in:

- **Windows Explorer** Any SOLIDWORKS document that references countertop.sldprt (such as the vanity assembly) does not recognize that the part name changed. Therefore, the SOLIDWORKS software cannot find the renamed part, and it does not appear in the assembly.

- **SOLIDWORKS Explorer** The SOLIDWORKS software recognizes that you renamed the part. Any document that references the part updates accordingly with the new name.

Accessing a Library of Standard Parts

SOLIDWORKS Toolbox includes a library of standard parts that are integrated with the SOLIDWORKS software. Select the standard and the type of part you want to insert, then drag the component into your assembly.

For example, when you attach the hinge to the vanity cabinet or when you fasten the waste pipe to the sink, you can use standard screws and washers included in SOLIDWORKS Toolbox. This way, you do not have to make additional parts to complete the vanity assembly.
You can customize the SOLIDWORKS Toolbox library of parts to include your company’s standards or to include those parts that you refer to most frequently. You can also make a copy of SOLIDWORKS Toolbox parts, then edit them as needed.

Solidworks Toolbox supports several international standards including ANSI, BSI, CISC, DIN, ISO, and JIS.

Additionally, SOLIDWORKS Toolbox has several engineering tools:

- **Beam Calculator**: Performs deflection and stress calculations on structural steel cross sections.

- **Bearing Calculator**: Performs bearing calculations to determine capacity ratings and basic life values.

- **Cams**: Creates cams with fully-defined motion paths and follower types. The cam can be either circular or linear with 14 motion types from which to choose. You can also set how the track for the follower is cut, either as a blind cut or a cut through the entire cam.

- **Grooves**: Creates industry standard O-ring and retaining ring grooves to your cylindrical model.

- **Structural Steel**: Brings the cross-section sketch of a structural steel beam into a part. The sketch is fully-dimensioned to match industry standard sizes. You can extrude the sketch in the SOLIDWORKS software to create the beam.

For a lesson on SOLIDWORKS Toolbox, see the Toolbox tutorial.
Examining and Editing Model Geometry

SOLIDWORKS Utilities is a set of tools that lets you examine and edit individual parts, and compare the features and solid geometry of pairs of parts.

For example, if you and a coworker design two similar types of faucet handles, you can use the Compare Features utility to compare the parts. This utility identifies the unique features of each part so you can collaborate and decide on the best design methods. Then, you can identify the most efficient designs and combine them in one model.

SOLIDWORKS Utilities includes the following tools:

**Compare**
- **Compare Documents.** Compares the properties of two SOLIDWORKS documents (including two configurations of the same model). You can compare two documents of the same or different types. For example, this utility identifies differences in file and document properties.
- **Compare Features.** Compares features of two parts and finds identical, modified, and unique features.
- **Compare Geometry.** Compares two parts to find their geometric differences. This utility identifies unique and modified faces in both parts. It also computes the common volume of the two parts (or assemblies) and the volume of material added and removed.
- **Compare BOMs.** Compares bill of material (BOM) tables from two SOLIDWORKS assembly or drawing documents. The results list missing columns and rows, extra columns and rows, and failed rows.

**Feature Paint**
Copies feature parameters (such as depth and size) from one feature to others that you select.

**Find and Replace Annotations**
Finds and replaces text in a variety of annotations for part, assembly, and drawing documents.

**Find/Modify**
Finds a set of features in a part that satisfies specified parameter conditions so you can edit them in batch mode.

**Geometry Analysis**
Identifies geometric entities in a part that could cause a problem in other applications such as finite element modeling or computer-aided machining. This utility identifies the following categories of geometric entities: sliver faces, small faces, short edges, knife (sharp) edges and vertices, and discontinuous edges and faces.

**Power Select**
Selects all the entities (edges, loops, faces, or features) in a part that meet the criteria that you define. You can specify criteria for edge convexity, edge angle, face color, feature color, feature type, feature name, and surface type.

**Report Manager**
Manages reports generated from the Geometry Analysis, Compare Geometry, Compare Features, Compare Documents, Compare BOMs, Symmetry Check, and Thickness Analysis utilities.
**Simplify**  Creates simplified configurations of a part or assembly for analysis.

**Symmetry Check**  Checks parts for geometrically symmetric faces.

**Thickness Analysis**  Determines thin and thick regions of a part. It also determines the thickness of a part within a specified range of values.

For a lesson on SOLIDWORKS Utilities, see the *SOLIDWORKS Utilities* tutorial.
This chapter includes the following topics:

- **Getting Ready for the Lesson**
- **Creating a Box**
- **Creating a Lid for the Box**
- **Putting the Box and Lid Together**
- **Creating a Drawing**

**Getting Ready for the Lesson**

Before you begin this lesson, it is helpful to know how to access the SOLIDWORKS software’s tools.

Many of the tools you use are accessible in three ways:

- Menus
- Toolbars
- CommandManager

These tools are context sensitive, which means that menu items are grayed out if the tools are not available for your current task. Sometimes, the tools do not appear at all, so it is helpful to know which toolbar you use to access them.

💡 For more information, see *Menus* in the Help.

The following table lists the tools you use in the lesson and their locations on menus, toolbars, and the CommandManager.
<table>
<thead>
<tr>
<th>Tool</th>
<th>Icon</th>
<th>Menu</th>
<th>Toolbar</th>
<th>CommandManager</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td><img src="image" alt="File" /></td>
<td>File &gt; New</td>
<td>Standard</td>
<td>Menu Bar</td>
</tr>
<tr>
<td>Save</td>
<td><img src="image" alt="File" /></td>
<td>File &gt; Save</td>
<td>Standard</td>
<td>Menu Bar</td>
</tr>
<tr>
<td>Options</td>
<td><img src="image" alt="Tools" /></td>
<td>Tools &gt; Options</td>
<td>Standard</td>
<td>Menu Bar</td>
</tr>
<tr>
<td>Sketch</td>
<td><img src="image" alt="Sketch" /></td>
<td>Insert &gt; Sketch</td>
<td>Sketch</td>
<td>Sketch</td>
</tr>
<tr>
<td>Smart Dimension</td>
<td><img src="image" alt="Tools" /></td>
<td>Tools &gt; Dimensions &gt; Smart</td>
<td>Sketch</td>
<td>Sketch</td>
</tr>
<tr>
<td>Rectangle</td>
<td><img src="image" alt="Sketch" /></td>
<td>Tools &gt; Sketch Entities &gt; Rectangle</td>
<td>Sketch</td>
<td>Sketch</td>
</tr>
<tr>
<td>Extruded Boss/Base</td>
<td><img src="image" alt="Features" /></td>
<td>Insert &gt; Boss/Base &gt; Extrude</td>
<td>Features</td>
<td>Features</td>
</tr>
<tr>
<td>Shell</td>
<td><img src="image" alt="Features" /></td>
<td>Insert &gt; Features &gt; Shell</td>
<td>Features</td>
<td>Features</td>
</tr>
<tr>
<td>Insert Components</td>
<td><img src="image" alt="Assembly" /></td>
<td>Insert &gt; Component &gt; Existing Part/Assembly</td>
<td>Assembly</td>
<td>Assembly</td>
</tr>
<tr>
<td>Mate</td>
<td><img src="image" alt="Assembly" /></td>
<td>Insert &gt; Mate</td>
<td>Assembly</td>
<td>Assembly</td>
</tr>
</tbody>
</table>
Creating a Box

The first part you create is a box.

Opening a New Part

A part is the basic building block in the SOLIDWORKS software. In this procedure, you open a new part document where you will build a model.

1. Click New (Standard toolbar) or File > New.
2. In the New SOLIDWORKS Document dialog box, click Part and click OK.
   A new part document opens.

Setting the Drafting Standard and Units

Before you begin modeling, you set the drafting standard and unit of measurement for the part.

1. Click Options (Standard Toolbar) or Tools > Options.
2. In the System Options - General dialog box, select the Document Properties tab.
3. In Overall drafting standard, select ISO.
4. On the left pane, click Units.
5. Under **Unit system**, select **MMGS** to set the unit of measurement to millimeter, gram, second.
6. Click **OK**.

**Sketching a Rectangle**

You use a sketch to construct the basic outline of the part. The sketch is in 2D. Later, when you extrude the sketch, it becomes a 3D model.

1. Click **Corner Rectangle** (Sketch toolbar) or **Tools > Sketch Entities > Rectangle**.
   - The software enters sketch mode.
   - The **Front**, **Top**, and **Right** planes are visible.
   - The PropertyManager opens at the left and prompts you to select a plane on which to sketch the rectangle.
   - The pointer changes to **to indicate that you can select a plane.**

2. Click the **Front** plane.
   - The pointer changes to **to indicate that you can now draw the rectangle.**
3. Starting anywhere, click, then drag the pointer to create a rectangle.
4. Click to complete the rectangle. It does not matter what size you make the rectangle; you can dimension it later.

You may see four symbols: □□□□. These symbols are called sketch relations. In the rectangular sketch, they indicate where lines are vertical □ and horizontal □.

The current view is isometric, which makes the rectangle appear skewed. To see the rectangle normal to (straight on), press the spacebar. In the Orientation dialog box, double-click Normal To.

Instead of exiting sketch mode, you keep the sketch open so you can dimension the rectangle in the next set of steps.

**Dimensioning the Sketch**

Now that you have a sketched rectangle, you need to dimension it by adding measurements. You can use the Smart Dimension tool to dimension the rectangle. If you had exited sketch mode in the previous procedure, you would have to re-enter sketch mode to dimension the sketch.

1. Click Smart Dimension (Dimensions/Relations toolbar) or Tools > Dimensions > Smart.

   The pointer changes to .

2. Select the top horizontal line in the rectangle. A dimension appears.

3. Drag the dimension up and click to place it.

4. In the Modify dialog box, type 100 and click .
5. Repeat steps 2 through 4 for the right vertical line in the rectangle.

6. In the upper right corner of the window in the Confirmation Corner, click the sketch icon exit sketch mode.

**Extruding the Sketch**

After dimensioning the 2D sketch, you can extrude it to make a 3D solid model.

1. Click **Extruded Boss/Base** (Features toolbar) or **Insert > Boss/Base > Extrude**.
   - If the sketch is selected, the Boss-Extrude PropertyManager appears and a preview of the extrude appears.
   - If the sketch is not selected, the Extrude PropertyManager appears and indicates that you need to select a sketch.

2. If the Extrude PropertyManager appears, select the sketch by clicking any line in the square. Otherwise, go to the next step. A preview of the extrude appears.
3. In the PropertyManager:
   a) Set Depth \( d_1 \) to 100.
   b) Click \( \checkmark \).
      The 2D sketch changes to a 3D model.

Creating a Hollow Model

In this procedure, you use the \textbf{Shell} tool to create a hollow box.

1. Click \textbf{Shell} (Features toolbar) or \textbf{Insert} > \textbf{Features} > \textbf{Shell}.

2. In the Shell PropertyManager, under \textbf{Parameters}, set \textbf{Thickness} \( d_1 \) to 5.

3. In the graphics area, select the face as shown:
Face<1> appears in the PropertyManager under **Faces to Remove**.

4. Click ✓.
The box is hollow with walls that are 5mm thick.

![Box Image]

The box is complete.

**Saving the Part**

1. Click **Save** (Standard toolbar) or **File > Save**.
2. In the Save As dialog box:
   a) Browse to the location where you want to save the document.
   b) For **File name**, type **box**.
   c) Click **Save**.
   The part is saved as **box.sldprt**.
3. Keep the part open.

**Creating a Lid for the Box**

You created the first part, a box. Now you need to create a second part to make a lid for the box.

![Lid Image]

**Opening a New Part**

1. Click **New** (Standard toolbar) or **File > New**.
2. In the New SOLIDWORKS Document dialog box, click **Part** and click **OK**.
   A new part document opens.
Setting the Drafting Standard and Units

Before you begin modeling, you set the drafting standard and unit of measurement for the part.

1. Click **Options** (Standard Toolbar) or **Tools > Options**.
2. In the System Options - General dialog box, select the Document Properties tab.
3. In **Overall drafting standard**, select **ISO**.
4. On the left pane, click **Units**.
5. Under **Unit system**, select **MMGS** to set the unit of measurement to millimeter, gram, second.
6. Click **OK**.

**Sketching a Rectangle**

The lid for the box is shaped like a square. In this procedure, you sketch a rectangle. Later you can dimension it to fit the box.

1. Click **Corner Rectangle** (Sketch toolbar) or **Tools > Sketch Entities > Rectangle**.
   The PropertyManager prompts you to select a plane on which to sketch the rectangle.
2. Click the **Front** plane.
3. Click, then drag the pointer to create a rectangle.
4. Click to complete the rectangle.

**Dimensioning the Sketch**

Now that you have a sketched rectangle, you need to dimension it so it has the proper measurements.

1. Click **Smart Dimension** (Dimensions/Relations toolbar) or **Tools > Dimensions > Smart**.
   
   The pointer changes to

2. Select the top horizontal line in the rectangle.
   A dimension appears.

3. Drag the dimension upwards and click to place it.

4. In the Modify dialog box, type 100 and click.
5. Repeat steps 2 through 4 for the right vertical line in the rectangle.

![Diagram of a rectangle with dimensions labeled 100 and lines to indicate dimensions.]

6. In the upper right corner of the window in the Confirmation Corner, click the sketch icon. Sketch mode is turned off.

**Extruding the Sketch**

After dimensioning the 2D sketch, you can extrude it to make a 3D solid model.

1. Click **Extruded Boss/Base** (Features toolbar) or **Insert > Boss/Base > Extrude**.
   
   Depending on what is selected in the graphics area, the following occurs:
   
   - If the sketch is selected, the Boss-Extrude PropertyManager appears and a preview of the extrude appears.
   - If the sketch is not selected, the Extrude PropertyManager appears and indicates that you need to select a sketch.

2. If the Extrude PropertyManager appears, select the sketch by clicking any line in the square. Otherwise, go to the next step.
   
   A preview of the extrude appears.
3. In the graphics area, click the handle (arrow) and drag it until you reach 10 on the scale, then click ✓ in the PropertyManager.

The 2D sketch changes to a 3D model.

Creating a Lip on the Cover

To ensure that the cover fits tightly on the box, you create a lip on the cover using another extrude.
1. Press the spacebar or click **View > Modify > Orientation**.
2. In the Orientation dialog box, double-click **Front**.
   The cover is rotated so the front is visible.

3. Click **Corner Rectangle** (Sketch toolbar) or **Tools > Sketch Entities > Rectangle**.
4. In the graphics area, select the face as shown:

5. Sketch a rectangle on the face. It does not matter what size you make the rectangle; you can dimension it later.

**Dimensioning the Sketch**

You need to dimension the rectangle so it has the proper measurements.
1. Click **Smart Dimension** (Dimensions/Relations toolbar) or **Tools > Dimensions > Smart**.
   
   The pointer changes to 📏.

2. In the graphics area:
   a) Select the top horizontal line in the rectangle.
   b) Select the top edge of the extrude.

3. Drag the dimension upwards and click to place it.

4. In the Modify dialog box, type 2 and click ✅.
5. Repeat steps 2 through 4 for the rest of the sketch:

6. In the upper right corner of the window in the Confirmation Corner, click the sketch icon. Sketch mode is turned off.

**Extruding the Sketch**

After dimensioning the 2D sketch, you can extrude it to make a lip for the lid.

1. Press the spacebar or click **View > Modify > Orientation**.
2. In the Orientation dialog box, double-click **Isometric**. The cover is rotated.

3. Click **Extruded Boss/Base** (Features toolbar) or **Insert > Boss/Base > Extrude**.
4. In the graphics area, select the sketch by clicking any line in the square.

5. In the graphics area, click the handle (arrow) and drag it until you reach 5 on the scale, then click ✔ in the PropertyManager.

The 2D sketch changes to 3D.

The lid is complete.
Saving the Part

1. Click Save (Standard toolbar) or File > Save.
2. In the Save As dialog box:
   a) Browse to the location where you want to save the document.
   b) For File name, type lid.
   c) Click Save.
      The part is saved as lid.sldprt.
3. Keep the part open.

Putting the Box and Lid Together

An assembly is a collection of part documents. The part documents become “components” in the assembly, in this case, the box and lid.

Opening a New Assembly

In this procedure, you open a new assembly document where you will insert the box and lid models.

1. Click New (Standard toolbar) or File > New.
2. In the New SOLIDWORKS Document dialog box, click Assembly and click OK.
   A new assembly document opens, and the Begin Assembly PropertyManager appears.

Inserting Parts into the Assembly

An assembly is a collection of parts. In this procedure, you insert the box and lid into the assembly, where they become components in the assembly.
1. In the Begin Assembly PropertyManager, under **Part/Assembly to Insert**, select **box**.

   The part appears in the graphics area and the pointer changes to 🁿.

2. In the graphics area, click to place the part in the assembly.
   The part moves to the center of the graphics area.

3. Click **Insert Components** (Assembly toolbar) or **Insert > Component > Existing Part/Assembly**.

4. In the Insert Component PropertyManager, under **Part/Assembly to Insert**, select **lid**.

5. In the graphics area, click to place the part in the assembly.
   The part appears in the graphics area. It is OK if the parts overlap.

### Moving a Component

When you insert components into an assembly, you may want to move them so they do not overlap. By moving the components, it is easier to select them when you mate the components.
1. Click **Move Component** (Assembly toolbar) or **Tools > Component > Move**.

   The Move Component PropertyManager appears and the pointer changes to ![Thumbnail](image1.png).

2. Drag the lid component to the right of the box. If you try to drag the box component, you are warned that the component is fixed and cannot be moved. By default, the first part in an assembly is fixed in position.

   ![Image of box and lid](image2.png)

3. Click ![Thumbnail](image3.png).

**Rotating a Component**

To align the components before you mate them, you can rotate them so they are in the proper orientation. By aligning the components, it is easier for you to select faces during the mate process.

1. Click the **Move Component** arrow (Assembly toolbar) and click **Rotate Component** or click **Tools > Component > Rotate**.

   The Rotate Component PropertyManager appears and the pointer changes to ![Thumbnail](image4.png).

2. Click the lid and rotate it approximately as shown. The lip should be in the back.

   ![Image of lid rotated](image5.png)
Mating the Components

Mates create geometric relationships between components. As you add mates, you define the allowable movement of the components.

1. Click **Mate** (Assembly toolbar) or **Insert > Mate**. 
The Mate PropertyManager appears.

2. Select the highlighted faces on each component. Click **Zoom In/Out** (Heads-up View toolbar) or **View > Modify > Zoom In/Out** to help you select the faces if necessary.

When you select the second face:

- The most logical mate is applied to the faces. In this case, the software makes the faces coincident.
- In the PropertyManager, under **Standard Mates, Coincident** is selected.
- The Mate pop-up toolbar appears with **Coincident** selected.
3. Click ✓. 
   The mate is applied, but the PropertyManager remains open so you can add more mates.

4. Select the highlighted faces on each component. Use Rotate View by clicking View > Modify > Rotate to help you select the back face of the lip on lid.sldprt:

A coincident mate is applied to the faces.
5. Click ✔.
6. Select the highlighted faces on each component:

A coincident mate is applied to the faces, and the lid fits into the box.

7. Click ✔ twice.

**Saving the Assembly**

1. Click **Save** (Standard toolbar) or **File > Save**.
2. In the dialog box:
   a) Browse to the location where you want to save the document.
   b) For **File name**, type `box_with_lid`.
   c) Click **Save**.
      The assembly is saved as `box_with_lid.sldasm`.
3. Keep the assembly open.
Creating a Drawing

You can create 2D drawings of the 3D solid parts and assemblies you design. Parts, assemblies, and drawings are linked documents; any changes that you make to the part or assembly change the drawing document.

Opening a New Drawing

1. Click New (Standard toolbar) or File > New.
2. In the New SOLIDWORKS Document dialog box, click Drawing and click OK. The Sheet Format/Size dialog box appears where you can set the drawing sheet parameters.
3. In the list, select A3 (ISO) and click OK.
   A new drawing document opens.

4. If the Model View PropertyManager appears, click to close it.

Setting the Drafting Standard and Units

Before you begin the drawing, you set the drafting standard and unit of measurement for the document.

1. Click Options (Standard Toolbar) or Tools > Options.
2. In the dialog box, select the Document Properties tab.
3. In the Document Properties - Drafting Standard dialog box, in Overall drafting standard, select ISO.
4. On the left pane, click Units.
5. In the Document Properties - Units dialog box, under Unit system, select MMGS to set the unit of measurement to millimeter, gram, second.
6. Click OK.

Inserting Standard 3 Views

The Standard 3 View tool creates three related orthographic views of a part or assembly.
1. Click **Standard 3 View** (Drawing toolbar) or **Insert > Drawing View > Standard 3 View**.
2. In the Standard 3 View PropertyManager, under **Part/Assembly to Insert**, select **box**.
3. Click ✔.  
   The standard 3 views of box.sldprt appear in the drawing. The views use the front, top, and left orientations.

---

### Inserting an Isometric Model View

When you insert a model view, you can choose the view orientation that you want to display. In this procedure, you insert an isometric model view of the assembly.

1. Click **Model View** (Drawing toolbar) or **Insert > Drawing View > Model**.
2. In the Model View PropertyManager, under **Part/Assembly to Insert**, select **box_with_lid**.
3. Click ✔.  
   The drawing view is attached to the pointer, but do not place it yet.
4. In the PropertyManager:
   a) Under **Orientation**, click **Isometric**.
   b) Under **Display Style**, click **Shaded With Edges**.
5. In the graphics area, click in the lower right corner of the sheet to place the drawing view.

![Drawing view](image)

6. Click ✓.

**Dimensioning the Drawing**

In this procedure, you use autodimensioning to add dimensions to a drawing view.

1. Click **Smart Dimension** (Dimensions/Relations toolbar), or **Tools > Dimensions > Smart**.
2. In the Dimension PropertyManager:
   a) Select the Autodimension tab.
   b) Under **Entities to Dimension**, click **Selected entities**.
   c) Under **Horizontal Dimensions**, select **Above view**.
   d) Under **Vertical Dimensions**, select **Left of view**.
3. In the graphics area, in the front view, click in the space between the drawing view border (dotted line) and the drawing view as shown:

![Drawing view border](image)

In the drawing view, the leftmost vertical edge turns pink and the bottom edge turns purple. These colors correspond to the colors in the PropertyManager under **Horizontal Dimensions** and **Vertical Dimensions**:
4. In the PropertyManager, click ✓. The drawing view is dimensioned. Drag a dimension to move it.

The drawing appears as:
Exercises

There are no step-by-step procedures for these exercises. However, you can access the finished parts, assemblies, and drawings at \texttt{install\_dir\samples\introsw}.

This chapter includes the following topics:

- \textbf{Covered Can}
- \textbf{Bolt, Washer, and Nut}

\textbf{Covered Can}

This exercise helps you to use basic tools and concepts by creating a can, lid, and drawing. Create the parts, assembly, and drawing using the given information.

Can:

\texttt{R5} is the fillet radius.
Lid:

Assembly:

Drawing:
- Two model views of the lid
- One model view of the cylinder
Bolt, Washer, and Nut

This exercise helps you to use basic tools and concepts by creating a bolt, washer, nut, and drawing.

Create the parts, assembly, and drawing using the given information.

Bolt:

Washer:
Nut:

Assembly:

Washer

Nut

Bolt